Print to a PDF file, plot file (.plt) or printer

Tekla Structures
2024
Tekla Structures

Print to a PDF file, plot file (.plt) or printer

You can print drawings and selected drawing areas to PDF files or to plot files (.plt) to be sent to a plotter or printer, or print drawings on a printer. You can also modify the output line colors and line widths. You can print to a single printer or to multiple printers, or print one drawing to multiple sheets.

Print a drawing

  1. On the File menu, click Printing > Print drawings.

    This opens the Print Drawings dialog box and Document manager.

    You can also start printing in the following ways:

    • In Document manager, select the drawings, right-click, and select Print, or click the Print button.

      The order of drawings matches the order they appeared in Document manager at the point in time when the Print Drawings dialog box was opened.

    • When a drawing is open, select File > Print drawings.
    • Press Shift+P on the keyboard.
  2. In Document manager, select the drawings that you want to print.

    You can also print locked drawings that are up to date. If a locked drawing is not up to date, you cannot open or print it, and a failed printout will be reported. You can print any unlocked drawings unless the status of the drawing indicates that the original part is deleted.

  3. In the upper-left corner of the Print Drawings dialog box, ensure Use one printer is selected.
    This is the default option.
  4. Load the desired printing settings from the settings list.

    When you load the printing settings, the Save button remains disabled. Once you make some changes in the printing settings, the name of the settings file will be displayed in italics and get an asterisk at the end. The Save button will be enabled once you have modified the settings.

    You can also give the settings a new name. For more information about the printing settings, see Printing settings files and search order.

  5. To show a preview of the drawing, click Click here to load a preview in the preview area.

    The drawing preview is always up to date. We recommend that you check the preview whenever you change the printing settings.

    Use the mouse wheel to zoom in the preview. You can also zoom into areas of interest. The preview also supports panning with the middle mouse button.

    If you want to preview with precision, place the printing dialog box so that you can see the current drawing and ensure that you have activated the Printer line widths switch in File > Settings.

    If you have selected to print several drawings, the drawings are shown one by one in the preview. Use Next and Previous to scroll through the set of selected drawings.

  6. Select the printing option:
    • PDF file: Converts the selected drawings to PDF format.
    • Printer: Sends the selected drawings to the selected printer.
    • Plot file: Converts the selected drawings to print files in a format suitable for the selected printer and saves them in a specified location.
  7. Define the printing settings on the Options tab. The available settings depend on the printing option that you have selected:
    Note:

    The advanced option XS_DRAWINGS_USE_CAP_HEIGHT_FOR_FONT_HEIGHT controls which font height system is used in printing, CAP font height or em font height (default).

    Option Description

    File location

    Enter the location for the PDF file or plot file, or use Browse... to browse to the folder.

    The \Plotfiles folder under the model folder is the default value.

    This option is only available if you have selected PDF file or Plot file.

    Printer or plotter Select the printer or plotter. Click Properties... to adjust printer properties.

    Include revision mark to file name

    Add the mark of the latest revision of the printed drawing to the print file name.

    Revision number is used by default. If you always want to use the revision mark instead, set the advanced option XS_​SHOW_​REVISION_​MARK_​ON_​DRAWING_​LIST to TRUE. If the revision mark is still not displayed, check the following advanced options and include REVISION_MARK in the value:

    XS_DRAWING_PLOT_FILE_NAME_A, XS_DRAWING_PLOT_FILE_NAME_W, XS_DRAWING_PLOT_FILE_NAME_G, XS_DRAWING_PLOT_FILE_NAME_M, or XS_DRAWING_PLOT_FILE_NAME_C, depending on the drawing type.

    This option is only available if you have selected PDF file or Plot file.

    Open folder when finished

    Open the PDF file or plot file folder in Windows Explorer after the printout has been created.

    This option is only available if you have selected PDF file or Plot file.

    Open file when finished

    Open the PDF file after it has been created.

    This option is only available if you have selected PDF file.

    Output to single file

    Print the selected drawings to a single PDF file.

    If you do not select this option, each of the selected drawings will be printed in a PDF file of its own.

    This option is only available if you have selected PDF file.

    PDF file name

    Give a file name to the PDF file. The file name is needed if you are printing to a single file. By default, the name Combined.pdf is used.

    This option is only available if you have selected PDF file and Output to single file.

    The PDF file name can also be controlled by a couple of advanced option switches for customizing print file names. These switches do not work for single combined multiple drawings PDF file.

    Sometimes the drawing file name may have an illegal character, which cannot be printed. Because of this, Tekla Structures replaces large number of illegal characters with an underscore "_". Check the file naming conventions provided by Microsoft "Naming Files, Paths, and Namespaces".

    File extension

    Specify a file name extension for the plot file. The default is plt.

    This option is only available if you have selected Plot file.

    File prefix

    File suffix

    Enter a specific prefix and/or suffix in the PDF or plot file name.

    When you enter a prefix or suffix, the file name preview under the File prefix and File suffix boxes will reflect the change immediately.

    The file name can also be controlled by advanced option switches for customizing print file names.

    This option is only available if you have selected PDF file or Plot file.

    Fit to paper

    Fit the drawing to a specific paper size.

    This setting does not work if you have selected Scale.

    Scale

    Force the printout to a specific scale.

    The Scale value will turn red if the drawing cannot fit on the specified sheet.

    This setting does not work if you have selected Fit to paper.

    Center drawing on paper Center the drawing on the sheet (or sheets).

    Print on multiple sheets

    Print on multiple sheets and specify the direction of printing the sheets. This is particularly useful if your drawing contains several drawings. Select to print from Left to right, top to bottom or from Bottom to top, right to left.

    When you use Print on multiple sheets, always set a particular Scale.

    The preview shows how the drawing is divided into sheets.

    Paper size

    Define the paper size or use automatic size.

    With the Auto setting Tekla Structures selects the paper size that has the least wasted area when the scaled print is fitted to the printable area on the sheet.

    Printers are often unable to print on the full area of a sheet, and leave borders. The printable area is determined for the selected printer when the option Printer or Plot file is selected. For PDF files, the printer is not known, so the output is sized to the full sheet. However, when printing a PDF, the same problem exists and the drawing content is fitted to the printable area of whatever printer is being used. The printable area is shown with white background and the non-printable border is shaded gray in the image below.

    Two configuration files affect paper sizes and drawing sizes: PaperSizesForDrawings.dat and DrawingSizes.dat . For more information, see Printing configuration files

    Orientation

    Define the orientation or use automatic orientation.

    The Auto setting means that the orientation that wastes least space is selected automatically.

    Color

    Select if the output is to be Color, Black and white, or Tekla Grayscale.

    For details on how the standard and custom colors are handled in different color modes, see Colors in drawings.

    Number of copies

    Define the number of paper copies to be printed.

    This option is only available if you have selected Printer.

    Collate

    Collate the printout when you are printing multiple copies.

    This option is only available if you have selected Printer.

    Embed fonts

    Embed the fonts in a PDF file.

    This ensures that fonts may be reproduced in a system that does not have the same fonts installed, but this also increases the file size. In certain cases, fonts may be embedded automatically. When using non-Latin fonts, we recommended that you use embedding, otherwise the PDF may not be displayed correctly.

    Note that you can also define a default Unicode font for the advanced option XS_DEFAULT_UNICODE_FONT_DRAWING_PRINTING. If the selected font does not contain all characters in the text, the font is defined by this advanced option. The default value is Arial Unicode MS. This font might not be installed on your machine by default, and you may need to install it. You can also define another font that contains the characters you need and that you have installed on your machine.

    Embed fonts is only available if you have selected PDF file.

    Select area

    Select a rectangular area from an open drawing to only show and print that area. This option only works when you have a drawing open.

    All settings in the Print Drawings dialog box also work when Select area is selected, and you can change the orientation, line width, and paper size, for example.

    Show entire drawing

    When you have selected an area with Select area, the Show entire drawing button appears, and you can use it to show the entire drawing in the preview again.

  8. Go to the Line properties tab to set the output colors and line widths (pen numbers).

    The Object color column shows the configured set of object colors by default. Use the Color on output options to define the colors that are used in the output and the Thickness column to define the line widths. Output preview shows you a preview of the selected output color and line width.

    If you have selected Tekla Grayscale or Black and white as the print color on the Options tab, the Color on output setting are disabled.

    In Tekla Grayscale mode, certain standard colors are shown and printed as black, whereas the Grayscale line property option converts all colors, standard and custom, to different shades of gray using an algorithm. In line properties, gray is shown in either grayscale mode as a percentage, for example, "Tekla Grayscale - Gray 50 %" or "Grayscale - Gray 29 %".

    To Do this

    Use colors in the current drawing preview as output colors

    You can use object colors in the currently previewed drawing as output colors. To use the colors in the current drawing preview in the output, delete the existing line properties first.

    1. Select all line property rows using Ctrl or Shift, right-click and select Delete.
    2. Ensure that the preview of the drawing is shown. If it is not shown, click Click here to load a preview in the preview area. This activates the button.
    3. Click the button.
    4. Ensure that the Color on output is set to By object on all rows.
    All object colors that exist in the previewed drawing are added to the Line properties tab as line properties. If a color exists already, it is not added again.

    The line thickness from the Default row is used for all rows, but you can adjust the line thickness.

    Add a new line property

    You can add a new line property to the list of line properties and specify the desired output for it.

    1. Click the button.
    2. To select a color, do one of the following:
      • Select a standard color.
      • Select a saved palette from the Custom list and click a custom color in the palette
    3. Click OK.

    A new line property with the specified color is added on the Line properties tab. The line thickness is taken from the Default row, but you can adjust that. If the color already exists, it will not be added.

    Map an object color to a custom color

    You can assign a custom color to an object color as the output color.

    1. Click a color row and select Custom from the Color on output list.
    2. Select a saved palette from the Custom list, click a custom color in the palette, and then click OK.

      You can also select several rows using Ctrl or Shift , right-click and then select Output > Custom.

    Use drawing object color in output

    You can use the drawing object color as the output color.

    • Click a color row and select By object from the Color on output list.

      You can also select several rows using Ctrl or Shift, right-click and select Output > By object.

    Print objects in grayscale You can print the desired object colors always in grayscale.
    • Click a color row and select Grayscale from the Color on output list.

      You can also select several rows using Ctrl or Shift, right-click and select Output > Grayscale.

      The Grayscale option converts all colors, standard and custom, to different shades of gray using an algorithm. In line properties, gray is shown in as a percentage, for example, "Tekla Grayscale - Gray 50 %" or "Grayscale - Gray 29 %".

    Skip objects in printing You can skip the printing of the drawing objects that use a specific object color.
    • Click a color row and select No output from the Color on output list.

      You can also select several rows using Ctrl or Shift, right-click and select Output > No output.

    Remove a line property
    1. Select one or more rows. You can use Ctrl or Shift to select multiple rows.
    2. Click Delete in the dialog box, or right-click and select Delete.
    Use default color and line width in printing The Default color and line thickness are used for those colors in the drawing that have no output definition on the Line properties tab.

    To use only one color and line thickness in the printout for all objects, define the desired color and line thickness for the Default row and delete all line property rows.

    If you select By object, drawing object colors are used in the output as they are in the drawing.

    Define the line width

    Do one of the following:

    • Enter the line width for each color in the Thickness box.
    • Define the line width for several color rows:
      1. Use Ctrl or Shift to select multiple rows.
      2. Right-click and select Line thickness.
      3. Enter the line width for the selected rows.

    Line width is expressed as a multiple of the advanced option XS_BASE_LINE_WIDTH value. The default value for this advanced option is 0.01 mm. For example, line width 25 will give a line weight of 0.25 mm.

    NOTE: The line widths in the drawing editor always follow the line Thickness setting if the drawing Color mode is Black and white, but in Color and Tekla Grayscale drawing color modes, the line widths are accurate in the current drawing only if the Printer line widths switch is active in File > Settings. In the print preview, correct line widths are always shown.

  9. To save your printing settings including the line properties, click Save in the upper-left corner.
    For more information about the printing settings and the search order, see Printing settings files and search order.

    You can also add frames and fold marks to you printouts.

  10. Click Print to print the drawings in the PDF format or as plot files, or to send them to a printer according to the settings you defined in the dialog box.
    Each drawing is sent to the printer as a separate print job.

    All printing errors are written to a log file in the model folder: logs\DPMPrinter_<username>.log.

  11. If you have selected drawings that need numbering or updating, a dialog box is displayed, and you can select how to proceed:
    Note: You cannot update or number locked drawings.
    • Print only up-to-date drawings (recommended)
    • Number and update before printing the drawings
    • Print drawings without updating
    • To cancel the whole process, click Cancel.
  12. Click Print

    A summary is displayed showing you the printing result and a list of drawings that need attention.

Example: Print to multiple sheets

The Print on multiple sheets setting on the Options tab prints the drawing on multiple sheets. You need to specify the direction of printing the sheets. This is particularly useful if your drawing contains several drawings.

In the example below, the option Bottom to top, right to left has been selected. The numbers indicate the printing order of the sheets.

In the next example, the option Left to right, top to bottom has been selected.

Print to multiple printers

You can print to more than one printer in one go based on the paper size of each selected drawing. When printing to multiple printers you typically have different printers for handling different paper sizes. Tekla Structures automatically selects the appropriate printer for each drawing.

To print to multiple sheets, you need to:

  • Create and save the printing settings for the necessary printers
  • Print by using Use multiple printers mode.

Create single printing settings

To be able to print to multiple printers, you first need to create single printing settings for each of the printers you want to print to:

  1. On the File menu, click Printing > Print drawings.

  2. Select Use one printer.

  3. Define the printing settings as desired on the Options tab and on the Line properties tab. Select the output type and printer, and define the paper size that this particular printer will handle in Use multiple printers mode.

  4. Save the settings with a desired name by clicking Save.

  5. Repeat this for each of the desired paper sizes. Do not use the size option Auto.

    For example, you could create the following single printer settings files with the output type set to PDF file:

    • PDF A4: Paper size set to A4, file prefix set to A4_
    • PDF A3: Paper size set to A3, file prefix set to A3_
    • PDF A2: Paper size set to A2, file prefix set to A2_

    When printing a set of drawings in the multiple printers mode using the above single printer settings files, all A4 drawings will generate .pdf files with prefix A4_, all A3 drawings will have prefix A3_, and all A2 drawing will generate .pdf files with prefix A2_.

    If you want to print more than one sheet size to the same printer in Use multiple printers mode, create a single printer settings file for each paper size, and specify the same printer in all of these files.

Print to multiple printers

  1. On the File menu, click Printing > Print drawings.
  2. In the upper-left corner, select Use multiple printers mode.
  3. In the Selected single printer settings files list, select the settings files to use in printing. You can select all or just some of the single printer settings files.

    The output type (printer, plot file, PDF file) is defined by each selected single printer settings file. Typically you would select settings files with the same output type. Output types lists the output types that are specified in the selected single printer settings files.

  4. Change other necessary settings on the Options tab.
    The available settings depend on the output type you have selected. The settings are described in the "Print to a single printer" section above.
  5. Change necessary line width and color settings on the Line properties tab.
  6. In the displayed Document manager, select the drawings that you want to print.
Was this helpful?
Previous
Next