使用线、多边形或零件切割对象

Modified: 14 11月 2024 Tekla Structures 2025

使用线、多边形或零件切割对象

使用线切割、多边形切割或零件切割可在模型中切割出零件的形状。如果您需要修改零件长度,不要使用切割,而是改为移动零件控柄或使用直接修改。

限制

  • 不要使用切割将零件切成两半。编号、材料列表和图纸会将零件视为一个零件,而不是两个单独的零件。

  • 不要使用切割来剪短钢零件,因为在通常用于钢材料列表的 LENGTH_GROSS 中不考虑切割。

线切割

使用线切割来切割出梁或柱的形状,或者切割板、项或钢筋组。

线切割会在选取的两点之间创建一条直切割线,该线垂直于穿过所选的两点的视图平面。

使用线切割可切割零件末端或零件的边。例如,使零件变窄或从梁末端切掉一个角。可以对一个零件末端应用多次线切割。

开始之前,请确保您在具有合适视图平面的视图中工作。这样可以更轻松地选取切割线的点。

  • 在许多情况下,您可以使用新视图 > 默认零件视图命令创建具有合适视图平面的视图。该命令创建的视图沿所选零件的主轴 (x,y,z) 具有视图平面。

  • 如果您需要不沿零件轴的其他角度的视图平面,可以先定义工作平面,然后使用新视图 > 在工作平面上命令。或者,您可以使用应用程序和组件目录中的 3D 切割组件。

使用线切割对象

  1. 在编辑选项卡上,单击线切割。

  2. 选择要切割的对象。

  3. 选取切割线的第一个点。

  4. 选取切割线的第二个点。

  5. 选取要删除的侧边。

    Tekla Structures 使用点划线显示切割。

    如果需要,您可以隐藏切割。

多边形切割

使用多边形切割来垂直于由您选取的点定义的平面,切割具有封闭多边形的零件或钢筋组。

开始之前,请确保您在具有合适视图平面的视图中工作。这样可以更轻松地选取多边形的点。

在许多情况下,您可以使用新视图 > 默认零件视图命令创建具有合适视图平面的视图,该命令创建的视图具有沿选定零件主轴(x、y、z)的视图平面。

使用多边形切割对象

  1. 在编辑选项卡上,单击多边形切割。

  2. 选择要切割的对象。

  3. 选取点以勾勒出用于切割的多边形。

    在定义多边形时,不要将切割边缘与要切割的零件的边缘完全放置在同一位置,因为这会导致软件不清楚是否应将边缘切割掉。

    根据要切割的对象的尺寸自动计算切割深度。切割会自动沿深度方向稍稍延伸到零件面以外 (3 mm)。

  4. 单击鼠标中键以闭合多变形并切割对象。

    Tekla Structures 使用点划线显示切割。如果需要,您可以隐藏切割。

    如果需要修改切割形状,可使用零件控柄或直接修改添加或删除点,或者移动边缘。

    您可以在多边形切割的角上添加倒角以微调形状。倒角对 NC 文件没有影响。

    多边形切割具有可以在属性窗体中修改的属性。

零件切割

使用另一个零件切割零件或钢筋组。

您也可以切割已经有切口的零件。例如,在您想创建更复杂的切割形状时,此功能很有用。

使用零件切割对象

  1. 如果没有用于切割的零件,请创建一个切割零件并使其通过要切割的零件。

    放置切割零件时,请勿使切割边缘或顶点与要切割的零件的边缘或顶点完全位于同一位置,否则应该切掉的内容可能会不明确。

  2. 在编辑选项卡上,单击零件切割。

  3. 选择要切割的对象。

  4. 选择切割的零件。

    利用切割零件,Tekla Structures 可以为所选对象创建切割。零件切割不影响其他对象。

    Tekla Structures 使用点划线显示切割。

  5. 删除切割零件。

    1. 确保 选择切割和添加材质选择开关已关闭。

    2. 选择切割零件并按删除。

      如果需要,您可以隐藏切割。

切割零件具有可以在属性窗体中修改的属性。

有关有效切割的提示和技巧

  • 考虑如何放置切割边缘

    避免将切割边缘、切割顶点或用于切割同一零件的其他切割放置在与要切割的零件的边缘或顶点完全相同的位置。将切割延伸到零件或其他切割外部至少 0.3 mm。这样做可帮助您避免实体错误。

  • 如果切割导致实体错误

    如果切割导致实体错误,Tekla Structures 将无法渲染零件面,零件将变得透明,并且仅一些边缘线可见。会话历史记录日志中会打印错误通知,指明导致失败的零件和切割。

    要在模型中定位故障,请在会话历史记录日志中单击包含 GUID 标识符的行。Tekla Structures 将会选择模型中的相应零件和切割。

    要修复错误,请沿不同的方向稍微移动有问题的切割 (0.3 mm)。如果该切割与其他切割相交,您可以尝试也移动其他切割。

  • 使用边缘折角

    如果可能,请使用边缘折角而不是小型切割(特别是在组件中)。

  • 钢型材的翼缘切割

    在切割翼缘时,如果切割零件切割腹板也非常轻微(至少 0.3 mm),则该切割很可能会成功。例如,如果您正在切割具有圆角的梁,则可能有必要进一步沿深度方向切割到腹板而不仅仅是翼缘厚度。

  • 圆管切割

    使用圆管 (23) 组件进行圆管切割。此组件可自动旋转切割零件,直到找到成功的切割位置。如果组件切割失败,请略微旋转切割零件,直到找到成功的切割位置。

在模型视图中隐藏切割

  1. 双击视图背景以打开视图属性对话框。
  2. 单击显示(D)... 打开显示对话框。
  3. 确保在显示设置中未选中切割和已添加材质选项。
  4. 单击修改。
  5. 如果您想在模型视图中临时显示隐藏的切割,请执行以下操作:
    1. 选择零件。
    2. 单击上下文工具栏上的 显示细节。

    显示所选零件的所有切割。要再次隐藏它们,请重画视图。

多边形切割属性

使用属性窗体中的多边形切割属性可查看和修改多边形切割的属性。

请注意,仅当创建和选择了多边形切割之后,属性窗体中才会提供多边形切割属性。在创建切割之前,您无法访问或修改切割属性。

如果您已自定义属性窗体布置,则属性列表可能会有所不同。

设置

描述

通用

名称

多边形切割的名称。

型材/截面/型号

多边形切割的截面,默认情况下为参数化截面 BL。

材料

多边形切割的材料,默认情况下为 ANTIMATERIAL。

无法更改切割材料。

等级

用于对多边形切割进行分组。

位置

在深度

多边形切割在深度方向上的位置。

更多

UDA

单击用户定义的属性按钮以打开切割的用户定义的属性 (UDA)。UDA 可用于为每个切割存储更多信息,例如,控制图纸中的尺寸创建。

零件切割属性

零件切割使用切割零件的属性。例如,如果切割零件是钢梁,则零件切割使用钢梁切割属性。默认零件切割属性取决于使用的切割零件。

如果要阻止从原始切割零件中将用户定义的属性 (UDA) 复制到反材料切割零件,请使用 XS_PART_CUT_INHERIT_UDAS_FROM_CUTTING_PART 高级选项。当设置为 FALSE 时,UDA 不会复制到反材料零件。

如果切割零件是中空截面,则使用类似但非中空截面创建切割,以便也去除切割内部。

请注意,仅当创建和选择了零件切割之后,属性窗体中才会提供零件切割属性。在创建切割之前,您无法访问或修改切割属性。

这些内容是否有用?
提交
上一步
下一步