Building hierarchy

Tekla Structures
2024
Tekla Structures

Building hierarchy

You can use building hierarchy to define a location breakdown structure in your model. Building hierarchy has a default hierarchy structure, project > site > building > level > space. You can add levels and spaces to the model by either importing them from a reference model, or creating them directly in your model. A level is a horizontal plane at specified elevation within a building. Spaces are volumes that provide for certain functions within a building.

To create a building hierarchy, set the XS_USE_INTEGRATED_BUILDING_HIERARCHIES advanced option to TRUE. The advanced option is by default set to FALSE.

Once you have set the advanced option to TRUE, save the model and reopen it to apply the change. To open the Building hierarchy dialog box, go to the Manage tab on the ribbon, and click Building hierarchy.

The defined building hierarchy and the object locations in the hierarchy are common for all users of the model. Building hierarchy is shared when using Tekla Model Sharing.

How to use the Building hierarchy dialog box

Description

1

The default hierarchy structure is project > site > building > level > space.

You can define the name of the project in File > Project properties. You can modify the names and properties of sites, buildings, levels and spaces in the table in the Building hierarchy dialog box. When you select the project in the hierarchy tree structure, the site is shown in the table. When you select the site in the hierarchy tree structure, the building is shown in the table. You can have one building in the hierarchy.

A building has one or multiple levels. When you select the building in the hierarchy structure, the levels that are in the selected building are shown in the table.

A level is a horizontal plane at a specified elevation. The level elevation is in many cases defined by the architect, and it often defines the finish floor level. Level is represented as a building storey in IFC. When you select a level in the hierarchy tree structure, the spaces at the selected level are shown.

Spaces are volumes that provide for certain functions, such as rooms, within a building. A space is automatically assigned to the closest level below it. If there are unassigned spaces in the model, they are shown in a separate folder in the hierarchy structure.

2

Define the level elevation.

3

Model objects are assigned to levels based on the elevation in the model.

Use the bottom offset to define a certain distance below a level. The objects that are within the defined distance are assigned to the level from which the distance is defined.

By default, objects are automatically assigned to the closest level below them.

4

Level offset defines the design level. For steel structures, this is normally top of steel (TOS).

5

Open the Import building hierarchy dialog box to import a building hierarchy from a reference model.

6

Click Modify to modify the objects for which you have edited the properties in the table.

7

Delete the selected levels and spaces from the table.

8

Select which columns are shown in the table.

Your column selection is used when you open the Building hierarchy dialog box the next time.

9

Enter additional information about the level, if needed.

Import levels and spaces from a reference model

You can import levels and spaces from a reference model. If you already have levels and spaces in the Building hierarchy dialog box, they will be replaced by the levels and spaces that you import.

  1. If the reference model from which you want to import the levels and spaces is already in your model, go to step 4.

    To insert a reference model to your model, click File > Import > Insert reference model.

  2. In the Add model dialog box, click Browse to select the reference model from the list.

  3. Click Add model.

  4. On the ribbon, click Manage > Building hierarchy to open the Building hierarchy dialog box.

  5. Click the Import button in the Building hierarchy dialog box.

  6. Select the reference model from which you want to import the levels and spaces.

    You can enter characters in the Reference model name box to get a list of the available reference models that contain the entered character. Alternatively, you can select the model from the Reference Models side pane, or from the model. If you select from the model, ensure that the Select reference models selection switch is active.

    The name of the reference model that you select is shown in the Reference model name box.

  7. Select the lowest level that is imported from the building hierarchy, either level or space.

  8. Click Import.

    If the model already has a building hierarchy, Tekla Structures displays a dialog box about replacing the existing hierarchy.

    If you click Replace, the levels and spaces are replaced as follows:

    • If you have selected Level in Lowest level to import from building hierarchy, levels will be replaced with the imported levels.

    • If you have selected Space in Lowest level to import from building hierarchy, both levels and spaces will be replaced with the imported levels and spaces.

    The imported levels and spaces are shown in the Building hierarchy dialog box. To have them visible in the model, ensure that you have selected Building hierarchy and Space in the display settings, click View properties > Display.

    If you clear the Building hierarchy and Space check boxes in the display settings, and click Modify, the imported levels and spaces are still shown in the model. Use the Redraw view command to update the view.

Create levels

Levels are horizontal planes at a specified elevation within a building.

  1. On the ribbon, click Manage > Level.

    Tekla Structures shows the level properties in the property pane.

  2. Pick a point at the level elevation in the model, or enter the elevation in the property pane and click the Insert level button in the property pane.

  3. To create another level, pick another point. To stop creating levels, press Esc.

Create spaces

Spaces are a volumes that provide for certain functions, such as a rooms, within a building. A space is automatically assigned to the closest level below it. Unassigned spaces are spaces that are not assigned to any level.

  1. On the ribbon, click Manage > Space.

    Tekla Structures shows the space properties in the property pane.

  2. Pick the first boundary point for the space in the model.

  3. Pick the second boundary point for the space.

  4. Pick the next boundary point for the space.

  5. Click the middle mouse button to create the space.

The created spaces are listed in the Building hierarchy dialog box under the levels they are assigned to.

Manage levels and spaces

You can manage levels and spaces in the Building hierarchy dialog box, or in the property pane.

To Do this

Modify level and space properties

Modify the level and space properties in the table in the Building hierarchy dialog box, or in the property pane. The modified properties are highlighted in yellow.

Click Modify to apply the changes in the model.

If you change the elevation of a level and the level has objects assigned to it, Tekla Structures displays a dialog box where you need to select whether to move the level only, or the level and the objects assigned to it.

Create model views automatically for new levels

Set the XS_​AUTOMATICALLY_​CREATE_​VIEW_​​FOR_​NEW_​LEVELS advanced option to TRUE.

Define IFC export properties for spaces in the property pane

  1. Select a space in the model.

    If the property pane is not open, double-click the space in the model.

  2. Define the IFC export properties:

    • Select the IFC entity value:

      IfcSpace, the space is exported. This is the default value.

      None, the space is not exported.

      Auto, the default value is used.

    • Select the Subtype (IFC4) value for IfcSpace.

      The default subtype is NOTDEFINED.

    • Define the User-defined type (IFC4) value.

      To do this, set Subtype (IFC4) to USERDEFINED.

  3. Click Modify to apply the changes.

Delete levels and spaces

Select a level or a space in the table in the Building hierarchy dialog box, and click the delete button . The level or space is also deleted from the model.

You can select more than one level or space in the table to be deleted at one go.

View to which level an assembly is assigned to

Inquire an assembly in the model.

Show and hide levels and spaces in the model

In View properties > Display, check or clear the Building hierarchy and Space check boxes.

Filter building hierarchy objects

Use the Location breakdown structure category to filter building hierarchy objects based on their location.

Create views on selected levels

You can create model views of the levels that you select in the Building hierarchy dialog box, or in the model.

  1. On the View tab, click New view > On selected levels.
  2. Select levels in the Building hierarchy dialog box, or in the model.
  3. In the Create views on selected levels dialog box, define the view name, and select the view properties.
  4. Select whether the view is created at the level offset.
  5. Click Create.

The created views are listed in the View list. On the ribbon, go to the View tab and click View list.

Example: Building hierarchy in Organizer

You can use Organizer to view the building hierarchy that you have defined.

  1. On the ribbon, click Manage > Building hierarchy to open the Building hierarchy dialog box.

  2. On the Manage tab, click Organizer.

  3. Select Synchronize in the dialog box that opens to get the building hierarchy to Organizer.

    The building hierarchy is shown at the top part of the Categories section and it has a green icon .

    When you make changes in the Building hierarchy dialog box, you need to synchronize Organizer to get the changes to Organizer.

  4. If needed, you can manually make changes in the levels, for example, move assemblies to another level.

    Select the assembly in the model, then right-click the target level in Organizer, and click the Move the selected objects command. Synchronize Organizer.

    You can remove the changes that you have manually made. Select the category, click and select Manage manual changes. Select the manually added objects marked with or , right-click and select Remove manual changes. Synchronize Organizer.

Note:

When you are using building hierarchy in your model, IFC export uses building hierarchy levels when the Spatial hierarchy from Organizer setting is selected in the IFC export dialog box. Building hierarchy spaces are not included in the export. Note that the hierarchies created in Organizer cannot be used at the same time.

To use the hierarchies created in Organizer in the IFC export, set XS_USE_INTEGRATED_BUILDING_HIERARCHIES to FALSE.

Was this helpful?
Previous
Next