管理员的公司设置

Tekla Structures
2024
Tekla Structures

管理员的公司设置

公司级别的设置主要是用于公司中所有工程的设置。使用 XS_SYSTEMXS_FIRM 设定这些设置。

对于下设多个子公司的大型公司,可以按以下所示使用这些设置:

  • XS_SYSTEM 可能包含多个路径,并且指向公司内部的通用设置。这些可以是公司徽标、报告、打印机设置、图纸设置、模板等。这些设置极少更改,并且存储在所有用户都可以访问的服务器上。例如,如果更新公司徽标,则只需在一个位置替换此徽标。
  • XS_FIRM 指向公司或附属公司建立的公司文件夹。文件夹包括所有特定办公室所使用的公司设置。例如徽标、图纸设置、模板、报告或打印机设置等。公司文件夹也可包含用户定义的子文件夹以存储属性文件。
  • XS_PROJECT 指向工程文件夹。此文件夹包含工程设置,例如承包商和制造商的徽标,或图纸设置等。工程文件夹也可包含用户定义的子文件夹以存储工程特定属性文件。

有关文件夹搜索顺序的更多信息,请参见文件夹搜索顺序

您也可以在自己的网络中,在线或离线使用 Tekla Warehouse 中的公司特定集合。如需了解更多信息,请参见 Tekla Warehouse 入门

使用网络中的文件夹权限并基于每位用户电脑的 collections.json 文件的集合级别,管理离线集合访问权限。

 "collections" 
"\\\\server-A\\company\\Tekla Structures collection" 
		

collections.json 文件可复制到 C:\Users\Public\Documents\Tekla\Tekla Warehouse\ 文件夹,从而共享给选定的用户。

模型模板自定义

您可以将自定义设置保存在模型中,并在创建新模型时将模型用作模板。如果您的公司有多种不同工程,比如停车库、办公大楼、桥梁和工业设施,那么使用模型模板会很有帮助。

要创建模型模板,请参见创建模型模板

默认情况下,模型模板文件夹位于您的环境文件夹中,在 ..ProgramData\Trimble\Tekla Structures\<version>\environments\<your environment>\ 下。确切的文件夹位置可能因环境和角色而异。使用高级选项 XS_​MODEL_​TEMPLATE_​DIRECTORY 可以定义其他位置。

您可以在 Tekla Warehouse 中下载、共享和存储模型模板。该图所示的示例为 Tekla Warehouse 中的模型模板。

Tekla Warehouse 中的插入模型按钮直接将模型模板安装在由 XS_MODEL_TEMPLATE_DIRECTORY 定义的文件夹中。创建新模型时,可以立即使用此模板。

更新模型模板

我们强烈建议您在 Tekla Structures 升级时更新模型模板。

  1. 使用已有模型模板创建一个新模型。
  2. 赋予该模型与上一 Tekla Structures 版本中相同的名称。
  3. 打开 3D 视图。
  4. 文件菜单上,单击 诊断和修复 > 诊断模型
  5. 视图选项卡上,单击屏幕截图 > 工程缩略图以创建工程缩略图,或在模型文件夹中添加一个名为 thumbnail.png 的自定义图片。

    图片的首选尺寸为 120 x 74 像素。

  6. 文件菜单上,单击另存为 > 保存

    如果未执行此操作,则可能会显示一条消息,提示该模型是使用先前版本创建的。

  7. 文件 菜单上,单击 另存为 > 另存为模型模板
  8. 更新模型模板的内容。
    1. 选择要在模型模板中包括的目录、图纸模板、报告模板和模型子文件夹。
    2. 从模型文件夹中手动删除所有 *.db 文件(环境数据库、选项数据库文件)。

      不要删除 db.idrmxslib.idrm 文件。它们是模型的一部分。

    3. 单击确认

    *.bak*.logxs_user 文件将自动从模型文件夹中删除。

模型模板保存在 XS_MODEL_TEMPLATE_DIRECTORY 所定义的位置。

现在,您可以看到您的模型模板的一个示例图片。应用程序和组件 目录现在也排列有序且易于使用。

自定义报告和图纸

如果您的公司已有 DXF、DWG 或 DGN 格式的图形模板,您可以将这些模板转换为 Tekla Structures 模板。

有关详细说明,请参阅有关 Template Editor User's Guide 中 AutoCAD 和 Microstation 文件的信息。

有关如何创建自己的模板和报告的信息,请参见Template Editor User's Guide报告模板

为图纸创建复制模板

为图纸创建复制模板允许您使用现有图纸作为创建类似零件、构件或浇筑体的新图纸的基础。您只需要修改复制图形中与原始图形不同的部分。

在以下情况下考虑复制图纸:

  • 模型中有几个相似的零件、构件或浇筑体。
  • 您需要制作相似零件、构件或浇筑体的单个零件、构件或浇筑体图纸。
  • 图纸需要大量的手工编辑。

例如,您可以为一个桁架制作并编辑图纸,然后针对相似的桁架复制图纸。这样当两个桁架不同时,您只需要修改复制的图纸。

相较于原始的图纸,复制的图纸可能包括更多的零件。零件属性、标记、关联注释和相关文本对象都从原始图纸中的相似零件中复制而来。

您可以使用主图纸目录模板来复制图纸。主图纸目录中的复制模板也可以用于其他模型。您可以在具有相同类型图纸的项目中使用复制模板。

  1. 文档管理器中,选择一个图纸。
  2. 右键单击并选择添加到主图纸目录,然后填写所需的属性。

复制模板位于主图纸目录下的复制模板中。要在其他模型中使用复制模板,请在模型中打开主图纸目录,单击工具栏上的 按钮,并添加存有模板的模型。

有关主图纸目录和复制模板的更多信息,请参见在主图纸目录中创建图纸

这些内容是否有用?
上一步
下一步