建筑层次

Tekla Structures 2022

建筑层次

您可以使用建筑层次在模型中定义位置分解结构。建筑层次有一个默认的层次结构,即工程 > 工地 > 建筑 > 标高 > 空间。您可以通过从参考模型中输入标高和空间,或者直接在模型中创建标高和空间,将其添加到模型中。标高是建筑内指定高度处的水平面。空间是在建筑内提供特定功能的体积。

要创建建筑层次,请将 XS_USE_INTEGRATED_BUILDING_HIERARCHIES 高级选项设置为 TRUE。默认情况下,此高级选项设置为 FALSE。

将此高级选项设置为 TRUE 后,保存模型并重新打开它以应用更改。要打开建筑层次对话框,请转到功能区上的管理选项卡,然后单击建筑层次。

已定义的建筑层次和层次中的对象位置对于模型的所有用户通用。使用 Tekla Model Sharing 时会共享建筑层次。

如何使用建筑层次对话框

描述

1

默认的层次结构是工程 > 工地 > 建筑 > 标高 > 空间。

您可以在文件 > 工程属性中定义工程的名称。您可以在建筑层次对话框中修改其他层次标高的名称。

建筑有一个或多个标高。

标高是指定高度处的水平面。标高高度在多数情况下由建筑师定义,并且通常会定义终止楼板标高。层在 IFC 中表示为建筑层。

空间是在建筑内提供某些功能(如房间)的体积。空间会自动附加到其下方最近的标高。

2

定义标高高度。

3

系统将根据模型中的标高将模型对象附加到标高。

使用底面偏移来定义标高以下的一定距离。在所定义距离内的对象会附加到定义距离起始处的标高。

默认情况下,对象会自动附加到其下最近的标高。

4

标高偏移定义设计标高。对于钢材结构,这通常是钢材顶部 (TOS)。

5

打开输入建筑层次对话框以从参考模型中输入建筑层次。

6

单击修改以修改您在表格中编辑了其属性的对象。

7

从表格中删除选定的标高和空间。

8

选择在表格中显示哪些列。

当您下次打开建筑层次对话框时可使用选择的列。

9

如果需要,输入有关标高的附加信息。

从参考模型中输入标高和空间

您可以从参考模型中输入标高和空间。如果建筑层次对话框中已有标高和空间,它们将被您输入的标高和空间所替代。

  1. 如果要从中输入标高和空间的参考模型已经在您的模型中,请转到步骤 4。

    要将参考模型插入模型,请单击文件 > 输入 > 插入参考模型。

  2. 在添加模型对话框中,单击浏览,从列表中选择所需参考模型,或使用相应的选择开关从模型中选择。

  3. 单击 添加模型。

  4. 在功能区上,单击管理 > 建筑层次以打开建筑层次对话框。

  5. 在建筑层次对话框中,单击输入按钮。

  6. 选择要从中输入标高和空间的参考模型。

  7. 选择从建筑层次中输入的最低标高,可以是标高也可以是空间。

  8. 单击输入。

    如果模型已经有建筑层次,Tekla Structures 会显示一个关于替代现有层次的对话框。

    如果您单击替代,标高和空间会替代如下:

    • 如果您在从建筑层次中输入的最低标高中选择了标高,标高将替代为输入的标高。

    • 如果您在从建筑层次中输入的最低标高中选择了空间,标高和空间都将替代为输入的标高和空间。

    输入的标高和空间显示在建筑层次对话框中。要使标高和空间在模型中可见,请确保您已在显示设置中选择建筑层次和空间,并单击视图属性 > 显示。

创建标高

标高是建筑内指定高度处的水平面。

  1. 在功能区上,单击管理 > 标高。

    Tekla Structures 在属性窗体中显示标高属性。

  2. 在模型中的标高高度选取一个点,或者在属性窗体中输入高度,然后在属性窗体中单击插入到模型中按钮。

  3. 要创建另一个标高,请选取另一个点。要停止创建标高,请按 Esc。

创建空间

空间是在建筑内提供某些功能(如房间)的体积。空间会自动附加到其下方最近的标高。未分配空间是未分配到任何层的空间。

  1. 在功能区上,单击 管理 > 间距。

    Tekla Structures 在属性窗体中显示空间属性。

  2. 选取模型中空间的第一个边界点。

  3. 选取空间的第二个边界点。

  4. 选取空间的下一个边界点。

  5. 单击鼠标中键创建空间。

创建的空间在建筑层次对话框中它们附加到的标高下列出。

管理标高和空间

您可以在建筑层次对话框或属性窗体中管理标高和空间。

目的 操作步骤

修改标高和空间的属性

在建筑层次对话框的表格中或者在属性窗体中,修改标高和空间的属性。

单击修改,在模型中应用更改。

删除标高或空间

在建筑层次对话框的表格中选择标高或空间,然后单击删除按钮 。

您可以在表格中选择多个标高或空间。

查看构件分配到哪个标高

在模型中查询构件。

在模型中显示和隐藏标高和空间

在视图属性 > 显示中,选中或清除建筑层次和空间复选框。

过滤建筑层次对象

使用位置分解结构类别,根据其位置来过滤建筑层次对象。

在所选标高上创建视图

您可以创建在建筑层次对话框或模型中所选标高的模型视图。

  1. 在视图选项卡上,单击新视图 > 在所选标高上。
  2. 在建筑层次对话框或模型中选择标高。
  3. 在在所选标高上创建视图对话框中,定义视图名称并选择视图属性。
  4. 选择是否在标高偏移处创建视图。
  5. 单击创建。

创建的视图列于视图列表中。在功能区上,转至视图选项卡并单击视图列表。

示例:管理器中的建筑层次

您可以使用管理器查看已定义的建筑层次。

  1. 在功能区上,单击管理 > 建筑层次以打开建筑层次对话框。

  2. 在管理选项卡上,单击管理器。

  3. 在打开的对话框中选择同步以将建筑层次同步到管理器中。

    建筑层次以绿色图标 显示在类别部分的顶部。

    在建筑层次对话框中进行更改时,您需要同步管理器以在管理器中获取更改。

  4. 如果需要,您可以在标高中手动进行更改,例如,将构件移动到另一个标高。

    在模型中选择构件,然后在管理器中右键单击目标标高并单击移动所选对象命令。同步管理器。

    您可以删除手动进行的更改。选择类别,单击 并选择管理手动更改。选择用 或 标记的手动添加对象,右键单击并选择删除手动更改。同步管理器。

注:

当您在模型中使用建筑层次时,如果在 IFC 导出对话框中选择了管理器中的空间层次结构设置,则 IFC 输出将使用建筑层次级别。建筑层次空间不包括在输出中。请注意,在管理器中创建的层次不能同时使用。

要在 IFC 输出中使用在管理器中创建的层次,请将 XS_USE_INTEGRATED_BUILDING_HIERARCHIES 设置为 FALSE。

这些内容是否有用?
提交
上一步
下一步