适用于管理员的环境、公司和工程设置

Tekla Structures
2021
Tekla Structures

适用于管理员的环境、公司和工程设置

Tekla Structures 设置是在多个层上进行管理的。在最高层,有硬编码的默认设置,这些默认设置无法更改,但可以在后面的层中将其覆盖。

  • 具有安装中包含的预设值的通用环境设置。可以修改或删除这些设置。通常,安装中始终包含通用环境。

  • 具有适用于特定区域的预设值的区域环境设置。

    如果需要,您可以清理不需要的文件的通用环境和所选区域环境。

  • 高级选项 XS_FIRM,它会定义一个文件夹(通常在网络驱动器上),该文件夹将为公司内的所有用户加载设置。

    该文件夹是公司文件的主容器。

  • 高级选项 XS_PROJECT,它会定义一个文件夹(通常在网络驱动器上),该文件夹为特定工程中的所有用户加载更高级别的设置。

  • 从环境或网络文件夹中加载的模型模板。在开始创建新模型时,只会加载一次模型模板。

  • 添加或编辑设置时本地保存的模型文件夹内容。

    请注意,如果您将内容保存在模型文件夹中,则在其他位置预保存的设置将覆盖在模型文件夹中存在的相同设置。

  • Windows AppData 文件夹,用于与 Tekla Structures 用户界面相关的用户特定的设置。

环境设置

通用性设置

在所有环境中都相同的全部设置和文件位于 \Tekla Structures\<version>\Environments\common 文件夹中。环境特定文件和设置位于单独的环境文件夹中。

env_global_default.ini 文件也位于 \common 文件夹中。此文件决定标准设置,并且是第一个读取的文件。其他初始化文件将在此文件之后读取,并且如果其他文件包含相同设置,则将覆盖先前的设置。

国家/地区特定设置

国家/地区特定的设置或区域特定的设置位于环境文件夹中,并且已由您当地的 Trimble 办事处/经销商本地化。环境的文件夹结构可能会有所不同,但存在相同类型的设置。例如,已本地化的设置包括截面数据库、材料数据库、报告、选择过滤、视图过滤、组件和自定义组件、宏、用户定义的属性以及图纸设置。

公司设置

公司级别的设置主要是用于公司中所有工程的设置。 使用 XS_SYSTEMXS_FIRM 设定这些设置。

对于下设多个子公司的大型公司,可以按以下所示使用这些设置:

  • XS_SYSTEM 可以包含多个路径,并且指向公司内部的通用性设置。 这些可以是公司徽标、报告、打印机设置、图纸设置、模板等。 这些是极少更改的设置,并且存储在所有用户都可以访问的服务器上。 例如,如果更新公司徽标,则只需在一个位置替换此徽标。
  • XS_FIRM 指向公司或附属公司建立的公司文件夹。 文件夹包括所有特定办公室所使用的公司设置。 例如徽标、图纸设置、模板、报告或打印机设置等。 公司文件夹也可包含用户定义的子文件夹以存储属性文件。
  • XS_PROJECT 指向工程文件夹。 此文件夹包含工程设置,例如承包商和制造商的徽标,或图纸设置等。 工程文件夹也可包含用户定义的子文件夹以存储工程特定属性文件。

有关文件夹搜索顺序的更多信息,请参见文件夹搜索顺序

您也可以在自己的网络中使用 Tekla Warehouse 公司特定的在线或离线集合。 使用 Trimble Identity 从在线集合中下载或安装。 另请参见适用于 Tekla Online services 的 Trimble Identity

通过网络中的文件夹权限并基于每位用户电脑的 collections.json 文件的集合级别来管理离线集合访问权限。

 "collections" 
"\\\\server-A\\company\\Tekla Structures collection" 
		

collections.json 文件可通过复制至 C:\Users\Public\Documents\Tekla\Tekla Warehouse\ 文件夹共享至选择的人。

模型模板

您可以将所需的设置随模型一起保存,并在创建新模型时将模型用作模板。 如果您公司有多种不同工程,比如停车库、办公大楼、桥梁和各种产业,此功能非常有用。

创建模型模板时,一定要先创建一个新的空白模型。 这是因为无法完全清除已经在实际工程中使用过的旧模型。 其中可能包含过多的信息,从而增大模型的规模,即使您删除模型中的所有对象和图纸也是如此。

要创建模型模板,请执行以下操作:

  1. 创建新模型并为其赋予一个唯一名称。
  2. 在模型中添加所需的截面、自定义组件和其他必要项目。
  3. 文件菜单上,单击另存为 > 保存

    您需要保存模型才能在 xslib.db1 文件中包括自定义组件。 否则,自定义组件不会包括在模型模板中。

  4. 文件菜单上,单击另存为 > 另存为模型模板
  5. 输入模型模板的名称,并选择要在模型模板中包括的目录、图纸模板、报告模板和模型子文件夹。
  6. 单击确认

    默认情况下,模型模板文件夹保存在您的环境文件夹的 ..ProgramData\Trimble\Tekla Structures\<version>\environments\<your environment>\ 下。 确切文件夹位置因环境和角色而异。 使用高级选项 XS_​MODEL_​TEMPLATE_​DIRECTORY 可以定义其他位置。

您可以在 Tekla Warehouse 中下载、共享和存储模型模板。 下图所示的示例为 Tekla Warehouse 中的模型模板。

Tekla Warehouse插入到模型中按钮会直接在 XS_MODEL_TEMPLATE_DIRECTORY 指向的文件夹中安装模型模板。 创建新模型时,可以立即使用此模板。

Tekla Structures 版本中的模型模板更新

我们强烈建议您在 Tekla Structures 版本升级中更新模型模板。

要更新模型模板,请执行以下操作:

  1. 使用已有模型模板创建一个新模型。
  2. 赋予该模型与上一 Tekla Structures 版本中相同的名称。
  3. 打开 3D 视图。
  4. 文件菜单上,单击校核和修正 > 校核模型
  5. 视图选项卡上,单击屏幕截图 > 工程缩略图以创建工程缩略图,或在模型文件夹中添加一个名为 thumbnail.png 的自定义图片。

    图片的首选尺寸为 120 x 74 像素。

  6. 文件菜单上,单击另存为 > 保存

    如果未执行此操作,则会显示一条消息,提示该模型是使用先前版本创建的。

  7. 文件菜单上,单击另存为 > 另存为模型模板
  8. 选择要在模型模板中包括的目录、图纸模板、报告模板和模型子文件夹。
  9. 单击确认
  10. 从模型文件夹中手动删除所有 *.db 文件(环境数据库、选项数据库文件)。

    *.bak*.logxs_user 文件将自动从模型文件夹中删除。

    请勿删除 .idrm 文件(db.idrmxslib.idrm),因为它们是模型的一部分。

    模型模板保存在 XS_MODEL_TEMPLATE_DIRECTORY 所指向的位置。

    现在,您可以看到您的模型模板的一个示例图片。 应用程序和组件 目录现在也排列有序且易于使用。

自定义报告和图纸

如果您的公司已有 DXF、DWG 或 DGN 格式的图形模板,您可以将这些模板转换为 Tekla Structures 模板。 有关操作的详细说明,请参见 AutoCAD 中的信息和模板编辑器帮助文件中的 Microstation 文件。

有关如何创建自己的模板和报告的信息,请参见模板编辑器帮助、报告模板

复制图纸模板

您应在以下情况下考虑复制图纸:

  • 模型中有几个相似的零件、构件或浇筑体。
  • 您需要制作相似零件、构件或浇筑体的单个零件、构件或浇筑体图纸。
  • 图纸需要大量的手工编辑。

例如,您可以为一个桁架制作并编辑图纸,然后针对相似的桁架复制图纸。 这样当两个桁架不同时,您只需要修改复制的图纸。

相较于原始的图纸,复制的图纸可能包括更多的零件。 零件属性、标记、关联注释和相关文本对象都从原始图纸中的相似零件中复制而来。

复制主图纸目录中的模板

您可以使用主图纸目录模板来复制图纸。 主图纸目录中的复制模板也可以用于其他模型。 还可以用于具有同类图纸的工程中。

要创建复制模板,请执行以下操作:

  1. 文档管理器中选择图纸。
  2. 右键单击并选择添加到主图纸目录,然后填写所需的属性。

复制模板位于主图纸目录下的复制模板中。 要在其他模型中使用复制模板,请在模型中打开主图纸目录,单击工具栏上的 按钮,并添加存有模板的模型。

有关主图纸目录和复制模板的更多信息,请参见在主图纸目录中创建图纸

工程设定

创建自己的组件文件夹

通常,工程中仅会使用少量的不同节点和组件。 为了确保工程中的每个人都能够使用相同组件,并且更快地寻找组件,我们建议您创建自己的组件文件夹。

  1. 单击侧窗格中的应用程序和组件按钮 打开应用程序和组件目录。
  2. 为工程新建组: 右键单击目录并选择新建组
  3. 添加组件到组: 选择目录中的组件,然后右键单击并选择添加到组。 然后选择这些组件要添加到的组。 您也可以将所选组件拖动到另一组。
  4. 隐藏不需要的组: 选择组,右键单击并选择隐藏/显示
提示:

应用程序和组件目录中,请使用访问高级功能 >目录管理中的命令,以修改目录定义。 有关更多信息,请参见自定义应用程序和组件目录XS_​COMPONENT_​CATALOG_​ALLOW_​SYSTEM_​EDIT

有关应用程序和组件目录的更多信息,请参见如何使用应用程序和组件目录

定义工程属性

在工程期间,会经常需要工程信息。 在工程开始时定义工程信息,可以使报告和图纸自动显示正确的信息。 在工程期间,您也可更新工程属性。

  1. 文件菜单上,单击工程属性
  2. 编辑工程属性。

    在编辑属性时,Tekla Structures 以黄色高亮显示已修改的属性。

  3. 在您准备好进行修改时,请单击修改应用更改。

创建并修改模板和报告

您可以修改现有报告和模板,或使用模板编辑器来创建自己的模板。 要打开模板编辑器,请单击文件 > 编辑器 > 模板编辑器,或在当前打开的图纸上双击现有表格也可打开此工具。 有关更多信息,请参见Template Editor User's Guide

请注意:如果您的模板位于受保护的文件夹中,则这些模板为只读模板,您无法将已修改模板保存至受保护文件夹。 在此情况下,以管理员身份登录运行 Tekla Structures

设置打印机

Tekla Structures 使用 Windows 驱动程序直接将打印数据写入 Windows 打印设备接口。 您可以将图纸打印为 PDF 文件,将其另存为绘图文件 (.plt) 以便通过打印/绘图机进行打印,或者在选定的打印机上进行打印。 要打印多种页面尺寸,您需要修改 drawingsizes.dat 文件。有关更多信息,请参见打印时使用的配置文件。 您还可以更改打印图纸中的线宽,有关更多信息,请参见打印为 .pdf 文件、打印文件 (.plt) 或打印到打印机图纸中的线宽

通过使用某些图纸类型特定的高级选项,您可以影响 Tekla Structures 自动命名 .pdf 文件和打印文件的方式。有关更多信息,请参见自定义打印输出文件名

Was this helpful?
Previous
Next