在任务管理器中创建任务

Tekla Structures
2021
Tekla Structures

在任务管理器中创建任务

您可以在任务管理器中创建计划的任务,并将这些任务链接到相关模型对象。每个任务必须至少具有名称及计划开始日期和结束日期。保存 Tekla Structures 模型时,会保存任务管理器中的任务。

您可以在模型和任务管理器中创建任务。要打开任务管理器,请单击功能区上的管理,然后单击任务

  • 在模型中,选择一个或多个模型对象,然后右键单击并选择任务 > 创建任务

    该任务即会自动链接到所选模型对象。

  • 任务管理器 中,单击

    如果在任务管理器中已选择现有任务,则会在新任务中使用已选择任务的属性。您可以修改属性。新任务尚未与任何模型对象链接。

    您可以通过单击 创建任务的子任务。

如果您创建的任务未显示在任务管理器中,请单击任务列表中的任意位置以更新视图。

在创建一项任务后,可以向该任务中添加对象以将该任务与模型链接,并定义任务属性。您可以在任务列表或在任务信息对话框中修改任务属性。请注意,您只能在任务信息对话框中修改某些属性。

提示:

如果您希望确保不会无意中更改任务属性,则可以锁定任务。选择任务,右键单击并选择锁定任务。锁定的任务在任务列表中带有一个锁 标记。

您可以一次性锁定一个或多个任务。如果您选择多个任务,并且一个或多个任务(不是全部任务)已经锁定,则任务管理器会在锁定任务命令前显示

将任务链接到模型

通过任务中包括的对象可将这些任务链接到模型。您可以将对象添加到任务中,从一个任务中将对象复制到另一个任务,以及从任务中删除对象。

要打开任务管理器,请单击功能区上的管理,然后单击任务
目的 操作步骤

将对象添加到任务

  1. 在模型中,选择要添加到任务中的对象。
  2. 执行以下操作之一:
    • 右键单击并选择任务 > 添加至选择的任务
    • 任务管理器中,右键单击所选任务并单击添加所选对象

在将对象添加到任务中后,任务管理器会将甘特图中任务栏的颜色更改为蓝色,并且选中任务列表中的链接到模型的任务复选框

将对象从一个任务复制到另一个任务

您可以在任务管理器中将对象从一个任务复制到另一个任务。如果您想将任务的所有对象移动到另一个任务中,则必须在复制后从原始任务中手动删除这些对象。
  1. 选择要从中复制对象的任务。
  2. 单击 会自动在模型中选择对象以查看哪些对象与任务链接。

    当激活后,该按钮会变为

  3. 右键单击所选任务并选择保持选择

    与任务链接的所有对象都保持选定状态。

  4. 选择要向其中复制这些对象的任务。
  5. 右键单击并选择添加所选对象

从任务中删除对象

  1. 选择要从中删除对象的任务。
  2. 单击 可自动选择模型中的对象。

    您可以从任务中删除所有对象,或选择删除哪些对象。如果不选择任何对象,则会从任务中删除所有对象。

  3. 要从任务中删除所有对象,请执行以下操作:
    • 在模型中,右键单击并选择任务 > 从选择的任务中删除

    • 任务管理器中,右键单击所选任务并单击删除所选对象

  4. 要从任务中删除某些对象,请执行以下操作:
    • 任务管理器中,右键单击所选任务并选择任务信息... > 对象。选择要删除的对象并按 Delete 键。

    • 在模型中,选择要删除的对象,右键单击并选择任务 > 从选择的任务中删除
  5. 在模型中单击视图,然后在任务管理器中再次单击该任务,以验证是否已成功删除对象。

定义任务类型

您可以为不同类型的任务定义任务类型。在任务类型中,可以定义与任务中对象相关联的生产率和用户定义的属性。您可以在创建任务之前事先定义任务类型,然后在定义任务属性时选择一个适当的任务类型。

  1. 要打开任务管理器,请单击功能区上的管理,然后单击任务
  2. 单击 > 任务类型...
  3. 单击添加
  4. 键入该任务类型的名称。
  5. 定义该任务类型的生产率。

    当计算任务持续时间时会使用生产率。使用生产率,您可以定义在某个特定时段内的生产量,例如,每小时完成的件数或者每小时完成多大面积,1.50 pcs/hour8.00 m2/hour。当您定义单位、数量和时间时,任务管理器会自动计算生产率。

    1. 单位列表中选择一个单位。

      默认单位为 PIECES

      默认任务类型单位为列于 WorkTypeProperties.xml 文件中的报告属性。该文件位于模型文件夹中,当您第一次打开任务管理器时会创建该文件。该文件中包括的报告属性取决于 Tekla Structures 环境。要更改任务类型单位或添加新任务类型,请编辑 WorkTypeProperties.xml 文件。

      您可以向文件中添加 Tekla Structures 报告属性、参考模型属性和计算。文件中定义的显示名称显示在单位列中,并且报告属性名称值将用于任务管理器。如果您添加计算,属性类型必须是 calc

      任务类型的默认单位取决于文件 > 设置 > 选项 > 单位和精度中的设置。

    2. 数量框中键入数量。
    3. 时间中键入时间。
  6. 选择与任务中对象相关联的计划日期用户定义的属性。
  7. 单击确认

在任务管理器中定义承包商

您可以为任务定义承包商并分配一个承包商。

  1. 要打开任务管理器,请单击功能区上的管理,然后单击任务
  2. 单击 > 承包商...
  3. 单击添加
  4. 键入承包商名称。
  5. 单击确认

定义通用任务属性

您可以定义任务的通用属性,例如名称、任务类型和承包商。

  1. 要打开任务管理器,请单击功能区上的管理,然后单击任务
  2. 从任务列表中选择一个任务。
  3. 右键单击并选择任务信息...
  4. 确保位于通用性选项卡上。
  5. 任务名称框中键入任务名称。
  6. 如果要将该任务标记为里程碑,请选中里程碑复选框。

    如果将任务长度设置为零,任务管理器会自动选中此复选框。

  7. 如果该任务与另一任务有从属关系,请选择该任务在甘特图中的移动方式:
    • 只向前仅在向前移动原有任务时,才会向前移动从属任务。如果将原有任务向后移动到一个更早的日期,则不会移动从属任务。
    • 向前和向后根据从属关系类型和可能的滞后时间,按照与原有任务相同的方向移动从属任务。
  8. 任务类型列表中选择任务类型。

    如果需要添加新任务类型,请单击列表旁的 并单击添加。定义任务类型属性并单击确认

  9. 承包商列表中选择承包商。

    如果需要添加新承包商,请单击列表旁的 并单击添加。输入承包商名称并单击确认

  10. 单击确认
提示:
  • 您可以复制任务列表中的属性值。右键单击一个属性并选择复制值。然后选择另一个属性,右键单击并选择粘贴值。您可以将已复制的值粘贴到多个任务。
  • 您可以一次性地将多个任务标记为里程碑任务。在任务列表中选择任务,右键单击并选择里程碑任务。里程碑任务以里程碑符号 的形式显示在甘特图中。

    如果您选择多个任务,并且一个或多个任务(不是全部任务)已经是里程碑任务,则任务管理器会在里程碑任务命令前显示

提示:

可以为从属任务的移动方式设置默认值。单击 > 任务设置... 选择值。默认值用于所有新任务中。

定义任务计划

您可以为任务制定一个计划。您可以定义开始日期和结束日期,或者输入开始日期和任务时长,并让任务管理器计算结束日期。

  1. 要打开任务管理器,请单击功能区上的管理,然后单击任务
  2. 从任务列表中选择一个任务。
  3. 右键单击并选择任务信息...
  4. 转到预定选项卡。
  5. 选择预定模式
    • 固定的开始和结束

      如果您向任务中添加对象或者从任务中删除对象,生产率会发生变化,但是任务时长不变。

    • 固定的开始

      如果您向任务中添加对象或从任务中删除对象,则任务时长会发生变化。

  6. 选择计划开始时间
  7. 选择计划结束时间或输入任务的计划长度

    计划长度会以班次(例如,可以是工作日)的形式显示。转到 > 非工作周期... 定义工作日。在输入计划长度时,任务管理器会计算任务的结束日期。

    如果使用固定的开始预定模式,则可以在计划的工作持续时间中输入任务长度。

    任务管理器会自动计算任务的总工作量、生产率和工作持续时间。

  8. 单击确认
提示:

可以设置预定模式的默认值。单击 > 任务设置... 选择值。默认值用于所有新任务中。

提示:

您也可以在甘特图中修改任务的持续时间。将鼠标指针放在甘特图中任务栏的边缘上。鼠标指针将变为双头箭头。按住鼠标左键,然后向右或向左拖动边缘。

若要检查子任务的日期是否在摘要任务日期范围内,请单击 > 检查日期。冲突的日期会以红色显示。

管理任务中对象的计划日期

您可以管理与任务中每个对象相关的各项活动的计划持续时间。

  1. 要打开任务管理器,请单击功能区上的管理,然后单击任务
  2. 从任务列表中选择一个任务。

    确保任务中有对象,并且您已经为计划日期定义了与相应的用户定义的属性关联的任务类型。

  3. 右键单击并选择任务信息...
  4. 转到对象选项卡。
  5. 单击 功能按钮,以便为任务中的对象计算计划日期。

    计算日期会写入对象属性中相应的用户定义的属性。

  6. 单击确认
提示:

要一次性计算多个任务的日期,请在任务列表中选择任务并单击

跟踪任务计划

通过定义实际计划和任务完成进度信息,您可以跟踪任务的进展情况。

  1. 要打开任务管理器,请单击功能区上的管理,然后单击任务
  2. 从任务列表中选择一个任务。
  3. 右键单击并选择任务信息...
  4. 转到跟踪选项卡。
  5. 选择完成情况跟踪模式:
    • 自动

      如果任务中没有对象,则自动任务级别跟踪模式的工作方式相同。

      如果任务中有对象,则自动对象级别跟踪模式的工作方式相同。

    • 任务级别

      任务管理器中的任务定义实际计划和任务完成进度。

    • 对象级别

      在模型中的对象属性中定义各个对象的实际开始日期和结束日期。任务管理器会计算任务长度以及任务完成进度。

      在更改模型中对象的日期时,请在任务管理器中刷新任务,以确保任务管理器中显示更改的日期。

  6. 单击确认
提示:

您可以设置完成情况跟踪属性的默认值。单击 > 任务设置... 选择值。默认值用于所有新任务中。

定义任务中对象的次序

您可以定义和保存对象在任务中的存储次序。

  1. 要打开任务管理器,请单击功能区上的管理,然后单击任务
  2. 从任务列表中选择一个任务。
  3. 右键单击并选择任务信息...
  4. 转到对象选项卡。
  5. 设置对象的排序次序:
    1. 单击 以选择表格中的所有对象,或选择要修改的对象。
    2. 单击

    排序次序列显示对象的次序。

    您还可以通过在模型中按所需的次序选择对象,来设置排序次序。在表格中选择对象,单击 并按所需次序在模型中选择对象。

  6. 如果需要,可更改表格中对象的次序:
    • 通过手动拖动将表格中的对象行调整为所需次序。

      一次可拖动多个对象行。

    • 单击表格列标题可对对象进行排序。

      按住 Ctrl 的同时选择多个列标题可以按多列排序对象。

  7. 单击确认
提示:

您可以在模型中显示次序。

  1. 在表格中选择对象。
  2. 播放 按钮旁的框中以秒为单位键入对象选择的速度。

    例如,如果您输入 2,则 Tekla Structures 会等待 2 秒,直到它选择次序中的下一个对象。

  3. 单击

对象在模型中的选择次序与它们在对象选项卡上的次序相同。对象在模型中会保持选中状态,直到您在模型中的某处单击为止。

提示:

要在模型中显示次序信息,请在表格中选择一个或多个对象,并单击 ,或按 Ctrl + D。次序信息显示在模型中的选定对象上。例如,2-1 表示该对象属于任务列表中的第二个任务,该对象是任务中的第一个对象。

要清除模型中的数字,请右键单击并选择更新窗口

当您定义任务中的当场浇筑工作次序或工作组时,可以使用管理器为每个组或拆运计划适当的数量

定义任务间的从属关系

您可以在任务管理器中定义任务间不同类型的从属关系。您一次可以为一个任务定义从属关系。

在甘特图中从属关系用箭头表示。根据其关系,箭头可以指向另一个任务的开始或结束。任务还可以取决于里程碑。

原有任务是必须在从属任务之前完成的任务。您还可以在任务之间定义滞后,例如,任务 1 必须在任务 2 开始前五天完成。在任务管理器中不能创建循环从属关系。

定义任务间的从属关系:

  1. 要打开任务管理器,请单击功能区上的管理,然后单击任务
  2. 从任务列表中选择一个任务。
  3. 右键单击并选择任务信息...
  4. 转到从属关系选项卡。

    如果您选择了多个任务,则不会显示任务信息...选项卡。

  5. 任务名称列表中选择原有任务。

    您不能选择当前任务的摘要任务,或已经与当前任务有从属关系的任务。

  6. 类型列表中选择从属关系类型。选项有:
    • 完成到开始 (FS):必须完成原有任务后,才能开始从属任务。

      您可以在甘特图中将一个任务栏拖放到另一个任务栏处,以便创建基本的完成到开始 (FS) 从属关系,即任务之间没有延迟天数。

    • 开始到开始 (SS):原有任务必须开始后,从属任务才能开始。
    • 完成到完成 (FF):原有任务必须完成后,从属任务才能完成。
    • 开始到完成 (SF):原有任务必须开始后,从属任务才能完成。
  7. 如果想在任务间增加延迟,请在滞后列表中输入一个值。

    请指定 1 到 100 之间的值。延迟的时间单位始终是

  8. 如果需要,请转到通用性选项卡,并检查甘特图中决定任务移动方式的带原有任务移动设置是否恰当。
  9. 单击确认
提示:

您还可以在甘特图中修改从属关系。右键单击从属关系箭头并执行以下操作之一:

  • 从列表中选择从属关系。
  • 输入一个新的滞后值,并按 Enter 键。

在甘特图中可以立即看到更改。

定义任务的附加信息

您可以在任务管理器中定义任务的附加信息,例如,网页链接、相关文档、工程计划和合同。

  1. 要打开任务管理器,请单击功能区上的管理,然后单击任务
  2. 从任务列表中选择一个任务。
  3. 右键单击并选择任务信息...
  4. 转到附加信息选项卡。
  5. 单击添加
  6. 选择文件并单击打开
  7. 请在说明框中输入附加说明。
  8. 单击确认

创建方案

任务包括在方案中。您可以创建不同的方案以定义备选工作流,例如,用于帮助您进行工程规划的设计、制造和安装计划。您还可以创建单独的每周方案,以方便进行工程跟踪。

  1. 要打开任务管理器,请单击功能区上的管理,然后单击任务
  2. 单击
  3. 单击添加

    任务管理器会将新的方案命名为方案并在名称中添加一个次序号,例如,方案1。您可以重命名该方案。

  4. 单击打开将任务添加到新方案。
  5. 单击 创建任务。
  6. 如果需要,可从其他方案中复制任务。
    1. 在方案列表中选择一个方案并单击打开
    2. 选择要复制的任务。

      所选任务的子任务也会一同复制。

    3. 右键单击并选择复制无对象复制
    4. 转回到新方案,在任务列表中为复制的任务选择位置,右键单击并选择粘贴

      当选择一个位置时,复制的任务将与所选任务位于同一级别。如果您未选择任何位置,则复制的任务会位于所有现有任务之后。

提示:

要一次性修改整个方案的开始日期,请单击 > 更改工程开始日期并选择新的开始日期。

要删除方案,请右键单击方案列表中的相应方案并单击删除

Was this helpful?
上一步
下一步