使用 GUID 选择要在报告中包括的对象

Tekla Structures
2021
Tekla Structures

使用 GUID 选择要在报告中包括的对象

您可以使用对象的 GUID(全局唯一标识符)来选择报告中包括的对象。

  1. 创建用于创建报告的模板。
    1. 文件菜单上,单击编辑器 > 模板编辑器
    2. 在模板编辑器中,单击文件 > 新建
    3. 选择文本模板并单击确认
    4. 添加用于 GUID 的行。
      • 单击插入 > 组件 >

        选择行的内容类型,然后单击确认

      • 单击插入 > 文本并输入文本 guid:Guid: GUID:.单击确认

        这使您可以在模型中选择对象。

      • 单击插入 > 值字段。单击一个点以定义行内字段的位置。将出现选择属性对话框,提示您选择值字段的属性。

        选择属性 GUID 并单击确认

    5. 在模板中添加所需数量的其它行。
    6. 单击File > Save As

      输入模板的名称并浏览到已为高级选项 XS_​TEMPLATE_​DIRECTORY 定义的文件夹。使用文件扩展名 .rpt

  2. 根据已保存的报告模板创建报告。
    1. 图纸和报告选项卡上,单击报告
    2. 从列表中选择您创建的报告模板。
    3. 单击从全部的目标中创建

      Tekla Structures 将会显示报告。

  3. 单击报告中包含 GUID 编号的行。

    Tekla Structures 将会在活动的模型视图中选择相应的对象。

Was this helpful?
上一步
下一步