建模改进

Tekla Structures
2021
Tekla Structures

建模改进

Tekla Structures 2021 引入了许多建模方面的改进。

零件实体创建方面的改进

Tekla Structures 2021 在钢结构零件和混凝土零件实体创建中使用实例化。由于同一零件实体几何形状可以在模型中的多个位置使用,而无需反复重新创建相似的几何形状,因此这将提高整体性能。将实体几何形状存储在实体缓冲区中所需占用的内存也更少,因为仅为所有类似的实例存储一个几何形状条目。例如,根据模型中相似零件的重复程度,在打开模型视图、编号和输出时可以感受到性能提升。

现在,实体几何形状是在零件的局部坐标中创建和存储的,这有助于提高精度。这改进了编号功能,因为不管零件在模型总体坐标中处于什么位置,零件均将分配到相同的系列中。

复制或移动对象时的新预览

在使用复制移动命令复制或移动对象时,Tekla Structures 现在会在模型中显示所复制或所移动对象的新位置的预览。这样一来,您可以先查看复制或移动的最终效果,然后再为所复制或所移动的对象选取目标点。

  1. 选择要复制或移动的对象。

  2. 运行复制移动命令。

  3. 选取复制或移动的原点。

    Tekla Structures 在第一个所选的点和光标位置之间显示一条拖引线。移动光标可查看预览的更改方式。

    请注意,Tekla Structures 始终在将复制或移动对象的位置显示预览,而不是在选取目标点时光标所在的位置显示预览。

  4. 选取目标点。

如果要限制预览中显示的对象数量,请使用高级选项 XS_PREVIEW_LIMIT。默认值为 1000。如果值为 0,则关闭预览。

线性阵列工具和径向阵列工具的改进

  • 线性阵列工具中,如果您未输入复制的份数,则将从复制之间的间距框中定义的对象间的间距中获取复制的份数。

  • 径向阵列工具中,如果您未输入角度或距离数,则将从复制之间的间距框中定义的对象间的距离中获取复制的份数。

使用 Enter 键完成命令

您现在可以使用 Enter 键完成命令。确保将新的高级选项 XS_ENTER_FINALIZES_COMMANDS 设置为 TRUE 以将 Enter 键启用为快捷键。

以前,仅可将空格键和鼠标中键作为完成命令的快捷键,对于直接修改命令,仅可将鼠标中键作为快捷键。

捕捉方面的改进

在渲染选项为已渲染零件已渲染组件 (Ctrl/Shift +4) 的视图中,无法再捕捉到对象的主隐藏参考线或几何线。

切割面方面的改进

在创建切割面时,现在在使用阴影线框灰度渲染选项(Ctrl+2Shift+2Ctrl+3Shift+3)时,也可以在零件和组件对象上选择平面。相关状态栏消息也得到了改进。

改进了属性窗格中的错误消息

以前,如果您在属性窗体的值框中输入了无效的值,则该框周围会显示红色边框,同时会显示一个红色感叹号。现在,不会显示感叹号,而是在值框的顶部显示一个工具提示,其中显示了错误消息。

浇筑管理方面的改进

  • 浇筑管理功能的性能得到了改进。这些改进加快了打开和修改模型以及计算浇筑体的速度。

  • 在使用计算浇筑体命令时,预制浇筑体不再自动添加到浇筑体中。不过,仍可以手动添加它们。

  • XS_CALCULATE_POUR_UNITS_ON_SHARING 的默认值已更改为 FALSE。这意味着,Tekla Structures 不再在写出和读入期间自动计算并更新共享模型中的浇筑体。相反,在需要最新的浇筑体信息时,每个用户现在可以在其本地版本的共享模型中运行计算浇筑体命令。

  • Tekla Structures 2020 SP1 引入了浇注计算方面的一些改进。有关详细信息,请参见 2020 SP1:新增功能和改进

从文件菜单中删除了使用情况统计部分

删除了文件 > 设置中的使用情况统计部分。请注意,默认情况下将收集使用情况数据。

包含所收集数据的 UserFeedbackLog.txt 文件现在与其他日志文件一起位于文件 > 日志 > 使用情况数据日志中。

请注意,在单击使用情况数据日志以打开 UserFeedbackLog.txt 文件时,该日志文件始终在默认文本编辑器中打开,这与其他日志文件不同,后者可通过 Tekla Structures 日志查看器打开。UserFeedbackLog.txt 文件不支持在查看器之间切换。

UserFeedbackLog.txt 日志文件位于 TeklaStructuresModels 文件夹中。

其他建模改进

  • 现在可以复制表面对象。如果将其附加到零件表面,则在复制零件时复制表面对象。表面也可以从一个对象类型复制或移动到相同的对象类型,即从一个零件移动到另一个零件,以及从一个浇筑对象移动到另一个浇筑对象。

  • 在模型视图中,在曲面对象中不再显示镶嵌边缘。这适用于 DirectX 渲染和旧式 (OpenGL) 渲染。

  • 功能区的编辑上现在提供了 将零件转换为项 使用几何结构创建形状命令。以前,可以使用右键单击上下文菜单或快速启动来启动这些命令。

  • 在建模模式和图纸模式中,已将活动窗口子菜单现从缩放上下文菜单中删除。在建模模式下,缩放命令可以在缩放菜单的视图选项卡中使用,并且工具提示将显示相关的键盘快捷键。在这两种模式下,缩放命令在快速启动中均可用,在这里也可以看到键盘快捷键。

  • 已从材料目录中删除钢筋钢筋网分支。钢筋定义包含在钢筋目录中。

Was this helpful?
Previous
Next