CAD

Tekla Structures
2021
Tekla Structures

CAD

CAD 输入和输出工具支持多种格式以输入和输出模型。您最多可以输入 10,000 个零件。如果零件的数量超过该值,Tekla Structures 将显示警告信息并不再输入该模型。

CAD 输入和输出格式

下表列出支持的输入和输出文件类型。

选项

输入

输出

输入自/输出到

SDNF

SDNF(钢结构深化中性文件,Steel Detailing Neutral File)用于在多种不同 CAD 系统中进行输入和输出。

HLI

HLI(高级界面)。IEZ AG Speedikon 软件

接合视图

接合视图设计系统

SDNF (PDMS)

工厂设计管理系统。Aveva 3D 工厂设计软件。

数据通过 SDNF 链接输出到 PDMS。Tekla Structures 将完成字段的信息写入到成员类属性中,而在 SDNF 输出中将忽略类信息。

XML

ArchiCAD 建模系统。

该输出存在以下限制:

  • 不使用转换文件。

  • 不输出孔、螺栓和焊缝。

除了 CAD 输入工具外,新建输入模型对话框也提供了 FEM 输入。FEM 输入的步骤与 CAD 输入的步骤相同。

输入 CAD 文件

  1. 文件菜单中,单击输入 > CAD

    此时显示输入模型对话框。

  2. 选择输入类型输入 CAD
  3. 单击新建,然后在新建输入模型对话框中为输入文件输入新名称。
  4. 新建输入模型对话框中,单击属性... 按钮定义输入设置,这些设置取决于所选的输入类型。

    有关输入类型特定设置的更多信息,请参见下面部分中的设置及其说明。

  5. 单击确认(O),应用更改的属性。
  6. 新建输入模型对话框中,单击确认
  7. 从列表中选择输入模型名称并单击输入
  8. 输入模型对话框中,选择要输入的零件版本。
  9. 单击全部接受

    如果要在现有模型的基础上输入新模型,则通常使用全部接受选项。如果您要在更改模型后重新输入该模型,也可以通过单击拒绝全部拒绝所有更改,或单击分别选取...接受或拒绝各个更改。

  10. Tekla Structures 显示消息要保存输入模型,接下去输入吗?,单击

    Tekla Structures 将在模型视图中添加该输入模型。

  11. 右键单击模型视图并选择适合工作区域到整个模型以确保输入的模型完全可见。
  12. 如果缺少零件,请检查视图属性对话框中检查向上深度向下深度的值,并在必要时更改它们。
注:

在 SDNF 输入中,如果您要输入 Tekla Structures 零件中没有的信息,您可以使用要输入的 SDNF 文件中的 SDNF 延长线,以及 Tekla Structures 中用户定义的属性 REVISION_NUMBER

CAD 输入的设置

设置 描述

转换选项卡

截面转换文件

材料转换文件

双截面转换文件

定义要使用的转换文件。

转换文件将 Tekla Structures 截面和材料名称映射到在其它软件中使用的名称。

有关转换文件的更多信息,请参见转换文件

参数选项卡

输入文件

您要输入的文件。您也可以浏览查找该文件。默认值为 import.lis

类型

定义输入文件或模型类型:

SDNF、HLI、接合视图、SDNF (PDMS)、XML

X原点 , Y原点 , Z原点

定义原点坐标以将文件置于特定位置。

SDNF选项卡

位置编号

输入零件的前缀和起始位置编号。

此设置与位置编号类型设置相关。

SDNF版本

将 SDNF 格式类型设置为 2.03.0

SDNF 3.0 通常是要选择的格式。但对于 StruCAD,最好共享 SDNF 2.0 文件。

应用切割和接合

设置为(默认值)可在输入中应用切割和接合。

仅当 SDNF 文件中包含切割和接合时才会包括切割和接合。

认为平移

设置为可创建偏移。多数情况下应选择(默认值)会将零件创建点置于零件端点。

多数情况下应选择(默认值)会将零件创建点置于零件端点。

创建日志文件

选择创建可在每次输入模型时写入新日志文件并删除以前的日志文件。

如果输入失败,请检查日志文件以查找原因。即使输入看上去已经成功,也应检查日志文件。

选择添加(默认值)会将日志文件信息添加到现有日志文件的末尾。

如果您不需要日志文件,请选择

显示日志文件

选择通过外部视图可在文本编辑器中显示日志文件。

选择在对话框中可创建一个单独的列表对话框,在该对话框中只能查看该文件。

如果您不想显示该文件,请选择

日志文件名

输出日志文件名或浏览查找现有的日志文件。

位置编号类型

SDNF 文件中包含标识符,这些标识符可以包含在零件的用户定义的属性中,也可以用作零件位置编号。

如果您希望标识符成为零件位置编号,请选择零件位置。使用该选项时不要使用位置编号选项。

如果您希望标识符成为零件的用户定义的属性,请选择通用编号

对于从 PDS 或 PDMS 输入文件,通常应选择“通用编号”选项。

要使用户定义的属性在对话框中可见,您需要将它们添加到 objects.inp 文件中。

接合视图选项卡

材料

选择材料等级。

报告 选项卡

创建报告

设置为可创建报告。

显示报告

设置为可显示报告。

报告模板

选择报告模板。

报告文件名称

输入报告文件名或浏览查找报告文件。

如果不给报告提供任何其它名称,报告将会以名称 import_revision_report.rpt 保存在模型文件夹中。

高级选项卡

当...起作用 对象状态是(相对于)

先前 计划列出模型中的对象,与要输入的文件中的对象进行比较。它们可以是新建修改删除相同

Tekla Structures 将输入对象的状态与模型中对象的状态进行比较。它们可以是不在模型中不同相同

使用不在模型中不同相同下的选项指定输入已更改对象时的操作。对应选项包括不起作用 复制修改删除

通常不需要更改默认值。

FEM 输入的设置

设置 描述

转换选项卡

截面转换文件

材料转换文件

双截面转换文件

定义要使用的转换文件。

转换文件将 Tekla Structures 截面和材料名称映射到在其它软件中使用的名称。

有关转换文件的更多信息,请参见转换文件

零件选项卡

零件 位置编号

构件 位置编号

输入前缀和起始位置编号。

参数选项卡

输入文件

您要输入文件的名称。您也可以浏览查找该文件。

类型

选择文件输入类型:DSTV、SACS、Monorail、Staad、Stan 3d、Bus

X原点 , Y原点 , Z原点

定义原点坐标以将文件置于特定位置。

默认屈服应力限制

当屈服应力大于等于界限的默认材料

当屈服应力小于界限的默认材料

当屈服应力小于界限的默认材料 设置用于 SACS 输入文件。定义屈服应力小于此限制时使用的材料。

设置当屈服应力大于等于界限的默认材料 用于 SACS 或 DSTV 输入文件。对于 SACS,该字段定义屈服应力大于或等于该限制时使用的材料。对于 DSTV,如果在输入文件中不包含材料等级,则您可以在此处输入材料等级。

组合构件

组合最大长度

要在 Tekla Structures 中将 FEM 模型中的多个元素合并为一个零件,请将组合构件设置为

例如,如果文件中的梁由多个元素构成,而且您选择,那么这些元素将在 Tekla Structures 模型中组合为一个梁。

如果使用值,则 Tekla Structures 将为 FEM 模型中的每个元素都创建一个梁。

组合最大长度 仅在您将组合构件设置为时应用。使用此设置可定义组合零件的最大长度。只有组合后的长度小于您此处输入的值时,Tekla Structures 才会将这些元素组合为一个零件。

Staad选项卡

材料

选择材料等级。

报告 选项卡

创建报告

设置为可创建报告。

显示报告

设置为可显示报告。

报告模板

选择报告模板。您也可以浏览查找该模板。

报告文件名称

输入报告文件名或浏览查找报告文件。

如果不给报告提供任何其它名称,报告将会以名称 import_revision_report.rpt 保存在模型文件夹中。

DSTV选项卡

版本

选择 DSTV 版本。

输入静态元素

输入其他元素

如果要输入的 DSTV 文件中包含静态模型和 CAD 模型,则您可以选择输入哪一个模型。

回答输入静态元素将输入静态模型。

回答输入其他元素将输入CAD模型。

Stan 3d选项卡

比例

指定该输入模型的比例。只要 Tekla Structures 模型和输入模型都使用毫米作为单位,您就可以在输入 Stan 3d 格式时不指定比例。如果 Stan 3d 文件使用毫米作为单位,则使用比例 1。如果 Stan 3d 文件使用米作为单位,则使用比例 1000。

材料

指定要输入零件的材料。

Bus选项卡

位置编号

指示要输入的梁、柱、支撑和悬臂梁的位置编号

材料

指定要输入零件的材料。

名称

指定要输入零件的名称。

等级

指定要输入零件的等级。

平面下的梁

在楼层标高对齐所有梁的顶部。

高级选项卡

当...起作用 对象状态是(相对于)

先前 计划列出模型中的对象,与要输入的文件中的对象进行比较。它们可以是新建修改删除相同

Tekla Structures 将输入对象的状态与模型中对象的状态进行比较。它们可以是不在模型中不同相同

使用不在模型中不同相同下的选项指定输入已更改对象时的操作。对应选项包括不起作用 复制修改删除

通常不需要更改默认值。

重新输入 CAD 模型

有时您已经输入了一个模型,但由于进行了某些更改,您需要重新输入该模型。

截面和材料转换文件需要与原始模型输入中定义的文件相同。

以下说明也适用于 CIMsteel (cis/2) 模型。

  1. 打开 Tekla Structures 和您已在其中输入现有 CAD 模型的模型。
  2. 文件菜单中,单击输入 > CAD
  3. 类型列表中选择导入类型。

    对于 CAD 模型,此操作通常仅适用于 SDNF 格式的文件。

  4. 名称框中为已输入的模型输入一个新名称。

    路径和文件名的总长度不能超过 80 个字符。如果路径总长度过长,则会显示一条消息,指示“文件名称和路径太长。请将文件放到另一个目录下。”此外,如果使用的名称与原始输入中使用的名称相同,Tekla Structures 将显示警告信息“输入模型的名称不合法”。

  5. 单击属性...按钮并确保转换选项卡上的截面材料转换文件与原始模型输入中采用的文件相同。
  6. 转到高级选项卡并定义 Tekla Structures 在输入已更改的对象时执行的操作:
    • 左边的列先前计划列出模型中对象的状态,与输入文件中对象的状态进行比较。它们可以是新建修改删除相同

    • 对象可以是不在模型中不同相同

    • 使用不在模型中不同相同下面的行中的列表框,指定输入更改对象时要执行的操作。对应选项包括不起作用 复制修改删除

      您可以选择仅将删除用于删除对象。您只能使用删除来删除那些已经从您的模型而不是从输入模型中删除的对象。

    • 通常,大多数用户都将使用默认设置。

  7. 单击确认(O)应用(A)
  8. 输入对话框中单击输入模型以输入更新的模型。
  9. 报告选项卡上创建报告以便比较各个输入。

输出到 CAD

您可使用多种格式输出 CAD 模型。

Note:

开始 SDNF 输出之前,请确保未在高级选项对话框的输出页面上设置高级选项 XS_​SDNF_​CONVERT_​PL_​PROFILE_​TO_​PLATE

  1. 打开一个 Tekla Structures 模型。
  2. 文件菜单中,单击输出 > CAD

    将会打开 CAD输出 对话框。

  3. 转换选项卡上输入所需转换文件的路径,在参数选项卡上输入参数,根据输出格式,在 SDNFXML 选项卡中定义设置。

    有关输出设置的更多信息,请参见下面的 CAD 输出设置部分。

  4. 在模型中选择要输出的零件。
  5. 单击应用(A)创建(R)

    Tekla Structures 将在当前模型文件夹中创建输出文件。

CAD 模型输出设置

设置

描述

转换选项卡

截面转换文件

材料转换文件

双截面转换文件

定义要使用的转换文件。

转换文件将 Tekla Structures 截面和材料名称映射到在其他软件中使用的名称。

有关转换文件的更多信息,请参见转换文件

参数选项卡

输出文件

输出文件的文件名。您也可以浏览查找该文件。

类型

选择输出格式:HLI、SCIA、SDNF、PDMS、SDNF (PDMS)、XML

X原点 , Y原点 , Z原点

定义原点坐标以将输出的模型置于特定位置。

PML 选项卡:不再支持此格式
SDNF 选项卡

SDNF版本

选择要在输出中使用的 SDNF 版本。

对于 StruCAD,请使用 SDNF 版本 2.0。

应用切割和接合

选择(默认)将在输出中应用切割和接合。

位置编号类型

SDNF 文件中包含标识符,这些标识符可以包含在零件的用户定义的属性中,也可以作为位置编号。可使用以下选项:

  • 零件位置

    标识符成为零件的位置编号。使用该选项时不要使用零件 位置编号字段。

  • 构件位置

    标识符成为构件的位置编号。

  • 通用编号

    标识符成为零件的用户定义的属性。

要使用户定义的属性可见,您需要将它们添加到 objects.inp 文件中。

认为平移

要在输出时忽略偏移记录,请选择;要考虑偏移记录,请选择

此设置不影响实际起点和终点信息,只影响平移。Tekla Structures 根据实际的实体对象而非参考线来写入起点和终点。

PDMS阶段平移

PDMS 阶段偏移定义输出零件的阶段偏移。例如,如果 Tekla Structures 模型的第一个状态为 1,且您输入 10 作为状态偏移,则其它软件中的 Tekla Structures 零件的状态为 11 等依此顺排。

工程公司

输入工程公司的名称。

客户

输入客户的名称。

结构编号

输入输出模型的唯一标识号。

项目编号

输入输出工程的唯一标识号。

修改数目

输入可选的修订编号。Tekla Structures 将会从模型的用户定义的属性 (REVISION_NUMBER) 中获得该修订编号。如果此字段是空白的,Tekla Structures 将使用 CAD输出 对话框中的修订编号(修改数目)。

问题规范

Tekla Structures 将在输出文件的文件头部分写入一个发行编码。对于 PDMS,该值始终为“Tekla Structures”。

设计规范

定义要在结构设计中使用的设计规范。

XML 选项卡

单位

指定转换单位(MM、M、IN、FT)。例如,对于一个以毫米为单位创建的 Tekla Structures 模型,请选择 IN,以便在输出文件中将所有零件尺寸转换为英寸。

XML 结构 ID

输出模型的唯一标识号。您必须始终输入标识号。Tekla Structures 将在重新输出模型时使用此值标识该模型。

XML 结构名

输出模型的唯一名称。

Was this helpful?
Previous
Next