为自定义组件自定义对话框

Tekla Structures
2021
Tekla Structures

为自定义组件自定义对话框

Tekla Structures 会自动为您定义的每个自定义组件创建一个对话框。 每个自定义组件具有一个输入 (.inp) 文件,用于定义自定义组件对话框的内容。 您可以使用自定义组件对话框编辑器工具来自定义该对话框。

此外,如果您是高级用户,则可以在文本编辑器中手动修改对话框输入文件 (.inp)。

修改自定义组件对话框

要打开自定义组件对话框编辑器,请在模型中选择自定义组件,然后右键单击并选择编辑自定义组件对话框

目的

操作步骤

查看和编辑对象属性

  1. 选择对话框元素。 例如文本框。

  2. 单击修改 > 属性

    现在,您可以查看和编辑对话框元素的当前属性。 例如,您可以检查在对话框中的每个标签下是否有正确的文本框。

或者,您可以双击对话框元素。 如果对话框元素未打开,无法用于查看和编辑,请尝试双击复选框正下方的空白处:

添加对话框元素

单击插入,然后从列表中选择合适的元素。 选项包括:

  • 选项卡页: 添加新选项卡

  • 标签: 为文本框或列表添加标签

  • 参数: 添加文本框

  • 属性: 添加列表

  • 零件: 添加一些基本零件属性

  • 截面: 添加一些基本截面属性

  • 图片: 添加自定义组件的说明性图片

添加图片

  1. 单击插入 > 图片以显示在工具 > 选项中设置的图片文件夹的内容。

  2. 选择图片。

    该图片必须为位图 (.bmp) 格式。

  3. 单击打开

  4. 将该图片拖动到所需的位置。

添加选项卡

  1. 单击插入 > 选项卡页

  2. 双击新选项卡。

  3. 输入新名称,然后按 Enter 键。

注:

每个选项卡最多可以包含 25 个字段。 如果您拥有 25 个以上的可见字段,则 Tekla Structures 会自动创建另一个选项卡。

显示或隐藏像素轴线

单击

Tekla Structures 会显示像素轴线,以便于在对话框中更轻松地对齐元素。

移动对话框元素

将对话框元素拖动到新位置。

您还可以使用快捷键 Ctrl+X(剪切)、Ctrl+C(复制)和 Ctrl+V(粘贴)。 例如,要将对话框元素移动到另一个选项卡,请执行以下操作: 选择对话框元素,按 Ctrl+X,转到另一个选项卡,然后再按 Ctrl+V

选择多个对话框元素

按住 Ctrl 键并单击对话框元素,或使用区域选择。

重命名选项卡或文本框标签

  1. 双击选项卡或文本框标签。

  2. 键入新名称。

  3. Enter 键。

删除对话框元素

  1. 选择要删除的对话框元素。

  2. 删除键。

删除选项卡

  1. 选择该选项卡。

  2. 右键单击并选择删除

将图片添加到列表

  1. 选择列表元素。

  2. 单击修改 > 属性

  3. 单击编辑值

  4. 单击浏览添加

  5. 选择要使用的图片,然后单击打开

  6. 对要使用的其它任何图片重复执行步骤 4-5。

  7. 单击确认以保存更改。

保存更改

单击文件 > 保存

自定义组件输入文件

每个自定义组件具有一个输入 (.inp) 文件,用于定义自定义组件对话框的内容。

创建新的自定义组件时,Tekla Structures 会为该组件自动创建一个输入文件。输入文件位于模型文件夹下的 \CustomComponentDialogFiles 文件夹中。输入文件的名称与自定义组件相同,文件扩展名为 .inp

修改自定义组件时,您将丢失对该输入文件所做的任何更改。但是,在修改自定义组件时,Tekla Structures 会自动创建该输入文件的备份副本。备份副本的文件扩展名是 .inp_bak,备份副本位于模型文件夹下的 \CustomComponentDialogFiles 文件夹中。创建备份文件时,Tekla Structures 会显示通知。

锁定或解除锁定自定义组件输入文件

您可以锁定自定义组件的输入 (.inp) 文件,以防止意外修改。 如果该文件未锁定,并且有其他人在自定义组件编辑器中更新自定义组件,则您对该对话框进行的所有修改都会丢失。

  1. 在模型中,选择要为其锁定或解除锁定输入文件的自定义组件。
  2. 右键单击并选择编辑自定义组件对话框
  3. 自定义组件对话编辑器中,单击锁定/解锁按钮

如果某些人在 .inp 文件锁定时,在自定义组件编辑器中修改自定义组件,则 .inp 文件不会更新。 即使 .inp 文件已锁定,您仍可以在自定义组件对话框编辑器中修改该对话框。

自定义组件对话框编辑器设置

自定义组件对话框编辑器中,单击工具 > 选项以便在自定义组件对话框编辑器中查看和修改基本设置。 要更改自定义组件对话框编辑器的语言,请单击工具 > 更改语言

选项

描述

图片文件夹

图片文件夹的位置。要恢复默认文件夹设置,请单击默认值

工程文件夹

工程文件夹的位置。当您单击文件 > 新建创建全新的输入文件并随后保存它时,该文件将保存在工程文件夹中。请注意,现有的输入文件保存在模型文件夹下。

参数宽度

文本框的默认宽度。

属性宽度

列表的默认宽度。

轴线间距 X

轴线间距 Y

X 和 Y 方向的像素轴线的间距。默认值为 5

捕捉到轴线

选择此项可显示或隐藏像素轴线。

选项

描述

语言

从列表中选择语言。关闭并重新打开对话框编辑器以使更改生效。可使用以下选项:

  • 自动:对话框编辑器使用 Tekla Structures 用户界面的语言
  • English
  • Dutch
  • French
  • German
  • Italian
  • Spanish
  • Japanese
  • Chinese Simplified
  • Chinese Traditional
  • Czech
  • Portuguese Brazilian
  • Hungarian
  • Polish
  • Russian
  • Korean
Was this helpful?
上一步
下一步