使用 GUID 选择要在报告中包括的对象

Tekla Structures
2018
Tekla Structures

使用 GUID 选择要在报告中包括的对象

您可以使用对象的 GUID(全局唯一标识符)来选择报告中包括的对象。

  1. 创建用于创建报告的模板。
    1. 文件 菜单上,单击 编辑器 > 模板编辑器
    2. 在模板编辑器中,单击 文件 > 新建
    3. 选择 文本模板 并单击 确认
    4. 添加用于 GUID 的行。
      • 单击 插入 > 组件 >

        选择行的内容类型,然后单击 确认

      • 单击 插入 > 文本 并输入文本 guid:Guid:GUID:.单击 确认

        这使您可以在模型中选择对象。

      • 单击 插入 > 值字段 。单击一个点以定义行内字段的位置。将出现 选择属性 对话框,提示您选择值字段的属性。

        选择属性 GUID 并单击 确认

    5. 在模板中添加所需数量的其它行。
    6. 单击 文件 > 另存为

      输入模板的名称并浏览到 ..\environment\<your_environment>\template 文件夹。使用文件扩展名 .rpt

  2. 根据已保存的报告模板创建报告。
    1. 图纸和报告 选项卡上,单击 报告
    2. 从列表中选择您创建的报告模板。
    3. 单击 从全部的目标中创建

      Tekla Structures 将会显示报告。

  3. 单击报告中包含 GUID 编号的行。

    Tekla Structures 将会在活动的模型视图中选择相应的对象。

这些内容是否有用?
上一步
下一步