Lmgrd is not running Cannot connect to license server system WinSock Connection refused and Windows services Error 5

Tekla Structures
Not version-specific
Tekla Structures
LMTOOLS
Tekla Structures Licensing Service
Environment
Not environment-specific

Issue:

In LMTOOLS, when you click Perform Status Inquiry on the Server Status tab, you will see the following message:

Image
me_lmgrd_error5_notrunning

 Additionally, the following message displays when you tried to start the service through Windows services.

Image
me_lmgrd_error5_notrunning

Causes:

The most common cause, the license service has not been configured to operate on the particular account.

Image
me_lmgrd-windows-service

Solution:

Verify that the hostname and physical address in the license file matches the hostname and physical address of the server

Configure the license service to run on the Local System account:-

  1. Verify that all three paths are entered correctly in the Config Services tab of LMTOOLS. Additionally, the Use Services and Start-Up options are selected. 

  2. Make sure the service configuration is correct and click Save Service.

  3. Open the Services.msc from the Windows start menu and locate the Tekla Licensing Services.

  4. Right-click the license service name and select Properties.

  5. Go to the Log On tab, and ensure that the Local System account is selected.

  6. Restart the license service.

  7. Return to the Server Status tab in LMTOOLS and click Perform Status Enquiry to verify that licenses are now available.

Image
me_lmgrd_localsystem

See Also:

Problems using LMTOOLS in Tekla licensing

Var det här användbart?