Настройки компании для администраторов

Tekla Structures
2024
Tekla Structures

Настройки компании для администраторов

Настройки на уровне компании — это главным образом настройки, которые используются всеми сотрудниками компании на всех проектах. Эти настройки задаются с помощью расширенных параметров XS_SYSTEM и XS_FIRM.

В более крупной компании с дочерними предприятиями эти настройки могут использоваться следующим образом:

  • XS_SYSTEM может содержать несколько путей и указывает на настройки, общие в пределах всей компании. Это может быть логотип компании, отчеты, настройки принтеров, настройки чертежей, шаблоны, например. Эти настройки редко меняются и хранятся на сервере, доступном всем пользователям. Если, например, логотип компании будет обновлен, его понадобится заменить только в одном месте.
  • XS_FIRM указывает на папку компании, созданную компанией или дочерним предприятием. Эта папка содержит все настройки компании, используемые в данном офисе. Это могут быть логотипы, настройки чертежей, шаблоны, отчеты или настройки принтеров, например. В папке компании также могут присутствовать созданные пользователем подпапки для хранения файлов свойств.
  • XS_PROJECT указывает на папку проекта. Эта папка содержит настройки проекта, такие как логотипы для подрядчиков и изготовителей или настройки чертежа, например. В папке проекта также могут присутствовать созданные пользователем подпапки для хранения файлов свойств, связанных с данным проектом.

Дополнительные сведения о порядке поиска в папках см. в разделе Порядок поиска в папках.

Также вы можете использовать коллекции (онлайн или офлайн) своей компании на сервисе Tekla Warehouse в вашей собственной сети. Дополнительные сведения см. в разделе Начало работы с Tekla Warehouse.

Управление доступом к офлайн-коллекциям осуществляется посредством прав доступа к папкам в вашей сети, а на уровне коллекции — в файле collections.json на компьютере каждого пользователя.

 "collections" 
"\\\\server-A\\company\\Tekla Structures collection" 
		

Файл collections.json можно передать пользователям, которым он необходим, путем его копирования в папку C:\Users\Public\Documents\Tekla\Tekla Warehouse\.

Настройка шаблонов моделей

Можно сохранить модель с пользовательскими настройками и использовать ее в качестве шаблона при создании новых моделей. Иногда удобно использовать шаблоны моделей, если ваша компания работает над проектами разного рода (паркинги, офисные здания, мосты, промышленные сооружения и т. д.).

О том, как создать шаблон модели, см. в разделе Создание шаблонов моделей.

По умолчанию папка шаблона модели находится в папке используемой среды (..ProgramData\Trimble\Tekla Structures\<version>\environments\<your environment>\). Точное местоположение папки зависит от используемой среды и роли. Задать другое расположение можно с помощью расширенного параметра XS_​MODEL_​TEMPLATE_​DIRECTORY.

Для загрузки, публикации и хранения шаблонов моделей можно использовать Tekla Warehouse. На этом рисунке показан пример шаблона модели на сервисе Tekla Warehouse.

При нажатии кнопки Вставить в модель на сервисе Tekla Warehouse шаблон модели устанавливается непосредственно в папку, определенную расширенным параметром XS_MODEL_TEMPLATE_DIRECTORY. Можно сразу же использовать шаблон для создания новой модели.

Обновление шаблонов моделей

При обновлении Tekla Structures настоятельно рекомендуем обновлять шаблоны моделей.

  1. Создайте новую модель, используя существующий шаблон модели.
  2. Дайте модели то же имя, что и в предыдущей версии Tekla Structures.
  3. Откройте 3D-вид.
  4. В меню Файл выберите Диагностика и исправление > Диагностика модели.
  5. На вкладке Вид выберите Снимок экрана > Эскиз проекта, чтобы создать эскиз проекта, или добавьте собственное изображение с именем thumbnail.png в папку модели.

    Предпочтительный размер изображения — 120 x 74 пикселя.

  6. В меню Файл выберите Сохранить как > Сохранить.

    Если этого н сделать, может появиться сообщение о том, что модель создана в более ранней версии.

  7. В меню Файл выберите Сохранить как > Сохранить как шаблон модели.
  8. Обновите содержимое шаблона модели.
    1. Выберите, какие каталоги, шаблоны чертежей, шаблоны отчетов и подпапки модели нужно включить в шаблон модели.
    2. Вручную удалите все файлы с расширением *.db (база данных среды, файлы баз данных параметров) из папки модели.

      Не удаляйте файлы db.idrm и xslib.idrm. Они являются частью модели.

    3. Нажмите кнопку ОК.

    Файлы *.bak, *.log и xs_user удаляются из папки модели автоматически.

Шаблон модели сохраняется в местоположении, определенном расширенным параметром XS_MODEL_TEMPLATE_DIRECTORY.

Теперь у вас есть изображение-образец вашего шаблона модели. Пользоваться каталогом Приложения и компоненты теперь должно быть удобнее.

Настройка отчетов и чертежей

Если у вашей компании уже есть графические шаблоны в формате DXF, DWG или DGN, вы можете преобразовать эти шаблоны в шаблоны Tekla Structures.

Подробные инструкции см. в сведениях о файлах AutoCAD и Microstation в Template Editor User's Guide.

Дополнительные сведения о том, как создавать собственные шаблоны и отчеты, см. в разделах Template Editor User's Guide, Отчеты и Шаблоны.

Создание шаблонов клонирования для чертежей

Создание шаблонов клонирования для чертежей позволяет использовать существующие чертежи в качестве основы для создания новых чертежей похожих деталей, сборок или ЖБ элементов. Достаточно изменить только те детали клонированного чертежа, которые отличаются от деталей исходного чертежа.

Клонировать чертежи имеет смысл, когда:

  • в модели имеется несколько сходных деталей, сборок или ЖБ элементов;
  • необходимо создать чертежи отдельной детали, сборки или ЖБ элемента для подобных деталей, сборок или ЖБ элементов;
  • чертежи требуют значительного редактирования вручную.

Например, можно создать чертеж для одной фермы, отредактировать его, а затем клонировать для подобных ферм. Достаточно внести изменения в клонированные чертежи там, где в фермах есть различия.

На клонированном чертеже может содержаться больше деталей, чем на исходном. Свойства деталей, метки, ассоциативные примечания и соответствующие текстовые объекты клонируются из подобной детали исходного чертежа.

Клонировать чертежи можно с помощью шаблонов Каталога чертежей-прототипов. Шаблон клонирования в Каталоге чертежей-прототипов также можно использовать в других моделях. Шаблоны клонирования можно использовать в проектах с чертежами одного типа.

  1. В диалоговом окне Диспетчер документов выберите чертеж.
  2. Щелкните правой кнопкой мыши и выберите Добавить в каталог чертежей-прототипов, а затем введите необходимые свойства.

Шаблон клонирования можно найти в разделе Шаблоны клонирования в Каталоге чертежей-прототипов. Чтобы использовать шаблоны клонирования в других моделях, откройте Каталог чертежей-прототипов в модели, нажмите кнопку на панели инструментов и добавьте модель, где будут сохранены шаблоны.

Дополнительные сведения о каталоге чертежей-прототипов и шаблонах клонирования см. в разделе Создание чертежей в каталоге чертежей-прототипов.

Была ли эта информация полезной?
Назад
Далее