Настройка диалоговых окон пользовательских компонентов

Tekla Structures
2021
Tekla Structures

Настройка диалоговых окон пользовательских компонентов

Для каждого созданного вами пользовательского компонента Tekla Structures автоматически создает диалоговое окно. У каждого пользовательского компонента есть входной файл (.inp), который определяет содержимое диалогового окна этого компонента. Настроить это диалоговое окно можно с помощью Редактора диалоговых окон пользовательских компонентов.

Кроме того, опытные пользователи могут редактировать входные файлы (.inp) диалоговых окон вручную в текстовом редакторе.

Редактирование диалогового окна пользовательского компонента

Чтобы открыть Редактор диалоговых окон пользовательских компонентов, выберите пользовательский компонент в модели, щелкните правой кнопкой мыши и выберите Редактировать диалоговое окно пользовательского компонента.

Задача

Что нужно сделать

Просмотреть и отредактировать свойства объекта

  1. Выберите элемент диалогового окна, например текстовое поле.

  2. Выберите Изменить > Свойства.

    Теперь можно просмотреть и изменить текущие свойства элемента диалогового окна. Например, можно проверить, правильные ли текстовые поля находятся под каждой подписью в диалоговом окне.

Также можно дважды щелкнуть элемент диалогового окна. Если элемент диалогового окна не открывается для просмотра и редактирования, попробуйте дважды щелкнуть в месте прямо под флажком:

Добавить элемент диалогового окна

Выберите Вставка и выберите из списка необходимый элемент. Возможные варианты:

  • Вкладка: добавить новую вкладку

  • Подпись: добавить подпись для текстового поля или списка

  • Параметр: добавить текстовое поле

  • Атрибут: добавить список

  • Деталь: добавить базовые свойства детали

  • Профиль: добавить базовые свойства профиля

  • Рисунок: добавить иллюстрацию пользовательского компонента

Добавить изображение

  1. Выберите Вставка > Рисунок, чтобы отобразить содержимое папки, указанной в поле Папка изображений (Инструменты > Параметры).

  2. Выберите изображение.

    Изображение должно быть в растровом формате (.bmp).

  3. Нажмите Открыть.

  4. Перетащите изображение в нужное место.

Добавить вкладку

  1. Выберите Вставка > Вкладка.

  2. Дважды щелкните новую вкладку.

  3. Введите новое имя и нажмите клавишу ВВОД.

Прим.:

Каждая вкладка может содержать до 25 полей. Если видимых полей больше 25, Tekla Structures автоматически создает еще одну вкладку.

Показать или скрыть пиксельную сетку

Нажмите .

Tekla Structures отображает пиксельную сетку, облегчающую выравнивание элементов в диалоговом окне.

Переместить элемент диалогового окна

Перетащите элемент диалогового окна в новое место.

Также можно использовать сочетания клавиш CTRL+X (вырезать), CTRL+C (копировать) и CTRL+V (вставить). Например, чтобы переместить элемент диалогового окна на другую вкладку, выберите элемент, нажмите CTRL+X, перейдите на нужную вкладку и нажмите CTRL+V.

Выбрать несколько элементов диалогового окна

Щелкайте элементы диалогового окна, удерживая клавишу CTRL, или воспользуйтесь рамкой выбора.

Переименовать вкладку или текстовое поле

  1. Дважды щелкните подпись вкладки или текстового поля.

  2. Введите новое имя.

  3. Нажмите клавишу ВВОД.

Удалить элемент диалогового окна

  1. Выберите элемент диалогового окна, который вы хотите удалить.

  2. Нажмите клавишу DELETE.

Удалить вкладку

  1. Выберите вкладку.

  2. Щелкните правой кнопкой мыши и выберите Удалить.

Добавить изображения в список

  1. Выберите элемент-список.

  2. Выберите Изменить > Свойства.

  3. Нажмите кнопку Изменить значения.

  4. Нажмите кнопку Обзор/добавить.

  5. Выберите нужное изображение и нажмите кнопку Открыть.

  6. Повторите шаги 4–5 для всех остальных изображений, которые вы хотите использовать.

  7. Нажмите ОК, чтобы сохранить изменения.

Сохранение изменений

Выберите Файл > Сохранить.

Входные файлы пользовательских компонентов

У каждого пользовательского компонента есть входной файл (.inp), который определяет содержимое диалогового окна этого компонента.

При создании нового пользовательского компонента Tekla Structures автоматически создает для него входной файл. Этот входной файл находится в папке \CustomComponentDialogFiles внутри папки модели. Входной файл имеет то же имя, что и пользовательский компонент, и расширение .inp.

При изменении пользовательского компонента все внесенные во входной файл изменения будут потеряны. Однако при внесении изменений в пользовательский компонент Tekla Structures автоматически создает резервную копию входного файла. Файл резервной копии имеет расширение .inp_bak и находится в папке \CustomComponentDialogFiles внутри папки модели. При создании резервной копии файла Tekla Structures выводит соответствующее уведомление.

Блокирование или разблокирование входного файла пользовательского компонента

Чтобы защитить входной файл пользовательского компонента (.inp) от случайных изменений, заблокируйте его. Если файл разблокирован, при обновлении пользовательского компонента в редакторе пользовательских компонентов другим пользователем все изменения, внесенные вами в диалоговом окне, будут потеряны.

  1. В модели выберите пользовательский компонент, входной файл которого вы хотите заблокировать или разблокировать.
  2. Щелкните правой кнопкой мыши и выберите Редактировать диалоговое окно пользовательского компонента.
  3. В Редакторе диалоговых окон пользовательских компонентов нажмите кнопку Блокировать/разблокировать .

Когда файл .inp заблокирован, при внесении изменений в пользовательский компонент в редакторе пользовательских компонентов файл .inp обновлен не будет. Вносить изменения в диалоговое окно компонента в Редакторе диалоговых окон пользовательских компонентов можно, даже если файл .inp заблокирован.

Настройки редактора диалоговых окон пользовательских компонентов

Для просмотра и изменения базовых настроек Редактора диалоговых окон пользовательских компонентов выберите в нем Инструменты > Параметры. Чтобы сменить язык интерфейса редактора, выберите Инструменты > Сменить язык.

Формат

Описание

Папка изображений

Местоположение папки с изображениями. Чтобы вернуться к местоположению, используемому по умолчанию, нажмите кнопку По умолчанию.

Папка проекта

Местоположение папки проекта. Когда вы создаете полностью новый входной файл — выбираете Файл > Создать и затем сохраняете его — этот файл сохраняется в папке проекта. Обратите внимание, что существующие входные файлы сохраняются внутри папки модели.

Ширина параметра

Ширина по умолчанию для текстовых полей.

Ширина атрибута

Ширина по умолчанию для списков.

Шаг сетки по Х

Шаг сетки по Y

Шаг пиксельной сетки по осям X и Y. Значение по умолчанию — 5.

Привязка к сетке

Установите флажок, чтобы отобразить пиксельную сетку.

Формат

Описание

Язык

Выберите язык из списка. Закройте и снова откройте редактор диалоговых окон, чтобы изменения вступили в силу. Возможны следующие варианты:

  • Авто: язык интерфейса редактора соответствует языку интерфейса Tekla Structures
  • English
  • Dutch
  • French
  • German
  • Italian
  • Spanish
  • Japanese
  • Chinese Simplified
  • Chinese Traditional
  • Czech
  • Portuguese Brazilian
  • Hungarian
  • Polish
  • Russian
  • Korean
Was this helpful?
Назад
Далее