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            Print to a PDF file, plot file (.plt) or
            printer


        
        You can print drawings and selected
            drawing areas to PDF files or to plot files (.plt) to be sent to a plotter or printer,
            or print drawings on a printer. You can also modify the output line colors and line
            widths (pen numbers). You can print to a single printer or to multiple printers, or
            print one drawing to multiple sheets.

             

        

Print a drawing

        
            	
                    On the File menu, click Printing > Print drawings. 
                    
                        This opens the Print Drawings dialog box and Document manager. 

                        You can also start
                            printing in the following ways:

                        	In Document manager, select the drawings, right-click, and select Print, or click the Print 
                                button.The order
                                of drawings matches the order they appeared in Document manager at the point in time when the Print Drawings dialog box was opened.

	When a drawing is open, select File > Print drawings.
	Press Shift+P on the keyboard.



                
	
                    In the upper-left corner,
                        ensure Use one printer is selected. 
                    This is the default option.

                
	
                    Load the desired printing
                        settings from the settings list.
                    
                        You can also give the
                            settings a new name. In this case, you need to give the new name before
                            you modify any settings, otherwise your changes will be lost. For more
                            information about the printing settings, see Printing settings and search order. 

                    

                
	
                    In Document manager, select the drawings that you want to print. 
                    
                        Any out-of-date drawings
                            are detected and you are asked whether to include them in the output or
                            not. 

                        You can also print locked
                            drawings that are up to date. If a locked drawing is not up to date, you
                            cannot open or print it, and a failed printout will be reported. You can
                            print any unlocked drawings unless the status of the drawing is
                            Original part deleted. 

                    

                
	
                    To show a preview of the
                        drawing, click Click here to load a preview. 
                    
                        The preview shows the drawings always up to date. We recommend that you
                            check the preview while you change the printing settings.

                        If you have selected to
                            print several drawings, the drawings are shown one by one in the
                            preview.  Use Next and Previous to scroll through the set of selected drawings. 

                         

                    

                
	
                    Select how to print: 
                    
                        	PDF file: Converts the selected drawings to PDF format. 
	Printer: Sends the selected drawings to the selected printer. 
	Plot file: Converts the selected drawings to print files in a format
                                suitable for the selected printer and saves them in a specified
                                location. 



                
	
                    Define the printing settings
                        on the Options tab. The available settings depend on the printing option that you have
                        selected: 
                    
                        	Option 	Description 
	
                                            File location 

                                        	
                                            Enter
                                                the location for the PDF file or plot file, or use
                                                Browse... to browse to the folder. 

                                            The
                                                \Plotfiles folder under the
                                                model folder is the default value. 

                                            This option is only available if you have selected
                                                PDF file or Plot file.

                                        
	Printer or plotter	Select the printer or plotter. Click
                                            Properties... to adjust printer properties.
	
                                            Include revision mark to file name

                                        	
                                            Add the mark of the latest revision of the printed
                                                drawing to the print file name.

                                            Revision number is used by default. If you always
                                                want to use the revision mark instead, set the
                                                advanced option XS_SHOW_REVISION_MARK_ON_DRAWING_LIST
                                                to TRUE. If the revision mark is still
                                                not displayed, check the following advanced options
                                                and include REVISION_MARK in the value:

                                            XS_DRAWING_PLOT_FILE_NAME_A,
                                                XS_DRAWING_PLOT_FILE_NAME_W,
                                                XS_DRAWING_PLOT_FILE_NAME_G,
                                                XS_DRAWING_PLOT_FILE_NAME_M,
                                                or XS_DRAWING_PLOT_FILE_NAME_C,
                                                depending on the drawing type. 

                                            This option is only available if you have selected
                                                PDF file or Plot file.

                                        
	
                                            Open folder when finished 

                                        	Open the PDF file or plot file folder
                                            in Windows Explorer after the printout has been created.
                                            This option is only available if you have selected
                                            PDF file or Plot file.

	
                                            Open file when finished 

                                        	Open the PDF file after it has been
                                            created. This
                                            option is only available if you have selected PDF file.

	
                                            Output to single file 

                                        	Print the selected drawings to a
                                            single PDF file. If you do
                                            not select this option, each of the selected drawings
                                            will be printed in a PDF file of its own. 
This
                                            option is only available if you have selected PDF file.
 
	
                                            File
                                                name

                                        	
                                            Give a
                                                file name to a PDF file. The file name is needed if
                                                you are printing to a single file. 

                                            The PDF file name can also be controlled by a couple
                                                of advanced option switches for 
                                                customizing print file names. These switches
                                                do not work for single combined multiple drawings
                                                PDF file. 

                                            This
                                                option is only available if you have selected
                                                PDF file and Output to single file. 

                                        
	
                                            File extension 

                                        	Specify a file name extension for the
                                            plot file. The default is
                                            plt.This option is only
                                            available if you have selected  Plot file.

	
                                            File prefix 

                                            File suffix 

                                        	
                                            Enter
                                                a specific prefix and/or suffix in the PDF or plot
                                                file name. 

                                            When
                                                you enter a prefix or suffix, the file name preview
                                                under the File prefix and File suffix boxes will reflect the change immediately. 

                                            

                                            The
                                                file name can also be controlled by advanced option
                                                switches for 
                                                customizing print file names. 

                                            This
                                                option is only available if you have selected
                                                PDF file or Plot file.

                                        
	
                                            Fit to paper 

                                        	
                                            Fit
                                                the drawing to a specific paper size. 

                                            This setting does not work if you have selected
                                                Scale. 

                                        
	
                                            Scale 

                                        	
                                            Force
                                                the printout to a specific scale. 

                                            The
                                                Scale value will turn red if the drawing cannot fit on
                                                the specified sheet. 

                                            This setting does not work if you have selected
                                                Fit to paper. 

                                        
	Center drawing on paper 	Center the drawing on the sheet (or
                                            sheets). 
	
                                            Print on multiple sheets 

                                        	Print on multiple sheets and specify
                                            the direction of printing the sheets. This is
                                            particularly useful if your drawing contains several
                                            drawings. Select to print from Left to right, top to bottom or from Bottom to top, right to left. When you use Print on multiple sheets, always set a particular Scale.
The preview shows how the drawing is divided into
                                            sheets. 
 
	
                                            Paper size 

                                        	Define the paper size or use automatic
                                            size. 
                                            With the Auto setting Tekla Structures selects the paper size that has the least wasted area
                                            when the scaled print is fitted to the printable area on
                                            the sheet. 
 Printers
                                            are often unable to print on the full area of a sheet,
                                            and leave borders. The printable area is
                                            determined for the selected printer when the option
                                            Printer or Plot file is selected. For PDF files, the printer is not known,
                                            so the output is sized to the full sheet. However, when
                                            printing a PDF, the same problem exists and the drawing
                                            content is fitted to the printable area of whatever
                                            printer is being used. The printable area is shown with
                                            white background and the non-printable border is shaded
                                            gray in the image below. 
  
Two
                                            configuration files affect paper sizes and drawing
                                            sizes:  PaperSizesForDrawings.dat and DrawingSizes.dat . For more
                                            information, see Configuration files used in printing
 
	
                                            Orientation 

                                        	
                                            Define
                                                the orientation or use automatic orientation. 

                                            The
                                                Auto setting means that the orientation that wastes
                                                least space is selected automatically. 

                                        
	
                                            Color 

                                        	
                                            Select
                                                if the output is to be Color, Black and white or Grayscale. 

                                        
	
                                            Number of copies 

                                        	
                                            Define
                                                the number of paper copies to be printed. 

                                            This option is only available if you have selected
                                                Printer.

                                        
	
                                            Collate 

                                        	
                                            Collate the printout when you are printing multiple
                                                copies. 

                                            This option is only available if you have selected
                                                Printer.

                                        
	
                                            Embed fonts 

                                        	
                                            Embed
                                                the fonts in a PDF file. 

                                            This
                                                ensures that fonts may be reproduced in a system
                                                that does not have the same fonts installed, but
                                                this also increases the file size. In certain cases,
                                                fonts may be embedded automatically. When using
                                                non-Latin fonts, we recommended that you use
                                                embedding, otherwise the PDF  may not be displayed
                                                correctly. 

                                            This option is only available if you have selected
                                                PDF file.

                                        
	
                                            Select area 

                                        	
                                            Select
                                                a rectangular area from an open drawing to only show
                                                and print that area. This option only works when you
                                                have a drawing open. 

                                            All
                                                settings in the Print Drawings dialog box also work when Select area is selected, and you can change the orientation,
                                                line width, and paper size, for example. 

                                        
	
                                            Show entire drawing 

                                        	
                                            When
                                                you have selected an area with Select area, the Show entire drawing button appears, and you can use it to show the
                                                entire drawing in the preview again. 

                                        



                
	
                    Go to the Line properties tab to map colors to line widths (pen numbers) and set the printout
                        colors: 
                    
                        	Option 	Description 
	
                                            Object color 

                                        	
                                            Shows
                                                the basic set of object colors. 

                                        
	
                                            Color on output 

                                        	
                                            	Set the
                                                  printout color by clicking a color box under
                                                  Color on output and selecting a new color from the displayed
                                                  colors. You can also define custom colors. 




                                            Different output color is often used when you just
                                                need one or two lines in color and the rest in
                                                black. Output colors are used in all printing
                                                options (printer, plot file and PDF file). The
                                                output colors are saved to and loaded from the
                                                printing settings files. 

                                            If you
                                                have selected  Printer line colors through File > Settings, and change a line color, the
                                                change is immediately shown in the drawing.

                                            The
                                                Color on output only applies when the Color option is set to Color on the Options tab in the Print Drawings dialog box. 

                                            For
                                                instructions on how to show correct line widht on
                                                the screen, see Line thickness in drawings.
                                            

                                        
	
                                            Line thickness 

                                        	
                                            	Enter
                                                  the line width (pen number) for each color in the
                                                  boxes. 

Line
                                                width is expressed as a multiple of the advanced
                                                option XS_BASE_LINE_WIDTH value. The
                                                default value for this advanced option is 0.01 mm.
                                                For example, line width 25 will give a line weight
                                                of 0.25 mm. 

                                            Note
                                                that the black and white color mode always shows the
                                                printer line width on the screen, whereas the color
                                                and grayscale color modes only show the printer line
                                                width on the screen if the Printer line widths switch is active in File > Settings. Also note that the screen is
                                                refreshed when printer settings, such as line width
                                                values, are modified.

                                            You
                                                can define Invisible color for parts and shapes in drawings in the
                                                part or shape properties. The Invisible color is not shown in printouts, neither on paper
                                                nor on PDF. 

                                            If you
                                                are having problems with showing correct line width,
                                                see Line thickness in drawings.
                                            

                                        
	
                                            Reset colors 

                                        	
                                            You
                                                can reset the printout colors: 

                                            	To
                                                  reset an individual output color, click the
                                                  corresponding Object color color box. The Color on output color box will change to have the same color.
                                                  

	To
                                                  reset all output colors to be the same as the
                                                  object colors, click the Reset colors button. 





                
	
                    Save your printing settings
                        by using the Save button in the upper-left corner. 
                    For more information about
                        the printing settings and the search order, see Printing settings and search order. You can also add frames and
                        foldmarks to you printouts.


                
	
                    Click Print to print the drawings in the PDF format or as plot files, or to send them
                        to a printer according to the settings you defined in the dialog box. 
                    Each drawing is sent to the
                        printer as a separate print job. All printing errors are
                        written to a log file in the model folder: logs\DPMPrinter_<username>.log .
                        


                



    Example: Print
            to multiple sheets

        
            
                The Print on multiple sheets setting on the Options tab prints the drawing on multiple sheets. You need to specify the direction
                    of printing the sheets. This is particularly useful if your drawing contains
                    several drawings. 

                In the example below, the option
                    Bottom to top, right to left has been selected. The numbers indicate the printing order of the sheets. 

                 

                In the next example, the option
                    Left to right, top to bottom has been selected. 

                 

            

        

    Print to multiple printers

        
            You can print to more than one printer in one go based on the paper size of each
                    selected drawing. When printing to multiple printers you typically have
                    different printers for handling different paper sizes. Tekla Structures automatically selects the appropriate printer for each drawing.

                To print to multiple sheets, you need to:

                	Create and save the printing settings for the necessary printers
	Print by using Use multiple printers mode.

Create single printing settings

                To be able to print to multiple
                    printers, you first need to create single printing settings for each of the
                    printers you want to print to: 

                	
                        On the File menu, click Printing > Print drawings.

                    
	
                        Select Use one printer.

                    
	
                        Define the printing
                            settings as desired on the Options tab and on the Line properties tab. Select the output type and printer, and define the paper size
                            that this particular printer will handle in Use multiple printers mode.

                    
	
                        Save the settings with a desired name by clicking Save.

                    
	
                        Repeat this for each of the desired paper sizes. Do not use the size
                            option Auto.

                         For example, you could
                            create the following single printer settings files with the output type
                            set to PDF file: 

                        	PDF A4: Paper size set to A4,
                                file prefix set to A4_
	PDF A3: Paper size set to A3,
                                file prefix set to A3_
	PDF A2: Paper size set to A2,
                                file prefix set to A2_

When printing a set of drawings in the multiple printers mode using the
                            above single printer settings files, all A4 drawings will generate
                                .pdf files with prefix A4_, all A3 drawings will have prefix
                                A3_, and all A2 drawing will
                            generate .pdf files with prefix
                                A2_.

                        If you want to print more
                            than one sheet size to the same printer in Use multiple printers mode, create a single printer settings file for each paper size, and
                            specify the same printer in all of these files. 

                        

                    

Print to multiple printers

            	
                    On the File menu, click Printing > Print drawings. 
                
	
                    In the upper-left corner,
                        select Use multiple printers mode. 
                
	
                    In the Selected single printer settings files list, select the settings files to use in printing. You can select all or
                        just some of the single printer settings files.
                    
                        
                            

                        The output type (printer,
                            plot file, PDF file) is defined by each selected single printer settings
                            file. Typically you would select settings files with the same output
                            type. Output types lists the output types that are specified in the selected single
                            printer settings files.

                        

                    

                
	
                    Change other necessary settings on the Options tab. 
                    The available settings depend on the output type you have selected. The
                        settings are described in the "Print to a single printer" section
                        above.

                
	
                    Change necessary line width and color settings on the Line properties tab.
                
	
                    In the displayed Document manager, select the drawings that you want to print. 
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