Create system libraries

Tekla Tedds
2020
Tekla Tedds Tekla Tedds for Word

Create system libraries

Creating system libraries is a multi-step process, and therefore, it is divided into several sub-tasks. To create system libraries, see the following instructions.

Note:

The following only applies to Tedds for Word.

Before creating system libraries

  1. Write the calculations which you want to include in your Tedds for Word documents in a normal manner.
  2. Change the user libraries directory and system libraries directory so that they point to the same location, or your development location.

Create system libraries

  1. To create a new set where the new items will be located, click File > New.
  2. If you have already an idea of the structure that you want the set to have, you can create new groups within the set.
  3. Select the calculations which you want to add in the set.
  4. Click Edit > New Item to create new items in the set.
    1. If you have selected the Select format and category of item contents setting, select the format in which the item is saved.

    The New item properties dialog box appears.



  5. Name the item and select the library to which you want to add entries.

    At this point, the new library is a user library, and the items in the set point to it as a user library.

  6. According to your needs, determine other details for the new item.
  7. Click OK.
  8. Click File > Save as and save the set to your development location.
  9. Repeat steps 3 to 6 for each item and entry that you want to add to the set and library.
    Note:

    Remember to save the set regularly.

Save system libraries

  1. Change the set so that it points to the library as a system library.

    For more information, see Frequently used procedures in creating system libraries.

  2. To ensure that all items are correctly displayed, do the following:
    1. To expand a group, select the group and press the * key on the numeric keypad.
    2. To collapse a group, select the group and press the - key on the numeric keypad.
  3. Save the set into your sets directory.
  4. Copy the set and the library to a disk or to a central area on your network.
    Note:

    Keep the original copies of the set and library in the original location, and remember to back them up.

After creating system libraries

  1. To protect the files from any accidental damage, set the read-only attribute on the copied set and library file using File Explorer.
  2. Inform other users about location of the set. Tell them to place the sets in their own sets directory. If necessary, ask them to copy the system library to their own system libraries directory.
    Note: If your organization uses a central system libraries area, copy the system library to the central system libraries area, and only distribute the set.
    Other users are now able to access your calculations.
  3. Change your user libraries directory and system libraries directory, so that they point back to their previous locations.
Was this helpful?
Wstecz
Dalej