Ustawienia firmy dla administratorów

Tekla Structures
2024
Tekla Structures

Ustawienia firmy dla administratorów

Ustawienia na poziomie firmy są to głównie ustawienia, które są używane w całej firmie do wszystkich projektów. Te ustawienia są określane za pomocą XS_SYSTEM i XS_FIRM.

W większych firmach mających oddziały, ustawienia mogą być używane w następujący sposób:

  • XS_SYSTEM może zawierać wiele ścieżek i wskazuje na ogólne ustawienia w firmie. Mogą to być na przykład: logo firmy, raporty, ustawienia drukarki, ustawienia rysunków, szablony. Są to ustawienia, które zmieniają się rzadko i są przechowywane na serwerze jako dostępne dla wszystkich. Na przykład, jeśli zostanie zaktualizowane logo firmy, wystarczy je wymienić w jednym miejscu.
  • XS_FIRM wskazuje folder firmowy skonfigurowany przez firmę lub jej oddział. Folder zawiera wszystkie ustawienia firmowe używane w konkretnym biurze. Mogą to być na przykład: logotypy, ustawienia rysunków, szablony, raporty lub ustawienia drukarki. W folderze firmowym można również mieć zdefiniowane przez użytkownika podfoldery do przechowywania plików właściwości.
  • XS_PROJECT wskazuje folder projektu. Folder zawiera ustawienia projektu, takie jak na przykład logo dla wykonawców i producentów lub ustawienia rysunków. Folder projektu może również zawierać podfoldery zdefiniowane przez użytkownika do przechowywania plików właściwości specyficznych dla projektu.

Aby uzyskać więcej informacji na temat kolejności przeszukiwania folderów, zobacz Kolejność przeszukiwania folderów.

Można również użyć specyficznych dla firmy kolekcji w Tekla Warehouse online lub offline z własnej sieci. Aby uzyskać więcej informacji, zobacz Pierwsze kroki w Tekla Warehouse.

Dostęp do kolekcji offline jest zarządzany na podstawie uprawnień do folderu w sieci oraz na poziomie kolekcji w pliku collections.json na komputerach poszczególnych użytkowników.

 "collections" 
"\\\\server-A\\company\\Tekla Structures collection" 
		

Plik collections.json może też być udostępniony wybranym użytkownikom przez skopiowanie go do folderu C:\Users\Public\Documents\Tekla\Tekla Warehouse\.

Dostosowywanie szablonów modelu

Można zapisać dostosowane ustawienia w modelu i używać modelu jako szablonu podczas tworzenia nowych modeli. Korzystanie z szablonów modelu może być przydatne, jeśli firma wykonuje różne rodzaje projektów, np. parkingi, budynki biurowe, mosty czy obiekty przemysłowe.

Aby utworzyć szablon modelu, zobacz Tworzenie szablonów modelu.

Domyślnie folder szablonu modelu znajduje się w folderze środowiska w ..ProgramData\Trimble\Tekla Structures\<version>\environments\<your environment>\. Dokładne położenie folderu może się różnić w zależności od środowiska i roli. Opcja zaawansowana XS_​MODEL_​TEMPLATE_​DIRECTORY umożliwia określenie innego położenia.

Szablony modelu można pobierać, udostępniać i przechowywać przy użyciu Tekla Warehouse. Ta ilustracja przedstawia przykładowy szablon modelu w Tekla Warehouse.

Przycisk Wstaw do modelu w Tekla Warehouse instaluje szablon modelu bezpośrednio w folderze określonym przez XS_MODEL_TEMPLATE_DIRECTORY. Możesz natychmiast użyć szablonu podczas tworzenia nowego modelu.

Aktualizowanie szablonów modelu

Podczas aktualizacji wersji Tekla Structures, zdecydowanie zaleca się aktualizowanie szablonów modelu.

  1. Utwórz nowy model za pomocą istniejącego szablonu modelu.
  2. Nadaj modelowi taką samą nazwę, jak w poprzedniej wersji Tekla Structures.
  3. Otwórz widok 3D.
  4. W menu Plik kliknij Diagnozuj i napraw > Diagnozuj model.
  5. Na karcie Widok kliknij kolejno Zrzut ekranu > Miniatura projektu, aby utworzyć miniaturę projektu lub dodaj niestandardowy obraz o nazwie thumbnail.png w folderze modelu.

    Preferowany rozmiar obrazu to 120 x 74 pikseli.

  6. W menu Plik kliknij Zapisz jako > Zapisz.

    Jeśli tego nie zrobisz, może pojawić się komunikat z ostrzeżeniem, że model został utworzony w poprzedniej wersji.

  7. W menu Plik kliknij Zapisz jako > Zapisz jako szablon modelu.
  8. Zaktualizuj zawartość szablonu modelu.
    1. Wybierz katalogi, szablony rysunków, szablony raportów i podfoldery modelu, które chcesz uwzględnić w szablonie modelu.
    2. Usuń ręcznie wszystkie pliki *.db (baza danych środowiska, pliki bazy danych opcji) z folderu modelu.

      Nie usuwaj plików db.idrm i xslib.idrm. Są one częścią modelu.

    3. Kliknij OK.

    Pliki *.bak, *.log i xs_user zostaną automatycznie usunięte z folderu modelu.

Szablon modelu jest zapisywany w lokalizacji określonej przez XS_MODEL_TEMPLATE_DIRECTORY.

Teraz dysponujesz przykładowym obrazem szablonu modelu. Katalog Aplikacje i komponenty jest teraz także uporządkowany i łatwy w użyciu.

Dostosowywanie raportów i rysunków

Jeśli firma posiada już szablony graficzne w formacie DXF, DWG lub DGN, możesz je konwertować do szablonów Tekla Structures.

Aby uzyskać szczegółowe instrukcje, zobacz informacje na temat plików AutoCAD i MicroStation w oknie Template Editor User's Guide.

Aby uzyskać informacje na temat sposobu tworzenia własnych szablonów i raportów, zobacz Template Editor User's Guide, Raporty i Szablony.

Tworzenie szablonów klonowania dla rysunków

Tworzenie szablonów klonowania rysunków umożliwia używanie istniejących rysunków jako bazy do tworzenia nowych rysunków podobnych elementów, zespołów lub zespołów betonowych. Wystarczy zmienić elementy sklonowanego rysunku różniące się od oryginalnego rysunku.

Należy pamiętać o klonowaniu rysunków, gdy:

  • W modelu istnieje kilka podobnych elementów, zespołów lub zespołów betonowych.
  • Musisz utworzyć rysunki pojedynczego elementu, zespołu lub zespołu betonowego podobnych elementów, zespołów lub zespołów betonowych.
  • Rysunki wymagają czasochłonnej ręcznej edycji.

Możesz na przykład utworzyć rysunek jednej kratownicy, zmodyfikować go, a następnie sklonować dla podobnych kratownic. Wystarczy zmodyfikować sklonowane rysunki w miejscach, w których kratownice różnią się między sobą.

Sklonowany rysunek może zawierać więcej elementów niż początkowy. Właściwości elementu, znaki, uwagi powiązane i powiązane obiekty tekstowe są klonowane z podobnego elementu na rysunku wyjściowym.

Rysunki można klonować przy użyciu szablonów z Katalogu rysunków głównych. Szablonów klonowania, które zawiera Katalog rysunków głównych, można również używać w innych modelach. Szablony klonowania można stosować w projektach, które mają taki sam rodzaj rysunków.

  1. W oknie Menedżer dokumentów wybierz rysunek.
  2. Kliknij prawym przyciskiem myszy, wybierz Dodaj do Katalogu rysunków głównych i wprowadź wymagane właściwości.

Szablon klonowania można znaleźć w oknie Szablony klonowania w Katalogu rysunków głównych. Aby użyć szablonów klonowania w innych modelach, otwórz Katalog rysunków głównych w modelu, kliknij przycisk na pasku narzędzi i dodaj model, w którym zapisane są szablony.

Więcej informacji o Katalogu rysunków głównych i szablonach klonowania można znaleźć w podrozdziale Tworzenie rysunków w Katalogu głównych rysunków.

Czy to było pomocne?
Wstecz
Dalej