Porady dotyczące raportów i szablonów raportów

Tekla Structures
2023
Tekla Structures

Porady dotyczące raportów i szablonów raportów

Aby efektywniej tworzyć raporty, warto rozważyć pewne kwestie.

Wybierz obiekty, które mają się znaleźć w raporcie, za pomocą identyfikatorów GUID.

Możesz wybrać obiekty, które znajdą się w raportach, za pomocą ich GUID (globally unique identifier – globalny jednoznaczny identyfikator).

  1. W Edytorze szablonów utwórz szablon używany do tworzenia raportu:
    1. W Tekla Structures, w menu Plik kliknij Edytory > Edytor szablonów.
    2. W edytorze szablonów kliknij Plik > Nowy.
    3. Wybierz Szablon tekstowy i kliknij OK.
    4. Dodaj wiersz dla GUID.
      • Kliknij kolejno opcje Wstaw > Komponent > Wiersz.

        Wybierz typ zawartości w wierszu i kliknij OK.

      • Kliknij Wstaw > Tekst i wpisz tekst guid:, Guid: lub GUID:. Kliknij OK.

        To umożliwia wybieranie obiektów w modelu.

      • Kliknij Wstaw > pole Wartość. Kliknij punkt, aby zdefiniować położenie pola w wierszu. Zostanie wyświetlone okno dialogowe Wybierz atrybut z monitem o wybranie atrybutu dla pola wartości.

        Wybierz atrybut GUID i kliknij OK.

    5. Dodaj wymaganą liczbę innych wierszy w szablonie.
    6. Kliknij Plik > Zapisz jako .

      Wprowadź nazwę szablonu i przejdź do folderu zdefiniowanego dla opcji zaawansowanej XS_TEMPLATE_DIRECTORY. Użyj rozszerzenia nazwy pliku .rpt.

  2. Utwórz raport na podstawie zapisanego szablonu raportu.
    1. Na karcie Rysunki i raporty kliknij Raporty.
    2. Wybierz utworzony szablon raportu z listy.
    3. Kliknij Utwórz ze wszystkich.

      Tekla Structures wyświetla raport.

  3. Kliknij wiersz zawierający numer GUID w raporcie.

    Tekla Structures wybiera odpowiedni obiekt w widoku aktywnego modelu.

Wyświetlanie zawartości raportu w prawidłowych komórkach

Możesz powiązać Tekla Structures tak, aby określone typy raportów otwierał w Microsoft Excel. Gdy otwierasz takie raporty w Microsoft Excel, wiersze szablonu raportu mogą nie być prawidłowo podzielone na komórki. Aby to naprawić, możesz dodawać tabulatory między komórkami.

  1. Otwórz istniejący szablon raportu w Edytorze szablonów.
  2. Dodaj \t między polami tekstowymi i polami wartości. Przykład:

  3. Zapisz raport.

    Wynik w Microsoft Excel:

    Wynik w edytorze tekstu:

Tip:

Możesz zamiast tego użyć przecinka lub średnika jako separatora pól tekstowych. Jednak różni użytkownicy stosują różne separatory, dlatego wynik może nie być czytelny w każdym edytorze tekstu.

Czy to było pomocne?
Wstecz
Dalej