Hierarchia budynku

Tekla Structures
2023
Tekla Structures

Hierarchia budynku

Można wykorzystać hierarchię budynku do zdefiniowania struktury podziału położenia w modelu. Hierarchia budynku ma domyślną strukturę: projekt > budowa > budynek > poziom > przestrzeń. Możesz dodawać poziomy i przestrzenie do modelu, importując je z modelu referencyjnego lub tworząc je bezpośrednio w swoim modelu. Poziom to pozioma płaszczyzna na określonej wysokości w budynku. Przestrzenie to objętości, które zapewniają pewne funkcje w obrębie budynku.

Aby utworzyć hierarchię budynku, nadaj opcji zaawansowanej XS_USE_INTEGRATED_BUILDING_HIERARCHIES wartość TRUE. Opcja zaawansowana jest domyślnie ustawiona na wartość FALSE.

Po ustawieniu opcji zaawansowanej jako TRUE zapisz model, a następnie otwórz go ponownie w celu zastosowania zmian. Aby otworzyć okno dialogowe Hierarchia budynku, przejdź na kartę Zarządzaj wstążki i kliknij Hierarchia budynku.

Zdefiniowana hierarchia budynku i położenie obiektów w hierarchii są wspólne dla wszystkich użytkowników modelu. Hierarchia budynku jest udostępniana podczas używania Tekla Model Sharing.

Korzystanie z okna dialogowego Hierarchia budynku

Opis

1

Domyślna struktura hierarchii to: projekt > miejsce > budynek > poziom > przestrzeń.

Możesz określić nazwę projektu w Plik > Właściwości projektu. Można zmieniać nazwy i właściwości budowy, budynków, poziomów i przestrzeni w tabeli w oknie dialogowym Hierarchia budynku. Po wybraniu projektu w strukturze drzewa hierarchii budowa jest wyświetlana w tabeli. Po wybraniu budowy w strukturze drzewa hierarchii budynek jest wyświetlany w tabeli. Można utworzyć jeden budynek w hierarchii.

Budynek ma jeden lub wiele poziomów. Po wybraniu budynku w strukturze hierarchii poziomy znajdujące się w wybranym budynku zostaną wyświetlone w tabeli.

Poziom to pozioma płaszczyzna na określonej wysokości. Wysokość poziomu jest w wielu przypadkach określana przez architekta i często definiuje ona końcowy poziom kondygnacji. Poziom jest reprezentowany w IFC jako kondygnacja budynku. Po wybraniu poziomu w strukturze drzewa hierarchii wyświetlane są przestrzenie na wybranym poziomie.

Przestrzenie to objętości, które pełnią określone funkcje, takie jak pomieszczenia w obrębie budynku. Przestrzeń jest automatycznie przypisywana do najbliższego poziomu poniżej. Jeśli w modelu istnieją nieprzypisane przestrzenie, są one wyświetlane w osobnym folderze w strukturze hierarchii.

2

Określ wysokość poziomu.

3

Obiekty modelu są przypisywane do poziomów na podstawie wysokości w modelu.

Użyj wartości offsetu dolnego do zdefiniowania określonej odległości poniżej poziomu. Obiekty znajdujące się w określonej odległości zostaną przypisane do poziomu, z którego zdefiniowana jest odległość.

Domyślnie obiekty są automatycznie przypisywane do najbliższego poziomu poniżej nich.

4

Offset poziomu umożliwia zdefiniowanie poziomu konstrukcyjnego. W przypadku konstrukcji stalowych jest to zwykle górny poziom stali (TOS - top of steel).

5

Otwórz okno dialogowe Importuj hierarchię budynku, aby zaimportować hierarchię budynku z modelu referencyjnego.

6

Kliknij Zmień, aby zmienić obiekty, których właściwości zostały edytowane w tabeli.

7

Usuń wybrane poziomy i przestrzenie z tabeli.

8

Określanie kolumn, które mają być wyświetlane w tabeli.

Wybór kolumn zostanie użyty po następnym otwarciu okna dialogowego Hierarchia budynku.

9

W razie potrzeby wprowadź dodatkowe informacje o poziomie.

Importowanie poziomów i przestrzeni z modelu referencyjnego

Istnieje możliwość importowania poziomów i przestrzeni z modelu referencyjnego. Jeśli w oknie dialogowym Hierarchia budynku są już wyświetlane poziomy i przestrzenie, zostaną one zastąpione przez zaimportowane poziomy i przestrzenie.

  1. Jeśli model referencyjny, z którego chcesz zaimportować poziomy i przestrzenie, znajduje się już w Twoim modelu, przejdź do kroku 4.

    Aby wstawić model referencyjny do swojego modelu, kliknij Plik > Importuj > Wstaw model referencyjny.

  2. W oknie dialogowym Dodaj model kliknij Przeglądaj, aby wybrać model referencyjny z listy.

  3. Kliknij Dodaj model.

  4. Na wstążce kliknij polecenie Zarządzaj > Hierarchia budynku, aby otworzyć okno dialogowe Hierarchia budynku.

  5. Kliknij przycisk Import w oknie dialogowym Hierarchia budynku.

  6. Wybierz model referencyjny, z którego chcesz zaimportować poziomy i przestrzenie.

    W polu Nazwa modelu referencyjnego można wprowadzić znaki, aby uzyskać listę dostępnych modeli referencyjnych, które zawierają wprowadzony znak. Można też wybrać model z panelu bocznego Modele referencyjne lub z modelu. W przypadku wybrania z modelu upewnij się, że aktywny jest przełącznik wyboru Wybierz modele referencyjne.

    Nazwa wybranego modelu referencyjnego zostanie wyświetlona w polu Nazwa modelu referencyjnego.

  7. Wybierz najniższy poziom importowany z hierarchii budynku, tzn. poziom lub przestrzeń.

  8. Kliknij Import.

    Jeśli model ma już hierarchię budynku, Tekla Structures wyświetli okno dialogowe z informacją o zamianie istniejącej hierarchii.

    Jeśli klikniesz Zastąp, poziomy i przestrzenie zostaną zastąpione w następujący sposób:

    • W przypadku wybrania opcji Poziom w Najniższy poziom do importu z hierarchii budynku poziomy zostaną zastąpione zaimportowanymi poziomami.

    • W przypadku wybrania opcji Przestrzeń w Najniższy poziom do importu z hierarchii budynku zarówno poziomy jak i przestrzenie zostaną zastąpione zaimportowanymi poziomami i przestrzeniami.

    Zaimportowane poziomy i przestrzenie będą widoczne w oknie dialogowym Hierarchia budynku. Aby były widoczne w modelu, należy wybrać opcje Hierarchia budynku oraz Przestrzeń w ustawieniach wyświetlania, a następnie kliknąć Właściwości widoku > Wyświetl.

    W przypadku odznaczenia opcji Hierarchia budynku oraz Przestrzeń w ustawieniach wyświetlania i kliknięcia Zmień zaimportowane poziomy i przestrzenie nadal będą wyświetlane w modelu. Aby zaktualizować widok, należy skorzystać z polecenia Przerysuj widok.

Tworzenie poziomów

Poziomy to poziome płaszczyzny na określonej wysokości w budynku.

  1. Na wstążce kliknij Zarządzaj > Poziom.

    Tekla Structures pokazuje właściwości poziomu w oknie właściwości.

  2. Wskaż punkt na wysokości poziomu w modelu lub wprowadź poziom w panelu właściwości, a następnie kliknij przycisk Wstaw poziom w panelu Właściwości.

  3. Aby utworzyć kolejny poziom, wybierz inny punkt. Aby zakończyć tworzenie poziomów, naciśnij klawisz Esc.

Tworzenie przestrzeni

Przestrzenie to objętości, które pełnią określone funkcje, takie jak pomieszczenia w obrębie budynku. Przestrzeń jest automatycznie przypisywana do najbliższego poziomu poniżej. Nieprzypisane przestrzenie to przestrzenie, które nie są przypisane do żadnego poziomu.

  1. Na wstążce kliknij Zarządzaj > Przestrzeń.

    Element Tekla Structures pokazuje właściwości przestrzeni w oknie właściwości.

  2. Wskaż pierwszy punkt graniczny dla przestrzeni w modelu.

  3. Wskaż drugi punkt graniczny dla przestrzeni.

  4. Wskaż kolejny punkt graniczny dla przestrzeni.

  5. Kliknij środkowy przycisk myszy, aby utworzyć przestrzeń.

Utworzone przestrzenie są listowane w oknie dialogowym Hierarchia budynku pod poziomami, do których są przypisane.

Zarządzanie poziomami i przestrzeniami

Do zarządzania poziomami i przestrzeniami służą okno dialogowe Hierarchia budynku i panel właściwości.

Aby wykonać procedurę

Zmiana właściwości poziomu i przestrzeni

Właściwości poziomu i przestrzeni można zmieniać w tabeli w oknie dialogowym Hierarchia budynku lub w panelu właściwości. Zmienione właściwości są wyróżnione kolorem żółtym.

Kliknij Zmień, aby zastosować zmiany w modelu.

Jeśli zmienisz wysokość poziomu, a na poziomie zostaną przypisane obiekty, Tekla Structures wyświetla okno dialogowe, w którym trzeba określić, czy ma zostać przesunięty tylko poziom, czy poziom i obiekty przypisane do niego.

Usuwanie poziomu lub przestrzeni

Wybierz poziom lub przestrzeń w tabeli w oknie dialogowym Hierarchia budynku, a następnie kliknij przycisk Usuń . Poziom lub przestrzeń zostanie również usunięty/a z modelu.

W tabeli można jednocześnie wybrać więcej niż jeden poziom lub przestrzeń do usunięcia.

Wyświetlanie informacji o poziomie, do którego jest przypisany zespół

Zbadaj zespół w modelu.

Pokaż oraz ukryj poziomy i przestrzenie w modelu

W oknie Właściwości widoku > Wyświetl zaznacz lub odznacz Hierarchia budynku oraz Przestrzeń.

Filtrowanie obiektów hierarchii budynku

Za pomocą kategorii Struktura podziału położenia można filtrować obiekty hierarchii budynku według ich lokalizacji.

Utwórz widoki na wybranych poziomach

Można tworzyć widoki modelu z poziomami wybranymi w oknie dialogowym Hierarchia budynku lub w modelu.

  1. Na karcie Widok kliknij Nowy widok > Na wybranych poziomach.
  2. Wybierz poziomy w oknie dialogowym Hierarchia budynku lub w modelu.
  3. W oknie dialogowym Utwórz widoki na wybranych poziomach nadaj widokowi nazwę i wybierz jego właściwości.
  4. Wybierz, czy widok zostanie utworzony na offsecie poziomu.
  5. Kliknij Utwórz.

Utworzone widoki znajdują się w Lista widoków. Na wstążce przejdź do karty Widok i kliknij Lista widoków.

Przykład: Hierarchia budynku w Organizatorze

Za pomocą Organizatora można wyświetlać zdefiniowaną hierarchię budynku.

  1. Na wstążce kliknij polecenie Zarządzaj > Hierarchia budynku, aby otworzyć okno dialogowe Hierarchia budynku.

  2. Na karcie Zarządzaj kliknij Organizator.

  3. Wybierz Synchronizuj w oknie dialogowym, które zostanie otwarte, aby pobrać hierarchię budynku do narzędzia Organizator.

    Hierarchia budynku jest wyświetlana w górnej części sekcji Kategorie i ma zieloną ikonę .

    W przypadku wprowadzenia zmian w oknie dialogowym Hierarchia budynku należy przeprowadzić synchronizację Organizator, aby pobrać zmiany do narzędzia Organizator.

  4. W razie potrzeby można ręcznie wprowadzać zmiany w poziomach, na przykład przenosić zespoły do innego poziomu.

    Wybierz zespół w modelu, następnie kliknij prawym przyciskiem myszy docelowy poziom w Organizator, po czym kliknij polecenie Przesuń wybrane obiekty. Synchronizuj Organizator.

    Zmiany wprowadzone ręcznie można usunąć. Wybierz kategorię, kliknij i wybierz Zarządzaj ręcznymi zmianami. Wybierz ręcznie dodane obiekty oznaczone symbolem lub , kliknij prawy przycisk myszy i wybierz Usuń zmiany wprowadzone ręcznie. Synchronizuj Organizator.

Uwaga:

W przypadku stosowania hierarchii budynku w modelu, eksport IFC używa poziomów hierarchii budynku jeżeli opcja Hierarchia przestrzenna z organizatora jest zaznaczona w oknie dialogowym Eksport IFC. W eksporcie nie są uwzględniane przestrzenie hierarchii budynku. Należy pamiętać, że nie można w tym samym czasie używać hierarchii utworzonej w narzędziu Organizator.

Aby skorzystać z hierarchii utworzonych w Organizator w eksporcie IFC, nadaj opcji XS_USE_INTEGRATED_BUILDING_HIERARCHIES wartość FALSE.

Czy to było pomocne?
Wstecz
Dalej