Bedrijfsinstellingen voor beheerders

Tekla Structures
2024
Tekla Structures

Bedrijfsinstellingen voor beheerders

Instellingen op bedrijfsniveau zijn hoofdzakelijk instellingen die voor alle projecten door het hele bedrijf worden gebruikt. Deze instellingen worden ingesteld met XS_SYSTEM en XS_FIRM.

Voor een groter bedrijf met dochterondernemingen kunnen de instellingen als volgt worden gebruikt:

  • XS_SYSTEM bevat mogelijk meerdere paden en verwijst naar algemene instellingen binnen het bedrijf. Dit kunnen bijvoorbeeld bedrijfslogo's, lijsten, printerinstellingen, tekeninginstellingen en templates zijn. Dit zijn instellingen die zelden wijzigen en op een server worden opgeslagen die voor allen beschikbaar is. Als het bedrijfslogo bijvoorbeeld wordt bijgewerkt, hoeft dit alleen op één plek te worden vervangen.
  • XS_FIRM verwijst naar de bedrijfsmap die door het bedrijf of een dochteronderneming is ingesteld. De map bevat alle bedrijfsinstellingen die op het specifieke kantoor worden gebruikt. Dit kunnen bijvoorbeeld logo's, tekeninginstellingen, templates, lijsten of printerinstellingen zijn. De bedrijfsmap kan ook door de gebruiker gedefinieerde submappen bevatten voor het opslaan van bestanden met eigenschappen.
  • XS_PROJECT verwijst naar de projectmap. De map bevat bijvoorbeeld projectinstellingen zoals logo's voor aannemers en fabrikanten of tekeninginstellingen. De projectmap kan ook door de gebruiker gedefinieerde submappen bevatten voor het opslaan van bestanden met projectspecifieke eigenschappen.

Raadpleeg voor meer informatie over de zoekvolgorde van mappen Zoekvolgorde voor mappen.

U kunt in uw eigen netwerk ook online of offline in bedrijfspecifieke verzamelingen van Tekla Warehouse gebruiken. Raadpleeg Aan de slag met Tekla Warehouse voor meer informatie.

Toegang tot de offline verzamelingen wordt beheerd met maprechten in uw netwerk en op het verzamelingsniveau in het bestand collections.json op de computer van elke gebruiker.

 "collections" 
"\\\\server-A\\company\\Tekla Structures collection" 
		

Het collections.json-bestand kan met geselecteerde personen worden gedeeld door het naar de map C:\Users\Public\Documents\Tekla\Tekla Warehouse\ te kopiëren.

Aanpassing van modeltemplates

U kunt de gewenste instellingen in een model met aangepaste instellingen opslaan en het model als template voor het maken van nieuwe modellen gebruiken. Het gebruik van modeltemplates kan handig zijn als uw bedrijf verschillende soorten projecten heeft, zoals parkeergarages, kantoorgebouwen, bruggen en industrieën.

Als u een modeltemplate wilt maken, raadpleegt u Modeltemplates maken.

De map van de modeltemplate bevindt zich standaard in uw omgevingsmap onder ..ProgramData\Trimble\Tekla Structures\<version>\environments\<your environment>\. De exacte maplocatie kan afhankelijk van uw omgeving en rol variëren. Gebruik de variabele XS_MODEL_TEMPLATE_DIRECTORY om een andere locatie te definiëren.

U kunt modeltemplates via Tekla Warehouse downloaden, delen en opslaan. Onderstaande afbeelding geeft een voorbeeld weer van een modeltemplate in Tekla Warehouse.

De knop In model invoegen in Tekla Warehouse installeert de modeltemplate rechtstreeks in de map waar XS_MODEL_TEMPLATE_DIRECTORY naar verwijst. U kunt de template direct gebruiken wanneer u een nieuw model maakt.

Modeltemplates bijwerken

Als u een upgrade uitvoert raden we u ten zeerste aan uw modeltemplates in de versie-upgrade van Tekla Structures bij te werken.

  1. Maak een nieuw model met een bestaande modeltemplate.
  2. Geef het model dezelfde naam als in de vorige versie van Tekla Structures.
  3. Open een 3D-venster.
  4. Klik in het menu Bestand op Diagnose en reparatie > Diagnose model.
  5. Klik op het tabblad Venster op Screenshot > Projectminiatuur om een projectminiatuur te maken of een gebruikersafbeelding met de naam thumbnail.png in de modelmap toe te voegen.

    Het voorkeursformaat van de afbeelding is 120 x 74 pixels.

  6. Klik in het menu Bestand op Opslaan als > Opslaan.

    Als u dit niet doet, verschijnt er mogelijk een melding met een waarschuwing dat het model in een vorige versie is gemaakt.

  7. Klik in het menu Bestand op Opslaan als > Opslaan als Model Template.
  8. Werk de inhoud van de modeltemplate bij.
    1. Selecteer welke databases, tekeningtemplates, lijsttemplates en modelsubmappen u in de modeltemplate wilt opnemen.
    2. Verwijder handmatig alle *.db-bestanden (omgevingsdatabase, databasebestanden met opties) uit de modelmap.

      De db.idrm-bestanden en xslib.idrm niet verwijderen. Ze vormen een onderdeel van het model.

    3. Klik op OK.

    De *.bak, *.log en xs_user bestanden worden automatisch uit de modelmap verwijderd.

De modeltemplate wordt opgeslagen in de locatie die door XS_MODEL_TEMPLATE_DIRECTORY is gedefinieerd.

U beschikt nu over een voorbeeldafbeelding voor uw modeltemplate. De database Applicaties en componenten is nu ook op orde en eenvoudig te gebruiken.

Aanpassing van lijsten en tekeningen

Als uw bedrijf al grafische templates in de indeling DXF, DWG of DGN heeft, kunt u deze templates naar Tekla Structures-templates converteren.

Raadpleeg voor gedetailleerde instructies de informatie over AutoCAD- en micro station-bestanden in de Template Editor User's Guide.

Raadpleeg de Template Editor User's Guide, lijsten en templates voor informatie over het maken van uw eigen templates en lijsten.

Kloontemplates voor tekeningen maken

Met het maken van kloontemplates voor tekeningen kunt u bestaande tekeningen als basis gebruiken voor het maken van nieuwe tekeningen van vergelijkbare onderdelen, merken of betonelementen. U hoeft alleen de onderdelen van de gekloonde tekening te wijzigen die van de oorspronkelijke tekening afwijken.

Overweeg tekeningen te klonen wanneer:

  • Er bevinden zich meerdere vergelijkbare onderdelen, merken of betonelementen in het model.
  • U moet onderdeel-, merk- of betontekeningen van vergelijkbare onderdelen, merken of betonelementen maken.
  • Voor de tekeningen zijn veel handmatige bewerkingen nodig.

U kunt bijvoorbeeld een tekening voor een spant maken, de tekening bewerken en deze vervolgens voor vergelijkbare spanten klonen. U hoeft dan alleen de gekloonde tekeningen waar de spanten verschillen te wijzigen.

De gekloonde tekening kan mogelijk meer onderdelen bevatten dan de originele tekening. Onderdeeleigenschappen, labels, associatieve opmerkingen en verwante tekstobjecten worden gekloond van een vergelijkbaar onderdeel in de originele tekening.

U kunt tekeningen klonen door de templates van de Tekeningendatabase te gebruiken. Een kloontemplate in de Tekeningendatabase kan ook in andere modellen worden gebruikt. U kunt kloontemplates gebruiken in projecten met dezelfde soort tekeningen.

  1. Selecteer in de Documentmanager een tekening.
  2. Klik met de rechtermuisknop en selecteer Toevoegen aan tekeningendatabase en vul vervolgens de gewenste eigenschappen in.

De kloontemplate kunt u vinden onder Kloontemplates in de Tekeningendatabase. Als u kloontemplates in andere modellen wilt gebruiken, opent u de Tekeningendatabase in het model, klikt u op de knop op de werkbalk en voegt u het model toe waar de templates zijn opgeslagen.

Raadpleeg over de Tekeningendatabase en kloontemplates: Tekeningen maken in de Tekeningendatabase voor meer informatie.

Was dit nuttig?
Vorige
Volgende