Verbeteringen in het modelleren

Tekla Structures
2021
Tekla Structures

Verbeteringen in het modelleren

Tekla Structures 2021 introduceert veel modelleerverbeteringen.

Verbeteringen in het maken van solide onderdelen

Tekla Structures 2021 gebruikt instancing voor het maken van een solide stalen en betonnen onderdelen. Dit verbetert de algehele prestaties omdat dezelfde onderdeel-solid-geometrie kan worden gebruikt op meerdere locaties in het model zonder de noodzaak om herhaaldelijk vergelijkbare geometrieën opnieuw te maken. Er is ook minder geheugen nodig om de solide geometrieën in de solid-buffer op te slaan, omdat de gegevens van maar één geometrie voor alle vergelijkbare geometrieën wordt opgeslagen. Afhankelijk van de herhaling van de vergelijkbare onderdelen in het model, kunnen de verbeterde prestaties bijvoorbeeld worden weergegeven in het modelvenster, in de nummering en in export.

Solide geometrieën worden nu gemaakt en opgeslagen in de lokale coördinaten van onderdelen. Dit verbetert de nauwkeurigheid. Dit verbetert de nummering als onderdelen worden toegewezen aan dezelfde reeks, ongeacht waar de onderdelen zich in de globale coördinaten van het model bevinden.

Nieuwe preview wanneer u objecten kopieert of verplaatst

Wanneer u objecten kopieert of verplaatst met het Kopiëren of Verplaatsen-commando, geeft Tekla Structures nu een preview van de nieuwe locatie van de gekopieerde of verplaatste objecten in het model weer. Hierdoor kunt u het eindresultaat van kopiëren of verplaatsen zien voordat u het bestemmingspunt voor de gekopieerde of verplaatste objecten aanwijst.

  1. Selecteer de objecten die u wilt kopiëren of verplaatsen.

  2. Voer het commando Kopiëren of Verplaatsen uit.

  3. Wijs de oorsprong aan voor kopiëren of verplaatsen.

    Tekla Structures geeft een lijn weer tussen het eerste geselecteerde punt en de cursorpositie. Verplaats de cursor om te zien hoe de preview wijzigt.

    Door Tekla Structures wordt de preview altijd weergegeven op de positie waar de objecten worden gekopieerd of verplaatst, niet op de positie waar de cursor zich bevindt wanneer u het bestemmingspunt aanwijst.

  4. Wijs de bestemming aan.

Als u het aantal in de preview weergegeven objecten wilt beperken, gebruikt u de variabele XS_PREVIEW_LIMIT. De standaardwaarde is 1000. Als de waarde 0 is, is het voorbeeld uitgeschakeld.

Verbeteringen in de Linear Array Tool en in Radial Array Tool

  • Als u in de Linear Array Tool het aantal kopieën niet invoert, wordt het aantal kopieën nu overgenomen van de gedefinieerde ruimte-afstanden tussen de objecten, in het vak Tussenruimte tussen kopieën.

  • Als u in de Radial Array Tool het aantal hoeken of de afstand niet invoert, wordt het aantal kopieën nu uit de gedefinieerde afstanden tussen de objecten gehaald, in het vak Tussenruimte tussen kopieën.

Gebruik Enter om commando's te voltooien

U kunt nu de toets Enter gebruiken om commando's te voltooien. Zorg ervoor dat de nieuwe variabele XS_ENTER_FINALIZES_COMMANDS is ingesteld op TRUE om het gebruik van de toets Enter als een sneltoets in te schakelen.

Voorheen werkten alleen de spatietoets en de middelste muisknop als snelkoppelingen om een commando te voltooien en voor de commando´s voor rechtstreekse wijziging werkte alleen de middelste muisknop als een sneltoets.

Verbeteringen in snappen

U kunt niet meer naar de eigen verborgen referentielijnen of geometrielijnen van een object snappen in vensters waarvan de weergaveoptie Onderdelen gerenderd of Gerenderde componenten (Ctrl/Shift + 4) is.

Kijkvlak verbeteringen

Wanneer u kijkvlakken maakt, kunt u nu ook vlakken van onderdelen en componentobjecten selecteren als u de rendering-opties voor het Draadvenster met schaduw en Grijswaarden (Ctrl+2, Shift+2, Ctrl+3 en Shift+3) gebruikt. De gerelateerde statusbalkberichten zijn ook verbeterd.

Verbeterde foutmeldingen in het eigenschappenvenster

Als u voorheen een ongeldige waarde in een waardevak in het eigenschappenvenster had ingevoerd, werd er een rode rand rondom het vak en een rood uitroepteken weergegeven. Er wordt nu geen uitroepteken maar een Knopinfo die de foutmelding weergeeft, bovenop het waardevak weergegeven.

Verbeteringen in stortbeheer

  • Er zijn prestatieverbeteringen in de stortbeheer- functies. Deze verbeteringen versnellen het openen en wijzigen van de modellen, maar ook het berekenen van de storteenheden.

  • Wanneer u het Storteenheden berekenen-commando gebruikt, worden de prefab-betonelementen niet meer automatisch aan de storteenheden toegevoegd. Ze kunnen echter nog steeds handmatig worden toegevoegd.

  • De standaardwaarde van XS_CALCULATE_POUR_UNITS_ON_SHARING is gewijzigd in FALSE. Dit betekent dat Tekla Structures de storteenheden tijdens het wegschrijven en inlezen niet meer automatisch in gedeelde modellen worden berekend en bijgewerkt. In plaats daarvan kan elke gebruiker nu het Storteenheden berekenen-commando nu in zijn/haar lokale versie van het gedeelde model uitvoeren wanneer hij of zij up-to-date informatie over storteenheden nodig heeft.

  • Sommige verbeteringen in stortberekeningen werden al in Tekla Structures 2020 SP1 geïntroduceerd. Zie 2020 SP1: Nieuwe functies en verbeteringen voor details.

Het gedeelte Gebruiksstatistieken is verwijderd uit het menu Bestand

Het gedeelte Gebruiksstatistieken in Bestands > Instellingen is verwijderd. Merk op dat gebruiksgegevens standaard worden verzameld.

Het UserFeedbackLog.txt-bestand dat de verzamelde gegevens bevat, is nu beschikbaar in Bestand > Logboeken > Gebruik gegevenslog, samen met de andere logbestanden.

Merk op dat als u klikt op Gebruik gegevenslog om het UserFeedbackLog.txt-bestand te openen, wordt het logbestand altijd met de standaard teksteditor geopend, in tegenstelling tot andere logbestanden die via de Tekla Structures-logbestandviewer kunnen worden geopend. De optie om te schakelen tussen de viewers werkt niet voor het bestand UserFeedbackLog.txt.

Het UserFeedbackLog.txt-logbestand bevindt zich nu in de map TeklaStructuresModels.

Andere verbeteringen in het modelleren

  • Oppervlak-objecten kunnen nu worden gekopieerd. Als ze aan het vlak van een onderdeel zijn gekoppeld, worden ze gekopieerd wanneer het onderdeel wordt gekopieerd. Oppervlakken kunnen ook afzonderlijk van één objecttype worden gekopieerd of verplaatst naar hetzelfde objecttype, dat wil zeggen van een onderdeel naar een ander onderdeel en van een stortobject naar een ander stortobject.

  • In modelvensters worden mozaïekpatronen niet langer in de gebogen oppervlakobjecten weergegeven. Dit geldt zowel voor DirectX-rendering als oudere (OpenGL) rendering.

  • De commando's Onderdeel naar item converteren en Vorm (item) van geometrie maken zijn nu beschikbaar in het tabblad Bewerken op het lint. Voorheen kon u deze commando's starten door het contextmenu van de rechtermuisknop of Snel starten te gebruiken.

  • Het submenu Huidige venster is nu verwijderd uit het Zoom contextmenu in de modelmodus en de tekeningmodus. In de modelmodus zijn de zoomcommando's beschikbaar in het tabblad Venster in het tabblad Zoom menu en de tooltips geven de gerelateerde toetsenbord sneltoetsen weer. In beide modi zijn de zoomcommando's beschikbaar Snel starten en daar kunt u ook de toetsenbord sneltoetsen zien.

  • De takken Wapeningsstaaf en Wapeningsnet zijn uit de materialendatabase verwijderd. Staaf-definities zijn beschikbaar in de Stavendatabase.

Was this helpful?
Previous
Next