Objecten kopiëren

Tekla Structures
2021
Tekla Structures

Objecten kopiëren

U kunt objecten op een aantal verschillende manieren kopiëren. Wanneer u een object kopieert, kopieert Tekla Structures alle objecten die ermee zijn verbonden, inclusief de componenten.

Kopiëren door twee punten aan te wijzen

De basismanier om objecten in een model of tekening te kopiëren, is door de oorsprong en een of meer bestemmingspunten te definiëren.

  1. Selecteer de objecten die u wilt kopiëren.
  2. Voer het commando Kopiëren uit.
    • Klik in het model op het tabblad Bewerken op Kopiëren.

    • Klik in de tekening op het tabblad Tekening op Kopiëren > Kopiëren.

  3. Wijs de oorsprong voor het kopiëren aan.

    Tekla Structures geeft in het model een elastieklijn weer tussen het eerste geselecteerde punt en de cursorpositie. Dit is een voorbeeld van de positie waar de objecten worden gekopieerd. Verplaats de cursor om te zien hoe het voorbeeld wijzigt.

    Door Tekla Structures wordt het voorbeeld altijd weergegeven op de positie waar de objecten worden gekopieerd, niet op de positie waar de cursor zich bevindt wanneer u het bestemmingspunt aanwijst.

  4. Wijs een of meer bestemmingen aan.

    De objecten worden onmiddellijk gekopieerd. Het commando Kopiëren blijft ingeschakeld.

  5. Als u de nieuwste kopieerbewerking ongedaan wilt maken, klikt u op de knop Ongedaan maken in de linkerbovenhoek van het hoofdvenster van Tekla Structures.

    Het commando Kopiëren blijft ingeschakeld.

  6. Als u het kopiëren wilt stoppen, drukt u op Esc.
Opmerking:

Als u het aantal in het voorbeeld weergegeven objecten wilt beperken, gebruikt u de variabele XS_PREVIEW_LIMIT. De standaardwaarde is 1000. Als de waarde 0 is, is het voorbeeld uitgeschakeld.

Rechtlijnig kopiëren

U kunt in het model meerdere kopieën van een object in dezelfde lineaire richting maken.

  1. Selecteer de objecten die u wilt kopiëren.
  2. Klik op het tabblad Bewerken op Kopiëren speciaal > Rechtlijnig.

    Het dialoogvenster Kopiëren - rechtlijnig wordt geopend.

  3. Wijs twee punten in het model aan of voer de coördinaten in de vakken dX, dY en dZ in.

    U kunt ook een formule gebruiken om de verplaatsing in de x-, y- en z-richting te berekenen. Bijvoorbeeld:

  4. Voer het aantal kopieën in.
  5. Klik op Kopiëren.
  6. Als u het kopiëren wilt stoppen, drukt u op Esc
    Tip:

    Als het dialoogvenster geopend is maar het commando niet langer is ingeschakeld, klikt u op de knop Aanwijzen... om het commando opnieuw in te schakelen.

Kopiëren door een afstand vanaf de oorsprong op te geven

U kunt objecten naar een nieuwe positie in het model of tekening kopiëren door een afstand vanaf de oorsprong op te geven. Gebruik het dialoogvenster Voer een numerieke locatie in om de afstand op te geven.

  1. Selecteer de objecten die u wilt kopiëren.
  2. Voer het commando Kopiëren uit.
    • Klik in het model op het tabblad Bewerken op Kopiëren.

    • Klik in de tekening op het tabblad Tekening op Kopiëren > Kopiëren.

  3. Wijs de oorsprong voor het kopiëren aan.
  4. Verplaats de cursor in de richting waarin u de objecten wilt kopiëren, maar wijs het punt niet aan.
  5. Voer de afstand in.

    Wanneer u gaat invoeren, geeft Tekla Structures automatisch het dialoogvenster Voer een numerieke locatie in weer.

  6. Klik op OK.

Kopiëren via drag & drop

U kunt objecten kopiëren door drag & drop te gebruiken.

  1. Klik in het menu Bestand op Instellingen en schakel het selectievakje Drag & Drop in om het commando in te schakelen.
  2. Selecteer de objecten die u wilt kopiëren.

  3. Houd de Ctrl-toets ingedrukt en sleep de objecten naar een nieuwe locatie.

    Het punt vanwaar u gaat verslepen (midden, hoek of middelpunt) is van invloed op de uitlijning van het object in de nieuwe locatie.

    Tekla Structures kopieert de objecten:

Opmerking:

Als u in een tekening stramienlabels wilt kopiëren, moet u eerst het stramienlabel selecteren en vervolgens de selectieknop Selecteer stramien lijn inschakelen of de handle van het stramienlabel selecteren.

Objecten naar een ander object kopiëren

In het model kunt u wapening, oppervlakten en afzonderlijke onderdeellassen tussen vergelijkbare objecten kopiëren en ze aanpasbaar maken aan het object waarnaar ze worden gekopieerd. Dit is met name handig wanneer u bijvoorbeeld eerder gemodelleerde onderdelen detailleert. De objecten waartussen u kunt kopiëren, kunnen verschillende afmetingen, lengten en rotaties hebben. Als u objecten vanuit een merk of betonelement kopieert, kopieert Tekla Structures indien mogelijk ook de merkstructuur. Submerken worden bijvoorbeeld als submerk gekopieerd als er een bovenliggend object wordt gevonden.

Tip:

In plaats van objecten te kopiëren van een merk of een storteenheid naar andere identieke merken of storteenheden, kunt u gebruik maken van de Batch-editor-tool. Batch-editor detecteert overeenkomende objecten in de doelmerken of betonelementen en bewerkt het overeenkomende object door de geometrie en eigenschappen te wijzigen.

Als u wapening of oppervlakten kopieert of verplaatst en u wilt dat deze worden aangepast aan het onderdeel waarnaar ze worden gekopieerd, let dan op de beperkingen:

  • De handles voor wapening of oppervlakte moeten ten dele hoeken zijn.

  • De onderdelen waartussen u kopieert moeten hetzelfde aantal hoeken in de doorsnede hebben.

  • moeten cirkelvormige onderdelen dezelfde doorsnedemaatlijnen hebben.

  1. Selecteer de objecten die u wilt kopiëren.
  2. Klik op het tabblad Bewerken op Kopiëren speciaal > Naar een ander object.
  3. Selecteer het object van waaruit u wilt kopiëren (bronobject).
  4. Selecteer de objecten waarnaar u wilt kopiëren (doelobjecten).

Alle inhoud naar een ander object kopiëren

U kunt in het model objecten uit een merk of betonelement naar andere vergelijkbare merken of betonelementen kopiëren zonder elk te kopiëren object afzonderlijk te selecteren. Dit is bijvoorbeeld handig wanneer u een merk hebt gedetailleerd en alle details naar een ander vergelijkbaar merk wilt kopiëren.

Tip:

In plaats van objecten te kopiëren van een merk of een storteenheid naar andere identieke merken of storteenheden, kunt u gebruik maken van de Batch-editor-tool. Batch-editor detecteert overeenkomende objecten in de doelmerken of betonelementen en bewerkt het overeenkomende object door de geometrie en eigenschappen te wijzigen.

  1. Zorg ervoor dat de selectieknop Selecteer merk is ingeschakeld.
  2. Selecteer het merk of betonelement van waaruit u wilt kopiëren (bronobject).
  3. Klik op het tabblad Bewerken op Kopiëren speciaal > Alle inhoud naar een ander object.
  4. Selecteer de merken of betonelementen waar u naar wilt kopiëren (doelobjecten).

Hierdoor kopieert Tekla Structures de volgende objecten:

  • Aangelaste onderdelen

  • Wapening, bouten en lassen

  • Uitsnijdingen, fittingen en vellingkanten

  • Submerken

  • Componenten

Opmerking:

Tekla Structures kopieert geen stortnaden of aansluitende onderdelen die zijn gemaakt door een component die ook het hoofdonderdeel van het merk heeft gemaakt. Als enkele te kopiëren objecten al in het merk of betonelement bestaan, kan Tekla Structures dubbele objecten maken. Tekla Structures waarschuwt u voor dubbele aansluitende onderdelen, wapening en submerken, maar niet voor dubbele bouten, lassen, uitsnijdingen of componenten.

Naar een ander vlak kopiëren

U kunt in het model objecten van het eerste vlak dat u opgeeft naar het tweede vlak en het derde, enzovoort dat u opgeeft, kopiëren. De positie van de gekopieerde objecten ten opzichte van het tweede vlak (en het derde, enzovoort) blijft hetzelfde als de positie van de oorspronkelijke objecten ten opzichte van het eerste vlak.

  1. Selecteer de objecten die u wilt kopiëren.
  2. Klik op het tabblad Bewerken op Kopiëren speciaal > Naar een ander vlak.
  3. Wijs de oorsprong van het eerste vlak aan.
  4. Wijs een punt op het eerste vlak in de positieve x-richting aan.
  5. Wijs een punt op het eerste vlak in de positieve y-richting aan.
  6. Herhaal stap 3-5 voor alle bestemmingsvlakken.

Uit een ander model kopiëren

U kunt objecten uit een ander model kopiëren op basis van fasenummers. Tekla Structures kopieert alleen aansluitende onderdelen uit het model als deze deel uitmaken van dezelfde fase als het hoofdonderdeel. Dit geldt ook voor componentobjecten.

  1. Klik op het tabblad Bewerken op Kopiëren speciaal > Uit een ander model.

    Het dialoogvenster Kopieer van bestaand model wordt geopend.

  2. Selecteer in de lijst Modellen het model waaruit u wilt kopiëren.

    Dit is het bronmodel. Merk op dat het doelmodel met dezelfde naam of met een nieuwere versie van Tekla Structures moet zijn gemaakt als het bronmodel. U kunt niet van een nieuwere versie naar een oudere versie kopiëren.

  3. Voer in het vak Fasenummer de nummers van de fasen in waaruit u objecten wilt kopiëren, gescheiden door spaties.

    Bijvoorbeeld 2 7.

  4. Klik op Kopiëren.
  5. Sluit het dialoogvenster.
Opmerking:

Als u stortnaden vanuit een ander model kopieert, passen de gekopieerde stortnaden zich automatisch aan het doelmodel aan. Controleer altijd of de gekopieerde stortnaden correct zijn aangepast.

Was this helpful?
Vorige
Volgende