De dialoogvensters van gebruikerscomponenten aanpassen

Tekla Structures
2021
Tekla Structures

De dialoogvensters van gebruikerscomponenten aanpassen

Tekla Structures maakt automatisch een dialoogvenster voor elke gebruikerscomponent die u definieert. Elke gebruikerscomponent heeft een invoerbestand (.inp) dat de inhoud van het dialoogvenster van de gebruikerscomponent definieert. U kunt het dialoogvenster aanpassen door de tool Gebruikerscomponent Dialoogvenster Editor te gebruiken.

Of als u een gevorderde gebruiker bent, kunt u de invoerbestanden (.inp) van het dialoogvenster ook handmatig in een teksteditor wijzigen.

Het dialoogvenster van een gebruikerscomponent wijzigen

Als u het Gebruikerscomponent Dialoogvenster Editor wilt openen, selecteert u een gebruikerscomponent in het model, klikt u met de rechtermuisknop en selecteert u Dialoogvenster gebruikerscomponent bewerken.

Taak

Actie

Objecteigenschappen weergeven en bewerken

  1. Selecteer een dialoogvensterelement. Bijvoorbeeld een tekstvak.

  2. Klik op Wijzigen > Eigenschappen.

    Nu kunt u de huidige eigenschappen van het dialoogvensterelement weergeven en bewerken. U kunt bijvoorbeeld controleren of u het juiste tekstvak onder elk label in het dialoogvenster hebt.

Daarnaast kunt u op het dialoogvensterelement dubbelklikken. Als het dialoogvensterelement niet voor weergeven en bewerken wordt geopend, moet u proberen op de ruimte direct onder het selectievakje te dubbelklikken:

Een dialoogvensterelement toevoegen

Klik op Invoegen en selecteer een geschikt element in de lijst. De opties zijn:

  • Tabblad: een nieuw tabblad toevoegen

  • Label: een label voor een tekstvak of lijst toevoegen

  • Parameter: een tekstvak toevoegen

  • Attribuut: een lijst toevoegen

  • Onderdeel: enkele basiseigenschappen toevoegen

  • Profiel: enkele basisprofieleigenschappen toevoegen

  • Afbeelding: een illustratieve afbeelding van de gebruikerscomponent toevoegen

Een afbeelding toevoegen

  1. Klik op Invoegen > Afbeelding om de inhoud van de Afbeeldingenmap weer te geven die in Extra > Opties is ingesteld.

  2. Selecteer een afbeelding.

    De afbeelding moet de bitmapindeling (.bmp) hebben.

  3. Klik op Openen.

  4. Versleep de afbeelding naar de gewenste locatie.

Een tabblad toevoegen

  1. Klik op Invoegen > Tabblad.

  2. Dubbelklik op het nieuwe tabblad.

  3. Voer een nieuwe naam in en druk vervolgens op Enter.

Opmerking:

Elk tabblad mag maximaal 25 velden bevatten. Als u meer dan 25 velden zichtbaar hebt, maakt Tekla Structures automatisch een ander tabblad.

Het pixelstramien weergeven of verbergen

Klik op .

Tekla Structures geeft een pixelstramien weer waardoor het eenvoudiger wordt om elementen in het dialoogvenster uit te lijnen.

Een dialoogvensterelement verplaatsen

Sleep het dialoogvensterelement naar een nieuwe locatie.

U kunt ook de toetsenbordsneltoetsen Ctrl+X (knippen), Ctrl+C (kopiëren) en Ctrl+V (plakken) gebruiken. Als u bijvoorbeeld een dialoogvensterelement naar een ander tabblad wilt verplaatsen, selecteert u het dialoogvensterelement, drukt u op Ctrl+X, gaat u naar een ander tabblad en drukt u op Ctrl+V.

Meerdere dialoogvensterelementen selecteren

Houd de Ctrl-toets ingedrukt en klik op de dialoogvensterelementen of gebruik gebiedsselectie.

De naam van een tabblad of tekstvaklabel wijzigen

  1. Dubbelklik op het tabblad of het tekstvaklabel.

  2. Voer een nieuwe naam in.

  3. Druk op Enter.

Een dialoogvensterelement verwijderen

  1. Selecteer het dialoogvensterelement dat u wilt verwijderen.

  2. Druk op Delete.

Een tabblad verwijderen

  1. Selecteer het tabblad.

  2. Klik met de rechtermuisknop en selecteer Verwijderen.

Afbeeldingen aan een lijst toevoegen

  1. Selecteer het lijstelement.

  2. Klik op Wijzigen > Eigenschappen.

  3. Klik op Waarden bewerken.

  4. Klik op Bladeren Toevoegen.

  5. Selecteer de afbeelding die u wilt gebruiken en klik op Openen.

  6. Herhaal de stappen 4-5 voor andere afbeeldingen die u wilt gebruiken.

  7. Klik op OK om de wijzigingen op te slaan.

De wijzigingen opslaan

Klik op Bestand > Opslaan.

Invoerbestanden van gebruikerscomponenten

Elke gebruikerscomponent heeft een invoerbestand (.inp) dat de inhoud van het dialoogvenster van de gebruikerscomponent definieert.

Wanneer u een nieuwe gebruikerscomponent maakt, maakt Tekla Structures automatisch een invoerbestand voor de gebruikerscomponent. Het invoerbestand bevindt zich in de map \CustomComponentDialogFiles onder de modelmap. Het invoerbestand heeft dezelfde naam als de gebruikerscomponent en de bestandsextensie is .inp.

Wanneer u een gebruikerscomponent wijzigt, raakt u wijzigingen kwijt die u het invoerbestand hebt aangebracht. Wanneer u echter de gebruikerscomponent wijzigt, maakt Tekla Structures automatisch een back-up van het invoerbestand. De back-up heeft de bestandsextensie .inp_bak en het bevindt zich in de map \CustomComponentDialogFiles onder de modelmap. Tekla Structures geeft een melding wanneer de back-up wordt gemaakt.

Het invoerbestand van de gebruikerscomponent vergrendelen of ontgrendelen

U kunt het invoerbestand (.inp) van de gebruikerscomponent vergrendelen om te voorkomen dat per er ongeluk wijzigingen worden aangebracht. Als het bestand is ontgrendeld en een andere persoon de gebruikerscomponent in de gebruikerscomponenteditor bijwerkt, gaan al uw wijzigingen in het dialoogvenster verloren.

  1. Selecteer in het model de gebruikerscomponent waarvan u het invoerbestand wilt vergrendelen of ontgrendelen.
  2. Klik met de rechtermuisknop en selecteer Dialoogvenster gebruikerscomponent bewerken.
  3. Klik in de Gebruikerscomponent Dialoogvenster Editor op de knop Vergrendelen/ontgrendelen .

Als iemand de gebruikerscomponent in de gebruikerscomponenteditor wijzigt wanneer het .inp-bestand is vergrendeld, wordt het .inp-bestand niet bijgewerkt. U kunt het dialoogvenster toch in de Gebruikerscomponent Dialoogvenster Editor wijzigen, zelfs als het .inp-bestand is vergrendeld.

Instellingen van het dialoogvenstereditor voor gebruikerscomponenten

Klik in de Gebruikerscomponent Dialoogvenster Editor op Extra > Opties om basisinstellingen in het dialoogvenstereditor voor gebruikerscomponenten weer te geven en te wijzigen. Klik op Extra > Taal wijzigen om de taal van de dialoogvenstereditor voor gebruikerscomponenten te wijzigen,

Optie

Beschrijving

Afbeeldingenmap

De locatie van de afbeeldingenmap. Als u de instelling van de standaardmap wilt herstellen, klikt u op Standaard

Projectmap

De locatie van de projectmap. Wanneer u een volledig nieuw invoerbestand maakt door op Bestand > Nieuw te klikken en dit vervolgens opslaat, wordt het bestand in de projectmap opgeslagen. Bestaande invoerbestanden worden onder de modelmap opgeslagen.

Parameterbreedte

De standaardbreedte voor tekstvakken.

Attribuutbreedte

De standaardbreedte voor lijsten.

Stramienafstand X

Stramienafstand Y

De afstand van het pixelstramien in de X- en Y-richting. De standaardwaarde is 5.

Naar stramien snappen

Selecteer of u het pixelstramien wilt weergeven of verbergen.

Optie

Beschrijving

Taal

Selecteer een taal in de lijst. Sluit de dialoogvenstereditor en open deze opnieuw om de wijzigingen door te voeren. U beschikt over de volgende opties:

  • Auto: de dialoogvenstereditor volgt de taal van de gebruikersinterface van Tekla Structures
  • English
  • Dutch
  • French
  • German
  • Italian
  • Spanish
  • Japanese
  • Chinese Simplified
  • Chinese Traditional
  • Czech
  • Portuguese Brazilian
  • Hungarian
  • Polish
  • Russian
  • Korean
Was this helpful?
Vorige
Volgende