사용자 컴포넌트의 대화 상자 사용자 지정

Tekla Structures
2021
Tekla Structures

사용자 컴포넌트의 대화 상자 사용자 지정

Tekla Structures는 정의되는 각각의 사용자 컴포넌트에 자동으로 대화 상자를 생성합니다. 각 사용자 컴포넌트에는 사용자 컴포넌트 대화 상자의 내용을 정의하는 입력(.inp) 파일이 있습니다. 사용자 컴포넌트 대화 상자 편집기 도구를 사용하여 대화 상자를 사용자 지정할 수 있습니다.

또는 고급 사용자라면 텍스트 편집기에서 대화 상자 입력(.inp) 파일을 수동으로 수정할 수 있습니다.

사용자 컴포넌트 대화 상자 수정

사용자 컴포넌트 대화 상자 편집기를 열려면 모델에서 사용자 컴포넌트를 선택하고 마우스 오른쪽 버튼을 클릭한 다음 사용자 컴포넌트 대화 상자 편집을 선택합니다.

대상

수행할 작업

객체 속성 보기 및 편집

  1. 대화 상자 요소를 선택합니다. 예: 텍스트 상자.

  2. 수정 > 속성을 클릭합니다.

    이제 대화 상자 요소의 현재 속성을 보고 편집할 수 있습니다. 예를 들어 대화 상자에서 각 라벨 아래에 올바른 텍스트 상자가 있는지 확인할 수 있습니다.

또는 대화 상자 요소를 두 번 클릭할 수 있습니다. 보고 편집할 수 있도록 대화 상자 요소가 열리지 않는 경우, 확인란 바로 아래 공간을 두 번 클릭합니다.

대화 상자 요소 추가

삽입을 클릭하고 목록에서 적당한 요소를 선택합니다. 옵션은 다음과 같습니다.

  • 탭 페이지: 새 탭 추가

  • 라벨: 텍스트 상자 또는 목록의 라벨 추가

  • 매개변수: 텍스트 상자 추가

  • 속성: 목록 추가

  • 부재: 일부 기본적 부재 속성 추가

  • 프로파일: 일부 기본적 프로파일 속성 추가

  • 그림: 사용자 컴포넌트의 예시 이미지 추가

이미지 추가

  1. 삽입 > 그림을 클릭하여 도구 > 옵션에서 설정한 이미지 폴더의 내용을 표시합니다.

  2. 이미지를 선택합니다.

    이미지는 비트맵(.bmp) 형식이어야 합니다.

  3. 열기를 클릭합니다.

  4. 원하는 위치로 이미지를 드래그합니다.

탭 추가

  1. 삽입 > 탭 페이지를 클릭합니다.

  2. 새 탭을 두 번 클릭합니다.

  3. 새 이름을 입력한 다음 Enter 키를 누릅니다.

주:

각 탭에는 최대 25개의 필드가 포함될 수 있습니다. 25개를 넘는 필드가 표시되면 Tekla Structures는 자동으로 새 탭을 생성합니다.

픽셀 그리드 표시 또는 숨기기

기호를 클릭합니다.

Tekla Structures가 대화 상자에서 요소를 보다 쉽게 정렬할 수 있는 픽셀 그리드를 표시합니다.

대화 상자 요소 이동

대화 상자 요소를 새 위치로 드래그합니다.

키보드 단축키 Ctrl+X(잘라내기), Ctrl+C(복사) 및 Ctrl+V(붙여넣기)도 사용할 수 있습니다. 예를 들어 대화 상자 요소를 다른 탭으로 이동하려면, 대화 상자 요소를 선택하고 Ctrl+X를 누른 다음 다른 탭으로 이동해 Ctrl+V를 누릅니다.

여러 대화 상자 요소 선택

Ctrl 키를 누른 상태에서 대화 상자 요소를 클릭하거나 영역 선택을 사용합니다.

탭 또는 텍스트 상자 라벨 이름 바꾸기

  1. 탭 또는 텍스트 상자 라벨을 두 번 클릭합니다.

  2. 새 이름을 입력합니다.

  3. Enter 키를 누릅니다.

대화 상자 요소 제거

  1. 제거할 대화 상자 요소를 선택합니다.

  2. 삭제 키를 누릅니다.

탭 제거

  1. 탭을 선택합니다.

  2. 마우스 오른쪽 버튼으로 클릭하고 삭제를 선택합니다.

목록에 이미지 추가

  1. 목록 요소를 선택합니다.

  2. 수정 > 속성을 클릭합니다.

  3. 값 편집을 클릭합니다.

  4. 찾아보기 추가를 클릭합니다.

  5. 사용할 이미지를 선택하고 열기를 클릭합니다.

  6. 사용하려는 다른 이미지에 대해서도 4-5단계를 반복합니다.

  7. 확인을 클릭하여 변경 사항을 저장합니다.

변경 사항 저장

파일 > 저장을 클릭합니다.

사용자 컴포넌트 입력 파일

각 사용자 컴포넌트에는 사용자 컴포넌트의 대화 상자의 내용을 정의하는 입력(.inp) 파일이 있습니다.

사용자가 새로운 사용자 컴포넌트를 생성하면 Tekla Structures가 그 컴포넌트에 대한 입력 파일을 자동으로 생성합니다. 이 입력 파일은 모델 폴더 아래의 \CustomComponentDialogFiles 폴더에 위치합니다. 입력 파일은 사용자 컴포넌트와 이름이 동일하며 파일명 확장자는 .inp입니다.

사용자 컴포넌트를 수정하면 입력 파일의 변경 사항이 모두 사라집니다. 하지만 사용자 컴포넌트를 수정할 때 Tekla Structures는 입력 파일의 백업 사본을 자동으로 생성합니다. 백업 복사본의 파일 이름 확장자는 .inp_bak이며 모델 폴더 아래의 \CustomComponentDialogFiles 폴더에 있습니다. Tekla Structures는 백업 파일이 생성될 때 알림을 표시합니다.

사용자 컴포넌트 입력 파일 잠금 또는 잠금 해제

실수로 수정하지 않도록 사용자 컴포넌트의 입력(.inp) 파일을 잠글 수 있습니다. 파일 잠금이 해제되고 다른 사용자가 사용자 컴포넌트 편집기에서 사용자 컴포넌트를 업데이트할 경우 대화 상자에 대한 모든 수정 사항이 손실됩니다.

  1. 모델에서 입력 파일을 잠그거나 잠금을 해제할 사용자 컴포넌트를 선택합니다.
  2. 마우스 오른쪽 버튼을 클릭하여 사용자 컴포넌트 대화 상자 편집을 선택합니다.
  3. 사용자 컴포넌트 대화 상자 편집기에서 잠금/잠금 해제 버튼()을 클릭합니다.

.inp 파일이 잠겨 있을 때 다른 사용자가 사용자 컴포넌트 편집기에서 사용자 컴포넌트를 수정하면 .inp 파일이 업데이트되지 않습니다. .inp 파일이 잠겨 있더라도 사용자 컴포넌트 대화 상자 편집기에서 대화 상자를 수정할 수 있습니다.

사용자 컴포넌트 대화 상자 편집기 설정

사용자 컴포넌트 대화 상자 편집기에서 도구 > 옵션을 클릭하여 사용자 컴포넌트 대화 상자 편집기의 기본 설정을 확인하고 수정합니다. 도구 > 언어 변경을 클릭하여 사용자 컴포넌트 대화 상자 편집기의 언어를 변경합니다.

옵션

설명

이미지 폴더

이미지 폴더의 위치. 기본 폴더 설정을 복구하려면 기본값을 클릭합니다.

프로젝트 폴더

프로젝트 폴더의 위치. 파일 > 새로 만들기를 클릭해 완전히 새로운 입력 파일을 만든 다음 저장하면 프로젝트 폴더에 파일이 저장됩니다. 기존 입력 파일은 모델 폴더 아래 저장됩니다.

매개변수 너비

텍스트 상자의 기본 너비.

속성 너비

목록의 기본 너비.

그리드 간격 X

그리드 간격 Y

X 방향과 Y 방향의 픽셀 그리드 간격. 기본값은 5입니다.

그리드에 스냅

픽셀 그리드를 표시할지 숨길지 선택합니다.

옵션

설명

언어

목록에서 언어를 선택합니다. 변경 사항을 적용하려면 대화 상자 편집기를 닫았다가 다시 엽니다. 옵션은 다음과 같습니다.

  • 자동: 대화 상자 편집기는 Tekla Structures 사용자 인터페이스의 언어를 따릅니다.
  • English
  • Dutch
  • French
  • German
  • Italian
  • Spanish
  • Japanese
  • Chinese Simplified
  • Chinese Traditional
  • Czech
  • Portuguese Brazilian
  • Hungarian
  • Polish
  • Russian
  • Korean
Was this helpful?
이전
다음