Copia di oggetti

Tekla Structures
2024
Tekla Structures

Copia di oggetti

È possibile copiare gli oggetti in diversi modi. Quando si copia un oggetto, Tekla Structures copia tutti gli oggetti collegati a esso, compresi i componenti.

Copia selezionando due punti

Il metodo di base per copiare gli oggetti in un modello o in un disegno è definire l'origine e uno o più punti di destinazione.

  1. Selezionare gli oggetti da copiare.
  2. Eseguire il comando Copia:
    • Nel modello, nella scheda Modifica cliccare su Copia.

    • Nel disegno, nella scheda Disegno cliccare su Copia > Copia.

  3. Selezionare l'origine per la copia.

    Nel modello Tekla Structures visualizza una linea elastica tra il primo punto selezionato e la posizione del cursore. Questa è un'anteprima della posizione in cui gli oggetti verranno copiati. Spostare il cursore per verificare in che modo l'anteprima cambia.

    Tekla Structures visualizza sempre l'anteprima nella posizione in cui gli oggetti verranno copiati, non nella posizione in cui si trova il cursore quando si seleziona il punto di destinazione.

  4. Selezionare uno o più punti di destinazione.

    Gli oggetti vengono copiati immediatamente. Il comando Copia rimane attivo.

  5. Per annullare l'ultima operazione di copia, cliccare sul pulsante Annulla sull'angolo superiore sinistro della finestra principale di Tekla Structures.

    Il comando Copia rimane attivo.

  6. Per interrompere la copia, premere Esc.
Nota:

Se si desidera limitare il numero di oggetti visualizzati nell'anteprima, utilizzare l'opzione avanzata XS_PREVIEW_LIMIT. Il valore di default è 1000. Quando il valore è 0, l'anteprima è disattivata.

Esecuzione di una copia lineare

Nel modello, è possibile creare più copie di un oggetto nella stessa direzione lineare.

  1. Selezionare gli oggetti da copiare.
  2. Nella scheda Modifica cliccare su Copia speciale > Trasla.

    Viene aperta la finestra di dialogo Copia - Trasla.

  3. Selezionare due punti o immettere le coordinate nelle caselle dX, dY e dZ.

    È inoltre possibile utilizzare una formula per calcolare gli spostamenti x, y e z. Ad esempio:

  4. Inserire il numero di copie.
  5. Cliccare su Copia.
  6. Per interrompere la copia, premere Esc
    Suggerimento:

    Se la finestra di dialogo è aperta ma il comando non è più attivo, cliccare sul pulsante Seleziona... per riattivare il comando.

Copia specificando una distanza dall'origine

È possibile copiare gli oggetti in una nuova posizione nel modello o nel disegno specificando una distanza dall'origine. Utilizzare la finestra di dialogo Inserisci una posizione numerica per specificare la distanza.

  1. Selezionare gli oggetti da copiare.
  2. Eseguire il comando Copia:
    • Nel modello, nella scheda Modifica cliccare su Copia.

    • Nel disegno, nella scheda Disegno cliccare su Copia > Copia.

  3. Selezionare l'origine per la copia.
  4. Spostare il cursore nella direzione in cui si desidera copiare gli oggetti ma non selezionare il punto.
  5. Inserire la distanza.

    Quando si inizia a digitare, Tekla Structures visualizza automaticamente la finestra di dialogo Inserisci una posizione numerica.

  6. Cliccare su OK.

Copia mediante selezione e trascinamento

È possibile copiare gli oggetti utilizzando il drag-and-drop.

  1. Nel menu File cliccare su Impostazioni e selezionare la casella di controllo Seleziona e trascina per attivare il comando.
  2. Selezionare gli oggetti da copiare.

  3. Tenere premuto il tasto Ctrl e trascinare gli oggetti in una nuova posizione.

    Il punto dal quale si inizia a trascinare (centro, angolo o punto intermedio) influisce sull'allineamento degli oggetti nella nuova posizione.

    Tekla Structures copia gli oggetti:

Nota:

Per copiare le etichette della griglia in un disegno, selezionare prima l'etichetta della griglia, quindi attivare il tasto di selezione Seleziona linea griglia oppure selezionare la grip dell'etichetta della griglia.

Copia di oggetti in un altro oggetto

Nel modello è possibile copiare armature, rivestimenti e saldature di officina tra oggetti simili e adattarli all'oggetto in cui vengono copiati. Ciò è utile, ad esempio, durante la specifica dei dettagli delle parti modellate in precedenza. Gli oggetti che è possibile copiare su altri oggetti possono avere dimensioni, lunghezza e rotazione diverse. Se si copiano o spostano oggetti da un assemblaggio o da un'unità di getto, Tekla Structures copia anche la struttura dell'assemblaggio, se possibile. Ad esempio, i sotto-assemblaggi vengono copiati come sotto-assemblaggi se viene trovato un oggetto principale.

Suggerimento:

Anziché copiare gli oggetti da un assemblaggio o un'unità di getto in altri assemblaggi o unità di getto identici, è possibile utilizzare lo strumento Editor batch. Editor batch rileva gli oggetti corrispondenti negli assemblaggi o nelle unità di getto di destinazione e modifica gli oggetti corrispondenti modificandone la geometria e le proprietà.

Se si copiano armature o rivestimenti e si desidera adattarli alla parte in cui vengono copiati, osservare le seguenti limitazioni:

  • Le grip dell'armatura o del rivestimento devono trovarsi negli spigoli della parte.

  • Le parti tra le quale si esegue la copia devono avere lo stesso numero di angoli della sezione trasversale.

  • Le parti circolari devono avere le stesse quote della sezione trasversale.

  1. Selezionare gli oggetti da copiare.
  2. Nella scheda Modifica cliccare su Copia speciale > Su un altro oggetto.
  3. Selezionare l'oggetto da copiare (oggetto di origine).
  4. Selezionare gli oggetti sui quali copiare (oggetto di destinazione).

Copia tutto il contenuto su un altro oggetto

Nel modello, è possibile copiare gli oggetti da un assemblaggio o un'unità di getto in altri assemblaggi o unità di getto simili, senza dover selezionare singolarmente ogni oggetto da copiare. Ciò è utile, ad esempio, quando si sono specificati i dettagli di un assemblaggio e si desidera copiare tutti questi dettagli in un altro assemblaggio simile.

Suggerimento:

Anziché copiare gli oggetti da un assemblaggio o un'unità di getto in altri assemblaggi o unità di getto identici, è possibile utilizzare lo strumento Editor batch. Editor batch rileva gli oggetti corrispondenti negli assemblaggi o nelle unità di getto di destinazione e modifica gli oggetti corrispondenti modificandone la geometria e le proprietà.

  1. Verificare che il tasto di selezione Seleziona gli assemblaggi Barra degli strumenti per selezione sia attivo.
  2. Selezionare l'assemblaggio o l'unità di getto da cui eseguire la copia (oggetto di origine).
  3. Nella scheda Modifica cliccare su Copia speciale > Tutto il contenuto a un altro oggetto.
  4. Selezionare gli assemblaggi o le unità di getto su cui eseguire la copia (oggetto di destinazione).

Come risultato, Tekla Structures copia gli oggetti seguenti:

  • Parti secondarie

  • Armatura, bulloni e saldature

  • Tagli, adattamenti e smussi bordo

  • Sotto-assemblaggi

  • Componenti

Nota:

Tekla Structures non copia le interruzioni getto o le parti secondarie create da un componente che ha creato anche la parte principale dell'assemblaggio. Se alcuni degli oggetti da copiare sono già presenti nell'assemblaggio o nell'unità di getto in cui eseguire la copia, Tekla Structures può creare oggetti duplicati. Tekla Structures avvisa in caso parti secondarie, armature e sotto-assemblaggi duplicati ma non in caso di bulloni, saldature, tagli o componenti duplicati.

Copia su un altro piano

Nel modello è possibile copiare gli oggetti dal primo piano specificato al secondo, terzo e così via. La posizione degli oggetti copiati in relazione al secondo piano, terzo e così via resta la stessa degli oggetti originali in relazione al primo piano.

  1. Selezionare gli oggetti da copiare.
  2. Nella scheda Modifica cliccare su Copia speciale > Su un altro piano.
  3. Selezionare il punto di origine del primo piano.
  4. Selezionare un punto sul primo piano nella direzione x positiva.
  5. Selezionare un punto sul primo piano nella direzione y positiva.
  6. Ripetere i passaggi da 3 a 5 per tutti i piani di destinazione.

Copia da modello

È possibile copiare gli oggetti da un altro modello in base ai numeri di fase. Tekla Structures copia le parti secondarie dal modello solo se appartengono alla stessa fase della parte principale. Ciò si applica anche agli oggetti componente.

  1. Nella scheda Modifica cliccare su Copia speciale > Da un altro modello.

    Viene aperta la finestra di dialogo Copia dal modello.

  2. Nella lista Database modello selezionare il modello da cui eseguire la copia.

    Questo è il modello di origine. Il modello di destinazione deve essere stato creato utilizzando la stessa versione di Tekla Structures o una versione più recente del modello di origine. Non è possibile copiare da una versione più recente a una versione precedente.

  3. Nella casella Numeri della fase immettere i numeri delle fasi da cui copiare gli oggetti, separati da spazi.

    Ad esempio, 2 7.

  4. Cliccare su Copia.
  5. Chiudere la finestra di dialogo.
Nota:

Se si copiano le interruzioni getto da un altro modello, le interruzioni getto copiate si adattano automaticamente al modello di destinazione. Verificare sempre che le interruzioni getto copiate si siano adattate correttamente.

È stato utile?
Precedente
Successivo