Personalizzazione delle finestre di dialogo dei componenti personalizzati

Tekla Structures
2021
Tekla Structures

Personalizzazione delle finestre di dialogo dei componenti personalizzati

Tekla Structures crea automaticamente una finestra di dialogo per ciascun componente personalizzato definito dall'utente. Ciascun componente personalizzato dispone di un file di input (.inp) che definisce i contenuti della finestra di dialogo del componente personalizzato. È possibile personalizzare la finestra di dialogo utilizzando lo strumento Editor delle finestre di dialogo del componente personalizzato.

In alternativa, gli utenti esperti possono possibile modificare manualmente i file di input della finestra di dialogo (.inp) Personalizzazione delle finestre di dialogo dei componenti personalizzati utilizzando un editor di testo in un editor di testo.

Modifica della finestra di dialogo di un componente personalizzato

Per aprire l'Editor delle finestre di dialogo del componente personalizzato, selezionare un componente personalizzato nel modello, cliccare con il pulsante destro del mouse e selezionare Modifica la finestra di dialogo del componente personalizzato.

Per

Operazione da eseguire

Visualizzare e modificare le proprietà degli oggetti

  1. Selezionare un elemento della finestra di dialogo. Ad esempio, una casella di testo.

  2. Cliccare su Modifica > Proprietà.

    Ora è possibile visualizzare e modificare le proprietà correnti dell'elemento della finestra di dialogo. Ad esempio, è possibile verificare che sia presente la casella di testo corretta in ciascuna etichetta della finestra di dialogo.

In alternativa, è possibile cliccare due volte sull'elemento della finestra di dialogo. Se l'elemento della finestra di dialogo non si apre per la visualizzazione e la modifica, provare a cliccare due volte sullo spazio sotto alla casella di controllo:

Aggiungere un elemento della finestra di dialogo

Cliccare su Inserire e selezionare un elemento adatto dalla lista. Le opzioni sono:

  • Scheda: per aggiungere una nuova scheda

  • Etichetta: per aggiungere un'etichetta per una casella di testo o una lista

  • Parametri: per aggiungere una casella di testo

  • Attributo: per aggiungere una lista

  • Parte: per aggiungere alcune proprietà di base della parte

  • Profilo: per aggiungere alcune proprietà del profilo di base

  • Immagine: per aggiungere un'immagine illustrativa del componente personalizzato

Aggiungere un'immagine

  1. Cliccare su Inserire > Immagine per visualizzare i contenuti della Cartella immagini impostati in Utilità > Opzioni.

  2. Selezionare un'immagine.

    Il formato dell'immagine deve essere bitmap (.bmp).

  3. Cliccare su Apri.

  4. Trascinare l'immagine nella posizione desiderata.

Aggiungere una scheda

  1. Cliccare su Inserire > Scheda.

  2. Cliccare due volte sulla nuova scheda.

  3. Immettere un nuovo nome, quindi premere Invio.

Nota:

Ciascuna scheda può contenere fino a 25 campi. Se sono presenti più di 25 campi visibili, Tekla Structures crea automaticamente un'altra scheda.

Mostrare o nascondere la griglia di pixel

Cliccare su .

Tekla Structures visualizza una griglia di pixel che facilita l'allineamento degli elementi nella finestra di dialogo.

Spostare un elemento della finestra di dialogo

Trascinare l'elemento della finestra di dialogo in una nuova posizione.

È inoltre possibile utilizzare gli shortcut da tastiera Ctrl+X (taglia), Ctrl+C (copia) e Ctrl+V (incolla). Ad esempio, per spostare un elemento della finestra di dialogo in un'altra scheda: selezionare l'elemento della finestra di dialogo, premere Ctrl+X, passare a un'altra scheda e premere Ctrl+V.

Selezionare più elementi della finestra di dialogo

Tenere premuto il tasto Ctrl e cliccare sugli elementi della finestra di dialogo oppure utilizzare la selezione area.

Rinominare una scheda o un'etichetta della casella di testo

  1. Cliccare due volte sulla scheda o sull'etichetta della casella di testo.

  2. Immettere un nuovo nome.

  3. Premere Invio.

Rimuovere un elemento della finestra di dialogo

  1. Selezionare l'elemento della finestra di dialogo da rimuovere.

  2. Premere Cancella.

Rimuovere una scheda

  1. Selezionare la scheda.

  2. Cliccare con il pulsante destro del mouse e selezionare Cancella.

Aggiungere immagini a una lista

  1. Selezionare l'elemento della lista.

  2. Cliccare su Modifica > Proprietà.

  3. Cliccare su Modifica valori.

  4. Cliccare su Sfoglia Aggiungi.

  5. Selezionare l'immagine da utilizzare e cliccare su Apri.

  6. Ripetere i passaggi 4-5 per tutte le altre immagini da utilizzare.

  7. Cliccare su OK per salvare le modifiche.

Salvataggio delle modifiche

Cliccare su File > Salva.

File di input del componente personalizzato

Ciascun componente personalizzato dispone di un file di input (.inp) che definisce i contenuti della finestra di dialogo del componente personalizzato.

Quando si crea un nuovo componente personalizzato, Tekla Structures crea automaticamente un file di input per il componente. Il file di input si trova nella cartella \CustomComponentDialogFiles nella cartella del modello. Il file di input ha lo stesso nome del componente personalizzato e l'estensione è .inp.

Quando si modifica un componente personalizzato, tutte le modifiche apportate al file di input andranno perse. Tuttavia, quando si modifica il componente personalizzato, Tekla Structures crea automaticamente una copia di backup del file di input. La copia di backup ha l'estensione file .inp_bak e si trova nella cartella \CustomComponentDialogFiles all'interno della cartella modello. Tekla Structures visualizza una notifica quando viene creato un file di backup.

Blocco o sblocco del file di input del componente personalizzato

È possibile bloccare il file di input del componente personalizzato (.inp) per evitare modifiche accidentali. Se il file è sbloccato e un'altra persona aggiorna il componente personalizzato nell'apposito editor, tutte le modifiche apportate alla finestra di dialogo andranno perse.

  1. Nel modello selezionare il componente personalizzato di cui si desidera bloccare o sbloccare il file di input.
  2. Cliccare con il pulsante destro del mouse e selezionare Modifica la finestra di dialogo del componente personalizzato.
  3. Nell'Editor delle finestre di dialogo del componente personalizzato cliccare sul pulsante Blocca/Sblocca .

Se il componente personalizzato viene modificato nell'Editor dei componenti personalizzati quando il file .inp è bloccato, il file .inp non sarà aggiornato. È comunque possibile modificare la finestra di dialogo nell'Editor delle finestre di dialogo del componente personalizzato anche se il file .inp è bloccato.

Impostazioni dell'editor delle finestre di dialogo del componente personalizzato

Nell'Editor delle finestre di dialogo del componente personalizzato cliccare su Utilità > Opzioni per visualizzare e modificare le impostazioni di base nell'editor delle finestre di dialogo del componente personalizzato. Cliccare su Utilità > Cambia lingua per modificare la lingua dell'Editor delle finestre di dialogo del componente personalizzato.

Opzione

Descrizione

Cartella immagini

La posizione della cartella immagini. Per ripristinare le impostazioni della cartella di default, cliccare su Default.

Cartella progetto

La posizione della cartella progetto. Quando si crea un file di input completamente nuovo cliccando su File > Nuovo e si salva, il file viene salvato nella cartella progetto. I file di input esistenti vengono salvati nella cartella del modello.

Larghezza parametro

La larghezza di default delle caselle di testo.

Larghezza attributo

La larghezza di default delle liste.

Spaziatura X della griglia

Spaziatura Y della griglia

La spaziatura della griglia di pixel nelle direzioni X e Y. Il valore di default è 5.

Snap alla griglia

Selezionare per mostrare o nascondere la griglia di pixel.

Opzione

Descrizione

Lingua

Selezionare una lingua dalla lista. Chiudere e riaprire l'editor delle finestre di dialogo per rendere effettiva la modifica. Le opzioni disponibili sono:

  • Auto: l'editor delle finestre di dialogo segue la lingua dell'interfaccia utente di Tekla Structures
  • English
  • Dutch
  • French
  • German
  • Italian
  • Spanish
  • Japanese
  • Chinese Simplified
  • Chinese Traditional
  • Czech
  • Portuguese Brazilian
  • Hungarian
  • Polish
  • Russian
  • Korean
Was this helpful?
Precedente
Successivo