Impostazioni di ambiente, azienda e progetto per gli amministratori

Tekla Structures
2019
Tekla Structures

Impostazioni di ambiente, azienda e progetto per gli amministratori

Impostazioni di ambiente

Impostazioni comuni

Tutte le impostazioni e i file uguali in tutti gli ambienti si trovano nella cartella \Tekla Structures\<version>\Environments\common. I file e le impostazioni specifici di ambiente si trovano in cartelle ambiente separate.

Il file env_global_default.ini si trova anche nella cartella \common. Il file determina le impostazioni standard ed è il primo file ad essere letto. Gli altri file di inizializzazione vengono letti dopo questo file e, se gli altri file contengono le stesse impostazioni, sostituiranno le impostazioni precedenti.

Impostazioni specifiche del paese

Le impostazioni specifiche del paese si trovano nelle cartelle ambiente e sono localizzate dall'ufficio/rivenditore Trimble di zona. La struttura delle cartelle degli ambienti può variare, ma sono presenti gli stessi tipi di impostazioni. Ad esempio, le impostazioni localizzate includono database profili, database materiali, report, filtri di selezione, filtri della vista, componenti e componenti personalizzati, macro, attributi utente e impostazioni dei disegni.

Impostazioni aziendali

Le impostazioni a livello di azienda sono principalmente impostazioni utilizzate all'interno dell'azienda per tutti i progetti. Queste impostazioni vengono impostate utilizzando XS_SYSTEM e XS_FIRM.

Per un'azienda di grandi dimensioni con filiali, le impostazioni possono essere utilizzate come segue:

  • XS_SYSTEM può contenere più percorsi e indica le impostazioni generali all'interno dell'azienda. Queste possono essere, ad esempio, logo aziendale, report, impostazioni di stampa, impostazioni di disegno, template. Queste impostazioni variano molto raramente e sono memorizzate su un server disponibile per tutti gli utenti. Ad esempio, se il logo aziendale viene aggiornato, deve essere sostituito solo in una posizione.
  • XS_FIRM indica la cartella azienda impostata dall'azienda o da una filiale. La cartella contiene tutte le impostazioni dell'azienda utilizzate nell'ufficio specifico. Queste possono essere, ad esempio, loghi, impostazioni di disegno, template, report o impostazioni di stampa.
  • XS_PROJECT indica la cartella di progetto. La cartella contiene, ad esempio, impostazioni di progetto, come i loghi per appaltatori e costruttori, o impostazioni di disegno.

Per ulteriori informazioni sull'ordine di ricerca delle cartelle, vedere Ordine di ricerca delle cartelle.

È inoltre possibile utilizzare le raccolte specifiche dell'azienda di Tekla Warehouse online o offline, nella propria rete. Utilizzare Trimble Identity per eseguire il download o l'installazione dalle raccolte online. Vedere anche Trimble Identity per Tekla Online services.

L'accesso alle raccolte offline è gestito con i diritti della cartella nella propria rete e a livello della raccolta nel file collections.json sul computer di ciascun utente.

 "collections" 
"\\\\server-A\\company\\Tekla Structures collection" 
		

Il file collections.json può essere suddiviso con persone selezionate copiandolo nella cartella C:\Users\Public\Documents\Tekla\Tekla Warehouse\.

Modelli prototipo

È possibile salvare un modello con le impostazioni richieste e utilizzare il modello come prototipo per creare nuovi modelli. Ciò può essere molto utile se l'azienda lavora su diversi tipi di progetti, come garage per parcheggi, edifici per uffici, ponti e costruzioni industriali.

Quando si crea un modello prototipo, iniziare sempre creando un nuovo modello vuoto. Questo perché i vecchi modelli utilizzati in progetti reali non possono essere ripuliti completamente. Possono infatti contenere informazioni in eccesso che determinano l'aumento delle dimensioni del modello anche se si eliminano tutti gli oggetti e i disegni dal modello.

Per creare un modello prototipo:

  1. Creare un nuovo modello e assegnargli un nome univoco.
  2. Aggiungere nel modello i profili desiderati, i componenti personalizzati e altri elementi necessari.
  3. Nel menu File cliccare su Salva come > Save .

    È necessario salvare il modello per includere componenti personalizzati nel file xslib.db1. Se non si salva il modello, i componenti personalizzati non vengono inseriti nel modello prototipo.

  4. Nel menu File cliccare su Salva come > Salva come modello prototipo .
  5. Immettere un nome per un modello prototipo e selezionare i cataloghi, i template di disegni, i modelli di report e le sottocartelle del modello da includere nel modello prototipo.
  6. Cliccare su OK.

    Di default, la cartella del modello prototipo viene salvata nella cartella ambiente in ..ProgramData\Trimble\Tekla Structures\<version>\environments\<your environment>\. La posizione esatta della cartella può variare in base al proprio ambiente e ruolo. Utilizzare l'opzione avanzata XS_​MODEL_​TEMPLATE_​DIRECTORY per definire un percorso diverso.

È possibile scaricare, condividere e memorizzare modelli prototipo in Tekla Warehouse. L'immagine di seguito mostra un esempio di modello prototipo in Tekla Warehouse.

Il pulsante Inserisci nel modello in Tekla Warehouse installa il modello prototipo direttamente nella cartella indicata da XS_MODEL_TEMPLATE_DIRECTORY. È possibile utilizzare immediatamente il prototipo quando si crea un nuovo modello.

Modelli prototipo nell'aggiornamento della versione di Tekla Structures

Si consiglia di aggiornare i propri modelli prototipo durante l'aggiornamento della versione di Tekla Structures.

Per caricare un modello prototipo:

  1. Creare un nuovo modello utilizzando un modello prototipo esistente.
  2. Assegnare al modello lo stesso nome utilizzato nella versione precedente di Tekla Structures.
  3. Aprire una vista 3D.
  4. Nel menu File cliccare su Diagnose and repair > Diagnose model .
  5. Nella scheda View cliccare su Screenshot > Project thumbnail per creare una miniatura del progetto o aggiungere un'immagine personalizzata denominata thumbnail.png nella cartella modello.

    La dimensione preferita dell'immagine è 120 x 74 pixel.

  6. Nel menu File cliccare su Salva come > Save .

    Se non si esegue questa operazione, viene visualizzato un messaggio per avvertire che il modello è stato creato con una versione precedente.

  7. Nel menu File cliccare su Salva come > Salva come modello prototipo .
  8. Selezionare i cataloghi, i template di disegni, i modelli di report e le sottocartelle del modello da includere nel modello prototipo.
  9. Cliccare su OK.
  10. Rimuovere manualmente tutti i file *.db (file di database d'ambiente, database di opzioni) dalla cartella del modello.

    I file *.bak , *.log e xs_user vengono automaticamente rimossi dalla cartella del modello.

    Non rimuovere i file .idrm ( db.idrm e xslib.idrm ) poiché fanno parte del modello.

    Il modello prototipo viene salvato in una posizione indicata da XS_MODEL_TEMPLATE_DIRECTORY.

    Si dispone ora di un'immagine di esempio per il modello prototipo. Il catalogo Applicazioni e componenti ora è anche ordinato e facilmente utilizzabile.

Personalizzazione di report e disegni

Se la propria azienda dispone già di template grafici in formato DXF, DWG o DGN, è possibile convertirli in template di Tekla Structures. Per istruzioni dettagliate sull'esecuzione di questa operazione, vedere le informazioni sui file di Microstation e AutoCAD nell'Aiuto dell'Editor template.

Per informazioni su come creare i template e report personalizzati, vedere l'Aiuto, i Report e i Template dell'Editor template.

Template di clonazione per i disegni

È necessario prendere in considerazione la clonazione dei disegni quando:

  • Nel modello sono presenti molte parti, assemblaggi o unità di getto simili.
  • È necessario creare disegni di officina, assemblaggio o unità di getto di parti, assemblaggi o unità di getto simili.
  • I disegni richiedono molte modifiche manuali.

Ad esempio, è possibile creare un disegno per una capriata, modificarlo, quindi clonarlo per capriate simili. Dopodiché, è sufficiente modificare i disegni clonati laddove le capriate sono diverse.

Il disegno clonato potrebbe contenere più parti rispetto al disegno originale. Le proprietà delle parti, le marche, le note associative e gli oggetti testuali correlati sono clonati da una parte analoga del disegno originale.

Template di clonazione nel Catalogo disegni principali

È possibile clonare i disegni utilizzando i template del Catalogo disegni principali. I template di clonazione nel Catalogo disegni principali possono inoltre essere utilizzati in altri modelli. Possono essere utilizzati in progetti che hanno lo stesso tipo di disegni.

Per creare i template di clonazione:

  1. Seleziona un disegno in Gestione documenti.
  2. Cliccare con il pulsante destro del mouse e selezionare Aggiungi al catalogo disegni principali , quindi inserire le proprietà richieste.

Il template di clonazione è disponibile in Template di clonazione nel Catalogo disegni principali. Per utilizzare i template di clonazione in altri modelli, aprire il Catalogo disegni principali nel modello, cliccare sul pulsante sulla barra degli strumenti e aggiungere il modello in cui sono salvati i template.

Per ulteriori informazioni sul Catalogo disegni principali e sui template di clonazione, vedere Creazione di disegni nel Catalogo disegni principali.

Impostazioni del progetto

Creazione della cartella componenti personalizzata

In genere, in un progetto vengono utilizzate solo alcune connessioni e componenti diversi. Per assicurarsi che tutti gli utenti del progetto usino gli stessi componenti e li trovino più velocemente, si consiglia di creare una cartella dei componenti personalizzata.

  1. Cliccare sul pulsante Applicazioni e componenti nel pannello laterale per aprire il catalogo Applicazioni e componenti.
  2. Creare un nuovo gruppo per il progetto: Cliccare con il pulsante destro del mouse sul catalogo e selezionare Nuovo gruppo.
  3. Aggiungere componenti al gruppo: Selezionare i componenti nel catalogo, cliccare con il pulsante destro del mouse e selezionare Aggiungi al gruppo. Selezionare quindi il gruppo al quale vengono aggiunti i componenti. È inoltre possibile trascinare i componenti selezionati in un altro gruppo.
  4. Nascondere i gruppi non necessari: Selezionare il gruppo, cliccare con il pulsante destro del mouse e selezionare Nascondi/Mostra.
Tip:

Nel catalogo Applicazioni e componenti utilizzare i comandi in Accedi a funzioni avanzate > Gestione catalogo per modificare le definizioni del catalogo. Per ulteriori informazioni, vedere Personalizzazione del catalogo Applicazioni e componenti e XS_​COMPONENT_​CATALOG_​ALLOW_​SYSTEM_​EDIT.

Per ulteriori informazioni sul catalogo Applicazioni e componenti , vedere Modalità di utilizzo del catalogo Applicazioni e componenti.

Definizione delle proprietà di progetto

Le informazioni sul progetto sono necessarie molte volte durante un progetto. Definire le informazioni sul progetto all'inizio di un progetto, in modo che report e disegni visualizzino automaticamente le informazioni corrette. È inoltre possibile aggiornare le proprietà di progetto durante il progetto.

  1. Nel menu File cliccare su Proprietà progetto.
  2. Modificare le proprietà del progetto.

    Quando si modificano le proprietà, Tekla Structures evidenzia le proprietà modificate in giallo nel pannello proprietà.

  3. Quando si è pronti con le modifiche, cliccare su Modifica per applicarle.

Creazione e modifica di template e report

È possibile modificare i report e i template esistenti oppure creare template personalizzati utilizzando l'Editor template. Per aprire l'Editor template, cliccare su File > Editor > Editor template oppure cliccare due volte su una tabella esistente in un disegno aperto per aprire lo strumento. Per ulteriori informazioni, vedere Template Editor User's Guide.

Se i template personalizzati si trovano in una cartella protetta, i template sono di sola lettura e non è possibile salvare un template modificato in una cartella protetta. In tal caso, eseguire Tekla Structures come amministratore.

Impostazione delle stampanti

Tekla Structures utilizza i driver di Windows per scrivere i dati di stampa direttamente nell'interfaccia del dispositivo di stampa Windows. È possibile stampare i disegni come file PDF, salvarli come file di stampa ( .plt ) per la stampa con stampante/plotter oppure stamparli su una stampante selezionata. Per stampare su più formati carta, è necessario modificare il file drawingsizes.dat. Per ulteriori informazioni, vedere File di configurazione utilizzati nella stampa. È inoltre possibile modificare lo spessore linea dei disegni stampati. Per ulteriori informazioni, vedere Stampa su un file .pdf, file di stampa (.plt) o su una stampante e Spessore linea nei disegni.

È possibile modificare il modo in cui Tekla Structures denomina automaticamente i file .pdf e i file di stampa, utilizzando determinate opzioni avanzate specifiche del tipo di disegno. Per ulteriori informazioni, vedere Personalizzazione dei nomi dei file di uscita di stampa.

Was this helpful?
Precedente
Successivo