Selezionare gli oggetti da includere in un report utilizzando i GUID

Tekla Structures
2018
Tekla Structures

Selezionare gli oggetti da includere in un report utilizzando i GUID

È possibile selezionare gli oggetti da includere nei report utilizzando i relativi GUID (Globally Unique Identifier).

  1. Creare un template utilizzato per creare il report.
    1. Nel menu File cliccare su Editor > Editor Template .
    2. Nell'Editor Template cliccare su File > Nuovo .
    3. Selezionare il template testuale e cliccare su OK.
    4. Aggiungere una riga per il GUID.
      • Cliccare su Inserisci > Componente > Riga .

        Selezionare un tipo di contenuto per la riga, quindi cliccare su OK.

      • Cliccare su Inserisci > Testo e immettere il testo guid: , Guid: o GUID:. Cliccare su OK.

        Ciò consente di selezionare gli oggetti nel modello.

      • Cliccare su Inserisci > Campo valore . Cliccare su un punto per definire la posizione del campo nella riga. Viene visualizzata la finestra di dialogo Selezionare Attributi che richiede di selezionare un attributo per il campo del valore.

        Selezionare l'attributo GUID e cliccare su OK.

    5. Aggiungere la quantità necessaria di righe nel template.
    6. Cliccare su File > Salva come .

      Immettere un nome per il template e cercare la cartella ..\environment\<your_environment>\template. Utilizzare l'estensione nome del file .rpt.

  2. Creare un report in base al template di report salvato.
    1. Nella scheda Disegni & Reports cliccare su Report.
    2. Selezionare il template di report creato dalla lista.
    3. Cliccare su Crea da tutto.

      Tekla Structures visualizza il report.

  3. Cliccare su una riga che contiene un numero GUID nel report.

    Tekla Structures seleziona l'oggetto corrispondente nella vista attiva del modello.

È stato utile?
Precedente
Successivo