Export BVX (ML027)

Tekla Structures - Not version-specific
Environment
France
Netherlands

 

Image
001.png

 

Fonction : générer des données de production pour les machines à bois Hundegger SpeedCut.

Processus BVX : Le format Hundegger BVX, comme le format BTL, utilise des "processus" pour décrire des opérations spécifiques. La différence entre les deux "langages" réside dans le format. Alors que les processus BTL sont décrits dans un format propriétaire, le format BVX est basé sur un format XML plus ouvert. Quoi qu'il en soit, chaque opération est un processus. Par exemple, lorsqu'une poutre en bois doit être sciée à l'aide d'un seul trait de scie, il convient d'utiliser le processus BVX "Couper". Et lorsqu'une pièce doit être équipée d'une "queue d'aronde", c'est le processus BVX "Queue d'aronde" qui doit être appliqué.
Le processus BVX à appliquer est déterminé par l'opération modélisée sur le composant dans Tekla Structures. Les opérations nommées dans Export BVX (ML027) peuvent être modélisées dans Tekla Structures à l'aide de composant. Pour les autres opérations, souvent plus complexes, l'utilisateur doit spécifier le processus à appliquer en modélisant un volume négatif et en lui donnant un nom spécifique.

Cliquez  ici pour obtenir une description spécifique à BVX de l'étendue des opérations actuellement prises en charge par l'outil d'exportation BVX.

Cliquez  ici pour des lignes directrices expliquant comment modéliser les pièces en bois afin que les données de production soient correctes pour les machines à bois.

 

 

Onglet Paramètres

Image
BVX_Export_Parametre_2605_FR

Dans l'onglet Paramètres vous pouvez définir les paramètres d'export.

OptionDescription
Export

Exporter les pièces concernées. Les options sont les suivantes :

● Pièces sélectionnées

● Toutes les pièces

Fonctionnement du filtre

Les options sont les suivantes :

● Le filtre n'est pas utilisé. Aucun filtre de sélection n'est appliqué.

● Exclure les pièces filtrées. Les éléments qui entrent dans le filtre de sélection suivants NE SONT PAS exportés.

● Uniquement les pièces filtrées Seuls les éléments entrant dans le cadre du filtre de sélection sont exportés.

FiltreCe champ est lié au champ Fonctionnement du filtre. Lorsque vous sélectionnez Exclure les pièces filtrées ou Uniquement les pièces filtrées dans le champ Opération de filtre, il est possible de sélectionner un filtre de sélection dans ce champ. Si vous choisissez Le filtre n'est pas utilisé, ce champ est grisé.
Dessiner les axes

Il est possible d'afficher un système de coordonnées local pour chaque composant à l'aide de lignes de construction dans le modèle Tekla Structures. Cela peut s'avérer utile pour l'analyse des problèmes. Lors de l'export de grandes quantités de pièces, il est recommandé de désactiver cette fonctionnalité. Cela accélérera le processus d'exportation. Les options sont les suivantes :

● Oui

● Non

Appliquer des filtres d'export

Indiquez si vous souhaitez appliquer un filtre d'export. Dans l'onglet Filtres d'export, tous les filtres d'export sont ajoutés. Les options sont les suivantes :

● Oui

● Non

Pièces du groupe

Les options sont :

● Par pièce dans assemblage. Le nombre d'occurrences d'une référence est indiqué par repère d'assemblage.

● Par pièce. Le nombre d'occurrences d'un repère de pièce particulier est noté. Le repère d'assemblage n'est pas indiqué.

● Par assemblage. Pour l'assemblage, chaque pièce est écrite sur une ligne distincte.

● Pas de regroupement. La sortie contient une ligne séparée pour chaque ligne individuelle et le repère d'assemblage n'est pas écrit.

Dimensions des pièces

Les options sont les suivantes :

● Du catalogue de profils

● Du modèle

Afficher le fichier Log

Affiche le fichier journal créé pendant l'export. En cas d'erreur lors de l'export, le fichier Log indiquera l'ID de l'objet en question. Sélectionnez la ligne correspondante et l'objet dans le modèle Tekla Structures est sélectionné. Les options sont les suivantes :

● Non

● Oui

Afficher les types d'évènements

Sélectionnez les informations qui seront écrites dans le fichier Log. Les options sont les suivantes :

● Tous.Les informations et les erreurs sont affichées.

● INFO. Seules les informations des processus correctement exportés sont affichées.

● ERROR. Seules les informations des processus qui n'ont pas été exportés sont affichées.

Réécrire le fichier Log

Indiquez si les fichiers journaux existants peuvent être écrasés ou si un nouvel export ajoutera les informations au fichier Log existant. Les options sont les suivantes :

● Oui

● Non

Versions du fichier BVX

Sélectionnez la version du fichier à exporter. Les options sont les suivantes :

● BVX1. Profils modélisés avec la commande Poutre acier.

● BVX2. Plaques modélisées avec la commande Plat par contour.

Orientation pièce

Orientation de la pièce sur la machine. Les options sont les suivantes :

Image
004.png
Image
005
Image
006.png

 

Précision

Orientation de la pièce sur la machine.

Distance. Nombre de décimales, de préférence au moins 1.

Angle. Nombre de décimales, de préférence au moins 2.

Chemin d'accès exportDéfinir l'emplacement des fichiers BVX.

Onglet Filtres d'export

Image
BVX_Export_FiltresExport_2605_FR

Dans l'onglet Filtres d'export, il est possible de définir des filtres d'export supplémentaires. Pour les projets relativement petits, il est possible d'exporter toutes les pièces dans un seul fichier, quelles que soient les différentes propriétés des pièces à exporter. Dans le cas de projets plus importants, par exemple divisés en phases ou regroupés par attribut d'utilisateur (UDA), il peut être souhaitable de créer un fichier d'export d'une phase particulière ou d'un groupe particulier de pièces, voire d'une combinaison des deux.

OptionDescription
Critère

Sélectionnez le critère souhaité dans la liste déroulante. En fonction de la propriété sélectionnée dans la liste , vous pouvez définir la valeur correspondante dans le champ Export.

Exemple

Image
BVX_Export_FiltresExport1_2605_FR
Activer

Indiquer si le critère doit être actif. Les options sont les suivantes :

● Oui

● Non

Nom UDA

Lorsque vous sélectionnez UDA sous Critère, une boîte de dialogue apparaît pour vous permettre de saisir le nom de l'UDA. Ce champs doit être saisi en lettres capitales.

Exemple

Image
BVX_Export_FiltresExport2_2605_FR
Export

Indiquer les composants à exporter en fonction du critère.

Exemple

Image
BVX_Export_FiltresExport3_2605_FR

 

Seules les pièces avec le matériau EPICEA sont exportées.

Générer

Les options sont les suivantes :

Un fichier pour toutes les pièces

● Fichiers par valeur

Préfixe du filtreLe préfixe du filtre dépend du critère et est défini automatiquement lors de la sélection d'un critère. Il peut encore être ajusté manuellement si nécessaire.

Onglet Configuration

Image
BVX_Export_Configuration_2605_FR

Dans l'onglet Configuration, définissez les propriétés supplémentaires qui seront exportées.

OptionDescription
Attributs libresVous pouvez donner à la propriété un nom que vous pouvez choisir librement. Si rien n'est saisi, le nom de la propriété est choisi.
Caractéristiques

Propriétés pouvant être exportées vers le fichier BVX. Les options sont les suivantes :

Vide

Classe

Phase

Numéro de lot

GUID

UDA

●  Texte

Finition

Rapport de propiété

Nom UDACe champ est activé lorsque la propriété UDA est sélectionnée. Ce champ vous permet de saisir l'attribut utilisateur en lettres capitales.

Onglet Filtre opérations

Image
BVX_Export_FiltresOperations_2605_FR

Dans l'onglet Filtre opérations, définissez les opérations.

Option Description
Opérations à exporterSpécifie l'opération à exporter.
Noms prédéfinisLe nom réservé à cette opération.
Noms supplémentairesVous pouvez éventuellement attribuer un nom supplémentaire à une opération (plusieurs noms sont possibles). Remarque : le nom des volumes négatifs (antimatières) ne doivent jamais comporter d'espace, sauf s'ils sont prédéfinis.

 

OpérationNoms prédéfinisSituationComposant
PerçageDrilling
Image
017.png
 
RainureSlot
Image
018.png
 
Mi-boisLap
Image
019.png
 
Encoche (de chevron)Birds Mouth
Image
020.png
 
PocheHousing
Image
021.png
 
Double entaille / moisageBlock House Half Lap
Image
022.png
 
Coupe de scieCut
Image
023.png
 
Coupe d'empannonDouble cut
Image
BVX Export
 
DélardementLongitudinal cut
Image
BVX Export
 
Double délardementRidge cut
Image
Snag_18898b3.png
Ridge/Valley cut (d153)
Encoche de noueValley cut
Image
025.png
Ridge/Valley cut (d153)
Mi-bois de faîteRidge lap
Image
026.png
 
EmbrèvementBrace shoulder
Image
027.png
Lap Verbinding (j152)
FeuillureRabbet
Image
028.png
 
RainureGroove
Image
029.png
 
MarqueurAftekenen
Image
030.png
Houtverbinding Aftekenen (m116)

Onglet Filtre opérations 2

Image
BVX_Export_FiltresOperations2_2605_FR

Dans l'onglet Filtre opérations, définissez les opérations.

OpérationNoms prédéfinisSituationComposant
TenonTenon
Image
031.png
Tenon et Mortaise (j150)
MortaiseMortise
Image
Snag_1b9f81a.png
Tenon et Mortaise (j150)
Tenon Q.A non traversantDovetail Tenon
Image
034.png
Queue d'aronde non traversante (j151)
Mortaise Q.A non traversantDovetail Mortise
Image
033.png
Queue d'aronde non traversante (j151)
Tenon queue-d'arondeSwallow Tenon
Image
BVX Export
Queue d'aronde traversante (j158)
Mortaise queue-d'arondeSwallow Mortise
Image
BVX Export
Queue d'aronde traversante(j158)
Coupe en arcArch Cut
Image
BVX_041
Usinage arc de cercle (m159)
ContourContour
Image
BVX_040
Contour (m149)
Contour profilProfile Contour
Image
BVX_039
Usinage extrémité (d142)
Débord de toitRoof Overhang Débord de toit (D084)
Face avant pocheHousing Front  

Onglet Filtre opérations BVX2

Image
BVX_Export_FiltresOperationsBVX2_2605_FR

Dans l'onglet Onglet Filtre opérations BVX2, vous définissez les opérations pour les plats. Via l'exportation BVX, il est également possible d'exporter les opérations des plats vers la machine. Cela se fait via BVX2.

OpérationNoms prédéfinisSituationComposant
PerçageDrilling  
RainureSlot  
LamageBlind Slot  
FenteSlit  
PasStep  
EncocheBlind Step  
En ligneInline  
ContourContour  
RainureGroove   
LangueTongue  
Sortie de texte   
Coupe de scieCut  

Onglet Opérations

Image
BVX_Export_Operations_2605_FR

Dans l'onglet Opérations, il est précisé que les volumes négatifs (antimatière) basés sur des profils ronds et tubulaires pleins portant la lettre D et dont le diamètre est inférieur ou égal à 50 mm doivent être exportés en tant que processus "Perçage".

OptionDescription
Préfixe du profil et diamètre maximalDéfinir le préfixe de la section transversale et le diamètre maximal pouvant être traité par la machine. Si un volume négatif est utilisé dans le modèle qui correspond aux deux conditions définies, le volume négatif sera automatiquement exécuté comme un processus de "Perçage", quelle que soit la désignation.
Scinder Mi-boisChoix du procédé à utiliser en combinaison avec l'opération de sciage en cas de fractionnement de l'opération. L'option boîtier/lap/fente dépend elle aussi de la machine.
Scinder si la longueur Mi-bois >Si le fractionnement de l'encoche en plusieurs opérations n'est pas souhaité, il est possible de l'éviter en réglant la valeur "Scinder si la longueur Mi-bois" sur une valeur supérieure à la plus grande longueur possible de l'encoche. Si cette valeur est inférieure à la longueur de l'entaille, le processus sera divisé.
Longueur max du blocDépend de la Scinder si la longueur Mi-bois >.
Largeur Poche intermédiaire

Longueur du bloc (chutes) à découper. Si ces cubes sont trop longs, cela peut entraîner des blocages et des dysfonctionnements dans la machine.

En fonction des dimensions de la machine et d'autres conditions limites.

Largeur Poche extrémitéLa largeur de "poche intermédiaire" est en fait la largeur/diamètre de l'outil utilisé pour réaliser les fentes intermédiaires.
Ajouter une coupe en profondeurUne profondeur de coupe supplémentaire est utilisée pour tenir compte des tolérances dans les dimensions du profil.
Profondeur de coupe maxLa distance dépend du diamètre de la lame de scie dans la machine.
Export des perçages par type de boulon

Indiquez les types de boulons à exporter ou à exclure de l'export. Les options disponibles sont les suivantes :

 

  • Tous
  • Montage
  • Atelier

Ces paramètres se trouvent dans les propriétés du boulon.

Image
BVX_Export_OperationsTypeBoulons_2605_FR
Ignorez les boulons sans trou

Les boulons sont automatiquement reconnus comme des trous. Si aucun trou n'est présent au niveau d'un boulon (ou d'un groupe de boulons), vous pouvez choisir de les ignorer.

 

Ces paramètres sont indiqués dans les propriétés du boulon sous « Trou spécial » avec le type de trou spécial « Aucun ».

Image
BVX_Export_OperationsAucunTrou_2605_FR

Les options sont les suivantes :

  • Oui
  • Non
Opération longitudinale sur toute la longueurIl est possible d'effectuer une opération sur toute la longueur de la pièce. Vous trouverez ci-dessous les différentes options. 
Modélisé commeModélisez une opération en tant que « Plan de Coupe » ou en tant que « Découpe».
Plan de coupe: Modélisez une opération de coupe sur toute la longueur de la pièce. Lorsque cette coupe est modélisée avec un angle de 90°, BVX peut exporter une opération de coque.
Découpe: modéliser une antimatière portant le nom de Longitudinal Cut. Cette découpe ne peut pas être réalisée à un angle de 90° par rapport à la pièce et doit donc toujours présenter un léger biseau compris entre 1° et 89°. Vous trouverez un exemple de cette opération dans l'onglet Filtre opérations.
Exporter commeLorsque l'opération est modélisée comme une découpe transversale ou longitudinale, il reste à choisir le mode d'export de cette opération. Les options disponibles sont les suivantes :
Image
BVX_045
La pièce est découpée. Le reste est ensuite fraisé.
Image
BVX_046
L'opération s'effectue par sciage. La partie restante est sciée, ce qui permet de la conserver intacte.

Onglet Info

Informations concernant la date de construction de l'outil. Cette date peut être différente de celle de l'outil que vous utilisez, mais le contenu peut être le même. Cette date peut vous être demandée lorsque vous contactez le service d'assistance.

Image
BVX_Export_Infos_2605_FR

Tous droits réservés. Aucune conclusion ne peut être associée à la représentation des images par rapport aux systèmes d'exploitation sous lesquels Tekla Structures fonctionne. Ce travail est soumis à la licence internationale Creative Commons Attribution-NonCommercial-NoDerivatives 4.0. Pour consulter une copie de cette licence, visitez le site http://creativecommons.org/licenses/by-nc-nd/4.0/ ou envoyez une lettre à Creative Commons, 444 Castro Street, Suite 900, Mountain View, California, 94041, USA.

Cela a-t-il été utile?
Soumettre