Exemple : Configuration de calques et export au format DWG (ancien export)

Tekla Structures
2023
Tekla Structures

Exemple : Configuration de calques et export au format DWG (ancien export)

Cet exemple illustre la définition de calques et l’export de types de ligne d’un calque particulier vers leurs propres sous-calques lors d’un export DWG.

Exemple : créer un filtre de sélection pour l'export DWG

Pour créer un filtre de sélection :

  1. Dans le modèle, cliquez sur le bouton Filtre de sélection .
  2. Dans la boîte de dialogue Groupe d'objets - Filtre de sélection, cliquez sur Nouveau filtre.
  3. Ajoutez les nouvelles règles de filtre.
    1. Créez une règle de filtre qui sélectionne des pièces en fonction du nom POUTRE.
    2. Créez une règle de filtre qui sélectionne des pièces en fonction S* du matériau (comme en acier).
  4. Enregistrez le filtre sous steel-beam.

Exemple : création de calque pour export au format DWG

Après avoir créé un filtre de sélection, continuez en créant les calques que vous souhaitez avoir dans le fichier DWG exporté.

Pour créer les calques dont vous souhaitez disposer dans le fichier DWG exporté :

  1. Dans le menu Fichier, cliquez sur Exporter > Dessins.
  2. Accédez à l'onglet Options calque.
  3. Cliquez sur Paramètres, puis sur Modifier calques.
  4. Cliquez sur Ajouter pour ajouter un nouveau calque.

    Créez des calques séparés pour les lignes pleines (steel-beam-layer) et les arêtes cachées (steel-beam-layer-H) des poutres en acier.

  5. Configurez la couleur des calques.

    Configurez les lignes pleines en rouge et les arêtes cachées en bleu.

  6. Cliquez sur OK pour accepter les remplacements.

Exemple : créer une règle pour l'export de dessin DWG et assigner un calque à la règle

Après avoir créé des calques, vous pouvez continuer en créant une règle pour exporter un groupe d'objets vers un calque et affecter le calque à la règle créée.

Pour créer une règle pour exporter un groupe d’objets vers un calque et assigner le calque à la règle créée :

  1. Cliquez avec le bouton droit de la souris sur une règle de pièce d'objet de modèle et sélectionnez Ajouter critère niveau suivant.
  2. Entrez un nom pour la règle (steel-beam-rule) et sélectionnez le filtre de sélection que vous avez créé pour les poutres en acier (steel-beam).

  3. Cliquez sur OK.
  4. Pour assigner un calque à une règle, double-cliquez sur la ligne sous steel-beam-rule et sélectionnez un calque, steel-beam-layer dans ce cas.
  5. Cliquez sur OK.

  6. Enregistrez les paramètres de la règle sous le nom example1 en utilisant le bouton Enregistrer sous.

  7. Fermez la boîte de dialogue en cliquant sur OK.

Exemple : définir un type de ligne personnalisé pour l'export DWG

Après avoir créé une règle, continuez en définissant un type de ligne personnalisé pour les lignes continues dans les fichiers DWG exportés. Dans cet exemple, vous allez ajouter certaines définitions de type de ligne.

Pour définir un type de ligne personnalisé :

  1. Ouvrez le fichier TeklaStructures.lin dans un éditeur de texte ( ..\ProgramData\Trimble\Tekla Structures\<version>\environments\common\inp ).
  2. Ajoutez la définition du type de ligne dans le fichier :

  3. Enregistrez le fichier. Vérifiez que l'extension de fichier n'est pas remplacée.

Exemple : définition des types de ligne et leurs épaisseurs pour les calques dans les exports DWG

Après la définition d'un type de ligne personnalisé, continuez en modifiant le fichier LineTypeMapping.xml et en définissant les types de ligne et les épaisseurs.

Pour définir les types de ligne et les épaisseurs :

  1. Ouvrez le fichier LineTypeMapping.xml ( ..\ProgramData\Trimble\Tekla Structures\<version>\environments\common\inp ) dans un éditeur de texte.
  2. Ajoutez les correspondances des types de ligne pour les calques comme indiqué dans le cadre bleu de l’image ci-dessous. Ne touchez pas aux lignes du cadre supérieur rouge.
  3. Enregistrez le fichier. Vérifiez que l'extension de fichier n'est pas remplacée.

  1. Les lignes sont présentes dans le calque steel-beam-layer.
  2. Les lignes sont dessinées avec XKITLINE00 (lignes pleines).
  3. Les lignes sont exportées en lignes CONTINUOUS au format DWG. La couleur de la ligne dans le fichier DWG était déjà définie dans les propriétés du calque (rouge). L'épaisseur de la ligne dans le fichier DWG est 0.35.
  4. Les lignes sont présentes dans le calque steel-beam-layer.
  5. Les lignes sont dessinées avec XKITLINE02 (arêtes cachées).
  6. Les lignes sont exportées en lignes DASHED dans un calque séparé appelé steel-beam-layer-H dans le fichier DWG. La couleur de la ligne dans le fichier DWG était déjà définie dans les propriétés du calque (bleu). L'épaisseur de la ligne dans le fichier DWG est 0.35.

Exemple : exporter le dessin vers DWG

Après avoir défini tous les paramètres du calque, continuez en exportant le dessin. Avant d'exporter le dessin vers DWG, vérifiez que toutes ses propriétés correspondent à vos exigences.

Pour exporter le dessin :

  1. Ouvrez le dessin que vous souhaitez exporter.
  2. Dans le menu Fichier, cliquez sur Export dessins.
  3. Saisissez le nom du fichier d'export.
  4. Définissez l’option Type sur DWG.
  5. Accédez à l’onglet Options du calque et chargez les paramètres de règle du calque que vous avez enregistrés auparavant sous le nom example1.
  6. Cochez les cases suivantes : Utiliser la conversion avancée de calques et types de ligne, Inclure calques vides et Couleur de l’objet pour chaque calque.
  7. Recherchez le fichierLineTypeMapping.xml.
  8. Accédez à l’onglet Options, configurez l’échelle pour l’export et cochez la case Exporter objets comme groupes et, si vous le souhaitez, Coupe ligne avec textes et Exporter les lignes personnalisées en tant que lignes éclatées.
  9. Cliquez sur Exporter.

Ouvrez le fichier DWG à l’aide d’un logiciel d’affichage DWG approprié. Vous pouvez constater que les lignes pleines de la poutre en acier sont présentes sur un calque et les arêtes cachées sur un autre. Vous pouvez également constater que les colonnes ne correspondent pas aux règles de calque que vous avez définies, puisqu’elles sont traitées en fonction d’autres règles.

Voici des exemples illustrant comment la sélection ou non de l'option Coupe lignes avec texte affecte le résultat.

Dans l’exemple suivant, l’option Coupe lignes avec texte est sélectionnée.

Dans l’exemple suivant, l’option Coupe lignes avec texte n’est pas sélectionnée.

Cela a-t-il été utile?
Précédent
Suivant