Améliorations de la modélisation

Tekla Structures
2021
Tekla Structures

Améliorations de la modélisation

Tekla Structures 2021 introduit de nombreuses améliorations en matière de modélisation.

Améliorations dans la création de solide de pièce

Tekla Structures 2021 utilise l’instanciation dans la création de solide de pièce en acier et en béton. Cela améliore les performances globales car la même géométrie solide de pièce peut être utilisée à plusieurs endroits dans le modèle sans avoir besoin de recréer des géométries similaires à plusieurs reprises. Moins de mémoire est également nécessaire pour stocker les géométries de solides dans le tampon de solide, car une seule entrée de géométrie est stockée pour toutes les instances similaires. En fonction de la répétition des pièces similaires dans le modèle, des performances améliorées peuvent être observées dans l’ouverture, le repérage et les exports de la vue du modèle, par exemple.

Les géométries de solides sont maintenant créées et stockées dans les coordonnées locales des pièces, ce qui améliore la précision. Cela améliore le repérage car les pièces seront assignées dans la même série, quel que soit l’endroit où les pièces sont situées dans les coordonnées globales du modèle.

Nouvel aperçu lorsque vous copiez ou déplacez des objets

Lorsque vous copiez ou déplacez des objets à l'aide de la commande Copier ou de la commande Déplacer, Tekla Structures affiche maintenant un aperçu du nouvel emplacement des objets copiés ou déplacés dans le modèle. Cela vous permet de voir le résultat final de la copie ou du déplacement avant de choisir le point de destination pour les objets copiés ou déplacés.

  1. Sélectionnez les objets à copier ou à déplacer.

  2. Exécutez la commande Copier ou la commande Déplacer.

  3. Choisissez l’origine de la copie ou du déplacement.

    Tekla Structures affiche une ligne dynamique entre le premier point sélectionné et la position du curseur. Déplacez le curseur pour voir comment l’aperçu change.

    Notez que Tekla Structures affiche toujours l’aperçu à la position où les objets seront copiés ou déplacés, pas à la position où le curseur se trouve lorsque vous choisissez le point de destination.

  4. Sélectionnez le point de destination.

Si vous souhaitez limiter le nombre d’objets affichés dans l’aperçu, utilisez l’option avancée XS_PREVIEW_LIMIT. La valeur par défaut est 1000. Lorsque la valeur est définie sur 0, l’aperçu est désactivé.

Améliorations de l’outil Copie Réseau et de l’outil Copie Réseau polaire

  • Dans l'outil Copie Réseau, si vous n'entrez pas le nombre de copies, celui-ci est désormais repris dans les distances d'espace définies entre les objets, dans la zone Écartement entre les copies.

  • Dans l'outil Copie Réseau Polaire,si vous n'entrez pas le nombre d'angles ou la distance, le nombre de copies est désormais repris des distances définies entre les objets, dans la zone Écartement entre les copies.

Utilisation de la touche Entrée pour exécuter les commandes

Vous pouvez maintenant utiliser la touche Entrée pour exécuter les commandes. Assurez-vous que la nouvelle option avancée XS_ENTER_FINALIZES_COMMANDS est définie sur TRUE pour permettre l’utilisation de la touche Entrée comme raccourci.

Auparavant, seul le bouton central de la souris et la touche Espace fonctionnaient comme raccourcis pour exécuter une commande, et pour les commandes de modification dynamique, seul le bouton central de la souris fonctionnait comme raccourci.

Améliorations apportées à l'accrochage

Vous ne pouvez plus accrocher les lignes de référence ou les lignes de géométrie cachées d'un objet dans les vues dont l'option de rendu est Pièces en rendu ou Composants en rendu (Ctrl/Maj +4).

Améliorations du plan de coupe

Lorsque vous créez des plans de coupe, vous pouvez désormais sélectionner des plans sur les pièces et les objets du composant même à l'aide des options de rendu Filaire ombré et Echelle de gris (Ctrl+2, Maj+2, Ctrl+3, et Maj+3). Les messages correspondants de la barre d’état ont également été améliorés.

Amélioration des messages d'erreur dans le panneau des propriétés

Auparavant, si vous aviez entré une valeur non valide dans une zone de valeur du panneau des propriétés, une bordure rouge autour de la zone et un point d’exclamation rouge étaient affichés. Désormais, il n’y a plus de point d’exclamation mais une infobulle avec le message d’erreur affichée en haut de la zone valeur.

Améliorations de la gestion de coulage

  • Les performances des fonctions de gestion du coulage ont été améliorées. Ces améliorations accélèrent l’ouverture et la modification des modèles, ainsi que le calcul des unités de coulage.

  • Lorsque vous utilisez la commande Calculer les coulages, les éléments préfabriqués ne sont plus ajoutés automatiquement aux unités de coulage. Cependant, ils peuvent toujours être ajoutés manuellement.

  • La valeur par défaut de XS_CALCULATE_POUR_UNITS_ON_SHARING a été remplacée par FALSE. Cela signifie que Tekla Structures ne calcule plus et ne met plus à jour automatiquement les unités de coulage dans les modèles partagés lors de la transmission et de l'acquisition. À la place, chaque utilisateur peut désormais exécuter la commande Calculer les coulages dans sa version locale du modèle partagé lorsqu’il a besoin d’informations d’unité de coulage à jour.

  • Certaines améliorations apportées aux calculs du coulage ont déjà été introduites dans Tekla Structures 2020 SP1. Voir  2020 SP1 : Nouvelles fonctionnalités et améliorations pour plus de détails.

La section Statistiques d’utilisation a été supprimée du menu fichier

La section Statistiques d’utilisation dans Fichier > Paramètres a été supprimée. Notez que les données d’utilisation sont collectées par défaut.

Le fichier UserFeedbackLog.txt contenant les données collectées est maintenant disponible dans Fichier > Logs > Log des données d'utilisation, avec les autres fichiers log.

Notez que lorsque vous cliquez sur Log des données d'utilisation pour ouvrir le fichier UserFeedbackLog.txt, le fichier log est toujours ouvert à l’aide de l’éditeur de texte par défaut, contrairement aux autres fichiers log qui peuvent être ouverts via la visionneuse du journal Tekla Structures. L’option de basculement entre les visionneuses ne fonctionne pas pour le fichier UserFeedbackLog.txt.

Le fichier log UserFeedbackLog.txt se trouve maintenant dans le répertoire TeklaStructuresModels.

Autres améliorations de modélisation

  • Les objets surface peuvent désormais être copiés. S'ils sont attachés à une face de la pièce, ils sont copiés lors de la copie de la pièce. Les surfaces peuvent également être copiées ou déplacées séparément d’un type d’objet vers un même type d’objet, c’est-à-dire d’une pièce à une autre et d’un objet de coulage à un autre objet de coulage.

  • Dans les vues de modèle, les arêtes de pavage ne sont plus affichées dans les objets de surface courbe. Cela s’applique à la fois au rendu DirectX et à l'ancien rendu (OpenGL).

  • Les commandes Convertir la pièce en article et Créer forme à partir de géométrie sont désormais disponibles dans Edition sur le ruban. Auparavant, ces commandes pouvaient être lancées à l’aide du menu contextuel accessible par clic droit ou du Démarrage rapide.

  • Le sous-menu Fenêtre active est désormais supprimé du menu contextuel Zoom en mode modélisation et en mode dessin. En mode modélisation, les commandes de zoom sont disponibles dans l' onglet Vue dans le menu Zoom, et les infobulles affichent les raccourcis clavier associés. Dans les deux modes, les commandes de zoom sont disponibles dans Démarrage rapide, et vous pouvez également voir les raccourcis clavier.

  • Les branches Armature et Treillis soudé ont été supprimées du catalogue de matériaux. Les définitions d’armature sont disponibles dans le catalogue d’armatures.

Was this helpful?
Previous
Next