Personnalisation du ruban

Tekla Structures
2021
Tekla Structures

Personnalisation du ruban

L'Editeur du ruban vous permet de personnaliser le ruban en fonction de vos besoins. Par exemple, vous pouvez modifier la taille et la forme des boutons. Vous pouvez créer des commandes définies par l'utilisateur et ajouter vos composants et extensions favoris au ruban pour un accès rapide.

Pour ouvrir l'Editeur du ruban, cliquez sur le menu Fichier > Paramètres > Personnaliser > Ruban.

Avec Editeur du ruban, vous pouvez

  • ajouter de nouveaux boutons au ruban

  • déplacer les boutons existants du ruban

  • redimensionner les boutons sur le ruban

  • modifier les icônes et les textes des boutons

  • supprimer les boutons dont vous n'avez pas besoin

  • créer de nouvelles commandes et ajouter les boutons correspondants

  • ajouter des barres de séparation sur le ruban

  • ajouter de nouveaux onglets

Remarque :

Si vous voulez personnaliser le ruban de modélisation, ouvrez Editeur du ruban en mode modélisation.

Si vous voulez personnaliser le ruban de dessin, ouvrez Editeur du ruban en mode dessin.

Vous ne pouvez personnaliser que les rubans qui sont disponibles dans votre configuration.

Les rubans personnalisés sont enregistrés dans le dossier ..\Users\<utilisateur>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Ribbons . Si vous ne trouvez pas le répertoire, vérifiez que vous pouvez afficher les fichiers et dossiers cachés sur votre ordinateur.

Les administrateurs de l'entreprise peuvent distribuer des rubans ou des onglets personnalisés à l'ensemble de l'organisation de la même manière que les personnalisations du panneau des propriétés.

Ajout d'un bouton au ruban

Pour ajouter un bouton, il vous suffit de sélectionner un type de bouton et son apparence, puis de faire glisser la commande sur le ruban ou sur la Barre d'outils d'accès rapide.

Pour Procéder comme suit

Ajouter un bouton pour une seule commande

  1. Dans la liste Ajouter élément de ruban , sélectionnez Bouton simple.

  2. Dans la liste Commande , sélectionnez la commande que vous souhaitez ajouter au ruban.

    Vous pouvez également ajouter des composants, des macros et des extensions. Parcourez la liste ou utilisez la zone Rechercher pour filtrer le contenu. Par exemple, saisissez treillis pour trouver la commande Créer treillis soudé et d’autres composants associés aux treillis :

  3. Dans la liste Apparence  :

    • Indiquez si le bouton a une icône. Sélectionnez la taille de l'icône, ou si vous souhaitez utiliser un icône extensible ou rechercher l'image de l'icône.

    • Indiquez si le bouton comporte du texte.

  4. Aperçu affiche ce à quoi le bouton ressemble. Modifiez l'apparence du bouton, si nécessaire.

  5. Faites glisser le bouton sur le ruban.

    La couleur bleue indique l’emplacement où le bouton sera inséré.

Ajouter un bouton de contrôle qui active/désactive une commande spécifique

Utilisez cette option pour ajouter au ruban n'importe quel bouton à partir du menu Fichier > Paramètres > Sélecteurs, par exemple. Vous pouvez également ajouter des boutons d'accrochage simples et des boutons de sélection au ruban.

  1. Dans la liste Ajouter élément de ruban , sélectionnez Bouton Contrôle.

  2. Dans la liste Commande , sélectionnez une commande qui peut être activée ou désactivée.

    Les commandes qui peuvent être activées ou désactivées comportent une case à cocher à côté d'elles.

  3. Dans la liste Apparence  :

    • Indiquez si le bouton a une icône. Sélectionnez la taille de l'icône, ou si vous souhaitez utiliser un icône extensible ou rechercher l'image de l'icône.

    • Indiquez si le bouton comporte du texte.

  4. Aperçu affiche ce à quoi le bouton ressemble. Modifiez l'apparence du bouton, si nécessaire.

  5. Faites glisser le bouton sur le ruban.

    La couleur bleue indique l’emplacement où le bouton sera inséré.

Ajouter un bouton déroulant sous un groupe de commandes

  1. Dans le fichier Ajouter élément de ruban , sélectionnez Bouton déroulant.

  2. Dans le fichier Apparence  :

    • Indiquez si le bouton a une icône. Recherchez l'image de l'icône.

    • Indiquez si le bouton comporte du texte.

  3. Aperçu affiche ce à quoi le bouton ressemble. Modifiez l'apparence du bouton, si nécessaire.

  4. Faites glisser le bouton sur le ruban.

    Le bouton est désormais un emplacement vide pour les commandes uniques. Vous devez ajouter des commandes au bouton déroulant pour le faire fonctionner.

    1. Dans le fichier Ajouter élément de ruban , sélectionnez Bouton simple.

    2. Dans le fichier Commande , sélectionnez la commande que vous souhaitez ajouter à la liste déroulante.

    3. Dans le fichier Apparence , définissez l'apparence du bouton.

    4. Faites glisser le bouton sur la liste déroulante.

      La couleur bleue indique l’emplacement où le bouton sera inséré. Si vous placez le pointeur de la souris sur une flèche vers le bas, une liste s’affiche et vous pouvez faire glisser des commandes dans la liste. La liste demeurera ouverte jusqu'à ce que vous cliquiez à nouveau sur la flèche vers le bas.

    5. Ajoutez autant de commandes que nécessaire au bouton déroulant.

Ajouter un bouton pour une commande unique, ainsi qu'un bouton déroulant avec un groupe de commandes

  1. Dans le fichier Ajouter élément de ruban , sélectionnez Bouton partagé.

  2. Dans le fichier Commande , sélectionnez la commande que vous souhaitez ajouter au ruban comme bouton principal pour l'ensemble du bouton partagé.

  3. Dans le fichier Apparence  :

    • Indiquez si le bouton a une icône. Sélectionnez la taille de l'icône, ou si vous souhaitez utiliser un icône extensible ou rechercher l'image de l'icône.

    • Indiquez si le bouton comporte du texte.

  4. Aperçu affiche ce à quoi le bouton ressemble. Modifiez l'apparence du bouton, si nécessaire.

  5. Faites glisser le bouton sur le ruban.

    Le bouton possède désormais une seule commande. Vous devez ajouter des commandes à la liste déroulante.

    1. Dans le fichier Ajouter élément de ruban , sélectionnez Bouton simple.

    2. Dans le fichier Commande , sélectionnez la commande que vous souhaitez ajouter à la liste déroulante.

    3. Dans le fichier Apparence , définissez l'apparence du bouton.

    4. Faites glisser le bouton sur la liste déroulante.

      La couleur bleue indique l’emplacement où le bouton sera inséré. Si vous placez le pointeur de la souris sur une flèche vers le bas, une liste s’affiche et vous pouvez faire glisser des commandes dans la liste. La liste demeurera ouverte jusqu'à ce que vous cliquiez à nouveau sur la flèche vers le bas.

    5. Ajoutez autant de commandes que nécessaire au bouton déroulant.

Vous pouvez également faire glisser des commandes sur la Barre d'outils d'accès rapide, située au-dessus du ruban, ou dans le conteneur fixe sur le côté gauche du ruban :

Déplacement d'un bouton

Vous pouvez réarranger les boutons dans le ruban. Notez que vous ne pouvez pas déplacer un bouton déroulant sous un autre bouton déroulant.

  1. Sélectionnez le bouton à déplacer.

    Le bouton est mis en surbrillance :

  2. Faites glisser le bouton vers un nouvel emplacement.

    La couleur bleue indique l’emplacement où le bouton sera inséré. Par exemple :

Redimensionnement d’un bouton

Vous pouvez modifier la taille des boutons existants.

  1. Sélectionnez le bouton à redimensionner :

  2. Déplacez le pointeur de la souris sur n’importe quel côté ou angle du bouton pour afficher une flèche blanche :

  3. Faites glisser la flèche pour définir une nouvelle taille :

    La taille du bouton change en conséquence. Les autres boutons sont automatiquement déplacés sur le ruban, si nécessaire.

  4. Double-cliquez sur le bouton pour l’agrandir.

    Le bouton occupe désormais tout l’espace vide qui l’entoure :

Modification de l’apparence d’un bouton

Vous pouvez modifier l'apparence de n'importe quel bouton.

  1. Sélectionnez le bouton à modifier.
    • Si vous ajoutez un nouveau bouton : sélectionnez la commande dans la liste Commande .

      Les propriétés actuelles du bouton sont affichées dans la liste Apparence .

    • Si le bouton existe déjà dans le ruban : cliquez avec le bouton droit sur le bouton sélectionné dans le ruban.

  2. Pour modifier l’icône, sélectionnez l’une des options suivantes :
    1. Aucun: aucune icône n’est utilisée pour le bouton
    2. Commande : Grande icône: la grande icône par défaut (32x32) est utilisée
    3. Commande : Petite icône: la petite icône par défaut (16x16) est utilisée
    4. Commande : icône extensible: l'icône à vecteur extensible est utilisée
    5. Galerie (bitmap): sélectionnez une grande ou petite icône bitmap de la galerie d'icones Tekla Structures
    6. Galerie (adaptable): sélectionnez une icône extensible dans la galerie d'icônes Tekla Structures
    7. Personnalisé: définissez une icône personnalisée en sélectionnant un fichier image approprié. La taille recommandée est de 32x32 pixels pour les grands boutons et 16x16 pixels pour les petits. Si vous avez des problèmes d'image personnalisée n'apparaissant pas avec la bonne taille, vérifiez le paramètre PPP du fichier image. Un PPP de 96 est recommandé.
  3. Pour modifier le nom, sélectionnez l’une des options suivantes :
    • Aucun: aucun nom n’est utilisé pour le bouton

    • Commande : Texte complet: la version complète par défaut du nom est utilisée

    • Commande : Texte court: la version courte par défaut du nom est utilisée

    • Personnalisé: saisissez un nom personnalisé pour le bouton

Création d'une commande définie par l'utilisateur avec l'éditeur de commande

Vous pouvez créer des commandes définies par l’utilisateur et les lier à n’importe quel fichier ou URL. Créez les commandes définies par l'utilisateur avec l'Éditeur de commande.

Les commandes définies par l’utilisateur sont enregistrées dans le dossier ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Commands.

  1. Cliquez sur le menu Fichier > Paramètres > Personnaliser > Commandes définies par l'utilisateur pour ouvrir l'Éditeur de commande.
  2. Cliquez sur Nouveau.
  3. Entrez un identifiant unique pour la commande, puis cliquez sur OK.

    Par exemple, créez un lien vers Tekla Discussion Forum. Entrez OpenTeklaDiscussionForum comme identifiant de la commande.

    Une nouvelle colonne avec d’autres propriétés s’affiche.

  4. Dans les zones Nom complet et Nom court, entrez un nom pour la commande.

    Ce nom sera visible dans l'interface utilisateur Tekla Structures. Vous pouvez définir deux noms différents : un nom complet et une version courte. Par exemple, entrez Tekla Discussion Forum comme nom complet de la commande et Forum comme version courte.

  5. Dans les paramètres Grande icône, Petite icône et Icône extensible, sélectionnez une icône pour la commande.

    Vous pouvez définir trois icônes différentes : une grande et une petite, ou une icône à vecteur extensible.

    Vous pouvez utiliser votre propre icône ou sélectionner une icône appropriée dans la galerie d'icônes Tekla Structures.

  6. Dans la zone Info-bulle, entrez une infobulle pour la commande.

    Par exemple, entrez Accéder au Tekla discussion forum.

  7. Dans la zone Action, définissez un fichier ou une URL.

    Par exemple, saisissez https://forum.tekla.com.

  8. Dans Disponibilité, sélectionnez le mode dans lequel la commande est disponible.
  9. Cliquez sur Enregistrer pour enregistrer la nouvelle commande.
  10. Accédez à l'Editeur du ruban.
  11. Sélectionnez le type de bouton.
  12. Dans la liste Commande, recherchez la nouvelle commande que vous avez créée.
  13. Dans la liste Apparence, modifiez l'apparence du bouton, si nécessaire.
  14. Faites glisser le nouveau bouton sur le ruban.

  15. Pour modifier une commande définie par l’utilisateur, cliquez avec le bouton droit sur le ruban et modifiez les propriétés de la commande comme pour n’importe quelle autre commande.

Ajout d’une barre de séparation

Vous pouvez ajouter des barres de séparation verticales et horizontales pour diviser les boutons en groupes plus petits sur le ruban.

  1. Dans la liste Ajouter élément de ruban, sélectionnez Séparateur.
  2. Dans la liste Apparence, indiquez s'il faut ajouter une barre horizontale ou verticale ainsi que l'épaisseur de la barre.

    Aperçu affiche ce à quoi ressemble la barre de séparation.

  3. Glissez l'élément d'aperçu sur le ruban.
  4. Pour modifier l'orientation ou l'épaisseur de la ligne de barre, cliquez avec le bouton droit sur la barre dans l'onglet et sélectionnez Orientation ou Epaisseur.
  5. Pour supprimer la barre, sélectionnez-la dans le ruban et appuyez sur Suppr de votre clavier.

    Vous pouvez également cliquer avec le bouton droit sur la barre du ruban et sélectionner Supprimer.

Suppression d'un bouton

  1. Sélectionnez le bouton dans le ruban.
  2. Appuyez sur Suppr sur votre clavier.

    Vous pouvez également cliquer avec le bouton droit sur le bouton du ruban et sélectionner Supprimer.

Ajout, masquage et modification des onglets

Vous pouvez ajouter, déplacer et renommer des onglets de ruban, choisir comment ils sont alignés, et cacher certains onglets s’ils ne sont pas nécessaires pour votre projet actuel. À titre d’exemple, si vous modélisez uniquement des pièces en acier, vous pouvez temporairement masquer l’onglet Béton.

Pour Procéder comme suit

Ajouter un nouvel onglet

  1. Dans le fichier Ajouter élément de ruban , sélectionnez Onglet.

  2. Entrez un nom pour l'onglet dans la zone Texte.

  3. Cliquez sur Ajouter onglet pour l'ajouter au ruban.

Modifier l'ordre des onglets sur le ruban

Faites glisser et déposez les titres d'onglet.

Sélectionner la manière dont les onglets sont alignés

Cliquez avec le bouton droit dans la zone de ruban et sélectionnez une des options Mode de navigation :

  • Défilement visible: le mouvement du ruban est minimal lorsque vous changez d’onglet

  • Aligner à gauche: l'affichage des icônes commence à partir du côté gauche du ruban

  • Aligner sur l'onglet: l'affichage des icônes commence à partir du côté gauche de l'onglet actuel

Masquer les onglets dont vous n'avez pas besoin dans votre projet en cours

  1. Placez le pointeur de la souris sur le titre d'un onglet.

    Un petit symbole en forme d’œil s’affiche à côté du titre de l’onglet :

  2. Cliquez sur le symbole en forme d’œil .

    Le symbole en forme d’œil change et le titre de l’onglet est grisé :

Désormais, l’onglet Affichage n’apparaît plus dans le ruban. Si vous faites glisser le ruban, les onglets masqués s’affichent comme suit :

Pour réafficher l’onglet masqué, cliquez de nouveau sur le symbole en forme d’œil.

Renommer un onglet

Cliquez avec le bouton droit de la souris sur l'onglet et sélectionnez Renommer. Entrez une nouveau nom pour l'onglet.

Supprimer un onglet

Sélectionnez l'onglet et appuyez sur Supprimer.

Vous pouvez également cliquer avec le bouton droit de la souris sur l'onglet et sélectionner Supprimer.

Enregistrement du ruban

Lorsque vous êtes satisfait des modifications, enregistrez le ruban personnalisé.

  1. Dans l'Editeur du ruban, cliquez sur le bouton Enregistrer.
  2. Lorsque vous revenez à Tekla Structures et que le programme demande si vous souhaitez charger le nouveau ruban, cliquez sur Oui.
    Le ruban est mis à jour avec les modifications que vous avez apportées.

Vérification des modifications

Vous pouvez comparer le ruban d’origine avec les changements effectués. Vous pouvez vérifier ce qui a été ajouté et supprimé, et ce qui a été déplacé vers des onglets différents.

  1. Enregistrez le ruban personnalisé, si vous ne l’avez pas déjà fait.
  2. Cliquez sur le bouton Comparer.
  3. Dans le fichier Comparer les rubans , vérifiez les changements que vous avez effectués.

    Par exemple :

    • N’existe pas : ces commandes ont été supprimées

    • Déplacé : ces commandes ont été déplacées vers un nouvel emplacement

    • Ajouts personnalisés : ces commandes ont été ajoutées

    Remarque :

    Ruban d’origine fait référence au fichier de ruban qui est fourni avec l’installation de Tekla Structures pour votre configuration actuelle.

  4. Si vous avez supprimé une commande que vous souhaitez restaurer, faites-la glisser de la boîte de dialogue Comparer les rubans sur le ruban.
  5. Lorsque vous avez terminé, cliquez sur Fermer.

Sauvegarde et restauration des rubans

Vous pouvez restaurer les rubans Tekla Structures par défaut à tout moment. Avant de restaurer les paramètres par défaut, veillez à enregistrer une copie de sauvegarde de votre ruban personnalisé, car les personnalisations seront définitivement supprimées. Vous pouvez utiliser le fichier de sauvegarde pour utiliser à nouveau votre ruban personnalisé, copier les paramètres de ruban sur un autre ordinateur ou partager le ruban personnalisé avec vos collègues.

  1. Pour enregistrer une copie de sauvegarde du ruban personnalisé :
    1. Dans l'Editeur du ruban, cliquez sur le bouton Enregistrer.
    2. Accédez au répertoire ..\Users\<utilisateur>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Ribbons.
    3. Faites une copie du fichier de ruban souhaité et enregistrez-le dans un autre répertoire.

      Les rubans sont nommés en fonction des configurations de Tekla Structures. Par exemple, dans la configuration Complet, le nom du fichier de ruban Modélisation est albl_up_Full--main_menu.xml.

  2. Cliquez sur le bouton Restaurer pour restaurer le ruban par défaut de modélisation ou de dessin Tekla Structures.
  3. Pour utiliser à nouveau le ruban personnalisé :
    1. Recopiez le fichier de sauvegarde dans le dossier ..\Users\<utilisateur>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Ribbons.
    2. Lorsque vous revenez Tekla Structures et que le programme demande si vous souhaitez charger le nouveau ruban, cliquez sur Oui.

      Le ruban est mis à jour avec les modifications que vous avez apportées.

Was this helpful?
Précédent
Suivant