Crear un cuadro en formato HTML

Tekla Structures
2024
Tekla Structures

Crear un cuadro en formato HTML

Los cuadros en formato HTML ofrecen más posibilidades para diferentes disposiciones, fuentes e imágenes. Los cuadros que generan una salida en formato HTML son gráficos y tienen la extensión de nombre de fichero .html.rpt.

Nota:

Si añade imágenes a su cuadro HTML, las imágenes deben estar en la carpeta ..\Program Files\Tekla Structures\<version>\bin\applications\Tekla\Tools\TplEd\bitmaps. En la salida HTML no se muestran las imágenes de otras carpetas.

  1. En el menú Archivo, haga clic en Editores > Editor Cuadros.
  2. En Editor Cuadros, haga clic en Archivo > Nuevo.
  3. Seleccione Cuadro gráfico y, a continuación, haga clic en OK.
  4. Añada filas nuevas al cuadro.
    1. Para añadir una fila nueva, haga clic en Insertar > Componente > Fila.
    2. Seleccione un tipo de contenido para la fila y, a continuación, haga clic en OK.
  5. Añada campos de valor para obtener los datos necesarios de la base de datos de Tekla Structures.
    1. Haga clic en Insertar > Campo de valor.
    2. Haga clic en un punto para definir la ubicación del campo dentro de la fila.

      Aparecerá el cuadro de diálogo Seleccionar Atributo y le solicita que seleccione un atributo para el campo de valor.

    3. Seleccione un atributo y, a continuación, haga clic en OK.
  6. Añada una cabecera para cada campo de valor.
    1. Haga clic en Insertar > Componente > Cabecera...
    2. Haga clic en Insertar > Texto...
    3. Escriba un encabezado para el cuadro y, a continuación, haga clic en OK.
    4. Haga clic en un punto para definir la ubicación del encabezado en la fila de cabecera.
  7. Guarde el cuadro:
    1. Haga clic en Archivo > Grabar Como
    2. Guarde el cuadro en la carpeta de modelo. Si también desea utilizar el cuadro en otros proyectos, guárdelo en la carpeta de cuadros definida para la opción avanzada XS_FIRM o XS_PROJECT.
    3. En el campo Nombre, introduzca un nombre para el cuadro.

      En el nombre de archivo incluya la extensión *.html.rpt. Por ejemplo, Part_list.html.rpt.

    4. Haga clic en OK.

Ejemplo

  1. Cabecera que contiene campos de texto
  2. Fila que contiene dos campos de valor
Consejo:
  • Para exportar informes a Microsoft Excel con una disposición determinada, por ejemplo, celdas combinadas, líneas de borde, tipos y tamaños de fuente, puede usar HTML en Editor cuadros. Cuando guarda el cuadro con la extensión de nombre de archivo .xls.rpt, el informe de Excel se abrirá automáticamente en Excel cuando Mostrar informe se define como Con visualizador asociado. Para obtener más información, consulte Cómo crear informes Excel básicos basados ​​en HTML.

  • Para crear un conjunto adicional de imágenes en la carpeta del informe, configure la opción avanzada XS_​CREATE_​ALSO_​BIG_​HTML_​REPORT_​PICTURES como TRUE. Las imágenes tienen el triple de tamaño que las del informe HTML.

¿Le ha resultado útil?
Anterior
Siguiente