Hojas de cálculo de Excel en el diseño de uniones

Tekla Structures
2021
Tekla Structures

Hojas de cálculo de Excel en el diseño de uniones

Puede usar hojas de cálculo de Excel en el diseño de uniones para todas las uniones de acero que tengan la pestaña Diseño o Tipo diseño en el cuadro de diálogo de la unión.

Puede enlazar las uniones a las hojas de cálculo de Excel seleccionando Excel en la opción Diseño externo en la pestaña Diseño o Tipo diseño. La información de unión se transfiere a la hoja de cálculo específica del tipo de unión donde se realizan los cálculos necesarios. Las propiedades calculadas se guardan en un archivo de salida y los valores de propiedades del componente modificados se transfieren de nuevo a la unión. La unión se modifica según los cambios.

Puede crear una hoja de cálculo de Excel para un tipo de unión utilizando el archivo component_template.xls disponible en la carpeta ..\Tekla Structures\<version>\Environments\common\exceldesign o usar un archivo predefinido.

Archivos utilizados en el diseño de uniones con hojas de cálculo de Excel

Los siguientes archivos se utilizan en el diseño de uniones con hojas de cálculo de Excel:

Archivo Descripción
Archivo de script de Visual Basic El archivo Excel.vb enlaza Tekla Structures con el software externo y define los nombres y ubicaciones de los archivos de hoja de cálculo de Excel. El archivo se encuentra en la carpeta ..\Tekla Structures\<version>\Environments\common\exceldesign.
Hoja de cálculo de Excel específica del tipo de componente La hoja de cálculo específica del tipo de componente contiene cálculos predefinidos. Al ejecutar el diseño de la unión, las propiedades de la unión y la información de las partes principal y secundarias se transfieren a las hojas Input y Component de la hoja de cálculo de Excel.

Excel busca el archivo de la hoja de cálculo pertinente en el siguiente orden:

  1. En la carpeta \exceldesign en la carpeta del modelo actual: archivo denominado como component_ + number or name + .xls, por ejemplo, ..\test_model\exceldesign\component_144.xls.
  2. En la ubicación definida con la opción avanzada XS_EXTERNAL_EXCEL_DESIGN_PATH del modo siguiente:

    XS_EXTERNAL_EXCEL_DESIGN_PATH (=%XS_DIR%\environments\common\exceldesign\) + "component_" + number + ".xls"

Archivo de resultados específico de la unión

El archivo de resultados contiene las propiedades de unión modificadas.

  • El archivo de resultados se crea automáticamente de la hoja Calculation.
  • El archivo se guarda en la carpeta \exceldesign en la carpeta del modelo y su nombre es el GUID, identificador único global.
  • El archivo se actualiza cada vez que se modifica la unión.
  • Los resultados del cálculo se pueden guardar como hoja de cálculo de Excel, en formato HTML o PDF, dependiendo de cómo se configure la hoja de cálculo.
Hoja de cálculo de plantilla La carpeta ..\Tekla Structures\<version>\Environments\common\exceldesign contiene una hoja de cálculo component_template.xls que debería utilizar para crear sus propias aplicaciones de hojas de cálculo para usarlas con los componentes de Tekla Structures.

Ejemplo de una hoja de cálculo de Excel en el diseño de unión

Las imágenes de este ejemplo muestran la hoja de cálculo de Excel que se utiliza para la unión Placa de unión (144).

La hoja de cálculo de muestra tiene las hojas siguientes:

La hoja Calculation contiene un informe de los cálculos.

La hoja Inputs contiene las propiedades de la unión del cuadro de diálogo de la unión.

La hoja Outputs contiene los resultados del diseño. Estos valores se transfieren de nuevo a la unión, y esta se modifica en consecuencia en el modelo.

La hoja Component contiene cálculos, información sobre la geometría de la unión y sobre la parte principal y las partes secundarias. Los atributos del componente de la hoja de cálculo son los mismos que los del archivo .inp correspondiente. Para obtener más información acerca de los archivos .inp consulte Archivos de entrada (archivos .inp).

Las hojas siguientes también están incluidas:

  • Data muestra información sobre las bases de datos.
  • Norm muestra la selección de código y las referencias a códigos.
  • Language muestra traducciones.

Ejemplo de visualización del proceso de diseño de uniones en Excel

Puede definir en el archivo Excel.vb cómo se visualiza el proceso de diseño de uniones en Excel. El archivo Excel.vb enlaza Tekla Structures con el software externo y define los nombres y ubicaciones de los archivos de hoja de cálculo de Excel.

  1. Abra el archivo Excel.vb que se encuentra en ..\Tekla Structures\<version>\Environments\common\exceldesign.
  2. Configure el archivo Excel.vb del modo siguiente:

    • Control de visualización - Const DEBUG As Boolean= True
    • Visualización utilizando Excel - Const SHOW_EXCEL As Boolean = True
    • Almacenando la salida - Const STORE_RESULTS As Boolean = True
  3. Guarde el archivo.
  4. Haga clic en el botón Aplicaciones y componentes del panel lateral para abrir la base de datos Aplicaciones y componentes.
  5. Busque Ángulo de unión (141) y haga doble clic para abrir el cuadro de diálogo de propiedades.
  6. En la pestaña Tipo diseño:
    1. Seleccione Excel en la opción Diseño externo.
    2. Introduzca los valores de carga.

  7. Haga clic en Modificar.

    El archivo de diseño de Excel se abre y muestra la hoja Inputs.

  8. Haga clic en OK para continuar.

    El proceso de diseño de Excel ahora calcula los datos que se muestran en la hoja Component y después abre la hoja Componente.

  9. Haga clic en OK para continuar.

    El proceso de diseño de Excel calcula ahora los valores de salida del resultado y después abre la hoja Outputs. Los valores de resultados calculados se transfieren a la unión.

  10. Guarde el archivo en la carpeta de modelo.
  11. Cuando hace clic en OK, se completa el proceso de diseño y se cierra el archivo de diseño de Excel.

Mostrar estado de unión en diseño de uniones en Excel

Al utilizar hojas de cálculo de Excel en el diseño de uniones, puede hacer que Tekla Structures utilice símbolos de componente en distintos colores para indicar el estado de un componente en el modelo.

Puede hacerlo incluyendo un atributo de error en la hoja Outputs de la hoja de cálculo de Excel del componente. El tipo del atributo es int.

Los valores posibles son:

Valor Color Estado

1

Verde

Las distancias de borde de tornillo son suficientes.

La unión pasa la comprobación de diseño de unión usando los códigos de diseño del Reino Unido y EE. UU. incluidos en el sistema.

2

Amarillo

Las distancias de borde de tornillo son insuficientes según el valor especificado en las configuraciones de Componentes en el menú Archivo > Configuración > Opciones.

3

Rojo

Tekla Structures no puede calcular las propiedades del componente. Los motivos posibles son:
  • La dirección de la unión no es correcta.
  • El plano de trabajo no es correcto.
  • La unión seleccionada no es adecuada para la situación.
  • La comprobación de diseño de la unión se ha realizado utilizando los códigos de diseño del Reino Unido y EE. UU. y la unión no puede admitir la carga que se ha definido.
Nota:

El color del símbolo de componente sólo se puede controlar en los componentes de sistema, no en los componentes personalizados.

Was this helpful?
Anterior
Siguiente