Personalizar los cuadros de diálogo de componentes personalizados

Tekla Structures
2021
Tekla Structures

Personalizar los cuadros de diálogo de componentes personalizados

Tekla Structures crea automáticamente un cuadro de diálogo para cada componente personalizado que defina. Cada componente personalizado tiene un archivo de entrada (.inp) que define el contenido del cuadro de diálogo del componente personalizado. Puede personalizar el cuadro de diálogo utilizando la herramienta Editor Diálogo Componente Personalizado.

Como alternativa, si es usuario experto, puede modificar los archivos de entrada de cuadro de diálogo (.inp) manualmente en un editor de texto.

Modificar el cuadro de diálogo de un componente personalizado

Para abrir el Editor Diálogo Componente Personalizado, seleccione un componente personalizado en el modelo, haga clic con el botón derecho del ratón y seleccione Editar cuadro diálogo componente personalizado.

A

Haga esto

Ver y editar propiedades de objeto

  1. Seleccione un elemento de cuadro de diálogo. Por ejemplo, un cuadro de texto.

  2. Haga clic en Modificar > Propiedades.

    Ahora puede ver y editar las propiedades actuales del elemento de cuadro de diálogo. Por ejemplo, puede comprobar si tiene el cuadro de texto correcto en cada etiqueta en el cuadro de diálogo.

Como alternativa, puede hacer doble clic en el elemento del cuadro de diálogo. Si el elemento del cuadro de diálogo no se abre para la visualización y la edición, intente hacer doble clic en la derecha del espacio bajo la casilla de verificación:

Añadir un elemento de cuadro de diálogo

Haga clic en Insertar y seleccione un elemento adecuado de la lista. Las opciones son las siguientes:

  • Pestaña: añadir una pestaña nueva

  • Etiqueta: añadir una etiqueta para una lista o un cuadro de texto

  • Parámetro: añadir un cuadro de texto

  • Atributo: añadir una lista

  • Parte: añadir algunas propiedades de parte básicas

  • Perfil: añadir algunas propiedades de perfil básicas

  • Imagen: añadir una imagen ilustrativa del componente personalizado

Añadir una imagen

  1. Haga clic en Insertar > Imagen para mostrar el contenido de la Carpeta Imágenes definida en Herramientas > Opciones.

  2. Seleccione una imagen.

    El formato de la imagen debe ser bitmap (.bmp).

  3. Haga clic en Abrir.

  4. Arrastre la imagen a la ubicación que desee.

Añadir una pestaña

  1. Haga clic en Insertar > Pestaña.

  2. Haga doble clic en la pestaña nueva.

  3. Escriba otro nombre y después pulse Intro.

Nota:

Cada pestaña puede contener hasta 25 campos. Si hay más de 25 campos visibles, Tekla Structures crea automáticamente otra pestaña.

Mostrar u ocultar la malla de píxeles

Haga clic en .

Tekla Structures muestra una malla de píxeles que facilita la alineación de elementos en el cuadro de diálogo.

Mover un elemento de cuadro de diálogo

Arrastre el elemento de cuadro de diálogo a una nueva ubicación.

También puede utilizar los métodos abreviados de teclado Ctrl+X (cortar), Ctrl+C (copiar) y Ctrl+V (pegar). Por ejemplo, para mover un elemento de cuadro de diálogo a otra pestaña: seleccione el elemento de cuadro de diálogo, pulse Ctrl+X, vaya a otra pestaña y pulse Ctrl+V.

Seleccionar varios elementos de cuadro de diálogo

Mantenga pulsada la tecla Ctrl y haga clic en los elementos de cuadro de diálogo o use una selección de área.

Renombrar una etiqueta de cuadro de texto o pestaña

  1. Haga doble clic en la etiqueta de cuadro de texto o pestaña.

  2. Escriba un nombre nuevo.

  3. Pulse Intro.

Eliminar un elemento de cuadro de diálogo

  1. Seleccione el elemento de cuadro de diálogo que desee eliminar.

  2. Pulse Supr.

Eliminar una pestaña

  1. Seleccione la pestaña.

  2. Haga clic con el botón secundario y seleccione Borrar.

Añadir imágenes a una lista

  1. Seleccione el elemento de lista.

  2. Haga clic en Modificar > Propiedades.

  3. Haga clic en Editar Valores.

  4. Haga clic en Examinar Añadir.

  5. Seleccione la imagen que desee usar y haga clic en Abrir.

  6. Repita los pasos 4 y 5 para cualquier otra imagen que desee utilizar.

  7. Haga clic en OK para guardar los cambios.

Guardar los cambios

Haga clic en Archivo > Guardar.

Archivos de entrada de componentes personalizados

Cada componente personalizado tiene un archivo de entrada (.inp) que define el contenido del cuadro de diálogo del componente personalizado.

Al crear un nuevo componente personalizado, Tekla Structures crea automáticamente un archivo de entrada para el componente. El archivo de entrada se encuentra en la carpeta \CustomComponentDialogFiles en la carpeta del modelo. El archivo de entrada tiene el mismo nombre que el componente personalizado y la extensión de nombre de archivo .inp.

Al modificar un componente personalizado, perderá los cambios que haya realizado en el archivo de entrada. No obstante, al modificar un componente personalizado, Tekla Structures crea automáticamente una copia de seguridad del archivo de entrada. La copia de seguridad tiene la extensión de nombre de archivo .inp_bak y se encuentra en la carpeta \CustomComponentDialogFiles en la carpeta del modelo. Tekla Structures muestra una notificación cuando se crea el archivo de copia de seguridad.

Bloquear o desbloquear el archivo de entrada del componente personalizado

Puede bloquear el archivo de entrada del componente personalizado (.inp) para impedir cambios accidentales. Si el archivo está desbloqueado y otro usuario actualiza el componente personalizado en el editor de componente personalizado, todas las modificaciones realizadas en el cuadro de diálogo se perderán.

  1. En el modelo, seleccione el componente personalizado cuyo archivo de entrada desea bloquear o desbloquear.
  2. Haga clic con el botón derecho y seleccione Editar cuadro diálogo componente personalizado.
  3. En Editor Diálogo Componente Personalizado, haga clic en el botón Bloquear/Desbloquear .

Si alguien modifica el componente personalizado en el editor de componente personalizado cuando el archivo .inp está bloqueado, el archivo .inp no se actualizará. De todos modos, puede modificar el cuadro de diálogo en el Editor Diálogo Componente Personalizado aunque el archivo .inp esté bloqueado.

Configuración del editor de diálogo de componente personalizado

En Editor Diálogo Componente Personalizado, haga clic en Herramientas > Opciones para ver y modificar la configuración básica en el editor de diálogo de componente personalizado. Haga clic en Herramientas > Cambiar Idioma para cambiar el idioma en el editor de diálogo de componente personalizado.

Opción

Descripción

Carpeta Imágenes

La ubicación de la carpeta de imágenes. Para restablecer la configuración por defecto de la carpeta, haga clic en Por defecto.

Carpeta Proyecto

La ubicación de la carpeta de proyecto. Al crear un archivo de entrada completamente nuevo haciendo clic en Archivo > Nuevo y después guardarlo, el archivo se guarda en la carpeta de proyecto. Tenga en cuenta que los archivos de entrada existentes están guardados en la carpeta del modelo.

Ancho Parámetro

La anchura por defecto de los cuadros de texto.

Ancho Atributo

La anchura por defecto de las listas.

Separación Malla X

Separación Malla Y

La separación de la malla de píxeles en las direcciones X e Y. El valor por defecto es 5.

Ajustar a malla

Seleccione mostrar u ocultar la malla de píxeles.

Opción

Descripción

Idioma

Seleccione un idioma de la lista. Para que el cambio surta efecto, cierre y vuelva a abrir el editor de cuadros de diálogo. Dispone de las siguientes opciones:

  • Auto: el editor de cuadros de diálogo sigue el idioma de la interfaz de usuario de Tekla Structures
  • English
  • Dutch
  • French
  • German
  • Italian
  • Spanish
  • Japanese
  • Chinese Simplified
  • Chinese Traditional
  • Chequia
  • Portuguese Brazilian
  • Hungarian
  • Polish
  • Russian
  • Korean
Was this helpful?
Anterior
Siguiente