Seleccionar los objetos a incluir en un informe utilizando los GUID

Tekla Structures
2018
Tekla Structures

Seleccionar los objetos a incluir en un informe utilizando los GUID

Puede seleccionar los objetos que desea incluir en los informes utilizando sus GUID (identificadores únicos globales).

  1. Cree un cuadro que se utilice para crear el informe.
    1. En el menú Archivo , haga clic en Editores > Editor Cuadros .
    2. En Editor Cuadros, haga clic en Archivo > Nuevo .
    3. Seleccione Cuadro de texto y haga clic en OK.
    4. Añada una fila para el GUID.
      • Haga clic en Insertar > Componente > Fila

        Seleccione un tipo de contenido para la fila y haga clic en OK.

      • Haga clic en Insertar > Texto y, a continuación, escriba el texto guid: , Guid: o GUID:. Haga clic en OK.

        Esto permite seleccionar los objetos del modelo.

      • Haga clic en Insertar > Campo de Valor . Haga clic en un punto para definir la ubicación del campo dentro de la fila. Aparecerá el cuadro de diálogo Seleccionar Atributo solicitándole que seleccione un atributo para el campo de valor.

        Seleccione el atributo GUID y haga clic en OK.

    5. Añada el resto de filas necesarias en el cuadro.
    6. Haga clic en Archivo > Grabar Como .

      Asigne un nombre al cuadro y busque la carpeta ..\environment\<your_environment>\template. Use la extensión de nombre de archivo .rpt.

  2. Cree un informe basado en el cuadro de informe que ha guardado.
    1. En la pestaña Dibujos e informes , haga clic en Informes.
    2. Seleccione en la lista el cuadro de informe que ha creado.
    3. Haga clic en Todas las partes.

      Tekla Structures muestra el informe.

  3. Haga clic en una fila que contenga un número GUID en el informe.

    Tekla Structures selecciona el objeto correspondiente en la vista del modelo activa.

¿Le ha resultado útil?
Anterior
Siguiente