Create a template in HTML format

Tekla Structures
2024
Tekla Structures

Create a template in HTML format

Templates in the HTML format give you more possibilities for different layout, fonts, and images. Templates that generate output in HTML format are graphical and have the file name extension .html.rpt.

Note:

If you add images to your HTML template, the images must be in the ..\Program Files\Tekla Structures\<version>\bin\applications\Tekla\Tools\TplEd\bitmaps folder. Images in other folders are not shown in the HTML output.

  1. On the File menu, click Editors > Template Editor.
  2. In the Template Editor, click File > New.
  3. Select Graphical template, then click OK.
  4. Add new rows in the template.
    1. To add a new row, click Insert > Component > Row.
    2. Select a content type for the row, then click OK.
  5. Add value fields to get the required data from your Tekla Structures database.
    1. Click Insert > Value field.
    2. Click a point to define the location of the field within the row.

      The Select Attribute dialog box open and prompts you to select an attribute for the value field.

    3. Select an attribute, then click OK.
  6. Add a header for each value field.
    1. Click Insert > Component > Header...
    2. Click Insert > Text...
    3. Enter a heading for the template, and then click OK.
    4. Click a point to define the location of the heading in the header row.
  7. Save the template:
    1. Click File > Save as
    2. Save the template in the model folder. If you want to use the template in other projects as well, save the template in the template folder defined for the advanced option XS_FIRM or XS_PROJECT.
    3. In the File name field, enter a name for the template.

      Include the extension *.html.rpt in the file name. For example, Part_list.html.rpt.

    4. Click OK.

Example

  1. Header that contains text fields
  2. Row that contains two value fields
Tip:
  • To export reports to Microsoft Excel with a certain layout, for example, merged cells, border lines, font types and sizes, you can use HTML in Template editor. When you save the template with the file name extension .xls.rpt, the Excel report will automatically open in Excel when Show report is set to With associated viewer. For more information, see How to make basic HTML-based excel reports.

  • To create an additional set of pictures to the report folder, set the advanced option XS_​CREATE_​ALSO_​BIG_​HTML_​REPORT_​PICTURES to TRUE. The pictures are three times larger in size compared to the ones in the HTML report.

Was this helpful?
Previous
Next