Change the rendering of parts, components and reference models

Tekla Structures
2024
Tekla Structures

Change the rendering of parts, components and reference models

You can easily change the rendering of parts, components and reference models in model views.

  1. On the View tab, click Rendering.
  2. Select one of the rendering options for parts, components, or reference models:

    Option

    Description

    Example

    Parts wireframe/Components wireframe/References wireframe

    Object outlines are displayed, surfaces are not. Objects are transparent.

    In this example, component objects are displayed as rendered.

    In DirectX rendered views, the part edge lines hidden behind another part are visualized with dashed lines if you have switched the Dashed line for hidden line option on in File menu > Settings > Switches.

    In this example, component objects are displayed as rendered.

    Parts shaded wireframe/Components shaded wireframe/References shaded wireframe

    Object outlines are displayed. Objects are transparent, and their surfaces are rendered.

    In this example, component objects are displayed as rendered.

    In DirectX rendered views, the part edge lines hidden behind another part are visualized with dashed lines if you have switched the Dashed line for hidden line option on in File menu > Settings > Switches.

    In this example, component objects are displayed as rendered.

    Parts grayscale/Components grayscale/References grayscale

    Objects are shown in grayscale.

    In this example, component objects are displayed as rendered.

    In DirectX rendered views, the part edge lines hidden behind another part are visualized with dashed lines if you have switched the Dashed line for hidden line option on in File menu > Settings > Switches.

    In this example, component objects are displayed as rendered.

    Parts rendered/Components rendered/References rendered

    Object surfaces are displayed. Objects are not transparent.

    In DirectX rendered views, any duplicate objects or overlapping parts on the same plane are visualized with a hatch if you have switched the Hatching of overlapping surfaces option on in File menu > Settings > Switches.

    In this example, the overlapping surfaces are visualized with a hatch.

    Show only selected part/Show only selected component/Show only selected reference

    Selected objects are displayed. Other objects are almost completely transparent.

    This option is useful, for example, when viewing clash check results in a large model.

    In this example, component objects are displayed as rendered.

    In DirectX rendered views, the part edge lines hidden behind another part are visualized with dashed lines if you have switched the Dashed line for hidden line options on in File menu > Settings > Switches.

    In this example, component objects are displayed as rendered.

Tip:

Alternatively, you can use the keyboard shortcuts Ctrl+1...5 for parts and Shift+1...5 for components to switch between the rendering options. Ctrl+Shift+1...5 works for references.

Was this helpful?
Previous
Next