Add symbols in drawings

Tekla Structures
2021
Tekla Structures

Add symbols in drawings

You can use symbols in drawings as such and in marks, object representations, and line arrows. Symbols can be created and edited in Symbol Editor.

Add symbols in drawings

You can add symbols in open drawings.

Symbols added in open drawings can be represented in three different ways: without leader line, with leader line, and along line. Tekla Structures adds symbols using the properties defined in Symbol Properties. All types of marks allow you to add symbols in them.

  1. In the drawing, hold down Shift and, on the Annotations tab, click Symbol and one of the following symbol commands:
    • Symbol: Add a symbol in the current drawing without a leader line.

    • Along line: Create a symbol along the line you define by picking two points. Then pick an insertion point for the symbol.

    • With leader line: Add a symbol with a leader line pointing to the point you pick first.

      For more information about the leader line types, see Leader line types.

  2. Modify the symbol properties:
    • File: Change the symbol file in use.
    • Number: Change the symbol.
    • Symbol: Change the color, height and angle of the symbol.
    • Frame: Change the frame type, leader line and color.
  3. Click OK.
  4. Pick one to three points in the drawing to place the symbol. The symbol command you selected affects the number of points to pick.

Add symbols in marks

You can select the symbol file to be used and the symbol to be added in the mark.

  1. In an open drawing, double-click a mark.
  2. In mark properties, double-click Symbol in the Available elements list.
  3. In the Mark content - Symbol dialog box, click Select next to the File box to select the symbol file you want to use.
  4. When you have selected the file, click Select next to the Number box, and double-click the symbol you want to use. You can also enter the number of the symbol if you know it.
  5. Click OK.

    Tekla Structures adds the name of the symbol file and the number of the symbol in the elements list.

  6. Click Modify in mark properties.

    Tekla Structures adds the symbol in the mark.

Change a symbol in a symbol file

You can make changes in a symbol in a symbol file. If you do this, we recommend that you save the file with another name and save it in another folder, for example, in model, firm or project folder.

  1. Depending on where you are in Tekla Structures, you can open a symbol file in Symbol Editor in several ways:
    • On the File menu, click Editors > Symbol editor. Open a symbol file using File > Open.
    • Open the Mark content - symbol dialog box by double-clicking a mark in an open drawing, and selecting Symbol from the available mark elements list in the mark properties dialog box. Then click Select..., select a file from the Symbol files browser and click Edit....
    • Open the Symbol Properties dialog box by double-clicking a symbol that you have added in a drawing. Then click Select..., select a file from the Symbol files browser and click Edit....
  2. Modify the file in the Symbol Editor:
    1. Click symbol in slot and sketch your new symbol with drawing tools.

      You can also import AutoCAD or MicroStation files on the Import tab.

    2. When you are happy with the symbol, point the symbol slot to check the number of the new symbol at the bottom of the window.

      In many places, when adding a symbol, you need to know the number of the symbol to be able to use it.

  3. Click File > Save as... and give a new name.

    You can also save the file with a new name in a new location, for example, in model, firm or project folder. We strongly recommend that you do not the original symbol files delivered with your Tekla Structures software. If you need to modify any symbols, copy the original symbol file and work on the copy, keeping the original symbol file intact.

    Tekla Structures reads the symbol files in certain search order, section "Symbol file search order" below.

  4. Click OK.
Tip:

In Symbol Editor, you can copy symbols between symbol files (*.sym). Press Ctrl + C and select the symbol you would like to copy, then open the symbol file you want to copy to (or a new symbol file), select the location for the symbol and press Ctrl + V.

Change the symbol file in use

You can change the currently used symbol file if the current symbol file does not contain the symbols that you need.

  1. Do one of the following, depending on what you are working with:
    • Open the Mark content - symbol dialog box by double-clicking a mark in an open drawing, and selecting Symbol from the available mark elements list in the mark properties dialog box.
    • Open the Symbol Properties dialog box by double-clicking a symbol that you have added in a drawing.
  2. Click Select... next to the File box.
  3. Select a new file from the Symbol files list and click OK or double-click the file.

Create a new symbol file

In addition to the default symbol files that are delivered with Tekla Structures, you can create symbol files of your own, and save them in model, firm, or project folder, for example.

If you decide to use your own files, you can add DXK_SYMBOLPATH in the options.ini file under the model folder and define your own symbol file folder paths there. The symbol files are read in a certain search order, see section "Symbol file search order" below.

  1. On the File menu, click Editors > Symbol editor.
  2. Click File > New.

    You can also open an existing symbol file, edit it and save with a new name.

  3. Create the symbol in the Symbol Editor.
  4. Click File > Save and save the symbol file in the folder that you use for keeping your symbol files.

    If you opened an existing symbol file, use File > Save as and give the symbol file another name.

Modify symbol properties

You can modify the properties of symbols in an open drawing.

To modify the symbol properties:

  1. Double-click a symbol.
  2. Switch all the check boxes off in the dialog box by clicking the on/off switch at the bottom of the dialog box, and select only the check boxes next to the properties that you want to modify..
  3. If necessary, change the symbol file in use and select the symbol to use.
  4. To modify symbol placement settings, click Place...

    Here you can set the placing to free or fixed, specify the search margin, minimal distance and select the desired quarter to place the symbol.

    For more information, see Placement properties for marks, dimensions, notes, texts and symbols.

  5. Go to the Appearance tab and set the symbol color, height and angle, and the frame type, leader line and color.
    For more information about the leader line types, see Leader line types.
  6. Click Modify.

Customize leader line arrow symbols

If you do not find a suitable leader line arrow in the Arrow list in mark properties, you can add an arrow of your own.

First you will create the arrow symbol in the Symbol Editor, and save the created symbol in the arrow.sym file. Then you need to add the position of the new symbol in the arrow.sym to the configuration file arrow.txt file, which tells which arrows are available for use in your environment.

  1. On the File menu, click Editors > Symbol editor to open the Symbol Editor.
  2. Open the arrow.sym file located in common environment or in your environment under symbols folder.
  3. Click an empty symbol slot and sketch your symbol with drawing tools.

    You can also import AutoCAD or MicroStation files through File > Import.

  4. When the symbol is completed, point the symbol slot to check the number of the new symbol at the bottom of the window.

  5. Save the arrow.sym file by clicking File > Save.
  6. Click File > Exit to close the Symbol Editor.
  7. Open the arrow.txt file located in the same symbols folder as the arrow.sym file.

    The file contains a list of symbol numbers.

  8. Add the number of your symbol preceded by zero (0) in the correct position and separate it with a comma:

    016,017,018,019,020,021,022,023,024,032,048,049,101,102,110,200

  9. Click File > Save to save your change.
  10. Add a bitmap of the created arrow in the ..\ProgramData\Trimble\Tekla Structures\<version>\Bitmaps folder on your computer.

    Use the following format in the file name: dr_dialog_arrow_type_022.bmp.

  11. Double-click a mark in a drawing to open mark properties.
  12. Open the Arrow list, and you should see that the new arrow symbol is now available for use.

Note:

We recommend you define a firm folder for symbols, because the default folders are overwritten when you upgrade to a newer version of Tekla Structures. Add the firm folder to the advanced option DXK_​SYMBOLPATH.

Add surfacing symbols in drawings

You can add surfacing symbols in cast unit drawings using the Add surfacing symbols macro.

Before you start, ensure that you have an object that has surface treatment in the model, and that you have created a cast unit drawing of that object. Also check in the cast unit drawing properties that the surface treatment is set to Visible.

  1. Open a drawing that has a part containing surface treatment.
  2. Click the Applications & components button in the side pane to open the Applications & components catalog.
  3. Click the arrow next to Applications to open the applications list.
  4. Double-click Add surfacing symbols.

  5. In the Create surface symbols dialog box, select the texts that you want to include in the surface treatment symbol from the Available elements list and add the texts to the Elements in mark by clicking Add >.
  6. Select All Views to include the symbols in all drawing views, or Selected Views to include the symbols only in the views you select.
  7. Change the font settings, if necessary.
  8. If you selected Selected Views, select the views where you wish to have surface treatment symbols.
  9. Click Create.

Tekla Structures creates the surface treatment symbols according to the defined settings. You can change the symbol properties and the text afterwards in Text Properties, which is opened when you double-click the symbol.

Symbol Editor

You can open Symbol Editor by clicking File > Editors > Symbol editor. In Symbol Editor, you can create new symbol files, and create and modify symbols.

The Symbol files dialog box in drawing mode allows you to change the symbol file in use. It also provides access to Symbol Editor.

We recommend that you have a look at the Symbol Editor User's Guide, so that you get familiar with creating new symbols and modifying the existing ones.

We strongly recommend that you do not modify the original symbol files delivered with your Tekla Structures application. If you need to modify any symbols, copy the original symbol file and work on the copy, keeping the original symbol file intact.

If your symbols are located in a protected folder, the symbols are read-only, because you cannot save a modified symbol in a protected folder if you are not an administrator. In this case, run Tekla Structures as administrator.

Symbol file search order

The symbol files (.sym) are searched from the following folders in the following order:

  1. All DXK_SYMBOLPATH folders

    The advanced option DXK_​SYMBOLPATH is defined in the environment initialization file <your_environment>.ini and in the Tekla Structures initialization file teklastructures.ini.

    Alternatively, you can add your own DXK_​SYMBOLPATH in options.ini under the model folder and define your own symbol folder paths there. Note that also the path settings in the <your_environment>.ini file need to be added there.

    The reading order of the .ini files containing the DXK_SYMBOLPATH definition:

    1. teklastructures.ini

    2. <your_environment> .ini

    3. options.ini

  2. Current model folder

    Add here any additional symbol files that you might need.

All symbol files that are found are available to be used in Tekla Structures. If there are duplicate file names, the first one found is used and the rest are discarded. If the model folder contains a symbol file that has the same name as another symbol file in DXK_SYMBOLPATH, the one in the model folder is discarded.

Example of overriding a symbol temporarily

If there is no permanent need to add your own symbol paths in the options.ini file in the model folder, you can temporarily override symbols. In this example, you will temporarily override the weld symbol with a customized symbol located in your model folder:

  1. Customize the symbol in ts_welds.sym first.
  2. Copy the edited ts_welds.sym in your model folder C:\TeklaStructuresModels\ <mymodel>
  3. Open the options.ini file located in your model folder, and add the line DXK_SYMBOLPATH=C:\ TeklaStructuresModels\<mymodel>; C:\TeklaStructures\2017\Environments\common\symbols; + possible other symbol folders in your local environment.

Define a firm folder for images and symbols

You can define a firm folder where Tekla Structures always searches for the images and symbols. When you store the images and symbols in this folder, you do not have to move them from folder to folder when you install a new version of Tekla Structures. Installing a new version does not replace the files in the firm folder.

Define the firm folder in the options.ini file under the model folder or user.ini using the advanced option XS_FIRM.

To define the firm folder for images and symbols in the options.ini file:

  1. Modify the options.ini file to include the advanced option DXK_SYMBOLPATH that points to the firm folder.

    The advanced option DXK_SYMBOLPATH may contain multiple paths separated by semicolons.

    Since Tekla Structures version 19.0, the folder path definitions like %DATADIR% or %XS_FIRM% in DXK_SYMBOLPATH have not converted the paths correctly when used in options.ini located in the firm folder. However, these definitions work correctly if used in user.ini. Currently in options.ini in the firm folder you need to write the absolute paths for DXK_SYMBOLPATH, like in the example below:

    DXK_SYMBOLPATH=C:\ProgramData\Trimble\Tekla Structures\2017\Environments\common\symbols\;C:\firm\Symbols\;

  2. In Template Editor, click Options > Preferences > File Locations and enter the path to the firm folder also for Symbols, pictures.
Was this helpful?
Previous
Next