Environment, company, and project settings for administrators

Tekla Structures
2019i
Tekla Structures

Environment, company, and project settings for administrators

Environment settings

Common settings

All settings and files that are the same in all environments are located in the \Tekla Structures\<version>\Environments\common folder. Files and settings that are specific to an environment are located in separate environment folders.

The env_global_default.ini file is also located in the \common folder. The file determines the standard settings, and it is the first file that is read. Other initialization files are read after this file, and if the other files contain the same settings, they will override the previous settings.

Country-specific settings

The country-specific settings are located in the environments folders, and they are localized by your local Trimble office/reseller. The folder structure of the environments can vary, but the same kind of settings exist. For example, the settings that are localized include profile database, material database, reports, selection filters, view filters, components and custom components, macros, user-defined attributes, and drawings settings.

Company settings

Company-level settings are mainly settings that are used throughout the company for all projects. These settings are set using XS_SYSTEM and XS_FIRM.

For a larger company with subsidiaries, the settings could be used as follows:

  • XS_SYSTEM may contain multiple paths, and it points to general settings inside the company. These can be company logo, reports, printer settings, drawing settings, templates, for example. These are settings that very seldom change, and are stored on a server available for all. For example, if the company logo is updated, it only has to be replaced in one place.
  • XS_FIRM points to the firm folder set up by the company, or a subsidiary. The folder contains all the company settings used at the particular office. These can be logos, drawing settings, templates, reports, or printer settings, for example. The firm folder can also have user-defined sub-folders for storing property files.
  • XS_PROJECT points to the project folder. The folder contains project settings, such as logos for contractors and fabricators, or drawing settings, for example. The project folder can also have user-defined sub-folders for storing project-specific property files.

For more information on the folder search order, see Folder search order.

You can also use Tekla Warehouse company-specific collections online or offline, in your own network. Use Trimble Identity for downloading or installing from the online collections. See also Trimble Identity for Tekla Online services.

The offline collection access is managed with folder rights in your network, and on the collection level in the collections.json file on each user's computer.

 "collections" 
"\\\\server-A\\company\\Tekla Structures collection" 
		

The collections.json file can be shared to selected persons by copying it to the C:\Users\Public\Documents\Tekla\Tekla Warehouse\ folder.

Model templates

You can save a model with the desired settings and use the model as a template when you create new models. This can be very useful if your company has different kinds of projects, such as, parking garages, office buildings, bridges, and industrial.

When you create a model template, always start by creating a new empty model. This is because old models that have been used in live projects cannot be completely cleaned. They may contain excess information that increases the size of the model even if you delete all objects and drawings from the model.

To create a model template:

  1. Create a new model and give it a unique name.
  2. Add in the model the desired profiles, custom components, and other necessary items.
  3. On the File menu, click Save as > Save.

    You need to save the model to include custom components in the xslib.db1 file. If you do not save the model, custom components will not be included in the model template.

  4. On the File menu, click Save as > Save as model template.
  5. Enter a name for the model template, and select which catalogs, drawing templates, report templates, and model subfolders you want to include in the model template.
  6. Click OK.

    By default, the model template folder is saved in your environment folder, under ..ProgramData\Trimble\Tekla Structures\<version>\environments\<your environment>\. The exact folder location may vary depending on your environment and role. Use the advanced option XS_​MODEL_​TEMPLATE_​DIRECTORY to define a different location.

You can download, share, and store model templates in Tekla Warehouse. The image below shows an example of a model template in Tekla Warehouse.

The Insert into model button in Tekla Warehouse installs the model template directly in the folder pointed by XS_MODEL_TEMPLATE_DIRECTORY. You can immediately use the template when creating a new model.

Model templates in Tekla Structures version update

We strongly recommend that you update your model templates in Tekla Structures version upgrade.

To update a model template:

  1. Create a new model using an existing model template.
  2. Give the model the same name as in the previous Tekla Structures version.
  3. Open a 3D view.
  4. On the File menu, click Diagnose and repair > Diagnose model.
  5. On the View tab, click Screenshot > Project thumbnail to create a project thumbnail, or add a custom image named thumbnail.png in the model folder.

    The preferred size of the image is 120 x 74 pixels.

  6. On the File menu, click Save as > Save.

    If you do not do this, a message may appear warning about the model being created with a previous version.

  7. On the File menu, click Save as > Save as model template.
  8. Select which catalogs, drawing templates, report templates, and model subfolders you want to include in the model template.
  9. Click OK.
  10. Remove manually all *.db files (environment database, options database files) from the model folder.

    The *.bak , *.log and xs_user files are automatically removed from the model folder.

    Do not remove the .idrm files ( db.idrm and xslib.idrm ) as they are part of the model.

    The model template is saved in a location pointed by XS_MODEL_TEMPLATE_DIRECTORY.

    You now have a sample image for your model template. The Applications & components catalog is now also in order and easy to use.

Customizing reports and drawings

If your company already has graphical templates in the DXF, DWG, or DGN format, you can convert these templates to Tekla Structures templates. For detailed instructions on how to do this, see the information on AutoCAD and Microstation files in the Template Editor Help.

For information on how to create your own templates and reports, see the Template Editor Help, and Reports and Templates.

Cloning templates for drawings

You should consider cloning drawings when:

  • There are several similar parts, assemblies, or cast units in the model.
  • You need to produce single-part, assembly, or cast-unit drawings of similar parts, assemblies, or cast units.
  • The drawings need a lot of manual editing.

For example, you can create a drawing for one truss, edit the drawing, and then clone it for similar trusses. Then you only need to modify the cloned drawings where the trusses differ.

The cloned drawing may contain more parts than the original drawing. Part properties, marks, associative notes and related text objects are cloned from a similar part in the original drawing.

Clone templates in Master Drawing Catalog

You can clone drawings by using the Master Drawing Catalog templates. A cloning template in the Master Drawing Catalog can also be used in other models. They can be used in projects that have the same kind of drawings.

To create cloning templates:

  1. Select a drawing in Document manager.
  2. Right-click and select Add to Master Drawing Catalog , and then fill in the required properties.

The cloning template can be found under Cloning templates in the Master Drawing Catalog. To use cloning templates in other models, open the Master Drawing Catalog in the model, click the button on the toolbar, and add the model where the templates are saved.

For more information on the Master Drawing Catalog and cloning templates, see Create drawings in Master Drawing Catalog.

Project settings

Create your own component folder

Usually, only a few different connections and components are used in a project. To ensure that everyone in the project uses the same components and finds the components faster, we recommend that you create a component folder of your own.

  1. Click the Applications & components button in the side pane to open the Applications & components catalog.
  2. Create a new group for the project: Right-click in the catalog and select New group.
  3. Add components to the group: Select the components in the catalog, right-click and select Add to group. Then select the group to which the components are added. You can also drag the selected components to another group.
  4. Hide the groups that you do not need: Select the group, right-click and select Hide/Unhide.
Tip:

In the Applications & components catalog, use the commands in Access advanced features > Catalog management to modify catalog definitions. For more information, see Customize the Applications & components catalog and XS_​COMPONENT_​CATALOG_​ALLOW_​SYSTEM_​EDIT.

For more information on the Applications & components catalog, see How to use the Applications & components catalog.

Define project properties

Project information is needed many times during a project. Define the project information at the beginning of a project to make reports and drawings display the correct information automatically. You can also update the project properties during the project.

  1. On the File menu, click Project properties.
  2. Edit the project properties.

    When you edit the properties, Tekla Structures highlights the modified properties in yellow.

  3. When you are ready with the modifications, click Modify to apply the changes.

Create and modify templates and reports

You can modify existing reports and templates, or create your own templates by using Template Editor. To open Template Editor, click File > Editors > Template editor , or double-click an existing table in an open drawing to open the tool. For more information, see Template Editor User's Guide.

Note that if your templates are located in a protected folder, the templates are read-only, and you cannot save a modified template in a protected folder. In this case, run Tekla Structures as an administrator.

Set up printers

Tekla Structures uses Windows drivers to write the print data directly to the Windows print device interface. You can print drawings as PDF files, save them as plot files ( .plt ) for printing with printer/plotter, or print them on a selected printer. To print to several paper sizes, you need to modify the drawingsizes.dat file, see more in Configuration files used in printing. You can also change the line width of the printed drawings, see more in Print to a single printer and Line thickness in drawings.

You can affect the way Tekla Structures automatically names the .pdf files and plot files by using certain drawing-type-specific advanced options, see more in Customize print output file names.

Was this helpful?
Previous
Next