2021 SP3: Model & results - New interactive 1D member forces table & filters

Tekla Structural Designer
2021
Tekla Structural Designer

2021 SP3: Model & results - New interactive 1D member forces table & filters

A powerful new tabular results feature for 1D Members is added in this release. This replicates the output of the recently enhanced “Member Forces” Report item (for more on this see the Reports & Drawings section of the 2021 SP2 Release Notes). The table features real-time filtering and configuration settings to customize the results exactly as you need. The configured table can then be exported directly to Excel to facilitate further result processing.

  • The new table “1D Member Forces” is available via Analyze > Model & Results from the drop list of table options as shown in the picture below. The table is immediately populated with the results for the selected load case, combination or envelope (at the left of the status bar at the bottom of the program window).
  • Note the following further options:

    • Imposed/ Live Load Reductions - activate the “Imposed/ Live Load Reductions” (I/LLR) option for results including these or deactivate to exclude them.
      • [TSD-9962] - as part of this enhancement, the ability to view 1D member results including I/LLR for envelopes for all appropriate member characteristics is added in the Results View and Load Analysis View (where previously it operated only for columns).

    • Strength/ Service Factors - activate the “Strength Factors” or “Service Factors” to see Strength or Service level results as you require.

  • Filtering - when the new 1D Member Forces table is selected, “Table Options” and “Model Filter” buttons appear on the ribbon. These enable configuration of the table as described below - the table is automatically updated following changes to these settings:

    • Model Filter - new filters can be added from a comprehensive list of filter types as shown in the picture below. You can also select an already created Report filter (more on this below).

      • To add a filter, select “Add filter…” then “New” then one of the filter options as shown below. The selected filter type is added as a new row in the Filter dialog. You then select this row to display its options - such as a list of model levels for the “Selected levels” option as shown. You can enable individual options, click the “+” button to activate all options, the “” button to deactivate all and the button to remove the filter type row.

      • Any number of filters can be added. For multiple filters, note the additional options to “Match all rules” or “Match any rule”.
    • Table Options - enables control of the number of fixed positions for which results are reported along members, with separate settings for beams and columns. The minimum number of positions for beam and column is 2 (ends only) and the maximum is 50.

      • There is an additional option to “Include points of interest” which are max/ min values for any of the reported results which are larger than those at any fixed position. When this is enabled (default) you can optionally enable “Skip positions close to points of interest” and the associated span/ factor which defines the distance for this. These options can be used together with the number of positions specified to control the number of rows included in the table.
  • Export to Excel - the 1D Member Forces results table can be exported directly to Excel via the Ribbon Export > Excel button. The exported data includes the selected; Analysis Method; case/ combination/ envelope; Load reductions applied/ not applied; combination factors Strength/ Service. When filtering is applied, all the active filters are also listed above the table as shown below.
  • Report Filters - As mentioned above, existing Report filters can also be selected in the Model Filter dialog.

    • Although not a new feature, it is worth highlighting here that Selected Member filters can be easily and rapidly graphically populated via the Review View > Show/Alter state > Report Filter command as shown in the picture below. Note that before using this graphical method, you first add the Selected Member filter(s) you need via the Report ribbon > Filters > Member option (there’s no need to manually add any members to them at this stage).

    • All your Report filters are then available for selection in the Model Filter dialog from the “Saved Report Filter” option as shown below. When filtering is applied, all the active filters are listed in a header above the table.

    • Note that you can also double-click a row in the table to select the associated member in the active views.

  • Reports - the options for the corresponding “Member Forces” report item are also enhanced as follows:

    • The previous “Positions Filter” menu options for beams and columns are removed and replaced with position number input boxes in the item Settings dialog as shown in the picture below.

    • The “Include points of interest” option and associated “Skip positions close to points of interest” setting detailed above are also added to further control the contents of the report table in the same manner as the Model and Results table.
Was this helpful?
Previous
Next