Scene content entity categories

Tekla Structural Designer
2021
Tekla Structural Designer

Scene content entity categories

The following paragraphs describe some of the most important entity categories of Scene Content.

Architectural Grids

Allows you to show or hide architectural grids in 3D views. When selected, architectural grids are displayed at the lowest level of the model.

Grid & Construction Lines

Allows you to show or hide grid and construction lines at individual levels in both 2D and 3D views.

You can control the levels at which grids are or are not displayed in the Properties window for each level. Grids are only displayed in 3D views if the Show grids in the 3D view option is selected and in 2D views if the Show grids in plane view option is selected.

Members

Allow you to manage how each member type is displayed. For each of the mentioned elements, you can display the following information:

Geometry

Displays the faces of the member by shading them according to the member type.

The following image displays a concrete beam and column example with the Geometry and Architectural Grids options selected.

InsertionLine

Displays a solid line between the start and end node of the member.

The following image displays the concrete beam and column example with the InsertionLine and Architectural Grids options selected.

LoadingLine

Displays a solid line through the center of the member. Any member loads are applied along the line.

The following image displays the concrete beam and column example zoomed with the InsertionLine and LoadingLine options selected.

Normals

Displays the normal directions at each corner of the member.

The following image displays the concrete beam and column example zoomed with the Geometry and Normals options selected.

Text

Displays the member name.

The following image displays a composite steel beam example with the Geometry and Text options selected.

Text2D

Displays the member name, section and class in the 2D plane of the member.

The following image displays the composite beam example with the Geometry and Text2D options selected.

Direction

Displays the direction from end 1 to end 2 of the member.

If the direction is incorrect, go to the Edit tab and click Reverse.

The following image shows the composite steel beam example with the InsertionLine and Direction options selected.

BoundingBox

Displays the bounding box of sections. Selecting the option may simplify right-clicking sections of a small cross section.

The following image displays the composite steel beam example with Geometry and BoundingBox selected.

Decking

Displays the strip of decking that is connected to the member.

The following image displays the composite steel beam example with Geometry and Decking selected.

Plan

Note:

The Plan entity category is only available in 2D views.

The initial display for 2D views is configured for modeling purposes, so by default, it does not display all the information that will be output when drawings are created. However, you can select the Plan entity category to overlay one of the following planar drawing categories on the 2D view:
  • General arrangement
  • Beam end forces
  • Foundation layout
  • Loading plan
  • Slab/mat layout

You can also select the individual drawing layers to be overlaid. The Plan category can be very useful, as it allows you to display information that would otherwise not be available whilst modeling.

To use the Plan category, do the following:

  1. Open a 2D view.
  2. In Scene Content, select Plan.
  3. In the list on the right side of the Plan category, you can select the drawing category.
  4. Click the arrow on the left side of the Plan category to view the different drawing layers that you can optionally display.

    Only the layers that exist in the previously mentioned planar drawing categories can be displayed. The most important layers are:

    NameDescription
    General Allows you to display grids, construction lines, and dimensions as they would appear in drawings.
    Members Allows you to display the various different member types labeled as they would appear in drawings.
    Walls Allows you to display concrete walls labeled as they would appear in drawings.
    Slabs/Mats Allows you to display concrete slabs labeled as they would appear in drawings.
    Other Allows you to display various other items that can be output to drawings.
    Note:

    It is not yet possible to overlay beam end forces or foundation reactions on a scene view. However, you can display them in general arrangement drawings.

    Tables Allows you to display tables of information that can be output to drawings.
    Connections Allows you to display connection names, attributes, and reactions as they would appear in drawings.
    Beam End Forces Allows you to display beam end forces as they would appear in drawings.

    By default, the layers that are initially selected match those in the first layer configuration for the drawing category in Model Settings > Drawings > Layer Configurations.

  5. Select or clear the layers according to your needs.
    Tip:

    Layer content can be further controlled in Model Settings > Drawings > Layer Configurations.

Example

To illustrate how the Plan category would typically be used, consider the following composite beam example designed to the AISC 360 ASD head code:

In the following floor view, the standard beam labeling for modeling is applied. The labeling consists of the beam name, section, grade, number of connectors, and transverse reinforcement.

When you produce drawings, additional design information would probably also be conveyed. The information can contain, for example, the amount beam camber required. The camber is included in one of the drawing layers, so you can include it in the 2D scene view, as long as you know the layer it belongs to.

To include the camber, do the following:
  1. Open a 2D scene view containing the beams.
  2. In Scene Content, select Plan.

    Depending on the current scene content selection, there may be a substantial duplication of axes, members, labeling, and so on.

  3. Expand the Plan category and do the following:
    1. Clear the Members and Slabs/Mats options.
    2. Select options according to the following images:

      The scene view should now appear less cluttered, as shown in the following image.

  4. On the Draw tab, click Settings and adjust the drawing settings as follows:
    1. Go to Options > Planar Drawings > General Arrangement.
    2. Go to the Beams tab.
    3. Ensure that the Camber option is selected.
    4. Go to the Slabs/Mats tab.
    5. Clear all Panel Labelling options and the Include panel span direction symbol option.
    6. Click OK.

    The drawing is updated to match the new drawing options.

Was this helpful?
Previous
Next