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Disclaimer 

This Software Manual has been developed for use with the referenced Software. Use of the Software, and use of this 
Software Manual are governed by a License Agreement. Among other provisions, the License Agreement sets certain 
warranties for the Software and this Manual, disclaims other warranties, limits recoverable damages, defines 
permitted uses of the Software, and determines whether you are an authorized user of the Software. All information 
set forth in this manual is provided with the warranty set forth in the License Agreement. Please refer to the License 
Agreement for important obligations and applicable limitations and restrictions on your rights. Trimble does not 
guarantee that the text is free of technical inaccuracies or typographical errors. Trimble reserves the right to make 
changes and additions to this manual due to changes in the software or otherwise. 
 
In addition, this Software Manual is protected by copyright law and by international treaties. Unauthorized 
reproduction, display, modification, or distribution of this Manual, or any portion of it, may result in severe civil and 
criminal penalties, and will be prosecuted to the full extent permitted by law. 
 
Tekla, Tekla Structures, Tekla BIMsight, BIMsight, Tekla Civil, Tedds, Solve, Fastrak and Orion and are either registered 
trademarks or trademarks of Trimble Solutions Corporation in the European Union, the United States, and/or other 
countries. More about Trimble Solutions trademarks: http://www.tekla.com/tekla- trademarks. Trimble is a 
registered trademark or trademark of Trimble Navigation Limited in the European Union, in the United States and/or 
other countries. More about Trimble trademarks: http://www.trimble.com/trademarks.aspx. Other product and 
company names mentioned in this Manual are or may be trademarks of their respective owners. By referring to a 
third party product or brand, Trimble does not intend to suggest an affiliation with or endorsement by such third 
party and disclaims any such affiliation or endorsement, except where otherwise expressly stated. 
 
Portions of this software: 
D-Cubed 2D DCM © 2010 Siemens Industry Software Limited. All rights reserved. 
EPM toolkit © 1995-2004 EPM Technology a.s., Oslo, Norway. All rights reserved. 
Open CASCADE Technology © 2001-2014 Open CASCADE SA. All rights reserved. 
FLY SDK - CAD SDK © 2012 VisualIntegrity™. All rights reserved. 
Teigha © 2003-2014 Open Design Alliance. All rights reserved. 
PolyBoolean C++ Library © 2001-2012 Complex A5 Co. Ltd. All rights reserved. 
FlexNet Copyright © 2014 Flexera Software LLC. All Rights Reserved. 
This product contains proprietary and confidential technology, information and creative 
works owned by Flexera Software LLC and its licensors, if any. Any use, copying, publication, distribution, display, 
modification, or transmission of such technology in whole or in part in any form or by any means without the prior 
express written permission of Flexera Software LLC is strictly prohibited. Except where expressly provided by Flexera 
Software LLC in writing, possession of this technology shall not be construed to confer any license or rights under any 
Flexera Software LLC intellectual property rights, whether by estoppel, implication, or  
otherwise. 
 
To see all the third party licenses, go to Tekla Structures, click Help --> About and click the Third party licenses button. 
 
The elements of the software described in this Manual are protected by several patents and possibly pending patent 
applications in the United Stated and/or other countries. For more information go to page 
http://www.tekla.com/tekla-patents. 
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Conventions used in this guide 

Typographical conventions 

The following typographical conventions are used in this guide: 

Header Usage  

Bold  Any text that you see in the user interface appears in bold. This 
font is used, for example, for window and dialog box titles, box 
and button names, and list items.  

Italic bold  New terms are in italic bold when they appear in the current 
context for the first time.  

Note boxes 

The following types of note boxes are used in this guide:  

 

 
A tip might introduce a shortcut, or suggest alternative ways of doing 
things. 

 

 

 

 
A note draws attention to details that you might easily overlook. It 
can also point you to other information in this guide that you might 
find useful. 

 

 

 
You should always read very important notes and warnings, like 
this one. They will help you avoid making serious mistakes, or 
wasting your time. 

 

 
 

 
This symbol indicates advanced or highly technical information 
that is usually of interest only to advanced or technically-oriented 
reader 
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1 Creating a User Library and Publishing Calculations 

1.1 Session topics 

• Introduction to libraries 
– Creating a user library 
– Saving and using items 

• Publishing calculations 

1.2 The User Library 

1.2.1 Introduction to the User Library 

The library Access System is a powerful and flexible utility which stores all the information needed to 
run a calculation.   

Mode One: Simple Mode   Mode Two: Advanced Mode 

• Default mode  
• Only allows retrieval of items from 

Calc Library 

• Retrieve items from the Calc Library 
• Add, remove and edit items from the 

User Library 
 

There are two types of Libraries: 
System  Contain fixed information which cannot be easily changed; includes the built-in calculations that 

Tedds provides 
User  Contain your own information and can be changed anytime; includes custom calculations that 

you have written.  Once saved into this library the calculation can be accessed from the ‘My 
Calculations’ index and run the same way as Tedds calcs. 
 

 
 

 
 



1 Creating a User Library and Publishing Calculations 8 (39) 

 

Training manual Tekla Tedds e-Learning 
© Trimble Solutions Corporation | March 1, 2016 Tedds: Expert 

 

The Library Access System uses two components and both are required to work properly: 
Calc Library (.LBR file) This is where the calculations, sketches, tables etc. are stored as Entries 

 
Calc Set (.LAS file) This is an index to the Calc Library Entries, it does not store any data but is instead an 

organized collection of references to the library. 
 
 

 

 

 

 

 

 

 

You work directly with the Set and the library is automatically saved and updated in the background. 
The components of a Set are organized in a folder tree system similar to Windows Explorer. 
• The folders are called Groups and act to organize the calculations. 
• The calculations are saved as Items inside the folders. 

There are many types of items that you can work with and save.  We encourage you to explore the 
other types on your own.  The following are the most common items that you will work with. 

Item Name System Library User Library Description 
Solution 

  
Returns a complete calculation 

Component 

  
Returns a part of a complete calculation 

Note 
  

Returns general information about the calculation 

Sketch 
  

Returns an image in the calculation 

 

 

 

 

Group 

Items 
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1.3 Working with the User Library 

1.3.1 Creating a Calc Set 

A new Calc Set must be created in order to save your custom calculations. 
• New sets can only be created in the Advanced Mode of the Library Access System. 
• Use the New Calc Set Wizard command or go to File > New. 

 

• The Wizard comprises of two dialog boxes that walk you through creating a new set. 
• Define the Name of the Calc Set. 
• Tedds automatically creates the Short Name and the File Name 
• We recommend you keep the Set stored locally in  
• My Documents > Tedds > Calc Sets 

 

 
 
 
 

 



1 Creating a User Library and Publishing Calculations 10 (39) 

 

Training manual Tekla Tedds e-Learning 
© Trimble Solutions Corporation | March 1, 2016 Tedds: Expert 

 

• The next screen defines the properties of the set 
• Indicate a Version to keep track of changes 
• The Author defines the creator of the calc 
• The Status defines what stage the calculation is at in the calc writing process 

– Choose from predefined labels or write your own 
• The library will be saved to a default location in My Documents > Tedds > Calc Libraries 

– Don’t change the location or name of the library 
 

Click Finish to exit the Set Wizard 
• The set has been created – a root folder will exist with the same name as the set  
• The white background signifies an editable mode 
 

 

 

 

 

 

1.3.2 Creating a Group 

Once the Set has been created you can organize the calculations and components in folders known as 
Groups. 
• First select the Root folder or other group that you want the new group created in. 
• Use the New Group command or go to Edit > New Group. 
• Each group must have a unique name. 
• A Long Name can be defined which is a descriptive title with more information on the group 

contents.  
• Hover over the Group name to display the Long Name 
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1.3.3 Creating an Item 

Calculations are saved into the Library as Items.  Items should be saved inside a Group and groups can 
contain multiple items. 
Steps for creating an item: 
• Select the location where the item will be saved in. 

– If empty, select the Group 
– If other items exist in the Group, select an existing item at the same level where the new item 

will be. 
• Use the New Item command or go to Edit > New item 
• A selection dialog box will be displayed 
• Highlight/select the calculation you want added to this Item 
• Remove field results in Document before saving – If checked this will remove all calculated results 

from the document 
• The default type is a Component – in the New Items Properties enter the component name. 
• If the Group location is empty – a dialog box will ask if you want the item saved in the selected 

Group. 
• If the Group had items saved inside it – the new item would be saved at the same level as the 

Group. 
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1.3.4 Saving a Calc Set 

• The Items have automatically been saved into the Calc Library file. 
• The Calc Set is not automatically saved. 
• If you try to close the Library without having saved the Calc Set, you will be prompted to save it. 
• Alternatively, you can use the Save Calc Set command, or got to File > Save. 
• You will then be prompted to save the Calc Set in the default Tedds location. 

1.3.5 Calc Item Field 

The Calc Item Field allows you to input previously saved Calc Items into your document.  You can add a 
conditional statement so different results will bring up different Calc Items. 
• In Tedds Field go to the Calc Item tab. 
• Write out a conditional statement and choose which calc items will be displayed if the condition is 

met or not. 
• The Calc Items must be in the same Library. 
• Run the calculation to display the appropriate Calc Item. 
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1.3.6 Using a Calc Item 

Once a Calc Item has been saved it can be used in new documents.  This will save you time if you have 
common pieces of calculations that need to be input in several different files. 
• Go to the My calculations library in the LAS 
• Locate the calculation the same way you do with a built-in Tedds module 
• Drag and drop the Item into the document. 
• Turn on semi-colons to drop the Items in the correct location.  

 

 

 

 

 

 

 

 

 

 

 

1.3.7 Opening a Calc Set 

• A previously saved Set can be opened by going to File > Open or click on the folder icon in the 
toolbar 

• This will open the Set in the editable mode with all the previously saved items 
• You must open the set in order to make changes, add new items or modify existing ones 
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1.3.8 Modifying a Calc Item 

You can modify a calc item without having to recreate it.  If the item is not already in the document, 
drag and drop it in first, then make the changes. 
• Highlight the complete item, then in the Calc Set right-click on the item name and go to Edit > Item 

Contents 
  

 
 
 
 
 
 
 
 
 

• Make sure to save the Set after modifying the item 
• You can view the changed Set by clicking on the Preview command 
• If the items were manually placed in a document they will not be updated automatically  

– The items are just text within the document 
– there is no link between the text and the library 

• Items that were inserted into the document as a Tedds Calc Item field will be updated once the 
document is recalculated. 
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1.3.9 Creating a Solution Item 

Once you’ve put your calculation together, either written from scratch or using pre-defined Calc Items, 
you can save the entire calculation as a Solution Item. 
• Follow the same procedure for creating a Component Item – highlight the entire calculation when 

prompted. 
• In the New Item Properties click on More to expand the options. 
• The Type drop-down menu allows you to choose from different Item types; this includes solution, 

note, sketch etc. 
 
 

• This solution can now be opened in Tedds Standalone. 
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1.4 Publishing Calculations 

1.4.1 The Calc Publishing Wizard 

The Calc Publishing Wizard allows you to easily distribute the calculations you write to other Tedds 
users. 
• It creates a single Microsoft Installer file that will install, to the correct location, all the Calc Set, 

Calc Library, Excel spreadsheet, Data List, Data Table and Data Graph files that you have used in 
your calculations. 

• Calculations are written and saved into the Library in exactly the same way as before. 
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1.4.2 Creating a Tedds User Calculation Package 

The Package Type setting controls what information will be included in the file that the Calc Publishing 
Wizard creates. 

Tedds User 
Calculation 

This option can be used for User Calc Library, User Calc Set and Excel files.  The 
Microsoft Installer file that is created can be sent to other users and when installed, 
will copy the information to the other user’s User Calc locations.  The other user is 
then able to access, edit and delete information from these files.  The calculations will 
be accessible under the My Tedds Calcs index in the Library. 

Tedds System 
Calculation  

Saves your calculations into the Library as System Calcs.  The Microsoft Installer file 
can then include Data Lists, Data Tables etc that you have created and saved into your 
System Calc locations.  They will be installed on the user’s machines System Calc 
locations allowing for protection of files.  These cannot be edited, and the calculations 
will appear amongst the standard Tedds calculations in the Library. 

Tedds System & User 
Calculation 

This option can be selected if you have a combination of the two options above. 

 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
 
 
 
 
 
 
 
 
 
 
 



1 Creating a User Library and Publishing Calculations 18 (39) 

 

Training manual Tekla Tedds e-Learning 
© Trimble Solutions Corporation | March 1, 2016 Tedds: Expert 

 

Files can be added to the project by selecting either a Calc Set or a Calc Library.  The Publishing Wizard 
will automatically add all the other associated files. 

  

 
 
 
 

• Browse to the appropriate Calc Set or Library and click Open to add. 
• Change the Read-Only status to True to prevent users from overwriting the information in the 

files. 

 
• Notice all required documents are included, in the Data Files category the appropriate Data Lists 

are included that were input to this document. 
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The Properties tab allows you to provide more information about the Microsoft Installer file that the 
Calc Publishing Wizard will create. 

• You must provide a Title, Author and Output installation package 

Title Text that appears in the title of the installation wizard 
Description Brief description that is displayed by the installation wizard (Optional) 
Author Your initials or other identifying information 
Contact web 
address 

Your e-mail address (Optional) 

Output installation 
package 

Name and location of where the .MSI file will be created.  The default location is: 
C:\Users\<username>\Documents\TEDDS\Publishing Projects 

Notes file Name and location of a text file in Rich Text Format (RTF) or plain text format (TXT) that 
is displayed by the installation wizard as notes (Optional) 

License agreement Name and location of a text file in Rich Text Format (RTF) or plain text format (TXT) that 
is displayed by the installation wizard as the licence agreement (Optional) 

 
• Click Build to create the .MSI file, as well as any .txt or .rft files requested. 
• The Files will be saved in the Output Installation Package location – share these files with your 

company. 

 
 
 
 

• Save the Publishing Project to re-build the package at a later date when you’ve made changes to 
the calculation. 

1.4.3 Installing a Tedds User Calculation Package 

• Double click on the .MSI file to install the calculation on another machine. 
• The calculation will now be available in the Library Index in both Tedds and Tedds for Word. 
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2 Creating a user interface 

2.1 Session Topics 

• Introduction to creating a user interface 
– Creating groups & controls 
– Inserting data tables 
– Displaying/hiding options based on conditions 
– Adding pictures 

2.2 Introduction to the user interface 

2.2.1 The User Interface Designer 

Why create a user interface? 

• When working through a calculation it may be hard to identify which variables need to be input or 
defined in the calculation versus the ones that are calculated automatically. 
– The interface allows you to group inputs in a logical way 

• Maximum and minimum values can be applied to help make sure only valid values are defined 
• Manually editing a document can lead to potential mistakes if changes are made without re-

calculating the entire document to update the results. 
• Individual input boxes are cumbersome, the interface will combine them into one place 

2.2.2 The User Interface Designer 

• The User Interface Designer is a tool within Tedds for Word for creating input interfaces. 
– The Interface designer in the Tedds ribbon is the default tool and its best used for simple 

interfaces, this is suitable for most applications. 
– The Interface designer pro, which is available in the Developer ribbon, is a more advanced 

tool for complex interfaces and is the same tool the CSC developers use to create the Tedds 
modules.   

• This is only recommended for experienced users and is beyond the scope of this session  
• It displays a template showing exactly how the interface and its components will appear when the 

calculation is performed. 
• Multiple inputs can be entered in a single window. 
• Data can be entered via multiple control types depending on the nature of the variable e.g. 

checkboxes or drop lists. 
• The interface designer is user friendly 

– Interfaces can be easily edited 
– Buttons, for making selections from data lists, data tables, etc, can be added to the interface 
– Sketches and Notes can also be added to the interface to illustrate the calculation 
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2.3 Creating a user interface 

2.3.1 Preparing the document 

• The User Interface Designer doesn’t have an option to write out a standard input line into the 
document. 

• This means that any variables defined in the User Interface will not be automatically displayed in 
the document. 

• Assignment statements need to be manually written into the document for every variable that 
needs to be displayed in the output. 

• The User Interface Designer should be inserted into the document above the assignment 
statements. 

To create a User Interface place the cursor where the interface will be created and click on the User 
Interface command. 
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2.3.2 Page Properties 

Page Properties can be defined to adjust the content and layout of the User Interface that is being 
created. These can be entered either graphically, by clicking in the appropriate area in the template on 
the left, or by using the table on the right. The main ones are listed below: 

Name This is text to be displayed in the Interface Designer only 
 

Title Text will appear at the top of the interface for the current page. If several pages are created, 
each can have a different title 

Finish if Enter an expression to replace the Next button with a Finish button, for example enter 1 or 
True in the box. 
 

Size This sets the overall size of the interface pages as either Medium or Large. The size can only 
be set on the first page; all subsequent pages always adopt the same size as the first page. 
 

Layout This controls the overall layout of the interface page. Different layouts are available 
depending upon the interface size selected. The layout specifies the maximum number and 
arrangement of controls on the page.  Some layouts include space for one or more page 
items; these can be used to display sketches or other items within the interface. 

Notes Library 
Item 

The browse buttons can be used to select a library item (either a Tedds or User Created item) 
to enter into the Notes page for the interface. When the calculation is run, the chosen item 
will then be displayed when the Notes button is clicked on the interface. This field can also 
be activated by clicking on the Notes button in the template 

Sketch Library 
Item 

The browse buttons can be used to select a sketch library item (either a Tedds or User 
Created sketch) to enter into the Sketches page for the interface. When the calculation is 
run, the chosen item will then be displayed when the Sketches button is clicked on the 
interface. This field can also be activated by clicking on the Sketches button in the template 

Events Advanced options for changing inputs to be displayed, calculated or validated depending on 
settings. 

Information Text displayed in the context help window when the active input control does not have its 
own information 
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2.3.3 What are Controls and Groups? 

A Control is the basic part of an interface that allows the user to enter information into the calculation.  
• Depending on the type of control being used, various Control Properties need to be defined  
• Examples of control properties include descriptions, variable names, default values and units.  
A Group allows multiple controls to be grouped together. 
• Allows you to group related controls together in the same area of the interface, with a title.  
• Allows for the use of logic, as to whether the controls in the group are enabled or not, dependant 

on other settings in the calc input 
 
There are several different types of controls depending what you need to input or show: 

Blank A blank line is inserted, used for spacing out controls within the interface 
Button A button is inserted into the interface to perform an operation, such as to run a Data List 
Checkbox A checkbox is inserted into the interface to perform an operation, such as to display other 

controls within the interface 
Drop List This control gives the user a drop list of standard values, which the user must select from 
Edit An Edit control is an input box for the user to type in a value 
Edit Drop List This control provides a drop down list with standard values, but also allows the user to enter 

values not in the initial list 
Edit Up Down An input box allowing the user to enter a value is provided with up and down buttons to 

adjust the value by a pre-set amount 
Label This option displays a line of text, defined by the user 
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2.3.4 Inserting Groups 

• Clicking the Add Group button with a blank interface template will insert a Group at the top of 

the template, with a Control inserted inside that Group  
• Once a Group has been added into the template, its Group Properties can be seen graphically 
• Click into the Title property of the Group to activate it and allow the property to be defined 
• When a Group has been activated, its properties will also be displayed in a table on the right 

hand side of the Interface Designer 
• Properties can be defined either graphically or by using the table of properties 
• Once a property is defined, clicking into another area of the template will update the Interface 

to show the information defined 
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2.3.5 Inserting Controls 

• Clicking the Add Control button with a blank interface template open will insert a Control at the 
top of the template 

• If other Controls already exist in the template, then the Add Control button will add a new control 
underneath the last one 

• If a Group already exists in the template, then the Add Control buttons will add a new Control after 
the Group 

• There is an additional Add Control button that appears next to the Group Title when a Group has 
been inserted 

• If this button is used, then a new Control is added to the end of that group 
• If a Group or Control has been positioned in the wrong place within the template, it can be 

activated and then moved up or down the page by using the Move Up or Move Down buttons 
• Groups and Controls can be deleted by activating them and then clicking the Delete button 
• If mistakes are made while inserting Groups and Controls or editing their properties, the Undo 

and Redo buttons can be used 
• As a Control is being edited graphically, small buttons appear to allow appropriate Greek 

Characters, Variable Names, Subscript and Superscript Characters and Units to be defined, in 
the same way as defining an Input Field, as discussed earlier in this manual 

 
 

Name This is the Variable Name of the value being defined 
Description This is the text to describe what the variable is 
Default value This is the default value that will appear automatically when the calc is run 
Units These are the units of the variable being defined 
Information This provides additional information to the user about this individual Control 
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The button control can be used to insert data fields or launch another interface. 
• A description can be added similar to the input types. 
• The Name field will put a description graphically on the button 
• Click in the command box to open a separate screen, this will set the information the button 

controls 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 

• Choose the data list from the available options – these are the same as the previous options we 
saw in the Data List Field. 

• The page and selection can be set for the first time the calculation is run 
– Click on the button at the right side and choose the default shape and size 

• The Selection variable and Page variable need to be defined if you want the program to remember 
what selection the user previously made when re-calculating the document. 
– These variable names can be anything 
– They must be in quotes 
– They should be unique names that do not occur anywhere else in the document. 
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2.3.6 Returning the Interface to the document 

• Click the Close button to return the User Interface to the document once completed or if it needs 

to be checked that it works correctly. 
• You will then be asked if you want to return the interface to the document;  

– Yes – will complete this task 

– No – will close the User Interface Designer WITHOUT retaining the information entered in this 
session 

– Cancel – will stop the Close process and will return you to the User Interface Designer 
• Once the User Interface has been returned to the document, it can be calculated to ensure that the 

calculation runs correctly with the User Interface. 

Editing an existing User Interface 

 

• To edit an existing User Interface in a document, you simply need to have that document as the 
active document and then click the User Interface button 

• Select the User Interface and click the Edit button to re-open it and make changes as needed. 

Enhancing the User Interface 

Creating a drop-down menu 
• When a particular variable only has a limited number of options for its value, the Drop List Control 

is useful. 
• A Default value can be defined, just as the Edit Control did. 
• The different options available for the variable value are listed in the Control Properties under 

Choices. 
• These can either be typed straight into this box, the options separated by Vertical Bars, or 

using the small drop-down arrow, they can be entered into a table. 
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2.3.7 Adding a Check Box 

• Check boxes can be used in many ways including to display more calculations or variables inputs. 
• This results in two options; True = 1 or False = 0 
• Indicate a variable name to use in conditional statements; this will not be displayed in the User 

Interface. 
• The default value will set if the check box is checked or unchecked when the user first calculates 

the document.  

 

2.3.8 Enabling a Control and changing the visibility 

• Controls can be enabled or disabled depending on calculated expressions, this can include: 
– Results from other controls 
– Whether or not a variable exists 
– Conditional statements, etc. 

• Enter the expression in the Enable if box 
• You can hide the control from view if the Hide if disabled option is set to True 
• Use the result from a check box to enable or disable other inputs 
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2.3.9 Refining a description  

• Descriptions can be dynamic, changing depending on what inputs are selected. 
• Input a function or conditional statement in the description box  
• Use the GetVar function to show the section size selected or indicate that no size has been 

selected 

2.3.10 Opening a new interface 

• You can create buttons that open a new user interface; this allows you to add more inputs based 
on initial selections 
– You can set the visibility of the control based on the check mark for further refinement 

• This is a button control type with the data as a Calc Item field 
You must create the sub interface and save it to your user library before  
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2.3.11 Add another page to the User Interface 

• Click on the Add page icon at the bottom of the Interface Designer screen 
• You can move the new page to any location by clicking on the drop arrow and choosing the new 

location.  
• This will show up as another page when Next is clicked during the calculation. 

 
 
 

2.3.12 Adding a sketch to a user interface 

You can add a sketch to any user interface.  These can be static pictures or dynamic sketches.   
• You must first save the sketch in the user library as a sketch item, you can then call this item into 

the user interface as a Library Item using the Calc Item field 
• You must select a layout that provides space for the sketch 
• Click on the Library Item and then browse to the Library and the sketch item. 
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3 Introduction to active sketches 

3.1 Session Topics 

• Introduction to creating active sketches 
– Drawing functions needed to create sketches 
– Proper way to define shape coordinates 
– Look at an advanced example 

3.2 Active Sketches 

3.2.1 Introduction to Active Sketches 

What are active sketches? 

• Active sketches are dynamic pictures included in the user 
interface or output that updates based on inputs in the 
calculation. 

• Many of the calculations in the Tedds Engineering Library 
include Active Sketches 

• Active sketches use the input data for a specific design to 
create sketches that are drawn to the correct proportions 

• Add active sketches to any calculation that you’ve written  
– Enhance the look of the calculation, help explain 

inputs in a diagram or show information for the calc 
– You can link the geometry to input data from a 

specific design to create sketches that are drawn to 
the correct proportions  

– You can add dimensional marks to the sketch 
– Include notes and tags to describe sections of the 

sketch  
• Active sketches are created using several drawing functions available in Tedds  

– Each function creates a single item, such as a line, a circle, a dimension mark, etc.    
– You write out each one in a list to create the complete picture 
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• A full list of all of the drawing functions is available by going to the Library Access System > Writing 
your own custom calculations > Calculation writing documentation > Tedds functions > Drawing 
functions 

• The number of drawing functions is quite large, but many of them are only required for drawing 
some of the more complex sketches used by calculations in the Tedds Engineering Library   

• Only need a handful of functions are needed for most sketches  
• As with all of the standard Tedds calculations, you can view notes and examples of all of the 

drawing functions available by selecting them in the library and clicking the Preview command 
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3.2.2 Creating a basic active sketch 

When writing out the drawing functions there are a couple rules that needs to be followed 
• All arguments should be entered with their appropriate units 
• All of the drawing functions must end with = ?  in order for the function to be calculated 
• Multiple drawing functions can then be used to build-up a more complex sketch and the 

properties associated with it.   
– This includes adding multiple shapes such as rectangles, lines, arcs etc. and detail functions 

such as colors and line thicknesses. 
• The first function you must use to create any new drawing is DrawCreateDrawing 

– This function includes inputs for the width and height of the drawing you want to create  
– DrawCreateDrawing(width unit, height unit) = ? 
– These arguments should be placed immediately after the function inside brackets, separated 

by commas 
• To show the drawing in the document, the Tedds ShowDrawing field must be used 

– A new blank field – { } – can be inserted into a document by pressing Ctrl+F9 on your keyboard 
– To complete the ShowDrawing field, =CSC|CALL ShowDrawing() should be entered inside the 

field’s curly brackets 
– {=CSC|CALL ShowDrawing()} 

You don’t have to create a complex shape right away; it may be easier in fact to build up the shape 
slowly by adding more functions, making sure the shape looks correct as you go.  Start with a simple 
shape or the most basic shape that builds up the picture. 

 
 

 
 
 

 

 
 

• The ShowDrawing field will be replaced by the sketch once the document is calculated. 
• Build on the sketch by adding more functions after the last function, but before the ShowDrawing 

field 
• Open the Library Access System and go to the calculation writing documentation to look up more 

functions and the available associated properties. 
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Once the additional functions have been added, re-calculate the document to see the updated sketch. 
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3.2.3 Creating Advanced Active Sketches 

It is unlikely that the drawing functions would be used to create a basic shape, such as a rectangle, as 
this can be done much quicker and easier directly in Word by using the Insert > Shapes command 
• It is much more likely that an active sketch would be created to show more useful objects or 

complex pictures 
• The active sketch of a steel section would be based on the section’s dimensions, which could be 

subject to change 
– An example would be to show a steel section 

• The active sketch of a steel section would be based on the section’s dimensions, which could be 
subject to change 

• Therefore, these dimensional properties should be defined first, just like any other variable 
assignment 

3.2.4 Advanced functions 

The DrawFillPolygon function can be used to create a shaded polygon of any shape 
• This function requires arguments to define each of the x and y co-ordinates that define the outline 

of the polygon 
• These should start from the origin (0,0) at the bottom left corner of the section and then working 

clockwise around the shape 
• As with the basic active sketch created previously, these arguments should be placed immediately 

after the function inside brackets, separated by commas and with their appropriate units if 
required 

• The Tedds ShowDrawing field must be used to display the active sketch in the document 

It can be useful to draw out the sketch first with all the coordinates defined.  You can then copy this 
information directly into the function. 

 
DrawFillPolygon(0in,0in, 0in,D, B,D, B,D-Tf, T,D-Tf, T,Tf, B,Tf, B,0in) = ? 
{=CSC|CALL ShowDrawing()} 
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There are several functions that allow you to refine the sketch.  Below are common functions, there 
are many more available and we encourage you to explore them within the program. 
 

DrawDimensionLine() Adds a dimension, coordinates in parenthesis for the start and end of dimension. 
• This function requires arguments for the co-ordinates for the start 

and end of the dimension you want to label and a final argument, 
in quotation marks, for the name of that dimension 

 
DrawDimensionLineCap() Adds symbol at the end of the dimension line. 

• This function requires one argument – the Style Name – which 
should be placed in quotation marks and inside brackets, 
immediately after the function 

• A full list of style names can be found in the preview window for 
this function shown in the library 

DrawDimensionAlignment() Allows you to indicate how the dimension line is referenced and shown in the sketch. 
• This function requires one argument – the alignment Name – which 

should be placed in quotation marks and inside brackets, 
immediately after the function 

• A full list of alignment names can be found in the preview window 
for this function shown in the library 

• Depending on which alignment name is selected, there is also an 
additional argument called Margin which can offset the entire 
dimension relative to the co-ordinates of the line 

• The functions are calculated in the order that they appear in the 
document, so this function can be changed for different dimensions 
by placing the function into the document multiple times 

 
DrawFillOutline() Draws an outline around the filled polygon, should go before DrawFillPolygon 

function. 
• This function requires one argument – either True or False – to 

specify whether an outline is created or not 
• This function should be placed on the line before the 

DrawFillPolygon function 
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3.2.5 Example of an advanced active sketch 

When creating advanced sketches you can define the values that make up the sketch as separate 
variables.  These can come from inputs, data lists, calculations, etc.  Use the same calc writing rules to 
define the variables.  Then use the variable names in the drawing functions instead of typing out the 
value.   Since the unit were defined with the variable name, they should not be added again within the 
drawing function. 

 
 

• Note how Tedds has automatically formatted the text for each dimension to include the specified 
variable name and the value of that variable 

• It has also automatically adjusted the arrows used and the location of the text for small 
dimensions 

• You can change the values of D, B, T or Tf, re-calculate the document and the sketch will update to 
reflect the changes 

• There are many other drawing functions available which allow you to create complex sketches 
using lines, polygons, arcs, paths, and transformations to name just a few 

• Instead of creating the same sketch from scratch to use in every document, you can create a Calc 
Item for the sketch and save it to your library. Then you can simply drag and drop the sketch into 
other documents. 

• If you don’t want to see the functions in the document, these could be set to a Hidden text style 


