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1 Manage Tekla Structures

Managing Tekla Structures means defining and maintaining the configurations
and settings you require to complete your work in different projects.

Basic configuration for your own use is generally explained in the
documentation of each feature. The customizations can be copied between
different models and for this it is good to have a basic understanding of the
file and folder structure (page 262).

If you manage Tekla Structures for other users, you are a Tekla Structures
administrator, and you will need a deeper understanding and more managed
approach to maintaining the configurations, settings and servers that your
users need in their work. To start customizing Tekla Structures for your
organization, read more below.
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2 Tekla Structures installation for
administrators

You can install Tekla Structures on a workstation using the standard
installation packages or by creating your own centralized installation using MSI
packages. You can also run Tekla Structures in a virtual environment.

If you have on-premises licenses, you also need to install a license server on
your own hardware.

2.1 Installation requirements
Trimble Identity

Tekla Online services, including online licensing, use Trimble Identity for
identification. You can use your Trimble Identity with other Trimble services,
such as Trimble Connect and SketchUp 3D Warehouse.

Each organization has at least one account administrator, who is responsible
for managing the Tekla Onlineorganization (group) used in Tekla Online
services. Several people in your company can be administrators. The first user
is invited by a Trimble representative, and that person is then responsible for
adding other users and administrators as necessary.

As an administrator, you:

• Invite or approve employees to your company's Tekla Online organization
to allow them unrestricted access in all Tekla Online services.

• Add external license users.

• Select who has access to your company's online licenses.

• Remove people from your company's employee group when they no
longer belong to your company.

For more information, see Create your Trimble Identity and Manage Trimble
Identities and Tekla Online licenses.

Tekla Structures installation for administrators 10 Installation requirements

https://teklastructures.support.tekla.com/not-version-specific/en/managing-tekla-accounts-and-model-sharing-licenses
https://teklastructures.support.tekla.com/not-version-specific/en/managing-tekla-accounts-and-model-sharing-licenses


Tekla Structures installation prerequisites

Installing Tekla Structures requires one of the following operating systems:
Windows 10 or Windows 8.1. If the operating system is not one of the
supported versions of Windows, the installation is cancelled.

The Tekla Structures installer is available as a 64-bit version.

For more information on recommended operating system and hardware
specifications, see Tekla Structures 2021 hardware recommendations.

Tekla Structures needs the following redistributable packages that are
automatically installed during the Tekla Structures software installation if they,
or newer versions of the packages, do not exist on your computer:

• Microsoft .NET Framework 4.7.2

• Microsoft Visual C++ 2010 Redistributable (x64) 10.0.40219

• Microsoft Visual C++ 2010 Redistributable (x86) 10.0.40219

• Microsoft Visual C++ 2013 Redistributable (x64) 12.0.40649

• Microsoft Visual C++ 2013 Redistributable (x86) 12.0.40649

• Microsoft Visual C++ 2015 Redistributable (x64) 14.0.23026

• Microsoft Visual C++ 2015 Redistributable (x86) 14.0.23026

If you create a customized installation package, make sure that the .NET
Framework is installed on the client computers.

In addition, the following installers are automatically installed during the Tekla
Structures software installation:

• Tsep File Dispatcher Launcher

• Tekla Warehouse Service

These installers are needed for Tekla Warehouse to work properly.

Tekla Warehouse offline content is available online. To find this content in
Tekla Warehouse, search for Catalogs and under Show, select Collections.

2.2 Installing Tekla Structures
You can install Tekla Structures on each workstation running the standard
installer separately on each workstation, or via a centralized installation with
an MSI package and your preferred software deployment tool.

You can download Tekla Structures software and environments from Tekla
Downloads. To have the latest software in use, we recommend that you install
the latest service pack of Tekla Structures. Service packs include
improvements and fixes to the latest or to a previous main version or service
pack of Tekla Structures. Service packs are available for all users with a valid
maintenance contract or subscription.
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NOTE You need to install Tekla Structures with administrator rights.

When you do a centralized installation, the end users do not need
administrator rights for the installation.

2.3 Installation files
Tekla Structures installers are .msi installers. Environment .msi installers
include sets of .tsep installers that contain the actual environment files and
settings. When installing a new version of Tekla Structures, install the software
first and then the environments. The .msi installers are installed to your
computer before opening Tekla Structures.

When you run the environment .msi installer, the installer creates the
environment folder and copies the .tsep installers to the..\Tekla
Structures\<version>\Extensions\To be installed folder. The
installer also creates the RemoveEnv.bat and ToBeRemoved.txt files, and
places them to the ..\Environments\<environment> folder. These files are
used when uninstalling an environment.

When running the environment .msi installer, you can select in the
installation wizard that the .tsep installers are run immediately when running
the environment installer. If you do not select to do this, the .tsep installers
are run when you open Tekla Structures for the first time after the installation.
In this case, Tekla Structures opens a dialog box that shows the installation
progress of the .tsep installers.

You can cancel the installation of extension .tsep installers in the dialog box
and postpone them to the next Tekla Structures start-up. The queued
environment .tsep installers are not cancelled, they are installed even if you
cancel. The .tsep packages contain information about the product type:
environment or extension, which is used to determine which installers can be
canceled.

Running the .tsep installers does not require administrator rights. The .tsep
installers install the environment files to the ..\Tekla Structures
\<version>\Environments\<environment> folder.

If you are installing several environments for the first time, we recommend
that you do not select to run the .tsep installers with the .msi installer. Some
of the .tsep packages are used in more than one environment and the same
version of a .tsep package is only installed once. Note that starting Tekla
Structures for the first time after installation can take a long time particularly if
you have installed several environments, as all the .tsep installers are run.
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2.4 Standard installation
Tekla Structures installation wizard has detailed instructions about the
installation.

For more information, see also Install Tekla Structures.

2.5 Centralized installation
Installing Tekla Structures centrally across the company network saves time in
a large company when there are many Tekla Structures users.

Centralized installation allows you to run the Tekla Structures installation
silently in the background so that the users do not see the installation wizard
dialog boxes. For detailed information on centralized installation, see
Centralized distribution of Tekla Structures 2021.

2.6 Installation in a virtual environment
You can also run Tekla Structures in a virtual environment. Application and
desktop virtualization allow users to run software from a server on the
network without locally-installed Tekla Structures on their workstation. Using
Tekla Structures from the server ensures that all users in a project are using
the same project environment set-up. For detailed information on virtualized
installation, see Using Tekla Structures with application and desktop
virtualization (page 23).

2.7 Folder structure
The default installation location is in Program Files. When Tekla Structures
is installed in this folder, configuration files are installed in the hidden
Program Data folder. This may be the preferred location for reducing the
likelihood of end-user interference with the software installation and
configurations.

If you install Tekla Structures in a normal file folder, all files are intalled in that
folder. This may be preferred for users who need to easily access all files.

Folder structure on local computer

See Tekla Structures installation folders for information on how the folder
structure on the local computer is set up.
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Company folder structure

If you use Tekla Model Sharing, you can synchronize the project and firm
folders through the Trimble Connect cloud service included in your Tekla
Structures subscription. .

If you have single-user or multi-user models, we recommend using a central
file folder for storing the models and setup files for the company-specific
settings and the project-specific settings. Tekla Structures then reads the
settings from the central file server. When upgrading to a new Tekla Structures
version, or updating the company logo, for example, the files only need to be
replaced in one place. This way taking backups and upgrading is easier.

For more information, see Create project and firm folders (page 263).

Backup

With all valuable information and work your company stores, it is important to
take backups of the model folders, and firm and project settings. If your
company has a system for taking automatic scheduled backups, schedule your
system to take the backups at night time, outside working hours to prevent
any possible conflicts in the model.

If you use on-premises licenses, do not forget to also take a backup of the
license entitlements and your active licenses.

Virus protection

Virus protection software has sometimes caused problems in saving models
and drawings to the model folder. These problems may occur especially if you
have your model saved on a network drive. We strongly recommend that you
add Tekla Structures into the safe list of your antivirus system, and set up your
virus protection in a way that actions in your model folder are not blocked or
scanned.

2.8 Tekla Structures settings in the Windows registry
Windows registry is a hierarchical database that stores configuration settings
and options in Microsoft Windows operating systems. Registry settings are
used during a Tekla Structures session and during a Tekla Structures
installation.

WARNING Do not change the registry settings. Changing the settings can
cause the operating system to fail. It is possible to view the
registry settings using the Registry Editor.

User settings

Some of the Tekla Structures user settings, for example, general options, and
dialog box locations and sizes are stored in the registry. The settings are saved
in a registry key named after the Tekla Structures version number in the
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registry branch HKEY_CURRENT_USER\Software\Trimble\Tekla
Structures\<VERSION>.

Tekla Structures uses the hardcoded default settings when opened for the first
time after the installation. If you change a setting during a Tekla Structures
session, Tekla Structures saves the change during the session, or when you
exit Tekla Structures. When you open the same version of Tekla Structures
again, the changed setting is used.

When upgrading to a newer Tekla Structures version, you can use the
Migration Wizard tool to copy the settings you have changed.

Installation settings

The Tekla Structures installation saves information to the 
HKEY_LOCAL_MACHINE\SOFTWARE\Trimble\Tekla Structures
\<VERSION> registry key.

2.9 Installing an on-premises license server
If you have on-premises licenses, you need to install the license server on your
own hardware. If you only use one license of Tekla Structures, you can install
the license server on the same computer as Tekla Structures, making the
license available on this one workstation. In an environment with multiple
licenses and users, you install the license server in your company network,
which allows for more flexible and efficient use of your licenses according to
need.

Before users can start using Tekla Structures with on-premises licenses, you
must:

• Install and set up a license server on a computer.

• Save the entitlement certificate and activate the licenses.

• Connect each client computer with Tekla Structures to the license server
either manually, through a customized installation or by instructing the
users.

For more information, see Tekla Structures on-premises licensing (page 29).

If you have online licenses, Tekla Structures always connects to Trimble's cloud
service when the user needs to reserve an online license and you do not need
to install your own license server.

2.10 Installing .tsep packages
Tekla Structures extension packages, .tsep packages, are Tekla Structures
extensions or additional environment content installers. Extensions are not
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part of the Tekla Structures product release. .tsep packages are available for
download in Tekla Warehouse.

You can install .tsep packages in three different ways.

Direct installation

1. Double-click the .tsep installer that you have downloaded.

2. The Tekla Structures extension manager dialog box opens with the
name of the extension that is going to be installed.

By default .tsep installers are opened with Tekla Structures extension
manager. Some .tsep installers are run directly from Tekla Warehouse
with the Insert into model option.

3. Select the Tekla Structures versions to which you want to import and click
the Import button. The next time you start Tekla Structures, the extension
is automatically installed, and it is shown in Tekla Structures extension
manager.

NOTE If the .tsep installer is not set to open with Tekla Structures
extension manager by default, you can set it manually. Right-click on
the .tsep installer and select Properties. In Opens with, select
Change and browse to TsepFileDispatcherLauncher.

Installation in Tekla Structures extension manager

You can also install a .tsep installer from Tekla Structures extension
manager in Tekla Structures.

1. In the Applications & components catalog, click  > Manage
extensions --> Extension manager to open Tekla Structures extension
manager.

2. Click Import and browse to the .tsep installer that you want to install.

3. Click Open.

The imported .tsep is installed the next time you start Tekla Structures. It
is shown in Tekla Structures extension manager, and is ready for use in
the Applications & components catalog.

Uninstall .tsep packages

To uninstall .tsep packages, do one of the following:

• In Tekla Structures extension manager, select the .tsep packages that
you want to uninstall (use Ctrl or Shift to select more than one), and click
Remove. The .tsep packages are removed when you restart Tekla
Structures.

• Browse to ..\Program Files\Tekla Structures\<version\nt\bin\
and double-click the TeklaExtensionPackage.Builder.exe to open the
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Tekla Structures Extension Package (TSEP) builder and test runner
dialog box.

Go to the Uninstall TSEP based extensions tab, select the .tsep
packages that you want to uninstall (use Ctrl or Shift to select more than
one), and click Uninstall selected. This will remove all the selected .tsep
packages. You do not need to restart Tekla Structures.

Centralized installation

You can centrally install a batch of .tsep installers across company
workstations. This method is meant for system administrators.

By default, the .tsep installers waiting for installation are stored in
\ProgramData\Trimble\Tekla Structures\<version>\Extensions\To
be installed. To install centrally, you need to copy the .tsep installers to
the %XSDATADIR%\Extensions\To be installed folder. Create the \To
be installed folder if it does not exist yet.

When Tekla Structures starts, it checks the available .tsep installers from the
\To be installed folder and installs them automatically. If there is an older
version of the same extension package, it is uninstalled before installing the
new version. Installation is cancelled if the same or newer version has already
been installed.

• The installed .tsep installers are stored in the %XSDATADIR%\Extensions
\Installed folder.

• Invalid .tsep installers are uninstalled and moved to the %XSDATADIR%
\Extensions\Invalid installations folder.

• Cancelled .tsep installers are stored in %XSDATADIR%\Extensions
\Cancelled installations.

Copying .tsep installers

We recommend that you use ROBOCOPY from the command prompt
(cmd.exe) to copy the .tsep installers. More information on ROBOCOPY can be
found on the Microsoft website, for example.

The basic syntax for ROBOCOPY is: robocopy <Source> <Destination>
[<File>[ ...]] [<Options>]
For example, to copy .tsep installers in Tekla Structures 2021:

robocopy
"\\Server1\prod\TeklaStructures\2021.0\Environments_TSEP"
"C:\ProgramData\Trimble\Tekla Structures\2021.0\Extensions\To be 
installed"
*.tsep
"C:\Program Files\Tekla Structures\2021.0\nt\bin
\TeklaExtensionPackage.TepAutoInstaller.exe"
2021.0 "C:\ProgramData\Trimble\Tekla Structures\2021.0" "2021"

This command will take all .tsep installers from the \Server1 network
directory and copy them to the local user's \To be installed folder. After
copying, TepAutoInstaller.exe installs all .tsep installers from the local
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user's \To be installed folder. Installing the packages allows users to start
Tekla Structures without first waiting for the installations to complete.

Centralized uninstallation

You can uninstall .tsep packages in batches by creating an empty file without
an extension, with the name RemoveExtensionOnStartup, in
\ProgramData\Trimble\Tekla Structures\<version>\Extensions
\Installed\[Extension_To_Be_Uninstalled]. The extensions are
removed the next time Tekla Structures is started.

2.11 Collaborative modeling
Several people can simultanously work in the same Tekla Structures model.

If your company takes part in external projects, or if more than one user works
with the same model at different locations, we recommend that you use Tekla
Model Sharing. With Tekla Model Sharing, the users in your company can work
with the same shared model, offline and with high performance, and
synchronize the changes with other team members even in a low-speed
network.

If you work in a local team and prefer not to use Internet while working on
your models, you can use the multi-user mode.

For model coordination and exchange of other project files, we offer Trimble
Connect. To find out more and set up collaboration in your organization, see
Tekla Model Sharing and multi-user for administrators (page 395) and Working
collaboratively within a Tekla Structures model.

Using the multi-user server requires your company to have more than one
Tekla Structures license.

Tekla Structures installation for administrators 18 Collaborative modeling



2.12 Upgrading Tekla Structures
You can install service packs on top of the existing installation of Tekla
Structures. You can update to new service packs without updating the existing
on-premises licenses. A new Tekla Structures version installs as a separate
instance and can exist on the same workstation with other Tekla Structures
versions. An update to a new version requires that you also update your on-
premises licenses, as the licenses have a highest allowed version. Online
licenses automatically allow you to use any Tekla Structures version that is
released during your subscription period.

If you already have an older version of Tekla Structures installed on your
computer, you can use Migration Wizard to copy the personal settings to the
new version. With the Migration Wizard you can choose to copy any of the
following settings and values:

• user.ini file

• Registry values, such as:

• Toolbars

• Dialog boxes

• General options

Migration Wizard does not copy the environment .tsep files which are
installed by the environment installers.

When you customize Tekla Structures, for example, add or change drawing or
report templates and catalog entries, we strongly recommend that you create
project and firm folders for the customized files. This is useful if you want to
store the files for future use, or if you want to retain them when you install a
new release.

Tekla Structures does not replace files in the project and firm folders when
you install a new release. You can retain your customized files without having
to copy and paste, or export and import from the previous versions. This
makes upgrading faster and easier. If you have customized previous Tekla
Structures versions without using firm or project folders, you will need to
transfer the customized information to the next Tekla Structures version.

Before you start using a new Tekla Structures version, always test that the old
company settings work.

TIP If you want to copy the settings later, you can start Migration Wizard manually
by double-clicking the MigrationWizard.exe in the \Tekla Structures
\<version>\nt\bin\applications\Tekla\Migrations folder. You can
select the version from which the settings are copied and the version to which
the settings are copied.
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2.13 Create start-up shortcuts with customized
initializations
You can use shortcuts to start teklastructures.exe with customized
initializations. You can use this functionality to create shortcuts for different
purposes, for example, to have customized setup files depending on the client
you are working for in a project. The Tekla Structures installation automatically
creates shortcuts for the selected environments.

NOTE We recommend that only administrators create the customization and the
necessary shortcuts. Otherwise, your settings may differ from the settings
defined for your firm, or for the particular project you are working for.

Create a start-up shortcut with customized initialization
1. Open the user.ini file using any standard text editor.

2. Save the file with a new name, for example, customer.ini or
project.ini.

3. Modify the file by adding the required settings.

4. Save the modified initialization file.

5. Open the Windows Start menu and select All Programs --> Tekla
Structures <version> .

6. Right-click Tekla Structures <version> and select Copy.

7. Paste the shortcut to your desktop.

8. Select the shortcut, right-click and select Properties.

9. Modify the Target of the shortcut by adding the required project
initialization information to it. 

First enter the path to the current teklastructures.exe, then the
desired parameters.

Use the quotation marks (") in the path to avoid possible problems if the
path contains spaces. If you have installed Tekla Structures to a path that
does not contain spaces, there will be no problems even if you remove
the quotations marks, for example, C:\TeklaStructures\. If you have
installed Tekla Structures to a path that contains spaces, the quotation
marks are needed, for example, C:\Program Files\Tekla
Structures\.
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The maximum length of a shortcut is 256 characters. If you have problems
with the length, you can call all other necessary initialization files from
your customized initialization file instead of adding them to the shortcut.

10. To override the settings defined in the shortcuts, use the parameter -i
<initialization_file> in the user.ini and option.ini files.

Available parameters in shortcuts
The table below lists the parameters you can use in the start-up shortcuts.

The parameters can be used in combinations. You can set the parameters to
automatically bypass the Tekla Structures - Choose setup dialog box, open a
model and run a macro, for example.

Parameter Description
-I
<ini_file_path
>

The given .ini file is loaded before the
environment .ini files. This parameter can be specified
multiple times.

This parameter can be used to bypass the Tekla
Structures - Choose setup dialog (the login dialog).

Example:

"C:\Program Files\Tekla Structures\<version>
\nt\bin\TeklaStructures.exe" -I
"C:\ProgramData\Trimble\Tekla Structures
\<version>\Environments\uk\Bypass.ini"
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Parameter Description
-i
<ini_file_path
>

The given .ini file is loaded after the role .ini files.
This parameter can be specified multiple times.

Example:

"C:\Program Files\Tekla Structures\<version>
\nt\bin\TeklaStructures.exe" -i
"C:\TeklaStructures\MySettings.ini"

To open an
existing model

<model_path>

The given model is opened after start-up.

Example:

"C:\Program Files\Tekla Structures\<version>
\nt\bin\TeklaStructures.exe"
"C:\TeklaStructuresModels\My model"

To open an
existing,
autosaved model

<model_path> /
autosaved

The given autosaved model is opened after start-up.

Example:

"C:\Program Files\Tekla Structures\<version>
\nt\bin
\TeklaStructures.exe""C:\TeklaStructuresMode
ls\My model" /autosaved

To create a new
model without a
model template

/
create:<model_
path>

A new model is created after start-up.

Example:

"C:\Program Files\Tekla Structures\<version>
\nt\bin\TeklaStructures.exe"/
create:"C:\TeklaStructuresModels\My model"

To create a new
model using a
model template

/
create:<model_
path> /
modelTemplate:
<template_name
>

A new model using a model template is created after
start-up.

Example:

"C:\Program Files\Tekla Structures\<version>
\nt\bin\TeklaStructures.exe"/
create:"C:\TeklaStructuresModels\My model" /
modelTemplate:"Cast-in-Place"

To create a new
multi-user model

/
create:<model_
path> /
server:<server
_name>

A new multi-user model is created after start-up.

Example:

"C:\Program Files\Tekla Structures\<version>
\nt\bin\TeklaStructures.exe"/
create:"C:\TeklaStructuresModels\My model" /
server:"my-server:1234"
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Parameter Description
To run a macro
after start-up

-m
<macro_file_pa
th>

The given macro is executed after start-up.

The example below opens Tekla Structures, sets the
environment, role and configuration from the
Bypass.ini file, opens the model, and reads in and
saves the model by using the Example Macro: Model
Sharing Read in and Save from the BIM Publisher tool
that is available in Tekla Warehouse.

"C:\Program Files\Tekla Structures\<version>
\nt\bin\TeklaStructures.exe" -I
"C:\ProgramData\Trimble\Tekla Structures
\<version>\Environments\<environment>
\Bypass.ini" "C:\TeklaStructuresModels
\<model>" -m "C:\ReadInSave2016.cs"

Example of an initialization file
Below is an example of a customized project initialization file that calls other
initialization files.

MyProject.ini
//The project is based on the default UK settings
call C:\ProgramData\Trimble\Tekla Structures\2019.0\Environments\uk
\env_UK.ini
//..but our company policy requires these changes
call c:\CompanySettings\OurPolicy.ini
//..and the fabricator requires something
call c:\Fabricators\Fabricator1.ini
//..and then we let users to make some changes (color etc.)
call c:\Users\user_%USERNAME%.ini

The project shortcut for this initialization file:

"C:\Program Files\Tekla Structures\<version>\nt\bin\TeklaStructures.exe" -
i "\\MyServer\MyProject\MyProject.ini" "\\MyServer\MyProject\MyModel\"

2.14 Using Tekla Structures with application and desktop
virtualization
Using Tekla Structures with the Citrix application and desktop virtualization is
a flexible and safe way to quickly add users to Tekla Structures projects
without locally installing Tekla Structures and copying project data to a user's
computer. Citrix application and desktop virtualization products are products
of Citrix Systems, Inc.
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The image below shows the main concepts in Tekla Structures virtualization.

Data center

Citrix thin clients
running on various
operating systems

Secure display data
connection over the internet

Virtualization platform
(hypervisor layer)

Virtual Tekla Structures
instances running on
Microsoft Windows

Streaming applications from the server enables the use of Tekla Structures on
client computers, tablets and smartphones that have different hardware and
software configurations. Tekla Structures runs on Windows on the remote
server and the virtualization solution allows client devices to be used for
display and user input.

Users connect through a secure connection to the data center located in your
premises or in the cloud. The project data is protected as everything is stored
only on the server. Using Tekla Structures from a centralized location ensures
that all users in the project are using the same project environment set-up.

Prerequisites for using Tekla Structures in a virtual
environment
Citrix virtualization is set up either on a physical server or on a virtual server.
Recommended hardware is described in Hardware recommendations for
running Tekla Structures on Citrix and .

For detailed instructions on installing and setting up XenApp and XenDesktop,
see the Citrix documentation.

The image below shows the main components in Tekla Structures
virtualization.
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Data center

Citrix XenServer/
VMware vSphere

License server

Citrix Receiver

File server

Virtual machine
running Windows

1

2

Citrix XenApp/XenDesktop
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1. Thin client application: users can access Tekla Structures with Citrix
Receiver through Citrix XenApp client or Citrix XenDesktop desktop viewer
on any supported operating system and hardware. Multiple concurrent
clients may share one virtual machine instance.

A good internet connection is required. Recommended network
bandwidth is 1 Mbps or more.

2. Each TeklaStructures.exe running on the virtual machine needs a
valid license.

Local, enterprise, or cloud Tekla license server can be used, and the
license server can be hosted in or out of the data center.

3. Read/write project files from network-attached storage (NAS). Fast disk
access is needed. Never use the local disk of the virtual server for saving
model folders.

Accessing any files from the client's local file system requires uploading
the files to the server, which may be very slow and should be avoided as
much as possible. Project data including environments should be stored
on another (server) machine in the data center or file system inside the
company network.

The key components for using Tekla Structures with the Citrix application and
desktop virtualization are:

• High-end Windows server that can serve multiple concurrent users. The
server is typically set up by the company's IT department.

• A file server that provides fast access to project files from the virtualization
server.
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• Tekla Structures installed on the server or on the virtual machine running
on the server.

• A reliable connection from the virtual hosts to Tekla license server as each
Tekla Structures user needs a valid Tekla Structures license

• Delivery groups (user groups) and access rights, which are defined on the
server with Citrix Studio.

• Delivery groups are set up by the administrator of the virtualization
environment.

• Access rights for delivery groups must be defined by the administrator
on the server.

• Citrix Receiver installed on client computers. The Citrix Receiver is typically
delivered through an Internet browser and installed by the end-user.

Set up the virtual environment for Tekla Structures
You need to set up the server, define delivery groups, install the Tekla
Structures software and environments on the server, and Tekla Structures
users need to install the Citrix Receiver on their computers.

1. Set up the server. 

The server must be a high-end computer with a fast graphics card, a fast
processor, and enough main memory for each user depending on the size
and level of detail of the projects they are working on. See Hardware
recommendations for running Tekla Structures on Citrix for more detailed
information.

For detailed instructions on installing and setting up XenApp and
XenDesktop, see the Citrix documentation.

2. Install Tekla Structures software and the needed environments on the
server. 

NOTE Storing models on the virtual computer local disk may cause
access problems. Use a dedicated file server for models, and
remember to select the correct network location for the model
folder during the Tekla Structures installation.

Tekla Structures environment settings are the same for all users
that use the same virtual computer. In the same manner as with
normal desktop installations, you still have to make sure that the
environments on different virtual machines are the same or
matching.

We strongly recommend that you use standard Tekla Structures
environments and amend them with company or project-specific settings
(on the network file server).
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3. Install the Citrix Receiver on the Tekla Structures client computer: 

We recommend that you use the Citrix Receiver web user interface.

a. Open the Citrix Receiver web user interface in your web browser. 

Use the https address provided by your company's administrators.

b. Install the Citrix Receiver client software by following the steps in the
installation wizard. Do not create an account, or login in the
installation wizard, but finish the installation and return to the web
user interface.

c. After the installation, return to the Citrix Receiver web user interface
and log in with the credentials provided by your company's
administrators.

d. Select the desired virtual desktop. If the virtual desktop does not start
automatically, run the downloaded Citrix (.ica) file.

You can now start using Tekla Structures on the virtual desktop, in the
same manner as if it was installed on your own computer.

• When you use the virtual desktop for the first time, you can give read
and write access to your local files in the file access dialog box.

• Note that referencing local files from your computer directly in Tekla
Structures is not recommended. If you need to access those files in
Tekla Structures, you should copy them to a shared network location
first.

• Note that model folders are not copied to the client computers.

The Citrix Receiver client is updated frequently. Always install the latest
client when the web user interface suggests you to do so.
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3 Manage Tekla Structures
licenses

There are two main types of licenses in Tekla Structures:

• Online licenses, which is the default option for new Tekla Structures
licenses and how the Tekla Model Sharing feature is licensed.

• On-premises licenses that you activate locally on a license server you install
on your own hardware. Users connect to your local server to reserve a
license.

Working with online licenses

You activate online licenses for each user's Trimble Identity, after which the
user is able to choose a license when they log in to Tekla Structures.
Administrator users can monitor the online license usage and contract
manager users can manage your subscription renewals in the Tekla Online
Admin Tool.

For online license instructions, see Manage Trimble Identities and Tekla Online
licenses.

Working with on-premises licenses

To get started with on-premises license administration:

1. Make sure you understand how licensing works, see Tekla Structures on-
premises licensing (page 29).

2. Install the license server as explained in Installing Tekla license server
(page 44).

3. Make sure the license server can connect to Trimble's activation server
and clients can connect to the license server, see Allowing Tekla license
server to operate through Windows Firewall (page 53).

4. Activate your licenses on the server as explained in Activate on-premises
licenses (page 64).

5. Test that licensing works and connect the clients to the license server as
explained in Preconfigure license server settings for users (page 68).

Manage Tekla Structures licenses 28

https://teklastructures.support.tekla.com/not-version-specific/en/managing-tekla-accounts-and-model-sharing-licenses
https://teklastructures.support.tekla.com/not-version-specific/en/managing-tekla-accounts-and-model-sharing-licenses


Additionally, you can ensure that the correct types of on-premises licenses are
available to the users who most need them by defining access rights for using
and borrowing licenses as explained in Modify on-premises license access
rights (tekla.opt) (page 73). This can prevent situations where there are no
licenses available for users that need them because someone else has
reserved or borrowed a license that they do not really need.

When you renew on-premises licenses and when you need to make hardware
changes on the license server, you must deactivate your licenses as explained
in Deactivate on-premises licenses (page 69).

If your on-premises licenses have become untrusted or disabled, they cannot
be used and you need to repair them. For information about how to do this,
see Repair an on-premises license (page 79).

See also

Troubleshoot Tekla licensing (page 80)

3.1 Tekla Structures on-premises licensing
The information on this page is not valid for online licenses.

On-premises licenses are an alternative to the default online licensing method.
Whether the license is on-premises or online is determined when you
purchase a license, so you cannot switch your licenses between the two
distribution methods yourself. You activate on-premises licenses on a license
server that you install on your own computer hardware. Tekla Structures
installations for one or more users connect to the license server to reserve a
license.

On-premises licensing technology

With on-premises licensing, Tekla Structures uses FlexNet (FlexNet Publisher
License Management) licensing system by Flexera Software. We provide our
own Tekla-specific tools for managing the licenses on top of the common
FlexNet platform, replacing some of the standard tools you may have
encountered when using other software products that use FlexNet for
licensing.

The license server software is compatible with several versions of Tekla
Structures. To see which license server version to use with your current Tekla
Structures version, see Hardware recommendations for Tekla 2020 license
server. The licenses are also compatible with older versions of Tekla Structures
in addition to the highest allowed version stated in the license. The license is
sent to you attached in an email as an entitlement certificate HTML file.

NOTE Keep backup copies of your license entitlements in a safe place.
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Local licensing on your workstation

If there are few users in your organization and you do not need to share the
same licenses between users, you will install a license server directly on the
Tekla Structures workstation. When you activate a license on the local license
server, Tekla Structures always uses that license and you can also start Tekla
Structures offline without borrowing a license. If you want to use this type of
setup, see .

For organizations with many users, it is not optimal to install and manage a
license server on each workstation because of the extra work involved, lack of
visibility and inability to flexibly share licenses between users. In this situation,
it is better to set up a central license server in your internal network.

License server in your local area network (floating licenses)

The illustration below shows how licensing works in a typical corporate setup
where licenses are activated on a centrally-managed license server, and there
is a mix of on-premises and online licenses in use.

Main user / IT administrator
License entitlement via email1

4
Online licenses

Tekla license server
License administration tool

(FlexNet & LMTOOLS)2
3

4

Tekla Structures users

Tekla Structures
License borrow tool (optional)

1. An administrator (main user or IT administrator) receives entitlement
certificates for new and updated FlexNet licenses as email attachments.

2. The administrator activates and manages the FlexNet licenses in the Tekla
License Administration Tool on the license server installed at your
organization.

For successful activation, the system must be able to contact Trimble's
online license activation service.
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3. The administrator adds users to your organization and allows access to
your purchased online licenses in the Tekla Online Admin tool.

Exception: users must get their free learning license themselves at the
Tekla Campus site.

4. Tekla Structures installations on the end-users' workstations reserve a
license on the license server or in the cloud when a user starts Tekla
Structures or joins Tekla Model Sharing. When the user stops using Tekla
Structures, the license reservation is revoked.

• You can optionally allow users to borrow licenses for a set period of
time, which allows the user to start Tekla Structures without network
access to the license server. To borrow a license, the user must have
the license borrow tool installed on their workstation.

• Online licenses cannot be borrowed; users must have internet access
to start Tekla Structures with an online license. For more information
about online licenses, see Manage Trimble Identities and Tekla Online
licenses.

Tekla Structures holds licenses in trusted storage. This means that Tekla
Structures does not support three-server redundancy, where licenses are held
in license files. However, you may have any number of license servers, and use
search paths for defining and finding them.

Using multiple license servers in one company

You may want to spread your license pool on several servers in your company.
You may have offices in many cities, each office with its own license server, or
you may simply want to divide the license pool to minimize disruption caused
by server downtime.
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License entitlement - 20 seats

Office A - 10 licenses

Office B users

Office B - 10 licenses

Office A users Office C users

You do not have to activate all of the licenses on the same license server even
if they are on the same entitlement certificate. For example, you can divide
your total license entitlement on several servers simply by activating one half
of your licenses on one server and the other half of the licenses on another
server. Or, as another example, you can activate some of the licenses on a
common server and the rest locally on each user’s computer. You can easily
change the location of the licenses by deactivating them on one license server
and activating on another so you can adjust the number of licenses to changes
in your user base over time.

In Tekla Structures, you can define two server addresses separated by a
semicolon (;). This way, if there is a maintenance break on one of the servers,
users can obtain the license from the other server.
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NOTE Defining several license servers may slow down the starting of Tekla
Structures. Therefore, we do not recommend defining more than two
servers.

License server hardware

The Tekla license server does not need high performance hardware. However,
it is important to ensure that the network connection and server hardware are
reliable, and to maintain the server system carefully.

NOTE Deactivate your licenses before you make changes to the hardware
or perform a major operating system upgrade on the license server
computer. Keep copies of your license entitlement certificate(s) in a
safe place in case something goes wrong, so that you can easily and
quickly activate the deactivated licenses on a different system. You
can only activate the same licenses again if they have first been
deactivated on the previous system. If the license server system
becomes permanently inoperable with the licenses still activated,
contact your local Tekla support for assistance.

See Tekla license server 2020 hardware recommendations for information on
operating systems and virtual machine platforms.

Configuration features for on-premises licenses

You have fine-grained control over the license use:

• You can control license use based on the license type (enterprise/domestic)
or Tekla Structures configuration.

• You can define minimum and maximum numbers of licenses users/user
groups have available.
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• You can allow or prevent license borrowing from named users/user
groups.

The configurations can be done based on host addresses, individual user
names or by user groups. See Modify on-premises license access rights
(tekla.opt) (page 73) for more information.

Checklists for on-premises licensing implementation

There are several prerequisites the administrator needs to take into account
before starting with FlexNet licensing. Take a look at the following listings:

• Checklist of Trimble deliverables needed in on-premises licensing
(page 34)

• Checklist of IT resources needed in on-premises licensing (page 35)

• Checklist for the on-premises license server administrator (page 36)

• Rights needed for administrator tasks in on-premises licensing (page 37)

Additional information sources

In addition to Tekla Structures specific documentation, you can find useful
information on the FlexNet system in the documents provided with the
installation and in Tekla Downloads. The following FlexNet License
Administration Guides by Flexera Software are generic guides that contain,
for example, instructions on how to create user groups and manage access
rights:

• C:\Tekla\License\Server\fnp_LicAdmin.pdf
• C:\Tekla\License\Server\LicenseAdministration.pdf

See also

Distributing and managing on-premises licenses (page 37)

Examples of different on-premises licensing setups (page 39)

Installing Tekla license server (page 44)

Checklist of Trimble deliverables needed in on-premises
licensing

The information on this page is not valid for online licenses.

To get started with the Tekla Structures on-premises FlexNet licensing, the
administrator needs to have the following items provided by Trimble:

• Entitlement certificate

Trimble has sent the license entitlement certificate in an e-mail to the
person in your organization who has made the license purchase, or to
someone named as the contact person. The entitlement certificate lists all

Manage Tekla Structures licenses 34 Tekla Structures on-premises licensing

https://download.tekla.com/tekla-structures/for-businesses


the Tekla Structures licenses you are entitled to use and includes the
activation IDs for entitled licenses.

For entitlement requests, contact your local Tekla representative.

• Tekla license server installation package

The Tekla license server installation package is available on Tekla
Downloads product download service. The installation package contains
the license server files and Tekla License Administration Tool.

• License Administration Guide

This guide by Flexera Software is a general guide that contains, for
example, instructions on how to create user groups and manage access
rights. This guide is provided in the license server installation package and
is installed in the folder where you install the license server in the .pdf
format.

Checklist of IT resources needed in on-premises licensing

The information on this page is not valid for online licenses.

In Tekla Structures on-premises licensing, you need to install the licensing
tools on your own hardware, taking into account the following IT resource
related requirements:

• Supported operating system

The FlexNet licensing system for Tekla Structures runs in Windows
operating system. The support for virtual servers is limited. For more
information, see Tekla Structures Hardware recommendations in Tekla
User Assistance.

• Windows user account with administrator rights

Your Windows login user name should not contain any special characters.

You need to have administrator rights to install and manage the license
server. For more information, see Rights needed for administrator tasks in
on-premises licensing (page 37).

• TCP/IP port 27007 for license server

Tekla licensing service (lmgrd) is automatically run in the TCP/IP port
27007. This port should be dedicated for Tekla licensing service only. If
required, you can manually set a different TCP/IP port for the licensing
service, see Modify the license file tekla.lic manually (page 50).

• Local area network

The license server and the client computers need to be in the same local
area network. The clients need to be able to contact the license server. If
there is no local area network in your company, we recommend that you
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install the license server on each computer that has Tekla Structures and
activate one license on each computer.

• Internal firewall and direct communication

The internal firewall of your company (for example, Windows Firewall) must
allow the communication between the server computer and the computers
with Tekla Structures. You must allow the applications tekla.exe and
lmgrd.exe to operate through the firewall. For more information, see
Allowing Tekla license server to operate through Windows Firewall
(page 53).

Direct communication from the server computer to the Internet needs to
be allowed when the license server at your company contacts the
activation server at Trimble Solutions. The activation communication uses
SOAP over HTTPS on the TCP/IP port 443.

Your firewall should not block any incoming or outgoing information during
the activation. To allow the activation communication, use the activation
server address in your firewall settings:

https://activate.tekla.com:443/flexnet/services/ActivationService?wsdl

If direct communication from the server computer to the Internet is not
allowed, contact your local Tekla Structures support for manual activation.

• System backup settings

If you have an automatic backup and restore system in your company,
configure your system so that it does not overwrite your actual Trusted
Storage with the backup copy. Trusted Storage is the place where the
licensing information is stored on the server computer, and it is located in
C:\ProgramData\FLEXnet depending on the operating system.

Checklist for the on-premises license server administrator

The information on this page is not valid for online licenses.

Your company or organization should assign an administrator for the Tekla
Structures on-premises license server. The license server administrator's
primary responsibilities are:

• Install the Tekla license server: Installing Tekla license server (page 44)

• If automatic installation is not possible, manually install and configure
Tekla license server: Install Tekla license server - manual installation
(page 47), Configure Tekla license server manually (page 51), Modify the
license file tekla.lic manually (page 50)

• Save the entitlement certificate on the license server computer and activate
licenses on the server to make the licenses available for Tekla Structures
users, or for yourself, if the license server is installed on your own
computer: Activate on-premises licenses (page 64)
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• Inform users of the license server name and port number so that they can
connect Tekla Structures to the server: Preconfigure license server settings
for users (page 68)

• If necessary, modify the firewall settings to allow licensing traffic: Allowing
Tekla license server to operate through Windows Firewall (page 53)

• If necessary, modify license access rights in the tekla.opt options file:
Modify on-premises license access rights (tekla.opt) (page 73)

• Export a customized product ID files for license borrowing and deliver
them to offline users: Provide offline users with a customized product ID
file (page 104)

• Inform users of the license policy of the company and monitor license use.

Rights needed for administrator tasks in on-premises
licensing

The information on this page is not valid for online licenses.

You need to have Windows administrator rights to install and manage the
Tekla Structures on-premises license server. Some applications also need to
be run as administrator separately. This depends on the Windows version you
are using.

• In Windows 7, Windows 8/8.1 and Windows 10, you need to log in as
administrator. In some cases, you need to run applications as
administrator. To do this, go to the folder containing the application, right-
click the application and select Run as administrator from the pop-up
menu.

• In Windows Server you need to log in as administrator. In some cases, you
need to run applications with unrestricted rights. To do this, right-click the
application, select Run as, and clear the Run this program with
restricted access check box.

Distributing and managing on-premises licenses
The information on this page is not valid for online licenses.

The Tekla Structures FlexNet licensing system offers several options for
distributing licenses to users. The way you distribute the licenses depends on
the size of the company or organization, and the amount of Tekla Structures
users.

There are two basic ways of distributing licenses to users:

• The licenses are available for multiple users on a common license server.
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• The licenses are activated on each user’s own computer.

You can also use a combination of license distribution methods. For example,
you can activate one license on a separate computer and activate the rest of
your licenses on a common license server.

You can also use online licenses together with on-premises licenses. Users can
switch between the two licensing methods when they start Tekla Structures.
For example, users can use an on-premises license at the office, but switch to
an online license when they are outside the office when they are mostly within
reach of the internet. Using an online license eliminates the need to borrow
licenses or connect to the office through VPN just to reserve a license.

The following table shows what is typical for managing the licenses that are
activated separately on each computer, and for licenses that are activated on a
common license server.

Licenses are activated on user's
own computer

Licenses are activated on a
common license server

No need for an assigned license
server administrator.

Each user manages the license server
that is installed on the user's own
computer.

Centralized maintaining and
administration of licenses is needed.

A license server administrator
maintains the license server and
manages the license use.

Typically, there are a few Tekla
Structures main users in a company.
The main users are good candidates
for license server administrators,
because they are already familiar with
Tekla Structures. For more
information on the responsibilities of
the license server administrator, see
Checklist for the on-premises license
server administrator (page 36)

No need to manage license access
rights.

Each user activates only the licenses
that are needed.

By default, all license configurations
activated on the server are available
for all Tekla Structures users.
However, centralized access rights
management is possible.

The license server administrator can
give different users access to different
configurations. The license server
administrator needs to modify the
tekla.opt options file to manage
the license access rights. For more
information on managing license
access rights, see Modify on-premises
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Licenses are activated on user's
own computer

Licenses are activated on a
common license server

license access rights (tekla.opt)
(page 73).

Tekla Structures can be used out of
office.

If the user's license is activated on a
computer, license borrowing or a VPN
connection is not needed.

Tekla Structures can be used out of
office.

A user needs to borrow a license from
the common license server or use a
VPN connection to the license server
to use Tekla Structures out of office.

Licenses are used only by one person.

Users have access only to the licenses
that are activated on their own
computer. If a user needs a license
that is activated on another
computer, the user needs to use the
other computer. Another option is to
deactivate licenses on one computer
and activate them on another, which
requires effort.

Licenses are checked out frequently
by several users.

When the licenses are activated on a
common server, they are available for
multiple users. The licenses are
checked out from the license server
only when they are needed. When a
user does not need a license, the user
closes Tekla Structures and the
license becomes available for another
user. Switching from using one
license to another is simple.
Rules of license usage

Tekla Structures users should accept
common rules or an internal
company policy. The rules should
contain regulations of managing the
licenses, for example, who is allowed
to borrow licenses. Usage of common
rules minimizes the amount of
conflicts in license management.

Examples of different on-premises licensing setups

The information on this page is not valid for online licenses.

The purpose of the following examples is to provide guidelines for Tekla
Structures on-premises license management in companies or organizations of
different sizes.

Example 1: One Tekla Structures user, all licenses activated on one
computer

Only one user in the company uses Tekla Structures. The user installs Tekla
Structures and the license server on the same computer.
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• Installing the license server is straightforward, and the default license
server settings can be used. The user does not need to modify the license
server settings, because the user runs the license server and Tekla
Structures on the same computer.

• Because the user installs the license server on a computer, the user does
not need to borrow a license or use a VPN connection to use Tekla
Structures out of office.

Example 2: Three Tekla Structures users, necessary licenses activated
separately on each computer

There are three Tekla Structures users in a company. Because the users use
different Tekla Structures configurations, each user installs a license server
separately on the user's own computer and activates only the needed licenses.

• A license server administrator is not needed, the users maintain their
license servers.

• Because the users install the license servers on their computers, they do
not need to borrow a license or use a VPN connection to use Tekla
Structures out of office.
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Example 3: Ten Tekla Structures users, necessary licenses activated on a
common license server and one user's computer

There are ten Tekla Structures users in a compan

y.
Because the users use different configurations, the company uses a common
license server.

• The company has an internal policy for license use containing regulations
for managing the licenses.

• One of the main users is assigned as the license server administrator. The
administrator installs the license server and informs the other users of the
hostname and port number of the server. The license server administrator
also performs other server maintenance duties.

• One of the users travels a lot and needs Tekla Structures on the journeys. A
license server is installed separately on the user’s computer, so the user
does not need to borrow a license or use a VPN connection for offline use
of Tekla Structures.

• Other users borrow licenses from the license server when they need to use
Tekla Structures offline.
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Example 4: Fifty Tekla Structures users in two offices, necessary licenses
activated on two separate servers

There are fifty Tekla Structures users in two separate offices. Both offices have
their own license servers.

• Both offices have assigned license server administrators. The license server
administrators install the license servers and perform license server
maintenance duties.

• The company has an internal policy for using licenses. The policy contains,
for example, the rules that define who is allowed to borrow licenses.

• Because the amount of Tekla Structures users is large, the license server
administrators create tekla.opt options files for controlling the access
rights for different licenses.

• Only a couple of users need to use Tekla Structures offline. The license
server administrators modify the option files to enable the license
borrowing only for those users who need to borrow licenses.

• If one server fails, the users can connect to the license server at the other
office. If there are licenses available on the license server, the users can use
the licenses.
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3.2 Installing Tekla license server
The Tekla license server installation package contains license server files,
applications for license management and guides. To install the license server
software, download the license server installation package with the latest
updates from Tekla Downloads product download service.

You have two choices in installation:

• Automatic default installation: Select automatic installation for normal
setup. Automatic installation is recommended.

For detailed installation instructions, see Install Tekla license server -
automatic installation (page 46).
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• Manual installation: Use manual installation if you need to separately
install the license server, modify the license file, configure the license
service, and start the server software. This is needed if you want to use
another TCP/IP port than the one used in the automatic installation, for
example. Use manual installation only if you are an advanced user of
FlexNet or FlexIm licensing.

For detailed installation instructions, see Install Tekla license server -
manual installation (page 47).

Before installing Tekla license server

• Install the license server using administrator's rights.

• Turn off the internal firewall and pause the antispyware/antivirus
protection.

• Ensure that you have access to the Internet. The Internet connection is
needed during the license activation process. An unreliable connection
speed may cause errors.

• If you are using other FlexNet licensing services, you need to stop them
before you install the Tekla license server. When you have completed
installing the Tekla license server, you can restart the other licensing
services.

See also

Problems in Tekla license server installation and connecting to the license
server (page 82)

Activate on-premises licenses (page 64)

Allowing Tekla license server to operate through Windows Firewall (page 53)

Which license server version to use

Check the table below to see which license server version to use with your
current Tekla Structures version. Also check if you need to upgrade to a new
service pack or progress release.

For information about updating the license server, see Update the Tekla
license server.

Tekla Structures
version

License Server 2016
SP1

License Server 2017 or
later

2018 or later

2017i - all versions

2017 - all versions

2016i - all versions
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Tekla Structures
version

License Server 2016
SP1

License Server 2017 or
later

2016 SP5/PR5 or later

2016 up to SP4/PR4 Upgrade to 2016
SP5/PR5 or later

21.1 SR7 or later

21.1 up to SR6 Upgrade to 21.1 SR7 or
later

21.1 all PV versions

21.0 or earlier

For instructions on how to install the license server, see .

Install Tekla license server - automatic installation

Before you start license server installation, stop FlexNet licensing services and
other licensing services.

For more information about which license server version to use, see Hardware
recommendations for Tekla 2020 license server.

To install the default setup of the Tekla license server to a computer that does
not have a previous version of Tekla license server installed:

1. To download the license server installation package with the latest
updates, go to Tekla Downloads, select the Tekla Structures version, and
click All downloads. On the next page, select License server as the File
type and click Apply filter. Then select the License server.

2. Select the installation language.

3. Select Automatic as the licensing service installation type to install the
default setup.

4. Select the folder where you want to install the license server and
complete the installation.

Tekla license server is installed.

In automatic license server installation, the license server address is
automatically set to 27007@your_hostname, where 27007 is the port and
your_hostname is the computer name/hostname. 27007@your_hostname is
used as the license server address in every Tekla Structures installation.

When you have installed the license server, you need to do the following:

• Save the entitlement certificate and activate the licenses. For more
information, see Activate on-premises licenses (page 64).

Manage Tekla Structures licenses 46 Installing Tekla license server

https://download.tekla.com/tekla-structures/for-businesses


• Connect Tekla Structures to the license server. For more information, see
Preconfigure license server settings for users (page 68).

• You can also change the language of the user interface in Tekla License
Administration Tool by opening the tool and clicking Language.

See also

Install Tekla license server - manual installation (page 47)

Problems in Tekla license server installation and connecting to the license
server (page 82)

Problems in Tekla licensing: Error codes and their descriptions (page 96)

Install Tekla license server - manual installation
Use manual installation if you want to separately install the license server,
modify the license file, configure the license server, and start the license server
software. In manual installation of Tekla license server, you also install two
files: installanchorservice.exe and uninstallanchorservice.exe.
You need these files when you manually install or uninstall FlexNet Licensing
Service.

For example, you need to install the license server manually if the default
TCP/IP port 27007 is already in use by other services or applications, and you
need to define another port in the license file tekla.lic.

Before you start license server installation, stop other FlexNet licensing
services.

To install the license server manually:

1. To download the license server installation package with the latest
updates, go to Tekla Downloads, select the Tekla Structures version, and
click All downloads. On the next page, select License server as the File
type and click Apply filter. Then select the License server.

2. Select the installation language.

3. Select Manual as the licensing server installation type and complete the
installation.

4. Go to the Start menu or Start screen (depending on your Windows
operating system) and open Command Prompt as administrator.

5. At the command prompt, enter the following commands:

a. cd /d %SYSTEMDRIVE%\Tekla\License\Server
b. installanchorservice.exe
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The licensing server is installed.

6. Modify the license file to include the hostname or IP address of the server,
and the correct TCP/IP port:

a. Open the ..\Tekla\License\Server folder on the server
computer.

b. Open the tekla.lic (license file) file with a text editor.

c. Replace text localhost on the line SERVER localhost ANY with
the hostname (computer name) or IP address of the license server.

d. Enter the TCP/IP port number after text SERVER server_hostname
ANY.

e. Save the changes and close the text editor.

7. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

8. On the Service/License File tab, click Configuration using Services.

9. On the Config Services tab to configure the licensing service:

a. In the Service Name box, enter the name of the service exactly as
follows: Tekla Licensing Service.

b. Click the Browse buttons to locate the lmgrd.exe (license server
manager), tekla.lic and tekla_debug.log files.

By default, lmgrd.exe, tekla.lic and tekla_debug.log are
located in the C:\Tekla\License\Server folder.

Note that if you set Path to the debug log file outside the
"C:\ProgramData\..." folder, you get an error message:
"Windows preferred path <SystemDrive>\ProgramData to store
service data is not set." This error message can be ignored.

c. Select the Use Services check box to run the licensing service as a
Windows service.

d. Select the Start Server at Power Up check box to start the licensing
service automatically after Windows startup.

e. Click Save Service to save the settings.
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10. Go to the Start/Stop/Reread tab and click Start Server to start the
license server.

11. Go to the Server Status tab and click Perform Status Enquiry.

In the status list, the line License server status shows the TCP/IP
port and hostname of the license server.

Now you can activate the licenses and connect Tekla Structures to the
license server.

You can also change the language of the user interface in Tekla License
Administration Tool by opening the tool and clicking Language.
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See also

Modify the license file tekla.lic manually (page 50)

Activate on-premises licenses (page 64)

Configure Tekla license server manually (page 51)

Problems using LMTOOLS in Tekla licensing (page 91)

Problems in Tekla licensing: Error codes and their descriptions (page 96)

Modify the license file tekla.lic manually

If you selected the Automatic installation option, the license server is set to
your hostname: 27007@server_hostname (port@hostname).

The licensing system automatically searches for an available TCP/IP port and
uses the first available port detected. The Automatic installation sets the port
to 27007.

You need to modify the tekla.lic license file if you:

• Select the Manual license server installation option

• Want to change the TCP/IP port of the licensing server

• Want to use the IP address of your computer instead of the hostname

To modify the license file tekla.lic manually:

1. Go to the ..\Tekla\License\Server folder on the server computer.

2. Open the tekla.lic file in a text editor.

3. Make the necessary changes:

• To use hostname or IP address: Replace text on the first line between
words SERVER and ANY with the hostname or IP address of your
license server.

Do not delete texts SERVER and ANY when you enter the hostname or
IP address of the license server.

The following formats are valid:

Hostname:server_hostname
Domain name: server_hostname.mycompany.com
IP address: 10.0.0.12
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You can check the hostname of the license server in LMTOOLS on the
System Settings tab. Go to Tekla Licensing --> LMTOOLS through the
Start menu or Start screen, depending on your Windows operating
system.

• To set the TCP/IP port manually: Enter the TCP/IP port number after
text SERVER server_hostname ANY.

The port number can be any free port in the range of 0 - 64000.

4. Save the changes and close the text editor.

5. Restart the Tekla Licensing Service in LMTOOLS or Windows Services for
the changes to take effect.

See also

Install Tekla license server - manual installation (page 47)
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Configure Tekla license server manually
If you encounter problems during the Tekla license server installation, the
license server may not start automatically. If this happens, you need to
configure the license server manually using LMTOOLS.

To configure the Tekla license server manually:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system. Start LMTOOLS
with administrators rights.

2. Go to the Service/License File tab and select Configuration using
Services.

3. Go to the Config Services tab and do the following:

Service Name: Select the licensing service. When working with Tekla
license server, always select Tekla Licensing Service.

Path to the lmgrd.exe: Click Browse and locate lmgrd.exe. This file is
by default located in the C:\Tekla\License\Server folder.

Path to the license exe: Click Browse and locate tekla.lic. This file is
by default located in the C:\Tekla\License\Server folder.

Path to the debug log file: Click Browse and locate tekla_debug.log.

This file is by default located in the C:\Tekla\License\Server folder.

To append the logging entries in the debug log file, start the debug log file
name path with the plus sign (+), like by default for tekla_debug.log. If
the plus sign is missing, the log file will be rewritten each time the service
is started.

Note that if you set Path to the debug log file outside the
"C:\ProgramData\..." folder, you get an error message: "Windows
preferred path <SystemDrive>\ProgramData to store service data is not
set." This error message can be ignored.

Use Services: Select the check box to run the licensing service as a
Windows service.

Start Server at Power Up: Select the check box to start the licensing
service automatically after Windows startup.

4. Click the Save Service button to save the settings.

5. Go to the Utilities tab and do the following:

Vendor Name: Enter tekla (all letters lowercase).

Path: Enter the name of the license server.

• If you run the license server and Tekla Structures on the same
computer, enter @localhost. You can also enter the TCP/IP port, for
example, 27007@localhost.
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• If you run the license server and Tekla Structures on separate
computers, enter the hostname of the license server, for example,
@server_hostname.

• You can also enter the TCP/IP port of the license server, for example,
27007@server_hostname. You must define the port if you use
another port than the default port.

• You can also enter several license servers. Separate the server names
with a semicolon. For example,
27007@server_hostname;27007@localhost.

6. Click the Override Path button to replace the existing license servers
displayed in the status list on the Server Status tab.

7. Go to the Start/Stop/Reread tab and start the license server by clicking
Start Server.

The status bar should display a message telling that server start was
successful.

8. Go to the Server Status tab and enquire the license server status by
clicking Perform Status Enquiry.

The status list displayes the TCP/IP port and hostname of the license server.
The list should indicate that license server is up and vendor daemon tekla is
up. The list also displays all the activated licenses on the server.

See also

Installing Tekla license server (page 44)

Problems in Tekla licensing: Error codes and their descriptions (page 96)

3.3 Allowing Tekla license server to operate through
Windows Firewall
When you set up Tekla license server in your network, you may also need to
configure the firewall and antivirus settings:

• You need to allow the applications tekla.exe and lmgrd.exe to operate
through the firewall on the license servers and on the client computers.
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• The internal firewall at your company must allow the communication
between the license server computer and the computers with Tekla
Structures.

• In addition to allowing the exceptions in your actual firewall, you may need
to configure exceptions for Windows Firewall. Windows Firewall may be set
on without you being aware of it, because some Windows updates may
automatically turn on the Windows Firewall.

For instructions on how to modify the firewall settings so that the Windows
Firewall on the license server allows licensing traffic, see:

• Allow exceptions in firewall for lmgrd.exe and tekla.exe (page 54)

• Allow traffic in fixed TCP/IP ports (page 55)

In addition to Windows Firewall, the information given also applies to firewalls
from other vendors.

Allow exceptions in firewall for lmgrd.exe and tekla.exe
You need to allow the applications tekla.exe and lmgrd.exe to operate
through the firewall on the license server computer to enable licensing traffic.

To allow exceptions for lmgrd.exe and tekla.exe on the license server
computer:

1. Press the Windows logo key + R on your keyboard to show the Run
dialog box, then type firewall.cpl and press Enter.

2. In the left pane, click Allow a program or feature through Windows
Firewall or Allow an app or feature through Windows Firewall
(depending on the operating system).

3. In Allowed programs or Allowed apps (depending on the operating
system), click Change settings.

Administrator permission is required. If you're prompted for an
administrator password or confirmation, enter the password or confirm.

4. Click Allow another program or Allow another app (depending on the
operating system).

5. Click Browse to browse for the \Server folder on the computer, select
lmgrd.exe and click Open.

By default, the path is ...\Tekla\License\Server.

6. Click Add to add lmgrd.exe to the Allowed programs or Allowed apps
and features list (depending on the operating system).

7. Select both Home/Work (Private) or Private (depending on the
operating system) and Public check boxes next to lmgrd.exe.

8. Allow the exceptions also for tekla.exe by repeating the steps 4 – 7.
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9. Click OK to confirm the changes.

See also

Allowing Tekla license server to operate through Windows Firewall (page 53)

Allow traffic in fixed TCP/IP ports
You need to modify the firewall settings to allow traffic through fixed TCP/IP
port.

To allow traffic in fixed TCP/IP ports in Windows on the license server
computer:

1. Ensure that no other software or service is using the ports that you are
about to set fixed.

Use the command line command netstat -anp TCP to find out which
ports are in use.

The numbers in the Local Address column after the colon (:) are the port
numbers that are in use.

2. Browse for tekla.lic, and open it using a text editor.

By default, the path is ..\Tekla\License\Server.

3. To set a fixed port for lmgrd.exe, enter the TCP/IP port number at the
end of the SERVER row.

The Automatic installation option sets the port to 27007.
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4. Enter the text port=free_port at the end of the VENDOR row, for
example, port=1234. 

Defining the TCP/IP port number on the VENDOR row may slow down the
restart time of Tekla Licensing Service.

5. Save the changes and close tekla.lic.

6. Update your license server with the changes:

a. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

b. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected. 
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c. Go to the Start/Stop/Reread tab and click Stop Server to stop the
license server, and then start the server again by clicking Start
Server.

7. Click the Windows logo key on your keyboard to show the Start menu or
Start screen, depending on the operating system.

8. Type wf.msc and press Enter. The Windows Firewall with Advance
Security MMS snap-in is displayed.

9. In the navigation tree, select Inbound Rule, and then in the Actions pane,
click New Rule.
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10. On the Rule type panel, select Port and then click Next.
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11. On the Protocol and Ports panel, select TCP, enter the TCP/IP port
numbers that you set in steps 3 and 4 in Specific local ports, and then
click Next.
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12. On the Action panel, select Allow the connection, and then click Next.

13. On the Profile panel, select the appropriate profiles, and then click Next.
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14. On the Name panel, enter the name of the rule, and then click Finish.

Manage Tekla Structures licenses 62 Allowing Tekla license server to operate through
Windows Firewall



The rule is created and automatically enabled.
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Tekla Structures

Allow exceptions in firewall for lmgrd.exe and tekla.exe (page 54)

Allowing Tekla license server to operate through Windows Firewall (page 53)

3.4 Activate on-premises licenses
You need to activate the on-premises licenses on the license server to be able
to use them. There is no activation for online licenses.

How license activation works

When you activate on-premises licenses, your license server contacts the
activation server at Trimble Solutions, and the license rights are transferred to
the license server in your company network or on your computer. You can
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activate licenses in Tekla License Administration Tool, which is installed
together with the license server.

• Internet access is required in license activation because the license server
at your company needs to contact the activation server at Trimble
Solutions.

• The activation server at Trimble Solutions tracks the activation status of
your licenses. You are not allowed to activate any version of the same
license again without first deactivating it. Deactivate the licenses before
you make any major changes to the computer that runs the Tekla license
server.

• You do not need to activate all the licences at once. You can activate part of
the licenses now and part of the licenses later on some other computer, for
example. Different configurations and different versions need to be
selected for activation separately.

Activate licenses

To activate an on-premises license, you must have the corresponding license
entitlement certificate file EntitlementCertificate.html. The entitlement
certificate is sent in an e-mail to the person in your organization who has
made the license purchase, or to someone they have named as the contact
person. The entitlement certificate states the configurations, quantities and
identifiers of the licenses you are entitled to use.

• We recommend that you save the entitlement certificate file
EntitlementCertificate.html to the ..\Tekla\License\Server
folder. You will need the file again if you later need to move the licenses to
a different computer.

If you have licenses in several entitlement files, rename the files as
necessary to avoid overwriting.

• You can activate licenses using either manual or automatic server
notification. Do not use automatic notification if you are using some other
FlexNet license and license server administration tool, such as FlexNet
Manager. Otherwise, we recommend using automatic notification. You can
find the instructions for both procedures below.

Activate on-premises licenses using automatic server
notification
You can activate Tekla Structures on-premises licenses in Tekla License
Administration Tool, which is included in the license server installation. To
activate the license, the license server at your company contacts the activation
server at Trimble Solutions through the internet. Online licenses do not need
to be activated.
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NOTE Do not use automatic notification if you are using some other FlexNet
license and license server administration tool, such as FlexNet
Manager. To notify the license server about license changes manually,
see Activate on-premises licenses (page 64).

To activate the licenses and notify the license server automatically:

1. Go to Tekla Licensing --> Tekla License Administration Tool through
the Start menu or Start screen, depending on your Windows operating
system.

2. Make sure the automatic license server notification is enabled. Check the

status on the  Notify Server button in the toolbar and click the
button if necessary.

3. Click Open and open the EntitlementCertificate.html file that
contains the license. The license information is displayed in the Entitled
Licenses area.

4. Click the Activate cell and select the number of licenses to activate.

5. Click the Activate button.

Your license server contacts the license activation server at Trimble
Solutions.

• The activated licenses are displayed in the Activated Licenses area.

• We recommend that you back up the trusted storage (..\ProgramData
\FLEXnet\) in a safe place away from the computer running the license
server. Backups can help you restore your licenses on the same server if
active licenses are accidentally erased.

• When you open Tekla License Administration Tool later on, it detects
expired and broken licenses you may have and asks if you want to
deactivate or repair them. If you select Yes, an automatic deactivation or
repair is run.

See also

Problems in Tekla license activation (page 85)

Problems in Tekla licensing: Error codes and their descriptions (page 96)
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Activate on-premises licenses using manual server
notification
You have to use manual notification if you are using some other FlexNet
license and license server administration tool, such as FlexNet Manager.

To activate the licenses and notify the server manually:

1. Go to Tekla Licensing --> Tekla License Administration Tool through
the Start menu or Start screen, depending on your Windows operating
system.

2. Make sure the automatic license server notification is disabled. Check the

status on the  Notify Server button in the toolbar and click the button
if necessary.

3. Click Open and open the EntitlementCertificate.html file that
contains the license. The license information is displayed in the Entitled
Licenses area.

4. Click the Activate cell and select the number of licenses to activate.

5. Click the Activate button.

Your license server contacts the license activation server at Trimble
Solutions.

6. Next, you need to notify the server. This has to be done each time you
activate a license.

a. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

b. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

c. In the LMTOOLS dialog box, go to the Start/Stop/Reread tab.

d. Click ReRead License File.

The license server reads the license information.

• The activated licenses are displayed in the Activated Licenses area.

• We recommend that you back up the trusted storage (..\ProgramData
\FLEXnet\) in a safe place away from the computer running the license
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server. Backups can help you restore your licenses on the same server if
active licenses are accidentally erased.

• When you open Tekla License Administration Tool, it detects expired and
broken licenses you may have and asks if you want to repair or deactivate
them. If you select Yes, an automatic deactivation or repair is run.

See also

Problems in Tekla license activation (page 85)

Problems in Tekla licensing: Error codes and their descriptions (page 96)

3.5 Preconfigure license server settings for users
When the license server is on a separate server in the network, Tekla
Structures connects to the license server to fetch a license. To be able to do
this, the license server address must be defined on each computer. This can
be done by typing in the address when starting the software for the first time
or you can include the address in an intialization file that you distribute as part
of your customized installation. You can also predefine the license,
environment and role with a customized startup shortcut and intialization file.

By default, when Tekla Structures starts for the first time on a computer, the
system asks for the address of your Tekla license server unless Tekla
Structures can find a license server with an active license installed on the same
computer. To avoid this manual process, you can include the Tekla license
server address in your customized configuration. Similarly, you can also select
the license for the user, and if you also preset the environment and role, the
user does not need to make any selections when starting Tekla Structures. To
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set up this for your users, see the instructions in Implementation guide for
administrators (page 110).

See also

Modify the license file tekla.lic manually (page 50)

3.6 Deactivate on-premises licenses
License deactivation releases license rights from a license server, which allows
you to activate a new version of the same license or to activate the same
license on different hardware. There is no deactivation for online licenses.

The activation server at Trimble Solutions tracks the activation status of your
on-premises licenses. You are not allowed to activate any version of the same
license again without first deactivating it.

When you deactivate licenses, your license server contacts the activation
server at Trimble Solutions, and the license rights are transferred away from
your Tekla license server.

When you need to deactivate licenses

• Before you upgrade or reinstall the operating system or before you change
the hardware components of any computer that has a license server
installation with active licenses.

• Before you activate a replacement license, including licenses that entitle
you to run a new version of Tekla Structures and replacement licenses for
any temporary licenses.
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• Before you activate the same license on a different license server, for
example, when you want to change from one license server computer to
another.

• Before you change the IP address on the license server computer.

• Before you format the hard drive of or decommission your server
computer.

When you do not need to deactivate licenses

You do not need to deactivate licenses before uninstalling and reinstalling the
Tekla license server software.

Deactivate on-premises licenses
The information on this page is not valid for online licenses.

• Internet access is required in license deactivation.

• Deactivation must be done on the license server containing the active
license. If your license server fails and cannot be recovered, contact your
local support for assistance.

To deactivate licenses:

1. Start the Tekla License Administration Tool app with administrator rights.
This tool is installed together with the Tekla license server and you can
find it through the Windows Start menu on the computer that is hosting
your license server.

2. In the Tekla License Administration Tool dialog box, go to the Statistic
tab and ensure that no one is using the licenses.

NOTE Before you deactivate licenses, ensure that the licenses are not in
use or borrowed. The borrowed licenses must be returned before
they can be deactivated.

3. If you have not activated the automatic server notifications (the Notify
Server option in Tekla License Administration Tool), you need to stop
the license server manually in LMTOOLS:

a. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system. Start
LMTOOLS with administrator rights.
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b. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

c. Go to the Start/Stop/Reread tab and click Stop Server.

4. In Tekla License Administration Tool, go to the Licenses tab. 

The Activated Licenses area lists the active licenses.

5. Select the Deactivate check box to select the license for deactivation. 

If you activated more than one license of the same type in one go, you
cannot deactivate those licenses one by one, but you need to deactivate
all of the licenses in one go.

6. The Deactivate button is activated, click it.

The license server contacts the activation server at Trimble Solutions. Internet
access is required at this stage. After a successful deactivation you will see the
license successfully deactivated message, and the Tekla License
Administration Tool is updated to reflect the deactivation.

See also

Problems in Tekla license deactivation (page 89)

Problems in Tekla licensing: Error codes and their descriptions (page 96)

3.7 Maintain Tekla licenses
After the licensing is set up, you can verify that you have the correct number of
licenses and that the licenses are used correctly.

• With online licenses, you can monitor both current license users and view
statistics of past usage in the Tekla Online Admin Tool.

• With on-premises licenses, you can monitor who is currently using licenses
(page 72).

You need to make changes in the following situations:

• If users are selecting incorrect license types or secondary users are
reserving too many licenses, you can ensure that the correct types of
licenses are available to the users who most need them by defining access
rights for using licenses.

With online licenses, you can adjust license acess in the Tekla Online Admin
Tool.

For adjusting on-premises license usage, see Modify on-premises license
access rights (tekla.opt) (page 73).
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• If you have on-premises licenses, you need to deactivate your existing
licenses (page 69):

• When you start using a new version of Tekla Structures, which requires
activating renewed licenses.

• Before you activate a changed version of the same license (for example,
the number of concurrent users is changed).

• Before you make hardware changes that affect the license server.

• If you want to move the licenses to a different license server (page 78).

• If your on-premises licenses become untrusted or disabled, you can repair
them a limited number of times as explained in Repair an on-premises
license (page 79).

See also

Troubleshoot Tekla licensing (page 80)

Monitor Tekla Structures license use
With online licenses, you can monitor both current license users and view
statistics of past usage in theTekla Online Admin Tool. For instructions on
using the Admin Tool, see Manage Trimble Identities and Tekla Online
licenses. With on-premises licenses, you can view current license usage as
instructed below.

The LMTOOLS application requires Windows administrator privileges to run.

With online licenses, you can monitor both current license users and view
statistics of past usage in the Tekla Online Admin Tool. For instructions on
using the Admin Tool, see Manage Trimble Identities and Tekla Online
licenses.

You can get a report of how many Tekla Structures on-premises licenses are
currently in use in your company with the LMTOOLS software that is delivered
with the Tekla license server.

To view which licenses are currently in use:

1. Go to  Tekla Licensing --> LMTOOLS  through the Start menu or Start
screen, depending on your Windows operating system.

2. If the correct Tekla license server is not defined, switch to the Utilities tab
and add the license server path:

a. Type tekla in the Vendor Name box.

b. Type your license server address as port@host in the Path box.

c. Click Override Path.
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3. On the Server Status tab, click Perform Status Enquiry. You will receive
a listing of how many licenses and which configurations are activated on
the server, and how many of the licenses are in use at the moment of
enquiry. 

The status enquiry uses abbreviations of Tekla Structures configurations,
which are explained here (page 75). You can also find the description of
the abbreviations in your entitlement certificate or in Tekla License
Administration Tool.

For a comprehensive description of the status enquiry syntax, see .

Modify on-premises license access rights (tekla.opt)
The Tekla Structures on-premises license server administrator may grant
different users and user groups different rights to use licenses by modifying
the tekla.opt options file. This can prevent situations where there are no
licenses available for users that need them because someone else has
reserved or borrowed a license that they do not really need.

The information on this page is not valid for online licenses.

The licensing options file tekla.opt is located in the ..\Tekla\License
\Server folder.

The most common configuration options include the following:

• You can define the access rights for specific usernames or hostnames/IP
addresses either individually or using groups that you define. You can use
the same username or hostname in several groups.
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• You can reserve a number of licenses for a specific configuration (e.g.,
Steel detailing) for exclusive use by a specific user or user group. If
necessary, the users in the group can reserve more licenses than the
reserved quota. Other users can only use one of the remaining free
licenses outside the reserved quota.

• You can define a maximum (max) number of licenses that a user or group
can simultaneously use. Users who are not included in this limitation can
use any free license.

• You can include (allow) a user or group in the exclusive use of all licenses
for a specific configuration. Other users are prevented from using the
configuration.

• You can exclude (disallow) specific users from using any licenses for a
specific configuration. All other users are allowed to use the configuration.

• You can include and exclude users from borrowing licenses.

To modify access rights in the tekla.opt file:

1. Go to the ..\Tekla\License\Server folder.

2. Open the tekla.opt file in a text editor.

3. Enter your definitions for license access rights and restrictions. 

The definition string consists of the following parts: [keyword] [Tekla
Structures feature] [user type] [name]
When you write the definition, follow the rules below.

• Note that the options file is case sensitive.

• If you need to define user groups and host groups, define them first.

Use Windows user names when defining user groups and hostnames
or IP addresses when defining host groups.

• Enter one definition per row. A definition consists of the following
things:

• An options keyword that defines the actions.

• A feature, such as a configuration, that is affected by the keyword.

• The type that is affected by the keyword.

The options are: USER, GROUP, HOST, and HOST_GROUP.

• The name of the user, user group, host, or host group that is
affected by the keyword.

You can use the hostnames or IP addresses of the computers with
the HOST and HOST_GROUP keywords.

• To disable a row in the options file, enter # in the beginning of the row.

Examples of definitions:
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INCLUDE PCD-C USER scarlett (Only the user scarlett is allowed to
use the Precast Concrete Detailing configuration.)

RESERVE 1 RCD-C USER vera (One license of the Rebar Detailing
configuration is reserved for the user vera.)

For details about the allowed keywords and configuration codes together
with more examples, Configuration codes and keywords used in access
right definitions (page 75).

4. Save the changes and close the text editor.

5. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

6. In LMTOOLS, go to the Start/Stop/Reread tab and click the ReRead
License File button to update the changes in the license file and in the
options file.

Useful links

For more information about limiting certain Tekla Structures versions to
certain users, see the following Support Article in Tekla User Assistance: How
to limit certain Tekla Structures version to certain users

Configuration codes and keywords used in access right definitions
When you define access rights in tekla.opt, you need to use correct
abbreviations (codes) for the configurations, otherwise the definitions do not
work. The access rights are defined using certain keywords.

Configuration codes

When you define access rights for different Tekla Structures configurations in
the tekla.opt options file, you need to add a proper code for each
configuration in the definition.

NOTE The configuration codes are backward compatible, and the codes
used for licensing in older Tekla Structures versions still work.
However, the commercial product name of the configuration may
change between versions. For example, the commercial product name
for STDL-C used to be Steel Detailing Limited, but now it is Primary.

The codes for the Tekla Structures configurations are listed below:

Configuration code Configuration
CM-C Construction Modeling
DEV-C Developer
DFR-C Drafter
EDU-C Educational
FUD-C Full
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Configuration code Configuration
PCD-C Precast Concrete Detailing
RCD-C Rebar Detailing
SDE-C Engineering
STD-C Steel Detailing
PPC-C Production Planner for Concrete
STDL-C Primary
VIE-C Project Viewer

Most common keywords

The most common keywords that are used for defining license access rights
and restrictions in the tekla.opt options file are listed and described below:

Keyword Description Usage information
EXCLUDE Prevent access to a Tekla

Structures configuration.
Use with the
abbreviation of the
configuration.

EXCLUDE_ENTITLEMENT Prevent license
borrowing.

Use with the activation
ID of the license.

EXCLUDEALL Prevent access to all
Tekla Structures
configurations.

 

GROUP Define a user group for
use with any options.

Use with Windows user
names (separated with
spaces).

HOST_GROUP Define a host group for
use with any options.

Use with computer
hostnames or IP
addresses (separated
with spaces).

INCLUDE Allow a user to use a
Tekla Structures
configuration.

Use with the
abbreviation of the
configuration.

INCLUDE_ENTITLEMENT Allow a user to borrow a
license.

Use with the activation
ID of the license.

INCLUDEALL Allow a user to use all
Tekla Structures
configurations.

MAX Limit the usage of a
configuration.

Use with the number of
licenses and the
abbreviation of the
configuration.
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Keyword Description Usage information
RESERVE Reserve licenses for a

user/host or a group of
users/hosts.

Use with the number of
licenses and the
abbreviation of the
configuration.

• When somebody is allowed to use a configuration with the INCLUDE
keyword, other users are automatically prevented from using the
configuration.

• When somebody is denied to use a configuration with the EXCLUDE
keyword, other users are automatically allowed to use the configuration.

• If no rules exist, everybody is allowed to use the configuration.

Some examples of definitions in a tekla.opt options file are given below:

Options file definition Description
INCLUDE PCD-C USER
scarlett

Only the user scarlett is allowed to use the
Precast Concrete Detailing configuration.

EXCLUDE FUD-C USER justin The user justin is not allowed to use the
Full configuration. Other users are allowed
to use the Full configuration.

GROUP tsusers jessica joe
neil
INCLUDEALL GROUP tsusers

The users jessica, joe and neil belong to
the group tsusers. Only the group tsusers
is allowed to use all configurations.

EXCLUDEALL HOST pcrobert No configuration is allowed to be used on
the computer pcrobert.

INCLUDE_ENTITLEMENT
qwer-1234-asdf-5678-zx
USER gwen

Only the user gwen is allowed to borrow a
license whose activation ID is qwer-1234-
asdf-5678-zx.

EXCLUDE_ENTITLEMENT
rtyu-9876-fghj-5432-cv
USER matt

The user matt is not allowed to borrow a
license whose activation ID is rtyu-9876-
fghj-5432-cv.

GROUP students amy chloe
andy dean
MAX 3 EDU-C GROUP
students

The users amy, chloe, andy, and dean
belong to the group students. The limit to
the usage of the Educational configuration
for the group students is three licenses.

RESERVE 1 RCD-C USER vera One license of the Rebar Detailing
configuration is reserved for the user vera.

GROUP STUDENTS user1
user2 user3
RESERVE 3 VIE-C GROUP
STUDENTS

The users user1 user2 user3 belong to the
group STUDENTS. 3 licenses of the Project
Viewer configuration are reserved for the
group STUDENTS.

STUDENTS is a group name.
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Options file definition Description
user1 - user 3 are Windows user names
separated with spaces.

The number 3 is the number of licenses to
reserve.

VIE-C is the configuration code for the
Project Viewer configuration.

Note that any licenses reserved for a group
are dedicated to that group. Even when
that group is not actively using the licenses,
the licenses are unavailable to other users.

INCLUDE VIE-
C:VENDOR_STRING=Enterpris
e USER john

Only the user john is allowed to use the
Project Viewer configuration which is of
type Enterprise.

Useful links

For more information about limiting certain Tekla Structures versions to
certain users, see the following Support Article in Tekla User Assistance: How
to limit certain Tekla Structures version to certain users

Move licenses between license servers
You can transfer an on-premises license from one license server to another.
Moving licenses can be necessary, for example, if you are switching to new
hardware or if you want to consolidate licenses from several workstations to a
central server.

The information on this page is not valid for online licenses.

1. Deactivate the licenses that you want to move (page 69) in the Tekla
License Administration Tool on the computer that currently contains the
licenses.

2. If the license entitlement certificate file containing these licenses is not
available on the other computer, find the 
EntitlementCertificate.html file that contains the license and copy
it to the computer on which you want to activate the licenses. 

• Entitlement certificate files are sent over email. In the installation
instructions, we recommend storing the entitlement files in the license
server installation folder (..\Tekla\License\Server\), from where
you can copy it to the same folder on the other computer.
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• Rename the files as necessary to avoid overwriting different
entitlement certificate files with each other.

• There can be several licenses in one file, so you can activate different
licenses on different computers using the same entitlement certificate
file.

3. Activate the licenses (page 64) in the Tekla License Administration Tool on
the other computer to complete the move.

We recommend that you back up the trusted storage (..\ProgramData
\FLEXnet\) in a safe place away from the computer running the license
server. Backups can help you restore your licenses on the same server if active
licenses are accidentally erased.

See also

Installing Tekla license server (page 44)

Repair an on-premises license
If your on-premises licenses have become untrusted or disabled, they cannot
be used and you need to repair them.

The information on this page is not valid for online licenses.

The license trust status is indicated in the Activated Licenses area in Tekla
License Administration Tool. If a trust status symbol is green, the information
is trusted, if red, the information is untrusted.

WARNING Because of technical and security reasons, you can repair an
Activation ID only a limited number of times, which at the
moment is two times a year. Therefore it is important that you
inform your local Tekla Structures representative about the
license repairs you have been performing, and keep count of the
repairs.

The status can be one of the following:

• A red H (Host) indicates whether the server has been moved to another
computer, or whether the computer hardware has changed radically.

The Host trust status of your license is not trusted:
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NOTE Licenses that have the Host trust status untrusted cannot be
repaired.

• A red T (Time) indicates whether the system clock has been tampered with.

The Time trust status of your license is not trusted:

• A red R (Restore) indicates whether the license is obtained from a backup
copy.

The Restore trust status of your license is not trusted:

To repair a license:

1. Go to Tekla Licensing --> Tekla License Administration Tool through
the Start menu or Start screen, depending on your Windows operating
system. 

The Activated Licenses area displays the activated licenses.

2. Click Repair. 

The license server contacts the activation server at Trimble Solutions.
After successful repairing the trust status in Tekla License Administration
Tool dialog box is updated.

For more information about the status of the activated licenses in the trusted
storage, see instructions in the following Support Articles in Tekla User
Assistance:

Checking the status of the activated licenses in the trusted storage

Checking the status of the activated licenses in the trusted storage (including
borrowing info)

Troubleshoot Tekla licensing
Click the links below for help in solving problems encountered in the following
areas:

• View and diagnose errors in Tekla Structures license activation,
deactivation and borrowing (page 81)

• Problems in Tekla license server installation and connecting to the license
server (page 82)

• Problems in FlexNet (page 84)
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• Problems in Tekla license activation (page 85)

• Problems in Tekla license deactivation (page 89)

• Problems in Tekla license borrowing (page 89)

• Problems in Tekla license trusted storage (page 90)

• Problems using LMTOOLS in Tekla licensing (page 91)

• Problems in starting Tekla Structures (page 93)

• Problems with options file tekla.opt (page 95)

For more information about error messages starting with an error code, see
Problems in Tekla licensing: Error codes and their descriptions (page 96).

View and diagnose errors in Tekla Structures license activation,
deactivation and borrowing
Tekla License Administration Tool and Tekla License Borrow Tool both give
error messages when errors occur. The tools automatically create packages of
all necessary files required for diagnosing the errors.

If you have a problem with activating or deactivating licenses, or borrowing or
returning licenses, Tekla License Administration Tool and Tekla License Borrow
Tool display an error message in the Activating Licenses(s), Deactivating
License(s), Borrowing License(s) or Returning Borrowed License(s) dialog
boxes, depending on the subject of the error.

• You can view more detailed information about an error by clicking the
View button in an error dialog box.

• Tekla License Administration Tool and Tekla License Borrow Tool
automatically create zip packages of all necessary files required for
diagnosing the errors in the C:\Tekla\License\Server\Reports folder
and in the %TEMP%\Tekla License Borrow Tool\Reports folder. Click
Browse in the error dialog box to browse for the folder containing the
error report package. You can send the package to your local support to
get help.

The error report package contains the following files:

tekla_debug.log - Tekla license server debug log file

error.txt - error report, contains error information. The Tekla License
Borrow Tool zip package only contains this file.

tekla.opt - access rights options file

tekla.lic - Tekla license file

See also

Troubleshoot Tekla licensing (page 80)

Problems in Tekla licensing: Error codes and their descriptions (page 96)
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Problems in Tekla license server installation and connecting to the
license server

License server installation fails, and the following message is displayed:
"A newer version of this application is already installed on this computer.
If you wish to install this version, please uninstall the newer version first.
Click OK to exit the wizard."

Reason: You have a newer version the license server installed.

Solution: You should not install an old version of the license server. Check the
latest available license server release on the Tekla Downloads product
download page.

The license server version is not dependent on Tekla Structures. However, if
you need to use an older version of the license server for some reason,
uninstall the newer version on your computer before installing the older
version.

License server installation does not finish (no error message)

Reason: Another software using the FlexNet licensing system is running on
the computer.

Solution: Stop all licensing services in LMTOOLS, then install the Tekla license
server and restart the licensing services you stopped earlier:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services is selected, select a license service from the services list, go to
the Start/Stop/Reread tab and click Stop Server.

Do the same for all the services you need to stop.

3. Install the Tekla license server.

4. In LMTOOLS, start the licensing services you stopped earlier.

Problem in license server connection. The following message is displayed:
"Error when connecting to the license server. Contact your system
administrator or try another server".

Reason: This problem is often related to firewall settings.

Solution: Check that your firewall allows the client to contact the license
server.
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License library initialization failed with error: The licensing service is not
installed.

Reason: The error occurs when you are starting Tekla License Administration
Tool, or when you are trying to run serveractutil.exe command line tool.

Solution: If you selected the Manual option for Tekla Licensing Service
installation then you need to manually install FLEXnet licensing service:

1. If you have some other FlexNet licensing service running on the server,
stop it before entering the commands.

2. Go to the Start menu or Start screen, depending on your Windows
operating system, and open Command Prompt as an administrator.

3. At the command prompt, type the following commands:

cd /D full_path_to_installation_directory
For example, if you install Tekla license server to the default folder, you
need to enter cd /D C:\Tekla\License\Server.

installanchorservice.exe

Cannot connect to the license server.

Solution: For the first time that you connect to the Tekla license server a client
computer that has a new version of Tekla Structures installed, you need to do
the following:

• Ensure that both (the client computer and the license server) are in the
same domain.

• Ensure that Local Area Network connection is established. The license
server and the client computers need to be in the same Local Area
Network.

• Turn off the firewall and pause the antispyware/antivirus protection of your
computer.

After the steps above do the following on your company's license server:

1. Make sure that no one is using Tekla Structures (ask all users to close
Tekla Structures).

2. Go to C:\Tekla\License\Server and open the tekla.lic file in a text
editor.

3. Add a free TCP/IP port for the licensing service at the end of the first row,
if it does not exist by default. Note that the automatic installation option
sets the port by default to 27007.

Example of the first row: SERVER MYSERVER ANY 27007, where
MYSERVER is the license server and 27007 is the port.
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4. Save and close the file after changes.

5. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

6. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

7. On the Start/Stop/Reread tab, click Stop Server. Wait couple of seconds
and click on Start Server.

After defining the server and the port, do the following on your Tekla
Structures workstations:

1. Start Tekla Structures.

2. When you are asked for a server, add the port to the front of the server
definition and click OK.

Example: 27007@MYSERVER

Cannot start the Tekla licensing service.

Reason: The tekla-debug.log file may be locked, thus preventing the
service from starting.

Solution: Delete the tekla-debug.log and restart the computer.

See also

Problems in Tekla licensing: Error codes and their descriptions (page 96)

Installing Tekla license server (page 44)

Allowing Tekla license server to operate through Windows Firewall (page 53)

Problems in FlexNet

An internal error occurred. FlexNet internal error.

Reason: There is a problem with the Tekla license server installation.

Solution: This error can often be fixed by performing the steps below:

1. Uninstall all existing Tekla license server installations.

2. Check that all the files are deleted from the Tekla license server
installation folder: .. \Tekla\License\Server.

3. Install the latest Tekla license server. Check for the latest version in Tekla
Downloads.
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See also

Installing Tekla license server (page 44)

Problems in Tekla licensing: Error codes and their descriptions (page 96)

Problems in Tekla license activation

The following message is displayed: "Error reading entitlement file".

Reason: The .NET Framework is not working for some reason.

Solution: Reinstall the existing .NET Framework, or install the latest .NET
Framework version that is available for your operating system.

License activation fails, and the following message is displayed: "Unable
to activate more licenses than you are entitled to".

Reason: There are a couple of possible reasons for the problem:

• You may have activated licenses on another computer. You cannot activate
more licenses than you are entitled to.

• You tried to activate a renewed temporary license or a permanent license
without deactivating the previous temporary license.

Solution: There are two possible solutions:

• Deactivate a license on another computer and then activate the license on
your computer.

• Deactivate the existing temporary license and then activate the succeeding
linked license.

For more information about deactivating licenses, see Deactivate on-premises
licenses (page 69).

The amount of activated licenses in Tekla License Administration Tool
and LMTOOLS does not match.

Manage Tekla Structures licenses 85 Maintain Tekla licenses



Reason: The licensing service is not updated with new license information.

Solution 1: Reread the license file in LMTOOLS:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Start/Stop/Reread tab, click ReRead License File.

Solution 2: If you are connected to several license servers, rereading the
license file may not work. In that case, you need to stop the license server and
then restart it in LMTOOLS:

1. Ensure that no one is using Tekla license server.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

3. On the Start/Stop/Reread tab in LMTOOLS, select the Force Server
Shutdown check box and click Stop Server.

4. Check that the status is "Stopping server". Wait for a few minutes.

5. Click Start Server, and ensure that "Server Start Successful" is displayed.

Manage Tekla Structures licenses 86 Maintain Tekla licenses



TIP To avoid the problem in the future, ensure that the license server is
automatically notified when you activate, deactivate, or repair licenses.

To enable the automatic notification functionality in Tekla License
Administration Tool, click the Notify Server button.

For more information about starting and stopping server and rereading
the license file, see .

For more information about activating licenses, see Activate on-premises
licenses (page 64).

No warning is displayed, even though the temporary license will expire
within one month.

Reason: The expiry warning message appears only when someone uses the
expiring license. Probably there are several permanent licenses (that have
been activated first) and some temporary licenses that have been activated
after the permanent ones.

When somebody starts Tekla Structures, the system uses licenses in the order
of activation. For example, if you have 10 permanent and 2 temporary
licenses, all 10 licenses must be in use before someone obtains the temporary
license, and receives the warning about the expiring license.

When you try to open the entitlement certificate in Tekla License
Administration Tool, nothing is shown.

Reason 1: You have not downloaded the attached entitlement certificate from
your e-mail application, but opened the certificate in an Internet browser and
saved it as an .html file from the browser.

Solution: Open the e-mail containing the entitlement certificate attachment
EntitlementCertificate.html. Download the entitlement certificate to
the ..\Tekla\License\Server folder from e-mail. Then try to open it again
in Tekla License Administration Tool by clicking Open.

For more information, see Activate on-premises licenses (page 64).

Reason 2: The virus protection system of your computer has removed the
Trimble Solutions logo from the license entitlement certificate.

Solution: The sender of the entitlement certificate should zip the entitlement
certificate file. Unzip the entitlement certificate file on the computer where the
licenses are going to be activated.

License was activated successfully, but the following error message is
displayed when you run the command line command ”serveractutil -
view”: "Activation library initialization failed."
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Reason: The license server installation was not successful.

Solution: Do the following:

1. Stop other FlexNet licensing services in LMTOOLS.

2. Run the installanchorservice.exe at the command prompt, restart
the license server.

After doing this you will be able to activate your licenses and use Tekla
Structures.

If the above did not work, you need to uninstall the license server and reinstall
the recent version once again with administrator rights.

For more information about uninstalling and installing the license server, see
and Installing Tekla license server (page 44).

The automatic notification functionality in Tekla License Administration
Tool does not work: nothing happens when you click the Notify Server
button

Reason: One of the reasons why the Notify Server button does not work in
Tekla License Administration Tool might be that Tekla Licensing Service is not
started on the computer.

Solution: To solve the issue, open Windows Control Panel --> Administrative
Tools --> Services . Ensure that the Tekla Licensing Service status is Running .
The Startup Type of the service should be set either to Automatic or to
Automatic (Delayed Start).

Your licenses no longer appear as activated licenses, or old version
licenses are activated, but they do not work.

Reason: Windows system restore may cause problems for licensing. For more
information, see Windows system restore might affect your model and
licensing.

Useful links

For more information about the status of the activated licenses in the trusted
storage, see instructions in the following Support Articles in Tekla User
Assistance:

Checking the status of the activated licenses in the trusted storage

Checking the status of the activated licenses in the trusted storage (including
borrowing info)

See also

Problems in Tekla licensing: Error codes and their descriptions (page 96)
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Problems in Tekla license deactivation

Unable to select a license for deactivation.

Reason: You cannot select a license for deactivation if the license is still
borrowed.

Solution: Return the license and then deactivate the license.

See also

Problems in Tekla licensing: Error codes and their descriptions (page 96)

Deactivate on-premises licenses (page 69)

Problems in Tekla license borrowing

Unable to select a date from the calendar in the Borrow Until box.

Reason: The maximum borrowing period is one month.

Solution: In Tekla License Borrow Tool, select a date that is within one month
from the date of borrowing:

1. Go to Tekla License Borrow --> Tekla License Borrow Tool through the
Start menu or Start screen, depending on your Windows operating
system.

2. In the Products area, click the Borrow Until box and select from the
calendar the expiration date that is within one month from the date of
borrowing.

Tekla Structures does not start up with the borrowed license.

Problem: You borrowed a license and disconnected from the network. When
you open Tekla Structures, the licensing dialog box is displayed, but Tekla
Structures does not find the borrowed license.

Solution: If Tekla Structures does not start up with the borrowed license,
please type only an asterisk character (*) into the server box in the licensing
dialog box.

This will force Tekla Structures to search for all possible locations for the
license. It might take some time until it finds the license.
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The computer that is running a borrowed license crashed, what should I
do?

Solution: If your computer only needs rebooting, you can use the borrowed
license again after rebooting. If your computer completely breaks down, the
license will automatically be available on the license server when the
borrowing period expires.

See also

Problems in Tekla licensing: Error codes and their descriptions (page 96)

Set up on-premises license borrowing for offline use (page 103)

Problems in Tekla license trusted storage

A license cannot be used.

Reason: The Host (H) trust status of your license is not trusted. Hardware
setup of your server computer has changed radically.

Solution: The licenses with the untrusted H trust status cannot be repaired.
Contact your local support.

We recommend that you run your license server on a proper server computer
that is regularly maintained. You need to deactivate your licenses before
performing any maintenance actions on your server computer. However,
unnecessary deactivations should be avoided due to technical and security
reasons.

For more information, see Repair an on-premises license (page 79).

A license cannot be used.

Reason: The Time (T) trust status of your license is not trusted. Time settings
of your server computer have changed radically.

Solution: You need to set the correct system date and time and after that
repair the license in Tekla License Administration Tool.

Do not manipulate system clock settings of the server computer that has
activated licenses.

For more information, see Repair an on-premises license (page 79).
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A license cannot be used.

Reason: The Restore (R) trust status of your license is not trusted. Your
backup system may have overwritten some licensing information.

Solution: You need to repair the license in Tekla License Administration Tool.

We recommend that you configure your system backup settings so that the
existing licensing software, tools and files are not automatically overwritten or
replaced with the restored ones.

For more information, see Repair an on-premises license (page 79).

See also

Problems in Tekla licensing: Error codes and their descriptions (page 96)

Repair an on-premises license (page 79)

Problems using LMTOOLS in Tekla licensing

LMTOOLS does not reread the license file.

Reason: Rereading the license file does not work if you are running a licensing
service locally on your computer and you are connected to another license
server at the same time.

Solution: You need to stop and restart the licensing service. Do the following:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

3. On the Start/Stop/Reread tab, click Stop Server and wait a few seconds
for the service to stop.

4. Click Start Server.

LMTOOLS is unable to stop the license server, and the message "Unable
to Stop Server" is displayed in the LMTOOLS message bar.

Reason: You may have selected an incorrect licensing service.

Solution: You need to select Tekla Licensing Service as the licensing service.
Do the following:
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1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

3. Go to the Start/Stop/Reread tab, and click Stop Server.

4. If this does not help, select the Force Server Shutdown check box and
click Stop Server again.

LMTOOLS is unable to stop the license server.

Reason: You did not run LMTOOLS with administrator rights.

Solution: Run LMTOOLS with administrator rights. For more information, see
Rights needed for administrator tasks in on-premises licensing (page 37).

Starting or stopping the server or rereading the license file cannot be
performed, and the message "No Server Selected" is displayed.

Reason: You have not selected the licensing service.

Solution: You need to select Tekla Licensing Service as the licensing service.
Do the following:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

3. Go to the Start/Stop/Reread tab and start or stop the server or reread
the license file.

Starting or stopping the server or rereading the license file is not
possible.

The status list in LMTOOLS indicates that the license server manager (lmgrd)
has not been started: "Error getting status: Cannot connect to license server
system. The license server manager (lmgrd) has not been started yet, the
wrong port@hostname or license file is being used, or the port or hostname in
the license file has been changed".

Reason: LMTOOLS points to the wrong lmgrd.exe.

Solution: You need to modify the settings in LMTOOLS. Do the following:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.
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3. Go to the Config Services tab, and click Browse to locate the lmgrd.exe
file.

By default, the file is installed in the ..\Tekla\License\Server folder.

4. Click Save Service.

5. Go to the Start/Stop/Reread tab and click Stop Server.

6. Click Start Server to restart the server.

The changes are applied.

LMTOOLS does not show the licensing service status.

The status list on the Server status tab in LMTOOLS indicates that the license
file cannot be found: "Error getting status: Cannot find license file. The license
files (or license server system network addresses) attempted are listed below.
Use LM_LICENSE_FILE to use a different license file, or contact your software
provider for a license file".

Reason: You are trying to perform a status enquiry of a licensing service that
is not running.

Solution: You need to start Tekla Licensing Service. Do the following:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

3. Go to the Start/Stop/Reread tab and click Start Server.

4. Go to the Server Status tab and click Perform Status Enquiry again.

See also

Install Tekla license server - manual installation (page 47)

Configure Tekla license server manually (page 51)

Problems in Tekla licensing: Error codes and their descriptions (page 96)

Problems in starting Tekla Structures

Tekla Structures does not start. The following message is displayed:
"Error when connecting to the license server. Contact your system
administrator or try another server".

Reason: You are not connected to the license server.

Solution: Check the following:

• Check that your network connection is working.
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• Check that you have entered the license server name correctly.

For more information, see Preconfigure license server settings for users
(page 68).

• Check that license information in LMTOOLS is correct. If not, reread the
license file in LMTOOLS and try to start Tekla Structures again.

For more information about LMTOOLS, see .

Tekla Structures does not start. The following message is displayed:
"License server system does not support this feature".

Reason: Your license server may not be up to date.

Solution: Update the status of your license server. Do the following:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system. Start LMTOOLS
using administrator rights.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

3. On the Start/Stop/Reread tab, click Stop Server and wait a couple of
seconds.

4. Click Start Server.

5. Start Tekla Structures.

If the problem still persists, contact your local Tekla Structures support. The
support will need a copy of the following files: tekla.lic, tekla.opt, and
tekla_debug.log files.

Tekla Structures does not start occasionally.

The following message is displayed: "Cannot connect to license server system.
The license server manager (lmgrd) has not been started, the wrong
port@host or license file is being used, or the port and hostname in the license
file has been changed".

Reason: There may be communication problems between your license server
and Tekla Structures client computers if the port of the license server is not
defined.

Solution: Define the port for the license server. Do the following:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.
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3. On the license server computer, define a free port for the license server in
the tekla.lic file. For more information, see Modify the license file
tekla.lic manually (page 50).

4. Go to the Start/Stop/Reread tab and stop the license server by clicking
Stop Server.

5. Click Start Server.

6. Start Tekla Structures on a client computer.

7. In Tekla Structures, click Tools --> Change License Server . Define the
port and hostname of the license server.

8. Close Tekla Structures.

9. Repeat steps 5 to 7 on all Tekla Structures client computers.

See also

Preconfigure license server settings for users (page 68)

Problems in Tekla licensing: Error codes and their descriptions (page 96)

Problems with options file tekla.opt

The tekla.opt file does not take effect.

Reason: The licensing service has not read the options file.

Solution: Do the following:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

3. On the Start/Stop/Reread tab, click ReRead License File.

4. Browse to the ..\Tekla\License\Server folder and open the
tekla_debug.log file and the tekla.opt file with a text editor.

5. Check that the tekla_debug.log file contains the same keyword strings
as the tekla.opt file.

If this does not help, please contact your local support.
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See also

Modify on-premises license access rights (tekla.opt) (page 73)

Problems in Tekla licensing: Error codes and their descriptions (page 96)

Problems in Tekla licensing: Error codes and their descriptions

Error 6

Problem: License library initialization failed with error: Activation Library
Initialization error #6. Please, contact software vendor to resolve the
problem.

Reason: Tekla license server installation folder contains .dll files that are
from the previous Tekla license server version.

Solution: To resolve the problem, do the following:

1. Close Tekla License Administration Tool and stop the Tekla license server
in LMTOOLS by clicking Stop Server on the Start/Stop/Reread tab.

2. Uninstall all existing Tekla license server installations.

3. If the Tekla license server installation folder contains any .dll files,
remove the files manually.

4. Now you can install Tekla license server to the same folder where the
uninstalled version was.
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For more information about license server installation, see Installing Tekla
license server (page 44).

NOTE Deactivation is not needed in this case. Licenses are kept safe in a
specific Flexera Software location outside Tekla license server
installation directory.

Error 20

Problem: Error 20: The licensing service is not installed.

Reason: The error occurs when you are starting Tekla License Administration
Tool, or when you are trying to run serveractutil.exe command line tool.

Solution: If you selected the Manual option for Tekla Licensing Service
installation then you need to manually install FLEXnet licensing service:

1. If you have some other FlexNet licensing service running on the server,
stop it before entering the commands.

2. Go to the Start menu or Start screen, depending on your Windows
operating system, and open Command Prompt as an administrator.

3. At the command prompt, type the following commands:

cd /D full_path_to_installation_directory
For example, if you install Tekla license server to the default folder, you
need to enter cd /D C:\Tekla\License\Server.

installanchorservice.exe

Error 109

Problem: There are no activated licenses to return. Another program
may have modified the activated licenses rights concurrently. (109)
Unable to return as there is no licenses in Trusted Storage.

Reason: The trusted storage has been modified, probably by some other
program.

 The red Restore (R) trust status of your license is not trusted. The
license is broken, therefore it cannot be returned.

Solution: The license will become available on the server machine
automatically when the borrow period ends.

Error 123 or error 50030

Problem: Message 1: Row n: An error occurred but FLEXnet Licensing did
not return an error number. (123)

Message 2: Failed to load trusted storage or specified ASR. (50030)
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Reason: These error messages indicate that the trusted storage cannot be
loaded, and your trusted storage is corrupted.

Solution: Your licenses need to be replaced. Contact your local Tekla
representative for a replacement along with some instructions.

Error 1316

Problem: License server installation fails.

The following message is displayed: "A network error occurred while
attempting to read from the file C:\Documents and Settings\<user>
\Local Settings\Application Data\Downloaded Installations
\...\Tekla Structures License Server v1.01.msi".

Reason: You have an older version of the license server installed.

Solution: Uninstall the old version and then install the new version of the
license server.

For more information about uninstalling the server, see .

Error 7174

License activation fails, and the following message is displayed:
"Unspecified FLEXnet Error with code 7174 Only deployed entitlement
line item can be fulfilled."

Reason: You are trying to activate an obsolete license.

Solution: You should have received a new entitlement certificate from your
local Tekla representative. Try the activation again with the new entitlement
certificate, and move the old obsolete entitlement certificate in an archive
folder.

For more information, see Activate on-premises licenses (page 64).

Error 7284

Problem: Unspecified FLEXnet Error with code 7284. Cannot perform
support actions on inactive fulfillment record
FID_xxxxxxxx_xxxxxxxxxxx__xxxx.

Reason: Trusted Storage has been restored from an old backup copy. The
license with fulfillment ID FID_ xxxxxxxx_xxxxxxxxxxx__xxxx has been
deactivated already.

Solution: You need to restore trusted storage files from the most recent
backup copy and then repair licenses if needed.

For more information about repairing licenses, see Repair an on-premises
license (page 79).

Error 7288 and error 111

Message 1: The activation of the fulfillment is denied by the activation
policy because fulfill count exceeded the available seat count.
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Message 2: The activation of the fulfillment is denied by the activation
policy because number of copies left is zero.

Reason 1: You may be trying to activate some licenses that have been
activated before on another server/computer.

Solution: Deactivate the licenses from the other computer, and then activate
the licenses on the new server/computer.

Reason 2: You may be trying to activate a renewed temporary license or
permanent licenses without deactivating the previous linked activated
licenses.

Solution: Deactivate the existing temporary licenses first and then activate the
succeeding linked licenses.

For more information about deactivating licenses, see Deactivate on-premises
licenses (page 69).

Error 7343

Problem: Unspecified FLEXnet Error with code 7343 Entitlement line item
has expired on <date> <time>.

Reason: License has expired. It is not possible to activate or repair expired
licenses.

Error 7466

Problem: License deactivation fails, and the following message is
displayed: "The return of the fulfillment is denied by the return policy
because max return exceeded".

Reason: You have deactivated the license too many times in a 30 days period.

Solution: You can deactivate the license again when 30 days have passed
since the first deactivation of the license in the past 30 days. The number of
deactivations of a license within a given time period is limited due to technical
and security reasons.

Error 7581

Problem: Unspecified FLEXnet Error with code 7581. Online Return/Repair
Request for the activationId XXXX-XXXX-XXXX-XXXX-XXXX-XX is not
originated from the original client machine.

Reason and solution: The computer is not the same where the licenses were
originally activated, and you need to return/repair licenses from the original
computer. Another reason might be that the computer has changed so much
that activation server at Trimble Solutions no longer recognizes it as the same
one, in which case you need to replace your licenses.

For more information about returning and repairing licenses, see Returning a
borrowed license (page 108) and Repair an on-premises license (page 79).
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Error 9999

Problem, reason and solution:: Licensing server at Trimble Solutions is
down. Wait for a while and retry.

Error 50005

Problem: Error (5005) License Activation failed - Initialization of API
Failed.

Problem: The activated licenses are not visible and it is not possible to activate
new licenses.

Reason: The installation package has failed to initialize or register some of the
software components.

Solution: Do the following:

1. Log in with administrator's rights.

2. Close Tekla License Administration Tool.

3. Stop Tekla license server and other license servers on the same computer
on the LMTOOLS --> Start/Stop/Reread tab.

4. Go to ..\Tekla\License\Server folder.

5. Double-click installanchorservice.exe.

6. Start Tekla license server and other license servers on the same computer
on the LMTOOLS --> Start/Stop/Reread tab.

7. Open Tekla License Administration Tool. The message should not be
displayed anymore.

Error 50018

Problem: License borrowing fails.

Reason: Wrong product ID file is used.

Solution: Do one of the following:

• Export a product ID file in Tekla License Administration Tool and use the
file for borrowing.

Error 50033

Problem: License borrowing fails.

Reason 1: Your license server may not have up-to-date license information.

Solution: In LMTOOLS, stop and then restart the server.

Reason 2: The INCLUDE keyword in the options file prevents the borrowing of
the configuration.

Solution: You need to add a dummy user "ACTIVATED LICENSE(S)" into the
group of the included users to enable the borrowing. Do the following:

1. Open tekla.opt using a text editor.
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2. Add "ACTIVATED LICENSE(S)" in the group of the included users, for
example:

GROUP steel "ACTIVATED LICENSE(S)" user1 user2 user3
user4
INCLUDE STD-C GROUP steel

3. Save the changes you made in tekla.opt.

4. In LMTOOLS, reread the license file or stop the server and then start the
server.

Error 50035

Problem: License borrowing fails.

Reason: The user tried to borrow a license that is not activated on the license
server. For example, the user tried to borrow a version 20 license and there
are only version 21 licenses activated on the server.

Solution: Do the following:

• Check that the product ID file is up to date. If not, export a new product ID
file in Tekla License Administration Tool ( File --> Export ) and send this file
to the user for borrowing. Then ask the user to save the new product ID
file, open the Tekla License Borrow Tool, click Open and browse for the
new .tpi file and try borrowing again.

• Check that your license information is up to date in LMTOOLS. If not,
reread the license file.

Error 50036

Problem: License borrowing fails.

Reason: You are not allowed to borrow the license.

Solution: Do one of the following:

• The options file (tekla.opt) needs to be modified so that the borrowing
of the license is allowed. For more information, see Modify on-premises
license access rights (tekla.opt) (page 73).

• Borrow another license.

Error 50037

Problem: License returning fails.

Reason: You tried to return the license to a different license server than it was
borrowed from.

Solution: You need to return the license to the same license server that it was
borrowed from. Do the following:

1. Go to Tekla License Borrow --> Tekla License Borrow Tool through the
Start menu or Start screen, depending on your Windows operating
system.
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2. Click Setup and enter the name of the license server where you originally
borrowed the license from and click OK.

3. Select the Return check box in the Borrowed Licenses area to select the
license for returning.

4. Click the Return button to return the license.

After successful returning of licenses, the Borrowed Licenses area is
updated.

Error 50040 or error 50041

Error 50040 or error 50041, problem 1: License activation, deactivation or
repairing fails

Reason: Your license server was not able to connect to activation server at
Trimble Solutions correctly. Usually this is a temporary problem in online
activation.

Solution: Do the following:

• Check that your Internet connection is working. An Internet connection is
needed during license activation and deactivation. A low connection speed
may also cause errors.

• Close Tekla License Administration Tool and try to activate the license a
while later.

• Try to activate another license.

• Your firewall may block the activation communication. Check your firewall
settings. For more information, see Allowing Tekla license server to operate
through Windows Firewall (page 53).

• Check that you have the latest Tekla license server version.

• This error could be caused by unfinalized Windows updates on the server
computer. Reboot the server and try again.

• Your Windows login user name may contain special characters. Try to log in
with another user name, for example, administrator.

• Check that your Internet connection is working.

• Contact your local Tekla Structures support and ask for a manual
activation.

Error 50040 or error 50041, problem 2: License borrowing fails.

Reason: You are not connected to the license server.

Solution: Do the following:

• Check that your network connection is working.

• Start Tekla License Borrow Tool and check that you have entered the
correct license server information.
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See also

View and diagnose errors in Tekla Structures license activation, deactivation
and borrowing (page 81)

Problems in Tekla license activation (page 85)

Problems in Tekla license borrowing (page 89)

Problems in Tekla license deactivation (page 89)

3.8 Set up on-premises license borrowing for offline use
Users who want to work in a location that does not have a reliable connection
to the on-premises license server can borrow an activated license from the
Tekla license server before leaving the office. The user receives a temporary
local license file valid for a set time period.

The information on this page is not valid for online licenses.

Users can borrow Tekla Structures on-premises licenses for offline use in Tekla
License Borrow Tool. Users need to have a network connection to the license
server to borrow and return a license.

Borrowed licenses are reserved for the duration of the borrowing even when
they are not in use, so the borrowed license is not available for other users.

Configuration files

A product ID (.tpi) file is needed for borrowing licenses. If you use the
licensing options file (tekla.opt) for managing license access rights, you
must always provide a customized product ID file for users. The default file
that lists all configurations will technically work in other cases, but
administrators should still provide a customized product ID file. The
customized file makes it easier for the users to select a license, because it
includes just those licenses that you have actually activated on the server. For
more information, see Provide offline users with a customized product ID file
(page 104).

You can define which licenses are available for which users in the licensing
options file (tekla.opt) on the license server. For more information, see
Modify on-premises license access rights (tekla.opt) (page 73).

How on-premises license borrowing works

License borrowing reserves and releases the on-premises licenses like this:

• The maximum license borrow period is one month. The user defines the
borrow expiration date when borrowing the license. The borrowed licenses
are unavailable to other users until they are returned or the license borrow
period ends.

• The user can return a license before the license borrow period is over
through the license borrow tool on the borrowing computer. Make sure
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your users return all borrowed licenses before a major operating system
upgrade, reinstallation or major hardware changes on their computer.

• Borrowed licenses must be returned before you deactivate those licenses
on the license server, for example, to upgrade the licenses to a new version
or to move the license server to new hardware. You can see who has
borrowed which licenses by enquiring the license status in the LMTOOLS
application on the license server.

NOTE If you do not follow the guidelines above, all users may lose the use of
the borrowed licenses until the end of the license borrowing period,
including the users who originally borrowed the licenses.

1. Install the Tekla License Borrow Tool on the users' computers with
customized product ID file(s).

2. To borrow a license, users must open the Tekla License Borrow Tool
installed on their computer when they are still online and can connect to
the Tekla license server.

The version of Tekla License Borrow Tool should be the same as the
version of Tekla license server.

3. After borrowing a license, users can go offline and freely work with, close
and reopen Tekla Structures within the license borrow period.

4. When the users are back online, they should return the borrowed licenses
to the license server.

If a user does not return the license, it becomes available for other users
on the license server after the license borrow time is over. However, the
license is still listed in the license borrow tool for the user until the user
returns it.

For detailed instructions, see Set up Tekla License Borrow Tool for Tekla
Structures offline use (page 105).

For end-user instructions, see Borrow a license from on-premises license
server (page 107) and Return a borrowed on-premises license (page 108).

See also

Problems in Tekla license borrowing (page 89)

Problems in Tekla licensing: Error codes and their descriptions (page 96)

Provide offline users with a customized product ID file
Tekla License Borrow Tool for on-premises licenses needs the activation IDs of
the licenses during borrowing. When you export a product ID file (.tpi) in
Tekla License Administration Tool, the activation IDs of the activated licenses
are written in the file. Then you can send the file to offline users.
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The information on this page is not valid for online licenses.

When you install Tekla License Borrow Tool, the standard.tpi file is
automatically installed in the ..\Tekla\License\Borrow folder. This default
product ID file lists all Tekla Structures configurations and their product IDs.
However, users can only borrow the licenses that are activated on the license
server.

You can create a customized product ID file that only lists the activation IDs of
the activated licenses available for borrowing. You need to export the product
ID file on the license server computer using Tekla License Administration Tool
and save the file on the computers of the users who borrow licenses. The
activation IDs are encrypted.

WARNING Product ID files are not updated automatically. If you deactivate
borrowable licenses or activate new licenses for borrowing, you
need to export a new product ID file and send it to Tekla
Structures offline users who borrow licenses.

To export the product ID file on the Tekla license server computer:

1. Go to Tekla Licensing --> Tekla License Administration Tool through
the Start menu or Start screen, depending on your Windows operating
system.

2. Click Export.

3. In the Save Product ID file As dialog box, enter the name of the product
ID file or keep the default file name, select a folder where you want to
save the file and click Save.

4. Send the product ID file to the Tekla Structures users who need to borrow
licenses and inform the users about the usage of the file. 

If the name of the file is standard.tpi and the file is saved in
the ..\Tekla\License\Borrow folder on the user’s computer, the file is
opened automatically when the user starts Tekla License Borrow Tool.

See also

Set up Tekla License Borrow Tool for Tekla Structures offline use (page 105)

Set up Tekla License Borrow Tool for Tekla Structures
offline use
You can use Tekla Structures on-premises licenses offline or off-site by
borrowing Tekla licenses with Tekla License Borrow Tool.

The information on this page is not valid for online licenses.

For information on using online licenses offline, see .
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Before you start, download and install the latest Tekla License Borrow Tool
from the Tekla Downloads product download page.

You can use the same Tekla License Borrow Tool for borrowing licenses for
different Tekla Structures versions. The version of Tekla License Borrow Tool
should be the same as the version of Tekla license server.

To set up Tekla License Borrow Tool for Tekla Structures offline use:

1. Go to Tekla License Borrow --> Tekla License Borrow Tool through the
Start menu or Start screen, depending on your Windows operating
system.

2. In the Setup dialog box, enter the port number and the hostname
(computer name) of the license server in the Server box in the format 
port@hostname, for example, 27007@server_hostname.

3. Still in the Setup dialog box, click Browse and select the product ID file.

4. Click OK. 

The Products area in the Tekla License Borrow Tool is updated.

5. In the Tekla License Borrow Tool dialog box, click Language and change
the language of the Tekla License Borrow Tool user interface, if necessary.

NOTE When you start Tekla Structures, and if Tekla Structures does not start with
the borrowed license, enter an asterisk (*) in the server box of the licensing
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dialog box. This will force Tekla Structures to search for all possible locations
for the license. This may take a while.

See also

Problems in Tekla license borrowing (page 89)

Borrow a license from on-premises license server
In Tekla License Borrow Tool, you can borrow Tekla Structures on-premises
licenses from Tekla license server when you want to work offline. Borrow the
license on the same computer that you will use for offline work.

The information on this page is not valid for online licenses.

For information on using online licenses offline, see .

Before you can borrow an on-premises license, you need to install Tekla
License Borrow Tool, connect the computer with Tekla Structures to the
license server and open the product ID file.

For more information about the prerequisites, see Set up Tekla License
Borrow Tool for Tekla Structures offline use (page 105).

To borrow a license:

1. Close Tekla Structures.

2. Go to Tekla License Borrow --> Tekla License Borrow Tool through the
Start menu or Start screen, depending on your Windows operating
system.

3. Click the Setup button at the top of the dialog box.

4. In the Setup dialog box, enter the port number and the hostname
(computer name) of the license server in the Server box in the format 
port@hostname, for example, 27007@server_hostname. 

You need to use exactly the same port and host name as when starting
Tekla Structures.

5. Still in the Setup dialog box, click Browse and select the product ID file.

6. Click OK.

7. In the Products area, click the Borrow Until box and select the expiration
date for the borrowing period from the calendar. 
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The maximum borrowing period is one month. The exact maximum
borrow period varies between 29 to 32 days depending on the borrowing
date.

8. Click the Borrow button to borrow the license. 

The borrowing progress is displayed in the Borrowing License(s) dialog
box. After successful borrowing, the Borrowed Licenses area shows the
borrowed license.

9. To ensure that the borrowing succeeded, disconnect your computer from
the license server and start Tekla Structures with the borrowed license.

See also

Problems in Tekla license borrowing (page 89)

Problems in Tekla licensing: Error codes and their descriptions (page 96)

View and diagnose errors in Tekla Structures license activation, deactivation
and borrowing (page 81)

Set up on-premises license borrowing for offline use (page 103)

Return a borrowed on-premises license
You can return a borrowed Tekla Structures on-premises license back to the
Tekla license server before the expiration date.

The information on this page is not valid for online licenses.

A borrowed license is automatically available on the license server on the day
following the expiration date.

However, the Borrowed Licenses area in Tekla License Borrow Tool is not
automatically updated. The license should be returned to the server that has
the same name as the name of the server from which the license was
borrowed. We recommend that you always return the expired licenses when
you want to stop borrowing a license.

To return a borrowed Tekla license:

1. Ensure that you are connected to the license server.

2. Close Tekla Structures.
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3. Go to Tekla License Borrow --> Tekla License Borrow Tool through the
Start menu or Start screen, depending on your Windows operating
system.

4. Select the Return check box in the Borrowed Licenses area to select the
license for returning.

5. Click the Return button to return the license. 

After successful returning of licenses, the Borrowed Licenses area is
updated.

See also

Problems in Tekla licensing: Error codes and their descriptions (page 96)
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4 Implementation guide for
administrators

Tekla Structures administrator is the person responsible for ensuring that the
company standards are used and set up in Tekla Structures. The following
sections explain how you can customize Tekla Structures.

4.1 Customizing Tekla Structures
Each new version of Tekla Structures introduces new features and
functionalities to improve the overall process used for completing a project.
Tekla Structures has multiple environments to suit the needs and
requirements of specific markets. Many features are localized in each Tekla
Structures version. Most of the changes in versions are focused on making the
default saved attributes more consistent, organized, simplified, and practical.

Your local technical team is dedicated to improving your knowledge and
experience of each new version. The team aims at enhancing your user
experience of Tekla Structures by performing tasks that have been identified
as essential by the existing users, new users, and potential users.

Before you start customizing Tekla Structures to suit the needs of your
company and your projects, collect the needed information, such as drawing
standards, used profiles, grades and materials, company logos, and naming
conventions.

The overall localization of Tekla Structures can be divided into four different
layers:

• Tekla Structures environment

• Company-level settings

• Project-level settings

• Multi-user settings

The three last ones are mainly managed by company administrators.

Implementation guide for administrators 110 Customizing Tekla Structures



Setting up the standard that a company uses, and the standards that a specific
project needs will make the designing process much more efficient because
the end user can concentrate on the design process.

Tekla Warehouse

Tekla Warehouse has a lot of additional content, such as application tools and
environment content. You can download Tekla Warehouse offline content that
includes the catalog content of environments, such as profiles, bolts,
materials, and reinforcement.

The offline catalog content is under Tekla Structures collections in Tekla
Warehouse. The content is in .tsep packages that are installed when opening
Tekla Structures.

You can also create a local collection for your company, and share it for your
organization in your internal network. You can manage the access rights on
the folder and collection level in the collections.json file on each user's
computer. Copy the file to the same location on each user's computer. The file
is located in C:\Users\Public\Public Documents\Trimble\Tekla
Warehouse\collections.json.

The image below shows an example of the collection paths with four Tekla
Structures collections:

In Tekla Warehouse the collections are found after mapping under My
collections --> Local and network collections .
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4.2 Overview of environments, roles and licenses
Tekla Structures is one product that has many different configurations. The
licenses you have determine which configurations you can use.

A Tekla Structures environment is set up for the materials, grades, profiles,
drawing settings, component settings, .ini file settings that are used in a
specific market. There are over 30 different environments in Tekla Structures.
By choosing a specific environment when starting Tekla Structures you will get
the settings for that market. You can install several environments, and add
missing environments later.

The blank project listed in the environments is an empty platform for your
own environment or project settings. It includes standard parametric profiles,
undefined bolt, material and rebar grades, basic drawing layouts and so on,
which you can complement from your own firm or project folders and Tekla
Warehouse.

Some environments give you the opportunity to select a role when logging in.
The role is independent from the licenses that are used. The purpose of the
roles is to make the user interface and settings clearer, easier and faster for
the user's tasks.

In practice, this means that settings, filters, reports and the user interface is
set up for the role the user has. For example, preloaded settings in object
properties that are not relevant for the role are not shown, making the list of
options shorter and clearer.

Role selection is primarily meant to be configured by Trimble and reseller
localization personnel, and be part of the Tekla Structures installation package.
However, advanced users and Tekla Structures system administrators can also
create their own roles inside their company organization. Additional content is
available in the Tekla Warehouse offline and online collections. Note that you
need to have a Trimble Identity for downloading or installing from the online
collections. For more information, see Trimble Identity for Tekla Online
services.
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Using roles for ribbon selection with the subscription license
configurations

Note that the ribbon selection with the subscription license configurations is
primarily meant to be configured by Trimble and reseller localization
personnel.

With the subscription licenses, roles can be used for controlling which ribbon
is shown for a certain role. The role-specific .ini files in the environments
(page 274), for example, role_Steel_Detailer.ini or
role_Rebar_Detailer.ini, contain advanced options 
XS_RIBBON_CONFIGURATION_DIAMOND, 
XS_RIBBON_CONFIGURATION_GRAPHITE, and 
XS_RIBBON_CONFIGURATION_CARBON. The advanced options define the
ribbons for the specific role.

The advanced options need to point the configuration identifiers (page 132) of
the ribbon files, either to the configuration identifiers of the legacy on-
premises license configurations, or to the configuration identifiers of the
online license configurations. It is not possible to make up new configuration
identifiers.

If the advanced options are not set, Tekla Structures uses the default ribbons
for each subscription license configuration.

Example:

For the users who select the Precast Concrete Detailing role, you could have
the following settings in the role_Precast_Detailer.ini file:

set XS_RIBBON_CONFIGURATION_CARBON=albl_up_Carbon
set XS_RIBBON_CONFIGURATION_GRAPHITE=albl_up_PC_Detailing
set XS_RIBBON_CONFIGURATION_DIAMOND=albl_up_PC_Detailing

For more examples, see your role_<role>.ini files used in your
environment.

TIP Administrators who have own environment and roles in use: for the own
role, such as, for timber detailer, you can create a folder for the ribbon
files in ..\<environment>\Timber\Detailing\Ribbons, for
example. Place the customized ribbon files in the folder, and include the
folder in the XS_SYSTEM path definition for that specific role.

4.3 Folder structure
Tekla Structures software and environments are separated into different
locations due to the requirements for Windows certification. By default, the
files are installed in the following folders:

• Software is installed under the \Program Files\Tekla Structures
folder.
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• Environments and extensions are installed under the \ProgramData
\Trimble\Tekla Structures folder.

• User settings are installed under the \Users\<username>\AppData
\Local\Trimble\Tekla Structures folder.

4.4 Project and firm folders
Project and firm folders are meant for storing the customized files. For any
company, we strongly recommend setting up firm and/or project folders on a
shared file server accessible to all users. If multiple teams on different sites
are working on the same project, you can set up a project or firm folder in a
folder in a .

Having the hierarchy of project and firm folders will make it much easier to
update company settings, ensure that everyone uses the same settings in a
project, and upgrade to a newer version of Tekla Structures.

All the settings that are used on the company level (for example, company
logo and drawing standards) should be stored in a firm folder, and all the
settings used on a specific project should be stored in the corresponding
project folder. Property files are always saved in the \attributes folder
under the current model folder, like, \TeklaStructuresModels
\<my_building>\attributes. These files should then be copied to the
project or firm folder, or to user-defined sub-folders under the project or firm
folder.

To use the saved settings in a firm and a project folder, set the path to the
folder by using the XS_PROJECT and XS_FIRM advanced options. These
advanced options should be put in the initialization, .ini, files. You can have
several different .ini files. You can define in the Tekla Structures shortcut
which .ini files to run and which settings to apply.

One of the most important advantages of using firm and project folders is that
Tekla Structures does not replace files in the project and firm folders when
you install a new version. This means that you retain your customized files
without having to cut and paste, or export and import from previous versions.
This makes upgrading to a newer version of Tekla Structures easier. When you
store files in one place, it is also easier to update the settings and ensure that
everyone in a project uses the same settings.

Example:
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In the current project, 123_project_ABC, you have set up the properties for the
concrete column, and saved them as column_ABC. To make these saved
settings available for everyone working in the 123_project_ABC project, copy
column_ABC.ccl from the \attributes folder under the model folder to
the \123_project_ABC project folder or on your file server, or to a user-
defined sub-folder under the \123_project_ABC project folder. Ensure that
everyone in the project has the correct path for the XS_PROJECT advanced
option in the .ini file.

For more information, see Create project and firm folders (page 263) and Files
and folders in Tekla Structures (page 262).

4.5 Folder search order
When you open a model, Tekla Structures searches for the associated files in
specific folders in a set order. It is important that you place the files in the
correct folders. Once Tekla Structures finds the associated files, it stops
searching. This means that the files that have the same name but are located
lower down the search order are ignored.

The basic folder search order is the following:

Folder Defined by
Model folder Currently open model
Project XS_PROJECT
Firm XS_FIRM
System XS_SYSTEM

You can specify more than one system folder, and this way define specific
settings for each role. Use the role options defined in the
env_<environment>.ini to point to the roles when specifying the system
folders in the XS_SYSTEM advanced option. Enter the options pointing to the
roles and separate them by semicolons, for example: set XS_SYSTEM=
%XS_STEEL%;%XS_ENGINEERING%;%XS_CONTRACTOR%;%XS_GENERAL
%;%XSDATADIR%\environments\common\system\
There are some exceptions to this search order. The exceptions are listed in
Folder search order (page 358).

NOTE Do not store customized files in the system folder. Tekla Structures replaces
these files when you install a new version.
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4.6 Initialization files
Initialization files (page 268) (.ini) are used for launching Tekla Structures.
They can contain many advanced options that you can use to configure Tekla
Structures for different standards and your own style of working. Tekla
Structures automatically creates the necessary .ini files during installation.
The number of .ini files it creates depends on how many country-specific
environments you choose to install.

Why are .ini files needed?

There are numerous settings to be made when Tekla Structures starts.
Advanced options are used to determine the appearance and the behavior of
Tekla Structures, for example, the language used, behavior of part marks on
drawings, and the location of your model folder. Advanced options are set
through the .ini files. The different .ini files and what they do, and how
they are related to each other are described below.

Different types of .ini files

The default reading order (page 269) of the .ini files is as shown in the image
below:

1. teklastructures.ini
Initializes the settings needed for Tekla Structures to run.

The teklastructures.ini file in the \bin folder starts Tekla
Structures. We recommend that you do not make any changes to this file.
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2. env_global_default.ini
Sets the global default settings.

The env_<your_environment>.ini file is located in the
\Environments subfolder and it contains all the environment-specific
settings. These files are set by your area office or reseller.

3. environment.ini
Sets the environment-specific settings.

You can define specific settings for roles in your environment and store
these settings in role-specific folders. Organizing the folder structure
based on roles is useful for keeping the role content up to date. Note that
the folder structure and content may vary depending on the environment.

In the env_<environment>.ini file, each role has an option where you
can add the paths that point to the folders in which you have stored the
role settings. For example, XS_STEEL (\Steel), XS_CONCRETE
(\Concrete), XS_ENGINEERING (\Engineering) and XS_PRECAST
(\Precast) each point to the folders that contain settings specific to that
role. An example for steel role could be as follows:

set XS_STEEL=%XSDATADIR%\environments\Steel\master_drawings\;%XSDATADIR%
\environments\Steel\model_filters\;%XSDATADIR%\environments\Steel
\model_settings\

XS_GENERAL points to the \General folder that has content common for
all roles and settings that are specific to modeling and drawings, for
example.

When defining role settings in XS_SYSTEM, you use the role options
defined in the env_<environment>.ini to point to the role-specific
settings. Note that you do not need to add the folder paths in XS_SYSTEM
as they are defined in the env_<environment>.ini.

4. role.ini
Sets the settings defined for a role.

The role_<role>.ini file is located in the \Environments subfolder
and it contains the settings specific for a chosen role. For example, the
role_Engineer.ini file in the \Environments\uk folder contains all
the settings for the Engineering role in the UK environment.

5. user.ini
Sets the settings specified by the user.

The user.ini file contains your personal settings. The advanced options
in user.ini override those in other .ini files. For example, if you have
set the same advanced option in an .ini file, in a file in the environments
subfolder and the user.ini file, Tekla Structures uses the value in the
user.ini file. The user.ini is located in the C:\Users\<user_name>
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\AppData\Local\Trimble\Tekla Structures\<version>
\UserSettings folder.

6. options.ini
Sets the settings specified for the company/project/model.

If there are several settings for the same advanced option, the later setting in
the reading order overrules the previous one. This means that the settings in
user.ini overrule the settings in env_global_default.ini, and the
settings in user.in can be overruled by the settings in options.ini.

The lang_enu.ini is the initialization file for the English language settings.
The file is located with the other installed languages in the \Tekla
Structures\<version>\nt\bin folder.

We recommend that you make all your customizations in the options.ini
file under the model folder, or in the user.ini file. This way the
customizations are kept when you install the next version of Tekla Structures.

4.7 Setting advanced options in .ini files
Tekla Structures contains three kinds of advanced options: user-specific
advanced options, system-specific advanced options, and model-specific
advanced options.

NOTE Changing an advanced option value in .ini files located outside the model
folder does not affect the existing models. You can only update the advanced
options in the Advanced options dialog box or in the options.ini file
located in the model folder, not from an options.ini file located in folders
defined for the XS_FIRM or XS_PROJECT advanced option. The .ini files are
also read when you open an existing model, but only new advanced options
that do not exist in options_model.db or options_drawings.db are
inserted, for example, such options that are not yet in the Advanced Options
dialog box, but have been added in the software.

User-specific advanced options set your personal preferences, for example
the appearance of the Tekla Structures window. Tekla Structures saves user-
specific advanced option settings in the options_<your_username>.ini
file, located in the C:\Users\<user_name>\AppData\Local\Trimble
\Tekla Structures\<version>\UserSettings folder.

The options.ini file contains the settings for model-specific advanced
options. It is located in the current model folder. To share your settings with
other people, copy the options.ini file to the system, project or firm folder.

The system-specific advanced options are stored in all other .ini files.

Setting advanced options

There are two methods for setting advanced options:
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• The advanced options are grouped in different categories according to
their usage in the Advanced Options dialog box. To access the dialog box,
click File --> Settings --> Advanced options. See more in Advanced options
reference.

• The .ini files are plain text files that can be edited with a text editor, for
example Notepad. The settings will then be saved in the options.ini file
under the model folder for the model that you have open. The settings can
then easily be copy-pasted into another .ini file. See more in File storing
options and advanced options (page 276).

We recommend that you only use one of these methods to set advanced
options. The settings in the Advanced Options dialog box override those in
the .ini files. Some advanced options need a Tekla Structures restart to
activate the new setting.

To set an advanced option in the user.ini file:

1. Locate the user.ini file in the C:\Users\<user_name>\AppData
\Local\Trimble\Tekla Structures\<version>\UserSettings
folder.

2. Select and right-click the user.ini file in Windows Explorer and click
Open with. You can open the file in any standard text editor.

3. Check that the advanced option is set to the value you want. If it is, you
can stop here.

4. To change or add the advanced option, on a new line, type set, add a
space and the name of the advanced option followed by its value in a
single line.

Tekla Structures only reads lines in the initialization file that start with set,
for example, set %XS_DIR%=C:\TeklaStructures\2019 .

5. Save the user.ini file.

4.8 Creating shortcuts
To use the correct .ini files for a specific project, the easiest way is to create
a shortcut for the project on the desktop. Shortcuts are used to start
teklastructures.exe with the defined initializations.

1. Make a copy of the default shortcut: In the Windows Start menu or Start
screen, find Tekla Structures <version>, then right-click the Tekla
Structures <version>.

2. Select Copy from the pop-up menu.

3. Paste the shortcut to your desktop.

4. Select the shortcut and right-click.

5. Select Properties from the pop-up menu.
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6. Modify the Target of the shortcut by adding the required project
initializations to it.

For example, you can use the following parameters in shortcuts:

• -i InitializationFile: Initialization file to be read during startup, for
example: -i \\MyServer\MyProject\Project1.ini. You can repeat
this parameter as many times as you need.

• ModelToBeOpened: Full path to the model to be opened automatically.

• /create:ModelToBeCreated: Full path to model to be created
automatically.

.ini files tell where things can be found and in which order, depending on
the folder structure that the company has set up. See more in Create start-up
shortcuts with customized initializations (page 19).

4.9 Bypassing the login screen
You can bypass the login screen by using a separate .ini file where you set
the following advanced options:

• XS_LICENSE_SERVER_HOST to set the on-premises license server address.
To use online licensing, set the value to https.

• XS_DEFAULT_LICENSE to set the default license for a user role.

• XS_DEFAULT_ENVIRONMENT points to the environment-specific .ini file,
for example %XSDATADIR%\Environments\uk\env_UK.ini

• XS_DEFAULT_ROLE points to the role-specific .ini file, for example
%XSDATADIR%\Environments\uk\role_Engineer.ini
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Define the startup shortcut using the parameter -I (capital i), for example, -I
%XSDATADIR%\Environments\uk\Bypass.ini. When you do this, an
additional initialization file is read BEFORE the environment .ini.

The content of such a file could be, for example:

set XS_LICENSE_SERVER_HOST=https
set XS_DEFAULT_LICENSE=DIAMOND
set XS_DEFAULT_ENVIRONMENT=%XSDATADIR%\Environments\uk\env_UK.ini 
set XS_DEFAULT_ROLE=%XSDATADIR%\Environments\uk\role_Engineer.ini 

See more in Create start-up shortcuts with customized initializations (page 19).

4.10 User-defined attributes
User-defined attributes are attributes set to an object in a model or a drawing.
These user-defined attributes can be used for many purposes, such as in
filters, drawings, reports, export, import, fabrication, erection, and revision
handling.

You can create your own user-defined attributes (page 305) that you need in
your company, or for a specific project. The user-defined attributes can be
numbers, text, lists, or dates. They can be set to be unique for an object or
allowed to be copied; they can also be ignored by numbering or affect
numbering.

The user-defined attributes are defined in objects.inp files. These files are
located in different folders following the Tekla Structures folder setup, and
they are merged together during startup. The objects.inp file reads the
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user-defined attributes in order from the folders listed below, starting from
the model folder:

Folder defined by
advanced option

Advanced option

Model Current model folder
Project XS_PROJECT (your defined project folder)
Firm XS_FIRM (your defined firm folder)
System XS_SYSTEM (your defined system folder)
inp XS_INP (your defined inp folder)

The files are merged so that if there are user-defined attributes in any of the
files, they are displayed in the user interface. Tekla Structures merges the files
so that duplicate attributes are removed. If Tekla Structures encounters the
same attribute name in different objects.inp files, the attribute from the
first read objects.inp file will be used.

If you need to have several objects.inp files in the same folder, you can use
a suffix in the file name to use all the files. This enables having several
objects_<suffix>.inp files in the same folder. The file name could be
objects_precast.inp, for example.
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5 Create and distribute
customized settings, user
interface elements, and
catalogs

Tekla Structures settings are managed on several layers, and many of the
settings can be customized to meet the needs of your company and projects.

If you are not yet familiar with the different files and folder that are essential
to get Tekla Structures working as efficiently as possible, see Implementation
guide for administrators (page 110) before you start customizing.

Customize modeling and drawing settings

In addition to Trimble's default settings, you can create your company's
general settings and project-specific settings. See Environment, company, and
project settings for administrators (page 124).

Share customized user interface elements

Also, many user interface elements can be customized and distributed to all
the users in a company. You can distribute

• customized ribbons (page 131)

• customized tabs (page 133)

• customized property pane layouts (page 135) and

• customized toolbars (page 137).

Customize catalogs and databases

You can customize catalogs and databases for

• profiles (page 146)

• materials (page 138)
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• shapes (page 209)

• bolts (page 226)

• rebars (page 243) and

• applications and components.

Check, for example, the profile and material needs for your project, and if
needed, clean up the catalogs and databases so that they contain the relevant
content for your project. This helps you to simplify your work and avoid
mistakes. Always ensure that the catalog content is correct. Mistakes in
catalogs may be hard to detect, but if left unnoticed, they may lead to serious
inconsistencies in quantity information, data transfer, or elsewhere. For
example, wrong material density will lead to systematic errors in reported
weights.

If necessary, you can add new content to the catalogs from other
environments, from Tekla Warehouse, or you can import content created in
other software solutions.

Create and distribute customized settings, user
interface elements, and catalogs

124 Environment, company, and project settings for
administrators

https://warehouse.tekla.com/


5.1 Environment, company, and project settings for
administrators
Tekla Structures settings are managed on several layers. On the highest layer
there are hard-coded default settings which cannot be changed but which you
can override on the following layers.

common environment  settings 

Windows AppData folder 

Tekla Structures hard-coded settings

regional environment settings 

XS_FIRM 

XS_PROJECT 

model template 

model folder 

These settings are constantly active

Tekla Structures reads these settings when a model is created

Tekla Structures reads these settings when a model is opened

• Common environment settings that have preset values included in the
installation. These can be modified or removed. The common environment
is usually always included in the installation.

• Regional environment settings with preset values that are suited for
specific regional areas.

If needed, you can clean up the common environment and the selected
regional environment of the files that you do not need.

• Advanced option XS_FIRM that defines a folder, typically on a network
drive, that loads settings for all users within your company.

This folder is the main container of files for the company.

• Advanced option XS_PROJECT that defines a folder, typically on a network
drive, that loads higher-ranking settings for all users within a specific
project.
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• Model template that is loaded from the environment, or from the network
folders. The model template is loaded only once when you start creating a
new model.

• Model folder content that is saved locally when you add or edit settings.

Note that if you save content in the model folder, the presaved settings in
other locations will override the same settings found in the model folder.

• Windows AppData folder for user-specific settings related to the Tekla
Structures user interface.

Environment settings

Common settings

All settings and files that are the same in all environments are located in the
\Tekla Structures\<version>\Environments\common folder. Files and
settings that are specific to an environment are located in separate
environment folders.

The env_global_default.ini file is also located in the \common folder. The
file determines the standard settings, and it is the first file that is read. Other
initialization files (page 268) are read after this file, and if the other files
contain the same settings, they will override the previous settings.

Country-specific settings

The country-specific, or region-specific, settings are located in the
environments folders, and they are localized by your local Trimble office/
reseller. The folder structure of the environments can vary, but the same kind
of settings exist. For example, the settings that are localized include profile
database, material database, reports, selection filters, view filters, components
and custom components, macros, user-defined attributes, and drawings
settings.

Company settings
Company-level settings are mainly settings that are used throughout the
company for all projects. These settings are set using XS_SYSTEM and 
XS_FIRM.

For a larger company with subsidiaries, the settings could be used as follows:

• XS_SYSTEM may contain multiple paths, and it points to general settings
inside the company. These can be company logo, reports, printer settings,
drawing settings, templates, for example. These are settings that very
seldom change, and are stored on a server available for all. For example, if
the company logo is updated, it only has to be replaced in one place.
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• XS_FIRM points to the firm folder set up by the company, or a subsidiary.
The folder contains all the company settings used at the particular office.
These can be logos, drawing settings, templates, reports, or printer
settings, for example. The firm folder can also have user-defined sub-
folders for storing property files.

• XS_PROJECT points to the project folder. The folder contains project
settings, such as logos for contractors and fabricators, or drawing settings,
for example. The project folder can also have user-defined sub-folders for
storing project-specific property files.

For more information on the folder search order, see Folder search order
(page 358).

You can also use Tekla Warehouse company-specific collections online or
offline, in your own network. Use Trimble Identity for downloading or installing
from the online collections. See also Trimble Identity for Tekla Online services.

The offline collection access is managed with folder rights in your network,
and on the collection level in the collections.json file on each user's
computer.

 "collections" 
"\\\\server-A\\company\\Tekla Structures collection" 
        

The collections.json file can be shared to selected persons by copying it
to the C:\Users\Public\Documents\Tekla\Tekla Warehouse\ folder.

Model templates

You can save a model with the desired settings and use the model as a
template when you create new models. This can be very useful if your
company has different kinds of projects, such as, parking garages, office
buildings, bridges, and industrial.

When you create a model template, always start by creating a new empty
model. This is because old models that have been used in live projects cannot
be completely cleaned. They may contain excess information that increases
the size of the model even if you delete all objects and drawings from the
model.

To create a model template:

1. Create a new model and give it a unique name.

2. Add in the model the desired profiles, custom components, and other
necessary items.

3. On the File menu, click Save as --> Save.

You need to save the model to include custom components in the
xslib.db1 file. If you do not save the model, custom components will not
be included in the model template.

4. On the File menu, click Save as --> Save as model template.
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5. Enter a name for the model template, and select which catalogs, drawing
templates, report templates, and model subfolders you want to include in
the model template.

6. Click OK.

By default, the model template folder is saved in your environment folder,
under ..ProgramData\Trimble\Tekla Structures\<version>
\environments\<your environment>\. The exact folder location may
vary depending on your environment and role. Use the advanced option
XS_MODEL_TEMPLATE_DIRECTORY to define a different location.

You can download, share, and store model templates in Tekla Warehouse. The
image below shows an example of a model template in Tekla Warehouse.

The Insert into model button in Tekla Warehouse installs the model template
directly in the folder pointed by XS_MODEL_TEMPLATE_DIRECTORY. You can
immediately use the template when creating a new model.

Model templates in Tekla Structures version update

We strongly recommend that you update your model templates in Tekla
Structures version upgrade.

To update a model template:

1. Create a new model using an existing model template.

2. Give the model the same name as in the previous Tekla Structures
version.

3. Open a 3D view.
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4. On the File menu, click Diagnose and repair --> Diagnose model.

5. On the View tab, click Screenshot --> Project thumbnail to create a
project thumbnail, or add a custom image named thumbnail.png in the
model folder.

The preferred size of the image is 120 x 74 pixels.

6. On the File menu, click Save as --> Save.

If you do not do this, a message may appear warning about the model
being created with a previous version.

7. On the File menu, click Save as --> Save as model template.

8. Select which catalogs, drawing templates, report templates, and model
subfolders you want to include in the model template.

9. Click OK.

10. Remove manually all *.db files (environment database, options database
files) from the model folder.

The *.bak, *.log and xs_user files are automatically removed from the
model folder.

Do not remove the .idrm files (db.idrm and xslib.idrm) as they are
part of the model.

The model template is saved in a location pointed by 
XS_MODEL_TEMPLATE_DIRECTORY.

You now have a sample image for your model template. The Applications
& components catalog is now also in order and easy to use.

Customizing reports and drawings

If your company already has graphical templates in the DXF, DWG, or DGN
format, you can convert these templates to Tekla Structures templates. For
detailed instructions on how to do this, see the information on AutoCAD and
Microstation files in the Template Editor Help.

For information on how to create your own templates and reports, see the
Template Editor Help, and and Templates (page 362).

Cloning templates for drawings

You should consider cloning drawings when:

• There are several similar parts, assemblies, or cast units in the model.

• You need to produce single-part, assembly, or cast-unit drawings of similar
parts, assemblies, or cast units.

• The drawings need a lot of manual editing.

For example, you can create a drawing for one truss, edit the drawing, and
then clone it for similar trusses. Then you only need to modify the cloned
drawings where the trusses differ.
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The cloned drawing may contain more parts than the original drawing. Part
properties, marks, associative notes and related text objects are cloned from a
similar part in the original drawing.

Clone templates in Master Drawing Catalog

You can clone drawings by using the Master Drawing Catalog templates. A
cloning template in the Master Drawing Catalog can also be used in other
models. They can be used in projects that have the same kind of drawings.

To create cloning templates:

1. Select a drawing in Document manager.

2. Right-click and select Add to Master Drawing Catalog, and then fill in the
required properties.

The cloning template can be found under Cloning templates in the Master
Drawing Catalog. To use cloning templates in other models, open the Master

Drawing Catalog in the model, click the  button on the toolbar, and add
the model where the templates are saved.

For more information on the Master Drawing Catalog and cloning templates,
see .

Project settings

Create your own component folder

Usually, only a few different connections and components are used in a
project. To ensure that everyone in the project uses the same components
and finds the components faster, we recommend that you create a
component folder of your own.

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Create a new group for the project: Right-click in the catalog and select
New group.

3. Add components to the group: Select the components in the catalog,
right-click and select Add to group. Then select the group to which the
components are added. You can also drag the selected components to
another group.

4. Hide the groups that you do not need: Select the group, right-click and
select Hide/Unhide.

TIP In the Applications & components catalog, use the commands in

Access advanced features  > Catalog management to modify
catalog definitions. For more information, see Customize the
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Applications & components catalog (page 254) and XS_COMPONENT_
CATALOG_ALLOW_SYSTEM_EDIT.

For more information on the Applications & components catalog, see .

Define project properties

Project information is needed many times during a project. Define the project
information at the beginning of a project to make reports and drawings
display the correct information automatically. You can also update the project
properties during the project.

1. On the File menu, click Project properties.

2. Edit the project properties.

When you edit the properties, Tekla Structures highlights the modified
properties in yellow.

3. When you are ready with the modifications, click Modify to apply the
changes.

Create and modify templates and reports

You can modify existing reports and templates, or create your own templates
(page 362) by using Template Editor. To open Template Editor, click File -->
Editors --> Template editor, or double-click an existing table in an open
drawing to open the tool. For more information, see Template Editor User's
Guide.

Note that if your templates are located in a protected folder, the templates are
read-only, and you cannot save a modified template in a protected folder. In
this case, run Tekla Structures as an administrator.

Set up printers

Tekla Structures uses Windows drivers to write the print data directly to the
Windows print device interface. You can print drawings as PDF files, save them
as plot files (.plt) for printing with printer/plotter, or print them on a selected
printer. To print to several paper sizes, you need to modify the
drawingsizes.dat file, see more in . You can also change the line width of
the printed drawings, see more in and .

You can affect the way Tekla Structures automatically names the .pdf files
and plot files by using certain drawing-type-specific advanced options, see
more in .

5.2 Distribute customized ribbons by using a firm or
environment folder
Company administrators can distribute the customized ribbon files to other
users in the company by placing the ribbon files in a firm or environment
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folder (not in the project folder). For example, the administrator can create
company ribbons and save them in the firm folder. These ribbons will be
displayed in the Tekla Structures user interface for all users who use the same
firm folder.

Add ribbons to a firm or environment folder
1. In the Ribbon editor, create the modeling and drawing ribbons that you

want to share. 

The ribbons are saved in the ..\Users\<user>\AppData\Local
\Trimble\Tekla Structures\<version>\UI\Ribbons folder.

If you cannot find the folder, ensure that you are able to view the hidden
files and folders (page 360) on your computer.

2. Copy the entire \Ribbons folder either to your company's firm folder or
to the system folder.

3. If the ribbon contains user-defined commands, create a sub-folder named
\Commands on the same level as the \Ribbons folder, and copy the
UserDefined.xml file from the ..\Users\<user>\AppData\Local
\Trimble\Tekla Structures\<version>\UI\Commands folder to the
\Commands folder you just created.

4. Restart Tekla Structures.

Loading order of custom ribbons
Tekla Structures loads the ribbons in the following order:

1. Tekla Structures default ribbon

2. Company ribbons in the environment folders

3. Company ribbons in the firm folder

4. User-defined ribbons under %localappdata%
Note that the ribbons which are loaded later will override previously loaded
ribbons that have the same configuration + editing mode combination. For
example, a ribbon defined in the firm folder will take precedence over the
ribbons in the environment folders.

If you have a customized ribbon in the ..\Users\<user>\AppData\Local
\Trimble\Tekla Structures\<version>\UI\Ribbons folder, it will take
precedence over company ribbons. To override this, open the Ribbon editor
and click Restore. The ribbon in the environment or firm folder will now be
used. Alternatively, you can remove or rename your own customized ribbons.
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Naming convention for ribbon files
The customization tool saves the custom ribbons as .xml files. The naming
convention for these files is:

<Tekla-Structures-configuration_identifier>--<Tekla-
Structures-editing-mode>.xml
The name consists of an internal configuration name, a separator of two dash
characters (--), an internal editing mode name, and the file name
extension .xml. For example, the Full license modeling ribbon is called
albl_up_Full--main_menu.xml.

Configuration identifier Configuration name
albl_up_Diamond Tekla Structures Diamond
albl_up_Graphite Tekla Structures Graphite
albl_up_Carbon Tekla Structures Carbon
albl_up_Construction_Modeling Construction Modeling
albl_up_Developer Developer
albl_up_Drafter Drafter
albl_up_Educational Educational
albl_up_Engineering Engineering
albl_up_Full Full
albl_up_PC_Detailing Precast Concrete Detailing
albl_up_Rebar_Detailing Rebar Detailing
albl_up_Steel_Detailing Steel Detailing
albl_up_Tekla_Structures_Prim
ary

Primary

albl_up_Viewer Project Viewer

Editing mode Purpose
main_menu Modeling ribbon
edit_draw_menu Drawing ribbon
plan_main_menu Importing ribbon

5.3 Distribute customized tabs by using a firm or
environment folder
As an alternative to customized ribbon files, which override the existing
ribbon, you can distribute customized tabs to other users in the company by
placing the tab files in a firm or an environment folder (not in a project folder).
The customized tabs are automatically appended to the end of the ribbon for
all users who use the same firm or environment folder. This means that an

Create and distribute customized settings, user
interface elements, and catalogs

133 Distribute customized tabs by using a firm or
environment folder



administrator can distribute customizations to all users in the company while
still allowing individual users to customize their ribbons as well.

Note that these customized tabs do not appear in the Ribbon editor, so the
users are not able to edit them. If the administrator has updated the contents
of a customized tab, the users will receive an update when they restart Tekla
Structures. Tabs are not configuration specific, so they are imported
regardless of the user's Tekla Structures license. If the tab contains commands
that are not available in the user's configuration, they will appear dimmed on
the ribbon.

NOTE If you use a firm folder to distribute the custom tabs, you need to set
the firm folder path in an .ini file, for example, in user.ini,
teklastructures.ini,project.ini or in company.ini. If you set
the firm folder path in the advanced option XS_FIRM, the tab file does
not work correctly, because the XS_FIRM definition in advanced
options is made on the model level and it is too late for the custom
tab to be initialized.

1. Create the following folder structure in your company's firm folder or in
the system folder. 

2. In the Ribbon editor, create a customized tab and add some commands to
it.

3. Save the ribbon.

4. Go to the ..\Users\<user>\AppData\Local\Trimble\Tekla
Structures\<version>\UI\Ribbons folder.

5. Open the ribbon *.xml file, which contains the tab you wish to share with
other users, in a text editor, for example, Microsoft Notepad.

6. Remove all the other content from the ribbon file except the first row and
the description of the tab you wish to share. 

Alternatively, you can copy the needed content in a new text file.

For example:

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<Tab Header="My Tab" IsCollapsed="false" IsUserDefined="true">
  <SimpleButton X="0" Y="0" Width="3" Height="4" 
Command="Common.Interrupt" Text="command:ShortText" Icon="myicon.png" 
ShowText="true" ShowIcon="true" />
  <SimpleButton X="3" Y="0" Width="3" Height="4" 
Command="RibbonEditor.Open" Text="command:ShortText" Icon="somefolder
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\myicon2.png" ShowText="true" ShowIcon="true" />
</Tab>

The button icons use relative paths. The icon path is relative to the *.xml
file where tab is read from. For example Icon="myicon.png" refers to
an icon in the same folder as the *.xml file, and the Icon="somefolder
\myicon2.png" refers to an icon in a sub-folder.

Alternatively, you can also go folders back: Icon="..\myicon.png".

7. Save the *.xml file with a new name in the ..\CustomTabs\Modeling
or ..\CustomTabs\Drawing folder. 

Tab files have the file name extension *.xml. We recommend that you
use the same name as for the tab. For example, MyTab.xml. The file
name is not case sensitive.

The tab will be added to either the modeling or drawing mode ribbons,
depending on the folder it is located in. Note that there can be several
custom tab files in the same folder. They are added to the ribbon one
after the other. If the same tab file exists in both the environment and
firm folders, the firm version overrides the environment version.

NOTE To avoid file name conflicts, we recommend that administrators
prefix all custom tab files with the company name, and that
extension developers prefix all custom tab files with the name of
the extension (for example, MyExtension_TabName.xml).

8. If the tab contains user-defined commands, copy the UserDefined.xml
file from the ..\Users\<user>\AppData\Local\Trimble\Tekla
Structures\<version>\UI\Commands folder to the \Commands folder
created in step 1.

9. Restart Tekla Structures. 

The customized tab now appears at the end of the ribbon.

See also

Create and distribute customized settings, user interface elements, and
catalogs (page 123)

Distribute customized ribbons by using a firm or environment folder
(page 131)

5.4 Distribute customized property pane layouts by using
a project, firm, or environment folder
Company administrators can distribute the customized property pane layouts
to other users in the company by placing the property pane layout file
PropertyTemplates.xml in a folder called PropertyRepository
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\Templates in a project, firm, or environment folder. For example, company
administrators can create company property pane layouts and save them in
the firm folder. These property panes are available in the Tekla Structures user
interface for all users who use the same firm folder.

Add a property pane layout file to a project, firm, or
environment folder
1. In the Property pane editor, create the property pane layouts that you

want to share. 

The property pane layouts are saved in the PropertyTemplates.xml
file, in the ..\Users\<user>\AppData\Local\Trimble\Tekla
Structures\<version>\UI\PropertyTemplates folder.

If you cannot find the folder, ensure that you are able to view the hidden
files and folders (page 360) on your computer.

2. Create a folder called PropertyRepository\Templates either in your
company's project folder, firm folder, or in the system folder.

3. Copy the PropertyTemplates.xml file to the PropertyRepository
\Templates folder.

4. Restart Tekla Structures.

Search order of the customized property pane layout files
The PropertyTemplates.xml file contains all the property pane layouts for
different object types. Note that the property pane layouts for different object
types are treated separately. For example, Tekla Structures can read the
property pane layout for steel beam from a different location than the
property pane layout for steel column.

If different object types are defined in different folder locations, the definitions
are combined. If the same object type is defined differently in different folder
locations, the definition that is higher in the search order is used.

The property pane layout in the ..\Users\<user>\AppData\Local
\Trimble\Tekla Structures\<version>\UI\PropertyTemplates\
folder has the highest priority, and after that Tekla Structures uses the default
search order.
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5.5 Distribute customized property pane settings by
using a project, firm, or environment folder
Company administrators can distribute the customized property pane settings
to other users in the company. Place the PropertyPaneSettings.xml file in
a folder called \PropertyPane in a project, firm, or environment folder.

1. Customize the property pane settings that you want to share. 

The property pane settings are saved in the
PropertyPaneSettings.xml file, in the ..\Users\<user>\AppData
\Local\Trimble\Tekla Structures\<version>\UI\PropertyPane
\ folder.

If you cannot find the folder, ensure that you are able to view the hidden
files and folders (page 360) on your computer.

2. Create a folder called \PropertyPane either in your company's project
folder, firm folder, or in the system folder.

3. Copy the PropertyPaneSettings.xml file to the \PropertyPane
folder.

4. Restart Tekla Structures. 

The file in ..\Users\<user>\AppData\Local\Trimble\Tekla
Structures\<version>\UI\PropertyPane\ has the highest priority in
the search order, and after that Tekla Structures uses the default search
order.

If the PropertyPaneSettings.xml file is placed in several different
folder locations, Tekla Structures reads the settings from different folders
and merges them.

See also

Create and distribute customized settings, user interface elements, and
catalogs (page 123)

5.6 Distribute customized toolbars by using a project,
firm, or environment folder
Company administrators can distribute the customized Selecting, Snapping,
and Snap override toolbars to other users in the company. Place the needed
toolbar .json files in a folder called \Toolbars in a project, firm, or
environment folder. For example, company administrators can create
company toolbars and save them in the firm folder. These toolbars are
available in the Tekla Structures user interface for all users who use the same
firm folder.

1. Customize the toolbars that you want to share. 
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The toolbars are saved in corresponding .json files, in the ..\Users
\<user>\AppData\Local\Trimble\Tekla Structures\<version>
\Toolbars folder.

If you cannot find the folder, ensure that you are able to view the hidden
files and folders (page 360) on your computer.

2. Create a folder called \Toolbars either in your company's project folder,
firm folder, or in the system folder.

3. Copy the needed .json files to the \Toolbars folder.

4. Restart Tekla Structures. 

The files in ..\Users\<user>\AppData\Local\Trimble\Tekla
Structures\<version>\Toolbars have the highest priority in the
search order, and after that Tekla Structures uses the default search
order.

See also

Create and distribute customized settings, user interface elements, and
catalogs (page 123)

5.7 Customize the material catalog
The material catalog contains information on material types and grades. In the
material catalog, materials are displayed in a hierarchical tree grouped
according to their types. Each material type has material grades listed under
them.

The following material types are available in Tekla Structures:

• Steel

• Concrete

• Reinforcing bar

• Timber

• Miscellaneous

By default, the material catalog contains standard, environment-specific
materials. You can add, modify, and delete material grades.

Tekla Structures stores the material information in the matdb.bin file.

See also

Important buttons in the material catalog (page 139)

Add a material grade (page 139)

Copy a material grade (page 140)
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Modify a material grade (page 141)

Delete a material grade (page 141)

Add user attributes to material grades (page 142)

Create user-defined material definitions (page 143)

Import and export material grades (page 144)

Important buttons in the material catalog
When you work with the material grades, note the usage of the following
buttons in the Modify Material Catalog dialog box:

Button Description
Saves the changes of a single edited material grade to the
computer’s memory until you click OK.
Saves the changes in the model folder.

Tekla Structures saves the modified catalog on the hard disk when
you click OK to close the dialog box and then click OK in the Save
confirmation dialog box.
Closes the Modify Material Catalog dialog box without saving the
changes.

Note that all changes made to the catalog will be lost even if you
have clicked Update, because the changes have not been saved on
the hard disk. The changes made to the catalog are visible during
one session, because the catalog is using the computer’s memory.
When you start Tekla Structures the next time, the previous data is
restored from the hard disk.

Tekla Structures stores the material information in the matdb.bin file. When
you first open a model, Tekla Structures reads the data from the hard disk and
stores it in the computer’s memory.

When you select a material, Tekla Structures reads the data from the
computer’s memory and displays it in the Modify Material Catalog dialog
box. This is faster than accessing the data from the hard disk.

See also

Customize the material catalog (page 138)

Add a material grade
1. On the File menu, click Catalogs --> Material catalog to open the Modify

Material Catalog dialog box.
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2. Select a material type, for example, steel.

3. Right-click and select Add Grade. 

A new material grade is added under to the material type you selected.

4. Change the material grade name by clicking the grade and entering a new
name for it.

5. Enter the material grade properties.

6. Click OK to save the material grade and close the Modify Material
Catalog dialog box.

7. Click OK in the Save confirmation dialog box to save the changes.

See also

Copy a material grade (page 140)

Modify a material grade (page 141)

Delete a material grade (page 141)

Import and export material grades (page 144)

Copy a material grade
You can add new material grades by modifying a copy of an existing, similar
material grade.

1. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

2. Select a material grade that is similar to the one you wish to create.

3. Right-click and select Copy Grade. 

A copy of the material grade with the name COPY is added to the material
tree.

4. Change the material grade name by clicking the grade and entering a new
name for it.

5. Modify the material grade properties.

6. Click OK to save the material grade and close the Modify Material
Catalog dialog box.

7. Click OK in the Save confirmation dialog box to save the changes.

See also

Add a material grade (page 139)

Modify a material grade (page 141)

Delete a material grade (page 141)
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Modify a material grade
You can modify existing material grades using the material catalog.

1. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

2. Select a material grade in the tree and modify its properties. 

• Use the General tab for entering three alternative names for the
material. The names are usually the material names used in different
countries or standards. The tab also contains the profile and plate
density values.

• Use the Analysis tab for entering information on the properties used
in structural analysis.

• Use the Design tab for entering information on the design-specific
properties, such as strengths and partial safety factors.

• Use the User attributes tab for creating your own attributes for
material grades.

For example, you can define a paint layer thickness, or the maximum
grain size of concrete using a user-defined attribute.

3. When you have finished modifying the material grade, click Update.

4. Click OK to close the Modify Material Catalog dialog box. 

Tekla Structures asks if you want to save the changes to the model folder.

5. Click OK in the Save confirmation dialog box to save the changes. 

The modified material catalog is saved in the current model folder and is
available only for that model. To make the modified catalog available for
all the other models, use export and import.

See also

Add a material grade (page 139)

Copy a material grade (page 140)

Delete a material grade (page 141)

Delete a material grade
1. On the File menu, click Catalogs --> Material catalog to open the Modify

Material Catalog dialog box.

2. Select the material grade that you want to delete.

3. Right-click and select Delete Grade.

4. Click OK to close the Modify Material Catalog dialog box.
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5. Click OK in the Save confirmation dialog box to save the changes.

See also

Add a material grade (page 139)

Copy a material grade (page 140)

Modify a material grade (page 141)

Add user attributes to material grades
You can add user attributes and their values to the material grades. The user
attributes can then be used, for example, in filtering.

1. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

2. On the User attributes tab, click Definitions to open the Modify
Material Properties dialog box.

3. Click Add to add a new row.

4. To define a user attribute, click each item on a row.

a. In the Category list, select a material category to which the user
attribute is applied.

b. In the Design code list, select a design code to which the attribute is
added.

c. In the Material type list, select a material type for the attribute.

d. In the Quantity type list, select the type of information that the user
attribute contains, for example, weight, area, ratio, or string.

e. In the Order column, define the order in which the user attributes are
shown in the dialog box. Smaller values are shown first.

f. In the Property name column, define a name for the property. 

The name is saved in the catalog and can be used in reports and
templates. When Property name is used in a template, 
MATERIAL.PROPERTY_NAME indicates where the property name
appears.

g. In the Label column, define a label for the attribute.

5. Click Update.

6. Click OK to close the Modify Material Properties dialog box.

See also

Modify a material grade (page 141)
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Create user-defined material definitions
You can replace the existing material definitions with your own definitions and
use them, for example, in drawing part marks. Material definitions can contain
text, numbers and symbols.

1. Save the symbol file user_material_symbols.sym in the symbol folder
(usually the folder ..\ProgramData\Trimble\Tekla Structures
\<version>\environments\common\symbols\).

2. Create a text file that contains your material definitions. 

Create the file using a text editor, for example Microsoft Notepad.

Each row in the file defines a material. Use the following syntax: 
material_name symbol_file_name@n, where

• material_name is the name of the material used in the material
catalog

• symbol_file_name is the symbol file name to be used

• n is the number of the symbol.

For example:

WARNING The order of material names in the definition file is relevant
to the conversion. Materials with more specific names need
to be listed before the ones with similar, but simpler names,
for example, S235JRG1 must be listed before S235JR.
Otherwise they both get the same symbol.

3. Save the file for example with the name
user_material_definitions.txt. 

All the named materials in the material catalog will be replaced with the
ones defined in this file.

4. Set the name of the file as a value for the advanced option 
XS_MATERIAL_SYMBOL_REPRESENTATION_FILE in File menu -->
Settings --> Advanced options --> Drawing Properties as follows: 
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set
XS_MATERIAL_SYMBOL_REPRESENTATION_FILE=user_material_defi
nitions.txt
You can also enter a full path to the material definition file. Without the
path Tekla Structures searches for the file in the model, firm, project, and
system folders.

See also

Customize the material catalog (page 138)

Import and export material grades
Use importing and exporting for merging material catalogs. Material catalogs
are imported and exported as .lis files.

Importing and exporting is useful when you:

• upgrade to a newer version of Tekla Structures and want to use a
customized material catalog from a previous version

• want to combine material catalogs that are stored in different locations

• want to share material catalog information with other users

• want to combine material catalogs across different environments.

TIP You can also download or share material grades using Tekla Warehouse.

See also

Import a material catalog (page 144)

Export an entire material catalog (page 145)

Export a part of the material catalog (page 146)

Units used in import and export (page 159)

Import a material catalog
Material catalogs are imported to Tekla Structures models as .lis files. You
can move an exported .lis file to any model folder and import it to an
existing material catalog.

1. Open the model to which you want to import a material catalog.

2. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

3. Click Import.

4. Browse for the folder that contains the import file, and select the file.
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5. Click OK. 

If a material with a same name as the material being imported already
exists, the Import confirmation dialog box appears and you have three
options:

• Replace: The existing material is replaced with the imported material.

• Merge: Material properties that are different in the import file are
added to the existing material. All the other properties remain
unchanged.

Use this option to import only certain elements of the material catalog,
such as user attributes.

• Leave: The existing material is not replaced and the material
definitions in the import file are ignored.

If you select the Apply for all check box, Tekla Structures uses the same
option (Replace, Merge, or Leave) for all the existing materials that have
the same name as the one being imported.

If a user attribute with a different definition already exists, you are
prompted to Replace or Leave the existing attribute.

6. Click OK to close the Modify Material Catalog dialog box.

7. Click OK in the Save confirmation dialog box to save the changes.

See also

Export an entire material catalog (page 145)

Export a part of the material catalog (page 146)

Units used in import and export (page 159)

Export an entire material catalog
Exporting and importing are used to merge material catalogs. Material
catalogs are exported from Tekla Structures models as .lis files. Note that
the Export command exports the entire catalog.

1. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

2. Click Export.

3. Browse for the folder where you want to save the exported file. 

By default, the file is saved to the current model folder.

4. Enter a name for the file and click OK.

5. Click OK to close the Modify Material Catalog dialog box.

6. Click OK in the Save confirmation dialog box to save the changes.
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See also

Import a material catalog (page 144)

Units used in import and export (page 159)

Export a part of the material catalog
If you do not want to export the whole material catalog, you can export a
branch of the material tree, meaning all the material grades grouped under
one material type, or a single material grade. Material catalogs are exported
from Tekla Structures models as .lis files.

1. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

2. Select material grades to be exported. 

• To export a branch of the material tree, right-click the branch and
select Export Grades.

• To export a single material grade, right-click the material grade and
select Export Grade.

3. Browse for the folder where you want to save the export files. 

By default, the file is saved to the current model folder.

4. Enter a name for the file and click OK.

5. Click OK to close the Modify Material Catalog dialog box.

6. Click OK in the Save confirmation dialog box to save the changes.

See also

Export an entire material catalog (page 145)

Import a material catalog (page 144)

Units used in import and export (page 159)

5.8 Customize the profile catalog
The profile catalog contains information on profiles, their rules and types, and
the analysis and design properties of the profiles. Profiles are displayed in a
hierarchical tree grouped according to rules.

By default, the profile catalog contains standard, environment-specific profiles
and generic parametric profiles. You can add, modify, import, export, and
delete profiles.

You can define your own user-defined profiles, which can be either fixed or
parametric. Use the profile catalog to create new fixed profiles, either from
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scratch or by copying an existing one. Use the sketch editor or .clb files to
create new parametric profiles.

Tekla Structures stores the profile catalog information in the profdb.bin file.

See also

Important buttons in the profile catalog (page 147)

Group profiles together (page 148)

Add user attributes to profiles (page 149)

Associate profile types with a certain material (page 153)

Delete a profile from the profile catalog (page 154)

Import and export profiles (page 155)

Create your own profiles (page 162)

Define standardized values for parametric profiles (page 208)

Create an image of a profile (page 208)

Customize the shape catalog (page 209)

Important buttons in the profile catalog
When you work with the profiles, note the usage of the following buttons in
the Modify Profile Catalog dialog box:

Button Description
Saves the changes of a single edited profile to the computer’s
memory until you click OK.
Saves the changes in the model folder.

Tekla Structures saves the modified catalog on the hard disk when
you click OK to close the dialog box and then click OK in the Save
confirmation dialog box.
Closes the Modify Profile Catalog dialog box without saving the
changes.

Note that all changes made to the catalog will be lost even if you
have clicked Update, because the changes have not been saved on
the hard disk. The changes made to the catalog are visible during
one session, because the catalog is using the computer’s memory.
When you start Tekla Structures the next time, the previous data is
restored from the hard disk.
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Tekla Structures stores the information of fixed profiles in the profdb.bin
file. When you first open a model, Tekla Structures reads the data from the
hard disk and stores it in the computer’s memory.

When you select a profile, Tekla Structures reads the data from the computer’s
memory and displays it in the Modify Profile Catalog dialog box. This is faster
than accessing the data from the hard disk.

See also

Customize the profile catalog (page 146)

Group profiles together
In the profile catalog, the profiles are displayed in a hierarchical tree and they
are grouped according to rules , such as the profile type (for example, I
profiles) and the profile subtype (for example, HEA). To change how the
profiles are grouped in the profile tree, you need to modify the rules.

The order in which you create the rules does not matter, only the location of
the rules in the profile tree.

Tekla Structures reads the rules from top to bottom in the profile tree. Profiles
are in the highest group where they meet the criteria defined in the rule. For
example, a rule that collects All profiles overrides all rules that are below it in
the profile tree.

See also

Add a rule to the profile catalog (page 148)

Modify a rule in the profile catalog (page 149)

Add a rule to the profile catalog
1. On the File menu, click Catalogs --> Profile catalog to open the Modify

Profile Catalog dialog box.

2. Right-click any existing rule and select Add Rule. 

The Profile manager rules dialog box appears.

3. Define the rule properties.

a. Enter a rule name in the Rule name box.

b. Select the Profile type to which the rule is applied.

c. Enter the Name filter string that defines the new rule. 

By default, the wildcard symbol (*) is entered, meaning “all entries”.

For example, to group all catalog entries with names beginning with
A, enter A* in the Name filter string box, or to group all catalog
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entries with names containing 100, enter *100*. Tekla Structures
groups the catalog entries that meet your criteria under the new rule.

4. Click OK to close the Profile manager rules dialog box.

5. Click OK to close the Modify Profile Catalog dialog box.

6. Click OK in the Save confirmation dialog box to save the changes. 

TIP You can add a next level rule that creates a subgroup under an
existing rule. Use the Add Next Level Rule command to add the
next level rule.

See also

Modify a rule in the profile catalog (page 149)

Modify a rule in the profile catalog
1. On the File menu, click Catalogs --> Profile catalog to open the Modify

Profile Catalog dialog box.

2. Right-click any existing rule and select Edit Rule. 

The Profile manager rules dialog box appears.

3. Modify the rule properties.

4. Click OK to close the Profile manager rules dialog box.

5. Click OK to close the Modify Profile Catalog dialog box.

6. Click OK in the Save confirmation dialog box to save the changes.

Profiles in the profile tree are listed in an alphabetical order, and rules are
listed in the order you specify. To change the order in which the rules appear,
use the Move up and Move down commands.

TIP If you want to delete a rule, right-click an existing rule and select Delete Rule.

See also

Add a rule to the profile catalog (page 148)

Add user attributes to profiles
You can add your own attributes to profiles. For example, you can specify
paint layer thickness, define the maximum grain size of concrete, sort out
different profile types by material, or create profile aliases for converting
imperial profiles to metric and vice versa.
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1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. On the User attributes tab, click Definitions. 

The Modify Profile Properties dialog box appears.

3. Click Add to add a new row.

4. To define a user attribute, click each item on a row.

a. In the Profile type list, select a profile type to which the user
attribute is applied.

b. In the Quantity type list, select the type of information that the user
attribute contains, for example, weight, area, ratio, or string.

c. In the Order list, define the order in which the user attributes are
shown in the dialog box. Larger values are shown first.

d. In the Property name list, define a name for the property. 

The name is saved in the catalog and can be used in reports and
templates. When Property name is used in a template, 
PROFILE.PROPERTY_NAME indicates where the property name
appears. For example, PAINT_LAYER_THICKNESS.

e. In the Symbol column, define an abbreviation that can be used for
the property, such as Ix or ct.

f. In the Label column, define a label for the attribute.

5. Click Update.

6. Click OK to close the Modify Profile Properties dialog box.

See also

Example: Add a user attribute to a profile and use it in a rule (page 150)

Example: Add a user attribute to a profile and use it in a rule
You can add your own attributes and their values to profiles. The user
attributes can then be used, for example, in profile filtering.

In this example, you will add a user attribute for I profiles’ rule.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. On the User attributes tab, click Definitions. 

The Modify Profile Properties dialog box appears.

3. Click Add to add a new row.

4. Select the row that was created and modify the properties as follows: 

• Set Profile type to I profiles.
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• Set Quantity type to String.

• Set Property name to HISTORICAL_PROFILE.

• Set Symbol to Hist.

• Set Label to Historical profile.

5. Click Update and OK.

6. In the profile tree, select I profiles and then HEA.

7. Right-click and select Add Next Level Rule.

8. In the Profile manager rules dialog box, set the rule properties as
follows: 

• Set Rule name to Historical profiles.

• In Profile type, clear the All profiles check box and select the I
profiles check box.

• Enter HEA* in the Name filter string box.
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• Set User attribute to HISTORICAL_PROFILE and Equals, and enter
Yes in the box next to the two other boxes.

9. Click OK. 

Historical profiles appears in the profile tree.

10. Select the required historical profile, for example HEA120, in the profile
tree.

11. Go to the User attributes tab and set Value of Historical profile to Yes. 

12. Click Update.

13. Repeat the steps 10 and 11 for any other required profiles.
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14. Click OK to close the Modify Profile Catalog dialog box.

15. Click OK in the Save confirmation dialog box to save the changes.

Next time you open the profile catalog, the profiles appear under Historical
profiles in the profile tree.

See also

Add user attributes to profiles (page 149)

Add a rule to the profile catalog (page 148)

Associate profile types with a certain material
You can define which profiles are available for steel parts, concrete parts, or
both. This affects which profile types are shown in the Select Profile dialog
box when you change the material of a part.

To define the material of a profile type:

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Select a profile type, for example, L profiles.

3. To associate the profiles with steel, right-click and select Material -->
Steel . 
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A check mark next to Steel indicates that the profiles are available for
steel parts.

4. To make the selected profiles available also for concrete parts, right-click
and select Material --> Concrete . 

If needed, you can remove the check mark by clicking the material again.

5. Click OK to close the Modify Profile Catalog dialog box.

6. Click OK in the Save confirmation dialog box to save the changes.

Delete a profile from the profile catalog
1. On the File menu, click Catalogs --> Profile catalog to open the Modify

Profile Catalog dialog box.

2. Select the profile that you want to delete.

3. Right-click and select Delete Profile.

4. Click OK to close the Modify Profile Catalog dialog box.

5. Click OK in the Save confirmation dialog box to save the changes.

Tekla Structures will continue showing parts in model views using the deleted
profiles until you modify the parts or reopen the model. After that, the parts
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having profiles that are not available in the profile catalog, are shown as sticks
without a profile.

If the deleted profile used a custom custom cross-section definition, delete it
separately to also remove the cross-section from your model.

See also

Customize the profile catalog (page 146)

Import and export profiles
Use importing and exporting for merging profiles across profile catalogs.
Profile catalogs are imported and exported as .lis files, sketched profiles
as .uel files, and user-defined parametric profiles as .clb files.

When you export an entire profile catalog, Tekla Structures creates three
separate files: profiles.clb, profiles.lis and rules.lis. The .clb file
contains parametric profile definitions, if they are used in the profiles in the
catalog, otherwise it is empty. The profiles.lis file includes the actual
profile definitions and the rules.lis file the branch rules. When you export a
branch of a profile catalog, the branch name is attached as prefix to the file
names.

Importing and exporting is useful when you:

• upgrade to a newer version of Tekla Structures and want to use a
customized profile catalog from a previous version

• want to combine profile catalogs that are stored in different locations

• want to share profile catalog information with other users

• want to combine profile catalogs across different environments.

Limitations

• You cannot import or export hard-coded profiles such as PROFILE_ZZ,
PROFILE_CC, and PROFILE_CW.

• You cannot import profiles that do not have a defined cross section.

• If you have used a sketched profile or a user-defined parametric profile as
the cross section for a fixed profile, you also need to import the sketched
profile or the user-defined parametric profile to the new model.

TIP You can also download or share profiles using Tekla Warehouse.

See also

Export an entire profile catalog (page 157)

Export a part of the profile catalog (page 157)
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Import profile catalog items (page 156)

Import and export sketched profiles (page 161)

Import profile catalog items
Tekla Structures has five types of profile catalog items: fixed profiles, hard-
coded parametric profiles, sketched profiles, user-defined parametric profiles,
and rule sets. Profiles and rule sets are imported to Tekla Structures models
as .lis files, sketched profiles as .uel files, and user-defined parametric
profiles as .clb files.

If you are importing an entire profile catalog or a branch, we recommend that
you save the related files in a separate folder. This makes the import process
faster.

1. Open the model to which you want to import profile catalog items.

2. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

3. Click Import to import a single file, or Import Directory to import the
contents of a file folder.

4. Select the import file or the import folder.

5. Click OK. Tekla Structures checks if there are duplicates in the profile
names in the import file compared to the profile catalog.

a. If the Review import items dialog box appears, there are duplicate
profile names and you must select each duplicate and assign the
action you want to perform with the following buttons: 

• Leave: The existing profile item is not replaced and the profile
definitions in the import file are ignored.

• Merge: Profile properties that are different in the import file are
added to the existing profile. All the other properties remain
unchanged.

Use this option to import only certain elements of the profile
catalog, such as user attributes.

• Replace: The existing profile item is replaced with the imported
profile item.

• If you leave Unknown as the action for a profile item, it is not
imported.

You can select more than one profile item at a time by using the Shift
and Ctrl keys and assign the same action to the entire selection.

NOTE Each cross section definition has a unique name and ID
number. If during an import, a cross section with the same
name but different properties is found in the existing profile
catalog, the cross section being imported is renamed by
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adding an incremental number at the end of the existing
name.

b. After you have selected the actions, click Continue to perform them.

6. Click OK to close the Modify Profile Catalog dialog box.

7. Click OK in the Save confirmation dialog box to save the changes.

See also

Import and export profiles (page 155)

Export an entire profile catalog (page 157)

Export a part of the profile catalog (page 157)

Import sketched profiles (page 161)

Units used in import and export (page 159)

Export an entire profile catalog
Profile catalogs are exported from Tekla Structures models as .lis, .uel,
and .clb files.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Click Export.

3. Browse for the folder where you want to save the export files. 

By default, the files are saved to the current model folder. For faster
profile catalog import, we recommend that you create a separate
subfolder for the catalog files.

4. Click OK to close the Modify Profile Catalog dialog box.

See also

Import and export profiles (page 155)

Export a part of the profile catalog (page 157)

Example of profile export file (page 158)

Import profile catalog items (page 156)

Units used in import and export (page 159)

Export a part of the profile catalog
If you do not want to export an entire profile catalog, you can export a branch
of the profile tree, meaning all the profiles grouped under one rule, or a single
profile. Profiles and rule sets are exported from Tekla Structures models
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as .lis files, sketched profiles as .uel files, and user-defined parametric
profiles as .clb files.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Select profiles to be exported. 

• To export a branch of the profile tree, right-click the branch and select
Export Profiles.

• To export a single profile, right-click the profile and select Export
Profile.

3. Browse for the folder where you want to save the export files. 

By default, the files are saved to the current model folder.

If you are exporting a single profile, enter a name for the file.

4. Click OK.

5. Click OK to close the Modify Profile Catalog dialog box.

See also

Export an entire profile catalog (page 157)

Example of profile export file (page 158)

Import profile catalog items (page 156)

Units used in import and export (page 159)

Example of profile export file

The export .lis file is divided into specific sections.

The first row in the file is PROFILE CATALOG EXPORT VERSION = n, where n
is the version number.

WARNING Do not delete this row. If the row does not appear in the file, the
import is canceled.

The next section defines the hierarchical tree structure that is used to display
the contents of the catalog.

The next section contains the profiles.

Create and distribute customized settings, user
interface elements, and catalogs

158 Customize the profile catalog



Fixed profiles

Fixed user-defined profiles

Fixed user-defined profiles can have more than one cross section. The profile
type for fixed user-defined profiles is 998. SUB_TYPE refers to the name of the
cross section definition. When importing fixed user-defined profiles, the
relevant cross section definitions must be in the same import file as the
profile.

Cross section definitions

See also

Export an entire profile catalog (page 157)

Export a part of the profile catalog (page 157)
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Units used in import and export

The table below lists the units Tekla Structures uses when importing and
exporting profile catalogs and material catalogs.

Type Unit (if blank, no unit)
Boolean  
Integer  
String  
Ratio  
Strain  
Angle degree
Length mm
Deformation mm
Dimension mm
Radius of inertia mm
Area mm2

Reinforcement area mm2

Transverse reinforcement area mm2/m
Area/unit length mm2/m
Volume mm3

Section modulus mm3

Moment of inertia mm4

Torsion constant mm4

Warping constant mm6

Force N
Weight kg
Distributed load N/m
Spring constant N/m
Mass/length kg/m
Surface load N/m2

Strength N/m2

Stress N/m2

Modulus N/m2

Density kg/m3

Moment Nm
Distributed moment Nm/m
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Type Unit (if blank, no unit)
Rotation spring constant Nm/rad
Temperature K (oC)
Thermal dilation coefficient 1/K (1/oC)
Factor  

See also

Import profile catalog items (page 156)

Import a material catalog (page 144)

Export an entire profile catalog (page 157)

Export an entire material catalog (page 145)

Import and export sketched profiles
To use a sketched profile in other Tekla Structures models, you have to export
the profile to a file (*.uel), and then import the file into another Tekla
Structures model.

We recommend that you use the profile catalog to import and export sketched
profiles. You can also use the Applications & components catalog to import
sketched profiles together with related custom components.

See also

Import sketched profiles (page 161)

Export sketched profiles (page 162)

Import sketched profiles
After you have exported sketched profiles to a file, you can import them to
another Tekla Structures model.

1. Open the Tekla Structures model you want to import to.

2. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

3. Click Import.

4. In the Import Profile Catalog dialog box, select *.uel from the Filter list.

5. Select the file to import.

6. Click OK.

7. Click OK to close the Modify Profile Catalog dialog box.

8. Click OK in the Save confirmation dialog box to save the changes.
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TIP To automatically import all *.uel files from a folder when creating a new model,
use the advanced option XS_UEL_IMPORT_FOLDER.

See also

Export sketched profiles (page 162)

Export sketched profiles

1. Open the Tekla Structures model you want to export from.

2. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

3. Right-click the profile you want to export and select Export Profile.

4. In the Export Profile Catalog dialog box, enter a name for the export file
in the Selection box.

5. If you want to save the export file to a specific location, browse for the
folder. 

By default, Tekla Structures saves the export file in the current model
folder.

6. Click OK.

See also

Import sketched profiles (page 161)

Create your own profiles
You can create your own profiles and save them in the profile catalog.

Use any of the following methods to create user-defined profiles in Tekla
Structures:

Profile type Creation methods
Fixed profile • Create user-defined cross sections

(page 163)

• Create a fixed profile (page 169)

• Create a fixed profile by copying
(page 170)

• Create a fixed profile based on a
parametric profile (page 171)

Parametric profile • Create parametric profiles
using .clb files (page 172)
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Profile type Creation methods
• Create parametric profiles by

sketching (page 180)
Parametric profile with variable cross
sections

• Create parametric profiles with
variable cross sections (page 205)

Create user-defined cross sections
User-defined cross sections can be used for creating fixed profiles. Define the
needed cross sections before creating the profile.

Use any of the following methods to define a cross section:

• Define a cross section using polygon.

Use this method to create a cross section with fixed dimensions.

• Define a cross section using a plate.

Use this method if you have a contour plate in the model.

• Define a cross section using a DWG file.

Use this method if you have a .dwg file of the profile you want to define.

Define a cross section using polygon
Define a cross section by picking the shape of the cross section.

1. On the File menu, click Catalogs --> Define profiles --> Define cross
section using polygon.

2. Define a cross section without or with inner contours. 

• To create a cross section with no inner contours:

a. Pick the corner points of the cross section to define the shape.
Start at the bottom-right corner and pick the points counter
clockwise.

b. Pick the start point and click the middle mouse button to close the
shape.
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c. Pick the center point of the cross section.

TIP To make it easier to define the shape, insert a reference
model of the cross section in the model, and use the
reference model as a basis for picking the cross section
shape.

Alternatively, you can create a few construction lines or
points in the model and use them to define the cross section
shape.

If you do not have any actual points to pick, picking the
center point of the cross section becomes difficult. This is
because the cross section shape disappears after you have
clicked the middle mouse button to close the shape.

• To create a cross section with inner contours:

a. Pick the corner points of the cross section to define the shape.

b. Pick the start point to close the shape.

c. Pick the corner points of the cross section inner contour.

d. Pick the start point to close the shape

e. Repeat until you have picked all inner contours.

f. Click the middle mouse button.
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g. Pick the center point of the cross section.

3. When the User Profile Cross Section dialog box appears, enter a name
for the cross section.

4. Click OK to close the User Profile Cross Section dialog box.

5. Click OK in the Save confirmation dialog box to save the changes.

You can then use this cross section when you add a new profile to the profile
catalog. The Profile type will be User-defined, fixed.

Define a cross section using a plate
You can define a cross section using a contour plate.

1. Create a contour plate that includes all the chamfers.

2. On the File menu, click Catalogs --> Define profiles --> Define cross
section using plate. 

The Profile Cross-Section from Plate (10) dialog box appears.

3. On the Parameters tab, enter a name in the Section name and Profile
name boxes. 

Other properties are optional.

4. Click OK.

5. Select the contour plate. 

Tekla Structures creates the cross section with the shape of the contour
plate.

You can then use this cross section when you add a new profile to the
profile catalog. The Profile type will be User-defined, fixed.

Properties: Profile cross-section from plate (10)

Use the Parameters tab to define the profile properties in the Profile cross-
section from plate (10) component.
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Option Description
Section name Name of the cross section shown in

the Modify Profile Catalog dialog
box.

If you leave this box empty, no profile
is created.

Profile name Name of the profile shown in the
Beam properties, and in the Modify
Profile Catalog dialog box.

If you leave this box empty, no profile
is created.

Save to The location of the profile catalog.

Select one of the following options:

• Model directory: The current
model folder.

• Global
directory: ..\ProgramData
\Trimble\Tekla Structures
\<version>\environments
\<environment>\profil

• Do not save: Does not save the
profile. This is useful for testing.

Min distance between points The minimum distance between the
corner points of the cross section.

To create simpler drawings of
complicated cross sections, increase
this value.

Center point offset The origin of the plate defines the
location of the profile reference line.

Enter an offset value to move the
reference line, relative to the cross
section.

Coordinate system Select one of the following options:

• Use local

• Use global xy-plane
Mirroring Select one of the following options:

• Do not mirror

• Mirror to x-direction

• Mirror to y-direction

• Mirror to x- and y-direction
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Define a cross section using a DWG file
If a cross section is available in DWG format, you can import the cross section
and add it as a DWG profile to the profile catalog.

Tekla Structures supports DWG files that have been created using version
ACAD2012 or earlier.

Before you start defining a cross section using a DWG file:

• Save the outline of the cross section as a DWG file. Ensure that the DWG
file only contains the outline of the profile.

• Make sure that the cross section is created as a closed polyline.

• Make sure that the outline consists of only one closed polyline. You cannot,
for example, define holes to your cross section with this method. If you
need holes or openings, use the polygon or the plate creation method.

• Remove hatching and unnecessary lines from the DWG file. Tekla
Structures imports all the lines it finds in the DWG file.

• If there are blocks in the DWG file, they must be exploded.

1. Open a model.

2. On the File menu, click Catalogs --> Define profiles --> Define cross
section using DWG file. 

The DWG Profile to Library (6) dialog box appears.

3. On the Parameters tab, browse for the DWG file.

4. Define the cross section properties.

5. Click OK.

6. In the model, pick the start and the end points of the cross section to be
imported. 

Tekla Structures imports the cross section and places the profile reference
line at the origin of the DWG file.

You can then use this cross section when you add a new profile to the
profile catalog. The Profile type will be User-defined, fixed.

Properties: DWG Profile to Library (6)

Use the Parameters tab to define the profile properties in the DWG profile to
library (6) component.

Option Description
Input file Browse for the DWG file to be

imported.
Section name Name of the cross section shown in

the Modify Profile Catalog dialog
box.
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Option Description
Profile name Name of the profile shown in the

Modify Profile Catalog dialog box.
Save to The location of the profile catalog.

Select one of the following options:

• Model directory: The current
model folder.

• Global
directory: ..\ProgramData
\Trimble\Tekla Structures
\<version>\environments
\<environment>\profil

• Do not save: Does not save the
profile. This is useful for testing.

Min distance between points The minimum distance between the
corner points of the cross section.

To create simpler drawings of
complicated cross sections, increase
this value.

Center point offset The origin of the plate defines the
location of the profile reference line.

Enter an offset value to move the
reference line, relative to the cross
section.

Modify a user-defined cross section
You can modify cross sections that have been defined using a polygon, a plate,
or a DWG file.

1. On the File menu, click Catalogs --> Define profiles --> Edit Polygon
Cross Section. 

The Modify Cross Section dialog box appears.

2. Select the cross section you want to modify.

3. Modify the cross section point properties. 

• Number refers to each point picked when the cross section was
created, in numerical order. The first point picked is 1, the second 2,
and so on.

• Chamfer refers to the chamfer shape.
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• x: and y: apply to the chamfer type. For example, if you want the
chamfer to be equal on both sides of the angle, only enter a value for
x:.

For an uneven chamfer, enter values for x: and y:.

4. Click Update.

5. Click OK to close the Modify Cross Section dialog box.

6. Click OK in the Save confirmation dialog box to save the changes.

TIP If you want to delete a cross section, select the cross section and click Delete.

Create fixed profiles
You can create new fixed profiles either from scratch or by copying an existing
one. You can also convert a parametric profile into a fixed one.

Create a fixed profile
You can create fixed profiles with a single cross section or with multiple cross
sections. Note that cross sections affect the total weight of the profile.

WARNING If you create a profile with multiple cross sections, create the
cross sections with the same number of corner points and in the
same order.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Right-click anywhere in the profile tree and select Add Profile. 

A new fixed profile with the name PROFILE1 is created.

3. Change the profile name by entering a new name in the Profile name
box. 

The profile name must be in upper case letters, with no spaces. Tekla
Structures automatically converts lower case letters to upper case letters.

4. In the Profile type list, select User-defined, fixed.

5. In the Profile subtype list, select the cross section you want to use. 

If you have created your own user-defined cross sections (page 163), you
can use one of them.

6. Under Equivalent type, select a profile type that matches the new cross
section as closely as possible. This is important because some
connections only work for certain types of profiles. 

The equivalent type and the profile dimensions, such as height and width,
affect which connections can be applied to the profile. An unsuitable
equivalent type or missing dimension values may result in problems with
connections.
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7. Click Update.

8. Modify the dimension values. 

Always enter values for the dimensions Height h and Width b, as these
values affect how Tekla Structures displays the profiles. If the values are 0,
the part is drawn as a line.

9. Under Cross section, define a relative location for each cross section:

a. In the Number list, select the number of the cross section.

b. In the Relative location box, enter the location of the cross section. 

This value indicates the location of the cross section along the axis:
0.0 for the start end and 1.0 for the second end. If you only have a
single cross section, select 1 for Number and enter 0.000 for
Relative location.

c. Click Update after defining each cross section.

10. Click Add to add more cross sections, if needed.

11. If you want to use a different cross section in the profile, select a new one
from the Profile subtype list.

12. If you want to remove a cross section, select the cross section from the
Number list and click Remove.

13. Click OK to close the Modify Profile Catalog dialog box.

14. Click OK in the Save confirmation dialog box to save the changes.

Example

For a pitched profile, you need two cross sections with the same center point
height. The Relative location value is 0.0 for the first cross section, 0.5 for
the second cross section, and 1.0 for the third cross section.
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Create a fixed profile by copying
You can create new fixed profiles by modifying a copy of an existing, similar
profile.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Select a fixed profile that is similar to the one you wish to create.

3. Right-click and select Copy Profile. 

A new profile with the name <existing_profile_name COPY> is created.

4. Change the profile name by entering a new name in the Profile name
box. 

The profile name must be in upper case letters, with no spaces. Tekla
Structures automatically converts lower case letters to upper case letters.

5. Modify the profile properties on the General, Analysis, and User
attributes tabs. 

WARNING Under Equivalent type, select a profile type that matches
the new cross section as closely as possible. This is important
because some connections only work for certain types of
profiles.

Always enter values for the dimensions Height h and Width
b, as these values affect how Tekla Structures displays the
profiles. If the values are 0, the part is drawn as a line.

The equivalent type and the profile dimensions, such as
height and width, affect which connections can be applied to
the profile. An unsuitable equivalent type or missing
dimension values may result in problems with connections.

6. Click Update.

7. Click OK to close the Modify Profile Catalog dialog box.

8. Click OK in the Save confirmation dialog box to save the changes.

Create a fixed profile based on a parametric profile

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Select a parametric profile from the list.

3. Right-click and select Add Profile. 

A new standard fixed profile is created, and it has the profile values of the
parametric profile.
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Modify a fixed profile
If necessary, you can modify existing fixed profiles using the profile catalog.
Note that the fixed profiles conform to industry standards, and you should not
modify them unless you are an administrator.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Select a fixed profile  in the tree and modify its properties. 

• The General tab contains information on profile types and
dimensions.

• The Analysis tab contains information on the properties used in
structural analysis. The structure can be analyzed with different
analysis software.

• The User attributes tab is for viewing or entering user attributes for
profiles.

3. When you have finished modifying the profile, click Update.

4. Click OK to close the Modify Profile Catalog dialog box. 

Tekla Structures asks if you want to save the changes to the model folder.

5. Click OK in the Save confirmation dialog box to save the changes.

Create parametric profiles using .clb files
You can create new parametric profiles using .clb files.

Follow the example workflow below to create a parametric profile with .clb
files.

How the .clb, components.clb and profitab.inp files work together

When you create new parametric profiles using this method, you need the
following three files:

• .clb

This file contains the cross section definitions. Create a new .clb file in
the ..\ProgramData\Trimble\Tekla Structures\<version>
\environments\common\inp folder for each parametric profile you
define.

• components.clb

This file contains a list of all .clb files that contain cross section
definitions. When you create a new .clb file, you need to add its file name
to the components.clb file located in the ..\ProgramData\Trimble
\Tekla Structures\<version>\environments\common\inp folder.

• profitab.inp
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This file is the link between the .clb files and the profile catalog. This file
contains a list of all parametric profiles available in Tekla Structures. The
file controls how the parametric profiles are displayed in the Modify
Profile Catalog dialog box. When you want to take a new parametric
profile into use, you must add the needed profile definitions, such as the
profile type, prefix and the unit of measurement, to the profitab.inp
file. The profitab.inp file is located under the environment folder
in ..\ProgramData\Trimble\Tekla Structures\<version>
\environments\<environment>\. The exact file location may vary
depending on the folder structure of your environment files .

Tekla Structures searches for the profitab.inp file in the standard
search order and then from the folder indicated by the advanced option 
XS_PROFDB.

Define the shape and point coordinates of the profile
Start by defining the shape and point coordinates of the new profile.

1. Design the profile on a paper.

a. Draw the cross section outline.

b. Add the needed corner points.

c. Add the needed dimensions.

d. Place the y-z coordinate axis center point to the middle of the cross
section. 

2. Define the y and z coordinate directions. For example: 

Create and distribute customized settings, user
interface elements, and catalogs

173 Customize the profile catalog



• positive y axis: up

• negative y axis: down

• positive z axis: on the right

• negative z axis: on the left

3. Define the y and z vectors. For example: 

• y1, y2, y3

• z1, z2, z3
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4. Make coordinate pairs to the points. 

Assign y, z vector pairs to each point. Start from the lower right corner and
define the points in the counter clockwise order. For example:

• point 1: y1 z3

• point 2: y2 z3

• point 3: y3 z2

• point 4: y3 z1

• point 5: y1 z1
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Create the .clb file
After defining the shape and point coordinates of the profile, you can continue
by creating the actual .clb file.

1. Create a new .clb file using any standard text editor, for example
Microsoft Notepad.

2. Define a library name that will be used in the profitab.inp file for this
profile. 

For example:

library_id "1Gen"
3. Define a cross section name that will be used in the profitab.inp file

for this profile. 

For example:

4. Define the dimensions of the cross section. 
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For example:

5. Define the coordinates of the profile. 

The coordinates must be the same as the y and z vectors that you defined
earlier. Define the default values. For example:

6. Define the geometry of one or several faces of the profile. 

For example:
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NOTE The index number refers to the point number: 0=start point of
the beam, 1=end point of the beam.

7. Save the .clb file in the ..\ProgramData\Trimble\Tekla
Structures\<version>\environments\common\inp folder.

8. Open the components.clb file.

9. Add your profile definition to the components.clb file by adding the
following line: 

Include
”new_file_name.clb” // give comment
10. Save the components.clb file.

Add profile definitions to the profitab.inp file
Before taking the new parametric profile into use, you must add the needed
profile definitions to the profitab.inp file.

1. Find the profitab.inp file, located under the environment folder
in ..\ProgramData\Trimble\Tekla Structures\<version>
\environments\<environment>\.

2. Copy the profitab.inp file to a model, project or firm folder.

3. Open the file in the new location using a standard text editor, such as
Microsoft Notepad.

4. Under a suitable category, add a new line for the profile definition. 

Use the following syntax:

Prefix
! Type ! SO ! Z ! MI ! MA ! G3-NAME ! Z3-NAME !
5. Save the file. 

The profile is now available in the profile catalog. You may have to restart
Tekla Structures for the change to take effect.

Example

An example of a profile definition:

PNL_A
! USER ! 0 ! ! 2 ! 3 !1Gen.RectChamfer !h*b-[c]

Properties used in profitab.inp
Use the following properties when you define new parametric profiles using
the profitab.inp file:
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Property Description
Prefix Prefix of the parametric profile. The

prefix is shown in the profile catalog.

For example, PNL_A.
Type Type of the parametric profile.

The profile types are/include the
following:

I, L, Z, U, PL, D, PD, P, C, T, HK, HQ, ZZ,
CC, CW, CU, EB, BF, SPD, EC, ED, EE,
EF, EZ, EW, 102, 103, 104, 105, 106,
USER

For example, in the default
environment, parametric profiles with
prefixes PD, EPD, CHS, CFCHS, O, Ø,
and TUBE all group under the type
PD, and appear under Circular
hollow sections in the profile
catalog.

SO Sorting order. The options are:

• -1: Decreasing sorting order

• +1: Increasing sorting order

• 0: No sorting order

• -2: Name increasing, value
decreasing

• +2: Value increasing, name
decreasing

For example, if your profile is
PLT200*10 or PLT10*200 and the
sorting order is +2, the result in the
output (such as a report) for both
cases is PLT200*10. If the sorting
order is -2, the result for both cases
is PLT10*200.

Z Unit of measurement. The options
are:

• 0: millimeters

• 1: inches

• 2: feet

• 3: centimeters

• 4: meters
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Property Description
MI Minimum number of parameters you

can use with the parametric profile.

For example, the rectangular hollow
section SHS has the following Profile
subtypes: h*t, h*b*t, h1*b1-
h2*b2*t. If you define SHS with a
minimum of two and a maximum of
two parameters, you will only have
the option h*t available in the Select
Profile dialog box.

MA Maximum number of parameters you
can use with the parametric profile.

G3-NAME Refers to a cross section file (.clb
file).

Can be a combination of a library id
and the name of a cross section,
separated by a full stop. For example, 
1Gen.RectChamfer.

Z3-NAME Defines how the profile parameters
relate to the parameters in the cross
section file.

Parameters in the order of
appearance in the .clb file, optional
parameters in square brackets. For
example, h*b-[c].

Can also be the name of the detailing
component.

Create parametric profiles by sketching
You can create parametric user-defined profiles by sketching. You can change
the dimensions of parametric profiles each time you use them in a model.

• Use the cross section sketch editor to create and modify sketched profiles.

• The Sketch Browser shows the objects of a sketched profile.

• Use the Variables dialog box to define the properties of a sketched profile.

Open the sketch editor

1. Open a Tekla Structures model.

2. On the File menu, click Editors --> Define cross section in sketch editor.
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Tekla Structures opens the sketch editor, the Sketch Browser, and the
Variables dialog box.

When you first open the sketch editor, the view is empty. The grid
coordinates and labels that you see in the sketch editor depend on the
grid properties of your actual Tekla Structures model.

Sketch Browser
The Sketch Browser shows the objects (lines, arcs, circles, constraints,
dimensions, and chamfers) of a sketched profile in a hierarchical, tree-like
structure. The Sketch Browser automatically opens when you open the
sketch editor.
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When you click an object in the sketch editor, Tekla Structures highlights the
object in the Sketch Browser, and vice versa.

The Sketch Browser displays the following information about a sketched
profile:

• Extrusion type (0, 1, or 2) and thickness of the sketched profile

• Lines, arcs, and circles

• Constraints

• Distances and dimensions and their values

• Chamfers and their type (0=None, 1=Line ... 7=Line and arc) and
dimensions.

Variables in sketched profiles
Use the Variables dialog box to define the properties of a sketched profile.
Variables can define fixed properties, or they can include formulas, so that
Tekla Structures calculates the property value each time you use the profile in
a model.
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The Variables dialog box automatically opens when you open the sketch
editor.

NOTE The Variables dialog box functions the same way as the
corresponding dialog box in the custom component editor. For more
information on how to use variables, see .

Sketch the outline of a profile
When you create a new sketched profile, start by sketching the outline and the
holes of the profile using lines, arcs, and circles.

Ensure that you create a closed shape, unless you are creating a profile of a
consistent thickness, such as a cold-rolled profile.

Sketch a polyline
You can create line segments in the sketch editor by picking points. Tekla
Structures automatically creates coincident constraints between the line
segments and displays a chamfer symbol where line segments meet.

1. Open the sketch editor. (page 180)

2. Click the Sketch polyline button: .

3. Pick points to create each line segment.

4. Click the middle mouse button to create the polyline. 
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Sketch an arc
You can create an arc in the sketch editor by picking three points.

1. Open the sketch editor. (page 180)

2. Click the Sketch arc button: .

3. Pick three points to define the arc. 

TIP You can use the advanced option XS_CS_CHAMFER_DIVIDE_ANGLE to
define the smoothness of the arc.

Sketch a circle
You can create a circle in the sketch editor by picking two points.

1. Open the sketch editor. (page 180)

2. Click the Sketch circle button: .

3. Pick a point to indicate the center of the circle (1).

4. Pick a point to indicate the radius of the circle (2). 
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Refine the shape of a sketched profile by adding a constraint
After you have sketched the outline of a profile, use constraints to refine your
sketch and lock the shape. For example, you can straighten lines, create 90
degree angles, force lines to meet, close the shape, and add chamfers in
corners.

To straighten the entire profile, use horizontal and vertical constraints in
conjunction with other constraints. Although the shape is locked, you can still
rotate the profile in the model.

Add a parallel constraint
You can force two lines in a sketched profile to be parallel to each other.

Before you start, sketch the outline of the profile in the sketch editor.
(page 183)

1. Click the Parallel constraint button: .

2. Select a line in the sketch (1).

3. Select another line in the sketch (2). 
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Add a perpendicular constraint
You can force a line in a sketched profile to be at a 90 degree angle to another
line you select. The lines do not have to intersect.

Before you start, sketch the outline of the profile in the sketch editor.
(page 183)

1. Click the Perpendicular constraint button: .

2. Select a line in the sketch (1).

3. Select another line in the sketch (2). 

Add a coincident constraint
You can force two lines in a sketched profile to start or end at the same point,
by extending or shortening one or both lines. The lines do not have to
intersect.

NOTE Tekla Structures automatically creates coincident constraints

• where two lines meet.

• between line segments when you draw them with the Sketch
polyline tool.

• between the start of the first line segment and the end of the last
line segment in a shape, if they are within a certain distance of
each other.

Before you start, sketch the outline of the profile in the sketch editor.
(page 183)

1. Ensure that the Snap to end points  snap switch is active.

2. Click the Coincident constraint button: .

3. Pick the end of the first line (1).

4. Pick the end of the second line (2). 
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Add a fixed constraint
You can lock the position and angle of a line in a sketched profile so that other
constraints do not affect it.

Before you start, sketch the outline of the profile in the sketch editor.
(page 183)

1. Click the Fixed constraint button: .

2. Select a line in the sketch.

Add a horizontal constraint
Use horizontal constraints to force a line in a sketched profile to be parallel to
the local x axis. Tekla Structures automatically creates horizontal constraints
when you create lines that are nearly horizontal.

Before you start, sketch the outline of the profile in the sketch editor.
(page 183)

1. Click the Horizontal constraint button: .

2. Select the lines you want to straighten (1, 2). 
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Add a vertical constraint
Use vertical constraints to force a line in a sketched profile to be parallel to the
local y axis. Tekla Structures automatically creates vertical constraints when
you create lines that are nearly vertical.

Before you start, sketch the outline of the profile in the sketch editor.
(page 183)

1. Click the Vertical constraint button: 

2. Select the lines you want to straighten (1, 2). 

Delete a constraint
You can delete constraints from sketched profiles.

1. Click  to open the Sketch Browser.

2. Select the constraint you want to delete.

3. Right-click and select Delete.

4. Click Refresh.

Add dimensions to a sketched profile
After you have sketched a profile, use dimensions to make different distances
in the profile parametric. You can use these dimensions to define the size of
the profile when you use it in a model.

Tekla Structures also adds the dimensions you create to the list of variables
that you can use in calculations.

NOTE Do not create too many dimensions in a sketch, or the dimensions will not be
able to adjust when the values are changed.

In the following example, if you create the dimension marked in red, the
dimension b1 will no longer work:
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Add a radial dimension to a sketch
You can create a radial dimension for an arc or a circle in a sketched profile.

Before you start, sketch the outline of the profile in the sketch editor.
(page 183)

1. Click the Sketch radial dimension button: .

2. Select the arc or circle. 

Add an angle dimension to a sketch
You can create an angle dimension between two lines in a sketched profile.
The angle is calculated counter clockwise from the first line you select.

Before you start, sketch the outline of the profile in the sketch editor.
(page 183)

1. Click the Sketch angle dimension button: .

2. Select the first line (1).

3. Select the second line (2). 

Create and distribute customized settings, user
interface elements, and catalogs

189 Customize the profile catalog



TIP If you are unable to see the angle symbol, scroll with the mouse
wheel to zoom in.

Add a dimension between two points in a sketch
You can add a dimension to a sketched profile, between two points you pick.

Before you start, sketch the outline of the profile in the sketch editor.
(page 183)

1. Click the Sketch free dimension button: 

2. Pick a point to indicate the start point of the dimension (1).

3. Pick a point to indicate the end point of the dimension (2).

4. Pick a point to indicate the location of the dimension lines and text. 

Add a horizontal dimension to a sketch
You can add a horizontal dimension to a sketched profile, between two points
you pick.

Before you start, sketch the outline of the profile in the sketch editor.
(page 183)

1. Click the Sketch horizontal dimension button: .

2. Pick a point to indicate the start point of the dimension (1).

Create and distribute customized settings, user
interface elements, and catalogs

190 Customize the profile catalog



3. Pick a point to indicate the end point of the dimension (2).

4. Pick a point to indicate the location of the dimension lines and text. 

Add a vertical dimension to a sketch
You can add a vertical dimension to a sketched profile, between two points
you pick.

Before you start, sketch the outline of the profile in the sketch editor.
(page 183)

1. Click the Sketch vertical dimension button: .

2. Pick a point to indicate the start point of the dimension (1).

3. Pick a point to indicate the end point of the dimension (2).

4. Pick a point to indicate the location of the dimension lines and text. 

Delete a dimension from a sketch
When you want to delete a dimension from a sketch, you can do it in the
sketch editor view, in the Variables dialog box, or in the Sketch Browser.

1. Select the dimension you want to delete.

2. Do one of the following: 

• In the sketch editor view or in the Sketch Browser, right-click and
select Delete.
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• In the Variables dialog box, click the Delete button.

Define positioning planes for a sketched profile
When you sketch a profile, you can define positioning planes for it. With
positioning planes you can determine the planes Tekla Structures will use for
positioning parts and components.

Part positioning planes
With part positioning planes you can determine how Tekla Structures positions
parts that have a sketched profile. These planes are used for the On plane
and At depth settings for parts, and also when placing custom components
that are bound to boundary planes.

The part positioning planes are displayed in blue:

The On plane options Left and Right are set according to the vertical blue
planes, and the Middle option is halfway between them.

The same principle applies to the At depth setting: the Front and Behind
options are set according to the horizontal blue planes, and the Middle option
is halfway between them.

Example

You can define part positioning planes so that an asymmetric profile will be
positioned according to its web only. In the following example, the Middle
option is illustrated in gray dotted lines:
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(1) Middle option

Connection positioning planes
With connection positioning planes you can determine how Tekla Structures
positions components in relation to the component main part that has a
sketched profile.

The connection positioning planes are displayed in green:

Example

The following image shows the default connection positioning planes of a
double tee slab that was created as a sketched profile. The green line
illustrates the default connection positioning planes.
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To place connections according to the location of the stems of the double tee,
move the connection positioning planes as shown below.

Show and hide positioning planes

To show or hide the positioning planes, do one of the following:

To Do this
Show or hide part positioning planes

Click .
Show or hide connection positioning
planes Click .

Move positioning planes
You can move the positioning planes by moving their handles. Note that if you
move the handles away from the outmost corners of the sketched profile, you
must bind them by adding a dimension to each handle. Otherwise the
positioning will not function correctly in the model.

1. Click the positioning plane to display the handles. 

The handles are displayed in pink. By default, the handles are at the
outmost corners of the sketched profile. For example:

2. Click a handle to select it. 

NOTE The same handle controls both the vertical and horizontal plane,
so you can move them both at the same time.
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3. Move the handle like any other object in Tekla Structures. 

For example, right-click and select Move.

4. If the handle is not at the outmost corner of the profile, add a dimension
between the handle and the corner.

Example

In the following examples, the left handle of the positioning plane has been
bound by using a horizontal dimension (b1):

Revert to default positioning planes
You can revert back to the default positioning planes of a sketched profile if
you have moved the planes.

To revert to the default positioning planes, do one of the following:

To Do this
Revert to the default part positioning
planes

1.
Click  to show the part
positioning planes.

2. Select the part positioning
planes.

3. Right-click and select Delete.

4.
Click  again to check that the
planes have reverted back to the
default.

Revert to the default connection
positioning planes

1.
Click  to show the
connection positioning planes.
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To Do this
2. Select the connection positioning

planes.

3. Right-click and select Delete.

4.
Click  again to check that the
planes have reverted back to the
default.

Check a sketched profile
You can check that the constraints and dimensions in a sketched profile work
correctly.

1. Double-click a dimension line to open the Distance Properties dialog
box.

2. Change the Value box.

3. Click Modify. 

Tekla Structures updates the profile in the sketch editor.

4. Check that the shape of the profile does not change and that the
dimensions adjust correctly.

5. Click Cancel to close the Distance Properties dialog box.

See also

Use sketched profiles in a model (page 199)

Save a sketched profile
Tekla Structures saves the sketched profiles in the current model folder, in the
xslib.db1 file, which is a library file containing custom components and
sketches. Sketched profiles are available in the Others section in the profile
catalog.

NOTE Note the following limitations when naming sketched profiles:

• You cannot use the name of a fixed profile.

• You cannot include numbers, special characters, or blank spaces in
the profile name.

• Lower case letters are automatically converted into upper case
letters.

To save a sketched profile, do one of the following:
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To Do this
Save a new profile 1.

Click Save sketch .

2. Enter a name in the Prefix box, and then click
OK.

Update an existing profile 1.
Click Save sketch .

2. Click Yes when prompted to update the
existing cross section.

Save a copy of the profile
under a different name

1.
Click Save sketch as .

2. Enter a new name in the Prefix box, and then
click OK.

See also

Import and export sketched profiles (page 161)

Modify sketched profiles
You can modify existing sketched profiles, for example, by modifying chamfers
or dimensions. You can also move corners or holes by moving the handles.
The chamfers are moved automatically when you move the handles.

Modify a sketched cross section

NOTE • You cannot change dimensions that have been calculated using
formulas in the Variables dialog box.

• Constraints may also prevent you from changing dimensions.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Open the Others branch at the end of the profile tree.

3. Right-click a sketched profile, and then select Edit profile to open the
profile in the sketch editor.

4. Double-click a sketch object to modify its properties. 

The sketch objects you can modify appear in yellow.

5. Modify the properties and then click Modify.

6. Close the sketch object properties dialog box.

7. Click the Save sketch as icon  to save the changes.
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Modify chamfers in a sketch
You can change the shape and dimensions of chamfers in a sketched profile.
For example, you can create rounded profile corners.

1. Double-click a chamfer symbol  in the sketch editor.

2. In the Chamfer Properties dialog box, change the shape and dimensions
of the chamfer.

3. Click Modify.

4. Click OK to close the dialog box.

5. Click the Save sketch as icon  to save the changes.

Set the sketch thickness
If you have sketched an open shape, such as a cold-rolled section, you must
define the extrusion type and thickness of the sketch in the Sketch Browser.
The thickness can be either fixed or parametric.

1. In the sketch editor, sketch an open polyline (page 183).

2. Do one of the following: 

• To set a fixed thickness:

a. In the Sketch Browser, right-click Thickness and select Add
Equation.

b. Enter the value of the thickness after =.

• To define a parametric thickness:

a. In the Variables dialog box, add a new parameter variable for
Length (for example, P1).

b. In the Formula column, define the default value for the
parameter variable.

c. In the Sketch Browser, right-click Thickness and select Add
Equation.

d. Enter the name of the parameter variable (for example, P1) after
=.

3. To define the extrusion type:
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a. In the Sketch Browser, right-click ExtrusionType and select Add
Equation.

b. Enter the extrusion type number (0, 1, or 2) after =.

4. Click the Save sketch as icon  to save the changes.

Extrusion types
The extrusion type defines how a sketched profile of a consistent thickness is
extruded. When you change the thickness, the profile grows inwards,
outwards, or symmetrically in both directions, depending on the extrusion
type. You must define the extrusion type for sketches that consist of an open
polyline.

Type Description Image
0 The sketch is extruded

symmetrically to the
outside and inside of the
polyline.

(Default)

1 The sketch is extruded
to the outside of the
polyline.

2 The sketch is extruded
to the inside of the
polyline.

Use sketched profiles in a model
Once you have created a sketched profile and saved it, you are ready to use it
in the model. If you have applied constraints correctly, the shape of the profile
will be maintained when you change its dimensions.

To use a sketched profile for a new part in a model:

1. Open the part properties in the property pane. 
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For example, to open the beam properties, on the Steel tab, hold down

Shift and click .

2. Click the ... button next to the Profile box. 

The Select Profile dialog box appears.

3. Open the Others branch at the end of the profile tree.

4. Select a sketched profile.

5. If the profile is parametric, you can define its dimensions in the Value
column on the General tab.

6. Click OK to close the Select Profile dialog box.

7. Pick points to place the part in the model.

See also

Create an image of a profile (page 208)

Example: Create a symmetric C-shaped profile by sketching
This example shows how to create a sketched profile using variables.

After completing the tasks, you will have a symmetric C-shaped profile with
the dimensions b1 = b2 and h2 = h3. When you use the profile in the model,
you can change the following dimensions:

• Width (b1)

• Total height (h1)

• Height (h2)

• Thickness (P1)

• Chamfers (P2)
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Example: Sketch a C-shaped profile

Start by sketching the outline of the profile.

1. Open the sketch editor.

2. Use the Sketch polyline command to create a rough C-shaped profile. 

At this stage, the profile does not have to be symmetric or have the right
dimensions.

3. Straighten the lines using the Add horizontal constraint  and Add

vertical constraint  commands. 

4. Save the profile and name it CSHAPE.

Example: Add dimensions to the sketched profile

After sketching the outline of the profile, you can continue by adding
dimensions.

1. Use the Sketch horizontal dimension  command to create the
distances b1 and b2. 
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2. Use the Sketch vertical dimension  command to create the
distances h1, h2, and h3. 

3. In the Variables dialog box, enter the following values for the distances: 

Name Formula Value Value
type

Variable
type

Visibility Label in
dialog

box
b1 150.00 150.00 Length Distance Show Width
b2 =b1 150.00 Length Distance Hide Width
h1 300.00 300.00 Length Distance Show Height
h2 70.00 70.00 Length Distance Show Height
h3 =h2 70.00 Length Distance Hide Height

4. Ensure that Visibility is set to Show for the distances b1, h1, and h2.

5. Save the sketched profile.
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Example: Set the sketch thickness

After adding dimensions to the sketched profile, you can continue by defining
the thickness of the sketch.

1. In the Variables dialog box, do the following:

a. Click Add to add a parameter variable P1.

b. In the Formula column, enter 20.00.

c. In the Visibility column, select Show.

d. In the Label in dialog box column, enter Thickness.

2. In the Sketch Browser, set the thickness using the parameter variable P1.

a. Right-click Thickness, select Add Equation, and then enter =P1.

b. Right-click ExtrusionType, select Add Equation, and then enter =2 to
get the sketch extruded to the inside of the polyline. 

3. Save the sketched profile.

Example: Modify the chamfers of the sketched profile

After setting the thickness of the sketch, you can continue by modifying the
chamfers of the sketched profile.

1. In the sketch editor, do the following:

a. Double-click a chamfer symbol .

b. In the Chamfer properties dialog box, change the chamfer type to

Line , and then click Modify.

c. Repeat steps 1a–b for all the chamfers.

2. In the Variables dialog box, do the following:

a. Click Add to add a parameter variable P2.
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b. In the Formula box, enter 10.00.

c. In the Visibility box, select Show.

d. In the Label in dialog box box, enter Chamfer.

3. In the Sketch Browser, do the following:

a. Double-click Chamfer constraint to open the chamfer properties.

b. Right-click Chamfer X, select Add Equation, and then enter =P2.

c. Enter the same value for Chamfer Y.

d. Repeat steps 4a–c for all the chamfers. 

4. Save the sketched profile.

Example: Use the sketched profile in a model

Your sketched profile is now completed and you can use it in a model.

1. Double-click a part to open the part properties in the property pane.

2. Click the ... button next to the Profile box. 

The Select Profile dialog box appears.

3. Open the Others branch at the end of the profile tree, and select the
CSHAPE profile.

4. If needed, modify the dimensions of the profile on the General tab. 

5. Click OK to apply the changes.

6. Pick points to place the part in the model. 
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Create parametric profiles with variable cross sections
You can create parametric user-defined profiles with variable cross sections
using the Profile Editor. You can use a profile with variable cross sections like
any other parametric profile.

You can

• use a cross section with different dimensions at different locations in a
profile

• modify the variables of the cross sections and the profile

• save the profile and use it as a parametric profile through the profile
catalog

• import and export variable cross section profiles

NOTE When you use this method, only the dimensions of a variable cross
section can vary, not the actual shape of the cross section. If you want
to use several different cross section shapes in the profile, create a
fixed profile (page 169) with multiple cross sections instead.

Create a profile with variable cross sections

Before you start:

• Create a sketched profile (page 180) using the sketch editor.
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• In the Variables dialog box in the sketch editor, set Visibility to Show for
the dimensions that you want to change when using the profile in a model.

1. On the File menu, click Catalogs --> Define properties --> Define profile
with variable cross section. 

The Define Profile with Variable Cross Section dialog box opens.

2. Select the sketch you want to use as the start and end cross section of the
profile.

3. Click OK. 

The Profile Editor and the Profile preview view appear.

4. Under Cross sections of the profile, add cross sections or remove
selected cross sections by clicking Add or Remove. 

When you click Add, Tekla Structures adds a new cross section at the end
of the profile, at the location 1.0., and moves the existing cross sections
towards the start of the profile. By default, cross sections are located at
0.1 intervals in the profile.

5. Under Cross section variables, define the following: 

• The relative location of each cross section in the profile.

Use the *.Location variables. For example, start=0.00, middle=0.5,
end=1.00.

• How the cross sections are aligned in the horizontal and vertical
direction.

Use the *.HorPos and *.VerPos variables.
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• How much the cross sections are offset from the alignment.

Use the *.HorOffset and *.VerOffset variables.

6. If you have added new cross sections, check that they do not overlap any
existing cross sections.

7. Set Visibility to Show for the dimensions that you want to change when
using the profile in a model.

8. If you want to use parameter variables and equations to define the cross
section dimension, click Add variable and define the variable values.

9. Save the profile.

a. Click Save.

b. In the Save profile as dialog box, enter a unique name for the profile.

You cannot include numbers in the profile name, or use the name of
a standard profile.

c. Click OK. 

Tekla Structures saves the profile in the current model folder.

Modify a profile with variable cross sections

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Open the Others branch at the end of the profile tree.

3. Right-click a profile with variable cross sections, and then select Edit
profile to open the profile in the Profile Editor.

4. Modify the profile properties.

5. Click Save.
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Define standardized values for parametric profiles
You can define standardized values for the dimensions of parametric profiles.
The standardized values are visible in the profile catalog where you can select
suitable dimension values for the profiles.

1. Under ..\ProgramData\Trimble\Tekla Structures\<version>
\environments\<environment> folder, locate the
industry_standard_profiles.inp file. 

The exact file location may vary depending on the folder structure of your
environment files.

If there is no industry_standard_profiles.inp file in your
environment, you can use the file of the default environment.

2. Copy the industry_standard_profiles.inp file and place it in your
firm, project, or model folder.

3. Open the copied industry_standard_profiles.inp file using any
standard text editor, for example, Microsoft Notepad.

4. Modify the file. 

The file has the following format:

• profile and profile subtype

• parameters separated by spaces

• units for each parameter

• standardized values for each parameter.

Each dimension combination has its own row.

5. Save the file.

Example

For example, the standardized combinations of dimension values for a C
profile are as follows:
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Create an image of a profile
To illustrate the shape and dimensions of a profile you have created, you can
create an image of it. Tekla Structures displays the image when you browse for
profiles in the profile catalog. The image must be in Windows bitmap (.bmp)
format and can be created with any bitmap editor, for example Microsoft
Paint.

1. Take a screenshot of the profile you have drawn or sketched. 

For example, press the Print Screen (Prt Scr) key to take a screenshot of
your entire desktop. To take a screenshot of an active window, press Alt
+Print Screen. The screenshot is placed on the clipboard.

2. Open the screenshot in any bitmap editor (for example, Microsoft Paint)
and modify the image if necessary.

3. Save the image in .bmp format in the ..\ProgramData\Trimble\Tekla
Structures\<version>\Bitmaps folder. 

The file name must match the actual profile name. For example, if the
profile name is mysketch, the image must be named mysketch.bmp.

4. Restart Tekla Structures. 

The image is now shown in the profile catalog.
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5.9 Customize the shape catalog
The shape catalog contains information on shapes that are used for defining
items. Use the Shape catalog dialog box to view and modify shape properties
and metadata, to group and tag shapes, and to import and export shapes.

The shape catalog includes default shapes, for example Default and
Concrete_Default, and other shapes that are read from specific shape folders
in a set folder search order (page 358). The shapes you import (page 211),
download from Tekla Warehouse, or create using existing geometry (page 216)
in the currently open model are also shown in the shape catalog.

Shape definition files

For each shape in the shape catalog, there are two definition files that contain
the shape information:

• One .xml file for shape attributes, such as name and GUID, stored in the
\Shapes folder

• One .tez or .xml file for geometric properties, such as coordinates,
stored in the \ShapeGeometries folder

Tekla Structures searches for these subfolders and definition files in the
model, project, firm, and system folders, and in the folder defined by the
advanced option XS_DEFAULT_BREP_PATH.

The definition files of the shapes that are used for items in a model are
automatically copied to the model folder.

If you have shapes that you would like to have available in the shape catalog
for all new models that are created in your project or company, copy the
corresponding .xml and .tez files to the correct subfolders (\Shapes and
\ShapeGeometries) in the \profil folder under your project or firm folder.

NOTE If your project, company, or environment uses a common location for shapes
that are used in several Tekla Structures versions including 2017i and older,
use .xml format for shape geometry files. The compressed .tez files do not
work in Tekla Structures 2017i or older versions.

Group structure and other shape files

The hierarchical group structure of the shape catalog is read from the
ShapeCatalog.Groups.xml file in the model folder. Using this file, the group
structure can be shared with all users in a project preferably in the beginning
of the project.

If you modify the group structure, Tekla Structures saves the changes to the
ShapeCatalog.Groups.user.<username>.xml file in the model folder.

The *.shapecatalog and *.ShapeCatalog.Groups.xml files are used for
exporting and importing shapes and the group structure between Tekla
Structures models.
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See also

Import shapes (page 211)

Create shapes (page 216)

Work with shapes and groups in the shape catalog (page 217)

Export shapes (page 222)

Organize the shape catalog view (page 223)

Import shapes
You can import the following types of shape files: tsc, skp, dxf, dwg, ifc,
ifcZIP, ifcXML, igs, iges, dgn, stp, step, and shapecatalog.

When using other modeling software to model shapes that you want to import
into Tekla Structures, we recommend that you center parts around the origin
and direct the parts along the x axis.

From Tekla Structures models you can also import shape catalog groups
(page 217) either with the shapes as .shapecatalog files or without the
shapes as .ShapeCatalog.Groups.xml files.

1. Open the model to which you want to import shapes and/or shape
catalog groups.

2. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

3. To import shapes without the group structure to a certain group or sub-
group in the shape catalog, select the group or sub-group on the left side
of the dialog box. 

If you do not select a group, Tekla Structures imports the shapes to the
Ungrouped group.

4. Click  Import.

5. In the Import shape definitions dialog box, browse to the folder that
contains the files to be imported, select the files, and then click Open. 

Tekla Structures checks if there are duplicates in the shapes in the import
files compared to the existing shape catalog.

In the Import dialog box, you can see the Status of each imported shape
(e.g. New shape definition, Shape name already exists) and, if a shape has
already been used in the model, the Instances of the shape.

6. If shapes with the same name and GUID as the shapes being imported
already exist in the shape catalog, you can replace or keep the existing
shapes. In the Import dialog box:
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• Select the Overwrite check box for each existing shape that you want
to replace with a new, imported shape.

• Clear the Overwrite check box for each existing shape that you want
to keep unchanged.

7. Click Import in the Import dialog box. 

Importing a large file can take several minutes.

8. Click OK to complete the import. 

The groups that contain new or modified shapes are marked with  on
the left side of the Shape catalog dialog box. The new or modified shape
rows are highlighted in yellow in the list of shapes.

9. Click  Save to save changes to the shape catalog.

Shape import has three possible results:

• Tekla Structures imports the shape as a watertight solid shape. All solid
operations are available.

• Tekla Structures imports the shape as a non-solid shape. A non-solid shape
means that the object may not be watertight. For example, it has holes, or
is missing a face or an edge.

• Import fails. This can happen, for example, if the shape is very complex or
has no volume. There may also be a tolerance difference between Tekla
Structures and the original software that was used to create the shape. To
find out why the import failed, check the session history log by going to File
menu --> Logs --> Session history log.

The Solidity column in the shape catalog shows if a shape is solid or non-solid.

When you import a shape into the shape catalog, Tekla Structures creates two
files: one .xml file for shape attributes, such as the name and GUID, and
one .tez file for geometric properties, such as coordinates. The files are
saved in the current model folder under the \Shapes and
\ShapeGeometries subfolders.

The shape name that is shown in the shape catalog is determined as follows:

• If you import a .tsc or .shapecatalog file, the shape name is read from
the imported file.

• If you import other file types, the shape name is the name of the imported
file.

TIP You can also download shapes from Tekla Warehouse, or create shapes
using existing geometry (page 216) in Tekla Structures models.
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See also

Example: Import a shape from SketchUp Pro (page 213)

Compress shape geometry files (page 214)

Clean shape geometry files (page 215)

Export shapes (page 222)

Customize the shape catalog (page 209)

Example: Import a shape from SketchUp Pro
In this example, you import a solid 3D shape from Trimble SketchUp Pro to a
Tekla Structures model.

1. Create an empty model in SketchUp Pro. 

Delete any extra entities, such as the default person on the drawing area.

2. Create a group of entities. 

Although Tekla Structures supports importing separate individual entities,
we recommend you create a group of entities or a component in
SketchUp.

All SketchUp groups and components should form watertight solids.
Select the group or component and open Entity Info to check that the
selection is a solid. SketchUp solids have a volume. If there is no volume
listed, the selection is not a solid.

3. Select the group and click Solid Tools --> Union to make the group of
entities into a union of solids. 

Your group becomes a single solid volume: a solid.

4. Place the solid in SketchUp so that it lies along the positive x axis (red),
and halfway on both y (green) and z axes (blue). In Tekla Structures, the
yellow and magenta part handles will align with the x axis used in
SketchUp. 

The location and rotation of the solid in SketchUp are important, since
they determine how an item is inserted and positioned in Tekla
Structures. Different positioning in SketchUp causes an offset in Tekla
Structures.

Create and distribute customized settings, user
interface elements, and catalogs

213 Customize the shape catalog



5. Save the SketchUp file.

6. In your Tekla Structures model, open the Shape catalog dialog box and

click  Import.

7. Select the SketchUp file.

8. Click Import.

Tekla Structures imports the shape to the shape catalog and you can use it to
define the shape of an item or a concrete item.

See also

Customize the shape catalog (page 209)

Import shapes (page 211)

Compress shape geometry files
You can compress shape geometry files by converting the files from .xml
format to compressed format .tez. Using the .tez format saves disk space.

In Tekla Model Sharing models, the shape geometry files are automatically
converted from .xml to .tez when you use Tekla Structures 2018 or a newer
version.

In older versions and in models that are not shared, you can manually
compress the shape geometry files that are stored in the \ShapeGeometries
subfolder in the current model folder. The files in the \Shapes subfolder will
not be compressed.

If you have already used any of the shapes for items in the model, they will
work the same way even after compression.

NOTE Compression is a permanent action, and you cannot undo it even if you do
not save the model.

Do not compress shape geometry files if you need them in models that you
will open using Tekla Structures 2017i or an older version. The .tez files do
not work in those versions.

If your project, company, or environment uses a common location for shapes
that are used in several Tekla Structures versions including 2017i and older,
do not convert those shape geometry files to .tez format. Otherwise the
shapes will not work in all versions.

How to compress shape geometry files

To compress existing shape geometry files, either re-import the original shape
files (page 211), or use the Compress shape geometries application as
follows:

1. Open the model whose shape geometry files you want to compress.
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2. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

3. Search for the Compress shape geometries application, and then
double-click to open it.

4. In the Compress shape XML files to TEZ format dialog box, click
Compress.

5. Re-open the model.

Clean shape geometry files
If some previously imported shapes cause missing faces or edges in items or
drawings, you can clean the shape geometry files. Cleaning means that Tekla
Structures investigates and corrects the shape geometry and tries to create
solid objects. This is useful with shapes that have been imported to Tekla
Structures models prior to version 2018i.

The Shape cleaner application provides an option to create backups of the
original shape geometry files and to revert to them, if needed.

How to clean shape geometry files

To clean existing shape geometry files, either re-import the original shape files
(page 211), or use the Shape cleaner application as follows:

1. Open the model whose shape geometry files you want to clean.

2. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

3. Search for the Shape cleaner application, and then double-click to open
it. 

The Shape cleaner dialog box opens.

4. Select the shapes that you want to clean.

5. If you want to create backups of the shape geometry files, select the
Create backups from shapes before cleaning check box.

6. Click Clean. 

Tekla Structures cleans the shapes and shows how many shapes resulted
in being solid objects and how many non-solid.

If you need to interrupt the cleaning process, you can click Stop.

7. Re-open the model to see the changed shape geometry in the items in the
model.

8. If you are not happy with the result, and if you have created the backup
files, you can go back to the original shape geometry files. 

a. Open the Shape cleaner dialog box again.
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b. Select the shapes that you want to restore.

c. Click Revert.

Create shapes
In addition to importing item shapes or downloading them from Tekla
Warehouse, you can create shapes using existing geometry and parts in Tekla
Structures models. For example, you can create a shape using a single part or
several parts that have been attached to each other.

The part reference point that has the yellow handle determines the origin of
the shape. The positive global x direction determines the direction of the
shape. Later on when you create items using the shape, the shape origin and
direction will align with the yellow and magenta item handles.

The shape name is generated using the part name and part location in the
format <grid location>_<elevation>_<part name>. For example:

• 1/D_+0_FOOTING

• 3/C_+0-+3600_COLUMN

• 1-2/A-B_+3600_SLAB

If there is already a shape with the same name in the shape catalog, Tekla
Structures adds two underscore characters and a running number at the end
of the new shape name. For example, 1/D_+0_FOOTING__1.

Create a shape by using existing geometry in the model
Use this method if you want to create a new shape using an existing part, but
you do not want to delete the part or change it to an item.

1. Using parts, model the geometry from which you want to create a shape.

2. If you want to include more than one part in the shape, attach the parts to
each other.

3. On the Edit tab, click  Create shape from geometry.

4. Select the part. 

Alternatively, you can first select the part, right-click, and then select
Create shape from geometry.

Tekla Structures adds a new shape to the shape catalog (page 209).

You can then use the shape when you create items in the model. You can also
modify items and shapes further in the Geometry editing mode.
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Create a shape by converting a part to an item
When you change an existing part in the model to an item, Tekla Structures
also creates a new shape and adds it to the shape catalog.

When you change a part to an item, Tekla Structures deletes the original part
and replaces it with the newly created item in the model. The name, material,
finish, class, pour phase, and the numbering properties of the original part are
saved as the corresponding item properties. Other part type specific
properties and user-defined attributes are not saved. The objects that are
attached to the original part, such as reinforcement and surfaces, are deleted.

1. Create the parts that you want to change to an item.

2. If you want to include more than one part in the item, attach the parts to
each other.

3. On the Edit tab, click  Convert part to item.

4. Select the part. 

Alternatively, you can first select the part, right-click, and then select
Convert part to item.

Tekla Structures changes the part to an item and adds a new shape to the
shape catalog (page 209).

Work with shapes and groups in the shape catalog
The shapes in the shape catalog can be arranged to a hierarchical group
structure. The group structure is shown on the left side of the Shape catalog
and Select shape dialog boxes. In the Shape catalog dialog box, you can add,
modify, and delete groups and sub-groups, and move and copy shapes
between the groups and sub-groups.
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The group structure may vary depending on the Tekla Structures environment
you are using, or your company or project administrator may have created
and shared a group structure. The group structure is read from the
ShapeCatalog.Groups.xml file in the model folder and from the
*.ShapeCatalog.Groups.xml files in the shape subfolders in the project,

firm, and system (XS_SYSTEM) folders. Some shapes may first be in the 
Ungrouped group, but if needed, you can regroup them.

The new shapes that you create (page 216) in the model are also added to the
Ungrouped group. If you import (page 211) new shapes without the group
structure, you can select a group for the shapes. You can also group shapes by
tagging or starring (page 223) them.

The groups that are marked with  are system groups. The groups that are

marked with  are user-defined groups.

The current user-defined groups and the changes you make to the group
structure are stored in the ShapeCatalog.Groups.user.<username>.xml
file in the model folder.

Note that even if you modify the group structure, the actual definition files
(.xml and .tez) of each shape remain in the original \Shapes and
\ShapeGeometries folders.
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In the Select shape dialog box, which is used for selecting a shape for an item,

also the  Recent group is shown. It contains the latest shapes that you
have used.

Add a new group or sub-group
1. On the File menu, click Catalogs --> Shape catalog to open the Shape

catalog dialog box.

2. If you want to add a sub-group to an existing group, select the group on
the left side of the dialog box.

3. Click  New group and do one of the following: 

• To create a highest-level group, select New group.

• To add a sub-group under the selected group, select New sub-group.

4. In the New group name dialog box, type a name for the new group and
click Create.

5. Add, move, or copy shapes to the new group, or modify the shape
properties as needed. 

See the instructions below.

6. Click  Save to save the changes to the shape catalog.

Modify a group or sub-group
For example, you can rename groups and sub-groups.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

2. Select the group or sub-group that you want to modify.

3. To rename the group, do the following:

a. Right-click and select Rename.

b. In the Rename group dialog box, type the new name and click
Rename.

4. To modify group properties, such as the manufacturer or tags (page 226)
of the shapes in the group, do the following:

a. Select all shapes in the group.

b. In the property area on the right side of the Shape catalog dialog
box, modify the properties.

Create and distribute customized settings, user
interface elements, and catalogs

219 Customize the shape catalog



5. Click  Save to save the changes to the shape catalog.

Select shapes
You can use the following methods when you select shapes in the Shape
catalog dialog box.

Selecting different sets of shapes is useful when you want to export (page 222)
or add tags (page 226) to certain shapes, or otherwise modify a sub-set of
shapes.

• Use the following commands on the catalog ribbon:

• Click Select all to select all the shapes in the currently visible group.

Alternatively, you can select one shape and then press Ctrl+A.

• Click Select none to clear the current selection.

• Click Invert selection to select the currently unselected shapes and to
deselect the currently selected shapes.

• To select several consecutive shapes, select the first shape, then hold down
Shift and select the last shape.

• To select several non-consecutive shapes, select the first shape, then hold
down Ctrl and select the other shapes.

Move or copy shapes between groups
1. On the File menu, click Catalogs --> Shape catalog to open the Shape

catalog dialog box.

2. Browse to and select the group from which you want to move or copy
shapes.

3. Do one of the following: 

• To move one or more shapes to another group, select the shapes and
drag them to the other group.

The shapes are removed from the selected group.

• To copy one or more shapes to another group, select the shapes, hold
down Ctrl, and then drag the shapes to the other group.

The shapes also remain in the selected group.

• To remove one or more shapes from the selected group, select the
shapes, right-click on one of the selected shapes, and then select
Remove from group.

If the shapes only belong to the selected group, the shapes are moved
to the Ungrouped group. If the shapes also belong to any other group,
they remain in that group.
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4. Click  Save to save the changes to the shape catalog.

Modify shape properties
1. On the File menu, click Catalogs --> Shape catalog to open the Shape

catalog dialog box.

2. Browse to and select the group in which you want to modify shape
properties.

3. Select one or more shapes.

4. In the property area on the right side of the Shape catalog dialog box,
modify the shape properties. 

For example, you can add a description or tags (page 226) to the selected
shapes.

Note that you cannot rename shapes, or remove or change the solidity
information, Tekla Structures version, source file location, or GUIDs of the
shapes.

5. Click  Save to save the changes to the shape catalog.

Delete a group or sub-group, or shapes
You can delete groups, sub-groups, and shapes within the groups from the
shape catalog. You can delete both the groups and the actual shapes at the
same time, or you can delete groups and shapes separately.

Before you delete shapes, ensure that any shape you want to delete is not
used for items in your Tekla Structures model. When you delete a shape from
the shape catalog, the shape is no longer available anywhere in the model.

If you try to delete shapes that are used for items in the model or whose
definition files are not in the model folder, Tekla Structures will not delete
those shapes.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

2. Select a group or sub-group on the left side of the dialog box.

3. Do one of the following: 

• To only delete the group but not the shapes in it, right-click on the
group and select Delete.

If the shapes only belong to the deleted group, the shapes are moved
to the Ungrouped group. If the shapes also belong to any other group,
they remain in that group.
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• To delete both the group and the shapes in it, right-click on the group
and select Delete with shapes.

• To only delete certain shapes in the group, select one or more unused
model-folder shapes, right-click on one of the shapes, and then select
Delete.

4. Click Yes to confirm the deletion.

5. Click  Save to save the changes to the shape catalog.

Export shapes
You can export shapes and shape catalog groups together or separately from
each other.

1. Open the model from which you want to export shapes and/or shape
catalog groups.

2. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

3. Choose from the following options to export shapes and/or groups: 

To Do this
Export all the shapes in the catalog,
but not the group structure

On the Shape catalog ribbon, click

 Export --> Export all shapes.
Export all the shapes and groups in
the catalog

On the Shape catalog ribbon, click

 Export --> Export all shapes
with groups.

Export the group structure of the
catalog, but not the actual shapes

On the Shape catalog ribbon, click

 Export --> Export group
structure only.

Export all the shapes in a group or
sub-group

Select the group or sub-group, right-
click, and select Export shapes.

For example, you can export the
shapes in the Starred group, or
groups of tagged shapes.

Export all the shapes in a group or
sub-group and also the group

Select the group or sub-group, right-
click, and select Export shapes with
group.
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To Do this
Export a group or sub-group and its
sub-groups, but not the actual shapes

Select the group or sub-group, right-
click, and select Export group
structure only.

Export one or more individual shapes Select the shapes (page 220), right-
click, and select Export.

4. In the Export to dialog box, browse to a folder, type a name for the
export file, and then click Save. 

If you are only exporting one individual shape, browse to and select a
folder for the export file, and click Select folder in the Export to dialog
box. The shape name is used as the name of the export file.

Tekla Structures saves the export file to the selected folder. When the
export is completed, you can click Open folder to open the export folder.

The file name extension of the export file depends on the exported
content, being:

• .tsc if only one shape is exported

• .shapecatalog if several shapes or both shapes and groups are
exported

• .ShapeCatalog.Groups.xml if only the group structure is exported

TIP You can also upload shapes to Tekla Warehouse.

See also

Import shapes (page 211)

Customize the shape catalog (page 209)

Organize the shape catalog view
You can organize the shape catalog view in the Shape catalog dialog box to
suit your needs and ways of working. For example, you can hide certain
property columns, or change the order of the property columns. You can also
filter shapes and mark them with stars and tags.

Some of these methods work the same way also in the Select shape dialog
box: showing and hiding property columns, changing the order of the
columns, filtering, and starring. The Select shape dialog box opens when you
click the ... button next to the Shape box in the item properties, or in a
component dialog box, to select a shape.

The changes you make to the dialog box layout are automatically saved to the
shape_catalog.settings.UI file in the ..\Users\<user>\AppData
\Local\Trimble\Tekla Structures\<version>\Catalogs\ folder. Tekla
Structures will use the saved layout next time you open the dialog box.
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Show or hide the catalog ribbon
If needed, you can show or hide the ribbon in the Shape catalog dialog box
and in the Select shape dialog box.

By default, the ribbon is shown in the Shape catalog dialog box, but hidden in
the Select shape dialog box.

• To show the ribbon, click the down arrow  at the right end of the (Home)
ribbon title bar.

• To hide the ribbon, click the up arrow  at the right end of the (Home)
ribbon title bar.

Work with property columns in the catalog view
You can organize the shape catalog view in the Shape catalog dialog box and
in the Select shape dialog box by showing and hiding the property columns,
and by changing the order, sort order, and width of the columns.

The Star column is always visible and you cannot hide it.

To Do this
Show or hide a property column 1.

Click  Show columns to open
a list of the available property
columns.

A check mark in front of a column
name indicates that the column
is visible.

2. To show a column, click the
column name to add a check
mark in front of the column
name.

3. To hide a column, click the
column name to remove the
check mark.

Change the order of the property
columns

Drag a column header to a new
location.

Change the sort order of a property
column

Click the column header.

The arrow symbol next to the column
header indicates if the sort order is
ascending  or descending .

To sort values by two properties and
in two columns:

1. Sort by one column.
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To Do this
2. Hold down Shift and then sort by

the other column.
Resize a property column Drag the edge between this and the

following column header. For
example:

You can also click  Fit columns to
adjust the widths of the visible
columns so that the longest value in
each column is shown.

Filter shapes
You can filter shapes in both the Shape catalog dialog box and the Select
shape dialog box. You can use filtering together with the other methods, such
as sorting, to narrow down the number of shapes shown in the shape catalog
view.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box. 

Alternatively, you can use the Select shape dialog box.

2. In the Filter box, type the search term or filtering criteria.

3. Select a group or sub-group. 

Tekla Structures shows the matching shapes in the selected group.

Add stars to shapes
You can mark important or preferred shapes with stars, so that you can easily
find these shapes later. The shapes that are marked with stars appear in the
Starred group in the shape catalog. Starring is user-specific, so it is only visible
to you.

The starring settings are stored in the
shape_catalog.settings.user.<username> file in the current model
folder.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box. 

Alternatively, you can use the Select shape dialog box.

2. Browse or search for the shapes that you want to mark with stars.
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3. In the list of shapes, click the white star symbol  in the Star column for
each shape that you want to add to the Starred group. 

By default, the Star column is the first column and the star symbol is at
the beginning of each shape row.

The star symbol turns yellow  and the shape is added to the Starred
group.

4. To remove the starring from a shape, click the yellow star symbol on the
shape row. 

The star symbol turns white again and the shape is removed from the
Starred group.

Add tags to shapes
In the Shape catalog dialog box, you can add tags to shapes. Use tags to add
keywords or other metadata to the shapes.

Tags are model-specific and saved to the
ShapeCatalog.Groups.User.<username>.xml file in the current model
folder.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

2. Select the shapes (page 220) that you want to tag.

3. Type the tag in the Tags box at the bottom-right corner of the Shape
catalog dialog box, and then press Enter. 

To add several tags to a shape, type the next tag in the next tag box and
press Enter.

Each group of tagged shapes appears with the  symbol under Tags in
the list of groups.

4. To remove a tag from a shape, select the shape and click the X symbol
after the tag name in the Tags section in the property area.

5. To delete a tag completely, select the tagged group, select all the shapes
in the group, and then click the X symbol after the tag name in the Tags
section in the property area.

6. Click  Save to save the changes to the shape catalog.
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5.10 Customize the bolt catalog
The individual bolt assembly elements, such as bolts of different sizes and
lengths, nuts and washers, are listed in the bolt catalog. Each bolt assembly
then consists of these bolt assembly elements. You cannot use a bolt if it does
not belong to a bolt assembly. The bolt assemblies are listed in the bolt
assembly catalog.

Tekla Structures stores the bolt catalog information in the screwdb.db file
and the bolt assembly catalog information in the assdb.db file.

See also

How the bolt catalog and bolt assembly catalogs work together (page 227)

Manage bolts and bolt assemblies (page 228)

Import and export bolts and bolt assemblies (page 233)

Bolt length calculation (page 237)

How the bolt catalog and bolt assembly catalogs work
together

(1) The Bolt standard options are read from the bolt assembly catalog.
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(2) The bolt assembly catalog defines which bolt standard is used in the bolt
assembly.

(3) The bolt catalog contains the different bolt diameters, lengths, and other
properties used in the bolt standard.

(4) The Bolt size options are read from the bolt catalog depending on the
selected Bolt standard option.

See also

Customize the bolt catalog (page 226)

Bolt catalog properties (page 240)

Bolt assembly catalog properties (page 242)

Manage bolts and bolt assemblies
This section describes how to manage bolts and bolt assemblies using the bolt
catalog and the bolt assembly catalog. You can add, modify, and delete bolts
and bolt assemblies.

Click the links below to find out more:

Add a bolt to the catalog (page 228)

Add a stud bolt to the catalog (page 229)

Modify bolt information in the catalog (page 230)

Delete a bolt from the catalog (page 231)

Add a bolt assembly to the catalog (page 231)

Modify bolt assembly information in the catalog (page 232)

Delete a bolt assembly from the catalog (page 232)

Add a bolt to the catalog
You need to add individual bolt elements, such as bolts, nuts, and washers, to
the bolt catalog before you can define bolt assemblies and use them in a
model.

The following steps are for adding bolts, but they also apply to adding nuts
and washers.

1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt
Catalog dialog box.

2. Enter the name of the bolt in the following box: 
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You can enter a maximum of 40 characters in the name box.

3. In the Type list, select an option to define the bolt element type.

4. Define the other properties of the new bolt. 

You can enter a maximum of 25 characters in the Standard box.

Use different names for bolt, nut, washer, and stud standards to
distinguish bolt element types from each other when defining bolt
assemblies.

5. Click Add to add the bolt to the bolt catalog. 

You cannot use a bolt if it does not belong to a bolt assembly. Therefore,
we recommend checking that the catalog also includes nuts and washers
that work with the new bolt so that you can create a bolt assembly. If the
catalog does not include suitable nuts and washers, add them the same
way as you added the new bolt.

6. Click OK. 

The Save confirmation dialog box appears.

7. Select Save changes to model folder to save the changes in the
screwdb.db file in the current model folder, and then click OK.

TIP You can also add bolts by importing them to the bolt catalog.

See also

Import bolts to the catalog (page 233)

Add a stud bolt to the catalog (page 229)

Modify bolt information in the catalog (page 230)

Delete a bolt from the catalog (page 231)

Bolt length calculation (page 237)

Bolt catalog properties (page 240)

Add a bolt assembly to the catalog (page 231)

Add a stud bolt to the catalog
A stud is special type of bolt that is welded to steel parts to transfer loads
between steel and concrete. You cannot use studs unless you have defined a
stud assembly that contains the assembly's name and material.

1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt
Catalog dialog box.
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2. Enter values for the following properties: 

• Name: Name for the stud bolt.

• Type: 

• Standard: This name is needed when creating a bolt assembly for the
stud.

• Diameter: Shank diameter.

• Length: Stud length.

• Weight: Stud weight.

• top thick: Head thickness.

• top diameter: Head diameter.

The units depend on the settings in File menu --> Settings --> Options -->
Units and decimals .

3. On the File menu, click Catalogs --> Bolt assembly catalog to open the
Bolt Assembly Catalog dialog box.

4. Select the standard for the stud bolt.

5. Set all the other bolt assembly elements to None. 

6. To create studs in the model, create bolts and select the stud assembly
standard.

See also

Bolt catalog properties (page 240)

Modify bolt information in the catalog
1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt

Catalog dialog box.

2. Select a bolt from the list.
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3. Modify the properties.

4. Click Update.

5. Click OK. 

The Save confirmation dialog box appears.

6. Select Save changes to model folder to save the changes in the
screwdb.db file in the current model folder, and then click OK.

See also

Add a bolt to the catalog (page 228)

Delete a bolt from the catalog (page 231)

Bolt catalog properties (page 240)

Delete a bolt from the catalog
1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt

Catalog dialog box.

2. Select a bolt from the list. 

Use the Shift and Ctrl keys to select multiple bolts.

3. Click Delete.

4. Click OK. 

The Save confirmation dialog box appears.

5. Select Save changes to model folder to save the changes in the
screwdb.db file in the current model folder, and then click OK.

See also

Add a bolt to the catalog (page 228)

Modify bolt information in the catalog (page 230)

Add a bolt assembly to the catalog
You can add new bolt assemblies to the bolt assembly catalog. Note that the
bolt assembly can contain only bolts or studs, not both of them.

1. On the File menu, click Catalogs --> Bolt assembly catalog to open the
Bolt Assembly Catalog dialog box.

2. Enter the name of the bolt assembly in the following box: 
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3. Define the other properties of the new bolt assembly. 

You can enter a maximum of 30 characters in the Standard box. For all
the other properties, you can enter a maximum of 25 characters.

4. Click Add to add the bolt assembly to the catalog.

5. Click OK. 

The Save confirmation dialog box appears.

6. Select Save changes to model folder to save the changes in the
assdb.db file in the current model folder, and then click OK.

See also

Import bolt assemblies to the catalog (page 235)

Modify bolt assembly information in the catalog (page 232)

Delete a bolt assembly from the catalog (page 232)

Bolt assembly catalog properties (page 242)

Modify bolt assembly information in the catalog
1. On the File menu, click Catalogs --> Bolt assembly catalog to open the

Bolt Assembly Catalog dialog box.

2. Select a bolt assembly from the list.

3. Modify the properties (page 242).

4. Click Update.

5. Click OK. 

The Save confirmation dialog box appears.

6. Select Save changes to model folder to save the changes in the
assdb.db file in the current model folder, and then click OK.

See also

Add a bolt assembly to the catalog (page 231)

Delete a bolt assembly from the catalog (page 232)

Bolt assembly catalog properties (page 242)

Delete a bolt assembly from the catalog
1. On the File menu, click Catalogs --> Bolt assembly catalog to open the

Bolt Assembly Catalog dialog box.

2. Select a bolt assembly from the list.

3. Click Delete.
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4. Click OK. 

The Save confirmation dialog box appears.

5. Select Save changes to model folder to save the changes in the
assdb.db file in the current model folder, and then click OK.

See also

Add a bolt assembly to the catalog (page 231)

Modify bolt assembly information in the catalog (page 232)

Import and export bolts and bolt assemblies
Use importing and exporting for merging bolts and bolt assemblies across
catalogs. Bolts are imported and exported as .bolts files, bolt assemblies
as .bass files, and bolt catalogs as .lis files.

When you export single bolts or bolt assemblies, you can select the bolts or
bolt assemblies you want to include in the .bolts or .bass file. When you
import and export bolt assemblies, also all the related bolt elements (bolts,
studs, screws, nuts, washers) are included in the .bass file.

You can import and export an entire bolt catalog. You can also import a part of
an exported bolt catalog.

Importing and exporting bolt catalogs is useful, when you:

• Upgrade to newer version of Tekla Structures and you want to use a
customized bolt catalog from a previous version.

• Want to combine bolt catalogs that are stored in different locations.

• Want to share bolt catalog information with other users.

TIP You can also download or share bolt assemblies using Tekla Warehouse.

See also

Import bolts to the catalog (page 233)

Export bolts from the catalog (page 234)

Import bolt assemblies to the catalog (page 235)

Export bolt assemblies from the catalog (page 235)

Import a bolt catalog (page 236)

Import a part of the bolt catalog (page 236)

Export an entire bolt catalog (page 237)
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Import bolts to the catalog

Bolts are imported and exported as .bolts files. A .bolts file can include
one bolt or several bolts.

1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt
Catalog dialog box.

2. Right-click in the Bolts list and select Import.

3. Select the import file.

4. Click OK. 

The bolts are displayed on the Bolts list by their original names.

5. Click OK. 

The Save confirmation dialog box appears.

6. Select Save changes to model folder to save the changes in the
screwdb.db file in the current model folder, and then click OK.

See also

Add a bolt to the catalog (page 228)

Import a bolt catalog (page 236)

Import a part of the bolt catalog (page 236)

Import bolt assemblies to the catalog (page 235)

Export bolts from the catalog (page 234)

Export bolts from the catalog

Bolts are imported and exported as .bolts files. A .bolts file can include
one bolt or several bolts.

1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt
Catalog dialog box.

2. Select bolts from the Bolts list. 

Use the Shift and Ctrl keys to select multiple bolts.

3. Right-click in the Bolts list and select Export.

4. Browse for the folder where you want to save the export file.

5. Enter a name for the file in the Selection box.

6. Click OK.

See also

Export bolt assemblies from the catalog (page 235)
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Export an entire bolt catalog (page 237)

Import bolts to the catalog (page 233)

Import bolt assemblies to the catalog

Bolt assemblies are imported and exported as .bass files. A .bass file can
include one bolt assembly or several bolt assemblies.

1. On the File menu, click Catalogs --> Bolt assembly catalog to open the
Bolt Assembly Catalog dialog box.

2. Right-click in the Bolt assemblies list and select Import.

3. Select the import file.

4. Click OK. 

The bolt assemblies are displayed on the Bolt assemblies list by their
original names.

5. Click OK. 

The Save confirmation dialog box appears.

6. Select Save changes to model folder to save the changes in the
assdb.db file in the current model folder, and then click OK.

See also

Add a bolt assembly to the catalog (page 231)

Import a bolt catalog (page 236)

Import bolts to the catalog (page 233)

Export bolt assemblies from the catalog (page 235)

Export bolt assemblies from the catalog

Bolt assemblies are imported and exported as .bass files. A .bass file can
include one bolt assembly or several bolt assemblies.

1. On the File menu, click Catalogs --> Bolt assembly catalog to open the
Bolt Assembly Catalog dialog box.

2. Select bolt assemblies from the Bolt assemblies list. 

Use the Shift and Ctrl keys to select multiple bolt assemblies.

3. Right-click in the Bolt assemblies list and select Export.

4. Browse for the folder where you want to save the export file.

5. Enter a name for the file in the Selection box.

6. Click OK.
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See also

Export an entire bolt catalog (page 237)

Export bolts from the catalog (page 234)

Import bolt assemblies to the catalog (page 235)

Import a bolt catalog
Bolt catalogs are imported to Tekla Structures models as .lis files.

1. Open the model to which you want to import a bolt catalog.

2. Copy the screwdb.lis file that you want to import to the current model
folder.

3. To import the bolt catalog file screwdb.lis from the current model
folder, go to Quick Launch, start typing import bolt catalog, and
select the Import Bolt Catalog command from the list that appears. 

Tekla Structures does not replace the entries that have the same names
as the entries in the import file.

4. Check the status bar for error messages. 

To view errors, go to the File menu and click Logs --> Session history
log .

See also

Import a part of the bolt catalog (page 236)

Export an entire bolt catalog (page 237)

Import a part of the bolt catalog
If you do not want to import the entire bolt catalog, you can select the parts to
be imported.

TIP If you only want to import a few bolts or bolt assemblies, use the import
and export commands of the corresponding catalogs.

1. Open the model that contains the bolt catalog you want to use.

2. Go to Quick Launch, start typing export bolt catalog, and select the
Export Bolt Catalog command from the list that appears. 

The bolt catalog is saved as the screwdb.lis file in the current model
folder.

3. Open the screwdb.lis file using a text editor, for example, Microsoft
Notepad. 

Each entry is listed on a separate row.

4. Delete the unwanted rows from the file. 
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WARNING Do not delete the STARTLIST and ENDLIST rows.

5. Save the file with the name screwdb.lis.

6. Open the model to which you want to import the bolt catalog.

7. Copy the screwdb.lis file that you want to import to the current model
folder.

8. To import the bolt catalog file screwdb.lis from the current model
folder, go to Quick Launch, start typing import bolt catalog, and
select the Import Bolt Catalog command from the list that appears.

See also

Import bolts to the catalog (page 233)

Import bolt assemblies to the catalog (page 235)

Import a bolt catalog (page 236)

Export an entire bolt catalog (page 237)

Export an entire bolt catalog
Bolt catalogs are exported from Tekla Structures models as .lis files.

1. Open the model that contains the bolt catalog you want to export.

2. Go to Quick Launch, start typing export bolt catalog, and select the
Export Bolt Catalog command from the list that appears. 

The exported bolt catalog is the screwdb.lis file in the current model
folder.

TIP The Export Bolt Catalog command exports the entire bolt catalog.
To export only part of the bolt catalog, modify the export file to
contain only the required elements. You can also export bolts from
the Bolt Catalog dialog box or bolt assemblies from the Bolt
Assembly Catalog dialog box.

See also

Export bolt assemblies from the catalog (page 235)

Export bolts from the catalog (page 234)

Import a bolt catalog (page 236)

Import a part of the bolt catalog (page 236)
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Bolt length calculation
Tekla Structures uses values from the bolt catalog and the bolt assembly
catalog when calculating the bolt length. If the bolt catalog does not contain
long enough bolts for your purposes, you need to add them to the bolt
catalog.

The following Assembly settings in the Bolt properties affect the bolt length
calculation process. If the check box is selected, the bolt element is used in the
bolt assembly.

Bolt assembly Bolt elements
1: If the check box is clear, only a hole
is created

2: Washer (1)

3: Washer (2)

4: Washers (3)

5: Nut (1)

6: Nut (2)

The chart and the detailed steps below explain the process of bolt length
calculation.

1. Tekla Structures calculates the minimum possible length of the bolt as
follows:

washer (1) thickness (if the check box is selected) +

material thickness +
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washer (2) thickness (if the check box is selected) +

washer (3) thickness (if the check box is selected) +

nut (1) thickness +

nut (2) thickness +

extra length

2. Tekla Structures searches for the closest match in the bolt catalog.

3. Tekla Structures calculates the number of washers required (must not
exceed 10) so that the length of the shaft is less than:

nut (1) thickness +

material thickness +

nut (2) thickness +

washer (1) thickness +

washer (2) thickness +

(number of washers*washer (3) thickness)

4. Tekla Structures checks that the bolt found in step 2 is longer than:

extra length +

nut (1) thickness +

material thickness +

nut (2) thickness +

add. dist (from the bolt catalog) +

washer (1) thickness +

washer (2) thickness +

(number of fitting washers * washer (3) thickness)

5. If the selected bolt does not fulfill the criteria in step 4, Tekla Structures
returns to step 2, otherwise it continues on to step 6.

6. Tekla Structures checks that the selected bolt fulfills all the following
conditions:

• Can the thread be inside the material to be connected? Even if this is
not allowed, the calculation always allows 3 or 4 mm of thread to be
inside the material, depending on the bolt diameter. If the bolt
diameter is ≥ 24 mm, it allows 4 mm, otherwise it allows 3 mm.

• Shaft length must be more than:

material thickness +

extra length +

Create and distribute customized settings, user
interface elements, and catalogs

239 Customize the bolt catalog



washer (1) thickness (if checked) -

maximum thread in material allowed (if thread in material = no) =
3 mm or 4 mm

• Shaft length is calculated as:

Screw length - screw thread length - thread end.

• Thread end is the part of the bolt between the shaft and the thread. It
is calculated as follows:

Diameter of bolt (mm) Thread end (mm)
>33.0 10.0
>27.0 8.0
>22.0 7.0
>16.0 6.0
>12.0 5.0
>7.0 4.0
>4.0 2.5
≤4 1.5

7. If the selected bolt does not fulfill all the above conditions, Tekla
Structures returns to step 2 and tries the next longest bolt.

8. If the advanced option XS_BOLT_LENGTH_EPSILON is set, the epsilon
thickness is added to, or subtracted from, the material thickness to avoid
inaccurate bolt length calculation.

For example, if this value is not taken into account, and the calculated
length is 38.001 mm, a 39 mm bolt might be selected.

See also

How the bolt catalog and bolt assembly catalogs work together (page 227)

Add a bolt to the catalog (page 228)

Bolt catalog properties
Use the Bolt Catalog dialog box to view and modify the properties of
individual bolt elements, such as bolts, washers, and nuts. The units depend
on the settings in File menu --> Settings --> Options --> Units and decimals .

Option Description
Type The type of the bolt element. The options are:
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Option Description

 (Nut)

 (Washer)

 (Stud)
Standard The name of the bolt element standard.

Used in the Bolt Assembly Catalog dialog box for defining bolt
elements in a bolt assembly.

Use different names for bolt, nut, washer, and stud standards to
distinguish bolt element types from each other.

Diameter The diameter of the bolt element.
Length The length of the bolt element.
Weight The weight of the bolt element.
add. dist The length of the part of the bolt that protrudes from the nut.

The value is used in bolt length calculation.
top thick The thickness of the bolt head.
thread len The length of the threaded part of the bolt shaft.

The value is not used in bolt length calculation (value is 0) if the
bolt is fully-threaded.

washer tol The tolerance between the washer inner diameter and the bolt
diameter.

The value is used when searching for the correct-sized washer
for the bolt. Not used in bolt length calculation.

span size The size of the wrench needed.
calc thick The calculation thickness of a nut or a washer.

This value is used in bolt length calculation.
real thick The true thickness of a nut or a washer.

This is for information only.
inner diam The inner diameter of a nut or a washer.

This is for information only.
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Option Description
outer diam The outer diameter of a nut or a washer.

This is for information only.
top diam The diameter of the hexagon.

This is for information only.

See also

Add a bolt to the catalog (page 228)

How the bolt catalog and bolt assembly catalogs work together (page 227)

Bolt assembly catalog properties
Use the Bolt Assembly Catalog dialog box to view and modify the properties
of bolt assemblies. The units depend on the settings in File menu --> Settings
--> Options --> Units and decimals .

Option Description
Short name This name is used in drawings and reports. It is usually the

commercial name for a specific bolt.
Standard This name is the full name which is shown in the bolt

assemblies list in the Bolt Assembly Catalog dialog box, and
in the Bolt standard list in the Bolt Properties dialog box.

The value is used in bolt length calculation.
Material The material of the bolt assembly.
Finish The type of the finish.
Grade The grade of the bolt assembly.
Tolerance The tolerances of the bolt assembly.

This is for information only. The values cannot be reported, for
example.
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Additional length for bolt calculation

Option Description
Add. dist... The Additional Distance option controls how much of the

bolt protrudes from the nut.

Additional Distance updates the Additional Distance values
of all bolts that use the selected bolt standard and have the
selected diameter.

The value is used in bolt length calculation.

Select whether the value of the additional length affects
all or individual diameters of one bolt assembly.

Enter the additional length value.

Select whether the value is absolute or relative to the
diameter.

See also

Add a bolt assembly to the catalog (page 231)

5.11 Customize the rebar catalog
The rebar catalog contains definitions for different reinforcement types, such
as reinforcing bars and strands of different grades.

The rebar catalog shows standard, environment-specific reinforcing bars and
strands of the environment (or environments) that you have installed and that
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is currently open. The blank project environment only contains undefined
reinforcing bars and strands.

You can add, copy, group, modify, and delete rebar definitions. You can also
import and export single definitions, groups of definitions, or entire rebar
catalogs.

Tekla Structures stores the rebar catalog information in the
rebar_database.inp file that is by default saved to the current model
folder.

Reinforcement meshes are not included in the rebar catalog. Standard meshes
are defined in their own catalog file (page 318), mesh_database.inp.

Work with definitions in the rebar catalog
You can add, copy, modify, and delete rebar definitions in the rebar catalog.

To use the newly added or modified rebar definitions in the model, reopen the
model.

Add a new rebar definition
You can add new definitions to the rebar catalog by defining the bar
properties from scratch.

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

2. Click  New bar.

3. In the New bar dialog box, enter the bar properties. 

If a property is shown in red, it is missing a value or has a value that is not
valid. For example, Grade and Size must have a value.

4. Click Add.

5. Click  Save to save the changes to the rebar catalog.

Add a new rebar definition by copying
You can add new definitions to the rebar catalog by copying an existing
definition and then modifying it.

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

2. Browse for and select the definition that you want to copy.
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3. Click  Copy. 

Alternatively, you can right-click and select Copy.

4. In the Copy dialog box, enter or modify the bar properties. 

Modify the property values that are shown in red so that the new
definition is not a duplicate of the original definition.

5. Click Add.

6. Click  Save to save the changes to the rebar catalog.

Select rebar definitions
You can use the following methods when you select rebar definitions in the
Rebar catalog dialog box.

Selecting different sets of definitions is useful when you want to export
(page 249) or add tags (page 253) to certain definitions, or otherwise modify a
sub-set of definitions.

• Use the following commands on the catalog ribbon:

• Click Select all to select all the definitions in the currently visible group.

Alternatively, you can select one definition and then press Ctrl+A.

• Click Select none to clear the current selection.

• Click Invert selection to select the currently unselected definitions and
to deselect the currently selected definitions.

• To select several consecutive definitions, select the first definition, then
hold down Shift and select the last definition.

• To select several non-consecutive definitions, select the first definition,
then hold down Ctrl and select the other definitions.

Modify a rebar definition
1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar

catalog dialog box.

2. Browse for and select the definition that you want to modify. 

To modify several definitions, hold down Ctrl or Shift when you select
(page 245).

3. In the property area on the right side of the Rebar catalog dialog box,
modify the bar properties. 

Create and distribute customized settings, user
interface elements, and catalogs

245 Customize the rebar catalog



For example, you can select whether the bar is a main bar, or a tie or
stirrup. You may also want to add tags (page 253) to the bar.

If a property is shown in red, it is missing a value or has a value that is not
valid. For example, Grade and Size must have a value.

4. Click  Save to save the changes to the rebar catalog.

Delete rebar definitions
1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar

catalog dialog box.

2. Select (page 245) one or more rebar definitions.

3. Right-click and select Delete.

4. Click Yes to confirm the deletion.

5. Click  Save to save the changes to the rebar catalog.

Work with groups in the rebar catalog
In the rebar catalog, the rebar definitions are arranged to groups. You can
add, copy, modify, and delete groups, and arrange the groups according to
different properties. The groups are listed on the left side of the Rebar
catalog and Select rebar dialog boxes.
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By default, the definitions in the rebar catalog are grouped according to
reinforcement grades. You can change how the definitions are grouped
(page 251) in the Rebar catalog dialog box or in the Select rebar dialog box.

To use the newly added or modified rebar definition groups in the model,
reopen the model.

Add a new group to the catalog
You can create new groups in the rebar catalog by copying an existing group
and the definitions contained in it.

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

2. On the left side of the dialog box, select a group, and then click 
Copy. 

Alternatively, you can right-click a group and select Copy.

3. In the New group name dialog box, enter a name for the new group, and
then click Copy. 

Tekla Structures adds the new group to the catalog.

4. Add, modify, and delete definitions (page 244) contained in the new group
as needed.
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5. Click  Save to save the changes to the rebar catalog.

Modify a group in the catalog
1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar

catalog dialog box.

2. Select the group that you want to modify.

3. Select all definitions in the group.

4. In the property area on the right side of the Rebar catalog dialog box,
modify the group properties. 

For example, you can change the grade or cranked length type. You may
also want to add tags (page 253) to all definitions in the group.

5. Click  Save to save the changes to the rebar catalog.

Delete a group from the catalog
You can delete groups and the definitions contained in them from the rebar
catalog.

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

2. Select a group from the list on the left side of the dialog box.

3. Right-click and select Delete.

4. Click Yes to confirm the deletion.

5. Click  Save to save the changes to the rebar catalog.

Import and export rebar definitions
Use importing and exporting for merging rebar definitions across different
catalogs, models, and Tekla Structures environments and versions. To use
reinforcing bars and strands in other Tekla Structures models, you can export
rebar definitions to a file (*.inp), and then import the file into another Tekla
Structures model.

TIP You can also download or share rebar catalog content using Tekla Warehouse.

Create and distribute customized settings, user
interface elements, and catalogs

248 Customize the rebar catalog



Import definitions to the rebar catalog
You can customize the rebar catalog by importing rebar definitions from
an .inp file.

1. Open the model to which you want to import rebar definitions.

2. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

3. Click  Import.

4. In the Import rebar definitions dialog box, browse for the folder that
contains the import file, select the file, and then click Open. 

Tekla Structures checks if there are duplicates in the definitions in the
import file compared to the rebar catalog.

5. If rebar definitions with the same properties as the definitions being
imported already exist in the rebar catalog, a confirmation dialog box
appears and you have the following three options:

• Click Overwrite to replace all existing definitions with the newly
imported definitions.

• Click Keep existing to discard the duplicate definitions being imported
and to only import the new definitions.

• Click Cancel to not to import any definitions.

6. Click  Save to save the changes to the rebar catalog.

7. To use the newly imported definitions in the model, reopen the model.

Export definitions from the rebar catalog
You can export all or selected rebar definitions, or a selected group of a rebar
catalog to a file (.inp).

1. Open the model from which you want to export rebar definitions.

2. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

3. Do one of the following:

• To export the entire catalog, click  Export --> Export all.

• To export a certain group only, select the group, right-click and select
Export.
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• To export certain definitions only, select the definitions (page 245) and

then click  Export --> Export selected.

Alternatively, you can right-click on one of the selected definitions and
then select Export.

4. In the Export as dialog box, browse for a folder, enter a name for the
export file, and then click Save. 

By default, Tekla Structures saves the file to the current model folder.

The file name extension is .inp.

Organize the rebar catalog view
You can organize the rebar catalog view in the Rebar catalog dialog box to
suit your needs and ways of working. For example, you can change how the
rebar definitions are grouped, hide certain property columns, or change the
order of the property columns. You can also filter definitions and mark them
with stars and tags.

Some of these methods work the same way also in the Select rebar dialog
box; grouping by some of the properties, showing and hiding property
columns, changing the order of the columns, filtering, and starring. The Select
rebar dialog box opens when you click the ... button next to the Size box in a
reinforcement object's properties, or in a component dialog box to select a
rebar definition.

The status bar at the bottom of the Rebar catalog and Select rebar dialog
boxes shows useful information, such as:

• The number of definitions in the selected group.

• The property by which the definitions are grouped.

• The property by which the definitions are sorted.

The arrow symbol indicates if the sort order is ascending  or descending
.

In the Rebar catalog dialog box, the status bar also shows the number of the
selected definitions.

The changes you make to the dialog box layout are automatically saved to the
rebar_catalog.settings.UI file in the ..\Users\<user>\AppData
\Local\Trimble\Tekla Structures\<version>\Catalogs\ folder. Tekla
Structures will use the saved layout next time you open the dialog box.

Show or hide the catalog ribbon
If needed, you can show or hide the ribbon in the Rebar catalog dialog box
and in the Select rebar dialog box.
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By default, the ribbon is shown in the Rebar catalog dialog box, but hidden in
the Select rebar dialog box.

• To show the ribbon, click the down arrow  at the right end of the (Home)
ribbon title bar.

• To hide the ribbon, click the up arrow  at the right end of the (Home)
ribbon title bar.

Change the grouping of rebar definitions
You can select the property by which the rebar definitions are grouped in the
rebar catalog. By default, the rebar definitions are grouped by grade.

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box. 

Alternatively, you can use the Select rebar dialog box.

2. Click  Group by, and then select the property by which you want to
group the rebar definitions. 

The definitions can be grouped by the properties whose property
columns are visible. For example, you can select Size or Cross section
area.

The properties that are available may vary in the Rebar catalog and
Select rebar dialog boxes.

Work with property columns in the catalog view
You can organize the rebar catalog view in the Rebar catalog dialog box and
in the Select rebar dialog box by showing and hiding the property columns,
and by changing the order, sort order, and width of the columns.

The Star column is always visible and you cannot hide it.

To Do this
Show or hide a property column 1.

Click  Show columns to open
a list of the available property
columns.

A check mark in front of a column
name indicates that the column
is visible.

2. To show a column, click the
column name to add a check
mark in front of the column
name.
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To Do this
3. To hide a column, click the

column name to remove the
check mark.

Change the order of the property
columns

Drag a column header to a new
location.

Change the sort order of a property
column

Click the column header.

The arrow symbol next to the column
header indicates if the sort order is
ascending  or descending .

To sort values by two properties and
in two columns:

1. Sort by one column.

2. Hold down Shift and then sort by
the other column.

Resize a property column Drag the edge between this and the
following column header. For
example:

You can also click  Fit columns to
adjust the widths of the visible
columns so that the longest value in
each column is shown.

Filter rebar definitions
You can filter rebar definitions in both the Rebar catalog dialog box and the
Select rebar dialog box. You can use filtering together with the other
methods, such as sorting, to narrow down the number of definitions shown in
the rebar catalog view.

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box. 

Alternatively, you can use the Select rebar dialog box.

2. In the Filter box, enter the search term or filtering criteria. 

For example, to find rebar definitions that are suitable for stirrups and
ties, enter tie.

Tekla Structures shows the groups that contain matching definitions.

3. Select a group. 

Tekla Structures shows the matching definitions in the group, for
example, the definitions that have Usage set to tie/stirrup.
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Add stars to rebar definitions
You can mark important or preferred rebar definitions with stars, so that you
can easily find these definitions later. The definitions that are marked with
yellow stars appear in the Starred group in the rebar catalog. Starring is user-
specific, so it is only visible to you.

The starring settings are stored in the current model folder in the
rebar_catalog.settings.user.<username> file, where the <username>
suffix is your username.

If you have starred definitions, the Rebar catalog dialog box opens with the
Starred group selected.

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box. 

Alternatively, you can use the Select rebar dialog box.

2. Browse or search for the definitions that you want to mark with stars.

3. In the definition list, click the white star symbol in the Star column for
each definition that you want to add to the Starred group. 

By default, the Star column is the first column and the star symbol is at
the beginning of each definition row.

The star symbol turns yellow  and the definition is added to the
Starred group.

4. To remove the starring from a definition, click the yellow star symbol on
the definition row. 

The star symbol turns white again and the definition is removed from the
Starred group.

Add tags to rebar definitions
In the Rebar catalog dialog box, you can add tags to rebar definitions. You
can use tags to add keywords or other metadata to the definitions.

For example, you could use tags like Stainless and Acid proof.

Tags are model-specific and saved to the rebar_catalog.settings file in
the current model folder.

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

2. Select the definitions (page 245) that you want to tag.
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3. Enter the tag in the Tags box at the bottom-right corner of the Rebar
catalog dialog box, and then press Enter. 

To add several tags to a definition, enter the next tag in the next tag box
and press Enter.

Each group of tagged definitions appears with the  symbol in the list of
groups, after the Starred group:

4. To remove a tag from a definition, select the definition and click the X
symbol after the tag name in the Tags section in the property area.

5. To delete a tag completely, select the tagged group, select all the
definitions in the group, and then click the X symbol after the tag name in
the Tags section in the property area.

6. Click  Save to save the changes to the rebar catalog.

5.12 Customize the Applications & components catalog
You can modify the catalog definition settings of the Applications &
components catalog using catalog definition files, and set up a group
structure to suit the needs of your company. Always check the settings and the
group structure when upgrading to a new Tekla Structures version.

Catalog definition files (ComponentCatalog.xml) can be located in folders
pointed by XS_SYSTEM, XS_FIRM, XS_PROJECT, and in the model folder. If there
are several catalog definition files, Tekla Structures combines the information
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in the files. For more information on the folder search order, see Folder search
order (page 358).

When you create a group structure for the Applications & components
catalog, define the highest level structure in a catalog definition file that is
located in a folder pointed by XS_SYSTEM. To hide unnecessary parts of the
group structure and catalog content from certain roles, edit the catalog
definition files of these roles.

For general instructions on how to use the Applications & components
catalog, see How to use the Applications & components catalog.

You can also add your own instructor side pane help pages for the tools in the
Applications & components catalog, see Add instructor help for applications
and components (page 260).

Edit the catalog
1. Set the XS_COMPONENT_CATALOG_ALLOW_SYSTEM_EDIT advanced

option to TRUE to edit the catalog definition files.

2. In the Applications & components catalog, click  Access advanced
features > Catalog management > Edit mode, and select the catalog
definition file that you want to edit. 

The list of files shows all the environment folders, the project and firm
folders if defined, and the model folder. You can define the needed
catalog definition file folder paths in XS_SYSTEM.

If XS_COMPONENT_CATALOG_ALLOW_SYSTEM_EDIT is not set to TRUE, a
small warning icon is shown next to the files in the XS_SYSTEM folder
locations. The image shows warning icons next to the files that appear
dimmed.
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The files that appear dimmed do not exist, but you can create the files by
selecting them, and answering Yes in the Edit mode message box.

You can remove an existing file by clicking the  button next to the file.
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3. Select the file that you want to edit. 
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The check mark in front of the folder name shows the file that is currently
being edited.

4. Create new groups and subgroups to organize the catalog content, right-
click in the catalog and select New group....

5. Move the content from Ungrouped items to the new groups, or to other
predefined custom groups. To move an item to another group, right-click
the item, select Add to group, and then select the target group. 
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It is important to keep the Ungrouped items group empty, because all
items downloaded from Tekla Warehouse are placed in that group. When
you place an item to a predefined group, it is automatically removed from
the ungrouped items.

For instructions on how to collect content to a group and publish it as a
catalog definition file, see .
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Maintain the catalog
To keep the Applications & components catalog structure and content clear
and in order, keep the groups up to date and organized, and remove the
unnecessary items from the catalog definition files.

1. Click  in the bottom-right corner in the Applications & components
catalog to display the message log: 

If an item defined in a catalog definition file is removed from the Tekla
Structures software, the removed item will be included in the
Applications & components catalog error message log.

2. If the log contains references to missing items, edit the relevant
ComponentCatalog.xml file to remove the references manually. 

We recommend that you make a back-up copy of the file before you start
editing.

3. Test thoroughly that these changes do not create any further errors, or
mess up the group structure in the Applications & components catalog.
Check at least the Ungrouped items and Legacy catalog groups.

4. Newly added items are placed in the Ungrouped items group. If there are
new items in the group, move them to the appropriate predefined groups,
and hide them from specific roles, if needed.

5. Add suitable thumbnails to the items, if needed.

Create and distribute customized settings, user
interface elements, and catalogs

260 Add instructor help for applications and
components



5.13 Add instructor help for applications and components
You can easily create side pane help for tools in the Applications &
components catalog.

In the Applications & components catalob, the Instructor shows content
already on selection, so the information is especially useful for giving advice to
your users on choosing between different components or giving instructions
before running a tool. To make full use of this feature, users should arrange
their side panes so that both panes are visible.

1. Select the tool you want to add help for in the Applications &
components catalog.

2. Click the Add help files button in the Instructor pane. 

A dialog box opens for creating the necessary files according to your
selections.

3. Click Next and select the languages that are used as user interface
languages in your organization. There needs to be a content file for each
language even if you do not translate the content.

4. Click Next and select the folder where you want to store the generated
files. The files can be stored in the model, project, firm, or system folder.
The standard folder search order (page 358) is followed.

5. Click Create. 

Tekla Structures creates an XML file that defines a link between the tool in
the Applications & components catalog and an HTML file for the help
content.

The HTML files are stored in a folder structure that separates files into
language-specific folders. The XML file and the root folder for the content
are named according to the identifier of the tool you are documenting.
You can copy files between the allowed storage locations, but do not
rename the files or folders or change the folder structure.

6. Edit the HTML content file(s) in your preferred tool, such as a text editor,
or replace the file with your own HTML file of the same name. If you do
not have any HTML editing experience, there are several good tutorials
available on the internet to quickly learn the few basics you need to know.
You can create your own HTML files by saving as HTML from familiar
tools, such as Microsoft Word or Google Docs. Note that the resulting files
will not look exactly the same as the original document.
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6 Files and folders in Tekla
Structures

Sometimes you need to know where Tekla Structures stores information, and
the types of files that Tekla Structures contains, where the files are located,
and how the files should be should be used.

Tekla Structures contains a large amount of files that affect the way the
software works. It is important to know which file controls which functionality,
and also which files we do not recommend that you touch.

The initialization file reading order is also very important. You need to know
the order in which the files are read when you open Tekla Structures, so that
you do not modify the files unnecessarily.

See also

Initialization files (.ini files) (page 268)

Input files (.inp files) (page 299)

File storing options and advanced options (page 276)

Data files (.dat files) (page 312)

Message files (page 313)

Standard files (page 316)

Property files (page 315)

Catalog files (page 318)

Font files and font conversion files (page 321)

Symbol files (page 322)

Image files (page 323)

Files related to templates, reports and drawings (page 322)

Log files (page 324)

Model folder files and file name extensions (page 333)
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Check and change Tekla Structures file and folder locations in Directory
browser (page 357)

Folder search order (page 358)

Create project and firm folders (page 263)

Location of certain hidden files and folders (page 360)

6.1 Create project and firm folders
Use project and firm folders for customized files. These can be custom
ribbons, drawing styles, profile and material catalogs, or any other settings
you want to store for future use. You can use the same files each time you
start a new model or install a new version of Tekla Structures. This also means
you can easily revert back to the default settings, because you have not
overwritten any of the system files.

Use the project folder and its sub-folders to store customized files that are
only used in a particular project. A project may consist of several models done
by separate teams, all spread out in different locations. You can save project-
specific files and settings in the project folder, so that everyone in the project
can use them. A project may also consist of one model that is shared by
different companies.

Use the firm folder and its sub-folders to store customized files for the entire
organization or company. The settings and files in the firm folder are meant to
be used in all projects within the company. For example, let's say you regularly
work for a company that has specific drawing layout standards it expects you
to use. Customize the drawing templates once for the company and save them
in the firm folder or in a sub-folder of the firm folder. You can then use the
customized drawing templates for all future projects for that company.

When working within one company, the firm and project folders are usually
located in network folders so that everyone can access them. In collaborative
projects that include multiple teams or companies, you can use a folder in the
linked .

Project and firm folders are defined by XS_FIRM and XS_PROJECT. When
working in a model sharing project, each company needs to have its own firm
settings in a folder defined by XS_FIRM, and a common project folder for
project settings defined by XS_PROJECT. It may be useful to create a startup
shortcut (page 19) on your desktop for each project containing all necessary
folders.

WARNING Changing an advanced option value in .ini files located outside the
model folder does not affect the existing models. You can only update
advanced options in the Advanced Options dialog box or in the
options.ini file located in model folder; not from an options.ini file
located in folders defined for the advanced options XS_FIRM or
XS_PROJECT. The .ini files are read also when you open an existing
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model, but only new advanced options that do not exist in
options_model.db or options_drawings.db are inserted, for
example, such options that are not yet in the Advanced Options dialog
box but have been added in the software.

Create a project or firm folder
1. Create an empty folder in a shared location, for example on a network

drive.

2. Name the folder appropriately.

3. In Tekla Structures, go to the File menu and click Settings --> Advanced
options.

4. In the File Locations category, define the path to the firm or project
folder you created in step 1 for the advanced option XS_FIRM or 
XS_PROJECT.

5. Restart Tekla Structures for the change to take effect.

See also

Folder search order (page 358)

Typical initialization files (.ini files) and their reading order (page 269)

Fixed sub-folders in project and firm folders
Some files need to be stored in particular, or fixed, sub-folders under project
and firm folders. If the files are not stored in these folders, Tekla Structures
cannot read the files. See the files which should be stored in fixed sub-folders
in the following table.

XS_FIRM or
XS_PROJECT sub-

folder

Further sub-folders and necessary
files

See also

\AdditionalPSe
ts

Use this folder to store additional
property set configuration files for IFC
export in the .xml format.

•

\CustomInquiry Use this folder to store:

• report templates for custom
inquiries as .it files

• the InquiryTool.config file for
defining which attributes are
included by default in the Manage
content dialog box for selecting

•
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XS_FIRM or
XS_PROJECT sub-

folder

Further sub-folders and necessary
files

See also

the properties shown in custom
inquiries

\Drawing
Details

Use this folder to store 2D drawing
details as .ddf and .png files.

NOTE To see the drawing details
stored in the \Drawing
Details sub-folder under a
firm or project folder in Tekla
Structures:

1. In the Drawing 2D
library side pane, click

the  Folder button.

2. Select Firm or Project.

•

\macros This sub-folder has the following sub-
folders:

• \Drawings
Use this folder to store macros
related to drawings as .bmp, .cs,
and .cs.pdb files.

• \Modeling
Use this folder to store macros
related to modeling as .bmp, .cs,
and .cs.pdb files.

NOTE Macros are primarily read
from the folder defined by
the XS_MACRO_DIRECTORY
advanced option. This
advanced option can point to
any folder, not just the 
\macros sub-folder of a firm
or project folder.

•

•

\profil This sub-folder can have the following
sub-folders:

• Customize the
shape catalog
(page 209)
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XS_FIRM or
XS_PROJECT sub-

folder

Further sub-folders and necessary
files

See also

• \ShapeGeometries
Use this folder to store shape
geometry descriptions as .tez
or .xml files.

• \Shapes
Use this folder to store shape
descriptions as .xml files.

\ProjectOrgani
zerData

This folder has the following sub-
folders:

• \DefaultCategoryTrees
Use this folder to store Organizer
categories as .category files.

• \PropertyTemplates
Use this folder to store property
templates from Organizer
as .propertytemplate files.

• \ExcelTemplates
Use this folder to store
customized templates in .xlt
format for exporting object
property values from Organizer.

•

\PropertyRepos
itory
\Templates

Use this folder to store customized
property pane layouts in the 
PropertyTemplates.xml file.

• Distribute
customized
property pane
layouts by
using a
project, firm,
or
environment
folder
(page 135)

\Symbols Use this folder to store:

• symbols as .sym and .dwg files

• other images and bitmaps used in
drawings

NOTE Symbols are primarily read
from the folder defined by
the DXK_SYMBOLPATH

• Add symbols
in drawings

• DXK_SYMBOLP
ATH
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XS_FIRM or
XS_PROJECT sub-

folder

Further sub-folders and necessary
files

See also

advanced option. This
advanced option can point to
any folder, not just the 
\Symbols sub-folder of a
firm or project folder.

\template Use this folder to store graphical
templates used in drawing layouts
as .tpl files.

NOTE Templates are primarily read
from the folder defined by
the 
XS_TEMPLATE_DIRECTORY
advanced option.

In the same way, the 
tpled.ini is primarily read
from the folder defined by
the XS_TPLED_INI advanced
option.

These advanced options can
point to any folder, not just
the \Template sub-folder of
a firm or project folder.

This folder also contains the following
sub-folders:

• \mark
Use this folder to store graphical
templates used in drawing marks.

NOTE Templates used in
drawing marks are
primarily read from the
folder defined by the XS_
TEMPLATE_MARK_SUB_
DIRECTORY folder. This
advanced option can
point to any folder, not
just the \template\mark
sub-folder of a firm or
project folder.

•

•
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XS_FIRM or
XS_PROJECT sub-

folder

Further sub-folders and necessary
files

See also

• \settings
Use this folder to store the 
tpled.ini file, which defines
environment-specific template
settings, and the user-defined
attributes (UDAs) related to
Template Editor in the 
contentattributes_user-
defined_YOUR_COMPANY.lst
file.

NOTE To read Template Editor files from
the template\settings sub-
folder within a firm or project
folder, the 
XS_TEMPLATE_DIRECTORY_SYSTEM
advanced option needs to point to
the \.ini sub-folder in the firm or
project folder.

6.2 Initialization files (.ini files)
Initialization files are used for defining Tekla Structures start-up parameters
and default settings. They contain advanced options that are used for
configuring Tekla Structures for different standards, and for your or your
company’s style of working.

Tekla Structures automatically creates the necessary initialization files
(page 269) during installation. The number of initialization files it creates
depends on how many Tekla Structures environments you have installed.

NOTE If you are defining a switch for an advanced option in an .ini file, use double
percent signs %%xxx%% around the switch. If you are defining a switch in the
Advanced Options dialog box, use single percent signs %xxx% around the
switch. For example, %%BOLT_NUMBER%%*D%%HOLE.DIAMETER%% for the
advanced option XS_BOLT_MARK_STRING_FOR_SIZE.

See also

Global default environment settings - env_global_default.ini (page 273)
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Local environment settings - env_<environment>.ini (page 274)

Role settings - role_<role>.ini (page 274)

Typical initialization files (.ini files) and their reading order

Below is a list of all the typical initialization files that are read when Tekla
Structures is started. The numbers indicate their reading order at startup. If
there are conflicting settings, the ones read later override the ones read
earlier.

WARNING Changing an advanced option value in .ini files located outside
the model folder does not affect the existing models. You can
only update advanced options in the Advanced Options dialog
box or in the options.ini file located in model folder; not from
an options.ini file located in folders defined for the advanced
options XS_FIRM or XS_PROJECT. The .ini files are read also
when you open an existing model, but only new advanced
options that do not exist in options_model.db or
options_drawings.db are inserted, for example, such options
that are not yet in the Advanced Options dialog box but have
been added in the software.

To check the files that have been read and their reading order, go to File
menu --> Logs --> Session history log .

File and reading order Description
1. fonts_<lang>.ini This file is optional, and it is only

needed for languages using special
characters. One example is the
fonts_jpn.ini file for the Japanese
language.

This file is read from Tekla
Structures\<version>\nt\bin\ if
it is available. It is installed to
the ..\nt\bin folder when Tekla
Structures is installed.

NOTE: Do not change these settings.
2. teklastructures.ini The file teklastructures.ini

starts Tekla Structures. It is read
from ..\Program Files\Tekla
Structures\<version>\nt\bin\.

This file contains basic system
settings, such as the location of
software and environment files. This
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File and reading order Description
file is installed to the ..\nt\bin
folder when Tekla Structures is
installed. It is always read at Tekla
Structures startup.

NOTE: Do not change these settings.
3. lang_<lang>.ini This file contains the language

settings. It is read from ..\Program
Files\Tekla Structures
\<version>\nt\bin\.

This file is installed to the ..\nt\bin
folder when Tekla Structures is
installed.

Which lang_<lang>.ini files exist
in the ..\nt\bin folder depends on
which languages you have selected to
install during the software
installation.

The language that is read depends on
the language you have selected in File
menu --> Settings --> Change
language in the previous Tekla
Structures session.

NOTE: Do not change these settings.
4. env_global_default.ini This file is used as a default for all

environments and contains the global
settings. The settings in the
env_global_default.ini file
provide the basics for all environment
settings globally. The settings in this
file can be localized and specified
differently in an environment-specific
initialization file that is read later than
this file.

This file is always read at Tekla
Structures startup
from ..\ProgramData\Trimble
\Tekla Structures\<version>
\environments\common\ and is
installed there from the common
environment installation package.

NOTE: Do not change these settings.
5. All .ini files defined in shortcut/
command line with -I <name>.ini

Usually none.
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File and reading order Description
6. env_<environment>.ini The env_<environment>.ini files

contain all the advanced options that
have environment-specific settings.
They are read from the environment
folder ..\ProgramData\Trimble
\Tekla Structures\<version>
\environments\. The exact location
may vary depending on your
environment.

The env_<environment>.ini files
that exist on your computer depends
on which environment packages you
have installed. Which
env_<environment>.ini file is read
depends on the environment that you
select in the Tekla Structures startup
dialog box.

NOTE: Do not change these settings.
7. role_<role>.ini The role_<role>.ini files contain

all the advanced options that have
typical role-specific settings. They are
read from the environment
folder ..\ProgramData\Trimble
\Tekla Structures\<version>
\environments\. The exact location
may vary depending on your
environment.

The available roles depend on the
environments you have installed.

You can select the role in the Tekla
Structures startup dialog box.

For example, this file defines that the
US environment imperial role uses
imperial units, shows the fractions
correctly, and understands input as
imperial. In US environment metric
role metric units are used.

NOTE: Do not change these settings.
8. All .ini files defined in shortcut/
command line with -i <name>.ini

Usually none.

9. company.ini The company.ini file is useful
especially for big companies that
want to unify certain enterprise-level

Files and folders in Tekla Structures 271 Initialization files (.ini files)



File and reading order Description
settings. This file is read from a folder
specified with the advanced option
XS_COMPANY_SETTINGS_DIRECTORY.
This file is read only if the advanced
option 
XS_COMPANY_SETTINGS_DIRECTORY
is set.

This file is created by the system
administrator when necessary, it is
not created by the installation.

10. user.ini The user.ini file is where you can
save your personal user settings.

This file is located in the same
location as the user-specific
options.bin file, for example,
C:\Users\<user>\AppData\Local
\Trimble\Tekla Structures
\<version>\UserSettings.

The user.ini is created in the above
mentioned location when you start
Tekla Structures for the first time and
create and save a model using the
current version. It is read when you
start Tekla Structures.

The changes you make in the
advanced options in the Advanced
Options dialog box override the
settings in all other initialization files,
if the advanced option exists in both
locations.

If user.ini has system options they
are read always when Tekla
Structures is opened.

If user.ini has model-specific
options they are used when new
model is created.

If user.ini has user-specific options
they are used when Tekla Structures
is used for the first time.

11. options.ini in system folder The folder is specified with the
advanced option XS_SYSTEM.

Files and folders in Tekla Structures 272 Initialization files (.ini files)



File and reading order Description
12. options.ini, firm-specific, if any
exist

13. options.ini, project-specific, if
any exist

The option.ini files containing
firm- or project-specific model
settings are saved in and read from
user-defined locations specified with
the advanced options XS_FIRM and
XS_PROJECT. They work in the
specified way for the firm in question,
or for the specified project if the
model has been set up to read
settings from these locations, and if
the user has manually moved the
options.ini file to these locations.
An options.ini is created in the
firm or project folder when you copy
or move it there.

Updating of model-specific and user-
specific advanced options can only be
done from the Advanced Options
dialog box or options.ini located in
model folder, not from the firm- or
project-specific options.ini files.

The options.ini in the firm or
project folder is read when you start
Tekla Structures or open the model.

14. options.ini, model-specific The options.ini in the model
folder.

See also

Create start-up shortcuts with customized initializations (page 19)

Settings defined by advanced options (page 296)

Global default environment settings - env_global_default.ini
The env_global_default.ini file defines the global defaults for advanced
options. The file is read from ..\ProgramData\Trimble\Tekla
Structures\<version>\environments\common\.

WARNING Do not modify the env_global_default.ini file. If you need to
modify some environment settings, copy the needed advanced
options from this file to your user.ini (page 275) file and modify
the settings there, or modify the settings in the Advanced
Options dialog box.
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For advanced options that are set according to your local standards, see the
environment settings file env_<environment name>.ini (page 274) and the role
settings file role_<role name>.ini (page 274). The local files override the
advanced options set in env_global_default.ini.

If the advanced option in the env_global_default.ini file is preceded by
rem, the software defaults are used and shown as the value. The outdated
advanced options are listed at the end of the file.

See also

Typical initialization files (.ini files) and their reading order (page 269)

Local environment settings - env_<environment>.ini
The env_<environment>.ini file contains advanced options that are set
according to local standards and are different from the global defaults. The file
is read from the environment folder..\ProgramData\Trimble\Tekla
Structures\<version>\environments\. The exact location may vary
depending on your environment.

WARNING Do not modify the env_<environment>.ini file. If you need to
modify some settings, copy the needed advanced options from
this file to your user.ini (page 275) file and modify the settings
there, or modify the settings in the Advanced Options dialog
box.

The global default environment settings file env_global_default.ini (page 273)
contains a complete listing of advanced options. The local files override the
advanced options set in env_global_default.ini.

See also

Typical initialization files (.ini files) and their reading order (page 269)

Role settings - role_<role>.ini
The role_<role>.ini files contain all the advanced options that have typical
role-specific settings. The file is read from the environment
folder ..\ProgramData\Trimble\Tekla Structures\<version>
\environments\. The exact location may vary depending on the
environment.

WARNING Do not modify the role_<role>.ini file. If you need to modify
some settings, copy the needed advanced options from this file
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to your user.ini (page 275) file and modify the settings there, or
modify the settings in the Advanced Options dialog box.

The role_<role>.ini file contains advanced options that are set according
to typical role requirements in your local area. These settings are different
from your environment settings in env_<environment name>.ini (page 274).
The global default environment settings file env_global_default.ini (page 273)
contains a complete listing of advanced options. The advanced option settings
in role_<role>.ini override the ones in env_<environment>.ini

See also

Typical initialization files (.ini files) and their reading order (page 269)

Add an advanced option to the user.ini file
You can save your personal user settings to the user.ini file. The user.ini
file is located in the same location as the user-specific options.bin file, for
example, ..\Users\<user>\AppData\Local\Trimble\Tekla
Structures\<version>\UserSettings.

NOTE We recommend that you add only system-specific (page 296)
advanced options to the user.ini file.

You can also add model-specific (page 296) advanced options, but the
model-specific advanced options only affect new models that you
create. This is because only the new advanced options that do not yet
exist in options_model.db or options_drawings.db are taken
into account. For more information, see Files storing option and
advanced options (page 276).

Adding user-specific advanced options in user.ini may not work as
desired as options.bin is loaded after user.ini and may override
the value.

1. Right-click the user.ini file in Windows Explorer and select Open with.
Select a standard text editor from the list of available programs.

2. On a new line, enter set, then a space, then the name of the advanced
option followed by an equal sign, and then the value in a single line.

Tekla Structures only reads lines in the initialization file that start with 
set.

3. Save user.ini.

4. Restart Tekla Structures for the changes to take effect.
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Possible values Example
TRUE
FALSE

set XS_DISABLE_WELD_PREP_SOLID=TRUE
set
XS_UNDERLINE_AFTER_POSITION_NUMBER_IN_HARDSTA
MP=FALSE

1 set XS_SINGLE_CLOSE_DIMENSIONS=1
0 set XS_SINGLE_USE_WORKING_POINTS=0
string value set

XS_USER_DEFINED_BOLT_SYMBOL_TABLE=bolt_symbol
_table.txt

switches set
XS_ASSEMBLY_FAMILY_POSITION_NUMBER_FORMAT_STR
ING=%%TPL:PROJECT.NUMBER%%
Use two switches.

TIP When you are moving to a new version of Tekla Structures, you can use
the Migration Wizard to automatically copy your user.ini file to the
new version. The Migration Wizard appears once you start Tekla
Structures for the first time after installation.

See also

Location of certain hidden files and folders (page 360)

Typical initialization files (.ini files) and their reading order (page 269)

6.3 File storing options and advanced options

WARNING Changing an advanced option value in .ini files located outside
the model folder does not affect the existing models. You can
only update advanced options in the Advanced Options dialog
box or in the options.ini file located in model folder; not from
an options.ini file located in folders defined for the advanced
options XS_FIRM or XS_PROJECT. The .ini files are read also
when you open an existing model, but only new advanced
options that do not exist in options_model.db or
options_drawings.db are inserted, for example, such options
that are not yet in the Advanced Options dialog box but have
been added in the software.

What happens at model creation

When a new model is created, Tekla Structures reads model-specific option
and advanced option values from the standard.opt file, and from the .ini
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files in a certain reading order (page 269), and creates the databases
options_model.db and options_drawings.db, and the options.ini file
under the model folder.

Changing a model-specific options or advanced options

• When you change a model-specific (page 296) option or advanced option
and press OK or Apply in the Options or Advanced Options dialog box,
the settings are taken into use (otherwise you will get a warning message).

• The updated model-specific option or advanced option settings are saved
in options_model.db and options_drawings.db under model folder
when the model is saved.

• In addition, there are also some special model-specific advanced options
that can be updated from the options.ini file located in the model
folder, for example, new advanced options that are not yet in the
Advanced Options dialog box.

• You can change model-specific advanced options only in the Advanced
Options dialog box or in the options.ini file that is located in model
folder.

• You can change model-specific options only in the Options dialog box
manually or by loading standard.opt file values in the dialog box.

Changing a user-specific options or advanced options

• When you change a user-specific (page 296) option or advanced option,
and press OK or Apply in the Options or Advanced Options dialog box,
the settings are saved in options.bin in ..\Users\<user>\AppData
\Local\Trimble\Tekla Structures\<version>\UserSettings.

• You can change user-specific advanced options only in the Advanced
Options dialog box.

• You can change user-specific options only in the Options dialog box
manually or by loading standard.opt file values in the dialog box.

Saving customized settings in the Options dialog box

• You can save your own model-specific settings in the Options dialog box by
using the Save button. Then the standard.opt file is saved in the
\attributes folder under the model folder.

Creating a list of advanced options and their values

• You can create a complete list of advanced options in a text file by clicking
Write to file in the Advanced Options dialog box. The list shows the name
of the advanced option, current value and type.

For more information about the standard.opt file, see Standard.opt settings
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Settings in the Options dialog box
The Options dialog box (File menu > Settings > Options) contains the current
values for a number of Tekla Structures settings.

Check the settings before you start modeling and change them, if necessary.

The model-specific (page 296) settings in this dialog box are saved in the
options_model.db and options_drawings.db databases in the model
folder, and the user-specific (page 296) settings in options.bin in your local
<user> folder. Changing user- or model-specific options in the Options dialog
box does not require Tekla Structures restart.

You can also save your own settings by using the Save button. Then the
standard.opt file is saved in the \attributes folder under model folder.
You may want to copy this file to your firm folder. When you create a model,
the standard.opt is read from the firm folder.

The options in the Options dialog box are described below.

Clash check settings
NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

Depending on how the objects selected for clash checking have been modeled,
different clash check settings are used. For example, if you have modeled
embeds as studs, steel parts, or reinforcing bars, respectively either bolt
settings, part settings, or reinforcement settings are relevant.

Option Description
Allowed penetration volume Defines the allowed clash check

tolerance if small collisions are
acceptable and can be ignored.

If the clashing volume is smaller than
the given value, for example 1 mm3,
then the clash is not reported.

Enter the value in the current volume
units.

Clash check between bolt and
bolted part

Defines whether the model is checked
for clashes that occur between bolts
and the related bolted parts.

If you select Yes, Tekla Structures will
check the bolts against the real
geometry of the bolted part profiles
including roundings, and using the
real bolt dimensions.
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Option Description
Define the clash check clearance
area for bolts

Use to check if bolts collide with parts
and if there is enough space to fix the
bolts.

Enter the clearance dimensions in
relation to the bolt head or nut
diameter d (the larger value), and the
nut thickness t. The clearance in front
of the bolted parts is the same as the
bolt length.

If you do not enter a value, Tekla
Structures uses the default value.

If you clear the check boxes, the
clearance will be zero.

If Tekla Structures cannot find the
bolt head or nut diameter in the bolt
catalog, it uses the shank diameter
instead.

Exact solid weld clash check Defines whether the model is checked
for duplicate and overlapping welds
and for clashes that occur between
welds and other objects (such as
parts and bolts).

If you select Yes, Tekla Structures will
check the welds against other welds,
against bolts, and against the real
geometry of the part profiles
including roundings, and using the
weld solid dimensions with normal
accuracy.

Reinforcing bar vs steel part
clearance (negative value to allow
overlap)

Defines the minimum clearance or
the allowed overlap for reinforcing
bars when they are checked against
steel parts.

To allow reinforcing bars to overlap
steel parts and to ignore the ribs of
bars, enter a negative value. The
maximum overlap is the actual bar
radius.

Tekla Structures only checks the
distance from bar side to part. Tekla
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Option Description
Structures does not check the
distance from bar end to part.

If you clear the check box, Tekla
Structures will not check the
clearance.

Reinforcing bar clearance (negative
value to allow overlap)

Defines the minimum clearance or
the allowed overlap for reinforcing
bars when they are checked against
other reinforcing bars.

To allow reinforcing bars to overlap,
enter a negative value.

If you clear the check box, Tekla
Structures will not check the
clearance.

Reinforcing bar cover thickness Defines the reinforcing bar cover
thickness.

Tekla Structures checks the cover
thickness against the part that the
reinforcing bar belongs to. Tekla
Structures only checks the distance
from bar side to part surface. Tekla
Structures does not check the
distance from bar end to part surface.
If the bar penetrates a part surface, a
clash is reported, even if the bar is
completely inside a cast unit or pour.

If you clear the check box, Tekla
Structures will not check the cover
thickness.

Components settings
Tekla Structures uses the information on the Components tab when it creates
parts using system components.

Component properties defined in component dialog boxes override these
settings. Tekla Structures only uses these settings if the corresponding boxes
in the component dialog boxes are empty.

If you change settings here, Tekla Structures only applies the new settings to
components you subsequently create. Components you created prior to
changing the preferences are not affected.

NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.
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Option Description
Profile names Defines parametric profile prefixes

for plates. It is important that profile
names are set up correctly so that
you can use filters and wizards
effectively.

Profile names must exist in the profile
catalog. If you want to use a
parametric profile that does not have
a name in the catalog, first add it to
the Profile Catalog, then enter it
here. Tekla Structures uses the
Folded plate prefix when you use the
folded plates in components.

Bolts In components, Tekla Structures uses
Factor of bolt edge distance and
Compare edge distance to to check
that the bolts it creates are not too
close to the edge of a part, and warns
you if they are. Check that Factor of
bolt edge distance is set according
to the standard you are using. The
default edge distance setting depends
on your environment.

Compare edge distance defines
whether the edge distance checks are
based on bolt or hole diameter.

To define the default bolt properties
to use in connections, select a Bolt
standard and Bolt size.

Parts Part material defines the default
part material grade.

Part start numbers defines start
numbers for parts that are Welded to
primary and Welded to secondary,
Loose parts, and Assembly loose
parts.

Cross-check these settings against the
numbering series you define to make
sure they do not overlap. If they
overlap, Tekla Structures may create
two non-identical parts with the same
part number. This generates an error
in the Numbering history log file
(page 330).

Files and folders in Tekla Structures 281 File storing options and advanced options



Drawing dimensions settings
NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

For more information about dimension settings, see

Option Description
Exaggeration This setting defines the default values

for Exaggeration limit and
Exaggeration scaling.

When you enable the exaggeration of
the dimensions, a drawing dimension
that is narrower than the defined limit
is expanded. Exaggeration limit
defines the default value for this limit.

Exaggeration scaling defines
whether you are using Paper or
Model as the exaggeration scaling
method:

• If you select Paper, the
exaggeration limit is multiplied by
the view scale.

• If you select Model, and the scale
is 1:10, all the dimensions smaller
than 10 mm are exaggerated
regardless of the drawing scale.

For more information about
exaggerated dimensions, see .

Absolute dimensions Show zero in absolute dimensions
--> Yes shows zero at the zero points
in absolute dimensions.

Draw absolute dimension values
parallel to dimension line --> Yes
shows dimensions parallel to
dimension lines in absolute
dimensions.

For more information, see
Dimensions in tags Units, Format and Precision define

the default unit, format and precision
used in dimension tags.

Available units: mm, cm, m, foot -
inch, cm / m, inch, feet.
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Option Description
Available formats: ###, ###[.#],
###.#, ###[.##], ###.##, ###[.###],
###.###, ### #/# and ###/##.###.

Available precision: 0.00, 0.50, 0.33,
0.25, 1/8, 1/16, 1/32, 1/10, 1/100,
1/1000

Show dimension in middle tag of
automatic dimension

Defines whether you want to create
dual dimension tags in assembly,
single-part, cast unit, or general
arrangement drawings.

For more information about
automatic dual dimensions, see .

For more information about manual
dual dimensions, see

When Tekla Structures creates the
drawing, it adds the lower dimension
tag in the selected unit, format and
precision.

Dimension line Dimension line extension length
for line arrow defines the length of
the line extension for dimensions that
have line arrows.

Note that line extensions are not
applied to dimensions that have
different arrows from line arrows,
and certain knock-off dimension
types.

Drawing objects settings
NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

Option Description
Edge chamfer Line color defines the default line

color of the edge chamfers in
drawings.

Line type defines the default line
type of the edge chamfers in
drawings.
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Option Description
These values are overridden by the
values set in the Edge Chamfer
Properties dialog box.

For more information about edge
chamfers, see .

General settings
NOTE: On this page, Autosave settings are user specific. All other settings are
model specific. Changing the settings does not require Tekla Structures
restart.

Option Description
Autosave Autosave interval: Autosave after

every xx modeling or editing
commands defines how often Tekla
Structures automatically saves a
model and a drawing.

This number represents the number
of commands you have given. For
example, if you create many objects
without interrupting (Esc), it counts as
one command.

Autosave after creating every xx
drawings defines the number of
drawings after which Tekla Structures
automatically saves your work.

For more information, see:

Default adaptivity Off means that adaptivity is not
defined.

Relative defines that handles retain
their relative distances to the nearest
part faces in relation to the part’s
overall size.

Fixed defines that handles retain
their absolute distances to the
nearest part faces.

You can also modify the adaptivity
settings for each part separately.
These modifications override the
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Option Description
default settings in the Options dialog
box.

For more information about
adaptivity, see

Load modeling settings
Use the settings on the Arrow length tab to scale loads in model views.

Use the settings on the other tabs of this page to define the building code and
safety factors Tekla Structures uses in load combination.

NOTES:

• Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

• You should not need to change the building code or safety factors during
the project. If you change these settings, you will also need to change the
load group types and check the load combinations.

Numbering settings
NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

Option Description
Position number separator Defines the default position number

separator. The options are dot (.),
comma (,), slash (/), and hyphen (-).

Rebar position number separator Defines the default reinforcing bar
position number separator. The
options are dot (.), comma (,), slash (/),
and hyphen (-).

Part number type Defines the default part number type.
The options are Part number and
Combined assembly / part number.

Orientation mark settings
NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

For details of what affects the part orientation and how, see .
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Option Description
North direction Project north (degrees counter

clockwise from global x) defines
which direction is north in the model.
Enter the value in degrees counter-
clockwise from the global x axis.

Part viewing direction Defines which direction parts are
viewed from in drawings.

Beam skew limit

Column skew limit

Tekla Structures uses limit angles to
determine whether a part is a beam
or a column when creating
orientation marks. Tekla Structures
treats parts outside these limits as
braces.

Parts skewed more than 80° are
columns.

Parts skewed less than 10° are
beams.

Preferred location for mark Defines the location of part marks in
drawings, to the left or right end of
the part.

Mark always to center of column This setting only affects columns.

Yes places part marks in the center of
columns in plan views. To indicate
part orientation, include compass
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Option Description
direction (Face direction) in the part
mark instead.

No places part marks on the same
flange in general arrangement and
assembly drawings.

Rebar set settings
NOTE: Settings on this page are model specific and only apply to rebar sets,
not to single reinforcing bars, reinforcing bar groups, or reinforcement
meshes. Changing the settings does not require Tekla Structures restart, but
you need to update the existing rebar sets in the model. To do this, go to the
Rebar tab on the ribbon and click More --> Regenerate.

Option Description
Covers and locations tab
Concrete cover Under Part global coordinate

system, define the default concrete
cover thickness between the rebar set
bars and the following faces of
concrete parts:

• Top

• Bottom

• Sides

To use the parts' local coordinate
system, under Part local coordinate
system, define the default concrete
cover thickness at the following faces
of concrete parts:

• Top

• Bottom

• Front

• Back

• Start

• End

You can also define concrete cover
settings for each concrete part
separately. These modifications
override the default settings in the
Options dialog box.
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Option Description
Layer prefix Under Part global coordinate

system and/or Part local coordinate
system, define the default bar layer
prefixes at different faces of concrete
parts.

You can also define bar layer settings
for individual rebar sets or leg faces,
or for individual bars using the user-
defined attributes of property
modifiers. These modifications
override the default settings in the
Options dialog box.

Links Define the bar layer prefix for rebar
set bars that have four or more legs,
for example closed stirrups.

General tab
Minimum lengths to be created Define Minimum bar length to

prevent Tekla Structures from
creating reinforcing bars that are too
short. This setting is primarily for
straight bars. Enter the minimum bar
length as Distance or as Coefficient
of bar diameter.

Define Minimum straight start/end
leg length for bent reinforcing bars.
Enter the minimum leg length as
Distance or as Coefficient of bar
diameter.

These settings are also available in
the Rebar set properties and in the
Rebar property modifier properties.

Rounding and step tapering tab
Rounding Define whether the lengths of straight

bars, first and last legs, and
intermediate legs are rounded in the
model, and whether the bar lengths
are rounded up, down, or to the
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Option Description
nearest suitable number according to
the rounding accuracy.

At splitter locations, define how much
the bar lengths can be rounded up.

Rounding settings are also available
in the Rebar set properties and in the
Rebar property modifier properties.

Step tapering Define the tapering step values for
straight bars, first and last legs, and
intermediate legs.

Step tapering settings are also
available in the Rebar set properties
and in the Rebar property modifier
properties.

Units and decimals settings
NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

The number located to the right of each option indicates the number of
decimals. The number of decimals affects the input and storage accuracy.
Always use a sufficient number of decimals.

For more information on unit and decimal settings, see Change units and
decimals.

Option Description
Length mm, cm, m, in (decimal), ft

(decimal), ft-in
Angle o, rad
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Option Description
Spring constant

Rot. spring constant

Factor (unitless)
Force
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Option Description
Distributed load

Surface load

Moment

Distributed moment

Temperature oC, oF, K
Deformation
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Option Description
Section dimension

Angle o, rad
Area

Section modulus

Moment of inertia mm4, cm4, in4
Radius of inertia

Torsion constant mm4, cm4, in4
Warping constant mm6, cm6, in6
Cover area
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Option Description
Strength

Modulus

Density
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Option Description
Weight

Strain o/oo, %, (unitless)
Thermal dilat. coeff. 1/oC, 1/oF, 1/K
Ratio o/oo, %, (unitless)
Volume

Length mm, cm, m, in (decimal), ft
(decimal), ft-in

Angle o, rad
Reinforcement area

Transverse reinforc.

Weight

Mass/Length
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Option Description
Volume

Force

Distributed load

Surface load

Moment

Temperature oC, oF, K

Files and folders in Tekla Structures 295 File storing options and advanced options



Option Description
Stress

Deformation

See also

File storing options and advanced options (page 276)

Settings defined by advanced options

Advanced options can be user-, model-, system or role-specific:

• User-specific advanced options are saved in your local options.bin file,
which is by default located in C:\Users\<user>\AppData\Local
\Trimble\Tekla Structures\<version>\UserSettings, and work in
the specified way in all models that you have. The folder can be changed
using the advanced option XS_USER_SETTINGS_DIRECTORY. In the
Advanced Options dialog box, the type is USER. Some user-specific
advanced options require restarting of Tekla Structures after changing the
value.

• Model-specific advanced options work in the specified way only in the
current model. They are saved to options_model.db and
options_drawings.db under model folder. In the Advanced Options
dialog box, the type is MODEL or DRAWING. Some special model-specific

Files and folders in Tekla Structures 296 File storing options and advanced options



options that are not visible in the Advanced Options dialog box can be
changed from options.ini file under the model folder.

• System-specific advanced options are general to all sessions of Tekla
Structures, and work in the specified way for all users and in all models. In
the Advanced Options dialog box, the type is SYSTEM. A system-specific
advanced option can be stored to options database by clicking SYSTEM
next to the option and changing it to MODEL(SYSTEM). Note that the
changed value only works for the current model. A MODEL(SYSTEM)
advanced option can be changed back to SYSTEM by changing it to
SYSTEM, and in this case it will be removed from the options database.
Some system-specific advanced options require restarting of Tekla
Structures after changing the value.

The system-specific advanced options are read from environment .ini
files:

• Global system settings are read from common env_global_default.ini
(page 273) in ..\ProgramData\Trimble\Tekla Structures
\<version>\environments\common\. These settings are used in all
environments.

• Environment-specific system settings are read from
env_<environment>.ini (page 274) in your environment folder. They
override any settings that are defined on a global level in
env_global_default.ini.

• Role-specific system settings are read from role_<role>.ini (page 274)
in environment folder. They override any settings that are defined on a
global and environment level in env_global_default.ini and
env_<environment>.ini.

• Company level system-specific system settings override all other
system-specific advanced options. You can save them in the firm or
project folders by setting the folders for the advanced options and .

• SYSTEM(ROLE) options are typically role specific. The settings are read
from .ini files and are not saved to the databases. When changed or if
the type is changed, the option will become model specific and be saved to
the databases. MODEL/DRAWING(ROLE) options are SYSTEM(ROLE)
options whose type and/or setting has been changed. The change would
be used when you want the SYSTEM(ROLE) option to be saved with the
model to options_model.db and options_drawings.db under model
folder. These settings can be set back to SYSTEM(ROLE), which will then
take into use the default value.

See also

Typical initialization files (.ini files) and their reading order (page 269)
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Change the advanced option values in the Advanced
Options dialog box
Use advanced options to configure Tekla Structures to suit the way you work,
or to comply with specific project requirements or industry standards. Change
the advanced options only in the Advanced Options dialog box. The settings
in the Advanced Options dialog override the settings in any other
initialization file.

1. On the File menu, click Settings --> Advanced options to open the
Advanced Options dialog box, or press Ctrl+E.

2. Browse the categories to find the advanced option you want to set. 

You can also enter a search term in the Search box. To search the search
term in all categories, select In all categories. You can also use wildcards.
For example, to find all advanced options that have the words anchor
and filter and that have any characters between these two words,
enter anchor*filter.

3. Set the advanced option to the desired value by entering the value or by
selecting the value from the list. 

• You can change the type of the role-specific advanced options from
SYSTEM (ROLE) to MODEL (ROLE) or DRAWING(ROLE) and vice versa
from the list next to the option type. When you change the option type
to SYSTEM(ROLE), the value automatically changes to the default
value. When you enter a value for a SYSTEM (ROLE) option, it changes
to MODEL (ROLE) or DRAWING(ROLE).

• You can change the type of system-specific advanced options from
SYSTEM to MODEL(SYSTEM), in which case the value is saved in the
options database. If you reset the advanced option back to SYSTEM,
the value will be removed from the options database and the value
specified in initialization files will be used.

• You can use switches with some advanced options, for example, to
define the contents of marks: %TPL:PROJECT.NUMBER%.

• If you are defining a switch for an advanced option in the Advanced
Options dialog box, use single percent signs %xxx% around the switch.
If you are defining the switch in an .ini file, use double percent signs %
%xxx%% around the switch.

• If you need to enter a folder path, you can type a backslash at the end
of the folder path or leave it out.

4. Click Apply or OK. 

TIP To create a complete list of advanced options in a text file, click
Write to file. The list shows the name of the advanced option
together with its current value and type. Note that writing to a file is
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only an export of the current settings, it is not another way of
changing the advanced options.

See also

Settings defined by advanced options (page 296)

6.4 Input files (.inp files)
Tekla Structures uses input files for various purposes, for example, to manage
user-defined attributes and some component dialog boxes, and for defining
how components work. All input files have the extension .inp.

Input files that you can use for configuring Tekla Structures are listed below.

File Description
analysis_design_conf
ig.inp

Contains settings for analysis and design.

fltprops.inp Includes materials and dimensions of available
flat bars (page 309).

mesh_database.inp Contains definitions for reinforcement meshes.
objects.inp Used to manage user-defined attributes

(page 302).
objects_rebar_set.in
p

Used to manage user-defined attributes of rebar
sets.

pop_mark_parts.inp Contains settings for pop-marking.
privileges.inp Used to control access rights.
profitab.inp Contains available parametric profiles (page 162).
rebar_config.inp Contains settings for reinforcement marks.
rebar_database.inp Rebar catalog (page 243). Contains definitions for

reinforcing bars and strands.
rebar_schedule_confi
g.inp

Contains internal bending types of reinforcing
bars and their mapping to area specific bending
codes.

Rebar shape manager is a more versatile way to
define reinforcing bar bending shapes.

Tekla Structures also imports and exports rebar catalogs as .inp files.

See also

Environment database file (page 304)
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Properties of the objects.inp file

Here, we explain the structure of user-defined attribute definitions. For
general information on modifying the definitions, such as file locations and
reading order, see Define and update user-defined attributes (UDAs)
(page 302).

The example below shows the main properties of objects.inp.

Property In the example Description
attribute or 
unique_attribute

attribute attribute is a regular
attribute, which is
copied with other part
properties.

unique_attribute is a
non-copyable attribute.
The value of the
attribute is never copied
to another part. For
example part checking
status attributes usually
cannot be copied.

attribute_name MY_INFO_1 Attribute name, used to
find the attribute value.

Ensure that Tekla
Structures does not
already use the attribute
name you use. Consider
using a prefix that
ensures the name is
unique, for example,
your initials, or an
abbreviation of your
company name.

The attribute name is
case-sensitive. Do not
use spaces or reserved
characters in attribute
names. The maximum
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Property In the example Description
length of the name can
be 19 characters.

To include the attribute
in a report or template,
add the name of the
attribute to your layout
in the Template Editor.
When you run a report
or create a drawing,
Tekla Structures displays
the current value of the
attribute.

label_text My Info 1 Label that Tekla
Structures displays in
the dialog box.

Some default attributes
have prompts like 
j_comment, meaning
that the prompt comes
from the joints.ail
message file.

value_type string integer or float for
numbers

string for text

string_not_modifiab
le for text whose
modification is
prevented. A field with
the 
string_not_modifiab
le property is always
displayed as dimmed
and it cannot be
switched on or off. The
value in the field is not
saved when clicking the
Apply button or
modified when clicking
the Modify button.

option for lists

date for date with small
calendar
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Property In the example Description
date_time_min for
date and time [12:00]
with small calendar

date_time_sec for
date and time [12:00:00]
with small calendar

If you change the value
type of a field that
already contains values
in the model, make sure
that the values are valid
for the new data type
and verify the results.

field_format %s Definition of the field
format in the dialog box

• %s for strings

• %d for numbers
special_flag no no or yes

For parts: consider in
numbering

For drawings: display the
attribute value in
Document manager

For other elements: no
effect

check_switch none none
This option is not used.

attribute_value_max 0.0 0.0
This option is not used.

attribute_value_min 0.0 0.0
This option is not used.

Define and update user-defined attributes (UDAs)
The property pane and many dialog boxes contain user-defined attributes
(UDAs) for various objects, including beams, columns, bolts and drawings.
Tekla Structures displays these fields when you click the More button in the
property pane or the User-defined attributes button in a dialog box. For
example, comment, locked, and erection status are user-defined attributes.
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When you define new user-defined attributes

The user-defined attributes are managed in the objects.inp (page 300) file. To
define new user-defined attributes, create your own objects.inp file in the
model, project or firm folder. After adding your own user-defined attributes,
you need to run the Diagnose and change attribute definitions command
to update the definitions (page 304) in the model.

When you define new user-defined attribute (page 305), make the definition of
the user-defined attribute unique. This is because a user-defined attribute
cannot have different definitions for different object types, such as beams and
columns.

The object.inp files are merged so that if there are user-defined attributes
in any of the files, they are displayed in the user interface. Tekla Structures
merges the files in a way that eliminates duplicate attributes. If Tekla
Structures encounters the same attribute name in different objects.inp
files, the attribute from the first read objects.inp file will be used.

If you need to have several objects.inp files in the same folder, you can use
a suffix in the file name to use all the files. This enables having several
objects_<suffix>.inp files in the same folder. The file name could be
objects_precast.inp, for example.

WARNING Do not copy the objects.inp file in the ..\environments
\common\inp\ folder. Copying the file creates unnecessary
duplicates and later objects.inp updates by Tekla Structures
can be lost.

Tekla Structures reads the objects.inp files from the following folders in the
following order:

1. model folder

2. project folder

3. firm folder

4. system folder

5. inp folder

Changing existing user-defined attribute definitions

Updating a user-defined attribute definition in a model does not convert any
values that are already stored in the field. If you change the value type of a
field that already contains values in the model, make sure that the values are
valid for the new data type and verify the results.

The safest approach is to create a new attribute when the format of the values
in the field changes. If you want to convert user-defined attribute values, you
can create a report that lists the values, convert them using external tools and
import the converted values (page 400).
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See also

Environment database file (page 304)

Update definitions of user-defined attributes (UDAs) in a model
When you have changed definitions of a user-defined attribute by modifying
the objects.inp file, you need to update the definitions in the model.

1. Open the model.

2. On the File menu, click Diagnose & repair and in the Utilities area, click
Diagnose and change attribute definitions. 

The Diagnose & Change Attribute Definitions dialog box opens.

3. Select an attribute from the list on left side to see the comparison of
current definitions and objects.inp definitions.

4. Select the definitions you want to update in the Object classes with
Objects.inp differences compared to current settings list.

5. Click Change current settings to selected Objects.inp settings.

See also

Define and update user-defined attributes (UDAs) (page 302)

Environment database file (page 304)

Properties of the objects.inp file (page 300)

Example: Create and update a user-defined attribute (UDA) (page 305)

Environment database file
To guarantee consistent model behavior when a model is used with different
roles, the environment database file (environment.db) contains the
definitions of the user-defined attributes (UDAs) used in the model.

When you create a new model, Tekla Structures merges the definitions from
your objects.inp (page 300) files to the environment.db file. Later, when you
add new user-defined attributes in the objects.inp file, the definitions are
saved in environment.db as you open the model.

You can modify your user-defined attributes (page 302) in an objects.inp
file but the changed definitions do not come into effect automatically. If there
are conflicts, the definitions in environment.db win. You need to run the
Diagnose and change attribute definitions command to see the conflicts
between environment.db and objects.inp, and select the attribute
definitions that you want to update.

See also

Update definitions of user-defined attributes (UDAs) in a model (page 304)
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Example: Create and update a user-defined attribute (UDA) (page 305)

Example: Create and update a user-defined attribute (UDA)
This example shows how to create your own user-defined attribute (UDA) and
update the model to use the changed attribute definition.

Create a user-defined attribute

1. Create a new model and save it.

The user-defined attributes in the model are merged from objects.inp
(page 302) files and Tekla Structures saves the attribute definitions in the
environment.db (page 304) file in the model folder.

2. Close the model.

3. Create an input file called objects.inp in the model folder by using a
standard text editor.

4. Enter the following information in objects.inp. For details about the
properties in the attribute string, see objects.inp (page 302).

/
*********************************************************
******************/
/* Part attributes */
/
*********************************************************
******************/
part(0,"Part")
{
/* User defined tab page */
tab_page("My UDA tab")
{
/* User defined attribute */
attribute("MY UDA", "My UDA", string,"%s", no, none,
"0,0", "0,0")
{
value("", 0)
}
}
tab_page("My UDA tab", "My UDA tab", 19)
modify (1)
}
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/
*********************************************************
******************/
/* Column attributes */
/
*********************************************************
******************/
column(0,"j_column")
{
/* Reference to the user defined tab page that is defined
above in */
/* the part() section: */
tab_page("My UDA tab", "My UDA tab", 19)
modify (1)
To see the example text file, click objects.inp - example 1.

NOTE If you want to create a user-defined attribute that also affects
numbering, set the special_flag (page 300) property of the
attribute to yes (it is no in the example above). Also, just like in
the example above, the definition of the tab_page must be in the 
part section, and the column (beam, etc.) section must have only
a reference to it.

5. Save objects.inp.

Test the user-defined attribute

1. Open the model.

2. Create a steel column.

3. Double-click the steel column to open its properties in the property pane.

4. Click the More button.

5. Go to My UDA tab.

6. Enter a value in the My UDA box.

7. Click Modify.

8. Copy the steel column.

9. Check the My UDA box of the new steel column.

The attribute value was also copied.
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10. Close the model.

Modify the user-defined attribute to make it unique

1. Open the objects.inp file in the model folder by using a standard text
editor.

2. Enter unique_ before the user-defined attribute.

/
*********************************************************
******************/
/* User-defined attributes */
/
*********************************************************
******************/
part(0,"Part")
{
/* Common tab pages for part attributes */
tab_page("My UDA tab")
{
unique_attribute("MY UDA", "My UDA", string,"%s", no,
none, "0,0", "0,0")
{
value("", 0)
}
}
tab_page("My UDA tab", "My UDA tab", 19)
modify (1)
}
/
*********************************************************
******************/
/* Column attributes */
/
*********************************************************
******************/
column(0,"j_column")
{
tab_page("My UDA tab", "My UDA tab", 19)
modify (1)
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}
This makes the user-defined attribute unique, meaning that the value of
the user-defined attribute will not be copied to another part.

3. Save objects.inp.

To see the example text file, click objects.inp - example 2.

Test the unique user-defined attribute

1. Open the model.

2. Enter a value in the My UDA box for a steel column and click Modify.

3. Copy the steel column.

4. Check the My UDA box of the new column.

5. The value was copied, so the user-defined attribute in the model is not
unique. There is a conflict between the environment.db and
objects.inp definitions.

Update the definitions of user-defined attributes

1. On the File menu, click Diagnose & repair and in the Utilities area, click
Diagnose and change attribute definitions.

The Diagnose & Change Attribute Definitions dialog box opens.

2. Select My UDA in the Attribute area on the left.

You can see that My UDA is not unique in the current setting, but it is set
to unique in objects.inp.

3. Select the definition in the area on the right.

4. Click Change current settings to selected Objects.inp settings.

Now the definition of the user-defined attribute is updated in the model.

If you now copy a steel column that has a value for My UDA, the value is
not copied to the new column.

See also

Update definitions of user-defined attributes (UDAs) in a model (page 304)

Define and update user-defined attributes (UDAs) (page 302)

Properties of the objects.inp file (page 300)
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Show plates as flat bars in drawings and reports
Tekla Structures can show plates as the equivalent flat bars for manufacturing.
Tekla Structures displays the plates as flat bars in reports and drawings.

1. Set the advanced option XS_USE_FLAT_DESIGNATION to TRUE.

2. Indicate the prefix you want to use for flat bars using the advanced option
XS_FLAT_PREFIX. 

For example, XS_FLAT_PREFIX=FLAT.

3. Set other platework-related advanced options as required.

4. Define materials, thickness, and width of available flat bars in the
Fltprops.inp (page 309) file.

TIP • To prevent Tekla Structures from displaying the profile in metric units in the
US environment Imperial role, add the flat bar prefix to the profitab.inp
(page 178) file as a parametric profile.

• See also page Platework in the Advanced Options dialog box for
information about advanced options related to platework.

Define flat bar sizes with the Fltprops.inp file
Use the Fltprops.inp file, located in the \profil folder under the
environment folder ..\ProgramData\Trimble\TeklaStructures
\<version>\environments\, to define flat bar thickness, width and
material. The exact location may vary depending on your environment.

NOTE Copy the Fltprops.inp file to a model, project or firm folder and then
modify the file in the new location as required.

The first row in the file contains flat bar material definitions (enclosed in
quotes " ", and without spaces) followed by plate thicknesses. If you do not
define a material, you can use all materials for all flat bars. The following rows
define the widths of available flat bars.

The units are millimeters.

Example

Fltprops.inp contains the following data:
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With the above data, Tekla Structures displays the following plates as flat bars:

Plate Material
5x40, 5x45, 6x50, 6x55 All materials
8x60, 8x65, 10x70, 10x75 S235
10x100, 10x110, 15x200, 15x220 S275J0

The flat bars get the prefix that is set in the XS_FLAT_PREFIX advanced option.

See also

Show plates as flat bars in drawings and reports (page 308)

Define unfolding parameters in the
unfold_corner_ratios.inp file
The unfolding parameters define the location of the neutral axis when a
profile is unfolded. The neutral axis is a line which runs along the length of a
profile where stress and strain are equal to zero. Tekla Structures uses these
parameters to create NC files and to display unfolded profiles in single-part
drawings.

To define unfolding parameters, modify the unfold_corner_ratios.inp
file, located in ..\ProgramData\Trimble\Tekla Structures\<version>
\environments\common\system, using a standard text editor. You can copy
the unfold_corner_ratios.inp file to a model, project or firm folder and
then modify the file in the new location as required. Tekla Structures searches
for this file in the default search order.

After modifying the unfold_corner_ratios.inp file, restart Tekla
Structures for the changes to take effect.

NOTE The settings in the unfold_corner_ratios.inp file have no effect
in the following cases:

• If the advanced option
XS_USE_OLD_POLYBEAM_LENGTH_CALCULATION is set to TRUE.

• If the advanced option
XS_CALCULATE_POLYBEAM_LENGTH_ALONG_REFERENCE_LINE is
set to TRUE. This only applies to polybeams with straight sections.

Unfold parameter properties

See below for an example of unfolding parameters in the
unfold_corner_ratios.inp file and the descriptions of the parameters.

1 HE300A S235JR 0 180 2 0 1000 .7
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Property In the example Description
Type 1 1 is polybeams

2 is plates modeled as
polybeams (for example,
PLT)

3 is for parts which are
not unfolded and follow
the old polybeam
calculation (for example,
the line 3 L* * disables
unfolding of L profiles)

Profile HE300A You can also use
wildcards with profile,
for example, HE300*.

Material S235JR You can also use
wildcards with material,
for example, S235*.

Rotation / thickness min 0 For polybeams: the
minimum angle when
the profile is rotated
around its longitudinal
axis

For plates: the minimum
thickness of plate

Rotation / thickness max 180 For polybeams: the
maximum angle when
the profile is rotated
around its longitudinal
axis

For plates: the maximum
thickness of plate

Flag 2 This property defines
what kind of parts are
affected by the next two
properties.

1 is sharp folds. Only
polybeams with straight
chamfers are affected.

2 is curved bends. Only
polybeams with curved
chamfers are affected.
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Property In the example Description
Angle / radius min 0 For sharp folds: the

minimum angle

For curved bends: the
minimum radius

Angle / radius max 1000 For sharp folds: the
maximum angle

For curved bends: the
maximum radius

Ratio .7 Defines how much the
profile stretches or
shrinks when unfolded.

Ratio = (1 - the relative
location of the neutral
axis).

If only the inner surface
of the profile shrinks,
the ratio is 1. If only the
outer surface of the
profile stretches, the
ratio is 0. By default, the
ratio is 0.5 for length
calculation and 0.0 for
bending radius
calculation.

Tekla Structures applies
the unfolding ratio if the
profile properties are
within the range
indicated by the
minimum and maximum
values.

See also

Folder search order (page 358)

6.5 Data files (.dat files)
Data files contain information used by certain components, or Rebar shape
manager, for example.
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WARNING These files affect the operation of components or Rebar shape
manager. Do not modify the files listed here unless you are an
administrator.

File Description
joints.dat Contains data used in Handrailing (1024) and

Stanchions (S76) components. Used in the
Stanchion connection type option.

railings.dat Contains data used in Handrailing (1024). Used in
the Stanchion connection type option.

steps.dat Contains the data for Stairs (S82) and Stairs
(S71). Used in the Step profile and Catalogue
step options.

std_flange_plates.d
at

Contains data for Tapered column (S99). Used in
the options:

• Outer flange profile

• Inner flange profile

• Top plate profile
std_stiffener_plate
s.dat

Contains data used in Tapered column (S99).
Used in the Horizontal stiffener profile box.

marketsize.dat Contains available market sizes for certain
material grade. Can be used with fMarketSize()
function in the custom component editor.

import_macro_data_t
ypes.dat

Contains the user-defined attributes that you can
include in an input file in attribute import.

RebarShapeManager.C
ustomProperties.dat

Contains the custom properties, template
attributes, and user-defined attributes that you
can use in bending shape rules in Rebar shape
manager.

Note that default data files are read from the environment's system folder, but
user-defined data files are stored in the model’s \attributes folder.

See also

Define flat bar sizes with the Fltprops.inp file (page 309)

6.6 Message files
Tekla Structures uses the information in the message files to display messages
in the user interface. Message files include, for example, texts used in dialog
boxes.
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• Message files with the .ail extension are located in the folder ..\Tekla
Structures\<version>\messages.

• Message files with the .xml extension are located in the folder ..\Tekla
Structures\<version>\messages\DotAppsStrings.

The files include texts in languages in which the Tekla Structures user interface
is available.

See also

Customize message files (page 314)

Customize message files
You can customize the messages that Tekla Structures displays in the user
interface.

1. Do one of the following: 

• To modify an .ail message file, go to the ..\Tekla Structures
\<version>\messages folder.

• To modify an .xml message file, go to the ..\Tekla Structures
\<version>\messages\DotAppsStrings folder.

2. Open the message file you want to customize using a standard text editor.

3. Modify the message as required.

4. Save the message file.

Example: customize a message file

In this example, you will modify a message that Tekla Structures uses for near
side plates in drawings. You want Tekla Structures to display (NS) instead of 
(N/S).

1. Go to the ..\Tekla Structures\<version>\messages folder.

2. Open by_number.ail using a standard text editor.

The by_number.ail file contains both prompts and default texts that
Tekla Structures uses in drawings.

3. Browse to the following section:

string by_number_msg_no_675
{
...
entry = ("enu", "(N/S)");
};

4. Change (N/S) to (NS) in the entry row.
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5. Save and close the file.

See also

Message files (page 313)

6.7 Property files
Property files are files that contain the object properties and settings that are
displayed in the property pane or in the dialog boxes of different model
objects or drawing objects.

By default, Tekla Structures uses the standard (page 316) property files when
you apply commands. The default standard property files are read from the
environment's system folder.

In addition to the default property files, you can define user-defined property
files, and load these saved properties later when you create, for example, new
model objects or drawing objects. Tekla Structures stores the saved, user-
defined property files in the current model’s \attributes folder.

To save a user-defined property file, do the following:

In the property pane In a dialog box
1. Enter a name for the property file

in the box next to the  button.

2.
Click  to save the property file.

1. Enter a name for the property file
in the box next to the Save as
button.

2. Click Save or Save as to save the
property file.

Example

Change the standard (page 316) steel column properties so that you create a
new type of column that you call custom1.

1. Open the steel column properties in the property pane.

2. Enter or modify the properties you want to save.

3. In the box next to the  button, enter a name for the new column
properties, for example, custom1.

4. Click .

Tekla Structures saves the new custom1.clm property file in the current
model’s \attributes folder.

See also

Model folder files and file name extensions (page 333)
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6.8 Standard files
Standard files are property files that Tekla Structures uses by default when you
apply commands.

The standard properties are displayed in the property pane of different model
objects, such as beams, columns or plates, or in the dialog boxes of, for
example, drawing objects.

How to take standard files into use

• In the property pane: the properties are loaded when you select the
standard option in the upper part of the property pane. The properties are
in use immediately.

If the values that you loaded are different from the previous values, the
property pane highlights the modified properties.

• In dialog boxes: the properties are loaded when you select the standard
option in the list next to the Load button, and click the Load button.

Standard files are named standard.* where the symbol * is the file name
extension. For example, standard.clm file is used for steel column
properties. The user-defined attributes are saved with the standard files as
*.morefiles. For example, standard.clm.more file is used for steel column
user-defined attributes.

Tekla Structures reads the default standard files from the environment's
system folder.

Save a set of standard files

If needed, you can save a set of standard files in the current model's
\attributes folder.

You can then copy the standard files to the project folder or the firm folder
for future use, to set up Tekla Structures to suit the way you work.

1. To save a set of standard files, go to Quick Launch.

2. Start typing save defaults.

3. Select the Save defaults command from the list.

Tekla Structures saves the following list of standard and *.more files in
the ..\TeklaStructuresModels\<model_name>\attributes folder:
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File Property
standard.bpl
standard.bpl.more

Bent plate properties

standard.clm
standard.clm.more

Steel column properties

standard.cpl
standard.cpl.more

Contour plate properties

standard.crs
standard.crs.more

Orthogonal beam properties

standard.dia
standard.dia.more

Twin profile properties

standard.fms
standard.fms.more

Plotting frames

standard.fpl
standard.fpl.more

Folded plate properties

standard.ipc
standard.ipc.more

Concrete item properties

standard.ips
standard.ips.more

Item properties

standard.ler
standard.ler.more

Layer properties

standard.mvi
standard.mvi.more

Model view properties

standard.num
standard.num.more

Numbering setup

standard.prf
standard.prf.more

Project properties

standard.prt
standard.prt.more

Steel beam properties

standard.scr
standard.scr.more

Bolt properties

standard.wld
standard.wld.more

Weld properties
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4. If you want to load the default property settings from the standard files
that are saved in the attributes folder, go to Quick Launch and use the
Load defaults command.

Create user-defined standard files

You can also create your own standard files. Tekla Structures saves the user-
defined standard files in current model’s \attributes folder.

1. To save a user-defined standard file, open the property pane or a dialog
box whose properties you want to save as a standard file.

2. Modify or enter the properties.

3. Save the properties.

• In the property pane: enter standard as the name

, and click .

• In a dialog box: in the box next to the Save as button, enter standard

as the name , and click Save as.

Tekla Structures saves the standard file and the related *.more file in
the current model’s \attributes folder. If a standard file with the same
file name extension exists in the in the \attributes folder, Tekla
Structures overwrites the previous file.

4. When you want to load the standard file, select it from the list of the
property files in the property pane or in a dialog box.

Alternatively, to load the default property settings from the standard
files that are saved in the attributes folder, go to Quick Launch and
use the Load defaults command.

See also

Property files (page 315)

Settings in the Options dialog box (page 277)

6.9 Catalog files
Tekla Structures uses ASCII and binary files to manage profile, material,
reinforcement, bolt and bolt assembly catalogs.

Each environment has its own folder, where the files related to different
catalogs are stored. For example, ..\environments\uk\general\profil\
contains the files for managing catalog files used in the United Kingdom. The
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exact file location may vary depending on the folder structure of your
environment files.

The following table lists files and file types related to catalogs.

File type File name Used for Located in
.inp profitab.inp Defines the names

that you can use
for parametric
profiles.

In the \profil folder,
under the environment
folders,
in ..\ProgramData
\Trimble\Tekla
Structures
\<version>
\environments
\<environment>\

rebar_databas
e.inp

The rebar catalog. In the \profil folder,
under the environment
folders,
in ..\ProgramData
\Trimble\Tekla
Structures
\<version>
\environments
\<environment>\

mesh_database
.inp

The reinforcement
mesh catalog.

In the \profil folder,
under the environment
folders,
in ..\ProgramData
\Trimble\Tekla
Structures
\<version>
\environments
\<environment>\

You can define
the file name
while exporting.

Created when you
export rebar
catalogs.

You can define the
folder where to export
the files.

.cnv matexp_<softw
are>.cnv

Contains
information to
convert material
names when
transferring model
information using
links. For example,
converts S235JR to
FE360B for DSTV.

In the \profil folder,
under the environment
folders,
in ..\ProgramData
\Trimble\Tekla
Structures
\<version>
\environments
\<environment>\

prfexp_<softw
are>.cnv

Contains
information to

In the \profil folder,
under the environment
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File type File name Used for Located in
convert profile
names when
transferring model
information using
links. For example,
converts HEA100
to HE100A for
DSTV.

folders,
in ..\ProgramData
\Trimble\Tekla
Structures
\<version>
\environments
\<environment>\

.clb For example,
RU_CF.clb

Contains the
definitions of
parametric
profiles used in
profitab.inp.

..\ProgramData
\Trimble\Tekla
Structures
\<version>
\environments
\common\inp

.lis You can define
the file name
while exporting.

Created when you
export bolt, profile
and material
catalogs.

You can define the
folder where to export
the files.

.db assdb.db The bolt assembly
catalog.

In the \profil folder,
under the environment
folders,
in ..\ProgramData
\Trimble\Tekla
Structures
\<version>
\environments
\<environment>\

screwdb.db The bolt catalog. In the \profil folder,
under the environment
folders,
in ..\ProgramData
\Trimble\Tekla
Structures
\<version>
\environments
\<environment>\

.bin profdb.bin The profile
catalog.

In the \profil folder,
under the environment
folders,
in ..\ProgramData
\Trimble\Tekla
Structures
\<version>
\environments
\<environment>\

Files and folders in Tekla Structures 320 Catalog files



File type File name Used for Located in
matdb.bin The material

catalog.
In the \profil folder,
under the environment
folders,
in ..\ProgramData
\Trimble\Tekla
Structures
\<version>
\environments
\<environment>\

See also

Customize the profile catalog (page 146)

Customize the material catalog (page 138)

Customize the bolt catalog (page 226)

Customize the rebar catalog (page 243)

6.10 Font files and font conversion files
You can define the location of font files with the advanced option 
DXK_FONTPATH in the teklastructures.ini or your environment
initialization file. For example, you can use fonts available in the
folder ..\ProgramData\Trimble\Tekla Structures\<version>
\environments\common\fonts.

This folder includes the following fonts:

Font Font type
fixfont.fon Tekla Structures system font
romco.fon Tekla Structures system font
romsim.fon Tekla Structures system font
romsim8.fon Tekla Structures system font

Fonts are converted using font conversion files available in the same folder:

File Description
template_fonts.cnv Used for converting Tekla Structures

system fonts (Template Editor fonts)
to Windows fonts in DWG/DXF export.

dxf_fonts.cnv Used for converting True Type fonts
to SHX fonts (font format understood
by AutoCAD) in DWG/DXF export.
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NOTE The Cyrillic fonts GOST 2.304-81 type A.ttf and GOST 2.304-81 type
B.ttf are located in the C:\Windows\Fonts folder, not
the ..\ProgramData\Trimble\Tekla Structures\<version>
\environments\common\fonts folder.

See also

Initialization files (.ini files) (page 268)

6.11 Symbol files
Symbols are used for example in various places in drawings, for example, as
separate objects, and in marks.

You can create symbols with Symbol Editor. In this case, the file name
extension is .sym. You can also use symbols of .dwg format.

Tekla Structures symbol files are by default located in the
folder ..\environments\common\symbols.

6.12 Files related to templates, reports and drawings
Tekla Structures has several files that relate to templates, reports, drawings
and printing.

File or file type Description Location
.rpt Report templates

(page 362) created with
the Template Editor

System folders defined
for the advanced option 
XS_SYSTEM

.tpl Drawing templates
(page 362) created with
the Template Editor

Template folders
defined for the
advanced option 
XS_TEMPLATE_DIRECTO
RY

.lay Layout definitions
created with the
Drawings & reports -->
Drawing properties -->
Drawing layout editor
command.

The \attributes sub-
folder in the model
folder
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File or file type Description Location
plotdev.bin Printer device definitions

created with the

Printer Catalog printer
instances.

System folders defined
for the advanced option 
XS_SYSTEM

xdproc Master Drawing
Catalog rule set

System folders defined
for the advanced option 
XS_SYSTEM

xdproc.master Master Drawing
Catalog master drawing
file

System folders defined
for the advanced option 
XS_SYSTEM

xdproc.master.png Master Drawing
Catalog sample
(preview) image files

System folders defined
for the advanced option 
XS_SYSTEM

xdproc.png Master Drawing
Catalog thumbnail
image files

System folders defined
for the advanced option 
XS_SYSTEM

For more information about the folder search order, see Folder search order
(page 358).

Note that default drawing, report, and template files are read from the system
folders defined with XS_SYSTEM (or from the XS_TEMPLATE_DIRECTORY
folders), but user-defined files are stored in the model’s \attributes folder.

6.13 Image files
Tekla Structures uses image files in several places:

• In templates in drawings

• In drawing snapshots

• In component dialog boxes and thumbnails

• In drawing line types

• In the surface treatment dialog box

• In the Master Drawing Catalog for thumbnails and sample images

• In profile properties dialog boxes

The following image file formats are supported in Tekla Structures:

• In templates: bmp, gif, grd, jpg, ppm, pgm, rle, tiff and xkrl
• In drawing snapshots, and int thumbnail and sample images for the

Master Drawing Catalog: png
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• Other situations: bmp

See also

Add images in a template (page 377)

6.14 Log files
Tekla Structures writes information to log files when you, for example, number
a model or save a model.

File Description
analysis.log Tekla Structures stores information in

this file when you run the analysis.
The file also contains information on
the errors that occurred during load
distribution. This log file is saved in
the current model folder.

check_database.log Tekla Structures stores information in
this file when you run the Repair
command in File menu --> Diagnose
& repair --> Model . This log file is
saved in the current model folder.

ClashCheck.log Contains clashes found in the most
recent clash check. This log file is
saved in the current model folder.

ClientLog_cat.txt
ClientLog_dog.txt

The client log files contain diagnostic
information and error messages
regarding the Tekla Model Sharing
sharing service, such as connecting to
the sharing service or the status of
the sharing service. The client log files
are saved in the \Users\<user>
\AppData\Local\Tekla
DataSharing folder.

The client log contains two log files
with the maximum size of 1
megabyte, so that the information will
not use too much disk space. When
the maximum file size is reached in
the ClientLog_cat.txt file, log
writing is switched to the
ClientLog_dog.txt file, and the
other way around. Each time the
client log file is switched, any
information previously saved in the
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File Description
current log file is cleared before any
new log information is written into
the log file.

ComponentCatalog_<user>.log Contains troubleshooting information
related to the Applications &
components catalog and any errors
that have occurred in the
Applications & components catalog.
For example, errors in the catalog
definition files are stored in the
ComponentCatalog_<user>.log
file. This log file is saved in the \logs
folder under the current model
folder.

Note that a limited number of older
log messages (approximately 1024KB)
related to the Applications &
components catalog are archived
and saved in the
ComponentCatalog_
<user>.bak.log file.

conflict.log Contains conflicts that have occurred
in the multi-user mode when more
than a one user has modified an
object. This log file is saved in the
current model folder.

DocumentManager_<user>.log Contains troubleshooting information
related to the Document manager,
and any errors that have occurred in
the Document manager. This log file
is saved in the \logs folder under the
current model folder.

Note that a limited number of older
log messages (approximately 256KB)
related to the Document manager
are archived and saved in the
DocumentManager_
<user>.bak.log file.

DPMPrinter_<user>.log Contains troubleshooting information
related to printing, and any errors
that have occurred in printing
drawings or reports to a printer, a
plot file, or a PDF file. This log file is
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File Description
saved in the \logs folder under the
current model folder.

Note that a limited number of older
log messages (approximately 1024KB)
related to printing are archived and
saved in the DPMPrinter2_
<user>.log file.

drawing_cloning.log Contains information on cloned
drawings. This log file is saved in the
current model folder.

drawing_history.log Contains information on drawing
history. Use the advanced option XS_
DRAWING_HISTORY_LOG_TYPE to
define the contents of the file. This
log file is saved in the current model
folder.

dstv_nc.log Each time you create NC files, Tekla
Structures stores information in this
file about the processed assemblies.
This log file is saved in the current
model folder.

error_<user>_<YYYYMMDD>_<HHMM
SS>.log

Each time an error occurs in Tekla
Structures, the error is saved in an
error log file. Error log files contain
the description of errors that have
occurred at a particular time. For
example, if an error has occurred on
April 1, 2019 at 9:15:30 AM, the name
of the related error log file is
error_<user>_20190401_091530.
log. This log file is saved in the \logs
folder under the current model
folder.

filetranerror.log Used only for cold rolled components,
such as Albion, Ayrshire, and Hispan.
If the File Transfer components do
not work as expected, Tekla
Structures stores error messages in
this file. This log file is saved in the
current model folder.

modelsharing.log Contains the sharing operations that
have been performed in Tekla Model
Sharing. For example, opening a
shared model and reading in the
changes made by other users are
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File Description
stored in the modelsharing.log file.
This log file is saved in the \logs
folder under the current model
folder.

numberinghistory.txt Contains full details of each
numbering session carried out on the
model. Each session is in a different
block of the file. This log file is saved
in the current model folder.

save_history.log Tekla Structures stores information in
this file each time you save a model.
This log file is saved in the current
model folder.

sharingfacade.log Contains the essential information
from the client log files when an error
has occurred in the Tekla Model
Sharing sharing service. This log file is
saved in the \logs folder under the
current model folder.

TeklaStructures_<user>.log Contains information on the entire
Tekla Structures session from
opening the model to closing it. The
file contains, for example, errors and
information on which catalogs were
used. This temporary log file is saved
in the \TeklaStructuresModels
folder, and it is removed when you
close Tekla Structures.

UserFeedbackLog.txt Contains the usage data on how you
use Tekla Structures. This log file is
saved in the
\TeklaStructuresModels folder.

Note that the
UserFeedbackLog.txt log file is
always opened with the default text
editor, unlike other log files which can
be opened through Tekla Structures
log viewer. The option to switch
between the viewers does not work
for the UserFeedbackLog.txt file.

wizard.log Tekla Structures stores information in
this file when you run a drawing rule
set (wizard) file. The file contains, for
example, errors and number of

Files and folders in Tekla Structures 327 Log files



File Description
drawings created. This log file is saved
in the current model folder.

See also

View a log file (page 328)

Change the name and location of session history log file (page 329)

Numbering history log file (page 330)

Numbering series in the numbering history log file (page 331)

View a log file
You can select how Tekla Structures displays the log files. Also, if parts or
assemblies are listed in a log file, you can check the parts or assemblies in the
model by selecting them in the log file.

1. Open the model whose log history you want view.

2. On the File menu, click Logs and select a log file you want to see. 

• Clash Check history log (ClashCheck.log)

• Session history log (TeklaStructures_<user>.log)

• Numbering history log (numberinghistory.txt)

• Saving history log (save_history.log)

• Drawing history log (drawing_history.log)

• Analysis history log (analysis.log)

• Usage data log (UserFeedbackLog.txt)

You can view the log file either in Tekla Structures log viewer, or in a
viewer that has been associated with the file type, for example, in
Microsoft Notepad.

To view the log file in the log viewer, in File --> Logs select View with
Tekla Structures log viewer

To view the log file in an associated viewer, File --> Logs select View with
default application.

The UserFeedbackLog.txt log file can be viewed only in associated
viewer, not in the log viewer.

3. If the log file contains information about parts or assemblies, you can
check the parts or assemblies in the model. In the log file, select a row
which contains a part or an assembly. 
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Parts and assemblies have the prefix guid.

Tekla Structures highlights the part in the model. If there are several parts
or assemblies on a row and you select that row, Tekla Structures
highlights all the parts in the model. You can also select parts on different
rows.

TIP You can access a part’s or an assembly’s pop-up menu from the log file
by right-clicking a row that contains a part or an assembly. Tekla
Structures displays the same pop-up menu as when you right-click a part
or an assembly in the model.

See also

Log files (page 324)

Change the name and location of session history log file (page 329)

Numbering history log file (page 330)

Change the name and location of session history log file
You can change the name and location of the session history log file
(TeklaStructures_<user>.log).

If someone else manages your installation of Tekla Structures, do not change
these settings unless you are instructed to do so.

Windows username and the .log file extension are always added after the
customizable part of the name.

1. Open a suitable initialization file (page 269) for editing. 

For example, user.ini or company.ini.

2. To change the name of the session history log file, add the following line
to the initialization file: 

set XS_LOG_FILE_NAME=<name of the file>
For example:

set XS_LOG_FILE_NAME=sessionhistory
If the Windows user name is "achilles", this example would result in a log
file named sessionhistory_achilles.log.

The default name is TeklaStructures_<user>.log.

3. To change the location of the session history log file, add the following
line to the initialization file: 

set XS_LOGPATH=<location of the file>
If there is no other location set, the file is stored in the parent folder for
model folders (by default c:\TeklaStructuresModels).
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4. Save the initialization file.

5. Restart Tekla Structures for the changes to take effect.

See also

Log files (page 324)

View a log file (page 328)

Numbering history log file
The numberinghistory.txt log file contains full details of each numbering
session carried out on the model. Each numbering session is in a different
block of the file.

NOTE If you remove or delete the numberinghistory.txt log file, Tekla Structures
generates a new file with the same name next time when you run numbering.
The new file does not contain a history of previous numbering sessions.

Example

Below is an example of the contents of a numberinghistory.txt log file.

1 User name, date and time of the numbering.
2 Numbering method.

• Modified numbering is displayed when you run the Number
modified objects command.

• Modified numbering for selected series is displayed
when you run the Number series of selected objects
command.

• Diagnose & Repair Numbering: All is displayed when you
run the Diagnose & repair numbering: All command.

• Diagnose & Repair Numbering: Series of selected
objects is displayed when you run the Diagnose & repair
numbering: Series of selected objects command.

• Renumber all is displayed when you select the Renumber all
option in the Numbering Setup dialog box.
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3 Some Compare options set in the Numbering Setup dialog box
are displayed in the numbering.history log file only if they are
set differently than the default value:

• Compare modified to old parts
• Compare new to old part
• No holes comparing
• No part name comparing
• Beam orientation
• Column orientation
Some Compare options are not displayed at all:

• Reinforcing bars

• Embedded objects

• Surface treatment
4 Numbering options.

• Use old numbers is displayed only when you have selected
the Re-use old numbers option in the Numbering Setup dialog
box.

• Check for standard parts is displayed only when you have
selected the Check for standard parts option in the
Numbering Setup dialog box.

5 Tolerances are set in the Numbering Setup dialog box.
6 Changes in the position numbers and in the numbering series

during one numbering session.
 In addition:

If a numbering series overlaps another, the errors are written to the
log file.

See also

Numbering series in the numbering history log file (page 331)

Numbering series in the numbering history log file
Tekla Structures lists information on the numbered parts and assemblies in
the numberinghistory.txt log file.

Example 1

The numberinghistory.txt log after one concrete beam B/20 has been
created and numbered:
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1 Part position number.

• The part with the GUID 
ID510F595D-0000-0030-3133-353939383335 is a part of the
numbering series Concrete_B-20/1.

• The part becomes the first part in the numbering series: 
Concrete_B-20/0 -> Concrete_B-20/1.

2 Assembly position number.

• The assembly ID of the part is 
ID510F595D-0000-002F-3133-353939383335.

• The part belongs to the B/20 assembly numbering series, which
is also the cast unit numbering series.

• The part gets the assembly position number: B/20: B/0 ->
B/20.

Example 2

The numberinghistory.txt log after another concrete beam B/21 has been
created and numbered:
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1 Part position number of the new part.

• The part with the ID 
ID510F595D-0000-0030-3133-353939383335 is part of the
numbering series Concrete_B-20/1.

• The part becomes the second part in the numbering series: 
Concrete_B-20/0 -> Concrete_B-20/2.

2 Assembly position number.

• The assembly ID of the part is 
ID510F595D-0000-002F-3133-353939383335.

• The part belongs to the B/20 assembly numbering series, which is
also the cast unit numbering series.

• The part gets the assembly position number: B/20 B/0 ->
B/21.

See also

Numbering history log file (page 330)

6.15 Model folder files and file name extensions
The following tables list the folders, files and file name extensions of files
located in a Tekla Structures model folder.

Files in the Tekla Structures model folder

File or file name extension Description
.db1 Model database
.db2 Numbering database
environment.db Database for user-defined attribute

definitions
xslib.db1 Contains information on user-defined

connections and details, and default
component descriptions.

.idrm Mapping file, which handles IDs. Do
not modify.

xslib.db2 Contains numbering information.
options_model.db and
options_drawings.db

Contain values for model-specific
options from the Options dialog box
and values for model-specific
advanced options from the Advanced
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Options dialog box. When a model is
created, Tekla Structures reads
model-specific options and advanced
options values from the
standard.opt file and .ini files in
the environment folders and saves
them in these two databases.

history.db Model history database.
xsdb.xs File used for displaying the name of

the model in the Open dialog box.
xs_user.<username> Contains interface settings specified

by the user.

Each time a model is saved, an
xs_user.<username> file is created
or updated. These settings are user
specific. If the xs_user.<username>
file is not found in the model folder
when you open the model, Tekla
Structures searches for the
xs_user.default file in the
following folder search order: model,
model\attributes, project, XS_FIRM
\attributes, system. If this file is not
found, Tekla Structures default
settings will be used.

This file contains settings for many of
the options in the Options dialog box
and the settings for the icons on the
Selecting and Snapping toolbars.

drawing_user.<username> Contains information on which snap
switches are switched on or off in the
drawing mode. This file is user
specific. Do not modify this file.

save_history.log Tekla Structures stores the
information in this file each time the
model is saved. The file includes the
saving time, date and information on
any conflicts during saving.

notification_report.xsr File used for displaying a notification
report of assignments when you open
a model.

TeklaStructuresModel.xml Contains a copy of basic details about
the Tekla Structures model, for
example the model name, version it

Files and folders in Tekla Structures 334 Model folder files and file name extensions



File or file name extension Description
was last saved with, and the Tekla
Structures environment. Tekla
Structures overwrites the details in
this file each time the model is saved.

The model details that you see when
you select a model on the startup
screen are read from this file. The file
can also be used as an information
source for external tools, such as
scripts.

dotlog.txt A log file that contains information on
Tekla Open API application use.

.locked A temporary file that locks the model
folder files to prevent modifications
while the model is in use.

.bak A backup copy of a file with a
corresponding name.

For example, the 
<modelname>.db1.bak file is the
backup copy of the model database
file <modelname>.db1.

assert.txt A log file that contains information on
assertion errors.

ClashCheck.txt A log file that contains information on
clashes found in the most recent
clash check and the date and time of
the clash check.

ClashCheck.history A file that contains information on all
clashes found in all clash checks and
the dates and times of the clash
checks.

wizard.txt Tekla Structures stores information in
this file when you run a drawing rule
set (wizard) file. The file contains, for
example, errors, number of drawings
created, and information on which
commands were used.

.lis Different catalogs can be exported
from and imported to different Tekla
Structures models as .lis files.
These include profile, material and
bolt catalogs.
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File or file name extension Description
.tsc Shapes can be exported from and

imported to different Tekla Structures
models as .tsc files.

.This_is_multiuser_model Contains information about the PC
running the Tekla Structures multi-
user server.

Do not alter or delete this file in
normal circumstances. If you move a
model to a different server, you
should delete this file. Tekla
Structures generates a new file with
the same name.

ComponentCatalog.xml Contains the model level catalog
definitions of the Applications &
components catalog.

<user>_ComponentCatalogUserSe
ttings.xml

Lists the recently used applications
and components, and their location in
the Applications & components
catalog structure.

Worktypes.xml Lists available task types. Created
when you start Task Manager.

WorkTypeProperties.xml Lists allowed property types and their
units.

.tmp A file used to store temporary data.

.cnv A file used to map Tekla Structures
profile and material names with
names used in other software.

.colorset Created when you export a color set
from Organizer.

Files in the \Analysis folder

File or file name extension Description
.ifc The analysis model exported in IFC

format.
.stp The analysis model exported in CIS/2

format.
.map A file used for debugging analysis

models.
analysis_results.db5 Database for analysis load

combination results.
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File or file name extension Description
.db6 Analysis model database.

Files in the \attributes folder

File or file name extension Description
.rop Reference object properties
.rop.more Reference object user-defined

attribute properties
.m10000017 FabTrol XML import properties
.m10000015 Import attribute properties
.ncf NC file properties
.ExportIFC.MainDialog IFC export properties
.m440000004 3D DWG/DXF export properties
.m440000003 3D DGN export properties
.m1000004 FEM export properties
.m10000011 CIS analysis model export properties
.m10000026 CIS manufacturing model export

properties
.m1000007 CAD export properties
.m10000016 Cover sheet export properties
.SObjGrp Model selection filter properties
.VObjGrp Model view filter properties
.OrgObjGrp Organizer filter properties
.bhuistd Building hierarchy properties
.PObjGrp Object group filter properties
.grd Rectangular grid properties
.grd.more Rectangular grid user-defined

attribute properties
.rgrd Radial grid properties
.rgrd.more Radial grid user-defined attribute

properties
.grdp Grid line properties
.grdp.more Grid line user-defined attribute

properties
.cnl Construction line properties
.cncrl Construction circle properties
.cnarc Construction arc properties
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File or file name extension Description
.cnplycrv Construction polycurve properties
.mvi Model view properties that you have

saved for the model.

Default 3D, part, component, custom
component, assembly, and cast unit
view settings files need to be saved
with names used in common
environment:

3D view: basic_view

3D part view: part_basic_view

Part front view: part_front_view

Part top view: part_top_view

Part end view: part_end_view

Part perspective view:
part_persp_view

3D component view:
component_basic_view

Component front view:
component_front_view

Component top view:
component_top_view

Component end view:
component_end_view

Component perspective view:
component_persp_view

Custom component front view:
custom_object_editor_front_view

Custom component top view:
custom_object_editor_top_view

Custom component end view:
custom_object_editor_end_view

Custom component perspective view:
custom_object_editor_perspective_vie
w

3D assembly or cast unit view:
assembly_basic_view

Assembly or cast unit front view:
assembly_front_view

Files and folders in Tekla Structures 338 Model folder files and file name extensions



File or file name extension Description
Assembly or cast unit top view:
assembly_top_view

Assembly or cast unit end view:
assembly_end_view

Assembly or cast unit back view:
assembly_back_view

Assembly or cast unit bottom view:
assembly_bottom_view

Assembly or cast unit perspective
view: assembly_persp_view

.gvi Saved properties for creating views
along grid lines

.rep Object representation properties

.clm Steel column properties

.clm.more Steel column user-defined attribute
properties

.prt Steel beam properties

.prt.more Steel beam user-defined attribute
properties

.sb Steel spiral beam properties

.sb.more Steel spiral beam user-defined
attribute properties

.crs Orthogonal beam properties

.crs.more Orthogonal beam user-defined
attribute properties

.dia Twin profile properties

.dia.more Twin profile user-defined attribute
properties

.cpl Contour plate properties

.cpl.more Contour plate user-defined attribute
properties

.blp Bent plate properties

.blp.more Bent plate user-defined attribute
properties

.lpl Lofted plate properties

.lpl.more Lofted plate user-defined attribute
properties

.ips Item properties

.ips.more Item user-defined attribute properties
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File or file name extension Description
.cpf Pad footing properties
.cpf.more Pad footing user-defined attribute

properties
.csf Strip footing properties
.csf.more Strip footing user-defined attribute

properties
.ccl Concrete column properties
.ccl.more Concrete column user-defined

attribute properties
.cbm Concrete beam or concrete polybeam

properties
.cbm.more Concrete beam or concrete polybeam

user-defined attribute properties
.csb Concrete spiral beam properties
.csb.more Concrete spiral beam user-defined

attribute properties
.csl Concrete slab properties
.csl.more Concrete slab user-defined attribute

properties
.cpn Concrete panel properties
.cpn.more Concrete panel user-defined attribute

properties
.lsl Concrete lofted slab properties
.lsl Concrete lofted slab user-defined

attribute properties
.ipc Concrete item properties
.ipc.more Concrete item user-defined attribute

properties
.rbr Reinforcing bar properties
.rbr.more Reinforcing bar user-defined attribute

properties
.rbg Reinforcing bar group properties
.rbg.more Reinforcing bar group user-defined

attribute properties
.rcu Curved reinforcing bar group

properties
.rci Circular reinforcing bar group

properties
.rbm Reinforcement mesh properties
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File or file name extension Description
.rbm.more Reinforcement mesh user-defined

attribute properties
.rbs Reinforcement strand pattern

properties
.rbs.more Reinforcement strand pattern user-

defined attribute properties
.rsp Reinforcement splice properties
.rsp.more Reinforcement splice user-defined

attribute properties
.rst Rebar set properties
.rst.more Rebar set user-defined attribute

properties
.rst.zones Rebar set spacing zone properties
.rst_pm Rebar set property modifier

properties
.rst_pm.more Rebar set property modifier user-

defined attribute properties
.rst_edm Rebar set end detail modifier

properties
.rst_edm.more Rebar set end detail modifier user-

defined attribute properties
.rst_sm Rebar set splitter properties
.admodel Analysis model properties
.admodel.more Analysis model user-defined attribute

properties
.lm1 Point load properties
.lm2 Line load properties
.lm3 Area load properties
.lm4 Uniform load properties
.m10000028 Wind load properties
.lm6 Temperature load properties
.lco Load combination properties
.adnode Analysis node properties
.adnode.more Analysis node user-defined attribute

properties
.prt_ad, .prt_design File types associated with steel beam

analysis property settings. .prt_ad
contains information associated with
the analysis part properties
and .prt_design contains

Files and folders in Tekla Structures 341 Model folder files and file name extensions



File or file name extension Description
information associated with the
actual steel beam design.

.crs_ad, .crs_design File types associated with orthogonal
steel beam analysis property
settings. .crs_ad contains
information associated with the
analysis part properties
and .crs_design contains
information associated with
orthogonal steel beam design.

.clm_ad, .clm_design File types associated with steel
column analysis property
settings. .clm_ad contains
information associated with the
analysis part properties
and .clm_design contains
information associated with the
actual steel column design.

.dia_ad, .dia_design File types associated with steel twin
profile analysis property
settings. .dia_ad contains
information associated with the
analysis part properties
and .dia_design contains
information associated with actual
twin profile design.

.cpl_ad, .cpl_design File types associated with contour
plate analysis property
settings. .cpl_ad contains
information associated with the
analysis part properties
and .cpl_design contains
information associated with actual
contour plate design.

.cpf_ad, .cpf_design File types associated with pad footing
analysis property settings. .cpf_ad
contains information associated with
the analysis part properties
and .cpf_design contains
information associated with the
actual pad footing design.

.csf_ad, .csf_design File types associated with strip footing
analysis property settings. .csf_ad
contains information associated with
the analysis part properties
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and .csf_design contains
information associated with the
actual strip footing design.

.ccl_ad, .ccl_design File types associated with concrete
column analysis property
settings. .ccl_ad contains
information associated with the
analysis part properties
and .ccl_design contains
information associated with the
actual concrete column design.

.cbm_ad, .cbm_design File types associated with concrete
beam analysis property
settings. .cbm_ad contains
information associated with the
analysis part properties
and .cbm_design contains
information associated with the
actual concrete beam design.

.csl_ad, .csl_design File types associated with concrete
slab analysis property
settings. .csl_ad contains
information associated with the
analysis part properties
and .csl_design contains
information associated with the
actual slab design.

.cpn_ad, .cpn_design File types associated with concrete
panel analysis property
settings. .cpl_ad contains
information associated with the
analysis part properties
and .cpl_design contains
information associated with the
actual concrete panel design.

.srf Surface treatment properties

.srf.more User-defined surface treatment
attribute properties

.srfo Surface properties

.srfo.more User-defined surface attribute
properties

.cha Edge chamfer properties

.cha.more User-defined edge chamfer attribute
properties
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File or file name extension Description
.scr Bolt properties
.scr.more User-defined bolt attribute properties
.wld Weld properties
.wld.more User-defined weld attribute

properties
*.udwcs User-defined weld cross sections

(UserDefinedWeldCrossSections.udwc
s)

.m1000009 Control number properties

.m1000010 Control number locking properties

.num Numbering setup properties

.rpr Report properties

.4d Project status visualization properties
standard.opt Settings are saved in standard.opt

in the \attributes folder only when
you save your own settings in the
Options dialog box using Save.

There is a standard.opt file in the
environment folder that gives the
initial values to be loaded when a
model is created.

Component properties files in the \attributes folder

Properties files for components available in the Applications & components
catalog, for example .j310000063 for 2L Splice (63) component properties.
These files are stored in the attributes folder under the model folder.

Object level drawing settings, saved in \attributes folder

File or file name extension Description
.dprt Object level part properties
.dim Object level dimension properties
.dimension_mark Object level dimension tag properties
.rdim Object level rebar dimension mark

properties
.pm Object level part mark properties
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.jm Object level connection mark

properties
.sm Object level bolt mark properties
.rm Object level reinforcement mark

properties
.mrms Object level merged reinforcement

mark properties
.pom Pour object mark properties
.surfm Object level surface treatment mark

properties
.note Object level associative note

properties
.wls Object level weld mark properties
.lev Object level level mark properties
.rev Object level revision mark properties
.drmsh Object level reinforcement mesh

properties
.drbr Object level reinforcement properties
.po Object level pour object properties
.sc Object level bolt properties
.dsrf Object level surface treatment

properties
.dgr Object level grid properties
.sbl Object level symbol properties
.wls Object level weld mark properties
.drtxt Object level text properties
.gln Object level line properties
.grt Object level rectangle properties
.gci Object level circle properties
.gar Object level arc properties
.gpl Object level polyline properties
.gpg Object level polygon and cloud

properties
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View level drawing settings, saved in \attributes folder

File or file name extension Description
.vi
.vi.copt

View level view properties

.vclassif

.vclassif.copt
View level detailed object level
settings

.vpm View level part mark properties

.vsm View level bolt mark properties

.vnpm View level neighbor part mark
properties

.vsurfm View level surface treatment mark
properties

.vjm View level connection mark
properties

.vrm View level reinforcement mark
properties

.vnrm View level neighbor reinforcement
mark properties

.vpom View level pour object mark
properties

.vp View level part properties

.vs View level bolt properties

.vnp View level neighbor part properties

.vsurf View level surface treatment
properties

.vw View level welding properties

.vr View level reinforcement properties

.vnr View level neighbor reinforcement
properties

.vrmp View level reference object properties

.vpo View level pour object properties

.vg View level grid properties

.vf View level filter properties

.vnf View level neighbor part filter
properties
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Files related to single-part drawings, drawing level
properties, saved in \attributes folder

File or file name extension Description
.wd
.wd.copt

Single-part drawing properties

.wd.more Single-part drawing user-defined
attributes

.wdf Single-part drawing filter properties

.wdnf Single-part drawing neighbor part
filter properties

.wdl Single-part drawing layout properties

.wdl.more Single-part drawing user-defined
layout attributes

.wdv Single-part drawing view properties

.wdv.more Single-part drawing user-defined view
attributes

.wdc Single-part drawing section view
properties

.wdc.more Single-part drawing user-defined
section view attributes

.wdd Single-part drawing dimension
properties

.wdd.more Single-part drawing user-defined
dimension attributes

.wdcd Single-part drawing dimensioning
properties

.wdcd more Single-part drawing user-defined
dimensioning attributes

.wpm Single-part drawing part mark
properties

.wsm Single-part drawing bolt mark
properties

.wnpm Single-part drawing neighbor part
mark properties

.wdsurfm Single-part drawing surface treatment
mark properties

.wdsurfm.more Single-part drawing user-defined
surface treatment mark attributes

.wjm Single-part drawing connection mark
properties
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.wdp Single-part drawing part properties
.wds Single-part drawing bolt properties
.wds.more Single-part drawing user-defined bolt

attributes
.wdnp Single-part drawing neighbor part

properties
.wdnp.more Single-part drawing user-defined

neighbor part attributes
.wdsrf Single-part drawing surface treatment

properties
.wdsrf.more Single-part drawing user-defined

surface treatment attributes
.wdgr Single-part drawing grid properties
.wdgr.more Single-part drawing user-defined grid

attributes
.wdr Single-part drawing protection

properties
.wdr.more Single-part drawing user-defined

protection attributes

Files related to assembly drawings, drawing level
properties, saved in \attributes folder

File or file name extension Description
.ad Assembly drawing properties
.ad.more Assembly drawing user-defined

attributes
.adf Assembly drawing filter properties
.adnf Assembly drawing neighbor part filter

properties
.adl Assembly drawing layout properties
.adl.more Assembly drawing user-defined

layout attributes
.adv Assembly drawing view properties
.adc Assembly drawing section view

properties
.add Assembly drawing dimension

properties
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.add.more Assembly drawing user-defined

dimension attributes
.adcd Assembly drawing dimensioning

properties
.adcd.more Assembly drawing user-defined

dimensioning attributes
.apm Assembly drawing part mark

properties
.asm Assembly drawing bolt mark

properties
.anpm Assembly drawing neighbor part

mark properties
.adsurfm Assembly drawing surface treatment

mark properties
.adsurfm.more Assembly drawing user-defined

surface treatment mark attributes
.ajm Assembly drawing connection mark

properties
.adp Assembly drawing part properties
.adp.more Assembly drawing user-defined part

attributes
.ads Assembly drawing bolt properties
.adnp Assembly drawing neighbor part

properties
.adnp.more Assembly drawing user-defined

neighbor part attributes
.adsrf Assembly drawing surface treatment

properties
.adsrf.more Assembly drawing user-defined

surface treatment attributes
.adw Assembly drawing welding properties
.adw.more Assembly drawing user-defined

welding attributes
.adgr Assembly drawing grid properties
.adgr.more Assembly drawing user-defined grid

attributes
.adr Assembly drawing protection

properties
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Files related to cast unit drawings, drawing level
properties, saved in \attributes folder

File or file name extension Description
.cud
.cud.copt

Cast unit drawing properties

.cud.more Cast unit drawing user-defined
attributes

.cudl Cast unit drawing layout properties

.cudl.more Cast unit drawing user-defined layout
attributes

.cudv Cast unit drawing view properties

.cudv.more Cast unit drawing user-defined view
attributes

.cudc Cast unit drawing section view
properties

.cudc.more Cast unit drawing user-defined
section view attributes

.cudd Cast unit drawing dimension
properties

.cudd.more Cast unit drawing user-defined
dimension attributes

.cudcd Cast unit drawing dimensioning
properties

.cudcd.more Cast unit drawing user-defined
dimensioning properties

.cupm Cast unit drawing part mark
properties

.cusm Cast unit drawing bolt mark
properties

.cunpm Cast unit drawing neighbor part mark
properties

.cudsurfm Cast unit drawing surface treatment
mark properties

.cudsurfm.more Cast unit drawing user-defined
surface treatment mark attributes

.cudrm Cast unit drawing reinforcement mark
properties

.cudrm.more Cast unit drawing user-defined
reinforcement mark attributes

.cudp Cast unit drawing part properties
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.cudp.more Cast unit drawing user-defined part

attributes
.cuds Cast unit drawing bolt properties
.cuds.more Cast unit drawing user-defined bolt

attributes
.cudnp Cast unit drawing neighbor part

properties
.cudnp.more Cast unit drawing user-defined

neighbor part attributes
.cudsrf Cast unit drawing surface treatment

properties
.cudsrf.more Cast unit drawing user-defined

surface treatment attributes
.cudr Cast unit drawing reinforcement

properties
.cudr.more Cast unit drawing user-defined

reinforcement attributes
.cudw Cast unit drawing welding properties
.cudw.more Cast unit drawing user-defined

welding attributes
.cudgr Cast unit drawing grid properties
.cudgr.more Cast unit drawing user-defined grid

attributes
.cudrp Cast unit drawing protection

properties
.cudrp.more Cast unit drawing user-defined

protection attributes
.cuf Cast unit drawing filter properties
.cunf Cast unit drawing neighbor part filter

properties

Files related to general arrangement drawings, drawing
level properties, saved in \attributes folder

File or file name extension Description
.gd
.gd.copt

General arrangement drawing
properties

.gclassif

.gclassif.copt
General arrangement drawing
detailed object level settings
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.gd.more General arrangement drawing user-

defined properties
.gdl General arrangement drawing layout

properties
.gdl.more General arrangement drawing user-

defined layout attributes
.gdv General arrangement drawing view

properties
.gdv.more General arrangement drawing user-

defined view attributes
.gdd General arrangement drawing

dimension properties
.gdd.more General arrangement drawing user-

defined dimension attributes
.gdcd General arrangement drawing

dimensioning properties
.gdcd.more General arrangement drawing user-

defined dimensioning attributes
.gpm General arrangement drawing part

mark properties
.gsm General arrangement drawing bolt

mark properties
.gnpm General arrangement drawing

neighbor part mark properties
.gdsurfm General arrangement drawing surface

treatment mark properties
.gdsurfm.more General arrangement drawing user-

defined surface treatment mark
attributes

.gjm General arrangement drawing
connection mark properties

.gdrm General arrangement drawing
reinforcement mark properties

.gdrm.more General arrangement drawing user-
defined reinforcement mark
attributes

.gnrm General arrangement drawing
neighbor reinforcement mark
properties

.gpom General arrangement drawing pour
object mark properties
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.gdp General arrangement drawing part

properties
.gdp.more General arrangement drawing user-

defined part attributes
.gds General arrangement drawing bolt

properties
.gds.more General arrangement drawing user-

defined bolt attributes
.gdnp General arrangement drawing

neighbor part properties
.gdnp.more General arrangement drawing user-

defined neighbor part attributes
.gdsrf General arrangement drawing surface

treatment properties
.gdw General arrangement drawing

welding properties
.gdw.more General arrangement drawing user-

defined welding attributes
.gdr General arrangement drawing

reinforcement properties
.gdr.more General arrangement drawing user-

defined reinforcement attributes
.gnr General arrangement drawing

neighbor reinforcement properties
.gpo General arrangement drawing pour

object properties
.gpbr General arrangement drawing pour

break properties
.gdrmp General arrangement drawing

reference object properties
.gdrmp.more General arrangement drawing user-

defined reference model attributes
.gdgr General arrangement drawing grid

properties
.gdgr.more General arrangement drawing user-

defined grid attributes
.gdrp General arrangement drawing

protection properties
.gdrp.more General arrangement drawing user-

defined protection attributes
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.gdf General arrangement drawing filter

properties
.gdnf General arrangement drawing

neighbor part filter properties

Files related to multidrawings, drawing level properties,
saved in \attributes folder

File or file name extension Description
.md Multidrawing properties
.md.more Multidrawing user-defined attributes
.mdl Multidrawing layout properties
.mdl.more Multidrawing user-defined layout

attributes
.mdr Multidrawing protection properties
.mdr.more Multidrawing user-defined protection

attributes

Files common to all drawings, and files in the \drawings
folder

File or file name extension Description
.dg Drawing files
.ldb Drawing export layer properties
.ldr Drawing link properties
.cs Section symbol properties
.detail Detail symbol properties
.fas Text file properties
.fhl Hyperlink properties
.dsf Drawing selection filter properties.

This file is saved when you select the
Drawing --> Selection filter check
box in the Filter or Selection Filter
properties.

.GridsDimXml

.ShapeDimXml

.HolesDimXml

Dimensioning rules
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.FilterDimXml
.OverallDimXml
.RecessesDimXml
.SecPartsDimXml
.dg.DPM Drawing snapshot files in the

\<model>\drawings\snapshots
subfolder. The files are created either
automatically or based on a user
request.

To create a snapshot of a drawing
automatically at the same time that
you create the drawing, set the the
advanced option
XS_DRAWING_CREATE_
SNAPSHOT_ON_DRAWING_CREATION
to TRUE. For more information about
creating snapshots, see .

Files related to IFC export in \IFC folder

File or file name extension Description
.ifc Exported IFC files

Files related to NC in the \DSTV_Profiles folder

File or file name extension Description
.nc1 NC (numerical control) files

Files in the \ModelSharing folder

File or file name extension Description
ModelSharingService.key Key file that is needed to perform

sharing in Tekla Model Sharing.
FileSharing.ini File sharing settings in Tekla Model

Sharing.
FileSharing.xml File needed for file sharing in Tekla

Model Sharing.
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Files in the \ProjectOrganizer folder

File or file name extension Description
.db Created when Organizer is opened

for the first time. Contains all
property template and category
information used in the model.

The database name shows the
version of the database, for example,
ProjOrg000020.db.

.propertytemplate Created when you export a property
template from Organizer.

.category Created when you export a category
from Organizer.

Files related to reports in the \Reports folder

File or file name extension Description
.xsr Tekla Structures reports

Files in the \SessionFileRepository folder

File or file name extension Description
Files in the
SessionFileRepository folder

Backup copies of the files that are
updated or deleted in Tekla Model
Sharing read in.

SessionFile.db Database for managing model folder
files in Tekla Model Sharing.

.storage Configuration file of
SessionFile.db.

Files related to shapes in the \ShapeGeometries and
\Shapes folders

File or file name extension Description
.tez
.xml

Shape geometry descriptions in the
\ShapeGeometries folder.
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.xml Shape descriptions in the Shapes

folder.

Files in the \screenshots folder

File or file name extension Description
.png Screenshot taken in Tekla Structures.

Files related to Unitechnik export in the \UT_files folder

File or file name extension Description
.uni Exported Unitechnik files

6.16 Check and change Tekla Structures file and folder
locations in Directory browser
Directory browser is a tool that helps you to find and modify the location of
the various Tekla Structures files and folders, and customize user settings.

NOTE Generally, only administrators should change these settings. If you
change them yourself, and you are sharing the same model with other
users, and your settings differ from those of the project, you will have
problems. Also, adding or modifying files in some of these folders may
require administrator rights.

To locate files and folders, and customize your Tekla Structures settings:

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Click the arrow next to Applications to open the applications list.

3. Double-click Directory browser. 

The Directory browser dialog box opens. You can check the most
common folder paths, and customize the settings in your user.ini file,
or in the user-specific or model-specific options.ini file.
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4. Check the folder paths and change them if necessary by clicking the
buttons on the left of the Basic tab. 

If you click the Project or Firm button and you have not set your firm and
project folder, Tekla Structures will prompt you to do so and add the
folder path definition to your user.ini file.

5. Check the settings in the user.ini and options.ini files and change
them if necessary by clicking the buttons on the right of the Basic tab.

6. Go to the Advanced tab and define the folder paths for additional folders
that you may need to access, such as custom components and macros.

6.17 Folder search order
When you open a model, Tekla Structures searches for the associated files in
specific folders in a set order.

It is important that you keep files in correct folders. Once Tekla Structures
finds the associated files, it stops searching. This means that files that have the
same name but are located lower down the search order are ignored.

The folder search order is:

Folder Defined by
Current model The open model
Project Advanced option XS_PROJECT.

If property files are stored in user-
defined sub-folders under the project
folder, Tekla Structures searches the
sub-folders for files in alphabetical
order. The first associated file is
selected. After that, each file with the
same file name suffix and file name
prefix as the selected file is ignored.
The names of the ignored files are
stored in the error log.

Firm Advanced option XS_FIRM.

If property files are stored in user-
defined sub-folders under the firm
folder, Tekla Structures searches the
sub-folders in alphabetical order. The
first associated file is selected. After
that, each file with the same file name
suffix and file name prefix as the
selected file is ignored. The names of
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Folder Defined by
the ignored files are stored in the
error log.

System Advanced option XS_SYSTEM

Tekla Structures does not search for certain files in exactly this order. The
exceptions are listed below.

The exceptions are:

File (type) Search order
objects.inp (page 302) • Model folder

• Project folder (XS_PROJECT)

• Firm folder (XS_FIRM)

• System folder (XS_SYSTEM)

• inp folder (XS_INP)
privileges.inp • Model folder

• Project folder (XS_PROJECT)

• Firm folder (XS_FIRM)

• System folder (XS_SYSTEM)

• inp folder (XS_INP)
.dat files (page 312) System folder (XS_SYSTEM)
Templates (page 362) • Folder containing your templates

indicated by the advanced option
XS_TEMPLATE_DIRECTORY

• Model folder

• Project folder (XS_PROJECT)

• Firm folder (XS_FIRM)

• Environment-specific system
templates indicated by the
advanced option
XS_TEMPLATE_DIRECTORY_SYSTE
M

• System folder (XS_SYSTEM)
Catalogs Profile (page 146), bolt (page 226),

material (page 138), and rebar
(page 243) catalogs:

• Model folder

• Project folder (XS_PROJECT)
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File (type) Search order
• Firm folder (XS_FIRM)

• Folder indicated by the advanced
option XS_PROFDB

Shape catalog (page 209):

• Model folder

• Project folder (XS_PROJECT)

• Firm folder (XS_FIRM)

• System folder (XS_SYSTEM)

• Folder indicated by the advanced
option XS_DEFAULT_BREP_PATH

Printer catalog:

• Model folder

• Project folder (XS_PROJECT)

• Firm folder (XS_FIRM)

• Folder indicated by the advanced
option XS_DRIVER

WARNING Do not store customized files in the system folder. That way, you
will avoid having problems or doing a lot of unnecessary work
when you upgrade to a newer version of the software.

6.18 Location of certain hidden files and folders
When Tekla Structures is installed in the ..\Program Files folder, some of
the files needed to run Tekla Structures are located in hidden folders and are
therefore invisible. You can see the hidden files and folders if you make them
visible in the Windows Folder Options.

NOTE You can always check the settings below. If you run into problems with the
settings, ask your administrator or local support for assistance.

Files related to the software

Software and, for example, the following files are installed under
the ..\Program Files\Tekla Structures\<version>\ folder.

• contentattributes_global.lst
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• contentattributes_userdefined.lst
(in the USA environment: contentattributes_customer.lst)

Files related to environments

Environments and, for example, the following files are installed under
the ..\ProgramData\Trimble\Tekla Structures\<version>
\environments\<environment>\ folder. The exact file location may vary
depending on the folder structure of your environment files.

• analysis_design_config.inp
• contentattributes.lst
• dimension_marks.sym
• InquiryTool.config
• objects.inp
• objects.inp
• privileges.inp
• product_finishes.dat
• rebar_config.inp
• TeklaStructures.lin
• TilePatternCatalog.dtd
• TilePatternCatalog.xml

Files related to user settings

User settings and, for example, the following files are installed under
the ..\Users\<username>\AppData\Local\Trimble\Tekla Structures
\<version>\ folder.

• user.ini
• options.bin
• customized property pane layout PropertyTemplates.xml file

• customized ribbon and customized tab .xml files

• customized contextual toolbar .xml files

• customized toolbar .json files

See also

Model folder files and file name extensions (page 333)
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7 Templates

Templates are descriptions of forms and tables that can be included in Tekla
Structures. Templates are either graphical or textual. Graphical templates are
inserted in drawing layouts as tables, text blocks, and drawing headers, for
example. Textual templates are used for creating reports. The contents of the
template fields are filled in by Tekla Structures at run time.

Tekla Structures includes a large number of standard templates you can use.
Use Template Editor to modify existing templates, or create new ones to suit
your needs.

Graphical template definitions have the file name extension .tpl. Textual
template definitions have the file name extension .rpt.

The ready-made textual and graphical templates are located under the
environment folders, in ...\ProgramData\Trimble\Tekla Structures
\<version>\environments\. The exact file location may vary depending on
the folder structure of your environment files. Textual and graphical
templates, except mark templates, can also be read from XS_FIRM or 
XS_PROJECT folders. For more information on where the templates are
searched for, see Folder search order (page 358).

Examples

Example of a title block:

Example of an inquiry report:
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Example of a part list report:

For more information on using templates, see Template Editor User's Guide
(page 364) or open the Template Editor Help in Template Editor by clicking
Help --> Contents .
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See also

Create a template (page 364)

7.1 Create a template
1. On the File menu, click Editors --> Template Editor.

2. In Template Editor, click File > New.

3. Select the template type and click OK. A new empty template is created.

4. Add new rows in the template.

a. Click Insert --> Component --> Row to add a new row.

b. Select a content type for the row and click OK.

c. Repeat steps a–b for each new row.

5. Add value fields to get the required data from your Tekla Structures
database.

a. Click Insert --> Value field .

b. Click a point to define the location of the field within the row. 

The Select Attribute dialog box appears prompting you to select an
attribute for the value field.

c. Select an attribute and click OK.

d. Repeat steps a–c for each value field.

6. Save the template.

a. Click File --> Save as.

b. Browse to the template folder defined for the advanced option
XS_TEMPLATE_DIRECTORY.

c. In the File name field, enter a name for the template.

d. Click OK.

See also

Templates (page 362)

Create a template in HTML format (page 365)

Create a template for nested assemblies (page 369)

Create a template for bending schedules or pull-out pictures (page 373)

Add images in a template (page 377)

Templates 364 Create a template



7.2 Template Editor User's Guide
This guide describes how you can use Template Editor to create, modify and
manage template definitions for both reports and drawings.

With Template Editor, you can produce labels, reports and legends allowing
you to gather and produce accurate and targeted information. Tekla
Structures has a number of ready-made templates, and you can use Template
Editor to modify the existing templates, or create new ones to suit your needs.

Template Editor is also used in other products than Tekla Structures. That is
why the term 'product' is used frequently in the content instead of the actual
software name. For exact instructions on how to use Template Editor together
with Tekla Structures to create and modify templates, see the other articles
under Templates (page 362).

The Template Editor User's Guide is currently available in English only. The
content is the same as in the Template Editor help.

7.3 Create a template in HTML format
Templates in HTML format give you more possibilities for different layout,
fonts, and images. Templates that generate output in HTML format are
graphical and have the file name extension *.html.rpt.

1. On the File menu, click Editors --> Template Editor.

2. In Template Editor, click File > New.

3. Select Graphical template and click OK.

4. Add new rows in the template.

a. Click Insert --> Component --> Row to add a new row.

b. Select a content type for the row and click OK.

c. Repeat steps a–b for each new row.

5. Add value fields to get the required data from your Tekla Structures
database.

a. Click Insert --> Value field .

b. Click a point to define the location of the field within the row. 

The Select Attribute dialog box appears prompting you to select an
attribute for the value field.

c. Select an attribute and click OK.

d. Repeat steps a–c for each value field.

6. Add a header for each value field.

a. Click Insert --> Component --> Header...
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b. Click Insert --> Text...

c. Enter a heading for the template, and then click OK.

d. Click a point to define the location of the heading in the header row.

e. Repeat steps a–d to create headings for all the value fields.

7. Save the template:

a. Click File --> Save as

b. Browse to the template folder defined for the advanced option
XS_TEMPLATE_DIRECTORY.

c. In the File name field, enter a name for the template. 

Include the extension *.html.rpt in the file name. For example,
Part_list.html.rpt.

d. Click OK.

NOTE If you add images in your HTML template, the images should be located
in ..\Program Files\Tekla Structures\<version>\nt\TplEd
\bitmaps folder, otherwise they are not shown in the HTML output.

Example

1. Header that contains text fields

2. Row that contains two value fields

See also

Templates (page 362)

Add images in a template (page 377)
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7.4 Create a .pdf report template
You can create graphical templates to be used for .pdf reports.

1. On the File menu, select Editors --> Template editor.

2. Select File --> New --> Graphical template.

3. Click Edit --> Properties.

4. In Template page properties dialog box, set the page size to match the
target page size (for example A4): 

The size must match a size defined in the PaperSizesForDrawings.dat
configuration file.

5. Add new rows and value fields to get the required data from your Tekla
Structures database. For more information about adding new rows and
value fields, see Create a template (page 364).

6. Click File --> Save as, and save the report with the filename
extension .pdf.rpt.

7. Copy the new template to your template folder, such as model or your
company settings folder (XS_FIRM). 

Now you can create a .pdf report using the new .pdf report template.
For more information about creating a report, see .
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Example .pdf report

In this report example, the following page size is used:

Below is an example of a report that has been created using this particular
report template. To open the report in a browser, click here.
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7.5 Create a template for nested assemblies
This example shows how to produce a template that displays the hierarchical
structure of nested assemblies. You will create a nested assembly structure in
a textual template similar to the one in the following picture:
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1. On the File menu, click Editors --> Template Editor.

2. In Template Editor, click File > New.

3. Select Textual template and click OK.

4. Add four new rows in the template.

a. Click Insert --> Component --> Row to add a new row.

b. Select a content type for the row, and then click OK. 

For the first and third row, select the ASSEMBLY content type, and for
the second and fourth row, select the PART content type.

c. Repeat steps a–b for each new row.

5. Use the arrow buttons under Sorting and drawing order to create a
nested assembly structure for the template.

a. Move the second and third row down one level.

b. Move the fourth row down two levels. 

The structure should now look like this:
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6. Add value fields to get the required data from your Tekla Structures
database. 

In this example, the added value fields are assembly or part position,
number, and weight.

a. Click Insert --> Value field .

b. Click a point to define the location of the field within the row. 

The Select Attribute dialog box appears prompting you to select an
attribute for the value field.

c. Select an attribute and click OK.

d. Repeat steps a–c for each value field.

7. Modify the layout of the template. For example:

a. Move objects to display the nested assembly structure in the printed
report. To do this, select the object you want to move and drag it to
the desired position.

b. Align objects. To do this, select all the objects you want to align, right-
click and select the appropriate option from the pop-up menu, for
example Align --> Right .

c. Add a header and a footer. To do this, click Insert --> Component -->
Page header and Page footer. Add the required information to the
header and footer.

8. Save the template.

Example

Below is an example textual template and a report that has been created
using the template:
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NOTE You can create graphical templates for nested assemblies in the same
manner as textual templates. The difference between graphical and textual
templates is that in a graphical template you can display project and company
information and graphics, such as table outlines, pictures, or symbols.

See also

Templates (page 362)

Templates 372 Create a template for nested assemblies



7.6 Create a template for bending schedules or pull-out
pictures
You can use Template Editor for creating bending schedules or pull-outs
pictures on reinforcement bars and bent meshes, and control the type of
information that is shown in the bending schedules.

1. On the File menu, click Editors --> Template Editor.

2. Click File --> New .

3. Select Graphical template and click OK.

4. Click Insert --> Component --> Row to add a new row.

5. Select REBAR or MESH as the content type for the row.

6. Add value fields to get the required data from your Tekla Structures
database.

a. Click Insert --> Value field .

b. Click a point to define the location of the field within the row. 

The Select Attribute dialog box appears prompting you to select an
attribute for the value field.

c. Select an attribute and click OK.

d. Repeat steps a–c for each value field.

7. Insert a graphical field to your REBAR or MESH content type row.

a. Click Insert --> Graphical Field...

b. Click and drag with the mouse to draw a frame.

8. Double-click the graphical field to open the Graphical Field Properties
dialog box.

9. Click Free attributes and go to the Application tab.

10. Select the required bending diagram attributes. 

You can also define the bending diagram attributes on the User tab. Note
that if the same attribute is set both as User attribute and Application
attribute, the Application attribute takes precedence.

For a list of attributes and values that can be used for bending schedules
in templates, see Bending schedule attributes (page 376).

11. Save the template.
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Example

Autoscaling pull-out pictures

There is a free attribute available for the PULLOUT attribute in graphical
templates that you can use to define the scale type. If you set the free
attribute ScaleType to 1 on the User tab in the Free attributes dialog box,
the pull-out pictures will be scaled to fit the available space in both X and Y
dimensions. As a result, the shape becomes out of proportion, but small
segments can be seen more easily. Note that you can also set this attribute on
the Application tab.
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A bending shape may look like this if you do not define the free attribute 
ScaleType:

The same bending shape that uses the free attribute ScaleType with value 1.

Change the appearance of the pull-out pictures

Tekla Structures uses the settings in the rebar_config.inp file in the system
folder defined by the advanced option XS_SYSTEM to define the appearance of
the pull-out pictures. You can change the colors, lines, and dimension unit,
format, and precision used in pull-out pictures, for example. For a list of
settings and values in rebar_config.inp, see Reinforcement settings for
drawings (rebar_config.inp)
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Bending schedule attributes
The following table lists the attributes and values that can be used for bending
schedules in templates.

Attribute Default value Available values
FontName romsim Available template fonts
FontSize 2.0 Available font sizes
FontColor 1 (black) 1 = black

2 = red

3 = bright green

4 = blue

5 = cyan

6 = yellow

7 = magenta

8 = brown

9 = green

10 = dark blue

11 = forest green

12 = orange

13 = gray
RotationAxis 2 0 = by view

1 = by global Z

2 = by local axis
ScaleType 0 0 = no

1 = yes

If you set the free
attribute ScaleType to 
1 for the PULLOUT
attribute, the pull-out
pictures will be scaled to
fit the available space in
both X and Y
dimensions. As a result,
the shape becomes out
of proportion, but small
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Attribute Default value Available values
segments can be seen
more easily.

Exaggeration 1 0 = no

1 = yes
EndMark 1 1 = straight

2 = half arrow

3 = full arrow
Dimensions 1 0 = no

1 = yes
BendingRadius 0 Shows the bending

radius in form of
diameter of the bending
roll.

0 = no

1 = yes
BendingAngle 1 0 = no

1 = yes
ImageWidth Width of the graphical

field multiplied by 4.
Number of pixels

ImageHeight Height of the graphical
field multiplied by 4.

Number of pixels

CouplerSymbols 1 Display srebar coupler
and end anchor symbols
in rebar bending
schedules. Rebar
coupler symbols will be
shown if
CouplerSymbols
property value is set to 1
and disabled if 0 is
entered. The default
value is 1.

See also

Create a template for bending schedules or pull-out pictures (page 373)
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7.7 Add images in a template
You can add images in graphical templates. For example, you might want to
include a company logo in your drawings. Tekla Structures supports the
following image formats in graphical
templates: .bmp, .jpg, .jpeg, .tif, .tiff and .png.

1. Open an existing graphical template or create a new graphical template in
Template Editor.

2. Add a new row in the template:

a. Click Insert --> Component --> Row to add a new row.

b. Select a content type for the row and click OK.

3. Ensure that you have the row selected, and click Insert > Picture to open
the Select Picture File dialog box. 

If a local symbols folder exists, the contents of that folder are shown by
default. You can browse for the contents of the common\symbols folder
by selecting that folder. If a local symbols folder does not exist, Tekla
Structures displays the contents of the common\symbols folder.

4. If you have images in other folders, you can display these folders in the
Select Picture File dialog box: 

a. In Template Editor, click Options --> Preferences.

b. Go to the File Locations tab and on the Symbols, pictures row, add
a new folder separated by a semicolon (;), for example:

The folder you defined is displayed in the Directory list:

5. Select an image from the File list and click OK and add the image. 

You can adjust the size by dragging from the image handles.
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Things to remember when adding images in templates

• Do not add very large images because they update very slowly.

• The image may look different in the image editor and in the printout or in
the exported DWG file.

• When you export the drawing to DWG, Tekla Structures copies the images
in the same folder as the DWG file. If the image for some reason is not in
the same folder, only the name of the image is displayed together with an
empty frame instead of the image in the DWG.

• If environments have local symbols, the local symbol folder is also included
in the search path with the common\symbols folder. If the local symbols
folder contains files with the same name as common\symbols folder, then
the local symbol file is used.

• When you open the drawing that contains images inserted in the template,
Tekla Structures first looks for the images in the model folder and then in
the \symbols folder in the current environment.

• You can define a folder where Tekla Structures always looks for images
using the advanced option DXK_SYMBOLPATH. You can also define a firm
folder for your images.

Example

Below are some examples of the Select Picture File dialog box showing folder
structure in different environments.
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In the following example, a company logo has been added in a template.

See also

Templates (page 362)

7.8 Content types
When you create a new row in the template, you must select a content type for
the row. For example, when you add a row and then add a value field,
Template Editor is asking for the content type. The content type determines
which template attributes you can use on that row.

The available content types are:

Content type Description
ANALYSIS_RIGID_LINK Use to create lists of analysis rigid links.

Templates 380 Content types



Content type Description
ANTIMATERIAL Use to create lists of holes and recesses, or parts

removed as a result of a cut.

In Template Editor, the same attributes that are
available for PART are available for ANTIMATERIAL.
However, only the attributes that are useful to be
used with ANTIMATERIAL are shown, including 
NAME, LENGTH, WIDTH, HEIGHT, AREA, PROFILE,
and NUMBER, and user-defined attributes.

ASSEMBLY Use to create lists of assemblies and single parts.
Includes all assemblies containing the selected
parts and bolts.

BOLT Use to create screw and bolt lists. Includes all bolts
connected to selected parts.

CAST_UNIT Use to create lists of cast units.
CHAMFER Use to create lists of the length of the chamfers.
COMMENT Use to create empty rows or rows that only have

textual data or lines anywhere on a template.
CONNECTION Use to create lists of connections.
DRAWING Use to create drawing lists without revision history

information. Use for reports and included
drawings.

HIERARCHIC_CAST_UNI
T

Use to create reports listing subassemblies of
concrete.

HIERARCHIC_OBJECT Use to create lists of various types of hierarchies.
For example, lists hierarchical objects in Organizer.

HISTORY Use to retrieve history information of the model.
You can use this content type with PART, REBAR, 
CONNECTION and DRAWING rows.

The following template attributes can be used with
this content type:

• TYPE: the type of the historical action, for
example update or numbering.

• USER: the user who made the change.

• TIME: the time the change was made.

• COMMENT: the comment which was entered
upon clicking Save.

• REVISION_CODE: the revision code which was
entered upon clicking Save.

HOLE Use to create lists of holes.
LOAD Use to create lists of loads.
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Content type Description
LOADGROUP Use to create lists of load groups.
MESH Use to create lists of meshes.
NUT Use to create lists of nuts. Contains all nuts for

bolts associated with the selected parts.
PART Use to create lists of parts.
POUR_BREAK Use to create lists of pour breaks.
POUR_OBJECT Use to create lists of pour objects.
POUR_UNIT Use to create lists of pour units.
REBAR Use to create lists of reinforcing bars.
REFERENCE_MODEL Use to list the reference models.
REFERENCE_OBJECT Use to list the reference model objects in a

reference model.

Only reference model objects that have user-
defined attributes are displayed in reports.

REFERENCE_ASSEMBLY Use to list the reference assemblies in a reference
model.

REVISION Use to create lists of revision marks.
SIMILAR_ASSEMBLY Use to create lists of similar parts.

To use this content type, you need to have an
empty (hidden in output) ASSEMBLY, PART or 
CAST_UNIT row in the row hierarchy above the
row with SIMILAR_* content type:

You cannot have any rows below SIMILAR_* row
content type in the row hierarchy.

Note: Used in drawings to collect similar object
information from the model. All the other attribute
information is collected from visible drawing
objects.

SIMILAR_CAST_UNIT
SIMILAR_PART
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Content type Description
SINGLE_REBAR Use to create lists of individual bars in reinforcing

bar groups.

For example, use it to get the lengths of the
individual bars in tapered reinforcing bar groups.

For rebar sets, SINGLE_REBAR works in the same
way as REBAR.

SINGLE_STRAND Use to create lists of individual prestressed
strands.

STRAND Use to create lists of prestressed strands.
STUD Use to create lists of studs.
SURFACE Use to create lists of surfaces.
SURFACING Use to create lists of surface treatments.
SUMMARY Use to summarize the contents of the row(s) that

are above SUMMARY in the hierarchy.

For example, use PART - SUMMARY hierarchy to
summarize the contents of the PART rows.

TASK Use to create lists of tasks.
WASHER Use to create lists of washers. Contains all washers

for all bolts associated with the selected parts.
WELD Use to create lists of welds.

See also

Template attribute files (contentattributes.lst) (page 383)

7.9 Template attribute files (contentattributes.lst)
Template attributes represent object properties. You can use template
attributes in value fields, formulas, and row rules to get the required data
from your Tekla Structures database.

When you output the template, Tekla Structures replaces the attribute with
the actual value of the corresponding object property. For example, if you
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include the attribute WEIGHT in a report template, Tekla Structures displays
the weight of the model object in the report.

Template attributes are defined in the following files:

File name Description
contentattributes.lst This is a container file listing all the

files that contain the actual attribute
definitions. The files are added with 
INCLUDE sentences. The order of the
files included in
contentattributes.lst defines
the reading order of the files.

This file is overwritten in the
installation when you install a newer
version of Tekla Structures. Ensure
that you make a copy of this file
before updating.

Generally, there is no need to modify
contentattributes.lst. Do not
modify it if you are not an
administrator.

contentattributes_global.lst This file contains attributes that are
hard-coded into the program. Do not
edit this file.

contentattributes_userdefined
.lst

This file contains user-defined
attributes, the same as in the
objects.inp file.

This file is overwritten in the
installation when you install a newer
version of Tekla Structures. To use
your own attributes in templates and
reports, create a copy of this file and
add the necessary attributes to that
file.

By default, these files are located in ..\Program Files\Tekla Structures
\<version>\nt\bin\TplEd\settings, but the location may be different in
your environment.

The search order for the contentattributes.lst file is defined in the
tpled.ini file. The location of the tpled.ini file is defined by the
XS_TPLED_INI advanced option.

The following pointers are allowed in the tpled.ini file:

• @\ = location of the tpled.ini file
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• .\ = location of tpled.exe (C:\Program Files\Tekla Structures
\<version>\nt\bin\TplEd)

To include your own attributes, modify the contentattributes.lst files in
the relevant environment folders. Note that the contentattributes.lst
files are overwritten when you install a new version of Tekla Structures.

See also

User-defined template attributes (page 385)

Location of certain hidden files and folders (page 360)

7.10 User-defined template attributes
User-defined template attributes are defined in the
contentattributes_userdefined.lst file. By default, this file includes
most of the user-defined attributes that are visible in the part properties. To
use your own attributes in templates and reports, you should make a copy of
the file, rename it appropriately, and add the necessary attributes to that file.

The contentattributes_userdefined.lst file is divided into two sections:

• A list of attribute names and default settings:
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• A list of attributes assigned to content types:

1. The content type of the row in Template Editor

2. The attribute hierarchy in Template Editor

3. Customizable comments, such as the tab name in the user-defined
attributes dialog box

4. The name of the user-defined attribute, must be the same as in the
objects.inp file

See also

Add user-defined template attributes to Template Editor (page 386)

Add comments to user-defined template attributes (page 388)

Add hierarchy to user-defined template attributes (page 388)

Add user-defined template attributes to Template Editor
This example shows how to add your own user-defined attributes to the
attribute tree in Template Editor.

Before you start, add your user-defined attribute to the objects.inp file. For
example, you might add an attribute named MY_ATTRIBUTE to the user-
defined properties of drawings.

1. Open the contentattributes_userdefined.lst file in a text editor.
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2. Save the file with an appropriate name, for example
MY_contentattributes_userdefined.lst, in the same folder.

3. Add MY_ATTRIBUTE to the list of attribute names and, define the settings
as follows: 

4. Add MY_ATTRIBUTE to the list of attributes assigned to content types. 

Select the content type according to which object the attribute is
associated to in the objects.inp file. In this example, the content type is 
DRAWING. Add the attribute in the format 
USERDEFINED.<ATTRIBUTE_NAME>.

5. Save the changes.

6. Open the contentattributes.lst file.

7. Add the following line in the file: 

[INCLUDE MY_contentattributes_userdefined.lst]
8. Save the changes. 

The attribute is shown in the attribute tree in Template Editor, under 
DRAWING > USERDEFINED:
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See also

User-defined template attributes (page 385)

Add comments to user-defined template attributes
You can add your own comments to the user-defined attibutes in the
Template Editor attribute tree.

1. Open your copy of the contentattributes_userdefined.lst file. 

For example, MY_contentattributes_userdefined.lst. Do not
modify the original contentattributes_userdefined.lst file.

2. Scroll down to the list of attributes assigned to content types.

3. Add your comment inside quotation marks, after the attribute name. 

For example:

4. Save the changes. 

The comment you added is displayed in the attribute tree in Template
Editor:

See also

User-defined template attributes (page 385)

Add hierarchy to user-defined template attributes
You can add your own hierarchy to the Template Editor attribute tree.
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1. Open your copy of the contentattributes_userdefined.lst file. 

For example, MY_contentattributes_userdefined.lst. Do not
modify the original contentattributes_userdefined.lst file.

2. Scroll down to the list of attributes assigned to content types.

3. Define the hierarchy in square brackets, between USERDEFINED. and the
attribute name. 

For example:

NOTE Notice the periods after the brackets, and between the
hierarchies.

4. Save the changes. 

The new hierarchy is shown in the attribute tree:

WARNING User-defined attributes are case sensitive. Ensure that you enter the
attribute name using the correct case for all characters.

See also

User-defined template attributes (page 385)
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7.11 Tips for templates
There are some things that you might consider to be able to use templates
more efficiently.

Click the links below to find out more:

• Use text type attribute in calculations (page 390)

• Change value field content to use imperial units (page 390)

• Define customized date format (page 391)

• Assembly or cast unit drawing sheet number (page 391)

• Use format functions in value fields (page 392)

Use text type attribute in calculations

Change text to numeric format

double(GetValue("ASSEMBLY_TOP_LEVEL"))
Change into correct format for calculation (double=decimals)

format(double(GetValue("ASSEMBLY_TOP_LEVEL")),"Length", "mm",
1)
Add all above into calculation formula

format(double(GetValue("ASSEMBLY_TOP_LEVEL")),"Length", "mm",
1)+15000
Another example of the same for part elevation

(double(GetValue("TOP_LEVEL"))-
(double(GetValue("BOTTOM_LEVEL"))))*1000

Change value field content to use imperial units

Advanced option to check if imperial units are in use:

GetValue("ADVANCED_OPTION.XS_IMPERIAL")==TRUE
Translated string call for multi lingual text:

GetValue("TranslatedText("albl_Diameter_")")
Formatting of units:

format(GetValue("DIAMETER"),"Length","inch-frac", 1/16)
format(GetValue("DIAMETER"),"Length","mm", 1)
Combine all above in a rule:
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if GetValue("ADVANCED_OPTION.XS_IMPERIAL")==TRUE then
GetValue("TranslatedText("albl_Diameter_")")+
format(GetValue("DIAMETER"),"Length","inch-frac", 1/16) + "
Inches"
else
GetValue("TranslatedText("albl_Diameter_")")+
format(GetValue("DIAMETER"),"Length","mm", 1)+" mm"
endif

Define customized date format

Use mid function to find year, month and day:

mid("","","") string, offset, n
year:

mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"6","4")
month:

mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"3","2")
days:

mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"0","2")
Combine all above in rule:

mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"6","4")
+"-"+
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"3","2")
+"-"+
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"0","2")

Assembly or cast unit drawing sheet number

Use match function to find "-" character

match(GetValue("NAME_BASE"),"*-*")
Use of mid function to return only characters after "-"

mid(GetValue("NAME_BASE"),(1+
(find(GetValue("NAME_BASE"),"-"))),2)
Combine all above in rule

if (match(GetValue("NAME_BASE"),"*-*"))
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then mid(GetValue("NAME_BASE"),(1+
(find(GetValue("NAME_BASE"),"-"))),2)
else ""
endif

Use format functions in value fields
You can define the format used in a value field in two ways: In the Value Field
Properties dialog box by filling in the fields for Datatype, Meaning, Unit and
Decimals, or by creating a formula in the Formula field. In formulas, you can
use the format function that converts an attribute value to a formatted
information string.

When you use a format function in a formula, always set the Datatype to Text
in the Value Field Properties dialog box. Leave the other fields in the Format
area empty.

For example, if you want to convert the attribute value to numbers with
decimals in the report, you need to include the conversion function double in
the format function:

The default values for unit and decimals are defined in the
contentattributes_global.lst file. The format function converts the
attribute value to a formatted information string on the basis of what you have
defined in the format function. The format function overrides the definitions in
the contentattributes_global.lst file and settings that you have defined
in the Format area of Value Field Properties dialog box.

Example of the result in a report when you use the formula above:

Mesh Information:
Geometry Size: 4/4-150/150-2750*2000
Length: 9'-1/4"
Height: 6'-6 3/4"
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Example of the result of the formula, when you use set the advanced option 
XS_IMPERIAL to FALSE instead of TRUE:

Mesh Information:
Geometry Size: 4/4-150/150-2750*2000
Length: 2750 mm
Height: 2000 mm
For a list of valid unit and precision strings, see the valuefieldclasses.lst
file located in the ..\Program Files\Tekla Structures\<version>\nt
\TplEd\settings folder. Do not make changes in this file. Below is an
example of the file content, which may change between Tekla Structures
versions.

// 
--------------------------------------------------------------------------
-------------
// 
// - Use only letters, numbers, slashes and underlines.
//
// 
--------------------------------------------------------------------------
-------------
//
// Class               =        units { presicions }

Length                 =        mm, dm, cm, m, inch, ft, yd, inch-frac 
{1/2, 1/4, 1/8, 1/16 }, ft-frac { 1/2, 1/4, 1/8, 1/16 }
Angle                  =        Degrees, radians
Area                   =        mm2, cm2, dm2, m2, sq.inch, sq.ft, sq.yd
Area/length            =        mm2/m, cm2/m, dm2/m, m2/m, in2/in, 
in2/ft, ft2/ft, sq.yd/ft
Volume                 =        mm3, cm3, dm3, m3, cu.in, cu.ft, cu.yd 
Weight                 =        kg, T, N, lbf, kip
Weight/length          =        kg/m, T/m, N/m, daN/m, kN/m, lbf/ft
Density                =        kg/m3, T/m3, N/m3, kN/m3, lbf/ft3
Temperature            =        Kelvin, Celsius, Fahrenheit
Section_modulus        =        mm3, cm3, in3
Moment_of_inertia      =        mm4, cm4, in4
Warping_modulus        =        mm6, cm6, in6
Force                  =        kg, T, N, daN, kN, lbf, kip
Force/length           =        kg/m, T/m, N/m, daN/m, kN/m, lbf/in, 
lbf/ft, kip/in, kip/ft
Force/area             =        kg/m, kg/cm, kg/mm, T/m, T/cm, T/mm, N/m, 
N/cm, N/mm, daN/m, daN/cm, daN/mm, kN/m, kN/cm, kN/mm, lbf/in, lbf/ft, 
kip/in, kip/ft
Moment                 =        kgm, Tm, Nm, daNm, kNm, lbf-in, lbf-ft, 
kip-in, kip-ft
Moment/length          =        kgm/m, Tm/m, Nm/m, daNm/m, kNm/m, lbf-
ft/ft, kip-ft/ft
Stress                 =        kg/m2, kg/cm2, kg/mm2, T/m2, T/cm2, T/
mm2, N/m2, N/cm2, N/mm2, daN/m2, daN/cm2, daN/mm2, kN/m2, kN/cm2, kN/mm2, 
psi, psf, ksi, ksf
Date                   =        dd.mm.yyyy, mm.dd.yyyy, mm/dd/yyyy, 
yyyy/mm/dd, dd-mm-yy, dd-mm-yy, yyyy-mm-dd, dd/mm/yy
Time                   =        hh:mm:ss, hh:mm:ss:am/pm
Date&&Time             =        dd.mm.yyyy, mm.dd.yyyy, mm/dd/yyyy, 
yyyy/mm/dd, dd-mm-yy, dd-mm-yyyy, yyyy-mm-dd, dd/mm/yy
Date_local             =        dd.mm.yyyy, mm.dd.yyyy, mm/dd/yyyy, 
yyyy/mm/dd, dd-mm-yy, dd-mm-yyyy, yyyy-mm-dd, dd/mm/yy
Time_local             =        hh:mm:ss, hh:mm:ss:am/pm
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Date&&Time_local       =        dd.mm.yyyy, mm.dd.yyyy, mm/dd/yyyy, 
yyyy/mm/dd, dd-mm-yy, dd-mm-yyyy, yyyy-mm-dd, dd/mm/yyLeadingZeroes
LeadingZeroes
DistanceList           =        mm, dm, cm, m, inch, ft, yd, inch-frac 
{1/2, 1/4, 1/8, 1/16 }, ft-frac { 1/2, 1/4, 1/8, 1/16 }

For more information about value fields, formats, format functions and other
functions, see Template Editor User's Guide.

Templates 394 Tips for templates



8 Tekla Model Sharing and multi-
user for administrators

You can find a table of the differences between Tekla Model Sharing and multi-
user models here.

8.1 Tekla Model Sharing
Tekla Model Sharing enables efficient global collaborative modeling within a
shared Tekla Structures model. Tekla Model Sharing gives users the freedom
to work with the same model at the same time in different locations and time
zones.

In Tekla Model Sharing each user has a local version of the model on their
computer, or on a network drive, and the model data is shared and
synchronized over the Internet using a Microsoft Azure cloud sharing service.
When a model is shared, it is connected to the cloud-based sharing service.
You can check the status of the service at any time.

NOTE The users of the same shared model need to have the same Tekla Structures
version, and use the same latest service pack.

When a user starts to share a model, the organization the user belongs to gets
the model ownership. In Tekla Model Sharing, an organization always owns all
the models shared by the users in the organization. A shared model is always
owned by only one organization. You can manage and view all the shared
models owned by your organization with the web-based Management Console
for Tekla Model Sharing. Logging in requires Trimble Identity administrator
rights.

Tekla Model Sharing requires a valid Tekla Model Sharing license and a
Trimble Identity which is part of a valid organization. Based on the Trimble
Identity information, you can assign and manage Tekla Model Sharing licenses
in the web-based Tekla Online Admin Tool. For more information, see
Managing Trimble Identities and Tekla Model Sharing licenses.
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Tekla Model Sharing cloud sharing service status is publicly available at Tekla
Model Sharing Status. On this web-site, you can also find information about
any service breaks.

For more information on how Tekla Model Sharing works, see

•

•

•

•

• Manage models in Management Console for Tekla Model Sharing

NOTE Tekla Model Sharing requires a single-user model. A model cannot be
simultaneously shared and used in the multi-user mode. If you want to start
using multi-user mode to share your model instead of Tekla Model Sharing,
you first need to exclude your local version of the model from the sharing
service and then convert it to a multi-user model.

The excluded model has no connection to the original shared model in the
sharing service. This means that if you exclude your local version of the model
from the sharing service and start to use the model in multi-user mode, you
cannot later merge the original shared model and the multi-user model.

8.2 Multi-user models
You can work on Tekla Structures models in either single-user or multi-user
mode. Multi-user mode allows several users to access the same model at the
same time. Several users can work on the same project and be aware of the
others' progress, so that copying and merging models is not needed.

The multi-user model consists of a single master model that can be located
anywhere in the network. Each user can access this model, and open their
own local view of the model on a client computer. This local view is called a
working model. Any changes that a user makes to the working model are local,
and not visible to other users, until the working model is saved to the master
model.

The multi-user model is locked during opening, saving, and numbering. When
one of the users performs any of these operations, other users cannot
perform them during that time. For more information, see .

NOTE All users of the multi-user model should use the same settings and
the same version and service pack of Tekla Structures.

Tekla Structures multi-user server runs as a service that is started
automatically when you start the computer. You do not need to log in to the
service. We recommend that you use the latest multi-user server version
available regardless of the Tekla Structures version that you use. Note that
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using the multi-user server requires your company to have more than one
Tekla Structures license.

Setting access rights to a multi-user model

You can protect user-defined attributes using privileges. You can also prevent
your model and drawings from being accidentally modified by using the
Locked user-defined attribute (UDA). You can use the UDA for parts
(separately for beams, columns, and so on), bolts, welds, specific drawing
types, project properties, and phase properties.

Using the Locked UDA and privileges together you can even restrict some
users or organizations from modifying your model. For more information on
access rights, see .

The Locked UDA has three values: Yes, No, and Organization. When set to
Yes, the object is locked and you cannot modify its properties. You can only
change the object's user-defined attributes that do not affect numbering. If
you try to modify a locked object, Tekla Structures displays the following
warning message:

There are locked objects, see report. The operation could not
be performed.
To add the lock attribute to the user interface, you need to add the following
line in the object's section in the objects.inp file:

 attribute("OBJECT_LOCKED", attribute("OBJECT_LOCKED",
"Locked:", option,"%s", none, none, "0.0", "0.0")
{
value("No", 1)
value("Yes", 0) 
value("Organization", 0)
}  
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9 Import Tekla Structures model
and drawings into another
model

You can use the Import model command to import a Tekla Structures model
and drawings to another model. If the imported model is later updated, you
can re-import the updated model.

• It is not possible to import a model or parts of it directly into the same
model (for example, if the model folder has been copied in the file system
and then worked on separately). You can work around this, for example, by
first importing the model into a new empty model or by using the Save as
command to create a copy of the model.

• If you import to an existing model, fix the possible numbering conflicts by
adding prefixes in numbering series.

• Importing models from older versions of Tekla Structures is not allowed.
When you try to import an old model, the following message is displayed:
"Importing models from previous versions is not supported. First save the
model with the current version. Note that you will not be able to use Tekla
Structures of previous version to edit the model." Click Open for upgrade
to open and save the model in the new version, or click OK.

• You can use the Import model command as a replacement to the old
model dump import. Import the model to an empty Tekla Structures model
created without a model template.

1. Open the Tekla Structures model into which you want to import the other
model.

2. Go to Quick Launch, start typing import model, and select the Import
model command from the list that appears.
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3. Select a model folder to import and click OK. 

The model objects and drawings are imported and the changes are
displayed using the same listing as is used in Tekla Model Sharing.

With default settings, the Locked attribute is set to Yes in the imported
objects. Locking is controlled by the advanced option 
XS_MODEL_IMPORT_LOCK_OBJECTS in the Import category of the Advanced
Options dialog box.
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10 Import user-defined attribute
values

You can import user-defined attribute (UDA) values to a model from a text file.
For example, you can import a list of manufactured or checked assemblies.
You can also clear existing user-defined attribute values through attribute
import.

You can import attribute values to Tekla Structures model objects, drawings,
and reference model objects (if configured, see ). You define matching criteria
for the attribute import in your input file, and you can additionally limit the
import scope to objects you select in the model or to reference model objects.

The input file can be:

• Exported from other software.

• Created manually using any standard text editor, for example, Microsoft
Notepad.

• Created from Microsoft Excel by saving the file with the Save as command
to Text (Tab-delimited) (*.txt) format.

• A simple Tekla Structures report containing the part GUIDs and user-
defined attributes.

NOTE There are alternative ways to import data into user-defined attributes. For
example, user-defined attributes can be filled in when you import IFC objects
and convert them to native Tekla Structures objects. There are also several
extensions in Tekla Warehouse that allow you to modify user-defined
attribute data.
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11Develop applications using
Tekla Open API

You can develop your own applications and additional features for Tekla
Structures through the Tekla Open API (Application Programming Interface).
Tekla Open API is implemented using Microsoft .NET technology.

Applications that are developed using Tekla Open API to work with Tekla
Structures are called extensions. To use the power of the Tekla Open API, you
must write program code outside Tekla Structures. If you do not know how to
program, you can still benefit from the Tekla Open API by downloading
extensions created by others from Tekla Warehouse.

With Tekla Open API you can:

• Record and run user interface actions

By recording and running user interface actions you can automate routine
tasks, such as creating daily reports.

• Create automation tools

You can create automation tools for frequently needed objects. With
automation tools you can, for example, create basic structures or add
typical details to drawings.

• Integrate Tekla Structures to other software

You can utilize the Tekla Open API and .NET in transferring information
between Tekla Structures and other software, such as Analysis & Design
software.

• Create new functionality.

For more information on Tekla Open API and extensions, visit the Tekla
Developer Center.
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12Disclaimer

© 2021 Trimble Solutions Corporation and its licensors. All rights reserved.

This Software Manual has been developed for use with the referenced
Software. Use of the Software, and use of this Software Manual are governed
by a License Agreement. Among other provisions, the License Agreement sets
certain warranties for the Software and this Manual, disclaims other
warranties, limits recoverable damages, defines permitted uses of the
Software, and determines whether you are an authorized user of the
Software. All information set forth in this manual is provided with the warranty
set forth in the License Agreement. Please refer to the License Agreement for
important obligations and applicable limitations and restrictions on your
rights. Trimble does not guarantee that the text is free of technical
inaccuracies or typographical errors. Trimble reserves the right to make
changes and additions to this manual due to changes in the software or
otherwise.

In addition, this Software Manual is protected by copyright law and by
international treaties. Unauthorized reproduction, display, modification, or
distribution of this Manual, or any portion of it, may result in severe civil and
criminal penalties, and will be prosecuted to the full extent permitted by law.

Tekla Structures, Tekla Model Sharing, Tekla PowerFab, Tekla Structural
Designer, Tekla Tedds, Tekla Civil, Tekla Campus, Tekla Downloads, Tekla User
Assistance, Tekla Discussion Forum, Tekla Warehouse and Tekla Developer
Center are either registered trademarks or trademarks of Trimble Solutions
Corporation in the European Union, the United States, and/or other countries.
More about Trimble Solutions trademarks: http://www.tekla.com/tekla-
trademarks. Trimble is a registered trademark or trademark of Trimble Inc. in
the European Union, in the United States and/or other countries. More about
Trimble trademarks: http://www.trimble.com/trademarks.aspx. Other product
and company names mentioned in this Manual are or may be trademarks of
their respective owners. By referring to a third-party product or brand, Trimble
does not intend to suggest an affiliation with or endorsement by such third
party and disclaims any such affiliation or endorsement, except where
otherwise expressly stated.

Portions of this software:
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EPM toolkit © 1995-2006 Jotne EPM Technology a.s., Oslo, Norway. All rights
reserved.

Portions of this software make use of Open CASCADE Technology software.
Open Cascade Express Mesh Copyright © 2019 OPEN CASCADE S.A.S. All rights
reserved.

PolyBoolean C++ Library © 2001-2012 Complex A5 Co. Ltd. All rights reserved.

FLY SDK - CAD SDK © 2012 VisualIntegrity™. All rights reserved.

This application incorporates Open Design Alliance software pursuant to a
license agreement with Open Design Alliance. Open Design Alliance Copyright
© 2002-2020 by Open Design Alliance. All rights reserved.

CADhatch.com © 2017. All rights reserved.

FlexNet Publisher © 2016 Flexera Software LLC. All rights reserved.

This product contains proprietary and confidential technology, information
and creative works owned by Flexera Software LLC and its licensors, if any. Any
use, copying, publication, distribution, display, modification, or transmission of
such technology in whole or in part in any form or by any means without the
prior express written permission of Flexera Software LLC is strictly prohibited.
Except where expressly provided by Flexera Software LLC in writing,
possession of this technology shall not be construed to confer any license or
rights under any Flexera Software LLC intellectual property rights, whether by
estoppel, implication, or otherwise.

To see the third party open source software licenses, go to Tekla Structures,
click File menu --> Help --> About Tekla Structures and then click the 3rd
party licenses option.

The elements of the software described in this Manual are protected by
several patents and possibly pending patent applications in the United States
and/or other countries. For more information go to page http://
www.tekla.com/tekla-patents.
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