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1 Tekla Structures configurations

Tekla Structures online licenses are purchased as a recurring or fixed-term
subscription. The license details, including renewal information, can be viewed
in the Tekla Online Admin Tool. The licenses unlock the Tekla Structures
Carbon, Tekla Structures Graphite, or Tekla Structures Diamond
configurations, which progressively enable more product features. Also special
student and developer configurations are available. Note that legacy
configurations are still used with on-premises licensing.

• Tekla Structures Diamond is for detailing & production information.

• Tekla Structures Graphite is for modeling & design documentation.

• Tekla Structures Carbon is for viewing & collaboration.

Our documentation covers the content of the Tekla Structures Diamond
configuration, so you may not have access to all the described features. If your
organization has licenses for different configurations, you can select between
them when you start Tekla Structures.

Feature map for online licenses

 Carbon Graphite Diamond
Modeling
Opening and
viewing models

✔ ✔ ✔

Modeling of parts,
steel assemblies,
precast cast units,
concrete pour
units

 ✔ ✔

Creating steel and
concrete
components

 ✔1 ✔

Creating unique
part marking
(numbering)

 ✔2 ✔
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 Carbon Graphite Diamond
Intelligent batch
editing tools

  ✔

Planning tools
Logistics planning,
sequencing,
scheduling,
classifying, status
visualization

✔ ✔ ✔

Drawings and reports
Creating reports &
print drawings

✔ ✔ ✔

Creating general
arrangement,
rebar and anchor
bolt drawings
(plan, section,
erection)

 ✔ ✔

Creating steel and
concrete
production
drawings (part,
assembly, cast
units)

  ✔

Interoperability
Exports for steel
CNC & MIS
systems

✔ ✔ ✔

Exports to rebar
manufacturing
systems

✔ ✔ ✔

Exports for
precast concrete
ERP & MES
systems

✔ ✔ ✔

Work with
reference models
(such as DWG,
DXF, IFC formats)

✔ ✔ ✔

Analyzing    
Create analysis
models and
analysis loads

 ✔ ✔
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 Carbon Graphite Diamond
Analysis and
design interfaces

 ✔ ✔

Other    
Open API
capabilities

✔ ✔ ✔

✔1 = Conceptual components only.

✔2 = Numbering is not available for steel or precast assemblies,
reinforcement is still numbered.

Feature map for on-premises licenses

 Full Ste
el
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Reb
ar
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ject
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Viewing ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Grids,
construction
lines, points

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Building
elements

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔1

Assemblies ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Precast cast units ✔ ✔ ✔ ✔ ✔

Batch editing ✔ ✔ ✔ ✔    ✔    
Pour modeling ✔2 ✔2 ✔2 ✔2 ✔2 ✔2 ✔2 ✔2
Pour viewing ✔2 ✔2 ✔2 ✔2 ✔2 ✔2 ✔2 ✔2 ✔2 ✔2 ✔2
Cast in Place cast
units

✔ ✔ ✔ ✔ ✔ ✔

Numbering ✔ ✔6 ✔ ✔3 ✔

Assigning control
numbers

✔ ✔ ✔ ✔

Steel
components

✔ ✔ ✔8 ✔8 ✔8 ✔8 ✔
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Concrete
components

✔ ✔ ✔5,
8

✔8 ✔8 ✔8 ✔

User-defined
attributes

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔9 ✔9 ✔7

Locking ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Multi-user ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Clash check
manager

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Planning tools
Lotting ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Precast planning
tools (such as
Palletizer and
Stacker)

✔ ✔1
0

✔ ✔

Sequencer ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Project status
visualization (4D)

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Task manager ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Organizer ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔4
External editors
Symbol Editor ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Template Editor ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Drawings, plans and reports
Drawing layout
editor

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Creating general
arrangement
drawings (plan,
section, erection)

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Modifying
general
arrangement

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔
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drawings (plan,
section, erection)
Creating steel
fabrication
drawings (single-
part drawings)

✔ ✔ ✔ ✔

Modifying steel
fabrication
drawings (single-
part drawings)

✔ ✔ ✔ ✔

Creating steel
fabrication
drawings
(assembly
drawings)

✔ ✔ ✔ ✔

Modifying steel
fabrication
drawings
(assembly
drawings)

✔ ✔ ✔ ✔

Creating precast
concrete
drawings (cast
unit drawings)

✔ ✔ ✔ ✔

Modifying
precast concrete
drawings (cast
unit drawings)

✔ ✔ ✔ ✔

Creating cast-in-
place concrete
drawings (cast
unit drawings)

✔ ✔ ✔ ✔ ✔

Modifying cast-in-
place concrete

✔ ✔ ✔ ✔ ✔
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drawings (cast
unit drawings)
Anchor bolt plans ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Reports ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Printing and
plotting

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Interoperability
Export CNC, DSTV ✔ ✔ ✔ ✔ ✔ ✔

Steel MIS links ✔ ✔ ✔ ✔ ✔ ✔

Import 2D and
3D DWG, DXF

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Export 3D DWG,
DXF, DGN

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Export drawings
(DXF, DWG)

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Import and
export CAD and
FEM packages

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

IFC export ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

CIS/2 import and
export

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

ELiPLAN import
and export

✔ ✔ ✔ ✔

BVBS export ✔ ✔ ✔ ✔ ✔

HMS export ✔ ✔ ✔ ✔

Unitechnik
export

✔ ✔ ✔ ✔

View reference
models

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Insert reference
models (DXF,

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔
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DWG, DGN, IFC,
XML, PDF)
Layout manager ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Analyzing
Create analysis
model

✔ ✔ ✔ ✔ ✔ ✔

Analysis and
Design interface

✔ ✔ ✔ ✔ ✔ ✔

Loads ✔ ✔ ✔ ✔ ✔ ✔

Open API
Open API
capabilities

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔4

✔1 = Limitation: 2500 parts, 5000 reinforcement objects, unlimited number of
bolts.

✔2 = Pours are enabled by an advanced option.

✔3 = Numbering is limited to cast-in-place parts, cast units and reinforcement.

✔4 = View only.

✔5 = Cast in Place concrete components only.

✔6 = Numbering is limited to steel parts and cast units.

✔7 = User-defined attributes in drawing properties can be edited, others view
only.

✔8 = Conceptual components only.

✔9 = User-defined attributes that affect numbering cannot be edited.

✔10 = Availability depends on the extension, check the Tekla Warehouse page
for details.
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2 Start Tekla Structures

With Tekla Structures, you can create information-rich 3D models of all
structures and materials, and the 3D model is also the single source of
information for drawings and other outputs, such as reports and NC data files.

When you start Tekla Structures, you are asked to choose your Tekla
Structures setup. The setup consists of an environment, role, and
configuration.

• Environment means region-specific settings and information. It defines, for
example, which profiles, material grades, default values, drawing settings,
component settings, reports, and templates are available and used for the
specific region.

• Role is a user group profile that limits the availability of files and settings in
an environment. The user interface has been customized for each role,
meaning that some of the settings that are not relevant for the specific role
are hidden to make the user interface clearer and easier to use.

• Configuration consists of a set of features that the user is entitled to based
on the license agreement.

If you are a company administrator, see Overview of environments, roles and
licenses.

2.1 Choose your Tekla Structures setup
1. Start Tekla Structures by selecting it from the Windows Start menu or by

double-clicking the desktop icon.

2. Sign in using your Trimble Identity when prompted. 

A dialog box where you choose your Tekla Structures setup and the type
of license appears. Proceed with the default online license option.

However, if you have an on-premises license, click Change license server
--> Use your on-premises license server.

Start Tekla Structures 12 Choose your Tekla Structures setup



3. Select an environment that fits the region where your project is done. 

If you cannot find the desired environment from the list, see Install and
license Tekla Structures.

You can also select blank project and use it as a basis for a customized
environment.

4. Select a role. 

The availability of roles depends on your environment, but typically the
following roles are available:

• Concrete Contractor

• Engineer

• General Contractor

• Precast Concrete Detailer

• Production Planner for Concrete

• Rebar Detailer

• Steel Detailer

5. Select a configuration. 

The configuration you are using may not contain all the features
described in the Tekla Structures product guides. For more information
on the features available in each configuration, see Tekla Structures
configurations (page 5).

6. Click OK. 
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Tekla Structures start screen appears.

7. Select what you want to do: 

• On the Recent tab, you can open a recently used model (page 16).

If the Recent tab is empty, then the All models tab is shown.

• On the All models tab, you can open any existing model (page 16).

If the All models tab is empty, then the New tab is shown.

On the Recent and All models tabs, you can sort each of the columns.
Additionally, you can change the order and size of the columns by
dragging them.

You can search models by name just by starting to type the name of
the model. For example, when you type N, Tekla Structures selects the
first model starting with the letter N.

To open the selected model, double-click the selected model, or select
the model and click the Open button.

• On the Shared models tab, you can open a model that has been
shared by using Tekla Model Sharing.

• On the New tab, you can create a new model (page 17).

2.2 Create your own environment: blank project
Blank project is a Tekla Structures environment that includes only generic
content, such as parametric profiles, undefined bolt, material and rebar
grades, and basic drawing layouts. It can be used for gathering region-,
company-, or project-specific settings, tools, and information. The blank
project is always included in the Tekla Structures installation.

Download and install content to the blank project

You can use Tekla Warehouse to download and install content to the blank
project. For example, you can download profiles, material grades, bolts,
reinforcement, components, applications, and templates from Tekla
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Warehouse across all environment- and manufacturer-specific collections, and
make combinations that suit your needs.

You can download and install content from Tekla Warehouse both before and
during a project. Before starting a project, you can install content to your
project and firm folders. During a project, you can install content to the model
folder.

2.3 Check or change your Tekla Structures setup
You can check your current Tekla Structures setup (environment, role, and
configuration) at any time without having to close the model.

1. On the File menu, click Settings and scroll down to the License area. 

You current setup is displayed.

2. Change the setup if needed. 

You may be required to restart Tekla Structures after the changes.

2.4 Tekla Structures usage data
Tekla Structures collects usage data on how you use the software. This
information helps to improve Tekla Structures, and it is an easy way to
influence the future development of Tekla Structures. Your data is combined
with other people's data to make a statistical analysis.

Tekla Structures collects usage patterns and trends of how you use the
commands and tools in the software. The program collects this information
automatically while you use Tekla Structures. You can view the log file to check
the collected data.

1. On the File menu, click Logs --> Usage data log to view the log file. 

Note that the UserFeedbackLog.txt log file is always opened with the
default text editor, unlike other log files which can be opened through the
Tekla Structures log viewer. The option to switch between the viewers
does not work for the UserFeedbackLog.txt file.

The UserFeedbackLog.txt log file is located in the Logs folder under
the path defined with XSUSERDATADIR in teklastructures.ini file.
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2. To fine-tune the data saving interval or the data sending interval, use the
advanced options XS_AUTOMATIC_USER_FEEDBACK_SAVING_INTERVAL
and XS_AUTOMATIC_USER_FEEDBACK_SENDING_INTERVAL.

2.5 Open a model
You can have one model open at a time. If you open a model and already have
one open, Tekla Structures prompts you to save the first model.

Open a recently used model
1. On the File menu, click Open.

2. Click Recent.

3. Select a model in the list. 

Tekla Structures shows the thumbnail image (page 18) of the model, if
you have added a one, and some basic creation information of the model.

4. To open the selected model, click Open or double-click the model. 

If no views are visible in the model, Tekla Structures prompts you to select
one.

NOTE If you want to remove a model from the Recent models list, right-click
a model and select one of the options.

• Delete the selected item: delete the selected model from the list

• Clear all: remove all the models from the list

• Clear invalid entries: remove all invalid models from the list, such
as deleted models that cannot be opened anymore

Open any existing model
1. On the File menu, click Open.

2. Click All models. 

If you want to search for models in another folder, click Browse....

If you want to sort the models based on name or the modification date,
use the Order by sorting.

3. Select a model in the list. 

Tekla Structures shows the thumbnail image (page 18) of the model, if
you have added a one, and some basic creation information of the model.
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4. To open the selected model, click Open or double-click the model. 

If no views are visible in the model, Tekla Structures prompts you to select
one.

Open a shared model
If you want to open a model that has been shared by using Tekla Model
Sharing, you need to be logged in with your Trimble Identity.

1. On the File menu, click Open.

2. Click Browse shared models. 

Tekla Structures prompts you to log in with your Trimble Identity, if not
already done so.

3. Select the shared model in the Shared models dialog box.

2.6 Create a new model
Create a separate model for each Tekla Structures project. Each model is
stored in its own folder under the TeklaStructuresModels folder.

1. On the File menu, click New.

2. In the Name box, enter a name for the new model. 

The maximum length of the name is 40 characters.

Do not use special characters (/ \ ; : |). We recommend that you try
to decide on a permanent name at this point. The name of the model can
be changed afterward, but it involves changing several file names.

3. Define where to save the new model. 

By default, the model is saved in the TeklaStructuresModels folder
that was created during installation. You can change the default folder by
clicking Browse. You can also select a recently used folder in the Place in
list.

4. Select whether to run Tekla Structures in single-user or multi-user mode. 

• Single-user: the model will be used by one person at a time.

• Multi-user: the model is stored on a server and may be used by several
people simultaneously. Enter the name of the server in the Server
box.

5. If you want to use a model template, select one. 

You can mark the important model templates as favorites, or hide the
templates that you do not need.

a. Select a model template in the list.
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b. Right-click and select Favorite or Hidden. 

If you marked a template as Favorite, it is placed on top of the
template list. Alternatively, use the star icon on the template to mark
it as Favorite, or to remove the marking.

If you marked a template as Hidden, it is removed from the template
list. Select the Show hidden items check box to show it again.

6. If you want to link the model to a Trimble Connect project, select the Start
Trimble Connect collaboration check box. 

Linking the model to a Trimble Connect project happens after the model
has been created. For further instructions, see Link a Tekla Structures
model to a Trimble Connect project.

7. Click Create. 

Tekla Structures creates the model and opens the default model view. The
contents of the model view may differ based on the model template you
chose in step 5.

See also

Create a thumbnail image of a model (page 18)

Edit project properties (page 19)

2.7 Create a thumbnail image of a model
You can add a thumbnail image to make it easier to recognize your project
even when you do not remember the exact name of the model. The thumbnail
image is displayed when you browse for existing models.

1. On the View tab, click  Screenshot --> Project thumbnail.

2. Select a view. 

Tekla Structures creates the image and saves it in the model folder with
the name thumbnail.png.

3. To check the thumbnail, go to the File menu, click Open, and select the
model you created the thumbnail for in the Recent or in the All models
list. 
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The image is now displayed with other model information. For example:

4. If you are unhappy with the thumbnail image, you can repeat steps 1–2 as
many times as you need. 

For example, you can zoom the model in and out to adjust what is shown
in the thumbnail image. When you create a new thumbnail, Tekla
Structures overrides the existing thumbnail image with the new one.

TIP Alternatively, if you want to use a custom image, you can add the image directly
to the model folder with the name thumbnail.png. The preferred size of the
image is 120 x 74 pixels.

2.8 Edit project properties
You will need project information, such as project number and name, many
times during a project. Update the project properties at the beginning of each
project to make reports and drawings display the correct information
automatically. All of the fields are optional.

1. On the File menu, click Project properties.

2. Edit the general project properties, and enter a description that helps you
identify the model when you next need to open it. 

The description is listed with the other model information when you select
a model in the Recent or in the All models list.

The limit for the length of the description is 78 characters.

When you edit the properties, Tekla Structures highlights the modified
properties in yellow. When you are ready with the modifications, click
Modify to apply the changes.

3. If you want to use another coordinate system for interoperability and
collaboration, click Base points to define a new base point. 

Once a base point has been defined, you can select it from the Location
by list.

Start Tekla Structures 19 Edit project properties



4. To define project-specific user-defined attributes, click User-defined
attributes. 

By default, you can define:

• Project comment

• User fields

• Execution class

• Classification system

• IFC export attributes

• GEO coordinates

• Status attributes

• Unitechnik factory location

The availability of the various user-defined attributes depends on your
environment (page 12), role and configuration (page 5).

Once you are finished with editing the project properties, as a result, you will
get updated project properties in drawings and reports.

Displaying project information in templates and reports

The fields in the image below refer to template attributes, which you can use
when designing your own reports and templates. To display project
information, add the corresponding template attributes in the templates and
reports.
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(1) NUMBER#2

(2) NAME

(3) BUILDER
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(4) OBJECT

(5) DESIGNER

(6) LOCATION

(7) ADDRESS

(8) POSTAL_BOX

(9) TOWN

(10) REGION

(11) POSTAL_CODE

(12) COUNTRY

(13) DATE_START

(14) DATE_END

(15) INFO1, INFO2

(16) DESCRIPTION

2.9 Save a model
You should save your model regularly to avoid losing any work. Tekla
Structures also automatically saves your work at regular intervals.

NOTE Tekla Structures versions are not backwards compatible. When you save a
model, you cannot open it in older versions of Tekla Structures due to
database differences.

Save the current model
To save changes to the current model file, do one of the following:

• On the top left corner of the screen, click Save .

• On the File menu, click Save as --> Save.

• Press Ctrl+S.

Save a copy with different name or location
You can create a copy of the model with a different name or in a different
folder. The original version of the model remains intact.
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NOTE When you save the model with a different name, all the GUIDs
(globally unique identifiers) of the saved model will change and be
different than in the original model. This means that the saved model
has no relation to the original model, and the saved model cannot be
used as backup.

1. On the File menu, click Save as --> Save as.

2. In the Model name box, enter a new name.

3. To save in a different location, click Browse and define where you want to
save the model.

4. Click OK. 

Tekla Structures creates a new copy with a different name, but the original
version of the model remains intact.

Save a backup copy
You can create a backup copy of the model with the same GUIDs (globally
unique identifiers) as the original model.

1. On the File menu, click Save as --> Save and create backup copy. 

Tekla Structures saves a copy of the model in
the ..\TeklaStructuresModels\backup\<model_name>\<date-
time> folder.

2. If you need to take the backup copy into use in place of the current model,
move the backup copy from the chosen date to your model folder. 

You can either replace all contents of the current model folder with the
content of the chosen backup folder, or you can rename the backup
folder (<date-time>) to match the original model name.

3. If you want to change the location of the backup folder, use the advanced
option XS_MODEL_BACKUP_DIRECTORY.

NOTE To save disk space, you can compress the 
XS_MODEL_BACKUP_DIRECTORY folder.

Save as a model template
You can save a model with the desired settings and use the model as a
template when you create new models.
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Define autosave settings
Use Autosave to automatically back up and save your work at set intervals.
You can set the autosave interval separately for the model and drawings.
Autosave files have the extension .db1_<user>.

1. On the File menu, click Settings --> Options, and go to the General
settings.

2. Under Autosave, set the autosave interval.

a. In the first box, enter the number of minutes after which Tekla
Structures saves the model. The default value is 15 minutes. 

Note that if there are no changes in the model during the autosave
interval, the autosave is not triggered.

b. In the second box, enter the number of drawings after which Tekla
Structures saves your work.

NOTE The smallest accepted value for the autosave interval is 2, both
for modeling and for drawings.

If you try to enter a value smaller than 2, Tekla Structures
automatically changes the value to 2.

3. Click OK.

4. Define where to store the Autosave files. 

By default, Tekla Structures stores the autosave files in
the ..\TeklaStructuresModels\autosave folder. To change the
folder, use the advanced option XS_AUTOSAVE_DIRECTORY.

5. Define whether to keep old autosave files. 

By default, Tekla Structures deletes the autosave files when you close a
model, to save disk space. To keep autosave files even if you exit Tekla
Structures without saving the model, use the advanced option
XS_KEEP_AUTOSAVE_FILES_ON_EXIT_WHEN_NOT_SAVING.

When to use an autosaved model
You can use the autosaved model if there are errors when trying to open a
model (page 16). When you open a model, Tekla Structures automatically
checks if the previous session ended normally. If it did not, Tekla Structures
asks whether you want to continue by using the autosaved model or the
original model.

If Tekla Structures displays the warning Fatal: Model memory corrupted by
read, it means that hardware problems have damaged the model database.
Your hard disk may be damaged. Use autosave or system backup files to
restore the model.
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3 Introduction to Tekla
Structures user interface

When you open a Tekla Structures model, a new window appears. By default,
the user interface will look something like this:

(1) This is your Tekla Structures model. If you are starting a completely new
project, you will only see the default model view and an empty grid at this
point.

(2) The green cube symbol represents the global coordinate system and it lies
at the global origin (x=0, y=0, z=0).

(3) The box around the grid represents the work area. In a view, you can only
see the parts that are within this area. Objects that are outside the work area
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exist in the model, but they are not visible. You can shrink and expand the
work area to suit your needs. You can also hide the work area box.

(4) The coordinate symbol with the three axes x, y, and z represents the local
coordinate system. It also indicates the direction of the model.

(5) The File menu is where you manage your models. You can save models
(page 22), print drawings, and import and export models, among other things.

(6) The ribbon contains all the commands and other functions you will use
when building your model. You can customize the ribbon according to your
needs.

(7) By default, the Quick Access Toolbar (page 44) contains the Save, Undo,
Redo, and Undo history shortcuts icons. You can customize the Quick Access
Toolbar according to your needs.

(8) The upper right corner shows your user-name and a green symbol
indicating that you are logged in and your license is working as expected. If a
clock symbol is shown instead of the green symbol, the clock indicates that
you are disconnected from online licensing.

(9) If you cannot find the command or dialog box you are looking for, search
with Quick Launch (page 30).

(10) Use the side pane (page 31) on the right side of the screen to check
instructions for the currently active ribbon command, view model objects
properties, add reference models and components, attach point clouds, use
custom inquiry, or to find direct access to Tekla Online services.

(11) The work plane handler toolbar controls which work plane you currently
have in use in the model.

(12) The model search toolbar enables a quick search for objects in the entire
model or within the selected model objects.

(13) The snap switches control which positions you can pick when creating
objects.

(14) The selection switches control which objects you can select.

(15) When you create objects, the status bar (page 36) will tell you how to
proceed and when to pick points.

3.1 How to use the ribbon and the commands on the
ribbon
All the essential commands in Tekla Structures are available on the ribbon.
The commands are grouped according to their use. You can modify the
appearance of the ribbon, and customize the content of the ribbon, if needed.
All commands throughout Tekla Structures work in the same manner.
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How to use commands on the ribbon

To Do this
Find commands Slide the ribbon right or left with your

mouse, or scroll with your mouse
wheel.

Some commands have more options
under them. The options become
available when you click the
command's name:

Activate the command you want to
use

On the ribbon, click the command.

The command runs until you end it or
use another command.

Check which command you need for
your current task, if you are unsure

Rest the mouse pointer on a
command.

A small window called tooltip
appears. Tooltips provide more
information about commands and
also give examples, hints, and tips.
For example:
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To Do this
Press Ctrl+F1 when a tooltip is open
to find more help on the command.

To switch the tooltips on or off, click
File menu --> Settings --> Switches ,
and then select or clear the Tooltips
check box.

View more detailed instructions on
how to use the currently active ribbon
command

In the side pane, click  to open
the Instructor side pane window.

On the ribbon, click a command. The
Instructor side pane window shows
short videos, steps and other
information on how to use the active
command.

End command Right-click and select Interrupt.

You can also press Esc.
Re-activate the last command Press Enter.

NOTE You can complete many commands by using the Enter or the space
key as a shortcut, or by using the middle mouse button.

To use the Enter key as a shortcut for completing commands, set the
advanced option XS_ENTER_FINALIZES_COMMANDS to TRUE.

Change the appearance of the ribbon
You can change the order of ribbon tabs, choose how they are aligned, and
even hide some parts of the ribbon if you do not need them in your current
project. For example, if you are only modeling steel parts, you can temporarily
hide the Concrete tab.

To Do this
Change the order of tabs on the
ribbon

Drag and drop the tab titles.

Change how the tabs are aligned Right-click on the top bar of the
ribbon, select Navigation mode, and
then select one of the options.

• Scroll visible: the ribbon
movement is minimal when you
switch between the tabs

• Align to left: the icons start from
the left side of the ribbon
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To Do this
• Align to tab: the icons start from

the left side of the current tab
Hide the tabs that you do not need in
your current project

1. Rest the mouse pointer on a tab
title.

A small eye symbol appears next
to the tab title:

2. Click the eye symbol .

The eye symbol changes and the
tab title becomes gray:

The View tab is now hidden from
the ribbon. If you slide the
ribbon, hidden tabs appear as:

3. To re-display the hidden tab, click
the eye symbol again.

Minimize the ribbon
You can minimize the ribbon to save space on your screen. When the ribbon is
minimized, the command buttons are hidden but the tabs are visible.

1. Right-click on the top bar of the ribbon, and select Minimized. 

The ribbon is now minimized to save space on the screen:

2. To access the commands when the ribbon is minimized, click a tab title. 

The ribbon becomes visible so that you can select a command.
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3. To restore the ribbon, right-click on the top bar of the ribbon, and select
Minimized again.

3.2 How to use Quick Launch to find commands, dialog
boxes, and toolbars
Use the Quick Launch box in the upper-right corner of the screen to find
commands, dialog boxes, toolbars, and other functions. The shortcut key for
Quick Launch is Ctrl+Q.

1. In the Quick Launch box , enter a search term. 

For example, type bolt if you are looking for bolt commands.

2. Wait for a list of search results to appear. For example: 

The search results show the location of the command. You can navigate in
the list by clicking the Recent, Ribbon, Menu, and All commands tabs.
The Recent tab lists 10 most recently started commands from the search
results.

Alternatively, you can navigate in the search results by using the up and
down arrow keys on the keyboard. Start the selected command by clicking
Enter.

Tekla Structures highlights the commands on the ribbon or on the File
menu. For example:
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If the command you have searched is in the side pane, Tekla Structures
opens the side pane window.

3. To run a command, click its name on the search results list. 

Or press the Enter key to instantly run the first command on the list.

4. For some basic settings (page 37) and toolbars a check box appears in
front them on the search results list. Click the command to activate the
setting, or to have the toolbar visible. 

5. If you want to open the list of search results again, click the Quick Launch
box and the list opens automatically. 

To clear the Quick Launch box, click the  button or press the Esc key.

See also

How to use the ribbon and the commands on the ribbon (page 26)

How to use the side pane (page 31)

3.3 How to use the side pane
Use the side pane on the right side of the screen, for example, to view model
object properties, and to add reference models and components.

To Do this
Open a side pane window Click a side pane button to open a side pane

window.

•
Click  to view model object properties
using Custom inquiry.

•
Click  to open Instructor and to view
instructions for the currently active ribbon
command.
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To Do this
•

Click  to find shortcut access to the
different Tekla Online services.

•
Click  to attach point clouds to a model.

•
Click  to show the properties of model
objects.

•
Click  to show the reference models list.

•
Click  to show the Applications &
components catalog.

When you click a side pane button, the side pane
window opens and becomes active. Active side

pane windows have blue buttons .
Keep multiple side pane
windows open at the same
time

Tekla Structures opens only one side pane
window at a time by default. You can keep
multiple side pane windows open at the same
time if needed.

• Right-click a side pane button and select
Single pane or Stacked panes.

Single pane: Tekla Structures opens a new
side pane window and closes all the other
open side pane windows.

Stacked panes: Tekla Structures opens a new
side pane window and keeps the other open
side pane windows stacked on top of each
other.

• Click Ctrl+side pane button to open the side
pane windows stacked on top of each other.

You can resize the side pane windows and
change their order by dragging them.

Close a side pane window You can close one active side pane window at a
time, or several windows at one go if you have
stacked them on top of each other.

• Click another side pane button to close the
active side pane window and to open a new
window.
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To Do this
•

Click the  button in the upper right corner
of each side pane window.

•
Click the arrow  in the side pane.

Move a side pane window When you position the mouse pointer on the
upper part of the side pane window, the upper
part is shown in light blue.

Grab the upper part of the side pane window
and drag the window to a new location.

Float and dock a side pane
window

You can float or dock the side pane windows.

• To float a side pane window: right-click a side
pane button and select Float.

• To dock a side pane window: right-click the
side pane button of a floating window and
select Attach to side pane.

Alternatively, you can drag the side pane
window back to the docking area on the right
or at the bottom of the screen. The docking
area is marked with blue color.

If you float a side pane window and close Tekla
Structures, the side pane window will be opened
in its floating position when you start Tekla
Structures the next time.

Adjust the size of a side
pane window

Resize a floating side pane window by dragging
its borders.

Find more help on the
content of a side pane
window

Click the  button.
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TIP Sometimes a side pane window opens on a second display that is not
connected to your computer at the moment. To return the side pane
window to the main display, right-click the side pane button and select
Attach to side pane.

See also

Introduction to Tekla Structures user interface (page 25)

3.4 How to use the contextual toolbar
When you click an object in a model or drawing, a contextual toolbar symbol

 appears next to the mouse pointer. Click the symbol to open the
contextual toolbar. Use the contextual toolbar to quickly view and change
some basic properties of an object, view, grid, and so on.

If multiple objects are being selected, the contextual toolbar displays the text
Varies for any properties that differ.

How to change object properties using contextual toolbar
The changes that you make on the contextual toolbar are immediately applied
to the model or drawing.

1. Click an object in a model or drawing. 

A contextual toolbar appears next to the mouse pointer.

2. Change the object properties on the contextual toolbar. 

The changes are applied immediately.

TIP Press the Tab key to move between the properties and command buttons on
the contextual toolbar.

Drawing commands in contextual toolbar
In the model, the Open or create drawings command in the contextual
toolbar opens a menu that lists the drawings created for the selected objects,
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and contains the Create fabrication drawing command for creating single-
part, assembly and cast unit drawings, and a command for showing the
drawings created for the selected objects in Document manager, where you
can then open the drawings.

In drawings, you can use the contextual toolbar to quickly view and change
some basic properties of a drawing object, view, grid, and so on.

Show or hide contextual toolbar
You can define whether the contextual toolbar is visible in Tekla Structures.

1. On the File menu, click Settings.

2. Under Toolbars, select or clear the Contextual toolbar check box. 

Alternatively, use the keyboard shortcut Ctrl+K to show or hide the
contextual toolbar.

Define contextual toolbar's position
You can define the position of the contextual toolbar, relative to an object's
reference point.

1. Select an object.

2. Hold down the Ctrl key and click the contextual toolbar with the left
mouse button. 

A dashed line appears between the contextual toolbar and the object.

3. Drag the contextual toolbar to a new position. 

For example, you can position the contextual toolbar on the left side of
the selected object.

4. Release the left mouse button. 

The contextual toolbar now appears in the position you defined, for
example on the left side of any object you select.
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Pin contextual toolbar in place
You can pin the contextual toolbar to a specific location on the screen, so that
the position is locked. For example, you could have it appear at the upper left
corner of the screen. In the locked state, the position of the contextual toolbar
is independent of the individual part’s location.

1. Drag the contextual toolbar to a new location.

2. Click  to pin the contextual toolbar to the new location. 

The pin icon changes when the position is locked.

3. To unlock the position, click .

Minimize contextual toolbar
You can minimize the contextual toolbar so that it takes less space on your
screen.

1. On the contextual toolbar, click . The contextual toolbar now has the

symbol .

2. To restore the contextual toolbar to its original size, click  again.

3.5 View status bar messages
Status bar is the area located at the bottom of the Tekla Structures main
window. Follow the instructions on the status bar when you use commands.
For example, when you are creating a part, the status bar will tell you how to
proceed and when to pick points.

1. Instructions and error messages

2. The status of Ortho (O), Smart select (S) and coordinate locks (X, Y, Z).

3. The level in assembly or component hierarchy (0–9)

4. The middle mouse button mode (Pan or Scroll)

5. The current phase

6. The number of selected objects and handles

See also

Basic settings in the File menu (page 37)
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3.6 Basic settings in the File menu
Use the toolbar settings and the switches in File menu --> Settings to control
some basic modeling and drawing settings.

1. Click File in the upper-left corner of the screen .

2. Go to Settings.

3. Under User interface, Switches, or Toolbars, switch the options either
on or off.

In drawings, under Color mode, click one of the options to change the
color mode to Black and white, Grayscale, or Color.

Alternatively, you can use Quick Launch (page 30) box  to
control the toolbars and the switches. Start typing the name of the toolbar or
the switch, for example, smart, in the Quick Launch box and select the
toolbar or the switch on the search results list to activate the setting.

User interface

• Toolbars: Use the option buttons to adjust the size of the icons on the
toolbars at the bottom of the screen, and at the same time the toolbar size.

• Font size (Ribbon): Use the slider to adjust the ribbon font size. The
default font size is 11p.

Switches

Option Description
Smart select Change how drag-and-drop works for

object handles.

When the option is on, you can drag
from object handles without selecting
them first.

When the option is off, you must
select the handles before dragging.
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Option Description
Drag & drop Activate or inactivate the drag-and-

drop command.

When the option is on, you can use
drag-and-drop when copying or
moving objects.

When the option is off, drag-and-drop
cannot be used.

Middle button pan Change the panning mode.

When the option is on, you can move
the model or drawing using the
middle mouse button.

When the option is off, you can move
the model using the left mouse
button.

Centered zooms Change the zooming mode.

When the option is on, the center
point of zooming is kept in the middle
of the view, regardless of the mouse
pointer position.

When the option is off, the mouse
pointer position determines the
center point of zooming.

Basic view auto rotation Activate or inactivate the auto
rotation of part and component 3D
views.

When the option is on, Tekla
Structures rotates the view once
whenever you create a new 3D view
of a part or component.

When the option is off, Tekla
Structures does not rotate the view.

Crossing selection Change how area selection works.

When the option is on, all objects that
fall at least partially inside the
rectangular area are selected,
regardless of the dragging direction.

When the option is off, the dragging
direction affects the selection of
objects.
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Option Description
Rollover highlight Switch the highlighting of objects on

or off.

Depending on the rendering engine
you are using, OpenGL or DirectX,
Tekla Structures highlights the objects
differently when rollover highlight is
on.

When the option is on, Tekla
Structures highlights selectable
objects when you move the mouse
pointer on them.

When the option is off, selectable
objects are not highlighted.

Select on right-click Change how objects can be selected.

When the option is on, you can select
objects also with the right mouse
button. Also the related context menu
is displayed immediately.

When the option is off, you can select
objects with the left mouse button.

Automatic rotation center Define how the view point is set.

When the option is on, the view point
changes whenever you click the
middle mouse button.

When the option is off, the view point
stays in a set position.

Ortho Activate or inactivate orthogonal
snapping. Orthogonal snapping also
works in drawings.

When the option is on, Tekla
Structures snaps to the closest
orthogonal point on the plane (0, 45,
90, 135, 180 degrees, and so on). The
mouse pointer automatically snaps to
positions at even distances in the
given direction.

When the option is off, orthogonal
snapping is not used.

Use legacy rendering Activate or inactivate the DirectX
rendering.

When the option is on, the legacy
OpenGL rendering is used.
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Option Description
When the option is off, the DirectX
rendering is used. DirectX rendering
is better optimized for modern
graphics cards.

The rendering setting is model view
specific, which means that you can
use a different rendering options in
different model views. If you switch
between the rendering options, you
need to reopen the model view to
activate the new value.

Hatching of overlapping surfaces In the DirectX rendered model views,
switch the hatching of overlapping
surfaces on the same plane on or off.

When the option is on, the
overlapping surfaces are visualized
with a hatch, and you can detect
duplicate objects or any overlapping
parts.

When the option is off, the
overlapping surfaces are not
visualized.

Hatching is shown in views whose
rendering option is Parts rendered /
Components rendered (Ctrl/Shift
+4).

If you switch the option on or off, you
need to reopen the view to activate
the new value.

Dashed line for hidden line In the DirectX rendered model views,
show or hide dashed lines for part
edge lines when the part edge lines
are hidden behind another part.

When the option is on, the dashed
lines are shown, making it easier to
see, for example, if the part flange is
facing towards or away from the web,
or, in more complex 3D views, which
part is on top of which.

Using the dashed lines also increases
Tekla Structures performance in the
transparent views.
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Option Description
When the option is off, the dashed
lines are not shown and the
performance effect is removed.

Dashed lines can be shown in all
views whose rendering option is one
of the following:

• Parts wireframe / Components
wireframe (Ctrl/Shift+1)

• Parts shaded wireframe /
Components shaded wireframe
(Ctrl/Shift+2)

• Parts grayscale / Components
grayscale (Ctrl/Shift+3)

• Show only selected part / Show
only selected component (Ctrl/
Shift+5).

If you switch the option on or off, you
need to restart Tekla Structures to
activate the new value.

Tooltips Show or hide the tooltips (page 26).

When the option is on, a small
window with examples, hints, and tips
appears when you rest the mouse
pointer on a command.

When the option is off, no tooltips
appear.

Snap tooltips Show or hide the snap tooltips.

When the option is on and you start a
command that requires picking
points, Tekla Structures displays a
snap tooltip that shows the name of
the snap point.

When the option is off, no snap
tooltips appear.

The following settings are available only in the drawing mode:
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Option Description
Printer line widths Show on the screen the drawing lines

with the defined line thickness in
color and grayscale color modes.

The black and white color mode
always shows the printer line
thicknesses on the screen, whereas
the color and grayscale color modes
only show the printer line thicknesses
on the screen if the Printer line
widths switch is enabled.

When the option is on, the lines in
color and grayscale modes are shown
with defined thickness.

When the option is off, the lines in
color and grayscale modes are shown
with default thickness.

Printer line colors Show line colors in the drawing.
Ghost outline Show hidden objects in drawings as

ghost outlines in color drawings. In
grayscale and black and white
drawings, hidden objects are not
shown even if Ghost outline is
selected.

When the option is on, hidden lines
are shown as ghost outlines.

When the option is off, hidden lines
are not shown.

Associativity symbol Shows which drawing objects are
associative and automatically
updated. Associativity symbols are
shown only when you select a
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Option Description
drawing object, for example a
dimension.

Objects that do not have valid
association get a ghost associativity
symbol and a question mark.

When the option is on, associativity
symbols are shown.

When the option is off, associativity
symbols are not shown.

Dimension creation associativity Activate the dimension creation
associativity functionality, which
displays and allows you to change the
dimension associativity rule for each
dimension point separately during
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Option Description
the manual dimensioning of the
drawing objects.

Drawing drag & drop Activate or inactivate the drag-and-
drop command in drawings.

When the option is on, you can use
drag-and-drop when moving objects
such as annotations, sketch objects
and grid lines without selecting the
objects or handles first.

When the option is off, you need to
select the objects or handles first
before you can drag.

Toolbars

Use the toolbar switches to switch the selected toolbars on and off:

• Snapping toolbar

• Snap override toolbar

• Selecting toolbar

• Work plane handler toolbar

• Model search toolbar

• Contextual toolbar

By default, the toolbars are located at the bottom of the screen.

See also

How to use the contextual toolbar (page 34)

How to use the ribbon and the commands on the ribbon (page 26)

How to use Quick Launch to find commands, dialog boxes, and toolbars
(page 30)

3.7 Icons on the Quick Access Toolbar
Quick Access Toolbar provides shortcut icons to the commonly used
commands. The toolbar is located on top left corner of the screen.
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If needed, you can customize the Quick Access Toolbar and add the
commands of your choice to it.

Icon Description
Save (page 22) changes to the current model file.

Undo the last action.

Redo the actions previously undone.

Open the Undo history dialog box. The dialog box lists
the commands you have run and the modifications
you have done. Use the list to undo or redo several
commands or modifications at one go.
This icon is visible if you use Tekla Model Sharing.

Read in other users' model changes from the sharing
service. Only the changed data is read in.
This icon is visible if you use Tekla Model Sharing.

Write out your model changes to the sharing service.
Only new or changed data is written out.
The icon is visible if you use Tekla Model Sharing.

Show read in changes. After you have read in, a list of
model changes is displayed.

See also

Introduction to Tekla Structures user interface (page 25)

3.8 Default keyboard shortcuts
Tekla Structures contains a large number of keyboard shortcuts that you can
use to speed up your work.

If you want to assign new shortcuts or change the default shortcuts, you can
customize the keyboard shortcuts.

Common commands

Command Keyboard shortcut
Help F1
Help: when tooltip is open Ctrl+F1
Open Recent models list Ctrl+O
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Command Keyboard shortcut
Create new model Ctrl+N
Save model Ctrl+S
Delete Del
Open properties

When an object is selected, the
properties are opened either in the
property pane or in a dialog box.

Alt+Enter

Undo Ctrl+Z
Redo Ctrl+Y
Interrupt Esc
Repeat last command Enter
Show/hide contextual toolbar Ctrl+K
Switch direct modification on/off D
Quick Launch Ctrl+Q
Open Advanced options dialog box Ctrl+E
Open Applications & components
catalog side pane

Ctrl+F

Open Keyboard shortcuts dialog box Ctrl+Shift+C

Rendering options

Command Keyboard shortcut
Parts wireframe Ctrl+1
Parts shaded wireframe Ctrl+2
Parts grayscale Ctrl+3
Parts rendered Ctrl+4
Show only selected part Ctrl+5
Components wireframe Shift+1
Components shaded wireframe Shift+2
Components grayscale Shift+3
Components rendered Shift+4
Show only selected component Shift+5
References wireframe Ctrl+Shift+1
References shaded wireframe Ctrl+Shift+2
References grayscale Ctrl+Shift+3
References rendered Ctrl+Shift+4

Introduction to Tekla Structures user interface 46 Default keyboard shortcuts



Command Keyboard shortcut
Show only selected reference Ctrl+Shift+5

Selecting objects

Command Keyboard shortcut
Switch rollover highlight on/off H
Select all selection switch F2
Select parts selection switch F3
Select rebar sets selection switch Alt+Q
Select rebar groups selection switch Alt+W
Select single rebars selection switch Alt+E
Select all objects in the model Ctrl+A
Select previous objects Alt+P
Select assembly Alt+object
Add to selection Shift
Toggle selection Ctrl
Selection filters Ctrl+G
Hide object Shift+H

Snapping

Command Keyboard shortcut
Snap to reference lines/points F4
Snap to geometry lines/points F5
Snap to nearest points F6
Snap to any position F7
Switch Ortho on/off O
Relative coordinate input R
Absolute coordinate input A
Global coordinate input G
Cycle forward through the available
snap points

Tab

Cycle backwards through the
available snap points

Shift+Tab

Switch coordinate lock X, Y or Z on/off X, Y or Z
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Copying and moving objects

Command Keyboard shortcut
Copy Ctrl+C
Move Ctrl+M
Switch smart select on/off S

Viewing the model

Command Keyboard shortcut
Open the Views list Ctrl+I
Switch between 3D/plane view Ctrl+P
Switch between views Ctrl+Tab
Updated window Ctrl+U
Zoom original Home
Zoom previous End
Zoom in Page Up
Zoom out Page Down
Zoom selected Shift+Space
Rotate using mouse Ctrl+R
Rotate using keyboard Ctrl+arrow keys

Shift+arrow keys
Set view rotation point V
Rotate once

Rotate continuously

Shift+R

Shift+T
Switch view rotation on/off F8
Pan P
Switch middle button pan on/off Shift+M
Move right

Move left

Move down

Move up

arrow keys

Center by cursor

Use to center the model on a
particular point.

Insert

Fly Shift+F
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Command Keyboard shortcut
Create clip plane Shift+X
Switch fullscreen on/off F11

Checking the model

Command Keyboard shortcut
Inquire object Shift+I
Measure distance F
Create report Ctrl+B
Open Phase manager Ctrl+H
Create AutoConnections Ctrl+J

Rebar display options

Command Keyboard shortcut
Leg face visibility Alt+1
Guideline visibility Alt+2
Property modifier visibility Alt+3
Splitter visibility Alt+4
End detail modifier visibility Alt+5
Rebar dimension visibility Alt+6
Color rebar groups Alt+7

Part position options

These keyboard shortcuts work for both native Tekla Structures parts as well
as for analysis parts.

Command Keyboard shortcut
Part position up Alt+arrow up
Part position down Alt+arrow down
Part position left Alt+arrow left
Part position right Alt+arrow right
Part rotation clockwise 90 degrees

Note that this command is not
available for analysis parts.

Alt+space
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Drawings

Command Keyboard shortcut
Open Document manager in model Ctrl+L
Open Document manager in
drawing mode

Ctrl+O

Print drawings Shift+P
Open next drawing Ctrl+Page Down
Open previous drawing Ctrl+Page Up
Associativity symbol Shift+A
Set next drawing color mode B
Ghost outline Shift+G
Add orthogonal dimension G
Add free dimension F
Open any drawing after creating the
drawing

Ctrl+Shift

In Document manager: Open user-
defined attributes

Alt+U

In Document manager: Add to
Master Drawing Catalog

Ctrl+M

In Document manager: Revision
handling

Ctrl+R

In Master Drawing Catalog: Select all Ctrl+A
In Master Drawing Catalog: Create
drawings for all parts

Alt+A

In Master Drawing Catalog: Create
drawings

Alt+C

Set UCS origin U
Set UCS by two points Shift+U
Toggle orientation Ctrl+T
Reset current Ctrl+1
Reset all Ctrl+0

3.9 How to use dialog boxes
You can use dialog boxes to view and modify the properties of various objects
in Tekla Structures. Typically dialog boxes open when you double-click an
object in the model or in the drawing.

Introduction to Tekla Structures user interface 50 How to use dialog boxes



NOTE Model object properties, such as part properties, are modified with the
property pane, not with dialog boxes.

Learn the common dialog box buttons

The following table lists some common buttons that can be found in the Tekla
Structures dialog boxes.

Button Description
Saves the properties and closes the dialog box. Tekla
Structures uses these properties the next time you create an
object of this type.
Saves the properties without closing the dialog box. Tekla
Structures uses these properties the next time you create an
object of this type.
Modifies the selected objects using the current properties of
the dialog box.
Fills the dialog box with the properties of the selected object.
If several objects are being selected, Tekla Structures takes
the properties randomly from one of them.
Switches all check boxes in the dialog box on and off.

Closes the dialog box without saving the properties or
modifying objects.
Saves the properties in the file shown in the list.

Loads the previously saved properties to the dialog box.
Tekla Structures also loads the properties of sub-dialog
boxes, even if they are not open. Select the name of the
properties file you want to use.
Saves the properties with the name given in the box. The
Save as button also updates the Load list. This is important
if you add or delete files manually.

Tekla Structures stores the properties files in the model
folder, also including the properties of sub-dialog boxes.

Modify object properties by using dialog boxes

1. Double-click an object to open the properties dialog box.

2. To indicate which properties should be changed, select or clear the
desired check boxes.

For example, if you want some part marks to share the same name but do
not want to change any of their other individual properties, ensure that
only the Name check box is selected.
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TIP Click  to switch all check boxes on or off.

3. Modify the properties as needed.

4. Select the objects you want to modify.

5. Click Modify.

Tekla Structures changes the properties whose check boxes you selected.

3.10 Change the language
You can change the language of the Tekla Structures user interface at any
time.

1. On the File menu, click Settings --> Change language.

2. Select a language from the list. 

You have the following options. The three-letter language codes that are
given in parentheses are used in some language-dependent file and
folder names.

• Chinese – simplified (chs)

• Chinese – traditional (cht)

• Czech (csy)

• Dutch (nld)

• English (enu)

• French (fra)

• German (deu)

• Hungarian (hun)

• Italian (ita)

• Japanese (jpn)

• Korean (kor)

• Polish (plk)

• Portuguese (ptg)

• Portuguese – Brazilian (ptb)

• Russian (rus)

• Spanish (esp)

3. Click OK.

4. Restart Tekla Structures for the change to take effect.
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3.11 Take screenshots
A screenshot is an image of a model or drawing view. You can use screenshots
in posters, brochures, or other material to show projects carried out using
Tekla Structures.

By default, the screenshots are saved in the \screenshots folder under the
current model folder with the name snap_xx.png.

Take a screenshot of a model
You can take screenshots of model views.

1. Open a model and adjust the model view according to your needs. 

For example, hide the work area box if you do not want to show it.

2. On the View tab, click  Screenshot --> Screenshot.

3. If you have multiple views of the model, click Pick view and select the
view to take the screenshot from.

4. To modify the settings, click Options.

a. Define the width, height, and DPI of the screenshot.

b. Click OK to save the changes.

5. Define a name and location for the screenshot.

a. Select Print to file and enter a descriptive name for the screenshot in
the File name box. 

You can also change the whole path. If you do not want to do this,
you can keep the default values for the path and the file name.

6. Click Show with associated viewer to show the screenshot in an
application that is by default associated with this file type.

7. Click Capture.

Take a screenshot of a drawing
A drawing screenshot is an image of an open drawing with or without borders.

1. Open a drawing and adjust the drawing view according to your needs. 

For example, delete unnecessary marks or dimensions, and hide
unnecessary parts.
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2. On the Views tab, click  Screenshot --> Screenshot.

3. Do one of the following: 

• Select View to take a screenshot of the open drawing with window
borders

• Select View without borders to take a screenshot of the open
drawing without window borders.

4. Under the preselected Print to file option enter a descriptive name for
the screenshot in the File name box. 

You can also change the whole path. If you do not want to do this, you can
keep the default values for the path and the file name.

5. Click Show with associated viewer to show the screenshot in an
application that is by default associated with this file type.

6. Click Capture.

Save a screenshot in bitmap format
By default, screenshots are created as Portable Network Graphics (.png) files.
You can also save a screenshot in bitmap (.bmp) format to use it, for example,
as a custom component thumbnail. Note that the bitmap file size is much
larger than when saving as PNG.

1. On the Views tab, click  Screenshot --> Screenshot.

2. Select Place on clipboard.

3. Click Capture.

4. Paste the screenshot in your graphics editor and save it in .bmp format.

NOTE The software that you use to open the screenshot may have a limit for the
number of pixels.

Screenshot settings
Use the Screenshot dialog box to view and modify the screenshot settings.

The following options are available in model views and in drawings.

Option Description
View name Shows the selected view name.
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Option Description
View Includes the view content and

window borders in the screenshot.

Not available in model views.
View without borders Includes only the view content in the

screenshot.

Not available in model views.
Rendered view For high resolution screenshots from

model views. The Options button
displays the Screenshot Options
dialog box.

Not available in drawings.
Place on clipboard Places the screenshot on the

clipboard.

Not available in drawings.
Print to file Saves the screenshot to a file.

The following screenshot options are only available in model views:

Option Description
Final width The width of the screenshot.

The units depend on the settings in
File menu --> Settings --> Options --
> Units and decimals .

Final height The height of the screenshot.

The units depend on the settings in
File menu --> Settings --> Options --
> Units and decimals .

DPI The pixel density (DPI) of the
screenshot.

There are limitations to pixel density.
You can change the DPI using a
graphics editor.

White background Uses white background.
Smooth lines Uses smooth lines to decrease jagged

edges.
Line width Sets the line width.
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4 Contact Tekla Structures
support (Support tool)

The Support tool allows you to contact Tekla Structures support directly. With
this tool you can collect the model, related files, and other necessary
information in one support request, and safely upload your request to Tekla
Structures support.

The Support tool:

• Automatically identifies the open model and includes all files or selected
files according to your selection from the model folder as attachments to
your request. Some logs and files in other folders are also attached, such
as the user feedback log, Tekla Structures logs and user-defined attribute
files.

• Automatically gathers application and system information.

• If a crash is encountered, attaches automatically to the Support tool the
crash dumps, session log files and Windows logs of type Error from last 72
hours. They can be skipped by clearing the Crash information file
category selection.

• Uploads the problem description, attached model, attached files, and all
other gathered information to Tekla Structures support.

NOTE Confidentiality information

All files you upload are treated as confidential. Only the recipient can access
the files.

4.1 Create a support request
1. On the File menu, click Help --> Contact Tekla support .

2. Log in using your Trimble Identity. 
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The Support tool opens and automatically fills in user, application and
Tekla Structures version information. Support tool reads your name, email
address, company name and support email address from your Trimble
Identity profile.

You can switch to another account by clicking Switch user.

3. Select a category from the list of predefined categories, or select Other
and enter the category.

4. Enter the problem description.

5. Click Next.

6. Select what you want to attach. The file name, file group, file size, and file
location are mentioned for each file. 

• By default all files are selected.

• Select the All check box, or select specific files from the Select the
files list.

• If you want to send some other attachments than shown in the Select
the files list, click the Add extra files button and browse for the files.

7. Click Next. 

The Support tool creates the package and shows the total attachment
size. You can also check application information and operating system
information before finalizing the support case creation.

8. Click Create case to upload your case to Tekla Structures support.

While you create the support case, the navigating back button in the upper-left
corner is disabled for a moment so that you cannot accidentally interrupt the
upload.

When the upload is complete, you will receive a notification at your email
address. After a successful upload, an automatic confirmation message will be
sent to you, and then Tekla Structures support will start solving your case.

For a list of offices and resellers together with their contact information, see
Offices and resellers.
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5 Disclaimer

© 2022 Trimble Solutions Corporation and its licensors. All rights reserved.

This Software Manual has been developed for use with the referenced
Software. Use of the Software, and use of this Software Manual are governed
by a License Agreement. Among other provisions, the License Agreement sets
certain warranties for the Software and this Manual, disclaims other
warranties, limits recoverable damages, defines permitted uses of the
Software, and determines whether you are an authorized user of the
Software. All information set forth in this manual is provided with the warranty
set forth in the License Agreement. Please refer to the License Agreement for
important obligations and applicable limitations and restrictions on your
rights. Trimble does not guarantee that the text is free of technical
inaccuracies or typographical errors. Trimble reserves the right to make
changes and additions to this manual due to changes in the software or
otherwise.

In addition, this Software Manual is protected by copyright law and by
international treaties. Unauthorized reproduction, display, modification, or
distribution of this Manual, or any portion of it, may result in severe civil and
criminal penalties, and will be prosecuted to the full extent permitted by law.

Tekla Structures, Tekla Model Sharing, Tekla PowerFab, Tekla Structural
Designer, Tekla Tedds, Tekla Civil, Tekla Campus, Tekla Downloads, Tekla User
Assistance, Tekla Discussion Forum, Tekla Warehouse and Tekla Developer
Center are either registered trademarks or trademarks of Trimble Solutions
Corporation in the European Union, the United States, and/or other countries.
More about Trimble Solutions trademarks: http://www.tekla.com/tekla-
trademarks. Trimble is a registered trademark or trademark of Trimble Inc. in
the European Union, in the United States and/or other countries. More about
Trimble trademarks: http://www.trimble.com/trademarks.aspx. Other product
and company names mentioned in this Manual are or may be trademarks of
their respective owners. By referring to a third-party product or brand, Trimble
does not intend to suggest an affiliation with or endorsement by such third
party and disclaims any such affiliation or endorsement, except where
otherwise expressly stated.

Portions of this software:
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EPM toolkit © 1995-2006 Jotne EPM Technology a.s., Oslo, Norway. All rights
reserved.

Portions of this software make use of Open CASCADE Technology software.
Open Cascade Express Mesh Copyright © 2019 OPEN CASCADE S.A.S. All rights
reserved.

PolyBoolean C++ Library © 2001-2012 Complex A5 Co. Ltd. All rights reserved.

FLY SDK - CAD SDK © 2012 VisualIntegrity™. All rights reserved.

This application incorporates Open Design Alliance software pursuant to a
license agreement with Open Design Alliance. Open Design Alliance Copyright
© 2002-2020 by Open Design Alliance. All rights reserved.

CADhatch.com © 2017. All rights reserved.

FlexNet Publisher © 2016 Flexera Software LLC. All rights reserved.

This product contains proprietary and confidential technology, information
and creative works owned by Flexera Software LLC and its licensors, if any. Any
use, copying, publication, distribution, display, modification, or transmission of
such technology in whole or in part in any form or by any means without the
prior express written permission of Flexera Software LLC is strictly prohibited.
Except where expressly provided by Flexera Software LLC in writing,
possession of this technology shall not be construed to confer any license or
rights under any Flexera Software LLC intellectual property rights, whether by
estoppel, implication, or otherwise.

To see the third party open source software licenses, go to Tekla Structures,
click File menu --> Help --> About Tekla Structures and then click the 3rd
party licenses option.

The elements of the software described in this Manual are protected by
several patents and possibly pending patent applications in the United States
and/or other countries. For more information go to page http://
www.tekla.com/tekla-patents.
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