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1 Get to know Tekla Structures
basic working methods

Before starting to create models and drawings, get to know some basic
working methods that you will need to work efficiently both in the Tekla
Structures models and in the drawings.

We recommend you to familiarize yourself how to

• work with grids (page 20) and views

• define the work area (page 48) and coordinates (page 51) that affect your
work

• zoom and rotate (page 81) the model

• create (page 196), select (page 113) and move (page 140) objects

• position objects by using snapping (page 83)

• filter objects (page 150) both in the modeling mode and in the drawing
mode.

See also

Create parts and modify part properties (page 196)

1.1 Set up the workspace
Before starting to model, check that your Tekla Structures workspace is set up
correctly.

1. Define the units and decimals you will use. (page 20)

2. Modify the grid to suit your needs. (page 20) Create a modular grid if
needed.

3. Create some views (page 31) to examine the model from different angles
and elevations.

Get to know Tekla Structures basic working
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4. Resize the work area to suit your project. (page 48)

5. Get familiar with the coordinate system (page 51). If you are modeling
sloped structures, shift the work plane accordingly. (page 53)

Change units and decimals
You can define which units and how many decimals Tekla Structures uses. The
settings are model-specific. Note that these settings do not have any effect on
drawings or reports, or on the Inquire and Measure tools.

1. On the File menu, click Settings --> Options , and go to the Units and
decimals settings.

2. Modify the units and decimals to suit your needs. 

The number located to the right of each option indicates the number of
decimals. The number of decimals affects the input and storage accuracy.
Always use a sufficient number of decimals.

• The settings on the Modeling tab affect the data that is used when you
are modeling, for example copying, moving, creating grids, creating
points, and so on.

• The settings on the Catalogs tab affect the profile and material data,
for example catalogs.

• The settings on the Analysis results tab affect the output data.

Reinforcement area and Mass/Length also affect cross section area
and weight per unit length in the rebar catalog.

• The settings on the MEP tab affect the data that is used in mechanical,
electrical, and plumbing design and construction.

3. Click OK to save the changes.

Work with grids
A grid represents a three-dimensional complex of horizontal and vertical
planes. The grid is shown on the view plane using dash-and-dot lines. You can
create both rectangular and radial grids. Use grids as an aid in locating objects
in a model. You can make rectangular grids and grid lines act magnetically so
that the objects on the grid lines of a rectangular grid follow if you move the
grid line.

• Create, modify, or delete a grid (page 23)

• Add a single grid line (page 28)

• Modify a single grid line (page 28)
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Grid terminology

(1) Grid origin is the point where the zero points of each coordinate axis
intersect

(2) Grid line extensions define how far the grid lines extend in each direction

(3) Grid labels are the names of the grid lines shown in views

Several grids in one model

You can have more than one grid in a model. You can create a large-scale grid
for the entire structure, and smaller grids for some detailed sections. Create as
many grids as needed, so that you can easily place objects in your model.
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Single grid lines

You can create single grid lines and attach them to an existing grid.

Single grid lines have handles (page 307). If the  Select grid line selection
switch is active and you select a grid line, the handles appear in magenta. If
you move the handles to make a skewed grid, you can do this only on the local
XY plane (page 31) of the grid.
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Create, modify, or delete a grid
When you create a new model, Tekla Structures automatically creates a
rectangular grid and a view according to the saved standard properties. If
needed, you can later modify the grid properties, or create new rectangular
and radial grids. You can modify an existing grid, or delete it. Use the grid
properties in the property pane to view and modify the grids.
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Create a rectangular grid or a radial grid

You can create both rectangular and radial grids and modify their properties in
the property pane.

1. Select whether to create a rectangular or a radial grid.

• To create a rectangular grid: on the Edit tab, click Grid --> Create
rectangular grid .

• To create a radial grid: on the Edit tab, click Grid --> Create radial
grid .

Tekla Structures shows a preview of the grid. You can modify the grid
properties in the property pane before inserting the grid. The grid preview
changes according to the changes in the property pane.

2. Pick a point in the model to indicate the origin of the grid, or click the
middle mouse button to accept the grid property values in the property
pane.

• If you pick an origin point to the grid, the grid is created using the
properties in the property pane, and the origin is the location you
picked.

• If you click the middle mouse button, the grid is created using the
properties in the property pane, and to the origin defined in the
property pane.

The coordinates of the origin are shown in the property pane in the
Origin section as the X, Y, and Z values.

NOTE When working with very large grids, always having the grid labels visible might
slow down Tekla Structures. To hide the grid labels when you zoom in, use the
advanced option XS_ADJUST_GRID_LABELS.
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Create a radial grid (alternative method)

This is an alternative method to create a radial grid. You can create a radial
grid using a component called Radial Grid. Note that the curved grid lines
created by the Radial Grid component are not truly curved but straight.

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Start typing radial grid in the search box.

3. Double-click Radial Grid to open the properties dialog box.

4. Modify the grid properties.

In the coordinate properties

• X defines the location of the curved grid lines and the distance
between the grid lines.

The first value is the radius of the innermost curved grid line.

• Y (degrees) defines the location of the straight grid lines and the
distance between the grid lines in degrees.

The first value defines how the grid is rotated. The grid is rotated
counter-clockwise from the x axis in the current work plane.

5. Click OK.

6. Pick a point to indicate the origin of the grid.

The grid is created automatically.

Modify a grid
Double-click an existing grid to modify it.

1. Ensure that the  Select grid selection switch is active.

2. Double-click a grid line. 

Depending on the type of the grid, the Rectangular grid or the Radial
grid properties open in the property pane.

3. Change the grid properties.

4. Click Modify to apply the changes.

Delete a grid
When you delete an entire grid, ensure that you do not have any other objects
selected. Otherwise Tekla Structures only deletes the objects, not the grid.

1. Ensure that only the  Select grid selection switch is active.

2. Select the grid.
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3. Press Delete.

4. Confirm that you want to delete the grid.

Grid properties
Use the Rectangular grid or the Radial grid properties in the property pane
to view and modify the properties of a grid. To open the properties, double-
click the grid. The file name extension of a rectangular grid property file is
*.grd. The file name extension of a radial grid property file is *.rgrd.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
Coordinates In the Rectangular grid properties:

Coordinates of the grid in the x, y, and z directions.

X: grid lines vertical to the work plane

Y: grid lines horizontal to the work plane

Z: elevations in the structure

You can enter a maximum of 1024 characters. Use a
zero at the start to represent a grid on the 0,0
coordinate and spaces as separators for
coordinates.

The x and y coordinates are relative, which means
that the entries for X and Y are always relative to
the previous entry. The Z coordinates are absolute,
which means that entries for z are absolute
distances from the work plane origin.

You can either define the coordinates individually,
or you can define several grid lines with equal
spacing. Both of the following coordinate entries
create three grid lines with the spacing of 4000:

0 4000 4000
0 2*4000
In the Radial grid properties:

Radial and angular values of the grid lines.
Elevations is the value of the grid in z direction.

Radial: curved grid lines. If you enter only one value
for radius, it must be >0.

Angular: straight grid lines. You can enter negative
angle values, if needed.

Elevations: elevations in the structure
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Setting Description
Use a zero at the start to represent a grid on the 0,0
coordinate and spaces as separators for
coordinates.

The Radial and Angular coordinates are relative,
which means that the entries are always relative to
the previous entry. The Elevations are absolute,
which means that entries are absolute distances
from the work plane origin.

You can either define the coordinates individually,
or you can define several grid lines with equal
spacing. Both of the following coordinate entries
create three grid lines with the spacing of 4000:

0 4000 4000
0 2*4000

Labels In the Rectangular grid properties:

Names of the grid lines shown in views.

Names in the X box are associated with the grid
lines parallel to the y axis and vice versa. The Z box
is for the names of levels parallel to the work plane.

If you wish, you can leave the label boxes empty.
In the Radial grid properties:

Names of the grid lines shown in views.

Names in the Radial box are associated with the
curved grid lines.

Names in the Angular box are associated with the
straight grid lines.

The Elevations box is for the names of levels
parallel to the work plane.

If you wish, you can leave the label boxes empty.
Line extensions In the Rectangular grid properties:

Define how far the grid lines extend in the directions
Left/Below and Right/Above.
In the Radial grid properties:

Define how far the grid lines extend in the directions
Start and End.

Origin Coordinates of the grid origin in the x, y, and z
directions. These values offset the grid from the
work plane origin, not from the global model origin.
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Setting Description
Magnetic grid plane In the Rectangular grid properties:

Select whether objects are bind to grid lines
(page 28). If you bind the objects to grid lines, the
objects follow if you move the grid line.

Grid color Use the color picker to pick the grid color.
Label font size and
color

Define the label font size.

Use the color picker to pick the label color.
UDAs Click the User-defined attributes button to open

the user-defined attributes (UDAs) of the grid. These
can be used for customizing drawing grid labels.

Add a single grid line
You can add new grid lines either between existing grid lines or between two
freely chosen points that you define in the model.

Add a grid line between existing grid lines
You can add new grid lines between existing grid lines.

1. Ensure that the  Direct modification switch is active.

2. Ensure that the  Select grid selection switch is active.

3. Select an existing grid to attach the grid line to.

4. Click the  symbol between two existing grid lines or outside the grid. 

Tekla Structures creates the grid line and gives it a label using the labels of
the adjacent grid lines. For example, a new grid line between the grid lines
1 and 2 receives the label 12*.

Add a grid line between two points
You can add new grid lines between two picked points.

1. On the Edit tab, click Grid --> Add grid line .

2. Select an existing grid to attach the grid line to.

3. Pick the start point of the grid line.

4. Pick the end point of the grid line. 

Tekla Structures creates the grid line.

Modify a single grid line
You can modify single grid line properties. You can also move grid lines or
change the grid line labels.
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Modify grid line properties
You can edit the properties of a single grid line in the property pane.

1. Ensure that the  Select grid line selection switch is active.

2. If the property pane is not open, double-click the grid line to open the
Grid line properties.

3. Change the properties as needed.

4. Click Modify to apply the changes.

Move a grid line
Use direct modification to move single grid lines.

1. Ensure that the  Direct modification switch is active.

2. Ensure that the  Select grid selection switch is active.

3. Select the grid.

4. Select the grid line you want to move.

5. Drag the grid line to a new location. 

You can also use the keyboard to enter a numeric location.

To start with the negative sign (-), use the numeric keypad. To enter an
absolute coordinate, first enter $, then the value. Press Enter to confirm.

Change a grid line label
Use the contextual toolbar to change the label of a single grid line.

1. Ensure that the  Direct modification switch is active.

2. Ensure that the  Select grid line selection switch is active.

3. Select a grid line.

4. On the contextual toolbar, enter a new label. 
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Stretch, shrink, or incline a grid line
Use direct modification to stretch, shrink, or incline single grid lines in
rectangular grids.

Note that this works only for the single grid lines that you have added in
rectangular grids by using the Add grid line command.

1. Ensure that the  Direct modification switch is active.

2. Ensure that the  Select grid selection switch is active.

3. Select the rectangular grid.

4. Select the grid line.

5. Drag a grid line handle  to a new location.

Turn grid line stretching off
If you move the outermost grid lines in rectangular grids using the line
handles, Tekla Structures stretches or shrinks the perpendicular, crossing grid
lines accordingly by default. You can switch this off temporarily.

1. Ensure that the  Direct modification switch is active.

2. Ensure that the  Select grid selection switch is active.

3. Select the grid line.

4. On the contextual toolbar, click the  Turn grid line stretching off
button.

Grid line properties
Use the Grid line properties in the property pane to view and modify the
properties of a single grid line. To open the properties, double-click a single
grid line. The file name extension of a grid line property file is .grdp.

The units depend on the settings in File menu --> Settings --> Options -->
Units and decimals .

Setting Description
Label Name of the grid line.
Depth in view plane Height of the grid plane

perpendicular to the view plane.
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Setting Description
Line extension Left/Below Define how far the grid lines extend in

the directions Left/Below and Right/
Above.

Line extension Right/Above

Magnetic Select whether objects are bind to
straight grid lines. If you bind the
objects to grid lines, the objects follow
if you move the grid line.

Visible in drawing Select whether grid lines are made
visible in drawings.

Grid line automatic dimensioning Select whether single grid lines are
used in grid dimensioning.

UDAs Click the User-defined attributes
button to open the user-defined
attributes (UDAs) of the grid line.

Delete a single grid line
You can delete grid lines in two different ways. The easiest way is by using
direct modification.

Delete a grid line using direct modification
Use direct modification to quickly delete single grid lines.

1. Ensure that the  Direct modification switch is active.

2. Select the grid line you want to delete.

3. Press Delete.

Delete a grid line (alternative method)
This is the alternative way of deleting single grid lines.

1. Ensure that the  Select grid line selection switch is active.

2. Select the grid line you want to delete.

3. Ensure that you do not have any other objects selected. 

If you also have other objects selected, Tekla Structures only deletes the
objects, not the grid line.

4. Right-click and select Delete from the pop-up menu.

5. Confirm that you want to delete the grid line.
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Work with views
A view is a representation of a model from a specific location. Each view is
represented in its own window within Tekla Structures. Selecting a part in a
view highlights the part in all open views.

• Create model views (page 33)

• Open, save, modify, or delete a view (page 43)

• Switch between views (page 45)

• Change the color settings for dimensions, labels, and model background
(page 69)

View plane

Each view has a view plane on which the grids (page 20) are visible and points
(page 631) are represented as blue crosses. Points that are located outside the
view plane are red. You can move the view plane (page 33) like any other
object.

Basic views

Basic views are those parallel to the global basic planes (xy, xz, and zy). In basic
views, two axes always define the view plane and the axes appear in the plane
name. The third axis is perpendicular to the view plane. It does not appear in
the plane name. In the basic plane view, the model is shown from the direction
of the third axis.

When you create basic views (page 34), you must define the view plane's
distance (the view plane coordinate) from the global origin in the direction of
the third axis.

Examples of basic views:

Plane 3D view Plane view
XY

XZ
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Plane 3D view Plane view
ZY

Other views

For other view types, you either define the view plane and coordinate by
picking points, or the points are defined automatically, depending on the
creation method.

Should I model in a 3D or plane view?

Views can be 3D or plane views. 3D, plane, and also elevation views provide
different type of information, which is useful for different tasks.

One common technique is to open several views:

• A 3D view to see a real-life version of the model

• A plane view, where you can add and connect parts

• An elevation view to check the level

If you are working with several screens, maximize your work area by putting
the different views on different screens.

You can easily switch between the 3D and plane view (page 31) by using the
keyboard shortcut Ctrl+P.

Move the view plane
You can move the view plane like any other object. When you move it, Tekla
Structures only uses the vector that is perpendicular to the view plane.

1. Click the view.

2. Right-click and select Move --> Linear.

3. Pick the start point of the translation vector, or enter its coordinates.

4. Pick the end point of the translation vector, or enter its coordinates.

5. Click Move to move the view plane.

Create model views
You can create model views in several ways in Tekla Structures.
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For example, you can create views

• of the entire model (3D view) (page 34)

• of selected parts (page 39)

• of selected components (page 40)

• along grid lines (axis views) (page 35)

• to the surface of an object (page 40)

Each view has properties which define its appearance. You can change the
appearance of a view after you have created it. To view and modify the
properties of each view (page 46), double-click anywhere on the model
background to open the View Properties dialog box.

If you create views along grid lines, you can view and modify the properties
(page 48) using the Creation of Views Along Grid Lines dialog box.

If you need to reopen views for later use, you can name and save (page 43)
them. Tekla Structures only saves the named views when you exit the model.

Create a basic view of the model
You can create a basic view along two coordinate axes. Use this view for the
overall viewing of the model.

1. On the View tab, click  New view --> Basic view .

2. Select a view plane from the Plane list. 

The view plane is defined by two axes.

3. In the Coordinate box, enter the view level. 

This value defines the distance of the view plane from the global origin,
perpendicular to the view plane.

4. Click Create.

Create a view using two points
You can create a view using two points you pick: the origin and a point in the
direction of the x axis.

1. On the View tab, click  New view --> Using two points .

2. Pick a point to indicate the origin of the view plane.

3. Pick a second point to indicate the direction of the x axis. 

The y axis is perpendicular to the view plane on which you picked the
second point.
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Create a view using three points
You can create a view using three points you pick: the origin, a point in the
direction of the x axis, and the third point in the direction of the y axis.

1. On the View tab, click  New view --> Using three points .

2. Pick a point to indicate the origin of the view plane.

3. Pick a second point to indicate the direction of the x axis.

4. Pick a third point to indicate the direction of the y axis.

Create a view of the work plane
You can create a view of the work plane using the current view properties.

• On the View tab, click  New view --> On work plane .

Create grid views
You can create views along the grid lines you select.

Before you start, create a view that contains a grid, and check the grid
properties. Note that with radial grid you can create the grid views only on the
straight grid lines, not on the arched grid lines.

If the grid properties are incorrect in some way, Tekla Structures may cut the
views at the wrong elevations or they may be named incorrectly. If you change
the grid labels or the elevation or grids later on, the views will not be
automatically renamed.

1. Select the grid.

2. On the View tab, click  New view --> Along grid lines .

3. Modify the grid view properties if needed.

a. In the Number of views list, select how many views you want to
create.

b. In the View name prefix box, enter a prefix.

c. In the View properties list, define which view properties (applied or
saved) you want to use.

4. Click Create. 

The Views dialog box opens.
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5. Click the arrow buttons to move views from the Named views list to the
Visible views list. 

The views will not be visible until you move them to the Visible views list.

Example

This example shows how to create vertical views of the grid lines 1–7 on the
following model:

In the Creation of views along grid lines dialog box, select All for the view
plane XZ and None for the view planes XY and ZY. Use the default settings for
the view name prefix and the view properties.

After creating the grid views, move the view named Grid 2 to the Visible views
list:
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The grid view is displayed as a plane view in a new window:

Rotate the view to see it in 3D:
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Create a view on a plane
You can create a view on the work plane or almost any plane of an existing
part.

1. On the View tab, click  New view --> On plane . 

When you hover the mouse cursor over model objects, Tekla Structures
highlights the available planes in light blue.

2. Select the desired plane.

TIP Alternatively, to create a view on the front, top, back, or bottom plane of
a part, you can also use the following commands available on the View
tab:

• On part front plane

• On part top plane

• On part back plane

• On part bottom plane

To use these commands, first select a command and then the part.
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Create a 3D view of a part
When you need to see a specific part clearly, create a 3D view of the part. The
part is placed in the center of the view.

1. On the View tab, click  New view --> 3D view of part .

2. Select the part. 

Tekla Structures creates the view using the properties defined in the
part_basic_view property file. The view plane y axis is the global z axis
of the model. The x axis is the projection of the part's local x axis onto the
global xy plane.

Tekla Structures fits the work area to include the selected part.

If you want Tekla Structures to rotate the view once whenever you create a
new 3D view, select the Basic view auto rotation setting in the File menu.

Create default part views
You can create four views of a part: front, top, end, and 3D view. Tekla
Structures creates these views all at once with the same command. The front,
top, and end views are plane views by default.

1. On the View tab, click  New view --> Default part views .

2. Select the part. 

Tekla Structures creates the four default views all at once, using the
properties defined in part_front_view, part_top_view,
part_end_view, and part_persp_view property files.

Create an undeformed part view
You can create a view that shows a deformed part in undeformed form. This
works only for beams and columns.

1. On the View tab, click  New view --> Undeformed part view .

2. Select the part. 

For example, select a warped beam. Tekla Structures displays the beam in
a separate view in undeformed form.

Create a 3D view of a component
When you need to see a specific component clearly, create a 3D view of the
component. The component is placed in the center of the view.
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1. On the View tab, click  New view --> 3D view of component .

2. Select the component. 

Tekla Structures creates the view, using the properties defined in the
component_basic_view property file. The view plane y axis is the global
z axis of the model. The x axis is the projection of the first secondary part
local x axis onto the global xy plane. Work area depth is 1 m in all
directions.

The component you select automatically defines the work area.

If you want Tekla Structures to rotate the view once whenever you create a
new 3D view, select the Basic view auto rotation setting in the File menu.

Create default component views
You can create four views of a component: front, top, end, and 3D view. Tekla
Structures creates these views all at once with the same command. The front,
top, and end views are plane views by default.

1. On the View tab, click  New view --> Default views of
component .

2. Select the component. 

Tekla Structures creates the four default views all at once, using the
properties defined in the component_front_view,
component_top_view, component_end_view, and
component_persp_view property files.

Create a surface view
Use the Create surface view macro to create an automatically aligned surface
view. This can be useful when modeling bolt groups, stiffener plates, and hole
penetrations on complex geometry.

To be able to select the surface of a part, ensure that you are using a model
view that shows part faces. On the View tab, click Rendering, and select either
the Parts grayscale or the Parts rendered option.

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Click the arrow next to Applications to open the applications list.

3. Double-click Create surface view to start the macro.

4. Select the surface of the part. 
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Tekla Structures creates a new temporary view and moves the work plane
typically along the longest edge of the part face. You can model in the
surface view and see your modeling work being done in your original 3D
view at the same time.

5. Press Esc to stop the macro.

6. To return the work plane back to the origin:

a. Repeat steps 1–2 to open the Applications list.

b. Double-click the Work plane global macro. 

The work plane returns back to the origin and is aligned with the
global x,y, and z planes of the model.
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Create a surface view along selected edge
Use the Create surface view wEdge macro to create a surface view and align
the work plane along the edge you select. This can be useful when modeling
bolt groups, stiffener plates, and hole penetrations on complex geometry.

To be able to select the surface of a part, ensure that you are using a model
view that shows part faces. On the View tab, click Rendering, and select either
the Parts grayscale or the Parts rendered option.

1. Ensure that the  Snap to geometry lines / points snap switch
(page 84) is active. 

This allows you to pick along an edge to define the direction.

2. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

3. Click the arrow next to Applications to open the applications list.

4. Double-click Create surface view wEdge to start the macro.

5. Select the surface of the part. 

When you hover the mouse pointer over the part edges, a yellow arrow
symbol is displayed to indicate the possible edges you can align the view
to. The head of the arrow represents the positive direction of the x axis.
The view will be rotated in this direction to form the flat horizontal edge of
the view. The origin of the view and work plane will be at the start of the
arrow snap line.
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6. Pick the desired edge. 

Tekla Structures creates a new temporary view, and the selected edge
forms the x axis of the view. You can model in the surface view and see
your modeling work being done in your original 3D view at the same time.

7. Press Esc to stop the macro.

8. To return the work plane back to the origin:

a. Repeat steps 2–3 to open the Applications list.

b. Double-click the Work plane global macro. 

The work plane returns back to the origin and is aligned with the
global x,y, and z planes of the model.

Open, save, modify, or delete a view
When you create views, you can have up to nine views on the screen at the
same time. If you need views for later use, you can name and save them. You
can modify the properties of an existing view by using the View Properties
dialog box.

Open a view
You can have up to nine views on the screen at the same time. If you are
unable to open a view, check how many views you already have open - you
may need to close some of them first.
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1. On the View tab, click  View list to open the Views dialog box. 

Tekla Structures lists all invisible named views on the left, and all visible
views on the right.

2. Select a view from the Named views list and click the right arrow to move
it to the Visible views list. 

You can also double-click a view to open it. If the view does not appear,
check how many views you already have open.

3. To open multiple views, use the Shift and Ctrl keys when you select views
from the list.

Save a view
If you need to reopen views later on, give each view a unique name. When you
exit the model, Tekla Structures only saves the named views. Temporary views
disappear when you close them.

Before you start, create one or more views (page 33) in the model.

1. Double-click the view to open the View Properties dialog box.

2. Enter a unique name in the Name box. 

Temporary views have a default name in parentheses. Do not use
parentheses when naming a view, or the view will not be saved for later
use.

NOTE In multi-user mode, it is very important to give views unique
names. If several users have different views with the same name,
the view settings of one user may accidentally override the
settings of another user.

3. Click Modify. 

Tekla Structures will automatically save all named views when you close
the model.

Modify a view
You can modify a view simply by double-clicking it.

1. Double-click the view to open the View Properties dialog box.

2. Modify the view properties (page 46). 

For example, to rename the view, enter a new name in the Name box.

3. Click Modify.

Delete a view
You can permanently delete named views.
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1. On the View tab, click  View list to open the Views dialog box. 

Tekla Structures lists all invisible named views (page 31) on the left, and all
visible views on the right.

2. Select the view you want to delete.

3. Click Delete. 

Tekla Structures deletes the view permanently. If the view was visible
during the deletion, it will remain visible until you close it.

4. To delete multiple views, use Shift or Ctrl when you select views from the
list.

Switch between views
You can easily switch between all open views while modeling. You can also
switch between the 3D and plane view to examine the current view from
different perspectives, or switch between view angles to show the model in
different angles.

Switch between open views

To switch between open views, do one of the following:

• Use the keyboard shortcut Ctrl+Tab.

• Click Window and select a view from the list.

The views are listed in alphabetical order.

• Right-click a view, then select Next window from the pop-up menu.

The next open view becomes active.

Switch between 3D and plane view

Use the Switch to 3D or plane command to examine the current view from
different perspectives.

• On the View tab, click  Switch to 3D or plane.

You can also press Ctrl+P.

Switch between view angles

Use the View angle command to show a view in different view angles.

1. Select the view, and click  View angle on the contextual toolbar.

2. Select a top, back, right, bottom, front, or left view.
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3. To return to the original 3D view, click the button in the middle of the view
angle options.

Update and refresh views
Use the Update window and Redraw commands to refresh a single view or
all views at once.

• Update: Removes temporary graphics (such as measured distances) but
does not redraw the view. Faster than redrawing.

• Redraw: Redraws the view completely and shows all previously hidden
objects.

To Do this
Update the current view Right-click the view and select Update window.
Update all of the views On the View tab, click Redraw --> Erase

temporary graphics.

Redraw the current view Right-click the view and select Redraw view.
Redraw all of the views

On the View tab, click .

See also

Switch between views (page 45)

View properties
Use the View Properties dialog box to view and modify the model view
properties.

Option Description
Name The name of the view.
Angle Whether the view angle is Plane or

3D.
Projection The projection type of views.

Orthogonal: All objects are of equal
size (no perspective). When you
zoom, text and point size remains the
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Option Description
same. In addition, the zoom remains
on object faces.

Perspective: Distant objects appear
smaller than close ones, as do text
and points. You can zoom, rotate, or
fly through the model.

Rotation How the view is rotated around the z
and x axes. Rotation is view-specific.

The units depend on the settings in
File menu --> Settings --> Options --
> Units and decimals .

Share This option is available only if the
model has been shared with Tekla
Model Sharing.

In Tekla Model Sharing, views are not
shared by default. Views are shared if
they have a name, and the Share
option is set to Shared.

Color and transparency in all views The color and transparency setting
that is used in all views (according to
the status of the objects in the
model).

Representation... Opens the Object Representation
dialog box for defining color and
transparency settings.

View depth The thickness of the displayed slice of
model. You can define the depth
separately upwards and downwards
from the view plane. Only objects
positioned within the view depth are
visible in the model.

The units depend on the settings in
File menu --> Settings --> Options --
> Units and decimals .

Display... Opens the Display dialog box for
defining which objects are displayed
(page 647) in the view and how.

Visible object group Which object group is displayed in the
view.

Object group... Opens the Object Group - View
Filter dialog box for creating and
modifying object groups.
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See also

Open, save, modify, or delete a view (page 43)

Grid view properties
Use the Creation of Views Along Grid Lines dialog box to view and modify
the properties of grid views.

Option Description
View plane The plane of the view defined by two axes similarly to the

default view.
Number of views Defines which grid lines the views will be created of.

None does not create any views.

One (First) only creates the view closest to the grid origin.

One (Last) only creates the view furthest from the grid
origin.

All creates all views in grid planes in the relevant
direction.

View name prefix The prefix to be used with the grid label in the view name.
This name overrides the name in the view properties.

View names consist of a prefix and a grid label, e.g. PLAN
+3000. If the View name prefix box is left empty, no
prefix is used. Tekla Structures adds a dash and a running
number to the view name if view names are otherwise
identical.

View properties Defines which view properties (applied or saved) will be
used.

Each view plane has its own view properties. You can load
the properties from the current view properties with the
option <applied values> or from saved view properties.
The Show button displays the current view properties.

See also

Create model views (page 33)

Define the work area
Tekla Structures indicates the work area of a view using dashed lines. Objects
outside the work area exist, but they are not visible. You can shrink and
expand the work area to suit particular situations, for example to concentrate
on a particular area of the model. You can temporarily hide the work area box.
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Fit work area to entire model
You can resize the work area to include all model objects, either in all views or
in selected views only.

1. On the View tab, click Work area  and select one of the following:

• To entire model in all views

Fits the work area to include all model objects in all visible views.

• To entire model in selected views

Fits the work area to include all model objects in the selected views.

Fit work area to selected parts
You can resize the work area to include only selected parts, either in all views
or in selected views only.

1. Select the objects you want to include.

2. On the View tab, click Work area  and select one of the following:

• To selected parts in all views

Fits the work area to include the selected model objects in all views.

• To selected parts in selected views

Fits the work area to include the selected model objects in the selected
views.
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Fit work area using two points
You can resize the work area based on two corner points you pick on the view
plane. The depth of the work area is the same as the view depth.

1. On the View tab, click Work area  and select Using two points.

2. Pick the first point.

3. Pick the second point.

Hide the work area box
You can temporarily hide the work area box in a view. This can be useful, for
example, when creating screenshots for presentations.

1. Hold down the Ctrl and Shift keys simultaneously.

2. On the View tab, click Redraw --> Redraw all views. 

3. To make the box visible again, click Redraw --> Redraw all views again.

TIP Alternatively, use the advanced option XS_HIDE_WORKAREA.

If you place objects are outside the work area
If you place new objects outside the work area, or copy or move objects
outside the work area, Tekla Structures displays a warning message Objects
outside the work area. You can expand the work area to include the new
objects.

If you do not wish to see thew warning message again you have the option to
hide future warnings of the same type. You can also have Tekla Structures
show these warnings again.

• To hide future warnings of the same type, select the Do not show this
message again check box.

• To re-display the warnings, hold down the Shift key while running a
command that should normally induce a warning message. For example, if
you deliberately copy or move objects outside the work area while holding
down the Shift key, the associated warning message reappears.

Get to know Tekla Structures basic working
methods

50 Set up the workspace



If you cannot see all objects
The visibility of objects in a view depends on a number of different settings. If
you cannot see all the desired objects in a model view, check the following
settings:

• work area

• view depth

• view filter

• view and representation settings

• color and transparency settings

Note that work area and view depth are like two virtual boxes. Objects that
have their handles partially or totally inside both boxes are visible. Newly
created objects are also visible outside the view depth but never outside the
work area. When you redraw a view, only the objects inside the view depth are
displayed.

See also

Define the work area (page 48)

View properties (page 46)

Filter objects (page 150)

Change the color and transparency of model objects by using object
representation (page 656)

Coordinate system
Tekla Structures uses two coordinate systems: the global and the local
coordinate system. The local coordinate system is also known as the work
plane.

Global coordinate system

The green cube symbol represents the global coordinate system and lies at the
global point of origin (x=0, y=0, z=0). The global coordinate system is static and
it cannot be changed.

Do not place the model far away from the origin. If you create model objects
far away from the origin, snapping to points (page 83) in the model views
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may become inaccurate. The further away from the origin you model, the less
precise all computations become.

If you need to use another coordinate system for inserting reference models
or exporting IFC models, you can use base points (page 57). When you use
base points, you can keep the coordinates small and locate the model
wherever needed.

Local coordinate system (Work plane)

The work plane represents the local coordinate system. Most of the
commands that are dependent on the coordinate system use the work plane
coordinates. For example creating points, part positioning, and copying always
comply with the work plane coordinate system. The coordinate symbol, which
is located in the lower right corner of the model view, follows the work plane.

The work plane is model specific, so it is the same in all views. The red work
plane arrow symbol shows the xy plane. The z direction follows the right-hand
rule (page 53).

You can change the local coordinate system by shifting the work plane
(page 53). The work plane also has its own red grid, which can be used for
positioning parts. You can show or hide (page 53) this grid as needed.

To control which work plane or base point you currently have in use in the
model, use the work plane handler toolbar (page 68).
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Right-hand rule
Right-hand rule indicates the direction of the coordinate axes. When you hold
the thumb, index finger, and middle finger of your right hand so that they
form three right angles, then the thumb symbolizes the x axis, the index finger
the y axis, and the middle finger the z axis.

Show or hide the work plane grid
The work plane grid is hidden by default. Use the options on the Snapping
toolbar to show or hide the work plane grid.

1. To show the grid, select Work plane from the second list. 

2. To hide the grid, select View plane from the same list.

See also

Shift the work plane (page 53)

Shift the work plane
You can set the work plane to any position by picking points or by selecting a
plane. This makes it easier to place parts accurately when modeling sloped
parts.
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For example, you can shift the work plane to the slope of the roof to make it
easier to model horizontal bracing and purlins in a sloped roof.

Set work plane to any part plane
Use the Work plane tool command to set the work plane to any part plane or
grid intersection. Note that you can select only native Tekla Structures object
planes. You cannot select reference model object planes.

1. On the View tab, click Work plane --> Work plane tool. 

2. Move your mouse over the model to preview the work plane direction.

3. Click the left mouse button to set the work plane.

Set work plane parallel to xyz plane
You can set the work plane parallel to the xy, xz, or zy plane.

1. On the View tab, click Work plane and select Parallel to XY(Z) plane. 
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2. In the Plane list box, select the plane parallel to the work plane.

3. Enter the depth coordinate. 

The depth coordinate defines the distance of the work plane from the
global origin along a line perpendicular to the plane parallel to the third
axis.

4. Click Change.

Set work plane using one point
You can set the work plane using one picked point. The work plane stays
parallel to the current work plane, but moves to a new position. The x and y
directions are unchanged.

1. On the View tab, click Work plane and select Using one point. 

2. Pick the new position of the work plane.

Set work plane using two points
You can set the work plane using two picked points. The first point you pick is
the origin, the second defines the x direction of the work plane. The y direction
remains the same as the previous work plane.

1. On the View tab, click Work plane and select Using two points. 

2. Pick the origin of the work plane.

3. Pick a point in the work plane, in the positive x direction.
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Set work plane using three points
You can set the work plane using three picked points. The first point you pick is
the origin, the second defines the x direction, and the third defines the y
direction of the work plane. Tekla Structures fixes the z direction according to
the right-hand rule.

1. On the View tab, click Work plane and select Using three points. 

2. Pick the origin for the work plane.

3. Pick a point in the positive x direction.

4. Pick a point in the positive y direction.

Set work plane parallel to view plane
You can set the work plane to be the same as the view plane of a selected
view.

1. On the View tab, click Work plane and select Parallel to view plane. 

2. Select the view.
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Restore the default work plane
Remember to change back to the default work plane when you have finished
modeling sloped structures.

1. On the View tab, click Work plane --> Parallel to XY(Z) plane. 

2. In the Plane list, select XY.

3. In the Depth coordinate box, enter 0.

4. Click Change.

Base points
The base points (control points) allow you to use a coordinate system based
on the civil origin or other coordinate system for interoperability and
collaboration. For example, you can use base points when inserting reference
models, exporting IFC models, in drawings, in Layout manager, and in reports
and templates.

Civil origin is the datum point or fundamental benchmark point of the national
land survey network.

When you use base points, you can keep the coordinates small and locate the
model wherever needed. You can create as many base points as you need, and
select one of those to be the project base point.

Note the following:

• Reference models should not have any additional lines to the origin.

• Reference models should not include objects that are very far from each
other because otherwise using the model may get difficult.

• Tekla Structures native objects, including reference models, should not be
inserted very far from the Tekla Structures model origin.

Define a base point

You can define base points in Project properties. In case you need to import
or export a reference model, you need to know the coordinates of the
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reference model that you are importing, or the coordinates that you want to
use in the resulting IFC export file.

TIP You can inquire the point coordinates in Tekla Structures: On the ribbon,

click the down arrow next to , and then select Point coordinates.
For more information, see Inquire object properties (page 686).

1. Open a Tekla Structures.

2. Click File --> Project properties --> Base points to open the Base point
dialog box.

3. Fill in the needed information: 

You can load existing base point settings. To do this, copy your settings file
<settings name>.basePoint.json from the \attributes folder
under the model where you have the base point settings you want to use
to the \attributes folder under the current model folder. In the Base
point dialog box, select the base point settings from the list.

Note that base point settings also work with project and firm folders: Copy
the base point settings file to the \attributes folder under the firm and
project folders.
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Name, Description Enter a name and a description for the base
point. Giving a name is obligatory.

Coordinate System Enter the name of the coordinate system you
are using.

East coordinate (E) Enter the East coordinate (E) that represents
the X coordinate related to the civil origin.

North coordinate (N) Enter the North coordinate (N) that represents
the Y coordinate related to the civil origin.

Elevation Enter the Elevationthat represents the Z
coordinate related to the civil origin.

Latitude,Longitude Enter the Latitude and Longitude of the base
point to be used in the IFC export.

Latitude and Longitude is additional
information, which some software can use. In
the IFC file, this is written to IFCSITE
information.

If the total number of digits in Longitude is
more than 15, the value is rounded up to the
nearest if it is > 99.999999999999999999.

To convert Latitude and Longitude information
between decimal format and degree/minute/
second (DMS) format, see Convert Latitude/
Longitude to decimal.

Location in the model Pick or enter a location for the base point in the
Tekla Structures model. The distance is
measured from the model origin.

The base point location in the model can have a
maximum value of +/- 10 km from the model
origin. Modeling is meant to be done near the
model origin, and the offset is to be given with
East coordinate and North coordinate values.

Angle to North Pick or enter the Angle to North, which is the
angle between Y and North directions. The
maximum number of decimals for the angle is
13.

Project base point If you want to set a coordinate system as the
project base point, select a base point from the
list at the top and then select the Project base
point check box.

4. To save the base point settings, type a unique name for the settings and
click  Save. To use the same base point settings in another model, copy
your settings file <settings name>.basePoint.json from the
\attributes folder under the current model folder to the \attributes
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folder under the model where you wish to use the same base point
settings. The settings also work with project and firm folders: Copy the
base point settings file to the \attributes folder under the firm and
project folders.

5. To avoid unwanted changes by others working in the same model, lock
the base point by clicking the  Lock/Unlock button next to the base

point name. The button changes to . To unlock the base point, click the
button again.

6. Click Modify to save the base point. 

A blue symbol is added in the model.

If you later on make changes to the base point, the base point location in
the model changes according to the location or rotation changes you
make in the Base point dialog box when you press Enter or click another
input field, and there is no need to click Modify. Note that if the base
point is locked, you cannot modify it.

Now you can insert a reference model, or export an IFC model using the
defined base point, for example.

Set a coordinate system as the project base point
One base point can be set to be as the project base point. Model origin is the
default project base point value if the model does not contain any base points,
or if none of the existing base points has been set to be the project base point.
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You can check and change the current project base point through File -->
Project properties --> Location by.

Note that it is not recommended to change the project base point temporarily
during a project.

1. Click File --> Project properties. 

You can see the current project base point in the Location by box.

2. To change the project base point, click Edit, and select a new project base
point from the Location by list.

3. Click Apply.

TIP You can also set a base point as the project base point in the Base point
dialog box by selecting a base point from the list at the top and then
selecting the Project base point check box.

Insert a reference model using a base point

Before you can insert a reference at the base points, you need to create a base
point in your model. To create the base point, you need to know the
coordinates of the reference model that you are importing.

1. Open the Reference Models list by clicking the Reference Models button

in the side pane .

2. In the Reference Models list, click the Add model button.

3. In the Add model dialog box, if you have any previously created reference
model properties files, load the desired file by selecting the file from the
properties file list at the top.

4. Browse for the reference model by clicking Browse....

5. In Group, select a group for the reference model, or enter a name for a
new group. 

If you do not enter a name for the group, the reference model is inserted
in the Default group.
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6. In Location by, select the base point you want to use.

7. Click the Add model button. Tekla Structures inserts the reference model
relative to the selected base point by using the coordinate system values,
elevation and angle in the base point definition in the model Project
properties. For example, both IFC2x3 and IFC4 reference model inserting
support base points.

Export an IFC model using a base point

Before you can export an IFC file using a base point, you need to create a base
point in your model.

1. Click File --> Export --> IFC to open the Export to IFC dialog box.

2. In Location by, select a base point that you have created.

3. Fill in other necessary IFC export information.

4. Click Export. The base point option exports the IFC model relative to the
base point using the coordinate system values, elevation, latitude,
longitude and angle in the base point definition in the model Project
properties.

Base points in drawings
It is possible to use base-point-defined coordinate system values in drawings.
If you change the project base point Z or the elevation value, the level value
will change accordingly when a drawing is opened.

• Base point data can be used in drawing and view level to set the coordinate
system. The base point can be used instead of datum offset.

• When the base point is set, level attributes and template attributes in
marks provide values in the specific base-point-defined coordinate system.
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• This setting affects level marks and attributes that end with _BASEPOINT.

• When the base point is set at the drawing level, the _BASEPOINT template
attributes can be used in drawing templates.

You can set Location by in drawing view properties to use model origin,
project base point or any base point defined coordinate system. Location by
uses the project base point as the default value.

The datum level only affects the attributes TOP_LEVEL and 
TOP_LEVEL_UNFORMATTED when Location by is set to Model origin or to the
project base point that is in the model origin.

To change the Location by value:

1. In an open drawing, double-click the drawing view frame to open the View
Properties dialog box.

2. On the Attributes 2 tab, set Location by to a new base point, or to the
model origin.

3. Click Modify. 

Example of base point usage in a drawing

In the following example, do the following:

1. Create a slab with a thickness of 200 mm with the slab's top at the level 0
in the model.
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2. Create a new base point "Control point 1" with elevation 20000 mm.

3. Create a GA drawing in plan view.

4. Open the GA drawing, double-click the view frame to open the View
properties dialog box.
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5. On the Attributes 2 tab, you set Location by to the new base point
(Project base point) "Base point 2" and click Modify.

6. Add a level mark using the following template attributes:

• COG_Z
• COG_Z_PROJECT
• COG_Z_BASEPOINT

7. Reopen the drawing.

Note that changing the value does not update the template attribute
automatically but after reopening the drawing.
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Base points in Layout manager
You can use base points in Layout manager when defining the location of
layout points.

• You can use base points as location coordinates when exporting and
importing layout points.

• When you add, modify or delete base points, you need to reopen or refresh
Layout manager to make the changed base point data available in Layout
manager.

Base point in reports and templates
You can inquire project base point and current base point value in reports and
templates.

The following table lists the template attributes where you can use _PROJECT
and _BASEPOINT at the end, for example, 
ASSEMBLY_BOTTOM_LEVEL_PROJECT or 
ASSEMBLY_BOTTOM_LEVEL_BASEPOINT. Note that _BASEPOINT uses the
current base point in the same way as the workplane uses the current
workplane. If there is no current base point defined, _BASEPOINT provides
values relative to model origin (Global).

Content type Attributes
ASSEMBLY, CAST_UNIT
and PART

ASSEMBLY_BOTTOM_LEVEL
ASSEMBLY_BOTTOM_LEVEL_UNFORMATTED
ASSEMBLY_TOP_LEVEL
ASSEMBLY_TOP_LEVEL_UNFORMATTED
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Content type Attributes
BOTTOM_LEVEL
BOTTOM_LEVEL_UNFORMATTED
BOUNDING_BOX_MIN_X
BOUNDING_BOX_MIN_Y
BOUNDING_BOX_MIN_Z
BOUNDING_BOX_MAX_X
BOUNDING_BOX_MAX_Y
BOUNDING_BOX_MAX_Z
BOUNDING_BOX_X
BOUNDING_BOX_Y
BOUNDING_BOX_Z
COG_X
COG_Y
COG_Z
START_X
START_Y
START_Z
END_X
END_Y
END_Z
TOP_LEVEL
TOP_LEVEL_UNFORMATTED
LOCATION_BREAKDOWN_STRUCTURE.LBS_FLOOR_
ELEVATION
ASSEMBLY.LOCATION_BREAKDOWN_STRUCTURE.L
BS_FLOOR_ELEVATION

REFERENCE MODEL, 
REFERENCE OBJECT and 
REFERENCE_ ASSEMBLY

BOUNDING_BOX_MIN_X
BOUNDING_BOX_MIN_Y
BOUNDING_BOX_MIN_Z
BOUNDING_BOX_MAX_X
BOUNDING_BOX_MAX_Y
BOUNDING_BOX_MAX_Z
LOCATION_BREAKDOWN_STRUCTURE.LBS_FLOOR_
ELEVATION
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Content type Attributes
POUR OBJECT BOTTOM_LEVEL

BOTTOM_LEVEL_UNFORMATTED
TOP_LEVEL
TOP_LEVEL_UNFORMATTED
LOCATION_BREAKDOWN_STRUCTURE.LBS_FLOOR_
ELEVATION

CONNECTION ORIGIN_X
ORIGIN_Y
ORIGIN_Z

HIERARCHIC OBJECT LOCATION_BREAKDOWN_STRUCTURE.LBS_FLOOR_
ELEVATION

Select the work plane
If you have defined base points or saved work planes, you can use the Work
plane handler toolbar to select which work plane you currently have in use in
the model.

By default, the Work plane handler toolbar is located at the bottom of the
screen.

You can select among the following work planes:

• Model origin (if project base point is set somewhere else)

• Project base point

• All base points (page 57) you have defined

• All work planes (page 53) you have set and saved

The symbol for model origin is different if the project base point is set to
model origin, or if the project base point is set somewhere else.

When a model is reopened, the last used work plane or base point is used.

Add a work plane to the toolbar

1. Set a work plane in the model.
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2. On the Work plane handler toolbar, enter a name for the work plane in
the Select work plane box.

3. Click the Save work plane  button to add the new work plane to the
list.

If needed, you can rename your work plane by double-clicking it and
entering a new name.

4. To remove a work plane from the list, click the Remove work plane 
button.

By default, the Work plane handler toolbar is located at the bottom of the
screen. If you are unable to find the toolbar, click File --> Settings, and in the
Toolbars list ensure that the Work plane handler toolbar is selected.

See also

Coordinate system (page 51)

Change the color settings for dimensions, labels, and model
background
You can define which color you want to use for dimensions, labels, and
background in the model. For example, if you set the background color to
black, you may need to adjust the other color settings as well to ensure that
the text and dimensions will be visible.

Change the color settings in the Advanced options dialog box by using RGB
values on a scale of 0.0 to 1.0. Separate the values with spaces. For example,
the color code for yellow is 1.0 1.0 0.0.

TIP Alternatively, if you wish to change the color settings at one go without using the
advanced options, you can use the Background Color Tool, which is available in
Tekla Warehouse.

To change the drawing mode color, go to File --> Settings --> Color mode and
select one of the options.

Find RGB values for colors
To find the right RGB values for colors, use, for example, the following tools:

• Background Color Selector tool, which is available in Tekla Warehouse

• Color picker for Tekla Structures tool, which is available in Tekla User
Assistance
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Change the model background color
Set the background color using a combination of four different advanced
options. You can control the color of each corner of the background
separately.

1. On the File menu, click Settings --> Advanced options , and go to the
Model views category.

2. Set the background color using the following advanced options: 

• XS_BACKGROUND_COLOR1

• XS_BACKGROUND_COLOR2

• XS_BACKGROUND_COLOR3

• XS_BACKGROUND_COLOR4

To use a single-colored background, set the same color code for all four
corners of the background. To use the default background color, leave the
boxes empty.

3. Click OK to save the changes.

4. Close and reopen the view to see the changes.

Examples

Below are some examples of possible background colors that you can define.
The first RGB value refers to the advanced option XS_BACKGROUND_COLOR1,
the second value to the advanced option XS_BACKGROUND_COLOR2, and so
on.

RGB values Result
1.0 1.0 1.0
1.0 1.0 1.0
1.0 1.0 1.0
1.0 1.0 1.0
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RGB values Result
0.98 0.98 0.99
0.99 0.99 0.99
0.00 0.37 0.99
0.21 0.46 0.88

0.6 0.8 0.9
0.6 0.8 0.9
1.0 1.0 1.0
1.0 1.0 1.0

0.6 0.8 0.9
0.6 0.8 0.9
0.5 0.2 0.0
0.5 0.2 0.0

0.1 0.6 0.6
0.5 0.9 0.5
0.1 0.6 0.6
0.5 0.9 0.5

TIP You can change the drawing mode background to black with the advanced
option XS_BLACK_DRAWING_BACKGROUND.
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Change the color of dimensions, part labels, and bolts
You can define which color you want to use for dimensions, part labels, and
bolts that are using the representation option Fast in the model.

1. On the File menu, click Settings --> Advanced options .

2. Search for the color setting you want to change. 

Color setting Advanced option
Dimension lines XS_VIEW_DIM_LINE_COLOR
Dimension text XS_VIEW_DIM_TEXT_COLOR
Part labels XS_VIEW_PART_LABEL_COLOR
Work plane grid XS_GRID_COLOR_FOR_WORK_PLANE
Bolts using the representation option
Fast

XS_VIEW_FAST_BOLT_COLOR

TIP To quickly find all color related advanced options, type color in the
Search box and press Enter. Make sure the In all categories check
box is selected.

3. Define the color using RGB color codes.

4. Click OK to save the changes. 

You may be required to restart Tekla Structures.

5. Close and reopen the view to see the changes.
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Change the rendering mode for model views
Tekla Structures model view rendering can use either DirectX technology or
the legacy OpenGL technology.

By default, Tekla Structures uses the DirectX rendering. The DirectX rendering
adds a subtle shading effect to Tekla Structures objects, making the 3D
visualizations clearer and more defined.

If you want to use the legacy OpenGL rendering, switch the Use legacy
rendering option on in File --> Settings --> Switches.

The rendering setting is model view specific, which means that you can use
different rendering options in different model views. If you switch between the
rendering options, you need to reopen the model view to activate the
rendering option.

DirectX rendering engine
The DirectX rendering mode is better optimized for modern graphics cards,
and the graphics performance is better on the recommended NVIDIA GeForce
GTX graphics cards than with graphics cards that have a lower end or no
graphics processing unit (GPU). For more information on the graphics cards,
see Tekla Structures hardware recommendations.

If you want to measure the performance of your DirectX 3D rendering engine,
you can use the TeklaMark tool from Tekla Warehouse. The tool tests how fast
your computer handles graphical information typically used in Tekla
Structures, for example, processor speed, load time, average draw time, and
per frame details. For more information, see the TeklaMark support article that
shows graphs of the collected performance data on different hardware setups.

NOTE If you use Tekla Structures via remote connections, the DirectX rendering may
not work as expected: parts that you have created may not show in the
model, or the model is working slowly. If you experience such problems,
switch the DirectX rendering off.

Use the following advanced options to fine-tune the DirectX rendering:

• XS_USE_ANTI_ALIASING_IN_DX

• XS_SHOW_SHADOW_FOR_ORTHO_IN_DX

• XS_SHOW_SHADOW_FOR_PERSPECTIVE_IN_DX

• XS_SHOW_STATISTICS_IN_DX
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DirectX rendering examples

Visualization of distance

In DirectX rendered model views, the visualization of the distances uses subtle
shadows and ambient occlusion. This gives a better understanding of the
structure and distances.

DirectX OpenGL

Depth accuracy

In DirectX rendered model views, the accuracy in depth buffer is improved so
that when the model is zoomed, parts are not shown through other parts'
faces as often as previously.

DirectX OpenGL

Dynamic states

In DirectX rendered model views, in dynamic states, such as in selection and in
preselection highlight, the selection is clearer and the highlight is less intrusive.
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DirectX OpenGL

Antialiasing for higher fidelity

In DirectX rendered model views, the image quality is by default better than in
OpenGL rendered model view, with less flickering.

DirectX OpenGL

High fidelity edge line

In DirectX rendered model views, there are no flickering zigzag lines but
continuous, smooth edges.

Get to know Tekla Structures basic working
methods

75 Set up the workspace



DirectX OpenGL

Accurate reinforcing bars

In DirectX rendered model views, reinforcing bars have edge lines. When you
zoom in, the reinforcing bars are shown as round.

DirectX OpenGL

Automatic edge lines for intersecting material in transparent view

In DirectX rendered model views, you can see where there are intersecting
materials in the model.
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DirectX OpenGL
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Accuracy and clarity on details

DirectX OpenGL
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Automatic hatching for overlapping surfaces on same plane

In DirectX rendered model views, duplicate objects or overlapping parts are
visualized with a hatch in non-transparent views (Ctrl+4 for parts and Shift+4
for components).

Switch the hatching on in File menu --> Settings --> Switches --> Hatching of
overlapping surfaces.

Dashed hidden lines

In DirectX rendered model views, the part edge lines that are hidden behind
another part are shown as dashed lines in transparent views (Ctrl+1, 2, 3, or 5
for parts and Shift+1, 2, 3, or 5 for components).

Switch the dashed lines on in File menu --> Settings --> Switches --> Dashed
line for hidden line.
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1.2 Zoom and rotate the model
The commands on the View tab allow you to focus on a particular area, or pull
out for a wider view. You can use a mouse, command, keyboard shortcut, or a
combination of these.

Zoom in and out
You can use a variety of tools to zoom in and out in the model. By default, the
mouse pointer position determines the center point of zooming.

To Do this
Zoom in Scroll forward with the mouse wheel.

Alternatively, press Page Up.
Zoom out Scroll backward with the mouse

wheel.

Alternatively, press Page Down.
Zoom to selected objects 1. Select the objects.

2. On the View tab, click  Zoom --
> Zoom selected.

Alternatively, press Shift+Space.
Zoom with menu commands On the View tab, click  Zoom and

select one of the zoom commands.
Keep the center point of zooming in
the middle of the view

On the File menu, click Settings and
select Centered zooms.

Define the zoom ratio Use these advanced options:

XS_ZOOM_STEP_RATIO

XS_ZOOM_STEP_RATIO_IN_
MOUSEWHEEL_MODE

XS_ZOOM_STEP_RATIO_IN_SCROLL_
MODE

Rotate the model
You can use either the middle or left mouse button, or keyboard, to rotate the
model in a view.
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To Do this
Rotate using the middle mouse
button

1. On the View tab, click 
Navigate --> Set view point.

You can also press V.

2. To set the view point, pick a
position in the view.

The following symbol appears in
the model:

3. Hold down the Ctrl key, and click
and drag the model with the
middle mouse button.

Tekla Structures rotates the
model around the view point you
defined in step 2.

Rotate using the left mouse button 1. On the View tab, click 
Navigate --> Rotate with
mouse.

You can also press Ctrl+R.

2. To set the view point, pick a
position in the view.

The following symbol appears in
the model:

3. Click and drag the model with the
left mouse button.

Tekla Structures rotates the
model around the view point you
defined in step 2.

Rotate using keyboard Use the keyboard shortcuts Ctrl
+arrow keys and Shift+arrow keys.

Ctrl+arrow keys rotates the model in
15 degree increments.

Shift+arrow keys rotates the model
in 5 degree increments.
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Pan the model
You can use either the middle or left mouse button to pan the model in a view.

To Do this
Move the model using the middle
mouse button

1. On the File menu, click Settings
and check that the Middle
button pan check box is
selected.

2. Hold down the middle mouse
button and drag the model.

Move the model using the left mouse
button

1. To activate dynamic panning, go
to the View tab and click 
Navigate --> Pan.

You can also press P.

The mouse pointer changes to a

hand: 

2. Hold down the left mouse button
and drag the model.

3. To stop panning, press Esc.

1.3 Snap to positions
Most commands ask you to pick points to place objects in the model or
drawing. This is called snapping. When you are creating a new object, Tekla
Structures displays snap symbols and snap tooltips for the available snap
points and a light gray line between the snap point and the last point picked.

Use the snap switches (page 84) on the Snapping toolbar to control which
positions you can snap to.
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For example, you can snap to

• different points, such as end points and midpoints

• centers

• intersections

• lines and edges

• dimensions and mark lines, drawing layout items and drawing frames

If you want to use exact distances or coordinates when snapping to positions,
use numeric snapping (page 87).

With the combination of different snapping tools, you can, for example, snap
to the closest orthogonal point (page 99) on the plane, both in the model and
in the drawings. Additionally, you can follow a line and pick a point at a
specified distance along the line, or create a temporary reference point to use
as a local origin, both in the model and in the drawings.

Tekla Structures displays snap dimensions in the model, which means you can
easily create objects of a desired length. Use the advanced option XS_DISPLAY_
DIMENSIONS_WHEN_CREATING_OBJECTS to switch the snap dimensions on or
off.

TIP Use the snapping keyboard shortcuts to speed up your work.

Snap to points by using snap switches
Use the snap switches to control which positions you can pick in the model or
drawing. By using snap switches, you can position objects precisely without
having to know the coordinates. You can use snap switches whenever Tekla
Structures prompts you to pick a point.

Click the snap switches on the Snapping toolbar to switch them on or off. If
there is more than one point available to snap to, press the Tab key to cycle
forward through the snap points, and Shift+Tab to cycle backwards through
them. Click the left mouse button to select the appropriate point.

(1) Use the snap switches (page 84) to control which positions you can pick
when placing objects. Snap switches define exact locations on objects, for
example, end points, midpoints, and intersections.

(2) Use the first list to define the snap depth.

(3) Use the second list to switch between the view plane and work plane
(page 53).
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(4) Use the third list to set the plane type (page 960). The plane type defines
what planes you can select in the model.

(5) You can hide selected switches from the toolbar.

Alternatively, you can control the snap switches with Quick Launch. Start
typing the name of the snap switch, for example, snap, and click the name of
the snap switch in the search results list to activate the switch.

Snap zone
Each object has a snap zone. It defines how close you need to pick to hit a
position. When you pick within the snap zone of an object, Tekla Structures
automatically snaps to the closest pickable point on that object.

You can set the snap zone using the advanced option XS_PIXEL_TOLERANCE.

Snap priority
If you pick and hit several positions simultaneously, Tekla Structures
automatically snaps to the point with the highest snap priority. To control
which positions you can pick, use snap switches. Snap switches define the
snap priority of positions.

Snap depth
The first list on the Snapping toolbar defines the depth of each position you
pick. You have the following options:

• Plane: You can snap to positions either on the view plane (page 31) or the
work plane (page 51), depending on what you have selected in the second
list on the Snapping toolbar.

• Auto: In perspective views, this option works like the 3D option. In non-
perspective views, it works like the Plane option.

• 3D: You can snap to positions in the entire 3D space.

Visual cues in snapping
Tekla Structures indicates where you can snap in the model and which snap
switches can be used to snap to certain positions.

When you start a command that requires picking points and you move the
mouse pointer over objects, the mouse pointer locks to a snap point and Tekla
Structures displays in the model

• a snap symbol

The snap symbol changes according to the possible snap point. Tekla
Structures automatically highlights the points where you can snap to.

Use the snap settings (page 104) to show or hide the snap symbols.
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• a snap tooltip which shows the name of the possible snap point

To show or hide the snap tooltips, click File --> Settings and select the
Snap tooltips check box.

• a turquoise reference line or geometry line of the object. The turquoise line
shows the line or the edge to which the snap point belongs to.

For example:

Additionally, Tekla Structures indicates in which direction the picked points are
located. When the Ortho (page 99) tool is active, Tekla Structures displays a
rubber band line between the last point picked and the snap point. The color
of the cursor and the rubber band line follow the color of the work plane axis:
red for x-axis, green for y-axis and blue for z-axis. For any other direction the
color of the rubber band line and the cursor is black.

As a general rule of thumb, you can only snap to something that is visible.

For example, if you use the rendering options Parts rendered or
Components rendered (Ctrl/Shift +4), the object surfaces are displayed and
the objects are not transparent. This means that you cannot snap to the
object's geometry lines or reference lines which cannot be seen through the
object.

Override the current snap switch settings
You can temporarily override the current snap switch settings, and activate
only the selected snap switch. The selected snap switch overrides the other
snap settings for the next point you pick.
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1. Run a command that asks you to pick a point. 

For example, start creating a beam.

2. To override the current snap switches, do one of the following: 

• Right-click to show a list of snap options, and then select one of the
options.

• Click File --> Settings, and in the list of toolbars select Snap override
toolbar.

A new toolbar appears. Click a button to activate the selected snap
switch.

• Use Quick Launch to activate a snap override switch. Type override in
the Quick Launch box and select the needed override switch in the
search results list.

Snap to points by using exact distance or coordinates -
numeric snapping
You can enter exact distances and coordinates when snapping to a position.
This is called numeric snapping.

Enter a distance or coordinates
Use the Enter a Numeric Location dialog box to specify the distance or
coordinates to a position you want to snap to.

1. Run a command that requires you to pick points. 

For example, start creating a beam.

2. Pick the first point.

3. Move the mouse pointer to indicate the direction of snapping.

4. Enter a distance or coordinates by using the keyboard. 

For example, type 1000 as the distance from the last point picked. When
you start typing, Tekla Structures displays the Enter a Numeric Location
dialog box automatically.

5. After entering the distance or coordinates, click OK or press Enter to snap
to the position.
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Snapping example: Track along a line towards a snap point
Tracking means that you follow a line and pick a point at a specified distance
along the line. You usually use tracking in combination with numeric
coordinates and other snapping tools, such as snap switches and orthogonal
snapping. This example shows how to pick a point at a specified distance along
a line. Use the Enter a Numeric Location dialog box to specify the distance
from the last point picked.

1. Create two beams and place them as shown below: 

2. Activate the beam command, to create one more beam.

3. Pick the first point. 

4. Move the mouse pointer over the grid line intersection so that it locks
onto the snap point, but do not click the mouse button. 
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5. Type 1000. 

When you start typing, Tekla Structures displays the Enter a Numeric
Location dialog box.

6. Click OK to confirm the distance. 

Tekla Structures creates a beam, which is 1000 units long and positioned
between the points you defined:
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You can also:

• Track beyond the snap point, for example 4000 units from the first point:

• Track in the opposite direction by entering a negative value, for example
-1000:

For an example of how to use numeric snapping in drawings, see Place a
sketch object at a specified distance.
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Change the snapping mode
Tekla Structures has three snapping modes: relative, absolute, and global. Use
the advanced option XS_KEYIN_DEFAULT_MODE to indicate the default
snapping mode.

1. On the File menu, click Settings --> Advanced options and go to the
Modeling properties category.

2. Set the advanced option XS_KEYIN_DEFAULT_MODE to RELATIVE, 
ABSOLUTE, or GLOBAL. 

• In the relative snapping mode, the coordinates you enter in the Enter
a Numeric Location dialog box as such without any prefix are relative
to the last position picked.

• In the absolute snapping mode, the coordinates are based on the
origin of the work plane.

• In the global snapping mode, the coordinates are based on the global
origin and the global x and y directions.

3. Click OK to save the changes.

4. If you want to temporarily override the default snapping mode, enter a
special character in front of the coordinates when entering a numeric
location. 

By default, the special characters are:

• @ for relative coordinates

• $ for absolute coordinates

• ! for global coordinates

Alternatively, you can start numeric snapping and bring up the special
characters by typing R, A, or G. R is for relative coordinates, A is for
absolute coordinates, and G is for global coordinates.

NOTE If you want to change the special character for any of the three
snapping modes, use the advanced options XS_KEYIN_RELATIVE_
PREFIX, XS_KEYIN_ABSOLUTE_PREFIX, and XS_KEYIN_GLOBAL_
PREFIX.

Options for coordinates
The table below explains the types of information you can enter in the Enter a
Numeric Location dialog box.

Note that Tekla Structures has three snapping modes: relative, absolute, and
global. You can temporarily override the default snapping mode by using a
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special character in front of the coordinates in the Enter a Numeric Location
dialog box.

You can enter Description Special character
One coordinate A distance to an indicated direction.  
Two coordinates If you omit the last coordinate (z) or

angle, Tekla Structures assumes that
the value is 0.

In drawings, Tekla Structures ignores
the third coordinate.

 
Three
coordinates

Cartesian
coordinates

The x, y, and z coordinates of a
position separated by commas.

For example, 100,-50,-200.

, (comma)

Polar
coordinates

A distance, an angle on the xy plane,
and an angle from the xy plane
separated by angle brackets.

For example, 1000<90<45.

Angles increase in the
counterclockwise direction.

<

Relative
coordinates

The coordinates relative to the last
position picked.

For example, @1000,500 or
@500<30.

@

Absolute
coordinates

The coordinates based on the origin
of the work plane.

For example, $0,0,1000.

$

Global
coordinates

The coordinates relative to the global
origin and the global x and y
directions.

For example, 6000,12000,0.

This is useful, for example, when you
have set the work plane to a part
plane and want to snap to a position
defined in the global coordinate
system without changing the work
plane to global.

!

Coordinate axis
prefixes

When using direct modification, with
relative and absolute coordinates,
you can also use axis prefixes to

x

y

z
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You can enter Description Special character
allow snapping in the prefixed
directions only.

For example, @z500 or
$y6000,z-500.

Axis prefixes cannot be used with
global coordinates.

If any of the entered coordinate
values has an axis prefix, the other
values need to have prefixes, too.

The axis prefixes are not case-
sensitive, and the prefixed values
can be entered in any order.

Snap to lines, edges, and extension lines
You can snap to lines when you model objects that should be lined up with an
existing object or with a grid line. You can also snap to the extension lines of
part reference lines, or to the extension lines of nearby objects' reference
lines.

Snap to a line or an edge
Use the Snap to line snap switch when you need to snap to another line in the
model. You can snap to grid lines, reference lines, and the edges of existing
objects.

Use the Snap to line snap switch when you need to create, for example,
several beams one after another on a grid line. With the Snap to line snap
switch you do not need separately pick the start point and the end point of the
beam.

1. Ensure that the  Snap to line snap switch is active.

2. Run a command that requires you to pick two or more points. 

For example, start creating a beam. When you move the mouse pointer
over a grid line or a nearby object, Tekla Structures automatically picks
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both ends of the line. The yellow arrow symbol indicates the direction of
the points.

3. To switch direction, move the mouse pointer closer to the opposite end of
the line.

4. Click the left mouse button to confirm the snap position. 

Tekla Structures creates the object. For example:

NOTE If you use the Snap to line snap switch with a command that requires
only one point to be picked, for example when creating a column, only
the start point of the line is used to position the part.

Snap to extension lines
Use the Snap to extension lines snap switch when you need to snap to the
extensions of the part reference lines, which are the lines between part
handles, or to the extensions of nearby objects' reference lines. The extension
line is shown as a blue, dashed line.
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The Snap to extension lines snap switch works with beams, polybeams,
plates, and slabs.

• With beams, the extension line is the line that passes through both of the
part handles.

• With polybeams, plates, and slabs, the extension lines are the lines that
pass through to the consecutive part handles.
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• With beams and polybeams, you can snap to the line that passes through
the handle at the end of the beam, and which is perpendicular to the
direction of the beam.

• When you snap to the extension lines of nearby objects, the extension line
snaps to the direction of the nearby object and the extension line indicates
the direction that is followed in snapping. Snapping to the extension lines
of nearby objects can be useful, for example, when you want to align
objects with one another.
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NOTE The Snap to reference lines and points  and Snap to geometry

lines and points  snap switches do not affect the Snap to
extension lines snap switch.

1. Ensure that the correct snap switches are active: 

• Switch on  Snap to extension lines.

• Switch on either  Snap to intersection points or  Snap to
nearest points (points on line) if you are snapping to the intersection
of an extension line and a grid line.

• Switch off  Snap to end points if you are working in 3D.

2. Run a command that requires you to pick points. 

For example, start creating a beam, a plate, or slab.

3. Move the mouse pointer over an existing object to see the extension lines. 

When a line is found, you can move the pointer further away while
keeping the snap.

4. Pick the rest of the points. 
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Tekla Structures creates the object:

Lock X, Y, or Z coordinate on a line
You can lock the x, y, and z coordinates on a line. This is useful when you need
to determine a point to pick and the needed point does not exist on the line.
When a coordinate is locked, you can only snap to points in that direction.

1. Run a command that requires you to pick positions. 

For example, start creating a beam.

2. Lock a coordinate: 

• To lock the x coordinate, press X.

• To lock the y coordinate, press Y.

• To lock the z coordinate, press Z.

Now you can only snap to points in the chosen direction.

Tekla Structures indicates the locked coordinate with the letters X, Y, or Z
in the status bar at the bottom of the Tekla Structures main window.

3. To unlock the coordinate, press the same letter (X, Y, or Z) again.
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Align objects using a snap grid
A snap grid makes it easier to align objects in a model, because it allows you to
snap to positions only at set intervals (page 104). Use a snap grid when you

pick points using the  Snap to any position snap switch.

1. On the File menu, click Settings --> Snap settings .

2. Define the grid spacing intervals in the Spacing boxes. 

For example, if the spacing of the x coordinate is 500, you can snap to
positions at intervals of 500 units in the x direction.

3. If needed, define offsets for the snap grid origin in the Origin boxes.

4. To activate the snap grid, select the Active (when free snap is on) check
box.

5. Click OK. 

Now when you pick points using the  Snap to any position snap
switch, you can only snap to positions at set intervals. The snap grid itself
is invisible in the model.

Snap in orthogonal directions
You can snap to orthogonal points in models and in drawings using the Ortho
tool. If you create objects that require you to pick multiple points, you can
snap in orthogonal directions relative to the two previously picked points.

NOTE The Ortho tool has the lowest priority among snap points.

Even if you have activated the Ortho tool, but Tekla Structures detects any
other possible snap point than an orthogonal point, Tekla Structures uses the
found snap point instead of the orthogonal snap point. If there are no other
possible snap points found, then Tekla Structures uses the orthogonal snap
point.

Activate the Ortho tool
Before you can snap in orthogonal directions, ensure that the Ortho tool is
active. The letter O in the status bar at the bottom of the Tekla Structures main
window indicates that Ortho is active.

If Ortho is not active

• press O to activate it

• alternatively, click File --> Settings and select the Ortho check box.
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Snap to orthogonal points
Use the Ortho tool to snap to the closest orthogonal point on the plane (0, 45,
90, 135, 180 degrees, and so on). The mouse pointer automatically snaps to
positions at even distances in the given direction. This can be useful, for
example, if you need to place marks in a consistent manner in exact locations
in a drawing.

1. Ensure that the Ortho tool is active. 

• Press O to activate Ortho if the tool is not active.

• Alternatively, on the File menu, click Settings and select the Ortho
check box.

2. Run a command that requires you to pick points. 

For example, start creating a beam. Tekla Structures displays an angle
symbol to indicate the direction of snapping.

The snapping precision depends on the current zoom level.

The angle interval (page 104) depends on the settings in the Model snap
settings dialog box.

3. Click the left mouse button to confirm the snap position. 
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Tekla Structures creates the object. For example:

Snap in orthogonal direction relative to previously picked points
When you create objects that require you to pick more than two points, for
example when you create a polybeam or a contour plate, you can snap in
orthogonal directions relative to the two previously picked points. This can be
useful, for example, if you need to create a rectangular slab that is on the view
plane but not along the x and y axes.

1. Ensure that the Ortho tool is active. 

• On the File menu, click Settings and select the Ortho check box.

• Alternatively, you can press O.

2. Run a command that requires you to pick multiple points. 

For example, start creating a polybeam or a rectangular slab.

3. Pick the first two points. 

Tekla Structures displays an angle symbol to indicate the direction of
snapping.

4. Move the mouse pointer in the model to see the angle symbol. 
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When the snap is orthogonal to a work plane axis, the color of the angle
symbol follows the color of the work plane axis: red for x-axis, green for y-
axis and blue for z-axis.

When the snap is orthogonal to the previous points, the color of the angle
symbol is black.

5. Pick the rest of the points. 
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Tekla Structures creates the object. For example:

Set a temporary reference point
You can set a temporary reference point to be used as a local origin when
snapping in models and drawings. Typically the Ortho tool and the Snap to
perpendicular points snap switch use the reference point information.

The reference point information is automatically set to the last picked point,
and shown as a gray cross. When you interrupt a command, the reference
point information, meaning the last picked point, is cleared. If you need to use
the reference point, set the temporary reference point manually.

1. Run a command that requires you to pick points. 

For example, start creating a beam.

2. Pick the start point. 

3. Hold down the Ctrl key and pick a position. 

Alternatively, right-click and select Define temporary snap reference
point and pick a position.

A gray cross indicates that this position is now a temporary reference
point. You can continue snapping from the temporary reference point.

Get to know Tekla Structures basic working
methods

103 Snap to positions



4. Repeat step 3 to create as many reference points as needed. 

If you use the Define temporary snap reference point command, you
need to activate it for every reference point you pick.

5. Release the Ctrl key and pick the end point. 

Tekla Structures creates the object between the start point and the end
point. For example:

Settings for the Ortho tool
Use the settings (page 104) in the Snap settings dialog box to set the angle
interval for Ortho. Use the Angle interval or the Custom angles option.

The default angle interval value is 90 degrees.

Snap settings
Use the Model snap settings dialog box in File menu --> Settings --> Snap
settings to view and modify the snap settings in the model. The Drawing
snap settings dialog box has the same options for drawings. These settings
are user specific.
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Option Description
Symbol Show or hide the snap symbols.

Select the check box to show the snap
symbols, and clear the check box to
hide them.

Active (when free snap is on) Select the check box to activate the
snap grid (page 99).

Spacing Define grid spacing intervals for the
snap grid origin. For example, if the
spacing of the x coordinate is 500,
you are can snap to positions at
intervals of 500 units in the x
direction.

Origin Define offsets for the snap grid origin.
Angle interval Set the angle interval for the Ortho

tool. This setting is used when you
snap to orthogonal points (page 100).

For example, if you set the interval to
10, the Ortho tool will snap to angles
at intervals of 10 degrees in the
model or drawing.

Custom angles Define custom angles for the Ortho
tool. This setting is used when you
snap to orthogonal points (page 100).

Separate the values with empty
spaces. For example, if you enter
12.5 60, the Ortho tool will snap to
the angles 12.5 and 60 in the model
or drawing.

See also

Snap to points by using snap switches (page 84)

1.4 Create model objects
When you model in Tekla Structures, you create and work with different types
of model objects. In most cases, a model object represents a building object
that will exist in the real building or structure, or that will be closely related to
it. A model object can also be a modeling aid that represents information that
is only relevant when you are creating the model. Model objects are either
created in the model or imported to it.
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You can create different types of model objects, such as parts and items, bolts,
reinforcement, and cuts, by using the commands on the ribbon.

Some ribbon commands have a keyboard shortcut that speed up your
modeling work. You can customize the keyboard shortcuts and assign your
own shortcuts for the most used commands.

Alternatively, you can use Quick Launch or the property pane to start many of
the commands that create model objects.

After you have created the model objects, you can view and modify the model
object properties by using the property pane.

Examples of model objects
Examples of model objects include:

• Parts (page 196) and items (page 300)

• Bolts (page 341) and welds (page 359)

• Reinforcement (page 469) and embeds

• Surface treatment (page 402) and surfaces (page 415)

• Cuts (page 389), fittings (page 375), bolt holes (page 353), and chamfers
(page 397)

• Pour breaks (page 458)

• Loads

Model objects may also be created by components (page 759).

To resize and reshape model objects, use the direct modification (page 107)
handles.

The following modeling aids can be used in the model:

• Grids (page 23) and grid lines (page 28)

• Construction objects (page 621) and points

• Reference models

You can combine model objects to bigger entities by creating assemblies, cast
units (page 430), and pour units (page 453).

You can manage model objects by using object groups (page 662), Organizer,
and other planning tools.

Create or delete a model object
1. Run a command that creates a model object, such as a part. 
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• On the ribbon: click a command. For example, click  to create a
steel beam.

• By using Quick Launch: enter a search term. For example, type steel
beam to find the Create steel beam command.

• In the property pane: ensure that you have nothing selected in the

model. Click the Object type list button  and select from the list
the object you want to create.

2. Pick points (page 83) to place the model object in the model. 

Tekla Structures creates the model object using the current properties of
the object type.

3. Follow the status bar messages to get instructions on how to proceed.

4. To create more model objects with the same properties, pick more points. 

The command runs until you end it or start another command.

5. If you want to delete a model object, select the object and press Delete.

1.5 Resize and reshape model objects
You can resize, reshape, and move model objects by using direct modification
handles. When you select an object, Tekla Structures displays the handles and
dimensions that are specific for that model object.

Direct modification can be used with the following object types:

• Parts

• Construction objects

• Grids and grid lines

• Line cuts and polygon cuts

• Reinforcement

• Rebar set guidelines, modifiers, and leg faces

• Pour breaks

• Custom parts

• Loads

1. Ensure that Direct modification is switched on. 

To switch direct modification on or off, click  or press D.

2. Click the object to select it. 
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Tekla Structures displays the handles that you can use to modify the
object.

The relevant dimensions are shown when you move the mouse pointer
slowly over the object's edges. The dimension colors follow the colors of
the work plane coordinate axes: red in the X direction, green in the Y
direction, and blue in the Z direction. Diagonal dimensions are magenta.

3. To reshape the object, drag any of the handles. 

Here are some examples of direct modification handles:

Handle Description

Reference point handle

Midpoint handle

End point handle (for reinforcing bars
only)
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Handle Description

Plane handle

Line handle

Axis handle (for items (page 300) and
custom parts only)

Rotation handle (for items and
custom parts only)

TIP You can use the snap switches (page 84) when dragging a handle. To
temporarily disable the snap switches, hold down the Shift key
when dragging a handle.

4. To give an exact value for a dimension, modify the dimension value.

a. Click a dimension to select it. 
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b. Type a new value. 

The yellow arrow defines the direction in which the object is extended
or shortened. You can change the direction by clicking the arrows.

c. Press Enter to confirm the new value. 

5. To change a dimension only from one end, move the dimension
arrowheads. 

You can either drag an arrowhead to a new location, or you can type an
exact distance or coordinates.

a. Select the dimension arrowhead you want to move. For example: 

To change a dimension at both ends, select both arrowheads.
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b. Type the distance or coordinates. 

When you start typing, Tekla Structures displays the Enter a Numeric
Location dialog box. Click OK to confirm the dimension.

6. To add a new object corner, drag a midpoint handle . For example: 

7. To display more modification options, select a handle. 

A contextual toolbar appears with more options. The availability of the
options depends on the object and handle you have selected.

Click this button To do this Location

Move a handle to
any location in the
3D space.

Move a handle in the
XY plane only.

Move a handle in the
Z direction only.

Move a handle along
the reference line
only.
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Click this button To do this Location

Move a handle in the
parallel direction
only.

Move a handle in the
perpendicular
direction only.

Move a handle
parallel to a certain
plane only. Select the
plane and drag the
handle to a new
location.

This option can be
useful when working
with a sloped roof,
for example.

Control the visibility
of direct
modification
dimensions. Click the
eye symbol to show
or hide dimensions.

• X, Y, Z
dimensions: All
orthogonal
dimensions in the
work plane
directions X, Y,
and Z are
displayed.

• Total
dimensions:
Only the total
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Click this button To do this Location
length is
displayed.

Show or hide
midpoint handles.

Add a new point at
the end of an object.

Only available for
objects that pass
through multiple
points, such as
polybeams, panels,
strip footings, and
rebar set modifiers.

NOTE Some of these options are located in an expandable section on
the contextual toolbar. Click the small triangle symbol on the
contextual toolbar to show or hide the options:

8. To delete a handle, select it and press Delete.

See also

Modify a construction object (page 628)

Modify a single grid line (page 28)

Modify a single reinforcing bar, bar group, or mesh (page 544)

Modify a rebar set (page 521)

Modify a pour break (page 463)

Add custom components to a model (page 845)

1.6 Select objects
Many Tekla Structures commands require to select objects. You can make
single selections and area selections. Tekla Structures highlights the selected
objects. The number of selected objects and handles is displayed in the
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bottom right corner of the status bar. For example:

Use the different commands and methods to select the objects. To control
which type of objects can be selected, use the selecting toolbar and the
selection switches.

Select single objects
1. Make sure that the correct selection switches are active.

2. Click an object to select it. 

Tekla Structures displays dimensions and dimension lines for column,
beam, reinforcing bar group, and for rebar set. If you want to hide the
dimensions, use the advanced options XS_DISPLAY_DIMENSIONS_WHEN_
SELECTING_OBJECTS and XS_DISPLAY_DIMENSIONS_WHEN_SELECTING_
REBARS.

NOTE When direct modification (page 107)  is switched on, the object
dimensions and dimension lines are always hidden. Only the direct
modification dimensions are then shown. This makes it easier to know which
dimensions can be edited.

Select multiple objects using area selection
You can select multiple objects using area selection. By default, the dragging
direction affects the selection of objects.
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1. Make sure that the correct selection switches are active.

2. To select all objects that are completely within a rectangular area, hold
down the left mouse button and drag the mouse from left to right. 

3. To select all objects that are at least partly within a rectangular area, hold
down the left mouse button and drag the mouse from right to left. 

4. If you want to change how area selection works, click File menu -->
Settings and select or clear the Crossing selection check box. 

By default, the option is switched off. When the option is off, the dragging
direction affects the selection of objects. When the option is on, all objects
that fall at least partially inside the rectangular area are selected,
regardless of the dragging direction.

Select all objects
To select all objects at once, do one of the following:

• On the ribbon, click the small down arrow next to the arrow button

, and then click Select all objects.

• Press Ctrl+A.

Note that
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• the Select all objects command respects the selection filter so that only
the objects that are matching the current selection filter are selected.

• the Select all objects command selects also those objects that are hidden
by a view filter, work area, or that have been hidden by using the Hide
command, if they match the selection filter.

Select previous objects
Sometimes you need to select again the same objects that you selected
previously but have then deselected. To select previously selected objects, do
one of the following:

• On the ribbon, click the small down arrow next to the arrow button

, and then click Select previous objects.

• Press Alt+P.

Select objects by identifier
If you know the GUID (globally unique identifier), or the ID of an object, or the
IFC GUID of a reference object, you can use the Select by identifier command
to locate the objects in a model or in a drawing.

You can often find information about the object GUID or ID, for example, in
reports and log files. By using the Select by identifier command you can
quickly find the objects in a model or in a drawing, instead of defining a view
filter or a selection filter with the specific GUID or ID. You can use IFC GUIDs to
find IFC reference objects. This is useful if you need to track updates and
changes in IFC reference models.

Additionally, you can use the Select by identifier command to inquire the
GUIDs of selected objects, instead of using the traditional inquiry (page 686).

To Do this
Find objects based on
the object GUID, ID, or
IFC GUID identifier

1. Do one of the following:

• In the modeling mode: on the ribbon, click
the small down arrow next to the arrow

button , and then click Select
by identifier.
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To Do this
• In the drawing mode: in Quick Launch,

type Select by identifier.

The Select by identifier dialog box opens.

2. Copy the object identifier, for example from a
log file, to the dialog box.

You can enter multiple identifiers in the dialog
box. Either enter each identifier on its own
row, or separate them with semicolon ;.

3. To define the search, select the needed check
boxes.

• Reference objects: Tekla Structures selects
IFC objects based on their GUID or IFC
GUID.

• Keep selection: Tekla Structures keeps the
currently selected object and appends it
with new selection.

• Zoom to selected: Tekla Structures selects
the object and zooms to it.

4. Click Select.

Tekla Structures selects the objects based on
the GUID in the model or in the drawing.

If there are identifiers that are not found in the
model or in the drawing, they are listed in the
status bar as identifier?.

Find a model object in a
drawing

You can select an object in a model, get its
identifier, and then find it in a drawing based on
the identifier.

1. In the modeling mode: on the ribbon, click the
small down arrow next to the arrow button

, and then click Select by
identifier.

The Select by identifier dialog box opens.

2. Select an object or objects in the model.
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To Do this
3. Click Get.

The Select by identifier dialog box lists the
identifiers of the selected objects.

If you want to get IFC GUIDs, make sure that
the Reference objects check box is selected.

4. Keep the dialog box open.

5. Open a drawing.

6. In the drawing mode, click Select to find the
objects in the drawing.

You can then continue working with the found
objects.

Find a drawing object in
a model

You can select an object in a drawing, get its
identifier, and then find it in a model based on the
identifier.

1. In the drawing mode: in Quick Launch, type
Select by identifier.

The Select by identifier dialog box opens.

2. Select an object or objects in the drawing.

3. Click Get.

The Select by identifier dialog box lists the
identifiers of the selected objects.

4. Keep the dialog box open.

5. Close the drawing.

6. In the modeling mode, click Select to find the
objects in the model.

You can then continue working with the found
objects.

Select handles
Sometimes you need to select only the handles of a part, for example when
moving the part.

Before you start, make sure that Crossing selection is switched off, and that

the Direct modification switch  is not active.

1. On the File menu, click Settings and make sure that Crossing selection is
switched off. If the Crossing selection is not switched off, selecting the
handles with the Alt key does not work.
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2. Make sure that the correct selection switches are active.

3. Hold down the left mouse button and drag the mouse from left to right to
include the entire part. 

The part becomes selected:

4. Hold down the Alt key and drag the mouse from left to right again. 
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Now only the part handles are selected:

NOTE When direct modification (page 107)  is switched on, Tekla Structures
also displays the direct modification handles for reference points, corners,
segments, and segment midpoints of the selected part. These handles are
blue.

Modify the selection
You can add objects to the current selection, or remove objects from the
selection.

1. To add objects to the current selection, press the Shift key and select
more objects.

2. To switch the selection of an object on or off, press the Ctrl key during the
selection. 

Tekla Structures deselects the objects that were already selected and
selects those that were previously not selected.
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3. To clear the selection of all objects and handles, click somewhere else. 

For example, click on the empty background of the current view.

Select assemblies, cast units, and nested objects
You can select either assemblies or cast units, or single objects in nested
assemblies or nested components.

Select assemblies and cast units
Use the Select assemblies selection switch to select assemblies and cast units
(page 430).

1. Ensure that the  Select assemblies selection switch is active.

2. Select a part. 

Tekla Structures selects the entire cast unit or assembly that contains the
selected part.

Select nested objects
You can select nested assemblies and components. The active selection switch
defines on which level you start and toward which direction you move in the
component or assembly hierarchy. The status bar shows the steps you take in
the hierarchy.

1. Ensure that the correct selection switch is active. 

• : to start from the assemblies on the highest level, move to their
sub-assemblies, and finally select single parts, bolts, and so on

• : to start from single objects and move to higher levels of nested
assemblies

• : to start from the components on the highest level, move to their
sub-components, and finally select single parts, bolts, and so on

• : to start from single objects and move to higher levels of nested
components

2. Place the mouse pointer on any part in the assembly or in the component.

3. Hold down the Shift key.

4. Scroll with the mouse wheel. 
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The blue highlighting box indicates the assembly or the component that
you can select.

Select reference models, reference model objects and
assemblies
You can select either entire reference models, or single objects and assemblies
that are part of a reference model. The use of selection switches differs in each
case.

Select an entire reference model

1. Activate the  Select reference models selection switch.

2. Activate the  Select components selection switch.

3. Select the reference model.

Select a reference model object

1. Activate the  Select reference models selection switch.

2. Activate the  Select objects in components selection switch.

3. Select the desired object in the reference model.
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Select a reference model assembly

1. Activate the  Select reference models selection switch.

2. Activate the  Select assemblies selection switch.

3. Select the desired assembly in the reference model.

Tips for selecting objects
Here are listed some tips that can help when you are selecting objects.

Switch rollover highlight on or off
By default, Tekla Structures highlights the objects that you can select. You can
switch the highlighting on or off.

To switch the rollover highlight on or off, on the File menu, click Settings and
select or clear the Rollover highlight check box. Alternatively, you can press
H.

Depending on the rendering engine (page 72) you are using, OpenGL or
DirectX, Tekla Structures highlights the objects differently when rollover
highlight is on.

In the example below, the rendering of parts (page 642) is set to Parts shaded
wireframe.

DirectX OpenGL
Tekla Structures highlights the objects
by showing them with darker object
color.

For example:

Tekla Structures highlights the objects
by showing them with light edge line
color.

For example:
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DirectX OpenGL

Select on right-click
You can change the settings so that you can select objects also with the right
mouse button.

1. On the File menu, click Settings and select the following check boxes: 

• Select on right-click

• Rollover highlight

2. Right-click an object to select it. Tekla Structures highlights the object and
shows the related shortcut menu.

If you cannot select objects
If you cannot select desired objects in the model, check the selection switches
and the filter settings.

• Check that you have switched on all the needed selection switches.

• If you still cannot select the objects, check the selection filter settings. You
can select a different filter or modify the current filter.

Interrupt object selection
You can have Tekla Structures interrupt the object selection process if the
selection takes over a defined period of time. For example, if you are working
on a large model and you accidentally select all or part of the model, you can
interrupt the selection if it takes over 5000 milliseconds (5 seconds) to
complete.

1. Define the time after which Tekla Structures asks if you want to interrupt
object selection.

a. On the File menu, click Settings --> Advanced options and go to the
Modeling properties category.
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b. Modify the advanced option XS_OBJECT_SELECTION_CONFIRMATION. 

The default value is 5000 milliseconds.

c. Click OK.

2. Select (page 113) all or part of the model.

3. When Tekla Structures asks if you want to interrupt object selection, click
Cancel.

1.7 Copy and move objects
The basic functionality of copying and moving objects is the same in models
and drawings. You can copy and move objects linearly, with rotation, and with
mirroring.

• Copy objects (page 127)

• Move objects (page 140)

• Rotate objects (page 145)

• Mirror objects (page 149)

Tips for copying and moving objects

By copying objects the modeling work becomes faster, more efficient, and
more consistent.

• Copy carefully

Always copy the objects carefully, and ensure that you are copying the
intended objects.

• Control over copying

At first, when you familiarize yourself with snapping, we recommend to use
the Copy Special - Linear - Pick method to have more control over the
copying action.

• Compare copied objects

Any comparison between the copied objects should be done before
running numbering. The numbering itself works as the final check.

• Select a suitable command for copying

• To ensure that the object is copied in the intended plane, use the Copy
special --> Linear command. The Copy - Linear dialog box can be used
as an explicit check to confirm that copying distance is in the intended
direction and round values.

• To copy objects, such as reinforcement, between similar objects, use the
Copy special --> To another object command. Always ensure that the
object you copy from and the object you copy to are of similar type and
have similar shape. For example, a polygonal slab and a rectangular
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column have different types of part handles, and their front faces are of
different shape and location.

• To copy objects around a specified line on the work plane, use the Copy
special --> Rotate command. When you use this command, copy
carefully and always check the outcome. If the results are not as
expected, copy in smaller chunks, for example, one component at a
time.

• To copy objects from one model to another, use the Copy special -->
From another model command. The copying is based on the phase
numbers in the original model. Successful copying requires that you
have set the objects correctly, without any additional objects, in a
specific phase in the source model. Otherwise all the objects included in
the phase are copied.

Note that if you copy objects from another model, only the model
objects are copied. The drawings are not copied.

• The source object for the copying determines the object orientation.

When the objects are copied with the Copy command, the object
orientation of the target object remains the same as the orientation of
the source object.

When the objects are copied with the Copy special --> To another
object command, the object orientation is defined in relation to the
source object's internal coordinate system, and this orientation will be
translated into the target object's internal coordinate system.

Custom components have their own logic for object orientation. It may
be more straightforward to add the component in the model than to
use copying, especially if the target object's main geometry differs
considerably from the source object's geometry.

• Duplicate objects

After copying and moving, check that the outcome is as expected and there
are no accidentally created duplicates in the model.

Two objects are considered duplicates if they have the same properties and
location. Tekla Structures checks for duplicate, overlapping objects when
you copy and move objects or create new objects in the same location as
an existing object. If duplicates are found, you can choose whether to keep
or delete them. If you choose to keep the duplicates, they are hard to
detect later on.

Use the advanced option XS_DUPLICATE_CHECK_LIMIT_FOR_COPY_AND_
MOVE to define the maximum number of objects that can be counted as
duplicates while copying or moving objects.

NOTE Tekla Structures does not check for duplicates when you copy
objects using a modeling tool, such as the Array of objects (29)
component.

Get to know Tekla Structures basic working
methods

126 Copy and move objects



• Assemblies and cast units

If you copy or move objects from an assembly or cast unit, Tekla Structures
copies the assembly structure if possible. For example, sub-assemblies are
copied as sub-assemblies if a parent object is found.

When selecting the correct content to be copied, first use model selection
filters (page 151), and secondly assembly, part, or component selection
switches.

To easily select all objects within an assembly or a cast unit according to the
selection filter, hold down the Alt key and click any object in the assembly
or cast unit.

• Drawing objects

You can copy and move drawing objects between drawing views that have
different scales.

• Reinforcement and surface treatment

If you copy or move reinforcement or surface treatments (page 402), and
want them to adapt to the part they are copied or moved to:

• The reinforcement handle or surface treatment handles must be in part
corners.

• The parts between which you copy or move must have the same
number of cross section corners.

• Circular parts must have the same cross section dimensions.

• Copy and move efficiently

You can keep the Move and Copy dialog boxes open if you are going to use
them often.

After you have run the Copy - Linear, Copy - Mirror, Copy - Rotate, or the
Move - Linear, Move - Mirror or Move - Rotate command, interrupt the
command and leave the dialog box open. When you want to continue
copying or moving, click the dialog box to activate it and continue to copy
or move objects.

Copy objects
You can copy objects in a number of different ways. When you copy an object,
Tekla Structures copies all objects connected to it, including the components.

Copy by picking two points
The basic way to copy objects in a model or drawing is by defining the origin
and one or more destination points.

1. Select the objects you want to copy.

2. Run the Copy command: 
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• In the model, on the Edit tab, click  Copy.

• In the drawing, on the Drawing tab, click  Copy --> Copy.

3. Pick the origin for copying. 

In the model, Tekla Structures displays a rubber band line between the
first picked point and the cursor position. This is a preview of the position
where the objects will be copied. Move the cursor to see how the preview
changes.

Note that Tekla Structures always displays the preview in the position
where the objects will be copied, not in the position where the cursor is
when you pick the destination point.

4. Pick one or more destination points. 
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The objects are copied immediately. The Copy command remains active.

5. If you want to undo the latest copy operation, click the  Undo button
on the top left corner of the Tekla Structures main window. 

The Copy command still remains active.

6. To stop copying, press Esc.

NOTE If you want to limit the number of objects shown in the preview, use
the advanced option XS_PREVIEW_LIMIT. The default value is 1000.
When the value is 0, the preview is off.
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Copy linearly
In the model, you can create multiple copies of an object in the same linear
direction.

1. Select the objects you want to copy.

2. On the Edit tab, click  Copy special --> Linear. 

The Copy - Linear dialog box opens.

3. Pick two points, or enter the coordinates in the dX, dY, and dZ boxes. 

You can also use a formula to calculate the x, y, and z displacements. For
example:

4. Enter the number of copies.

5. Click Copy.

6. To stop copying, press Esc.  

TIP If the dialog box is open but the command is no longer active, click
the Pick... button to re-activate the command.

Copy by specifying a distance from origin
You can copy objects to a new position in the model or drawing by specifying a
distance from the origin. Use the Enter a Numeric Location dialog box to
specify the distance.

1. Select the objects you want to copy.

2. Run the Copy command: 

• In the model, on the Edit tab, click  Copy.

• In the drawing, on the Drawing tab, click  Copy --> Copy.

3. Pick the origin for copying.

4. Move the cursor in the direction you want to copy the objects, but do not
pick the point.

5. Type the distance. 

When you start typing, Tekla Structures displays the Enter a Numeric
Location dialog box automatically.

6. Click OK.
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Copy using drag-and-drop
You can copy objects by using drag-and-drop.

1. On the File menu, click Settings and select the Drag & drop check box to
activate the command.

2. Select the objects you want to copy. 

3. Hold down the Ctrl key and drag the objects to a new location. 

The point you start dragging from (center, corner, or middle point) affects
the object's alignment in the new location.

Tekla Structures copies the objects:

NOTE To copy grid labels in a drawing, first select the grid label and then

either activate the  Select grid line selection switch or select the
grid label handle.

Copy objects to another object
In the model, you can copy reinforcement, surface treatments, and single part
welds between similar objects and make them adaptive to the object they are
copied to. This is useful, for example, when you detail previously modeled
parts. The objects that you can copy between can have different dimensions,
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length, and rotation. If you copy objects from an assembly or cast unit, Tekla
Structures copies the assembly structure as well, if possible. For example, sub-
assemblies are copied as sub-assemblies if a parent object is found.

TIP Instead of copying objects from an assembly or cast unit to other
identical assemblies or cast units, you can use the Batch editor tool.
Batch editor detects matching objects in the target assemblies or cast
units, and edits the matching objects by modifying their geometry and
properties.

If you copy reinforcement or surface treatments and want them to adapt to
the part they are copied to, note the limitations:

• The reinforcement or surface treatment handles must be in part corners.

• The parts between which you copy must have the same number of cross
section corners.

• Circular parts must have the same cross section dimensions.

1. Select the objects you want to copy.

2. On the Edit tab, click  Copy special --> To another object.

3. Select the object to copy from (source object).

4. Select the objects to copy to (target object).

Copy all content to another object
In the model, you can copy objects from an assembly or cast unit to other
similar assemblies or cast units without individually selecting each object to
copy. This is useful, for example, when you have detailed an assembly and
want to copy all details to another similar assembly.

TIP Instead of copying objects from an assembly or cast unit to other
identical assemblies or cast units, you can use the Batch editor tool.
Batch editor detects matching objects in the target assemblies or cast
units, and edits the matching objects by modifying their geometry and
properties.

1. Ensure that the  Select assemblies selection switch is active.

2. Select the assembly or cast unit to copy from (source object).

3. On the Edit tab, click  Copy special --> All content to another
object.

4. Select the assemblies or cast units to copy to (target objects).
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As a result, Tekla Structures copies the following objects:

• Secondary parts

• Reinforcement, bolts, and welds

• Cuts, fittings, and edge chamfers

• Sub-assemblies

• Components

NOTE Tekla Structures does not copy pour breaks, or secondary parts
created by a component that has also created the assembly main part.
If some of the objects to be copied already exist in the assembly or
cast unit to copy to, Tekla Structures may create duplicate objects.
Tekla Structures warns you about duplicate secondary parts,
reinforcement, and sub-assemblies, but not about duplicate bolts,
welds, cuts, or components.

Copy to another plane
In the model, you can copy objects from the first plane you specify to the
second, third, and so on, plane you specify. The position of the copied objects
relative to the second, third, and so on, plane remains the same as the
position of the original objects relative to the first plane.

1. Select the objects you want to copy.

2. On the Edit tab, click  Copy special --> To another plane.

3. Pick the point of origin of the first plane.

4. Pick a point on the first plane in the positive x direction.

5. Pick a point on the first plane in the positive y direction.

6. Repeat steps 3–5 for all destination planes.

Copy from another model
You can copy objects from another model based on phase numbers. Note that
Tekla Structures copies secondary parts from the model only if they belong to
the same phase as their main part. This also applies to component objects.

1. On the Edit tab, click  Copy special --> From another model. 

The Copy from Model dialog box opens.

2. In the Model directories list, select the model to copy from. 

This is the source model. Note that the target model must have been
created using the same or newer version of Tekla Structures as the source
model. You cannot copy from a newer version to an older version.
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3. In the Phase numbers box, enter the numbers of the phases from which
to copy objects, separated by spaces. 

For example, 2 7.

4. Click Copy.

5. Close the dialog box.

NOTE If you copy pour breaks from another model, the copied pour breaks
automatically adapt to the target model. Always check that the copied
pour breaks have adapted correctly.

Copy objects using linear array tool
Use Linear array tool to copy selected objects linearly along multiple
directions at defined intervals or spacing. Tekla Structures does not check for
duplicates when you copy objects using this method.

How to use Linear array tool

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Search for Linear array tool, and then double-click to open it.

3. Select the Copy method. The options are: 

• Selected objects only

This is the default. Only the selected objects are copied.

• All associated objects

Selected objects and all objects associated with them are copied. For
example, cuts and fittings applied to a part.

• Advanced

This option is similar to All associated objects, but works better with
modifications. For example, when you have stairs that have posts
welded to the steps, and you modify the distance between steps.

4. Select the Copy origin. The options are: 
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• Object to be copied

This is the default. Copies are relative to the input objects.

• Origin point

Copies are relative to the input origin point.

5. Define the settings.

6. Select the objects to copy.

7. Click OK to close the dialog box.

8. Click the middle mouse button.

9. Pick origin point.

10. Pick axis direction X.

11. Pick axis direction Y. 

The selected objects are copied.

How to define the settings

1 Offset along the Y axis. The default value is 0 mm.
2 Offset along the Z axis. The default value is 0 mm.
3 Number of copies. The default value is 0.

If you leave this empty, the number of copies is taken from the Space
between copies field.
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4 Space between copies. The default value is 0 mm.

Use the space character to separate values. Enter a value for each space
between copies.

This option is not available if you select Equal as the spacing method.
5 Copy direction. The options are:

• Normal (default)

Spacing values are calculated from the origin in positive direction along
the axis.

• Reverse

Spacing values are calculated from the origin in negative direction along
the axis.

• Centered

Copies are centered on the origin.

• Mirror

Spacing values are calculated from the origin in both positive and
negative direction. Mirrored copying doubles the number of copies.

6 Spacing method. The options are:

• Equal (default)

Copies are equally spaced based on the length of the X or Y axis.

• Specified

Copies are spaced according to the number and spacing values given.

Copy objects using radial array tool
Use Radial array tool to copy selected objects radially along multiple
directions at defined intervals or spacing. Tekla Structures does not check for
duplicates when you copy objects using this method.

How to use Radial array tool

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Search for Radial array tool, and then double-click to open it.
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3. Select the Copy method. The options are: 

• Selected objects only

This is the default. Only the selected objects are copied.

• All associated objects

Selected objects and all objects associated with them are copied. For
example, cuts, welds, and bolts.

• Advanced

This option is similar to All associated objects, but works better with
modifications. For example, when you have stairs that have posts
welded to the steps, and you modify the distance between steps.

4. Select the Rotate copies option. 

The default is Yes.

5. Define the rotation axis. 

The default is X.

6. Define the settings.

7. Select the objects to copy.

8. Click OK to close the dialog box.

9. Click the middle mouse button.

10. Pick origin point.

11. Pick axis direction X.

12. Pick axis direction Y. 

The selected objects are copied.
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How to define the settings

1 Distance between copies. The default value is 0.
2 Rotation. The options are:

• Angle (default)

The copies are rotated by angle.

• Distance

The copies are rotated by distance.
3 Number of angles or distances. The default value is 0.

If you leave this empty, the number of copies is taken from the
Space between copies field.

4 Space between copies.

Use the space character to separate values. Enter a value for each
space between copies.

5 Copy direction. The options are:

• Normal (default)

Spacing values are calculated from the origin in positive direction
along the axis.

• Reverse

Spacing values are calculated from the origin in negative
direction along the axis.

• Centered

Copies are centered on the origin.
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• Mirror

Spacing values are calculated from the origin in both positive
and negative direction. Mirrored copying doubles the number of
copies.

6 Radial distance.

The radial distance should be equivalent to the distance you picked
when applying the component.

If the radial distance is smaller or greater than the picked distance,
the spacing between the copied objects is not the same as given in
the Space between copies box (4).

Tekla Structures calculates the rotation angle according to the dialog
box values (spacing and radial distance), and the rotation angle
overrides the spacing given in the dialog box.

Copy objects using Array of objects (29) component
Use the Array of objects (29) component to copy model objects along a line. If
you modify the original object, Tekla Structures also changes the copied
objects.

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Search for the Array of objects (29) component, and then double-click to
open it.

3. Define the settings: 

• Number of copies: Enter the number of copies you want to create.

• Spacing values: Define the spacing of the objects.

• Copy to the opposite direction: Select Yes if you want to copy in the
direction opposite to the points you pick.

• Start point for copying: Choose either the object to be copied or the
first input point.

• Copy at equal distances (Ignore spacing values): Select Yes if you
want to create the objects at equal distances. Spacing value will be
ignored.

4. Click OK to save the settings.

5. Select the objects to copy.

6. Click the middle mouse button to finish selecting.

7. Pick a point to indicate the start of the line along which to arrange copied
objects.

8. Pick a point to indicate the end of the line.
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Examples

Example Description
An array of steel objects.

An array of concrete objects.

Move objects
You can move objects in a number of different ways, especially in models.
When you move an object, Tekla Structures also copies all objects connected
to it, including the components.

Move by picking two points
The basic way to move objects in a model or drawing is by defining the origin
and one or more destination points.

1. Select the objects you want to move. 
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2. Run the Move command: 

• In the model, on the Edit tab, click  Move.

• In the drawing, on the Drawing tab, click  Move --> Move

3. Pick the origin for moving. 

In the model, Tekla Structures displays a rubber band line between the
first picked point and the cursor position. This is a preview of the position
where the objects will be moved. Move the cursor to see how the preview
changes.

Note that Tekla Structures always displays the preview in the position
where the objects will be moved, not in the position where the cursor is
when you pick the destination point.

4. Pick the destination point. 

The objects are moved immediately. The Move command does not
remain active.

NOTE If you want to limit the number of objects shown in the preview, use
the advanced option XS_PREVIEW_LIMIT. The default value is 1000.
When the value is 0, the preview is off.

Move linearly
You can move objects linearly to a new position in the model.
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1. Select the objects you want to move.

2. On the Edit tab, click  Move special --> Linear. 

The Move - Linear dialog box opens.

3. Pick two points in the model, or enter the coordinates in the dX, dY, and
dZ boxes. 

You can also use a formula to calculate the x, y, and z displacements. For
example:

4. Click Move.

TIP If the dialog box is open but the command is not active anymore, click
the Pick... button to re-activate the command.

Move by specifying a distance from origin
You can move objects to a new position in the model or drawing by specifying
a distance from the origin. Use the Enter a Numeric Location dialog box to
specify the distance.

1. Select the objects you want to move.

2. Run the Move command: 

• In the model, on the Edit tab, click  Move.

• In the drawing, on the Drawing tab, click  Move --> Move.

3. Pick the origin for moving.

4. Move the cursor in the direction you want to move the objects, but do not
pick the point.

5. Type the distance. 

When you start typing, Tekla Structures displays the Enter a Numeric
Location dialog box automatically.

6. Click OK.

Move using drag-and-drop
You can move objects by dragging them to a new location.

1. On the File menu, click Settings and select the Drag & drop check box to
activate the command.

2. Select the objects you want to move. 

Get to know Tekla Structures basic working
methods

142 Copy and move objects



3. Drag the objects to a new location. 

The point you start dragging from (center, corner, or middle point) affects
the object's alignment in the new location.

The objects are moved immediately.

4. To move an end point using drag-and-drop:

a. Select the handle.

b. Hold down the left mouse button, and drag the handle to a new
location. 

The end point is moved accordingly:
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Note that for some objects you may need to switch on Smart select
to drag from handles without selecting them first. To switch it on, click
File --> Settings and select the Smart select check box.

NOTE To move grid labels in a drawing, first select the grid label and

then either activate the  Select grid line selection switch or
select the grid label handle.

Move to another plane
In the model, you can move objects from the first plane you specify to the
second, third, and so on, plane you specify. The moved objects remain in the
same position in the second plane, third, and so on, plane as the original
objects in the first plane.

1. Select the objects you want to move.

2. On the Edit tab, click  Move special --> To another plane.

3. Pick the point of origin of the first plane.

4. Pick a point on the first plane in the positive x direction.

5. Pick a point on the first plane in the positive y direction.

6. Repeat steps 3–5 for the destination planes.

Move objects to another object
In a model, you can move objects from an object to other, similar objects. This
is useful, for example, when you detail previously modeled parts. The objects
that you move between can have different dimensions, length, and rotation.

If you move reinforcement or surface treatments and want them to adapt to
the part they are moved to, note the limitations:

• The reinforcement or surface treatment handles must be in part corners.

• The parts between which you move must have the same number of cross
section corners.

• Circular parts must have the same cross section dimensions.

1. Select the objects you want to move.
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2. On the Edit tab, click  Move special --> To another object.

3. Select the object to move from (source object).

4. Select the objects to move to (target object).

Rotate objects
You can copy or move an object in a model by rotating it around any line you
choose. In a drawing, you can copy or move an object by rotating it around a
given line on the work plane.

NOTE Positive rotation is according to the right-hand rule (page 53) (clockwise when
looking from the start point of the rotation axis).

Rotate around a line
Use the line option in the Rotate dialog box when you want to copy and
rotate, or move and rotate objects around any given line in the model.

1. Select the objects you want to copy or move.

2. Activate the rotation command. 

• To copy and rotate, go to the Edit tab and click  Copy special -->
Rotate.

The Copy - Rotate dialog box opens.

• To move and rotate, go to the Edit tab and click  Move special -->
Rotate.

The Move - Rotate dialog box opens.

3. In the Around list, select line.

4. Pick the start point of the rotation axis, or enter its coordinates.

5. Pick the end point of the rotation axis, or enter its coordinates.

6. If you are copying, enter the number of copies.

7. If needed, enter the dZ value, which is the difference in position between
the original and copied object in the z direction.

8. Enter the rotation angle.

9. Click Copy or Move. 

The objects are rotated accordingly.
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Example

In this example, a fitting plate is copied and rotated around a construction line
that is located at the following coordinates.

As a result, the copied fitting plates follow the curve of the concrete panel.

Rotate around the z axis
Use the Z option in the Rotate dialog box when you want to copy and rotate,
or move and rotate objects around the z axis in the model.

1. Select the objects you want to copy or move. For example: 
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2. Activate the rotation command. 

• To copy and rotate, go to the Edit tab and click  Copy special -->
Rotate.

The Copy - Rotate dialog box opens.

• To move and rotate, go to the Edit tab and click  Move special -->
Rotate.

The Move - Rotate dialog box opens.

3. Select Z in the Around list.

4. Pick a point to define the rotation axis, or enter its coordinates. 

In the example below, the red cross indicates the picked point.

5. If you are copying, enter the number of copies.

6. If needed, enter the dZ value, which is the difference in position between
the original and copied object in the z direction.

7. Enter the rotation angle. For example: 
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8. Click Copy or Move. 

The objects are rotated accordingly.

Rotate drawing objects
Use this option when you want to rotate drawing objects on the work plane.

1. Select the objects you want to copy or move.

2. Activate the rotation command. 

• To copy and rotate, go to the Drawing tab and click  Copy -->
Rotate.

The Copy - Rotate dialog box opens.

• To move and rotate, go to the Drawing tab and click  Move -->
Rotate.

The Move - Rotate dialog box opens.

3. Pick a point, or enter its coordinates.

4. If you are copying, enter the number of copies.

5. Enter the rotation angle.

6. Click Copy or Move.
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Rotation settings
Use the Copy - Rotate and Move - Rotate dialog boxes to view and modify the
settings that are used when you rotate objects in Tekla Structures. The units
depend on the settings in File menu --> Settings --> Options --> Units and
decimals .

Option Description
X0 The x and y coordinates of the start

point of the rotation axis.Y0
Origin angle The angle of the rotation axis when

rotating around a line on the work
plane.

Number of copies Define the number of copies created.
dZ The difference in position between

the original and copied object in the z
direction.

Rotation angle The rotation angle between the
original and new position.

Around Define whether the rotation axis is a
line on the work plane or in the z
direction.

Mirror objects
When you copy or move objects, you can mirror them through a plane that is
perpendicular to the work plane and passes through a line you specify.

Note that Tekla Structures cannot create mirrored copies of object properties.
For example, the Copy special --> Mirror command does not fully mirror
objects if they include components with asymmetrically positioned parts, or
reinforcement objects with asymmetric properties such as spacing.

Mirror model objects
Use this method to copy and mirror, or move and mirror objects in a model.

1. Select the objects you want to copy or move.

2. Activate the mirroring command. 

• To copy and mirror, go to the Edit tab and click  Copy special -->
Mirror.

The Copy - Mirror dialog box opens.
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• To move and mirror, go to the Edit tab and click  Move special -->
Mirror.

The Move - Mirror dialog box opens.

3. Pick the start point of the mirroring plane, or enter its coordinates and
angle.

4. Pick the end point of the mirroring plane, or enter its coordinates and
angle. 

The first picked point (X0, Y0) is the origin, and the second picked point
calculates the angle around the origin.

5. Click Copy or Move.

Mirror drawing objects
Use this method to copy and mirror, or move and mirror objects in a drawing.

1. Select the objects you want to copy or move.

2. Activate the desired mirroring command. 

• To copy and mirror, go to the Drawing tab and click Copy --> Mirror.

The Copy - Mirror dialog box opens.

• To move and mirror, go to the Drawing tab and click Move --> Mirror.

The Move - Mirror dialog box opens.

3. Pick the start point of the mirroring plane, or enter its coordinates in the
dialog box.

4. Pick the end point of the mirroring plane, or enter its coordinates in the
dialog box.

5. Enter the angle in the dialog box.

6. Click Copy or Move.

1.8 Filter objects
Use filters to restrict what can be selected or what is visible in a view. You can
create filters of your own, or you can use any of the standard filters available
in Tekla Structures.

Here are some examples of what filters can be used for:

• To select a large number of objects

Use selection filters when you need to change a specific object property
that is common for many objects. The rest of the objects will not be
affected, even if you try to include them in the selection.
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• To check the model

Use view filters to ensure that beams are called beams, columns are called
columns, and so on. You can highlight several groups of objects, one at a
time, to check that all required objects are included in a given group.

• To hide objects

Use view filters to temporarily hide the columns in a view so that it easier
to select all the beams, for example.

• To find objects

You can create a selection filter to find all locations where ½” reinforcing
bars are in the model, for example. Once the filter is active, you can make
an area selection that includes the entire model. All specified reinforcing
bars become selected, but the other objects will not be affected.

See also

Use existing filters (page 151)

Create new filters (page 153)

Filtering techniques (page 161)

Examples of filters (page 181)

Use existing filters
Before creating new custom filters, check out the existing view and selection
filters available in Tekla Structures.

How to use a view filter
Use view filters to define which objects are displayed in a model view.

1. Double-click the view to open the View Properties dialog box.

2. Select a filter from the Visible object group list. 

For example, select purlins.

3. Click Modify. 
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Now only the objects defined by the filter are visible. For example, the
purlins:

4. To stop using the filter:

a. Double-click the view to open the View Properties dialog box.

b. In the Visible object group list, select the standard filter.

c. Click Modify. 

All objects are visible again:
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NOTE If you cannot see all desired objects (page 50), note that the
work area, view depth, view setup, and object representation
settings also affect the visibility of objects.

How to use a selection filter
Use selection filters to define which objects can be selected in the model. Note
that an object must be visible in the model to be selectable.

1. On the Selecting toolbar, select a filter from the 
list. 

The list is by default located at the bottom of the Tekla Structures main
window.

For example, select the Name - Footing filter.

2. Select the desired objects in the model. 

You can select multiple objects or even the entire model at once. Now that
the filter is active, only objects defined by the filter become selected. For
example, if the Name - Footing filter is active, only footings are selectable
and the rest of the objects stay intact:

3. If you cannot select all objects defined by the selection filter, check your
view filter settings and ensure that you have switched on all the needed
selection switches.

4. To stop using the filter, go to the Selecting toolbar and select the
standard filter. 

All objects are selectable again.
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Create new filters
You can create custom filters to define which objects are visible and selectable
in the model and drawings. Add new filter rules, one on each row, to define
which objects should be included or excluded.

Create a view filter
You can create your own custom filters to define which objects are visible in a
model.

1. Double-click the view to open the View Properties dialog box.

2. Click Object group. 

The Object Group - View Filter dialog box opens, showing the currently
active filter.

3. Click New filter to create a new filter from scratch.

4. Click Add row to add a new filter rule.

5. In the Category list, select an object category. 

You have the following options:

• Part

• Component

• Bolt

• Weld

• Reinforcing bar

• Surface

• Assembly

• Construction object

• Load

• Template

• Reference assembly

• Reference object

• Location breakdown structure

• Pour object

• Pour break

• Pour unit

• Task

• Object

Get to know Tekla Structures basic working
methods

154 Filter objects



6. In the Property list, select a suitable object property (page 164). 

The options vary depending on the object category you chose in step 5.

7. In the Condition list, select a suitable condition (page 161).

8. In the Value list, type a value. 

Alternatively, to use the current value of an existing object, click Select
from model... and select the desired object from the model. To use the
values of multiple objects, click Multi-select from model, select the
objects from the model, and then click the middle mouse button. For date
values, also the Select date... option is available.

The values can be complete strings, such as the profile name UC310*97.
You can also use incomplete strings together with wildcards (page 181).
For example, the value UC* will match with all parts whose profile name
begins with the characters UC*. Empty values are matched to empty
object properties.

If you use multiple values, separate the strings with blank spaces (for
example, 12 5). If a value consists of multiple strings, enclose the entire
value in quotation marks (for example, "custom panel"), or use a
question mark (for example, custom?panel) to replace the space.

9. Repeat steps 4–8 to create as many filter rules as needed. 

You can apply several filter rules at the same time.

10. Use the And/Or options and brackets (page 161) to define how multiple
rows work together.

11. Select the check boxes next to all filter rules that you want to enable. 

If the check box is selected, the filter rule is enabled and effective. For
example:

By default, each new rule is disabled.

12. Define the filter type.

a. Click  to display more settings.
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b. Select or clear the check boxes to define where the filter will be used. 

For example, the same filter may be used both as a view filter and as
a selection filter.

13. Enter a unique name in the box next to the Save as button. 

NOTE • Filters are case sensitive.

• Do not use spaces in filter names.

• We recommend that you use _ (underscores) in your naming
convention.

• To have the filter appear at the top of the list, right after the
standard filter, use capital letters in the filter name.

14. Click Save as to save the filter.

15. To apply the filter to the current view, click Modify.

Create a selection filter
You can create your own custom filters to help you select objects in a model.

1. On the Selecting toolbar, click  to open the Object Group - Selection
Filter dialog box. 

2. Follow the instructions above on how to create a view filter. 

The same instructions apply to selection filters.

Create a drawing filter
For general arrangement drawings, you can create drawing filters that affect
the whole drawing, not just a specific view. Drawing filters select objects in the
whole drawing.

You can use drawing filters together with saved object property files when you
create and apply object level settings in the whole drawing. For example, you
might create a filter that selects all beams, then save an object property file
that defines that the part color is blue, and then create and apply an object
level settings file that changes all beams to blue in the whole drawing.

1. In a GA drawing, on the Drawing tab, click Properties --> Drawing.

2. Click Filter.

3. Click New filter to create a new filter from scratch.

4. Click Add row to add a new filter rule.

5. In the Category list, select an object category. 
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You have the following options:

• Part

• Component

• Bolt

• Weld

• Reinforcing bar

• Surface

• Assembly

• Construction object

• Template

• Reference assembly

• Reference object

• Location breakdown structure

• Pour object

• Pour break

• Pour unit

• Task

• Object

6. In the Property list, select a suitable object property (page 164). 

The options vary depending on the object category you chose in step 5.

7. In the Condition list, select a suitable condition (page 161).

8. In the Value list, type a value. 

Alternatively, to use the current value of an existing object, click Select
from drawing and select the desired object from the drawing. To use the
values of multiple objects, click Multi-select from drawing, select the
objects from the drawing, and then click the middle mouse button. For
date values, also the Select date... option is available.

The values can be complete strings, such as the profile name UC310*97.
You can also use incomplete strings together with wildcards (page 181).
For example, the value UC* will match with all parts whose profile name

Get to know Tekla Structures basic working
methods

157 Filter objects



begins with the characters UC*. Empty values are matched to empty
object properties.

If you use multiple values, separate the strings with blank spaces (for
example, 12 5). If a value consists of multiple strings, enclose the entire
value in quotation marks (for example, "custom panel"), or use a
question mark (for example, custom?panel) to replace the space.

9. Repeat steps 4–8 to create as many filter rules as needed. 

You can apply several filter rules at the same time.

10. Use the And/Or options and brackets (page 161) to define how multiple
rows work together.

11. Select the check boxes next to all filter rules that you want to enable. 

If the check box is selected, the filter rule is enabled and effective. For
example:

By default, each new rule is disabled.

12. Define the filter type.

a. Click  to display more settings.

b. Select or clear the check boxes to define where the filter will be used. 

For example, the same drawing filter may be used both as a model
view filter and as a model selection filter, and also as an Organizer
filter.

13. Enter a unique name in the box next to the Save as button. 

NOTE • Filters are case sensitive.

• Do not use spaces in filter names.

• We recommend that you use _ (underscores) in your naming
convention.

• To have the filter appear at the top of the list, right after the
standard filter, use capital letters in the filter name.

14. Click Save as to save the filter.

15. When you are done, click Cancel to close the filter properties dialog box.
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Create a drawing view filter
You can create your own custom view filters to help you select a specific group
of view objects in a drawing view.

You can use drawing view filters for changing the appearance of a certain
object group, or for selecting which objects are hidden in a drawing view.

You can also use drawing view filters together with saved object property files
when you create and apply object level settings in the selected view. For
example, you might create a view filter that selects all columns in a view, then
save an object property file that defines that the part color is red, and then
create and apply an object level settings file that changes all columns to red in
the selected view.

1. Open a drawing.

2. Double-click a drawing view frame.

3. Click Filter.

4. Click New filter to create a new filter from scratch.

5. Click Add row to add a new filter rule.

6. In the Category list, select an object category. 

You have the following options:

• Part

• Component

• Bolt

• Weld

• Reinforcing bar

• Surface

• Assembly

• Construction object

• Template

• Reference assembly

• Reference object

• Location breakdown structure

• Pour object

• Pour break

• Pour unit

• Task

• Object

Get to know Tekla Structures basic working
methods

159 Filter objects



7. In the Property list, select a suitable object property (page 164). 

The options vary depending on the object category you chose in step 5.

8. In the Condition list, select a suitable condition (page 161).

9. In the Value list, type a value. 

Alternatively, to use the current value of an existing object, click Select
from drawing and select the desired object from the drawing. To use the
values of multiple objects, click Multi-select from drawing, select the
objects from the drawing, and then click the middle mouse button. For
date values, also the Select date... option is available.

The values can be complete strings, such as the profile name UC310*97.
You can also use incomplete strings together with wildcards (page 181).
For example, the value UC* will match with all parts whose profile name
begins with the characters UC*. Empty values are matched to empty
object properties.

If you use multiple values, separate the strings with blank spaces (for
example, 12 5). If a value consists of multiple strings, enclose the entire
value in quotation marks (for example, "custom panel"), or use a
question mark (for example, custom?panel) to replace the space.

10. Repeat steps 4–8 to create as many filter rules as needed. 

You can apply several filter rules at the same time.

11. Use the And/Or options and brackets (page 161) to define how multiple
rows work together.

12. Select the check boxes next to all filter rules that you want to enable. 

If the check box is selected, the filter rule is enabled and effective. For
example:

By default, each new rule is disabled.

13. Define the filter type.

a. Click  to display more settings.
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b. Select or clear the check boxes to define where the filter will be used. 

For example, the same drawing view filter may be used both as a
model view filter and as a model selection filter, and also as an
Organizer filter.

14. Enter a unique name in the box next to the Save as button. 

NOTE • Filters are case sensitive.

• Do not use spaces in filter names.

• We recommend that you use _ (underscores) in your naming
convention.

• To have the filter appear at the top of the list, right after the
standard filter, use capital letters in the filter name.

15. When you are done, click Cancel to close the filter properties dialog box.

Create a drawing selection filter
You can create your own custom filters to help you select objects in a drawing.

You can use selection filters in drawings if you want to hide certain parts from
drawings or drawing views, or change the part color or representation for
certain parts.

Also, if you have some different looking part marks for different types of parts,
you can select the specific parts using a selection filter and then only modify
part marks for those parts.

1. In an open drawing, on the Selecting toolbar, click  (Ctrl+G). 

The Selection filter dialog box opens.

2. Follow the instructions above on how to create a drawing or drawing view
filter. 

The same instructions apply to drawing selection filters.

3. Click Apply or OK to select the parts according to the filter.

Filtering techniques
By using conditions, brackets, and the And/Or options you can create filters
that can be as complex as needed.

Conditions

Use conditions to define how filter criteria relate to one another. Note that
when you create filters (page 153), you are always defining what should be
shown (or be selectable) in the model or drawing. Therefore, if you enter
"Component name does not contain gusset", you are telling Tekla Structures
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to show all components whose name does not contain the word "gusset".
Tekla Structures then hides all components which have the word "gusset" in
their name.

Condition Description
Equals Use this condition when the filter

value must be matched exactly. For
example, "Part name equals BEAM."

Does not equal Filters out objects that contain the
value you enter. For example, "Part
profile does not equal BL200*20"
means that Tekla Structures will hide
(or not select) the objects whose
profile is BL200*20. The rest of the
objects will be shown (or selected).

Begins with Finds all objects that start with the
value you enter. For example,
"Component name begins with
purlin."

Does not begin with Filters out objects that start with the
value you enter. For example,
"Component name does not begin
with shear" means that Tekla
Structures will hide (or not select) the
objects whose name begins with the
word "shear". The rest of the objects
will be shown (or selected).

Ends with Finds all objects that end with the
value you enter. For example,
"Component name ends with plate."

Does not end with Filters out objects that end with the
value you enter. For example,
"Component name does not end with
angle" means that Tekla Structures
will hide (or not select) the objects
whose name ends with the word
"angle". The rest of the objects will be
shown or selected.

Contains Finds all objects that include the value
you enter. For example, "Component
name contains plate" would find
base plate and shear plate
simple.

Does not contain Filters out objects that include the
value you enter. For example,
"Component name does not contain
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Condition Description
gusset" means that Tekla Structures
will hide (or not select) the objects
whose name contains the word
"gusset". The rest of the objects will
be shown or selected.

Greater than Finds all objects that exceed the value
you enter. For example, "Template
attribute LENGTH is greater than
5000."

This property can only be used with
numerical data, such as the part start
number, class, phase, or LENGTH.

Greater or equal Finds all objects that match or exceed
the value you enter.

This property can only be used with
numerical data, such as the part start
number, class, phase, or LENGTH.

Less than Finds all objects that are less than the
value you enter.

This property can only be used with
numerical data, such as the part start
number, class, phase, or LENGTH.

Less or equal Finds all objects that match or are
less than the value you enter.

This property can only be used with
numerical data, such as the part start
number, class, phase, or LENGTH.

Later than Available for dates only. The date
must be later than the one you have
defined. For example, "Object's
approval date later than 4/10/2017."

Later than or equal Available for dates only. The date
must be later than or equal to the one
you have defined.

Earlier than Available for dates only. The date
must be earlier than the one you have
defined. For example, "Object's
approval date earlier than
2/18/2017."

Earlier than or equal Available for dates only. The date
must be earlier than or equal to the
one you have defined.
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And/Or options

Use the And/Or options when you create filter rules that consist of several
rows.

Option Description
And Use to find objects that match both

values.

When you create filter rules between
objects whose Category settings
differ, use the And option when
possible to avoid potential problems
with more complex rules.

Or Use to find objects that match either
value.

empty (= And) Empty means the same as And.

Brackets

You can use single, double, and triple brackets to create more complex filter
rules.

Example 1. Use the format "A and (B or C)" to find objects that match the first
filter rule and either of the last two rules.

Example 2. Use the format "(A and B) or C" to find objects that match both of
the first two rules or the third.

Object properties in filtering
You can select from a wide variety of object properties when creating new
filters. In the tables below, the properties are listed according to their object
category. In addition to these, almost all categories contain user-defined
attributes and template attributes that can also be used in filtering.
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Category: Object

Use the Object category to filter objects based on their object level properties.

Property Description
GUID To filter objects based on their

globally unique identifier (GUID). For
example, "Object GUID begins with
ID7554C9EB-C8B4."

Phase To filter objects based on their phase
number. For example, "Object phase
does not equal 3."

Object type To filter objects based on their type.
Select an object type from the Value
list, or use the Select from model...
or Multi-select from model option.

NOTE: We recommend that you
include one filter rule for the Object
type property in each filter you
create. This ensures that only objects
of this type are filtered in. If you leave
the object type out, the filtering
outcome will be different, and objects
that do not match the category in
further filter rules may be filtered in.

The following object types can be
selected from the list:

• Assembly

• Bolt group

• Connection

• Part

• Pour break

• Pour object

• Pour unit

• Reference object

• Reinforcing bar

• Surface

• Surface treatment

• Weld

The following object types are shown
as numeric values only:
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Property Description
• 1 = point

• 9 = fitting

• 11 = polygon cut

• 12 = line cut

• 24 = construction line

• 30 = construction plane

• 38 = added material

• 42 = construction circle

• 43 = construction arc

• 48 = reference model

• 76 = analysis part

• 79 = edge chamfer

• 103 = construction polycurve
Is component To filter objects based on whether or

not they are components. The options
are Yes and No. For example, "Object
is component equals Yes."

Some object types are not visible directly, but only when the objects that make
them up are visible. For example, assemblies are visible when parts are visible,
and pour units are visible when pour objects are visible. Therefore, using the
object type Assembly or Pour unit alone in a view filter in the model or in
drawings does not show anything. However, selection filters are able to select
object types like assemblies and pour units.

Category: Part

Use the Part category to filter parts (page 196) based on their common
properties.

Property Description
Name To filter objects based on their name.

For example, "Part name equals
SLAB."

Profile To filter objects based on their profile.
For example, "Part profile does not
equal L20*2."

Material To filter objects based on their
material grade. For example, "Part
material equals C25/30."
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Property Description
Finish To filter objects based on how the

part surface has been treated. For
example, "Part finish equals "FP -
Fire proofing"."

Prefix To filter objects based on their
numbering prefix. For example, "Part
prefix equals P."

Start number To filter objects based on their start
number. For example, "Part start
number greater than 100."

Numbering series To filter objects based on their
numbering series information. For
example, "Part numbering series
equals TP/1."

Note that position number separator
can be a dot (.), comma (,), slash (/), or
hyphen (-), depending on what you
have defined in File menu -->
Settings --> Options --> Numbering.

Position number To filter objects based on their
position number. For example, "Part
position number does not equal P/5."

Note that position number separator
can be a dot (.), comma (,), slash (/), or
hyphen (-), depending on what you
have defined in File menu -->
Settings --> Options --> Numbering.

Class To filter objects based on their class
number. For example, "Part class
equals 210."

Phase To filter objects based on their phase
number. For example, "Part phase
equals 1 2."

Lot To filter objects based on their lot
number. For example, "Part lot
greater than 1."

Primary part To filter objects based on whether
they are main or secondary parts in
an assembly or cast unit. 1 = primary
part, 0 = secondary part. For example,
"Part primary part equals 1."
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Property Description
Pour phase To filter parts based on their pour

phase. For example, "Pour phase
does not equal 0."

Category: Component

Use the Component category to filter components (page 759) based on their
common properties.

Property Description
Name To filter components based on their

name. For example, "Component
name equals "shear plate
simple"."

Connection code To filter components based on their
connection code, which can be either
a text string or a number. For
example, "Component connection
code equals 200_2."

Running number To filter components based on their
unique running number. For example,
"Component running number less
than 150."

Phase To filter components based on their
phase number. For example,
"Component phase equals 2."

Is conceptual To filter components based on their
type. Components can be either
detailed or conceptual. Yes =
conceptual, No = detailed. For
example, "Component is conceptual
equals Yes."

Category: Bolt

Use the Bolt category to filter bolts (page 341) based on their common
properties.

Property Description
Size To filter bolts based on their

diameter. For example, "Bolt size less
than 20.00."

Standard To filter bolts based on their bolt
assembly standard/grade. For
example, "Bolt standard equals
7990."
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Property Description
Site/Workshop To filter bolts based on their assembly

type. Site = 0, Workshop = 1. For
example, "Bolt Site/Workshop equals
1."

Phase To filter bolts based on their phase
number. For example, "Bolt phase
equals 3 4."

Length To filter bolts based on their length.
For example, "Bolt length greater than
50.00."

Hole 1 type … Hole 5 type To filter bolts based on their hole
types in the bolted parts 1...5. The
options are Slotted, Oversized,
Tapped, No hole, and Regular.

Category: Weld

Use the Weld property to filter welds (page 359) based on their common
properties.

Property Description
Size above line

Size below line

To filter welds based on their size. For
example, "Weld size above line equals
5.00."

Reference text To filter welds based on their
reference text, which is a user-
definable value in the Weld
properties. For example, "Weld
reference text contains 12345."

Phase To filter welds based on their phase
number. For example, "Weld phase
equals 3."

Type above line

Type below line

To filter welds based on their weld
type (page 367). Select the type from
the Value list.

Length above line

Length below line

To filter welds based on their length
value. For example, "Weld length
greater than 0.00."

Welding site To filter welds based on where they
should be made. The options are Site
and Workshop.

Position number To filter welds based on their unique
position number. For example, "Weld
position number is greater than 100."
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Property Description
Angle above line

Angle below line

To filter welds based on the angle of
weld preparation, bevels, or groove.
For example, "Weld angle below line
greater than 0.000."

Contour above line

Contour below line

To filter welds based on their fill type
contour. The options are None,
Flush, Convex, and Concave. For
example, "Weld contour above line
does not equal None."

Effective throat above line

Effective throat below line

To filter welds based on their weld
size used in weld strength calculation.
For example, "Weld effective throat
above line equals 0.500."

Finish above line

Finish below line

To filter welds based on how they
have been treated. The options are
None, Grind, Machine, Chip,
Finished weld, and Smooth
transition.

Increment amount above line

Increment amount below line

To filter welds based on their amount
of increments. For example, "Weld
increment amount above line greater
than 0."

Intermittent type To filter welds based on their shape.
The options are Continuous,
Intermittent, and Staggered
intermittent.

Pitch above line

Pitch below line

To filter welds based on their spacing
of weld increments.

Root face thickness above line

Root face thickness below line

To filter welds based on their root
face thickness, in other words, the
height of the narrowest part inside
the root opening.

Root opening above line

Root opening below line

To filter welds based on the space
found between the welded parts.

Size prefix above line

Size prefix below line

To filter welds based on their weld
size prefix. For example, "Weld size
prefix above line equals a."

The standard ISO 2553 prefixes are a
(Design throat thickness), s
(Penetration throat thickness), and z
(Leg length).
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Property Description
User defined cross-section To filter welds based on whether or

not they contain user-defined cross-
sections. The options are Yes and No.

Electrode classification To filter welds based on their weld
electrode classification. The options
are (empty), 35, 52, 50, E60XX, E70XX,
E80XX, and E90XX.

Electrode strength To filter welds based on their
electrode strength. For example,
"Weld electrode strength greater than
0.000."

Electrode coefficient To filter welds based on their
electrode coefficient.

Process type To filter welds based on their welding
process type. The options are SMAW,
SAW, GMAW, FCAW, ESW, and EGW.

NDT inspection To filter welds based on their non-
destructive testing and inspection
level. The options are A, B, C, D, and
E.

Is around weld To filter welds based on whether only
one edge or the entire perimeter of a
face is welded. No = edge, Yes =
around.

Category: Reinforcing bar

Use the Reinforcing bar category to filter reinforcing bars (page 496) based on
their common properties.

Property Description
Name To filter reinforcing bars based on

their name. For example, "Reinforcing
bar name equals "STIRRUP"."

Class To filter reinforcing bars based on
their class number. For example,
"Reinforcing bar class equals 3."

Size To filter reinforcing bars based on
their size. The size property depends
on the environment and may contain
letters and special characters. For
example, in the US imperial
environment, "Reinforcing bar size
equals #18."
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Property Description
Diameter To filter reinforcing bars based on

their diameter. Diameter is the
nominal diameter of the bar, not
actual. For example, "Reinforcing bar
diameter less than 12."

Length To filter reinforcing bars based on
their total length. For example,
"Reinforcing bar length greater than
5000.00."

Material To filter reinforcing bars based on
their material grade. For example,
"Reinforcing bar material does not
equal Undefined."

Prefix To filter reinforcing bars based on
their numbering prefix. For example,
"Reinforcing bar prefix equals R."

Start number To filter reinforcing bars based on
their start number. For example,
"Reinforcing bar start number greater
than 1."

Numbering series To filter reinforcing bars based on
their numbering series information.
For example, "Reinforcing bar
numbering series equals R/1."

Position number To filter reinforcing bars based on
their position number. For example,
"Reinforcing bar position number
equals R/3."

Phase To filter reinforcing bars based on
their phase number. For example,
"Reinforcing bar phase equals 2."

Shape To filter reinforcing bars based on
their bending shape (page 588). For
example, "Reinforcing bar shape does
not equal 2_1."

Layer To filter rebar set bars based on their
bar layer information. For example,
"Rebar set bar layer equals B3" (the
third layer of bottom bars).
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Category: Surface

Use the Surface category to filter surfaces (page 415) based on their common
properties.

Property Description
Name To filter surfaces based on their

name. For example, "Surface name
equals SURFACE."

Type To filter surfaces based on their type.
The options are Formwork and
Concrete finish.

Class To filter surfaces based on their class
number. For example, "Surface class
does not equal 13."

Phase To filter surfaces based on their phase
number. For example, "Surface phase
equals 3 4."

Category: Assembly

Use the Assembly category to filter assemblies, cast units (page 430), and
rebar assemblies (page 614) based on their common properties.

Property Description
Name To filter assemblies and cast units

based on their name. For example,
"Assembly name does not contain
RAFTER."

GUID To filter assemblies based on their
globally unique identifier (GUID). For
example, "Assembly GUID equals
ID89F414A7-
ECA6-4B14-99CB-6985B84E64CB."

Prefix To filter assemblies and cast units
based on their numbering prefix. For
example, "Assembly prefix equals A."

Start number To filter assemblies and cast units
based on their start number. For
example, "Assembly start number
greater than 1."

Position number To filter assemblies and cast units
based on their position number. For
example, "Assembly position number
equals A/13."

Phase To filter assemblies and cast units
based on their phase number. For
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Property Description
example, "Assembly phase does not
equal 1."

Assembly level To filter assemblies and cast units
based on their position in the
assembly hierarchy. The larger the
value, the lower the position in the
assembly hierarchy. 0 is the top-most
level, and 1 is the first sub-assembly
level.

For example, to check if the model
contains sub-assemblies, use the filter
rule "Assembly level greater than or
equal to 1."

Assembly type To filter assemblies and cast units
based on their type.

• 0 = precast

• 1 = cast in place

• 2 = steel

• 3 = timber

• 4 = rebar

• 6 = miscellaneous
Assembly series To filter assemblies and cast units

based on their numbering series
information. For example, "Assembly
series equals C/1."

Category: Construction object

Use the Construction object category to filter construction objects based on
their common properties.

Property Description
Phase To filter construction objects based on

their phase number. For example,
"Construction object phase does not
equal 1."

Type To filter construction objects based on
their type. The options are Line, Arc,
Circle, Plane, and Polycurve.
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Category: Load

Use the Load category to filter loads based on their common properties.

Property Description
Load group To filter loads based on which load

group they belong to. For example,
"Load group does not equal
DefaultGroup."

Load type To filter loads based on their type.
The options are line, point, area,
uniform, and temperature.

Note that wind loads are handled as

area loads in filtering. Use the 

Select components and  Select
objects in components selection
switches to select wind loads.

Phase To filter loads based on their phase
number. For example, "Load phase
does not equal 1."

Category: Template

Use the Template category to filter parts and other objects by using template
attributes.

With this category, you can type the name of any template attribute or user-
defined attribute directly in the Property box, even if it is not on the list. Use
the ASSEMBLY., CAST_UNIT., or POUR_UNIT. prefix in front of the property
name to access higher hierarchy level attributes, and the USERDEFINED.
prefix to access user-defined attributes.

For example, to filter objects that are one hierarchy level below the cast-unit
with the user-defined attribute User field 1, type
CAST_UNIT.USERDEFINED.USER_FIELD_1 in the Property box.

In some cases, you can filter objects based on properties of other objects from
lower hierarchy levels. This is possible when there is only one lower level
object to be accessed. For example, there is only one main part in each
assembly or cast unit, so you can access the main part properties from the
assembly or cast unit level using the MAINPART prefix. Similarly, there can only
be one pour object in each pour unit, so you can access the pour object
properties from the pour unit level using the POUR_OBJECT prefix.

For example, to filter objects in assemblies whose main part has a certain
name, type ASSEMBLY.MAINPART.NAME in the Property box.
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For example, to filter all reinforcing bars belonging to pour units with a certain
pour object type, type POUR_UNIT.POUR_OBJECT.POUR_TYPE in the Property
box.

TIP To check which unit Tekla Structures uses for a particular template
attribute, use the Select from model... option in the Value list in the
filtering dialog box.

Category: Reference assembly

Use the Reference assembly category to filter reference model assemblies
based on their common properties.

Property Description
Creation  
GUID To filter reference model assemblies

based on their globally unique
identifier (GUID). For example,
"Reference assembly GUID equals
IDA51E6BFF-
DAB9-4A56-970C-7486EF17B7B7."

Phase To filter reference model assemblies
based on their phase number. For
example, "Reference assembly phase
equals 2."

Lot To filter reference model assemblies
based on their lot number. For
example, "Reference assembly lot
greater than 1."

Description To filter reference model assemblies
based on their description, which is a
user-definable value in the Reference
object dialog box. For example,
"Reference assembly description
contains "architect model"."

Info text To filter reference model assemblies
based on their info text, which is a
user-definable value in the Reference
object dialog box. For example,
"Reference assembly info text
contains revised."

Locked To filter reference model assemblies
based on whether or not they are
locked. 0 = No, 1 = Yes, 2 =
Organization.

Logical name To filter reference model assemblies
based on their logical name, which is
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Property Description
a user-definable value in the
Reference object dialog box. For
example, "Reference assembly logical
name equals "MEP heating
system"."

Category: Reference object

Use the Reference object category to filter reference model objects based on
their common properties.

Property Description
Creation  
GUID To filter reference model objects

based on their globally unique
identifier (GUID).

Phase To filter reference model objects
based on their phase number. For
example, "Reference object phase
does not equal 1."

Lot To filter reference model objects
based on their lot number. For
example, "Reference object lot equals
1."

Description To filter reference model objects
based on their description, which is a
user-definable value in the Reference
object dialog box. For example,
"Reference object description
contains "architect model"."

Info text To filter reference model objects
based on their info text, which is a
user-definable value in the Reference
object dialog box. For example,
"Reference object info text contains
revised."

Locked To filter reference model objects
based on whether or not they are
locked. 0 = No, 1 = Yes, 2 =
Organization.

Logical name To filter reference model objects
based on their logical name, which is
a user-definable value in the
Reference object dialog box. For
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Property Description
example, "Reference object logical
name contains "3rd floor"."

TIP You can filter reference model object attributes using the Template
category and the EXTERNAL. prefix in the Property box. For example,
"Reference object EXTERNAL.Material equals A572."

Category: Location breakdown structure

Use the Location breakdown structure category to filter objects based on
their location categories, which can be defined in Organizer.

Property Description
Site To filter objects based on which site

category they belong to. For example,
"Location breakdown structure site
equals "Site 2"."

Building To filter objects based on which
building category they belong to. For
example, "Location breakdown
structure building does not equal
"Building A"."

Section To filter objects based on which
section category they belong to. For
example, "Location breakdown
structure section equals Ramp."

Floor To filter objects based on which floor
they are located on. For example,
"Location breakdown structure floor
equals "Floor 4"."

Category: Pour object

Use the Pour object category to filter pour objects (page 451) based on their
common properties.

Property Description
Pour number To filter pour objects based on their

pour number. For example, "Pour
number equals 5."

Pour type To filter pour objects based on their
type. For example, "Pour type equals
WALL."

Concrete mixture To filter pour objects based on the
properties of their concrete mix, for
example, maximum grain size of

Get to know Tekla Structures basic working
methods

178 Filter objects



Property Description
aggregate, and/or plasticity of fresh
concrete.

Material To filter pour objects based on their
material grade. For example,
"Material equals C35/45 ."

Pour phase To filter pour objects based on their
pour phase. For example, "Pour
phase does not equal 0."

Category: Pour break

Use the Pour break category to filter pour breaks (page 458) based on their
common properties.

Property Description
Creation
ID number To filter pour breaks based on their ID

number. For example, "ID number
equals 25237."

Phase To filter pour breaks based on their
phase. For example, "Pour break
phase equals 2 3."

Pour break type To filter pour breaks based on their
type. For example, "Pour break type
equals "Watertight construction
joint"."

Category: Pour unit

Use the Pour unit category to filter pour units based on their common
properties.

Property Description
Name To filter pour units based on their

name. For example, "Pour unit name
contains beam."

GUID To filter pour units based on their
globally unique identifier (GUID). For
example, "Pour unit GUID contains
8505."
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Category: Task

Use the Task category to filter scheduled tasks based on their common
properties.

Property Description
Name To filter scheduled tasks based on

their name. For example, "Task name
contains floors."

Planned start date To filter scheduled tasks based on
their planned start date. For example,
"Task planned start date earlier than
Review date."

Planned end date To filter scheduled tasks based on
their planned start date. For example,
"Task planned end date later than or
equal to 10/13/2017."

Actual start date To filter scheduled tasks based on
their actual start date.

Actual end date To filter scheduled tasks based on
their actual end date.

Completeness To filter scheduled tasks based on
their completeness. The value is a
percentage. For example, "Task
completeness is 75."

Critical To filter scheduled tasks based on
how critical they are. A task can be
critical only if it has been imported
from external software. 1 = Critical, 0
= Not critical.

Note that this property is not visible
in Task manager.

Local To filter scheduled tasks based on
whether they were created in Task
manager or imported from external
software. 1 = Created in Task
Manager, 0 = Imported.

Contractor To filter scheduled tasks based on the
contractor. For example, "Task
contractor equals "Contractor A"."

Scenario To filter scheduled tasks based on the
scenario they belong to. For example,
"Task scenario equals "Scenario
1"."
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Property Description
Task type To filter scheduled tasks based on

their type. For example, "Task type
does not equal "A - Floor
tiling"."

Wildcards
A wildcard is a symbol that stands for one or more characters. You can use
wildcards to shorten strings, for example in filtering.

Wildcard Description Example
* (asterisk) Matches any number

of characters
HE* matches all parts with a profile name
that begins with the characters "HE".

You can also this symbol at the beginning
of a word: *BRAC*.

? (question
mark)

Matches a single
character

HE?400 matches parts with profile names
such as HEA400, HEB400, and HEC400.

[ ] (square
brackets)

Matches whatever is
enclosed in the
brackets

L[78]X4X1/2 matches parts with the
profile names L7X4X1/2 and L8X4X1/2.

NOTE The characters * and ? may also be used in object names in Tekla Structures. If
the object name you want to filter contains * or ?, you need to enclose these
characters in square brackets. For example, to find the profile P100*10, enter 
P100[*]10 in the filter field.

See also

Filter objects (page 150)

Examples of filters
Here are some examples of filters that you can create. The same filtering
techniques can be used for view, selection, and drawing filters.

Filter parts based on their name
Create a filter that only shows parts with a certain name.

1. Create a new view filter. (page 153)

2. Click Add row three times to add three filter rules.

3. In the first filter rule, define that the object type must be part:
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a. In the Category list, select Object.

b. In the Property list, select Object type.

c. In the Condition list, select Equals.

d. In the Value list, select Part.

e. In the And/Or list, select And.

4. In the second and third filter rules, define that the part name must be
BEAM or COLUMN:

a. In the Category list, select Part.

b. In the Property list, select Name.

c. In the Condition list, select Equals.

d. In the Value box, enter the part names, BEAM and COLUMN.

e. In the And/Or list, select Or.

5. Include the second and third filter rule in brackets. The filter is now
looking for parts that are named either BEAM or COLUMN.

6. Enter a unique name in the box next to the Save as button.

7. Click Save as. 

Filter main parts
Create a filter that selects the main parts only.

1. Create a new selection filter. (page 153)

2. Click Add row twice to add two filter rules.

3. In the first filter rule, define that the object type must be part:

a. In the Category list, select Object.

b. In the Property list, select Object type.

c. In the Condition list, select Equals.

d. In the Value list, select Part.

e. In the And/Or list, select And.

4. In the second filter rule, define that you only want to include main parts:

a. In the Category list, select Part.
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b. In the Property list, select Primary part.

c. In the Condition list, select Equals.

d. In the Value box, enter 1. 

In this context, 1 means the main parts, and 0 would mean the
secondary parts.

5. Enter a unique name in the box next to the Save as button.

6. Click Save as. 

Filter bolts based on their size
Create a filter that only shows bolts of certain sizes.

1. Create a new view filter. (page 153)

2. Click Add row twice to add two filter rules.

3. In the first filter rule, define that the object type must be bolt:

a. In the Category list, select Object.

b. In the Property list, select Object type.

c. In the Condition list, select Equals.

d. In the Value list, select Bolt group.

e. In the And/Or list, select And.

4. In the second filter rule, define that the bolt size must be 12.00 or 16.00:

a. In the Category list, select Bolt.

b. In the Property list, select Size.

c. In the Condition list, select Equals.

d. In the Value box, enter the bolt sizes, 12.00 and 16.00. 

Separate the strings with a blank space.

5. Enter a unique name in the box next to the Save as button.

6. Click Save as. 
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Filter parts based on their assembly type
Create a filter based on assembly types. For example, you can create a filter
that only shows cast-in-place and precast columns. Steel columns and any
other columns or parts are hidden. The same filtering technique can be used
for steel, concrete, timber, and miscellaneous parts.

1. Create a new filter. (page 153)

2. Click Add row four times to add four filter rules.

3. In the first filter rule, define that the object type must be part:

a. In the Category list, select Object.

b. In the Property list, select Object type.

c. In the Condition list, select Equals.

d. In the Value list, select Part.

e. In the And/Or list, select And.

4. In the second filter rule, define that the part name must be COLUMN:

a. In the Category list, select Part.

b. In the Property list, select Name.

c. In the Condition list, select Equals.

d. In the Value box, enter the part name, COLUMN.

e. In the And/Or list, select And.

5. Include the first and second filter rule in brackets.

6. In the third and fourth filter rules, define that the assembly type must be
precast or cast in place:

a. In the Category list, select Assembly.

b. In the Property list, select Assembly type.

c. In the Value box, enter the assembly types, 0 and 1. 

Value Assembly type
0 precast
1 cast in place
2 steel
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Value Assembly type
3 timber
4 rebar
6 miscellaneous

d. In the And/Or list, select Or.

7. Include the third and fourth filter rule in brackets. The filter is now looking
for concrete parts that are named COLUMN.

8. Enter a unique name in the box next to the Save as button.

9. Click Save as. 

Filter sub-assemblies
Create a filter that only selects parts that belong to a sub-assembly.

1. Create a selection filter. (page 153)

2. Click Add row to add a new filter rule.

3. In the Category list, select Template.

4. In the Property list, select ASSEMBLY.HIERARCHY_LEVEL.

5. In the Condition list, select Does not equal.

6. In the Value box, enter 0. 

In this context, 0 means that the part does not belong to any sub-
assembly, and 1 would mean that the part does. The filter will show only
those parts whose value is not 0.

7. Enter a unique name in the box next to the Save as button.

8. Click Save as. 
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Filter objects based on their class
Create a filter based on object types and class. The following example filter can
be used to select or show parts and reinforcement in certain classes.

1. Create a new view filter. (page 153)

2. Click Add row three times to add three filter rules.

3. In the first and second filter rules, define that the object type must be part
or reinforcement.

a. In the Category list, select Object.

b. In the Property list, select Object type.

c. In the Condition list, select Equals.

d. In the Value list, select Part for the first rule and Reinforcing bar for
the second rule.

e. In the And/Or list, select Or for the first rule and And for the second
rule.

4. Include the first and second filter rule in brackets.

5. In the third filter rule, use the template attribute CLASS_ATTR to define
that the object class must be less than or equal to 5:

a. In the Category list, select Template.

b. In the Property list, type CLASS_ATTR.

c. In the Condition list, select Less or equal.

d. In the Value list, enter 5.

The filter is now looking for parts and reinforcement that belong to
classes 0–5.

6. Enter a unique name in the box next to the Save as button.

7. Click Save as. 

Filter reference model objects
Create a filter based on reference model object properties.

1. Create an empty view or selection filter. (page 153)

2. Click Add row to add a new filter rule.

3. In the Category list, select Template.

4. In the Property list, select the desired template attribute or enter one of
your own (page 164). 
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TIP To find the attribute name used by the reference model, select a
reference model object, right-click and select one of the Inquire
commands. Find the property name in the Inquire object dialog box
and copy it.

5. Add the prefix EXTERNAL. in front of the template attribute name.

6. In the Condition list, select Equals.

7. In the Value box, enter the desired value or click Select from model... to
select the object in the model.

8. Enter a unique name in the box next to the Save as button.

9. Click Save as. 

Filter parts within component
Create a filter that selects all parts within a component.

1. Create an empty selection filter. (page 153)

2. Click Add row twice to add two filter rules.

3. In the first filter rule, define that the object must be a component:

a. In the Category list, select Object.

b. In the Property list, select Is component.

c. In the Condition list, select Equals.

d. In the Value list, select Yes.

e. In the And/Or list, select And.

4. In the second filter rule, define that the object type must be part:

a. In the Category list, select Object.

b. In the Property list, select Object type.

c. In the Condition list, select Equals.

d. In the Value list, select Part.

5. Enter a unique name in the box next to the Save as button.

6. Click Save as. 
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Filter reinforcement in pour units based on pour object type
Create a filter that only shows all reinforcement that belongs to pour units
with a pour object of a certain type.

1. Ensure that you have XS_ENABLE_POUR_MANAGEMENT set to TRUE.

2. Calculate the pour units. (page 453)

3. Create a new view filter. (page 153)

4. Click Add row twice to add two filter rules.

5. In the first filter rule, define the pour object type.

a. In the Category list, select Template.

b. In the Property box, enter POUR_UNIT.POUR_OBJECT.POUR_TYPE.

c. In the Condition list, select Equals.

d. In the Value box, enter the pour object type, for example MyType, or
click Select from model... to select the object in the model.

e. In the And/Or list, select And.

6. In the second filter rule, define that the object type must be
reinforcement:

a. In the Category list, select Object.

b. In the Property list, select Object type.

c. In the Condition list, select Equals.

d. In the Value list, select Reinforcing bar.

7. Enter a unique name in the box next to the Save as button.

8. Click Save as. 

Filter all contents of a pour unit
Create a filter that selects all contents of a pour unit with a certain name.

1. Ensure that you have XS_ENABLE_POUR_MANAGEMENT set to TRUE.

2. Calculate the pour units. (page 453)
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3. Create a selection filter. (page 153)

4. Click Add row to add a new filter rule.

5. In the Category list, select Pour unit.

6. In the Property list, select Name.

7. In the Condition list, select Equals.

8. In the Value box, enter the pour unit name, for example MyName.

9. Enter a unique name in the box next to the Save as button.

10. Click Save as. 

Copy and remove filters
You can copy custom filters to another model by manually copying filter files to
the attributes folder under the desired model folder. You can also manually
remove unneeded filters from the same folder. If you want to make a filter
available in all models, copy the file to your company's project or firm folder.

Copy a filter to another model
1. Select the filter you want to copy. 

The filters you have created are located in the attributes folder under
the current model folder. You can recognize different filter types based on
their file name extension:

File name extension Filter type
.VObjGrp Model view filter
.SObjGrp Model selection filter
.PObjGrp Object group filter
.vf Drawing view filter
.vnf Drawing view level neighbor part filter
.wdf Single-part drawing filter
.wdnf Single-part drawing neighbor part

filter
.adf Assembly drawing filter
.adnf Assembly drawing neighbor part filter
.cuf Cast unit drawing filter
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File name extension Filter type
.cunf Cast unit drawing neighbor part filter
.gdf General arrangement drawing filter
.gdnf General arrangement drawing

neighbor part filter
.dsf Drawing selection filter

2. To make the filter available in another model, copy the file to the
attributes folder of the destination model folder.

3. To make the filter available in all models, copy the file to your company's
project or firm folder.

4. Restart Tekla Structures.

Remove a filter
1. Remove the filter file from the model’s attributes folder.

2. Restart Tekla Structures.

Select values from the model
You can select object properties and dates directly from the model. This can be
useful when creating view filters, selection filters, and object groups.

Before you start, create an empty view or selection filter, or an object group.

1. Create an empty view or selection filter (page 153), or an object group
(page 662).

2. Click Add row.

3. Select options from the Category and Property lists.

4. In the Value list, select one of the options. 

The availability of options depends on your selection in the Property list.
You can select dates from the model only if the property is a date.

a. To select an object property, click Select from model... and then
select an object.

b. To select a date, click Select date... to open the Select Date dialog
box, and then select one of the options. 

You can either select a date from the calendar, select the review date,
or define the number of days before or after the review date. The
review date is the same as Review date in the Project Status
Visualization dialog box.
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1.9 Tips for large models

Modeling item Tips
Coordinate system (page 51) • Do not place the model far away

from the origin. The further away
from the origin you model, the
less precise all the computations
become.

• Mark global coordinates as labels
instead of actually using them
during modeling.

• If you need to use building site
coordinates, drop the first digits if
they are always the same. For
example, instead of coordinate
758 375 6800, use 375 6800.

• Base points allow you to use
another coordinate system
needed for interoperability and
collaboration. You can use another
coordinate system for inserting
reference models and exporting
IFC models. When you use base
points, you can keep the
coordinates small and locate the
model wherever needed. You can
create as many base points as you
need, and select one of those to
be the project base point. For
more information, see Base points
(page 57).

Work area (page 48) and visibility • Keep the work area as small as
possible.

• Show only the required parts in
views.

• Use view filters to control the
visibility of parts.

Views (page 31) • Close unnecessary views.

• Close all views when you save
large models.

Selection switches • Switch on the Select reference
models selection switch only
when necessary. The speed of
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Modeling item Tips
zooming and rotating may be
affected by this switch especially in
large and complicated models that
contain reference models.

Round objects • Create holes with the Create bolts
command instead of using part
cuts with round beams.

• Use studs to model small straight
round objects instead of small
round beams.

• Model lifting hooks and other
embeds with reinforcement bars
instead of round polybeams.

Hollow core profiles • Use simple fixed (non-parametric)
profiles.

• Use chamfers for curved corners.
Custom components (page 823) • Do not create overly complex

custom components. When used
in great numbers they consume a
lot of memory.

Numbering (page 712) • Do not number the whole model
in one go. Numbering all objects in
large models may take a
considerable amount of time.

Model database • If your model file is getting large,
repairing the model database can
help to reduce the file size
considerably and therefore help
with memory problems.

Firm and Project folders • Save Firm and Project folders
locally on the hard drive of your
computer instead of a network
drive. This saves time if network
speed is slow.

When working in the multi-user
mode, ensure that the folders are
synchronized on all users’ hard
drives so that important data is
not lost or changed.
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1.10 Create model templates
Model templates allow you to start a model with predefined company
templates and settings. This can be especially useful for sub-contractors.

Only single-user models can be created with model templates. If you wish to
create a multi-user model using a model template, create the model in single-
user mode and then switch to multi-user mode.

By default, the model template folder is saved in your environment folder. Use
the advanced option XS_MODEL_TEMPLATE_DIRECTORY to define a different
location.

Create a new model template
You can create your own model templates and use them for creating new
models. You can select which catalogs, custom components, model subfolders,
drawing templates, and report templates from the model are included in the
model template.

1. Create a new model. 

Always start by creating a new empty model. This is because old models
that have been used in live projects cannot be completely cleaned. They
may contain excess information that increases the size of the model even
if you delete all objects and drawings from the model.

2. Add the desired part properties, drawing properties, profiles, materials,
custom components, sketches, and so on, in the model. 

You can copy the needed attribute files from another model, for example.

3. On the File menu, click Save as --> Save. 

You need to save the model to include custom components in the
xslib.db1 file. If you do not save the model, custom components will not
be included in the model template.

4. On the File menu, click Save as --> Save as model template.

5. Enter a name for the model template.

6. Select which catalogs, drawing templates, report templates, and model
subfolders to include in the model template. 

You can only select files and folders that are available in the model folder.
Catalogs are typically located in an environment folder and they are
included in the model folder only if they have been modified.

7. If you want to open the destination folder after creating the model
template, select the check box.

8. Click OK. 

You can now use the model template for creating new models.
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9. When you create new models in File --> New, you can mark the important
model templates as favorites, or hide the templates that you do not need. 

a. Select a model template in the list.

b. Right-click and select Favorite or Hidden.

If you marked a template as Favorite, it is placed on top of the
template list. Alternatively, use the star icon on the template to mark
it as Favorite, or to remove the marking.

If you marked a template as Hidden, it is removed from the template
list. Select the Show hidden items check box to show it again.

Modify an existing model template
To modify an existing template, save the model as a new template.
Alternatively, you can modify the template by copying new or updated files
directly to the model template folder.

1. Create a model using the existing model template.

2. Make the needed changes.

3. Save it as a new model template.

Download model templates
You can download, share, and store model templates using Tekla Warehouse.

Model template options
Use the Save as model template dialog box to define which files and folders
are included in the model template.

Setting Files and folders included
Profiles profdb.bin

profitab.inp
Materials matdb.bin
Components and sketches ComponentCatalog.txt

ComponentCatalogTreeView.txt
xslib.db1
thumbnail_bitmap.arc
*.dat files

CustomComponentDialogFiles
folder
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Setting Files and folders included
Attribute definitions Includes all attribute definitions of the

current model.
Bolts and bolt assemblies screwdb.db

assdb.db
Reinforcement rebar_database.inp

RebarShapeRules.xml
rebardatabase_config.inp
rebardatabase_schedule_config
.inp

Meshes mesh_database.inp
Options Includes all options of the current

model.
Drawing templates *.tpl files
Report templates *.rpt files
Include model subfolders Lists all subfolders found in the

model folder. The selected folders are
included in the model template.

The attributes folder, which
contains part and drawing properties,
and the
CustomComponentDialogFiles
folder are included by default.
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2 Create parts, reinforcement,
and construction objects

When you know the basic principles of how to create and modify different
types of model objects in Tekla Structures, you can start working on more
detailed level with your model.

First, to get your model started, you need to create some parts (page 196).
Parts are the building blocks of the physical model. You can continue working
with the parts by, for example, deforming their shape (page 328), or by adding
some details to the parts (page 341), such as bolts, welds, or cuts or fittings.

When you use a workshop weld or bolt to join parts together, you will learn
how to work with assemblies.

For concrete parts, each concrete part is considered a separate cast unit
(page 430). For construction purposes, you may need to merge several
concrete parts into one cast unit. If you model cast-in-place concrete
structures, you may need to check how to work with pours (page 444). And
once you have created a model of concrete parts, you will need to reinforce
the parts (page 469) to gain higher strength for the parts.

Additionally, you may need to use points or construction objects (page 621) as
modeling aids. Points and construction objects help you to place other objects
in the model.

See also

Adjust how model objects are displayed (page 642)

Change the color and transparency of model objects by using object
representation (page 656)

Check the model (page 666)

Number the model (page 712)
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2.1 Create parts and modify part properties
In Tekla Structures, the term part refers to the basic building objects that can
be modeled and detailed further. Parts are the building blocks of the physical
model.

You can create steel parts and concrete parts. A special type of parts are items
(page 300). Use them to model objects that would be difficult to model using
basic Tekla Structures parts and commands, such as cutting.

Create steel parts by using the commands on Steel tab on the ribbon. Create
concrete parts by using the commands on the Concrete tab on the ribbon.

Every part has properties that define it, such as material, profile, and location
(page 310). Also, parts have user-defined attributes (UDAs) (page 323) that you
can use to provide additional information about a part. You can use part
properties in view filters (page 154) and selection filters (page 156) to, for
example, select, modify, and hide parts. You can also include part properties
and UDAs in drawing and report templates.

To view and modify the part properties, use the property pane. You can view
and modify the properties of a one part type at a time, or the common
properties of several, similar part types. If needed, you can copy properties

from one part to another part by using the  Copy properties button in
the property pane.
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The basic steel parts are

• column (page 199)

• beam (page 201)

• polybeam (page 204)

• curved beam (page 207)

• twin profile (page 210)

• orthogonal beam (page 213)

• spiral beam (page 216)

• plate (page 220)

• bent plate (page 224)

• lofted plate (page 247)

The basic concrete parts are

• column (page 260)

• beam (page 260)

• polybeam (page 266)

• spiral beam (page 270)
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• panel (page 275)

• slab (page 278)

• lofted slab (page 282)

• pad footing (page 294)

• strip footing (page 297)

Create a steel column

1. On the Steel tab, click Column .

2. Pick a point. 

Tekla Structures creates the column using the Steel column properties in
the property pane, and at the level defined in the properties.

Alternatively, you can start the command in the property pane.

1. Ensure that you have nothing selected in the model.

2. In the property pane, click the Object type list button  and select
Steel column from the list.

Tekla Structures starts the command and shows the properties in the
property pane.
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Modify steel column properties
1. If the property pane is not open, double-click the column to open the

Steel column properties.

2. Change the properties as needed.

3. Click Modify.

Steel column properties
Use the Steel column properties in the property pane to view and modify the
properties of a steel column. To open the properties, double-click the steel
column. The file name extension of a steel column property file is *.clm.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
Name User-definable name of the column.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile Profile (page 320) of the column.
Material Material (page 322) of the column.
Finish Type of finish.

Finish is user definable. It describes
how the part surface has been
treated, for example, with anti-
corrosive paint, hot galvanized, fire
retardant coating, and so on.

Class Use to group columns.

For example, you can display parts of
different classes in different colors.

Numbering series
Part numbering Part prefix and start number for the

part position number (page 713).
Assembly numbering Assembly prefix and start number for

the assembly position number
(page 713).

Position
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Setting Description
Vertical Vertical position (page 315) of the

column, relative to column's reference
point.

Rotation Rotation (page 313) of the column
around its axis on the work plane.

Horizontal Horizontal position (page 317) of the
column, relative to column's reference
point.

Top Position of the second end of the
column in the global z direction.

Bottom Position of the first end of the column
in the global z direction.

Deforming
Warping Use to warp columns using

deformation angles.
Cambering Use to pre-camber (page 334) the

column.
Shortening Use to shorten the column in the

model. The true length of the column
is decreased in the drawing.

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.

Create a steel beam

1. On the Steel tab, click .
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2. Pick two points. 

Tekla Structures creates the beam between the points you picked, using
the Steel beam properties in the property pane.

Alternatively, you can start the command in the property pane.

1. Ensure that you have nothing selected in the model.

2. In the property pane, click the Object type list button  and select
Steel beam from the list.

Tekla Structures starts the command and shows the properties in the
property pane.

Modify steel beam properties
1. If the property pane is not open, double-click the beam to open the Steel

beam properties.

2. Change the properties as needed.

3. Click Modify.

Steel beam properties
Use the Steel beam properties in the property pane to view and modify the
properties of a steel beam, steel polybeam, or curved beam. To open the
properties, double-click the steel beam. The file name extension of a beam
property file is *.prt.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General

Create parts, reinforcement, and construction
objects

202 Create parts and modify part properties



Setting Description
Name User-definable name of a beam.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile Profile (page 320) of the beam.
Material Material (page 322) of the beam.
Finish Type of finish.

Finish is user definable. It describes
how the part surface has been
treated, for example, with anti-
corrosive paint, hot galvanized, fire
retardant coating, and so on.

Class Use to group beams.

For example, you can display parts of
different classes in different colors.

Numbering series
Part numbering Part prefix and start number for the

part position number (page 713).
Assembly numbering Assembly prefix and start number for

the assembly position number
(page 713).

Position
On plane Beam's position on the work plane

(page 311), relative to the beam's
reference line.

Rotation Rotation (page 313) of the beam
around its axis on the work plane.

At depth Position depth (page 313) of the
beam. The position is always
perpendicular to the work plane.

End offset
Dx Change the length of the beam

(page 318) by moving the beam end
point along the beam's reference line.

Dy Move the beam end (page 318)
perpendicular to the beam's
reference line.

Dz Move the beam end (page 318) in the
z direction of the work plane.
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Setting Description
Curved beam
Plane Plane of curvature.
Radius Radius of the curved beam.
Number of segments Number of segments Tekla Structures

uses when drawing the curved beam.
Deforming
Warping Use to warp beams using

deformation angles.
Cambering Use to pre-camber (page 334) beams.
Shortening Use to shorten beams in the model.

The true length of the beam is
decreased in the drawing.

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.

Create a steel polybeam
A polybeam can contain straight and curved segments.

1. On the Steel tab, click Beam --> Polybeam.

2. Pick the points you want the beam to go through.

3. Click the middle mouse button. 
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Tekla Structures creates the polybeam between the points you picked,
using the Steel beam properties in the property pane. Note that you
cannot create a closed polybeam.

4. If you want to create curved segments, chamfer the corners of the
polybeam. 

For example:

Modify steel polybeam properties
1. If the property pane is not open, double-click the polybeam to open the

Steel beam properties.

2. Change the properties as needed.

3. Click Modify.

Steel beam properties
Use the Steel beam properties in the property pane to view and modify the
properties of a steel beam, steel polybeam, or curved beam. To open the
properties, double-click the steel beam. The file name extension of a beam
property file is *.prt.
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If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
Name User-definable name of a beam.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile Profile (page 320) of the beam.
Material Material (page 322) of the beam.
Finish Type of finish.

Finish is user definable. It describes
how the part surface has been
treated, for example, with anti-
corrosive paint, hot galvanized, fire
retardant coating, and so on.

Class Use to group beams.

For example, you can display parts of
different classes in different colors.

Numbering series
Part numbering Part prefix and start number for the

part position number (page 713).
Assembly numbering Assembly prefix and start number for

the assembly position number
(page 713).

Position
On plane Beam's position on the work plane

(page 311), relative to the beam's
reference line.

Rotation Rotation (page 313) of the beam
around its axis on the work plane.

At depth Position depth (page 313) of the
beam. The position is always
perpendicular to the work plane.

End offset
Dx Change the length of the beam

(page 318) by moving the beam end
point along the beam's reference line.
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Setting Description
Dy Move the beam end (page 318)

perpendicular to the beam's
reference line.

Dz Move the beam end (page 318) in the
z direction of the work plane.

Curved beam
Plane Plane of curvature.
Radius Radius of the curved beam.
Number of segments Number of segments Tekla Structures

uses when drawing the curved beam.
Deforming
Warping Use to warp beams using

deformation angles.
Cambering Use to pre-camber (page 334) beams.
Shortening Use to shorten beams in the model.

The true length of the beam is
decreased in the drawing.

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.

Create a curved steel beam
1. On the Steel tab, click Beam --> Curved beam.

2. Pick the start point (1). 
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3. Pick a point on the arc (2).

4. Pick the end point (3). 

Tekla Structures creates the beam between the points you picked, using
the Steel beam properties in the property pane.

The radius is defined by the points you pick.

Modify curved beam properties
1. If the property pane is not open, double-click the curved beam to open

the Steel beam properties.

2. Change the properties as needed.

3. Click Modify.

Steel beam properties
Use the Steel beam properties in the property pane to view and modify the
properties of a steel beam, steel polybeam, or curved beam. To open the
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properties, double-click the steel beam. The file name extension of a beam
property file is *.prt.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
Name User-definable name of a beam.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile Profile (page 320) of the beam.
Material Material (page 322) of the beam.
Finish Type of finish.

Finish is user definable. It describes
how the part surface has been
treated, for example, with anti-
corrosive paint, hot galvanized, fire
retardant coating, and so on.

Class Use to group beams.

For example, you can display parts of
different classes in different colors.

Numbering series
Part numbering Part prefix and start number for the

part position number (page 713).
Assembly numbering Assembly prefix and start number for

the assembly position number
(page 713).

Position
On plane Beam's position on the work plane

(page 311), relative to the beam's
reference line.

Rotation Rotation (page 313) of the beam
around its axis on the work plane.

At depth Position depth (page 313) of the
beam. The position is always
perpendicular to the work plane.

End offset
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Setting Description
Dx Change the length of the beam

(page 318) by moving the beam end
point along the beam's reference line.

Dy Move the beam end (page 318)
perpendicular to the beam's
reference line.

Dz Move the beam end (page 318) in the
z direction of the work plane.

Curved beam
Plane Plane of curvature.
Radius Radius of the curved beam.
Number of segments Number of segments Tekla Structures

uses when drawing the curved beam.
Deforming
Warping Use to warp beams using

deformation angles.
Cambering Use to pre-camber (page 334) beams.
Shortening Use to shorten beams in the model.

The true length of the beam is
decreased in the drawing.

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.

Create a twin profile
A twin profile consists of two parallel and identical beams. You define the
positions of both beams by selecting the twin profile type and setting the
clearance between the beams in two directions.
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1. On the Steel tab, click Beam --> Twin profile.

2. Pick two points. 

Tekla Structures creates the twin profile between the points you picked,
using the Twin profile properties in the property pane.

Alternatively, you can start the command in the property pane.

1. Ensure that you have nothing selected in the model.

2. In the property pane, click the Object type list button  and select
Twin profile from the list.

Tekla Structures starts the command and shows the properties in the
property pane.

Modify twin profile properties
1. If the property pane is not open, double-click either of the beams to open

the Steel beam properties.

2. Change the properties as needed.

3. Click Modify .

Twin profile properties
Use the Twin profile properties in the property pane to view and modify the
properties of a twin steel profile. The file name extension of a twin profile
property file is *.dia.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General

Create parts, reinforcement, and construction
objects

211 Create parts and modify part properties



Setting Description
Name User-definable name of a twin profile.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile The profile of both the beams in the
twin profile.

Material Material (page 322) of the beams.
Finish Type of finish.

Finish is user definable. It describes
how the part surface has been
treated, for example, with anti-
corrosive paint, hot galvanized, fire
retardant coating, and so on.

Class Use to group twin profiles.

For example, you can display parts of
different classes in different colors.

Twin profile type Define how the profiles are
combined.

Numbering series
Part numbering Part prefix and start number for the

part position number (page 713).
Assembly numbering Assembly prefix and start number the

assembly position number (page 713).
Position
On plane Twin profile's position on the work

plane (page 311), relative to the twin
profile's reference line.

Rotation Rotation (page 313) of the twin profile
around its axis on the work plane.

At depth Position depth (page 313) of the twin
profile. The position is always
perpendicular to the work plane.

End offset
Dx Change the length of the twin profile

(page 318) by moving the twin profile
end point along the twin profile's
reference line.

Clearance between members
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Setting Description
Horizontal The horizontal clearance between the

profiles.
Vertical The vertical clearance between the

profiles.
IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.

Create an orthogonal beam
Use the Orthogonal beam command when you want to create a steel part
that is perpendicular to the current work plane. After you have created an
orthogonal beam, you can modify it as if it were beam or column.

1. On the Steel tab, click Beam --> Orthogonal beam.
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2. Pick a point. 

Tekla Structures creates the beam using the Orthogonal beam properties
in the property pane, and at the level (page 327) defined in the properties.

Alternatively, you can start the command in the property pane.

1. Ensure that you have nothing selected in the model.

2. In the property pane, click the Object type list button  and select
Orthogonal beam from the list.

Tekla Structures starts the command and shows the properties in the
property pane.

Modify orthogonal beam properties
1. If the property pane is not open, double-click the orthogonal beam to

open the properties.

2. Change the properties as needed.

3. Click Modify.

Orthogonal beam properties
Use the Orthogonal beam properties in the property pane to view and modify
the properties of an orthogonal steel beam. The file name extension of an
orthogonal beam property file is *.crs.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
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Setting Description
Name User-definable name of the beam.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile Profile (page 320) of the beam.
Material Material (page 322) of the beam.
Finish Type of finish.

Finish is user definable. It describes
how the part surface has been
treated, for example, with anti-
corrosive paint, hot galvanized, fire
retardant coating, and so on.

Class Use to group beams.

For example, you can display parts of
different classes in different colors.

Position
Vertical Vertical position (page 315) of the

beam, relative to beam's reference
point.

Rotation Rotation (page 313) of the beam
around its axis on the work plane.

Horizontal Horizontal position (page 317) of the
beam, relative to beam's reference
point.

Top Position of the second end of the
beam in the global z direction.

Bottom Position of the first end of the beam
in the global z direction.

Numbering series
Part numbering Part prefix and start number for the

part position number (page 713).
Assembly numbering Assembly prefix and start number the

assembly position number (page 713).
IFC Export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. TheSubtype (IFC4)
User-defined type (IFC4)
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Setting Description
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.

Create a steel spiral beam
Use the Create steel spiral beam command when you want to model spiral
staircases and complex architectural shapes, for example.

Basic concepts related to spiral beams
The images below illustrate some basic concepts related to the creation of
spiral beams. Note that if you change the positioning, the entire geometry of
the spiral beam changes.

(1) Start point (the first point picked)

(2) Center point (the second point picked)

(3) Direction of the rotation axis (the optional third point picked)

(4) Center axis
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(5) Total rise: the distance from the start point to the end point, parallel to the
center axis

(6) Rotation angle: the rotation angle of the spiral beam, given in degrees.
Note: positive value = counter-clockwise rotation, negative value = clockwise
rotation.

(7) Radius: the distance from the start point to the center point, perpendicular
to the center axis

Create a spiral beam
1. On the Steel tab, click Beam --> Spiral beam.

2. Pick the start point. 

3. Pick the center point. 

4. To set the rotation axis in the work plane +Z direction, click the middle
mouse button to finish. 

NOTE Alternatively, instead of clicking the middle mouse button, you
can pick a second center axis point to define the direction of the
rotation axis.

Tekla Structures creates the spiral beam. For example:
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5. Click the spiral beam to select it. 

The contextual toolbar appears with the following options:

(1) Rotation angle

(2) Total rise

(3) Twist angle at start

(4) Twist angle at end

6. To add more rotation, enter a bigger value in the Rotation angle box.

7. To make the spiral more loose, enter a bigger value in the Total rise box.

8. To change the radius, move the start point or center point.

Limitations
• Spiral beam has a single, constant radius.

• Unfolding of spiral beams whose total rise is larger than 0.00 does not
produce completely straight results in drawings. The amount of deviation in
the part profile outlines and part length depends on several factors: the
type, size, and length of the profile; the amount of total rise; and the
amount of rotation angle and detailing used.

• Spiral beams are not always untwisted in unfolding. If unequal twisting is
applied to the start end and end end, the unfolded drawing shows an
unfolded but twisted part as a result.

• Connections and details may not work as expected with spiral beams.

• DSTV export of spiral beams may not produce a correct result.
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• You cannot export spiral beams as parts in IFC export. If you are modeling
cast-in-place structures with spiral beam, you can export the geometry to
IFC as pour objects.

Steel spiral beam properties
Use the Steel spiral beam properties in the property pane to view and modify
the properties of a steel spiral beam. To open the properties, double-click the
spiral beam. The file name extension of a steel spiral beam property file is
*.sb.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
Name User-definable name of a beam.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile Profile (page 320) of the beam.
Material Material (page 322) of the beam.
Finish Type of finish.

Finish is user-definable. It describes
how the part surface has been
treated.

Class Use to group beams.

For example, you can display parts of
different classes in different colors.

Numbering series
Part numbering Part prefix and start number for the

part position number (page 713).
Assembly numbering Assembly prefix and start number for

the assembly position number
(page 713).

Position
On plane Beam's position on the work plane

(page 311), relative to the beam's
reference line.

Rotation Rotation (page 313) of the beam
around its axis on the work plane.
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Setting Description
At depth Position depth (page 313) of the

beam. The position is always
perpendicular to the work plane.

Geometry
Rotation angle Rotation angle of the spiral beam,

given in degrees.
Total rise Distance from the start point to the

end point, parallel to the center axis.
Twist angle at start

Twist angle at end

Twist +/- angle of the spiral beam at
the start/end of the beam.

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.

Create a contour plate
When you create a contour plate, the profile you select defines the thickness
of the plate and the points you pick define the shape. The corners of the
contour plate can be chamfered.

1. On the Steel tab, click .

2. Pick the corner points of the contour plate.
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3. Click the middle mouse button. 

Tekla Structures creates the plate using the Contour plate properties in
the property pane.

Alternatively, you can start the command in the property pane.

1. Ensure that you have nothing selected in the model.

2. In the property pane, click the Object type list button  and select
Contour plate from the list.

Tekla Structures starts the command and shows the properties in the
property pane.

Create a round contour plate
1. Create a square contour plate with four equal sides.

2. Select the plate.

3. Double-click a handle. 

To make it easier to select the handles of the contour plate corners,

ensure that the Direct modification switch  is not active.

The Corner chamfer properties open in the property pane.

4. In the Type list, select Rounding .

5. In the Radius box, enter the chamfer radius. 

The radius must be equal to half of the side of the square.

6. Click Modify.

7. Repeat the above steps for each corner you want to chamfer. 
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Alternative way of creating a round plate

1. Create a diamond-shaped plate with four equal sides.

2. To round the corners, use the Arc point  chamfer type.

Modify contour plate properties
1. If the property pane is not open, double-click the plate to open the

Contour plate properties.

2. Change the properties as needed.

3. Click Modify.

Contour plate properties
Use the Contour plate properties in the property pane to view and modify the
properties of a contour plate. To open the properties, double-click the contour
plate. The file name extension of a contour plate property file is *.cpl.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
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Setting Description
Name User-definable name of the contour

plate.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile Profile (page 320) of the contour
plate.

Material Material (page 322) of the contour
plate.

Finish Type of finish.

Finish is user definable. It describes
how the part surface has been
treated, for example, with anti-
corrosive paint, hot galvanized, fire
retardant coating, and so on.

Class Use to group contour plates.

For example, you can display parts of
different classes in different colors.

Numbering series
Part numbering Part prefix and start number for the

part position number (page 713).
Assembly numbering Assembly prefix and start number the

assembly position number (page 713).
Position
At depth Position depth (page 313) of the

contour plate. The position is always
perpendicular to the work plane.

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)

More
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Setting Description
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.

Create a conical or a cylindrical bent plate
You can create cylindrical or conical bent steel plates either by selecting two
parts or two part faces. The parts that you use for creating a bent plate must
be contour plates, or beams whose profile is a plate (for example, PL200*20).
Position the parts so that there is some room on both sides, so that Tekla
Structures can create a curved section between them.

After creating a cylindrical or conical bent plate, the individual parts no longer
exist in the model. The bent plate gets its properties and coordinates from the
first part that you selected when creating the bent plate. The first part is the
main section of the bent plate. You can later change the main section, if
needed.

Limitations

• Only the side faces of the part can be used for creating a bent plate.

• Chamfered or cut faces cannot be used for creating a bent plate.

• Curved beams and deformed parts cannot be used for creating a bent
plate.

• Details (such as bolts, welds, cuts, chamfers, and preparations) in simple
cases are supported on the curved section of the bent plate.

In addition to the cylindrical and conical bent plates, you can also create stand-
alone bent plates (page 240) which do not require any input parts.

Create a cylindrical bent plate
You can create a cylindrical bent plate by selecting two steel parts or two part
faces. Cylindrical bent plate has a radius that you can modify. The bent plate
properties, such as the ID, thickness, class, and material of the plate, are
determined by the first part you select.

You can create cylindrical bent plates also when the selected parts are
intersecting.

1. On the Steel tab, click Plate --> Create cylindrical bent plate .

2. On the bent plate toolbar, select whether you want to create the bent
plate by selecting parts or by selecting part faces. 
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Additionally, you can enter the radius of the cylindrical bent plate. If no
radius is entered, Tekla Structures creates the bent plate using the default
radius.

• If you selected By parts:

a. Select the first part.

b. Select the second part.

Tekla Structures creates the cylindrical bent plate.
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• If you selected By faces:

a. Select the first part face.
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b. Select the second part face.

Tekla Structures creates the cylindrical bent plate.

Create a conical bent plate
You can create a conical bent plate by selecting two steel parts or two part
faces. Conical bent plate has two radiuses that you can modify. The bent plate
properties, such as the ID, thickness, class, and material of the plate, are
determined by the first part you select.

To be able to create conical bent plates, the selected parts or part faces need
to be of a shape that creating a conical bent plate is possible. If the selected
parts or part faces are such that creating a cylindrical bent plate is possible, a
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cylindrical bent plate is created. You can create different shapes of conical
bent plates: inward bend, outward bend, or with 180 degrees opening angle.

1. On the Steel tab, click Plate --> Create conical bent plate .

2. On the bent plate toolbar, select whether you want to create the bent
plate by selecting parts or by selecting part faces. 

You can enter two radiuses for the conical bent plate. If no radiuses are
entered, Tekla Structures creates the bent plate using the default radiuses.

• If you selected By parts:

a. Select the first part.

b. Select the second part.
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c. Tekla Structures creates the conical bent plate.

• If you selected By faces:

a. Select the first part face.
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b. Select the second part face.

c. Tekla Structures creates the conical bent plate.

Modify the bend radius
When you create a cylindrical bent plate, you can enter a radius for the plate.
For a conical bent plate you can enter two radiuses. If you do not enter any
radius, Tekla Structures uses a default bend radius when creating bent plates.
You can later change the bend radius to suit your needs.

1. Ensure that  Direct modification is switched on.

2. Select the bent plate. 
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A blue line handle appears in the middle of the curved section.

3. Select the line handle. 

Depending on the type of the bent plate, one (for cylindrical bent plate) or
two (for conical bent plate) blue dimension arrows appear.

• For cylindrical bent plate:
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• For conical bent plate:

4. To modify the radius, do one the following: 

• Drag the arrow or arrows forward or backward along the magenta line.

The dimension "r =" changes accordingly. When you release the arrow,
the radius also changes in the model.

• On the contextual toolbar, enter the radius or the radiuses.

• Alternatively, you can select the arrow and type a dimension. When
you start typing, Tekla Structures displays the Enter a Numeric
Location dialog box. Click OK to confirm the dimension.

Modify the shape of a bent plate
When you create a bent plate, Tekla Structures adds a curved section between
the parts you select. You can modify the curved section by choosing one of the
predefined options or by modifying the shape manually. You can also modify
the flat sections, which are the original parts the bent plate was made of.

1. Ensure that  Direct modification is switched on.
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2. Select the bent plate. 

A blue line handle appears in the middle of the curved section.

3. Select the line handle. 

A contextual toolbar appears.

4. On the contextual toolbar, select one of the predefined shape options: 

Option Description Example

Tapered bend A gradual decrease in
the width between the
parts.

This is the default shape.

Narrow bend Constant width between
the parts. The width is
determined by the
narrowest part.

Wide bend Constant width between
the parts. The width is
determined by the
widest part.

5. To modify the curved section manually:

a. Select the blue line handle. 
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You can modify the side boundaries or the lateral boundaries of the
bends both in the cylindrical and in the conical bent plate. Tekla
Structures displays the boundary handles in blue:

b. Drag the handles to change the shape of the curved section. 

For example:

6. To modify the flat sections:
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a. Select the bent plate. 

Tekla Structures displays a green selection handle in the middle of
each flat section:

b. Click the selection handle of the section you want to modify. 

The direct modification handles of the selected section become
visible:

c. Use the direct modification handles to change the shape of the flat
section.

7. To modify the angle of the bent plate:

a. Click the green selection handle in the middle of the flat section
whose angle you want to modify.

b. Select the line handle. 

A contextual toolbar appears.

c. On the contextual toolbar, click  Enable angle manipulator. 
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The angle manipulator wheel appears in the model.

d. Modify the angle using the wheel. 

If you want to modify the angle of another flat section, click the other
green selection handle.

8. To change the main section of the bent plate:

a. Click the green selection handle of the section that you want to set as
the main section. 

A contextual toolbar appears.

b. On the contextual toolbar, click  Set main section. 

The direct modification handles become active in the new main
section. The main section and the coordinate system of the bent plate
change accordingly, changing the bent plate orientation in an
unfolded drawing.

Remove curved sections
You can return bent plates into individual objects, and then edit and use them
as any other model object. If the bent plate consists of several curved sections
that are all joined to the same part, you can either remove each curved section
separately or explode the entire bent plate all at once.

To Do this
To remove individual
curved sections

1.
Ensure that  Direct modification is
switched on.

2. Select the curved section you want to remove.

A blue line handle appears.

3. Select the line handle.

A contextual toolbar appears.

4.
On the contextual toolbar, click  Remove
bend.
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To Do this
Tekla Structures removes the selected curved
section. For example:

To explode the entire
bent plate

1. Select one of the curved sections.

2. Right-click and select Explode.

Tekla Structures explodes the entire bent plate
into individual objects. For example:

If the bent plate solids that have been created using a previous version of
Tekla Structures seem to be broken, you can remove or explode the bends.
Then remodel the bends using the Create cylindrical bent plate command.

Examples
Here are some examples of bent plates that you can create:
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Starting point End result

Modify bent plate properties
1. If the property pane is not open, double-click the bent plate to open the

Bent plate properties.

2. Change the properties as needed.

3. Click Modify.

Bent plate properties
Use the Bent plate properties in the property pane to view and modify the
properties of a bent plate. To open the properties, double-click the bent plate.
The file name extension of a bent plate property file is *.bpl.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
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Setting Description
Name User-definable name of the plate.

The name can contain a maximum of 61
characters.

Tekla Structures uses part names in reports and in
Document manager, and to identify parts of the
same type.

Profile Profile (page 320) of the plate.
Material Material (page 322) of the plate.
Finish Type of finish.

Finish is user definable. It describes how the part
surface has been treated, for example, with anti-
corrosive paint, hot galvanized, fire retardant
coating, and so on.

Class Use to group plates.

For example, you can display parts of different
classes in different colors.

Numbering series
Part numbering Part prefix and start number for the part position

number (page 713).
Assembly numbering Assembly prefix and start number for the assembly

position number (page 713).
IFC export
IFC entity For IFC export, select the IFC entity type and

subtype of the part. The available subtypes depend
on the selected IFC entity.

You can select the IFC4 subtype among the
predefined options, or you can select
USERDEFINED and then enter any text in User-
defined type (IFC4).

Subtype (IFC4)
User-defined type
(IFC4)

More
UDAs Click the User-defined attributes button to open

the user-defined attributes (page 323) (UDAs) of
the part. UDAs provide additional information
about the part.

Create a stand-alone bent plate
You can create stand-alone bent plates which do not require any input parts to
be selected. Use stand-alone bent plates to model cylindrical and conical parts,
such as hoods, hoppers, cones, and so on.
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Limitations

• Tekla Structures does not support full 360 degree stand-alone bent plates.
However, you can create 359 degree plates instead.

• Use the local coordinate system in drawing creation.

In addition to the stand-alone bent plates, you can also create cylindrical and
conical bent plates (page 224) either by selecting two parts or two part faces.
The parts that you use for creating a bent plate must be contour plates, or
beams whose profile is a plate.

Create a stand-alone bent plate

1. Ensure that  Direct modification is switched on.

2. On the Steel tab, click Plate --> Create stand-alone bent plate .

3. Define the first radius of the bend: 

a. Pick the center point.

b. Pick the start point for the arc.

c. Pick the end point for the arc.

The picking order defines the up direction. For example, if you create an
arc on the xy plane in the counterclockwise direction, the up direction
points to the positive z axis, according to the right-hand rule (page 53).

4. Pick a point to define the height of the bend. 
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Alternatively, you can enter the height in the bent plate contextual
toolbar.

5. Define the second radius of the bend: 

a. Pick a point based on the preview of the plate.

b. If you want to change the direction of the plate after you have picked
a point, click the left mouse button.

Alternatively, if you want to create a cylindrical bend, click the middle
mouse button. In this case the radius 2=radius 1.
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6. To complete the bent plate creation, click the middle mouse button. 
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Modify the shape of a stand-alone bent plate
Use direct modification dimension values and handles to modify the bent
plate shape.
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• You can change the angle, radiuses and height of the bend by entering new
dimension values.

• You can drag and stretch the edges of the bent plate.
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• You can add and delete intermediate points.

• You can create unfolded drawings of the stand-alone bent plates.

Modify bent plate properties
1. If the property pane is not open, double-click the bent plate to open the

Bent plate properties.

2. Change the properties as needed.

3. Click Modify.

Bent plate properties
Use the Bent plate properties in the property pane to view and modify the
properties of a bent plate. To open the properties, double-click the bent plate.
The file name extension of a bent plate property file is *.bpl.
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If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
Name User-definable name of the plate.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile Profile (page 320) of the plate.
Material Material (page 322) of the plate.
Finish Type of finish.

Finish is user definable. It describes
how the part surface has been
treated, for example, with anti-
corrosive paint, hot galvanized, fire
retardant coating, and so on.

Class Use to group plates.

For example, you can display parts of
different classes in different colors.

Numbering series
Part numbering Part prefix and start number for the

part position number (page 713).
Assembly numbering Assembly prefix and start number for

the assembly position number
(page 713).

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
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Setting Description
part. UDAs provide additional
information about the part.

Create a steel lofted plate
With lofted plates you can create rolled plates with varying shapes and plates
with double-curved form, for example.

Prerequisites and examples of lofted plates
Before you can create lofted plates, you need to have construction objects
(page 621) in your model. Tekla Structures creates the shape of the lofted plate
according to the geometry of the used construction objects, by connecting the
start point of the first construction object to the start point of the second
construction object. The end points of construction objects are connected in
similar way.

You can connect the following construction objects as a lofted plate:

• construction line to construction line

For example:

• construction line to construction arc

For example:
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• construction arc to construction arc

For example:

• construction circle to construction circle

For example:
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• construction polycurve to construction polycurve

Create a lofted plate
1. Create the needed construction objects in the model. The shape of the

lofted plate is based on the construction objects' shape. 

You need to have

• construction lines (page 622)

• construction arcs (page 624)

• construction circles (page 623)

or

• construction polycurves (page 626)

With polycurves, use the Create arc by tangent or Create tangent

line options  on the construction polycurve toolbar. To
create polycurves only with straight segments, use the Create line

option . Note that the construction polycurves do not
need to have the same number of segments, as long as both of them
are tangential.

2. When you have created the needed construction objects, go to the Steel
tab and click Plate --> Create lofted plate.

3. On the toolbar that appears, click a button to specify whether to create
the lofted plate by using two construction objects, or by using a
construction object and a point. 

• Use two construction objects  to create a lofted plate:
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a. Select the first construction object: line, arc, circle, or polycurve.

For example, if you are using two construction circles to create a
lofted plate.

b. Select the second construction object.

Tekla Structures creates the lofted plate between the selected
construction objects, using the Lofted plate properties in the
property pane.
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• Use one construction object and a point  to create a lofted
plate:

a. Select the first construction object: line, arc, circle, or polycurve.

For example, if you are using a construction polycurve and a point
to create a lofted plate.

Tekla Structures shows a preview of the part geometry. Use the
preview to set the direction and size of the lofted plate.
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b. Pick a point.

Tekla Structures creates the lofted plate based on the preview,
using the Lofted plate properties in the property pane.
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Modify the shape of a lofted plate
Use direct modification dimension handles and dimension values to modify
the lofted plate shape.

• Modify, for example, the height and radius of the lofted plate.

• For lines and arcs: drag the arc symbol  at the midpoint of a line or an
arc to modify the lofted plate shape.
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Split a lofted plate
Note that you cannot split closed cylindrical or conical lofted plates.

1. On the Edit tab, click Split.

2. Select the lofted plate you want to split.

3. Pick a point for the dividing line. 

Tekla Structures splits the lofted plate.

For example:
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Swap the end handle points to correct the geometry of a lofted plate
In some cases when you try to create a lofted plate, the geometry of the plate
would become self-intersecting, meaning that the start and end points of the
top and bottom construction object are opposite of each other. In these cases
the plate is not created.

You can try to resolve the situation and create the lofted plate by changing the
modeling direction of the construction lines or arcs.

1. Select the construction line or the construction arc. 

With construction lines, ensure that the Direct modification  switch
is not active. You can then see the yellow and magenta object handles.

Create parts, reinforcement, and construction
objects

255 Create parts and modify part properties



2. On the contextual toolbar, click  Swap ends. 

Tekla Structures changes the modeling direction of the selected
construction object, and the lofted plate can be created correctly.

With construction circles you can try to resolve the situation by moving either
of the circles.

Unfold lofted plates
You can unfold lofted plates in single-part drawings. The unfolding works for
lofted plates which have been created from single geometry to single
geometry, and for tangential polycurve lofted plates.

Examples of unfolded lofted plates created from single geometry to single
geometry:

Examples of tangential polycurve unfolded lofted plates:
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Modify lofted plate properties
1. If the property pane is not open, double-click the lofted plate to open the

Lofted plate properties.

2. Change the properties as needed.

3. Click Modify.

Lofted plate properties
Use the Lofted plate properties in the property pane to view and modify the
properties of a steel lofted plate. To open the properties, double-click the steel
lofted plate. The file name extension of a steel lofted plate property file is
*.lpl.
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If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
Name User-definable name of the lofted

plate.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile Profile (page 320) of the lofted plate.
Material Material (page 322) of the lofted

plate.
Finish Type of finish.

Finish is user definable. It describes
how the part surface has been
treated, e.g. with anti-corrosive paint,
hot galvanized, fire retardant coating,
etc.

Class Use to group lofted plates.

For example, you can display parts of
different classes in different colors.

Numbering series
Part numbering Part prefix and start number for the

part position number (page 713).
Assembly numbering Assembly prefix and start number for

the assembly position number
(page 713).

Face type
Face type Select whether the top and bottom

faces of the plate are flush with the
plane.

Perpendicular:
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Setting Description

The top and bottom faces of the plate
are non-linear.
Bounded by curved planes:

The top and bottom faces of the plate
are planar.

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.
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Create a concrete column

1. On the Concrete tab, click Column .

2. Pick a point. 

Tekla Structures creates the column using the Concrete column
properties in the property pane, and at the level defined in the properties.

Alternatively, you can start the command in the property pane.

1. Ensure that you have nothing selected in the model.

2. In the property pane, click the Object type list button  and select
Concrete column from the list.

Tekla Structures starts the command and shows the properties in the
property pane.

Modify concrete column properties
1. If the property pane is not open, double-click the column to open the

Concrete column properties.

2. Change the properties as needed.

3. Click Modify.
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Concrete column properties
Use the Concrete column properties in the property pane to view and modify
the properties of a concrete column. To open the properties, double-click the
concrete column. The file name extension of a concrete column property file is
*.ccl.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
Name User-definable name of the column.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile Profile (page 320) of the column.
Material Material (page 322) of the column.
Finish Type of finish.

Finish is user-definable. It describes
how the part surface has been
treated.

Class Use to group columns.

For example, you can display parts of
different classes in different colors.

Position
Vertical Vertical position (page 315) of the

column, relative to column's reference
point.

Rotation Rotation (page 313) of the column
around its axis on the work plane.

Horizontal Horizontal position (page 317) of the
column, relative to column's reference
point.

Top Position of the second end of the
column in the global z direction.

Bottom Position of the first end of the column
in the global z direction.

Cast unit
Cast unit numbering Part prefix and start number for the

part position number (page 713).
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Setting Description
Cast unit Indicate whether the column is

precast or cast-in-place.
Pour phase Pour phase (page 450) of the cast-in-

place parts. Use to separate pour
objects from one another.

Deforming
Warping Use to warp columns using

deformation angles.
Cambering Use to pre-camber (page 334) the

column.
Shortening Use to shorten the column in the

model. The true length of the column
is decreased in the drawing.

Concrete covers for rebar sets
Coordinate system Select whether the concrete cover

thickness (page 558) of the rebar sets
in the part is defined in the global
coordinate system, or in the part's
local coordinate system.

The default global and local cover
thickness values are defined in the
Options dialog box.

If you select the empty option, Tekla
Structures uses the global values.

Top, Bottom, Sides, Front , Back,
Start, End

To override global or local default
values from the Options dialog box,
define the cover thickness at each
required part face.

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
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Setting Description
part. UDAs provide additional
information about the part.

Create a concrete beam

1. On the Concrete tab, click .

2. Pick two points. 

Tekla Structures creates the beam between the points you picked using
the Concrete beam properties in the property pane.

Alternatively, you can start the command in the property pane.

1. Ensure that you have nothing selected in the model.

2. In the property pane, click the Object type list button  and select
Concrete beam from the list.

Tekla Structures starts the command and shows the properties in the
property pane.

Modify concrete beam properties
1. If the property pane is not open, double-click the beam to open the

Concrete beam properties.

2. Change the properties as needed.

3. Click Modify.

Concrete beam properties
Use the Concrete beam properties in the property pane to view and modify
the properties of a concrete beam or polybeam. To open the properties,
double-click the concrete beam. The file name extension of a concrete beam
property file is *.cbm.
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If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
Name User-definable name of a beam.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile Profile (page 320) of the beam.
Material Material (page 322) of the beam.
Finish Type of finish.

Finish is user-definable. It describes
how the part surface has been
treated.

Class Use to group beams.

For example, you can display parts of
different classes in different colors.

Position
On plane Beam's position on the work plane

(page 311), relative to the beam's
reference line.

Rotation Rotation (page 313) of the beam
around its axis on the work plane.

At depth Position depth (page 313) of the
beam. The position is always
perpendicular to the work plane.

End offset
Dx Change the length of the beam

(page 318) by moving the beam end
point along the beam's reference line.

Dy Move the beam end (page 318)
perpendicular to the beam's
reference line.

Dz Move the beam end (page 318) in the
z direction of the work plane.

Curved beam
Plane Plane of curvature.
Radius Radius of the curved beam.
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Setting Description
Number of segments Number of segments Tekla Structures

uses when drawing the curved beam.
Cast unit
Cast unit numbering Part prefix and start number for the

part position number (page 713).
Cast unit Indicate whether the beam is precast

or cast in place.
Pour phase Pour phase (page 450) of the cast-in-

place parts. Use to separate pour
objects from one another.

Deforming
Warping Use to warp beams using

deformation angles.
Cambering Use to pre-camber (page 334) beams.
Shortening Use to shorten beams in the model.

The true length of the beam is
decreased in the drawing.

Concrete covers for rebar sets
Coordinate system Select whether the concrete cover

thickness (page 558) of the rebar sets
in the part is defined in the global
coordinate system, or in the part's
local coordinate system.

The default global and local cover
thickness values are defined in the
Options dialog box.

If you select the empty option, Tekla
Structures uses the global values.

Top, Bottom, Sides, Front , Back,
Start, End

To override global or local default
values from the Options dialog box,
define the cover thickness at each
required part face.

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)
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Setting Description
More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.

Create a concrete polybeam
A polybeam can contain straight and curved segments.

1. On the Concrete tab, click Beam --> Polybeam.

2. Pick the points you want the beam to go through.

3. Click the middle mouse button. 

Tekla Structures creates the beam between the points you picked, using
the Concrete beam properties in the property pane. Note that you
cannot create a closed polybeam.

4. If you want to create curved segments, chamfer the corners of the
polybeam. 
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For example:

Modify concrete polybeam properties
1. If the property pane is not open, double-click the polybeam to open the

Concrete beam properties.

2. Change the properties as needed.

3. Click Modify.

Concrete beam properties
Use the Concrete beam properties in the property pane to view and modify
the properties of a concrete beam or polybeam. To open the properties,
double-click the polybeam. The file name extension of a concrete beam
property file is *.cbm.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General

Create parts, reinforcement, and construction
objects

267 Create parts and modify part properties



Setting Description
Name User-definable name of a beam.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile Profile (page 320) of the beam.
Material Material (page 322) of the beam.
Finish Type of finish.

Finish is user-definable. It describes
how the part surface has been
treated.

Class Use to group beams.

For example, you can display parts of
different classes in different colors.

Position
On plane Beam's position on the work plane

(page 311), relative to the beam's
reference line.

Rotation Rotation (page 313) of the beam
around its axis on the work plane.

At depth Position depth (page 313) of the
beam. The position is always
perpendicular to the work plane.

End offset
Dx Change the length of the beam

(page 318) by moving the beam end
point along the beam's reference line.

Dy Move the beam end (page 318)
perpendicular to the beam's
reference line.

Dz Move the beam end (page 318) in the
z direction of the work plane.

Curved beam
Plane Plane of curvature.
Radius Radius of the curved beam.
Number of segments Number of segments Tekla Structures

uses when drawing the curved beam.
Cast unit
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Setting Description
Cast unit numbering Part prefix and start number for the

part position number (page 713).
Cast unit Indicate whether the column is

precast or cast in place.
Pour phase Pour phase (page 450) of the cast-in-

place parts. Use to separate pour
objects from one another.

Deforming
Warping Use to warp beams using

deformation angles.
Cambering Use to pre-camber (page 334) beams.
Shortening Use to shorten beams in the model.

The true length of the beam is
decreased in the drawing.

Concrete covers for rebar sets
Coordinate system Select whether the concrete cover

thickness (page 558) of the rebar sets
in the part is defined in the global
coordinate system, or in the part's
local coordinate system.

The default global and local cover
thickness values are defined in the
Options dialog box.

If you select the empty option, Tekla
Structures uses the global values.

Top, Bottom, Sides, Front , Back,
Start, End

To override global or local default
values from the Options dialog box,
define the cover thickness at each
required part face.

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)

More
UDAs Click the User-defined attributes

button to open the user-defined

Create parts, reinforcement, and construction
objects

269 Create parts and modify part properties



Setting Description
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.

Create a concrete spiral beam
Use the Create concrete spiral beam command when you want to model
spiral staircases, parking ramps, and complex architectural shapes, for
example.

Basic concepts related to spiral beams
The images below illustrate some basic concepts related to the creation of
spiral beams. Note that if you change the positioning, the entire geometry of
the spiral beam changes.

(1) Start point (the first point picked)

(2) Center point (the second point picked)

(3) Direction of the rotation axis (the optional third point picked)

(4) Center axis

(5) Total rise: the distance from the start point to the end point, parallel to the
center axis

(6) Rotation angle: the rotation angle of the spiral beam, given in degrees.
Note: positive value = counter-clockwise rotation, negative value = clockwise
rotation.

(7) Radius: the distance from the start point to the center point, perpendicular
to the center axis
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Create a spiral beam
1. On the Concrete tab, click Beam --> Spiral beam.

2. Pick the start point. 

3. Pick the center point. 

4. To set the rotation axis in the work plane +Z direction, click the middle
mouse button to finish. 

NOTE Alternatively, instead of clicking the middle mouse button, you
can pick a second center axis point to define the direction of the
rotation axis.

Tekla Structures creates the spiral beam. For example:
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5. Click the spiral beam to select it. 

The contextual toolbar appears with the following options:

(1) Rotation angle

(2) Total rise

(3) Twist angle at start

(4) Twist angle at end

6. To add more rotation, enter a bigger value in the Rotation angle box.

7. To make the spiral more loose, enter a bigger value in the Total rise box.

8. To change the radius, move the start point or center point.

Limitations
• Spiral beam has a single, constant radius.

• Unfolding of spiral beams whose total rise is larger than 0.00 does not
produce completely straight results in drawings. The amount of deviation in
the part profile outlines and part length depends on several factors: the
type, size, and length of the profile; the amount of total rise; and the
amount of rotation angle and detailing used.

• Spiral beams are not always untwisted in unfolding. If unequal twisting is
applied to the start end and end end, the unfolded drawing shows an
unfolded but twisted part as a result.

• Connections and details may not work as expected with spiral beams.

• DSTV export of spiral beams may not produce a correct result.
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• You cannot export spiral beams as parts in IFC export. If you are modeling
cast-in-place structures with spiral beam, you can export the geometry to
IFC as pour objects.

Concrete spiral beam properties
Use the Concrete spiral beam properties in the property pane to view and
modify the properties of a concrete spiral beam. To open the properties,
double-click the spiral beam. The file name extension of a concrete spiral
beam property file is *.csb.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
Name User-definable name of a beam.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile Profile (page 320) of the beam.
Material Material (page 322) of the beam.
Finish Type of finish.

Finish is user-definable. It describes
how the part surface has been
treated.

Class Use to group beams.

For example, you can display parts of
different classes in different colors.

Position
On plane Beam's position on the work plane

(page 311), relative to the beam's
reference line.

Rotation Rotation (page 313) of the beam
around its axis on the work plane.

At depth Position depth (page 313) of the
beam. The position is always
perpendicular to the work plane.

Geometry
Rotation angle Rotation angle of the spiral beam,

given in degrees.
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Setting Description
Total rise Distance from the start point to the

end point, parallel to the center axis.
Twist angle at start

Twist angle at end

Twist +/- angle of the spiral beam at
the start/end of the beam.

Cast unit
Cast unit numbering Part prefix and start number for the

part position number (page 713).
Cast unit Indicate whether the column is

precast or cast in place.
Pour phase Pour phase (page 450) of the cast-in-

place parts. Use to separate pour
objects from one another.

Concrete covers for rebar sets
Coordinate system Select whether the concrete cover

thickness (page 558) of the rebar sets
in the part is defined in the global
coordinate system, or in the part's
local coordinate system.

The default global and local cover
thickness values are defined in the
Options dialog box.

If you select the empty option, Tekla
Structures uses the global values.

Top, Bottom, Sides, Front , Back,
Start, End

To override global or local default
values from the Options dialog box,
define the cover thickness at each
required part face.

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
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Setting Description
part. UDAs provide additional
information about the part.

Create a concrete panel or wall
You can create a concrete panel or wall that passes through the points you
pick.

1. On the Concrete tab, click Panel .

2. Pick the points you want the panel or wall to go through.

3. Click the middle mouse button. 

Tekla Structures creates the panel or wall using the Concrete panel
properties in the property pane. Note that you cannot create a closed
panel or wall structure.

4. If you want to create curved segments, chamfer the corners of the panel
or wall. 
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For example:

Alternatively, you can start the command in the property pane.

1. Ensure that you have nothing selected in the model.

2. In the property pane, click the Object type list button  and select
Concrete panel from the list.

Tekla Structures starts the command and shows the properties in the
property pane.

Modify concrete panel or wall properties
1. If the property pane is not open, double-click the panel or the wall to open

the Concrete panel properties.

2. Change the properties as needed.

3. Click Modify.

Concrete panel or wall properties
Use the Concrete panel properties in the property pane to view and modify
the properties of a concrete panel or a wall. To open the properties, double-
click the panel or the wall. The file name extension of a concrete panel
property file is *.cpn.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
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Setting Description
Name User-definable name of the panel.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile Profile (page 320) of the panel
(thickness × height of the wall).

Material Material (page 322) of the panel.
Finish Type of finish.

Finish is user-definable. It describes
how the part surface has been
treated.

Class Use to group panels.

For example, you can display parts of
different classes in different colors.

Position
On plane Panel's position on the work plane

(page 311), relative to the panel's
reference line.

Rotation Rotation (page 313) of the panel
around its axis on the work plane.

At depth Position depth (page 313) of the
panel. The position is always
perpendicular to the work plane.

End offset
Dx Change the length of the panel

(page 318) by moving the beam end
point along the panel's reference line.

Dy Move the panel end (page 318)
perpendicular to the panel's
reference line.

Dz Move the panel end (page 318) in the
z direction of the work plane.

Cast unit
Cast unit numbering Part prefix and start number for the

part position number (page 713).
Cast unit Indicate whether the panel or wall is

precast or cast in place.
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Setting Description
Pour phase Pour phase (page 450) of the cast-in-

place parts. Use to separate pour
objects from one another.

Bending
Plane Plane of curvature.
Radius Radius of the curved panel.
Number of segments Number of segments Tekla Structures

uses when drawing the curved panel.
Concrete covers for rebar sets
Coordinate system Select whether the concrete cover

thickness (page 558) of the rebar sets
in the part is defined in the global
coordinate system, or in the part's
local coordinate system.

The default global and local cover
thickness values are defined in the
Options dialog box.

If you select the empty option, Tekla
Structures uses the global values.

Top, Bottom, Sides, Front , Back,
Start, End

To override global or local default
values from the Options dialog box,
define the cover thickness at each
required part face.

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.
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Create a concrete slab
When you create a concrete slab, the profile you select defines the thickness of
the slab and the points you pick define the shape. The corners of the slab can
be chamfered.

1. On the Concrete tab, click Slab .

2. Pick the corner points of the slab.

3. Click the middle mouse button. 

Tekla Structures creates the slab, using the Concrete slab properties in
the property pane.

Alternatively, you can start the command in the property pane.

1. Ensure that you have nothing selected in the model.

2. In the property pane, click the Object type list button  and select
Concrete slab from the list.

Tekla Structures starts the command and shows the properties in the
property pane.

Create a round concrete slab
1. Create a square slab with four equal sides.

2. Select the plate.

3. Double-click a handle. 

To make it easier to select the handles of the slab corners, ensure that the

Direct modification switch  is not active.

The Corner chamfer properties open in the property pane.

4. In the Type list, select Rounding .
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5. In the Radius box, enter the chamfer radius. 

The radius must be equal to half of the side of the square.

6. Click Modify.

7. Repeat the above steps for each corner you want to chamfer. 

Alternative way of creating a round slab

1. Create a diamond-shaped slab with four equal sides.

2. To round the corners, use the Arc point  chamfer type.

Modify concrete slab properties
1. If the property pane is not open, double-click the slab to open the

Concrete slab properties.

2. Change the properties as needed.

3. Click Modify.

Concrete slab properties
Use the Concrete slab properties in the property pane to view and modify the
properties of a concrete slab. To open the properties, double-click the concrete
slab. The file name extension of a concrete slab property file is *.csl.
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If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
Name User-definable name of the slab.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Thickness Thickness of the slab.
Material Material (page 322) of the slab.
Finish Type of finish.

Finish is user-definable. It describes
how the part surface has been
treated.

Class Use to group slabs.

For example, you can display parts of
different classes in different colors.

Position
At depth Position depth (page 313) of the

concrete slab. The position is always
perpendicular to the work plane.

Cast unit
Cast unit numbering Part prefix and start number for the

part position number (page 713).
Cast unit Indicate whether the slab is precast or

cast in place.
Pour phase Pour phase (page 450) of the cast-in-

place parts. Use to separate pour
objects from one another.

Concrete covers for rebar sets
Coordinate system Select whether the concrete cover

thickness (page 558) of the rebar sets
in the part is defined in the global
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Setting Description
coordinate system, or in the part's
local coordinate system.

The default global and local cover
thickness values are defined in the
Options dialog box.

If you select the empty option, Tekla
Structures uses the global values.

Top, Bottom, Sides, Front , Back,
Start, End

To override global or local default
values from the Options dialog box,
define the cover thickness at each
required part face.

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.

Create a concrete lofted slab
With lofted slabs you can create curved and double-curved slabs or walls, for
example.

Prerequisites and examples of lofted slabs
Before you can create lofted slabs, you need to have construction objects
(page 621) in your model. Tekla Structures creates the shape of the lofted slab
according to the geometry of the used construction objects, by connecting the
start point of the first construction object to the start point of the second
construction object. The end points of construction objects are connected in
similar way.

You can connect the following construction objects as a lofted slab:
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• construction line to construction line

For example:

• construction line to construction arc

For example:

• construction arc to construction arc

For example:
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• construction circle to construction circle

For example:
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• construction polycurve to construction polycurve

Note that rebar sets do not work with lofted slabs.

Create a lofted slab
1. Create the needed construction objects in the model. The shape of the

lofted slab is based on the construction objects' shape. 

You need to have

• construction lines (page 622)

• construction arcs (page 624)

• construction circles (page 623)

or

• construction polycurves (page 626)

With polycurves, use the Create arc by tangent or Create tangent

line options  on the construction polycurve toolbar. To
create polycurves only with straight segments, use the Create line

option . Note that the construction polycurves do not
need to have the same number of segments, as long as both of them
are tangential.

2. When you have created the needed construction objects, go to the
Concrete tab and click Slab --> Create lofted slab.

3. On the toolbar that appears, click a button to specify whether to create
the lofted slab by using two construction objects, or by using a
construction object and a point. 

• Use two construction objects  to create a lofted slab:
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a. Select the first construction object: line, arc, circle, or polycurve.

For example, if you are using two construction circles to create a
lofted slab:

b. Select the second construction object:

Tekla Structures creates the lofted slab between the selected
construction objects, using the Lofted slab properties in the
property pane.
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• Use one construction object and a point  to create a lofted
slab:

a. Select the first construction object: line, arc, circle, or polycurve.

For example, if you are using a construction polycurve and a point
to create a lofted slab:

Tekla Structures shows a preview of the part geometry. Use the
preview to set the direction and height of the lofted slab.
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b. Pick a point.

Tekla Structures creates the lofted slab based on the preview.
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Modify the shape of a lofted slab
Use direct modification dimension handles and dimension values to modify
the lofted slab shape.

• Modify, for example, the height and radius of the lofted slab.

• For lines and arcs: drag the arc symbol  at the midpoint of a line or an
arc to modify the lofted slab shape.
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Split a lofted slab
Note that you cannot split closed cylindrical or conical lofted slabs.

1. On the Edit tab, click Split.

2. Select the lofted slab you want to split.

3. Pick a point for the dividing line. 

Tekla Structures splits the lofted slab.

For example:

Swap the end handle points to correct the geometry of a lofted slab
In some cases when you try to create a lofted slab, the geometry of the slab
would become self-intersecting, meaning that the start and end points of the

Create parts, reinforcement, and construction
objects

290 Create parts and modify part properties



top and bottom construction object are opposite of each other. In these cases
the slab is not created.

You can try to resolve the situation and create the lofted slab by changing the
modeling direction of the construction lines or arcs.

1. Select the construction line or the construction arc. 

With construction lines, ensure that the Direct modification  switch
is not active. You can then see the yellow and magenta object handles.

2. On the contextual toolbar, click  Swap ends. 

Tekla Structures changes the modeling direction of the selected
construction object, and the lofted slab can be created correctly.

With construction circles you can try to resolve the situation by moving either
of the circles.

Modify concrete lofted slab properties
1. If the property pane is not open, double-click the lofted slab to open the

Lofted slab properties.

2. Change the properties as needed.

3. Click Modify.

Lofted slab properties
Use the Lofted slab properties in the property pane to view and modify the
properties of a concrete lofted slab. To open the properties, double-click the
concrete lofted slab. The file name extension of a concrete lofted slab property
file is *.lsl.
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If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
Name User-definable name of the lofted

slab.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Thickness Thickness of the slab.
Material Material (page 322) of the lofted slab.
Finish Type of finish.
Class Use to group lofted slabs.

For example, you can display parts of
different classes in different colors.

Face type
Face type Select whether the top and bottom

faces of the slab are flush with the
plane.

Perpendicular:

The top and bottom faces of the slab
are non-linear.

Create parts, reinforcement, and construction
objects

292 Create parts and modify part properties



Setting Description
Bounded by curved planes:

The top and bottom faces of the slab
are planar.

Cast unit
Cast unit numbering Part prefix and start number for the

part position number (page 713).
Cast unit Indicate whether the slab is precast or

cast in place.
Pour phase Pour phase (page 450) of the cast-in-

place parts. Use to separate pour
objects from one another.

Concrete covers for rebar sets
Coordinate system Select whether the concrete cover

thickness (page 558) of the rebar sets
in the part is defined in the global
coordinate system, or in the part's
local coordinate system.

The default global and local cover
thickness values are defined in the
Options dialog box.

If you select the empty option, Tekla
Structures uses the global values.

Top, Bottom, Sides, Front , Back,
Start, End

To override global or local default
values from the Options dialog box,
define the cover thickness at each
required part face.

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. TheUser-defined type (IFC4)
More
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Setting Description
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.

Create a pad footing

1. On the Concrete tab, click .

2. Pick a point. 

Tekla Structures creates the pad footing using the Pad footing properties
in the property pane, and at the level (page 327) defined in the properties.

Alternatively, you can start the command in the property pane.

1. Ensure that you have nothing selected in the model.

2. In the property pane, click the Object type list button  and select Pad
footing from the list.

Tekla Structures starts the command and shows the properties in the
property pane.
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Modify pad footing properties
1. If the property pane is not open, double-click the pad footing to open the

Pad footing properties.

2. Change the properties as needed. 

For example, to create a circular pad footing, select a circular section for
Profile.

3. Click Modify.

Pad footing properties
Use the Pad footing properties in the property pane to view and modify the
properties of a pad footing. To open the properties, double-click the pad
footing. The file name extension of a pad footing property file is *.cpf.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
Name User-definable name of the pad

footing.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile Profile (page 320) of the pad footing.
Material Material (page 322) of the pad

footing.
Finish Type of finish.

Finish is user-definable. It describes
how the part surface has been
treated.

Class Use to group pad footings.

For example, you can display parts of
different classes in different colors.

Position
Vertical Vertical position (page 315) of the pad

footing, relative to pad footing's
reference point.

Rotation Rotation (page 313) of the pad footing
around its axis on the work plane.
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Setting Description
Horizontal Horizontal position (page 317) of the

pad footing, relative to pad footing's
reference point.

Top Position of the top surface of the pad
footing in the global z direction.

Bottom Position of the bottom surface of the
pad footing in the global z direction.

Cast unit
Cast unit numbering Part prefix and start number for the

part position number (page 713).
Cast unit Indicate whether the pad footing is

precast or cast-in-place.
Pour phase Pour phase (page 450) of the cast-in-

place parts. Use to separate pour
objects from one another.

Concrete covers for rebar sets
Coordinate system Select whether the concrete cover

thickness (page 558) of the rebar sets
in the part is defined in the global
coordinate system, or in the part's
local coordinate system.

The default global and local cover
thickness values are defined in the
Options dialog box.

If you select the empty option, Tekla
Structures uses the global values.

Top, Bottom, Sides, Front , Back,
Start, End

To override global or local default
values from the Options dialog box,
define the cover thickness at each
required part face.

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)

More
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Setting Description
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.

Create a strip footing
1. On the Concrete tab, click Footing --> Strip footing.

2. Pick the points you want the footing to go through.

3. Click the middle mouse button. 

Tekla Structures creates the strip footing between the points you picked
using the Strip footing properties in the property pane. Note that you
cannot create a closed strip footing.

4. If you want to create curved segments, chamfer the corners of the footing.

For example:

Alternatively, you can start the command in the property pane.

1. Ensure that you have nothing selected in the model.
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2. In the property pane, click the Object type list button  and select
Strip footing from the list.

Tekla Structures starts the command and shows the properties in the
property pane.

Modify strip footing properties
1. If the property pane is not open, double-click the strip footing to open the

Strip footing properties.

2. Change the properties as needed.

3. Click Modify.

Strip footing properties
Use the Strip footing properties in the property pane to view and modify the
properties of a strip footing. To open the properties, double-click the strip
footing. The file name extension of a strip footing property file is *.csf.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
Name User-definable name of the strip

footing.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Profile Profile (page 320) of the strip footing.
Material Material (page 322) of the strip

footing.
Finish Type of finish.

Finish is user-definable. It describes
how the part surface has been
treated.

Class Use to group strip footings.

For example, you can display parts of
different classes in different colors.

Position
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Setting Description
On plane Strip footing's position on the work

plane (page 311), relative to the
footing's reference line.

Rotation Rotation (page 313) of the strip
footing around its axis on the work
plane.

At depth Position depth (page 313) of the strip
footing. The position is always
perpendicular to the work plane.

End offset
Dx Change the length of the strip footing

(page 318) by moving the footing end
point along the footing's reference
line.

Dy Move the strip footing end (page 318)
perpendicular to the beam's
reference line.

Dz Move the strip footing (page 318) in
the z direction of the work plane.

Cast unit
Cast unit numbering Part prefix and start number for the

part position number (page 713).
Cast unit Indicate whether the strip footing is

precast or cast-in-place.
Pour phase Pour phase (page 450) of the cast-in-

place parts. Use to separate pour
objects from one another.

Bending
Plane Plane of curvature.
Radius Radius of the curved strip footing.
Number of segments Number of segments Tekla Structures

uses when drawing the curved strip
footing.

Concrete covers for rebar sets
Coordinate system Select whether the concrete cover

thickness (page 558) of the rebar sets
in the part is defined in the global
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Setting Description
coordinate system, or in the part's
local coordinate system.

The default global and local cover
thickness values are defined in the
Options dialog box.

If you select the empty option, Tekla
Structures uses the global values.

Top, Bottom, Sides, Front , Back,
Start, End

To override global or local default
values from the Options dialog box,
define the cover thickness at each
required part face.

IFC export
IFC entity For IFC export, select the IFC entity

type and subtype of the part. The
available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype
among the predefined options, or you
can select USERDEFINED and then
enter any text in User-defined type
(IFC4).

Subtype (IFC4)
User-defined type (IFC4)

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.

Create items
In Tekla Structures, the term item refers to the parts that have a 3D shape.
Shapes are created in an external modeling software, or in Tekla Structures,
and they are available in the Tekla Structures shape catalog.

Items are similar to other parts (page 196), such as beams and columns. The
main difference between items and other types of parts is that a 3D shape
defines the geometry of an item, whereas a part has a 2D profile that is
extruded to create the length of the part.

You can use items to model objects that would otherwise be difficult to model
using basic Tekla Structures parts and commands, such as cutting. You can
also use items to model objects that use shapes modeled in an external
software or by a manufacturer.
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Every item has properties that define it, such as shape, material, and location.
If you want to use item properties in view and selection filters or in drawing
and report templates, you need to use the template attributes of parts and
profiles. If you want to separate items from parts, use the IS_ITEM template
attribute.

Limitations to items

• Items cannot be mirrored.

• Items cannot be split or combined. Splitting an imported item creates a
duplicate to the splitting position.

• Items can only be cut or attached to another part if they have a solid shape.

• The gross weight value of an imported item may be different from that of
an identical Tekla Structures part modeled with cuts. This is because the
cuts are not taken into account when calculating the gross weight of parts.

Create an item or a concrete item

1. Ensure that  Direct modification is switched on. 

This makes it easier to adjust the location and rotation of the item in the
model.

2. Depending on the material of the item you want to create, do one of the
following: 

• On the Steel tab, click Item .

• On the Concrete tab, click Item .

TIP Alternatively, you can start the command in the property pane.

a. Ensure that you have nothing selected in the model.

b. In the property pane, click the Object type list button  and
select Item or Concrete item from the list.

Tekla Structures starts the command and shows the properties
in the property pane.

In the property pane, you can modify the item properties and
select the shape, for example.
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3. Move the mouse pointer over object faces and edges in the model, and
see how the item turns over and adjusts to the object faces. 

If you are adding the item to another object (such as part or pour object),
Tekla Structures also shows location dimensions to the nearest object
edges.

4. Pick the first point of the item.

5. To indicate the direction of the item, pick another point. 

Tekla Structures places the item between the points you picked starting
from the first point (yellow handle) towards the direction of the second
point (magenta handle), using the Item or Concrete item properties in
the property pane.

Tekla Structures shows the coordinate axes, rotation handles, and location
dimensions that you can use to fine-tune the location and rotation of the
item. The handles are red, green, and blue, according to the local
coordinate system of the item.

6. To move the item along any of its coordinate axes, drag the relevant axis
handle to a new location.

7. To rotate the item around any of its coordinate axes, drag the relevant
rotation handle to a new location. 

Press Tab to rotate the item in 90-degree steps in the direction of the
selected rotation handle.

8. To move or rotate the item by specifying a distance or angle:

a. Select an axis handle, a rotation handle, or a dimension arrowhead.

b. Type the value by which you want the dimension to change. 

When you start typing, Tekla Structures displays the Enter a Numeric
Location dialog box.

c. Click OK to confirm the new dimension.

9. If you want to add more items to the model, click the middle mouse
button and repeat steps 3–8.

10. To stop adding items, press Esc.
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11. If needed, you can modify the item geometry (page 334) further in the
Geometry editing mode.

Modify item or concrete item properties
1. If the property pane is not open, double-click the item or the concrete

item to open the Item or the Concrete item properties.

2. Change the properties as needed.

3. Click Modify.

Change the shape of an item
When you create or modify an item, you can select the shape from the list that
contains all the shapes available in the shape catalog.

Before you start, ensure that you have the required shape available in the
shape catalog.

1. Double-click an item to open the item properties in the property pane.

2. Click the ... button next to the Shape box to open the Select shape dialog
box.

3. On the left side of the dialog box, select a group or sub-group. 

TIP The latest shapes you have used can be found in the  Recent
group, and the shapes you have marked as important are in the
Starred group.

4. If needed, use the Filter box to search for a shape in the selected group.

5. Select a shape from the list.

6. Click OK to close the Select shape dialog box.

7. Click Modify in the property pane to apply the changes.

Convert a part to an item
You can change existing parts in the model to items and at the same time add
corresponding shapes to the shape catalog.

When you change a part to an item, Tekla Structures deletes the original part
and replaces it with the newly created item in the model. The name, material,
finish, class, pour phase, and the numbering properties of the original part are
saved as the corresponding item properties. Other part type specific
properties and user-defined attributes are not saved. The objects that are
attached to the original part, such as reinforcement and surfaces, are deleted.

1. Create the parts (page 196) that you want to change to an item.
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2. If you want to include more than one part in the item, attach the parts to
each other (page 330).

3. On the Edit tab, click  Convert part to item.

4. Select the part. 

Alternatively, you can first select the part, right-click, and then select
Convert part to item.

Tekla Structures changes the part to an item and adds a new shape to the
shape catalog.

The shape name is generated using the part name and part location in the
format <grid location>_<elevation>_<part name>. For example:

• 1/D_+0_FOOTING

• 3/C_+0-+3600_COLUMN

• 1-2/A-B_+3600_SLAB

If there is already a shape with the same name in the shape catalog, Tekla
Structures adds two underscore characters and a running number at the end
of the new shape name. For example, 1/D_+0_FOOTING__1.

Item and concrete item properties
Use the Item and the Concrete item properties in the property pane to
define, view, and modify the properties of an item. To open the properties,
double-click the item or the concrete item.

The file name extension of an item property file is *.ips.

The file name extension of a concrete item property file is *.ipc.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
Name User-definable name of an item.

The name can contain a maximum of
61 characters.

Tekla Structures uses part names in
reports and in Document manager,
and to identify parts of the same type.

Create parts, reinforcement, and construction
objects

304 Create parts and modify part properties



Setting Description
Shape Shape of an item.

To select a shape from the shape
catalog, click the ... button next to the
Shape box.

To show the item shape in reports
and drawing tables, use the PROFILE
template attribute.

Material Material (page 322) of the item.
Finish Type of finish.

Finish is user definable. It describes
how the part surface has been
treated, e.g. with anti-corrosive paint,
hot galvanized, fire retardant coating,
etc.

Class Use to group items.

For example, you can display parts of
different classes in different colors.

Numbering series (available for items)
Part numbering Part prefix and start number for the

part position number (page 713).
Assembly numbering Assembly prefix and start number for

the assembly position number
(page 713).

Position
On plane Item's position on the work plane

(page 311), relative to the item's
reference line.

Rotation Rotation (page 313) of the item
around its axis on the work plane.

At depth Position depth (page 313) of the item.
The position is always perpendicular
to the work plane.

End offset
Dx Move the item along (page 318) its

reference line.
Dy Move the item perpendicular

(page 318) to its reference line.
Dz Move the item in the z direction

(page 318) of the work plane.
Cast unit (available for concrete items)
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Setting Description
Cast unit numbering Part prefix and start number for the

part position number (page 713).
Cast unit Indicate whether the item is precast

or cast-in-place.
Pour phase Pour phase (page 450) of the cast-in-

place parts. Use to separate pour
objects from one another.

Concrete covers for rebar sets (available for concrete items)
Coordinate system Select whether the concrete cover

thickness (page 558) of the rebar sets
in the part is defined in the global
coordinate system, or in the part's
local coordinate system.

The default global and local cover
thickness values are defined in the
Options dialog box.

If you select the empty option, Tekla
Structures uses the global values.

Top, Bottom, Sides, Front , Back,
Start, End

To override global or local default
values from the Options dialog box,
define the cover thickness at each
required part face.

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (page 323) (UDAs) of the
part. UDAs provide additional
information about the part.

2.2 Adjust part position and show part information
When you create a part, you position the part by picking points. If needed, you
can adjust the position of a part in different ways after the part creation.

Part position

In part creation, the part handles and part reference line help you to define
the part position. You can adjust the position of parts (page 310), such as
rotation (page 313), by using the Position and End offset sections in the
property pane, or by using the contextual toolbar.

Also, check the following tips that help you to create and position, for example,
curved and horizontal parts:

Create parts, reinforcement, and construction
objects

306 Adjust part position and show part information



• Create curved parts (page 325)

• Create horizontal parts (page 326)

• Create beams close to each other (page 327)

• Position columns, pad footings, and orthogonal beams (page 327)

• How to model identical areas (page 328)

Show part information

To display selected part properties in the model view, use part labels
(page 324). Part labels are textual descriptions that are displayed next to the
part whose properties they show.

Show part handles and part reference lines in a model view
Part handles can be used to move a model object or to modify the model
object’s shape or size. Part reference line is line between two reference points,
and the reference line has handles at the line ends.

NOTE When you create horizontal parts, such as beams, always pick points in the
same direction, for example, from left to right. This ensures that Tekla
Structures places and dimensions the parts in the same way in drawings, and
that part marks automatically appear at the same part end.

Show part handles
Tekla Structures indicates the direction of a part with handles. When you select
a part, Tekla Structures shows the handles. The handle of the first end point is
yellow, the rest are magenta.

For information on how to select only the handles of a part, see Select objects
(page 113).

If direct modification (page 107) is on, Tekla Structures also displays direct
modification handles for the reference points, corners, segments, and
segment midpoints of the selected part. These handles are blue.
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Modify the length of a part using handles

If you do not want to use direct modification, you can use the part handles to
modify the length of a part.

1. Ensure that the Direct modification switch  is not active.

2. Select the part.

Tekla Structures highlights the handles of the part.

3. Click one of the handles to select it.

4. Move the handle like any other object in Tekla Structures.

For example, right-click and select Move.

If Drag & drop is active (page 142), just drag the handle to a new location.

WARNING Do not use cuts or fittings (page 375) to change the length of a
part, for the following reasons:

• Cuts may cause shop errors, because cuts do not always affect
part length when you export information to NC files.

• Fittings may cause problems with connections and details.

Swap handles

You can change the modeling direction of a part by using the Swap handles
macro. This changes the yellow start handle to magenta, and the other way
around.

1. Select the part whose modeling direction you want to change.

Tekla Structures shows the part handles.
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2. Go to Quick Launch, start typing swap handles, and select the
Macro.Swap handles command from the list that appears.

Tekla Structures changes the modeling direction of the part, and swaps
the start and end handles.

Show part reference lines in a model view
When you create a part, you position the part by picking points (page 83).
These points are the part reference points. If you pick two points to position a
part, the points form a part reference line, and handles appear at the line
ends. By default, the part reference line is invisible in the model. It may be
useful to display it when snapping to the middle points of parts, for example.

1. Double-click the view to open the View Properties dialog box.

2. Click Display... to open the Display dialog box.

3. On the Advanced tab, select the Part reference line check box.

4. Click Modify. 
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The part reference lines are displayed.

Modify the position of a part
Use the property pane and its Position and End offset sections to modify the
part position. Alternatively, you can use the contextual toolbar to modify the
part position.

To modify the position of a part, do one of the following:

To Do this
Modify part position using the
property pane

1. Double-click a part to open the
part properties in the property
pane.

2. In the Position or in the End
offset section, modify the
desired position settings, such as
part rotation (page 313) or part
vertical position (page 315).

For example, you can define the
part to be positioned 200 units
above its handles.

3. Click Modify.
Modify part position using the
contextual toolbar

1.
Click  in the contextual
toolbar.

2. Modify the settings. The object
moves in the model accordingly.

• To change the overall position
of a beam, column, panel, or
footing, use the round
selection dial. Click a sector in
the dial to select a position.
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To Do this
• To change the rotation angle,

click and drag the green
rotation angle knob.

The rotation angle knob snaps
to every 5 degrees. Hold down
Shift to override this.

• To change the Angle, Plane
offset, or Depth offset, enter
a value in the corresponding
box.

• To change the position of a
plate or slab, select an option
and enter a value in the
Depth offset box.

Alternatively, you can use keyboard shortcuts to modify the part's position.

See also

Part position on the work plane (page 311)

Part rotation (page 313)

Part position depth (page 313)

Part vertical position (page 315)

Part horizontal position (page 317)

Part end offsets (page 318)

Part position on the work plane
Use the On plane setting in the part properties to view and change the part’s
position on the work plane. The position is always relative to part's reference
line.
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Alternatively, you can use the contextual toolbar (page 310) or keyboard
shortcuts to modify the part's position.

Option Description Example
Middle The reference line is in

the middle of the part.

Right The part is positioned
underneath the
reference line.

Left The part is positioned
above the reference line.

Examples

Position Example
Middle 300

Right 300

Left 300
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Part rotation
Use the Rotation setting in the part properties to view and change the
rotation of a part around its axis on the work plane.

You can also define the angle of rotation. Tekla Structures measures positive
values clockwise around the local x axis.

Alternatively, you can use the contextual toolbar (page 310) or keyboard
shortcuts to modify the part's position.

Option Description Example
Front The work plane is

parallel to the front
plane of the part.

Top The work plane is
parallel to the top plane
of the part.

Back The work plane is
parallel to the back
plane of the part.

Below The work plane is
parallel to the bottom
plane of the part.
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Part position depth
Use the At depth setting in the part properties to view and change the
position depth of the part. The position is always relative to the part reference
line between the part handles.

Alternatively, you can use the contextual toolbar (page 310) or keyboard
shortcuts to modify the part's position.

Option Description Example
Middle The part is positioned in

the middle of the
reference line.

Front The part is positioned
above the reference line.

Behind The part is positioned
underneath the
reference line.

Examples

Position Example
Middle 400
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Position Example
Front 400

Behind 400

Part vertical position
Use the Vertical setting in the part properties to view and change the vertical
position of the part. The position is always relative to the part’s reference
point.

Alternatively, you can use the contextual toolbar (page 310) to modify the
part's position.

Option Description Example
Middle The reference point is in

the middle of the part.
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Option Description Example
Down The part is positioned

underneath the
reference point.

Up The part is positioned
above the reference
point.

Examples

Position Example
Middle 200

Down 200
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Position Example
Up 200

Part horizontal position
Use the Horizontal setting in the part properties to view and change the
horizontal position of the part. The position is always relative to the part’s
reference point.

Alternatively, you can use the contextual toolbar (page 310) to modify the
part's position.

Option Description Example
Middle The reference point is in

the middle of the part.

Left The part is positioned on
the left side of the
reference point.
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Option Description Example
Right The part is positioned on

the right side of the
reference point.

Examples

Position Example
Middle 150

Left 150

Right 150

Part end offsets
Use the Dx, Dy and Dz settings in the part properties to move the ends of a
part, relative to its reference line. You can enter positive and negative values.
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Alternatively, you can use the contextual toolbar (page 310) to modify the
part's position.

Option Description
Dx Changes the length of the part by

moving the part end point along the
reference line.

Dy Moves the part end perpendicular to
the reference line.

Dz Moves the part end in the z direction
of the work plane.

Examples

Position Example
Dx

End point: 200

Dx

End point: -200

Dy

End point: 300

Dy

End point: -300

Dz

End point: 400
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Position Example
Dz

End point: -400

Select and change the profile or material of a part
Each part has a profile and a material, which are selected using the profile
catalog and the material catalog.

Select and change the profile of a part
There are two types of profiles available for parts in Tekla Structures:

• Fixed profiles

Fixed profiles are profiles that can be obtained pre-manufactured. The
properties of the fixed profiles conform to industry standards, and you
should not modify them unless you are an administrator. Fixed profiles are
environment-specific.

• Parametric profiles

Parametric profiles are partly user-definable: they have a predefined shape
but you can change their cross section dimensions using one or more
parameters. Tekla Structures calculates the cross section shape each time
you open the model.

You can use the fixed or parametric profiles available in the Tekla Structures
profile catalog, or you can customize the profile catalog in several ways.

Change the profile of a part

When you create or modify a part (page 196), you can select the profile of a
part from a list that contains all the profiles available in the profile catalog.

1. Double-click a part to open the part properties in the property pane.

2. Click the ... button next to the Profile box.

The Select Profile dialog box appears.

By default, only the profile types that are relevant to the material of the
part are shown. For example, if you are changing the profile of a steel
part, only the profile types that are associated with steel are shown.
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3. If needed, define what profile information you want to see.

• To display all the profiles of the profile catalog in the list, regardless of
the material the profile types are associated with, select the Show all
profiles check box.

• To see all the properties of profiles, select the Show details check box.

4. Select a profile from the list.

5. If the profile is parametric, define its dimensions on the General tab.

(1) Click the Value box and replace the existing value with a new one.

6. Click OK to close the Select Profile dialog box.

7. Click Modify in the property pane.

Alternatively, if you know the name of the profile, you can enter it directly in
the Profile box in the property pane or in the contextual toolbar.

Use standardized values for profile dimensions

You can use standardized values for the dimensions of parametric profiles.

1. Double-click a part to open the part properties in the property pane.

2. Click the ... button next to the Profile box.

The Select Profile dialog box appears.

3. Select a parametric profile.
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If standardized values have been defined for this profile, the Use industry
standardized values only check box appears on the General tab under
the profile properties:

4. Select the Use industry standardized values only check box.

5. Select the profile dimensions from a list in the Value column.

Select and change the material of a part
When you create or modify a part (page 196), you can select the material and
grade of a part from a list that contains all the materials available in the
material catalog.

1. Double-click a part to open the part properties in the property pane.

2. Click the ... button next to the Material box. 

The Select Material dialog box appears.

3. If needed, define what material information you want to see. 

• To include aliases for material grades in the list, select the Show
aliases check box.

Aliases are alternative names. For example, they can be former names,
or names used in different countries or standards. Tekla Structures
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automatically changes aliases into the standard name when you select
a material grade.

• To see all the properties of materials, select the Show details check
box.

4. Select a material from the list.

5. Click OK to close the Select Material dialog box.

6. Click Modify in the property pane.

Alternatively, if you know the name of the profile, you can enter it directly in
the Profile box in the property pane or in the contextual toolbar.

TIP If needed, you can customize the material catalog.

Examples of user-defined attributes (UDAs) for parts

User-defined attributes (UDAs) provide additional information about a part.
UDAs can consist of numbers, text, or lists. If needed, you can define and
update user-defined attributes.

The following table gives some examples of what you can use part UDAs for:

Attribute Can be used...
Comment In part and weld marks in Tekla Structures

drawings, or in projects.
Shorten When drawings of the parts are created, Tekla

Structures decreases the true length of the part by
this value. This is useful when creating assembly
drawings of bracing bars that should always be
under tension.

Camber In part marks in Tekla Structures drawings.
Preliminary mark To obtain preliminary numbers for parts in reports.
Locked To protect objects from being accidentally

changed.
Shear, Tension, and
Moment

To save reaction forces for AutoDefaults. You can
enter forces separately for each end of a part.

User field 1...4 User-defined fields. You can change the names of
these fields and add new user-defined fields.

Connection code When importing information on connection types
into Tekla Structures. You can then use the
connection codes as rules in AutoConnection and
AutoDefaults. Each end of a part can have a
different connection code.
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Attribute Can be used...
Moment connection For selecting whether to show moment connection

symbols in drawings or not.

Show part information by using part labels
You can display selected part properties, user-defined attributes and template
attributes in a model view by using part labels.

Part labels are textual descriptions that are displayed next to the part they
represent. You can define what information to display in the labels, such as the
name, profile, and position number of the part.

1. Double-click the view to open the View Properties dialog box.

2. Click Display... to open the Display dialog box.

3. Go to the Advanced tab.

4. Next to the Part label, in the Properties list, select a property.

5. Click Add > to add the property to the Part label list. The Part label check
box is automatically selected when you add properties.

6. To remove a property from the Part label list, select a property and click
Remove. The Part label check box is automatically cleared if you remove
all the properties.
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7. If needed, define which user-defined attribute or template attribute you
want to display in part labels.

a. Select User-defined attribute in the Properties list.

b. Click Add >. The Part label dialog box appears.

c. Enter the user-defined attribute name exactly as it appears in the
objects.inp file, or the template attribute name. For example,
PRELIM_MARK.

d. Click OK.

8. In the Show for list, select for which parts you want to show the part
labels. 

• All: Part labels are shown for all parts in the view.

• Selected: Part labels are only shown for the parts you select.

• Main part for selected: Part labels are only shown for the main parts
of the assemblies you select.

• Main part for all: Part labels are shown for all main parts of all
assemblies.

Note that if you select the Selected or the Main part for selected option,
you need to first apply the changes to the view when the view is selected.
Then continue to select the objects for which you want to show the part
labels.

9. Click Modify.

Create curved parts
You can create curved parts by defining a radius and the number of segments
for a part. The number of segments determines how realistic the curved part
looks: the more segments, the less angular the part appears.

1. Create a part that can be bent: a beam, panel, or strip footing.

2. Double-click the part to open the part properties.

3. Go to the Curved beam or Bending settings area, depending on the part
type.

4. In the Radius box, enter the radius.

5. In the Number of segments box, enter the number of segments you
want to use.

6. If needed, define the plane of curvature, which is relative to the current
work plane.

7. Click Modify to bend the part.
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Examples

Number of segments: 2

Number of segments: 5

Number of segments: 15

See also

Modify the position of a part (page 310)

Create horizontal parts
When creating horizontal parts, such as beams, always pick points in the same
direction. For example, pick positions from left to right, and from bottom to
top (in positive x, y directions). This ensures that Tekla Structures places and
dimensions the parts in the same way in drawings, and that part marks
automatically appear at the same part end.

To ensure that beam rotation is correct in drawings, set part Rotation to Top
in the part properties.
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Create beams close to each other
When you create beams so that they are located very close to each other,
Tekla Structures may consider them as a twin profile. To prevent this from
happening, use the user attribute MAX_TWIN_SEARCH_DIST in the profile
catalog.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Select the desired profile in the profile tree.

3. Go to the User attributes tab and set the property Twin profile
detection distance to a larger value than 0, for example to 0.1.

4. Click OK.

5. Create the beams using the profile.

See also

Create a steel beam (page 201)

Create a twin profile (page 210)

Position columns, pad footings, and orthogonal beams
For parts that you create by picking only one point (such as columns), you can
define the top and bottom level of the part in the global z direction. The part is
created at the defined level, not at the level you picked in the model. This can
be useful when creating multi-story structures, as you can define exact levels
for each part you create.

To define the top and bottom levels of a part:

1. Create a part that requires you to pick only one point. 

For example, a column.

2. Double-click the part to open the part properties.

3. Go to the Position settings area.

4. Modify the top and bottom levels of the part. 

• Top: Use to define the top level of the part.

• Bottom: Use to define the bottom level of the part.

5. Click Modify.

Example

In this example, the concrete columns form a two-story structure. To position
the upper columns correctly, you must modify their bottom level position.
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(1) Top level = 1000, Bottom level = 0

(2) Top level = 1700, Bottom level = 1200

(3) Slab thickness = 200

See also

Modify the position of a part (page 310)

How to model identical areas
Most structures contain identical areas, from simple frames to entire floors.
Save time by modeling these areas once, then copying them throughout the
model. For example, create a column with a base plate and cap plate, then
copy the column to all the locations where it occurs in the model.

You can use this technique to create and reproduce any identical area.
Depending on the project, you may even be able to add connections before
copying the area of the building.

TIP For a project that has several identical floors, try modeling an entire floor, then
copying it to several levels.

See also

Copy and move objects (page 125)

2.3 Modify parts
This section explains how to modify different part properties, such as shape,
position and length of a part. It also explains how to split and combine parts,
and how to use the deforming options to warp and camber parts.

Click the links below to find out more:
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Modify the adaptivity of reinforcement, surface treatment, or edge chamfers in
parts (page 416)

Split parts (page 329)

Combine parts (page 329)

Attach parts to each other (page 330)

Warp a part (page 332)

Camber a part (page 334)

Modify items (page 334)

Split parts
Use splitting to split a part into two. You can use splitting with straight parts,
polybeams and curved beams without offsets, and normal and tapered
reinforcing bar groups. You can also split contour plates and concrete slabs.

Split a straight or curved part or polybeam
1. On the Edit tab, click Split.

2. Select the part you want to split.

3. Pick a point for the splitting line.

4. If you split a polybeam, check that the following are correct: 

• The position and orientation settings of the split polybeams

• The components related to the split polybeams

Split a plate or slab
1. On the Edit tab, click Split.

2. Select the contour plate or concrete slab you want to split. 

Note that bent plates, lofted plates, or lofted slabs cannot be split.

3. Pick the points you want the splitting line to go through. 

The first picked point and the last picked point need to be on an edge of
the plate or slab.

NOTE Areas with chamfers, cuts, or openings cannot be split. If you try to pick points
in these areas, the preview of the splitting line turns red, indicating that
splitting is not possible.
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Combine parts
You can combine two parts into one. This can be useful when you want to
model complex parts (such as folded plates) that are otherwise difficult to
model, or when you want to model prefabricated parts that are delivered to
the workshop already attached to profiles.

1. On the Edit tab, click Combine.

2. Select the first part. 

The properties of the first selected part will be used for the combined
part.

3. Select the second part. 

The parts are combined into one.

If the center lines of the parts are not in line with each other, Tekla
Structures combines them by taking the largest distance between the
start and end points from both parts. For example:

Limitations

• Combining does not work for contour plates, polybeams or slabs.

• When you combine parts, Tekla Structures retains the attached objects and
connections. Tekla Structures does not recreate connections in the part
that was selected first.

See also

Attach parts to each other (page 330)

Attach parts to each other
You can attach one or more parts to another part, or detach or explode the
attached parts using the Added material commands.
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When you modify the properties of attached parts, note that some of the part
properties are taken from the main part. These properties are not shown in
the properties of the attached part. You can inquire the properties of the
whole part and the properties of each attached part separately. The attached
parts are taken into account when calculating area, volume, and weight:

• Weight (Gross) compares the weight with fittings and without fittings, and
shows the biggest weight result without cuts and with attached parts.

• Weight (Net) shows the weight with cuts and attached parts based on the
geometry volume of the modeled part.

• Weight shows the net weight.

Limitations

• Connections must be added to the part to which other parts have been
attached. You cannot add connections to an attached part.

• All reinforcement components may not work correctly with parts that have
been attached to each other using the Added material commands. The
geometry of the parts is not always kept suitable for adding a component.
For example, the reference points of the attached part may be lost and
therefore the orientation information needed for adding the reinforcement
is not known anymore.

Attach a part to another part
1. Double-click the view to open the view properties, click the Display...

button, and ensure that the Cuts and added material option is selected
in the display settings.

2. On the Edit tab, click Added material --> Attach to part .

3. Select the part to attach to.

4. Select the part you want to attach. 

You can attach more than one part at a time.

5. Click the middle mouse button to attach the part.

Detach an attached part
1. Double-click the view to open the view properties, click the Display...

button, and ensure that the Cuts and added material option is selected
in the display settings.

2. On the Edit tab, click Added material --> Detach from part .

3. Select the attached part you want to detach. 

You can detach more than one part from several different parts at a time.
Select the parts either by clicking them or by using area selection.
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4. Click the middle mouse button to detach the part. 

The detached part keeps the color it had as an attached part.

Explode attached parts
You can explode a part that has attached parts.

1. Double-click the view to open the view properties, click the Display...
button, and ensure that the Cuts and added material option is selected
in the display settings.

2. On the Edit tab, click Added material --> Explode part .

3. Select the part you want to explode.

4. Click the middle mouse button to explode the part.

Warp a part
You can warp steel and concrete beams and columns, and concrete slabs. The
warping functionality is available only in the Full, Precast Concrete Detailing,
and Steel Detailing configurations.

Warp a beam or a column using deformation angles
1. Double-click a beam or a column to open the properties.

2. Go to the Deforming section.

3. In the Warping Start box, enter the angle of the beam at its start point,
relative to the part handles.

4. In the Warping End box, enter the angle of the beam at its end point,
relative to the part handles. 

For example, to warp the beam 10 degrees at the end point, enter 0 in the
Start angle box and 10 in the End angle box.

5. Click Modify to warp the beam. 
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Warp a concrete slab by moving chamfers
Before you start, create a concrete slab by using the Slab command on the
Concrete tab.

1. Double-click a chamfer to open the Corner chamfer properties.

2. Modify the chamfer properties. 

Do not modify the chamfers so that the slab faces are no longer planar.

• To move the upper corner of the chamfer, modify the Dz1 value.

• To move the lower corner of the chamfer, modify the Dz2 value.

3. Click Modify to warp the slab.

Warp a Floor Bay (66) slab
Before you start, create a concrete slab by using the Modeling of floor bay (66)
component.

1. Ensure that the Select components selection switch is on.

2. Select the chamfer you want to move. 

For example, select the corner point of a slab component to warp that end
of the slab:

3. Right-click and select Move special --> Linear... .

4. In the Move - Linear dialog box, enter a value in the appropriate direction
box. 

For example, enter 100 in the dZ box to lift that corner up 100 mm.

5. Click Move. 
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Tekla Structures moves the point in the direction you selected, which
warps the slabs.

6. Right-click and select Interrupt.

7. Ensure that the Select objects in components selection switch is on.

8. To see the warping angle of a single slab, double-click a slab to open the
Concrete beam properties, and go to the Deforming section. 

The Warping start and end values show the warping angle at the start
point and at the end point of the part.

Camber a part
You can use cambering to pre-camber parts, in other words, to curve long
heavy sections that will settle on site and become flat. Use cambering to show
the natural camber of a prestressed part in a model. Cambering affects the
position of cuts, skews, and embeds in the model.

1. Double-click the part to open the part properties.

2. Go to the Deforming section.

3. In the Cambering box, define the degree of camber.

4. Click Modify. 

Tekla Structures cambers the part in the local z direction.
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Modify items
You can fine-tune the geometry of the model by modifying items. This is how
you can create sloping slabs, for example.

TIP You can create item shapes using existing geometry and parts in the model.

When you modify an item's geometry, you can move item vertexes (corner
points), edges, and faces. However, the faces always need to stay planar, so
you cannot move all vertexes or edges freely. You may first need to add new
edges to split existing faces. These edges act as hinges or turning joints
between the faces.

When you have modified an item's geometry and want to save the changes,
you can choose to update the item's current shape, or to create a new shape.
Tekla Structures also stores temporary shapes in the shape catalog in case you
need to undo actions. The unused temporary shapes will be deleted from the
shape catalog when you save the model.

Start geometry editing
Before you start, create items (page 300).

1. Ensure that  Direct modification is switched on.

2. Select the item whose geometry you want to modify. 

You can only modify items that have a solid shape.

The Geometry editing tab appears at the right end of the ribbon:

Tekla Structures shows the direct modification axis and rotation handles
for the selected item. For example:
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3. Modify the position settings in the item properties (page 304) so that both
On plane and At depth are set to Middle with offset 0. 

This ensures that the later geometry modifications are accurate.

4. If you need to adjust the item location in the model, drag the direct
modification axis handles or location dimension arrowheads.

Modify the geometry of an item
Before you start, ensure that you have the Geometry editing tab open and
the correct item selected.

1. Click  Handles to display handles for the selected item. For example: 
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2. Move the mouse pointer over the selected item to highlight its faces,
edges, and vertexes.

3. To check the coordinates of a vertex, select the vertex. 

Tekla Structures shows the absolute, work plane based coordinates in the
model view. For example:

4. To move a face, edge, or vertex, drag it to a new location. 

Alternatively, you can use numeric snapping (page 87) and the Enter a
Numeric Location dialog box.

To move a selected vertex to an exact location, you must enter all three
coordinates (x, y, and z) of the new location, for example 400,200,0.

Note that you can use a special character (page 91) in front of the
coordinates to temporarily override the default (relative) snapping mode,
for example ! for global coordinates. With relative and absolute
coordinates, you can also use coordinate axis prefixes x, y, and z to move
a vertex or dragged edge in the prefixed directions only, for example
@z500 or $y6000,z-500.

5. To delete an edge or vertex, select it and press Delete. 

You can only delete edges whose both adjacent faces are in the same
plane, and vertexes whose all adjacent faces are in the same plane.

If the adjacent faces of an edge or vertex are not in the same plane, you
can drag the edge or vertex on top of another one to combine them.

6. If you need to undo actions, press Ctrl+Z.
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Add an edge to an item
You can add edges to the selected item, and so split existing faces. Create the
new edges so that they do not cross over any existing edges.

Before you start, ensure that you have the Geometry editing tab open and
the correct item selected.

1. On the Geometry editing tab, click  Edge.

2. Pick the start point of the edge. 

The start point must be located on an existing edge or vertex.

3. Pick the end point of the edge. 

The end point must be located on a vertex or on the same face as the
start point, but on another edge. If you try to pick an invalid point, Tekla
Structures shows a preview of the edge in red.

Tekla Structures creates the edge between the points you picked. For
example:

(1) Start point

(2) End point

4. If you want to add more edges, repeat steps 2 and 3.

5. To stop adding edges, press Esc.

Add a vertex to an item
You can add vertexes and related edges to the faces of the selected item. You
can use the vertexes as drainage points when you create sloping slabs and
plan drainage, for example.
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Note that you cannot add vertexes to faces that have openings or recesses if
these openings are part of the item shape. However, if only the item in the
model has been cut, and not its shape, you can add vertexes to these faces.

Before you start, ensure that you have the Geometry editing tab open and
the correct item selected.

1. On the Geometry editing tab, click  Point.

2. Move the mouse pointer over the faces of the selected item. 

In convex-polygonal areas, where all internal angles at face corners are
less than 180 degrees, Tekla Structures shows a preview of the edges that
start from each face corner and join at the current location of the mouse
pointer. For example:

If the item faces have concave-polygonal areas, where at least one internal
angle is larger than 180 degrees, Tekla Structures automatically shows and
adds edges that separate the concave-polygonal areas from the convex-
polygonal areas.

3. Pick a point on the desired face. 
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Tekla Structures creates the vertex and related edges that join the new
vertex to all existing vertexes of the same face. For example:

4. If you want to add more vertexes, pick more points.

5. To stop adding vertexes, press Esc.

Save a modified item and shape
When you save modified items in the model, you can choose to update the
selected item's current shape, or to create a new shape for later use.

Before you start, ensure that you have the Geometry editing tab open and
the correct item selected.

1. On the Geometry editing tab, click  Save as. 

The Save as dialog box opens.

2. Select one of the following options: 

• Update current shape to use this geometry

to update the current shape, the modified item, and all the items using
that shape in the model.

If all items are not updated in the model, save and re-open the model.

• Create a new shape in the shape catalog with the name

to create a new shape in the shape catalog, and to update the
modified item in the model to use the new shape.

3. If you chose to create a new shape, enter a name for the shape.
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4. Click Save. 

Tekla Structures updates the items in the model and saves the shape in
the shape catalog.

The temporary shapes that were created during the editing process will be
deleted from the shape catalog when you save the model if the shapes are not
used by any item.

2.4 Add details to parts
This section explains how to create and view details using Tekla Structures. It
also gives you some techniques for fine-tuning the part shape.

You can create and view details, for example, the following ways:

• create bolts (page 341), studs (page 353) and holes (page 353)

• create welds (page 359) and define how they appear in the model
(page 371)

• create fittings (page 375), cuts (page 389) and part chamfers (page 397) to
refine the shape of a part, and to fit beams and columns (page 376) and
also contour plates, slabs, and panels (page 380) to each other

• add surface treatment to parts (page 402) and surfaces to part faces
(page 415)

• modify adaptivity (page 416) of the details

• show all the detailing that belongs to a part (page 416)

Create bolts
To create bolts, you can either create a single bolt group or apply a component
that automatically creates bolt groups.
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Tekla Structures uses the same command for creating bolts, studs (page 353)
and holes (page 353). If you want to create only holes, do not use any bolt
elements (such as bolts, washers, and nuts).

If you want to create bolts without creating holes, use the No hole option for
Special hole type in the Bolt properties.

You can create different marks for bolts and holes in drawings.

Create a bolt group

1. On the Steel tab, hold down Shift and click Bolt . 

The Bolt properties open.

2. Modify the Bolt properties, if needed. 

For example, the Bolt group settings affect the end result: the shape of
the bolt group, the number of bolts in the group, and the spacing of the
bolts. See the Bolt group shape section below for examples.

To define the hole properties, use the Holes settings in the Bolt
properties.

3. Select the main part, to which the secondary parts will be bolted.

4. Select the secondary parts.

5. Click the middle mouse button to finish selecting parts.

6. Pick a point to indicate the bolt group origin.

7. Pick a second point to indicate the direction of the bolt group x axis. 

NOTE Tekla Structures determines the location of the bolt group using
the following values: the bolt group x axis and the work plane.
Dimensions are relative to the bolt group origin, which is the first
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point picked. Tekla Structures sets the x direction of the bolt
group using the second point picked. It is important that the
points you pick to create the bolt group are close enough to the
parts you want to connect.

Create a single bolt

1. On the Steel tab, hold down Shift and click Bolt  to open the Bolt
properties.

2. Under Bolt group, select Array from the Shape list.

3. In the Bolt dist X and Bolt dist Y boxes, enter 0.

4. Create the bolt the same way you would create a bolt group:

a. Select the main part, to which the secondary parts will be bolted.

b. Select the secondary parts.

c. Click the middle mouse button to finish selecting parts.

d. Pick a point to indicate the bolt origin.

e. Pick a second point to indicate the direction of the x axis.

Create bolts using the Auto bolt component
Use the Auto bolt component to bolt parts and nearby parts, shim plates,
splice plates, or other plates. Auto bolt follows the part rotation and finds the
best rotation so that you do not need to set the work plane. With Auto bolt
one bolt group can span many parts, for example, manage a splice as a single
group.

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Start typing auto bolt in the search box.

3. Double-click Auto bolt in the catalog to open the Auto bolt dialog box.

4. Define the bolt properties.

5. If needed, you can show cut length as temporary lines to view where the
bolts should be placed even if they are not created. 

• Select  in the list at the bottom of the dialog box to not show the
temporary lines.

• Select  in the list at the bottom of the dialog box to show the
temporary lines.

To delete the temporary lines, right-click the view and select Redraw view.
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6. Click Apply.

7. Select the main part. 

Auto bolt uses this part to identify the best rotation. This part will be the
main part of the assembly.

8. Select the secondary part.

9. Click the middle mouse button.

10. Pick the first and the second position to define the bolt group direction. 

The positions you pick define a line that is used to find all parallel part
faces and the optimal plane and locations for the bolts. The plane is
chosen as follows:

a. The face with the longest projection of the line

b. If there are two faces with equally long projections, the face which is
closer to the line

c. If there are two equally close faces, the larger face
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For example, with special part profiles, selecting points close to the
wanted face ensures that the bolts are placed correctly:

Examples

Examples of parts bolted using the Auto bolt component are shown below.
The main parts and the selected points are highlighted.
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Create a bolt group by exploding a component
An alternative way to create bolts is to first apply a component that includes
bolt groups, and then explode the component.

1. Apply a component that includes bolt groups. 

For example, connect two beams, or a beam to a column, using a bolted
end plate.

2. Explode (page 831) the component.

a. Select the component to explode.
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b. Right-click and select Explode component. 

Tekla Structures separates the objects in the component.

3. Modify the bolt group.

a. Select the bolt group and double-click it to open the properties.

b. Modify the properties.

c. Click Modify.

Change or add bolted parts
You can change the parts a bolt group connects to.

1. On the Steel tab, click Bolted parts.

2. Select the bolt group.

3. Reselect the main and secondary parts.

4. Click the middle mouse button to finish selecting the parts.

Bolt group shape
Use the Bolt group settings in the Bolt properties to select the shape of a bolt
group and to determine how many bolts the bolt group contains.

In the images below, the yellow handle indicates the origin of the bolt group,
and the magenta handle indicates the x direction of the bolt group.

Shape Other bolt group settings Example
values

Result

Array Bolt dist X

Spacing between bolts, in the x
direction of the bolt group.

150

Bolt dist Y

Spacing between bolts, in the y
direction of the bolt group.

100

Circle Number of bolts 6
Diameter of the bolt group 100

List Bolt dist X

x coordinate of each bolt, from
the bolt group point of origin.

75 175 250

Bolt dist Y

y coordinate of each bolt, from
the bolt group point of origin.

75 -50 0
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Bolt properties
Use the Bolt properties to view or modify the properties of a bolt group. Use
the Holes section to define the properties of bolt holes. The units depend on
the settings in File menu --> Settings --> Options --> Units and decimals .

Setting Description
Bolt
Size Bolt diameter.
Standard Bolt assembly standard/grade.
Bolt type Define whether the bolts are

assembled on-site or in the shop.
Connect as Indicate whether you are bolting a

secondary part or a sub-assembly.
Thread in material Indicate if the thread of the bolt can

be inside the bolted parts. Tekla
Structures does not use this value
when calculating the length of full-
threaded bolts.

Cut length Indicate which parts the bolt
connects. The value defines the area
Tekla Structures should search for
parts that belong to the bolt group.
Using cut length you can determine
whether the bolt will go through one
flange or two.

Tekla Structures searches for parts
using half the cut length value, in
both directions from the bolt group
plane. In the illustration below, A is
the cut length and B is the bolt origin.
Tekla Structures calculates the search
area as A/2 in both directions from
point B.
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Setting Description

Tekla Structures warns you if the cut
length is too small (i.e. the bolt group
contains no parts) and makes the bolt
length 100 mm.

If there are large gaps between the
connected parts, the gap is added to
the length of the bolt. Tekla Structures
calculates bolt length using the total
distance between the first and last
surfaces.

NOTE: If you want to force a bolt to
be a certain length, enter a negative
value for cut length (e.g. -150).

NOTE: If holes or blind holes cannot
be created, increase the cut length.

Extra length Additional bolt length.

Increases the material thickness that
Tekla Structures uses when
calculating bolt length. For example,
you might need extra bolt length to
allow for painting. You can also build
additional lengths into bolt
assemblies.

Assembly Select whether to create washers and
nuts with the bolt.

If you want to create only holes
(page 353) without any bolts, clear all
the check boxes.

Bolt group
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Setting Description
Shape Bolt group shape. You have the

following options:

• Array for rectangular

• Circle for circular

• List for any shape
Bolt dist X Bolt spacing or coordinate, depending

on the bolt group shape (Array or
List).

Bolt dist Y Bolt spacing or coordinate, depending
on the bolt group shape (Array or
List).

Number of bolts Number of bolts in a circular bolt
group.

Diameter Diameter of a circular bolt group.
Holes
Tolerance Tolerance = Hole diameter - Bolt

diameter
Plain hole type Select Through to create holes that

are open throughout the part.

Select Blind to create partial-depth
holes that do not extend completely
through parts.

Hole depth Depth of a blind hole measured from
the bolt/hole reference points (yellow
and magenta handles).

Note that you may also need to adjust
the Cut length value.

Parts with special holes If you want to create oversized,
slotted, or tapped holes, or if you
want to omit holes, select the desired
check boxes to indicate which plies of
the connection get special holes.

Use the same settings for all
special holes

Select this check box to create similar
special holes in each of the connected
parts. The properties of the special
hole that is closest to the bolt head
will be used for all special holes in the
bolt group.

If you clear this check box, you can
define special hole properties
separately for each of the parts.
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Setting Description
Special hole type Oversized, slotted, tapped, or no

holes. This option becomes active
when you select one or more Special
hole check boxes next to Parts with
special holes.

Oversized Allowance of an oversized hole.
Slotted hole X x allowance of a slotted hole. Zero for

a round hole.

To create slotted holes with an offset
from the bolt center in the x direction,
enter an offset value in the second
box (Slot offset).

Slotted hole Y y allowance of a slotted hole. Zero for
a round hole.

To create slotted holes with an offset
from the bolt center in the y direction,
enter an offset value in the second
box (Slot offset).

Core hole size Size of a predrilling hole.
Position
On plane Move the bolt group perpendicular to

the bolt group x axis.

Rotation Define how far the bolt group is
rotated around the x axis, relative to
the current work plane.

For example, you can use this box to
indicate on which side of the
connected parts you want the bolt
head to be.

At depth Move the bolt group perpendicular to
the current work plane.

Offset from
Dx, Dy, Dz Offsets that move the bolt group by

moving the bolt group x axis. Use to
change the position of the bolt group.
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Setting Description
The start point values Dx, Dy and Dz
move the first end of the bolt group,
relative to the bolt group x axis. The
end point values move the second
end of the bolt group.

• A positive Dx value moves the
start point towards the end point.

• Dy moves the end point
perpendicular to the bolt group x
axis on the current work plane.

• Dz moves the end point
perpendicular to the current work
plane.

An example bolt group with the Dx
start point set to 75:

More
UDAs Click the User-defined attributes

button to open the user-defined
attributes (UDAs) of the bolt. UDAs
provide more information about the
bolts.

Show cut length as temporary lines This option is available in the Auto
bolt component.

Shows where the bolts should be
placed even if they are not created.

• Select  to not show the
temporary lines.

• Select  to show the
temporary lines.
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Create studs
A stud is special type of bolt that is welded to steel parts to transfer loads
between steel and concrete.

Tekla Structures uses the same command for creating bolts (page 341), studs
and holes (page 353). When you create studs, select the stud assembly
standard in the Bolt properties. You can create a group of studs or a single
stud.

You can also create studs by using the Shear Stud (1010) component.

1. Ensure that the needed studs are added to the bolt catalog and bolt
assembly catalog.

2. On the Steel tab, hold down Shift and click Bolt  to open the Bolt
properties.

3. In the Standard list, select the bolt assembly standard for the studs.

4. Under Bolt group, do one of the following: 

• To create a group of studs, define Shape and the related properties as
desired.

• To create a single stud, select Array from the Shape list and type 0 in
the Bolt dist X and Bolt dist Y boxes.

5. Modify the other properties as desired.

6. Select the main part.

7. Click the middle mouse button to finish selecting parts.

8. Pick a point to indicate the origin of the stud or stud group.

9. Pick a second point to indicate the direction of the stud group x axis.

Create bolt holes
Tekla Structures uses the same command for creating bolts, studs and holes.
Before creating holes, you need to change some of the properties in the Bolt
properties. If you want to create only holes, do not use any bolt elements
(such as bolts, washers, and nuts).

You can create the following types of holes:

• Round

• Oversized

• Slotted

• Tapped
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When several parts are connected together with a bolt group or single bolt,
you can create different holes in each of the parts, or you can use the same
properties for the special holes in all the parts.

You can also select whether the holes you create are open throughout the
parts, or partial-depth or blind holes that do not extend completely through
the parts.

The hole properties are available in the Holes section in the Bolt properties
(page 348).

Create round holes
You can create a group of round holes, or a single round hole. Tekla Structures
calculates the diameter of a round hole as the sum of Size and Tolerance.

1. On the Steel tab, hold down Shift and click  Bolt to open the Bolt
properties.

2. If you do not want to create any bolts, clear all the Assembly
check boxes. 

3. If needed, modify the hole properties. 

For example, to create partial-depth holes, set Plain hole type to Blind
and enter a value in the Hole depth box.

4. Create the holes the same way you would create a bolt group (page 342):

a. Select the main part, to which the secondary parts will be bolted.

b. Select the secondary parts.

c. Click the middle mouse button to finish selecting parts.

d. Pick a point to indicate the hole group origin.

e. Pick a second point to indicate the direction of the hole group x axis.

Create oversized holes
You can create a group of oversized holes.
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1. On the Steel tab, hold down Shift and click  Bolt to open the Bolt
properties.

2. If you do not want to create any bolts, clear all the Assembly
check boxes. 

3. Next to Parts with special holes, indicate which plies of the connection
get oversized holes by selecting the desired Special hole check boxes. 

For example:

4. If you want to create similar holes in each of the parts with oversized
holes, select the Use the same settings for all special holes check box. 

The holes will be created using the properties of the holes in the first part
from the bolt head.

If you clear this check box, you can define hole properties separately for
each of the parts with oversized holes.

5. In the Special hole type list, select Oversized.

6. In the Oversized box, enter the allowance for the oversized hole.

7. If needed, modify the other hole and bolt properties.

8. Create the holes the same way you would create a bolt group (page 342):

a. Select the main part, to which the secondary parts will be bolted.

b. Select the secondary parts.

c. Click the middle mouse button to finish selecting parts.

d. Pick a point to indicate the hole group origin.

e. Pick a second point to indicate the direction of the hole group x axis.
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Create slotted holes
You can create a group of slotted holes. You can also create slotted holes with
offsets from the bolts.

1. On the Steel tab, hold down Shift and click  Bolt to open the Bolt
properties.

2. If you do not want to create any bolts, clear all the Assembly
check boxes. 

3. Next to Parts with special holes, indicate which parts should be slotted
by selecting the desired Special hole check boxes. 

Tekla Structures counts the pieces of steel from the head of the bolt down.
For example, if you select the second check box from the head of the bolt,
Tekla Structures slots the second piece of steel from the head of the bolt.

4. If you want to create similar holes in each of the slotted parts, select the
Use the same settings for all special holes check box. 
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The holes will be created using the properties of the holes in the first
slotted part from the bolt head.

If you clear this check box, you can define hole properties separately for
each of the slotted parts.

5. In the Special hole type list, select Slotted.

6. Enter the allowance for the slotted hole in the x and y directions of the
hole group using the Slotted hole X and Slotted hole Y boxes. 

(1) Tolerance

(2) Slotted hole X or Y

(3) Bolt size

7. If you want to offset the slotted holes from the bolts so that the bolts are
not in the middle of the holes, enter an offset value in the Slot offset box
next to Slotted hole X and Slotted hole Y.

8. If needed, modify the other hole and bolt properties.

9. Create the holes the same way you would create a bolt group (page 342):

a. Select the main part, to which the secondary parts will be bolted.

b. Select the secondary parts.

c. Click the middle mouse button to finish selecting parts.

d. Pick a point to indicate the hole group origin.

e. Pick a second point to indicate the direction of the hole group x axis.

Create tapped holes
You can create tapped holes that have threads drilled in them.

1. On the Steel tab, hold down Shift and click  Bolt to open the Bolt
properties.

2. If you do not want to create any bolts, clear all the Assembly check boxes.
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3. Next to Parts with special holes, indicate which plies of the connection
get tapped holes by selecting the desired Special hole check boxes. 

For example:

4. If you want to create similar holes in each of the tapped parts, select the
Use the same settings for all special holes check box. 

The holes will be created using the properties of the holes in the first
tapped part from the bolt head.

If you clear this check box, you can define hole properties separately for
each of the tapped parts.

5. In the Special hole type list, select Tapped.

6. In Core hole size, enter the predrilling hole size.

7. If needed, modify the other hole and bolt properties.

8. Create the holes the same way you would create a bolt group (page 342):

a. Select the main part, to which the secondary parts will be bolted.

b. Select the secondary parts.

c. Click the middle mouse button to finish selecting parts.

d. Pick a point to indicate the hole group origin.

e. Pick a second point to indicate the direction of the hole group x axis.

Create different holes with one bolt group
When several parts are connected together with a bolt group or single bolt,
you can create different holes in each of the parts. For example, the holes in
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one part can be slotted, and the holes in the other parts can be either special
holes or regular round holes.

Up to five parts can get special bolt holes with one bolt. The rest of the
connected parts (the sixth and so on) will get regular round holes.

1. On the Steel tab, hold down Shift and click  Bolt to open the Bolt
properties.

2. Next to Parts with special holes, indicate which parts get special holes by
selecting the desired Special hole check boxes. 

For example:

3. Clear the Use the same settings for all special holes check box.

4. For each of the parts with special holes, select an option in the Special
hole type list.

5. Depending on the type of the special holes in each of the parts, enter the
needed hole dimensions and other properties.

6. Create the holes the same way you would create a bolt group (page 342):

a. Select the main part, to which the secondary parts will be bolted.

b. Select the secondary parts.

c. Click the middle mouse button to finish selecting parts.

d. Pick a point to indicate the hole group origin.

e. Pick a second point to indicate the direction of the hole group x axis.

Create welds
You can either create a weld manually, or use a component that automatically
creates welds.

By default, Tekla Structures places the welds to the arrow side using the Above
line properties according to the ISO standard. You can change this to Below
line to comply with the AISC standard with the advanced option XS_AISC_
WELD_MARK.
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Create a weld between parts
Weld two parts together using the weld position defined in the Weld
properties. The length of the weld depends on the length of the connection
between the welded parts.

1. On the Steel tab, click Weld --> Create weld between parts .

2. Select the part to weld to. 

If you are creating a workshop weld, this is the main part of the assembly.

3. Select the part to be welded. 

If you are creating a workshop weld, this is the secondary part of the
assembly.

(1) Main part

(2) Secondary part

Create a weld to a part
You can create a weld to a single part, without connecting any other parts.

1. On the Steel tab, click Weld --> Create weld to part .

2. Select the part that you want to weld.

3. Pick the starting and end point, or alternatively, pick the points you want
the weld to go through.

4. Click the middle mouse button to create the weld.

Example

Use the Create weld to part command to weld seams in tubular sections:
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TIP To model tubular sections with visible seams, use the SPD profile.

Create a polygon weld
Create polygon welds when you want to define the exact position of the weld
by picking the points you want the weld to traverse.

If you want to create double-sided polygon welds, define both the Above line
and Below line properties.

1. On the Steel tab, click Weld --> Create polygon weld .

2. Select the part to weld to. 

If you are creating a workshop weld, this is the main part of the assembly.

3. Select the part to be welded. 

If you are creating a workshop weld, this is the secondary part of the
assembly.

4. Pick the starting and end point, or alternatively, pick the points you want
the weld to go through. 

To create a double-sided polygon weld, pick the polygon points on one
side of the part to be welded. Tekla Structures automatically searches for
the corresponding points on the other side of the part.

5. Click the middle mouse button to create the weld.

6. If needed, modify the weld by dragging the handles.

Example

This example shows a double-sided polygon weld along three (outer and
inner) edges of a rectangular hollow profile:
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Weld properties
Use the Weld properties to view or modify the properties of a weld. The units
depend on the settings in File menu --> Settings --> Options --> Units and
decimals .

NOTE Some of the properties are only displayed in reports, not in drawings.

Setting Description
Common attributes
Edge/Around Indicates whether only one edge or the entire

perimeter of a face should be welded.

Edge: 

Around: 
Workshop/Site Indicates where the weld should be made. This

setting affects assemblies and drawings.

Workshop: 

Site: 
Position Not available for polygon welds.

Defines the position of a weld relative to the work
plane. The type and position of the parts to be
welded affect the position of the weld.

The options for weld position are:

• + x

• - x
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Setting Description
• + y

• - y

• + z

• - z

In most cases, Tekla Structures creates the weld on
the face or side of the part that faces in the
selected direction (x, y, or z). Also the following
factors may affect the position of the weld:

• perpendicularity of the part edge towards the
selected direction (x, y or z)

• length of the part edge

• distance of the part edge in the selected
direction (x, y or z)

The following image shows welds in different
positions:

Shape The shape of the weld can be:

•
 (Regular, continuous weld)

•
 (Intermittent weld)

•
 (Staggered, intermittent weld)

Connect as See Use welds to create assemblies (page 425).
Placement Defines how the weld is placed in relation to the

assembly parts.

The options are:
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Setting Description
• Auto

The weld placement adapts to the typical
situation of the weld type.

Square-, V-, and U-groove welds are located in
the middle of the main and secondary parts.
Single-bevel and J-groove welds are located on
the secondary part side.

This is the default option.

• Main part

The weld is located fully on the main part side.

Does not affect V- or U-groove welds.

• Secondary part

The weld is located fully on the secondary part
side.

Does not affect V- or U-groove welds.
Preparation Defines which assembly parts, if any, are

automatically prepared for welding.

The options are:

• None

Parts are not prepared for welding.

This is the default option.

• Auto

Parts are prepared for welding according to the
weld type.

• Main part

The main part is prepared for welding.

• Secondary part

The secondary part is prepared for welding.
Weld
Prefix The weld size prefix. Shown in drawings, but only if

the weld size is also defined.

The standard ISO 2553 prefixes are:

• a - Design throat thickness

• s - Penetration throat thickness

• z - Leg length
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Setting Description

Note that if the last character of the prefix is s,
Tekla Structures creates the solid weld object
according to the right-hand image so that a equals
weld size.

Type See the list of weld types (page 367) below.
Size The size of the weld.

If you enter a negative weld size, Tekla Structures
creates the weld, but does not display it in
drawings. If you enter a zero weld size, Tekla
Structures creates the weld, and in drawings
displays the weld reference line and the weld type
symbol without the weld size.

For compound weld types  and , you
can enter two size values.

Angle The angle of weld preparation, bevels, or groove.

Enter a positive value for bevel and groove welds.

Tekla Structures displays the angle between the
weld type symbol and the fill type contour symbol.

Contour The fill type contour of a weld can be:

• None

• Flush 

• Convex 

• Concave 

This setting does not affect solid weld objects.
Finish Tekla Structures displays the finish symbol above

the weld type symbol in drawings. The options are:

• G (Grind)

• M (Machine)
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Setting Description
• C (Chip)

•  (Flush finished weld)

•  (Smooth blended weld face)

This setting does not affect solid weld objects.
Root face Root face thickness is the height of the narrowest

part inside the root opening.

Root face values do not appear in drawings, but
you can use the WELD_ROOT_FACE_THICKNESS
template attribute in reports to show the root face
dimension in the weld list.

Effective throat The weld size used in weld strength calculation.
Root opening The space between the welded parts.

Enter a positive value for square-groove welds.
# of incr. The amount of increments in an intermittent weld.

Only use with the ISO standard.
Length Defines the length value that is shown in the weld

mark.

For intermittent welds, defines the length of an
increment.

Does not affect continuous solid weld objects.
Pitch If the advanced option XS_AISC_WELD_MARK is set

to TRUE, the center-to-center spacing of weld
increments in an intermittent weld.

If the advanced option XS_AISC_WELD_MARK is set
to FALSE, the space between the weld increments
in an intermittent weld.

Tekla Structures uses the – character by default to
separate weld length and pitch, for example 50–
100. To change the separator to @, for example,
set the advanced option
XS_WELD_LENGTH_CC_SEPARATOR_CHAR to @.
Use these buttons to copy and to link together the
Above line and Below line property values.

Click the  and  buttons to copy values
between the Below line and Above line columns.

Click the  button to switch the linking on or off.
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Setting Description

The middle button is yellow  when the values
are linked. This means that if you change a value in
either of the columns, also the corresponding
value in the other column changes.

Tail information
NDT inspection level Defines the non-destructive testing and inspection

level.
Electrode classification Defines the weld electrode classification.
Electrode strength Defines the electrode strength.
Electrode coefficient Defines the electrode strength coefficient.
Process type Defines the process type.
Reference text Additional information to appear in the weld mark.

For example, information about the weld
specification or process.

The maximum number of characters that can be
shown is 80, including one character for each line
of text. To show long reference texts in reports,
also adjust the template field length accordingly.

Note that the special characters are shown in weld
marks in model views only if the Arial font supports
the special characters.

More
UDAs Click the User-defined attributes button to open

the user-defined attributes (UDAs) of the weld.
UDAs provide additional information about the
weld.

List of weld types

Use the weld properties to define the weld type. Some weld types also
automatically prepare the parts to be welded. The following table shows the
available weld types:

Number Type Name Optional
automatic

weld
preparation

Supported
solid weld

object

0  None No No
10 Fillet weld No Yes
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Number Type Name Optional
automatic

weld
preparation

Supported
solid weld

object

3 Bevel-groove
(single-V butt
weld)

Yes Yes

4 Bevel-groove
(single-bevel
butt weld)

Yes Yes

2 Square-
groove
(square butt
weld)

Yes Yes

5 Single-V butt
weld with
broad root
face

Yes Yes

6 Single-bevel
butt weld with
broad root
face

Yes Yes

7 U-groove weld
(single-U butt
weld)

Yes Yes

8 J-groove weld
(single-J butt
weld)

Yes Yes

16 Flare V-groove
weld

No No

15 Flare-bevel-
groove weld

No No

1 Edge-flange
weld

No No

17 Corner-flange
weld

No No

11 Plug weld No No

9 Bevel backing
weld

No No

12 Spot weld No No

13 Seam weld No No

14 Slot weld No No
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Number Type Name Optional
automatic

weld
preparation

Supported
solid weld

object

18 Partial
penetration
weld (single-
bevel butt +
fillet)

No Yes

19 Partial
penetration
weld (square
groove + fillet)

No Yes

20 Melt-through
weld

No No

21 Steep-flanked
single-V butt
weld

Yes Yes

22 Steep-flanked
single-bevel
butt weld

Yes Yes

23 Edge weld No No

24 Surfacing
weld

No No

25 Fold joint No No

26 Inclined joint No No

Welds in components
You can define the properties of the welds used in components. Tekla
Structures displays the appropriate weld dialog box when you click the Welds
button in the component properties dialog box.

The example image shows each weld definition using a number for the Bent
gusset (140) connection. For each weld definition, use the upper row to define
the above-line properties of the weld, and the lower row for the below-line
properties.

You can select the weld type from the Type list.

For compound welds  and , you can enter two size values.
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See also

Create welds (page 359)

Weld preparation
When parts are prepared for welding, their edges can be beveled to produce a
groove for the weld. You can define the angle of bevels and grooves.

You can either prepare a part for welding manually, or apply a component that
does it automatically, or you can use the Preparation options in the Weld
properties or in the component weld properties.

NOTE When you use components' weld preparation options, the supported weld
types (page 367) are placed correctly in the model. If you use cuts for
preparing the part edges, the welds may not be placed correctly.

Prepare a part for welding with a polygon
You can manually prepare a part for welding by cutting it with a polygonal
shape.

Before you start, ensure that the work plane (page 53) is on the plane you are
cutting on.

1. On the Steel tab, click Weld --> Prepare part for welding with polygon .

2. Select the part that you want to cut.

3. Pick positions to outline the polygon to be used for cutting. 

Extend the polygon outside the part, so that it is clear that the part edge
should be cut away.

4. Click the middle mouse button to close the polygon and to cut the part.
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(1) The part to be cut

(2) Cuts are displayed using dash-and-dot lines

Prepare a part for welding with another part
You can manually prepare a part for welding by cutting it with another part.
The cutting part will subsequently be deleted.

Before you start, create a cutting part and position it through the part you
want to cut.

1. On the Steel tab, click Weld --> Prepare part for welding with another
part .

2. Select the part that you want to cut.

3. Select the cutting part. 

(1) The part to be cut

(2) The cutting part

(3) Cuts are displayed using dash-and-dot lines

Set the visibility and appearance of welds
Modify the display settings to define how welds appear in the model.

1. Double-click the view to open the View Properties dialog box.

2. Click Display... to open the Display dialog box.

3. Ensure that the Welds check box is selected.

4. Select a representation option for welds: 
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• Fast

Use this option to show the weld symbols only.

• Exact

Use this option to show welds as solid objects with weld symbols, and
to display weld marks when you select welds.

• Exact - no weld mark

Use this option to show welds as solid objects without weld symbols.
Weld marks will not be displayed when you select welds.

5. Ensure that the view is being selected.

6. Click Modify to apply the changes. 
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NOTE If the representation option is Exact and you still cannot see the
weld object in the model, check that the following properties have
been defined for the weld in question:

• Size

• Type

• Angle

• Root opening

See also

Create welds (page 359)

Adjust the display settings (page 647)

Change a weld to a polygon weld
You can change existing welds to polygon welds if the existing welds have
been created by using the Create weld between parts command or by a
component. The new polygon welds will traverse the same points as the
original welds did.

When converting double-sided weld segments to a polygon weld, Tekla
Structures may not be able to create the polygon weld. If the welds to be
converted consist of more than one polygon, or if there is a different number
of weld segments on the sides of the welded part, Tekla Structures does not
create the double-sided polygon weld but separate single-sided polygon
welds.

1. Select the weld you want to change. 

To select multiple welds, hold down the Ctrl or Shift key.

2. On the Steel tab, click Weld --> Convert to polygon weld .

See also

Create welds (page 359)

Split a polygon weld
You can split a double-sided polygon weld into two single-sided polygon welds.

1. Select the double-sided polygon weld that you want to split.

2. Right-click and select Split.

See also

Create welds (page 359)

Change a weld to a polygon weld (page 373)
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Create user-defined cross sections for welds
You can define special cross sections for model welds. This is useful when you
need weld cross sections that are not predefined in Tekla Structures.

For example, you can create bevel backing welds:

To find the welds in the model that have a user-defined cross section, set
Category to Weld and Property to User-defined cross section in the
selection or view filter, or in the color and transparency settings.

Define a user-defined cross section for a weld

1. Select the weld you want to modify.

2. Right-click and select Define Cross Section.

3. In the weld cross section editor view:

a. Pick points to indicate the weld cross section corners.

b. Click the middle mouse button to finish picking.

Remove a user-defined cross section from a weld
You can remove user-defined cross sections from model welds and revert to
the previous standard cross sections.

1. Select a weld that has a user-defined cross section.

2. Right-click and select Remove Cross Section. 

Tekla Structures removes the user-defined cross section and uses the
previous standard cross section and properties for the weld.

Limitations

• User-defined weld cross sections are reported using only the above-line
properties.
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• User-defined weld cross sections do not create automatic weld
preparation.

Fit part ends
The Fit part end command adjusts the end of a beam or a column by creating
a fitting plane, perpendicular to the view plane that passes through the two
points you pick. Use the Fit part end command to cut or to extend the part
end, as needed. Do not use the command to make considerable extensions to
part length.

You can use the Fit part end command to adjust only the end of a beam or a
column, not the sides. The command affects the nearest end of the part.

TIP To make it easier to pick the points, ensure that you are working in a view
with a suitable view plane.

• In many cases you can create a view with a suitable view plane by
using the New view --> Default part views command. The command
creates views which have view planes along the main axes (x,y,z) of
the selected part.

• If you need the view plane on some other angle which is not along
the part axis, you can first define the work plane and then use the
New view --> On work plane command.

1. On the Edit tab, click Fit part end. 

2. Select the part that you want to adjust with a fitting.

3. Pick the first point of the fitting line.

4. Pick the second point of the fitting line. 
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The end of the part is adjusted.

If you apply a second fitting to the same part end, Tekla Structures will
ignore the first fitting, and use the second one. You can apply one fitting
and one or more line cuts (page 391) to the part end.

Note that when creating NC files in DSTV format, fittings affect the length
of the beam in the NC file. The overall length of a beam will be the fitted
net length of the beam.

If you want have more options on how to create and adjust fittings, use
the Fit beams and columns (page 376) or the Fit objects (page 380)
component.

See also

Fit beams and columns (page 376)

Fit objects (page 380)

Cut objects with a polygon, line, or part (page 389)
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Fit beams and columns
You can use the Fit beams and columns connection to connect two beams,
two columns, or a beam and a column with fittings and cuts only.

The fittings and cuts that connect the parts can be placed in several ways. You
can define that a gap is created between the parts, and use welds to connect
them.

The table below shows examples of the connections.

Example Description
Mitre connection

Fit both profiles

One of the two profiles is not cut

1. Select the Fit beams and columns component in the Applications &
components catalog.

2. To change the default properties, open the Fit beams and columns
component dialog box and modify the properties on the Settings tab.

3. Define the gap size between the main part and the secondary part. If you
do not enter any value, a gap is not created.
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 Description
1 Cut offset of the main part
2 Gap between the main part and the secondary part

4. Select the fitting type.

The type you select in list (1) defines which fitting methods are available in
list (2). For the fitting type options, see the image below.

(3) When both the main part and the secondary part are skewed, select
whether the fitting is created in the direction of the web or the flange.

The fitting type options are as follows:

 Description
1 Mitre
2 Secondary part is fitted to the main part, both parts are fitted.
3 Main part is fitted to the secondary part, both parts are fitted.
4 Secondary part is fitted to the main part, the main part is not

fitted.
5 Main part is fitted to the secondary part, the secondary part is

not fitted.
6 Secondary part is fitted with an overlap on the main part, both

parts are fitted.
7 Secondary part is fitted with an overlap on the main part, the

main part is not fitted.
8 Main part is fitted with an overlap on the secondary part, the

secondary part is not fitted.
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5. Define the maximum gap size between the main part and the secondary
part. To do this, select the following fitting type:

Select one of the following:

• Use default

The secondary part is fitted perpendicularly.

• Method by threshold

Define the gap threshold distance. If the distance between the main
part and the secondary part is shorter than the value you define, the
secondary part is fitted perpendicularly.

In the example image below, the distance is 150.0, while the value you
have defined is 200.0.

If the distance is greater than the threshold value you define, the fitting
on the secondary part is aligned with the main part.

In the example image below, the defined distance is 0.

• Define gap

The value you define is used as the distance to fit the secondary part.

In the example image below, the defined distance is 100.0.
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6. Select whether the Main part (1) and Secondary part (2) are fitted, or cut
with a line cut.

7. In Connect parts, select how the parts are connected:

• No: Parts are not connected.

• Cast unit: The secondary part is added to the main part cast unit.

• Sub assembly: The secondary part is added to the main part cast unit
as a sub-assembly.

• By welding: The secondary part is welded to the main part.

When you select By welding, you can define the weld properties on
the Welding tab.

8. On the Welding tab, define the weld properties.

For detailed information on the weld properties, see the Weld properties
section in Create welds (page 359).

9. Click OK.

10. In the model, select the main part (beam or column).

11. Select the secondary part (beam or column).

The connection is automatically created when you select the secondary
part.

Fit objects
You can use the Fit objects component to fit contour plates, slabs, beams,
columns, and panels in any order.

(1) Main part

(2) Secondary part

(3) Additional material
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For example, in concrete constructions, you can use the Fit objects
component to fit walls to sloping slabs and keep them connected. The walls
are fitted to follow the slab geometry, and they adapt to any changes made in
the slab.

You can also use the Fit objects component to fill the gap between inclined
slabs, such as ramps and horizontal floor slabs. Filling these gaps exactly
without small gaps or overlaps creates steady pours of these cast-in-place
parts.

Connection logic

The Fit objects component fits the secondary part to the main part by
creating cuts where necessary and filling the gaps with additional parts.

The component only fits secondary part faces that create an angle between
-35° and 35° degrees with the main part. The example image below shows that
additional material is not created for secondary parts with an angle more than
35°.

Once the main part and secondary part faces to be fitted have been identified,
the secondary part face is fitted in the direction of its adjacent faces.

(1) Face to be fitted
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(2) Adjacent faces

Planes are extended from the adjacent faces until they intersect with the main
part.

Additional material is created to fill the space between the extended planes,
the main part, and the secondary part.

Limitations

• Curved panels, polywalls, and polybeams are not supported.

• Fit to main part setting: With the Face projection option, only the closest
face of the main part is projected. Multiple faces cannot be projected.
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• Additional material is not always created from the same object type as the
secondary part. For example, for walls, the additional material is created as
a slab.

• Parts created with sketched profiles are not supported as secondary parts.

Fit objects in the model

We recommend that you first define the properties that you want to use when
fitting the objects. When you have defined the properties, select the parts that
you want to fit, and create the fitting in the model.

1. Select the Fit objects component in the Applications & components
catalog.

2. To change the default properties, open the Fit objects dialog box and
modify the properties.

3. Create gap: Define the gap distance between the main part and the
additional material or the secondary part. To create a fitting that is level
with the main part, leave the value as 0.0.

The gap distance is measured in the direction perpendicular to the
secondary part face, shown with the dashed line in the image below. After
the gap direction is established, the same gap is applied along the main
part face. In the example, the gap distance is 200 mm.
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When more than one face is fitted, the gap direction is perpendicular to
an imaginary line between the outer faces of the object. To use the same
example, when there is only one face between the outer faces, the
direction of the gap distance remains the same.

4. Create additional material: Select what kind of additional material is
created.

• As added material

Tekla Structures automatically attaches the added material (page 330)
to the secondary part to form one single combined part.

This is a useful option if you are creating quantity reports based on
parts, because quantities such as HEIGHT take into account the added
material and attempt to take the full height of the combined part.
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• As parts added to assembly/cast unit

Additional material is added to the cast unit (concrete) or assembly
(other material) of the fitted part.

• As loose parts

Additional material is created as a separate individual part.

• No

Additional material is not added to fill the gap between the part to be
fitted and the main part. Note that if the part to be fitted overlaps with
the main part, cuts are used to remove the overlapping material.

(1) Wall fitted only by cutting material

(2) Additional material not added
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5. Create to: Select whether the part is fitted to the nearest face or to all
faces within a certain distance.

• Nearest face only fits the nearest face to the main part.

Fit objects considers each secondary part face one at a time to
determine which secondary part face is closest to the main part. For
each face, Fit objects checks the following:

a. Identifies the center point of the secondary part face.

b. Creates a line from the center point of the secondary part face
towards the main part, perpendicular to the main part face, until
the line intersects with the main part.

c. Measures the line.

d. Repeats steps a - c for all secondary parts and the main part.

The shortest line indicates the two closest faces. The face
corresponding to the secondary part is the Nearest face.

(1) Shortest distance

(2) Face to be fitted (= nearest face)

The result is shown in the image below:

• Faces closer than fits all the faces that are closer than the specified
distance.

The distance is measured similarly as in Nearest face, except that all
points of a face need to be below the defined distance for that face to
be fitted.
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In the example above, the used limit distance is 1000 mm. The only
face that has all its vertexes closer than 1000 mm is the face near the
bottom, and it is therefore the only face fitted.

• Use Direct modification to manually select which secondary part
faces are to be fitted.

In the model, select the component. The green and red direct
modification handles that appear on the secondary part faces indicate
the faces that can be fitted.

Red and green faces indicate the faces that have been and that have
not been fitted, respectively. Click a green face to fit that face. Click a
red face to stop that face from getting fitted, as shown in the example
image below.

Create parts, reinforcement, and construction
objects

387 Add details to parts



6. Use fit part end if possible: Add fittings to parts in the same way as with
the Fit part end command (page 375).

This option only applies to those objects that can be fitted with the Fit
part end command: beams, columns, and footings. Slabs, plates, and
walls cannot be fitted in this way, so this option does not affect them.

• Yes: If possible, parts are fitted by using the Fit part end command.

• No: The Fit part end command is not used, and parts are fitted using
the option you select in Create additional material.
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7. Fit to main part: Define how the main part is used to fit the secondary
part.

• Actual face: The secondary parts are fitted exactly to the geometry of
the main part. The image below shows an example of Actual face
applied to a wall and a column.

• Face projection: The secondary parts are fitted to the plane that is
coplanar with the main part face. The image below shows an example
of Face projection applied to a wall and a column.

8. Click Modify to save the properties that you have defined.

9. Select the main part (part to be fitted to).

10. Select the secondary part (part to be fitted).

The part is fitted when you select the secondary part.

Cut objects with a polygon, line, or part
Use polygon cuts, lines cuts, or part cuts to shape a part in a model.

If you need to modify the length of a part, do not use cuts but move the part
handles (page 307). In addition to cuts, you can use the Fit part end command
to adjust the part end.

Create parts, reinforcement, and construction
objects

389 Add details to parts



NOTE Do not use cuts to cut a part into two. Numbering, material lists and drawings
will consider the part as one, not as two separate parts.

Do not use cuts to shorten steel parts because cuts are not taken into account
in LENGTH_GROSS, which is often used in steel material lists.

Cut objects with a polygon
Use a polygon cut to cut a part, or a rebar set, with a closed polygon,
perpendicular to the plane that is defined by the points you pick. Tekla
Structures displays the cut using dash-and-dot lines.

The depth of the cut is calculated automatically based on the dimensions of
the object to be cut. The Polygon cut command automatically extends the cut
slightly (3 mm) outside of the part face in depth direction.

Tekla Structures uses the parametric profile BL to create polygonal cuts.

TIP To make it easier to pick the points for a polygon cut in a 3D view on a
correct plane, use the New view --> Default part views command to
create a suitable view. The command creates views that have view planes
along the main axes (x,y,z) of the selected part.

1. On the Edit tab, click Polygon cut.

2. Select the object that you want to cut.

3. Pick points to outline the polygon to be used for cutting. 

When defining the polygon, do not place the cut edges exactly at the same
location as the edge of the part to be cut, as it can be unclear whether the
edge should be cut away or not.

4. Click the middle mouse button to close the polygon and to cut the object. 
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You can hide the cuts (page 395), if needed.

If you need to modify the cut shape, use direct modification (page 107) or
handles (page 307) to add or remove points, to add or change chamfers
(page 397), or move an edge.

Cut objects with a line
Use line cuts to shape a beam or a column, or to cut a plate, a slab, an item, or
a rebar set. A line cut creates a cutting plane, perpendicular to the view plane
that passes through the two points you pick. You can use the line cut to cut the
end of a part, or the side of a part, for example to make a part narrower. Tekla
Structures displays the cut using dash-and-dot lines.

You can have several line cuts to one part end.

TIP To make it easier to pick the points for the cutting line, ensure that you
are working in a view with a suitable view plane.

• In many cases you can create a view with a suitable view plane by
using the New view --> Default part views command. The command
creates views that have view planes along the main axes (x,y,z) of the
selected part.
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• If you need the view plane at some other angle, not along the part
axis, you can first define the work plane and then use the New view
--> On work plane command. Alternatively, you can use the 3D cut
component from the Applications & components catalog.

1. On the Edit tab, click Line cut.

2. Select the object that you want to cut. 

3. Pick the first point of the cutting line.

4. Pick the second point of the cutting line. 

5. Pick the side that you want to remove. 
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You can hide the cuts (page 395), if needed.

Cut objects with a part
You can cut a part, or a rebar set, using another part. Note that you can cut
parts that already have cuts. That can be useful, for example, when you want
to create more sophisticated cut shapes. Tekla Structures displays the cut
using dash-and-dot lines.

1. If you do not have a part to cut with, create a cutting part and position it
through the part you want to cut. 

Do not place the cutting part so that the cut edges or vertices are exactly
at the same location as the edges or vertices of the part to be cut. It may
be unclear what should be cut away.

2. On the Edit tab, click Part cut.

3. Select the object that you want to cut. 

4. Select the cutting part. 
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Using the cutting part, Tekla Structures creates the cut to the selected
object. The part cut does not affect other objects.

5. Delete the cutting part.

a. Ensure that the  Select cuts and added materials selection
switch is off.

b. Select the cutting part and press Delete. 

You can hide the cuts (page 395), if needed.
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Tips on how to cut efficiently
• Avoid part faces

Avoid placing cut edges, cut vertices, or other cuts cutting the same part
exactly at the same location as the edges or vertices of the part to be cut.
Extend the cut outside of the part or other cut at least 0.3 mm. This
practice helps you to avoid solid errors.

• Use polygon cuts

Whenever possible, use polygon cuts. The Polygon cut command
automatically extends the cut slightly outside of the part face in depth
direction.

• Use edge chamfers

Whenever possible, use edge chamfers (page 398) instead of small cuts,
especially in components.

• Tips for flange cuts of steel profiles

When cutting a flange, if the cutting part cuts very slightly the web as well
(at least 0.3 mm), the cut is more likely to succeed. For example, if you are
cutting a beam that has roundings, it may be useful to cut even further
onto the web in depth direction than just the flange thickness.

• Tips for round tube cuts

Use the Round tube (23) component for round tube cuts. The component
automatically rotates the cutting part until a successful cut position is
found. If the component fails, rotate the cutting part slightly until you find a
successful cut position.

• If a cut causes a solid error

If a cut causes a solid error, Tekla Structures is unable to render part faces
and the part becomes transparent, only some edge lines being visible.

An error notification is printed in the session history log stating which part
and which cut caused the failure.

To locate the failure in the model, click a row that contains a GUID identifier
in the session history log. Tekla Structures selects the corresponding part
and cut in the model.

To fix the error, move the problematic cut slightly (0.3 mm) to a different
direction. If the cut is intersecting with other cuts, you can try to move also
the other cuts.

Hide cuts in a model view

1. Double-click the view background to open the View Properties dialog
box.

2. Click Display... to open the Display dialog box.
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3. Ensure that the Cuts and added material option is not selected in the
display settings.

4. Click Modify.

5. If you want to temporarily display the hidden cuts in a model view:

a. Select the part.

b. Click  Display detailing on the contextual toolbar.

All the cuts of the selected part are displayed. To hide them again, redraw
the view (page 46).

Polygon cut properties
Use the Polygon cut properties in the property pane to view and modify the
properties of a polygon cut.

Note that the polygon cut properties are available in the property pane only
after a polygon cut has been created and selected. You cannot access or
modify the cut properties before the cut is created.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
Name Name of the polygon cut.
Profile Profile of the polygon cut, by default parametric

profile BL.
Material Material of the polygon cut, by default

ANTIMATERIAL.

The cut material cannot be changed.
Class Use to group polygon cuts.
Position
At depth Position of the polygon cut in depth direction.
More
UDAs Click the User-defined attributes button to open

the user-defined attributes (UDAs) of the cut. UDAs
can be used to store more information for each
cut, for example, to control the dimension creation
in drawings.
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Part cut properties

Part cut uses the properties of the cutting part. For example, if the cutting part
is a steel beam, part cut uses the Steel beam cut properties. The default part
cut properties depend on the used cutting part.

If the cutting part is a hollow section, the cut is created with a similar, but non-
hollow section, so that the inside of the cut is removed as well.

Note that the part cut properties are available in the property pane only after a
part cut has been created and selected. You cannot access or modify the cut
properties before the cut is created.

Chamfer part corners and edges
Chamfers are modeling details that can be used to refine the shape of parts
for aesthetic, practical, and manufacturing reasons. In Tekla Structures, you
can chamfer part corners and part edges.

Limitations:

• Only the following parts have corner chamfers: contour plates, concrete
slabs, strip footings, steel and concrete polybeams, and concrete panels.

• The end points of a part do not have corner chamfers. The handles that
you select must be at corner points or between two segments of a part.

Chamfer part corners
When Tekla Structures creates a part, by default it has a rectangular chamfer
at each corner, which does not change the geometry of the part. You can
modify the default chamfers.
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TIP To make it easier to select the handles of part corners, ensure that the

Direct modification switch  is not active.

1. Select the part.

2. Double-click the handle of a part corner. 

The Corner chamfer properties open.

3. Modify the chamfer properties.

4. Select the handles of the part corners you want to modify.

5. Click Modify.

Chamfer part edges
1. Double-click the view to open the View Properties dialog, click the

Display... button, and ensure that the Cuts and added material option is
not selected in the display settings.

2. On the Edit tab, click Chamfer edge. 

Alternatively, you can start the command in the Object type list in the
property pane.

3. Select the part you want to chamfer.

4. Pick a point where you want the chamfer to start on the part edge.

5. Pick a second point where you want the chamfer to end on the part edge. 

Tekla Structures displays the chamfer in light blue.

6. If needed, you can modify the chamfer.

a. Double-click the chamfer to open the Edge chamfer properties.

b. Change the chamfer properties.

c. Click Modify. 

TIP Alternatively, use the contextual toolbar to modify the edge
chamfer.

7. Right-click the view and select Redraw view. 
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Tekla Structures removes the chamfered edge.

Corner chamfer properties
Use the Corner chamfer properties in the property pane to view and modify
the properties of a corner chamfer. To open the properties, double-click the
handle of chamfered corner.

The units depend on the settings in File menu --> Settings --> Options -->
Units and decimals .

Setting Description
Shape
Type Shape of the chamfer. See Corner

chamfer types and dimensions for
more information.

X / Distance X / Radius Dimensions of the chamfer. The
dimension depends on the chamfer
type.

Y / Distance Y / Radius

Dz1 Only used for contour plates and
concrete slabs.

Moves the top or bottom surface of
the part corner in the part’s local z
direction.

Use these options, for example, to
give plates varying thicknesses.

Dz2

Corner chamfer types and dimensions

The table below describes the available corner chamfer types and dimensions.
The chamfer type numbers can be used in sketches and custom components.
Straight chamfers can have different dimensions in two directions. Curved
chamfers only use one dimension.
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Numbe
r

Type Symbol Dimensions

0 None x: not used

y: not used
1 Line x:the distance in the x coordinate

direction from the corner

y: the distance in the y coordinate
direction from the corner

2 Rounding x: the radius

y: not used
3 Arc x: the radius

y: not used
4 Arc point x: not used

y: not used
5 Square The chamfer is perpendicular to the

edges.

x: the distance in the x coordinate
direction from the corner

y: the distance in the y coordinate
direction from the corner

6 Square parallel The chamfer is parallel to the
opposite edge.

x: the distance in the x coordinate
direction from the corner

y: the distance in the y coordinate
direction from the corner

7 Line and arc x (if smaller than y): the arc radius

x (if bigger than y): the distance in the
x coordinate direction from the
corner

y (if smaller than x): the arc radius

y (if bigger than x): the distance in the
y coordinate direction from the
corner

Status of corner chamfers in polybeams

To see the corner chamfer lines of polybeams, set the advanced option XS_
DRAW_CHAMFERS_HANDLES to CHAMFERS or to CHAMFERS_AND_HANDLES.

Tekla Structures shows the status of polybeam chamfers using the following
colors:

Create parts, reinforcement, and construction
objects

400 Add details to parts



Color Description Example
Magenta Correct chamfer

Yellow Correct chamfer that
cannot be unfolded

Red Incorrect chamfer

Edge chamfer properties
Use the Edge chamfer properties in the property pane to view and modify the
properties of an edge chamfer. To open the properties, double-click the edge
chamfer when the chamfer if visible in the model. The file name extension of
an edge chamfer property file is *.cha.

The units depend on the settings in File menu --> Settings --> Options -->
Units and decimals .

Setting Description More information
Shape on edge
Type Shape of the chamfer.  
Distance X Defines how far away

from the chamfered
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Setting Description More information
edge the chamfer will
end in the x direction.

Distance Y Defines how far away
from the chamfered
edge the chamfer will
end in the y direction.

 

Shape at end
First end type The shape and position

of the first end point.
The options are:

• Full: The end point is
positioned at the end
of the part (moving
along the nearest
edge), and the shape
is straight.

• Straight: The end
point is positioned at
the point you pick,
and the shape is
straight.

• Bevelled: The end
point is positioned at
the point you pick,
and the shape is
angled.

Second end type The shape and position
of the second end point.

Distance The distance between
the (picked) end point
and the bevelled points.

 

General
Name Name of the chamfer.  

Add surface treatment to parts
Use the surface treatment tools to add surface treatment to parts. Surface
treatment for concrete parts include flat finishes, surface mixes, and tiles.
Surface treatment for steel parts include fire-proofing and unpainted areas, for
example.
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When you modify the shape or size of a part, Tekla Structures automatically
modifies the surface treatment to fit the part (page 416).

When you create overlapping surface treatments, the smaller surface
treatment overrides the larger one. The overlapping area is recognized in
reports: only the topmost (visible) surface treatment is calculated.

Add surface treatment to an entire part face
1. On the Edit tab, click Surfaces --> Surface treatment to part face .

2. Pick the origin of the surface treatment.

3. Pick a point to indicate the direction of the surface treatment.

4. Select the part to apply the surface treatment to.

a. Move the mouse cursor over a part. Tekla Structures highlights the
faces that you can select.

b. Select the part face.

Add surface treatment to a selected area on a part face
1. On the Edit tab, click Surfaces --> Surface treatment to selected area .

2. Pick the origin of the surface treatment.

3. Pick a point to indicate the direction of the surface treatment.
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4. Select an area of the part face to apply the surface treatment to.

a. Move the mouse pointer over a part. Tekla Structures highlights the
faces that you can select.

b. Select the part face.

c. Pick three or more points on the part face to define a polygonal area.

Add surface treatment to all faces of a part
1. On the Edit tab, click Surfaces --> Surface treatment to all faces of

part .

2. Select the part to apply the surface treatment to.

Add surface treatment to cut faces
1. On the Edit tab, click Surfaces and then either Surface treatment to

part face or Surface treatment to selected area.

2. Pick the origin of the surface treatment.

3. Pick the direction.

4. Select the cut face to apply the surface treatment to: 

5. If you are using the Surface treatment to selected area command, pick
the points to define the area of the surface treatment.

Surface treatment on chamfered parts
Take these things into account when adding surface treatment to chamfered
parts:

• Surface treatment does not work on sketched profiles with chamfers.
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• Add surface treatment before chamfering the part. If surface treatment is
applied to a chamfered part, the surface treatment chamfer cannot be
modified later on.

• The chamfers for the main part and surface treatment are separate.
Modifying the main part chamfer does not affect the surface treatment
chamfer.

• The orientation of unsymmetrical chamfers depends on the face where it
was created (such as top, bottom, left, or right). To change the orientation
of an unsymmetrical chamfer, you must swap the chamfer's x and y values.

Surface treatment on parts with openings and recesses

To force Tekla Structures to consider openings and recesses in parts when
adding surface treatment, set the Cut by father part cuts to Yes in the
Surface treatment properties.

(1) The green surface treatment has the Cut by father part cuts set to Yes.

(2) The tiled surface treatment is not cut by the cut in the part: Cut by father
part cuts is set to No.

NOTE If you use the Surface treatment to all faces of part command and
set the Cut by father part cuts to Yes, Tekla Structures automatically
adds surface treatment also to the cut faces.

Modify surface treatment properties
1. If the property pane is not open, double-click the surface treatment to

open the Surface treatment properties.

2. Change the properties as needed.
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3. Click Modify.

Note that if you modify the Pattern properties, you need to first click Modify
in the property pane and then redraw the view to make the changes visible.

Surface treatment properties
Use the Surface treatment properties in the property pane to view and
modify the properties of a surface treatment. To open the properties, double-
click the surface treatment. The file name extension of a surface treatment
property file is *.srf.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
Name User-definable name of the surface

treatment.

The name can contain a maximum of
61 characters.

Type Select the type of surface treatment.
Subtype Select the subtype of a specific

surface treatment.
Material Depending on the type of the surface

treatment, select the material of the
surface treatment.

Color Depending on the type of the surface
treatment, set the color of the surface
treatment.

Thickness Depending on the type of the surface
treatment, enter the thickness of the
surface treatment.

Cut by father part cuts To force Tekla Structures to consider
openings and recesses in parts when
adding surface treatment, set this to
Yes.

Position
In depth Select the location of the surface

treatment, and set the Depth offset
value.

Pattern (for tiled surface treatment)
Pattern If you have set Tile surface as the

Type of the surface treatment, select
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Setting Description
the pattern of the tiled surface
treatment.

Tile width

Tile height

Define the tile width and height.

Mortar height

Mortar width

Define the mortar height and width.

Tile color

Mortar color

If needed, use the color picker to pick
the tile and the mortar color.

More  
UDAs Click the User-defined attributes

button to open the user-defined
attributes (UDAs) of the surface
treatment. UDAs provide more
information about the surface
treatment.

Define new surface treatment subtypes
You can add new options to the Subtype list in the Surface treatment
properties by editing the product_finishes.dat file.

NOTE This section is for advanced users.

1. Copy the product_finishes.dat file to your firm, project, or model
folder. The file is located under the \ProgramData\Trimble\Tekla
Structures\<version>\environments folder. The exact file location
may vary depending on the folder structure of your environment files.

2. Open the copied file using any text editor. 

The first section of the file explains the available types of surface
treatment. The surface treatment types are hard-coded, so do not modify
this section:

3. Go to the sections that define the options for each type of surface
treatment: 
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4. Add rows to define new options.

a. Define the surface treatment type. For example, 1 for concrete finish.

b. Define a code for the surface treatment option. For example, MF for
Magnesium Float.

c. Define the full name of the surface treatment option. For example, 
Magnesium Float. Remember to enclose the name in double
quotes " ".

5. Save the file.

See also

Add surface treatment to parts (page 402)

Tiled surface treatment
Tekla Structures includes complex tile and brick surface treatment options,
such as basketweave and herringbone patterns. Tiled surface treatment
options are based on repeating tile patterns that are stored in XML format.

The tile pattern surface treatment are available in Surface treatment
properties if you have set the Type to Tile surface.

NOTE This section is for advanced users.

Define a new tile pattern

1. Copy the TilePatternCatalog.xml file to your firm, project, or model
folder. The file is located under the \ProgramData\Trimble\Tekla
Structures\<version>\environments folder. The exact file location
may vary depending on the folder structure of your environment files.

2. Open the copied file using any text editor.

3. Add a new <TilePattern> element to the file. 
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The <TilePattern> element must have <HOffset> and <VOffset>
elements and at least one <Tile> element. Other elements are optional.

TIP You may find it easier to copy one of the existing elements, and then
modify it to suit your needs.

4. Repeat adding <TilePattern> elements for all the patterns you want to
define.

5. Save the TilePatternCatalog.xml file.

Example tile pattern definition
This example explains how the Basketweave tile pattern is defined in the
TilePatternCatalog.xml file.

The Basketweave pattern block is made up of eight tiles:

(1) Tile width

(2) Mortar width

(3) VOffset
(4) HOffset
(5) Red marks indicate TileOrigin. Angle value for vertical tiles is 90.

(6) Tile height

(7) Mortar height

The pattern is repeated in the x and y direction of the surface treatment,
starting from the origin of the surface treatment. You can run the pattern in
different x directions:
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In the TilePatternCatalog.xml file, the pattern is defined as follows:

(1) Name of the pattern

(2) Size of the pattern block in the x direction, after which the pattern repeats

(3) Size of the pattern block in the y direction, after which the pattern repeats
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The definition file uses the same symbols as the Surface treatment
properties:

Tile pattern definitions

The predefined tile patterns that are available in the Surface treatment
properties are stored in the following files:

File Description
TilePatternCatalog.xml • Contains the tile pattern

definitions.

• Located under the \ProgramData
\Trimble\Tekla Structures
\<version>\environments
folder.

TilePatternCatalog.dtd • Document Type Declaration (DTD)
file that defines the elements
allowed in the
TilePatternCatalog.xml file.

• Located in the same folder as the
TilePatternCatalog.xml file.

Thumbnail images • The images that appear in the
Pattern section in the Surface
treatment properties.

• Located in the ..\ProgramData
\Trimble\Tekla Structures
\<version>\Bitmaps folder.

• File names identify the pattern
types. For example,
herringbone.bmp illustrates the
herringbone pattern type.
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Tile pattern elements

The TilePatternCatalog.xml file can contain the following elements:

Element Description
TilePatternCatalog The container for tile patterns.

Required.
TilePattern Tile pattern element. Required. This

element can contain the following
elements listed in this table.

HOffset Horizontal offset of the tile pattern.
Required.

VOffset Vertical offset of the tile pattern.
Required.

Tile The individual tiles used in a tile
pattern. At least one required.

Color Color of the tile or mortar, defined by
the RGB values (0–255). Optional.

Parameter Creates an attribute for any element
in the TilePattern. Optional.

Label The label that identifies a parameter
in the Surface treatment properties.
Optional.

TileOrigin The origin of an individual tile,
defined from the origin of the
pattern. Optional.

Create an unpainted area using the No paint area component
You can create an unpainted area between bolted steel parts using the No
paint area component.

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Search for No paint area.

3. On the General tab:

a. Click the Load bolt standards button to display the available bolt
standards, and select the relevant standards.

b. Select the clearance location from the Create for list. 
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• Define the hole tolerance.

• Define the contact area offset.

c. In the Allowable gap box, enter the maximum distance that can exist
between two plates so that the surface treatment can be created.

4. On the Surfacing attributes tab:

a. Select one of the following Surfacing attributes. 

• standard surface treatment properties file

• A custom surface treatment properties file

You can create your own property files in the Surface treatment
properties. The Type has to be Steel finish and the Subtype has
to be UP - Unpainted.

• ...
Define the custom attributes and the position for the surface
treatment.

5. Click OK.

6. Select a bolt group in the model. 
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The unpainted area is created between the bolted parts.

See also

Add surface treatment to parts (page 402)

Add surfaces to part faces and pour object faces
You can add surfaces to the faces of parts and pour objects in the model. You
can add surfaces to any face geometry, for example curved faces. You can use
surfaces for calculating surface areas, such as formwork areas, or for defining
face-specific concrete covers for rebar sets.

Each surface is added to a single flat or curved face. Surfaces do not extend
over fillet edges between flat and curved faces.

Surfaces are associated with the objects they are attached to. Surfaces cannot
exist as standalone objects. A surface can be associated either with a cast-in-
place part or a pour object, but not with both. Surfaces associated with parts
or pours can be shown in reports as belonging to those objects.

If you modify the geometry of the associated part, the surface will adapt to the
changes. If you copy, move, or delete the associated part, the surface will
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follow. If a part and one or more of its surfaces are selected and copied or
moved, all the surfaces of the part will follow.

If a surface is added to a pour object, it will not automatically adapt to changes
that only affect the pour object, such as inserting pour breaks. The surface will
not be copied if the parts that form the pour object are copied.

You can also copy and move surfaces separately from the objects they are
attached to, but only within the same object type, i.e. from a part to another
part, or from a pour object to another pour object. The source object face and
the target object face need to be similar enough and facing in the same
direction. The point picked when the source surface was created must also
land on the target face.

Limitations:

• Surfaces do not recognize faces created by displaying objects with high
accuracy, such as curved profile fillets.

• Surfaces do not have handles, so their geometry cannot be modified
separately from the associated object.

• Surfaces are not shown in drawings.

Add a surface to a face
1. On the Edit tab, click Surfaces --> Add surface to face.

2. Depending on whether you want to create the surface on a part or on a
pour object, use a part view or a pour view (page 447). 

To switch between part and pour views, click Pour view on the Concrete
tab.

3. Select the part face or pour object face to which you want to add the
surface. 

Tekla Structures adds the surface using the Surface properties in the
property pane.

If you modify the properties, Tekla Structures uses the new properties the
next time you create an object of the same type.

Modify surface properties
1. If the property pane is not open, double-click the surface to open the

Surface properties.

2. Change the properties as needed. 

For example, you can define the surface type and whether you want the
surface to be cut by the holes in the part or pour object.

If you want to use the surface for defining a specific concrete cover
thickness (page 558) for rebar sets at this part face or pour object face, set
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Type to Concrete cover and then enter the value in the Concrete cover
box in the Rebar set section.

3. Click Modify.

Modify the adaptivity of reinforcement, surface treatment,
or edge chamfers in parts
Reinforcement, surface treatment and edge chamfers adapt to the parts they
are linked to. For example, reinforcement, surface treatment and edge
chamfers automatically adapt to changes in part geometry and size. You can
modify the adaptivity settings either for the entire model or for each model
object separately. If you modify the adaptivity of individual model objects,
these modifications override the default settings that you may have defined
for the entire model.

The options are:

• Off: adaptivity is not defined

• Relative: handles retain their relative distances to the nearest part faces in
relation to the part's overall size

• Fixed: handles retain their absolute distances to the nearest part faces

Define default adaptivity settings
You can define default adaptivity settings that affect the entire model.

1. On the File menu, click Settings --> Options , and go to the General
settings.

2. Under Default adaptivity, select one of the options.

3. Click OK to save the changes.

Modify the adaptivity of an individual model object
You can modify the adaptivity settings for each reinforcement or surface
treatment separately. These modifications override the default settings that
you may have defined for the entire model.

1. In the model, select the reinforcement (page 561) or surface treatment
(page 402) whose adaptivity settings you want to change.

2. Right-click, select Adaptivity, and then select one of the options.

Display detailing of a part
In some cases it is useful to see in the model all the objects that are connected
to a part, such as components, welds, fittings, reinforcement, and surfaces.
You can then examine, for example, whether parts are welded correctly.
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1. Select a part.

2. Click  Display detailing on the contextual toolbar. 

Alternatively, you can use Quick Launch.

Tekla Structures displays all bolts, welds, cuts, fittings, and other details
belonging to the part, even if you had defined them as hidden in the display
settings (page 647). For concrete parts, Tekla Structures displays also
reinforcement, surface treatment, and surfaces.

See also

Add details to parts (page 341)

Adjust how model objects are displayed (page 642)

2.5 Work with assemblies
In Tekla Structures, assembly is a structure that consists of one or several parts
or items and possibly other objects, such as bolts, welds and reinforcement.
When a part or an item is modeled, Tekla Structures automatically creates an
assembly for it. This means that also a loose part or an item has an assembly.
When you model more parts in Tekla Structures, you may need to merge
several parts into one assembly or join several assemblies together.

Building up assemblies

There are different methods on how to form assemblies in the model and
achieve the desired assembly structure. The structure can be flat where the
assemblies are on one level, or there can be sub-assemblies on several
assembly levels in the assembly structure.

Try out the different ways of composing assembly structures to find out which
ones suit your purposes. Note that the different methods to form the
assemblies may affect your drawings and reports. We recommend you to test
the different outputs early on in the modeling phase to ensure that all the
relevant assembly information is included in the needed deliverables, such as
production drawings.

If needed, you can later add parts and assemblies to existing assemblies, or
otherwise modify the assembly structure (page 426) to produce the desired
outcome.

Additionally, consider the direction how you form the assembly: it might be
useful to build the assembly from bottom to top, so that you first create sub-
assemblies and then form a higher-level assembly (page 419) that includes the
sub-assemblies.

NOTE Concrete cast units (page 430) are technically considered as
assemblies, and they have similar commands available as steel
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assemblies. In some cases, the assembly commands need to be used
for cast units as well.

Hierarchical assemblies

A sub-assembly is an assembly that is added to another assembly to form a
hierarchical nested assembly (page 419). A hierarchical assembly consists of
the highest level (main) assembly, and one or more levels of sub-assemblies
under it. Hierarchical assemblies support the manufacturing process of large
assemblies, by enabling the combining of assemblies from smaller sub-
assemblies into a larger one.

Note that the assembly hierarchy affects the drawing and report outputs.
Report and drawing templates need to be made with similar hierarchy as the
assembly hierarchy in the model in order to output the data from the correct
assembly levels.

Assembly types and assembly hierarchy
Before you start to build up the assemblies in the model, consider the needed
assembly structure, how it needs to be composed, and how is affects the
drawings and reports. There are several methods how the assembly structure
can be formed, depending on the needed structure.

Method Assembly type More information
Bolt or weld parts to an
existing assembly as
secondary parts.

Basic assembly Use bolts and welds to
create and connect
assemblies and sub-
assemblies (page 424)

Add parts to an existing
assembly a secondary
parts.

Basic assembly Add parts to an existing
assembly (page 427)

Bolt or weld assemblies
to an existing assembly
as sub-assemblies.

Nested assembly Use bolts and welds to
create and connect
assemblies and sub-
assemblies (page 424)

Add parts or assemblies
to an existing assembly
as sub-assemblies.

Nested assembly Create nested
assemblies (page 427)

Join existing assemblies
together without adding
any loose parts.

Nested assembly Join existing assemblies
(page 427)

TIP To easily check the structure and hierarchy of an assembly, use the
Assembly tree viewer tool from Tekla Warehouse.
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Assembly types

Single-part assembly and basic assembly

A single-part assembly consists of one single part. When a part is modeled,
Tekla Structures automatically creates an assembly for it.

A basic assembly consists of a main part with secondary parts, and the
assembly is on one assembly level.

assembly

main part

Basic assembly

secondary part

secondary part

secondary part

assembly

main part

Single-part assembly

Tekla Structures creates basic assemblies when you:

• Use workshop bolts or workshop welds to manually connect parts
together.

• Apply a component that automatically creates workshop welds or
workshop bolts.

• Use the Add to assembly command to add parts to an existing assembly
as secondary parts.

The main part in an assembly has other parts welded or bolted to it, or added
with the Add to assembly command. By default, the main part is not welded
or bolted to any other parts. You can change the main part if needed.

Nested assembly

A nested assembly consists of a parent assembly and sub-assemblies which are
on the lower assembly levels in the assembly hierarchy.

Tekla Structures creates a nested assembly when you:

• Use bolts or welds to connect assemblies to an existing assembly as sub-
assemblies.
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• Use the Add as sub-assembly command to add parts or assemblies to an
existing assembly as sub-assemblies.

Nested assembly Assembly level in
assembly hierarchy

0

2

1

3

sub-assembly

sub-assembly

sub-assembly

assembly

Another type of a nested assembly is created when you join existing
assemblies as sub-assemblies. The sub-assemblies are on the same assembly
level.

Use the Join as sub-assemblies command to join existing assemblies
together. You can add assemblies as sub-assemblies, but not any loose parts
(parts or items).

Higher-level assembly

sub-assembly

sub-assembly

sub-assembly

assembly
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NOTE Sub-assemblies in a nested assembly retain their own assembly
information and main part. You can define the properties separately
for the sub-assemblies and the parent assembly.

To select assemblies in different assembly hierarchy levels, place the
mouse pointer on any part in the assembly, press Shift and scroll up
or down with the middle mouse button.

How to check the assembly hierarchy in a nested assembly
You can work on any level of a nested assembly, from single parts and bolts,
through the sub-assemblies, up to the highest level of the nested assembly.

The active selection switch defines on which level you start and toward which
direction you move in the assembly hierarchy. The status bar shows the level
of the assembly hierarchy you are on.

The assembly on the highest hierarchy level gets the number 0, and the
assemblies or objects inside an assembly lower in the hierarchy get the
number 1, 2, and so on. You can continue to level 9.

• When the  Select assemblies selection switch is active:

Start from the assemblies on the highest level, move to their sub-
assemblies, and finally select single parts, bolts, and so on.

To shift to a specific level in an assembly, place the mouse pointer on any
part in the assembly, press Shift and scroll up with the middle mouse
button to highlight the objects on the lower levels in assembly hierarchy,
level by level.

• When the  Select objects in assemblies selection switch is active:

Start from single objects and move to higher levels of nested assemblies.

To shift to a specific level in an assembly, place the mouse pointer on any
part in the assembly, press Shift and scroll up with the middle mouse
button to highlight the objects on the higher levels in assembly hierarchy.

The blue highlighting box indicates the assembly that you can select.
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The assembly hierarchy in nested assemblies affects drawings and reports.
Report and drawing templates need to be made with similar hierarchy as the
assembly hierarchy in the model to output the data from the correct assembly
levels.
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You can create separate drawings and reports of the sub-assemblies and the
nested assembly, and still produce dimensions, marks, fabrication information,
and so on for all the assembly levels.

For more information how to work with the assembly hierarchy, watch the
Working with multi-level assemblies video.

Assembly examples

Column corbel

A column corbel is fabricated in one workshop, and then attached to the
column in another workshop. Model the corbel as a sub-assembly of the
column. Then create an assembly drawing for each workshop: one assembly
drawing showing how the corbel is welded together, another assembly
drawing showing how the corbel and the other parts are welded to the
column.
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(1) Drawing 1, Workshop 1

(2) Drawing 2, Workshop 2

Complex truss

Model the halves of a complex truss as assemblies. Create assembly drawings
for the workshop to fabricate the truss halves. Then create another assembly
drawing showing how the halves should be joined on site.

Built-up profile

In a frame of built-up columns and beams, each built-up profile can be a sub-
assembly. You can create an assembly drawing showing the entire frame, and
separate drawings showing how the columns and beams are constructed.

Use bolts and welds to create and connect assemblies and
sub-assemblies
You can use bolt and weld properties in the property pane to create
assemblies, or to connect sub-assemblies to an existing assembly.

Use bolts to create and connect assemblies
Assemblies and their main parts are automatically defined when you create
workshop bolts. Additionally, you can connect more parts to assemblies by
using bolts, or create nested assemblies by connecting sub-assemblies to an
existing assembly.

To control how Tekla Structures creates the assembly, use the Connect as and
Bolt type lists in the Bolt properties in the property pane

The order in which you select parts when creating the bolt determines the
main and secondary parts of the assembly, or the assembly hierarchy.

Assembly type Connect as Bolt type Result
Basic assembly As secondary

part
Workshop Basic assembly

with the part you
are bolting as a
secondary part.

The first part you
select usually
becomes the
main part in the
assembly.

Nested assembly As sub-assembly Workshop or Site Nested assembly
with the assembly
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Assembly type Connect as Bolt type Result
you are bolting as
a sub-assembly.

The first part you
select determines
the assembly to
which you are
bolting.

 As secondary
part

Site No assembly
created.

Bolt secondary parts to an assembly

1. Open the Bolt properties in the property pane.

2. In the Connect as list, select As secondary part.

3. Select the main part to which the secondary parts will be bolted.

4. Select the secondary parts.

5. Click the middle mouse button to finish selecting parts.

6. Pick a point to indicate the bolt group origin.

7. Pick a second point to indicate the bolt group x direction.

Bolt sub-assemblies to an assembly

1. Open the Bolt properties in the property pane.

2. In the Connect as list, select As sub-assembly.

3. Select a part in the assembly to bolt to.

4. Select a part in the sub-assembly to be bolted.

5. Click the middle mouse button to finish selecting parts.

6. Pick a point to indicate the bolt group origin.

7. Pick a second point to indicate the bolt group x direction.

Use welds to create and connect assemblies
Assemblies and their main parts are automatically defined when you create
workshop welds. Additionally, you can connect more parts to assemblies by
using welds, or create nested assemblies by connecting sub-assemblies to an
existing assembly.

To control how Tekla Structures creates the assembly, use the Connect as and
Workshop/Site lists in the Weld properties in the property pane

The order in which you select parts when creating the weld determines the
main and secondary parts of the assembly, or the assembly hierarchy. The first

Create parts, reinforcement, and construction
objects

425 Work with assemblies



part you select becomes the main part of the assembly. Tekla Structures
dimensions secondary parts relative to the main part in assembly drawings.

Assembly type Connect as Bolt type Result
Basic assembly As secondary

part Workshop: 
Basic assembly
with the part you
are welding as a
secondary part.

The first part you
select usually
becomes the
main part in the
assembly.

Nested assembly As sub-assembly
Workshop: 

or Site: 

Nested assembly
with the assembly
you are welding
as a sub-
assembly.

The first part you
select determines
the assembly to
which you are
welding.

 As secondary
part Site: 

No assembly
created.

Weld secondary parts to an assembly

1. Open the Weld properties in the property pane.

2. In the Connect as list, select As secondary part.

3. Select the part to weld to.

4. Select the parts to be welded.

Weld sub-assemblies to an assembly

1. Open the Weld properties in the property pane.

2. In the Connect as list, select As sub-assembly.

3. Select a part in the assembly to weld to.

4. Select a part in the sub-assembly to be welded.

Modify the assembly structure
You can modify the assembly structure by adding more parts or assemblies, or
by changing the main part of an assembly, for example.
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Concrete cast units (page 430) are technically considered as assemblies, and
they have similar command available as steel assemblies. In some cases, the
assembly commands need to be used for cast units as well.

NOTE The active selection switch controls whether you can select assemblies or
parts when you use the different assembly commands.

Add parts to an existing assembly
You can add secondary parts to a basic assembly, or to any level of a nested
assembly.

1. Ensure that the Select objects in assemblies  or Select objects in

components  selection switch is active. 

2. Select the parts you want to add.

3. Right-click and select Assembly --> Add to assembly.

4. Select the assembly to which you want to add the parts.

Create nested assemblies
You can add parts and assemblies as sub-assemblies in another assembly on a
lower level in the assembly hierarchy.

1. Ensure that the Select assemblies  selection switch is active.

2. Select the parts or assemblies you want to add to another assembly. 

They will become sub-assemblies in the nested assembly.

3. Right-click and select Assembly --> Add as sub-assembly.

4. Select the assembly to which you want to add the parts or assemblies.

Alternatively, you can use the Assembly --> Add as sub-assembly command
on the ribbon.

Join existing assemblies
You can join existing assemblies as sub-assemblies without adding any loose
parts. The joined sub-assemblies are on the same assembly level. For example,
you can model two halves of a complex truss as assemblies, and then join the
halves together to form a higher-level assembly that contains the halves as
sub-assemblies. The assembly with the largest volume becomes the main
assembly.

1. Ensure that the Select assemblies  selection switch is active.
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2. Select the assemblies you want to join.

3. Right-click and select Assembly --> Join as sub-assemblies.

Alternatively, you can use the Assembly --> Join as sub-assemblies command
on the ribbon.

NOTE This command adds a new assembly hierarchy level on top, and the
resulting new assembly contains only sub-assemblies.

If needed, you can change the main assembly. Use the Assembly -->
Set as main object command on the ribbon.

Create a sub-assembly of assembly parts
You can create a sub-assembly of parts that are already in an assembly.

1. Ensure that the Select objects in assemblies  or Select objects in

components  selection switch is active.

2. Select the parts you want to include in the sub-assembly. 

Note that you need to select several parts to create the sub-assembly.

3. Right-click and select Make into Sub-Assembly.

Check and highlight objects in an assembly
Use the Inquire tool to check which objects belong to a particular assembly,
cast unit, or rebar assembly.

1. On the ribbon, click the down arrow next to , and then select
Assembly objects to inquire the assembly objects.

2. Select an assembly, cast unit, or rebar assembly. Ensure that you are on
the intended assembly hierarchy level. 

Tekla Structures highlights the other objects that belong to the same
assembly, cast unit, or rebar assembly. The following colors are used:

Object type Highlight color
Steel part - main part

Main reinforcement object in rebar
assembly

orange

Steel part - secondary part

Secondary reinforcement object in
rebar assembly

yellow

Concrete - main part magenta
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Object type Highlight color
Concrete - secondary part cyan
Reinforcement in cast unit blue

Change the main part in an assembly
The main part in an assembly has other parts welded or bolted to it. By
default, the main part is not welded or bolted to any other parts. You can
change the main part in an assembly.

1. If needed, check what is currently the main part of the assembly. 

Use the Inquire tool to check which objects belong to a particular
assembly.

To easily check the structure and hierarchy of an assembly, use the
Assembly tree viewer tool from Tekla Warehouse.

2. Ensure that the Select objects in assemblies  or Select objects in

components  selection switch is active.

3. Select the new main part.

4. Right-click and select Assembly --> Set as new main part of assembly. 

Tekla Structures changes the main part.

Alternatively, you can use the Assembly --> Set as main object command on
the ribbon.

Use this command also to change the main part in a concrete cast unit.

Change the main assembly
If you have joined existing assemblies together, the assembly with the largest
volume has become the main assembly. You can change the main assembly
within the sub-assemblies.

1. Ensure that the Select assemblies  selection switch is active.

2. Place the mouse pointer on any part in the assembly, press Shift and
scroll with the middle mouse button in the assembly hierarchy to see the
sub-assemblies.

3. Select the new main assembly.
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4. Right-click and select Set as new main sub-assembly. 

Tekla Structures changes the main sub-assembly. When the assembly is
inquired, Tekla Structures highlights the main sub-assembly's main part in
orange.

Alternatively, you can use the Assembly --> Set as main object command on
the ribbon.

Remove objects from assemblies
If you want to disassemble your assembly, you can remove objects from an
assembly, or ungroup the objects belonging to an assembly.

Remove a part or a sub-assembly from an assembly
1. Select the part or sub-assembly you want to remove.

2. Right-click and select Assembly --> Remove from assembly.

3. To remove another part or sub-assembly, restart the command.

Explode an assembly or a sub-assembly

1. Ensure that the  Select assemblies selection switch is active.

2. Select the assembly or sub-assembly you want to explode.

3. Do one of the following: 

• To explode the entire assembly, right-click and select Assembly -->
Explode.

• To only explode the sub-assembly, right-click and select Assembly -->
Explode Sub-Assembly.

When you explode a nested assembly, always start from the highest assembly
hierarchy level. Tekla Structures breaks the assembly hierarchy level by level
and ungroups the objects that belong to the assembly. You need to use the
Explode command several times to break a nested assembly back to single
parts.

You can also use the Explode Sub-Assembly to explode sub-assemblies to
single parts without breaking the entire assembly hierarchy.

2.6 Create cast units
In Tekla Structures, each modeled concrete part is considered as its own cast
unit. When you model concrete parts in Tekla Structures, you may need to
merge several concrete parts into one cast unit. For example, a single cast unit
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could consist of a column with corbels. The cast unit can then have the
production drawings and other deliverables.

Concrete cast units are technically considered as assemblies, and they have
similar commands available as steel assemblies (page 417). In some cases, the
assembly commands need to be used for cast units as well.

Create a cast unit
You need to specify which parts form the cast unit. Cast units can include
reinforcement, as well as concrete parts.

1. On the Concrete tab, click Cast unit --> Create cast unit .

2. Select the objects you want to include in the cast unit.

3. Click the middle mouse button to create the cast unit.

Check and highlight objects in a cast unit
Use the Inquire tool to check which objects belong to a particular cast unit or
assembly.

1. On the ribbon, click the down arrow next to , and then select
Assembly objects.

2. Select a part that belongs to a cast unit or an assembly. 

Tekla Structures highlights the other parts that belong to the same cast
unit or assembly. The following colors are used:

Object type Highlight color
Concrete - main part magenta
Concrete - secondary part cyan
Reinforcement blue
Steel part - main part orange
Steel part - secondary part yellow

Change the cast unit main part
The main part in a concrete cast unit is the one with the largest volume of
concrete. You can change the main part in a cast unit.

1. If needed, check what is currently the main part of the cast unit. 

Use the Inquire tool to check which objects belong to a particular cast
unit.

Create parts, reinforcement, and construction
objects

431 Create cast units



2. Ensure that the Select objects in assemblies  selection switch is
active.

3. Select the new main part.

4. Right-click and select Set as new main part of assembly.

Define the cast unit type of a part
You must define the cast unit type of concrete parts. Tekla Structures checks
the cast unit type of the main part each time you create or modify a cast unit.
It is important to use the correct cast unit type, because some functionalities,
for example numbering, are based on the cast unit type.

1. Double-click a concrete part to open the part properties in the property
pane.

2. Go to the Cast unit section.

3. In the Cast unit list, select one of the following: 

• Cast in place

Cast units that are constructed fully in their final location.

• Precast

Cast units that are built at another location and transported to their
final location for placement in the full structure.

4. Click Modify to save the changes.

Some best practices when you are working with cast units
• Always check that all the concrete parts and related accessories are

connected to the cast unit.

• Cast units always have a main part. The main part in a cast unit is usually
the part with the largest volume of concrete. You can change the main part.
Always ensure that the main part is the intended one as the cast unit gets
many of its properties from the main part. Keep the possible sub-assembly
hierarchy clear.

• Cast units get their position numbers (page 712) according to the
numbering settings. Identical cast units have the same position number
and they are included in the same drawing. In addition to the position
numbers, you can assign other identifiers to separate the cast units with
the same drawing and position number.

• The cast unit drawings contain all the hierarchical content included in the
cast unit. Always check that all of the concrete parts, cuts, reinforcement,
and surface treatment are connected to the correct parts and that embeds
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are added as sub-assemblies to the cast unit. This ensures that all the
objects are included in the drawings.

• To indicate the casting direction (page 434) of a precast concrete part, you
can define which part face you want to face upwards in the casting form.
Therefore, this face will be the front face view in the fabrication drawing.
Casting direction affects the numbering of parts. By modeling beams and
interior walls from left to right, bottom to top, the default front face is
towards the viewer, and any fixed part marks are oriented upright. When
using wall layout for exterior walls, model in the clockwise direction.

• If you copy fully detailed cast units in a model, use the Copy special -->
Copy all content to another object command. With this command, all
objects in a cast unit are copied to other similar cast units without
individually selecting each object to copy. This means that, for example,
secondary parts, sub-assemblies, components, and cuts and fittings are
copied with the cast unit.

Additionally, you can

• inquire (page 686) the cast unit’s general properties, such as volume and
weight which are automatically calculated

• inquire the cast unit’s own properties, such as position number

• inquire the cast unit’s main part properties

• list all parts, rebars and sub-assemblies of the cast unit.

Add objects to cast units
You can use different methods to add objects to cast units. The available
methods depend on the objects' material and on the hierarchy you want to
create in the cast unit.

• The default way of working is to use the Add to cast unit command. Using
this command you can add concrete parts that need to be in the same
casting unit. The parts retain their geometry and you can use them as input
when modeling components, shown in drawings.

• Use the Add as sub-assembly command to add embeds. Embeds are
always added as sub-assemblies on a lower level in the cast unit hierarchy.
Sub-assemblies can consist of one or multiple parts. In both cases the parts
have to be added to a cast unit as sub-assemblies. Sub-assemblies in a cast
unit retain their own assembly information and their main part. If in a
precast cast unit the precast element consists of numerous shells or layers,
the secondary cast units need to be added as sub-assemblies to the main
cast unit.

• Use the Attach to part command to attach one or more concrete parts to
another part in the cast unit. Additionally, you can use the command to
merge parts if you need them to be reported or drawn as one part.

Create parts, reinforcement, and construction
objects

433 Create cast units



To Do this Available for
Add an object as a
secondary part

1. On the Concrete tab, click Cast
unit --> Add to cast unit.

2. Select the object you want to
add.

3. Select an object in the cast unit.

Concrete, timber,
miscellaneous
materials

Add an object as a
sub-assembly

1. If you are adding a custom part,
ensure that the Select
components (custom objects)

 selection switch is active.

2. On the Steel tab, click Assembly
--> Add as sub-assembly.

3. Select the object you want to
add.

4. Select the cast unit to which you
want to add the object.

Steel, concrete,
timber,
miscellaneous
materials

Remove objects from cast units
If you want to disassemble your cast unit, you can remove objects from a cast
unit, or ungroup the objects belonging to a cast unit.

Remove objects from a cast unit
1. On the Concrete tab, click Cast unit --> Remove from cast unit .

2. Select the object you want to remove from the cast unit. 

You need to restart the command to remove another object.

Explode a cast unit
You can ungroup the objects belonging to a cast unit.

1. On the Concrete tab, click Cast unit --> Explode .

2. Select an object in the cast unit you want to explode.

Casting direction
To indicate the casting direction of a concrete part, you can define which part
face you want to face upwards in the casting form. The top-in-form face is
displayed in the front view of a drawing.

Create parts, reinforcement, and construction
objects

434 Create cast units



Casting direction for concrete and non-concrete parts
To enable this feature for non-concrete parts as well, and to indicate in the
model the part face that is shown in the drawing main (front) view, use the
advanced option XS_SET_FIXEDMAINVIEW_UDA_TO_AFFECT_NUMBERING.

The casting direction affects the numbering of parts. If you define the casting
direction for parts that differ only by their modeling direction, they get
different position numbers. This is because the modeling direction affects the
top-in-form face of the parts. By default, the casting direction of the parts is
undefined, which means the modeling direction does not affect numbering.

NOTE In drawings, use the Fixed coordinate system to show the top-in-form face in
the front view.

Example

In the following example, each cast unit gets a different position number,
because the top-in-form setting and the orientation of the panels is different.
The red arrow indicates the modeling direction.

In the following example, the cast units get the same position number,
because their top-in-form setting has not been defined. The red arrow
indicates the modeling direction.
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Define the casting direction of a part
You can define the casting direction for concrete parts.

1. Set the rendering of parts to Rendered by doing one of the following: 

• On the View tab, click Rendering --> Parts rendered.

• Press Ctrl + 4.

2. On the Concrete tab, click Cast unit --> Set top-in-form face.

3. Move the mouse pointer over the selected concrete part.

4. Select the part face that will face upwards in the form.

TIP Alternatively, you can do this in the user-defined attributes of the part.

• Concrete parts: Select an option for the Top in form face user-defined
attribute.

• Non-concrete parts: With XS_SET_FIXEDMAINVIEW_UDA_TO_AFFECT_
NUMBERING set to STEEL, TIMBER, and/or MISC, select an option for the
Fixed drawing main view user-defined attribute.

Show the top-in-form face
You can display the top-in-form face of a concrete part in a model view.

1. On the Concrete tab, click Cast unit --> Show top-in-form face.

2. Click the concrete part whose top-in-form face you want to show. 
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Tekla Structures highlights the top-in-form face in red:

TIP To hide the top-in-form face again, right-click the view and select Update
window.

Note that if you have not specifically set the top-in-form value, the Show top-
in-form face command highlights the default face, which is the front face of
the part.

2.7 Batch editing of assemblies or cast units
Using the Batch editor tool you can quickly copy modifications done to an
assembly or a cast unit to other, identical assemblies or cast units that have
the same position number, or to very similar but differently numbered
assemblies or cast units.

Batch editor reduces the amount of repetitive work in situations where you
need to edit very similar assemblies or cast units by modifying the object
geometry or by changing the part properties.

Unlike the Copy special --> To another object or Copy special --> All content
to another object commands which replace the duplicate objects in the
target assemblies or cast units, Batch editor detects matching objects in the
targets and modifies their geometry and properties without replacing the
objects.

This is important especially in the late stages of a project when the detailing of
all objects is done and the documentation has been created or issued. For
example, replacing of objects and components might damage not only the
target but nearby assemblies or cast units which would not require any
modifications, and the changes would have a negative impact on the drawings
that are ready for issuing.
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With Batch editor you can

• Select a source assembly or cast unit in the model, and based on the
source, generate a list of target assemblies or cast units to which you can
copy the edits done in the source. Batch editor only detects assemblies or
cast units which have the same position number as the source.

If needed, you can manually add very similar but differently numbered
assemblies or cast units to the list of targets.

• Use the list to copy all edits done in the source assembly or cast unit to the
specified target assemblies or cast units in one go.

Batch editor attempts to avoid replacing of modified objects. Batch editor
detects matching objects in the targets assemblies or cast units and
modifies their geometry and properties.

Both the main and secondary part geometry and property edits, as well as
modifications in component properties can be copied. Note that to copy
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the main part geometry edits, the Copy main part position edits
performed after selecting the source assembly option needs to be on.

If there are secondary parts in the target assemblies or cast units which do
not exist in the source anymore, Batch editor deletes the excess
secondary parts in the targets assemblies or cast units when you copy the
edits.

• Use the list of target assemblies or cast units for

• viewing the differences between the source and the target assemblies
or cast units before copying the edits.

• browsing the list of target assemblies or cast units and fixing possible
errors before running numbering.

Batch editor uses the Validation attribute to report detected differences
in the number of objects between the selected source and the listed target
assemblies or cast units, and to compare the assembly or cast unit weight
and volume. The Validation attribute also reports any missing or
additional objects in the target assemblies or cast units.

Limitations and recommendations in using Batch editor
• Batch editor works only on the assembly or on the cast unit level.

Assembly or cast unit secondary parts cannot be selected as a source or
target. For example, you cannot copy edits from one part to another, or
from one sub-assembly to another.

• Batch editor does not copy the following:

• values of unique user-defined attributes

• sub-assembly properties

• assembly numbering information

• Batch editor does not support the following object types:

• Pour units and pour objects

• Load object types in analysis and design

• We recommend that you do not use Batch editor if the source assembly or
cast unit has been split.

• We recommend that you do not use Batch editor with mirrored
assemblies or cast units.

Rebar groups and components are not always adapted correctly to the
main part. This applies especially to cases where new objects are added to
the mirrored target assemblies or cast units.
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• We recommend that you do not use Batch editor with assemblies or cast
units that look similar but are modeled using different methods.

This applies to, for example, assemblies or cast units that have different
orientation of secondary object, or assemblies or cast units that have been
modeled using different object types as the main part.

• Rebar groups and some macros do not adapt to the geometry of the main
part with different dimensions or different shape.

• The main part geometry edits that are copied to rotated or mirrored
assemblies or cast units may not work as expected.

• Batch editor overrides the overall dimensions of the parts that the Wall
layout tool creates. Therefore, we recommend to use Batch editor for
copying edits to precast walls that have identical dimensions.

Edit similar assemblies or cast units with Batch editor
1. On the Edit tab, click Batch editor. 

The Batch editor dialog box opens.

2. Click the Select button and select a source assembly or a cast unit in the
model. 

Batch editor finds all assemblies or cast units with the same position
number. The assemblies or cast units are listed in the Target assemblies
list.

3. To add target assemblies or cast units manually, select them in the model
and click the Add button. 

To remove target assemblies or cast units from the list, select them in the
list and click the Remove button.

Note that if you delete the source in the model, the source list becomes
empty. Similarly, if you delete the targets in the model, the list of targets
becomes empty.

4. In the Target assemblies list, use the check boxes to select the
assemblies or cast units to which you want to copy the modifications from
the source assembly or cast unit. 
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To select several check boxes in one go, select the targets, and hold down
the Shift key and click the left mouse button.

5. To view the differences between the source and the target assemblies or
cast units, or to fix errors, use the Validation attribute in the Target
assemblies list. 

Batch editor uses the Validation attribute to report detected differences
in the number of objects between the selected source and the listed
target assemblies or cast units, and to compare the assembly or cast unit
weight and volume. The Validation attribute also reports any missing or
additional objects in the target assemblies or cast units.

You can check the missing and additional objects in the model. Click the
Additional or Missing objects link to check the highlighted the objects in
the model.

6. To copy the modification from the source assembly or the cast unit to the
targets, click the Copy button. 

Batch editor analyzes the detected differences between the selected
source and the targets, and makes all the selected target assemblies or
cast units identical to the source.

7. To review the copying results in the model, select the target objects in the
list. 

Select the Zoom to selected check box to automatically zoom to the
object selected in the list.
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8. Number the modified assemblies or cast units to validate that all
modifications have been copied properly.

Settings in Batch editor
Use the Settings to define how the edits are copied.

• Copy main part position edits performed after selecting the source
assembly

When the option is on, Batch editor copies the geometrical modifications
done to the assembly or cast unit main part, such as dragging of end point
handles of the main part, or changing the main part location with the Move
or Move special commands.

NOTE Batch editor recognizes only the edits that you have done after
selecting the source assembly or cast unit, and switching the
option on. If you first modify the main part geometry and only then
switch the option on, the main part edits are not copied.

If the option is off, only the secondary part and component edits are
copied.

• Copy main part properties

When the option is on, Batch editor copies the assembly or cast unit main
part property modifications to the selected targets. Use this option, for
example, when you want to copy the edits to targets with different main
part profile dimensions.

Note that user-defined attributes are copied but unique user-defined
attributes are not copied.

• Update copied components in target assemblies

When the option is on, Batch editor modifies the components in the
target assemblies or cast units according to the properties set in the
component properties dialog box. All manual changes, such as modifying
the geometry of component objects, are lost.

If the option is off, manual changes in the component, for example,
modifying the geometry of component objects or the component object
properties, are copied to the target assemblies or cast units.
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Work with property columns in Batch editor
You can organize the list of target assemblies or cast units and the property
columns in Batch editor. Add, edit, or remove property columns to show the
needed properties about the target assemblies or cast units.

To Do this
Add more property columns in the
Target assemblies list

1. Click the  button in the upper
right corner of the Batch editor.

Alternatively, you can right-click
the property column header and
select Edit.

2. In the Add/Edit properties
dialog box, do the following:

• Select the required property
from the list on the left and
drag it to the list on the right.
Use the Search box for
searching properties. You can
add several properties to the
same column.

• If you want to add a custom
text in a column cell, select
Custom text and type the
required text in the displayed
Text box. Then press Enter to
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To Do this
add the custom text in the list
on the right.

• To show the property cells
even though there is no value,
select the Show empty fields
of the column option.

3. Enter the name for the property
column and click OK.

The new property columns are
added to the Target assemblies
view.

Change the order of the property
columns

Drag the property column header to a
new location in the list of targets.

Change the sort order of a property
column

Click the column header.

The arrow symbol next to the column
header indicates if the sort order is
ascending  or descending .

Resize a property column Drag the edge between this and the
following column header.

Refresh the Target assemblies list Click  in the upper right corner of
the Batch editor.

2.8 Manage pours
With the pour management functionality of Tekla Structures, you can view the
geometry of cast-in-place concrete structures, show them as parts or as pour
objects, plan pours and pour breaks, and report pour information, such as
concrete volumes and formwork areas. You can define pours, pour units, pour
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objects, and pour breaks for concrete parts whose cast unit type is Cast in
place.

In Tekla Structures, a pour object is a building object that consists of one or
more cast-in-place concrete parts, or parts of them. The cast-in-place concrete
parts are merged into one pour object if they have the same material grade
and they touch each other. They also need to be in the same pour phase to be
merged. Pour objects are visible in pour views.

A pour unit is an entity for cast-in-place concrete and it consists of a pour
object and all related reinforcement, embeds, and other objects that need to
be in place before concrete can be poured on the building site.

A pour is a group of pour objects that is poured at one go.

With a pour break you can split a pour object into smaller pour objects.

NOTE Pour management is mainly targeted at contractors for quantity take-
off, planning, and on-site activities. By default, pour management is
disabled in new models in most roles. You can enable pour
management (page 445) in the current model using the advanced
option XS_ENABLE_POUR_MANAGEMENT.

See also

Enable pour management (page 445)

View cast-in-place concrete structures (page 447)

Define the pour phase of a part (page 450)

Pour objects (page 451)

Pour units (page 453)

Pour breaks (page 458)

Troubleshoot pours (page 464)

Example: Create concrete geometry and work with pours (page 467)

Enable pour management
By default, pour management is disabled in new models in most roles. You can
enable pour management in the current model in the Advanced Options
dialog box.

WARNING If pour management is enabled in the model, do not disable it
using XS_ENABLE_POUR_MANAGEMENT, especially in the middle of
the project. This may cause problems if you have drawings
containing pour objects, and if you are sharing your model. The
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pour objects and pour breaks in the model and in the drawings
may get invalid, and you may lose all pour-related modeling work.

1. On the File menu, click Settings --> Advanced options to open the
Advanced options dialog box.

2. Under Concrete detailing, set XS_ENABLE_POUR_MANAGEMENT to TRUE.

3. Click OK.

4. Save and re-open the model for the change to take effect. 

The commands that show and create pour objects and pour breaks are
now available in the model and in drawings.

See also

Disable pour management temporarily (page 446)

Disable pour management temporarily
You can temporarily disable pour management. This may be needed if pour
management seems to significantly slow down your model, for example, when
the pours and pour objects are very large and require splitting into smaller
ones.

When pour management is temporarily disabled, the existing pour objects and
pour breaks are still present in the model, but any modifications to the model
geometry that would normally update pour objects and pour breaks
automatically will not do that. Any information related to pours will be
outdated and inaccurate, for example, in reports, and the pour breaks will not
be adaptive. They will be updated automatically when you re-enable pour
management.

To disable or re-enable pour management:

1. Go to Quick Launch, start typing pours and pour breaks, and select
the Toggle pours and pour breaks command from the list that appears.

2. Click Yes in the confirmation dialog box.

NOTE If you are working in a Tekla Model Sharing model, remember to re-enable
pour management before you write out. Similarly, if you are working in the
multi-user mode, re-enable pour management before you save the model. In
this way, information related to pours stays up to date for all users of the
model.

TIP If you have problems opening a large model with pour objects that contain many
parts, you may need to disable pour management before you open the model.
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You can do this by modifying the xs_user.[user name] file located in the
model folder. Set PAPB to 0 to disable pours, and then save the file.

When needed, remember to re-enable pour management.

See also

Enable pour management (page 445)

View cast-in-place concrete structures
When pour management is enabled, you can view cast-in-place concrete
structures in model views either as parts or as pour objects.

Depending on your needs, you can switch between the different
representation options for cast-in-place concrete structures. For example,
working in a part view is useful when you want to reinforce individual parts or
change their geometry. A pour view is useful when you want to find out the
volume of concrete to be poured or check which objects belong to a pour unit,
or when you want to reinforce continuous structures that span multiple parts.

Set the appearance of cast-in-place concrete structures
You can define how cast-in-place concrete structures appear in a model view.

1. Ensure that pour management is enabled (page 445).

2. Double-click the view to open the View Properties dialog box.

3. Click Display to open the Display dialog box.

4. Ensure that the Parts check box is selected.

5. In the Cast in place list, select either: 

• Parts

• Pours
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6. If you selected Parts for the cast-in-place concrete structures, in the Cast
in place parts list, select either: 

• Merged

Tekla Structures shows concrete parts as merged in the model if their
cast unit type is Cast in place, if they have the same material grade
and pour phase (page 450) number, and if they touch or overlap one
another. When these criteria are met, Tekla Structures removes the
outlines of the individual parts within each continuous concrete
structure.

• Separated

Tekla Structures shows concrete parts as individual parts and
separated by their outlines.
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7. Ensure that the view is selected.

8. Click Modify to save the changes.

TIP To quickly change the representation of the active view from Parts to Pours, and

the other way round, click  Pour view on the Concrete tab.

You can also create two views, a pour view and a part view, and keep them both
open side by side on your screen.

Part view vs. pour view
Continuous concrete structures cannot be selected or highlighted in part
views. When you hold the mouse pointer over a concrete structure in a part
view, Tekla Structures highlights the original parts belonging to it. You can
select a part and modify it if needed:

Duplicates and overlapping parts are counted only once in the volume
calculations for pour objects. Note that single part and cast-unit volumes are
still calculated the same way as before, which means that the sum of single

Create parts, reinforcement, and construction
objects

449 Manage pours



part and cast-unit volumes may be higher than the volume of pour objects
that are defined from exactly the same part geometry.

When you reinforce a concrete structure, you need to reinforce the individual
concrete parts within it in part views, or you can reinforce pour objects by
using Reinforcing Bar Shape Catalog or rebar sets in pour views. Therefore,
you can reinforce a part of a continuous concrete structure independently
from the whole continuous concrete structure. All reinforcement are visible
both in part views and in pour views.

Define the pour phase of a part
Use the pour phase property to separate pour objects from one another. By
defining pour phases, you can prevent cast-in-place concrete parts from
merging even if they have the same material grade and they touch or overlap
one another.

NOTE Pay attention to pour phases when you create cast-in-place concrete
parts. For example, use pour phase 0 for horizontal structures, like
beams and slabs, and pour phase 1 for vertical structures, like
columns and walls, to separate them to different pour objects. In this
way you can make sure that the number of parts included in each
single pour object is reasonable, and that your models do not slow
down due to too large pour objects.

To modify the pour phase of a part:

1. Double-click a concrete part to open the part properties in the property
pane.

2. Under Cast unit:

a. In the Cast unit type list, ensure that the cast unit type is set to Cast
in place.

b. In the Pour phase box, enter a pour phase.

By default, the pour phase is 0. If you are unable to change the value, the
cast unit type that you set in step 2a is incorrect.

3. Click Modify.

NOTE When you define pour phases, make sure that parts in different pour phases
do not overlap. If you use parts (not pour objects) to report geometric
information, overlapping volumes of different pour phases are not merged
but counted twice in calculations, and you may end up with incorrect volume,
area, or weight information.

See also

View cast-in-place concrete structures (page 447)
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Pour objects

When pour management is enabled (page 445), each concrete part whose cast
unit type is Cast in place automatically forms a pour object.

Tekla Structures automatically merges multiple cast-in-place concrete parts to
a pour object if they have the same material grade and pour phase (page 450)
number, and if they touch or overlap one another.

By creating pour breaks (page 458) you can split pour objects into smaller pour
objects.

NOTE Make sure that the number of parts included in each single pour
object is reasonable. Too large number of parts and part surfaces in a
pour object slows down the model.

Pour objects are visible in pour views (page 447). All pour objects are displayed
using the same color, regardless of the individual parts’ color within a concrete
structure. You can change the default color by using the advanced option XS_
POUR_OBJECT_COLOR in File --> Settings --> Advanced options --> Concrete
detailing .

You can also use different color and transparency settings (page 452) to show
pour object groups, for example, by pour number.
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TIP You can group pour objects using Organizer or Task manager.

Limitations

The following commands are not available for pour objects: Copy, Move,
Delete, Split, and Combine. This is because pour object geometry is defined
by parts. If you want to change the geometry of pour objects, you have to
modify the parts instead of pour objects, or you can create pour breaks.

See also

Modify the properties of a pour object (page 453)

Reinforce pour objects using Rebar shape catalog (page 504)

Create a rebar set (page 470)

Change the color and transparency of pour objects
By default, all pour objects are displayed using the same color in pour views,
regardless of the individual parts’ color. You can customize the pour object
color and transparency in model views by defining object groups and then
selecting specific color and transparency settings for each group.

TIP To change the default color of pour objects, use the advanced option XS_
POUR_OBJECT_COLOR in File --> Settings --> Advanced options -->
Concrete detailing .

1. On the View tab, click Representation. 

The Object Representation dialog box is displayed.

2. Create a new object group for the pour objects whose color and
transparency you wish to change.

a. In the Object Representation dialog box, click Object group....

b. In the Object Group - Representation dialog box, click Add row.

c. To direct the settings to pour objects instead of parts, select the
following options for the row: 

• Category = Object

• Property = Object type

• Condition = Equals

• Value = Pour object

d. If needed, add any additional filtering criteria. 

For example, to filter pour objects by a certain user-defined attribute,
add a row with Pour object as Category, and define the Property,
Condition, and Value as desired.
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e. Enter a unique name in the box next to the Save as button.

f. Click Save as to save the object group.

g. Click Close.

3. Repeat step 2 if you wish to create more object groups.

4. In the Object Representation dialog box, select an object group from the
Object group list.

5. In the Color list, choose a color for the object group.

6. In the Transparency list, set the transparency of the object group.

7. Click Modify. 

The object group’s color and transparency changes in the model.

See also

Change the color and transparency of model objects by using object
representation (page 656)

Modify the properties of a pour object
Pour objects have properties and user-defined attributes which you can view,
define, and modify.

For example, you can enter a Pour number that you can use to define the
sequence of pours, and a Pour type that you can use to describe each pour
object.

1. Ensure that you are using a pour view. If not, click Pour view on the
Concrete tab to show the pour objects.

2. Ensure that the  Select objects in assemblies selection switch is
active.

3. Double-click the pour object whose properties you want to modify.

4. In the property pane, enter or modify the pour object properties.

5. Click Modify.

See also

Pour objects (page 451)

Pour units
When pour management is enabled, you can create pour units that combine
together pour objects and other objects. A pour unit is an entity for cast-in-
place concrete and it consists of a pour object and all related reinforcement,
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embeds, and other objects that need to be in place before concrete can be
poured on the building site.

For each pour object (page 451) in the model, there is a corresponding pour
unit to which the pour object belongs. You can automatically add other objects
to pour units by using the Calculate pour units command. You can also
modify the pour units manually.

The following model objects can be added to pour units:

• Reinforcement, such as single reinforcing bars, bar groups, reinforcement
meshes and strands

• Assemblies (for example, rebar assemblies and embeds)

• Sub-assemblies (for example, embeds in cast-in-place cast units)

• Bolts (for example, anchor bolts and shear studs)

• Surfaces added to the pour object

• Precast cast units

Precast cast units can only be added manually, not by using the Calculate
pour units command.

Note that some model objects such as parts and welds cannot be directly
added to a pour unit. Instead, these objects are indirectly linked to the pour
unit through the assemblies and cast units they belong to.

One model object can be included in only one pour unit at a time.

Calculate pour units
You can have Tekla Structures detect which objects form pour units and
automatically add the objects to pour units.

1. Ensure that pour management is enabled (page 445).

2. On the Concrete tab, click Calculate pour units. 

Tekla Structures adds the objects (page 457) to pour units.

You can check the pour units in a pour view, or using the Inquire tool,
Organizer, or reports.

If you want to modify the pour units, you can manually add and remove
objects. The manual additions will be kept even if you use the Calculate pour
units command again, but the objects you manually remove from pour units
will be added again.

Check and inquire objects in a pour unit
You can visually check which objects are included in a pour unit. You can also
use the Inquire tool to get information about the pour unit and the objects in
it.
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1. Ensure that you are using a pour view (page 447). If not, on the Concrete
tab, click Pour view to show the pour objects.

2. Ensure that the  Select assemblies selection switch is active.

3. Click a pour object to select its pour unit. 

A magenta box indicates the pour unit.

4. Right-click and select Inquire . 

Tekla Structures lists the objects in the pour unit and shows their
properties in the Inquire object dialog box.

Add objects to a pour unit
In addition to using the Calculate pour units command, you can manually
add objects to pour units.

1. Ensure that you are using a pour view (page 447). If not, on the Concrete
tab, click Pour view to show the pour objects.

2. Select the objects that you want to add to a pour unit. 

You can add reinforcement, assemblies, precast cast units, and bolts.

If you have other objects selected, they will not be added.

3. Right-click and select Pour --> Add to pour unit. 

Alternatively, you can go to Quick Launch and use the Add selected
objects to pour unit command. You can also assign a keyboard shortcut
to this command.

4. Click a pour object to add the objects to the corresponding pour unit.
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Tekla Structures adds all the objects that can be added to the pour unit. The
unallowed objects are not added.

TIP If you do not have objects selected, you can first start the Add to pour unit
command by using Quick Launch or a customized keyboard shortcut, and then
select the object that you want to add to the pour unit.

Remove objects from a pour unit
After using the Calculate pour units command, you can manually remove
objects from pour units.

1. Select the object that you want to remove from a pour unit.

2. Right-click and select Pour --> Remove from pour unit. 

Alternatively, you can go to Quick Launch and use the Remove selected
objects from pour unit command. You can also assign a keyboard
shortcut to this command.

The removed object can then be added to another pour unit either manually
with the Pour --> Add to pour unit command, or automatically with the
Calculate pour units command.

TIP If you do not have objects selected, you can first start the Remove from pour
unit command by using Quick Launch or a customized keyboard shortcut, and
then select the object that you want to remove from the pour unit.

Reset pour unit relations
In some cases you may need to reset all or some of the pour unit contents and
relations defined using the Calculate pour units command and/or the Add to
pour unit command.

To do this:

1. Go to Quick Launch.

2. Search for and select the appropriate command of the following: 

• Reset all pour unit relations

• Reset all manually assigned pour unit relations

• Reset all pour unit relations except manual assignments

3. In the confirmation dialog box, click Yes to reset pour unit relations. 

Note that if you use the Reset all pour unit relations command, and
then click No in the confirmation dialog box to cancel the resetting of the
manual assignments, the automatic relations are still reset. If you want to
recreate the automatic relations, use the Calculate pour units command
again.
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Modify the properties of a pour unit
You can modify the pour unit properties in the same way as pour object
properties, but using a different selection switch.

1. Ensure that you are using a pour view (page 447). If not, click Pour view
on the Concrete tab to show the pour objects.

2. Ensure that the  Select assemblies selection switch is active.

3. Double-click the pour unit whose properties you want to modify.

4. In the property pane, enter or modify the pour unit properties. 

For example, you can define the pour unit name and user-defined
attributes.

5. Click Modify.

How Tekla Structures automatically adds objects to pour units
When you use the Calculate pour units command, Tekla Structures
automatically adds objects to pour units.

Each object that collides with a pour object, meaning that the object at least
partly overlaps the pour object, is added to the same pour unit to which the
pour object belongs.

If any object in an assembly collides with a pour object, the entire assembly is
added to the pour unit.

Only reinforcement objects that belong to cast-in-place parts are added to
pour units.

If any object in a reinforcing bar group or strand group collides with a pour
object, the entire group is added to the pour unit. On the other hand,
individual reinforcing bars in a rebar set can be added to different pour units.

Objects colliding with more than one pour object

If an object collides with more than one pour object, the object will be
associated with the pour object whose bounding box has the lowest global z
coordinate.

For example, the reinforcing bars colliding with a footing pour object and a
column pour object are associated with the footing pour object because its
bottom face has a lower global z coordinate than the column pour object.
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If the lowest global z coordinates of the pour object bounding boxes are the
same or differ less than 100 mm, the object will be associated with one of the
pour objects according to these rules:

1. If the object's center of gravity is within only one of the colliding pour
object bounding boxes, the object will be associated with that pour object.

2. If the object's center of gravity is within more than one pour object
bounding box, or completely outside any pour object bounding box, the
object will be associated with the pour object whose center of gravity is
closest to the object's center of gravity.

If there are changes in pour units

Whenever there are changes in a pour object or pour unit, all associations to
that pour unit are reset. Similarly, if there are changes in an object associated
with the pour unit, this association is reset. The next time you use the
Calculate pour units command, only the unresolved associations are
calculated.

See also

Pour units (page 453)

Pour breaks
When pour management is enabled, you can use pour breaks to split pour
objects into smaller pour objects.
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Pour breaks are visible and you can work with them both in pour views and in
part views (page 447). Pour breaks are displayed as a thin plane or line,
depending on the part rendering option (page 642) you use.

WARNING If you move or copy a part, pour breaks do not follow the part.
Pour breaks remain at their original locations, and adapt to any
cast-in-place concrete parts (page 459) they still touch.

If a pour break does not split a pour object completely into two, the pour
break is displayed in red by default. This means that it is invalid and needs to
be remodeled.

See also

Set the visibility of pour breaks (page 460)

Create a pour break (page 461)

Modify a pour break (page 463)

Pour break adaptivity
Pour breaks are adaptive to changes in cast-in-place concrete parts and pour
objects. This means that if you change the geometry or location of a cast-in-
place concrete part or pour object, its pour breaks change accordingly.
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If you delete a cast-in-place concrete part, its pour breaks disappear as well.

If you modify a cast-in-place concrete structure in any of the following ways, its
pour breaks adapt:

• Change the profile or dimensions of a part

• Add or remove cuts or fittings

• Change chamfer shape or dimensions

• Add or remove parts of the cast-in-place concrete structure by:

• Changing the cast unit type of a part from Precast to Cast in place or
vice versa

• Changing the pour phase of a part

• Changing the concrete grade of a part

• Moving, copying, or deleting parts

If you move a cast-in-place concrete part outside its pour breaks, the pour
breaks disappear. If you move a part so that it still hits one or more pour
breaks, the pour breaks that are inside the part stay in their original locations
and adapt to the part in the new location.

If you copy or move a pour break and it hits a cast-in-place concrete part in the
destination location, the pour break adapts to the part. Also the pour breaks
that you copy from another model adapt to the parts in the model they are
copied to.

If a pour break is dependent on another pour break that is split or deleted, the
dependent pour break is deleted as well. If a pour break is dependent on
another pour break that is moved, the dependent pour break adapts inside
the pour object, as long as the pour break plane can touch the moved pour
break.

If a pour break is split so that it becomes partial, the pour break is deleted. A
partial pour break can only split a cast-in-place part or pour object in
conjunction with other pour breaks.

Set the visibility of pour breaks
You can show pour breaks in model views.

Before you start, ensure that pour management is enabled (page 445).

1. Double-click a model view to open the View Properties dialog box.

2. Click Display... to open the Display dialog box.

3. Select the Pour break check box.

4. Click Modify.
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See also

Pour breaks (page 458)

Create a pour break
You can add pour breaks to pour objects or concrete parts whose cast unit
type is Cast in place.

You can create pour breaks by picking one, two, or more points in the model.

When you create a pour break that traverses more than two points, the pour
break will be limited to the pour object it splits and perpendicular to the
current work plane. If you need to create an inclined or horizontal pour break
using multiple points, shift the work plane (page 53) first.

TIP Use the  Snap to nearest points (points on line) snap switch
(page 84) to start or end pour breaks on part or pour object edges.

Use the  Snap to any position snap switch (page 84) to pick
intermediate points for pour breaks.

To create a pour break, do any of the following:

To Do this
Create a pour break, perpendicular to
a part face, using one point

1. On the Concrete tab, click Pour
break --> Single point .

2. Pick the location for the pour
break.

Create a pour break that splits all
cast-in-place concrete parts and pour
objects located between two points

1. On the Concrete tab, click Pour
break --> Two points.

2. Pick two points to define the
location of the pour break.

Create a pour break using multiple
points

1. If needed, shift the work plane.

2. On the Concrete tab, click Pour
break --> Multiple points .

3. Pick the points you want the pour
break to go through.

Create a pour break defined by the
opposite corners of a rectangle

1. If needed, shift the work plane.

2. On the Concrete tab, click Pour
break --> Multiple points .
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To Do this
3.

Hover over , and then click

 on the toolbar that appears.

4. Pick two opposite corner points
of the pour break.

Create a pour break defined by the
center and one corner of a rectangle

1. If needed, shift the work plane.

2. On the Concrete tab, click Pour
break --> Multiple points .

3.
Hover over , and then click

 on the toolbar that appears.

4. Pick the center point of the pour
break.

5. Pick one corner point of the pour
break.

Create a pour break defined by three
corners of a rectangle

1. If needed, shift the work plane.

2. On the Concrete tab, click Pour
break --> Multiple points .

3.
Hover over , and then click

 on the toolbar that appears.

4. Pick three corner points of the
pour break.

Create a pour break defined by one
side midpoint and two corners of a
rectangle

1. If needed, shift the work plane.

2. On the Concrete tab, click Pour
break --> Multiple points .

3.
Hover over , and then click

 on the toolbar that appears.

4. Pick one side midpoint of the
pour break.

5. Pick two corner points of the
pour break.

If the pour break you are creating does not split a pour object or cast-in-place
part completely into two, Tekla Structures does not add the pour break to the
model. You may need to use another Pour break command to create a valid
pour break, for example Multiple points instead of Single point.
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See also

Modify a pour break (page 463)

Pour breaks (page 458)

Modify a pour break
You can modify, copy, move, and remove existing pour breaks.

Before you start:

• Ensure that the  Direct modification switch is active.

• Ensure that the  Select pour breaks selection switch is active.

• Select the pour break.

Tekla Structures displays the handles and dimensions that you can use to
modify the pour break.

To modify a pour break:

To Do this
Change the shape or location
of the pour break

Drag a corner point or an end point to a new
location.

Change a location dimension Drag a dimension arrowhead to a new
location, or:

1. Select the dimension arrowhead which
you want to move.

2. Using the keyboard, enter the value with
which you want the dimension to change.
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To Do this
To start with the negative sign (-), use the
numeric keypad.

To enter an absolute value for the
dimension, first enter $, then the value.

3. Press Enter, or click OK in the Enter a
Numeric Location dialog box.

Add an intermediate point to
the pour break Drag a midpoint handle  to a new location.

Remove an intermediate
point from the pour break

1. Select an intermediate corner point.

2. Press Delete.
Modify the pour break
properties

1. Double-click the pour break to open the
property pane.

2. Modify the properties.

3. Click Modify.
Copy the pour break Copy (page 127) the pour break like any other

object in Tekla Structures. For example, right-
click and select Copy.

Move the pour break Move (page 140) the pour break like any other
object in Tekla Structures. For example, right-
click and select Move.

You may need to move the pour break if you
have moved the part, because the pour break
does not follow the part.

Remove the pour break Press Delete.

See also

Pour breaks (page 458)

Resize and reshape model objects (page 107)

Troubleshoot pours
When you work with cast-in-place concrete parts, it is important that you
regularly check the resulting pour objects, and try to get rid of the errors
related to them, before you start detailing, or creating drawings and reports.
The errors in solid pour objects may lead to inaccuracies in volume and other
quantity calculations, and to incorrect representation and hatching in
drawings.
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While you model, use the following methods to check the model for pour-
related errors:

• Check if there are Solid error rows in the session history log file
(page 707).

• Ensure that the cast-in-place concrete parts and pour objects look
continuous in model views. They should not have part outlines or shadow
lines inside them, like in the following images:

If you notice errors or overlapping volumes or faces, try remodeling some of
the parts.

You can also try out the following tips to avoid pour-related errors:

• Make sure that the number of parts included in a single pour object is
reasonable.

• Sometimes modeling the parts in a different order may fix errors in pour
objects.
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• To control which lines are visible in drawings, use the advanced options
XS_DRAW_CAST_PHASE_INTERNAL_LINES and
XS_DRAW_CAST_UNIT_INTERNAL_LINES.

This may help because the cast-in-place concrete parts that have errors are
treated in the same way in drawings as the precast concrete parts.

If remodeling the parts does not fix errors in solid pour objects, then overlap
the parts as little as possible to ensure that the volume and quantity
calculations are close to the correct values.

Example: Identify and fix a pour error

This is how an error related to a solid pour object can be indicated in a model
view and in a drawing. The pour object is not shown as continuous, and there
are extra lines between the parts in the pour object:

Checking the session history log file (page 707) and clicking a Solid failure
position row helps you to locate the error in the model (press Ctrl+2 to see
through the parts):

Try moving a beam end so that it is no longer on the same surface as the
column side:
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This is how the model and the drawing look like after you have fixed the
model:

Also the volume of the pour object is now correct, for example, in reports. The
overlapping volume of the beam and the column is only counted once.

See also

View solid errors (page 707)

Manage pours (page 444)

Example: Create concrete geometry and work with pours
The guidelines in this example help you to efficiently model cast-in-place
concrete geometries, and to define, visualize, sequence, and report pours and
pour breaks.

Before you start, ensure that you have pour management enabled. See Enable
pour management (page 445).

1. If possible, use an existing engineering or architectural model or drawing
as a basis when you create concrete structures in Tekla Structures. 

Import the existing model or drawing as a reference model to your Tekla
Structures model.

See Insert a reference model and Reference models and compatible
formats.

2. If you are using an IFC model as a reference model:
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a. Convert the concrete structures you need from the IFC model to
native Tekla Structures objects. 

See Convert IFC objects into native Tekla Structures objects and
Example: Convert IFC objects into Tekla Structures objects at one go.

b. Check the conversion results.

c. If needed, modify the converted objects. 

For example, you may need to change the profile, material, or cast
unit type of the converted objects.

TIP Use Organizer for checking and selecting objects.

3. If you are using a different reference model type, or if there are structures
that cannot be converted from an IFC model, model the needed concrete
structures as cast-in-place concrete parts in Tekla Structures. 

You can model by tracing over the reference model.

See Create parts and modify part properties (page 196).

4. For each cast-in-place concrete part, define a pour phase number to
divide your Tekla Structures model into pour objects. 

For example, use the default pour phase 0 for horizontal structures, like
beams and slabs, and the default pour phase 1 for vertical structures, like
columns and walls, to separate them to different pour objects.

See Define the pour phase of a part (page 450).

TIP Use selection filters or Organizer to efficiently select multiple parts
and to modify them all at the same time.

5. View and check the pour objects in a pour view. 

See View cast-in-place concrete structures (page 447) and Pour objects
(page 451).

6. If needed, modify the pour phases or create pour breaks to fine-tune the
pour objects. 

For example, create pour breaks to split large slabs into smaller pour
objects.

See Create a pour break (page 461) and Pour breaks (page 458).

7. Once you are ready with the concrete geometry and pour objects, you can
define pour sequences by entering pour numbers for pour objects, or by
using the Organizer categories. 

See Modify the properties of a pour object (page 453) and Categories in
Organizer.
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8. Calculate the pour units, and modify them by adding and removing
objects if needed. 

See Pour units (page 453).

9. You can also define other properties for pour objects and pour units, for
example, concrete mixtures, or dates or status of workflow. 

See Modify the properties of a pour unit (page 457) and Categories in
Organizer.

10. Use Organizer to categorize pours. Then you can select them by their
sequence and report pour-specific information, such as pour volumes and
formwork areas. 

See View object properties in Organizer and Example: Organize the model
into location and custom categories, and view quantities.

11. If you wish, use Task manager to include pour objects and pour units in
tasks and to schedule pours. You can then visualize pour status
information based on planned and actual dates by using Project status
visualization. 

See Create a task in Task manager and Project status visualization.

12. Create general arrangement drawings for pour units. 

Select a pour unit using the  Select assemblies switch, create a 3D
view of the pour unit, and then create a GA drawing using the 3D view.

This way you can automatically include in the drawing all reinforcement,
embeds, and other objects that need to be shown with the pour object.

See Pours in drawings.

2.9 Create reinforcement
Once you have created a model of concrete parts, you will need to reinforce
the parts to gain higher strength for the parts.

In Tekla Structures, you can use different methods to create reinforcement. In
many cases, you may need to use a combination of several reinforcement
tools to get the desired results.

The most automated method is to use the various reinforcement components
Tekla Structures contains. We recommend that you use reinforcement
components to create reinforcement whenever possible. The components are
adaptive, attached to a concrete part, and updated automatically if the
dimensions of the reinforced part change.

Create parts, reinforcement, and construction
objects

469 Create reinforcement



Rebar sets are another flexible and versatile method to create reinforcement.
Also the rebar sets are adaptive to concrete geometry, and easy to modify
using direct modification.

In addition to these methods, you can manually create:

• single reinforcing bars (page 496)

• reinforcing bar groups (page 496)

For more automated reinforcing bar group creation you can use Rebar
shape catalog (page 498), which contains predefined reinforcement shapes.

• reinforcement meshes

• prestressed strands (page 517)

• reinforcement splices (page 519)

When needed, you can also combine several reinforcement objects into rebar
assemblies (page 614), for example, to create reinforcement cages.

Create a rebar set
Rebar sets are reinforcing bars that you can modify by using direct modification
and the rebar set guidelines, leg faces, and local modifiers. You can create
rebar sets when you want to flexibly reinforce various areas in concrete parts
or pour objects.

You have several options for creating rebar sets. Longitudinal and crossing
rebar sets, and rebar sets created according to concrete part or pour object
faces, are attached and adaptive to a concrete part or pour object. Using the
Point input command you can create rebar sets even outside concrete
objects. You can also use Rebar shape placing tool to create rebar sets.

NOTE When you work with rebar sets, ensure that the  Direct modification
switch is active.

Basic concepts related to rebar sets
The leg faces (page 525) of a rebar set are planes that define where the
reinforcing bar legs are created. Tekla Structures creates leg faces at the
reinforced faces of concrete parts or pour objects, or according to the points
you pick when you create rebar sets.

The rebar set leg surfaces are similar to leg faces, but they can be curved. Tekla
Structures creates leg surfaces when you create rebar sets using the By
guidelines command.
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Each rebar set has at least one guideline that defines the distribution direction
of the bars. The spacing of the bars is also measured along the guideline. The
guideline can be a line, or a polyline that may have corner chamfers.

In the example below, the leg faces are shown in gray, and the guideline is
highlighted in yellow:

The position of the guideline affects the bar creation. If you move or lift an end
of the guideline, the bars turn respectively. For example:
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If needed, you can create up to two secondary guidelines, and use them to
define different spacings along the rebar set. You can also use secondary
guidelines when you create longitudinal bars for curved structures (page 489).
Tekla Structures automatically creates three guidelines for longitudinal rebar
sets in curved beams, polybeams, strip footings, and wall panels. The rebar
sets that have leg surfaces can only have one secondary guideline.

If you need to modify a rebar set only at certain locations, you can create local
property modifiers, end detail modifiers, and splitters.

Create longitudinal rebars
You can create rebar sets that consist of longitudinal reinforcing bars in a
concrete part or pour object.

1. Depending on the concrete object you want to reinforce, use a part view
or a pour view (page 447).

2. On the Rebar tab, click Longitudinal.

3. Move the mouse pointer over the edges of a concrete part or pour object. 
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Tekla Structures highlights the cross sections that you can select.

4. Select the cross section that you want to reinforce. 

5. If needed, modify the cross section size or shape for the bars. 

To do this, click  on the contextual toolbar, and then drag the cross
section handles.

6. In the selected cross section, select the faces that you want to reinforce. 
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By default, only one of the faces is selected. To select multiple faces, hold
down Shift or Ctrl.

Tekla Structures highlights the selected faces in yellow.

7. To extend or shorten individual faces, click  on the contextual toolbar.
Then drag the yellow and magenta end handles.

8. To finish, click the middle mouse button, or click  Create the rebar set
on the contextual toolbar.

Tekla Structures creates a rebar set at each selected face, and the bars
perpendicular to the selected cross section.

Create crossing rebars
You can create a rebar set that consists of crossing reinforcing bars in a
concrete part or pour object.

1. Depending on the concrete object you want to reinforce, use a part view
or a pour view (page 447).

2. On the Rebar tab, click Crossing.
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3. Move the mouse pointer over the edges of a concrete part or pour object. 

Tekla Structures highlights the cross sections that you can select.

4. Select the cross section that you want to reinforce. 

5. If needed, modify the shape of the bars. 

To change the cross section size for the bars, click  on the contextual
toolbar and then drag the cross section handles.

6. With  active on the contextual toolbar, in the selected cross section,
select the bar legs that you want to create. 

By default, all legs are selected and Tekla Structures creates a leg for each
object face.

• To unselect a selected leg, hold down Ctrl and click the leg.

• To unselect all legs, click  on the contextual toolbar.

• To select more than one leg, select the first leg, and then hold down
Ctrl or Shift when selecting the rest of the legs.

• To select all legs, click  on the contextual toolbar.
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Tekla Structures highlights the selected legs in yellow, and creates a
continuous bar shape of the legs.

7. If you want to rotate the bar shape, for example, to move stirrup hooks to
another corner, press Tab for counterclockwise or Shift+Tab for clockwise
direction.

8. If you need to extend or shorten individual legs, click  on the contextual
toolbar and then drag the bar end handles. 

This way you can also create overlapping bar shapes, or extend bar ends
outside the concrete object.

9. If you want to modify the distribution length of the bars, adjust the length
of the rebar set guideline. 

Click  on the contextual toolbar and then drag the guideline end
handles .

10. To finish, click the middle mouse button, or click  Create the rebar set
on the contextual toolbar.

Tekla Structures creates the bars parallel to the selected cross section, and
distributes the bars along the length of the guideline.
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Create rebars by face
You can create rebar sets according to a face of a concrete part or pour object.

1. Depending on the concrete object you want to reinforce, use a part view
or a pour view (page 447).

2. On the Rebar tab, click By face.

3. Define the faces and areas of the concrete object you want to reinforce,
and the direction of the bars using the following options on the contextual
toolbar: 

Click this button To do this

Create bars at the near face of the concrete object.

Create bars at the far face of the concrete object.

Create bars parallel to the longest object face edge.

With the  option, bars are created so that they are
parallel to the edge that is closest to the mouse pointer.

Create bars perpendicular to the longest object face
edge.

With the  option, bars are created so that they are
perpendicular to the edge that is closest to the mouse
pointer.

Create bars in two directions: one set of bars parallel to
the longest object face edge, and the other set of bars
perpendicular to the edge.

With the  option, one set of bars is parallel and the
other set of bars perpendicular to the edge that is closest
to the mouse pointer.

Create bars for an entire object face.

Create bars for a rectangular area on an object face.

Create bars for a polygonal area on an object face.

4. Depending on the area you selected to reinforce, do one of the following: 

• To reinforce an entire object face:

a. Move the mouse pointer over the faces of a concrete part or pour
object.
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Tekla Structures shows the object face dimensions, and a symbol
that indicates the direction of the bars.

b. Select the object face.

• To reinforce a rectangular area, pick two opposite corners of the area.

• To reinforce a polygonal area, pick the polygon corners.
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Then click the middle mouse button.

Tekla Structures creates the bars according to the options you selected. If you
selected to create bars in two directions, Tekla Structures creates two rebar
sets: one with bars parallel to the longest object face edge, and one with bars
perpendicular to it.

Create rebars by guidelines
You can create a rebar set at one or more faces of a concrete part, according
to one or two guidelines you define by picking points.

1. On the Rebar tab, click By guidelines.

2. Select the part faces that you want to reinforce. 
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Tekla Structures highlights the selected faces in yellow.

You can select as many faces as you like.

If you need to deselect a selected face, click the face again.

3. Click the middle mouse button to finish selecting faces.

4. Pick points to define the location for the primary guideline, and then click
the middle mouse button. 
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5. If you want to create a secondary guideline, pick points to define its
location. 

6. Click the middle mouse button to create the rebar set and the guidelines.

Tekla Structures creates a rebar set that extends over the faces you selected,
and distributes the bars along the guidelines.

Create rebars by point input
You can create a set of reinforcing bars so that you define the shape of the
bars by picking points in the model.

1. On the Rebar tab, click More --> Point input.

2. On the contextual toolbar, select an option to define the rebar set type
and the number of cross sections in the rebar set. 

The options are:

• Normal

• Tapered
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• Tapered ridge

• Tapered curved

• Tapered N

If you select the Tapered N option, enter the number of cross sections.

3. Pick points to define the shape of the bar at the first cross section. 

You can use different snapping (page 83) methods, such as Ortho and
temporary reference points.

4. Click the middle mouse button to finish picking.

5. Depending on the rebar set type and the number of cross sections, do
one of the following: 

• For a  Normal rebar set, pick the start point and the end point of
the rebar set.

• At the second and subsequent cross sections for other types of rebar
set, pick points to define the bar shape. Then click the middle mouse
button to finish picking at each cross section.

Tekla Structures creates a rebar set with leg faces between each cross section.

Rebar set properties
Use the contextual toolbar or the property pane to view and modify the
properties of rebar sets. The file name extension of the property file is .rst.

See also Rebar set properties (page 1016) and Modify a rebar set (page 521).
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Limitations
• Roundings in bent bar corners are not taken into account in automatic

clash avoidance when Tekla Structures creates rebar sets and arranges
them to layers.

• You cannot create rebar sets in deformed parts.

Create a rebar set using Rebar shape placing tool
You can create a rebar set by selecting a predefined bar shape from Rebar
shape placing tool. The predefined shapes in Rebar shape placing tool are
based on the shapes that have been defined in Rebar shape manager and
saved in the RebarShapeRules.xml file.

Use Rebar shape placing tool to reinforce parts and pour objects. The rebar
sets may extend across single or multiple objects.

Rebar shape placing tool does not work with round, spiral, or 3D bar shapes,
or in tapered variable cross sections.

Create rebar sets

1. On the Rebar tab, click More --> Rebar placing. 

The Rebar shape placing tool dialog box opens.

2. If you want to create bars that extend across several parts or pour objects,
for example dowel bars, select Multiple objects from the list at the
bottom of the dialog box.

3. If you want to create several rebar sets in the same cross section, select
the Keep cross section check box.

4. Select one of the predefined bar shapes from the tree view on the left. 

If the shape that you need is not available, or if you want to remove the
shapes that you do not need, you can reorganize the tree view (page 488).

5. Define the bar dimensions. 

The dimensions you can define vary depending on the selected bar shape.

The hook properties are visible only if you have set the advanced option
XS_REBAR_RECOGNITION_HOOKS_CONSIDERATION to FALSE in File
menu --> Settings --> Advanced Options --> Concrete Detailing.

• To set a Length of leg value, click a leg in the preview of the shape.

If you do not enter a Length of leg value, the leg length is calculated
automatically according to the dimensions of the concrete structure.

• To set a Bending angle value for a bend that is not 90 degrees, click
one of the legs next to the bend.

6. Set the rebar set reference point to start, middle, or end by double-
clicking the different legs or hooks in the preview of the shape. 
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When you are placing the rebar set in the model, you can move the rebar
set preview to a new location by dragging the reference point.

7. Modify the other bar properties as needed. 

For example, you can use Layer order number to arrange bars to layers
when two or more rebar sets overlap.

8. On the Spacing tab, define the spacing properties of the rebar set.

9. To place the rebar set in the model, move the mouse pointer over the
edges and faces of a concrete structure. 

Depending on the concrete structure you want to reinforce, use a part
view or a pour view (page 447).

Tekla Structures highlights the cross sections and faces that you can
select. For example:

Create parts, reinforcement, and construction
objects

484 Create reinforcement



10. Select the cross section or face that you want to reinforce. 

If you have Multiple objects selected, click each cross section or face to
select them. Click the middle mouse button to finish selecting.

Tekla Structures shows a preview of the bar shape in the model, and the
first and last bars in the rebar set in cyan.
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11. To move the rebar set to the desired location in the selected cross section
or face, do any of the following: 

• Click a blue line segment to place the rebar set reference point on that
line segment. For example:
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If needed, you can still change the reference point location in the
Rebar shape placing tool dialog box by double-clicking the desired
location in the preview.

• Drag the magenta reference point handle  to a new location on the
blue line.

• To turn the bar shape, click  on the contextual toolbar.
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12. Click the middle mouse button to create the rebar set. 

13. If you have the Keep cross section check box selected, repeat steps 4–12
to create more rebar sets in the same cross section.

TIP If the Rebar shape placing tool dialog box is already open but the command is
not active, click the Select cross section button to start creating rebar sets
again.

Add and remove rebar shapes
You can modify the tree view in Rebar shape placing tool by adding
frequently used bar shapes to the tree, or removing the bar shapes that you
do not need.

1. On the Rebar tab, click More --> Rebar placing. 

The Rebar shape placing tool dialog box opens.

2. Click Organize catalog.

Create parts, reinforcement, and construction
objects

488 Create reinforcement



3. To create a new category folder, click .

4. Drag and drop the selected shapes to the folder. 

If multiple shapes have the same shape code and you drag them to the
categories, the shape codes get a suffix (1), (2), and so on. You can
rename the shapes by clicking the name twice and entering a new name
or suffix, for example, (a), (b).

When the shapes are listed in a report, they all get the same shape code.

5. Change the name of the folder in a similar way, if needed.

6. To remove a shape from a category, select the shape and click .

7. Click OK.

Examples: Rebar sets in curved structures
You can reinforce curved concrete structures using rebar sets.

The curved concrete structures can include curved beams (page 263),
polybeams (page 266) that have Arc point chamfers, and flat spiral beams
(page 270) whose total rise is zero. You can also reinforce strip footings and
wall panels the same way as you reinforce beams and polybeams.

For more information about creating rebar sets, see also Create a rebar set
(page 470).

Create longitudinal bars for a curved beam
In this example, we will create longitudinal bottom bars for a curved concrete
beam.

1. Create a curved concrete beam.

a. On the Concrete tab, click Beam.

b. Pick two points.

c. Double-click the beam to modify its properties.

d. Set the radius and number of segments, and then click Modify.

2. Create longitudinal bars at the bottom face of the beam.

a. On the Rebar tab, click Longitudinal.

b. Move the mouse pointer over the edges of the beam, and select the
cross section that you want to reinforce.

c. Click the middle mouse button to create the rebar set. 
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Tekla Structures creates the curved longitudinal bars according to the
beam geometry. For example:

The rebar set has three guidelines: one at each end of the beam and
one in the midpoint of the beam.

Create crossing bars for a curved polybeam
In this example, we will create crossing U-shaped stirrups for a curved
concrete polybeam.

1. Create a concrete polybeam with curved segments.

a. On the Concrete tab, click Beam --> Polybeam.

b. Pick at least three points you want the beam to go through, and then
click the middle mouse button.

c. Select the polybeam.

d. Select the handle in a polybeam corner, and then select the Arc
point chamfer type on the contextual toolbar.

2. Create crossing bars that follow the bottom and side faces of the beam.

a. On the Rebar tab, click Crossing.

b. Move the mouse pointer over the edges of the beam, and select the
cross section that you want to reinforce.

c. In the selected cross section, hold down Ctrl and click the top bar leg
to unselect it.

d. Click the middle mouse button to create the rebar set. 
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Tekla Structures creates the crossing bars radially according to the
beam geometry. For example:

The rebar set guideline is a polyline with three points, and the
midpoint has the Arc point chamfer.

Create reinforcing bars for a spiral beam
In this example, we will reinforce a spiral beam whose total rise is zero. We will
create longitudinal bottom bars and crossing U-shaped stirrups.

You can use the following manual method also for more complex concrete
objects that have been imported and that cannot be reinforced automatically.

1. Create a flat spiral concrete beam.

a. On the Concrete tab, click Beam --> Spiral beam.

b. Pick the start point of the beam.

c. Pick a point to indicate the beam's center of curvature.

d. Click the middle mouse button.

e. Ensure that Total rise is 0.

2. Create longitudinal bars at the bottom face of the beam.

a. On the Rebar tab, click Longitudinal.

b. Move the mouse pointer over the edges of the beam, and select the
cross section that you want to reinforce.

c. Click the middle mouse button to create the rebar set. 
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Tekla Structures creates a longitudinal rebar set with one guideline.

d. Press Esc to interrupt the command.

3. Modify the longitudinal rebar set by creating more guidelines.

a. Select the rebar set.

b. On the contextual toolbar, click  Add secondary guideline.

c. Ensure that you are in the single point picking mode (  shown on the
contextual toolbar).

d. Pick the start point for a secondary guideline.

e. Pick the start point for another secondary guideline.

f. Press Esc to finish creating secondary guidelines.

g. If needed, move the guidelines to desired locations by dragging them
or their end point handles. 
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For example, you can move the primary guideline to the midpoint of
the beam, one of the secondary guidelines to the start of the beam,
and the other secondary guideline to the end of the beam.

h. Modify the geometry (page 523) and properties (page 1019) of the
guidelines as needed. 

The bars are constructed according to the locations and spacing
settings of these three guidelines.

4. Create crossing bars that follow the bottom and side faces of the beam.

a. On the Rebar tab, click Crossing.

b. Move the mouse pointer over the edges of the beam, and select the
cross section that you want to reinforce.

c. In the selected cross section, hold down Ctrl and click the top bar leg
to unselect it.

d. Click the middle mouse button to create the rebar set. 
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Tekla Structures creates a crossing rebar set with one guideline.

e. Press Esc to interrupt the command.

5. Modify the crossing rebar set by modifying the guideline.

a. Select the rebar set to highlight the guideline.

b. Drag the guideline end points  to the beam ends. 
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c. Drag the guideline midpoint  to the beam midpoint. Ensure that

the new guideline corner has the Arc point chamfer. 

Alternatively, you can click  on the contextual toolbar to make the
guideline follow the leg face edges that are located between the
guideline end points.

Tekla Structures arranges the crossing bars radially along the beam.
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Limitations

• If curved longitudinal bars have too small start and/or end offset values,
the bars closest to leg face edges may be divided into small bar segments.
To avoid this, increase the offset values.

Create a single reinforcing bar

1. On the Rebar tab, click  Single bar. 

If you need to modify the properties before you create the reinforcement,
hold down Shift and click the Single bar command to open the Single
rebar properties.

2. Select the part to reinforce.

3. Pick the bar start point.

4. Pick the other bar reference points to set the bar shape.

5. Click the middle mouse button to finish picking. 

Tekla Structures attaches the bar to this part.

6. If you want to modify the reinforcement, do one of the following: 

• Use direct modification (page 544). Ensure that the  Direct
modification switch is active.

• Double-click the reinforcement to open the Single rebar properties
and modify the properties (page 1009).

See also

Create a reinforcing bar group using Rebar shape catalog (page 498)

Create a reinforcing bar group (page 496)

Create parts, reinforcement, and construction
objects

496 Create reinforcement



Create a reinforcing bar group
A reinforcing bar group includes several identical, or very similar, reinforcing
bars. Tekla Structures always treats these bars as a group, modifies them in
the same way, deletes them all at the same time, and so on. You first define
the shape of a single bar, then the direction in which Tekla Structures
distributes the bars.

NOTE If you do not want to manually define the bar shape, use Rebar shape
catalog (page 498) and its predefined reinforcement shapes instead.

1. On the Rebar tab, click . 

If you need to modify the properties before you create the reinforcement,
hold down Shift and click the command button to open the Rebar group
properties.

2. Select the part to reinforce. 

Tekla Structures attaches the bar group to this part.

3. Pick the bar start point.

4. Pick the other bar reference points. 

These points define the plane of the first bar and the shape of a single bar
in the group.

5. Click the middle mouse button to finish picking.

6. Pick the start point of the bar group.

7. Pick the end point of the bar group. 
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The start and end points indicate the distribution length and direction of
the bars. Usually the distribution length of the bars is perpendicular to the
plane so that the cover thickness on the sides can be defined.

8. If you want to modify the reinforcement, do one of the following: 

• Use direct modification (page 544). Ensure that the  Direct
modification switch is active.

• Double-click the reinforcement to open the Rebar group properties
and modify the properties (page 1009).

See also

Create a curved reinforcing bar group (page 505)

Create a circular reinforcing bar group (page 507)

Create a tapered or spiral reinforcing bar group (page 509)
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Create a reinforcing bar group using Rebar shape catalog
A reinforcing bar group includes several identical, or very similar, reinforcing
bars. You can create a reinforcing bar group by selecting a predefined
reinforcement shape from Rebar shape catalog. The predefined shapes in
Rebar shape catalog are based on the shapes that have been defined in
Rebar shape manager and saved in the RebarShapeRules.xml file.

Rebar shape catalog does not work with tapered reinforcing bar groups
(page 509) or with 3D bar shapes.

NOTE If you do not want to use the predefined shapes but want to manually
define the bar shape, use the Bar group (page 496) command instead.

1. On the Rebar tab, click Bar group --> Rebar shape catalog. 

The Rebar Shape Catalog dialog box opens.

2. Select one of the predefined shapes from the tree view on the left. 

You can add frequently used shapes to the tree view (page 501), or delete
the shapes that you do not need.

If you select an existing reinforcement in the model and click the Get
button, the properties of that reinforcement are displayed in the Rebar
Shape Catalog dialog box.

3. If needed, modify the bar properties. 

• To set a Length of leg value, click a leg in the preview of the shape.

If you do not enter a Length of leg value, the leg length is calculated
automatically according to the dimensions of the concrete part.

• To set a Bending angle value for a bend that is not 90 degrees, click
one of the legs next to the bend.

• For circular, polygonal and spiral reinforcement, you can enter Circle
diameter and Overlap distance values.

The hook properties are visible only if you have set the advanced option
XS_REBAR_RECOGNITION_HOOKS_CONSIDERATION to FALSE in File
menu --> Settings --> Advanced Options --> Concrete Detailing.

4. If needed, set the reference point of the reinforcement (page 501) to start,
middle, or end by double-clicking the different legs or hooks in the
preview of the shape.

5. Click OK.

6. In the model, place the mouse pointer over a part face or edge. 
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A preview showing the placing and dimensions of the reinforcement is
displayed.

7. Based on the preview, select a placing for the reinforcing bar group and
click the left mouse button. 

Tekla Structures creates the reinforcement.

8. If you want to modify the reinforcement, do one of the following: 

Create parts, reinforcement, and construction
objects

500 Create reinforcement



• Use direct modification (page 544). Ensure that the  Direct
modification switch is active.

• Double-click the reinforcement to open the reinforcing bar group
properties, and modify the properties (page 1009).

See also

Create a reinforcing bar group (page 496)

Create a rebar set using Rebar shape placing tool (page 483)

Add more reinforcement shapes to the tree view in Rebar shape catalog
You can modify the tree view in Rebar shape catalog by adding frequently
used shapes to the tree, or deleting the shapes that you do not need.

1. On the Rebar tab, click Bar group --> Rebar shape catalog. 

The Rebar Shape Catalog dialog box opens.

2. Click Organize catalog.

3. Create a new category folder by clicking .

4. Drag and drop the selected shapes to the folder. 

If multiple shapes have the same shape code and you drag them to the
categories, the shape codes get a suffix (1), (2), and so on. You can
rename the shapes as you wish by clicking the name twice and entering a
new name or suffix, for example, (a), (b).

When the shapes are listed in a report, they all get the same shape code.

5. Change the name of the folder in a similar way, if needed.

6. To remove a shape from a category, select the shape and click .

7. Click OK.

See also

Create a reinforcing bar group using Rebar shape catalog (page 498)

Set the reinforcement reference point in Rebar shape catalog
When you use Rebar shape catalog and select a shape, you can set the
reference point to the start, middle or end of the reinforcing bar leg. When you
create the reinforcement in the model, you can move the reinforcement to a
new location by dragging the reference point. This is useful, for example, when
the reinforcing bar legs are of certain length and you want to aim the
reference point, for example, to the middle of a part edge. You can also move
the reference point of circular reinforcement shapes.
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1. On the Rebar tab, click Bar group --> Rebar shape catalog. 

The Rebar Shape Catalog dialog box opens.

2. Select a reinforcement shape.

3. Set the reference point to the desired location (start, middle, end) by
double-clicking the position in the preview of the shape. 

4. If needed, modify the bar properties.

5. Click Apply or OK.

6. In the model, place the mouse pointer over a part face or edge.

7. Based on the preview, select the desired placing and hold down the Alt
key and click the left mouse button. 

Create parts, reinforcement, and construction
objects

502 Create reinforcement



The reference point is displayed.

8. Move the reinforcement to a new location by dragging the reference point.

9. Click the middle mouse button to create the reinforcement. 

NOTE For circular reinforcement you can set the reference point to the
center line as follows:

a. Place the mouse pointer over a column edge to have the
reinforcement oriented correctly.

b. Hold down the Alt key and click the left mouse button.

c. Drag the reference point and hold down Shift key to snap to
the center of column.
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d. Click the middle mouse button to create the reinforcement.

See also

Create a reinforcing bar group using Rebar shape catalog (page 498)

Reinforce pour objects using Rebar shape catalog
You can reinforce pour objects in pour views using Rebar shape catalog.

NOTE Rebar sets (page 470) and Rebar shape catalog are the methods to
reinforce pour objects in pour views. If you want to use other
reinforcement commands, such as Bar group (page 496), or
reinforcement components, you need to reinforce single parts in part
views. All reinforcement are visible both in part views and in pour
views.

When you reinforce pour objects using Rebar shape catalog:

• The reinforcement is attached to the reinforced part, not to the pour
object.

• The reinforcement geometry is defined in accordance with the pour object
geometry even though the reinforcement is attached to a part. For
example, pour breaks can limit the length of reinforcing bars.

• In reports the reinforcement information is listed according to the part, not
to the pour object.

Before you start, create concrete parts whose cast unit type is Cast in place.
Tekla Structures automatically forms pour objects of them.

1. Ensure that you are using a pour view. If not, click Pour view on the
Concrete tab.

2. If needed, create pour breaks by selecting any of the Pour break
commands on the Concrete tab: 

• Single point

• Two points

• Multiple points

3. To insert a reinforcement to a pour object, on the Rebar tab, click Bar
group --> Rebar shape catalog. 

The Rebar Shape Catalog dialog box opens.

4. Select a shape from the tree view on the left and modify the properties, if
needed.

5. Click OK.

6. In the model, place the mouse pointer over a face or an edge of a pour
object. 
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7. Based on the preview, select a placing for the reinforcement and click the
left mouse button to create the reinforcement. 

See also

Create a reinforcing bar group using Rebar shape catalog (page 498)

Manage pours (page 444)

Create a curved reinforcing bar group
You can reinforce curved segments in a concrete beam or a curved wall.

1. On the Rebar tab, click Bar group --> Curved group. 

If you need to modify the properties before you create the reinforcement,
hold down Shift and click the Curved group command to open the
Curved bar properties.

2. Select the part to reinforce. 

Tekla Structures attaches the bar group to this part.

3. Pick three points on an arc to define the curve. 
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4. Pick two points to indicate the distribution direction of the bars. 

Tekla Structures creates a group of curved reinforcing bars.
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5. If you want to change the curved reinforcing bar group properties:

a. Double-click the curved reinforcing bar group to open the Curved bar
properties.

b. Modify the properties (page 1009).

c. Click Modify.

See also

Create a reinforcing bar group using Rebar shape catalog (page 498)

Create a reinforcing bar group (page 496)

Create a circular reinforcing bar group (page 507)

Create a tapered or spiral reinforcing bar group (page 509)

Modify reinforcement (page 520)

Create a circular reinforcing bar group
You can reinforce round circular columns.

1. On the Rebar tab, click Bar group --> Circular group. 

If you need to modify the properties before you create the reinforcement,
hold down Shift and click the Circular group command to open the
Circular rebar properties. For example, to create a circular spiral bar, set
Rebar group type to Spiral.

2. Select the part to reinforce. 

Tekla Structures attaches the bar group to this part.

3. Pick three points on the outer contour of the concrete part to define the
circular bars. 
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The radius is automatically calculated from these three points.

4. Pick two points to indicate the distribution direction of the bars. 

Tekla Structures creates a group of circular reinforcing bars.
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NOTE If you want to modify the splice length of the round stirrups, enter
negative values in the Start and End boxes in the Circular rebar
properties.

5. If you want to change the circular reinforcing bar group properties:

a. Double-click the circular reinforcing bar group to open the Circular
rebar properties.

b. Modify the properties (page 1009).

c. Click Modify.

See also

Create a reinforcing bar group using Rebar shape catalog (page 498)

Create a reinforcing bar group (page 496)

Create a curved reinforcing bar group (page 505)

Create a tapered or spiral reinforcing bar group (page 509)

Modify reinforcement (page 520)

Create a tapered or spiral reinforcing bar group
For example for rectangular concrete parts with variable cross sections, you
can create tapered reinforcing bar groups by specifying the bar shape at each
cross section. For concrete parts with a uniform cross section, you can also
create spiral reinforcing bar groups, and it is sufficient to pick two points to
define the distribution area of the bar group. If the part shape is not
rectangular, an alternative bar shape can be defined.
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Use the Rebar group type list in the reinforcing bar group properties to select
or change the bar group type.

To create a circular spiral bar group (page 507), use the Bar group --> Circular
group ribbon command and the Circular rebar properties instead.

1. On the Rebar tab, hold down Shift and click . 

The Rebar group properties open.

2. In the General section, select a tapered or spiral option from the Rebar
group type list.

3. If needed, enter or modify the other bar properties.

4. Select the part to reinforce. 

Tekla Structures attaches the bar group to the part.

5. Pick points to define the shape of the bar at the first cross section.

6. Click the middle mouse button to finish picking.

7. Depending on the bar group type and the number of cross sections, do
one of the following:

• At the second and each subsequent cross section for a tapered bar
group, pick points to define the bar shape. Then click the middle
mouse button to finish picking at the cross section.

• For a spiral bar group, pick two points to define the distribution area of
the bar group.

Tekla Structures creates the reinforcement.

Reinforcing bar group types

Option Description Example

Normal

Not tapered.

Pick two points to define the distribution
area of the bar group.

 

Tapere
d

One bar dimension changes linearly in
the group.
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Option Description Example

Tapere
d ridge

One bar dimension changes linearly in
the group. The dimension is longest in
the middle of the group.

Tapere
d
curved

One bar dimension changes along a
curve. The dimension is longest in the
middle of the group.

 

Tapere
d N

One bar dimension changes linearly
between N cross sections. Enter the
number of cross sections in the Number
of cross sections box.

Spiral

The reinforcing bars rise in a polygonal or
circular shape along the longitudinal axis
of the part.

See also

Create a reinforcing bar group using Rebar shape catalog (page 498)

Create a reinforcing bar group (page 496)

Reinforcing bar and bar group properties (page 1009)

Modify a single reinforcing bar, bar group, or mesh (page 544)
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Create a reinforcement mesh
You can create a reinforcement mesh that consists of two perpendicular bar
groups. Tekla Structures treats mesh bars as one unit but distinguishes the
main and crossing bars.

The reinforcement mesh can be rectangular, polygonal, or bent. You can also
create a customized reinforcement mesh.

NOTE You cannot change the mesh type once the mesh has been created.

Create a rectangular reinforcement mesh

1. On the Rebar tab, hold down Shift and click  Mesh. 

The Rebar mesh properties open in the property pane.

2. In the Mesh type list, select Rectangle. 

NOTE You cannot change the mesh type once the mesh has been
created.

3. Select the part to reinforce. 

Tekla Structures attaches the mesh to this part.

4. Pick the start point of the mesh.

5. Pick a point to indicate the direction of the longitudinal bars.

6. Click the middle mouse button to finish picking. 

Tekla Structures creates the mesh parallel to the work plane, to the left of
the points you picked.

7. If you want to modify the reinforcement mesh, do one of the following: 
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• Use direct modification (page 544). Ensure that the  Direct
modification switch is active.

• Double-click the reinforcement to open the Rebar mesh properties
and modify the properties (page 1011).

Create a polygonal reinforcement mesh

1. On the Rebar tab, hold down Shift and click  Mesh. 

The Rebar mesh properties open in the property pane.

2. In the Mesh type list, select Polygon. 

NOTE You cannot change the mesh type once the mesh has been
created.

3. Select the part to reinforce. 

Tekla Structures attaches the mesh to this part.

4. Pick the start point of the mesh.

5. Pick the corner points of the mesh.

6. Click the middle mouse button to finish picking.

7. Pick a point to indicate the direction of the longitudinal bars. 

Tekla Structures creates the mesh.

8. If you want to modify the reinforcement, do one of the following: 
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• Use direct modification (page 544). Ensure that the  Direct
modification switch is active.

• Double-click the reinforcement to open the Rebar mesh properties
and modify the properties (page 1011).

Reinforcement mesh with holes

If you want to reinforce a part that has holes, you need to pick the corner
points of holes when you create the reinforcement.

1. Select the part to reinforce.

2. Pick the start point of the mesh.

3. Pick the corner points of the mesh.

4. Pick the corner points of the hole.

Note that you need to pick the corner points of the hole in the opposite
direction than the corner points in the mesh.

5. Click the middle mouse button to finish the picking.

6. Pick a point to indicate the direction of the longitudinal bars.

Create a bent reinforcement mesh

1. On the Rebar tab, hold down Shift and click  Mesh. 

The Rebar mesh properties open in the property pane.
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2. In the Mesh type list, select Bent. 

NOTE You cannot change the mesh type once the mesh has been
created.

3. Enter the bending radius.

4. Select the part to reinforce. 

Tekla Structures attaches the mesh to this part.

5. Pick three or more points to indicate the bending shape of the crossing
bars. 

6. Click the middle mouse button to finish picking.

7. Pick two points to indicate the length and direction of the longitudinal
bars. 
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Tekla Structures creates the mesh.

8. If you want to modify the reinforcement mesh, do one of the following: 

• Use direct modification (page 544). Ensure that the  Direct
modification switch is active.

• Double-click the reinforcement to open the Rebar mesh properties
and modify the properties (page 1011).

Create a customized reinforcement mesh
You can create a customized reinforcement mesh that consists of two
perpendicular bar groups.

1. On the Rebar tab, hold down Shift and click  Mesh. 

The Rebar mesh properties open in the property pane.

2. In the Layout section, select the Custom Mesh option.

3. Enter an identifier for the mesh in the Mesh box. 

The default identifier is Custom Mesh.

4. Modify the other mesh properties (page 1013) as needed.

5. Select the part to reinforce. 

Tekla Structures attaches the mesh to this part.

6. Pick two points to indicate the direction of the longitudinal bars.

7. If you want to define the mesh plane, pick one more point.

8. Click the middle mouse button to finish picking.
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9. If needed, you can save customized properties as property files, and load
these properties later on when you create new meshes.

Create a reinforcement strand pattern
You can create prestressed straight or deflected strands for concrete parts.

NOTE To allow positioning of the strands, first create points to the part you
are creating the strands for. On the Edit tab, click Points and select
On plane to open the Point Array dialog box. Define the point
coordinates.

1. On the Rebar tab, click  Strand. 

If you need to modify the properties before you create the reinforcement,
hold down Shift and click the Strand command to open the Strand
pattern properties.

2. Select the part you are creating strands for.

3. Pick each of the points that you are using to position the strands (for
example, at the end of a part). 

The points you pick define the first cross section.

4. Click the middle mouse button to finish picking.

5. Pick points to position the strands. 

• If you create a single cross section, pick two points to define the length
of the strands.

• If you create two or more cross sections, for each cross section, pick
points to indicate the strand positions. Pick the strand positions in the
same order as for the first cross section.

6. Click the middle mouse button to finish picking. 
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Tekla Structures creates the strands.

7. If you want to change the strand properties:

a. Double-click the strand pattern to open the Strand pattern
properties.

b. Modify the properties (page 1032).

c. Click Modify.

See also

Debond reinforcement strands (page 518)

Debond reinforcement strands
1. Double-click the strand pattern in which you want to debond strands. 

The Strand pattern properties opens.

2. Click the Debonding button to open the debonding properties.

3. On the Debonding tab, click the Add button to create a new row in the
table.

4. Enter the strand numbers in the Debonded strands field. 

The strand number is the selection order number of the strand.

• To set the same values for all the strands, enter all the strand
numbers, separated by a space. For example, 1 2 3 4.

• To set separate values for each strand, click Add to add a new row,
then enter the strand number in the Debonded strands field.
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5. Define the debonded lengths. 

To set symmetrical lengths, select the End lengths = start lengths check
box and only enter values in the From start or Middle to start fields.

6. Click Modify. 

Tekla Structures displays the debonded section of the strand in red.

See also

Create a reinforcement strand pattern (page 517)

Reinforcement strand properties (page 1032)

Create a reinforcement splice
You can join reinforcing bars or reinforcing bar groups together with
reinforcement splices. There can be a gap between the bars or groups.

1. On the Rebar tab, click Edit --> Rebar splice. 

If you need to modify the properties before you create the reinforcement,
hold down Shift and click the Rebar splice command to open the Rebar
splice properties.

2. Select the first reinforcing bar or bar group.

3. Select the second reinforcing bar or bar group. 

Tekla Structures creates the splice. The splices have blue splice symbols

 in the model.

Create parts, reinforcement, and construction
objects

519 Create reinforcement



4. If you want to change the splice properties:

a. Double-click the splice to open the Rebar splice properties.

b. Modify the properties.

c. Click Modify.

Splice properties

Use the Rebar splice properties to view and modify the properties of splices.
The file name extension of a saved splice property file is .rsp.

Option Description
Joint type Splice type.

Lap left creates the lap to the direction of the first
reinforcing bar or bar group selected, Lap right to the
direction of the second.

Lap both centers the lap between the bars or bar groups.
Lap length Length of the lap joint.
Offset Offset of the splice center point from the point where the

bars originally met.
Bar positions Select whether the lapping bars are on top of each other

or parallel to each other.

See also

Create a reinforcing bar group using Rebar shape catalog (page 498)

Create a reinforcing bar group (page 496)

Split and splice a reinforcement (page 564)
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2.10 Modify reinforcement
Once you have added reinforcement to your model, you can modify the shape
of the reinforcement, for example. Tekla Structures includes several methods
for the modification.

Rebar sets

When you modify rebar sets, you can use direct modification on the rebar set
guidelines (page 521), leg faces (page 525), and modifiers (page 533).

Single reinforcing bars, bar groups, and meshes

When you modify single reinforcing bars, bar groups, or meshes, you can use:

• direct modification (page 544)

• handles (page 554)

• grouping (page 551)

• combining (page 552)

• splitting (page 553)

See also

Use adaptivity to modify a reinforcement (page 561)

Attach a reinforcement object to a concrete part (page 562)

Split and splice a reinforcement (page 564)

Assign running numbers to reinforcement (page 566)

Classify reinforcement to layers (page 567)

How to calculate the reinforcing bar length (page 570)

How to calculate the reinforcing bar leg length (page 573)

Modify a rebar set
You can modify rebar sets by changing the rebar set properties, by using the
rebar set guidelines or leg faces, or by creating local rebar set modifiers. The
guidelines, leg faces, and modifiers all have direct modification handles.

NOTE When you work with rebar sets, ensure that the  Direct modification
switch is active.

In case you open an existing model using a new version of Tekla Structures,
always update the existing rebar sets first: on the Rebar tab, click More -->
Regenerate.

See also Modify a rebar set using leg faces and leg surfaces (page 525) and
Modify a rebar set locally using modifiers (page 533).
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Modify the properties of a rebar set
You can change the properties of a rebar set in the property pane or on the
contextual toolbar.

1. Double-click the rebar set that you want to modify.

2. If you want to use previously saved properties from a file, select the
property file from the topmost list in the property pane: 

3. Modify the rebar set properties (page 1016) in the property pane.

4. Click Modify to save the changes.

5. To save the properties for later use, enter a name for the property file in

the topmost box in the property pane, and then click .

TIP Alternatively, you can modify the rebar set properties on the contextual toolbar.

Change the layer order of a rebar set
You can adjust the order of the bar layers when two or more rebar sets
overlap.

By default, the layer order is based on the creation order of the rebar sets.
Tekla Structures automatically places the bars that are created first closest to
the concrete surface, and the bars created last will be the furthest.

1. Select a rebar set.

2. On the contextual toolbar, adjust the layer order by using the following
buttons: 

• Click  to move the bars to the outermost layer.

• Click  to move the bars one layer outwards.

• Click  to move the bars one layer inwards.

• Click  to move the bars to the innermost layer.

Alternatively, you can enter a number in the Layer number box in the
property pane, and then click Modify to save the changes.
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The smaller the layer number, the closer to the concrete surface the bar
layer is. You can use both positive and negative numbers.

If you set the same layer number for several rebar sets, the bars will be
placed on the same layer, and the bars may collide.

3. If needed, fine-tune the layer order at any individual leg face or leg surface
(page 525) separately. 

These modifications override the default settings and the layer order
settings of the entire rebar set.

Modify a rebar set using guidelines
The guidelines of a rebar set define the distribution direction of the bars. The
spacing of the bars is also measured along the guidelines. You can modify the
rebar set guidelines by using direct modification.

See also Resize and reshape model objects (page 107), Distribute bars in a
rebar set (page 541), and Create a secondary guideline (page 537).

To show or hide (page 540) the guidelines when you select rebar sets in the
model, go to the Rebar tab and click Visibility --> Guidelines. Alternatively,
you can use the keyboard shortcut Alt+2 or the advanced option
XS_REBARSET_SHOW_GUIDELINES.

To modify a guideline, select a rebar set and do any of the following:

• To move a guideline, drag the line handle.

• To move a guideline point, drag the point handle .

• To add a new point to the start or end of a guideline:

1. Select the start or end point of the guideline .

2. Click  Add new point on the contextual toolbar.

3. Pick a location for the new start or end point.

• To add an intermediate point to a guideline, drag a midpoint handle .

• To remove a point from a guideline, select the point and press Delete.

• To modify chamfers at intermediate corner points of a guideline:

1. Select a corner point.

2. Define the chamfer type and dimensions (page 397) on the contextual
toolbar.

• To change the direction (page 539) of a guideline, select the guideline and

click  Swap ends on the contextual toolbar.
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• To make a guideline follow the leg face edges that are located between the
guideline end points:

1. Move the guideline end points to the leg face edges.

2. If there are cuts at the edges, add intermediate points to the guideline,
and drag the handles to the corners of the cuts.

3. Double-click the guideline to open its properties in the property pane.
Select Yes in the Follow edges list, and then click Modify.

Alternatively, select the guideline and click  on the contextual
toolbar.

Change the bar plane orientation of a rebar set
By default, Tekla Structures creates rebar set bars at planes that are
perpendicular to the guidelines. In slanted or complex concrete structures, you
may want to align the bar planes with the global z direction of the model, or
some other way.

1. Select a rebar set.

2. On the contextual toolbar, click  Bar plane orientation. 

Tekla Structures shows a yellow arrow with two blue direct modification
handles, at the start point of the primary guideline. The bars become
aligned with the global z direction.

3. To adjust the bar plane orientation some other way, drag the handles. 

For example, you can let the top handle snap to a certain location, such as
a part corner, in the model.
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4. If you want to revert to the original bar plane orientation, and to hide the

yellow arrow, click  again on the contextual toolbar.

Modify a rebar set using leg faces and leg surfaces
In addition to modifying an entire rebar set, you can make changes to any
individual leg face or leg surface. Leg surfaces are especially useful when you
reinforce curved or complex concrete structures.

NOTE If a leg face or leg surface is shown in red in the model, it means that the
geometry of some bars in the rebar set is not valid. Check and fix the
properties of the rebar set (page 1016) (for example, the bending radius) or
the leg face (page 1020) or leg surface (page 1021).

Show the leg faces and leg surfaces
To modify rebar sets by using leg faces, you first need to make the leg faces
visible.

Tekla Structures also shows the leg surfaces. They automatically adapt to the
geometry of the parts they are associated with. You can only modify leg
surfaces by using their properties (page 1021) or contextual toolbar, not by
using direct modification.

1. Ensure that the  Direct modification switch is active.

2. On the Rebar tab, click Visibility --> Leg faces.

3. Select a rebar set. 
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Tekla Structures shows the leg faces and leg surfaces. Tekla Structures
also shows the bar layer numbers of the rebar set on each leg face or leg
surface, for example LN=1.

4. Move the mouse pointer over a leg face or leg surface and click to select it.

Tekla Structures highlights the leg face or leg surface in yellow.

Alternatively, you can use the keyboard shortcut Alt+1 or set the advanced
option XS_REBARSET_SHOW_LEGFACES to TRUE.
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Modify the leg faces
You can use any of the following methods when you modify rebar set leg
faces.

1. To move a leg face, drag it to a new location. 

The connected leg face planes remain intact.

If you want the connected leg faces to follow the dragged leg face, hold
down Alt when dragging. The size of the dragged leg face remains the
same, but the connected leg face planes may change.

If you want to detach the leg face from the connected leg faces, hold down
Shift when dragging.

2. To move an edge of a leg face, drag the edge to a new location. 

The connected leg faces follow, if possible.

3. To create a parallel copy of a leg face, hold down Ctrl and drag the leg
face.

4. To create a new, connected leg face, hold down Ctrl and drag an edge of
the leg face. 
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5. To add a new leg face at a part face or pour object face, ensure that the

rebar set is selected, click  Add leg face on the contextual tab on the
ribbon, and then select the part face or pour object face.

6. To create a new leg face on the basis of its corner points, switch Picking

mode to , click  Add leg face on the contextual tab on the
ribbon, and then pick points to indicate the leg face corners. Click the
middle mouse button to finish picking.

7. To add a new corner point to a leg face, drag a midpoint handle. 
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8. To remove a corner point from a leg face, select the point and press
Delete.

9. To modify a corner chamfer of a leg face, select the corner point, and then
select the chamfer type (page 397) and enter the chamfer dimensions on
the contextual toolbar. 
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10. To remove a leg face, select it and press Delete.

11. To define an additional offset between a leg face and the bars, select the
leg face and enter a value for Additional offset on the contextual toolbar,

for example, . 

A negative value moves the bars outside the concrete.

12. To flip bars over to the other side of a leg face, select the leg face and click

 Flip bar side on the contextual toolbar. 
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Note that after flipping, Tekla Structures searches for concrete on the
other side of the leg face to create a concrete cover and apply the
concrete cover settings. If there is no concrete, the concrete cover
thickness will be zero.

13. To change the order of the bar layers at an individual leg face, select the
leg face and adjust the layer order by using the following buttons on the
contextual toolbar: 

• Click  to move the bars to the outermost layer.

• Click  to move the bars one layer outwards.

• Click  to move the bars one layer inwards.

• Click  to move the bars to the innermost layer.
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Alternatively, you can enter a number in the Layer number box in the
property pane, and then click Modify to save the changes.

The smaller the layer number, the closer to the concrete surface the bar
layer is. You can use both positive and negative numbers.

These modifications override the layer order settings of the entire rebar
set (page 521).

TIP You can modify leg face properties (page 1020) also in the property pane.

Modify the leg surfaces
Use these methods to modify rebar set leg surfaces.

1. To add a new leg surface at a part face, ensure that the rebar set is

selected, click  Add leg surface on the contextual tab on the ribbon,
and then select the part face. 

If you try to add a leg surface to a part face that already has a leg surface
that belongs to the same rebar set, Tekla Structures does not add the new,
duplicate leg surface.

2. To remove a leg surface, select it and press Delete.

3. To change the order of the bar layers at an individual leg surface, select
the leg surface and adjust the layer order by using the following buttons
on the contextual toolbar: 

• Click  to move the bars to the outermost layer.

• Click  to move the bars one layer outwards.

• Click  to move the bars one layer inwards.

• Click  to move the bars to the innermost layer.

Alternatively, you can enter a number in the Layer number box.

The smaller the layer number, the closer to the concrete surface the bar
layer is. You can use both positive and negative numbers.

These modifications override the layer order settings of the entire rebar
set (page 521).

4. To define an additional offset between a leg surface and the bars, select
the leg surface and enter a value for Additional offset on the contextual
toolbar. 

A negative value moves the bars outside the concrete.
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5. To define whether the bars at a leg surface are cut by the openings in the

concrete, select the leg surface and click the  Create holes button on
the contextual toolbar.

TIP You can modify leg surface properties (page 1021) also in the property pane.
After modifying the properties of the selected leg surfaces, click Modify to save
the changes.

Modify a rebar set locally using modifiers
You can use modifiers to modify a rebar set at certain locations only.

For example, you can create a local property modifier to only change the
properties of certain bars in a rebar set, or you can create hooks or threading
by adding an end detail modifier, or you can split rebar set bars into stock
lengths by using splitters.

You can also create secondary guidelines for the rebar set. With a secondary
guideline you can define a different spacing at the start and end of the rebar
set bars, for example.

Modifiers are lines, or polylines that may have corner chamfers. Modifiers are
projected to rebar set leg faces. Each modifier then only affects the rebar set
bars that its projection touches.

NOTE When you work with rebar sets, ensure that the  Direct modification
switch is active.

To select entire rebar sets, or bar groups or individual bars within rebar sets in

the model, you can use the three reinforcement selection switches .
Tekla Structures then shows the existing modifiers that affect the selected
rebar set bars, and the direct modification handles of the modifiers. Different
modifiers have different colors as follows:
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Modifier Color Example
Property modifier Light green

End detail modifier Magenta

Splitter Orange

Secondary guideline Light blue

An arrowhead symbol  close to the midpoint of each modifier indicates
the direction (page 539) of the modifier, pointing from the start towards the
end of the modifier.

When you select a modifier, Tekla Structures indicates the rebar set bars that
are affected by the modifier, and shows the other, unaffected bars as semi-
transparent.

You can modify the modifiers by using direct modification, or by changing their
properties in the property pane or on the contextual toolbar. When you
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change the modifier properties, the properties of the rebar set bars change at
the location defined by the modifier.

When you delete a modifier, the rebar set reverts to the state it had without
the modifier.

Create a property modifier
Property modifiers are shown in light green.

1. Using the reinforcement selection switches , select the rebar set
bars for which you want to create the modifier.

2. On the Rebar set contextual tab on the ribbon, click  Property
modifier.

3. Define how you want to place the modifier in the model. 

Click the Picking mode button on the contextual tab to cycle through the
picking modes and to select the picking mode.

The  button indicates that you can pick one point, and the 

button indicates that you can pick multiple points. The  button
indicates that the modifier will be created for the selected bars only.

4. Depending on the selected picking mode, do one of the following: 

• Pick one point to create a single line modifier for the selected rebar
set, bar group, or bars.

• Pick two points to define the end points of a single line modifier. Then
click the middle mouse button.

• Pick multiple points to create a polyline modifier. Then click the middle
mouse button to finish picking.

5. To end the command, press Esc.

6. To apply local modifications to the rebar set bars at the modifier location:

a. Select the modifier.

b. If you need to change the modifier geometry, drag the direct
modification (page 107) handles.

c. Change the property modifier properties (page 1022) on the
contextual toolbar or in the property pane.

d. If you used the property pane, click Modify to save the changes.
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Create an end detail modifier
End detail modifiers affect the nearest end of the bar, so by moving the
modifier you can change the bar end that it affects. End detail modifiers are
shown in magenta.

Tekla Structures displays the threaded bar ends in dark red.

1. Using the reinforcement selection switches , select the rebar set
bars for which you want to create the modifier.

2. On the Rebar set contextual tab on the ribbon, click  End detail.

3. Define how you want to place the modifier in the model. 

Click the Picking mode button on the contextual tab to cycle through the
picking modes and to select the picking mode.

The  button indicates that you can pick one point, and the 

button indicates that you can pick multiple points. The  button
indicates that the modifier will be created for the selected bars only.

4. Depending on the selected picking mode, do one of the following: 

• Pick one point to create a single line modifier for the selected rebar
set, bar group, or bars.

• Pick two points to define the end points of a single line modifier. Then
click the middle mouse button.

• Pick multiple points to create a polyline modifier. Then click the middle
mouse button to finish picking.

5. To end the command, press Esc.

6. To apply local modifications to the rebar set bars at the modifier location:

a. Select the modifier.

b. If you need to change the modifier geometry, drag the direct
modification (page 107) handles.

c. Change the end detail modifier properties (page 1026) on the
contextual toolbar or in the property pane.
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d. If you used the property pane, click Modify to save the changes.

Create a splitter
Splitters split bars and create lap or crank splices. Splitters are shown in
orange.

1. Using the reinforcement selection switches , select the rebar set
bars for which you want to create the modifier.

2. On the Rebar set contextual tab on the ribbon, click  Splitter.

3. Define how you want to place the splitter in the model. 

Click the Picking mode button on the contextual tab to cycle through the
picking modes and to select the picking mode.

The  button indicates that you can pick one point, and the 

button indicates that you can pick multiple points. The  button
indicates that the splitter will be created for the selected bars only.

4. Depending on the selected picking mode, do one of the following: 

• Pick one point to create a single line splitter for the selected rebar set,
bar group, or bars.

• Pick two points to define the end points of a single line splitter. Then
click the middle mouse button.

• Pick multiple points to create a polyline splitter. Then click the middle
mouse button to finish picking.

TIP If you want to create the splitter at a rounded distance from a bar
end, and the dimension shown is measured from the other bar end,
hold down Shift when you are placing the splitter in the model to
switch the measuring point to the other bar end.

5. To end the command, press Esc.

6. To apply local modifications to the rebar set bars at the splitter location:

a. Select the splitter.

b. If you need to change the splitter geometry, drag the direct
modification (page 107) handles.

c. Change the splitter properties (page 1029) on the contextual toolbar
or in the property pane.

d. If you used the property pane, click Modify to save the changes.
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Create a secondary guideline
You can create up to two secondary guidelines for a rebar set. Secondary
guidelines are shown in light blue.

Note that if a rebar set was created using the By guidelines command, or if it
otherwise has leg surfaces, you can only create one secondary guideline.

1. Select a rebar set.

2. On the Rebar set contextual tab on the ribbon, click  Secondary
guideline.

3. Define how you want to place the guideline in the model. 

The  button on the contextual tab indicates that you can pick one

point, and the  button indicates that you can pick multiple points.
Click the button to change the picking mode.

4. Depending on the picking mode, do one of the following: 

• Pick one point to create a single line guideline.

• Pick two points to define the end points of a single line guideline. Then
click the middle mouse button.

• Pick multiple points to create a polyline guideline. Then click the
middle mouse button to finish picking.

5. To create another secondary guideline, repeat steps 3 and 4. 

If there are already two secondary guidelines in a rebar set, the tooltip of

the  button changes to Maximum number of secondary guidelines
reached and you cannot create more guidelines.

6. Press Esc to stop creating secondary guidelines.

7. If needed, select a secondary guideline and modify its geometry
(page 107) and properties (page 1019). 
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For example, you can adjust the secondary guideline's length or spacing
values.

See also Distribute bars in a rebar set (page 541).

8. To set a secondary guideline as the primary guideline, select the
secondary guideline and click  Set as primary on the contextual
toolbar.

TIP Alternatively, you can create secondary guidelines the same way as you copy
other modifiers (page 539): hold down Ctrl and drag the primary guideline.

Create a modifier by copying
You can copy rebar set modifiers.

1. Select a rebar set, bar group, or bar to show its modifiers. 

If you cannot see modifiers, ensure that the required modifier types are
set visible (page 540).

2. Select the modifier that you want to copy.

3. Hold down Ctrl and drag the modifier to the desired location. 

Tekla Structures creates a new modifier when you release the mouse
button.

4. Select the modifier to modify its geometry (page 107) and properties as
needed.

Change the direction of a modifier
You can change the direction of rebar set modifiers, splitters, and guidelines.

1. Select a rebar set, bar group, or bar to show its modifiers. 

If you cannot see modifiers, ensure that the required modifier types are
set visible (page 540).
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2. Select the modifier whose direction you want to change.

3. On the contextual toolbar, click  Swap ends. 

The arrowhead symbol  close to the midpoint of the modifier
changes direction, indicating the changed modifier direction.

Make a modifier follow edges
You can define that a rebar set modifier, splitter, or guideline attempts to
follow the leg face edges that are located between the modifier end points.
This is useful when you reinforce and detail curved concrete structures, for
example.

1. Move the modifier end points to the leg face edges.

2. If there are cuts at the edges, add intermediate points to the modifier, and
drag the handles to the corners of the cuts.

3. Double-click the modifier to open its properties in the property pane.
Select Yes in the Follow edges list, and then click Modify. 

Alternatively, select the modifier and click  on the contextual toolbar.

Show or hide rebar set modifiers
If you have many rebar set modifiers in your model, it may be useful to only
show some of them when you select rebar set bars, and hide the ones that are
not currently needed. You can show and hide modifiers according to their
type.

For example, you can show the end detail modifiers only, and hide all property
modifiers and splitters.

You can also show or hide primary and secondary guidelines.

1. Go to the Rebar tab and click Visibility.

2. Do any of the following:

• Click Guidelines to switch the guidelines on or off.

• Click Property modifiers to switch the property modifiers on or off.

• Click Splitters to switch the splitters on or off.

• Click End detail modifiers to switch the end detail modifiers on or off.

Alternatively, you can use the following keyboard shortcuts or advanced
options:

• Alt+2, XS_REBARSET_SHOW_GUIDELINES

• Alt+3, XS_REBARSET_SHOW_PROPERTY_MODIFIERS

• Alt+4, XS_REBARSET_SHOW_SPLITTERS
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• Alt+5, XS_REBARSET_SHOW_END_DETAIL_MODIFIERS

To show or hide the rebar set modifiers that have been created by using
components, use the advanced option
XS_REBARSET_SHOW_MODIFIERS_CREATED_BY_COMPONENTS. By default, this
advanced option is set to FALSE and these modifiers are hidden when you
select rebar set bars.

How to cut rebar sets
You can cut rebar sets automatically by the existing cuts in the concrete parts
or manually by using the cutting commands on the Edit tab. You can modify
cuts in rebar sets the same way as you modify cuts in parts in the model, by
using direct modification.

You can use the following commands to create cuts:

• line cut (page 391)

• polygon cut (page 390)

• part cut (page 393)

Concrete cover settings are also applied to cuts, even on cut edges that are
parallel to reinforcing bars.

Cut a rebar set using a cut in a concrete part
When you create rebar sets for concrete parts using the Longitudinal,
Crossing, By face, and By guidelines commands, Tekla Structures
automatically cuts the new rebar sets using the existing cuts in the concrete
parts. If you add a new cut to a concrete part with a rebar set, the rebar set is
not automatically cut. If you want to cut the rebar set as well, use the Part cut
command, and use the new cut as the cutting part.

1. On the Edit tab, click Part cut.

2. Select the rebar set you want to cut.

3. Select the cut in the concrete part. 

Tekla Structures cuts the rebar set.

Modify a cut in a rebar set
You can modify cuts in rebar sets using direct modification. For example, you
can make a cut in a rebar set of a different size or shape from a cut in a
concrete part.

1. Ensure that the  Direct modification switch is active.

2. Select the cut in the rebar set.

3. Modify the cut using direct modification (page 107).
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Distribute bars in a rebar set
Rebar sets may have different spacing values between the bars. The spacing of
the bars is measured along the rebar set guidelines. You can modify the
spacing values in model views or in the property pane, or by using property
modifiers. You can also add, move, and delete single bars.

NOTE When you work with rebar sets, ensure that the  Direct modification
switch is active.

Modify the spacing properties

You can modify the spacing properties in model views and using the
contextual toolbar, or in the property pane.

1. Select a rebar set.

2. If you want to modify spacing properties using a secondary guideline or
property modifier, select the secondary guideline or property modifier. 

To modify secondary guideline spacings independently from the primary

guideline, click  on the contextual toolbar, or set Inherit from primary
to No in the secondary guideline properties (page 1019).

For the property modifier (page 1022), set Modify distribution to Yes.

3. On the contextual toolbar, click  Modify the spacings. 

Tekla Structures shows the spacing values and the start and end offsets in
the model.
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For rebar sets and property modifiers, the values are shown on the
primary guideline, for secondary guidelines on the secondary guideline.

When spacing modification is enabled, you cannot modify the geometry of
the guidelines.

4. To specify how the bars are spaced, select an option for Creation method
on the contextual toolbar.

5. To modify a spacing value, an offset, or the number of bars, click the value
in a model view, enter a new value, and then press Enter. 

When Creation method is set to By exact spacings, you can list multiple
spacing values (separated with space characters) and/or use multiplication
to repeat the same spacing, for example, 100 200 5*300.

Alternatively, you can modify the spacing properties in the property pane.

Add, move, and delete single bars

1. Select a rebar set.

2. If you want to move bars along a secondary guideline, select the
secondary guideline. 

Click  on the contextual toolbar, or set Inherit from primary to No in
the secondary guideline properties.

3. On the contextual toolbar, click  Move, add, delete reinforcement. 

Tekla Structures displays a  handle for each bar on the guideline, and

 symbols between the bars.

4. Do any of the following: 
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• To add a bar between two existing bars, click .

• To move a bar, select the  handle of the bar and drag it to a new
location.

You can also use the keyboard to enter a numeric location (page 87).
Then press Enter to confirm.

• To delete a bar, select the  handle of the bar and press Delete.

You can also use the Exclude list in the rebar set (page 1016), secondary
guideline (page 1019), or property modifier (page 1022) properties to leave out
the first and/or last rebar set bars.

Modify a single reinforcing bar, bar group, or mesh
You can modify a reinforcement by using direct modification. You can either
modify the reinforcement simply by dragging handles, or select a command
from the contextual toolbar.

NOTE Direct modification does not work for the following reinforcement
types:

• Circular (page 507), curved (page 505), or 3D reinforcing bars

• Reinforcement strand patterns (page 517)

If you have created the reinforcement using a component, you need to
explode the component before using direct modification.

Before you start:

• Ensure that the  Direct modification switch is active.

• Select the reinforcement.

Tekla Structures displays the handles that you can use to modify the

reinforcement, and a toolbar icon . Click the icon to open the toolbar
and to select the appropriate command. The available commands depend
on the type of the reinforcement you are modifying.
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To modify single reinforcing bars, reinforcing bar groups, or reinforcement
meshes:

To Do this Command
available for

Change the cover
thickness of a
reinforcing bar

Drag a line handle to the desired
location.

Reinforcing bars,
reinforcing bar
groups,
reinforcement
meshes

Add polygon
points to a
reinforcing bar

Drag a midpoint handle  to the
desired location.

Reinforcing bars,
reinforcing bar
groups, polygonal
and bent
reinforcement
meshes

Add points to the
start or end of a
reinforcing bar

1. Click the start or end reference
point of the reinforcing bar

.

2. Click the Add new point
button  on the toolbar.

3. Pick a location for the new
start or end point.

Reinforcing bars,
reinforcing bar
groups
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To Do this Command
available for

Remove points
from a reinforcing
bar

1. Select one or more reference
points.

2. Press Delete.

Reinforcing bars,
reinforcing bar
groups, polygonal
and bent
reinforcement
meshes

Add hooks 1. Click the start or end point of

the reinforcing bar .

A toolbar for hook properties
appears.

2. Select the desired shape for
the hook.

3. If you selected Custom hook,
enter the angle, radius, and
length for the hook and click

.

Reinforcing bars,
reinforcing bar
groups

Change the
bending radius of
a reinforcing bar

1. Click the Change bending
radius button  on the
toolbar.

2. Enter a value in the box next to
the Change bending radius
button and press Enter.

Reinforcing bars,
reinforcing bar
groups

Change the
diameter of a
reinforcing bar

1. Click the Change diameter
button  on the toolbar.

2. Select a value from the list
next to the Change diameter
button.

Reinforcing bars,
reinforcing bar
groups,
reinforcement
meshes

Modify the
spacings by
adjusting the
range

1. Click the Modify spacings
button  on the toolbar.

2.

Drag a handle  to the
desired location.

Reinforcing bar
groups,
reinforcement
meshes

Modify the
spacings by
splitting the range
in two

1. Click the Modify spacings
button  on the toolbar.

Reinforcing bar
groups,
reinforcement
meshes
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To Do this Command
available for

2.
Drag a midpoint handle  to
the desired location and
release the handle.

Tekla Structures creates a new
reinforcing bar and the range
is split in two. The spacing in
the two new ranges is as close
as possible to the original
spacing.

3. If needed, change the number
of spaces or the spacing value.
Click the midpoint handle and
enter the desired values in the
boxes on the toolbar and press
Enter.

Move, add, or
remove
reinforcement

1. Click the Move, add, delete
reinforcement button  on
the toolbar.

Tekla Structures displays the
line handles for each
reinforcing bar.

2. Do one of the following:

• To move a reinforcing bar,
highlight it and drag it to
the desired location.

• To add a reinforcing bar
between two reinforcing

bars, click .

• To delete reinforcing bars,
select them and press
Delete.

Reinforcing bar
groups,
reinforcement
meshes

See also

Use handles to modify a reinforcement (page 554)

Use adaptivity to modify a reinforcement (page 561)

Check the validity of reinforcement geometry (page 564)
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Distribute bars in a reinforcing bar group
You can select how reinforcing bars are distributed in a bar group by modifying
the bar spacings.

To modify the spacings of bars in a reinforcing bar group, do one of the
following:

To Do this
Modify the spacings
using direct
modification
(page 544)

1.
Ensure that the Direct modification switch 
is active.

2. Select a reinforcing bar group.

3. On the contextual toolbar, click the Modify the
spacings button .

4.

Drag a handle  to the desired location.
Modify the spacings
using the Rebar
group properties

1. Select a reinforcing bar group.

2. Double-click the reinforcement to open the
Rebar group properties.

3. In the Distribution section, select a spacing
option from the Creation method list.

4. Enter the required values.

5. Click Modify.

Spacing options in the Creation method list:

Option Description Example
Equal
distribut
ion by
number
of
reinforci
ng bars

Enter the number of reinforcing bars.

Tekla Structures divides the available
distance by the number of bars.

Enter the number of bars in the
Number of reinforcing bars box.

Equal
distribut
ion by
target
spacing
value

Enter a spacing value.

Tekla Structures aims the spacing value
as close as possible to the value in the
Target spacing value box.
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Option Description Example
By exact
spacing
value
with
flexible
first

Enter the spacing value in the Exact
spacing value box.

Creates fixed, regular spaces between
the bars. The first space adjusts to even
out the bar distribution.

If the first space is less than 10% of the
exact spacing value, Tekla Structures
removes one bar.

By exact
spacing
value
with
flexible
last
space

Enter the spacing value in the Exact
spacing value box.

Creates fixed, regular spaces between
the bars. The last space adjusts to even
out bar distribution.

 

By exact
spacing
value
with
flexible
middle
space

Enter the spacing value in the Exact
spacing value box.

Creates fixed, regular spaces between
the bars. The middle space adjusts to
even out bar distribution.

If there are an odd number of bars (two
middle spaces), the other middle space
adjusts to even out bar distribution.

 

By exact
spacing
value
with
flexible
first and
last
space

Enter the spacing value in the Exact
spacing value box.

Creates fixed, regular spaces between
the bars. Both the first and last spaces
adjust to even out bar distribution.

By exact
spacings

Enter the spacing values manually in the
Exact spacing values box.

Use multiplication to repeat spacings,
for example, 5*200 to create five spaces
of 200.

See also

Create a reinforcing bar group (page 496)

Create a reinforcing bar group using Rebar shape catalog (page 498)

Modify a single reinforcing bar, bar group, or mesh (page 544)
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Delete bars from a reinforcing bar group
You may occasionally need to delete or exclude specific reinforcing bars. For
example, when several reinforced areas intersect, causing reinforcing bars to
overlap, or when you want to start bar distribution at a specific distance from
the end of a part.

To delete reinforcing bars from a group, do one of the following:

To Do this
Delete bars using direct
modification (page 544)

1.
Ensure that the  Direct modification
switch is active.

2. Select a reinforcing bar group.

3. On the contextual toolbar, click the Move,
add, delete reinforcement button .

4. Select the bars to be deleted and press
Delete.

Delete bars using the Rebar
group properties

1. Select a reinforcing bar group.

2. Double-click the reinforcement to open the
Rebar group properties.

3. In the Distribution section, select an
option from the Exclude list.

4. Click Modify.

Examples when you have used the Exclude options:

Before excluding bars After excluding bars
Two reinforcing bar groups have been
added to a concrete beam:

• one bar group with flexible last
space

• one bar group with flexible first
space

Two reinforcing bar groups without
the excluded bars:

• one bar group with the last bar
excluded

• one bar group with the first bar
excluded
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See also

Create a reinforcing bar group (page 496)

Create a reinforcing bar group using Rebar shape catalog (page 498)

Modify a single reinforcing bar, bar group, or mesh (page 544)

Ungroup a reinforcement
You can ungroup reinforcing bar groups and reinforcement meshes. Only
reinforcement where each reinforcing bar is in one plane can be ungrouped.

NOTE You cannot ungroup circular (page 507) or curved (page 505)
reinforcing bar groups.

1. On the Rebar tab, click Edit --> Group.

2. Select one of the reinforcing bars in a reinforcing bar group or in a
reinforcement mesh. 

The reinforcing bar group is replaced with single reinforcing bars. The
single bars get the same properties and offsets as the group.

If you ungroup a reinforcement mesh, the offsets for single bars are zero.

Before ungrouping After ungrouping

See also

Modify reinforcement (page 520)

Create a reinforcing bar group using Rebar shape catalog (page 498)

Create a reinforcing bar group (page 496)

Create a reinforcement mesh (page 511)
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Group reinforcement
You can group single reinforcing bars and reinforcing bar groups. Only
reinforcement where each reinforcing bar is in one plane can be grouped. All
groups are created with exact spacings. Single reinforcing bars need to have
the same bending shape.

NOTE You cannot create circular (page 507) or curved (page 505) reinforcing
bar groups by grouping.

1. On the Rebar tab, click Edit --> Group.

2. Select all the reinforcing bars or reinforcing bar groups that you want to
group.

3. Click the middle mouse button.

4. Select one reinforcing bar or reinforcing bar group to copy the properties
from. 

The new group gets the same properties as the selected reinforcing bar.

NOTE The reinforcing bar or reinforcing bar group that you copy the
properties from is also added to the group. This means, for
example, that you cannot copy properties from a separate
reinforcing bar group which you do not want to include in your
new reinforcing bar group.

Before grouping After grouping

See also

Modify reinforcement (page 520)

Create a reinforcing bar group using Rebar shape catalog (page 498)

Create a reinforcing bar group (page 496)

Create a single reinforcing bar (page 496)
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Combine two reinforcing bars or reinforcing bar groups into one
You can combine two single reinforcing bars or reinforcing bar groups into
one. Reinforcing bars can be combined if their end points are connected, or
the bars are parallel and close to each other. However, in certain cases it is
possible to combine bars or groups that are not connected nor parallel. The
combined reinforcement gets the same properties as the bar selected first.

NOTE You cannot combine Tapered N reinforcing bar groups.

1. On the Edit tab, click Combine.

2. Select the first single bar or bar group to be combined.

3. Select the second single bar or bar group to be combined. 

Tekla Structures combines the reinforcing bar groups or bars into one.

See also

Create a reinforcing bar group using Rebar shape catalog (page 498)

Create a reinforcing bar group (page 496)

Create a single reinforcing bar (page 496)

Modify reinforcement (page 520)

Split a reinforcing bar group
You can split normal and tapered reinforcing bar groups into two groups. You
can also split single reinforcing bars into two.

1. On the Edit tab, click Split.

2. Select a reinforcing bar group.

3. Pick two points to indicate where to split the group. 

Tekla Structures splits the reinforcing bar group.

NOTE You cannot split reinforcing bar groups diagonally.

Once split, each new reinforcing bar group retains the properties
of the original group. For example, if the bars in the original group
had hooks at both ends, bars in the new groups also have hooks
at both ends. Modify the properties of the new groups, if needed.
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Before splitting After splitting

See also

Create a reinforcing bar group using Rebar shape catalog (page 498)

Create a reinforcing bar group (page 496)

Create a single reinforcing bar (page 496)

Modify a single reinforcing bar, bar group, or mesh (page 544)

Use handles to modify a reinforcement
If you do not want to use direct modification to modify a reinforcement, you
can use, for example, the reinforcement handles to modify the reinforcement.

Tekla Structures uses handles to indicate:

• The ends and corners of a reinforcing bar.

• The distribution length of a bar group.

• The corners and main bar direction of a mesh.

When you select a reinforcement, Tekla Structures highlights the handles. The
handle of the first end point is yellow, the rest are magenta.
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1. Select the reinforcement. 

Tekla Structures highlights the handles.

2. Click one of the handles to select it.

3. Move the handle like any other object in Tekla Structures. 

For example, if Drag and drop is active, just drag the handle to a new
position.

NOTE If you want to use the reinforcement handles, ensure that the

Direct modification switch  is not active. If the switch is
active and direct modification (page 544) is on, Tekla Structures
displays direct modification handles for the reference points,
ends, legs, and leg midpoints of the selected reinforcement. These
handles are blue.

See also

Check the validity of reinforcement geometry (page 564)

Add hooks to reinforcing bars
You can add hooks to the ends of reinforcing bars for anchoring purposes.
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NOTE Hooks are intended to be used only for anchoring purposes. Do not
use hooks as a method to model other reinforcing bar geometry,
because it may cause problems with visibility in drawings, in
adaptivity, and in bar bending shape recognition.

To add hooks to reinforcing bars, do one of the following:

To Do this
Add hooks using direct
modification (page 544)

1.
Ensure that the  Direct modification
switch is active.

2. Select a single reinforcing bar or a
reinforcing bar group.

3. Click the start or end point of the

reinforcing bar .

A toolbar for hook properties appears.

4. Select the desired shape for the hook.

5. If you select Custom hook, enter the
angle, radius, and length for the hook. Click

.
Add hooks using the Single
rebar or Rebar group
properties

1. Select a single reinforcing bar or a
reinforcing bar group.

2. Double-click the reinforcement to open its
properties.

3. In the Hooks section, select a hook type
for the bar start and/or end from the Hook
type list.

4. If you select Custom hook, enter the
angle, radius and length for the hook.

5. Click Modify.
Add hooks to rebar sets
using end detail modifiers

See Modify a rebar set locally using modifiers
(page 533).

For custom hooks you need to enter the hook information:
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Option Description
Angle Enter a value between -180 and +180

degrees.

1. Angle

2. Length

3. Radius

Radius Enter the internal bending radius of
the hook.

Use the same radius for the hook and
for the reinforcing bar. If the hook and
the reinforcing bar have different
radiuses, Tekla Structures does not
recognize the shape of the bar.

Length Enter the length of the straight part.

If the length is set to zero, no hooks
are created.

Hook examples

 Description
1 Standard 90-degree hook
2 Standard 135-degree hook
3 Standard 180-degree hook
4 Custom hook

If you select a standard hook, the Angle, Radius, and Length use predefined
dimensions.

The rebar_database.inp file contains the predefined minimum bending
radius and minimum hook length for all standard hooks.

See also

Create a reinforcing bar group (page 496)

Create a reinforcing bar group using Rebar shape catalog (page 498)

Modify a single reinforcing bar, bar group, or mesh (page 544)
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Define the reinforcement cover thickness
Reinforcing bars need a concrete cover to protect them against harmful
elements, such as the weather and fire. When you create single bars, Tekla
Structures uses the thickness of concrete cover to determine the position of
the bar.

To define the reinforcement cover thickness, do one of the following:

To Do this
Change the cover
thickness using direct
modification
(page 544)

1.
Ensure that the  Direct modification switch
is active.

2. Select a single reinforcing bar, a reinforcing bar
group, or a mesh.

3. Drag a line handle to the desired location.

Change the cover
thickness using the
Single rebar, Rebar
group, or Rebar
mesh properties

1. Select a single reinforcing bar, a reinforcing bar
group, or a mesh.

2. Double-click the reinforcement to open its
properties.

3. Define the reinforcing bar cover thickness in the
Cover thickness section.

The cover thickness can be defined in three
directions:

• On plane, that is, the distance from part’s
bottom, top, and side faces to the bar.

You can enter several values. Enter the values
in the order you pick the points to create the
bar. If you enter less values than there are bar
legs, Tekla Structures uses the last value for
the remaining legs.

• From plane, that is, the distance from the end
face of the part to the bar.

If the reinforcing bar is outside the part, enter
a negative value in the On plane and/or the
From plane boxes.
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To Do this
• In the longitudinal direction of the bar, that is,

start and end.

To define the length of an ultimate leg of a
bar, use the Leg length option and the Snap
to nearest points switch. Then pick
anywhere on a part edge or line to indicate
the direction for the bar leg.

4. Click Modify.
Change the default
cover thickness of the
rebar sets in a model

1. On the File menu, click Settings --> Options to
open the Options dialog box.

2. Go to the Rebar set settings and to the Covers
and locations tab.

3. Modify the settings and click OK.

You can define the default cover thickness values
in the global and/or parts' local coordinate
systems and at different part faces. In each
concrete part's properties, you can then select
whether to use the global or local cover thickness
values.

4. To apply the changes to all or selected existing
rebar sets in the model, go to the Rebar tab on
the ribbon and click More --> Regenerate.

Change the cover
thickness of the rebar
sets in an individual
concrete part or for a
part type

1. Double-click a concrete part to access its
properties.

2. Go to the Concrete covers for rebar sets
section.

Alternatively, you can click User-defined
attributes and go to the Rebar set tab.

3. Select the coordinate system: Global or part's
Local.

If you select the empty option, Tekla Structures
uses the global cover thickness values from the
Options dialog box.

4. To override the default values from the Options
dialog box, define the cover thickness at each
required part face.

• With the Global coordinate system, you can
enter the top, bottom, and side face values.

• With the Local coordinate system, you can
enter the top, bottom, front, back, start, and
end face values.
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To Do this
5. Click Modify to update the selected part's

properties.

6. To save the cover thickness values for later use
for this part type, update the standard file or
create a property file.

Change the concrete
cover thickness of the
rebar sets at a
concrete part face or
pour object face

1. Add a surface (page 414) to the object face at
which you want to change the concrete cover.

2. Double-click the surface to modify its properties
in the property pane.

3. In the Type list, select Concrete cover.

4. In the Rebar set section, enter the concrete
cover thickness in the Concrete cover box.

5. Click Modify to apply the changes.

NOTE: If you add surfaces to pour object faces,
update the rebar sets each time you reopen the
model. On the Rebar tab on the ribbon, click More -->
Regenerate.

On plane From plane Start and end

See also

Create a reinforcing bar group (page 496)

Create a reinforcing bar group using Rebar shape catalog (page 498)

Create a rebar set (page 470)

Modify reinforcement (page 520)
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Select the definition for a reinforcement
When you create (page 469) or modify (page 520) reinforcement, such as a
reinforcing bar group, rebar set, or reinforcement component, you can select a
definition for the bars from the rebar catalog. Selecting the definition
automatically sets some basic reinforcement properties, such as grade, size,
and bending radius.

1. Open the properties of the reinforcement.

2. In the property pane or component dialog box, click the ... button next to
the Size box. 

The Select rebar dialog box appears.

3. If needed, organize the rebar catalog view. 

For example, you can filter rebar definitions, or group and sort them
differently.

4. Select a rebar definition from the list.

5. Click OK to close the Select rebar dialog box.

6. Click Modify in the reinforcement properties to apply the changes.

Use adaptivity to modify a reinforcement
Reinforcement follows the shape of the part also when the reinforcement
handles are located on the face or edge of the part.

The following types of adaptivity are available:

• Fixed adaptivity: handles retain their absolute distances to the nearest part
faces.

• Relative adaptivity: handles retain their relative distances to the nearest
part faces in relation to the part’s overall size.

1. Select a reinforcement.

2. Right-click and select Adaptivity and then one of the adaptivity options
from the pop-up menu. 

When a part is modified, Tekla Structures handles the reinforcement
according to the adaptivity selection.

TIP To modify the general adaptivity settings, click File menu -->
Settings --> Options --> General.

You can also modify the adaptivity settings for each part separately.
These modifications override the general settings in the Options
dialog box.
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Adaptivity examples

Reinforcing bars
in their original
position

Fixed adaptivity

Relative
adaptivity

See also

Check the validity of reinforcement geometry (page 564)

Modify a single reinforcing bar, bar group, or mesh (page 544)

Attach a reinforcement object to a concrete part
When you create a reinforcement object, such as a bar group, rebar set, or
mesh, Tekla Structures attaches it to the concrete part that you have selected
to reinforce. Later in some cases, you might need to attach the reinforcement
object to another concrete part manually. The attached reinforcement objects
follow the part if the part is moved, copied, or deleted.
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NOTE Only attached reinforcement objects are shown in cast unit drawings
and reports with the part.

1. If you want to manually attach only certain single bars in a rebar set to a
part, create a property modifier (page 535) for the bars that you want to
attach.

2. Select the reinforcement object that you want to attach. 

To attach single rebar set bars, first select the rebar set, then the property
modifier that affects the bars that you want to attach.

3. Right-click and select Attach to part.

4. Select the part to which you want to attach the reinforcement object. 

The reinforcement object is attached to the part.

Note that if you have manually attached single bars in rebar sets to parts in
Tekla Structures 2022 SP2 or older versions, using property modifiers for
manual attachment does not work with these bars. To revert all manually
attached bars in rebar sets to automatic attachment (page 568), select all the
rebar sets in the model and use the Detach from part command.

Detach a reinforcement object from a concrete part

If needed, you can detach a reinforcement object from a concrete part.

1. Select the reinforcement object that you want to detach.

To detach single rebar set bars, first select the rebar set, then the property
modifier that affects the bars that you want to detach.

2. Right-click and select Detach from part.

The reinforcement object is detached from the part.

Note that if you detach a rebar set or a property modifier, the bars in the rebar
set are reattached automatically if they are inside a concrete part.

TIP Alternatively, you can use the ribbon when you manually attach or detach
reinforcement objects.

1. On the Rebar tab, click More --> Attach to part or More --> Detach from
part.

2. Select the reinforcement object that you want to attach or detach.

3. If you are attaching the reinforcement object, select the part to which you
want to attach the reinforcement object.

See also

How Tekla Structures automatically attaches rebar set bars to concrete parts
(page 568)
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Modify reinforcement (page 520)

Check the validity of reinforcement geometry
Reinforcement creation or modification can result in invalid reinforcement
geometry. For example, too big bending radius can cause invalid
reinforcement geometry. If a model contains a reinforcement with invalid
geometry, the reinforcement is not shown in the drawings. The reinforcement
becomes visible and the drawings are updated when the geometry is
corrected.

If a rebar set leg face or leg surface (page 525) is shown in red in the model, it
means that the geometry of some bars in the rebar set is not valid. Check and
fix the properties of the rebar set (page 1016) (for example, the bending
radius) or the leg face (page 1020) or leg surface (page 1021).

NOTE Reinforcement geometry validity check does not work with circular
(page 507) or curved (page 505) reinforcing bar groups.

1. On the File menu, click Diagnose & Repair and in the Model area, click
Diagnose model.

2. Check the results. 

If there are inconsistencies in the geometry, Tekla Structures displays a
warning message, and draws a thin line between the reinforcement
handles to show the invalid geometry.

You can correct the reinforcement geometry by selecting the line and
modifying the reinforcement properties.

See also

Modify a single reinforcing bar, bar group, or mesh (page 544)

Modify a rebar set (page 521)

Split and splice a reinforcement
You can split long reinforcing bars and bar groups that exceed the stock
length, and create splices in split locations.

Use the Automatic splicing tool macro to split and splice reinforcement that
exceeds the stock length. You can first check the length of the reinforcing bars
in the model according to the manufacturer. You can then define the portion
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of the reinforcement to be split and spliced in the same cross section, and the
location, symmetry, type, and length of the splices.

NOTE Automatic splicing tool does not work with rebar sets (page 470). To
split bars in rebar sets, use splitters instead.

If the reinforcement that is going to be split belongs to a rebar assembly
(page 614), the newly split bars are also added to the rebar assembly.

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Click the arrow next to Applications to open the applications list.

3. Double-click Automatic splicing tool to start the macro.

4. In the Automatic Splicing Tool dialog box:

a. Select the manufacturer of the reinforcement. 

The maximum bar lengths and lap lengths are then listed by the
grade and size of the bar.

If needed, you can define the length information in the
AutomaticSplicingTool_Manufacturers.dat file. You can copy
the default file from ..\ProgramData\Trimble\Tekla
Structures\<version>\environments\common\system , edit it,
and save it to your project or firm folder.

b. For the bar grades and sizes that are not listed in the
AutomaticSplicingTool_Manufacturers.dat file, use the
Maximum length for unspecified stock box to define the maximum
reinforcing bar length after which the bars are split and spliced.

c. To check if the length of the reinforcing bars exceeds the maximum
length, use one of the buttons next to Perform check to: 

• To check all reinforcement in the model, click All.

• To check specific reinforcement, first select the reinforcement or
cast units in the model, and then click Selected.

Tekla Structures lists the reinforcing bars that are longer than the
maximum length under Longer rebars on the right side of the dialog
box.

When you select a row in the Longer rebars list, Tekla Structures
highlights the corresponding reinforcement in the model.

d. Define which proportion of the reinforcement can be spliced in the
same cross section.

e. Define the symmetry that is applied when the reinforcing bars are
spliced.

f. Define the offset of the splice center point.
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g. Define the minimum longitudinal distance between two parallel bar
splices.

h. Select the splice type. 

You can create lap splices, coupler splices, or welded splices.

i. For lap splices, define the default lap length as a distance or in
relation to the nominal bar diameter. 

This value will be used if there is no lap length defined for a bar grade
and size in the AutomaticSplicingTool_Manufacturers.dat file.

j. For lap slices, define whether the lapping bars are on top of each
other or parallel to each other.

k. To split and splice reinforcement, use one of the buttons next to
Perform split and splice to: 

• To splice all reinforcement in the model, click All.

• To splice specific reinforcement, first select the reinforcement in
the Longer rebars list, or in the model using the Select objects in

components switch , and then click Selected.

See also

Create a reinforcement splice (page 519)

Assign running numbers to reinforcement
You can assign running numbers to reinforcement in cast units. You can then
use the running numbers in addition to or instead of the position numbers in
reinforcement marks and tables in drawings, and in reports.

Use the Rebar sequence numbering macro to assign cast unit specific
running numbers (1, 2, 3...) to the reinforcement in the model. Running
numbers are unique inside each cast unit. The macro does the following:

• Updates the position numbers of the modified model objects using the
Number modified objects command in Drawings & reports --> Perform
numbering .

• Assigns running numbers to the reinforcing bars, reinforcing bar groups,
and reinforcement meshes in the model.

• Saves a running number as the user-defined attribute Rebar sequence
number (REBAR_SEQ_NO) of each bar, group, or mesh.

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Click the arrow next to Applications to open the applications list.
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3. Double-click Rebar sequence numbering to start the macro.

4. To show the running numbers in drawings and reports, use the user-
defined attribute REBAR_SEQ_NO.

See also

Number reinforcement (page 724)

Classify reinforcement to layers
To be able to show in drawings what is the order of different reinforcement
layers near a surface of a concrete part, you need to classify reinforcement in
the model. You can do this by using the Rebar classification macro.

Rebar classification classifies the reinforcing bars and reinforcement meshes
by their order of depth in concrete slabs and panels. The reinforcing bars and
meshes get an attribute indicating the layer where they are placed inside the
concrete part.

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Click the arrow next to Applications to open the applications list.

3. Double-click Rebar classification to start the macro.

4. In the Rebar classification dialog box:

a. Enter the prefixes that you want to use for the reinforcement layers
near the top, bottom, front, and back surfaces of the concrete parts.

b. Select whether you want to classify All objects or Selected objects. 

If you select Selected objects, select the reinforcement or the
concrete parts containing the reinforcement that you want to classify.

c. Click Preview to view the properties of the reinforcement in each
layer. 

The layers are named using the relevant surface prefix and numbered
starting from the surface.

d. If you do not want to classify a reinforcement, select it from the list
and click Delete item.

e. To save the classification attributes of the reinforcement, do one of
the following: 

• Click Modify to also keep the Rebar classification dialog box
open.

• Click OK to also close the Rebar classification dialog box.

5. In a drawing, run the Rebar layering marker macro to create layer-
specific markers for reinforcement.
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How Tekla Structures automatically attaches rebar set bars
to concrete parts
When you create or modify a rebar set, Tekla Structures automatically attaches
each bar in the rebar set to a concrete part. This concrete part is the parent
part of the rebar set bar.

Depending on the cast unit type, bottom level, and volume of the concrete
parts, and the bar length, location, and orientation, and the number of bars in
the rebar set, Tekla Structures searches for and chooses the parent part for
each of the bars as follows:

• Each bar that is at least partly inside only one concrete part is attached to
that part.

• Each bar that is inside both precast and cast-in-place concrete parts is
attached to a precast part.

(1) = precast part, (2) = cast-in-place part

In this and the following images, the parent part is shown in green.

Then, for each bar that is inside two or more concrete parts, either precast
parts or cast-in-place parts, but not both:

• A bar is considered horizontal if the angle between the horizontal plane
and the bar plane that contains the vertices of the bar is less than 45
degrees, or for a straight bar, if the angle of the bar direction to the
horizontal plane is less than 45 degrees. Otherwise the bar is vertical.

(1) = horizontal bars, (2) = vertical bars
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• If the bar is placed horizontally, it is attached to the part that contains the
longest bar length.

• If the bar is placed vertically and if the bar is fully inside one part and
partially inside other parts, it is attached to the part that contains the whole
bar.

• If the bar is placed vertically and partly inside several parts, it is attached to
the part whose bottom face has the lowest global z coordinate.

Sometimes several parts might match one of the above criteria and could be
the parent part of a rebar set bar. For example:

A horizontal bar is equally in two
parts.

Two parts contain some of a vertical
bar and their bottom levels are at
equal height.

Two parts contain all of a vertical bar
but are at different heights.

In cases like these, Tekla Structures chooses the parent part for each bar from
among the matching parts as follows:

• If one of the parts is the more common parent part in the rebar set than
the other parts, Tekla Structures attaches the bar to that more common
parent part.

For example:

Create parts, reinforcement, and construction
objects

569 Modify reinforcement



In this plan or elevation view, two
parts overlap and the dashed bars are
entirely in both parts.

The dashed bars are attached to the
green part because it contains more
bars of the rebar set than the red
part.

In this plan view, the dashed bars are
in two parts. The bar planes are
vertical and the parts are at equal
height.

The dashed bars are attached to the
green part because the most bars of
the rebar set are attached to it.

• If there is no more common parent part for a rebar set, Tekla Structures
attaches the bar to the part that has the smallest volume.

For example:

In this plan view, two parts overlap
and a rebar set with the dashed bars
is entirely in both parts.

The bars are attached to the green
part because it has the smaller
volume.

If the volumes of the parts are equal for several parts, Tekla Structures
chooses the part with the smallest ID.

If you need to override the automatic attachment of rebar set bars to concrete
parts, you can manually attach (page 562) rebar sets and bars in them.

How to calculate the reinforcing bar length
You have three options how to calculate the reinforcing bar length in Tekla
Structures:

• Along center line, which is the default method

• As a sum of leg lengths

• Using a formula
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Along center line

The center line length calculation is used by default when
XS_USE_USER_DEFINED_REBAR_LENGTH_AND_WEIGHT is set to FALSE in File
menu --> Settings --> Advanced options.

Center line length calculation uses the actual reinforcing bar diameter by
default.

In the example below, the center line length is calculated as follows: 450 -
(30 + 14) + 2*3.14*(30+14/2)*1/4 + 250 - (30 + 14) = 670.1
where

• 30 = bending radius

• 14 = actual diameter (12 is nominal)

Sum of leg lengths (SLL)

The sum of leg length calculation is based on the dimensions of the straight
legs and it does not take the bending radius into account.

This calculation is used when
XS_USE_USER_DEFINED_REBAR_LENGTH_AND_WEIGHT and
XS_USE_USER_DEFINED_REBARSHAPERULES are set to TRUE in File menu -->
Settings --> Advanced options.

In the example below, the reinforcing bar length is 450 + 250 = 700
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If the length value is shown as zero in reports and inquiries, you need to define
the length in Rebar Shape Manager for each shape.

To define the length in Rebar Shape Manager:

1. In Bending schedule fields, right-click in the L cell and select SLL (Sum of
leg lengths) from the pop-up menu.

2. Click Update.

3. Click Save.

Using a formula

You can also use a formula in Rebar Shape Manager to calculate the
reinforcing bar total length.

You need to set XS_USE_USER_DEFINED_REBAR_LENGTH_AND_WEIGHT and
XS_USE_USER_DEFINED_REBARSHAPERULES to TRUE File menu --> Settings --
> Advanced options.

For example, to take the bending radius into account and to calculate the
length along the reinforcing bar outer surface, do the following:

1. In Bending schedule fields, right-click in the L cell and select (formula)
from the pop-up menu.

2. Enter the following formula for the length calculation: S1 + S2 +
2*3.14*(RS + DIA)*1/4

where

• S1 = straight leg length 1 (406)

• S2 = straight leg length 2 (206)

• RS = rounding radius (30)

• DIA = actual diameter (14)
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Accuracy

The accuracy of reinforcing bar length is defined in the rebar_config.inp
file. The values can vary in each environment.

For example, the values shown below are from a rebar_config.inp file. In
the default environment the file is located in ..\ProgramData\Trimble
\Tekla Structures\<version>\Environments\default\system\
folder.

The following settings define the accuracy and rounding for the leg lengths:

• ScheduleDimensionRoundingAccuracy=1.0
• ScheduleDimensionRoundingDirection="DOWN"
The following settings define the accuracy and rounding for the total
reinforcing bar length:

• ScheduleTotalLengthRoundingAccuracy=10.0
• ScheduleTotalLengthRoundingDirection="DOWN"
Note that also XS_USE_ONLY_NOMINAL_REBAR_DIAMETER affects the
reinforcing bar length calculation.

See also

Rebar shape manager in reinforcement shape recognition (page 576)

How to calculate the reinforcing bar leg length
How the reinforcing bar leg length is calculated depends on the angle between
the bar legs.

• When the angle is <= 90°, the length is measured to the extension of a leg
along the outer edge
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• When the angle is > 90 ° and <= 180 °, the tangential length is used

The leg lengths are calculated using Rebar Shape Manager, where
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• S1 = straight portion of a bar for the first segment

• S2 = straight portion of a bar for the second segment

• A1 = bending angle measured between the extension of the first leg and
the second leg. The angle is 0° if the second segment continues to the
same direction as the first segment (the bar is straight)

• L1 = leg length for the first reinforcing bar segment

• L2 = leg length for the second reinforcing bar segment

• RS = bending radius

• DIA = actual diameter of the reinforcing bar

See also

Rebar shape manager in reinforcement shape recognition (page 576)

Reinforcing bar and bar group properties (page 1009)

Reinforcement shape recognition
Tekla Structures recognizes different reinforcing bar bending shapes and
assigns shape codes to them. Tekla Structures then uses the shape and
dimension information in bending schedules, pull-out pictures, templates and
reports.

Tekla Structures includes two methods for shape recognition.

User-defined bending shape
definitions.

These definitions are created with
Rebar shape manager (page 576)
and saved in the
RebarShapeRules.xml file.

The file is located in the environment
folder under ..\ProgramData
\Trimble\Tekla Structures
\<version>\Environments\. The
exact file location may vary
depending on the folder structure of
your environment files.

Tekla Structures internal, hard-coded
bending type definitions.

Only used if the advanced option
XS_USE_USER_DEFINED_REBARSHAPE
RULES is set to FALSE.

These internal bending types
(page 588) of reinforcing bars are
mapped to area-specific reinforcing
bar bending type codes in the
rebar_schedule_config.inp file.

The file is located
in ..\ProgramData\Trimble
\Tekla Structures\<version>
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\environments\common\system
folder.

See also

Reinforcement in templates (page 612)

Rebar shape manager in reinforcement shape recognition
You can define your own bar bending shapes and assign shape codes with
Rebar shape manager, and thus increase the amount of recognized bar
shapes. User-defined bending shapes are useful when Tekla Structures does
not recognize the bending shape and assigns the UNKNOWN bending type to the
shape.

Rebar shape manager is meant for users who need to customize the bending
shapes according to company or project requirements.

With Rebar shape manager you can:

• Customize the existing bending shapes and create new bending shapes
(page 576).

• Establish your own rules (page 580) for defining the bending shapes.

• Compare selected bars (page 585) in the model to the existing bending
shapes.

• Customize your own dimension mappings that are used in templates and
reports (page 586).

• Import and export user-defined bending shapes.

• Use user-defined bending shapes in bending schedules and pull-out
pictures.

NOTE Rebar shape manager is a tool for recognizing reinforcing bar shapes. You
cannot control the reinforcing bar creation properties, such as cover
thickness, reinforcing bar grade, or size, with this tool.

See also

Tips for reinforcement shape recognition in Rebar shape manager (page 587)

Define reinforcing bar bending shapes in Rebar shape manager
With Rebar shape manager you can establish your own rules for defining the
bending shapes. When you define your own reinforcing bar bending shapes
and shape codes, an .xml file called RebarShapeRules.xml is created in the
current model folder.

In addition, Tekla Structures installation contains by default another .xml file
called RebarShapeRules.xml. This file contains the most typical bending
shapes in your environment, and it is located in the environment folder
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under ..\ProgramData\Trimble\Tekla Structures\<version>
\Environments\. The exact file location may vary depending on the folder
structure of your environment files.

When you define new shapes, the shapes in the default
RebarShapeRules.xml rule file can be appended to your own shapes. Tekla
Structures reads valid RebarShapeRules.xml rule files in the model, project,
firm, and system folders in that order. When the shape codes and report field
values are applied, Tekla Structures uses the first matching shape in a
RebarShapeRules.xml file which is found first based on the search order. If a
shape is unknown according to the definitions in the first
RebarShapeRules.xml file, only then the next rule file (or files) will be used.
All the found bending shapes are displayed in Rebar shape manager.

1. Select reinforcing bars in the model.

2. On the File menu, click Editors --> Rebar shape manager. 

Rebar shape manager opens and lists the selected reinforcing bars in the
Model rebars list.

Alternatively, you can first open Rebar shape manager and then select
reinforcing bars in the model. Click Get selected to add the reinforcing
bars to the Model rebars list.

• The Model rebars list shows the ID and the shape code of the selected
reinforcing bars.

• The Shape catalog list shows the shapes that exist in the default
RebarShapeRules.xml rule file.

• The Tolerances tab shows the tolerances used when the bending
shape rules are compared.

3. Select one unknown shape from the Model rebars list. 

Tekla Structures shows a preview of the shape. The blue numbers in the
preview are related to the straight bar legs in the shape, and the green
numbers to the arc legs.

Under the preview, Tekla Structures shows a description of the recognized
bar geometry, and the number of bendings and arcs. If you move the
mouse pointer over the text, a tooltip shows which tolerance values and
other properties are in use for the selected bar. If the bar geometry has
been simplified in the recognition process, (Simplified) is shown next to
the description text, and the tooltip shows the simplification result.

4. If needed, you can compare selected bars (page 585) in the model to the
existing bending shapes in the rule files.

5. To define the needed information for a bending shape, do the following: 

To define Do this
Tolerances Enter tolerance values for the following measurements:

• Dimension (leg lengths and other distances)
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To define Do this
• Angle (bending and twist angles)

• Radius (bending radiuses)

Note that the tolerance values are stored along with the rule
file RebarShapeRules.xml, and thus the tolerances are
specific to each rule file.

The following tolerances are also used in rebar shape
recognition, and they can be adjusted using the 
XS_REBAR_RECOGNITION_... advanced options, the rebar
catalog (rebar_database.inp), and the Shape recognition
user-defined attributes of individual reinforcement objects:

• Extra point shortening

• Curve tolerance

• Max curve radius requiring bending

Additionally, you can use the Recognize as straight bar user-
defined attribute to have Tekla Structures recognize individual
reinforcement objects as straight bars even though they are
bent in the model.

Shape code Enter a shape code for an unknown shape.

Note that multiple reinforcement shapes that are variants of
the same shape can have the same Shape code but different
Bending shape rules.

Bending
shape rules

If the bending shape rules that Rebar shape manager
defines automatically are not sufficient to distinguish certain
bending shapes, you can manually add (page 580) new
bending shape rules.

Add or delete a bending shape rule by clicking the Add and
Delete buttons on the right.

Use the Reset button to restore the original values.
Check hooks Select the check box if you want to define different shape

codes or bending schedule fields for two bars that otherwise
have exactly the same geometry, but one bar has hooks and
the other one does not.

If you select the check box, hooks are considered as hooks. If
you clear the check box, hooks are considered as normal legs.

Note that the Check hooks option works independently from
the advanced option , and it allows bars that have different
hooks to have different shape code or schedule fields
regardless of the value of the advanced option.
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To define Do this
Update Update the existing shape code definition of the selected

reinforcing bar.

You can update the definition if you have modified the shape
code, bending shape rules or the contents of bending
schedule fields.

Bending
schedule
fields

Define the content (page 586) for a bending schedule. Right-
click a field to select a bending shape property or to enter a
formula.

The names of the Bending schedule fields (A, B, and so on)
are used in templates and reports. To make sure that old
reports also work correctly, we recommend that you use the
same DIM_XX fields as in the rebar_schedule_config.inp
file.

Schedule
fields...

Click the Schedule fields button to add, remove or change
the order of the available schedule fields. If needed, you can
reset the schedule fields to original defaults.

If you change the set of available schedule fields and update
an existing shape, the old schedule fields which do not exist
anymore will be cleared. Therefore we recommend that you
do not to remove any of the default schedule fields unless
you are sure they have not been used in any of the existing
shapes.

You can change the names of the existing schedule fields or, if
you add new fields, give names to them. To use the fields in
templates and reports, use the DIM_XX or ANG_xx fields, and
replace xx with the schedule field name.

6. When you have finished defining the new shape, click Add to add the
bending shape definition to the RebarShapeRules.xml file. 

To enable the Add button you need to change the bending shape rule,
enter a shape code or select the Check hooks check box.

7. Click Save to save the RebarShapeRules.xml file. 

By default, the file is located in the current model folder.

When you create, for example, a bending schedule, Tekla Structures uses
the updated bending shape information, recognizes the added bending
shape and assigns a correct shape code to it.

NOTE Rebar shape manager is able to recognize bending shapes
regardless of the modeling direction of the bars. This means that
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the modeling direction has no effect on the shape definition and
the shape code.

When defining the bending shapes, the start or the end of
modeling direction is always sorted based first on bending angles,
then on twist angles, and finally on leg lengths. However, bending
radius is not taken into account in the sorting. This means that
radius 1 may not always be less than radius 2 or vice versa.

After the sorting, the bars that are not recognized with their
original input point order are automatically examined also in the
reversed input point order. This eliminates the need to create
duplicate definitions for certain bar shapes.

See also

Rebar shape manager in reinforcement shape recognition (page 576)

Add new bending shape rules manually in Rebar shape manager
In some cases, the bending shape rules that are defined in Rebar shape
manager are not sufficient to distinguish certain bending shapes. If needed,
you can manually add new bending shape rules for reinforcing bars in Rebar
shape manager.

1. In Rebar shape manager, click Add next to the Bending shape rules list.

2. In the New bending rule dialog box, select the options from the lists to
define the new rule. 

The content of the lists depends on the shape and the bending of the
reinforcing bar.

3. Click OK to add the new rule to the Bending shape rules list. 

The OK button is enabled only when the rule is valid.

Bending shape rule settings

All the rule options are available in the New bending rule dialog box, even
though only certain selections are valid, depending on the type of the
conditions used. The left and right condition of a rule need to be of the same
type. The values in the parentheses are the values that were used to create the
bar shape.

Use the New bending rule dialog box in Rebar shape manager to manually
define rules for reinforcing bar bending shapes.

Option Description
Angle (A) Bending angle between the legs.

Bending angle is always between 0 and +180 degrees. The
angle cannot be negative.
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Option Description
Twist angle (T) Rotation angle of a plane that has been created by two

bars of consecutive lengths. The plane is rotated around
the axis of the last bar creating the plane.

For bars where all the legs lie in the same plane, the twist
angle is either 0 degrees or +180 degrees.

If the bar twists out of the plane, i.e. the bar is in 3D, the
twist angle is between -180 and +180 degrees.

1. Leg 1

2. Leg 2

3. Leg 3

4. Twist angle direction

5. Plane created by legs 1 and 2
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Option Description
Twist angle
example

The twist angle between two planes is +90 degrees. The
planes are created by legs 1 and 2, and legs 2 and 3.

1. Twist angle: +90 degrees
Radius (R, RX) Bending radius of the bending.

(RX) Radius * is the value of the bending radius when
all the bendings have equal radius. Otherwise the value is
zero (0). Radius * = Radius 1 ensures that all the
bendings have been created using the same radius.

Bending length
(BL)

Center line length of the bending.

Straight length
(S)

Straight length between the start and the end of adjacent
bendings.

The rule is generated only when there is no straight part,
for example, Straight length 2 = 0.

Leg length (L) Length of the leg.
Leg (V) Leg direction as a vector value.
Bar diameter
(DIA, DIAX)

Diameter of the reinforcing bar.

Nominal
diameter (NDIA,
NDIAX)

Nominal diameter of the reinforcing bar.

Center line
length (CLL)

Leg length according to the center line.

Sum of leg
lengths (SLL)

Sum of all leg lengths.

Reversed Reversed reinforcing bar.

You can use Reversed to have additional bending shape
rules and/or formulas for the schedule fields.
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Option Description
When used in a rule, you can have separate definitions in
shape code and/or schedule fields for reinforcing bars
that have different modeling order of the points.

When used as a part of a formula, you can eliminate the
automatic normalization of the modeling order of the
points. For example, a formula if (REVERSED) then
L2 else L3 endif forces the content of the field to
show the desired leg length depending on the order of
the points or legs.

Arc inner radius
(RI)

Inner radius of the arc.

Arc outer radius
(RO)

Outer radius of the arc.

Arc angle (AA) Angle of the arc.
Arc length (AL) Length of the arc.
Arc twist angle
(AT)

Rotation angle of the arc.

Arc width (AW) Width of the arc.
Arc height (AH) Height of the arc.
Curve width
(CW)

Extreme width of the curved bar.

Curved height
(CH)

Extreme height of the curved bar.

RFACTOR Relative radius.
LFACTOR Relative length.
Spiral rounds
(SR)

Rounds of the spiral bar.

Spiral pitch (SP) Pitch of the spiral bar.
Spiral length (SL) Distance between the reference points of the spiral bar.
Spiral total
length (STL)

Total length of the spiral bar when the bar is installed on
site.

Standard radius
(RS)

Standard minimum bending radius.

The bending radius depends on the size and the grade of
the bar.

Weight per
length (WPL)

Weight per leg length.

Leg distance
from leg (D)

Similar to Point/arc distance off from leg (H). The
difference is that Point/arc distance off from leg (H)
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Option Description
considers the bending radius, whereas Leg distance
from leg (D) is measured from the sharp corner.

When the legs are parallel, both Leg distance from leg
(D) and Point/arc distance off from leg (H) give the
same result.

Point/arc
distance along
leg (K)

Distance parallel to a leg from outer edge to outer edge,
or tangential to the bending.

The distances are positive or negative depending on the
leg direction.

Example:

Point/arc
distance off
from leg (H)

Distance perpendicular to a leg from outer edge to outer
edge, or tangential to the bending.

The distances are positive or negative depending on the
leg direction.

Example:
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Option Description
Start hook (SH)

End hook (EH)

Hook angle (SHA,
EHA)

Hook radius
(SHR, EHR)

Hook straight
length (SHS, EHS)

Hook length,
method A (SHLA,
EHLA)

Hook length,
method B (SHLB,
EHLB)

Start and end hook properties.

Use method A or B for the hook length calculation:

Constant angle Constant value of the angle.

Enter the value in the rightmost box.
Constant radius Constant value of the radius.

Enter the value in the rightmost box.
MAXCURVE Maximum radius of an arc that requires bending.

When an arc's bending radius exceeds MAXCURVE, the
arc is treated as a straight leg.

Custom
properties,
template
attributes, user-
defined attributes

The custom properties, template attributes, and user-
defined attributes defined in the
RebarShapeManager.CustomProperties.dat file
appear at the end of the list and can be used like any
other option.

See also

Define content for templates and reports in Rebar shape manager (page 586)

Rebar shape manager in reinforcement shape recognition (page 576)
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Compare reinforcing bars to bending shapes in Rebar shape manager
In Rebar shape manager, you can compare selected reinforcing bars in the
model to the existing bending shapes in the RebarShapeRules.xml files.

Comparing is useful, for example, when you want to check if a bar with a
special shape complies with any of the bending shapes or shape rules, or
when you want to check why a bar is not recognized as you would expect. You
can then modify either the bar shape in the model or the bending shape rules
as needed.

1. Select reinforcing bars in the model.

2. On the File menu, click Editors --> Rebar shape manager. 

Rebar shape manager opens and lists the selected reinforcing bars in the
Model rebars list.

Alternatively, you can first open Rebar shape manager and then select
reinforcing bars in the model. Click Get selected to add the reinforcing
bars to the Model rebars list.

3. In the Model rebars list, select the bar shape that you want to compare.

4. In the Shape catalog list, select an existing bending shape.

5. Under the Shape catalog list, click Compare to selected.

In the Bending shape rules list, you can see the passed rules in green and the
failed rules in red. An additional warning dialog box is shown if there are other
reasons for mismatches between the shapes.

See also

Rebar shape manager in reinforcement shape recognition (page 576)

Define reinforcing bar bending shapes in Rebar shape manager (page 576)

Add new bending shape rules manually in Rebar shape manager (page 580)

Define content for templates and reports in Rebar shape manager
Use the Bending schedule fields in Rebar shape manager to define the
content for templates and reports. Each of the Bending schedule fields cells
can contain a shape property or a formula.

When you right-click in a Bending schedule fields cell, you can:

• Select a shape property from the list. The content of the list depends on the
reinforcing bar geometry.

• Select the (empty) option to clear the content of the current cell.

• Select the (formula) option to enter a formula. The variables in the formula
can either be the shape properties visible in the pop-up menu, or direct
references to other non-empty bending schedule field cells.

You can use the following functions in the formulas, in the same way as in
custom components:
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• Mathematical functions

• Statistical functions

• Trigonometric functions

When you map angles and trigonometric functions in the Schedule
field formula dialog box, enter the functions (sin, cos, tan) in small
letters, for example sin(A1). Capital letters are not recognized, and a
blank space will appear in reports.

If you have angles in a formula, the formula needs to be in radians. For
example, if you want to subtract 180 degrees from angle A1, enter A1-PI in
capital letters. If you enter A1-180 or A1-pi, the formula does not work.

Bending schedule fields cell shows the result of a valid formula. If the
formula is not valid, a question mark and text describing the error is shown.

NOTE Use the fields S, T, U or V to report angles. If you do not use these
fields, you need to override the default unit settings in the Template
Editor.

Example

Formula is L1+L3+L5-2*DIA
• L1, L3 and L5 are the leg lengths measured from outer edge to outer edge

• H1 is the total width

• to achieve H1: L1+L3+L5 minus 2*bar diameter

See also

Add new bending shape rules manually in Rebar shape manager (page 580)

Rebar shape manager in reinforcement shape recognition (page 576)

Tips for reinforcement shape recognition in Rebar shape manager

The reinforcing bar shape recognition is based on each shape’s bending shape
rules. The shapes and their rules are listed in the RebarShapeRules.xml file,
located in the environment folder under ..\ProgramData\Trimble\Tekla
Structures\<version>\Environments\ by default. (The exact file location
may vary depending on the folder structure of your environment files.)
Sometimes a shape matches the rules of two shapes, and Tekla Structures
does not recognize the reinforcing bar shape as expected.

NOTE The most convenient way to ensure that a shape is recognized
correctly is to modify the shape definition by adding more rules
(page 580) to the shape in Rebar shape manager.

However, if necessary, you can manually modify the RebarShapeRules.xml
file and thus affect the shape recognition. When Tekla Structures recognizes
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the shape, the order of the shapes in the RebarShapeRules.xml is
important:

• The first shape that matches the rules is the one that Tekla Structures
recognizes as the shape. If you need to change the order of the shapes to
change how Tekla Structures recognizes the shape, you can do it by
manually modifying the RebarShapeRules.xml file. If you modify the file
and change the order of the shapes, make sure that the structure of the file
stays valid.

• You can divide the shape definitions in several RebarShapeRules.xml
files and different folders. Tekla Structures searches the
RebarShapeRules.xml file in the model, project, firm, and system folders
in that order. Tekla Structures uses the first matching shape in the first
RebarShapeRules.xml file which is found based on the search order.

See also

Rebar shape manager in reinforcement shape recognition (page 576)

Hard-coded bending type identifiers in reinforcement shape
recognition
Tekla Structures recognizes different reinforcing bar bending shapes and
assigns bending type identifiers to them.

NOTE This bending shape recognition method and the following bending types are
only used if the advanced option XS_USE_USER_DEFINED_REBARSHAPERULES
is set to FALSE.

We recommend having XS_USE_USER_DEFINED_REBARSHAPERULES set to 
TRUE, which is the default value, and using Rebar shape manager (page 576)
instead in bending shape recognition.

The bending type identifiers in the table below are internal, hard-coded types
of Tekla Structures. The leg dimensions (D1, D2, and so on) and bending angles
(A1, A2, and so on) of reinforcing bars are Tekla Structures internal dimensions
and angles. You can map the Tekla Structures internal bending types, for
example, to country- or project-specific bending types, and the Tekla
Structures internal dimensions and angles to specific template attributes. You
can do this in the rebar_schedule_config.inp file.

Reinforcing bar bending dimensions are calculated so that the leg dimensions
(D1, D2, and so on) follow the outer edge, or the edge extension, of the
reinforcing bar. The total length is calculated according to the center line of the
reinforcing bar.

If Tekla Structures does not recognize the shape of a reinforcing bar, it assigns
the UNKNOWN bending type to it.

The magenta points in the images in the table below represent the points you
pick in the model when you create reinforcing bars.
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NOTE If you want to customize the hard-coded bending shapes or define
new bending shapes, use Rebar shape manager (page 576).

Bending
type

identifier

Bending shape

1

2_1

Requires standard bending radius.
2_2

Non-standard bending radius.
3_1

3_2

4

4_2
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Bending
type

identifier

Bending shape

4_3

4_4

5_1

5_2

5_3

6_1

6_2
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Bending
type

identifier

Bending shape

7

8

9

Requires 180 degree hook.
10

11

D1 = Radius from center of circle to the center line of reinforcing
bar.

12
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Bending
type

identifier

Bending shape

13

Can also be modeled using hooks at both ends (i.e. model D1 and
D5 using 90 degree hooks).

14

Requires 90 degree hooks at both ends.
14_2

14_3
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Bending
type

identifier

Bending shape

14_4

Requires 90 degree hooks at both ends.
14_5

Recognized when the start point and end point are in the same
location and no hooks are used.

If XS_REBAR_RECOGNITION_HOOKS_CONSIDERATION is set to 
FALSE, reinforcing bars with hooks (types 14 and 48) are
recognized as 14_5.

15

Requires hooks at both ends.
16_1
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Bending
type

identifier

Bending shape

16_2

17

18

19

20_1

20_2
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Bending
type

identifier

Bending shape

21

22

23

24

25

26

Requires 180 degree hooks at both ends.
27

Requires 90 degree hooks at both ends.
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Bending
type

identifier

Bending shape

28

Requires 180 degree hooks at both ends.
29

Requires 90 degree hooks at both ends.
29_2

29_3

29_4
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Bending
type

identifier

Bending shape

29_5

30

Requires 180 degree hooks at both ends.
31

Requires 90 degree hooks at both ends.
32

Requires 180 degree hooks at both ends.
32_2
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Bending
type

identifier

Bending shape

33

Requires 90 degree hooks at both ends.
34

35

Requires 180 degree hook.
36

Requires 180 degree hook.
36_2

Can also be modeled using hooks at both ends.
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Bending
type

identifier

Bending shape

36_3

Can also be modeled using hooks at both ends.
37

Requires 180 degree hook.
38

Requires 180 degree hook at one end and 90 degree hook at the
other end.

38_2

39

40

Requires 180 degree hooks at both ends.
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Bending
type

identifier

Bending shape

41

Requires 90 degree hooks at both ends.
42

Requires 180 degree hooks at both ends.
43

43_2

44

Requires hooks at both ends.
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Bending
type

identifier

Bending shape

44_2

Requires 180 degree hooks at both ends.
45

Requires hooks at both ends.
45_2

Requires 180 hooks at both ends.
46

Requires hooks at both ends.
47

Requires 90 degree hooks at both ends.
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Bending
type

identifier

Bending shape

48

Requires hooks at both ends.
48_2

Requires hooks at both ends.
48_3

49

D1 = Reinforcing bar center line diameter.
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Bending
type

identifier

Bending shape

49_2

50

Requires hooks at both ends.
51

Requires 90 degree hooks at both ends.
52

Requires hooks at both ends.
53

Requires hooks at both ends.
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Bending
type

identifier

Bending shape

54

Requires hooks at both ends.
55

56

57

58

59
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Bending
type

identifier

Bending shape

60

61

Requires hooks at both ends.
61_2

Recognized if XS_REBAR_RECOGNITION_HOOKS_CONSIDERATION
is set to FALSE.

61_3

Requires hooks at both ends.
62

Requires hook.
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Bending
type

identifier

Bending shape

63

Requires hook.
64

Requires hooks at both ends.
64_2

Recognized if XS_REBAR_RECOGNITION_HOOKS_CONSIDERATION
is set to FALSE.

65

Requires hooks at both ends.
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Bending
type

identifier

Bending shape

65_2

Recognized if XS_REBAR_RECOGNITION_HOOKS_CONSIDERATION
is set to FALSE.

66

67

67_2
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Bending
type

identifier

Bending shape

68

69_1

69_2

70_1

70_2
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Bending
type

identifier

Bending shape

71

72

73_1

73_2

73_3
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Bending
type

identifier

Bending shape

74

75_1

75_2

76

77
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Bending
type

identifier

Bending shape

78

79_1

79_2

80

UNKNOWN For example:
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See also

Reinforcement in templates (page 612)

Reinforcement shape recognition (page 575)

Reinforcement in templates
Sometimes you need to localize reinforcing bar bending types or to create
templates for reinforcing bar bending schedules.

NOTE If you want to customize the hard-coded bending shapes or define new
bending shapes, use Rebar shape manager. See Define reinforcing bar
bending shapes in Rebar shape manager (page 576).

Reinforcement templates

You can show dimensions, bending angles, and bending types of reinforcing
bars in drawings and reports by including reinforcement-specific attributes,
such as DIM_A, ANG_S, SHAPE, and SHAPE_INTERNAL, in template fields. For
more information on creating templates, see Template Editor User's Guide.

Mapping dimensions

Use the rebar_schedule_config.inp file in the ..\ProgramData
\Trimble\Tekla Structures\<version>\environments
\<environment>\system folder to map

• Tekla Structures internal reinforcing bar dimensions and angles with
specific template attributes

• Tekla Structures internal reinforcing bar bending types with specific
bending types

These mappings are environment-specific by default. You can modify them to
suit your company or project needs.

You can use equations, functions, and if statements to calculate the
dimensions and angles you need to show.

Use any standard text editor (for example, Microsoft Notepad) to edit the
rebar_schedule_config.inp file.

Examples

The following example of the rebar_schedule_config.inp file maps the
internal bending type 5_1 to the bending type identifier E, and the leg
dimensions and bending angles to specific template attributes.
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rebar_schedule_config.inp

With this mapping, the internal bending type 6_2 becomes XY, and the
template attributes DIM_B and DIM_C will show the horizontal and vertical
dimensions of the second leg D2, and DIM_E and DIM_F the horizontal and
vertical dimensions of the fourth leg D4.

rebar_schedule_config.inp

The following example maps the internal bending type 4 to the bending type
identifier A if the dimensions D1 and D3 are the same. Otherwise it maps 4 to 
B.

rebar_schedule_config.inp

If Tekla Structures does not recognize a reinforcing bar bending shape, it uses
the internal bending type UNKNOWN for it. In the
rebar_schedule_config.inp file you can also define how unknown
bending types appear in drawings and reports. For example, you may just
want to use the bending type identifier ???, and list all leg dimensions and
bending angles.

Create parts, reinforcement, and construction
objects

613 Modify reinforcement



rebar_schedule_config.inp

See also

Hard-coded bending type identifiers in reinforcement shape recognition
(page 588)

Reinforcement shape recognition (page 575)

2.11 Work with rebar assemblies
A rebar assembly is a prefabricated reinforcement entity or cage that usually
consists of several reinforcement objects, such as single reinforcing bars,
different bar groups and rebar sets, reinforcement meshes, and possibly
strands. Rebar assemblies can also contain assemblies and parts as sub-
assemblies.
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The structure of a rebar assembly can be flat where all objects are on one
assembly hierarchy level, or there can be sub-assemblies on several assembly
levels in the assembly structure.

Note that the assembly hierarchy affects the drawing and report outputs.
Report and drawing templates need to be made with similar hierarchy as the
assembly hierarchy in the model in order to output the data from correct
assembly levels. We recommend you to test the different outputs early on in
the modeling phase to ensure that all the relevant assembly information is
included in the needed deliverables, such as production drawings.

When you work with rebar assemblies, use the same selection switches and
the same methods to move in the assembly hierarchy as with other nested
assemblies (page 421).

Create a rebar assembly
You can create basic, one-level rebar assemblies or nested, hierarchical rebar
assemblies. Start by creating basic rebar assemblies. If needed, you can later
add more objects or sub-assemblies, or form hierarchies by adding these basic
rebar assemblies as sub-assemblies to higher-level rebar assemblies.

A reinforcement object can only have one relation, either to a concrete part or
to a rebar assembly. When you add a reinforcement object to a rebar
assembly, it will be detached from the part. If a reinforcement object already
belongs to a rebar assembly, it cannot be attached to a part.

Note that individual rebar set bars or rebar set bar groups cannot be added to
rebar assemblies, only entire rebar sets can be added.
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Create a basic rebar assembly
You can create a basic rebar assembly with various reinforcement objects on
the same assembly hierarchy level.

The reinforcement object with the highest weight will become the main object
of the rebar assembly.

1. Create the reinforcement objects that you want to include in the rebar
assembly.

2. On the Rebar tab, click Assembly --> Create rebar assembly.

3. Select the objects that you want to include in the rebar assembly. 

You can select reinforcing bars, bar groups, rebar sets, reinforcement
meshes, and strands.

4. Click the middle mouse button to finish selecting objects and to create the
rebar assembly.

TIP Alternatively, you can first select the objects, then start the command, and finally
click the middle mouse button. This may help in controlling that you have a
correct set of objects selected for the rebar assembly.

Note that if you select components and want to include the component
objects in the rebar assembly, the components need to be exploded first. Tekla
Structures warns you about this and explodes the components when you click
Yes in the warning dialog box.

Note that if you select parts and assemblies, they are added as sub-
assemblies, and the rebar assembly becomes a nested assembly (page 618).

To modify the rebar assembly structure, for example, by adding or removing
objects and hierarchy levels, see Modify a rebar assembly (page 617) and
Remove objects from a rebar assembly (page 620).

Rebar assembly properties
Use the Rebar assembly property pane to view and modify the properties of
rebar assemblies. The file name extension of a rebar assembly property file
is .ras.

Property Description
Assembly numbering Numbering prefix and start number (=

numbering series) of the rebar assembly.
Name User-definable name of the rebar assembly.

By default, the name of the rebar assembly
main object is shown in brackets [ ].
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Property Description
Rebar assembly type Select the type for the rebar assembly.

The options are (empty), Cage, Mesh, Bent
mesh, Braced girder, Embed, and Roll mat.

IFC entity For IFC export, select the IFC entity type and
subtype of the rebar assembly. The available
subtypes depend on the selected IFC entity.

You can select the IFC4 subtype among the
predefined options, or you can select
USERDEFINED and then enter any text in User-
defined type (IFC4).

Subtype (IFC4)
User-defined type (IFC4)

UDAs User-defined attributes provide additional
information about the rebar assembly, for
example, workflow information. User-defined
attributes can consist of numbers, text, lists, or
dates.

You can use the values of user-defined
attributes in reports and drawings.

You can also change the name of the fields, and
add new ones, by editing the objects.inp file.

Modify a rebar assembly
You can modify the rebar assembly structure by adding more objects, or by
changing the main object of a rebar assembly, for example.

NOTE The active selection switch controls whether you can select reinforcement
objects or assemblies when you use the different rebar assembly commands.

Add objects to an existing rebar assembly
You can add more objects to a basic rebar assembly, or to any level of a nested
rebar assembly.

Note that you can only add parts to rebar assemblies as sub-assemblies. See
the 'Create a nested rebar assembly' instructions below.

1. Ensure that the  Select objects in assemblies or  Select objects
in components selection switch is active. 

2. Select the objects that you want to add.

3. Right-click and select Assembly --> Add to assembly.

4. Select the rebar assembly to which you want to add the objects.
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Create a nested rebar assembly
You can add parts, assemblies, and rebar assemblies as sub-assemblies in a
rebar assembly on a lower level in the assembly hierarchy.

1. Ensure that the  Select assemblies selection switch is active.

2. Select the parts and assemblies that you want to add to the rebar
assembly. 

They will become sub-assemblies in the nested rebar assembly.

3. Right-click and select Assembly --> Add as sub-assembly.

4. Select the rebar assembly to which you want to add the parts and
assemblies.

Alternatively, you can use the Rebar --> Assembly --> Add as sub-assembly
command on the ribbon.

Check and highlight objects in a rebar assembly
Use the Inquire tool to check which objects belong to a particular rebar
assembly.

1. On the ribbon, click the down arrow next to , and then select
Assembly objects to inquire the rebar assembly objects.

2. Select a rebar assembly. Ensure that you are on the intended assembly
hierarchy level. 

Tekla Structures highlights all the objects that belong to the same rebar
assembly. The main reinforcement object is highlighted in orange and the
other rebar assembly objects in yellow.

Change the main object of a rebar assembly
By default, the main object in a rebar assembly is the reinforcement object
with the highest weight. You can change the main object in a rebar assembly.

1. If needed, check what is currently the main object of the rebar assembly. 

Use the Inquire tool to check which objects belong to a particular rebar
assembly.

2. Ensure that the  Select objects in assemblies or  Select objects
in components selection switch is active.

3. Select the new main object.
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4. Right-click and select Assembly --> Set as new main object of assembly.

Tekla Structures changes the main object.

Alternatively, you can use the Rebar --> Assembly --> Set as main object
command on the ribbon.

Note that if you remove the main object from a rebar assembly, the remaining
reinforcement object with the highest weight is automatically set as the new
main object.

Change the coordinate system of a rebar assembly
By default, the main reinforcement object of a rebar assembly sets the local
coordinate system of the rebar assembly. The coordinate system then defines
the orientation, length, width, and height of the rebar assembly for drawings
and reports. If a rebar assembly is not shown the way you want in drawings
and reports, even though you changed the main object, you can adjust the
coordinate system of the rebar assembly.

1. Ensure that the  Direct modification switch is active.

2. Select a rebar assembly.

3. On the contextual toolbar, click  Define or remove coordinate
system. 

Tekla Structures shows a blue direct modification handle at the origin, and
the red, green, and blue axis handles and rotation handles that you can
use to adjust the coordinate system of the rebar assembly.

4. To move the coordinate system to a new location, drag the  handle that
is located at the origin.

5. To move the coordinate system along any of the coordinate axes, drag the
relevant axis handle to a new location.
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6. To rotate the coordinate system around any of the coordinate axes, drag
the relevant rotation handle to a new location. 

Press Tab to rotate the coordinate system in 90-degree steps in the
direction of the selected rotation handle.

7. To move or rotate the coordinate system by specifying a distance or angle:

a. Select an axis handle or a rotation handle.

b. Type the value by which you want the handle to move. 

When you start typing, Tekla Structures displays the Enter a Numeric
Location dialog box.

c. Click OK or press Enter to confirm the value.

8. To revert to the original coordinate system, click  again on the
contextual toolbar.

Remove objects from a rebar assembly
If you want to disassemble a rebar assembly, you can remove objects from it,
or ungroup the objects belonging to the rebar assembly.

Remove an object from a rebar assembly
You can remove reinforcement objects or sub-assemblies from a rebar
assembly one by one.

1. Select the object that you want to remove.

2. Right-click and select Assembly --> Remove from assembly.

Alternatively, you can use the Rebar --> Assembly --> Remove from assembly
command on the ribbon.

To remove another object, restart the command.

Explode a rebar assembly or a sub-assembly
You can explode a rebar assembly back to single reinforcement objects, or just
ungroup the objects belonging to a sub-assembly.

When you explode a nested rebar assembly, always start from the highest
assembly hierarchy level. Tekla Structures breaks the assembly hierarchy level
by level and ungroups the objects that belong to the highest level of the rebar
assembly.

You can also explode sub-assemblies to single reinforcement objects without
breaking the entire assembly hierarchy. The ungrouped sub-assembly objects
remain within the higher-level, parent rebar assembly.

1. Ensure that the  Select assemblies selection switch is active.
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2. Select the rebar assembly or sub-assembly that you want to explode. 

Ensure that you are on the intended assembly hierarchy level.

3. Do one of the following: 

• To explode a basic rebar assembly, or the highest level of a nested
rebar assembly, right-click and select Assembly --> Explode.

Use the Explode command several times to break a hierarchical
nested rebar assembly back to single reinforcement objects.

• To explode a sub-assembly, right-click and select Assembly -->
Explode Sub-Assembly.

Alternatively, you use the Explode assembly and Explode sub-assembly
commands on the ribbon, under Rebar --> Assembly.

2.12 Create construction objects and points
Points and construction objects help you to place other objects in the model.

When you want to place objects to a position where no lines or objects
intersect in the model, you can create construction lines (page 622), planes
(page 622), circles (page 623), arcs (page 624), and polycurves (page 626).
For example, you can easily pick (page 83) the points at intersections of
construction lines and circles. The snap priority of construction objects is the
same as with the other lines.

Use the display settings (page 647) to control if points and construction
objects are visible in model views. Points and construction objects remain in
the model when you update or redraw views and windows. They do not
appear in drawings.

Use the following selection switches to control if you can select points and
construction objects in the model:

, , 

You can also create magnetic construction lines or planes to bind and move
groups of objects (page 859). For example, rather than binding lots of handles
and chamfers to part faces, simply create a construction plane that goes
through all the handles and chamfers. Then make this plane magnetic and
bind the plane to the appropriate face. When you move the plane, the
attached handles and chamfers move with it.

See also

Create a construction line (page 622)

Create a construction plane (page 622)

Create a construction circle (page 623)
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Create a construction arc (page 624)

Create a construction polycurve (page 626)

Copy a construction object with offset (page 627)

Modify a construction object (page 628)

Create points (page 631)

Create a construction line

1. On the Edit tab, click Construction object --> Line .

2. Pick the start point of the construction line.

3. Pick the end point of the construction line. 

Tekla Structures creates the line.

4. To end the command, press Esc.

5. To modify the construction line properties, double-click the line in the
model. 

The line properties are shown in the property pane.

a. If you want to make the line magnetic, select Yes in the Magnetic list.

b. Select a color for the line.

c. Define how far the line extends beyond the picked points.

d. Select a line type for the line.

e. Click Modify .

See also

Create construction objects and points (page 621)

Copy a construction object with offset (page 627)

Modify a construction object (page 628)

Create parts, reinforcement, and construction
objects

622 Create construction objects and points



Create a construction plane

1. On the Edit tab, click Construction object --> Plane .

2. Pick three points.

3. Click the middle mouse button. 

Tekla Structures draws the plane.

4. To end the command, press Esc.

5. To modify the construction plane properties, double-click the plane in the
model. 

The plane properties are shown in the property pane.

a. Enter a name for the plane.

b. If you want to make the construction plane magnetic, select Yes in the
Magnetic list.

c. Click Modify.

See also

Create construction objects and points (page 621)

Modify a construction object (page 628)

Create a construction circle
You can create construction circles that are parallel to the view plane by
picking two points, or you can create construction circles by picking three
points in the 3D space in the model.

1. On the Edit tab, click Construction object --> Circle .

2. On the contextual toolbar that appears, click a button to specify which set
of points you want to pick: 
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• Click , and then pick the center point and a point to define the
radius of the circle.

Tekla Structures creates the circle parallel to the view plane.

• Click , and then pick three points: the center point, a point to define
the radius, and a point to define the plane of the circle.

• Click , and then pick three points along the arc of the circle.

Tekla Structures creates the circle using the points you picked and using
the current properties. Tekla Structures also indicates the center point of
the circle with an X in the model.

3. To end the command, press Esc.

4. To modify the construction circle properties, double-click the circle in the
model. 

The circle properties are shown in the property pane.

a. Select a color for the circle.

b. Select a line type for the circle.

c. Click Modify.

See also

Create construction objects and points (page 621)

Copy a construction object with offset (page 627)

Modify a construction object (page 628)

Create a construction arc
You can create construction arcs by picking three points in the 3D space in the
model.

1. On the Edit tab, click Construction object --> Arc .

2. On the contextual toolbar that appears, click a button to specify which set
of points you want to pick:

• Click , and then pick three points: the center point, start point, and
end point of the arc.

You can also define the angle or the length of the arc.
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• Click , and then pick the start point, end point, and a point along
the arc.

• Click , and then pick a point to define a tangent, and two points
along the arc.
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Tekla Structures creates the arc using the points you picked and using the
current properties. Tekla Structures also indicates the center point of the
arc with an X in the model.

3. To end the command, press Esc.

4. To modify the construction arc properties, double-click the arc in the
model. 

The arc properties are shown in the property pane.

a. Select a color for the arc.

b. Select a line type for the arc.

c. Click Modify.

See also

Create construction objects and points (page 621)

Copy a construction object with offset (page 627)

Modify a construction object (page 628)

Create a construction polycurve
You can create 3D construction polycurves that pass through the points you
pick and that can have straight and curved segments.

1. On the Edit tab, click Construction object --> Polycurve .

2. On the contextual toolbar that appears, click a button to specify which set
of points you want to pick to create a polycurve segment. 

You can switch between these picking modes each time you complete a
segment.

• For a straight segment, click  and then pick the start point and the
end point of the segment.

• For a curved segment, click  and then pick three points along the
segment.
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• For a curved tangential segment, click  and then pick a point on the
tangent line, the start point, and the end point of the segment.

• For a straight segment that is tangential to the previous segment, click

 and then pick a point on the tangent line.

Tekla Structures creates a polycurve segment.

3. Repeat step 2 for each polycurve segment that you want to create, but
skip picking the first point of the segment as it is the same as the last
point of the previous segment.

4. Click the middle mouse button to finish picking. 

Tekla Structures creates the polycurve through the points you picked,
using the polycurve's current properties.

5. To end the command, press Esc.

6. To modify the construction polycurve properties, double-click the
polycurve in the model. 

The polycurve properties are shown in the property pane.

a. Select a color for the polycurve.

b. Select a line type for the polycurve.

c. Click Modify .

See also

Create construction objects and points (page 621)

Copy a construction object with offset (page 627)

Modify a construction object (page 628)

Copy a construction object with offset
You can copy construction lines, circles, arcs, and polycurves in the direction
that you indicate, and using the offset values that you specify. For example,
you can create new circles and arcs centered in the same location as the
original circle or arc, and adjust the radiuses using the offset values.

1. On the Edit tab, click Construction object --> Copy with offset .

2. Select the construction object that you want to copy. 

You can copy lines (page 622), circles (page 623), arcs (page 624), and
polycurves (page 626).

3. Enter the offset values in the box that appears, and then press Enter. 
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If you only enter one offset value, Tekla Structures creates one copy of the
object.

To create several copies, enter multiple offset values. For example, 500
1000 1500, or 4*800.

4. Click in the direction where you want to copy the object.

Tekla Structures copies the selected object in the direction you indicated.

For example, if you selected a line, Tekla Structures makes a new copy of the
line in the specified location. If you selected a circle or arc, Tekla Structures
creates a new object that is centered in the same location as the original
object, and adjusts the radius using the offset value that you specified.

See also

Create construction objects and points (page 621)

Modify a construction object (page 628)

Modify a construction object
You can modify construction points, lines, circles, arcs, polycurves, and planes
using direct modification.

Before you start:

• To show (or hide) construction objects in model views, adjust their visibility
(page 647) in the Display settings.

• Ensure that the  Direct modification switch is active.

• Select the construction object. Use the following selection switches:

, , 

Tekla Structures displays the handles and dimensions that you can use to
modify the construction object.

When you select a handle and move the mouse pointer over , Tekla
Structures displays a toolbar with more modification options. The available
options depend on the type of the construction object you are modifying.

To modify a construction object, do any of the following:

To Do this Available for
Set a reference
point to move in
one, two, or any
direction

1. Select the handle in the reference
point.

Construction
points, lines, circle
center points,
planes
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To Do this Available for
2. To define in which directions the

handle can move, select an
option from the list on the
toolbar:

You can also press Tab to cycle
through the options.

3. To move the handle parallel to a
certain plane only, click  and
select the plane.

Move a point, a
point on a line,
circle, arc or
polycurve, or a
plane corner

Drag the handle in the reference
point to a new location.

All construction
objects

Move a circle or
arc

Drag the handle in the center point to
a new location.

Construction
circles, arcs

Move a line or a
plane edge

Drag the line handle to a new
location.

Construction
lines, planes

Move a plane Drag the plane to a new location. Construction
planes

Show or hide
diagonal
dimensions

1. Select a handle.

2. On the toolbar, click .

3. Click the eye button to show or
hide orthogonal and total
dimensions:

Construction
lines, planes

Change a
dimension

Drag a dimension arrowhead to a new
location, or:

1. Select the dimension arrowhead
which you want to move.

Construction
lines, circles,
planes

Arcs (numeric
input only)
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To Do this Available for
To change the dimension at both
ends, select both arrowheads.

To change the radius of a circle or
arc, select the outer arrowhead.

2. Using the keyboard, enter the
value with which you want the
dimension to change.

To start with the negative sign (-),
use the numeric keypad.

To enter an absolute value for the
dimension, first enter $, then the
value.

3. Press Enter, or click OK in the
Enter a Numeric Location
dialog box.

Chamfer a
polycurve corner

1. Select a corner handle.

2. On the toolbar:

•
Click  to create a
rounded chamfer, and then
enter the chamfer radius.

•
Click  to create a straight
chamfer, and then enter the
chamfer dimensions X and Y.

3. Press Enter to confirm the
chamfer dimensions.

Polycurves

Change an arc to
a line

Make a curved
segment straight

Select the arc or segment midpoint

handle (with an arc symbol)  and
press Delete.

Arcs, curved
polycurve
segments

Change a line to
an arc

Make a straight
segment curved

Drag the arc symbol  at the
midpoint of the line or segment.

Lines, straight
polycurve
segments

Add a corner
point and an
intermediate
segment to a
polycurve

Drag a segment midpoint handle to a
new location.

Polycurves

Remove a corner
point and the two

Select the corner point handle and
press Delete.

Polycurves
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To Do this Available for
connected
segments
Remove the last
polycurve
segment

Select the end point handle and press
Delete.

Polycurves

Change the radius
of an arc and keep
the end point
locations

Click the radius dimension, enter a
new value, and press Enter.

Arcs

Change the radius
of a polycurve
segment and keep
the end point
locations

Drag the arc symbol  at the
segment midpoint handle.

Curved polycurve
segments

Change the angle
or length of an arc

Drag the start or end point to a new
location.

Arcs

Copy a
construction
object using offset

See Copy a construction object with
offset (page 627).

Lines, circles, arcs,
polycurves

Change the
modeling
direction of the
selected
construction
object

On the contextual toolbar, click 
Swap ends.

This may be needed when you create
lofted plates (page 247) or lofted
slabs (page 285) by using construction
objects and if the geometry of the
plate or slab would become self-
intersecting.

Lines, arcs

See also

Create construction objects and points (page 621)

Create points (page 631)

Resize and reshape model objects (page 107)

Create points
You can create points to make it easier to place model objects at positions
where no lines or objects intersect.
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There are many ways to create points in Tekla Structures. Which method is the
most convenient at each time depends on what you have already created in
the model and which locations you can easily pick.

When you create points, Tekla Structures always places them according to the
work plane coordinate system. Points located on the view plane are by default
blue and points outside the view plane are by default red. You can change the
color of points in the point properties.

Use the display settings (page 647) to control if points are visible in model
views, and to adjust the point size if needed.

Create points on a line
You can create points at equal intervals along a line that is defined by two
points.

1. On the Edit tab, click Points --> On line . 

The Divided Line Points dialog box appears.

2. Define the number of points to be created.

3. Click OK.

4. Pick the start point of the line (1).

5. Pick the end point of the line (2).
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Create points on a plane
You can create several equally spaced points in the desired area in the model.
The points are created in relation to the picked origin position.

A point array consists of several points in a rectangular xy(z) pattern relative to
the current work plane. The x, y, and z coordinates of the points define the
array pattern. The x and y coordinates are relative distances between the
points on the work plane. The z coordinates are absolute distances
perpendicular to the work plane.

1. On the Edit tab, click Points --> On plane . 

The Point Array dialog box appears.

2. Define the array point coordinates. 

Use positive or negative values to define the direction of the array.

Use a zero at the beginning of the row to represent a point in the array
origin. Separate multiple values with spaces. For example, 0 4000 4000,
or 0 5*1000.

3. Pick the origin of the array in the view. 

Alternatively, you can define the origin in the Point Array dialog box.

4. Click Create.

Create points parallel to two points
You can create offset points that are parallel to a line between two points you
have picked.

1. On the Edit tab, click Points --> Parallel to two points . 

The Point Input dialog box appears.

2. Define the distances at which the points are created. 

If you want to create multiple pairs of offset points, enter multiple values
separated with spaces.

3. Click OK.

4. Pick the start point of the line (1).

5. Pick the end point of the line (2). 

The picking order of the start point and the end point defines the offset
direction of the new points.

When you look from the start point to the end point, Tekla Structures
creates the new points to the left of the picked points. If you enter
negative values to the Point Input dialog box, Tekla Structures creates
points to the right of the picked points.
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When you pick points, Tekla Structures uses arrows to indicate the offset
direction.

For example, if you enter 500 500 to the Point Input dialog box, the first
pair of new points is created at a 500 mm distance from the picked points,
and the second pair of points is created at a 500 mm distance from the
first pair of points.

Create points along the extension line of two points
1. On the Edit tab, click Points --> Along extension of two points . 

The Point Input dialog box opens.

2. Define the distances at which the points are created. 

Separate multiple values with spaces.

3. Click OK.

4. Pick the start point of the line (1).

5. Pick the end point of the line (2). 

For example, if you enter 500 100 100 to the Point Input dialog box, the
first point is created at 500 mm distance from the end point of the line,
and the second and the third point are each created at 100 mm distance
from the previous point.
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TIP Enter a negative value to the Point Input dialog box to create a point between
the start point and the end point.

Create projected points on a line
You can project a point onto a selected line or its extension.

1. On the Edit tab, click Points --> Projected points on line .

2. Pick the first point on the line (1).

3. Pick the second point on the line (2).

4. Pick the point to be projected (3).

Create points along an arc using center and arc points
You can create points along an arc.

1. On the Edit tab, click Points --> Along arc using center and arc points . 

The Arc Points dialog box appears.

2. Select either Angles or Distances and enter the angles or distances
between the points along the arc. 

Give the angle values in degrees.

Separate multiple angle and distance values with spaces.
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3. Click OK.

4. Pick the center point.

5. Pick the start point of the arc. 

Tekla Structures creates the arc points counterclockwise from the start
point.

Create points along an arc using three arc points
You can create points as an extension of an arc.

1. On the Edit tab, click Points --> Along arc using three arc points . 

The Arc Points dialog box appears.

2. Select either Angles or Distances and enter the angles or distances
between the points along the arc. 

Give the angle values in degrees.

Separate multiple angle and distance values with spaces.

3. Click OK.

4. Pick three points along the arc (1-3).
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Create points tangent to a circle
You can create a point along the tangent of a circle.

1. On the Edit tab, click Points --> Tangent to circle .

2. Pick the center point of the circle (1).

3. Pick a point on the circle to define the radius (2).

4. Pick the end point of the tangent (3).

5. Pick a side to indicate the side on which Tekla Structures creates the
tangent point (4).

(1): Tangent point

Create points at any position
You can create a point at the position you pick.

NOTE Snap switches (page 84) determine the positions you can pick.

You can also use temporary reference points and numeric snapping to create a
point, for example, to a certain distance from an existing corner or a point.

1. On the Edit tab, click Points --> At any position .

2. Pick the intersection of two part edges (1), or the corner of a part (2).
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Create bolt points
You can create points on the view plane at the center points of single bolts and
bolt group bolts.

1. On the Edit tab, click Points --> Bolt points .

2. Select a bolt or a bolt group.

Create points at the intersection of two lines
You can create a point at the intersection of two lines in the view plane. The
lines are treated as infinite length. The extensions of the lines must intersect at
some point.

1. On the Edit tab, click Points --> At intersection of two lines .

2. Pick the start point of the first line (1).

3. Pick the end point of the first line (2).

4. Pick the start point of the second line (3).

5. Pick the end point of the second line (4).

Create points at the intersection of a plane and a line
You can create a point where a line intersects with a plane.

1. On the Edit tab, click Points --> At intersection of plane and line .

2. Pick three points to define the plane.

3. Pick the first point of the line.

4. Pick the second point of the line.

Create points at the intersection of a part and a line
You can create points where a line intersects with the surface of a part.

1. On the Edit tab, click Points --> At intersection of part and line .

2. Select the part.
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3. Pick the first point on the line.

4. Pick the second point on the line.

Create points at the intersection of a circle and a line
You can create points where a circle and a line intersect.

1. On the Edit tab, click Points --> At intersection of circle and line .

2. Pick the center point of the circle (1).

3. Pick a point on the circle to define the radius (2).

4. Pick the first point on the line (3).

5. Pick the second point on the line (4).

(1): New points

Create points at the intersection of two part axes
You can create points where the axes of two parts intersect, and project the
points onto the axis of the part that you select first.

1. On the Edit tab, click Points --> At intersection of two part axes .

2. Select the first part (1).

3. Select the second part (2). 

Tekla Structures projects the point onto the axis of the first part.
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Import points

NOTE This is for advanced users.

You can import points to specific locations in an open Tekla Structures
model using the Point Creation Import (8) component. You need to
specify the point coordinates in a text file. In some cases this file is
generated by another software package.

1. Create a point import file.

a. Create a text file that consists of single lines for each point. 

Use commas or tabs as delimiters for the three point coordinates on
a line. For example:

100,500,1000
300,700,1500

b. Save the file.

NOTE During the import process, Tekla Structures ignores all lines in the
import file which do not consist of valid values delimited by tabs
or commas.

2. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

3. Enter point in the Search... box.

4. Click Point Creation Import (8).

5. Enter the ASCII file name. 

Include the full path and the file name extension (for example .txt). If
you do not specify the path, Tekla Structures looks for the file in the
current model folder.

6. Define the origin of the imported points by entering the coordinates.

7. Click Create.

Point properties
Use the Point properties to view and modify the properties of a point.

If you have customized the property pane layout, the list of properties may be
different.

Setting Description
General
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Setting Description
Color Change the color of the points.

Note that if you change the point
color, the changed color is not applied
the next time you create points. The
points are created using the default
point color.

Location
X

Y

Z

The local (work plane) and global x, y,
and z coordinates of a point. Indicates
the correct location of the point.

TIP You can change the point size in Adjust the display settings (page 647).
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3 Adjust how model objects are
displayed

You can use different methods to adjust how model objects are displayed:

• To change the rendering of parts and components and select whether the
object surfaces or the object outlines are displayed in the views, see
Change the rendering of parts, components and reference models
(page 642).

• To change the general display settings, Adjust the display settings.

• You can temporarily change the part representation to show parts with
exact lines or with high accuracy as explained in Change the part
representation to show parts with exact lines or with high accuracy.

• You can temporarily hide selected objects or show only the selected objects
as explained in Temporarily hide model objects or show only selected
model objects (page 652).

• Detailed instructions for changing model object color and transparency can
be found in Change the color and transparency of model objects by using
object representation.

• You can group model objects using various criteria (for example, profile) to
handle them as a single unit when you define display settings, see Use
object groups in object representation and in filters (page 662).

3.1 Change the rendering of parts, components and
reference models
You can easily change the rendering of parts, components and reference
models in model views.

1. On the View tab, click Rendering.

2. Select one of the rendering options for parts, components, or reference
models: 
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Option Description Example
Parts
wireframe/
Components
wireframe/
References
wireframe

Object outlines are displayed,
surfaces are not. Objects are
transparent.

In this example, component
objects are displayed as
rendered.

In DirectX rendered views, the
part edge lines hidden behind
another part are visualized
with dashed lines if you have
switched the Dashed line for
hidden line option on in File
menu --> Settings -->
Switches.

In this example, component
objects are displayed as
rendered.

Adjust how model objects are displayed 643 Change the rendering of parts, components and
reference models



Option Description Example
Parts shaded
wireframe/
Components
shaded
wireframe/
References
shaded
wireframe

Object outlines are displayed.
Objects are transparent, and
their surfaces are rendered.

In this example, component
objects are displayed as
rendered.

In DirectX rendered views, the
part edge lines hidden behind
another part are visualized
with dashed lines if you have
switched the Dashed line for
hidden line option on in File
menu --> Settings -->
Switches.

In this example, component
objects are displayed as
rendered.
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Option Description Example
Parts
grayscale/
Components
grayscale/
References
grayscale

Objects are shown in
grayscale.

In this example, component
objects are displayed as
rendered.

In DirectX rendered views, the
part edge lines hidden behind
another part are visualized
with dashed lines if you have
switched the Dashed line for
hidden line option on in File
menu --> Settings -->
Switches.

In this example, component
objects are displayed as
rendered.

Parts
rendered/
Components
rendered/

Object surfaces are displayed.
Objects are not transparent.
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Option Description Example
References
rendered

In DirectX rendered views, any
duplicate objects or
overlapping parts on the
same plane are visualized
with a hatch if you have
switched the Hatching of
overlapping surfaces option
on in File menu --> Settings
--> Switches.

In this example, the
overlapping surfaces are
visualized with a hatch.

Show only
selected
part/Show
only selected
component/
Show only
selected
reference

Selected objects are
displayed. Other objects are
almost completely
transparent.

This option is useful, for
example, when viewing clash
check results in a large model.

In this example, component
objects are displayed as
rendered.
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Option Description Example
In DirectX rendered views, the
part edge lines hidden behind
another part are visualized
with dashed lines if you have
switched the Dashed line for
hidden line options on in File
menu --> Settings -->
Switches.

In this example, component
objects are displayed as
rendered.

TIP Alternatively, you can use the keyboard shortcuts Ctrl+1...5 for parts and Shift
+1...5 for components to switch between the rendering options. Ctrl+Shift+1...5
works for references.

See also

Adjust the display settings (page 647)

Change the rendering mode for model views (page 72)

3.2 Adjust the display settings
Adjust the display settings to define how parts and other model objects
appear in model views.

Set the visibility and representation of model objects in the
Display settings
You can define the visibility and representation separately for different types
of model objects.

1. Double-click the view to open the View Properties dialog box. 

Alternatively, on the View tab, click View properties.

2. Click the Display... button to open the Display dialog box.

3. Select or clear check boxes to specify which objects are visible in the view.
You can specify separately the object visibility for the objects in model and
for the objects in components.
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4. Select a representation option for parts, bolts, holes, welds, construction
planes and reinforcing bars. 

You have the following options:

• Fast

• Exact

• Reference line (only for parts)

• Exact slotted holes (only for holes)

• Exact - no weld mark (only for welds)

5. If you are working with cast-in-place (page 447) concrete structures, and
the pour management functionality is enabled (page 445): 

a. In the Cast in place list, select whether you want to show the
structures as Parts or as Pours.

b. If you selected Parts for the cast-in-place concrete structures, select
whether you want to show the parts as Merged or as Separated.

6. Ensure that the view is selected.

7. Click Modify to apply the changes.

NOTE To quickly modify the visibility of objects in model and in components, use the
contextual toolbar. Click the view, and use the eye icon on the contextual
toolbar to set the visibility.

Display settings
Note that some of these settings may affect system performance.

Option Description
Settings
Parts Defines how parts are displayed.

Fast uses a rapid drawing technique
that displays internal hidden edges,
but skips cuts. The setting does not
automatically affect already modeled
parts. When you switch this setting
on, the fast representation mode will
be applied only to newly created parts
and to parts that are displayed with
the Show with exact lines
command.

Exact displays the cuts, but hides the
internal hidden lines of parts.
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Option Description
Reference line shows parts as sticks
(page 309). This option increases
display speed significantly, when
viewing the entire model, or large
parts of it.

Cast-in-place concrete structures can
be displayed as Pours, or as Parts
that can be Merged or Separated.
For more information, see View cast-
in-place concrete structures
(page 447).

Bolts Defines how bolts are displayed.

Fast displays the axis and a cross to
represent the bolt head. This is the
recommended representation mode
for bolts, because it increases display
speed significantly and consumes less
system memory.

Exact shows bolts, washers, and nuts
as solid objects.

Holes Defines how holes are displayed.

Fast only displays the circle in the
first plane. When using this option,
Tekla Structures always displays fast
holes on the first part (counting from
the head of the bolt). If there are
slotted holes in any of the parts, a
slotted hole is displayed on the first
part, even if the hole in that part is
not slotted. The new slotted hole has
the same size and rotation as the first
slotted hole (counting from the head
of the bolt).

Holes that are outside a part are
always displayed as fast holes.

Exact shows holes as solid objects.

Exact slotted holes only displays
slotted holes in exact mode and
ordinary holes in fast mode.

Welds Defines how welds are displayed.

Fast displays a symbol for welds.

Exact shows welds as solid objects
and displays the weld symbols. When
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Option Description
you select welds, the weld marks are
displayed.

Exact - no weld mark shows welds
as solid objects but does not display
the weld symbols, nor the weld marks
when you select welds.

For more information, see Set the
visibility and appearance of welds
(page 371).

Construction planes Defines how construction planes are
displayed.

Reinforcing bars Defines how reinforcement objects
are displayed.

Fast displays the shape of
reinforcement meshes using an
outline polygon and a diagonal line.
Single reinforcing bars and bar groups
are displayed as solid objects.

Exact shows reinforcing bars, bar
groups, and reinforcement meshes as
solid objects.

Advanced
Part label See Show part information by using

part labels (page 324).
Point size Defines the size and appearance of

points in views. Also affects the size
and appearance of the handles,
together with XS_HANDLE_SCALE.

In model increases the point size on
the screen when you zoom in. Shows
points and handles as 3D cubes:

In view does not increase the point
size. Shows points and handles as flat
2D objects:
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3.3 Change the part representation to show parts with
exact lines or with high accuracy
Even if you have set the part representation to Fast in the display settings, you
can temporarily view the parts using different representation options.

Show parts with exact lines
Use the Show part with exact lines command to temporarily display a part
with exact lines even if you are using the Fast representation option for parts.

1. Select the part.

2. Go to Quick Launch, start typing show part with exact lines, and
select the Show part with exact lines command from the list that
appears.

3. Click the view in which you want to display exact lines.

4. To clear the exact lines effect, on the View tab, click .

Show parts with high accuracy
You can temporarily display parts with the highest possible level of accuracy.
This can be useful, for example, when checking a large model, because the
entire model can still be displayed in the Fast or Exact representation mode
but the individual part can be shown in more detail.

1. Select the parts.

2. Right-click, and then hold down the Shift key while selecting Show with
exact lines. 

Tekla Structures displays the selected parts with the highest possible level
of accuracy.

3. To clear the high accuracy effect, right-click and select Show with exact
lines.
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(1) Normal display mode

(2) High accuracy mode

3.4 Temporarily hide model objects or show only selected
model objects
You can temporarily show, hide, or show hidden model objects and assemblies
in model views.

Hide parts or other objects in a model view
You can quickly hide selected parts or other objects in a model view. This can
be useful, for example, when you want to temporarily hide some parts to see
the parts behind them.

1. Select the parts or objects you want to hide. 
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2. Right-click and select Hide. 

Tekla Structures shows the hidden parts as part reference lines.

To completely hide the selected parts, hold down the Shift key when
selecting the command.

The selected parts become invisible.
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3. To make the hidden parts or objects visible again, click  on the View
tab. 

Alternatively, right-click in the view and select Redraw view.

Show only selected parts or other objects in a model view
As an alternative to hiding single parts or other objects in a model view, you
can define which parts you want to keep visible. All of the other, unselected
parts will be hidden.

1. Select the parts or objects that you want to keep visible. 

2. Right-click and select Show only selected. 
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Tekla Structures shows the unselected parts almost as transparent.

TIP To completely hide the unselected parts, hold down the Shift key
when selecting the command.

To show the unselected parts as part reference lines, hold down the
Ctrl key when selecting the command.

3. To make the unselected parts or objects visible again, click  on the
View tab. 

Alternatively, right-click in the view and select Redraw view.

Temporarily show assembly and component objects in a
model view
You can temporarily show the contents of an assembly or a component even if
some of the assembly or component objects are not visible in a model view.

To Do this
Show the contents of an assembly 1. Right-click an assembly, or a part

in the assembly.

2. Select Assembly --> Show
assembly .

For a concrete part, select Show
assembly.

Tekla Structures shows an orange box
around the assembly, and displays all
parts, bolts, welds, and other details
(not cuts or fittings) belonging to the
assembly, even if you had defined
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To Do this
them as hidden in the display settings
(page 647).

For concrete parts, Tekla Structures
displays reinforcement and surface
treatment (not surfaces), even if you
had defined them as hidden in the
display settings.

Show the contents of a component 1. On the View tab, click Rendering
--> Show component content .

2. Select a component.

Tekla Structures displays all bolts,
welds, and other details belonging to
the component, even if you had
defined them as hidden in the display
settings (page 647).

Reapply the display settings
(page 647) and make assembly or
component objects hidden again

On the View tab, click .

3.5 Change the color and transparency of model objects
by using object representation
Use object representation to set the color and transparency of model objects in
model views and to create customized presentations of the model by using
defined object groups.

With object representation settings and object groups you can define that, for
example, only some model objects are visible or that some model objects are
of certain color.

To open the object representation settings, on the View tab, click
Representation. The Object Representation dialog box opens.

Note that changing the settings in the Object Representation box affects all
model views.

The following images show the same model with different transparency
settings:
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1. Standard color and transparency settings

2. Only parts whose profile name starts with IPE* or HEA* are visible

3. Parts whose user-defined attribute Planned erection date is set to a
certain date are displayed in blue, while all other parts are 90%
transparent

Use the Class property to change the color of parts and
reinforcement
Use the object representation settings Color by class and Visible to enable
the changing of the color of parts and reinforcement in the part and
reinforcement properties.

1. To open the object representation settings, on the View tab, click
Representation. The Object Representation dialog box opens.

2. In the dialog box, ensure that 

• Object group is set to All

• Color is set to Color by class

• Transparency is set to Visible

With these settings, all parts and reinforcement are colored according to
their Class property in the part and reinforcement properties.

The possible class numbers range between 0 and 14, and result in
different colors as follows:
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Class numbers above 14 produce the same colors as 1...14. For example,
class numbers 2, 16, 30, 44, and so on, all result in red.

3. To change the part or reinforcement color in the part or reinforcement
properties:

a. In the property pane, in the Class box, select a new class.

b. Click Modify.

Alternatively, you can change the Class property on the contextual
toolbar.

NOTE You can also use class numbers to define the default color of pour objects and
pour breaks.

Define color and transparency settings for object groups
1. On the View tab, click Representation to open the Object

Representation dialog box. 

The settings Color by class and Visible are on by default.

2. To define the color and visibility of a selected object group, click Add row.

3. Select an object group (page 662) from the Object group list.

4. Use the Color list to define the color for the objects in the object group.

5. Use the Transparency list to define the transparency for the objects in
the object group.

6. Repeat steps 3–5 for each row you add.
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7. Use the Move up and Move down buttons to change the order of the
rows. 

The reading order of the rows is from bottom to upwards. If an object
belongs to several groups, the upmost row defines the color and
transparency setting defined for the objects.

8. Enter a unique name in the box next to the Save as button.

9. Click Save as to save the settings.

NOTE If your setting does not contain the group All, Tekla Structures adds that row
to the bottom of the list when you click Modify, Apply or OK.

Color settings in object representation

Option Description
As is The current color is used.

If the object belongs to one of the
object groups defined in the following
rows, its color is defined by the
settings that the object group in
question has on that row.

Colors Select color from the list.
Color by class All parts are colored according to

their Class property.
Color by lot Parts belonging to different lots or

phases get different colors according
to the lot or phase number:

Color by phase

Color by analysis type Displays parts according to the
member analysis class.
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Option Description
Color by analysis utility check Displays parts according to the

utilization ratio in analysis.
Color by attribute Displays parts in different colors

according to the values of a user-
defined attribute.

Transparency settings in object representation

Option Description
As is The current visibility.

If the object belongs to any object
group whose visibility and color
settings have been defined, the
settings will be read from that object
group.

Visible Object is shown in the views.
50% transparent Object is transparent in the views.
70% transparent
90% transparent
Hidden Object is not shown in the views.

Define your own colors for object groups in object
representation
If the color properties are not sufficient, you can define your own colors.

1. On the View tab, click Representation to open the Object
Representation dialog box.

2. Select an object group from the Object group list.

3. In the Color list, select Choose color....

4. Do one of the following: 
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• Click a color in the Basic colors palette.

• Click Define Custom Colors and create a color of your own:

a. Click a color in the color window.

b. Define the color depth by using the color bar on the right, or enter
the exact RGB values.

c. Click Add to Custom Colors.

d. Click the color in the Custom colors palette to select it.

5. Click OK.

6. Click Save to save the changes. 
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When you open the Object Representation dialog box the next time, the
Color list shows a maximum of 10 colors that you last defined.
Customized colors are shown above the dashed line:

Information about the colors that you define for the object groups is stored in
the used_custom_colors.clr file, which is located in the current model's 
\attributes folder.

Information about the colors that you add in the Custom colors palette is
stored in the xs_user.xxx file in the model folder (xxx is your user name).

Copy object representation settings to another model
1. Select the settings you want to copy. 

The settings you have created are located in the current model’s
\attributes folder, and they have the file name extension .rep.

2. Select where you want to copy the settings. 

• To make the settings available in another model, copy them to the
\attributes folder of the destination model.

• To make the settings available in all models, copy them to the project
or firm folder, defined by the advanced option or .

3. Restart Tekla Structures.

If you want to delete the settings in the \attributes folder, select the .rep
file and press Delete.
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3.6 Use object groups in object representation and in
filters
In object groups the objects are grouped by a set of rules and conditions. Use
the object groups to control the transparency and coloring of model objects in
the model views, and in filters to define which objects are displayed or can be
selected.

Where object groups are used
Object groups are sets of rules with which you can group objects by selected
properties and conditions.

Use object groups in

• object representations to control the transparency and coloring of model
objects in all views

• model view filters (page 154) to define which objects are displayed in the
selected view

• selection filters (page 156) to define which objects can be selected

• Organizer to filter the content of categories

• Project status visualization to review the status of model objects in a
specific time frame

Object groups for different purposes use different object group files. Object
group files are saved in the current model’s attributes folder.

Object group File name extension
Object group - Representation .PObjGrp
Object group - View filter .VObjGrp
Object group - Select filter .SObjGrp
Object group - Organizer .OrgObjGrp

Create an object group for object representation
1. On the View tab, click Representation to open the Object

Representation dialog box.

2. Click Object group... to open the Object Group - Representation dialog
box.

3. Select an existing object group from the Save/Load list to create a
modified version or click New filter to start without existing settings.

4. Click Add row or continue to modify the settings on an existing row.
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5. Select options from the Category, Property, and Condition lists. 

You can use the same object properties (page 164) and techniques
(page 161) as in filtering.

6. In the Value list, enter a value or select one from the model. 

The values can be complete strings, such as the profile name UC310*97.
You can also use incomplete strings together with wildcards (page 181).
For example, the value UC* will match with all parts whose profile name
begins with the characters UC*. Empty values are matched to empty
object properties.

If you use multiple values, separate the strings with blank spaces (for
example, 12 5). If a value consists of multiple strings, enclose the entire
value in quotation marks (for example, "custom panel"), or use a
question mark (for example, custom?panel) to replace the space.

7. Use the And/Or options and brackets (page 161) to define how multiple
rows work together.

8. To temporarily disable rules without deleting them, you can deselect the
check boxes in the first column of the row. Select the check box to re-
enable the rule.

9. Enter a unique name in the box next to the Save as button.

10. Click Save as to save the object group.

Object group - Representation settings

When you create object groups in the Object Group - Representation dialog
box, you can use the same object properties and techniques as in filtering. The
following table introduces the options shortly, for more detailed information
see Object properties in filtering (page 164) and Filtering techniques
(page 161).

Column Description
Check boxes Select the check box to include the row in the rule.

By default each new row is disabled
Parentheses Use parentheses to create nested rules.
Category Use the Object category with user-defined

attributes or, for example, if you need to create a
selection filter based on GUIDs.

Property Select an available property. All user-defined
attributes can be selected as well.

Condition Numeric, textual, and date properties all have
different set of conditions.
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Column Description
Value You can enter the value manually, or select the

value from the model by clicking an object.

For example, if you select Part as Category, and
Name as Property, and click a part in the model,
you get its Name property in the object group rule.

And/Or Use the And/Or column when you create rules
with several rows.

An empty field is the same as if it had the And
option selected.

Copy object groups to another model
1. Select the object group you want to copy. 

The object groups you have created are located in the model’s
\attributes folder, and they have the file name extension .PObjGrp.

2. Select where you want to copy the object group. 

• To make an object group available in another model, copy the file to
the \attributes folder of the destination model.

• To make an object group available in all models, copy the file to the
project or firm folder, defined by the advanced option XS_PROJECT or
XS_FIRM.

3. Restart Tekla Structures.

If you want to delete the object group file in the \attributes folder, select
the .PObjGrp file and press Delete.
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4 Check the model

You can use a variety of tools to check and view the model, and to ensure the
model does not contain errors.

• To quickly search for objects in the entire model or within the selected
model objects, see Search for model objects (page 666).

• To take snapshots and to create animations that demonstrate the design
and build options of your model and use them in your presentations, see
Visualize the model (page 669).

• To travel through the model by using the Fly command, see Fly through the
model (page 682). If you need to focus in on required details in the model,
see Create clip planes (page 683). To show parts in a selected view angle,
see Show parts, components, or assemblies in a selected view angle Show
parts, components, or assemblies in a selected view angle (page 685).

• Use the different Inquire commands to get particular information about
model objects, as described in Inquire object properties (page 686).

• Use the Measure commands to measure, for example, distances, as
described in Measure objects (page 692).

• To find colliding objects in a model, see Detect clashes (page 695).

• To check the inconsistencies in a model, you can compare selected parts or
assemblies, view solid errors in a log file, or diagnose and repair the model
to check and repair errors, or to find distant objects. For instructions, see
Compare parts or assemblies (page 707), View solid errors (page 707),
Diagnose and repair the model (page 708) and Find distant objects
(page 710).

4.1 Search for model objects
You can quickly search for objects in the entire model or within the selected
model objects by using the Model search toolbar.
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When you run a search in the model, Tekla Structures searches for objects
whose property values contain the search term, and then highlights and
selects the objects that have matching property values. Tekla Structures
searches for the following objects and checks the listed object properties for
matches:

• Parts and items: name, profile or shape, material, part position number,
assembly position number or cast unit position number, GUID

• Pour objects: pour type (if pour management is enabled (page 445))

• Reinforcement: name, grade, position number, cast unit position number,
GUID

• Surfaces: name, GUID

• Components: name, running number (shown in the Inquire object dialog
box), GUID

• Assemblies: name, assembly position number, GUID

• Cast units: name, cast unit position number, GUID

• Pour units: name (if pour management is enabled)

• All other objects: GUID

You can use the following wildcards (page 181) in the search term: *, ?, or [ ], or
" " for exact match.

The search term may consist of several words. When a property value of an
object contains all of those words, Tekla Structures finds that object.

If there is only one word in the search term, Tekla Structures finds all the
objects whose property values contain that word. For example, with the search
term Plate you can find objects with the name Plate or End plate, but
objects with the name Plate1 are not found.

If you enclose the search term in " ", Tekla Structures only finds the exact
matches. For example, "end plate" does not find objects with the name
Stiffened end plate or Two sided end plate.

The search is not case-sensitive, which means that you can use both lower-
case and upper-case letters. For example, the search terms beam and BEAM
give the same search results.

If the Select assemblies  selection switch is active, Tekla Structures
searches for assemblies, cast units, and pour units with matching names or
position numbers. Otherwise Tekla Structures searches for other objects with
matching property values. Other selection switches do not affect the search
results.

Check the model 667 Search for model objects



Search in the entire model
When you run a search in the entire model, Tekla Structures also searches for
the hidden objects whose property values match the search criteria.

1. If pour management is enabled (page 445) and you are searching for pour
objects or pour units, ensure that you are using a pour view (page 447).

2. On the Model search toolbar, enter the search term in the box. 

You can use wildcards *, ?, or [ ], or " " for exact match.

3. Click , or press Enter.

Tekla Structures highlights and selects the model objects whose property
values match the search criteria, and shows the object properties in the
property pane.

Search within the selected model objects
1. Select the objects within which you want to search. 

You can use area selection or a filter (page 150) to focus on certain
objects.

2. On the Model search toolbar, enter the search term in the box. 

You can use wildcards *, ?, or [ ], or " " for exact match.

3. Click .

Tekla Structures highlights and selects the model objects whose property
values match the search criteria, and shows the object properties in the
property pane.

Review the search results
You may find these tips useful when you examine the search results and the
selected model objects.

• To hide the model objects whose property values do not match the search
criteria, do any of the following:

• Press Ctrl+5 to show the matching objects only.

• Press Shift+5 to show the matching component objects only.

• Right-click and select Show only selected (page 654).

• To narrow down your search further, you can run nested searches. Keep
the first search result objects selected and then run another search within

them by clicking .
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• To review the matching objects as a list, use Organizer. Object Browser
lists the selected objects and shows their properties in columns.

• To review or modify the properties of the selected objects, use the property
pane.

Show or hide the Model search toolbar
By default, the Model search toolbar is visible and located at the bottom of
the Tekla Structures main window.

If the toolbar is not visible, do one of the following:

• Go to the File menu, click Settings, and in the Toolbars list, select the
Model search toolbar check box.

• Go to Quick Launch, start typing toolbar, and then select the Model
search toolbar check box in the list that appears.

If you want to hide the Model search toolbar, clear the Model search toolbar
check box in File --> Settings --> Toolbars or by using Quick Launch.

4.2 Visualize the model with Trimble Connect Visualizer
Trimble Connect Visualizer creates a basic rendering of an open Tekla
Structures 3D model. You can use Trimble Connect Visualizer to take
snapshots and create animations that demonstrate the design and build
options of your model. You can then use the snapshots and animations in
your presentations.

You can access Trimble Connect Visualizer directly from Tekla Structures. The
Trimble Connect Visualizer commands are located on the View tab.

Visualize all model objects
1. On the View tab, click the arrow under Visualize.

2. On the menu, select  Visualize all. 

A rendering of the entire model opens in Trimble Connect Visualizer.

Note that parts that are not visible in the Tekla Structures model view are
also rendered.

Visualize the selected model objects
1. Select the objects that you want to visualize.
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2. On the View tab, click the arrow under Visualize.

3. On the menu, select  Visualize selected. 

A rendering of the selected model objects opens in Trimble Connect
Visualizer.

Working in Trimble Connect Visualizer
Before you take snapshots or create animations in Trimble Connect Visualizer,
you can zoom, drag, and pan the model to get the desired views. You can also
adjust the scene settings to control, for example, the brightness of the scene
and the position of the sun.

Zoom, rotate, or pan the rendered model
• Do any of the following: 

To Do this
Zoom in Do either of the following:

• Scroll forward with the mouse wheel.

• Press the W key on the keyboard.
Zoom out Do either of the following:

• Scroll backward with the mouse wheel.

• Press the S key on the keyboard.
Rotate the model 1. Place the mouse pointer over the point around

which you want to rotate the model.

2. Hold down the left mouse button.

3. Drag the model with the left mouse button.

You can also press the arrow keys on the keyboard
to rotate the model.

Pan the model 1. Hold down the middle mouse button.

2. Drag the model with the middle mouse
button.

You can also press the A and D keys on the
keyboard to pan the model.

Adjust the scene
In Trimble Connect Visualizer, you can modify the following scene settings:

• The used skybox, or background, and its rotation
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• The position of the sun

• The brightness of the scene

• The visibility and position of the ground plane

1. Click  on the Trimble Connect Visualizer side pane.

2. Do any of the following: 

To Do this
Change the skybox The skybox that is currently in use is highlighted

with blue. To change the skybox:

• Click another skybox in the skybox selector at
the top of Trimble Connect Visualizer.

You can also use your own images as skyboxes.
Note that all skybox images need to be 360°
images with a ratio of 2:1. Save the skyboxes in the
C:\Users\<user>\Pictures
\TrimbleConnectVisualizer\Skyboxes folder.
The skyboxes will be available in the skybox
selector the next time you open Trimble Connect
Visualizer.

Rotate the skybox • Move the rotation slider at the top of Trimble
Connect Visualizer.

You can lock the position of the skybox and the

direction of the sun together by clicking . After
locking the direction of the sun and the position of
the skybox, moving the rotation slider also moves
the sun direction slider by the same amount.

Adjust the brightness of
the scene

• Move the brightness slider at the upper-right
corner.

Adjust the position of
the sun

Do any of the following:
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To Do this
• To change the direction of the sun, move the

sun direction slider at the upper-left corner.

You can lock the direction of the sun and the

position of the skybox together by clicking .
After locking the direction of the sun and the
position of the skybox, moving the rotation
slider also moves the sun direction slider by the
same amount.

• To change the height of the sun above the
horizon, move the sun height slider on the left
side of the rendered model.

Show or hide the ground
plane

• To switch between showing and hiding the

ground plane, click  on the left side of the
rendered model.

When the ground plane is switched on, a slider

appears below the  button. You can move the
slider to adjust the height of the ground plane.
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Take and view snapshots
1. Adjust the position of the model and the scene as needed.

2. Click  at the upper-left corner of the Trimble Connect Visualizer
window.

Trimble Connect Visualizer takes a snapshot of the current view of the
rendered model. The snapshots are saved in the C:\Users\<username>
\Pictures\TrimbleConnectVisualizer folder.

To open the C:\Users\<username>\Pictures
\TrimbleConnectVisualizer folder and view the snapshots that you have

taken, click  at the upper-left corner of the Trimble Connect Visualizer
window.

Create animations
You can combine different views of the rendered model to create animations
that show the model from different angles. Do the following:

1. Click  on the Trimble Connect Visualizer side pane.

2. Do any of the following: 

To Do this
Add a view a. Move the model to get the view that you want

to use.

b. Click + on the toolbar below the view.

Repeat steps a to b to create all necessary views.

Note that when you have added multiple views,
you need to click + on the right side of the view
after which you want to add the new view.
Similarly, click + or on the left side of the view
before which you want to add the new view.
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To Do this

Remove a view from the
animation

• Click the Close button (X) at the upper-right
corner of a view.

Set the time between
views

The time between views determines the speed of
the animation.

• Type the desired time in seconds in the box

below the rendered model ( ).
Play or stop the
animation • To play the animation, click  on the toolbar

below the rendered model.

• To stop the animation and return to the first

view, click .
Play the animation
continuously

You can choose to play the animation in a loop
without stopping.

a. Click  on the toolbar below the rendered
model.

b. To play the animation, click .
Freeze the sun position
in the animation

In each view you create, the sun is in a different
position. Animations can look strange if the sun
moves, so it might be helpful to freeze the sun
position.

• Click  on the toolbar below the rendered
model.

3. To save the animation, use a screen recorder, such as the built-in free
screen recorded in Windows 10. 

You can find more information, for example, here.
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Return to the initial view of the model

1. Click  on the Trimble Connect Visualizer side pane.

The model returns to the view that was opened when you started Trimble
Connect Visualizer.

Enter or exit full screen mode

1. Click  on the Trimble Connect Visualizer side pane.

Show or hide the Trimble Connect Visualizer side pane

1. Click  at the bottom of the Trimble Connect Visualizer side pane.

Use Trimble Connect Visualizer in VR mode
The VR mode in Trimble Connect Visualizer allows you to easily switch to a
virtual reality mode. In the VR mode, you can move either with the keyboard or
with an Xbox One controller that is connected to your computer. Note that
moving in the VR mode imitates the speed of walking or running.

The VR mode uses the OpenVR API. Because of this, using the VR mode in
Trimble Connect Visualizer has some prerequisites:

• A VR device that is compatible with OpenVR must be attached to your
computer and configured according to the instructions of the hardware
vendor. Among others, HTC Vive, Oculus Rift, Windows MR, and VarjoVR
devices are compatible with OpenVR.

The VR mode in Trimble Connect Visualizer is heavier to render than the
regular 3D mode. Check the technical specifications of the device to see if
the device has enough capacity for working in the VR mode in Trimble
Connect Visualizer. For more information, contact the vendor of your
device.

• Steam and SteamVR need to be downloaded and installed onto your
computer:

1. Download Steam and install it onto your computer.

2. Create a Steam account and sign in to Steam.

3. Download the SteamVR package onto your computer.

4. Start SteamVR and configure it.

You do not need to be signed in to Steam to work in the VR mode in
Trimble Connect Visualizer. It is enough to set up Steam once, and then
sign in for updates occasionally.
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1. Click  in the Trimble Connect Visualizer side pane. 

If the VR mode icon ( ) is not visible, your computer does not meet the
requirements of the VR mode.

2. Move in the VR mode as you wish. 

To move in the VR mode with Do this
Your keyboard The keyboard controls are the same

as in the regular 3D mode:

• To move forward, press the W key.

• To move backward, press the S
key.

• To move left, press the A key.

• To move right, press the D key.

• To move up and down, press the Q
and E keys.

• To rotate around the global
vertical axis, press the X and Z
keys.

• To move at running speed, hold
down Shift .

An Xbox One controller When an Xbox One controller is
connected to your computer via
Bluetooth, use the following controls:

• To move the viewer relative to the
view direction, use the left stick.

• To rotate around the global
vertical axis, use the right stick.

• To move up and down, use the left
and right triggers.

• To move at running speed, hold
down the left stick.

3. To switch back to the 3D mode, click  again.

Modify material mappings for Trimble Connect Visualizer
By default, Trimble Connect Visualizer attempts to map the materials used in
Tekla Structures to the material types used in the Trimble Connect Visualizer
material catalog. You can also set material type mappings manually to define
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how you want materials to look in Trimble Connect Visualizer. If necessary, you
can override the materials of particular model objects, and use another
material instead.

You can currently map the Tekla Structures materials to the following pre-
defined material types in Trimble Connect Visualizer:

• Asphalt

• Concrete

• Dark gravel

• Default: renders objects with white matte material

• Glass

• Grass

• Ground

• Light Gravel

• Steel

• Timber

• Water

Pre-defined materials and their color and transparency information are read
from the materials_ifc.xml file saved in the ..\TeklaStructures
\<version>\bin\applications\Tekla\Tools
\TrimbleConnectVisualizer\TrimbleConnectVisualizer_Data
\StreamingAssets folder.

You can also map to your own user-defined materials. For more information,
see Create and modify user-defined materials (page 679).

In Trimble Connect Visualizer, you can currently only render the material type
of objects, not their material finish. This means that paints or other finishes
are not visible in Trimble Connect Visualizer.

To set the material type mappings used in Trimble Connect Visualizer:

1. On the View tab in Tekla Structures, click the arrow on the right side of
Visualize.

2. On the menu, select  Visualizer material type mapping.

3. In the lists on the right side of the related Tekla Structures materials,
select the Trimble Connect Visualizer material types that you want to map
to. 

Selecting the blank option renders the color of the Tekla Structures class
as a material that is similar to plastic. The blank option can be useful if
you need to show the class colors to communicate an aspect of the
structural design.
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4. To override the Tekla Structures material of particular model objects in
Trimble Connect Visualizer:

a. In the model, select the objects.

b. In the Override Visualizer materials of selected objects list, select
the material that you want to use for visualizing the selected objects.

c. Click Set.

The selected override material is stored to the model objects' 
VISUALIZER_MATERIAL user-defined attribute, which you can see by
inquiring the object properties (page 686).

5. Click OK to update the material type mapping.

6. To save the material type mapping as an XML file, do either of the
following: 

To Do this
Save the material
mapping to the model
folder

• When Tekla Structures asks you if you want to
save the material mapping to the model, click
Yes.

The material type mapping is saved in the model
folder under the \attributes folder. The file
name is VisualizerMaterials.tcv11.

The material type mapping is saved for all users of
the model, including the users that edit the model
using Tekla Model Sharing or the multi-user mode.

NOTE To avoid issues, do not modify the colors in
the VisualizerMaterials.tcv11 file
manually.

Save the material
mapping to local
application data

• When Tekla Structures asks you if you want to
save the material mapping to the model, click
No.

The material type mapping is saved in the \Users
\<user>\AppData\Local\Trimble\Tekla
Structures\<version>\Trimble Connect
Visualizer folder. The file name is
VisualizerMaterials.tcv11.

The material type mapping now applies to all
projects that you are working on.

NOTE To avoid issues, do not modify the colors in
the VisualizerMaterials.tcv11 file
manually.

Check the model 678 Visualize the model with Trimble Connect
Visualizer



To Do this

Create and modify user-defined materials
You can create your own customized materials in Trimble Connect Visualizer
with the material editor. The customized materials can be used in Trimble
Connect Visualizer material mapping in the same way as pre-defined
materials.

NOTE User-defined materials are not shared to other users with Tekla Model
Sharing. Any objects that use user-defined materials appear with their
class colors to other users.

To create or modify user-defined materials:

1. Visualize the model. (page 669)

2. To open the material editor, click  on the Trimble Connect Visualizer
side pane. 
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The material editor contains the following elements:
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(1) List of user-defined materials

(2) Material name box

(3) Texture picker

(4) Scaling or tiling of the selected texture

(5) RGB color values

(6) Transparency

(7) Roughness

(8) Metallic look

(9) Bump strength

(10) Preview of the material

3. Do one of the following: 

• To create a new material, type a name in the material name box.

• To modify an existing user-defined material, select the material in the
list of user-defined materials.

4. In the material editor, do any of the following: 

To Do this
Add a texture a. Click the texture picker.

b. Click the texture that you want to use.

Note that you can only use textures that are
saved in the C:\Users\<user>\Pictures
\TrimbleConnectVisualizer\Textures
folder as .png or .jpg images.

To reset the material texture, click X at the upper-
right corner of the texture picker.

Adjust scaling or tiling of
texture, RGB colors,
transparency,
roughness, metallic look,
or bump strength

Either drag the related slider, or type the desired
value in the related box.

Preview all objects with
the current user-defined
material settings

Click .

To reset the objects to use their original materials,

click .

5. To save the material, click . 
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User-defined materials are saved in the C:\Users\<user>\AppData
\Local\TrimbleConnectVisualizer\CustomMaterials folder.

Each user-defined material is defined using the following files:

• <Material name>.xml

• <Material name>_DiffuseMap.png

• <Material name>_NormalMap.png

• <Material name>_RoughnessMap.png

Note that the name of the material file and the material name in the .xml
file need to be the same.

To avoid issues, do not modify any of the material files manually.

4.3 Fly through the model
Using the Fly command, you can travel through a model, changing direction
and varying the speed as you go. You can also adjust the field of view setting,
which can be useful when flying in a tight space.

1. Set view projection to Perspective.

a. Double-click the view to open the View Properties dialog box.

b. In the Projection list, select Perspective.

c. Click Modify.

2. If needed, adjust the field of view setting. 

The bigger the value, the more distance there is between the parts when
you fly through the model.

a. On the File menu, click Settings --> Advanced options , and go to
the Model views category.

b. Modify the advanced option XS_RENDERED_FIELD_OF_VIEW.

c. Click OK.

3. On the View tab, click Fly.

4. Select a view. 

The mouse pointer changes into an arrow and a cross. The arrow
indicates the current flying direction.
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5. Drag the mouse to move around in the model. 

• To fly forward, move the mouse forward.

• To change the flying direction, drag the mouse in the desired direction.

The flying speed grows exponentially when you are approaching the
model from a distance.

• To move up or down, hold down Ctrl and drag the mouse forward or
backward.

• To change the camera angle, scroll with the mouse wheel.

• To fly in the in the direction of the camera angle, hold down Shift and
scroll forward or backward.

6. To stop flying, press Esc.

4.4 Create clip planes
Clip planes enable you to focus on the required detail in the model. You can
either create clip planes by selecting an object face, or create clip planes that
are based on the view depth.

Create a clip plane
You can create up to six clip planes in any model view that shows the object
faces.

1. When you create clip planes, ensure that you are using a model view that
shows object faces. 

On the View tab, click Rendering, and use any of the following options:

• Parts shaded wireframe (Ctrl+2)

• Parts grayscale (Ctrl+3)

• Parts rendered (Ctrl+4)

• Components shaded wireframe (Shift+2)

• Components grayscale (Shift+3)

• Components rendered (Shift+4)

• References shaded wireframe (Ctrl+Shift+2)

• References grayscale (Ctrl+Shift+3)

• References rendered (Ctrl+Shift+4)

2. On the View tab, click Clip plane .
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3. Move the mouse pointer over the model objects. 

A green symbol indicates the object faces that you can select and align the
clip plane with. The green line indicates the side that will be clipped out.
For example:

Note that the snap depth setting on the Snapping toolbar affects the
object faces you can select. Set snap depth to 3D or Auto to select object
faces in the entire 3D space.

4. Select an object face. 

The clip plane symbol appears in the model:

5. Repeat step 4 to create as many clip planes as needed.

6. To finish creating clip planes, press Esc.

7. To move a clip plane, select the clip plane scissor symbol and drag it to a
new location. 

8. If you want to move the clip plane scissor symbol to a new location on a
clip plane, hold down Shift and drag the symbol. 

This does not move the clip plane, only the scissor symbol.

9. You can delete the clip planes when you do not need them anymore. 
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• To delete a single clip plane, select the clip plane symbol and press
Delete.

• To delete all the clip planes in all the open views, click View --> Clip
plane --> Delete all clip planes .

Create a view depth clip plane
If the model objects do not fit to the work area view depths, you can create
view depth clip planes on the contextual toolbar.

Based on the view depth, you can, for example, easily isolate an entire floor
from a building. View depth clip planes can be created both in native Tekla
Structures models as well as in reference models and overlay models.

1. If needed, modify the view depth of the current view on the contextual
toolbar.

2. On the contextual toolbar, click Add or update view depth clip planes

.

3. If you want to remove the view depth clip planes, click Remove view

depth clip planes  on the contextual toolbar, or click View --> Clip
plane --> Delete all clip planes. 

Note that the work area box may have gaps to view depths, and when
working with overlay models, you can clip models that are outside the
work area.

Limitations:

• You cannot move the view depth clip planes by dragging the clip plane to a
new location. This is because the view depth clip planes are strictly
connected to the view depth.

• After you have adjusted the view depth, click the Add or update view
depth clip planes button to manually update the view depth clip plane.
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4.5 Show parts, components, or assemblies in a selected
view angle
In some cases it is useful to examine parts, components, or assemblies in a
selected view angle. For example, when you reinforce concrete elements, you
can easily check the distances between the reinforcing bars.

Limitation:

The View angle option is not available for:

• detail system components

• detail custom components

• custom seams

1. Select an object.

2. Click  View angle on the contextual toolbar.

3. Select a top, back, right, bottom, front, or left view. 

Tekla Structures displays the object in the selected view angle. Note that
the full object is not always displayed.

For parts, the view angle is based on the selected object's coordinate
system, so that the top view is looking to the negative z-direction. For
example, if you select the top view, Tekla Structures sets the current view
angle from up to down in the coordinate system.

For assemblies and components, the view angle is based on the assembly
main part's coordinate system. Because of that, the object may not always
appear as expected in the selected view angle.

4. To return to the original 3D view, click the button in the middle of the view
angle options.

NOTE Tekla Structures shows the object in the current view, which is the view
where your mouse has last been. If the contextual toolbar is located,
for example, on top of two views, the object is shown in the view
where your mouse has last been and not in the view where the object
was selected.

See also

Adjust how model objects are displayed (page 642)

4.6 Inquire object properties
Use the Inquire commands to get information about a particular object, or a
group of objects, within the model.
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Do any of the following:

To inquire Do this
Object properties 1.

On the ribbon, click  Object.

2. Select an object.

Tekla Structures displays the object properties
in a separate window.

Point coordinates 1. On the ribbon, click the down arrow next to

, and then select Point coordinates.

The Inquire point coordinates dialog box is
displayed.

2. Click Pick, and then pick a point in the model
to see the coordinates of the point in:

• Local coordinates

• Model coordinates (global)

• Project base point coordinates

• Current base point coordinates
Center of gravity 1. On the ribbon, click the down arrow next to

, and then select Center of gravity.

2. Select one or more parts or reinforcement
objects.

Tekla Structures creates a point at the center
of gravity of the selected objects, and displays
information about the center of gravity in a
separate window.

Object properties using
custom reports

See Custom inquiry (page 689).

Welded parts 1. On the ribbon, click the down arrow next to

, and then select Welded parts.

2. Select a part.

Tekla Structures highlights the selected part
and all the parts that are welded to it.

Primary welded parts 1. On the ribbon, click the down arrow next to

, and then select Primary welded part.
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To inquire Do this
2. Select a part.

Tekla Structures highlights the primary part
when you select a secondary part.

Assembly, cast unit, or
rebar assembly objects

See Check and highlight objects in an assembly
(page 428), Check and highlight objects in a cast
unit (page 430), or Check and highlight objects in a
rebar assembly (page 618).

Component objects 1. On the ribbon, click the down arrow next to

, and then select Component objects.

2. Select a component.

Tekla Structures highlights all objects
belonging to the selected component.

Phases
On the ribbon, click the down arrow next to ,
and then select Phases.

Tekla Structures displays information about objects
in different phases in a separate window.

Model size Tekla Structures displays the quantity of all objects
in the current model in a separate window.

On the ribbon, click the down arrow next to ,
and then select Model size.

See also

Object property report templates (page 688)

Object property report templates

When you view object properties using the Inquire object command, Tekla
Structures uses the following report templates:

Object type Template
Assemblies TS_Report_Inquire_Assembly.rpt
Bolts TS_Report_Inquire_Bolt.rpt
Cast units TS_Report_Inquire_Cast_Unit.rpt
Parts TS_Report_Inquire_Part.rpt
Pour breaks TS_Report_Inquire_Pour_Break.rpt
Pour objects TS_Report_Inquire_Pour_Object.rpt
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Object type Template
Pour units TS_Report_Inquire_Pour_Unit.rpt
Rebar assemblies TS_Report_Inquire_Rebar_Assembly.rpt
Reinforcement meshes TS_Report_Inquire_Rebar_Mesh.rpt
Rebar sets TS_Report_Inquire_Rebar_Set.rpt
Reinforcement strands TS_Report_Inquire_Rebar_Strand.rpt
Reference models TS_Report_Inquire_Reference.rpt
Reinforcement TS_Report_Inquire_Reinforcement.rpt
Surfaces TS_Report_Inquire_Surface.rpt
Welds TS_Report_Inquire_Welding.rpt

When Tekla Structures is installed in the ..\Program Files folder, these
templates are by default available in the folder ..\ProgramData\Trimble
\Tekla Structures\<version>\environments\common\system.

You can copy these templates to your project or firm folder and then modify
the copied templates according to your needs. For more information on how
to use templates, see the Template Editor user documentation.

You can also create a custom template for connections and details by saving
the template with the name TS_Report_Inquire_Connection.rpt.

See also

Inquire object properties (page 686)

Custom inquiry
You can use the Custom inquiry command to display information about the
selected model object in the side pane. You can define what information you
want to display.

Use the Custom Inquiry tool

1. Click the Custom Inquiry button  in the side pane. 

Alternatively, you can click the down arrow next to  on the ribbon,
and then select Custom inquiry.

The Custom Inquiry window opens in the side pane.

2. In the Report type list, select the report template you want to use for
showing the object information.

3. Select a model object. 
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Tekla Structures displays the object properties in the side pane.

If you select several objects or object types, for example parts, bolts, and
reinforcing bars, Tekla Structures displays the quantity of all the selected
objects, regardless of the object types, or the report template used. For
the object properties that differ, Tekla Structures shows Varies.

Define what information is shown by Custom Inquiry tool
You can define what information is displayed in the Custom Inquiry side pane
window. You can add and modify report templates and the attributes in them.

1. Click the Custom Inquiry button  in the side pane. 

Alternatively, you can click the down arrow next to  on the ribbon,
and then select Custom inquiry.

The Custom Inquiry window opens in the side pane.

2. Click the  button. 

The Manage contents dialog box appears.

The Attributes list contains the attributes that are available by default. In
the Calculated attributes area you can create your own attribute
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formulas. The Contents of Custom Inquiry list contains the attributes
whose values will be displayed in the side pane.

3. Define which report templates and attributes are available. 

• To modify an existing report template, select it from the top left-hand
list in the Manage contents dialog box.

• To create a new report template, enter a name in the box next to the

 button, and then click .

• To modify the default attributes, edit the InquiryTool.config file.

For example, you can change the units of the attributes.

• To create a new calculated attribute, click the  button below the
Calculated attributes area. To modify a calculated attribute, double-
click a cell in the Calculated attributes area. In the Attribute cell,
type the name of the attribute. In the Equation cell, use attribute
names and standard mathematical symbols (+, -, *, and /) to form
equations.

4. Define which attributes are shown in the Custom Inquiry side pane
window. 

• To add more attributes to the side pane, select an attribute in the

Attributes or Calculated attributes list and then click the 
button.

• To remove attributes from the side pane, select an attribute in the

Contents of Custom Inquiry list and then click the  button.

• To change the order of the attributes, use the  buttons.

• To change the formula of an attribute, click the down arrow and select
a different formula (Sum, Average, Max, or Min) from the list.

5. Click  to save the changes.

Modify the default attributes in InquiryTool.config file
Use the InquiryTool.config file to control which attributes are shown as
default attributes in the Manage contents dialog box in the Custom Inquiry
tool.

NOTE This section is for advanced users.

Tekla Structures searches for the InquiryTool.config file in the following
folders in the following order:

1. \attributes folder in the model folder
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2. \CustomInquiry subfolder in the folder defined by XS_PROJECT

3. \CustomInquiry subfolder in the folder defined by XS_FIRM

4. \CustomInquiry subfolder in the folder defined by XS_SYSTEM

If you specify several folders that have \CustomInquiry as a subfolder, Tekla
Structures uses the first folder it finds.

To add new attributes to the InquiryTool.config file:

1. Open the InquiryTool.config file in any standard text editor.

2. Copy the entire contents of [ATTR_CONTENT_??] to the end of the file.

3. Change the position number of the new attribute. 

For example, change [ATTR_CONTENT_??] to [ATTR_CONTENT_66].

4. Modify the NAME, DISPLAY_NAME, DATATYPE, UNIT, and DECIMAL values
of the new attribute. Use the attribute names and definitions that are
included in the contentattributes_global.lst or
contentattributes_userdefined.lst file.

5. Change the TOTAL_ATTR_CONTENT value to reflect the total number of
attributes in the file. 

For example, change TOTAL_ATTR_CONTENT=65 to 
TOTAL_ATTR_CONTENT=66.

6. Save the file.

4.7 Measure objects
Use the Measure commands to measure angles, arcs, the distance between
two points and between bolts in the model.

All measurements are temporary. The measurements appear in the model
view window until you update or redraw (page 46) the window.

The units depend on the settings in File menu --> Settings --> Options -->
Units and decimals .

Measure distances
You can measure horizontal, vertical and user-defined distances in the model.

1. Press Ctrl+P to switch to the plane view.

2. On the Edit tab, click Measure and select one of the following commands:
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• Distance

This command measures the distance between any two points. Use
this command to measure inclined or aligned distances. By default, the
results contain the distance and the coordinates.

• Horizontal distance

This command measures the distance between two points in the
direction of the view plane x axis.

• Vertical distance

This command measures the distance between two points in the
direction of the view plane y axis.

3. Pick the start point.

4. Pick the end point.

5. Pick a point to indicate on which side of the dimension line you want the
measurement to appear. 

The measurement is displayed until the next window update or redraw
(page 46).

Measure angles
You can measure angles in the model.

1. On the Edit tab, click Measure --> Angle .

2. Pick the center point.

3. Pick the start point.

4. Pick the end point. 

The measurement is displayed until the next window update or redraw
(page 46).

Measure arcs
You can measure the radius and length of an arc in the model.

1. On the Edit tab, click Measure --> Arc .

2. Pick the start point.

3. Pick the middle point. 

This can be any point along the arc between the start and end points.

4. Pick the end point. 
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The measurement is displayed until the next window update or redraw
(page 46).

(1) Start point

(2) Middle point

(3) End point

(4) Arc radius

(5) Arc length

Measure bolt spacing
You can measure distances between bolts in a bolt group. Tekla Structures also
gives you the edge distances between the bolts and a selected part.

1. On the Edit tab, click Measure --> Bolt spacing.

2. Select a bolt group.

3. Select a part. 
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The measurement is displayed until the next window update or redraw
(page 46).

4.8 Detect clashes
Use the Clash Check Manager tool to find objects that collide or that are too
close to each other.

Clash Check Manager can check clashes within native Tekla Structures
models, within reference models, and between the objects in these models.

Use the clash check settings to define clearances between different model
objects.

For information on point cloud clash check, see the instructions about
modifying point cloud properties and visualization settings.

You can also use the sections and floors created in Organizer to run a
controlled clash check.

If you want to use another Tekla Structures model as a reference model, you
must export it in the IFC format to be able to use it in clash check. The
following reference model file types are supported in clash check:

• IFC

• IFC4

• DWG
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• DGN

• SKP

• .tekla (overlay models excluded)

See also

Find clashes in a model (page 696)

Modify, view, and print clash check results (page 703)

Find clashes in a model
You can use clash check to find clashes between reference model objects and
pour objects, and between these objects and native Tekla Structures parts, and
inside reference models and Tekla Structures models.

Check the model for clashes

1. On the Manage tab, click Clash check .

2. In the Clash Check Manager dialog box, select the appropriate clash
check settings to determine what is included in the clash check. 

• Between reference models

Clashes between reference models are included in the clash check.

• Objects in reference models

Clashes within reference models are included in the clash check (bolts
and welds are not included).

• Between reference models and components

Clashes between reference models and components are included in
the clash check.

When you have the whole component and this setting selected, the
component parts are included in the clash check.

Note that if you already have the Select objects in components
selection switch active to select the parts in the component, the
Between reference models and components setting does not have
any effect, even if you have the check box selected in Clash Check
Manager.

• Between parts

Clashes between native Tekla Structures parts are included in the clash
check.
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3. Set the Minimum distance between reference model objects and pour
objects, and between these objects and native Tekla Structures parts. 

Objects that are closer to each other than the set minimum distance are
reported in the clash check results. You can filter out minimum distance
type clashes from the clash check results by setting the minimum distance
value to 0.0.

You can define a minimum distance value within the range from 500 mm
to -500.0 mm. With a negative minimum distance, you can define how
much overlap is allowed without reporting a clash.

When checking the minimum distance, Clash Check Manager uses the
Tekla Structures units set in File --> Settings --> Options --> Units and
decimals.

Note that Tekla Structures uses a hard-coded tolerance when checking
clashes between native parts. If the native parts overlap less than 0.25
mm, clashes are not reported.

4. In the model, select the objects that you want to include in the clash
check.

5. In the Clash Check Manager dialog box, click  to check the objects. 

The status bar in Clash Check Manager indicates that clash check is in
progress.

Tekla Structures also displays a dialog box with a clash check progress bar.
The progress bar first shows the clash check progress for Tekla Structures
objects, and then for reference model objects and pours. You can cancel
the clash check in the dialog box.

When the clash check is finished, the status bar in the Clash Check
Manager dialog box shows a message about listing the clash check results
and a progress bar that indicates how long it will take to list all the clashes.
When the listing is complete, the status bar message changes to Ready.

6. If you want to include more objects in the clash check, select the desired
model objects and re-run the clash check. 

New clashes are appended to the end of the list.

7. After removing or modifying objects, re-run the clash check to see if the
clash still exists.

a. Select the desired clashes in Clash Check Manager.

b. Click  to re-run the clash check.

NOTE If you do not wish to check the entire model, you can use Organizer to select
the sections and floors for which you want to run the clash check. Select a
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section or a floor in the category tree in Organizer, right-click and select
Select in the model.

NOTE If you cannot find the clashes in the model, change the rendering of objects to
Show only selected part (Ctrl+5) for better visibility.

Note that clashes are not detected if the profiles and positions are identical.

Symbols used in clash check
Clash Check Manager uses symbols to indicate the state of a clash.

Flag
symbol

State Description

(none) Active The default state. The clash is not new, modified,
resolved, or missing.

New All clashes are marked as new when they are
found for the first time.

Modified If the object has been modified (for example, if
the profile has been changed), the state changes
to modified when you re-run the clash check.

Only certain object properties affect this flag. To
see which properties have an effect, right-click
one of the column headings. Both visible and
hidden properties affect the flag.

Resolved If the objects no longer clash, the state changes
to resolved when you re-run the clash check.

Missing If one or both of the clashing objects have been
removed from the model, the state changes to
missing when you re-run the clash check.

About clash types
Tekla Structures shows the type of each clash in the Type column in the Clash
Check Manager dialog box.
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The following clash types can occur:

Type Description Example
Clash The object partly

overlaps with
another object.

Clash Two identical
objects overlap
completely.
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Type Description Example
Clash Objects intersect

with each other in
several locations.

Clash The object cuts
through another
object.
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Type Description Example
Is inside The object is

inside another
object.

Min distance The objects are
closer to each
other than the
defined minimum
distance.

The minimum
distance is used
between
reference model
objects and pour
objects, and
between these
objects and native
Tekla Structures
parts. Minimum
distance is not
used between
native Tekla
Structures parts
only.

Open and save clash check sessions
Clash check sessions are saved as .xml files in
the ..\TeklaStructuresModels\<model>\Clashes folder. Tekla
Structures creates the folder automatically when you open Clash Check
Manager for the first time.

To open or save sessions in Clash Check Manager, do any of the following:
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To Do this
Save the current session

Click  in the Clash Check
Manager dialog box.

Open a session 1.
Click  in the Clash Check
Manager dialog box.

2. In the Open dialog box, select a
session.

3. Click Open.
Start a new session

Click  in the Clash Check
Manager dialog box.

Clash Check Manager clears the list
of clashes without running a clash
check.

If you already have clashes listed in
the Clash Check Manager dialog box,
selecting or clearing the check box of
the Between reference models,
Between reference models and
components, Objects in reference
models, Between parts, or
Minimum distance setting will start a
new clash check session. Tekla
Structures displays a dialog box
asking whether you want to save your
current clash check session.

Save the current session with another
name or in another location

1.
Click the arrow  next to the 
button in the Clash Check
Manager dialog box.

2.
Click Save as .

3. In the Save as dialog box, browse
to the folder where you want to
save the session.

4. In the File name box, enter a
new name.

5. Click Save.
Save only selected clashes 1. In the Clash Check Manager

dialog box, select the clashes that
you want to save.
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To Do this
2.

Click the arrow  next to the 
button.

3.
Click Save selected .

Modify, view, and print clash check results
You can modify, view, and print clash check results in the Clash Check
Manager dialog box.

To open the Clash Check Manager dialog box, go to the Manage tab on the

ribbon and click Clash check .

Modify clash check results
You can change the status and priority of clashes, group and ungroup clashes,
and add comments for clashes in the Clash Check Manager dialog box.

To Do this
Change the status of a clash 1. Select the clash whose status you

want to change.

2. Right-click on the Status column.

3. Select a suitable status.
Change the priority of a clash 1. Select the clash whose priority

you want to change.

2. Right-click on the Priority
column.

3. Select a suitable priority.
Group and ungroup clashes You can combine several clashes into

a group so that the clashes are
treated as a single unit.

1. Select the clashes that you want
to group.

2. Right-click and select Group -->
Group .

3. If you want to add clashes to a
group that already exists, select
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To Do this
the clashes and the group, and
then repeat step 2.

Note that you cannot create
nested groups of clashes.

4. If you want to ungroup clashes:

a. Select the clash group to
ungroup.

b. Right-click and select Group
--> Ungroup .

Add, modify, and remove comments
for a clash

You can add comments for clashes
and clash groups. For example, you
might want to use comments as
reminders to yourself and other
users. You can modify the comments
and remove them.

1. Select the clash or clash group
for which you want to add a
comment.

2. Right-click and select Clash
Information.

3. Go to the Comments tab.

4.
Click  to open the Add
comment dialog box.

5. Enter your comment in the
Comment box.

6. Modify the author name and the
date, if needed.

7. Click OK.

To modify a comment, select the
comment in the Clash Information

dialog box and click .

To delete a comment, select the
comment in the Clash Information

dialog box and click .
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View clash check results
You can search for clashes, and view the history and other details of a clash in
the Clash Check Manager dialog box.

To Do this
Search for clashes Use the Search box to find clashes.

The more search terms you enter, the
more refined your search will be. For
example, if you enter column 8112,
only the clashes that match both of
these terms are displayed.

1. Open the clash check session
from which you want to find
clashes.

2. In the Search box, enter the
words to search for.

The search results are displayed
as you type.

3. To narrow down your search,
enter more characters.

4. To display all clashes again, click
 next to the Search box.

To zoom in the active view To zoom in the active view so that the
selected objects are shown in the
center of the view, double-click a
clash in Clash Check Manager.

To zoom in on and highlight a
clashing object

To zoom in on and highlight a
clashing object when there is only one
clash, right-click the clash in Clash
Check Manager and select Clash
Information.

View the history of a clash You can view the history of a
particular clash. For example, you can
view when and by whom the clash
was detected.

1. Select a clash or a clash group.

2. Right-click and select Clash
Information.

3. Go to the History tab to view the
history information.

View the details of a clash You can view the details of a clash,
such as the profile, material and class
of the objects that collide. This can be
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To Do this
useful especially when you view clash
groups that contain more than two
objects.

1. Select the clash or clash group
whose details you want to view.

2. Right-click and select Clash
Information.

You can view the details of one
clash or clash group at a time. If
you select more than one clash
or clash group, the Clash
Information option is disabled.

Show or hide a column in Clash
Check Manager

1. Right-click one of the column
headings to open a menu.

2. Click any of the list items to show
or hide them.

A check mark  in front of the
item indicates that it is visible.

Click the heading of the desired
column to alternate between
ascending and descending sort order.

Print clash check results
You can print the clash check results from the Clash Check Manager dialog
box. You can control the print settings in the same manner as in any standard
Windows application.

To Do this
Print the clash check results 1.

Click  to open the clash check
session that you want to print.

2.
Click Print....

3. If needed, modify the print
settings.

4. Click Print....
Preview before printing 1.

Click the down arrow next to 
and select Print preview....

2. Click one of the page layout

buttons  to
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To Do this
select how many pages to view at
a time.

3. Click  to print the current
page.

Define the page setup
Click the arrow  next to the 
button and select Page setup.

4.9 Compare parts or assemblies
You can compare two selected parts or assemblies to check, for example, if
they get the same position number.

1. Select the objects you want to compare. 

• To compare parts, select two parts in the model.

• To compare assemblies, select a part in each assembly.

2. On the Edit tab, click Compare, and then select either Compare parts or
Compare assemblies. 

Tekla Structures displays the results on the status bar. For example, you
may get a message that the part geometry differs or parts are positioned
differently in the assembly.

See also

Check the model (page 666)

4.10 View solid errors
You can view solid errors in a log file. This may be needed, for example, if
overlapping volumes and faces occur for parts and pour objects, and you need
to analyze the error.

1. On the File menu, click Logs --> Session history log .

2. Look for rows that start with the phrase Solid error.

3. Click the corresponding Solid failure position row to show the
solid object error. 
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A diamond-shaped position locator is displayed in the model to point you
to the error.

TIP When you click a Solid error row in the log file, hold down the z
key to center the view to the error location.

4. Redraw the view to hide the position locator.

See also

Troubleshoot pours (page 464)

4.11 Diagnose and repair the model
Use the Diagnose & repair commands to check and to repair errors and
inconsistencies in the structure of model objects and the library database
(xslib). By diagnosing and repairing the model you can ensure, for example,
that empty assemblies are removed and that unused points and attributes are
deleted. Repairing the model also corrects invalid object relations and
hierarchies. We recommend you to diagnose and to repair your model
regularly to maintain the consistency and integrity of your model databases.

1. On the File menu, click Diagnose & repair.

2. Select the appropriate diagnose command. 

The errors and inconsistencies found in the model are listed in a report.
Some of them are automatically corrected, some of them are warnings
that you need to correct manually.

If a profile, material grade, bolt element or assembly, or reinforcement
seems to be missing from the corresponding catalog, your Tekla
Structures environment or a catalog file may not be the same as the
model's original one.

If there are solid errors (page 707) in the model objects, these errors are
listed in the report. The report is updated every time you run the
Diagnose model command. (Solid errors are also listed in the session
history log file TeklaStructures_<user>.log.)

The following table lists the most common errors and inconsistencies
found when diagnosing the model.
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Diagnosis result Description Action needed
Empty assembly The assembly

does not contain
any objects.

a. On the File menu, click Diagnose
& repair.

b. Under Model, click Repair model
to delete the assembly.

Missing assembly A part is not
included in any
assembly.

a. On the File menu, click Diagnose
& repair.

b. Under Model, click Repair model
to create an assembly and to
move the part to it.

Illegal profile An unknown
profile has been
found.

a. Ensure that you are using the
correct Tekla Structures
environment.

b. Use the model's original
profdb.bin and profitab.inp
files and save them in the model
folder.

c. Reopen the model.
Illegal material An unknown

material grade
has been found.

a. Ensure that you are using the
correct Tekla Structures
environment.

b. Use the model's original
matdb.bin file and save it in the
model folder.

c. Reopen the model.
Illegal bolt An unknown bolt

element or bolt
assembly has
been found.

a. Ensure that you are using the
correct Tekla Structures
environment.

b. Use the model's original
screwdb.db and assdb.db files
and save them in the model
folder.

c. Reopen the model.
Illegal reinforcing
bar size or grade

Illegal
reinforcement
mesh

Reinforcement
with invalid
properties has
been found.

a. Ensure that you are using the
correct Tekla Structures
environment.

b. Use the model's original
rebar_database.inp and
mesh_database.inp files and
save them in the model folder.

c. Reopen the model.
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Diagnosis result Description Action needed
Invalid rebar
geometry

Reinforcement
with undefined
geometry has
been found.

See Check the validity of
reinforcement geometry (page 564).

Solid creation
failed

A model object
with invalid
geometry has
been found.

a. Ensure that you are using the
correct Tekla Structures
environment and profile catalog
files.

b. Try the following:

• If there are cuts and/or fittings in
the object, slightly adjust one of
them or the object.

• Check the pour geometry.
(page 464)

• Remodel the object.

If the model does not contain any errors or inconsistencies, a message is
displayed on the status bar.

See also

Check the model (page 666)

4.12 Find distant objects
When the work area is huge, the model may contain some distant objects that
are not easy to find. Use the Find distant objects command to find these
objects.

1. On the File menu, click Diagnose & repair.

2. Under Utilities, click Find distant objects. 

Tekla Structures displays a list of object GUIDs. At the end of the list, Tekla
Structures displays additional six objects that have the biggest and
smallest x, y, or z coordinates.

3. Select an object in the list.
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4. Right-click and select a command. 

You can, for example, inquire or delete the object.

See also

Check the model (page 666)
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5 Number the model

This section explains how to change numbering settings and apply numbering
in Tekla Structures.

Click the links below to find out more:

What is numbering and how to plan it (page 712)

Adjust the numbering settings (page 721)

Number parts (page 722)

Change existing numbers (page 725)

Clear existing numbers (page 726)

Check the numbering (page 727)

View the numbering history (page 729)

Repair numbering errors (page 730)

Renumber the model (page 730)

Control numbers (page 731)

Number parts by design group (page 738)

Numbering examples (page 741)

5.1 What is numbering and how to plan it
Before you can create drawings or accurate reports, you need to number all
parts in the model. You do not need to number the model before you create
general arrangement drawings.

Numbering is the key to the production output, for example, drawings, reports,
and NC files. Numbers are also needed when you export models. Part
numbers are vital in the fabrication, shipping, and erection stages of
construction. Tekla Structures assigns a mark to each part and assembly/cast
unit in a model. The mark includes part or assembly prefix and position

Number the model 712 What is numbering and how to plan it



number, and other elements, such as profile or material grade. It is useful to
identify the parts with numbers to see which parts are similar and which
different. Identical parts within a numbering series have the same number,
which makes the planning of the production easier.

We recommend that you plan the numbering in an early phase of the project.
If other users are using the same model, it is even more important to make a
numbering plan that everybody in the project follows. You should have the
numbering ready before you create the first drawings and reports.

When planning the numbering, it can be useful to number the model in
phases, for example first floor of the building first, then the second, and so on.

Give start numbers in wide ranges so that you do not run out of numbers
within a numbering series, and that any numbering series does not overlap
with another. For example, start the first floor with the start number 1000 and
the second with start number 2000.

If the numbering of a part or assembly is not up to date, a question mark (?) is
displayed in the part label and in the Inquire object dialog box, for example:

See also

Numbering series (page 713)

Identical parts (page 716)

Identical reinforcement (page 717)

Define what affects numbering (page 718)

User-defined attributes in numbering (page 719)

Family numbers (page 719)

Inquire object properties (page 686)

Numbering series
Use numbering series to divide steel parts, assemblies, and cast units into
groups. For example, you can allocate a separate numbering series to each
phase or part type. Using separate numbering series for different parts speeds
up the numbering operation.

The name of a numbering series consists of a prefix and a start number. You do
not always have to define a part prefix (for example, you may want to omit the
part prefix for minor parts).
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When you run numbering, Tekla Structures compares parts that belong to the
same series with each other. All identical parts in the same numbering series
are given the same part number.

NOTE Concrete parts are numbered according to the cast unit numbering settings.
For example, if the cast unit prefix is C and the start number is 1, concrete
parts will get the part prefix Concrete_C-1.

This applies also to concrete components whose part position prefix is
Concrete and start number is 1.

Example

For example, if you define a numbering series with the prefix P and start
number 1001, Tekla Structures numbers that series P1001, P1002, P1003, ...

See also

Plan your numbering series (page 714)

Assign a numbering series to a part (page 715)

Assign a numbering series to an assembly (page 715)

Overlapping numbering series (page 716)

Family numbers (page 719)

Plan your numbering series
Before you start modeling, it is a good idea to plan the numbering prefixes and
start numbers you will use for the entire project. Careful planning prevents
numbering conflicts.

To save time, include the numbering series in the default part properties for
each type of part before you start modeling.

You may want to omit the part prefix for minor parts, such as plates. If you do
this, ensure that you assign a Start number for that numbering series so that
it will not overlap other parts.

Example

One way to plan the numbering series is to create a table:

Part type Part

Prefix

Part

Start number

Assembly

Prefix

Assembly

Start
number

Beam PB 1 AB 1
Vertical brace PVB 1 AVB 1
Horizontal brace PHB 1 AHB 1
Rafter PR 1 AR 1
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Part type Part

Prefix

Part

Start number

Assembly

Prefix

Assembly

Start
number

Purlin PP 1 AP 1
Column PC 1 AC 1
Plate  1001 A 1

See also

Numbering series (page 713)

Overlapping numbering series (page 716)

Assign a numbering series to a part
1. Double-click a part to open the part properties in the property pane.

2. Go to the Numbering series section. 

If you are assigning a cast unit numbering series to a concrete part, go to
the Cast unit section.

3. Define a part prefix and a start number.

4. Click Modify.

See also

Assign a numbering series to an assembly (page 715)

Numbering series (page 713)

Assign a numbering series to an assembly

To assign a numbering series to an assembly:

To Do this
To assign a numbering series
to an assembly according to
its main part

1. Check what is the main part of an
assembly.

a. On the ribbon, click the down arrow

next to , and then select
Assembly objects.

b. Select the assembly.

Tekla Structures highlights the main
part in orange.

c. Press Esc.
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To Do this
2.

Ensure that the  Select objects in
assemblies selection switch is active.

3. Double-click the assembly main part to
open the part properties in the property
pane.

4. Under Numbering series, define an
assembly prefix and a start number.

5. Click Modify.
To assign a numbering series
to an assembly by using the
assembly properties

1.
Ensure that the  Select assemblies
selection switch is active.

2. Double-click an assembly to open the
assembly properties in the property
pane.

3. In the Assembly numbering boxes,
define an assembly prefix and a start
number.

4. Click Modify.

See also

Assign a numbering series to a part (page 715)

Numbering series (page 713)

Overlapping numbering series
When you plan numbering, ensure that you reserve enough numbers for each
series. If a series overlaps another, Tekla Structures numbers only one of the
objects that would have overlapping numbers and leaves the other object
unnumbered.

Tekla Structures warns you about series overlaps. View the numbering history
log to check which numbers overlap, and then adjust the numbering prefixes
and start numbers so that the series will not overlap anymore.

See also

Numbering series (page 713)

View the numbering history (page 729)
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Identical parts
Tekla Structures gives parts the same number if the parts are identical in the
fabrication or casting. If a part is deformed after fabrication or casting (for
example if the part is cambered, shortened, or warped), the final geometry on
site and in the model may be different.

Tekla Structures treats parts as identical and gives them the same number if
the following basic part properties are the same:

• Part geometry

• Casting direction

• Numbering series

• Profile

• Material

• Finish

• Shortening

You can set the degree of tolerance for part geometry in the Numbering
Setup dialog box. If the geometry of parts differs within this degree of
tolerance, Tekla Structures treats the parts as identical for numbering
purposes.

Class does not affect numbering. Tekla Structures gives the same number to
identical parts that belong to different classes.

If you have created NC files, pop marks and contour marking affect
numbering.

See also

Casting direction (page 434)

Define what affects numbering (page 718)

User-defined attributes in numbering (page 719)

Identical reinforcement
Tekla Structures treats reinforcing bars as identical, and gives them the same
number, if the following properties are the same:

• Bar geometry

• Numbering series

• Size

• Grade

• Bending radius
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To specify how the geometry of reinforcing bars is taken into account in
numbering and which type of bar geometry (modeled, rationalized, or
fabrication) is used when bars are compared with each other, use the
advanced option XS_REBAR_GEOMETRY_TYPE_IN_NUMBERING.

Class does not affect numbering. Tekla Structures gives the same number to
identical reinforcing bars that belong to different classes.

The modeling direction of tapered reinforcing bar groups affects numbering.
This means that identical bar groups with different modeling directions receive
different numbers.

The bar length rounding, step tapering, and some other rebar set settings
affect bar geometry and thus the numbering of rebar set bars. The rounding
settings that are defined in the rebar_config.inp file for drawings and
reports do not affect numbering.

See also

Create reinforcement (page 469)

Define what affects numbering
To define which properties affect numbering in your model, modify the
settings in the Numbering Setup dialog box.

You can have Tekla Structures compare the following properties:

• Holes (if created with the Bolt command)

• Part name

• Beam orientation

• Column orientation

• Assembly name

• Assembly phase (XS_ENABLE_PHASE_OPTION_IN_NUMBERING set to TRUE)

• Reinforcement

• Embedded objects (affect only cast units)

• Surface treatment (affects only assemblies)

• Welds (affect only assemblies)

If these properties differ, Tekla Structures treats objects as different, and
therefore numbers them differently.
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For example, if two otherwise identical parts have different names and you
select the Part name check box, Tekla Structures gives the parts different
numbers.

By default, a part retains its number, as long as only one part has that
particular number, regardless of the settings in the Numbering Setup dialog
box.

See also

Adjust the numbering settings (page 721)

What is numbering and how to plan it (page 712)

Identical parts (page 716)

Identical reinforcement (page 717)

User-defined attributes in numbering (page 719)

General numbering settings (page 1005)

User-defined attributes in numbering
You can set in the objects.inp file whether a user-defined attribute affects
numbering or not. Tekla Structures treats parts and reinforcing bars as
different, and therefore numbers them differently, if the values of the user-
defined attribute differ.

NOTE Only user-defined attributes of parts and reinforcement can affect
numbering. User-defined attributes of other objects, such as phases, projects
and drawings do not affect numbering.

If you want Tekla Structures to consider a user-defined attribute when
numbering, set the special_flag option of the attribute to yes in the Part
attributes section of objects.inp. For reinforcement, you need to set 
special_flag to yes also in the Reinforcing bar attributes section.
Tekla Structures assigns different numbers to parts or reinforcement that are
otherwise identical but have different values for this user-defined attribute.

If you want Tekla Structures to ignore a user-defined attribute when
numbering, set the special_flag option to no in objects.inp.

See also

Examples of user-defined attributes (UDAs) for parts (page 323)

Select and change the profile or material of a part (page 320)

Define what affects numbering (page 718)
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Family numbers
With family numbering you can group objects within the same numbering
series into different “families”. This can be used, for example, to find similar
precast cast units that can be cast in the same bed.

Family numbering is not available for cast-in-place cast units.

When you use family numbering, the cast unit position numbers consist of a
family number and a qualifier. For example:

1. Family number

2. Qualifier

Assemblies and precast cast units that match the comparison criteria you
define in the Numbering Setup dialog box get the same family number.
However, if they have the same family number but different part geometry or
materials, they get unique qualifier numbers.

See also

Numbering series (page 713)

Assign family numbers (page 720)

Change the family number of an object (page 721)

Example: Use family numbers (page 741)

Assign family numbers
1. On the Drawings & reports tab, click Numbering settings -->

Numbering settings to open the Numbering Setup dialog box.

2. Go to the Family numbering tab.

3. Define which numbering series to assign family numbers to.

a. Click Add series to open the Add series dialog box. 

Tekla Structures displays all the assembly and cast unit numbering
series in the model.

b. Select a numbering series from the list, and then click Add. 

The numbering series appears in the family numbering list.

4. Under Compare, select the properties that need to be identical for the
members of the same family. 
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Define comparison criteria for each numbering series separately.

Select at least one check box, but not all of them. If you select all the check
boxes, the family number will be the same as the normal assembly
position, and the qualifier number will be 1 for all. If you do not select any
check boxes, only one family number per series is assigned.

5. Click Apply. 

Tekla Structures stores the settings in the numbering database file
(<model_name>.db2) in the current model folder the next time you save
the model.

6. If you are assigning family numbers to parts that have already been
numbered, clear the existing numbers.

7. Update numbering in the model. 

Tekla Structures assigns a family number to all objects in the numbering
series.

See also

Family numbers (page 719)

Clear existing numbers (page 726)

Change the family number of an object
You can change the family number and/or family qualifier of an object.

1. Select the objects whose family numbers you want to change.

2. On the Drawings & reports tab, click Change number --> Change family
number .

3. In the Assign Family Number dialog box, enter the desired values in the
Family number and Family qualifier boxes.

4. Click Assign.

See also

Family numbers (page 719)

5.2 Adjust the numbering settings
You can adjust the numbering settings to better suit your needs. This should
be done early in the project, before creating any drawings or reports. Do not
change your numbering conventions in the middle of a project.

1. On the Drawings & reports tab, click Numbering settings -->
Numbering settings to open the Numbering Setup dialog box.
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2. Modify the settings (page 1005) if necessary. 

For example, you can define which part properties affect numbering in
your model. Using the default settings is effective in most cases.

3. Click Apply or OK. 

NOTE Always check and repair numbering after you have changed the
numbering settings.

See also

Define what affects numbering (page 718)

Numbering settings during a project (page 746)

Repair numbering errors (page 730)

5.3 Number parts
Use the Number modified objects command to number all parts that have
been created or modified since the last numbering. If this is the first time you
run numbering for this model, all parts in the model are new and will therefore
be numbered.

To number new and modified parts:

• On the Drawings & reports tab, click Perform numbering --> Number
modified objects . 

Tekla Structures numbers the parts according to the numbering settings
(page 1005).

See also

Number a series of parts (page 722)

Number assemblies, cast units, and rebar assemblies (page 723)

Number reinforcement (page 724)

Number welds (page 725)

Save preliminary numbers (page 725)

Number parts by design group (page 738)

Number a series of parts
Use the Number series of selected objects command to only number parts
that have a certain prefix and start number. This enables you to limit the
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numbering to certain series of objects only, which can be useful in large
models.

Before you start, we recommend that you plan the numbering series carefully,
and split the model into smaller numbering series, for example by area or
phase.

1. Select the parts that have the desired prefix and start number. 

Only parts that have the same prefix and start number as the selected
part will be numbered.

2. On the Drawings & reports tab, click Perform numbering --> Number
series of selected objects. 

Tekla Structures numbers all parts in the specified numbering series.

See also

Example: Number selected part types (page 743)

Example: Number parts in selected phases (page 744)

Number assemblies, cast units, and rebar assemblies
To number assemblies, cast units, and rebar assemblies, use the same
numbering commands as for numbering parts. Before numbering, you can
modify the sort order, which defines how assemblies, cast units, and rebar
assemblies are given their position numbers. Sorting does not affect part
position.

1. If needed, modify the sort order of assemblies and cast units.

a. On the Drawings & reports tab, click Numbering settings -->
Numbering settings to open the Numbering Setup dialog box.

b. Modify the sort order by selecting options from the Sort by and Then
by lists. 

The default sort order is XYZ. You have the following options:
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• The x, y or z coordinates of the main part of the assembly or cast
unit, or the main reinforcement object of the rebar assembly.

The sorting is based on the center of gravity (COG) location of the
assembly or cast unit. Tekla Structures finds the center of gravity
for each assembly and cast unit and compares them in the order
you defined.

• The user-defined attribute of an assembly or the main part

If your sorting is based on user-defined attributes, Tekla
Structures displays a list that includes all the available user-
defined attributes.

c. Click Apply or OK to save the changes.

2. If needed, modify the other numbering settings (page 1005).

3. On the Drawings & reports tab, click Perform numbering --> Number
modified objects to number the model.

NOTE If you add new parts in the model, parts that have already been numbered are
not renumbered to suit the sorting order. In this case you should check and
repair the numbering of those parts.

See also

Repair numbering errors (page 730)

Number reinforcement
To number reinforcement, use the same numbering commands as for
numbering parts.

To specify how the geometry of reinforcing bars is taken into account in
numbering and which type of bar geometry is used when bars are compared
with each other, use the advanced option
XS_REBAR_GEOMETRY_TYPE_IN_NUMBERING.

Before numbering rebar assemblies, you may want to modify the sort order
settings similarly as when numbering assemblies or cast units (page 723).

Note that reinforcement may affect the numbering of cast units. To force Tekla
Structures to give otherwise identical cast units different numbers if they have
different reinforcement, select the Reinforcing bars check box in the
Numbering Setup dialog box.

Part numbering and cast unit numbering do not affect the numbering of
reinforcement.

See also

Number parts (page 722)
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Identical reinforcement (page 717)

Define what affects numbering (page 718)

User-defined attributes in numbering (page 719)

Assign running numbers to reinforcement (page 566)

Number welds
Use the Number welds command to assign numbers to welds. Weld numbers
are displayed in drawings and reports.

1. On the Drawings & reports tab, click Perform numbering --> Number
welds to open the Weld Numbering dialog box.

2. If needed, modify the weld numbering settings (page 1007). 

For example, you can define whether to assign numbers for All welds or
Selected welds.

3. If you selected to assign numbers to certain welds only, select the welds.

4. Click Assign numbers to start numbering welds.

See also

Number parts (page 722)

Save preliminary numbers
Preliminary mark is a user-defined attribute that defines the part position
number. You can save the current part position numbers as preliminary
numbers for selected parts. The previous preliminary numbers are overridden.

1. Select the parts.

2. On the Drawings & reports tab, click Numbering settings --> Save
preliminary numbers .

The preliminary numbers appear on the Parameters tab in the parts' user-
defined attributes.

See also

Number parts (page 722)

5.4 Change existing numbers
Use the Change number commands to change the existing part, assembly,
multi-position, or family numbers into something you have defined yourself.
These commands do not change the numbering series of parts. To prevent
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drawing, modeling, and fabrication errors, Tekla Structures does not allow you
to use identical numbers for two different assemblies or parts.

1. On the Drawings & reports tab, click Change number and select one of
the following commands: 

• Change part number

• Change assembly number

• Change part multinumber

• Change assembly multinumber

• Change family number

The corresponding dialog box appears. For example, if you select the
Change assembly number command, the Assign Assembly Number
dialog box appears.

2. Select a part in the model.

3. In the dialog box that appeared (for example Assign Assembly Number),
click Get to view the current numbering properties of the part.

4. Enter the numbering properties you want to use for this part. 

Note that the position numbers you enter here are not absolute numbers.
For example, if the start number of the series is 100, the position
numbers refer to numbers in that series. Therefore, position number 1 is
actually 100, position number 2 is 101, position number 3 is 102, and so
on.

5. If you are changing the assembly number of selected parts, ensure that
the Assign to option is set to Selected objects only. 

Otherwise, all parts with the same original number will be renumbered.

6. Click Assign to change the number. 

If the number you specified is already in use, Tekla Structures displays a
warning and keeps the original number.

Tekla Structures also displays a warning if the position number is higher
than the highest current number. This is for information only and the
number is still changed.

See also

Number parts (page 722)

5.5 Clear existing numbers
Use the Clear commands to permanently remove the current position
numbers of parts. Next time you run numbering, Tekla Structures assigns new
numbers to these parts, irrespective of what their previous numbers were.
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1. Select the parts whose numbers you want to clear.

2. On the Drawings & reports tab, click Change number and select one of
the following commands: 

• Clear part and assembly numbers

• Clear part numbers

• Clear assembly numbers

• Clear reinforcing bar numbers

Tekla Structures removes the position numbers of the selected parts.

See also

Number parts (page 722)

5.6 Check the numbering
You can check the position numbers in many places:

• You can add the position numbers to the part labels.

1. In the model, make sure the Select views selection switch is active.

2. Double-click the background to open the View Properties dialog box.

3. Click Display... to open the Display dialog box.

4. Go to the Advanced tab and add Part position to the Part label.

5. Click Modify.

The part labels now contain the position numbers.

• You can check the part number in .
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• The drawing label can show the position number and the amount of
identical parts.

• You can use the Inquire commands.
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• You can create reports that list your assembly and part positions.

See also

Repair numbering errors (page 730)

5.7 View the numbering history
To view the numbering history:

• On the File menu, click Logs --> Numbering history log .

Tekla Structures displays the numbering log file.
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5.8 Repair numbering errors
We recommend that you check and repair numbering in the model every now
and then, especially before producing drawings or reports.

NOTE If you work with Tekla Model Sharing or in the multi-user mode, it is
very important that you repair numbering regularly.

1. On the Drawings & reports tab, click Numbering settings -->
Numbering settings to open the Numbering Setup dialog box.

2. Ensure that the option Compare to old is selected for New parts.

3. Ensure that one of the following options is selected for Modified parts: 

• Compare to old

• Keep number if possible

4. Click OK to save the changes.

5. Unless you want to repair the entire model, select the objects whose
numbering you want to repair.

6. On the File menu, click Diagnose & repair and select one of the following
commands under Numbering: 

• Diagnose and repair numbering: all

This command numbers all parts and assemblies, even the unmodified
ones.

• Diagnose and repair numbering: series of selected objects

This command numbers all parts and assemblies that have the same
prefix and start number as the selected part.

Note that Tekla Structures assigns the position number of the oldest
part or assembly to all identical parts, even if a newer part or assembly
has a smaller position number.

TIP To manually assign a certain position number on a part or
assembly, use the Change number command after repairing
numbering in the model.

See also

Change existing numbers (page 725)
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5.9 Renumber the model
Use the Renumber all option when the numbering needs to be started over.
This option permanently removes the existing position numbers and resets
them with new ones. Any existing drawings will also be removed.

1. On the Drawings & reports tab, click Numbering settings -->
Numbering settings to open the Numbering Setup dialog box.

2. Select the Renumber all check box.

3. Click Apply or OK.

4. On the Drawings & reports tab, click Perform numbering --> Number
modified objects .

5. When you are asked to confirm the renumbering of the model, click Yes. 

Tekla Structures renumbers the entire model.

See also

Change existing numbers (page 725)

Clear existing numbers (page 726)

5.10 Control numbers
Control numbers are additional numbers that can be used to identify parts in
a model. Use control numbers if you need to give additional, unique numbers
to assemblies or cast units, regardless of their position numbers.

Control numbers can be useful, for example, when delivering a large number
of similar wall elements to the site. To successfully pack and unpack the load,
you need to plan the order of the wall elements already when the order is
shipped. Although all of the wall elements may have the same cast unit
position number, you can assign a unique control number to each individual
wall element.

See also

Assign control numbers to parts (page 731)

Control number order (page 732)

Display control numbers in the model (page 734)

Remove control numbers (page 735)

Lock or unlock control numbers (page 736)

Example: Use control numbers to indicate the erection order (page 736)
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Assign control numbers to parts
1. On the Drawings & reports tab, click Numbering settings --> Assign

control numbers to open the Create control numbers dialog box.

2. Indicate which parts to assign control numbers to. 

• To number the entire model, do not select any parts.

• To only number specific parts, select the parts you want to number.

3. If you want to assign control numbers only to parts in a specific
numbering series:

a. In the Numbering list, select By numbering serie.

b. Enter the Prefix and Start number in the corresponding boxes.

4. Define the control numbers to be used.

a. In the Start number of control numbers box, enter the first control
number to be used.

b. In the Step value box, define the control number interval. 

For example, to assign the control numbers 2, 5, 8, 11, and so on,
enter 2 in the Start number of control numbers box and 3 in the
Step value box.

5. Use the Renumber list to specify how to treat parts that already have
control numbers. 

• Select No to keep the existing control numbers.

• Select Yes to replace the existing control numbers with new ones.

6. Use the First direction, Second direction, and Third direction lists to
define the order of control numbers.

7. In the Write UDA to list, select where to save the control numbers. The
control number will appear on the Parameters tab in the user-defined
attributes dialog box either for: 

• Assembly

• Main part

8. Click Apply to save the changes.

9. Click Create to number the parts.

See also

Control number order (page 732)

Control number settings (page 1008)
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Control number order
When you assign control numbers, you must define in what order to assign
them. The order is based on the location of each part on the global coordinate
system.

The options are:

• None

• X

• Y

• Z

• -X

• -Y

• -Z

With positive directions (X, Y, and Z), the parts with the lowest coordinate value
are numbered first. With negative directions (-X, -Y, and -Z), the parts with the
highest coordinate value are numbered first.

For example, if the first direction is X, the second direction is Y, and the third
direction is Z, numbering starts from the parts that have the lowest x
coordinate value. If multiple parts have the same x coordinate, also their y
coordinates are compared. If multiple parts have the same x and y
coordinates, also their z coordinates are compared.

Example

In the following example, the first direction is X and the second direction is Y.
The numbers 1–8 indicate the control numbers.
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See also

Assign control numbers to parts (page 731)

Display control numbers in the model
If the control numbers are not displayed in the model, you can set them visible
using the display settings.

1. Double-click the view to open the View Properties dialog box.

2. Click Display... and go to the Advanced tab.

3. Select the Part label check box.

4. In the Properties list, select User-defined attributes, and then click Add
>. 

The Part label dialog box is displayed.

5. Enter ACN and click OK. 

The property is moved to the Part label list.

6. Click Modify. 

The control numbers are displayed in the model, right after the part
position numbers.
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Example

In the following example, the numbers 1–8 indicate the control numbers.

See also

Control numbers (page 731)

Remove control numbers
If needed, you can remove existing control numbers from all or some of the
parts. Do not remove control numbers unless you are absolutely sure that
they are no longer needed.

NOTE Removing of control numbers is different than reassigning of control
numbers. If you only want to reassign new control numbers to parts
that already have control numbers, use the Renumber option in the 
dialog box.

1. Double-click a part to open the part properties in the property pane.

2. Click the User-defined attributes button. 

The current control number of the part is displayed on the Parameters
tab, in the Control Number box. For example:
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3. Remove the existing control number from the box.

4. Click Modify to apply the change.

See also

Control numbers (page 731)

Lock or unlock control numbers
To prevent other users from changing the control numbers of some or all of
the parts in the model, use the Lock/unlock control numbers command.
Later on, if the control numbers need to be changed, you can use the same
command for unlocking the numbers.

1. On the Drawings & reports tab, click Numbering settings --> Lock/
unlock control numbers to open the Lock/Unlock control numbers
dialog box.

2. Define which parts’ control numbers to lock or unlock. 

• To lock or unlock the control numbers of all parts, do not select any
parts in the model.

• To lock or unlock the control numbers of specific parts only, select the
parts in the model.

3. In the Status list, select Lock or Unlock.

4. Click Apply to save the changes.

5. Click Create to lock or unlock the numbers.

See also

Control numbers (page 731)

Example: Use control numbers to indicate the erection
order
This example shows how to assign control numbers to six concrete walls. As
four of these walls have the same cast unit position, you cannot make a clear
distinction between the cast units based on their position number. That is why
each wall will get a unique identifier that indicates their erection order at the
site. The erection order also affects the order of shipping. For example, the
wall number 1 needs to be shipped on top of the delivery, because it will be
erected first on the site; the wall number 2 should be the second on the
bundle, because it will be erected next; and so on.
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The following image represents the desired end result.

Erected as 1st

Erected as 2nd

Erected as 3rd

Erected as 4th

Erected as 5th

Erected as 6th

To assign control numbers to the concrete walls:

1. On the Drawings & reports tab, click Numbering settings --> Assign
control numbers to open the Create control numbers dialog box.

2. Select the six concrete walls.

3. Define that you want to assign control numbers only to parts in the
numbering series S with the start number 1.

a. In the Numbering list, select By numbering serie.

b. In the Prefix box, enter S.

c. In the Start number box, enter 1.
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4. Define that you want to use the numbers 1–6 as the control numbers for
these concrete walls.

a. In the Start number of control numbers box, enter 1.

b. In the Step value box, enter 1.

5. Define that you want to first number the walls with identical z coordinates
in the order they appear in the positive x axis.

a. In the First direction list, select Z.

b. In the Second direction list, select X.

6. Click Apply to save the changes.

7. Click Create to number the concrete walls. 

Each concrete wall gets a unique control number, as shown in the
following image.

TIP If you cannot see the control numbers in the model, modify the
display settings. For more information on the required settings, see
Display control numbers in the model (page 734).

5.11 Number parts by design group
You can number parts by design groups so that you can differentiate the parts
from each other in drawings and reports. The design group numbers can be
used in engineering documents or as preliminary numbers.
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Design group numbers consist of a prefix, a separator, and a number or a
letter.

Use the Design group numbering application to assign prefixes and numbers
or letters to parts on the basis of design groups. The Design group
numbering application groups parts that match a selection filter into a design
group, numbers them, and optionally compares the part lengths. The
application also compares the user-defined attributes of parts that are set to
affect numbering.

NOTE The Design group numbering application only numbers parts that
have a profile extruded to create the length of the part, such as
beams, columns, panels, and footings. Contour plates, slabs, or items
are not numbered.

Before you start:

• Create the needed selection filters that define the design groups.

• If you want to use certain letters in design group numbering, list the
allowed letters using the advanced option XS_VALID_CHARS_FOR_
ASSEMBLY_POSITION_NUMBERS. By default, letters A–Z are allowed.

• In multi-user or Tekla Model Sharing models, make sure that only one of
the users runs the Design group numbering application.

To number parts by their design group:

1. In the model, Click the Applications & components button  in the
side pane to open the Applications & components catalog.

2. Click the arrow next to Applications to open the applications list.

3. Double-click Design group numbering to start the application.

4. In the Design group numbering dialog box:

a. Click Add group to create design group numbering settings for parts
matching a selection filter. 

• Select the filter in the Group filter column.

The selection filters are read from specific folders in the standard
folder search order.

• Enter the design group prefix and start number or start letter you
want to use for the parts in this group.

• In the Compare length column, define whether the part lengths
are compared or not.

b. Repeat step 4a for all part groups that you want to number by design
group.
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c. If needed, change the order of the groups by using the Move up and
Move down buttons. 

If a part belongs to several groups, the last group filter in the list
overrides the previous ones.

d. If you want to compare part lengths, define the length tolerance. 

For example, if you enter 0, parts must be exactly the same length to
receive the same design group number (or letter). If you enter 2, part
lengths can differ 2 mm from each other.

The default tolerance is 0.05 mm.

e. Enter a number separator that is used to separate the design group
prefix and number or letter in drawing marks and in reports. For
example, enter - . 

We recommend that you do not change the separator during the
project.

f. To reuse old, unneeded numbers or letters, select the Reuse old
numbers check box.

g. In Number using letters, select whether to use letters or not.

h. In Renumber all, select whether to renumber all parts or not.

i. To number the parts by design group, click Perform numbering. 

A design group number is saved as the user-defined attribute 
DESIGN_GROUP_MARK of each part.

By default, the user-defined attribute DESIGN_GROUP_MARK is
available in the objects.inp file in the Engineering configuration in
the default and US environments.

j. To create a report to show the numbering results, select whether to
create a report of all or the selected parts, and then click Create
report. 

Tekla Structures shows the report in the List dialog box and also
saves the report. The report is saved as dgnReport.txt in the folder
defined by the advanced option XS_REPORT_OUTPUT_DIRECTORY. In
the Default environment, the report is saved in the \Reports folder
under the current model folder.

When you select a row in the List dialog box, Tekla Structures
highlights and selects the corresponding part in the model.

If the numbering of a part is not up to date, meaning that the part has
been modified after numbering, a question mark (?) is added after the
design group number.

5. To show the design group numbers in drawing marks or in reports, use
the user-defined attribute DESIGN_GROUP_MARK.
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See also

Create new filters (page 153)

5.12 Numbering examples
This section gives some examples of numbering the model.

Click the links below to find out more:

Example: Number identical beams (page 741)

Example: Use family numbers (page 741)

Example: Number selected part types (page 743)

Example: Number parts in selected phases (page 744)

Example: Number identical beams
This example explains how different numbering settings result in different part
numbers when you modify a part.

To number identical beams:

1. Create three identical beams with the numbering series prefix P and start
number 1.

2. Number the model. All the beams have the part position number P1.

3. Modify one of the beams.

4. Number the model. You should now have two beams P1 and one P2.

5. Change beam P2 to be identical to the others.

6. Number the model. 

Depending on the numbering settings in the Numbering Setup dialog
box, Tekla Structures assigns one of the following part position numbers
to the modified part:

• Compare to old: P1

• Keep number if possible: P2

• Take new number: P3

See also

Number parts (page 722)
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Example: Use family numbers

In this example, the following four beams have the numbering series prefix B
and the start number 1. The parts have the same main profile, and each pair
has the same length, but the holes are different.

Assembly position: B/1

Assembly position: B/2

Assembly position: B/3

Assembly position: B/4

We use the following family numbering settings:

• Use family numbering for series: add series B/1

• Compare: select options Main part profile and Overall length

With the given family numbering criteria, Tekla Structures divides the beams
into two families. All beams have the same profile, but each pair has a
different length. Within both families the beams get different qualifiers
because they have different holes.

• The first beam gets the assembly position number B/1-1

• The second beam gets the assembly position number B/1-2

• The third beam gets the assembly position number B/2-1

• The fourth beam gets the assembly position number B/2-2
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See also

Family numbers (page 719)

Example: Number selected part types
This example shows how different numbering settings can be used for
different part types. We will use one set of numbering settings for steel anchor
rods, and another one for steel columns. Note that the Number series of
selected objects command numbers all parts that have the same assembly
prefix.

To number anchor rods and columns:

1. Create steel columns.

2. Create anchor rods with the numbering series prefix AR and start number
1. 

Ensure that this numbering series is different to any other parts or
assemblies in the model.

3. On the Drawings & reports tab, click Numbering settings -->
Numbering settings to open the Numbering Setup dialog box.

4. Ensure that the Column orientation check box is not selected, and then
click Apply. 

5. Select one of the anchor rods in the model.

6. On the Drawings & reports tab, click Perform numbering --> Number
series of selected objects. 

All parts with the AR prefix and start number at 1 are numbered.
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7. Wait until the anchor rod numbering is complete.

8. On the Drawings & reports tab, click Numbering settings -->
Numbering settings to open the Numbering Setup dialog box.

9. Select the Column orientation check box, and then click Apply.

10. Select one of the steel columns in the model.

11. On the Drawings & reports tab, click Perform numbering --> Number
series of selected objects. 

All columns belonging to the same numbering series as the selected
column are numbered.

See also

Number a series of parts (page 722)

Example: Number parts in selected phases
This example shows how to number a model that consists of multiple phases,
each phase having a different detailing and submittal schedule. This enables
you to release drawings for a particular phase at any time.

Before you start, divide the model into phases.

To number parts in selected phases:

1. Apply a specific numbering series prefix and start number for parts in
each phase. 

For example:

• The beams in phase 1 get the numbering series prefix B and start
number 1000.

• The beams in phase 2 get the numbering series prefix B and start
number 2000.
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(1) Phase 1: green

(2) Phase 2: magenta

2. Ensure that the numbering series are not overlapping. 

For example, to avoid numbering overlaps with the beams in phase 2,
phase 1 should not contain more than 1000 position numbers.

3. Select the parts you want to number. 

TIP Use selection filters to easily select parts belonging to a certain
phase or parts with a specific start number series. You can also use
selection filters to ignore specific phases that are already completed
or phases that are not ready for numbering.

4. On the Drawings & reports tab, click Numbering settings -->
Numbering settings to open the Numbering Setup dialog box.

5. Modify the numbering settings, and then click Apply.

6. Select one of the parts you want to number.

7. On the Drawings & reports tab, click Perform numbering --> Number
series of selected objects. 

All parts belonging to the same numbering series as the selected part are
numbered.
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See also

Number a series of parts (page 722)

Numbering settings during a project (page 746)

5.13 Tips for numbering
• It is a good idea to have some kind of a routine in numbering. For example,

number the model when you start your working day or when you finish for
the day.

• To save time, include the numbering series in the default part properties
for each type of part before you start modeling.

• Numbering is not just another way of classifying parts. To classify, use
Organizer, user-defined attributes, or colors.

• If you have overlapping position numbers, Tekla Structures will warn you
about it.

You can have a closer look at the overlapping position numbers in the
numbering history log. To display the log, click File menu --> Logs -->
Numbering history log.

See also

Numbering settings during a project (page 746)

Numbering examples (page 741)

Create a standard-part model (page 747)

Numbering settings during a project
You can use different numbering settings at different times in a project.

For example:

• Before releasing a phase of the project for fabrication, you might use the
Re-use old numbers option for numbering the entire model.

• If a phase has already been released for fabrication in a project, you might
use the Take new number option for new and modified parts.

• If you are numbering other phases of the project at earlier stages of
detailing, you might use the Compare to old option and try to combine as
many position numbers as possible.

See also

Example: Number parts in selected phases (page 744)
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General numbering settings (page 1005)

Create a standard-part model
A standard-part model contains only standard parts with specific part prefixes.
You can use these prefixes when numbering parts in another model. The
prefixes that you define will be used as actual part position numbers in the
other model.

The standard-part model is only used for comparing parts when you number
parts in a project model. It cannot be used for creating parts in the project
model.

NOTE This functionality only applies to steel parts. Assemblies are not
affected.

1. Create a new model and give it a descriptive name. 

For example, StandardParts.

2. Create the objects you want to use as standard parts.

3. Explode all components. 

You can explode the components if you plan to delete the unnecessary
parts such as duplicate angles and main parts.

4. Delete all unnecessary items.

5. Give the objects part prefixes that are not used elsewhere (for example,
STD1, STD2, and so on). 

Ensure that the standard-part model does not contain duplicate part
prefixes. You do not need to define the assembly prefix or the part or
assembly start numbers.

6. Save the standard-part model. 

To use the standard-part model with Tekla Model Sharing, save the
standard-part model in a separate folder under the current model folder.

To use the standard-part model with a multi-user model, save the
standard-part model so that all users have access to it.

7. Open a project model that you wish to number.

8. On the File menu, click Settings --> Advanced options --> Numbering .

9. Check that the advanced option XS_STD_PART_MODEL points to the
correct standard-part model. 

For example:

XS_STD_PART_MODEL=C:\TeklaStructuresModels\StandardParts\
10. On the Drawings & reports tab, click Numbering settings -->

Numbering settings to display the Numbering Setup dialog box.
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11. If you have selected the Part name check box, ensure that the project
model has the same part names as the standard-part model.

12. Select the Check for standard parts check box.

13. Click Apply to save the changes.

14. On the Drawings & reports tab, click Perform numbering --> Number
modified objects to number the project model. 

As the parts are being numbered, Tekla Structures compares all parts in
the project model to the standard-part model. Any part prefixes found in
the standard-part model are applied to all identical parts found in the
project model. The numbering series of the oldest numbered standard
part in the project model is applied to all identical parts found in the
project model.

See also

Number parts (page 722)
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6 Applications

All available applications, macros, and drawing plugins are located in the
section Applications of the Applications & components catalog. You can also
record macros of your own and show them on the list.

Macros

Macros (page 751) are saved as .cs files in the \drawings or \modeling
folder under the folders that have been defined with the advanced option . By
default, this advanced option is set to ..\ProgramData\Trimble\Tekla
Structures\<version>\environments\common\macros.

In addition to this global folder, you can define a local folder and store local
macros there, for example, environment macros or firm macros. Specify the
local macro folder for the advanced option XS_MACRO_DIRECTORY in addition
to the global folder. Define the global folder first and then the local folder.
When you create a macro you need to set it as global or local, and the macro
will be placed in the global or local folder according to your selection. The
macros in the global folder are read first.

Example of the definition for XS_MACRO_DIRECTORY containing a global folder
and a local folder:

%XSDATADIR%environments\common\macros;%XSDATADIR%environments\uk\General
\user-macros

Macros in the modeling mode

Macro Description
AutoConnectSelectedParts
(page 778)

Use to automatically create
connections without opening the
AutoConnection dialog box.

AutomaticSplicingTool (page 564) Use to split long reinforcing bars and
bar groups that exceed the stock
length, and create splices in split
locations.

ContinuousBeamReinforcement Use to reinforce a continuous beam.
The macro creates main top and
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Macro Description
bottom bars, stirrups, fittings, and
additional top and bottom bars using
system components.

CreateSurfaceView (page 33) Use to create an automatically aligned
surface view.

CreateSurfaceView_wEdge (page 33) Use to create a surface view and align
the work plane along the edge you
select.

DesignGroupNumbering (page 738) Use to number parts by design
groups so that you can differentiate
the parts from each other in drawings
and reports.

DirectoryBrowser Use to to find and modify the location
of the various Tekla Structures files
and folders, and customize user
settings.

RebarClassificator (page 567) Use to classify the reinforcing bars
and reinforcement meshes by their
order of depth in concrete slabs and
panels.

RebarSeqNumbering (page 566) Use to assign cast unit specific
running numbers (1, 2, 3...) to the
reinforcement in the model.

RebarSplitAndCoupler Use to split a reinforcing bar group
and add couplers in relation to the
direction of the picked points.

UpdateRebarAttributes Use to manage the user-defined
attributes (UDAs) of the couplers and
the end anchor parts created by
Rebar Coupler and Anchor Tools.

Macros in the drawing mode

Macro Description
Add surfacing symbols in drawings Use to add surface treatment symbols

in cast unit drawings.
Moment connection symbols Use to create moment connection

symbols to show the beams that are
connected to columns with rigid
connections.

Create dimensions marks for all
rebars

Use to add dimension marks to all
rebars at one go.

Exaggerate selected dimensions Use to exaggerate narrow dimensions
to make them easier to read.
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Macro Description
Rebar layering marker Use to mark reinforcing bar layers

with different marking styles and line
types in a drawing.

Rebar mesh view creator Use to create drawing views each
containing one reinforcement mesh.

Remove change clouds Use to remove dimension change
symbols, mark change symbols, and
associative note change symbols at
one go in an open drawing.

Extensions (.tsep)

You can download Tekla Structures extensions that have the .tsep file
extension from Tekla Warehouse and import (page 755) these extensions to
the Applications & components catalog. When you restart Tekla Structures,
the imported extensions are installed and added to the Ungrouped items
group in the catalog. You can move them to a suitable group.

Publish groups in the Applications & components catalog

You can collect content to a group that you create in the Applications &
components catalog. You can then publish the group (page 756) as a catalog
definition file to make it available for other Tekla Structures users.

See also

Working with applications (page 751)

6.1 Working with applications
You can run, add, edit, rename, save as and delete applications, macros and
plugins in the Applications section of Applications and Components catalog.
You can also record and edit macros.

To Do this
Record a macro 1. Click the Applications &

components button  in the
side pane to open the
Applications & components
catalog.

2. Click the Access advanced

features button  and then
click Record macro > Global or
Local depending on whether you
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To Do this
want to save the macro in the
global or local macros folder.

The Local command is only
available if you have defined a
location for the local macros
using the advanced option 
XS_MACRO_DIRECTORY.

3. Enter a name for the macro in
the Macro name box.

4. Click OK and perform the actions
you want to record.

5. Click Stop recoding to stop
recording.

The recorded macro is saved
under global or local macros in
the macros\drawings or
macros\modeling folder
depending on the mode (drawing
or modeling) you were using
while you were recording the
macro.

Create a macro file and add contents
later

1. Click the Applications &

components button  in the
side pane to open the
Applications & components
catalog.

2. Click the Access advanced

features button  and then
click New macro > Global or
Local depending on whether you
want to save the macro in the
global or local macros folder.

The Local command is only
available if you have defined a
location for the local macros
using the advanced option 
XS_MACRO_DIRECTORY.

3. Enter a name for the macro in
the Macro name box.
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To Do this
4. Click OK.

This creates an empty macro file
that is displayed in the
Applications list.

5. Right-click the empty macro file
and select Edit.

6. Add the macro content, for
example, by copying commands
from other macro files and save
the file.

View or edit a macro 1. Click the Applications &

components button  in the
side pane to open the
Applications & components
catalog.

2. Click the arrow next to
Applications to open the
applications list.

3. Right-click the macro you want to
edit and click Edit.

The macro can be opened in any
text editor.

4. If needed, edit the macro and
save the macro file.

Run an application 1. Click the Applications &

components button  in the
side pane to open the
Applications & components
catalog.

2. Click the arrow next to
Applications to open the
applications list.

3. Double-click the application you
want to run.

Save an application with another
name

1. Click the Applications &

components button  in the
side pane to open the
Applications & components
catalog.
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To Do this
2. Click the arrow next to

Applications to open the
applications list.

3. Right-click the application that
you want to save with another
name and click Save as.

4. Enter a new name for the
application and click OK.

The application will be added in
the list.

Rename an application 1. Click the Applications &

components button  in the
side pane to open the
Applications & components
catalog.

2. Click the arrow next to
Applications to open the
applications list.

3. Right-click the application you
want to rename and click
Rename.

4. Enter a new name for the
application and click OK.

The name of the application
changes.

Delete an application 1. Click the Applications &

components button  in the
side pane to open the
Applications & components
catalog.

2. Click the arrow next to
Applications to open the
applications list.

3. Right-click the application you
want to delete and click Delete.

The application is removed from
the list.
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See also

Applications (page 749)

6.2 Import a .tsep extension to the Applications &
components catalog
You can import Tekla Structures .tsep extensions (Tekla Structures extension
package) to the Applications & components catalog.

Before you begin, download the .tsep extension from Tekla Warehouse. For
more information, see Download content from Tekla Warehouse.

NOTE Some Tekla Structures extensions have an .msi installation file. You
must install these extensions separately. Download the .msi
installation file from Tekla Warehouse, then double-click the file to run
the installation.

System administrators can copy multiple .tsep extension files to the \Tekla
Structures\<version>\Extensions\To be installed folder on a Tekla
Structures user's computer. The extensions are installed the next time the
user restarts Tekla Structures.

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Click  Manage extensions --> Extension manager.

3. In the Extension manager, click Import.

4. Browse to the location where you saved the .tsep extension, then
double-click the .tsep extension. 

Tekla Structures opens a dialog box that lists the installed Tekla Structures
versions that are compatible with the extension. If none of the installed
Tekla Structures versions are compatible, the compatible versions are
listed.

5. Select the Tekla Structures versions to which you want to import the
extension.

6. Click Import. 

The extension is shown in the Extension manager in all the Tekla
Structures versions that you selected.

7. Restart Tekla Structures to install the imported extension.

The extension is shown in the Ungrouped items group in the Applications &
components catalog. You can move the extension to a more suitable group, or
create a new group.
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TIP In Extension manager, you can list the extensions by type: extension or
environment. You can also search for content based on name, author,
description, and type of extension.

See also

How to use the Applications & components catalog (page 766)

6.3 Remove .tsep extensions from the Applications &
components catalog
You can uninstall installed extensions in Extension manager

Installing and uninstalling extensions creates a log file to \Tekla Structures
\<version>\Extensions\TSEP Logs.

1. Select one or several extensions. 

Use Ctrl or Shift to select several extensions.

2. Click Remove.

3. Restart Tekla Structures to remove the extensions.

6.4 Copy .tsep extensions to a new Tekla Structures
version
When starting to use a new Tekla Structures version, you can use the Migration
Wizard tool to copy the installed .tsep extensions to the new version.

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Click  Manage extensions --> Migrate extensions.

3. Restart Tekla Structures to install the copied extensions.

6.5 Publish a group in the Applications & components
catalog
You can collect content, such as macros, extensions, and system and custom
components to a group that you create in the Applications & components
catalog. You can then publish the group as a catalog definition file to make it
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available for other Tekla Structures users. For the published content to work
correctly in another Tekla Structures installation, the content must also exist in
that installation.

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Create a new group:

a. Right-click in the catalog and select New group.

b. Enter a name for the group.

c. Select the group and click the small arrow on the right to add a
description to the group.

d. Add content to the group. 

Some content in the Applications & components catalog may be
hidden. To publish the hidden content, select the Show hidden items
check box at the bottom of the catalog.

Note that the model-specific items you add to the group are visible in
the modeling mode and the drawing-specific items in the drawing
mode.

e. Add the needed information to the items in the group: description,
tags, and additional thumbnail images. 

Use a thumbnail image from the \Tekla Structures\<version>
\Bitmaps folder to ensure that the image is available for other Tekla
Structures users.

3. Right-click the group and select Publish group to create a catalog
definition file. 

The file contains the following information:

• Name and description of the published group

• Names and descriptions of the subgroups

• References to the items that you have added to the group

The file does not contain the actual items. When other users use the
group, they must ensure that the referenced items exist in their Tekla
Structures installation and model.

• Descriptions, tags and thumbnail references of the items in the group

The file does not contain the actual thumbnail image files.

4. Add a unique prefix to the filename in the Publish group dialog box. 

The filename format must be <prefix>_ComponentCatalog.ac.xml.

5. Click Save. 

The file is by default saved to the model folder.
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6. Make the group available for other Tekla Structures users by moving the
<prefix>_ComponentCatalog.ac.xml catalog definition file to an
appropriate folder: 

• Project, firm or system folder defined in XS_PROJECT, XS_FIRM, or 
XS_SYSTEM.

• \attributes folder under the current model folder

• Extensions folder in \Tekla Structures\<version>
\environments\common\extensions, or to any of the folders
defined in XS_EXTENSION_DIRECTORY.

The Applications & components catalog also searches the subfolders
of these folders. We recommend that you use the extension folders if
you have created your own extensions and have included them in the
group.

7. Check that the catalog definition file works correctly:

a. Delete the published group from your Applications & components
catalog.

b. Click  > Catalog management > Reload catalog to load and view
the published group.

When you have checked the group, other users can start using it:

• If the group content is already included in other users' Tekla Structures
installation, they can use the group immediately after reloading the catalog

by clicking  > Catalog management > Reload catalog.

• If the group content, for example extensions, is not included in other users'
Tekla Structures installation, they have to download the missing extensions
from Tekla Warehouse first, and then re-open the model where they are
going to use the group.
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7 Components

Components are tools that you can use to connect parts in the model.
Components automate tasks and group objects so that Tekla Structures treats
them as a single unit. You can save the properties of a component and use
them in other projects.

Components adapt to changes in the model, which means that Tekla
Structures automatically modifies a component if you modify the parts it
connects. When you copy or move objects, Tekla Structures automatically
copies or moves all the associated components with the objects.

All components are stored in the Applications & components catalog. Click the

Applications & components button  in the side pane to open the
Applications & components catalog.

System components

Tekla Structures contains a wide range of predefined system components by
default. There are three types of system components:

• Connection components connect two or more parts, and create all the
required objects such as cuts, fittings, parts, bolts, and welds.

For example, end plates, clip angles, and bolted gussets are connections.

In the Applications & components catalog, the connection symbol is .

• Detail components add a detail or a reinforcement to the main part. A
detail is only connected to one part.

For example, stiffeners, base plates, and lifting hooks are steel details, and
beam reinforcement and pad footing reinforcement are concrete details.

In the Applications & components catalog, the detail symbol is .

• Detailing components automatically create and assemble the parts to
build a structure, but do not connect the structure to existing parts.

For example, stairs, frames, and towers are detailing components.
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In the Applications & components catalog, the detailing symbol is .

You can also create your own components, custom components (page 823), if
you do not find a system component that suits your needs. You can use
custom components in the same way as system components.

7.1 Component properties
Each component has a dialog box where you can define the properties of the
component. You can open the dialog box by double-clicking the component in
the Applications & components catalog.

The image below shows a typical example of a steel connection, the Two sided
clip angle (143) connection. Concrete and reinforcement component dialog
boxes may have different options.

Components 760 Component properties



 Description
1 In the upper part of the dialog box, you can save and load predefined

settings. Some components have buttons for accessing bolts, welds
and DSTV properties.

When modifying connections and details, you can select whether Tekla
Structures ignores other types of connections and details, or modifies
all selected connections and details irrespective of their type. With the
modify option, the type of the selected components is changed to
match the type of the component you are currently modifying.

For more information, see and Model folder files and file name
extensions.

2 On the tabs, you can define the properties of the parts and bolts that
the component creates. You can enter values manually, use system
default values, AutoDefaults values, automatic values, or for some steel
connections, the values in the joints.def file.

Manually entered values, AutoDefaults, automatic values and the
properties defined in the joints.def file all override the system
defaults. System default values are used if you do not manually enter a
value or select any other type of property value. You cannot change the
system default values.

For more information on joints.def, see Define connection
properties in the joints.def file (page 794).

3 For information on the dialog box buttons, see .
4 If you select an AutoDefaults  option, Tekla Structures uses the

property defined in the AutoDefaults rules.

The image in the AutoDefaults option is an example and does not
necessarily match the outcome in the model.

For more information on AutoDefaults, see AutoDefaults (page 780).
5

If you select an automatic  option, Tekla Structures automatically
determines which option to use for a property.

For example, when you use the automatic option for the stiffener in
End plate (144), the connection automatically adds the stiffener to a
beam-to-column connection, but does not add it to a beam-to-beam
connection.

For more information on AutoConnection, see AutoConnection
(page 775).

6 The parts that are yellow in the component dialog box are created by
the component.

7 The parts that are blue in the component dialog box should already
exist in the model before you create the component.
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 Description
8 Up direction indicates how the connection is rotated around the

secondary part, relative to the current work plane. The  symbol on
the Picture tab of the component dialog box indicates the correct up
direction.

If there are no secondary parts, Tekla Structures rotates the connection
around the main part. The options are: +x, -x, +y, -y, +z, -z.

You can change the default up direction on the General tab of the
component dialog box. Try changing the positive directions first.

7.2 Add a component to a model
When you add a component to a model, you either attach the component to
existing parts in the model, or pick positions to indicate the location or length
of the component.

Connections and details have a main part that you select first. Connections
also have one or more secondary parts that you select after you have selected
the main part. Detailing components do not always have a main part and
secondary parts. Instead, they automatically create and assemble the parts to
build a structure when you pick a position in the model.

If you use a component you are unfamiliar with, use the default properties of
the component. Then check what needs to be modified, and modify only few
properties at a time to see how the modifications affect the component. This is
quicker than trying to set all the component properties before seeing what the
component actually creates.

Tekla Structures opens a command prompt when you add a component. Do
not close the prompt window, because it displays information on adding the
component. This information can be useful in problem situations.

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog. 

You can also press Ctrl + F.

2. Select a component and do one of the following: 

To Do this
Add a
connection

1. Select the main part.

2. Select the secondary part or parts.

• If there is one secondary part, the connection is
automatically created when you select the secondary part.
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To Do this
• If there are several secondary parts, click the middle mouse

button to finish selecting the parts and to create the
connection.

In the example image below, the numbers from 1 to 4 show the
selection order of parts. The blue parts should already exist in
the model before you create the component.

Add a
detail

1. Select the main part.

2. Pick a position in the main part to determine the location of
the detail.

Add a
detailing
component

Pick one to three positions to determine the location of the
objects that the detailing component creates.

When you have added components to the model, you can use the property
pane to list the components:

• If you select one component in the model, the property pane shows the
name and number of that component. You can open the component
properties dialog box by clicking the Component properties button in the
property pane.

• If you select several different components in the model, the property pane
shows lists that have the text Varies. Open the lists to show the names and
numbers of the selected components.
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• If you select components and other model objects, click the Object type

list button  in the property pane to open a list of the selected object
types, and select Component to list the components.

Component status

When you have added the component, Tekla Structures shows the component
status using the symbols shown in the table below. Double-click the symbol to
open the component properties.

Color Status
The green symbol shows that the component was created
successfully.

The detailing component symbol in the model is .
The yellow symbol shows that the component was created,
but has problems.

This often occurs when bolts or holes have an edge distance
that is less than the default value.
The red symbol shows that the component was not created.

Common reasons are that the properties are incorrect or that
the up direction is not appropriate.

7.3 Modify a component in a model
You can modify the properties of a component after you have added the
component in the model, for example, if you need to change the number of
bolts or plate dimensions.

1. Double-click the component symbol in the model to open the component
dialog box.

2. Modify the properties.

3. If needed, define which connections and details are modified: 

• Ignore other types: Tekla Structures only modifies the connections and
details that are of the same type as the connection or detail you are
modifying.

• Modify connection type: If you have selected several connections and
details, click Modify to modify all the selected connections and details
irrespective of their type. If the connection type of a selected
connection is not the same as in the connection dialog box, Tekla
Structures changes the connection type.

4. Click Modify.
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7.4 View a component in a model
You can create several views of a component to view it from different
viewpoints.

1. Click the component symbol in the model to select the component.

2. Right-click and select Create view --> Default views of component . 

Tekla Structures creates four views: front, end, top, and perspective.

The example image shows the default views of the End plate (144)
connection.

NOTE You can check the dimensions, such as bolt locations and edge distances,
using the Measure tool in the Component front view.

7.5 Component tips
Default properties

If you use a component you are unfamiliar with, use the default properties of
the component. Then check what needs to be modified, and modify only few
properties at a time to see how the modifications affect the component. This is
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quicker than trying to set all the component properties before seeing what the
component actually creates.

Valid profiles

Some components work with certain profiles only. If a component is not
created successfully, try entering a valid profile.

Select components switch

You can switch on the Select components switch  to be able to select any
object that belongs to the component.

Component is not added to the model

If the component is not added to the model, check the status bar. For
example, you may need to click the middle mouse button to stop selecting
parts before Tekla Structures creates the component.

Using thickness to create needed parts

If a component does not by default create the parts that you need, look for
options to create them. If there are no options, try entering a thickness value
for the parts.

If a component creates parts that you do not need, look for options to remove
them. If there are no options, enter a zero (0) as the thickness of the parts.

Many secondary parts are found

If you are using a connection that only allows one secondary part, you may see
the message Many parts found on the status bar. This means that Tekla
Structures cannot determine which parts to connect. You may have several
parts in the same location, or the view may be set too deep.

7.6 How to use the Applications & components catalog
Components are stored in the Applications & components catalog and
organized into two different types of groups: default groups are automatically
available and predefined groups depend on your environment.

Click the Applications & components button  in the side pane to open
the Applications & components catalog. You can also press Ctrl + F.

To use a component (page 759), select it in the catalog and follow the
instructions on the status bar to add the component to the model. Double-
click the component in the catalog to open the component properties dialog
box.
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Groups in the catalog
Default groups and predefined groups are shown against different background
color in the catalog.

Default groups are automatically available:

• Recent contains the 12 components and applications that you have most
recently used in the model.

• Ungrouped items contains the components and applications that are not
in any predefined group.

Ungrouped items can be, for example, imported components that have not
been moved to any other group yet.

• Applications contains applications (page 749), macros and drawing
plugins.

If you create your own macros, you can add them to this group.

• Connections contains connections and seams.

• Detailing contains detailing components.

• Details contains details.

• Parts contains custom parts.

• Legacy catalog shows the folder structure of the Component Catalog
used in previous Tekla Structures versions if the catalog definition files are
found in the standard folder search paths.

Depending on your environment, the catalog may also contain predefined
groups for specific usage, such as Steel --> Beam to beam connections. You
can create your own groups according to your needs, for example, for your
own favorite connections. This way you can find these connections quickly and
easily. You can also hide the groups that you are not using so that only the
groups you use are visible in the catalog.

Model-specific components are shown in the modeling mode and drawing-
specific components are shown in the drawing mode.

Search for a component in the catalog
To search for a component in the catalog, enter the search term in the search
box. The search is case-insensitive.

Note that the search does not find catalog content that has been hidden.
Select the Show hidden items check box to show the hidden content.

The search uses the following rules:
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• Non-numeric search terms find partial matches, for example, bolt shows
both bolt and bolted in the search result.

If you have more than one word in the search term, for example bolt
plate, the words are automatically combined so that the search result
shows the components that contain both bolt and plate in their name,
description, or tags.

• Numeric (integer) search terms find the exact match, for example, 121
shows component number 121 in the search result.

You can use the *, ? and [ ] wildcards to search for partial numeric
matches. For example, 10* finds components number 10, 110, 104, 1040,
and so on.

• You can restrict the search to specific tags, groups and types of
components by using the keywords tag, group, or type. For example, 10
tag:advanced finds the number 10 components that have advanced in
the tag, and type:custom finds all custom components.

Change the view in the catalog

• Click  to show the thumbnail view.

• Click  to show the list view.

• Click  to show the compact view.

The compact view shows the thumbnail images of the group that you select
from the list above the search box. You can use the compact view to have
more space on the screen.

• Click  to show the normal view.

Show selected components in the catalog
Click Show selected to show a Selected components group that contains the
components that are selected in the model or in the drawing.

Click Show selected again to hide the Selected components group.

The Show selected button is not available when you are using the search in
the catalog.

TIP You can use the property pane to list the components that you have selected in
the model. If you select one component, the property pane shows the name and
number of the component. If you select several different components, the
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property pane shows lists that have the text Varies. Open the lists to show the
names and numbers of the selected components.

If you select components and other model objects, click the Object type list

button  in the property pane to open a list of the selected object types, and
select Component to list the components.

View and modify component information in the catalog
Each component has an information box that shows the type of the
component and the groups the component belongs to. You can add a
description for the component and tags that can be used in the search.

1. Select a component in the catalog and click the small arrow on the right to
open the component information box.

2. Type a description in the Description box.

3. Click  to add a tag and enter a tag in the box.

4. If needed, click  again to add more tags. You can also remove tags.

5. Click outside the information box to close it.

The descriptions and tags that you add are by default saved in the
ComponentCatalog.xml file in the model folder.

Add a thumbnail image for a component in the catalog
Components have a default thumbnail image that shows a typical situation
where the component can be used. You can add several thumbnails for a
component and select which thumbnail is shown in the thumbnail view in the
Applications & components catalog.

1. Select a component in the catalog.

2. Right-click and selectThumbnails.

3. Click Add thumbnail.

4. Select an image and click Open. You can use any standard image format,
for example, .png, .jpeg, .gif, .tiff, and .bmp.

5. Select the check boxes of the thumbnails that you want to show in the
component information box. You can also remove thumbnails, except for
the default thumbnail.
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6. Click Close.

The thumbnail information that you add is by default saved in the
ComponentCatalog.xml file in the model folder.

Publish a component in the catalog
You may need to use the same component with different settings in different
situations. To easily use the component, you can define the settings for each
situation and publish the component in the catalog.

For example, you may need End plate (144) in three different situations. Add
End plate (144) once to each situation in the model. Define the settings
needed and then publish each End plate (144) in the catalog. You will then
have End plate (144) saved in the catalog as three separate components, each
with different settings. You can use these components from the catalog in the
same way as other components.

1. Add a component once to all needed situations in the model.

2. Define the desired settings for each situation.

3. Select one of the components you added in the model, right-click and
select Publish in Catalog....

4. Enter a descriptive name for the component and click OK.

5. Repeat steps 3-4 for each component you added.

The components are first placed in the Ungrouped items group in the catalog.
They have the name you entered and the thumbnail image of the original
component.

You can move the components to a more appropriate group in the catalog and
change the thumbnail image. For example, you can create a basic component
view in each situation, and use an image of the view as the thumbnail.

Create and modify groups in the catalog
You can create groups and subgroups, and move groups to different locations
in the predefined groups section in the catalog. You can add and remove
components from the groups, rename the groups, and add descriptions for
the groups.

To Do this
Create a
group

Right-click in the catalog and select New group.... Drag the
group to the desired location.

Create a
subgroup

Right-click a group in the catalog and select New group....
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To Do this
Name a
group

Right-click a group, select Rename... and type the name.

Add
components
to the group

• Select components in the catalog and drag them to another
group.

• Select components in the catalog, right-click and select Add
to group. Then select the group to which the components
are added.

• Right-click a group, select Add all to group and select the
group to which all the components in the group are added.

Note that the components are copied, not moved, to the
other groups.

Remove a
group

Remove a
component
from a group

Right-click a group or a component in a group, and select
Remove from group.

The groups that you create are by default saved in the
ComponentCatalog.xml file in the model folder.

NOTE You cannot add or remove groups in the default groups, and you cannot
modify the content of the default groups. However, you can hide the default
groups and the individual items in the groups.

Change the order of groups in the catalog
You can change the order of the predefined groups in the Applications &
components catalog. Predefined groups depend on your environment, for
example, Steel and Concrete can be such groups. Note that you cannot
change the order of the default groups, for example, Applications,
Connections, and Detailing.
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You can control the order with a sort index. The Sort index option is available
in the group information of each predefined group in the Applications &
components catalog. Sort indexes are saved in the catalog definition files.

You can change the sort index by entering either a negative or a positive
integer number, or 0, in the Sort index option box. A negative sort index
moves a group towards the top and a positive sort index moves a group
towards the bottom in the predefined groups section. Enter 0 or clear the
value to revert to the default order. By default, the groups are in alphabetical
order.

The sort index changes you make are model specific and they are saved in the
ComponentCatalog.xml file in the \model folder. Administrators can define
the order of groups for an environment or a project using the catalog
definition files in the environment, firm and project folders. Do not edit these
files if you are not an administrator.

Note that even if administrators have defined the order, you can still make
model-specific changes to the order of the groups by entering a different sort
index value for a group. If you need to revert to the default order, enter 0 as
the sort index.

To change the order:

1. Select a predefined group.

2. Click the small arrow on the right to open the group information box.

3. Enter a number in the Sort index box. 

The group is immediately moved.

4. Save the model to keep the order.
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Hide groups and components in the catalog
1. Select a group or a component in the catalog.

2. Right-click and select Hide / Unhide to hide the group or the component.

3. To view the hidden group or component again, select the Show hidden
items check box at the bottom of the catalog. The hidden group or
component is shown as dimmed.

4. To show the hidden group or component normally, right-click it and select
Hide / Unhide.

Show the catalog message log
If there are errors or warnings, for example, in the catalog definition files, the
Message Log button is shown in the lower right corner in the catalog. The
button is not shown if there are no errors or warnings.

To view the error log, click the Message Log button.

Errors and warnings are also written to the ComponentCatalog_<user>.log
file in the \logs folder under the model folder.

Catalog definitions

The commands in Access advanced features  > Catalog management
are used for modifying catalog definitions. Generally, there is no need to
modify catalog definitions. Do not modify the definition files if you are not an
administrator. For more information on administrator tasks, see Customize
the Applications & components catalog.

7.7 Convert components to conceptual or detailing
components
Depending on the Tekla Structures configuration you are using, you can create
either detailing or conceptual components.

• Detailing components include all the information needed for fabrication,
such as assemblies, cast units, and reinforcing bars.

Detailing components have a round symbol in the model:  or .

• Conceptual components look similar to detailing components but do not
include the option to change part numbering or assembly numbering
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settings. Conceptual components are meant to be used as reference
information for further fabrication detailing.

Conceptual components have a rectangular symbol in the model:  or

.

You can create conceptual components in the Tekla Structures Graphite
configuration, and in the Engineering, Rebar Detailing, and Construction
Modeling configurations.

You can edit conceptual components and convert them to detailing
components in the Tekla Structures Diamond configuration, and in the Full,
Primary, Steel Detailing, and Precast Concrete Detailing configurations.

Modifying part properties, such as the size of the component main part, does
not automatically convert a detailing component to a conceptual component,
or vice versa. For example, if you use the Engineering configuration and
modify the model, detailing components are not converted to conceptual
components. However, detailing components will adapt to the changes done
in the model, but you cannot modify any properties using the component
dialog box. Detailing components will also remain as detailing components
unless you convert them one by one.

You can convert components in the Applications & components catalog. Click

the Applications & components button  in the side pane to open the
Applications & components catalog.

Do one of the following:

To Do this Configuration
Convert a
conceptual
component
to a detailing
component

1.
Click  > Convert to
detailing component.

2. Select the component
symbol.

Tekla Structures Diamond

Full, Primary, Steel
Detailing, Precast Concrete
Detailing

Convert a
detailing
component
to a
conceptual
component

1.
Click  >Convert to
conceptual component.

2. Select the component
symbol.

Tekla Structures Graphite

Engineering, Construction
Modeling, Rebar Detailing
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7.8 Automate connection creation
This section describes the tools that you can use to automate connection
creation in the model.

Click the links below to find out more:

AutoConnection (page 775)

AutoDefaults (page 780)

AutoConnection and AutoDefaults rules (page 785)

AutoConnection
Use the AutoConnection tool to automatically select and apply connections
with predefined properties to selected parts in a model. With AutoConnection,
Tekla Structures automatically creates similar connections for similar framing
conditions.

You can use AutoConnection to quickly add connections individually, in
phases, or project-wide. This is useful when you are working on a large project
using many connections, modifying a model, or importing modified profiles.

NOTE Before using AutoConnection in a working model, we recommend that you
create a test model, and create all the connection conditions in it that you
need for a particular project. You can then use the test model to check the
rules and properties of various connection types. The model also acts as a
quick reference for connection information.

See also

Define AutoConnection settings and rules (page 775)

Create a connection using AutoConnection (page 778)

AutoConnection and AutoDefaults rules (page 785)

Define AutoConnection settings and rules
With AutoConnection you can define groups of rules which Tekla Structures
automatically applies when creating connections in a model. By using a rule
group to select connections and connection properties you do not have to
select each connection and define its properties separately. For example, you
can create separate rules for different standards, projects, manufacturers, and
even individual models.
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AutoConnection settings

To open the AutoConnection Setup dialog box, on the File menu, click
Catalogs --> AutoConnection settings.

Icon Setup level Description
Rule group You can use rule groups to organize

connections and connection properties
according to different standards,
projects, manufacturers, and models.
You can create, modify and delete rule
groups.

Framing condition Framing conditions are predefined
connection types that you cannot
change. Tekla Structures creates the
framing conditions automatically:

• Beam to beam web

• Beam to beam flange

• Beam to column web

• Beam to column flange

• Beam splice
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Icon Setup level Description
• Column splice

Rule set You can use rule sets to define which
connection to use in a certain situation.
You can create additional rule sets.

Connection The connection to apply if the rule set
criteria are met.

To apply a particular connection, the
conditions in the model have to match
all the rules in the branch that contains
the connection.

Rules.zxt file

When you use AutoConnection, Tekla Structures saves the AutoConnection
information in a zipped rules.zxt file in the \attributes folder under the
current model folder.

You can copy the rules.zxt file to the project or firm folder to make it
available in other models. Each time you modify the AutoConnection setup
you need to recopy this file to the firm and project folders. To use the modified
setup in other models, restart Tekla Structures.

Limitation

You can have a maximum of two secondary parts in the connection (for
example, you cannot use complex gussets with several secondary parts).
AutoConnection uses the profile height and ID number as the criteria for
determining the first secondary and second secondary parts.

Create a rule group for AutoConnection
You can define rule groups for AutoConnection to organize connections and
connection properties according to different standards, projects,
manufacturers, and models.

1. On the File menu, click Catalogs --> AutoConnection settings.

2. Right-click an existing rule group and select New Rule Group.

3. Click the New group and enter a name. 

Give the rule group a name that reflects the group of connections that you
want to create (page 778). For example, use the fabricator's name, the
project name, or any name that clearly identifies the connection rules that
you want to use for a specific model.

When you create a new rule group, Tekla Structures automatically adds the
existing framing conditions in the group.
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Create a rule set for AutoConnection
You can create AutoConnection rule sets under framing conditions to specify
which connection properties to use when specific conditions in the model are
met.

You only need to create AutoConnection rule sets if you plan to use different
connections (page 778) to connect similar framing conditions. For example, in
the model, some beam-to-beam connections require clip angles, others need
shear tabs. You need to define rule sets to determine where each connection
type should be used.

1. On the File menu, click Catalogs --> AutoConnection settings.

2. Click the plus icon in front of the rule group  to open the tree structure.

3. Right-click the relevant framing condition  and select Create
Additional Rule Sets.

4. Right-click the new rule set and select Edit Rule Set....

5. Enter a name for the rule set.

6. Select a rule from the Available rules list.

7. Click the right arrow button to move the selected rule into the list of Rules
in rule set.

8. Enter the values used in the rule: either an exact value, or minimum and
maximum values.

9. Click OK.

NOTE The order of the rules in the tree structure is important. Tekla Structures uses
the first rule that matches the conditions in the model so you should place the
most limiting rule highest in the tree, and the most generic rule lowest.

You can change the priority of a rule set by right-clicking the rule set and
selecting Move up or Move down.

Change a connection in an AutoConnection rule set
You can change the connection in a rule set by selecting a connection in the
Applications & components catalog.

1. On the File menu, click Catalogs --> AutoConnection settings.

2. Click the plus icon in front of the relevant framing condition  and rule

set  to find the connection that you want to change.

3. Right-click the connection and select Select Connection Type....

4. Double-click a connection in the Select component dialog box.

5. Click OK in the AutoConnection Setup dialog box.
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Create a connection using AutoConnection
Use AutoConnection to have Tekla Structures automatically create connections
using the properties of predefined rules. When you use AutoConnection, Tekla
Structures ignores the properties in the connection dialog boxes. Tekla
Structures does not modify the existing connections.

1. In the model, select the parts to connect.

2. On the Edit tab, click Components --> Create AutoConnections.

3. Select the rule groups from the lists on the Rule groups tab. 

1 Rule group for AutoConnection
2 Rule group for AutoDefaults

4. If needed, go to the Advanced tab to change the rules used in the framing
conditions:

a. Select the connection in the Connection selection option: 

• AutoConnection applies the connection defined in the rule group
that you have selected in the first list on the Rule groups tab.

• None does not create a connection.

• Click Select... to select a connection from the Applications &
components catalog. Tekla Structures creates the connection
using the default properties.

b. Select the connection properties in the Parameters selection option:

• Autodefaults applies the properties of the rule group that you
have selected in the first list on the Rule groups tab.
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• No autodefaults applies the default connection properties.

5. Click Create connections.

TIP You can also use the Auto connect selected parts macro to automatically
create connections using the current properties without opening the
AutoConnection dialog box.

Macros are located in the Applications group in the Applications &
components catalog.

See also

Define AutoConnection settings and rules (page 775)

AutoDefaults
Use AutoDefaults to set up properties for existing connections. AutoDefaults
allows you to modify the default connection properties and save them for use
in specific circumstances. When you use AutoDefaults, Tekla Structures
automatically creates the connections with the predefined AutoDefaults
properties. You can also use AutoDefaults for a single connection.

For example, you can use AutoDefaults to automatically adjust the thickness of
each base plate you create, according to the main part profile. If the main part
profile changes, Tekla Structures automatically adjusts the thickness of the
base plate.

NOTE Before using AutoDefaults in a working model, we recommend that you
create a test model, and create all the connection conditions in it that you
need for a particular project. You can then use this test model to check the
rules and properties of various connection types. It also acts as a quick
reference for connection information.

See also

Define AutoDefaults settings and rules (page 780)

Modify a connection using AutoDefaults (page 785)

AutoConnection and AutoDefaults rules (page 785)

Define AutoDefaults settings and rules
Use AutoDefaults to set up properties for existing connections. AutoDefaults
chooses connection properties based on the framing condition. With
AutoDefaults you can create rules that define the situations where the
predefined properties are used.

To apply the configured AutoDefaults settings and rules to connections, see
Modify a connection using AutoDefaults (page 785).
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AutoDefaults settings

To open the AutoDefaults setup dialog box, click File --> Catalogs -->
AutoDefaults settings.

Icon Setup level Description
Rule group You can use rule groups to organize settings

according to different standards, projects,
manufacturers, and models. You can create,
modify and delete rule groups.

Components The component tree structure shows the
connections that are available on component
toolbars in Tekla Structures.

Rule set Rule sets control which properties to use in
certain situations. You can create additional rule
sets.

Tekla Structures processes AutoDefaults rule sets
in the order in which they are in the tree, so you
can control the selection of properties.

Properties file The properties files are under the rule sets. By
default, each connection has a standard
properties file that defines the standard
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Icon Setup level Description
properties, for example, standard.j144 or
standard.j1042.

You can create additional properties files for the
properties that you want to use again and give
the files distinctive names.

Defaults.zxt file

When you use AutoDefaults, Tekla Structures saves the AutoDefaults rules in a
zipped defaults.zxt text file in the \attributes folder under the current
model folder.

You can copy the defaults.zxt file to the project or firm folder to make it
available in other models. Each time you modify the AutoDefaults setup, you
need to recopy this file to the firm or project folder. To use the modified setup
in other models, restart Tekla Structures.

NOTE We do not recommend that you edit the defaults.zxt file using a
text editor, but if you do, ensure that you are using the right syntax.
The easiest way to unzip the .zxt file is to change the file
extension .zxt to txt.gz and unzip the file. Change the extension
back to .zxt when you have finished. You do not need to zip the file
after editing it, Tekla Structures can also read the unzipped file.

Limitation

AutoDefaults only affects connection parts (clip angles, shear tabs, end plates,
…), bolts, and welds. AutoDefaults cannot change beam profiles or the
connection number.

Create a rule group for AutoDefaults

You can define rule groups for AutoDefaults to group the rules according to
different standards, projects, or manufacturers, for example.

1. On the File menu, click Catalogs --> AutoDefaults settings.

2. Right-click an existing rule group and select New Rule Group.

3. Click the New group to rename it. 

Give the rule group a name that reflects the contents of the group. For
example, use the fabricator's name, the project name, or any name that
clearly identifies the rules that you want to use for a specific model.

When you create a new rule group, Tekla Structures automatically adds the
existing components to the group.
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Create a rule set for AutoDefaults

You can create rule sets to define which connection properties are used when
specific conditions in the model are met.

1. On the File menu, click Catalogs --> AutoDefaults settings.

2. Click the plus icon in front of the rule group  to open the tree structure.

3. Click the plus icon in front of the relevant group of components  and
connection .

4. Right-click an existing rule set and select New Rule Set.

5. Right-click the new rule set and select Edit Rule Set....

6. Enter a name for the rule set.

7. Select a rule from the Available rules list.

8. Click the right arrow button to move the selected rule into the list of Rules
in rule set.

9. Enter the values used in the rule: either an exact value, or minimum and
maximum values.

10. Select from the Parameter files selection in rule set list how the
properties are selected in the rule set. 

Option Description
Use
combination of
first
parameters

Tekla Structures uses the properties files it finds in the first
matching sub-rule set and does not check other rule sets.

Iterate until
connection
symbol is
green

Tekla Structures checks sub-rule sets until it finds matching
properties.

Iterate until
connection
symbol is
yellow

Tekla Structures checks sub-rule sets until it finds matching
properties.

Use
combination of
all parameters

Tekla Structures checks all rule sets and uses the properties
files in all matching rule sets. The order of the properties
files is important.

When Tekla Structures combines the properties files, the
most recent files (the lowest in the tree) override previous
ones. If you do not enter any values for the properties,
Tekla Structures does not override the previous property
values.

11. Click OK.

Components 783 Automate connection creation



NOTE The order of the rules (page 788) in the tree structure is important. Tekla
Structures uses the first rule that matches the conditions within the model so
you should place the most limiting rule highest in the tree, and the most
generic rule lowest.

You can change the priority of a rule set by right-clicking the rule set and
selecting Move up or Move down.

Modify connection properties for AutoDefaults

Each connection has a default standard property file that defines the
properties for the connection. You can modify the properties that the standard
file uses. Save the connection properties that you want to use and set the
standard file to use these properties (page 785) in the AutoDefaults settings.

1. On the File menu, click Catalogs --> AutoDefaults settings.

2. Click the plus icon in front of the rule group  to open the tree structure.

3. Click the plus icon in front of the relevant group of components  and
connection .

4. Right-click the standard.j connection file that you want to modify, for
example, standard.j144 and select Edit Connection Parameters....

5. In the connection dialog box, set the properties that you want to save. 

Such properties could be, for example, bolt properties, profiles, and
materials.

6. Enter a descriptive name for the properties in the box next to the Save as
button.

7. Copy this name in the Connection code option on the General tab. 

Using the same name allows you to check which properties Tekla
Structures used in specific situations. Tekla Structures does not
automatically show the AutoDefaults values in the connection dialog box.

8. Click Save as. 

Tekla Structures saves the properties file in the \attributes folder
under the current model folder. The filename consists of the name you
entered in Save as and the file extension .jXXX, where XXX is the
connection number, for example, sec_0-190.j144.

9. Click Cancel to close the connection dialog box and return to the
AutoDefaults setup dialog box. 

If you click OK to close the connection dialog box, you need to load the
default properties the next time you use the connection. Using the default
properties ensures that AutoDefaults can modify the properties.
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10. Right-click the standard.j file again and select Select Connection
Parameters.... 

The Attribute File List dialog box that opens contains the properties that
have been set and saved in the connection dialog box.

11. Select a file in the Attribute File List dialog box.

12. Click OK.

Modify a connection using AutoDefaults
When you use a connection that you are unfamiliar with, first use the default
properties. Then use AutoDefaults to modify the properties.

1. Double-click a connection symbol in the model to open the connection
dialog box.

2. On the General tab, select a rule group from the AutoDefaults rule
group list.

3. On all tabs, select the AutoDefaults options marked with the arrow symbol
 for the properties in which you want to use AutoDefaults.

4. Click Apply.

If you manually modify the properties after using AutoDefaults, Tekla
Structures uses the manually modified properties.

For example, you have manually set the base plate thickness of a connection
to 20 mm. AutoDefaults is active and sets the plate thickness according to the
main part profile. If you modify the main part profile, Tekla Structures does not
update the base plate thickness. It remains at 20 mm.

NOTE You can view which AutoDefault rules and properties are used:

• To view AutoDefaults rules, select the connection symbol in the model,
right-click and select Inquire .

Tekla Structures shows the rule group, rule sets and properties files used.

• To view the AutoDefaults properties, double-click the connection symbol in
the model, select <AutoDefaults> in the list box next to the Load button
and click Load.

See also

Define AutoDefaults settings and rules (page 780)

AutoConnection and AutoDefaults rules
You can create your own AutoConnection and AutoDefaults rules for project
and company defaults. By defining rules you can accurately select connections
and connection properties when using AutoConnection and AutoDefaults.

Components 785 Automate connection creation



General rules

• Profile name is the name in the profile catalog.

• Profile type

Profile type Number
I 1
L 2
Z 3
U 4
Plate 5
Round bar 6
Pipe 7
Square pipe 8
C 9
T 10
ZZ 15
CC 16
CW 17
Polygon plate 51

• Number of secondary parts

• Number of main parts

• Material name

Orientation rules

Depending on the relative angle of a beam, the connections can be classified
as sloped, skewed, or cant. The angle value can be between - 90 and 90
degrees.

• Sloped angle (relative to main part cross section)

The longitudinal axis of the secondary part follows the slope of the
longitudinal axis of the main part.

• Skewed angle (relative to main part longitudinal axis)
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The longitudinal axis of the secondary part is skewed according to the main
part cross section. The angle is the smaller of the angles between the
longitudinal axis of the secondary part and the main part Z or Y axis.

• Cant angle

For rotated secondary parts

Dimension rules

• Profile depth

• Web depth

For profiles with an upper and lower flange, the web depth is: h-t1-
t2-2*r1
Or, if t2 is zero: h-2*t-2*r1
For profiles with one flange, the web depth is h-t-r1-r2.

• Web thickness

• Flange thickness

Forces and strengths

• Shear force

• Axial force

• Bending moment
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See also

Combining and iterating properties for AutoDefaults (page 788)

AutoDefaults example: Using iteration with connection check (page 790)

Using reaction forces and UDLs in AutoDefaults and AutoConnection
(page 792)

Combining and iterating properties for AutoDefaults

Combining properties

You can save properties files that cover different groups of properties and use
these files to define many rules. For example, you can have one file for bolt
properties and another for profile properties. AutoDefaults combines the
separate files into one file. This means that you can define fewer files because
you can use one file for several rules. If the files contain different values for
the same property, Tekla Structures uses the last property it finds, see the
example image below.
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Iterating properties

Tekla Structures tests the properties until the connection symbol is yellow or
green. Iteration changes the properties automatically if the connection is not
created successfully, even if the rules match. If connection check is active, the
iteration results in properties that have passed the check.
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Limitations

• Tekla Structures cannot iterate property files directly. Use a single iteration
rule set with sub-rule sets.

• You cannot have many parallel iteration rule sets. Use a single iteration rule
set and place it just before the default rule set.

• Place the combination rule sets above the iteration rule set in the
AutoDefaults tree structure.

• Combination rule sets can only be one level deep.

• Tekla Structures disregards empty rule sets, so include at least one rule in
each rule set.

See also

Define AutoDefaults settings and rules (page 780)

AutoDefaults example: Using iteration with connection check
You can use the connection check result when using AutoDefaults with
iteration. If an iteration rule matches, but the connection does not pass the
connection check and the connection symbol remains red, AutoDefaults
continues testing other rules and properties until the connection symbol is
green.

In this example, you will create iteration rules to set the number of bolts
according to the result of the connection check. After this, you will use the
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rules group and connection check together for a connection. The example
image below shows the rules in the AutoDefaults setup dialog box.

To create iteration rules for use with connection check:

1. On the File menu, click Catalogs --> AutoDefaults settings.

2. Right-click the tree and select New Rule Group.

3. Click the new rule group and rename it to Iteration example.

4. Browse the Iteration example tree to find End plate (144), right-click
it, and select Create Additional Rule Sets.

5. Right-click the New rule set and select Edit Rule Set.

6. Change the rule set name to ITERATION.

7. Set the Parameter file(s) selection in rule set option to Iterate until
connection symbol is green.

8. Click OK.

9. Right-click the ITERATION rule set and select Create Additional Rule
Sets.

10. Right-click the New rule set and select Edit Rule Set.

11. Change the rule set name to 2 bolts.

12. Select the rule Secondary 1 depth and set the minimum and maximum
depth values for two bolts.

13. Set the Parameter file(s) selection in rule set option to Use
combination of first parameters.

14. Click OK.
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15. Right-click the connection properties file standard.j144 under 2 bolts
and select Select Connection Parameters.

16. Select a properties file for two bolts in the Attribute File List and click
OK. 

TIP If there is no suitable properties file, you can create a new file. Right-
click the standard.j144 file and select Edit Connection
Parameters. Save the needed properties and click Cancel to close
the dialog box. The saved properties are now available in the
Attribute File List.

17. Click Apply to have the changes available in the connection dialog box.

18. Repeat steps 9 to 16 for other rule sets.

19. Open the End plate (144) dialog box.

20. Select <Defaults> from the list next to the Load button and click Load.

21. On the General tab, set the AutoDefaults rule group option to the
Iteration example you created.

22. On the Design type tab, set the Check connection option to Yes.

23. Enter the load from secondary members in the Shear, Tension, and
Moment options.

24. Click OK.

See also

Define AutoDefaults settings and rules (page 780)

Combining and iterating properties for AutoDefaults (page 788)

Using reaction forces and UDLs in AutoDefaults and AutoConnection
You can set reaction forces for AutoConnection and AutoDefaults in the user-
defined attributes of a part, and for AutoDefaults also on the Design tab in the
connection dialog box.

Reaction forces

When you use reaction forces in a rule and AutoDefaults is activated, Tekla
Structures first searches for reaction forces in the corresponding connection’s
properties. If the properties do not contain reaction forces, Tekla Structures
searches the user-defined attributes of the secondary part of the connection.
If Tekla Structures does not find forces there, you cannot use reaction force
rules.

Shear force calculation

If you have not given any reaction force values, shear force is calculated using
the UDL (uniformly distributed load) shear force routine. The UDL calculation
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is mainly intended for use with imperial units. It uses the yield stress value,
profile dimensions, and UDL percentage to calculate the maximum shear force
allowed.

• Yield stress is defined in the material catalog.

• Profile dimensions come from the profile catalog.

• UDL percentage is taken either from the connection dialog box or from an
advanced option.

Tekla Structures compares the result with the shear force rule in AutoDefaults.

To use UDLs for AutoConnection and AutoDefaults:

To Do this
Use UDL for
AutoConnectio
n

1. On the Design tab in the connection dialog box, set the
UDL option to Yes.

2. Enter the UDL percentage in the UDL% box.

If you do not enter any value, Tekla Structures uses a
default percentage set with the 
XS_AUTODEFAULT_UDL_PERCENT advanced option.

Use UDL for
AutoDefaults

1. On the Design tab in the connection dialog box, set the
Use UDL option to Yes.

2. Enter the UDL percentage in the UDL % box.

If you do not enter any value, Tekla Structures uses a
default percentage set using the 
XS_AUTODEFAULT_UDL_PERCENT advanced option.

See also

Design and Design type tabs (page 818)

7.9 Advanced component settings
This section describes how to set default properties for different connection
types, how to use Excel spreadsheets in connection design, and advanced
component properties, such as analysis and design properties.

Click the links below to find out more:

Define connection properties in the joints.def file (page 794)

Excel spreadsheets in connection design (page 806)

General tab (page 816)

Design and Design type tabs (page 818)

Components 793 Advanced component settings



Analysis tab (page 820)

Define connection properties in the joints.def file
The joints.def file contains general connection settings and connection-
specific settings for different connection types. You can use the joints.def
file to set the default properties for different connection types. Joints.def is
a text file that you can open and edit in any standard text editor.

Tekla Structures uses the values defined in the joints.def file for the
properties that do not have values in the connection dialog boxes. If you
manually enter values in the connection dialog boxes, the manually entered
values are used instead of the values in the joints.def file. AutoDefaults
also override the values defined in the joints.def file.

Tekla Structures stores the joints.def file in the system folder. Tekla
Structures searches for the joints.def file in the standard search order:
model, project, firm, and system folder.

How to use the joints.def file
The joints.def file contains general connection settings and connection-
specific settings for different connection types in separate sections. You can
modify the joints.def file using any standard text editor.

When you modify the file:

• Enter absolute values or names.

• Do not use feet and inch symbols.

• Ensure that the profiles exist in the profile catalog.

• Ensure that the bolts exist in the bolt catalog.

• You can set the measurement units at the beginning of the file.

• You can define in the JOINTDEFAULT line whether Tekla Structures uses
the default values in the joints.def file or the system default values, for
example, as follows:

• Value 1 means that the default values defined in the joints.def file
are used.

• Value 0 means that the system default values are used.

• The // characters at the beginning of a line mean that the line is a
comment line. Tekla Structures does not use the information on these
lines.
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• You can force Tekla Structures to use the system default for a particular
property by entering the value -2147483648 for the property.

Connection-specific properties

The properties for clip angles, shear tabs, end plates, gusset connections and
diagonal connections are in separate sections. Each section begins with a
header row that contains the column labels, for example as follows:

joints.def

Do not add columns to the file. If Tekla Structures cannot find a property in the
connection-specific section, it searches for the default property in the general
defaults section.

Connections that use the joints.def file

The following connections use the joints.def file:

• Welded gusset (10)

• Bolted gusset (11)

• Bracing cross (19)

• Tube gusset (20)

• Tube crossing (22)

• Two sided angle cleat (25)

• Corner tube gusset (56)

• Corner bolted gusset (57)

• Wraparound gusset (58)

• Hollow brace wraparound gusset (59)

• Wraparound gusset cross (60)

• Wrapped cross (61)

• Gusseted cross (62)

• Corner wrapped gusset (63)

• Beam with stiffener (129)

• Column with shear plate (131)

• Bolted moment connection (134)

• Clip angle (141)

• Two sided end plate (142)

• Two sided clip angle (143)

• End plate (144)

• Shear plate simple (146)
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• Welded to top flange (147)

• Welded to top flange S (149)

• Moment connection (181)

• Column with stiffeners W (182)

• Full depth (184)

• Full depth S (185)

• Column with stiffeners (186)

• Column with stiffeners S (187)

• Column with stiffeners (188)

• Shear plate tube column (189)

• Bent plate (190)

Example: How Tekla Structures uses the joints.def file
This example explains how Tekla Structures calculates the bolt diameter and
other properties of the Bolted gusset (11) connection using the joints.def
file.

The height of the diagonal profile is 10". Tekla Structures calculates the bolt
size and the number of bolts according to the profile height. It searches the 
BOLTHEIGHT rows for a profile height of 10".

As the profile height is greater than 8.0 but under 12.0, Tekla Structures uses
the row with profile height 8.0. This sets the bolt diameter to 0.75.

Tekla Structures uses the bolt diameter to assign the bolt and part properties.
It searches the DIAGBOLTPART rows for bolt diameter 0.75.

The following property values are used:

Bolt diameter 0.75
Number of
bolts
horizontally

2

Edge distance
horizontally

1.5
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Edge distance
vertically

1.5

Distance
between bolts
horizontally

2.5

Distance
between bolts
vertically

System default is used.

Tekla Structures does not use the connection plate thickness or angle profile
properties in this connection.

General defaults in the joints.def file
Tekla Structures uses the general defaults in the joints.def file if it cannot
find a connection property in the connection-specific section.

For example, for clip angles, Tekla Structures determines the bolt diameter
and the number of bolts according to the secondary beam height. If the
secondary beam is higher than the highest value in the clip angle section in
the joints.def file, Tekla Structures uses the default bolt diameter in the
general defaults.

The properties in the general defaults section in the joints.def file are:

Property Description
boltdia Bolt diameter
pitch Distance from the center of one bolt to the center of the

next bolt
clipweld Weld size
angle-cc-inc Tekla Structures adds bolt to bolt distance and web

thickness, then rounds up the result using this value.
Complies with the US AISC standard.

lprofgapinc Tekla Structures rounds up the angle profile gap using this
value. Complies with the US AISC standard.

lsize Size of the angle profile
copedepth Notch size
copelength Notch size
boltedge Edge distance
webplatelen Haunch plate height (h)
webplatewid Haunch plate width (b)
beamedge Setback distance between the end of the beam and the

main part
knifeclr No longer used
clipedge Edge distance for bolts (clip angles only)
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Property Description
gap No longer used
shearplateth
k

Shear tab thickness

endplatethk End plate thickness
shearweld Size of weld
cliplsize Size of angle profile (clip angles only)
flangecutcle
ar

Flange cut clearance

slotsize Size of slotted hole
clipslots Part with slotted holes:

• 1 = beam

• 2 = angle profiles

• 3 = both

This property is the Slots in option on the Bolts tab.
clip_attac Clip angle attached to the main part and secondary parts:

• 1 = both parts bolted

• 2 = main part bolted/secondary part welded

• 3 = main part not welded

• 4 = main part welded/secondary part bolted

• 5 = both parts welded

• 6 = main part not bolted

• 7 = secondary part not welded

• 8 = secondary part not bolted

• 9 = both parts bolted/welded

This property is the bolt attachment option on the Bolts tab
where the location of bolts is defined.

copedepth_in
c

Tekla Structures rounds up notch depth using this value.

copelength_i
nc

Tekla Structures rounds up notch length using this value.

Bolt diameter and number of bolts in the joints.def file
In the joints.def file, the BOLTHEIGHT rows in each connection-specific
section show the default bolt diameter and default number of bolt rows for
the connection type.
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Tekla Structures determines the bolt diameter and the number of bolts
according to the connection type based on the following properties:

For According to
Clip angles Secondary beam height
Shear tabs Secondary beam height
End plates Secondary beam height
Gusset
connections

Angle profile length

Diagonal
connections

Profile height

Clip angle, shear tab, and end plate connections

Tekla Structures calculates the default bolt diameter and the number of bolt
rows vertically according to the height of the secondary beam. You can enter
the following properties:

Property Description
name BOLTHEIGHT
part ANGLECLIP
sec.beam.height Minimum height of the secondary beam for a certain

number of bolts
diameter Bolt diameter. The diameter must exist in the bolt

catalog.
number_of_bolts Number of bolts vertically

Gusset connections

Tekla Structures calculates the default bolt diameter and the number of bolt
rows horizontally according to the length of the angle profile. You can enter
the following properties:

Property Description
name BOLTHEIGHT
part GUSSET
lproflength or 
angleproflength

Length of the angle profile

diameter Bolt diameter. The diameter must exist in the bolt
catalog.

number_of_bolts Number of bolts horizontally
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Diagonal connections

Tekla Structures calculates the default bolt diameter and number of bolt rows
horizontally according to the profile height. You can enter the following
properties:

Property Description
name BOLTHEIGHT
part DIAGONAL
conn.pl.height
or profileheight

Profile height

diameter Bolt diameter. The diameter must exist in the bolt
catalog.

number_of_bolts Number of bolts horizontally

Bolt and part properties in the joints.def file
Once Tekla Structures has used the joints.def file to calculate the bolt
diameter, it uses the result to assign other properties to bolts and parts,
according to the connection type.

In clip angle connections, for example, the default properties for bolts and
parts are in the rows that begin with ANGLECLBOLTPART in the CLIP ANGLE
section of the joints.def file.

The table below lists the properties that you can assign for bolts and parts in
each connection type.

Property Description Clip
angle

Shear
tab

End
plate

Guss
et

Diago
nal

name Identifies the connection
type.

For example, 
GUSSETBOLTPART for
gusset connections.

* * * * *

bolt
diamete
r

The bolt diameter must
exist in the bolt catalog.

* * * * *

shear
plate
thickne
ss

Thickness of the shear
tab

 *    

end
plate
thickne
ss

Thickness of the end
plate

  *   
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Property Description Clip
angle

Shear
tab

End
plate

Guss
et

Diago
nal

gusset
thickne
ss

Thickness of the gusset
plate

   *  

conn.
plate
thickne
ss

Thickness of the
connection plate

    *

angle
profile
or L
profile

The name of the used
angle profile must exist
in the profile catalog.
Enter the exact profile,
for example: 
L100*100*10.

*   * *

number Number of bolts in each
row vertically and
horizontally.

* * * * *

pitch Distance between the
bolts from the center of
each bolt for vertical and
horizontal bolts

* * * * *

edge
distanc
e

Distance from the center
of a bolt to the edge of
the part for vertical and
horizontal bolts

* *  * *

vert.
bolt
firshol
e

Position of the first
vertical row of bolts

* *  *  

Gusset connection properties in the joints.def file

Enter the additional default properties for gusset connections in the 
GUSSETDEFDIM row . All gusset connections do not use all the properties.

Property Description Affects plate shape
name GUSSETDEFDIM  
boltdia_def Bolt diameter for all bolt groups

Tekla Structures uses this value
if the Bolt size box is empty in
the connection dialog box.

 

tol_prim Tolerance between the gusset
and main part web
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Property Description Affects plate shape
tol_sec Tolerance between the gusset

and secondary part web
 

dist_diag_pri
m

Clearance between the first
secondary part selected and the
main part

 

dist_diag_sec Perpendicular distance from the
last secondary part selected to
the nearest secondary part

 

angle_first_c
orner

Corner angle dimension Yes

angle_sec_cor
ner
dist_between_
diag

Clearance between braces  

first_bolt_fr
om_line

Bolt edge distance for the bolt
groups on the Gusset tab

 

corner_dx Corner dimension  
corner_dy Corner dimension  
movey

 option on the Gusset
tab

 

movez
 option on the Gusset

tab

 

dist1 Edge length of the gusset plate
perpendicular to the lowest
brace

Yes

dist2 Edge length of the gusset plate
perpendicular to the braces

Yes

dist3 Edge length of the gusset plate
perpendicular to the uppermost
brace

Yes

tol_lprof Edge tolerance from gusset
plate to connection plate

 

tol_stiffener Stiffener tolerance  
chamfer_dx Stiffener chamfer dimension on

the Gusset tab
 

chamfer_dy Stiffener chamfer dimension on
the Gusset tab
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Property Description Affects plate shape
chamfer_corne
r_dx

 

chamfer_corne
r_dy

 

side_length Side length  
diafit_length Fit length in the Bracing cross

(19) connection.

Tekla Structures uses this value
if the option on the Parameters
tab is empty.

 

The example image below shows the properties of the Wraparound gusset
(58) connection on the Picture tab.

1. tol_lprof
2. corner_dy
3. corner_dx
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4. dist_diag_sec
5. tol_sec
6. angle_sec_corner
7. dist3
8. dist_between_diag
9. dist2
10. dist1
11. dist_diag_prim
12. tol_prim

Diagonal connection properties in the joints.def file

Enter the additional default properties for bolts and parts in the DIAGDEFDIM
row. All diagonal connections do not use all the properties.

Property Description
name DIAGDEFDIM
boltdia_def Bolt diameter for all bolt groups

Tekla Structures uses this value if the Bolt size box is
empty in the connection dialog box.

dist_gus_diag Gap between the gusset plate and the brace

If the tube profiles are closed with end plates, 
dist_gus_diag is the gap between the gusset plate and
the end plate.

See the Tube crossing (22) image below.
dist_in Cut depth in the brace. Enter a negative value to prevent

the connection plate from being inside the tube brace.

See the Tube crossing (22) image below.
dist_dv Brace edge distance to the edge of the connection plate.

This dimension changes the width of the connection plate.

See the Tube crossing (22) image below.
sec_cut_tol On the Brace conn tab:
slot_length_t
ol

tube_cut_tol On the Brace conn tab:
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Property Description
conn_cut_dx On the Brace conn tab:
conn_cut_dy

round_plate_t
ol

On the Brace conn tab:

flanges_cut_a
ngle

On the Brace conn tab:

dist_flanges_
cut
dist_skew_cut
end_plate_thk End plate thickness

The example image below shows the properties of the Tube crossing (22)
connection on the Picture tab:

1. dist_dv
2. dist_in
3. dist_gus_diag

Profile dependent bolt dimensions in the joints.def file

For some connections, such as Clip angle (141) and Two sided clip angle
(143), Tekla Structures calculates the bolt size according to the profile size.

For these connections, Tekla Structures takes the bolt size from the 
PROFILEBOLTDIM rows of the PROFILE TYPE-DEPENDENT BOLT
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DIMENSIONS section in the joints.def file if you leave the corresponding
options empty on the Bolts tab.

Property Description
width Profile width
one bolt
firsthole

For single bolts, distance from the edge of the profile
angle to the first hole

two bolts
firsthole

For two bolts, distance from the edge of the profile
angle to the first hole

pitch Distance between bolts from the center of each bolt,
for vertical and horizontal bolts

For example, to find the bolt dimensions to be used with an L6X6X1/2 profile
in a clip angle connection:

1. Tekla Structures first searches the PROFILEBOLTDIM rows for L6X6X1/2
in the PROFILE TYPE-DEPENDENT BOLT DIMENSIONS section.

2. If there is no match, Tekla Structures then searches the 
ANGLECLBOLTPART rows in the CLIP ANGLE section.

Excel spreadsheets in connection design
You can use Excel spreadsheets in connection design for all steel connections
that have the Design or Design type tab in the connection dialog box.

You can link connections to Excel spreadsheets by selecting Excel in the
External design option on the Design or Design type tab. The connection
information is transferred to the connection type-specific spreadsheet where
the needed calculations are made. The calculated properties are saved to an
output file and the modified component property values are transferred back
to the connection. The connection is modified according to the changes.

You can create an Excel spreadsheet for a connection type using the
component_template.xls file available in the ..\Tekla Structures
\<version>\Environments\common\exceldesign folder, or use a
predefined file.
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Files used in Excel spreadsheet connection design
The following files are used in the connection design with Excel spreadsheets:

File Description
Visual Basic script file The Excel.vb file links Tekla Structures with the

external software and defines the Excel spreadsheet
file names and the locations. The file is located in
the ..\Tekla Structures\<version>
\Environments\common\exceldesign folder.

Component type-
specific Excel
spreadsheet

The component type-specific spreadsheet contains
predefined calculations. When you run the connection
design, the connection properties and information of
the main and secondary parts are transferred to the
Input and Component sheets of the Excel
spreadsheet.

Excel searches for the relevant spreadsheet file in the
following order:

1. From the \exceldesign folder in the current
model folder: file named as component_ + 
number or name + .xls, for
example, ..\test_model\exceldesign
\component_144.xls.

2. From the location defined with the 
XS_EXTERNAL_EXCEL_DESIGN_PATH advanced
option as follows:

XS_EXTERNAL_EXCEL_DESIGN_PATH (=
%XS_DIR%\environments\common
\exceldesign\) + "component_" + number
+ ".xls"

Connection specific
result file

The result file contains the modified connection
properties.

• The result file is created automatically from the
Calculation sheet.

• The file is stored in the \exceldesign folder in
the model folder and named with the GUID,
Globally Unique Identifier.

• The file is updated each time you modify the
connection.

• The calculation results can be stored as an Excel
spreadsheet, or in HTML or PDF format, depending
on how the calculation spreadsheet is configured.
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File Description
Template
spreadsheet

The ..\Tekla Structures\<version>
\Environments\common\exceldesign folder
contains a component_template.xls spreadsheet
you should use to create your own spreadsheet
applications to use with Tekla Structures components.

Example of an Excel spreadsheet in connection design
The images in this example show the Excel spreadsheet that is used for the
End plate (144) connection.

The sample spreadsheet has the following sheets:

The Calculation sheet contains a report of the calculations.
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The Inputs sheet contains the properties of the connection from the
connection dialog box.
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The Outputs sheet contains the design results. These values are transferred to
the connection and the connection in the model is modified accordingly.

The Component sheet contains calculations, information on the connection
geometry, and on the main part and the secondary parts. The component
attributes in the spreadsheet are the same as in the corresponding .inp file.
See more about .inp files in .
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The following sheets are also included:

• Data shows catalog information.

• Norm shows the code selection and references to codes.

• Language shows translations.
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Example of visualizing the Excel connection design process
You can define in the Excel.vb file how the Excel connection design process
is visualized. The Excel.vb file links Tekla Structures with the external
software and defines the Excel spreadsheet file names and the locations.

1. Open the Excel.vb file located in ..\Tekla Structures\<version>
\Environments\common\exceldesign.

2. Configure the Excel.vb file as follows: 

• Visualizing control - Const DEBUG As Boolean= True
• Visualizing using Excel - Const SHOW_EXCEL As Boolean = True
• Storing the output - Const STORE_RESULTS As Boolean = True

3. Save the file.

4. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

5. Search for Clip angle (141) and double-click it to open the properties
dialog box.

6. On the Design type tab:
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a. Select Excel in the External design option.

b. Enter the load values.

7. Click Modify. 
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The Excel design file opens and shows the Inputs sheet.

8. Click OK to continue. 
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The Excel design process now calculates the data that is shown on the
Component sheet, and then opens the Component sheet.

9. Click OK to continue. 

The Excel design process now calculates the result output values and then
opens the Outputs sheet. The calculated results values are transferred to
the connection.
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10. Save the file in the model folder.

11. When you click OK, the design process is completed and the Excel design
file is closed.

Showing connection status in Excel connection design
When you use Excel spreadsheets in connection design, you can have Tekla
Structures use different colors in component symbols to show the status of a
component in the model.

You can do this by including an error attribute on the Outputs sheet of the
component's Excel spreadsheet. The type of the attribute is int.

The possible values are:

Val
ue

Colo
r

Status

1 Gree
n

Bolt edge distances are sufficient.

The connection passes the connection design check using the UK
and US design codes embedded in the system.

2 Yello
w

Bolt edge distances are insufficient according to the value
defined in the Components settings in File --> Settings -->
Options.

3 Red Tekla Structures cannot calculate the component properties. The
possible reasons are:

• The connection direction is not correct.

• The work plane is not correct.

• The selected connection is not appropriate for the situation.

• The connection design check was carried out using the
embedded UK and US design codes and the connection
cannot support the loading you have defined.

NOTE The component symbol color can only be controlled for system components,
not for custom components.

General tab
The General tab is available in steel connections and steel details.
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Option Description
Up direction Rotates the connection around the secondary part or the

detail around the main part.

You can define the rotation angle around the x- and y-axis
of the secondary part. The upper box is for the y-axis and
the lower box for the x-axis.

Position in
relation to
primary part

Available only for details. The check boxes next to the
images indicate the position of the definition point of the
detail, relative to the main part.

Horizontal offset and Vertical offset define the
horizontal and vertical alignment of the detail, relative to
the main part.

Detail type Available only for details. This option determines on which
side of the part the detail will be created, but it depends on
where you pick the input point of the detail.

• End detail

Pick a point on a part. The detail will be created from
the picked point towards the start or end point of the
part depending on which one of them is further from
the picked point. If you pick the mid point of the part,
the detail will be created towards the end (magenta
handle) point of the part. If you pick the start point of
the part, the detail will be created towards the end
point (and vice versa).

• Intermediate detail

Pick a point on a part. The detail will be created from
the picked point towards the start (yellow handle) point
of the part. Do not pick the start (yellow handle) point
of the part.

• Intermediate detail (reverse)

Pick a point on a part. The detail will be created from
the picked point towards the end (magenta handle)
point of the part. Do not pick the end (magenta handle)
point of the part.

Locked Prevents modifications.

You can use the privileges.inp file to control the
access to the Locked attribute.

Class A number given to all parts the connection creates. You
can use class to define the color (page 657) of the parts in
the model.
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Option Description
Connection
code

Identifies the connection. Enter a suitable code.

You can display the connection code next to the
component in the model and in connection marks in
drawings.

1. Open the View Properties dialog box by double-
clicking in the model and click Display....

2. Check that the Component symbols check box is
selected on the Settings tab.

3. On the Advanced tab, select the Connection text
check box.

4. Click Modify.

If you have not entered a connection code, the connection
name will be displayed next to the component.

AutoDefaults
rule group

Automatically sets connection properties according to the
selected rule group. Rule group None switches
AutoDefaults off.

AutoConnectio
n rule group

Automatically switches the connection to another
according to the selected rule group.

See also

AutoDefaults (page 780)

AutoConnection (page 775)

Design and Design type tabs
Some component dialog boxes include a Design tab, others include a Design
type tab. You can use the options on these tabs to check if the component will
bear the uniform distributed load (UDL). Some Design tabs include only the
design check. Tekla Structures saves the design summary as a .txt file in the
model folder.

You can use AutoDefaults rule groups and Excel files in the design check:

• AutoDefaults rule groups automatically modify component properties to
take the calculated load. To define which AutoDefaults rule group to use, go
to the General tab and select the rule in the AutoDefaults rule group list
box.

For more information, see Using reaction forces and UDLs in AutoDefaults
and AutoConnection (page 792).

• The information in an Excel file checks the connection design and
automatically updates component properties to bear the UDL. This is
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useful when you want to check connection design according to other
design codes. See Excel spreadsheets in connection design (page 806).

Design tab

This design check is intended to be used with imperial units.

To check the design:

1. Go to the Design tab and select Yes in the Use UDL list.

2. To use information in an Excel spreadsheet in the UDL calculation, select
Excel in the External design list.

3. Enter the information you want to use in the calculation.

4. Select the connection in the model and click Modify.

Tekla Structures checks the component. A green component symbol
indicates that the connection will bear the UDL, red indicates that it will
not.

5. To view the results of the check, right-click the component symbol and
select Inquire from the pop-up menu.

The Inquire object dialog box shows the summary of the design check
and related information.

See also Excel spreadsheets in connection design (page 806).

Design type tab

This design check is intended to be used with imperial units.

To check the design:

1. Go to the Design type tab and select Yes in the Check connection list.

Tekla Structures checks the connection each time it is used or changed in
the model.

2. Enter the information you want to use in the calculation.

3. Select the connection in the model and click Modify.

Tekla Structures checks the component. A green component symbol
indicates that the connection will bear the UDL, red indicates that it will
not.

4. To view the results of the check, right-click the component symbol and
select Inquire from the pop-up menu.

The Inquire object dialog box shows the summary of the design check:
the part checked, the name of the check, the applied and allowed force
and how much capacity has been used, the results and possible solutions.

Design tab for check design only

The design is based on the British standard BS5950.

The design has the following limitations:
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• Design only works in the UK environment.

• Design is available only if the main part and the secondary parts are
perpendicular.

• Design is available only with two bolts horizontally.

• Design is available only when vertical bolts are defined from the top.

• Design is valid for I profiles only.

To check the design:

1. Go to the Design tab and select On in the Design list.

2. Enter the Tie Force in kilo Newtons (kN).

Tie force is required if the design check is turned on and the framing type
of the connection is beam-to-column. If there is no tie force, enter 0.

3. Enter the Shear Force in kN.

If the design check is turned on, enter a positive value. If there is no shear
force, enter 0.

4. Select the connection in the model and click Modify.

The connection symbol shows the design check status:

• Green means that the design check was successful.

• Yellow means that a warning occurred in the design check.

• Red means that a fatal error occurred in the design check.

5. To view the results of the check, right-click the connection symbol and
select Inquire from the pop-up menu.

The Inquire object dialog box shows the summary of the design check
and related information.

NOTE If the message Numbering not up to date is shown in the Inquire
object dialog box, the marks will not be correct. You need to
renumber the model to ensure that the marks are up-to-date. After
that use the Inquire command again to get the correct marks to the
design check summary.

Analysis tab
Use the Analysis tab in the steel connection or detail dialog box to define how
Tekla Structures handles connections and details in the analysis.
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Option Description
Use analysis restraints Set to Yes to use the analysis properties of the

connection or detail in the analysis instead of
the analysis properties of the parts in the
connection.

You also need to set Member end release
method by connection to Yes in the Analysis
Model Properties dialog box when you create
the analysis model.

For more information, see Analysis model
properties.

Member selection Use to associate the analysis properties with
each connection part (Primary, 1. secondary, 2.
secondary, and so on).

Restraint combination For more information, see Defining support
conditions.Support condition

Longitudinal member
offset

For more information, see Analysis part
properties.

Analysis profile Tekla Structures uses this profile in the analysis
instead of the one in the physical model to take
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Option Description
the stiffness of the connection or detail into
account.

Analysis profile length In the analysis, Tekla Structures overrides the
profile of the part in the physical model for this
length.
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8 Custom components

You can define customized connections, parts, seams, and details for your
project. These are called custom components. You can use custom components
in the same way as any Tekla Structures system component. By editing the
custom components you can create intelligent, parametric custom
components that automatically adjust to changes in the model.

When to use

Define a custom component if you cannot find a predefined system
component (page 759) that meets all your needs. Custom components are
useful especially if you need to create a large number of complex model
objects and copy them across several projects.

Benefits

Once you define and store a custom component in the Applications &
components catalog, you can easily access it from the catalog and use it in
another location in the same model. If you must modify the custom
component, you only need to make the changes once. When you save the
changes, they will be automatically applied to all copies of that custom
component in the model. You can also import and export custom components
as .uel files between models and share the custom components with your
colleagues, or store the custom components in a model template (page 192)
so that they are available with each new model that is based on the used
template.

Custom component types

You can create four types of custom components:
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Type Description Example
Custom part Creates a group of objects

that may contain
connections and details.

Note: Unlike other custom
components, custom parts
are not marked with a

component symbol  in
the model. Custom parts
have the same position
properties as beams have.

Custom
connection

Creates connection objects
and connects the secondary
parts to the main part. The
main part may be
continuous at the
connection point.

Custom detail Creates detail objects and
connects them to a single
part at the location you
picked.
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Type Description Example
Custom seam Creates seam objects and

connects the parts along a
line that you create by
picking with two points. The
parts are usually parallel.

8.1 Examples of custom parts
Custom parts may consists of a single part or a group of parts, and they often
have a complex composition. The following images show some examples of
custom parts:

Steel Company standard
bracing plates

Castellated beam and
cell beam

Built-up beams/columns

Built-up beams
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Standard glazing fixings

Precast concrete Sandwich panel

Lifters

Standard embeds/
inserts

Standard beams

8.2 Examples of custom connections
Custom connections can be used to connect a main part to up to 30 secondary
parts. The connection is made between the main part and the ends of the
secondary parts. The following images show some examples of custom
connections:

Steel Built-up plate seat
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Shear plate

Typical japanese post
connections

Precast concrete Base detail

Double tee to L profile

Column cut-out

Wall panel connections

8.3 Examples of custom details
Custom details can be used to add more information to a single part, such as
extra plates or cut-outs. The following images show some examples of custom
details:
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Steel Backing plates

Cast base

Timber base

Out rigger (stiffeners)
and out rigger plate
(stiffeners)

Precast concrete Door and window

Column patterns

Hollow core end details

Lifting details
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Mock joint/reveal

Side pocket

8.4 Examples of custom seams
Custom seams can be used to connect a main part to up to 30 secondary
parts. They can also be used on one main part only. The seam is made along
the length of the part. The following images show some examples of custom
seams:

Steel Steel stair step

Turnbuckles
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Handrail

Precast concrete Double tee connection

Panel to panel grout
tube connection

8.5 Define custom components
You can define customized components that have all the details you need.

Start by defining a simple custom component which you can modify later.
Defining a simple custom component typically takes only few minutes. You can
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invest more time in defining your custom components if you are planning to
use them in future projects.

By editing the custom components (page 840) even further you can define
self-adjusting, parametric custom components (page 869) that automatically
adjust to changes in the model. This is more time-consuming but can pay off
later when you have a group of parametric custom components which you can
use across several models or projects.

Explode an existing component
When you start defining a custom component, we recommend that you first
apply a similar system component in the model and then explode it. Exploding
means that you ungroup the objects of an existing component. Once the
objects are detached, you can modify, remove or add objects to suit your
needs, and then create new custom components using these objects.
Exploding a component and using the detached objects as a basis for a new
custom component can be useful when you want to create custom
components more quickly.

Alternatively, you can create individually the component objects that are
needed in a custom component, such as parts, cuts, fittings, and bolts.

1. In the model, select the component you want to explode.

2. Right-click and select Explode Component. 

Tekla Structures separates the component objects. You can modify the
objects and use them when you define new custom components.

Define a custom component
The following example shows how to define a simple custom connection.

1. Click the Applications & components  button in the side pane to
open the Applications & components catalog.

2. Click the Access advanced features  button and select Define
custom component.... 
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The Custom Component Wizard dialog box opens.

3. In the Type list, select the component type (page 823): connection, detail,
seam, or part.

4. In the Name box, enter a unique name for the component.

5. Modify the other properties (page 953) on the Type/Notes tab, Position
tab, and Advanced tab, and then click Next >.

6. In the model, select the objects you want to include in the custom
component. 

You can use area selection to select multiple objects simultaneously
(page 113). The main and secondary parts and the grids are ignored when
you select objects for the custom component.
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NOTE If you cannot select desired objects in the model, check the
selection switches and the selection filter settings (page 153).

If you want to include rebar set modifiers (page 533) in the
custom component:

• Ensure that Direct modification is switched off when you
select the modifiers.

• Hold down Shift and select the modifiers one by one. Area
selection does not select modifiers.

7. Click Next >.

8. Select the main part for the component. 

9. Click Next >.

10. Select the secondary parts for the component. 
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To select multiple secondary parts, hold down Shift when you select
them. The maximum number of secondary parts in a custom component
is 30.

NOTE Pay attention to the order in which you select secondary parts.
Tekla Structures will use the same picking order when you use the
custom component in a model.

11. Define any other properties required for this custom component, such as
detail or seam position. 

The properties depend on the component type that you selected in step 4.

12. If you want to adjust any of the settings at this stage, click < Back to
return to the previous page of the Custom Component Wizard.

13. When you are happy with the settings, click Finish to create the custom
component. 

The custom component is added in the model and in the Applications &
components catalog.

14. If needed, add a thumbnail image for the custom component. 

The thumbnail image is displayed in the Applications & components
catalog. In the thumbnail image you can show a typical situation where
the component can be used.

a. Take a screenshot of the custom component.

b. Add a thumbnail image (page 769) of the custom component in the
Applications & components catalog. 
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Tekla Structures shows the thumbnail image in the Applications &
components catalog:

15. If you want to modify custom component settings afterwards:

a. On the custom component editor toolbar (page 840), click the

Modify custom component settings  button.

b. Change the settings.

c. Click OK.

The defined custom component is not intelligent and Tekla Structures does not
adjust dimensions to suit any changes in the model. To have the component
adapt to changes in the model, edit (page 840) the component in the custom
component editor, where you can build dependencies between component
objects and model objects.

Define a nested custom component
You can define more complex custom components by joining two or more
components together as a nested component. This allows you to create
smaller, simpler components and wrap them up into a single component. The
original components become sub-components in the nested component.
Nested components are typically used with precast and cast-in-place
components, such as with embeds.

Do not nest components more than necessary. If you nest more than two
levels, you might run across some limitations. To view the different component
levels in a nested custom component (page 121), hold down the Shift key and
scroll with the mouse wheel.

1. In the model, create the components and other model objects that you
want to include in the nested component.

2. Click the Applications & components  button in the side pane to
open the Applications & components catalog.

3. Click the Access advanced features  button and select Define
custom component.... 

The Custom Component Wizard dialog box opens.
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4. In the Type list, select the type of the nested custom component.

5. In the Name box, enter a unique name for the nested component.

6. Modify the other properties on the Type/Notes tab, Position tab, and
Advanced tab, and then click Next >.

7. Select the components and any other objects you want to include in the
nested component, and then click Next >.

8. Follow the instructions in the Custom Component Wizard to continue. 

You will be asked to select the main and secondary parts for the nested
component. Depending on the component type that you selected in step
4, you may also have to define other properties, such as detail or seam
position.

9. When you are happy with the settings, click Finish to create the nested
component. 

The component is added in the model and in the Applications &
components catalog. The sub-components are shown in the Custom
component browser, together with the other component objects:

10. If you want to change the settings afterwards: 
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a. In the custom component editor (page 840), click the Modify

custom component settings button .

b. Change the settings.

c. Click OK.

WARNING If you use a component of the type plug-in as a sub-component
of a nested component, and change the sub-component's
properties in the custom component editor, note that those
changes may be lost when you save the nested component and
use it in a model.

To prevent losing any properties, link a variable to each plug-in
property that you want to keep. You can also use component
attribute files to do this. For more information, see Examples of
parametric variables and variable formulas in custom
components (page 884).

Example: Define a custom end plate component
This example shows how to define a simple custom component based on an
existing end plate component.

1. Click the Applications & components  button in the side pane to
open the Applications & components catalog.

2. Click the Access advanced features  button and select Explode
component.

3. Select the end plate component in the model. 

Tekla Structures separates the objects in the component.
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4. Click the Access advanced features  button and select Define
custom component....

5. In the Type list, select Connection.

6. In the Name box, enter a unique name for the custom component. 

7. Click Next >.

8. Select the objects you want to use in the custom component, and then
click Next >. 
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You can use area selection (left to right) to select the objects. Tekla
Structures ignores the main part and secondary parts and the grids when
you are selecting objects to include in the custom component.

9. Select the column as the main part, and then click Next >. 

The main part supports the secondary part.

10. Select the beam as the secondary part. 

The secondary part is supported by the main part.

NOTE When you select multiple secondary parts, pay attention to the
order of selection. The custom component will use the same
selection order when you add the component in a model. The
maximum number of secondary parts in a custom component is
30.

11. Click Finish. 
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Tekla Structures displays a component symbol for the new component.

You have now defined a simple custom component, which you can use in
locations similar to where it was originally created. This component is not
intelligent and Tekla Structures does not adjust dimensions to suit any
changes in the model. To make the custom component intelligent, you
need to edit (page 840) it in the custom component editor.

8.6 Edit and save custom components
Use the custom component editor to fine-tune existing custom components,
and to make the components parametric. When you edit a custom
component, Tekla Structures updates all instances of that component
throughout the model with the changes you have made.

Edit a custom component
1. In the model, select the custom component by clicking the green

component symbol .

NOTE Custom parts do not have a component symbol in the model. To

select custom parts, ensure that the Select components 
selection switch is active.
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2. Right-click and select Edit Custom Component.

The custom component editor opens. It consists of the following parts:

• The Custom component browser

• The Custom component editor toolbar
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• Four different views of the custom component

3. Modify the custom component in one of the four custom component
views. You can, for example:

• Add or remove component objects

For example, add extra bolts or stiffeners to the component. Only
component objects, not the main or secondary parts, can be modified
in the custom component editor.

• Bind component objects to a plane (page 850)

• Add a distance between component objects (page 862)

• Set object properties by using parametric variables (page 864)

4. Save the custom component.

Click Yes when prompted to replace all occurrences of the custom
component in the model. All instances of the custom component are now
updated with the changes you made.
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Custom component browser

Custom component browser shows the contents of a custom component in
a hierarchical, tree-like structure. Custom component browser lists the
model objects, to which custom component is attached, and the objects the
custom component creates. You can create links between custom component
variables and component object properties.

The Custom component browser works with the views. When you select a
part in the view, Tekla Structures highlights it in the Custom component
browser, and vice versa.

You can copy names, values, and references (page 868) from main and
secondary parts in the component in the Custom component browser, and
then use them in the Variables dialog box to define the properties of custom
components.

Custom component editor toolbar

Use the tools on the Custom component editor toolbar, for example, to
create distances, select planes, and to save the component.

Icon Description
Creates a distance.

Select the plane first and then the
handle or chamfer where to bind.
Creates a reference distance.

Creates distances automatically.

Tekla Structures binds the selected
part to their handles’ contact planes
(page 960). Tekla Structures selects
planes in the following order:

1. construction planes

2. planes of the main and the
secondary parts

Creates a construction plane
(page 859).
Creates a construction line
(page 859).

Plane types Shows plane types you can use when
defining distance variables.
Edits the type or the position of a
custom component (page 953), or
add notes after you have created the
component.
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Icon Description
Shows all created variables
(page 849).
Opens Custom component browser.

Saves the custom component with
another name.
Saves and update the existing
components in the model.
Closes the editor.

Save a custom component
After modifying a custom component, save the changes.

Tekla Structures saves the custom component in the current model folder, in
the xslib.db1 file, which is a library file containing custom components and
sketches.

To Do this
Save changes to all copies of the
custom component

1. In the custom component editor,

click the Save component 
button.

2. In the Save confirmation dialog
box, click Yes.

Tekla Structures saves the
changes and applies them to all
copies of the custom component
in the model.

Save the component with a new name 1. In the custom component editor,
click the Save with new name

 button.

2. Enter a new name for the
component.

Save and close the component 1. In the custom component editor,

click the Close  button.

2. In the Close custom component
editor message, click Yes.

If you click No, the custom
component editor closes without
saving the changes.
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Protect a custom component with a password
You can set a password to prevent others from modifying a custom
component. Password-protected custom components can still be added to
models as usual.

1. In the model, select a custom component.

2. Right-click the custom component symbol and select Edit Custom
Component.

3. On the Custom component editor toolbar, click the Display variables

 button. 

The Variables dialog box opens.

4. Click Add to create a new parametric variable.

5. In the Name box, enter Password.

6. In the Formula box, enter the desired password.

7. Save the custom component.

The next time someone tries to edit this custom component, they will be asked
for the password.

NOTE If you have a password protected custom component and you explode
the custom component in the Custom component editor, you can
either use the Explode Component or Explode component with
parameters command.

The Explode Component command explodes the custom component
without creating the component parameters and mappings.

The Explode component with parameters command will ask you to
enter the password. Only after entering the correct password will the
component be exploded, and the component parameters and
mappings created.

8.7 Add custom components to a model
Use the Applications & components catalog to add your custom component
to a model.
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Add a custom connection, detail, or seam to a model

1. Click the Applications & components  button in the side pane to
open the Applications & components catalog.

2. To search for a component, browse the catalog or enter a search term in
the search box. 

Custom components have the following symbols in the catalog:

Type Symbol

Custom part

Custom connection or seam

Custom detail

3. Select the custom component you want to add.

4. Follow the instructions on the status bar to add the custom component in
the model.

5. To modify the properties, double-click the custom component in the
model.

Example: Add a custom connection to a model

This example shows how to add a previously created custom end plate
connection (page 837) to a model. Because you have not modified the custom
component to adapt to different situations in the model, you need to add it to
a similar location where it was created. Otherwise the custom component may
not work as required.

1. Click the Applications & components  button in the side pane to
open the Applications & components catalog.

2. In the catalog, select the custom end plate connection you want to add.

Tekla Structures displays instructions on the status bar.

3. Select the column as the main part.

4. Select the beam as the secondary part.

Tekla Structures adds the end plate connection to the model.
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Add or move a custom part in the model
Use the direct modification handles and dimensions when you add or move
custom parts. If you are unable to select custom parts in the model, ensure

that the Select components  selection switch is active.

NOTE This method cannot be used when adding custom parts to faces that
have cuts or edge chamfers. You need to hide the cutting parts and
edge chamfer objects from the view before you add custom parts on
cut or chamfered faces using direct modification.

We do not recommend using this method with custom parts that are
parametric, and in which the input points define the dimensions of the
custom part. The preview is simplified, based on the default custom
part dimensions, and snapping has a different focus than usually.

1. Ensure that Direct modification  is switched on.

2. Click the Applications & components  button in the side pane to
open the Applications & components catalog.

3. In the catalog, select the custom part you want to add.

4. Move the mouse pointer over part faces and edges in the model, and see
how the custom part turns over and adjusts to the part faces. 

If you are adding the custom part to another object, Tekla Structures
shows location dimensions to the nearest object edges.

If you are adding a custom part that has only one input point, press Tab to
rotate it in 90-degree steps around the work plane Y axis.

5. Depending on the number of custom part input points, pick one or two
points to place the custom part in the model. 

Tekla Structures shows the coordinate axes, rotation handles, and location
dimensions that you can use to fine-tune the location and rotation of the
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custom part. The handles are red, green, and blue, according to the local
coordinate system of the custom part.

6. Click the middle mouse button to confirm the location and rotation. 

Tekla Structures adds the custom part to the model.

7. To move the custom part along any of its coordinate axes, drag the
relevant axis handle to a new location. 

8. To rotate the custom part around any of its coordinate axes, drag the
relevant rotation handle to a new location. 

Custom components 848 Add custom components to a model



Press Tab to rotate the custom part in 90-degree steps in the direction of
the selected rotation handle.

9. To move or rotate the custom part by specifying a distance or angle:

a. Select an axis handle, a rotation handle, or a dimension arrowhead.

b. Type the value by which you want the dimension to change. 

When you start typing, Tekla Structures displays the Enter a Numeric
Location dialog box.

c. Click OK to confirm the new dimension.

10. To stop modifying, press Esc.

8.8 Add variables to a custom component
Variables are the properties of a custom component. You can create variables
in the custom component editor and use them to adapt custom components
to changes in the model. Some of the variables appear in the custom
component's dialog box, while others are hidden and are only used in
calculations.

Variable types

There are two types of variables:

• Distance variable: The distance between two planes, or between a point
and a plane. A distance variable binds parts together, or works as a
reference distance.

• Parametric variable: Controls all the other properties in a custom
component, such as name, material grade, and bolt size. Parametric
variables are also used in calculations.
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Distance variables

Use distance variables to bind custom component objects to a plane
(page 850), so that the component objects stay at a fixed distance even if the
surrounding objects change. You can create distance variables manually or
automatically.

You can bind the following objects to a plane:

• construction planes

• reference points of parts (only custom component objects)

• reference points of bolt groups

• chamfers

• part and polygon cut handles

• line cuts

• reference points of reinforcing bars

• reference points of reinforcement meshes and strands

• fittings

You can decide which distance variables are shown in the custom component's
dialog box. Show the variables if you want to edit their values in the dialog box.
Hide the variables if you only use them to bind objects to a plane.

Parametric variables

Use parametric variables to set properties for any object the custom
component creates (page 864). After creating the variable, you will be able to
change the value directly in the custom component's dialog box.

You can also create formulas (page 884) to calculate values. For example, you
can calculate the position of a stiffener relative to the beam length.

You can decide which parametric variables are shown in the custom
component's dialog box. Show the variables if you want to edit their values in
the dialog box. Hide the variables if you only use them in calculations.

NOTE There are some limitations concerning the variable names.

• To be able to correctly reference a variable in your formula, the
variable name must be 19 characters or shorter. Variables with
longer names will not work correctly when referenced.

• Variable names cannot contain mathematical operators (+,-,*,/).

• You cannot use a mathematical constant, such as PI or e, as a
variable name.
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Bind component objects to a plane
Use distance variables to bind component objects to a plane. Binding keeps the
custom component at a fixed distance from the plane even if the surrounding
objects change. Distance variables automatically get the prefix D (distance),
which is shown in the Variables dialog box.

Bind objects automatically
You can bind objects automatically to the main and secondary parts of a
connection or detail. The selected objects, or their handles, are bound to
existing planes if the objects (or handles) are located exactly on the plane.

NOTE You cannot bind custom parts (page 825) automatically, because they
do not have a main part.

1. In the custom component editor, click the Automatically create

distances for picked components' handle points  button.

2. Select an object that has handles (page 307). 

3. Click the middle mouse button to bind the object. 

Tekla Structures binds the object from a maximum of three directions to
the existing planes.

Tekla Structures displays a distance symbol for each binding. Select the
object to see the bindings.
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The corresponding distance variables are shown in the Variables
(page 964) dialog box:

Bind objects manually
Create the bindings manually if you want to bind a custom component from
specific handles only. You can bind an object to a maximum of three planes.

1. Ensure that Direct modification  is switched off. 

The selection of handles is easier when Direct modification is off.

2. Ensure that you are using a model view that shows object faces. 

On the View tab, click Rendering, and use one of the following options:

• Parts grayscale (Ctrl+3)
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• Parts rendered (Ctrl+4)

3. In a custom component view, select the custom component to see its
handles (page 307). 

4. Select the handle that you want to bind to a plane. 

5. In the custom component editor, click the Create distance  button. 

You can also right-click and select Bind to plane.
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6. Move the mouse pointer in a custom component view to highlight the
plane that you want to bind with the handles. 

For example:

NOTE If you cannot highlight the correct plane, change the plane type
(page 960) on the Custom component editor toolbar. Boundary
and component planes work for most profile types, so try to use
them whenever you can.

7. Click the plane to create the binding. 
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Tekla Structures displays a distance symbol for the binding.

The corresponding distance variable is shown in the Variables dialog box:

NOTE If you have created a nested custom component and have used a
component of the type plug-in as a sub-component of a nested
component, or another custom component as a sub-component of a
nested component,

the bindings may be lost or do not work as desired when you save the
nested component and use it in a model.

Test a binding
Test all bindings to see that they work correctly.

To be able to select distances in the model, ensure that the Select distances

 selection switch active.

1. Double-click the distance symbol in a custom component view. 
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The Distance Properties dialog box opens.

2. In the Value box, enter a new value.

3. Click Modify. 

You should see the binding change in the model.

TIP Alternatively, you can test the binding in the Variables (page 964)
dialog box:

a. Enter a new value in the Formula box.

b. Press Enter.

You should see the binding change in the model.

Check a binding
You can check what is bound to what by using the Inquire objects command.

To be able to select distances in the model, ensure that the Select distances

 selection switch active.

1. On the ribbon, click Object.

2. Select a distance symbol in a custom component view. 
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The Inquire object dialog box shows information about the binding.

Delete a binding
Bindings cannot be modified, but you can delete the existing bindings and
then create new ones to rebind the objects.

To be able to select distances in the model, ensure that the Select distances

 selection switch active.

1. Select the binding in a custom component view.

2. Press Delete. 

You can also select the binding in the Variables (page 964) dialog box and
then click the Delete button.

Example: Bind an end plate to a plane
This example shows how to bind the end plate top to the upper side of the
beam.

1. Ensure that Direct modification  is switched off. 

The selection of end plate handles is easier when Direct modification is
off.

2. In a custom component view, select the end plate to see the end plate
handles. 
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3. Select the top handle of the end plate.

4. Right-click the top handle and select Bind to plane.

5. Move the pointer over the upper side of the beam flange to highlight it. 

Here we are using the boundary plane type. If the part profile changes,
the boundary plane is always found.

NOTE If you cannot highlight the desired plane, change the plane type
(page 960) on the Custom component editor toolbar.

6. Click the upper side of the beam flange. 
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A distance symbol appears in the custom component views.

7. Give a descriptive name for the binding you created:

a. In the custom component editor, click the Display variables button

. 

The Variables dialog box opens.

b. In the Label in dialog box box, enter Plate Top to Flange Top
as the name of the new binding.

Bind component objects using magnetic construction
planes or lines
Instead of binding each component object handle to a plane separately, you
can use magnetic construction planes and lines. The objects that are directly
on a magnetic construction plane (or line) will move with the plane (or line),
which means you only need to create one distance variable instead of 8, for
example.

Bind handles using a magnetic construction plane
1. In the custom component editor, click the Create construction plane

button .

2. Pick four points to define the shape of the construction plane. 

For example, create a plane that goes through all the handles and
chamfers of the custom component.

3. Click the middle mouse button. 
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Tekla Structures creates a construction plane. For example:

4. Double-click the plane. 

The plane properties are shown in the property pane.

5. Enter a name for the plane.

6. In the Magnetic list, select Yes.

7. Click Modify. 

Now when you move the construction plane, all handles that are on the
plane are moved as well:

8. Bind the construction plane to a part face:

a. Select the construction plane, right-click and select Bind to plane.

b. Select a suitable part face. 
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For example, the inner flange of the column:

Tekla Structures displays a distance symbol for the binding. Now if
you move the part face, the handles on the magnetic construction
plane will follow.

NOTE Only the objects whose reference points are directly on the
magnetic construction plane are affected. By default, the
magnetic distance is 0.2 mm. To change this setting, use the
advanced option XS_MAGNETIC_PLANE_OFFSET.

Bind handles using a magnetic construction line
1. In the custom component editor, click the Add construction line button

.

2. Pick the starting point of the construction line.

3. Pick the end point of the construction line. 

Tekla Structures creates a construction line.

4. Double-click the line. 

The line properties are shown in the property pane.

5. Enter a name for the line.

6. In the Magnetic list, select Yes.

7. Click Modify. 

Now when you move the construction line, all handles that are on the line
are moved as well.

8. Bind the construction line to a part face:

a. Select the construction line, right-click and select Bind to plane.
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b. Select a suitable part face. 

Tekla Structures displays a distance symbol for the binding. Now if
you move the part face, the handles on the magnetic construction
line will follow.

Add a distance between component objects
Use reference distance variables to add a distance between two points or a
point and a plane. The reference distance changes as you move the objects it
refers to. You can use reference distances in calculations, for example, to
determine the spacing of rungs on a ladder. Reference distance variables
automatically get the prefix D (distance), which is shown in the Variables
dialog box.

1. In a custom component view, select a handle (page 307). 

This is the starting point for your measurement.

2. In the custom component editor, click the Create reference distance

button .

3. Move the mouse pointer in the view to highlight a plane. 
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This will be the end point for your measurement. If you cannot highlight
the correct plane, change the plane type (page 960) on the Custom
component editor toolbar.

4. Click the plane to select it. 

Tekla Structures displays the distance.

The corresponding reference distance variable is shown in the Variables
dialog box:
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Note that the Create reference distance command remains active. You
can click more planes if you want to measure other distances.

5. To stop measuring, press Esc.

6. To check that the reference distance works correctly, move the handle. 

The distance changes accordingly. For example:

See also

Add variables to a custom component (page 849)

Set object properties by using parametric variables
Use parametric variables to set basic properties (such as name, material,
profile, position number, and so on) for any object the custom component
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creates. Parametric variables automatically get the prefix P (parameter), which
is shown in the Variables dialog box.

The following example shows how to create a variable that sets all welds in a
custom component to a given size. After creating the variable, you are able to
change the weld size directly in the custom component's dialog box.

1. In the custom component editor, click the Display variables button . 

The Variables dialog box opens.

2. Click Add to create a new parametric variable.

3. In the Name box, enter a name for the variable. 

You can also use the default name, such as P1. In this example, enter
Weldsize as the name of the variable.

4. In the Value type list, select a suitable value type (page 964). 

The type determines what kind of values can be used with this variable. In
this example, select Length, which is suitable for lengths and distances.

5. In the Formula box, enter a value or variable formula. 

Leave this box empty.

6. In the Label in dialog box box, enter a descriptive name for the
parametric variable. 

This label will be shown in the custom component's dialog box. In this
example, enter Weld size as the label.

7. In the Visibility list, define whether the variable will be visible in the
custom component's dialog box. 

Hide the variable if you only use it in calculations. Show the variable if you
want to be able to edit the value in the custom component's dialog box. In
this example, select Show.

8. Click Close. 

You have now created a parametric variable with the following settings:

9. In the Custom component browser, link the variable to the desired
object property.
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a. Select the property. 

Select the Size above line property of the uppermost weld.

b. Right-click the property and select Add Equation. 

c. After the equal sign, enter the name of the parametric variable. 
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Enter Weldsize here.

You can now modify the Size above line property by using the Weld
size box in the custom component's dialog box.

10. Repeat step 9 for any other property of the same type, if needed. 

Repeat the procedure for the other welds as well, so that they will all be
linked to the Weld size box in the custom component's dialog box.

11. Save the custom component. (page 844) 
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The variable is now displayed in the custom component's dialog box,
unless you set the visibility of the variable to Hide in step 7.

If you change the weld size value now, the size of all welds within the
custom component will change accordingly.

See also

Copy properties and property references from another object (page 868)

Copy properties and property references from another
object
You can copy properties, such as names and values, from other objects and
use them to determine the properties of a custom component. You can also
copy property references. The link is dynamic, so when the property changes,
the reference reflects the change. For example, you can use a beam length
reference in variable formulas. Even if the length changes, the correct value is
always used in calculations.

1. In the Custom component browser, browse for the object property you
want to copy. 

To find the required component object more easily, select it in a custom
component view. Tekla Structures highlights the selected object in the
Custom component browser.

2. Right-click the property and select one of the following: 

• Copy Name

Copies the name of the object. For example, Material.

• Copy Value

Copies the value the object currently has. For example, S235JR.

• Copy Reference

Copies the link to the property. For example, 
fP(Material,"ID57720EEE-0000-000E-3134-363730393237").
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3. Right-click where you want to insert the object property, and then select
Paste. 

For example, you can paste a reference to the Formula box in the
Variables (page 964) dialog box to use it in a calculation.

See also

Examples of parametric variables and variable formulas in custom
components (page 884)

Create a variable formula
Use variable formulas to add more intelligence to your custom components.
Variable formulas always begin with the equal sign (=). At its simplest, a
formula can be a simple dependency between two variables, stating that P2
equals half of P1 (P2=P1/2), for example. To create more complex calculations,
you can use functions and operators inside the formula. For example, you can
add mathematical expressions, if statements, references to object properties,
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and so on. When you create formulas, note that multiplication is faster than
division, for example, P1*0.5 is faster than P1/2.

The following example shows how to create a formula that sets the weld size
to half the thickness of the secondary part flange. When the component is
used in a model, Tekla Structures will use the thickness of the secondary part
flange to calculate the size of the weld.

1. In the custom component editor, click the Display variables button . 

The Variables dialog box opens.

2. Click Add to create a new parametric variable.

3. In the Name box, enter a name for the variable. 

In this example, enter w as the name of the variable.

4. In the Custom component browser, go to Input objects --> Secondary
parts --> Part --> Profile properties .

5. Right-click Flange thickness 1 and select Copy Reference. 

6. In the Formula box, type =, right-click, and select Paste. 

Tekla Structures pastes the reference to flange thickness from the
clipboard.

7. After the flange thickness formula, enter *0.5. 

The formula should now read:

=fP(Flange thickness 1,"GUID")*0.5
8. Set the other values as follows:

a. In the Value type list, select Length.
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b. In the Visibility list, select Hide.

9. In the Custom component browser, go to Component objects --> Weld
--> General properties .

10. Right-click Size above line, select Add Equation and type = w. 

See also

Functions in variable formulas (page 871)

Functions in variable formulas
You can use functions to calculate values for parametric variables. Variable
formulas always begin with the equal sign (=).

For more information, see Set object properties by using parametric variables
(page 864).

Arithmetic operators
Use arithmetic operators to combine expressions that return numeric values.
You can use the following arithmetic operators:

Operator Description Notes
+ addition Use also to create strings of

parameters.
- subtraction  
* multiplication Multiplication is faster than division.

=D1*0.5 is faster than =D1/2
/ division  
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Logical and comparison operators
Use logical and comparison operators inside if statements. You can use if-
then-else statements to test a condition and to set the value according to the
result.

For example:

=if (D1>200) then 20 else 10 endif
You can use the following operators inside if statements:

Operator Description Example
== both sides are equal  
!= sides are not equal  
< left side is smaller  
<= left side is smaller or

equal
 

> right side is smaller  
>= right side is smaller or

equal
 

&& logical AND

both conditions must
be true

=if (D1==200 && 
D2<40) then 6 else 
0 endif

If D1 is 200 and D2 smaller than 40,
the result is 6, otherwise 0.

|| logical OR

only one condition
must be true

=if (D1==200 || 
D2<40) then 6 else 
0 endif

If D1 is 200 or D2 is smaller than 40,
the result is 6, otherwise 0.

Reference functions
Use reference functions to refer to the property of another object, such as the
plate thickness of a secondary part. Tekla Structures refers to the object on the
system level, so if the object property changes, so does the reference function
value.

You can use the following reference functions:

Function Description Example
fTpl("template
attribute",
"object GUID")

Returns the
template attribute
value of an object
that has a given
object GUID.

=fTpl("WEIGHT","ID50B8559A
-0000-010B-3133-3534323730
38")
returns the weight of an object
whose GUID is
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Function Description Example
ID50B8559A-0000-010B-3133-353
432373038.

fP("user-defined
attribute",
"object GUID")

Returns the user-
defined attribute
value of an object
that has a given
object GUID.

=fP("comment",
"ID50B8559A-0000-010B-3133
-353432373038")
returns the user-defined attribute
comment of an object whose
GUID is
ID50B8559A-0000-010B-3133-353
432373038.

fValueOf("paramet
er")

Returns the value
of the parameter.

If the equation is =P2+"*"+P3,
the result is P2*P3
With =fValueOf("P2")
+"*"+fValueOf("P3"), where
P2=780 and P3=480, the result is 
780*480

fRebarCatalogValu
e(BarGrade,
BarSize, Usage,
FieldName)

Returns the
reinforcing bar
catalog value of
an object.

Usage can be
either 2 ("Tie") or
1 ("Main").

FieldName must
be one of the
following:

• 0
NominalDiame
ter

• 1
ActualDiamete
r

• 2 Weight

• 3 MinRadius

• 4 Hook1Radius

• 5 Hook1Angle

• 6
Hook1Length

• 7 HookRadius

• 8 Hook2Angle

fRebarCatalogValue("A500HW
", "10", 1, 2)
returns the size, usage, and
weight of an object whose
reinforcing bar grade is A500HW.
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Function Description Example
• 9

Hook2Length

• 10
Hook3Radius

• 11 Hook3Angl

• 12
Hook3Length

• 13 Area

ASCII file as a reference function
You can refer to ASCII files to get data. Tekla Structures searches for the files in
the following order:

1. model

2. ..\TeklaStructuresModels\<model>
\CustomComponentDialogFiles\

3. project (set with advanced option XS_PROJECT)

4. firm (set with advanced option XS_FIRM)

5. system (set with advanced option XS_SYSTEM)

The format for reading files is the following:

fVF("filename", "key_value_of_row", column_number)
• Key value of row is a unique text value.

• Column number is an index starting from 1.

You can specify a character for data separation: fVF(data file, lookup
value, column#[, separator character]).

• You can use a preferred column separator of choice. This enables the
support for spaces in names, profiles, shapes, and so on, as well as the use
of distance lists as input.

• You can use blank or empty strings as input.

• Only a single character can be used as a separator. For example, you
cannot use a more complex separator such as "/+/", because only the
first character would be considered as a column separator.

Example

The =fVF("Overlap.dat", "MET-202Z25", 5) function is in the Formula
box in the Variables dialog box. The function gets the value 16.0 for the
profile MET-202Z25, from the Overlap.dat file.
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1. Key value of the row (MET-202Z25)

2. Column number (5)

Mathematical functions
Use mathematical functions to create more complex mathematical
expressions. You can use the following functions:

Function Description Example
fabs(parameter) Returns the absolute value of

the parameter
=fabs(D1) returns
15

if D1 = -15
exp(power) Returns e raised to the power

e is Euler’s number.

=exp(D1) returns
7.39

if D1 = 2
ln(parameter) Returns the natural logarithm

of the parameter (base
number e)

=ln(P2) returns 2.71

if P2 = 15

log(parameter) Returns the logarithm of the
parameter (base number 10)

=log(D1) returns 2

if D1=100
sqrt(parameter) Returns the square root of the

parameter
=sqrt(D1) returns 4

if D1 = 16
mod(dividend,
divider)

Returns the modulo of the
division

=mod(D1, 5) returns
1

if D1 = 16
pow(base number,
power)

Returns the base number
raised to the specified power

=pow(D1, D2)
returns 9

if D1 = 3 and D2 = 2
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Function Description Example
hypot(side1,side2) Returns the hypotenuse

1. side1

2. hypotenuse

3. side2

=hypot(D1, D2)
returns 5

if D1 = 3 and D2 = 4

n!(parameter) Returns the factorial of the
parameter

=n!(P2) returns 24

if P2 = 4

(1*2*3*4)
round(parameter,
accuracy)

Returns the parameter
rounded off to the given
accuracy

=round(P1, 0.1)
returns 10.600

if P1 = 10.567
PI Returns the value of pi to 31

decimal places
=PI returns
3.1415926535897932
384626433832795

Statistical functions
Use statistical functions to calculate sums and averages, and to round values.
You can use the following statistical functions:

Function Description Example (P1 = 1.4 P2 = 2.3)
ceil() Returns the smallest whole

number greater than or equal
to the parameter

=ceil(P1) returns 2

floor() Returns the largest whole
number less than or equal to
the parameter

=floor(P1) returns 1

min() Returns the smallest
parameter

=min(P1, P2) returns 1.4

max() Returns the largest parameter =max(P1, P2) returns 2.3
sum() Sum of the parameters =sum(P1, P2) returns 3.7
sqsum() Sum of the squared

parameters: (parameter1)2 +
(parameter2)2

=sqsum(P1, P2) returns
7.25

ave() Average of the parameters =ave(P1, P2) returns 1.85
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Function Description Example (P1 = 1.4 P2 = 2.3)
sqave() Average of the squared

parameters
=sqave(P1, P2) returns
3.625

Example: Ceil and floor statistical functions

In this example, you have the following parametric variables:

• Beam length: P1 = 3500

• Post spacing: P2 = 450

P1 / P2 = 7.7778

You can use the ceil and floor statistical functions to round the value and
then use the rounded value as the number of beam posts:

• =ceil(P1/P2) returns 8

• =floor(P1/P2) returns 7

Data type conversion functions
Use data type conversion functions to convert values into another data type.
You can use the following data type conversion functions:

Function Description Example
int() Converts data to integer Useful especially for calculating

profile dimensions:

=int(100.0132222000) returns
100, if decimals are set to 0 in the
Options dialog box

double() Converts data to a double  
string() Converts data to string  
imp() Converts imperial units

Use this function in
calculations instead of
imperial units. You cannot
use imperial units directly
in calculations.

For the following examples,
length unit is set to mm and
decimals are set to 2 in the
Options dialog box.

=imp(1,1,1,2) meaning 1 foot
1 1/2 inch returns 342.90 mm

=imp(1,1,2) meaning 1 1/2
inches returns 38.10 mm

=imp(1,2) meaning 1/2 inches
returns 12.70 mm

=imp(1) meaning 1 inch returns
25.40 mm

=3’/3" is not possible, but 
=imp(36)/imp(3) is ok
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Function Description Example
vwu(value,
unit)

Converts the length
values and angle values.
The available units are:

• "ft" ("feet", "foot")

• "in" ("inch", "inches")

• "m"

• "cm"

• "mm"

• "rad"

• "deg"

=vwu(4.0,"in") returns 101.60
mm, if length unit is set to mm
and decimals are set to 2 in the
Options dialog box

=vwu(2.0,"rad") returns
114.59 degrees, if angle is set to
degrees and decimals are set to 2
in the Options dialog box

NOTE The units depend on the settings in File menu --> Settings -->
Options --> Units and decimals .

String operations
Use string operations to manipulate character strings. Strings must be inside
quotation marks in variable formulas.

You can use the following string operations:

Operation Description Example (P1 = "PL100*10")
match(param
eter1,
parameter2)

Returns 1 if parameters
are equal and 0 if
different.

You can also use
wildcards *, ?, and [ ]
with the match function.

=match(P1, "PL100*10")
returns 1

Accept all profiles starting with
PFC: =match(P4, "PFC*")
Accept profiles starting with PFC,
and height starts with 2, 3, 4 or 5: 
=match(P4, "PFC[2345]*")
Accept profiles starting with PFC,
heights are 200, 300, 400 or 500
and width starts with 7: 
=match(P4, "PFC[2345]00?
7*")

length(param
eter)

Returns the number of
characters in the
parameter.

=length(P1) returns 8

find(paramete
r, string)

Returns the order number
(starting at zero) of the
specified string and -1 if
the specified string is not

=find(P1, "*") returns 5
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Operation Description Example (P1 = "PL100*10")
found from the
parameter.

getat(paramet
er, n)

Returns the n:th (starting
at zero) character from
the parameter.

=getat(P1, 1) returns "L"

setat(paramet
er, n,
character)

Sets the n:th (starting at
zero) character to the
specified character in the
parameter.

=setat(P1, 0, "B") returns
"BL100*10"

mid(string, n,
x)

Returns x characters from
the string starting from
n:th (starting at zero)
character. If you leave out
the last argument (x),
returns the last part of
the string.

=mid(P1,2,3) returns "100"

reverse(string) Reverses the given string. =reverse(P1) returns
"01*001LP"

Example 1

To define profile size PL100*10 with two variables P2 = 100 and P3 = 10, enter
the formula as follows:

="PL"+P2+"*"+P3

Example 2

Tekla Structures handles bolt spacings as strings. To define bolt spacing, set
Value type to Distance list and enter the formula as follows:

=P1+" "+P2
This results in 100 200, if P1 = 100 (length) and P2 = 200 (length).

Trigonometric functions
Use trigonometric functions to calculate angles. You can use the following
trigonometric functions:

Function Description Example
sin() Returns the sine value =sin(d45) returns 0.71
cos() Returns the cosine value =cos(d45) returns 0.71
tan() Returns the tangent value =tan(d45) returns 1.00
asin() Inverse function of sin(),

return value in radians
=asin(1) returns 1.571 rad
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Function Description Example
acos() Inverse function of cos(),

return value in radians
=acos(1) returns 0 rad

atan() Inverse function of tan(),
return value in radians

=atan(1) returns 0.785 rad

sinh() Returns the hyperbolical sine
value

=sinh(d45) returns 0.87

cosh() Returns the hyperbolical
cosine value

=cosh(d45) returns 1.32

tanh() Returns the hyperbolical
tangent value

=tanh(d45) returns 0.66

atan2() Returns the angle whose
tangent is the quotient of the
two numbers. Return value in
radians

=atan2(1,3) returns 0.32

NOTE When you use trigonometric functions in variable formulas, you need
to include a prefix to define the unit. If you do not include a prefix,
Tekla Structures uses radians as the default unit.

• d is degree. For example, sin(d180)
• r is radians (default). For example, sin(r3.14) or sin(3.14)

Market size function
Use the market size function in a custom component to select a suitable plate
dimension (usually plate thickness) from the available market sizes. For
example, a plate’s thickness should match the web of a beam.

Function Description Example
fMarketSize(material,
thickness, extrastep)

Returns the next available
market size for the
material from the
marketsize.dat file,
based on the thickness
you specify.

The file must be in
the ..\environments
\your_environment
\profil folder or the
system folder.

For an extra step, enter a
number to define the
increment to the next size
(default is 0).

=fMarketSize("S235JR
", 10, 0)
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Example

In this example, you have the following data in marketsize.dat:

S235JR,6,9,12,16,19,22
SS400,1.6,2.3,3.2,4.5,6,9,12,16,19,22,25,28,32,38
DEFAULT,6,9,12,16,19,22,25,28,32,38

The first item in a row is a material grade followed by available plate
thicknesses in millimeters. The DEFAULT line lists the thicknesses available in
all other material grades.

With the above data, the function =fMarketSize("S235JR",10,0) would
return 12, and =fMarketSize("S235JR",10,1) would return 16 (one size
up).

Framing condition functions
Use the framing condition functions to return the skew, slope, and cant angle
of the secondary beam relative to the main part (column or beam). You can
use the following framing condition functions:

Function Description Example
fAD("skew
", GUID)

Returns the skewed angle
of the secondary part
whose GUID is given.

=fAD("skew","ID50B8559A-0000-
010B-3133-353432373038")
returns 45

ID50B8559A-0000-010B-3133-353432
373038 is the GUID of the secondary
part, which is at a 45 degree angle to
the main part.

fAD("slope
", GUID)

Returns the sloped angle
of the secondary part
whose GUID is given.

=fAD("slope","ID50B8559A-0000
-010B-3133-353432373038")
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Function Description Example
fAD("cant"
, GUID)

Returns the cant angle of
rotated secondary part
whose GUID is given.

=fAD("cant","ID50B8559A-0000-
010B-3133-353432373038")

NOTE • These functions do not return positive and negative slope and
skew values. It is not possible to determine up or down slope and
left or right skew with these functions.

• The maximum skew angle to return is 45 degrees.

• Tekla Structures calculates the angles in 2D so that slope and skew
are isolated from each other. For example, the skew angle is not
taken into consideration when calculating the slope angle, which
means that the slope angle value stays the same regardless of the
secondary part's rotation around the primary part.

To find out the true 3D slope with the skew included, you can use
the following mathematical formula:

TRUE_SLOPE = atan( tan(SLOPE) * cos(SKEW))

Example 1

The slope and skew are relative to a beam framing into a column.

Side view Top view

1. Column

2. Beam
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3. Slope

4. Skew

Example 2

With two beams, the slope is actually the horizontal skew of the beam framing
into the other beam, and the vertical slope of the beam relative to the main is
actually the skew angle.

Side view Top view

1. Skew

2. Slope

How to avoid cyclic dependencies in formulas
Be careful not to create cyclic dependencies between variables, or else the
custom component will not work correctly. A cyclic dependency chain contains
formulas that make a variable eventually dependent on itself.

In the following example, variable P1 becomes dependent on itself, through
variables P2 and P3:

Cyclic dependencies may also occur when binding handles to other objects or
when using magnetic construction planes. When you create new formulas,
bindings, or magnetic construction planes, Tekla Structures checks if they
create cyclic dependency chains in a custom component. If that happens, a
warning message "Caution. Operation created cycle." is displayed.
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Tekla Structures also writes the message "Cycle detected in parametric solver"
into the session history log file and lists the objects involved in the cyclic
dependency, to help you find and remove the cyclic dependency. If you do not
remove it, the custom component will not work correctly.

8.9 Examples of parametric variables and variable
formulas in custom components
Here you will find some examples that demonstrate how to use parametric
variables and variable formulas to create intelligent custom components that
adapt to changes in the model.

NOTE There are some limitations concerning the variable names.

• In some of the examples below, we reference variables by name. To be
able to correctly reference a variable in your formula, variable name must
be 19 characters or shorter. Variables with longer names will not work
correctly when referenced.

• Variable names cannot contain mathematical operators (+,-,*,/).

• You cannot use a mathematical constant, such as PI or e, as a variable
name.

The examples are independent from each other.

• Example of a variable formula: Set the end plate material (page 886)

This example shows how to link a parametric variable to the end plate
material of a component object.

• Example of a variable formula: Create new component objects (page 890)

This example shows how to create a parametric variable that adds bolts to
the custom component.

• Example of a variable formula: Replace sub-components (page 891)

This example shows how to create a parametric variable that replaces sub-
components with other sub-components.
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• Example of a variable formula: Modify a sub-component by using a
component attribute file (page 893)

This example shows how to create a parametric variable that modifies a
sub-component on the basis of a component attribute file.

• Example of a variable formula: Define the stiffener position using
construction planes (page 894)

This example shows how to use construction planes for determining the
position of the stiffeners. You will position the stiffeners so that they divide
the beam into three equally long sections.

• Example of a variable formula: Determine the bolt size and bolt standard
(page 897)

This example shows how to create two parametric variables that determine
the bolt size and bolt standard.

• Example of a variable formula: Calculate the bolt group distance
(page 898)

This example shows how to create a variable formula that calculates the
bolt group distance from the beam flange.

• Example of a variable formula: Calculate the number of bolt rows
(page 900)

This example shows how to create a variable formula that calculates the
number of bolt rows based on the beam height. You will use if statements
in the calculations.

• Example of a variable formula: Link variables to user-defined attributes
(page 902)

This example shows how to link parametric variables to the user-defined
attributes of panels. You can then use the user-defined attributes in view
filters to show or hide the panels.

• Example of a variable formula: Calculate the number of handrail posts
using a template attribute (page 904)

This example shows how to create a variable formula that calculates the
number of handrail posts based on the length template attribute of the
beam. The handrail posts are created at both ends of the beam and one of
them is copied with the Array of objects (29) component.

• Example of a variable formula: Link an Excel spreadsheet to a custom
component (page 907)

This example shows how to link a parametric variable to an Excel
spreadsheet. For example, you can use Excel spreadsheets to check
connections.
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• Examples of a variable formula: Rebar set modifiers in custom components
(page 907)

These examples show you how to use rebar set modifiers for defining the
properties and hooks of rebar set bars in custom components.

Example of a variable formula: Set the end plate material
This example shows how to link a parametric variable to the end plate material
of a component object.

1. On the Custom component editor toolbar, click the Display variables

 button. 

The Variables dialog box opens.

2. Click the Add button. 

A new parametric variable appears.

3. In the Value type list, change the variable's value type to Material.

4. In the Label in dialog box box, enter End Plate Material. 

5. In the Custom component browser, browse for the end plate material. 

6. Right-click Material and select Add Equation.

7. Enter P1 after the equal sign, and then press Enter.
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8. Save the custom component.

9. Close the custom component editor.

You can now change the end plate material in the custom component's dialog
box.

Example of a variable formula: Create a nested connection
with stiffeners
This example shows how to create a nested custom connection that consists of
and end plate, a bolt group, welds, and two Stiffeners (1003) components.
The stiffeners are optional, which means that you can choose whether or not
to create them when using the component in a model.

1. Add an End plate (144) component. 

2. Explode the end plate component.

3. Add two Stiffeners (1003) components. 
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4. Create a nested custom component that contains the stiffeners and the
end plate objects.

a. Click the Applications & components  button in the side pane
to open the Applications & components catalog.

b. Click the Access advanced features  button and select Define
custom component....

c. In the Type list, select Connection.

d. In the Name box, enter End plate with stiffeners.

e. Click Next >.

f. Make an area selection (from right to left) to include the following
objects in the nested component: the column, the beam, the stiffener
components, and all the end plate objects. 
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g. Click Next >.

h. Choose the column as the main part of the nested component, and
then click Next >.

i. Choose the beam as the secondary part of the nested component,
and then click Finish. 

Tekla Structures creates the nested component.

5. Select the nested component you just created.

6. Right-click and select Edit Custom Component.

7. In the custom component editor, click the Display variables  button. 

The Variables dialog box opens.

8. Create the following parametric variables:

a. Click Add to create a new parametric variable P1.

b. In the Value type list, select Yes/No.

c. In the Label in dialog box box, enter Create Stiffener 1.

d. Click Add to create a new parametric variable P2.

e. In the Value type list, select Yes/No.

f. In the Label in dialog box box, enter Create Stiffener 2. 

9. Link the variables to the Creation property of the two stiffeners:

a. In the Custom component browser, browse for the uppermost
Connection.
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b. Right-click Creation and select Add Equation.

c. Enter P1 after the equal sign, and then press Enter.

d. Browse for the second Connection.

e. Right-click Creation and select Add Equation.

f. Enter P2 after the equal sign, and then press Enter. 

10. Save and close (page 844) the nested component.

You now have the following options in the nested component's dialog box:

Example of a variable formula: Create new component
objects
This example shows how to create a parametric variable that adds bolts to the
custom component.

1. On the Custom component editor toolbar, click the Display variables

 button. 

The Variables dialog box opens.

2. Click Add to create a new parametric variable.

3. Modify the variable as follows:

a. In the Value type list, select Yes/No.

b. In the Label in dialog box box, enter Create bolts. 
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4. Select the bolt group in a custom component view to highlight it in the
Custom component browser.

5. In the Custom component browser, browse for Bolt.

6. Right-click Creation and select Add Equation.

7. Enter P1 after the equal sign, and then press Enter. 

8. Save the custom component.

9. Close the custom component editor.

You now have the following option in the custom component's dialog box:

Example of a variable formula: Replace sub-components
This example shows how to create a parametric variable that replaces sub-
components with other sub-components.

Custom components 891 Examples of parametric variables and variable
formulas in custom components



1. On the Custom component editor toolbar, click the Display variables

 button. 

The Variables dialog box opens.

2. Click Add to create a new parametric variable.

3. Modify the variable as follows:

a. In the Value type list, select Component name. 

Tekla Structures automatically adds the suffix _name in the variable
name. Do not delete the suffix.

b. In the Formula box, enter the name of the sub-component.

c. In the Label in dialog box box, enter Cast-in plate. 

4. Link the variable to the Name property of both sub-components:

a. In the Custom component browser, browse for the Name attribute
of the first sub-component.

b. Right-click Name and select Add Equation.

c. Enter P1_name after the equals sign.

d. Repeat steps 4b–4c for the other sub-component.
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5. Save the custom component.

6. Close the custom component editor.

You can now change the sub-components by using the Cast-in-plate option in
the custom component's dialog box.

Example of a variable formula: Modify a sub-component by
using a component attribute file
This example shows how to create a parametric variable that modifies a sub-
component on the basis of a component attribute file.

1. On the Custom component editor toolbar, click the Display variables

 button. 

The Variables dialog box opens.

2. Click Add to create a new parametric variable.

3. In the Value type list, select Component attribute file. 

Tekla Structures automatically adds the suffix _attrfile in the variable
name. Do not delete the suffix.

4. In the Formula box, enter the name of the component attribute file.

5. In the Name box, ensure that the variable has the same prefix as the
variable that is linked to the component name. 

In this example, the prefix is P1.

NOTE The component name and the component attribute file variables
must always have the same prefix, otherwise they do not work.

6. In the Label in dialog box box, enter Properties file. 
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7. In the Custom component browser, browse for the component attribute
file property of the sub-component.

8. Right-click Attribute file and select Add Equation.

9. Enter P1_attrfile after the equal sign, and then press Enter. 

10. Save the custom component.

11. Close the custom component editor.

You can now modify the sub-component by using the Properties file option in
the custom component's dialog box.

Example of a variable formula: Define the stiffener position
using construction planes
This example shows how to use construction planes for determining the
position of the stiffeners. You will position the stiffeners so that they divide the
beam into three equally long sections.
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1. Ensure that Direct modification  is switched off. 

The selection of handles is easier when Direct Modification is off.

2. On the Custom component editor toolbar, click the Display variables

 button. 

The Variables dialog box opens.

3. Click Add to create a new parametric variable.

4. Get the GUID of the beam.

a. On the ribbon, click Inquire objects .

b. Select the beam.

c. In the Inquire Object dialog box, check the GUID of the beam.

5. Modify the variable as follows:

a. In the Formula box, enter
=fTpl("LENGTH","ID4C8B5E24-0000-017D-3132-383432313432
"). 

ID4C8B5E24-0000-017D-3132-383432313432 is the GUID of the
beam.

The value of the variable is now the same as the beam length. If you
change the beam length, also the value changes.

b. In the Label in dialog box box, enter Beam Length.

6. Click Add to create another parametric variable.

7. Modify the new variable as follows:

a. In the Formula box, enter =P1/3.

b. In the Label in dialog box box, enter 3rd Points.

8. Create a construction plane:

a. In the custom component editor, click the Add construction plane

 button.

b. Pick the required points and then click the middle mouse button to
create a construction plane in the center of a stiffener at one end. 
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9. Bind the stiffener to the construction plane:

a. Select the stiffener.

b. Hold down Alt and use area selection (from left to right) to select all
stiffener handles. 

c. Right-click and select Bind to plane.

d. Bind the stiffener handles to the construction plane.

10. Bind the construction plane to the beam end:

a. Select the construction plane.

b. Right-click and select Bind to plane.

c. Bind the construction plane to the beam end. 
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11. Repeat steps 9–11 for the stiffener at the other end.

12. In the Formula box, enter =P2 for the two distance variables that bind the
construction planes to the beam ends.

13. Save the custom component.

14. Close the custom component editor.

If you now change the beam length, the position of the stiffeners changes so
that the stiffeners divide the beam into three equally long sections.

Example of a variable formula: Determine the bolt size and
bolt standard
This example shows how to create two parametric variables that determine
the bolt size and bolt standard.

1. On the Custom component editor toolbar, click the Display variables

 button. 

The Variables dialog box opens.

2. Click Add twice to create two new parametric variables.

3. Modify the first variable as follows: 

• In the Value type list, select Bolt size.

Tekla Structures automatically adds the suffix _diameter to the name
of the variables. Do not delete the suffix.

• In the Label in dialog box box, enter Bolt Size.

4. Modify the second variable as follows:
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a. In the Value type list, select Bolt standard. 

Tekla Structures automatically adds the suffix _screwdin to the
name of the variable. Do not delete the suffix.

b. In the Name box, change the prefix of the second variable so that the
prefixes for the two variables are the same. 

In this example, the prefix is P1.

NOTE The bolt size and bolt standard variables must always have
the same prefix, otherwise they do not work.

c. In the Label in dialog box box, enter Bolt Standard.

5. Link the parametric variables to the bolt group properties:

a. In the Custom component browser, browse for the size property of
the component object.

b. Right-click Size and select Add Equation.

c. Enter P1_diameter after the equal sign, and then press Enter.

d. Right-click Bolt standard and select Add Equation.

e. Enter P1_screwdin after the equal sign, and then press Enter. 

6. Save the custom component.

7. Close the custom component editor.

You can now determine the bolt size and bolt standard for the custom
component in the custom component's dialog box.
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Example of a variable formula: Calculate the bolt group
distance
This example shows how to create a variable formula that calculates the bolt
group distance from the beam flange.

1. Modify the bolt group properties as follows:

a. In the custom component editor, double-click the bolt group. 

The Bolt properties open.

b. Clear all values that are in the Offset from section.

c. Click Modify. 

The bolt group moves to the same level with the start point handle of
the bolt group.

2. Bind the bolt group to the beam flange:

a. In the custom component editor, select the bolt group.

b. Select the yellow top handle. 

c. Right-click the handle and select Bind to plane.

d. Select the top flange of the beam. 
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A new distance variable appears in the Variables dialog box.

3. On the Custom component editor toolbar, click the Display variables

 button. 

The Variables dialog box opens.

4. Click Add to create a new parametric variable.

5. Modify the variable as follows:

a. In the Formula box, enter a distance value.

b. In the Label in dialog box box, enter Vertical distance to
bolt.

6. In the Formula box, enter =-P1 for the distance variable. 

7. Save the custom component.

8. Close the custom component editor.

You can now determine the bolt group distance from the beam flange by
changing the Vertical distance to bolt value in the custom component's
dialog box.

Example of a variable formula: Calculate the number of
bolt rows
This example shows how to create a variable formula that calculates the
number of bolt rows based on the beam height. You will use if statements in
the calculations.
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1. On the Custom component editor toolbar, click the Display variables

 button. 

The Variables dialog box opens.

2. Click Add to create a new parametric variable.

3. In the Value type list, select Number.

4. In the Custom component browser, browse for height property of the
beam.

5. Right-click Height and select Copy Reference.

6. In the Formula box, enter the following if statement for the parametric
variable: 

=if (fP(Height,"ID50B8559A-0000-00FD-3133-353432363133")< 301) then 2 
else (if (fP(Height,"ID50B8559A-0000-00FD-3133-353432363133")>501) then 4 
else 3 endif) endif

In the formula,
fP(Height,"ID50B8559A-0000-00FD-3133-353432363133") is the
beam height reference copied from the Custom component browser.
The variable gets its value in the following way:

• If the beam height is under 301 mm, the value is 2.

• If the beam height is over 501 mm, the value is 4.

• If the beam height is between 300 and 500 mm, the value is 3.

7. Click Add to create another parametric variable.

8. In the Value type list, select Distance list for the new variable.

9. In the Formula box, enter =P1+"*"+100 for the new variable. 
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In the formula, 100 is the bolt spacing and the P1 value is the number of
bolt rows.

10. In the Custom component browser, browse for Bolt group distance x.

11. Right-click Bolt group distance x and select Add Equation.

12. Enter P2 after the equal sign, and then press Enter.

13. Save the custom component.

14. Close the custom component editor.

When you now change the beam height, the number of bolt rows changes as
well.

Example of a variable formula: Link variables to user-
defined attributes
This example shows how to link parametric variables to the user-defined
attributes of panels. You can then use the user-defined attributes in view
filters to show or hide the panels in the model.

1. On the Custom component editor toolbar, click the Display variables

 button. 

The Variables dialog box opens.

2. Click Add to create a new parametric variable.

Custom components 902 Examples of parametric variables and variable
formulas in custom components



3. Modify the variable as follows:

a. In the Value type list, select Text.

b. In the Formula box, enter Type1.

c. In the Label in dialog box box, enter Panel1.

4. In the Custom component browser, browse for the user-defined
attributes of the first panel. 

You will link the P1 variable to the USER_FIELD_1 attribute. However, the
attribute is not visible in the Custom component browser.

5. Make the user-defined attribute visible in the Custom component
browser:

a. Double-click the first panel. 

The panel properties open in the property pane.

b. Click More. 

The dialog box for user-defined attributes opens.

c. Go to the Parameters tab.

d. Enter text in the User field 1 box.

e. Click Modify.

6. In the Custom component browser, click Refresh. 

USER_FIELD_1 appears under User-defined attributes in the Custom
component browser.

7. Link P1 to USER_FIELD_1.

a. Right-click USER_FIELD_1 and select Add Equation.

b. Enter P1 after the equal sign, and then press Enter.

8. Create two new parametric variables and link them to the user-defined
attributes of the other two panels.

9. Save the custom component.
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10. Close the custom component editor.

You can now create a view filter (page 153) in the model to hide or show
panels using the User field 1 attribute and the Formula values you entered
for the parametric variables in the filter.

Example of a variable formula: Calculate the number of
handrail posts using a template attribute
This example shows how to create a variable formula that calculates the
number of handrail posts based on the length template attribute of the beam.
The handrail posts were created at both ends of the beam and one of them
was copied with the Array of objects (29) component.

1. On the Custom component editor toolbar, click the Display variables

 button. 

The Variables dialog box opens.

2. Create three new parametric variables by clicking Add.

3. Modify the variable P1 as follows: 

• In the Formula box, enter 250.

• In the Label in dialog box box, enter End Distance.

4. Modify the variable P2 as follows: 

• In the Formula box, enter 900.

• In the Label in dialog box box, enter Spacing.

5. Modify the variable P3 as follows: 

• In the Value type box, select Number.

• In the Label in dialog box box, enter Number of Posts.
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6. Inquire the GUID of the beam:

a. On the ribbon, click Inquire objects .

b. Select the beam.

c. Check the GUID of the beam in the Inquire Object dialog box.

7. In the Formula box of the P3 variable, enter
=(fTpl("LENGTH","ID50B8559A-0000-010B-3133-353432373038")
-(P1*2))/P2. 

fTpl("LENGTH","ID50B8559A-0000-010B-3133-353432373038") is
the length template attribute of the beam and
ID50B8559A-0000-010B-3133-353432373038 is the GUID of the beam.

The number of the posts is calculated as follows: First the end distances
are subtracted from the beam length, and then the result is divided by the
post spacing.

8. In the Custom component editor, link the variables P2 and P3 to the
properties of Array of objects (29).

a. Right-click dist_between_elem and select Add Equation.

b. Enter P2 after the equal sign, and then press Enter.

c. Right-click number_of_arrays and select Add Equation.

d. Enter P3 after the equal sign, and then press Enter.

9. Bind the first post to the beam end.
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a. Select the post in the custom component view.

b. Hold down Alt and use area selection (from left to right) to select the
post handles.

c. Right-click and select Bind to plane. 

10. Bind the last post to the other beam end by following the instructions in
step 9.

11. Modify the distance variables as follows:

a. In the Formula box, enter =P1.

b. In the Visibility list, select Hide.

12. Save the custom component.

13. Close the custom component editor.

You can now change the spacing and the end distance of the handrail posts in
the custom component dialog box. Tekla Structures calculates the number of
posts based on the spacing, end distance, and length of the beam.
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Example of a variable formula: Link an Excel spreadsheet to
a custom component
This example shows how to link a parametric variable to an Excel spreadsheet.
For example, you can use Excel spreadsheets to check connections.

1. Create an Excel spreadsheet. 

The name of the spreadsheet file must be
component_"component_name".xls. For example,
component_stiffener.xls for a custom component whose name is
stiffener.

2. Save the Excel spreadsheet in the model folder: ..\<model>
\exceldesign\. 

Alternatively, you can save the spreadsheet in the folder defined with the 
XS_EXTERNAL_EXCEL_DESIGN_PATH advanced option.

3. On the Custom component editor toolbar, click the Display variables

 button. 

The Variables dialog box opens.

4. Click Add to create a new parametric variable.

5. Modify the variable as follows:

a. In the Value type list, select Yes/No.

b. In the Name box, enter use_externaldesign.

c. In the Label in dialog box box, enter Use external design. 

6. Save the custom component.

7. Close the custom component editor.

The custom component dialog box now contains the Use external design
option.

Examples of a variable formula: Rebar set modifiers in
custom components
You can use rebar set modifiers in custom components. You can define the
rebar set bar and modifier properties using parametric variables.

For each modifier property that you want to parametrize, the corresponding
Apply property is also needed. By using the Apply property you can override
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an existing property value with an empty value. Clearing an existing value is
not possible without the Apply property.

Example: Define the class and size of rebar set bars using a property
modifier
This example shows how to use a rebar set property modifier for defining the
class and size of certain rebar set bars in a custom component. You will define
the class and size using parametric variables and modifier-specific Apply
properties.

The parametric variable for class will be defined so that if the class is set to 0,
the class value is not applied, but the original class of the rebar set is used.

1. In the model, select a previously created custom component (page 830)
that contains a rebar set and a property modifier. 

NOTE Custom parts do not have a component symbol in the model.

To select custom components, ensure that the Select

components  selection switch is active.

2. Right-click and select Edit Custom Component.

3. On the Custom component editor toolbar, click the Display variables

button . 

The Variables dialog box opens.

4. In the Variables dialog box, create and define parametric variables as
follows:

a. Click Add three times to create three new parametric variables. 

The variable names will be P1, P2, and P3.

b. Modify the variable P1 for class number input as follows: 

• In the Value type list, select Number.

• In the Label in dialog box box, enter Class.

c. Modify the variable P2 for Apply property control as follows: 

• In the Formula box, enter =if (P1==0) then 0 else 1
endif.

This means that if P1 (Class) is set to 0, the class property is not
applied when you use the custom component. If P1 is set to any
other value, then the class property is applied.

• In the Value type list, select Yes/No.

Custom components 908 Examples of parametric variables and variable
formulas in custom components



• In the Visibility list, select Hide.

This means that the variable P2 will not be visible in the custom
component dialog box.

• In the Label in dialog box box, enter Apply class.

d. Modify the variable P3 for bar size input as follows: 

• In the Name box, change the name to P3_size.

• In the Value type list, select Rebar size.

• In the Label in dialog box box, enter Bar size.

• In the Formula box, replace zero with a valid bar size value.

5. In the Custom component browser, link the parametric variables to the
property modifier properties:

a. Browse for Component objects --> Rebar property modifier -->
General properties .

b. Right-click Class, select Add Equation, enter P1 after the equal sign
(=), and then press Enter. 

Similarly, link the other variables and properties as follows:

• Apply class property = P2
• Size = P3_size
• Apply size property = 1
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6. Save and close (page 844) the modified custom component.
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Now you have the following properties available in the custom component's
dialog box and you can modify the class and size of those rebar set bars that
are affected by the property modifier:

You can use the component in locations similar to where the component was
originally created. This component is not adaptive and Tekla Structures does
not adjust the component dimensions to suit any changes in the model. To
make the custom component adaptive, you need to modify (page 840) it in the
custom component editor.

Example: Create and modify rebar hooks using an end detail modifier
This example shows how to use a rebar set end detail modifier for creating
hooks at certain rebar set bar ends in a custom component. You will define the
hook properties using parametric variables and modifier-specific Apply
properties.

1. In the model, select a previously created custom component (page 830)
that contains a rebar set and an end detail modifier. 

NOTE Custom parts do not have a component symbol in the model.

To select custom components, ensure that the Select

components  selection switch is active.

2. Right-click and select Edit Custom Component.

3. On the Custom component editor toolbar, click the Display variables

button . 

The Variables dialog box opens.

4. In the Variables dialog box, create and define parametric variables as
follows:

a. Click Add four times to create four new parametric variables. 

The variable names will be P1, P2, P3, and P4.

b. Modify the variable P1 for hook type input as follows: 
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• In the Value type list, select Rebar hook type.

• In the Label in dialog box box, enter Hook type.

• In the Formula box, enter 4 for a custom hook.

The different hook types are identified with numbers: 1 = 90
degree hook, 2 = 135 degree hook, 3 = 180 degree hook, 4 =
custom hook.

c. Modify the variable P2 for hook angle input as follows: 

• In the Value type list, select Number.

Note that although Angle is available as a value type, the Number
option must be used for the hook angle.

• In the Label in dialog box box, enter Custom hook angle.

d. Modify the variable P3 for hook length input as follows: 

• In the Value type list, select Number.

• In the Label in dialog box box, enter Custom hook length.

e. Modify the variable P4 for hook radius input as follows: 

• In the Value type list, select Number.

• In the Label in dialog box box, enter Custom hook radius.

5. In the Custom component browser, link the parametric variables to the
end detail modifier properties:

a. Browse for Component objects --> Rebar end detail modifier -->
General properties.

b. Right-click Hook angle, select Add Equation, enter P2 after the equal
sign (=), and then press Enter. 

Similarly, link the other variables and properties as follows:

• Hook radius = P4
• Rebar hook type = P1
• Apply hook angle property = 1
• Hook length = P3
• Apply hook radius property = 1
• Apply hook length property = 1
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• Apply hook type property = 1

6. Save and close (page 844) the modified custom component.
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Now you have the following properties available in the custom component's
dialog box and you can modify the hooks of those rebar set bars that are
affected by the end detail modifier:

You can use the component in locations similar to where the component was
originally created. This component is not adaptive and Tekla Structures does
not adjust the component dimensions to suit any changes in the model. To
make the custom component adaptive, you need to modify (page 840) it in the
custom component editor.

8.10 Import and export custom components
You can import and export custom components as .uel files between models.

NOTE You can share your custom components in Tekla Warehouse, and also
download custom components made by other users.

Export a custom component
You can export custom components in a .uel file.

1. Click the Applications & components  button in the side pane to
open the Applications & components catalog.

2. In the catalog, select the custom components you want to export.

3. Right-click the selection, and then select Publish.

4. Browse for the folder where you want to save the file.

5. Enter a name for the export file. 

The file name extension is .uel. Do not change the file name after
exporting the custom component. If the file name differs from the name
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in the Applications & components catalog, it may be difficult to find the
right component later on.

The data files that are used by the custom component are included in the
exported .uel file. The data files need to be located in the model folder
or in the CustomComponentDialogFiles subfolder to be exported. Only
files specified directly in fVF functions are exported. For example: 
=fVF("myData.dat", ...) directly specifies the file, but 
=fVF(P1, ...) does not.

6. Click Save to export the custom components. 

TIP If you want to export custom components as separate files, select
the custom components in the Applications & components
catalog, right-click, and then select Publish separately.

Import a custom component
You can import previously made custom components to another model.

1. Click the Applications & components  button in the side pane to
open the Applications & components catalog.

2. Click the Access advanced features  button , and then select Import.

3. Browse for the folder that contains the export file. 

The location depends on where you saved the file when you exported the
custom component.

4. Select the export file.

5. Click Open to import the custom components. 

TIP You can import custom components to a new model automatically
by using the XS_UEL_IMPORT_FOLDER advanced option. Export all
custom components to certain folders and enter these folders as
the value for the XS_UEL_IMPORT_FOLDER advanced option to
easily import the custom components to new models.

8.11 Hints and tips for using and sharing custom
components
Here you will find some useful tips on how to create and use custom
components more efficiently.
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Tips for creating custom components
• Enter short, logical names for custom components.

Use the description field to describe the component and to explain what it
does.

• Create simple components for specific situations.

Simple components are easier and faster to model, and also much easier
to use. Avoid creating a single, complex component which you will use for
every possible purpose.

• Consider creating a separate component model.

Use that model when you create and test custom components.

• Use the simplest part you can with as few handles as possible.

For example, if all you need is a rectangular shape, use a rectangular plate,
not a contour plate. Rectangular plates only have two handles, so you only
need to create a few bindings to manipulate them. Contour plates require
more bindings because they have four handles.

Excessive bindings can cause a slower, less responsive model.

1. Rectangular plate

2. Contour plate

• Model parts only as accurately as you need.

If the only part information required is a part mark in a general
arrangement drawing, plus a quantity on a materials list, create a simple
bar or plate. If you need to include the part in a detailed view later on,
simply re-model the part more accurately at that point.

• Model embeds as custom parts and include them in components.

The majority of embeds are standard embeds, which are designed and
manufactured as mass production, and stored to be readily available at the
factory. The other type of embeds is a bespoke embed, which is
manufactured for a specific project, and needs its own workshop drawing,
and which are quantified more accurately.
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To have suitable embeds in you model, you can either

• create your own embeds as custom parts

• create your own embeds as items (page 300)

• use Tekla Warehouse to find embeds.

If you create your own embed custom components, be careful with the
sub-assembly hierarchy. It is better to have a clear sub-assembly main part
and then the other parts added to the main part.

• You can use custom connections in AutoConnections

• You can use custom components in AutoDefaults

Custom components are listed in the Other components group. Newly
created custom components are not listed in the Other components
group until you have reopened the model. Custom connections, details and
seams work in AutoDefaults.

Tips for sharing custom components
• Use Tekla Warehouse to share and store custom components.

• Provide essential information.

If you distribute your component to other users, remember to list the
profiles it works with.

• Use fixed profiles (page 320) whenever possible.

• If your custom component contains user-defined profile cross
sections, remember to include them when you copy the custom
component to a new location.

Tips for updating custom components to a new version
When you start using a new version of Tekla Structures, always check that
custom components created in older versions work correctly in the new
version.

When you edit custom components created with an older version of Tekla
Structures, and the new version contains improvements that require an
update, Tekla Structures asks whether you want to update the component. If
you do not update the component, it works in the same manner as in the
version where it was originally created, but you do not gain the benefits of the
new improvements.

If you choose to update the component, you need to check and sometimes
recreate dimensions depending on the improvements. When you delete a
dimension and create a new one (even with the same name), the equations
that contain the dimension also need to be modified, because the dependency
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created by the equation is lost when a dimension is deleted. You can recreate
dimensions and modify equations in the custom component editor.

8.12 Customize the dialog boxes of custom components
Tekla Structures automatically creates a dialog box for each custom
component you define. Each custom component has an input (.inp) file that
defines the contents of the custom component's dialog box. You can
customize the dialog box by using the Custom Component Dialog Editor
tool.

Alternatively, if you are an advanced user, you can modify the dialog box input
(.inp) files manually (page 923) in a text editor.

Modify the dialog box of a custom component
To open the Custom Component Dialog Editor, select a custom component
in the model, right-click, and select Edit Custom Component Dialog Box.

To Do this
View and edit object properties 1. Select a dialog box element. For

example, a text box.

2. Click Modify --> Properties .

Now you can view and edit the
current properties of the dialog
box element. For example, you
can check that you have the
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To Do this
correct text box under each label
in the dialog box.

Alternatively, you can double-click the
dialog box element. If the dialog box
element will not open for viewing and
editing, try double-clicking the space
right underneath the check box:

Add a dialog box element Click Insert and select a suitable
element from the list. The options
are:

• Tab Page: add a new tab

• Label: add a label for a text box or
list

• Parameter: add a text box

• Attribute: add a list

• Part: add some basic part
properties

• Profile: add some basic profile
properties

• Picture: add an illustrative image
of the custom component

Add an image 1. Click Insert --> Picture to show
the contents of the Image Folder
set in Tools --> Options .

2. Select an image.

The image must be in the bitmap
(.bmp) format.

3. Click Open.

4. Drag the image to the desired
location.

Add a tab 1. Click Insert --> Tab Page .

2. Double-click the new tab.

3. Enter a new name, and then
press Enter.
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To Do this

NOTE Each tab may contain up to
25 fields. If you have more
than 25 fields visible, Tekla
Structures automatically
creates another tab.

Show or hide the pixel grid
Click .

Tekla Structures displays a pixel grid
that makes it easier to align elements
in the dialog box.

Move a dialog box element Drag the dialog box element to a new
location.

You can also use the keyboard
shortcuts Ctrl+X (cut), Ctrl+C (copy),
and Ctrl+V (paste). For example, to
move a dialog box element to another
tab: select the dialog box element,
press Ctrl+X, go to another tab, and
press Ctrl+V.

Select multiple dialog box elements Hold down the Ctrl key and click the
dialog box elements, or use area
selection.

Rename a tab or text box label 1. Double-click the tab or text box
label.

2. Type a new name.

3. Press Enter.
Remove a dialog box element 1. Select the dialog box element you

want to remove.

2. Press Delete.
Remove a tab 1. Select the tab.

2. Right-click and select Delete.
Add images to a list 1. Select the list element.

2. Click Modify --> Properties .

3. Click Edit Values.

4. Click Browse Add.

5. Select the image you want to use
and click Open.
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To Do this
6. Repeat steps 4–5 for any other

images you want to use.

7. Click OK to save the changes.
Save the changes Click File --> Save .

Custom component input files
Each custom component has an input (.inp) file that defines the contents of
the custom component's dialog box.

When you create a new custom component, Tekla Structures automatically
creates an input file for the component. The input file is located in the
\CustomComponentDialogFiles folder under the model folder. The input
file has the same name as the custom component, and the file name
extension is .inp.

When you modify a custom component (page 840), you will lose any changes
you have made to the input file. However, when you modify the custom
component, Tekla Structures automatically creates a backup copy of the input
file. The backup copy has the file name extension .inp_bak, and it is located
in the \CustomComponentDialogFiles folder under the model folder. Tekla
Structures displays a notification when the backup file is created.

Lock or unlock the custom component input file
You can lock the custom component's input (.inp) file to prevent accidental
modifications. If the file is unlocked, and someone else updates the custom
component in the custom component editor, all your modifications to the
dialog box will be lost.

1. In the model, select the custom component whose input file you want to
lock or unlock.

2. Right-click and select Edit Custom Component Dialog Box.

3. In the Custom Component Dialog Editor, click the Lock/Unlock button

.

If someone modifies the custom component in the custom component editor
when the .inp file is locked, the .inp file will not be updated. You can still
modify the dialog box in the Custom Component Dialog Editor even if
the .inp file is locked.
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Custom component dialog editor settings
In the Custom Component Dialog Editor, click Tools --> Options to view and
modify basic settings in the custom component dialog editor. Click Tools -->
Change Language to change the language of the custom component dialog
editor.

Option Description
Image folder The location of the image folder. To

restore the default folder setting, click
Default.

Project folder The location of the project folder.
When you create a completely new
input file by clicking File --> New and
then save it, the file is saved in the
project folder. Note that existing input
files are saved under the model
folder.

Parameter width The default width for text boxes.
Attribute width The default width for lists.
Grid spacing X

Grid spacing Y

The spacing of the pixel grid in the X
and Y directions. The default value is 
5.

Snap to grid Select to show or hide the pixel grid.

Option Description
Language Select a language from the list. Close

and reopen the dialog editor for the
change to take effect. You have the
following options:

• Auto: the dialog editor follows the
language of the Tekla Structures
user interface

• English

• Dutch

• French

• German

• Italian

• Spanish

• Japanese

• Chinese Simplified

• Chinese Traditional
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Option Description
• Czech

• Portuguese Brazilian

• Hungarian

• Polish

• Russian

• Korean

Customize the dialog boxes of custom components by using
a text editor
Each custom component has an input (.inp) file that defines the contents of
the custom component's dialog box. If you are an advanced user, you can
customize the dialog box input files manually in a text editor. Be careful when
modifying an input file, as errors may cause the dialog box to disappear.

Note that the General tab is reserved for predefined general properties. You
cannot rename the General tab or add more parameters to it.

Alternatively, you can use the Custom Component Dialog Editor tool to
customize the dialog box (page 918).

Add new tabs
1. Open the .inp file in a text editor.

2. Add a new tab definition, as shown below: 

3. Save the .inp file.
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NOTE The fourth tab is reserved for the General properties, so you cannot
add your own parameters to it.

Add text boxes
1. Open the .inp file in a text editor.

2. Add parameter elements and enclose them in curly brackets, as shown
below: 

3. Save the .inp file.

Add images
1. Create an image and save it in bitmap (.bmp) format in

the ..\ProgramData\Trimble\Tekla Structures\<version>
\Bitmaps folder.

2. Open the .inp file in a text editor.

3. Add an image definition, as shown below: 
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(1) y = 100

(2) x = 50

(3) height = 75

(4) width = 100

4. Save the .inp file.

Change the order of boxes
1. Open the .inp file in a text editor.

2. Change the last number in the parameter definition. 

The boxes are listed from top to bottom, as shown below:

3. Save the .inp file.
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Change the location of boxes
You can define an exact location for each text box.

1. Open the .inp file in a text editor.

2. Define the exact location of the box using three values: the x coordinate, y
coordinate, and width of the box. 

For example:

(1) x = 374

(2) y = 25

(3) width = 160

3. Save the .inp file.

Example: Add a group of check boxes in the custom component dialog
box
This example shows how to add a check box for each bolt group in a custom
component by modifying the .inp file. When the component is used in a
model, you can select which bolts to create by selecting the desired check
boxes.

1. Define a custom component (page 830) that contains bolts. 
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For example, create a custom tee connection that creates one bolt group
and three single bolts:

2. Create parametric variables that control the creation of bolts. 

With check box groups, the Value type of these variables must be
Yes/No. For example, create three variables P1, P2, and P3, one for each
single bolt in the custom tee connection.

3. Link the variables (page 864) to the Creation property of the bolts. 

For example, link the variable P1 to the Creation property of the first bolt,
the variable P2 to the Creation property of the second bolt, and so on.

4. Save the custom component.
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5. In the model, click File --> Open the model folder to open the current
model folder.

6. Go to the \CustomComponentDialogFiles folder.

7. Open the .inp file in a text editor.

8. Add an image definition (page 924). 

For example:

If you use a custom image, save it in bitmap (.bmp) format in
the ..\TeklaStructures\<version>\Bitmaps folder.

9. Add a toggle_group element to define the toggle group origin, that is,
the position of the group of check boxes in the custom component dialog
box. 

Use the x and y coordinate values to define the position. For example:

(1) x = 200

(2) y = 320

10. Within the toggle_group element, add a line for each check box you
want to add. 
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Use the same parametric variables that you created in step 2.

The two numeric values after the variable name are offsets from the
toggle group origin. For example, the first definition "P1", 160, -165,
"0" means that the check box for the variable P1 is located 160 steps
right and 165 steps up from the toggle group origin.

Direction Negative values Positive values
X left right
Y up down

(1) offset in X direction

(2) offset in Y direction

11. Save the .inp file.

12. Close and reopen the model for the change to take effect. 

Custom components 929 Customize the dialog boxes of custom
components



Now when you select and clear check boxes in the dialog box, the number
of bolts changes accordingly in the model. For example:

NOTE Tekla Structures automatically adds the Effect in modify label
and check box for each toggle group you create.

Example: Customize the dialog box of a custom stiffener
detail
This example shows how to customize the dialog box of a custom stiffener
detail to make it easier to adjust the settings later on.

In the beginning, the custom component dialog box looks like the following:

Do this
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1. Create a custom stiffener detail (page 931)with all the needed variables
that control the creation of stiffener plates.

2. Add a list with images. (page 942)

3. Arrange text boxes and labels. (page 947)

4. Dim unavailable options. (page 949)

Example: Create a custom stiffener detail with variables
This example shows how to create a custom stiffener detail with variables that
control the shape and position of the stiffeners.

Create a basic custom stiffener detail
This example shows how to create a basic stiffener detail.

1. Create a beam with two stiffeners. 

TIP To create the stiffeners, you can use the Stiffeners (1003)
component and then explode the component.

2. Click the Applications & components  button in the side pane to
open the Applications & components catalog.

3. Click the Access advanced features  button and select Define
custom component.... 

The Custom Component Wizard dialog box opens.

4. In the Type list, select Detail.

5. In the Name box, type Stiffeners. 
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6. Click Next >.

7. Select the stiffeners and the beam as the objects that form the custom
component. 

8. Click Next >.

9. Select the beam as the main part.

10. Click Next >.

11. Select the middle point of the beam as the reference point. 

TIP Switch to the plane view (page 45) to select the middle point more
easily.
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12. Click Finish to finish creating the stiffener detail. 

Tekla Structures displays a component symbol for the new custom
component and adds the stiffener detail to the component catalog.

Create bindings to control the stiffener shape
This example shows how to bind custom component handles to a plane to
control the shape of the stiffeners.

1. Open the stiffener detail in the custom component editor.

a. Right-click the custom component in the model.

b. Select Edit Custom Component. 

The custom component editor opens showing the custom component
editor toolbar, the component browser, and four views of the custom
component.
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2. On the View tab, click Rendering --> Parts rendered. 

Part surfaces and available planes can be selected only when they are
rendered.

3. On the Custom component editor toolbar, select Outline planes from
the list. 

4. In a custom component view, select the stiffener on the right.

5. Bind the two inside handles of the stiffener to the beam web.

a. Select the two handles next to the beam web. 

b. Right-click and select Bind to plane.

c. Move the pointer over the face of the web to highlight it. 

d. Click the web to bind the handles.

6. Bind the two outside handles of the stiffener to the face of the top flange. 
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Use the same method as in step 5.

7. Bind the two bottom handles of the stiffener to the inside face of the
bottom flange. 

Use the same method as in step 5.

8. Bind the two top handles of the stiffener to the inside face of the top
flange. 

Use the same method as in step 5.

9. Repeat steps 4 –11 for the stiffener on the left.
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10. On the Custom component editor toolbar, click the Display variables

button . 

The Variables dialog box opens.

11. Click Add to create a new parametric variable P1.

12. Modify the variable P1 as follows:

a. In the Formula box, enter 10.

b. In the Label in dialog box box, enter Stiffener set back.

13. In the Formula box, enter =P1 for all variables that got values during the
binding of the handles. 

For example:

The variable P1 now controls the distances of these variables.

14. In the Visibility list, set the variable P1 to Show and the other variables to
Hide. 

You have now created distance variables that control the stiffener shape.
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Create bindings to control the stiffener position
This example shows how to bind custom component handles to a plane to
control the position of the stiffeners.

1. Open the stiffener detail in the custom component editor.

a. Right-click the custom component in the model.

b. Select Edit Custom Component. 

The custom component editor opens showing the Custom
component editor toolbar, the Custom component browser, and
four views of the custom component.

2. On the Custom component editor toolbar, select Component planes
from the list. 

3. Select all the handles of both stiffeners. 

4. Right-click and select Bind to plane.

5. Bind the handles to the vertical component plane. 
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You have now created distance variables that control the position of the
stiffeners.

Create variables to control the stiffener thickness
This example shows how to control the stiffener thickness so that it is one and
a half times the web thickness rounded up to the nearest available plate
thickness. The available thickness values are 10, 12, and 16 mm.

1. Open the stiffener detail in the custom component editor.

a. Right-click the custom component in the model.

b. Select Edit Custom Component. 

The custom component editor opens showing the Custom
component editor toolbar, the Custom component browser, and
four views of the custom component.

2. On the Custom component editor toolbar, click the Display variables

button . 

The Variables dialog box opens.

3. Click Add to create a new parametric variable P2.

4. Modify the variable P2 as follows:

a. In the Formula box, enter =1.5*.

b. In the Visibility list, select Hide.

c. In the Label in dialog box box, enter Plate calculation.

5. Select the beam in a custom component view to highlight the beam (main
part) in the Custom component browser.

6. In the Custom component browser, select Web thickness of the main
part.
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7. Right-click and select Copy Reference. 

8. Paste the reference value to Formula after =1.5*. 

NOTE A reference function refers to the property of an object, such as
the web thickness of a part. If the object property changes, so
does the reference function value.

9. Click Add to create a new parametric variable P3.

10. Modify the variable P3 as follows:

a. In the Value type list, select Number.

b. In the Formula box, enter =if (P2 < 12 && P2 > 10) then 12
else if (P2 > 12) then 16 else 10 endif endif. 

This means that if P2 is less than 12 and greater than 10, the
thickness is 12. If P2 is greater than 12, the thickness is 16. If none of
these conditions are met, the thickness is 10.

11. In the Custom component browser, link the variable P3 to the Profile
property of the first contour plate. 
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12. Repeat step 11 for the second contour plate.

You have now created and linked all required variables that control the
stiffener thickness according to the web thickness.

Create variables to control the creation of stiffener plates
This example shows how to create five variables to control which stiffener
plates are created and what is the class of the plates.

1. Open the stiffener detail in the custom component editor.

a. Right-click the custom component in the model.

b. Select Edit Custom Component. 

The custom component editor opens showing the Custom
component editor toolbar, the Custom component browser, and
four views of the custom component.

2. On the Custom component editor toolbar, click the Display variables

button . 

The Variables dialog box opens.

3. Click Add to create a new parametric variable P4.

4. Modify the variable P4 as follows:

a. In the Formula box, enter 2.

b. In the Value type list, select Number.

c. In the Visibility list, select Show.

d. In the Label in dialog box box, enter Plates created.

5. Click Add to create a new parametric variable P5.
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6. Modify the variable P5 as follows:

a. In the Formula box, enter =if P4==0 then 0 else 1 endif.

b. In the Value type list, select Yes/No.

c. In the Visibility list, select Hide.

d. In the Label in dialog box box, enter Do not create right.

7. Click Add to create a new parametric variable P6.

8. Modify the variable P6 as follows:

a. In the Formula box, enter =if P4==1 then 0 else 1 endif.

b. In the Value type list, select Yes/No.

c. In the Visibility list, select Hide.

d. In the Label in dialog box box, enter Do not create left.

9. Click Add to create a new parametric variable P7.

10. Modify the variable P7 as follows:

a. Rename P7 as LeftC.

b. In the Formula box, enter 4.

c. In the Value type list, select Number.

d. In the Visibility list, select Show.

e. In the Label in dialog box box, enter Left plate class.

11. Click Add to create a new parametric variable P8.

12. Modify the variable P8 as follows:

a. Rename P8 as RightC.

b. In the Formula box, enter 5.

c. In the Value type list, select Number.

d. In the Visibility list, select Show.

e. In the Label in dialog box box, enter Right plate class.

13. In the Custom component browser, link the variables P5 and RightC to
the right stiffener plate. 
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14. Link the variables P6 and LeftC to the left stiffener plate. 

Example: Add a list with images in a custom component dialog box
This example shows how to add an illustrative list in the custom stiffener detail
dialog box. You can do this either in the custom component dialog editor or by
editing the input (.inp) file manually.

In the beginning of this example the dialog box has the text box shown below,
and the you need to know the values (0 is left, 1 is right, and 2 is both plates)
that control the creation of stiffener plates.

Replace the text box with a list that is easier to use:
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Add a list by using the dialog editor

1. Create a custom stiffener detail (page 931) with all the needed variables
that control which stiffener plates are created. 

In this example, the variable is called Plates created.

2. Open the stiffener dialog box for editing.

a. In the model, select the custom stiffener detail.

b. Right-click and select Edit Custom Component Dialog Box.

3. Check the name of the parametric variable that controls the plate
creation.

a. In the dialog editor, double-click the Plates created box. 

The Object Properties dialog box opens.

b. Check the name of the parametric variable. 
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In this example, the name is P4.

c. Click Cancel to close the dialog box.

4. Select the Plates created text box and click Delete.

5. Click Insert --> Attribute to add a new attribute list.

6. Drag the attribute list to a suitable location, next to the Plates created
label.

7. Select the attribute list and then click Modify --> Properties to edit its
properties.

8. Enter P4 as the Name of the attribute. 

Now the attribute list is linked to the parametric variable that controls the
plate creation.

9. Click Edit Values to add the list items.

10. In the Edit Attribute Values dialog box, add an image for the left plate.

a. Click Browse Add.

b. Browse for a suitable image. 

If you create new images, make sure they are in the bitmap (.bmp)
format. Save the images in the ..\ProgramData\Trimble\Tekla
Structures\<version>\Bitmaps folder.

The maximum image size is 245x245 pixels.

c. Click Open.

11. Repeat step 9 to add an image for the right plate, and then for both
plates.
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12. In the Edit Attribute Values dialog box, select the image of both plates
and then click Default to make the attribute the default value. 

13. Click OK.

14. Click Apply in the Object Properties dialog box, and then click Cancel to
close the dialog box.

15. In the dialog editor, click File --> Save to save the changes.

16. Close and reopen the model for the change to take effect.

Add a list by editing the .inp file

1. Create a custom stiffener detail (page 931) with all the needed variables
that control which stiffener plates are created. 

In this example, the variable is called Plates created.

2. In the model, click File --> Open the model folder to open the current
model folder.

3. Go to the \CustomComponentDialogFiles folder.

4. Open the .inp file in a text editor. 
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5. Remove the following line: 

parameter("Plates created", "P4", integer, number, 2)
6. Add a new Plates created attribute with the following settings: 

7. Add a new P4 attribute with the following settings: 

The list now contains three options, and Both is the default value. The list
options are linked to the variable P4 that controls the creation of the
stiffener plates.
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8. Edit the line numbers so that there are no empty rows between the
variables in the dialog box. 

9. Browse for the images you want to use in the dialog box. 

If you create new images, make sure they are in the bitmap (.bmp) format.
Save the images in the ..\ProgramData\Trimble\Tekla Structures
\<version>\Bitmaps folder.

The maximum image size is 245x245 pixels.

10. Replace the option texts with the actual file names of the images, but with
the file name extension .xbm. 

11. Save the .inp file.

12. Close and reopen the model for the change to take effect.

Example: Arrange text boxes and labels in a custom component dialog
box
This example shows how to arrange the text boxes and labels around a list in
the custom component dialog box. You can do this either in the custom
component dialog editor or by editing the input (.inp) file manually.
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In the beginning of this example the dialog box looks like the following:

Arrange the dialog box elements more nicely, in the following manner:

Arrange the elements by using the dialog editor

1. Create a custom stiffener detail (page 931) with all the needed variables
that control the creation of stiffener plates.

2. Open the stiffener dialog box for editing.

a. In the model, select the custom stiffener detail.

b. Right-click and select Edit Custom Component Dialog Box.

3. Drag the Plates created label above the list with images.

4. Drag the Left plate class label and the corresponding text box to the left
side of the list.

5. Drag the Right plate class label and the corresponding text box to the
right side of the list.

6. Drag the Stiffener set back label and the corresponding text box
underneath the list.

7. In the dialog editor, click File --> Save to save the changes.

8. Close and reopen the model for the change to take effect.

Arrange the elements by editing the .inp file

1. Create a custom stiffener detail (page 931) with all the needed parametric
variables that control the creation of stiffener plates.
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2. In the model, click File --> Open the model folder to open the current
model folder.

3. Go to the \CustomComponentDialogFiles folder.

4. Open the .inp file in a text editor.

5. Edit the file as follows: 

6. Save the .inp file.

7. Close and reopen the model for the change to take effect.

Example: Dim unavailable options in a custom component dialog box
This example shows how to dim the unavailable options in the custom
stiffener detail dialog box based on conditions. You can do this either in the
custom component dialog editor or by editing the input (.inp) file manually.

In the beginning of this example all the options are available:

Define that the Left plate class text box is unavailable if only the right plate is
created, and vice versa.
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Dim unavailable options by using the dialog editor

1. Create a custom stiffener detail (page 931) with all the needed parametric
variables that control the creation of stiffener plates.

2. Open the stiffener dialog box for editing.

a. In the model, select the custom stiffener detail.

b. Right-click and select Edit Custom Component Dialog Box.

3. Define that the Left plate class text box must be dimmed if only the right
stiffener plate is created.

a. In the Plates created list, select the image for the right plate class. 

Note that a blue selection border must be displayed for the image:

b. Hold down the Ctrl key and click the Left plate class text box. 

c. Click the Toggle visibility  button. 

The Left plate class text box is now dimmed:
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4. Unselect the Left plate class text box by clicking the Right plate class
text box.

5. Define that the Right plate class text box must be dimmed if only the left
stiffener plate is created.

a. In the Plates created list, select the image for the left plate class. 

Note that a blue selection border must be displayed for the image:

b. Hold down the Ctrl key and select the Right plate class text box. 

c. Click the Toggle visibility  button. 

The Right plate class text box is now dimmed:

6. In the dialog editor, click File --> Save to save the changes.

7. Close and reopen the model for the change to take effect.

Dim unavailable options by editing the .inp file

1. Create a custom stiffener detail (page 931) with all the needed parametric
variables that control the creation of stiffener plates.

2. In the model, click File --> Open the model folder to open the current
model folder.

3. Go to the \CustomComponentDialogFiles folder.

4. Open the .inp file in a text editor.

5. Add the following line to the end of the attribute P4 line: 
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"toggle_field:LeftC=0;RightC=1"

The logic is the following:

Selecting the image CC_left returns 0, CC_right returns 1, and CC_both
returns 2.

toggle_field:RightC=1
When 0 (left) is selected, RightC is dimmed.

toggle_field:LeftC=0
When 1 (right) is selected, LeftC is dimmed.

6. Save the .inp file.

7. Close and reopen the model for the change to take effect.

TIP If you want to hide unavailable options instead of dimming them in the stiffener
dialog box, add an exclamation mark in the conditions:

"toggle_field:!LeftC=0;!RightC=1"
The option is now completely hidden when unavailable:

8.13 Custom component settings
Here you will find more information about the various custom component
properties and plane types.
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• Custom component properties in the Custom Component Wizard
(page 953)

You must define these properties when you create new custom
components. You can change some of these properties when you modify
an existing custom component.

• Default properties of a custom component dialog box (page 956)

Each custom component has a dialog box that you can modify. By default,
the dialog box has a Position tab for custom parts and a General tab for
custom connections, details, and seams.

• Plane types (page 960)

When you create distance variables for a custom component, you must
select a plane type. The plane type defines what planes you can select.

• Variable properties (page 964)

Use the Variables dialog box to define properties for distance and
parametric variables.

Custom component properties in the Custom Component
Wizard
You must define these properties when you define new custom components
with the Custom Component Wizard. You can change some of these
properties when you modify an existing custom component.

For more information, see Define custom components (page 830) and Edit and
save custom components (page 840).

Type/Notes tab properties
On the Type/Notes tab, you have the following options:

Option Description
Type Select the type of the custom component.

Type affects how you insert the custom component
in the model. Type also defines if the custom
component connects to existing parts.

Name Enter a unique name for the custom component.
Description Enter a short description for the custom

component. Tekla Structures shows the description
in the Applications & components catalog.

Component identifier Enter an additional name or reference for the
component, for example a design code reference.
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Option Description
This can be shown in general arrangement and
assembly drawings, and in lists.

To show this in drawings, include Code in the
Connection Mark Properties dialog box.

Position tab properties
On the Position tab, you have the following options:

Option Description Note
Up direction Sets the default up

direction.
Not available for parts.

Position type The position (or origin)
of the component,
relative to the main part.

Not available for details
and parts.

You can define the position for custom connections and seams. You have the
following options:

Option Description Example
Middle Where the center lines

of the main and
secondary parts
intersect.

Box plane Where the main part
bounding box and the
center line of the
secondary part intersect.

Collision plane Where the main part
and the center line of
the secondary part
intersect.

Endend plane Where the center line of
the secondary part hits
the end of the main part.
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Option Description Example
Gusset plane Where the center lines

of the main part and the
first secondary part
intersect. The x direction
is perpendicular to the
center line of the main
part.

Advanced tab properties
On the Advanced tab, you have the following options:

Option Description Note
Detail type Determines on which

side of the main part the
component is located.
The options are:

• Intermediate detail

Tekla Structures
creates all
components on the
same side of the
main part

• End detail

Tekla Structures
creates all
components on the
side of the main part
closest to the details

Only affects asymmetric
components.

Only available for details
and seams

Definition point
position in relation to
primary part

Determines the position
you pick to create the
detail, relative to the
main part.

Only available for details
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Option Description Note
Definition point
position in relation to
secondary part

Determines where the
component is created,
relative to the secondary
part.

Only available for
connections and seams

Allow multiple
instances of
connection between
same parts

Select this option to
create many
components to the same
main part, in different
locations.

Only available for
connections and seams

Exact positions Select this option to
position the seam based
on the positions that you
pick in the model.

Clear the check box to
let Tekla Structures use
automatic seam
recognition to position
the seam. This is useful
especially with warped
seams.

Only available for seams

Use the center of the
bounding box in
positioning

Select to position the
custom part based on
the center of its
bounding box (the box
that surrounds the
actual part profile).

Only available for parts

Default properties of a custom component dialog box
Each custom component has a dialog box that you can modify. By default, the
dialog box has a General tab for custom connections, details, and seams, and
a Position tab for custom parts.

For more information, see Customize the dialog boxes of custom components
(page 918).

To view the current properties, double-click the custom component in the
model.

Default properties of custom connections, details, and seams
By default, the dialog box of a custom connection, detail, or seam has the
following options:
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Option Description Note
Up direction Indicates how the component

is rotated around the
secondary part, relative to the
current work plane. If there
are no secondary parts, Tekla
Structures rotates the
connection around the main
part.

 

Position in relation
to primary part

The creation point of the
component, relative to the
main part.

Only available for
details.

Position in relation
to secondary part

Tekla Structures automatically
places the component
according to the selected
option.

By default, only
available for seams.

If you want to use this
property in
connections, select
the Allow multiple
instances of
connection between
same parts check
box on the Advanced
tab when you create
the component.

Place to picked
positions

Select this option to place the
seam at the points you pick.

Only available for
seams.

Detail type Determines on which side of
the main part the component
is located. The options are:

• Intermediate detail

Tekla Structures creates all
components on the same
side of the main part.

• End detail

Tekla Structures creates all
components on the side
that is closest to the
details.

Only affects asymmetric
components.

Only available for
details.

Locked Select Yes to prevent other
users from modifying the
properties.
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Option Description Note
Class The class of the parts that the

custom component creates.
 

Connection code Identifies the component. You
can display this connection
code in connection marks in
drawings.

 

AutoDefaults rule
group

The rule group used for
setting the connection
properties.

 

AutoConnection rule
group

The rule group Tekla
Structures uses to select the
connection.

 

Default properties of custom parts
By default, the dialog box of a custom part has the following options:

Option Description Example
On plane Changes part location on the work

plane.
Middle

Right

Left
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Option Description Example
Rotation Rotates the part in steps of 90

degrees.
Top and Below

Front and Back

At depth Changes part location perpendicular
to the work plane.

Middle

Front

Behind
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Option Description Example
Show third
handle

Sets the third handle of a nested
custom part visible in the desired
direction.

You can bind the third handle in the
desired direction and thus force the
part to follow the rotation of another
part.

None

Above

On the left

Plane types
When you add distance variables to a custom component, or to a model, you
must select a plane type. The plane type defines what planes you can select.
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You have the following options on the Custom component editor toolbar:

For more information, see Add variables to a custom component (page 849).

Plane type Description Example
Boundary planes You can select the edges of a

bounding box that surrounds
the profile.

Center planes You can select the center
planes of a profile.

Outline planes You can select the outer and
inner surfaces of a profile.
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Plane type Description Example
Cut planes If the part contains line, part,

or polygon cuts, this option
enables you to select cut
surfaces. Fittings cannot be
selected.

Component planes What you can select depends
on the component type and
the Position type of the
custom component.

TIP When you create distance variables in a model and bind model object reference
points to different planes, select the plane type from the third list on the
Snapping toolbar. Most of the plane type options there are the same as above,
but Grid planes is available instead of Component planes.

Examples of component planes
See below for examples of possible component planes. What you can select
depends on the component type and the Position type of the custom
component.

Part component planes
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Connection component planes

Detail component planes

Seam component planes
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Variable properties
Use the Variables dialog box to view, modify, and create parametric variables,
and to view fixed and reference distance variables.

Tekla Structures uses variables with custom components (page 849), sketched
cross sections, and parametric modeling. The examples below are given for
custom components, but the same principles apply also to sketched cross
sections and parametric modeling.

Option Description
Category Component parameters lists all

variables in the component.

Model parameters lists variables in
the current model (such as bindings
between a part's end point and a grid
plane).

Name A unique name of a variable. Use this
name to refer to the variable in the
custom component editor.

To be able to correctly reference a
variable, its name must be 19
characters or shorter. Variables with
longer names will not work correctly
when referenced.

Formula Use this box to enter a value or a
formula (page 869).

Formulas begin with =.
Value Shows the current value of Formula.
Value type Select a value type from the list. The

type determines what kind of value
you can enter for the variable.

Variable type This property can be either Distance
or Parametric.
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Option Description
Visibility Use this setting to control the visibility

of a variable.

Set to Show to display the variable in
the custom component dialog box.

Label in dialog box The name of the variable that Tekla
Structures displays in the custom
component dialog box.

The maximum length is 30 characters.

Value types

You have the following options for the value type:

Option Description
Number A whole (integer) number. Use for

quantity and multiplier.
Length A decimal (floating point) number.

Use for lengths and distances. Length
numbers have unit (mm, inch, etc.)
and they are rounded to two decimal
places.

Text A text (ASCII) string.
Factor A decimal value without a unit. You

can set the number of decimals for
the value type in File menu -->
Settings --> Options --> Units and
decimals .

Angle A decimal number type for storing
angles, stored to one decimal place, in
radians.

Material A data type associated with the
material catalog. Use to select a
material grade from the Select
Material dialog box.

Profile A data type associated with the profile
catalog. Use to select a profile from
the Select Profile dialog box.

Bolt size

Bolt standard

Data types linked to the bolt catalog.
Bolt size works with Bolt standard.
They have a fixed naming format:
Px_diameter and Px_screwdin. Do
not change the fixed name.

To show values for these in the
component’s dialog box, x must be
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Option Description
the same for both, for example,
P1_diameter and P1_screwdin.

Bolt type For determining the bolt type (site/
workshop) in the custom component
dialog box. Linked to the Bolt type
property of bolts in the Custom
component browser.

Stud size

Stud standard

Stud length

Data types linked to the bolt catalog.
Stud size, Stud standard and Stud
length work together. They have a
fixed naming format: Px_size,
Px_standard and Px_length. Do
not change the fixed names.

To show values for these in the
component’s dialog box, x must be
the same for all of them. For example,
P9_size, P9_standard, and
P9_length.

Hole type A data type for determining whether
holes are special holes and for
selecting the special hole type
(slotted/oversized/no hole).

Plain hole type A data type for determining whether
holes are through or blind holes.
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Option Description
Distance list Use with options that have several

length values, such as bolt spacings.

Use space as a separator between the
distances.

Distance list total Use for calculating the total value of
several listed length values, such as
bolt spacings.

Use space as a separator between the
distances.

Weld type A data type for selecting the weld
type.

Chamfer type A data type for determining the shape
of a chamfer.

For more information, see Chamfer
part corners and edges (page 397).

Welding site A data type for determining the
welding place: workshop or building
site.

Rebar grade

Rebar size

Rebar bending radius

Data types linked to reinforcement
catalog. Rebar grade, Rebar size,
and Rebar bending radius work
together. They have a fixed naming
format: Px_grade, Px_size, and
Px_radius. Do not change the fixed
name.

To show values for these in the
component's dialog box, x must be
the same for all, for example,
P1_grade, P1_size, and P1_radius.
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Option Description
Rebar hook type Used for rebar set end detail

modifiers, to specify the hook type.
Length adjustment type Used for rebar set end detail

modifiers, to specify how the bar
length is extended or shortened,
according to a specified end offset or
leg length.

Bars affected Used for rebar set modifiers, to
specify how many bars are to be
modified (1/1, 1/2, and so on).

Rebar stagger type Used for rebar set splitters, to specify
the stagger type (left/right/middle).

Rebar lap side Used for rebar set splitters, to specify
the side of the overlap (left/right/
middle).

Rebar lap placement Used for rebar set splitters, to
determine whether the lapping bars
are parallel to each other or on top of
each other.

Rebar lap type Used for rebar set splitters, to
determine whether the reinforcing
bars are kept straight at lap splices by
offsetting entire bars, or placed
slanted by offsetting bar ends.

Reinforcement mesh For determining meshes in custom
components. Linked to the Catalog
name property of reinforcement
meshes in the Custom component
browser.

Cross bar location Used for rebar meshes, to determine
whether the crossing bars are located
above or below the longitudinal bars.

Component name

Component attribute file

Use Component name for replacing
a sub-component inside a custom
component with another sub-
component. Linked to the Name
property of objects in the Custom
component browser.

Use Component attribute file for
setting the properties of a sub-
component inside a custom
component.

Component name and Component
attribute file work together. They

Custom components 968 Custom component settings



Option Description
have a fixed naming format: Px_name
and Px_attrfile. Do not change the
fixed name.

To show values for these in the
component's dialog box, x must be
the same for both, for example,
P2_name and P2_attrfile.

Yes/No For determining whether or not Tekla
Structures creates an object in a
custom component. Linked to the
Creation property of objects in the
Custom component browser.

Shape A data type associated with the shape
catalog. Use for selecting a shape
from the Shape Catalog dialog box.

Bitmask For defining bolt assembly (nuts and
washers) and parts with slotted holes.
Linked to the Bolt structure and
Parts with slotted holes properties
of bolts in the Custom component
browser.

The value is a five-digit series of ones
and zeros. This relates to the check
boxes in the bolt properties. 1 means
that a check box is selected, 0 means
that a check box is clear.

In the example below, the value of
10010 means that a bolt with a
washer and a nut is created in the
bolt assembly.
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Option Description
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9 Predefined parametric profiles
available in Tekla Structures

The below predefined parametric profiles are available in Tekla Structures.

The profiles are listed in the same order as they appear in the profile catalog in
the default environment.

To change how the profiles are grouped in the profile catalog, modify the
profile catalog rules.

You can download additional predefined profiles from Tekla Warehouse.

9.1 I profiles

HIh-s-t*b (symmetric)

HIh-s-t1*b1-t2*b2

HIh1-h2-s-t*b

HIh1-h2-s-t1*b1-t2*b2

Predefined parametric profiles available in Tekla
Structures

971 I profiles

http://warehouse.tekla.com/


9.2 I beams (steel)

I_BLT_Ah-b1-s1-t1*h2-b2-s2-t2

I_BLT_B h*b1*t1*s-b2*t2

I_HEMh*b*c*s*t

I_VAR_Ah1-ht*b1-bt*s*t

9.3 L profiles

Lh*b*t

Predefined parametric profiles available in Tekla
Structures

972 L profiles



9.4 Z profiles

BENTZ h*b*d*t[-a]

Z h*b*t

Z_VAR_A h1*b1*b2-s-h2*b3

Z_VAR_B h1*b1*b2-s-h2*b3

Z_VAR_C h1*b1*b2-s-h2*b3

Predefined parametric profiles available in Tekla
Structures

973 Z profiles



9.5 U profiles

Uh*b*t

9.6 C profiles

Ch*b*t

C_BUILTh*b*s*t

C_VAR_Ah1*b1-s-h2*b2

C_VAR_Bh1*b1-s-h2*b2

Predefined parametric profiles available in Tekla
Structures

974 C profiles



C_VAR_Ch1*b1-s-h2*b2

C_VAR_Dh-b-d-c-s

9.7 T profiles

Th-s-t-b

9.8 Welded box profiles

HK h-s-t*b-c

HKh-s-t1*b1-t2*b2-c

9.9 Welded beam profiles

B_WLD_A h*b*s*t

Predefined parametric profiles available in Tekla
Structures

975 T profiles



B_WLD_B h*b*s*t

B_WLD_C h*s

B_WLD_D h*b*s*t

B_WLD_E h*b*s*t

B_WLD_F h*b*s*[t]

B_WLD_G h*b*s*t*a

Predefined parametric profiles available in Tekla
Structures

976 Welded beam profiles



B_WLD_H h*bo*bu*s*to*tu

B_WLD_I h*bo*s*to*bu*tu*a

B_WLD_J h1*h2*b*s*t

B_WLD_K h1*h2*b*s*t

B_WLD_L h*wt*wb*s*tt*tb

B_WLD_M h1*p1*p2*p3*p4

Predefined parametric profiles available in Tekla
Structures

977 Welded beam profiles



B_WLD_N
p1*p2*p3*p4*p5*p6*p7*p8*p9

B_WLD_O
b1*h1*b4*h5*b7*h6*P1*P2

B_WLD_P
W*H*FT*WT*TPT*TPW*BPT*BPW

9.10 Box profiles

B_BUILTh*b*s*t

Predefined parametric profiles available in Tekla
Structures

978 Box profiles



B_VAR_Ah1-h2*t

B_VAR_Bh1-h2*t

B_VAR_Ch1-h2*t

9.11 WQ profiles

HQh-s-t1*t2*b2

HQh*s-t1*b1-t2*b2-c

9.12 Rectangular sections

PLh*b

h=height

b=thickness

(smaller=b)

Predefined parametric profiles available in Tekla
Structures

979 WQ profiles



9.13 Circular sections

Dd

ELDd1*r1*d2*r2

9.14 Rectangular hollow sections

Ph*t (symmetric)

Ph*b*t

Ph1*b1-h2*b2*t

Predefined parametric profiles available in Tekla
Structures

980 Circular sections



9.15 Circular hollow sections

PDd

PDd1*d2*t

EPDd1*r1*d2*r2*t

9.16 Cold rolled profiles

ZZh-t-e-b (symmetric)

ZZh-t-e1-b1-e2-b2

CCh-t-e-b (symmetric)

CCh-t-e1-b1-e2-b2

Predefined parametric profiles available in Tekla
Structures

981 Cold rolled profiles



CW h-t-e-b-f-h1 (symmetric)

CW h-t-e1*b1-f1-f2-e2*b2

CUh-t-h1-b-e (symmetric)

CUh-t-h1-b1-h2-b2-e

EBh-t-e-b-a

EBh-t-e1-b1-e2-b2-a

Reference points: 1=right

2=left

3=top

BFh-s-b-h1

SPDd*t

SPDd2*d2*t

Predefined parametric profiles available in Tekla
Structures

982 Cold rolled profiles



ESPD d1-d2*t

ECh-t-e-b-a

ECh-t-e1-b1-e2-b2-a

EDh-t-b-e-h1-h2-f1-f2-a

EEh-t-e-b-f1-f3-h1-f2-a

EFh-t-e-b1-b2-f1-f2/h1-a

Predefined parametric profiles available in Tekla
Structures

983 Cold rolled profiles



EZh-t-e-b-f1-f3-h1-f2-a

EWh-t-e-b1-b2-f1-f2-h2-h1-a

9.17 Folded plates

FFLAa-b-t

FPANBh-b-t

FPANB_-b-t

FPANBAh-b-t

FPANBA_h-b-t

FPANBBh-c-d-t

Predefined parametric profiles available in Tekla
Structures

984 Folded plates



FPANCVb-c-d-t

FPANGh-b-c-t

FPANGAh-b-c-t

FPANJa-b-c-t

FPANJa-b-c-t

FPAN a-b-c-t-g

FPANVVa-b-c-t-g

Predefined parametric profiles available in Tekla
Structures

985 Folded plates



FP_Ah-b-c-d-g

FP_AAh*b2*t*a

FP_Bh-b-c-d-g-i

FP_BBh-b-d

FP_Cb-h-c

FP_CCh-b-a-d-s

Predefined parametric profiles available in Tekla
Structures

986 Folded plates



FP_Db-h-c-d-f-g-i-j-s

FP_Eb-h-c-d-f-g-s

FP_Fb-h-c-d-f-g-s

FP_Gb-h-c-d-f-g-s

FP_Hb-h-c-d-f-s

FP_Ib-h-c-d-f-s

Predefined parametric profiles available in Tekla
Structures

987 Folded plates



FP_Jb-h-c-d-a

FP_Kb-h-c-d

FP_Lb-h-c-d-f-s

FP_Mb-h-c-d-s

FP_Nb-h-c-d

FP_Ob-h-c-d-s

Predefined parametric profiles available in Tekla
Structures

988 Folded plates



FP_Pa1*a2*h-b1*b2-Alpha1-Alpha2-
Beta1-Beta2-s

FP_Qb-h-c-d-s

FP_Rb-h-c-d

FP_Sb-h-c-s

FP_Tb-h-a-d-s

FP_Ub-h-a-d-s

Predefined parametric profiles available in Tekla
Structures

989 Folded plates



FP_Vb-h-s-c

FP_Wb-h-a-d-s

FP_WWh-b-a-c-s

FP_Yh-b-c-d

FP_Zd-h-b-s-a-f

Predefined parametric profiles available in Tekla
Structures

990 Hat profiles



9.18 Hat profiles

HAT h*a*c*t

HATCa-b-c-b1-h-b3-b4-b5-s

HATAb1*h1*h2*h3*h4*h5*h6*b2*t*f
*a*h*b

HATBb*b1*b2*h*h1*h2*h3*h4*t*f*a

Predefined parametric profiles available in Tekla
Structures

991 I beams (concrete)



9.19 I beams (concrete)

HIIh1*b1*t1-h2-s-b2*t2[-sft[-sfb]]

IIh*b1*t1-s-b2*t2[-sft[-sfb]]

SIIh1*b1*t1-h2-s-b2*t2[-sft[-sfb]]

9.20 Ledger beams (concrete)

RCLs*h-b*t

Predefined parametric profiles available in Tekla
Structures

992 Ledger beams (concrete)



RCDLs*h-b*t

RCDLs*h-b*t1*t2

RCDXs*h-b*h2*h1

RCDXs*h-b*h4*h3*h2*h1

RCDXs*h-b*h4*h3*h2*h1-ex

RCXXs*h-b*t*h1-h2-ex

RCXs*h-b*h2*h1

9.21 T profiles (concrete)

HTTh*b-s-t-b2-h2

TCh-b-t-s

Predefined parametric profiles available in Tekla
Structures

993 T profiles (concrete)



TRIh*b-b2*t1-h3-t2

TTh*b-s-t-b2

TTTh*b-bl-br-hw-bwmin-bwmax

T_VAR_Ah1*h2*s*b1*t1-sft

T_VAR_Bh-b-c-d

Predefined parametric profiles available in Tekla
Structures

994 Irregular beams (concrete)



9.22 Irregular beams (concrete)

IRR_Ab-h-g-c-d

IRR_Bh-b-c-d-f-g

IRR_Ch-b-c-d

IRR_Db1*b2-h1*h2

IRR_Eh-b-c-d-h2-h3-h4

Predefined parametric profiles available in Tekla
Structures

995 Irregular beams (concrete)



IRR_Fa*b

IRR_Gh*b*h2*b2

IRR_Hh*b*h2*b2

IRR_Ih*b*b2

IRR_Jh*b*b2

OCTB*b1-H*h1

REC_Ah-b

REC_Bh-b-b1

Predefined parametric profiles available in Tekla
Structures

996 Irregular beams (concrete)



REC_Ch-b-b1

REC_Dh-b-b2

REC_Eh-b

REC_Fh-b

REC_Gh-b

REC_Hh-b

REC_I a-b*h

TRI_Ah-b

Predefined parametric profiles available in Tekla
Structures

997 Irregular beams (concrete)



TRI_Ba1

TRI_Cb-h

TRI_Dh*b

TRI_Eb*h*h2*b2

9.23 Panels

PNL_Ah*b

PNL_Bh*b

Predefined parametric profiles available in Tekla
Structures

998 Panels



PNL_Ch*b-a-ht*bt

PNL_Dh*b-a-ht*bt

PNL_Eh*b-a-ht*bt

PNL_Fh*b-a-ht*bt

PNL_Gh*b

PNL_Hh*b-a-ht

Predefined parametric profiles available in Tekla
Structures

999 Panels



PNL_Ih*b-a-ht*bt

PNL_Jh*b-a-ht*bt

PNL_Kh*b

PNL_Lh-b-c-f

PNL_Mh-b-c-f-d

PNL_Nh-b-d-f-g-j

PNL_Oh-b-d-f-g-i-t

Predefined parametric profiles available in Tekla
Structures

1000 Variable cross sections



9.24 Variable cross sections

HEXRECTh-b-br-hr

HXGONb

OBLINCLh1-h2-h3-h4-b

OBLRIDh1*b1*b2-h2-h3-l2-l1

OBLVAR_Ah1*b1*b2-h2

OBLVAR_Bh1-h2-b

OBLVAR_Ch-b-a-i-j-k-m-n

Predefined parametric profiles available in Tekla
Structures

1001 Variable cross sections



OBLVAR_Dh-c-b

OBLVAR_Eh-b-a-c-d-i-j-k-l-m-p-o

OCTAGONb-b2

PRMDASh*b-he*be

PL_Vh*b-he*be

PRMDh*b-h2*b2

ROUNDRECTd-Rb*Rh-t*ye-ze

Predefined parametric profiles available in Tekla
Structures

1002 Others



9.25 Others

BLKSd1-d2

CAPd

HEMISPHERd

NUT_Md

RCRWh*b-b2*b3-b4-t1*t2-t3*t4

Predefined parametric profiles available in Tekla
Structures

1003 Others



SKh*b-h2-t-b2-b3

SPHEREd

STBb-h-h1-b1-b2-d

STEPh-b*h1-b1-s

Predefined parametric profiles available in Tekla
Structures

1004 Others



10Modeling settings

This section provides more information about some of the settings you can
modify in Tekla Structures.

Click the links below to find out more:

• Modify the position of a part (page 310)

• Numbering settings (page 1005)

• Reinforcement settings (page 1009)

10.1 Numbering settings
This section provides more information about specific numbering settings.

Click the links below to find out more:

• General numbering settings (page 1005)

• Weld numbering settings (page 1007)

• Control number settings (page 1008)

General numbering settings
Use the Numbering Setup dialog box to view and modify some general
numbering settings.

Setting Description
Renumber all All parts get a new number. All information on previous

numbers is lost.
Re-use old numbers Tekla Structures reuses the numbers of parts that have

been deleted. These numbers may be used to number
new or modified parts.

Modeling settings 1005 Numbering settings



Setting Description
Check for standard
parts

If a separate standard-part model (page 747) has been
set up, Tekla Structures compares the parts in the
current model to those in the standard-part model.

If the part to be numbered is identical to a part in the
standard-part model, Tekla Structures uses the same
part number as in the standard-part model.

Compare to old The part gets the same number as a previously
numbered similar part.

Take new number The part gets a new number even if a similar numbered
part already exists.

Keep number if
possible

Modified parts maintain their previous numbers if
possible. Even if a part or assembly becomes identical
with another part or assembly, the original position
number is maintained.

For example, you might have two different assemblies,
B/1 and B/2, in the model. Later on you modify B/2 so
that it becomes identical with B/1. If the Keep number
if possible option is used, B/2 will maintain its original
position number when you renumber the model.

Synchronize with
master model (save-
numbering-save)

Use this setting when working in multi-user mode. Tekla
Structures locks the master model and performs a save,
numbering, and save sequence, so that all other users
can continue working during the operation.

Automatic cloning If the main part of a drawing is modified and therefore
gets a new assembly position, the existing drawing is
automatically assigned to another part of the position.

If the modified part moves to an assembly position that
does not have a drawing, the original drawing is
automatically cloned to reflect the changes in the
modified part.

Holes The location, size, and number of holes affects
numbering.

Part name The part name affects numbering.
Beam orientation The orientation of beams affects numbering of

assemblies.
Column orientation The orientation of columns affects numbering of

assemblies.
Assembly name The assembly name affects numbering.
Assembly phase Only enabled when XS_ENABLE_PHASE_OPTION_IN_

NUMBERING is set to TRUE.

The assembly phase affects numbering.
Reinforcing bars Reinforcing bars affect numbering.
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Setting Description
Embedded objects Sub-assemblies affect the numbering of cast units.
Surface treatment Surface treatments affect the numbering of assemblies.
Welds Welds affect the numbering of assemblies.
Tolerance Parts get the same number if their dimensions differ

less than the value entered in this box.
Assembly position sort
order

See Number assemblies, cast units, and rebar
assemblies (page 723).

Family numbering See Assign family numbers (page 720).

See also

Adjust the numbering settings (page 721)

Numbering settings during a project (page 746)

Numbering examples (page 741)

Weld numbering settings
Use the Weld Numbering dialog box to view and modify the weld numbering
settings. The weld number is displayed in drawings and weld reports.

Option Description
Start number The number from which the numbering

starts. Tekla Structures automatically
suggests the following free number as
the start number.

Apply for Defines which objects are affected by
the change.

All welds changes the number of all
welds in the model.

Selected welds changes the number of
the selected welds without affecting
others.

Renumber also welds that have a
number

Tekla Structures replaces existing weld
numbers.

Re-use numbers of deleted welds If some welds have been removed, Tekla
Structures uses their numbers when
numbering other welds.

See also

Number welds (page 725)
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Control number settings
Use the Create control numbers (S9) dialog box to view and modify the
control number settings.

Option Description
Numbering Defines which parts get control

numbers.

All creates consecutive numbers for all
parts.

By numbering series creates control
numbers for parts in a specific
numbering series.

Assembly/Cast unit numbering series Defines the prefix and start number of
the numbering series for which to
create control numbers.

Needed only with the By numbering
series option.

Start number of control numbers The number from which the numbering
starts.

Step value Defines the interval between two
control numbers.

Renumber Defines how to treat parts that already
have control numbers.

Yes replaces the existing control
numbers.

No keeps the existing control numbers.
First direction Defines in what order to assign control

numbers.Second direction
Third direction
Write UDA to Defines where to save the control

numbers.

Assembly saves the control numbers to
the user-defined attributes of
assemblies or cast units.

Main part saves the control numbers to
the user-defined attributes of assembly
or cast unit main parts.

The control number appears on the
Parameters tab.
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See also

Control numbers (page 731)

10.2 Reinforcement settings
This section provides more information about the various reinforcement
settings you can modify in Tekla Structures.

Click the links below to find out more:

Reinforcing bar and bar group properties (page 1009)

Reinforcement mesh properties (page 1011)

Rebar set properties (page 1016)

Reinforcement strand properties (page 1032)

Reinforcing bar and bar group properties

Use the Single rebar and Rebar group properties to view and modify the
properties of reinforcing bars and reinforcing bar groups. The file name
extension of the property file is:

• .rbr for bars (page 496)

• .rbg for groups (page 498)

• .rci for circular groups (page 507)

• .rcu for curved groups (page 505)

General, Hooks, Cover thickness, IFC export, More

The following properties are available for single reinforcing bars and
reinforcing bar groups:

Option Description
Name User-definable name of the bar.

Tekla Structures uses bar names in reports and drawing
lists, and to identify bars of the same type.

Grade Steel grade of the bar. Size-grade-radius
combinations are
predefined in the rebar
catalog. Click the ...
button to open the
Select rebar dialog box.
The dialog box shows
the available bar sizes

Size Diameter of the bar.

Depending on the
environment, the nominal
diameter of the bar, or a mark
that defines the diameter.
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Option Description
Bending radius for the chosen grade.

You can also select
whether the bar is a
main bar, or a stirrup or
tie.

Internal radius of the bends in
the bar.

You can enter a separate value
for each bar bend. Separate
the values with spaces.

Bending radius complies with
the design code you are using.
Main bars, stirrups, ties, and
hooks usually have their own
minimum internal bending
radii, which are proportional to
the diameter of the reinforcing
bar. The actual bending radius
is normally chosen to suit the
size of the mandrels on the
bar-bending machine.

Class Use to group reinforcement.

For example, you can display bars of different classes in
different colors.

Numbering Mark series of the reinforcing bar.
Hook type Shape of the hook. The rebar catalog

(rebar_database.inp)
contains the predefined
minimum bending
radius and minimum
hook length for all
standard hooks.

See Add hooks to
reinforcing bars
(page 555).

Angle Angle of a custom hook.
Radius Internal bending radius of a

standard hook or custom hook.
Length Length of the straight part of a

standard or custom hook.

Cover thickness
on plane

Distances from the part
surfaces to the bar on the
same plane as the bar.

See Define the
reinforcement cover
thickness (page 558).

Cover thickness
from plane

Distance from the part surface
to the bar, or to the bar end,
perpendicular to the bar plane.

Start Concrete cover thickness or leg
length at the first end of the
bar.

End Concrete cover thickness or leg
length at the second end of the
bar.
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Option Description
IFC entity For IFC export, select the IFC entity type and subtype of

the bar or bar group. The available subtypes depend on
the selected IFC entity.

You can select the IFC4 subtype among the predefined
options, or you can select USERDEFINED and then enter
any text in User-defined type (IFC4).

Subtype (IFC4)
User-defined
type (IFC4)

UDAs You can create user-defined attributes to add information
about reinforcement. Attributes can consist of numbers,
text, or lists.

You can use the values of user-defined attributes in
reports and drawings.

You can also change the name of the fields, and add new
ones, by editing the objects.inp file.

Special, Distribution

The following properties are available for:

• reinforcing bar groups, including tapered (page 509) groups

• curved reinforcing bar groups

• circular reinforcing bar groups

Option Description  
Rebar group
type

What is the type of the
group.

See Create a tapered or spiral
reinforcing bar group
(page 509).Number of

cross sections
Creation
method

How the bars are spaced. See Distribute bars in a
reinforcing bar group
(page 547).Number of

reinforcing bars
Target spacing
value
Exact spacing
value
Exact spacing
values
Exclude Which bars are omitted

from the group.
See Delete bars from a
reinforcing bar group
(page 550).
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Reinforcement mesh properties

Use the Rebar mesh properties to view and modify the properties of
reinforcement meshes. The file name extension of a reinforcement mesh
property file is .rbm.

Option Description
Name User-definable name of the mesh.

Tekla Structures uses mesh names in reports and
drawing lists.

Class Use to group reinforcement.

For example, you can display bars of different classes
in different colors.

Numbering Mark series of the mesh.
Mesh type Shape of the mesh. Select Polygon, Rectangle, or

Bent.
Cross bar location Define whether the crossing bars are located above or

below the longitudinal bars.
Cut by father part
cuts

Define whether the polygon or part cuts in the part
also cut the mesh.

Mesh Identifier of the mesh. For standard meshes, the mesh
name used in the mesh catalog.

To create a Standard mesh, click the ... button and
select a mesh from the mesh catalog.

The properties of standard meshes are defined in the
mesh_database.inp file.

To create a custom mesh (page 516), select the
Custom mesh option and define the properties
(page 1013).

Grade Steel grade of the bars in the mesh.

Available for custom meshes.
Bending radius Internal radius of the bends in the bar.

Available for bent meshes.
Hooks See Add hooks to reinforcing bars (page 555).

Available for bent meshes.
Cover thickness on
plane

Distance from the part surface to the main bars on the
same plane as the bars.

Cover thickness
from plane

Distance from the part surface to the bar, or bar end,
perpendicular to the bar plane.
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Option Description
Start Thickness of concrete cover or leg length from the

mesh starting point.

Available for rectangular and bent meshes.
End Thickness of concrete cover or leg length at the end

point of the bar.

Available for bent meshes.
IFC entity For IFC export, select the IFC entity type and subtype of

the mesh. The available subtypes depend on the
selected IFC entity.

You can select the IFC4 subtype among the predefined
options, or you can select USERDEFINED and then
enter any text in User-defined type (IFC4).

Subtype (IFC4)
User-defined type
(IFC4)

UDAs You can create user-defined attributes to add
information about reinforcement. Attributes can
consist of numbers, text, or lists.

You can use the values of user-defined attributes in
reports and drawings.

You can also change the name of the fields, and add
new ones, by editing the objects.inp file.

See also

Create a reinforcement mesh (page 511)

Custom reinforcement mesh properties
Use the Rebar mesh properties to view and modify the properties of
customized reinforcement meshes. The file name extension of a
reinforcement mesh properties file is .rbm.
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You can define the following properties for the customized reinforcement
meshes (page 516):

1. Longitudinal distance

2. Cross distance

3. Longitudinal left overhang

4. Longitudinal right overhang

5. Cross left overhang

6. Cross right overhang

7. Length

8. Width

Option Description
Spacing method Define how the mesh bars are distributed.

• Same distance for all: Use to create meshes with
evenly-spaced bars.

Tekla Structures distributes as many bars as possible
for the length of Length or Width, using the
Distances and Left overhang values.

The Right overhang is calculated automatically, and it
cannot be zero.
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Option Description
• Multiple varying distances: Use to create meshes

with unevenly-spaced bars.

Tekla Structures calculates the Width and Length
based on the Distances, the Left overhang and the
Right overhang values.

If you do not change any of the values, the spacing
method changes back to Same distance for all.

Distances Spacing values of longitudinal or crossing bars.

If you select the Multiple varying distances spacing
method, enter all spacing values, separated by spaces.
You can use multiplication to repeat spacing values. For
example:

2*150 200 3*400 200 2*150
You can create meshes with unevenly-spaced bars. You
can also define a different bar size or multiple different
bar sizes for the longitudinal bars and the crossing bars.

Multiple bar sizes enable pattern creation. For example, if
you enter bar diameters 20 2*6 in the longitudinal
direction, Tekla Structures creates a pattern with one size
20 bar and two size 6 bars. This pattern can be repeated
in the mesh along the longitudinal direction.

Left overhang Extensions of crossing bars over the outermost
longitudinal bars.

Extensions of longitudinal bars over the outermost
crossing bars.

Right overhang

Diameters Diameter or size of the longitudinal or crossing bars.

You can define multiple diameters for the bars in both
directions. Enter all the diameter values, separated by
spaces. You can use multiplication to repeat diameter
values. For example, 12 2*6 in longitudinal direction and
6 20 2*12 in crossing direction.

Width Length of crossing bars.
Length Length of longitudinal bars.

Modeling settings 1015 Reinforcement settings



Option Description
Grade Steel grade of the bars in the mesh.

See also

Create a reinforcement mesh (page 511)

Reinforcement mesh properties (page 1011)

Rebar set properties
Use the property pane or the contextual toolbar to view and modify the
properties of the rebar sets. The file name extension of the property file
is .rst.

General

Option Description
Name User-definable name of the bars.

Tekla Structures uses bar names in reports and drawing lists,
and to identify bars of the same type.

Grade Steel grade of the bars. Grade-size-radius
combinations are predefined
in the rebar catalog. Click
the ... button in the property
pane to open the Select
rebar dialog box. The dialog
box shows the available bar
sizes for the chosen grade.
You can also select whether
the bars are main bars, or
stirrups or ties.

Size Diameter of the bars.

Depending on the
environment, the nominal
diameter of the bars, or a
mark that defines the
diameter.

Bending
radius

Internal radius of the bends in
the bars.

Bending radius complies with
the design code you are
using. Main bars, stirrups,
ties, and hooks usually have
their own minimum internal
bending radii, which are
proportional to the diameter
of the reinforcing bar. The
actual bending radius is
normally chosen to suit the
size of the mandrels on the
bar-bending machine.

Automatic values are shown
in square brackets, for
example [120.00].
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Option Description
Class Used to group reinforcement.

For example, you can display bars of different classes in
different colors.

Numbering Numbering series of the bars.

Special

Option Description
Follow edges Select whether the rebar set guideline attempts to follow the

leg face edges that are located between the guideline end
points.

Layer
number

Defines the order of the bar layers. The smaller the layer
number, the closer to the concrete surface the bar layer is.
You can use both positive and negative numbers.

If you do not define the layer numbers, Tekla Structures
arranges the bar layers according to their creation order. The
bar layer that is created first is closest to the concrete
surface.

You can also adjust the layer order (page 522) by using these
options on the contextual toolbar:

Note that if you copy properties from one rebar set to
another, the layer number is not copied.

Distribution

Option Description
Start offset The offsets at the start and end of the guideline.

By default, Tekla Structures calculates the offset
values according to the concrete cover settings
and bar diameter. Automatic values are shown in
square brackets, for example [32.00].

Note that the automatic offset values may
change if the outermost rebar set bars are split
by splitters and the split bars would end up in the
concrete cover area.

End offset

Creation method How the bars are spaced. For more information,
see Spacing options.Number of reinforcing

bars
Target spacing value
Exact spacing value
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Option Description
Exact spacing values
Exclude Which bars are omitted from the rebar set.

See also Examples.

Advanced: Rounding

Option Description
Straight bars Define whether the lengths of straight

bars, first and last legs, and
intermediate legs are rounded, and
whether the bar lengths are rounded
up, down, or to the nearest suitable
number according to the rounding
accuracy.

First and last legs
Intermediate legs

Rounding up at splitters At splitter locations, define how much
the bar lengths can be rounded up.

Advanced: Step tapering

Option Description
Type Define whether the bars are step

tapered, and how the tapering steps
are created.

The options are None, Distance, and
Number of bars.
If you select the Number of bars
option, enter the number of bars in
one tapering step.

Straight bars If you select the Distance option,
enter the tapering step values for
straight bars, first and last legs, and
intermediate legs.

First and last legs
Intermediate legs

Advanced: Minimum lengths to be created

Option Description
Minimum bar length Use to prevent Tekla Structures from

creating reinforcing bars that are too
short. This setting is primarily for
straight bars. Enter the minimum bar
length as Distance or as Coefficient
of bar diameter.
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Option Description
Minimum straight start/end leg
length

Use for bent reinforcing bars. Enter
the minimum leg length as Distance
or as Coefficient of bar diameter.

IFC export

For IFC export, select an option in IFC entity and in Subtype (IFC4). The
available subtypes depend on the selected IFC entity.

You can select the IFC4 subtype among the predefined options, or you can
select USERDEFINED and then enter any text in User-defined type (IFC4).

More

Click the User-defined attributes button to open the user-defined attributes
of the rebar sets. The file name extension of the user-defined attribute file
is .rst.more.

You can use user-defined attributes to define or override settings, such as bar
layer prefix and number, or grouping settings.

See also

Create a rebar set (page 470)

Modify a rebar set (page 521)

Secondary guideline properties (page 1019)

Leg face properties (page 1020)

Leg surface properties (page 1021)

Property modifier properties (page 1022)

End detail modifier properties (page 1026)

Splitter properties (page 1029)

Secondary guideline properties
Use the property pane or the contextual toolbar to view and modify the
properties of the rebar set secondary guidelines.

General

To make a secondary guideline follow the leg face edges that are located
between the guideline end points, select Yes from the Follow edges list in the
property pane.

Alternatively, select the secondary guideline and click  on the contextual
toolbar.

Modeling settings 1019 Reinforcement settings



Spacing properties

If you want a secondary guideline to have similar spacing properties as the
primary guideline, select Yes from the Inherit from primary list in the
property pane. You can then modify the Start offset and End offset values if
needed. The spacing values and ranges are automatically scaled by the ratio of
the secondary guideline length to the primary guideline length.

If you want to define the secondary guideline spacing properties
independently from the primary guideline, select No from the Inherit from
primary list, and then modify the following spacing properties as needed:

Option Description
Start offset The offsets at the start and end of the guideline.

By default, Tekla Structures calculates the offset
values according to the concrete cover settings
and bar diameter. Automatic values are shown in
square brackets, for example [32.00].

Note that the automatic offset values may
change if the outermost rebar set bars are split
by splitters and the split bars would end up in the
concrete cover area.

End offset

Creation method How the bars are spaced. For more information,
see Spacing options.Number of reinforcing

bars
Target spacing value
Exact spacing value
Exact spacing values
Exclude Which bars are omitted from the rebar set.

See also Examples.

See also

Modify a rebar set locally using modifiers (page 533)

Distribute bars in a rebar set (page 541)

Rebar set properties (page 1016)

Leg face properties
Use the property pane or the contextual toolbar to view and modify the
properties of the rebar set leg faces.
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Attributes

Option Description
Layer number Defines the order of the bar layers. The smaller the

layer number, the closer to the concrete surface
the bar layer is. You can use both positive and
negative values.

By default, Tekla Structures arranges the bar layers
according to their creation order. The bar layer that
is created first is closest to the concrete surface.

You can also adjust the layer order by using these
options on the contextual toolbar:

Note that if you copy properties from one leg face
to another, the layer number is not copied.

Additional offset Distance between the leg face and the bars.

A negative value moves the bars outside the
concrete.

Flip bar side Shows if the bars are flipped over to the other side
of the leg face (Yes) or not (No). The default value
is No.

See also

Modify a rebar set using leg faces and leg surfaces (page 525)

Rebar set properties (page 1016)

Leg surface properties
Use the property pane or the contextual toolbar to view and modify the
properties of the rebar set leg surfaces. The file name extension of the
property file is .rst_ls.

Attributes

Option Description
Layer number Defines the order of the bar layers. The smaller the

layer number, the closer to the concrete surface
the bar layer is. You can use both positive and
negative values.

By default, Tekla Structures arranges the bar layers
according to their creation order. The bar layer that
is created first is closest to the concrete surface.
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Option Description
You can also adjust the layer order by using these
options on the contextual toolbar:

Note that if you copy properties from one leg
surface to another, the layer number is not copied.

Additional offset Distance between the leg surface and the bars.

A negative value moves the bars outside the
concrete.

Create holes Select whether the bars at the leg surface are cut
by the openings in the concrete.

See also

Modify a rebar set using leg faces and leg surfaces (page 525)

Rebar set properties (page 1016)

Leg face properties (page 1020)

Property modifier properties
Use the property pane or the contextual toolbar to view and modify the
properties of the rebar set property modifiers. The file name extension of the
property file is .rst_pm.

General

Option Description
Name User-definable name of the bars.

Tekla Structures uses bar names in reports and drawing lists,
and to identify bars of the same type.

Grade Steel grade of the bars. Grade-size-radius
combinations are predefined
in the rebar catalog. Click
the ... button in the property
pane to open the Select
rebar dialog box. The dialog
box shows the available bar
sizes for the chosen grade.
You can also select whether
the bars are main bars, or
stirrups or ties.

Size Diameter of the bars.

Depending on the
environment, the nominal
diameter of the bars, or a
mark that defines the
diameter.

Bending
radius

Internal radius of the bends in
the bars.

Bending radius complies with
the design code you are
using. Main bars, stirrups,
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Option Description
ties, and hooks usually have
their own minimum internal
bending radii, which are
proportional to the diameter
of the reinforcing bar. The
actual bending radius is
normally chosen to suit the
size of the mandrels on the
bar-bending machine.

Automatic values are shown
in square brackets, for
example [120.00].

Class Used to group reinforcement.

For example, you can display bars of different classes in
different colors.

Numbering Numbering series of the bars.

Special

Option Description
Follow edges Select whether the property modifier attempts to

follow the leg face edges that are located between
the modifier end points.

Modify distribution Select whether the property modifier affects the
bar spacings.

If you select Yes, the Distribution properties
become available, and Bars affected and First
affected bar are unavailable.

Bars affected Select how many bars can be modified in the same
location:

• 1/1 = all bars are modified in the same cross
section.

• 1/2 = every second bar is modified in the same
cross section.

• 1/3 = every third bar is modified in the same
cross section.

• 1/4 = every fourth bar is modified in the same
cross section.

First affected bar Define which is the first bar to be modified,
starting from the first end of the modifier.

Enter a positive number, or use the arrow buttons
to change the number.
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Option Description
Affect whole bar plane Select whether the property modifier affects all

bars of a rebar set that are in the same plane even
though some of the bars are not touched by the
property modifier (or its projection).

For example, to modify bars on opposite sides of
an opening using the same modifier, select Yes.

Grouping Select whether and how the bars that are affected
by the property modifier are grouped. The options
are:

• Automatic: Bars are grouped according to
automatic rules.

• Manual: Bars are grouped regardless of their
geometry or arrangement.

Note that this option does not group bars from
different sides of splitters.

• No grouping: Bars are not grouped, but they
are individual bars. Use this option for
overriding automatic and manual grouping.

Distribution

These properties are available when Modify distribution is set to Yes.

Option Description
Start offset The offsets at the start and end of the modifier.

Automatic values are shown in square brackets,
for example [32.00].

Note that the automatic offset values may
change if the outermost rebar set bars are split
by splitters and the split bars would end up in the
concrete cover area.

End offset

Creation method How the bars are spaced. For more information,
see Spacing options.Number of reinforcing

bars
Target spacing value
Exact spacing value
Exact spacing values
Exclude Which bars are omitted from the rebar set.

See also Examples.
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Advanced: Rounding

Option Description
Straight bars Define whether the lengths of straight

bars, first and last legs, and
intermediate legs are rounded, and
whether the bar lengths are rounded
up, down, or to the nearest suitable
number according to the rounding
accuracy.

First and last legs
Intermediate legs

Rounding up at splitters At splitter locations, define how much
the bar lengths can be rounded up.

Advanced: Step tapering

Option Description
Type Define whether the bars are step

tapered, and how the tapering steps
are created.

The options are None, Distance, and
Number of bars.
If you select the Number of bars
option, enter the number of bars in
one tapering step.

Straight bars If you select the Distance option,
enter the tapering step values for
straight bars, first and last legs, and
intermediate legs.

First and last legs
Intermediate legs

Advanced: Minimum lengths to be created

Option Description
Minimum bar length Use to prevent Tekla Structures from

creating reinforcing bars that are too
short. This setting is primarily for
straight bars. Enter the minimum bar
length as Distance or as Coefficient
of bar diameter.

Minimum straight start/end leg
length

Use for bent reinforcing bars. Enter
the minimum leg length as Distance
or as Coefficient of bar diameter.
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More

Click the User-defined attributes button to open the user-defined attributes
of the rebar set property modifiers. The file name extension of the user-
defined attribute file is .rst_pm.more.

You can use user-defined attributes to define or override settings, such as bar
layer prefix and number, or grouping settings.

See also

Modify a rebar set locally using modifiers (page 533)

Rebar set properties (page 1016)

End detail modifier properties
Use the property pane or the contextual toolbar to view and modify the
properties of the rebar set end detail modifiers. The file name extension of the
property file is .rst_edm.

Special

Option Description
Follow edges Select whether the end detail modifier attempts to

follow the leg face edges that are located between
the modifier end points.

Bars affected Select how many bars can be modified in the same
location:

• 1/1 = all bars are modified in the same cross
section.

• 1/2 = every second bar is modified in the same
cross section.

• 1/3 = every third bar is modified in the same
cross section.

• 1/4 = every fourth bar is modified in the same
cross section.

First affected bar Define which is the first bar to be modified,
starting from the first end of the modifier.

Enter a positive number, or use the arrow buttons
to change the number.

End type Select Hook or Cranking.

If you select the empty option, no hooks or cranks
are created, but you can define length
adjustments, end preparations, and user-defined
attributes.
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Hook

These properties are available when End type is Hook.

Option Description
Hook type Shape of the hook. The rebar catalog

(rebar_database.inp)
contains the predefined
minimum bending radius and
minimum hook length for all
standard hooks.

See Add hooks to reinforcing
bars (page 555).

Angle Angle of a custom hook.
Radius Internal bending radius of a

standard hook or custom
hook.

Length Length of the straight part of
a standard or custom hook.

Hook
rotation

Rotation angle of a hook out
of the bar plane. Use to create
3D bars.

For example:

Cranking

These properties are available when End type is Cranking.

(1) = Location of the end detail modifier

Option Description
Cranking type Select No cranking, Standard cranking, or

Custom cranking.

Use the No cranking option to override other end
detail modifiers that create cranks.

With standard cranking, the crank dimensions are
read from the rebar catalog
(rebar_database.inp).

Crank straight length With custom cranking, enter the length of the
straight segment of the crank.

This is (2) in the image above.
Cranked length With custom cranking, select whether the length of

the cranked segment is defined in the diagonal (4)
or horizontal (3) direction:
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Option Description

 or 

Then select and enter the needed distance or a
multiplier of the bar diameter.

Cranked offset With custom cranking, enter the offset distance of
the straight segment of the crank.

This is (5) in the image above.

The default value is 2 * actual bar diameter.
Crank rotation Defines to which angle the crank is rotated.

Length adjustment

Option Description
Adjustment type Select whether and how the bar length is adjusted

(extended or shortened).

• No adjustment: Bar length is not adjusted.

• End offset: Bar length is adjusted according to
the specified end offset.

Use this option to keep the leg faces on the
concrete faces and adaptive to the concrete
faces, but still to extend or shorten the bar
ends.

• Leg length: Bar length is adjusted according to
the specified leg length.

Length Depending on the adjustment type, the length of
the end offset or leg.

With end offset, enter a positive value to extend
the bars, or a negative value to shorten the bars.

With leg length, enter a positive value to set the leg
length.

Align bar ends When the lengths of straight bars are rounded
and/or step tapered, select whether the bar ends
nearest to the end detail modifier are aligned or
not.

If you select No, the rounding and step tapering
happens at the tapered edge of the rebar set, and
if both edges are tapered, at the edge that has a
larger angle.
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End preparations

Option Description
Method Select the end method of the bars. The options

are:

• Coupler

• Coupler female

• Coupler male

• Threaded

• Anchor
Type Select the end method type. The options are:

• Standard

• Position

• Bridging

• Transition

• Bolt

• Weldable
Product Product name of the end detail. Can be shown in

reports.
Code Product code of the end detail. Can be shown in

reports.
Thread type Enter the type of the threading.
Threaded length Length of the threading from the bar end.
Extra fabrication
length

Additional length needed with some threading
methods. Can be shown in reports, but does not
affect the total length of the bar.

More

Click the User-defined attributes button to open the user-defined attributes
of the rebar set end detail modifiers. The file name extension of the user-
defined attribute file is .rst_edm.more.

See also

Modify a rebar set locally using modifiers (page 533)

Rebar set properties (page 1016)
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Splitter properties
Use the property pane or the contextual toolbar to view and modify the
properties of the rebar set splitters. The file name extension of the property
file is .rst_sm.

Some of the following settings depend on the splitter direction. An arrowhead

symbol  close to the midpoint of each splitter indicates the direction and
the left and right sides of the splitter. The arrow points from the start towards
the end of the splitter.

Special

Option Description
Follow edges Select whether the splitter attempts to follow the

leg face edges that are located between the splitter
end points.

Bars affected Select how many bars can be modified in the same
location:

• 1/1 = all bars are modified in the same cross
section.

• 1/2 = every second bar is modified in the same
cross section.

• 1/3 = every third bar is modified in the same
cross section.

• 1/4 = every fourth bar is modified in the same
cross section.

First affected bar Define which is the first bar to be modified,
starting from the first end of the modifier.

Enter a positive number, or use the arrow buttons
to change the number.

Split type Select Lapping or Cranking.
Split offset Defines how far from the splitter the split is

created.

Positive values move the split to the right side and
negative values to the left side of the splitter.

Lapping

These properties are available when Split type is Lapping.

Option Description
Lapping type Select Standard lapping or Custom lapping.
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Option Description
Lap length With custom lapping, enter the length of the lap

splice.

With standard lapping, the lap length is read from
the rebar catalog (rebar_database.inp).

Lap side Select the side of the lap splice from the splitter:

• Lap left

• Lap right

• Lap middle
Lap placement Select whether the lapping bars are parallel to each

other, or on top of each other.

Cranking

These properties are available when Split type is Cranking.

(1) = Location of the splitter

Option Description
Cranking type Select Standard cranking or Custom cranking.

With standard cranking, the crank dimensions are
read from the rebar catalog
(rebar_database.inp).

Crank straight length With custom cranking, enter the length of the
straight segment of the crank.

This is (2) in the image above.
Cranked length With custom cranking, select whether the length of

the cranked segment is defined in the diagonal (4)
or horizontal (3) direction:

 or 

Then select and enter the needed distance or a
multiplier of the bar diameter.

Cranked offset With custom cranking, enter the offset distance of
the straight segment of the crank.
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Option Description
This is (5) in the image above.

The default value is 2 * actual bar diameter.
Crank side Select to which side of the splitter the crank is

created, Left or Right.
Crank rotation Defines to which angle the crank is rotated.

Staggering

Option Description
Stagger type Select whether and in which direction the splices

are staggered. The options are:

• No stagger

• Stagger left

• Stagger right

• Stagger middle
Stagger offset The offset of the adjacent bars if they are

staggered.

See also

Modify a rebar set locally using modifiers (page 533)

Rebar set properties (page 1016)

Reinforcement strand properties

Use the Strand pattern properties to view and modify the properties of
strands. The file name extension of the property file is .rbs.

Option Description
General
Name User-definable name of the strand.

Tekla Structures uses strand names in reports and
drawing lists, and to identify strands of the same
type.

Grade Steel grade of the strand.
Size Diameter of the strand.

Depending on the environment, the nominal
diameter of the strand, or a mark that defines the
diameter.
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Option Description
Bending radius Internal radius of the bends in the strand.

You can enter a separate value for each bend.
Separate the values with spaces.

Class Use to group reinforcement.

For example, you can display strands of different
classes in different colors.

Numbering Mark series of the strand.
Special
Pull per strand Pre-stress load per strand (kN).
Number of cross
sections

Number of cross sections of the strand pattern.

For example:

• Number of cross sections along strand profile =
1:

• Number of cross sections along strand profile =
2:

• Number of cross sections along strand profile =
3:

• Number of cross sections along strand profile =
4:

In this double-tee beam, the number of cross
sections is 4:
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Option Description

Debonding
Debonded strands Enter the strand number. The strand number is the

selection order number of the strand.
From start

Middle to start

Middle to end

From end

Enter the length of the debonding.

If you select the Symmetry check box, values from
From start and Middle to start are copied to From
end and Middle to end.

Symmetry Define whether the end and start lengths are
symmetrical.

IFC export
IFC entity For IFC export, select the IFC entity type and subtype

of the strands. The available subtypes depend on
the selected IFC entity.

You can select the IFC4 subtype among the
predefined options, or you can select USERDEFINED
and then enter any text in User-defined type (IFC4).

Subtype (IFC4)
User-defined type
(IFC4)

More
UDAs You can create user-defined attributes to add

information about reinforcement. Attributes can
consist of numbers, text, or lists.

You can use the values of user-defined attributes in
reports and drawings.

To set values for user-defined attributes, click the
User-defined attributes button.

You can also change the name of the fields, and add
new ones, by editing the objects.inp file.

See also

Create a reinforcement strand pattern (page 517)

Debond reinforcement strands (page 518)
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11Disclaimer

© 2023 Trimble Solutions Corporation and its licensors. All rights reserved.

This Software Manual has been developed for use with the referenced
Software. Use of the Software, and use of this Software Manual are governed
by a License Agreement. Among other provisions, the License Agreement sets
certain warranties for the Software and this Manual, disclaims other
warranties, limits recoverable damages, defines permitted uses of the
Software, and determines whether you are an authorized user of the Software.
All information set forth in this manual is provided with the warranty set forth
in the License Agreement. Please refer to the License Agreement for important
obligations and applicable limitations and restrictions on your rights. Trimble
does not guarantee that the text is free of technical inaccuracies or
typographical errors. Trimble reserves the right to make changes and
additions to this manual due to changes in the software or otherwise.

In addition, this Software Manual is protected by copyright law and by
international treaties. Unauthorized reproduction, display, modification, or
distribution of this Manual, or any portion of it, may result in severe civil and
criminal penalties, and will be prosecuted to the full extent permitted by law.

Tekla Structures, Tekla Model Sharing, Tekla PowerFab, Tekla Structural
Designer, Tekla Tedds, Tekla Civil, Tekla Campus, Tekla Downloads, Tekla User
Assistance, Tekla Discussion Forum, Tekla Warehouse and Tekla Developer
Center are either registered trademarks or trademarks of Trimble Solutions
Corporation in the European Union, the United States, and/or other countries.
More about Trimble Solutions trademarks: http://www.tekla.com/tekla-
trademarks. Trimble is a registered trademark or trademark of Trimble Inc. in
the European Union, in the United States and/or other countries. More about
Trimble trademarks: http://www.trimble.com/trademarks.aspx. Other product
and company names mentioned in this Manual are or may be trademarks of
their respective owners. By referring to a third-party product or brand, Trimble
does not intend to suggest an affiliation with or endorsement by such third
party and disclaims any such affiliation or endorsement, except where
otherwise expressly stated.

Portions of this software:

EPM toolkit © 1995-2006 Jotne EPM Technology a.s., Oslo, Norway. All rights
reserved.
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Portions of this software make use of Open CASCADE Technology software.
Open Cascade Express Mesh Copyright © 2019 OPEN CASCADE S.A.S. All rights
reserved.

PolyBoolean C++ Library © 2001-2012 Complex A5 Co. Ltd. All rights reserved.

FLY SDK - CAD SDK © 2012 VisualIntegrity™. All rights reserved.

This application incorporates Open Design Alliance software pursuant to a
license agreement with Open Design Alliance. Open Design Alliance Copyright
© 2002-2020 by Open Design Alliance. All rights reserved.

CADhatch.com © 2017. All rights reserved.

FlexNet Publisher © 2016 Flexera Software LLC. All rights reserved.

This product contains proprietary and confidential technology, information
and creative works owned by Flexera Software LLC and its licensors, if any. Any
use, copying, publication, distribution, display, modification, or transmission of
such technology in whole or in part in any form or by any means without the
prior express written permission of Flexera Software LLC is strictly prohibited.
Except where expressly provided by Flexera Software LLC in writing,
possession of this technology shall not be construed to confer any license or
rights under any Flexera Software LLC intellectual property rights, whether by
estoppel, implication, or otherwise.

To see the third party open source software licenses, go to Tekla Structures,
click File menu --> Help --> About Tekla Structures --> 3rd party licenses
and then click the option.

The elements of the software described in this Manual are protected by
several patents and possibly pending patent applications in the United States
and/or other countries. For more information, go to page http://
www.tekla.com/tekla-patents.
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batch editing
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