Contents

1 Manage Tekla Structures ............................................................. 9
  1.1 Before you start using Tekla Structures.........................................................9
  1.2 Get started with managing Tekla Structures in an enterprise company.................................................................9
  1.3 Get started with managing Tekla Structures in a small or medium company........................................................................................... 10
  1.4 Get started with managing Tekla Structures as an individual user........11

2 Plan the installation and set up Tekla Structures................... 12
  2.1 Tekla Structures installation requirements.................................................12
  2.2 Overview of environments, roles, and configurations in Tekla Structures.........................................................................................................13
  2.3 Folder structure for Tekla Structures installation...................................... 14
    Hidden files and folders for Tekla Structures..................................................15
    Company folder structure..................................................................................16
    Backing up important Tekla Structures folders..................................................16
    Virus protection and Tekla Structures folders..................................................16
  2.4 Project and firm folders................................................................................. 16
    Benefits of the project and firm folders...........................................................17
    Advanced options for defining the project and firm folders..............................18
    Create a project or firm folder............................................................................18
    Example of using a firm folder............................................................................19
    Fixed sub-folders in project and firm folders..................................................20
  2.5 Use a Trimble Connect project as the project or the firm folder.............. 23
    Set a folder in a Trimble Connect project as XS_PROJECT................................................ 24
    Set a folder in a Trimble Connect project as XS_FIRM.......................................................25
  2.6 Tekla Structures installation for administrators........................................ 26
    Tekla Structures installation on workstations..................................................26
    Installation files for Tekla Structures software and environments......................27
    Standard Tekla Structures installation............................................................27
    Centralized Tekla Structures installation..........................................................27
    Tekla Structures installation in a virtual environment.......................................27
  2.7 Install .tsep packages.................................................................................... 28
    Install .tsep packages directly from the file system............................................28
    Install .tsep packages using the Extension manager in Tekla Structures................ 29
    Update installed extensions................................................................................29
    Uninstall .tsep packages in Tekla Structures extension manager..........................29
    Uninstall .tsep packages in Tekla Structures Extension Package (TSEP) builder
      and test runner.................................................................................................30
    Centralized installation of .tsep packages..........................................................30
  2.8 Use Tekla Structures with application and desktop virtualization...........31
    Prerequisites for using Tekla Structures in a virtual environment.......................32
3 Customize Tekla Structures for users ........................................ 35
  3.1 Hierarchy of Tekla Structures settings ........................................ 35
      Environment settings for administrators ........................................ 37
      Common environment settings .................................................. 37
      Country-specific environment settings ....................................... 37
      Company settings for administrators ......................................... 37
      Customization of model templates ............................................. 38
      Update model templates .......................................................... 39
      Customization of reports and drawings ....................................... 40
      Create cloning templates for drawings ........................................ 40
  3.2 Distribute customized ribbons by using a firm or environment folder... 41
      Add ribbons to a firm or environment folder ................................ 41
      Loading order of custom ribbons .............................................. 42
      Naming convention for ribbon files .......................................... 42
  3.3 Distribute customized tabs by using a firm or environment folder ....... 43
  3.4 Distribute customized property pane layouts by using a project, firm, or environment folder.................................................. 45
      Add a property pane layout file in a project, firm, or environment folder .................................................. 45
      Search order of customized property pane layout files .................. 46
  3.5 Distribute customized property pane settings by using a project, firm, or environment folder.................................................. 46
  3.6 Distribute customized toolbars by using a project, firm, or environment folder .................................................. 47
  3.7 Files for configuring Tekla Structures ....................................... 47
      Folder search order ..................................................................... 48
      Check and change Tekla Structures file and folder locations in Directory browser .................................................. 51
      Initialization files for start-up parameters and default settings .......... 52
      Typical initialization files (.ini files) and their reading order .......... 52
      Global default environment settings - env_global_default.ini ........ 58
      Local environment settings - env_<environment>.ini .................... 58
      Role settings - role_<role>.ini .............................................. 58
      Add an advanced option to the user.ini file ................................ 60
      Input files (.inp files) for configuring Tekla Structures ................. 61
      Show plates as flat bars in drawings and reports ......................... 62
      Define materials, thickness, and width of flat bars in the Fitprops.inp file .................................................. 62
      Define unfolding parameters in the unfold_corner_ratios.inp file .... 64
      Data files (.dat files) for configuring Tekla Structures ................. 66
      Customize user interface text in message files ............................ 68
      Customize message files .......................................................... 68
      Customize object properties and settings in property files ............ 69
      Save a user-defined property file in the property pane ................. 69
      Save a user-defined property file in a dialog box ......................... 70
      Standard files ......................................................................... 70
      How properties are loaded from standard files ............................. 70
      Save a set of standard files ...................................................... 71
      Create user-defined standard files ............................................ 72
      Files related to catalogs .......................................................... 73
      Font files for customizing Tekla Structures .................................. 75
      Symbol files for drawings ......................................................... 76
      Files related to templates, reports and drawings .......................... 76
3.8 Develop applications using Tekla Open API

4 Start new projects as a Tekla Structures administrator

4.1 Start the first project
4.2 Start new projects........................................................................................................... 137
4.3 Define project properties............................................................................................... 137
4.4 Reuse files and settings from previous projects or Tekla Structures versions........... 138
  Check advanced options for the project and firm folders.............................................. 138
  Manually transfer files and settings to a new project.................................................... 138
  Import Tekla Structures model and drawings into another model.................................. 139
4.5 Define and update user-defined attributes (UDAs)..................................................... 141
  When you define new user-defined attributes............................................................... 142
  Best practice for user-defined attribute names.............................................................. 142
  Best practices for user-defined attribute definitions..................................................... 143
  Best practices for user-defined attribute translations................................................... 143
  Search order of objects.inp files.................................................................................... 143
  If you need to change existing user-defined attribute definitions................................. 144
  Update definitions of user-defined attributes (UDAs) in a model................................. 144
  Environment database file............................................................................................ 145
  Example: Create and update a user-defined attribute (UDA)........................................ 145
  Add UDAs in reference models..................................................................................... 149
  Properties of the objects.inp file.................................................................................. 151
4.6 Templates..................................................................................................................... 151
  Template Editor User’s Guide........................................................................................ 153
  Create a textual template.............................................................................................. 153
  Example: Create a template for nested assemblies...................................................... 163
  Create a graphical template.......................................................................................... 167
  Control font height metric in graphical templates....................................................... 167
  Create a template in HTML format............................................................................... 178
  Create a .pdf report template....................................................................................... 180
  Create a template for bending schedules or pull-out pictures...................................... 183
    Autoscaling pull-out pictures...................................................................................... 186
    Changing the appearance of pull-out pictures........................................................... 187
    Bending schedule attributes..................................................................................... 187
  Add images in a template............................................................................................. 189
  Content types in templates.......................................................................................... 192
  Template attribute files (contentattributes.lst).......................................................... 195
  User-defined template attributes.................................................................................. 196
    Example: Add user-defined template attributes to the Template Editor..................... 197
    Add comments to user-defined template attributes................................................... 199
    Add hierarchy to user-defined template attributes................................................... 200
  Tips for templates......................................................................................................... 201
    Using type attributes in calculations........................................................................ 201
    Change value field content to use imperial units....................................................... 201
    Define customized date format.................................................................................. 202
    Assembly or cast unit drawing sheet number............................................................ 202
    Use format functions in value fields.......................................................................... 203
4.7 Set up a project for collaboration and interoperability.............................................. 205
  Checklist for interoperabilitySet up a project for collaboration and interoperability.. 205
  Collaborative modeling for administrators.................................................................. 205
  Management of Tekla Model Sharing........................................................................... 206
  Install the cache service for Tekla Model Sharing...................................................... 206
  Host your own potree point cloud data.......................................................................... 210
  Create a potree file with Point cloud manager............................................................ 210
  Configure an Azure Storage Account to host the point cloud data............................ 211
4.8 Customize catalogs and databases............................................................. 243

Additional content in Tekla Warehouse.......................................................... 243

Customize the material catalog........................................................................ 244
  Important buttons in the material catalog........................................................  245
  Add a material grade.........................................................................................  245
  Copy a material grade.......................................................................................  246
  Modify a material grade....................................................................................  246
  Delete a material grade.....................................................................................  247
  Add user attributes to material grades.............................................................  247
  Create user-defined material definitions.........................................................  248
  About importing and exporting material grades..............................................  249
  Export a part of the material catalog...............................................................  249
  Export an entire material catalog.................................................................... 249
  Import a material catalog................................................................................ 250
  Units used in import and export..................................................................... 251

Customize the profile catalog.......................................................................... 252
  Important buttons in the profile catalog........................................................  252
  How profiles are grouped together.................................................................... 253
  Add a rule to the profile catalog...................................................................... 253
  Modify a rule in the profile catalog................................................................. 254
  Add user attributes to profiles....................................................................... 254
  Associate profile types with a certain material............................................. 257
  Delete a profile from the profile catalog....................................................... 258
  Import and export profiles............................................................................. 259
  Create your own profiles.............................................................................. 265

Customize the shape catalog........................................................................... 312
  Create shapes................................................................................................. 313
  Organize shapes and groups in the shape catalog......................................... 314
  Organize the shape catalog view................................................................. 322
  Import shapes into Tekla Structures............................................................... 326
  Export shapes................................................................................................. 329
  Compress shape geometry files...................................................................... 331
  Clean or restore shape geometry files............................................................ 332

Customize the bolt catalog............................................................................... 333
  How the bolt catalog and bolt assembly catalogs work together.................... 334
  Manage bolts and bolt assemblies................................................................. 334
  Import and export bolts and bolt assemblies............................................... 338
  How bolt and bolt assembly catalogs affect length calculation..................... 342
  Bolt catalog properties.................................................................................. 345
  Bolt assembly catalog properties................................................................. 347

Customize the rebar catalog........................................................................... 348
  Work with definitions in the rebar catalog.................................................... 349
  Work with groups in the rebar catalog......................................................... 351
  Import and export rebar definitions.............................................................. 352
  Organize the rebar catalog view................................................................. 354

Customize the Applications & components catalog....................................... 359
  Edit the Applications & components catalog.............................................. 360
Maintain the Applications & components catalog..................................................363
Create your own component folder.............................................................................364
Troubleshooting components or groups in the Applications & components catalog............................................................................................................................................. 365
Add instructor help for applications and components..................................................365

4.9 Create customized desktop shortcuts for Tekla Structures.................... 367
Create a desktop shortcut for Tekla Structures with customized initializations........367
Available parameters in desktop shortcuts for Tekla Structures..................................369
Example of an initialization file.......................................................................................... 370
Bypass the sign in dialog box.............................................................................................371

5 Daily management of Tekla Structures......................................................... 372
5.1 Management of the organization for Tekla Online services....................372
5.2 Management of Tekla Structures subscriptions....................................... 373
5.3 Tekla Structures upgrades for administrators........................................... 373
5.4 Printer settings..............................................................................................374

6 Disclaimer........................................................................................................ 375
Managing Tekla Structures means customizing and deploying Tekla Structures for users in your organization or for your own use.

Types of users who manage Tekla Structures include:

- Tekla Structures administrators or BIM managers, who customize Tekla Structures for users in their organization.
- IT administrators who manage the network environment and Tekla Structures subscriptions, and deploy Tekla Structures for users.
- Individual users, such as freelancers, who have a personal Tekla Structures subscription and want to customize Tekla Structures for their own use.

1.1 Before you start using Tekla Structures

You must have a Trimble Identity to download Trimble products and to use your subscriptions.

Tekla Online services, including Tekla Structures subscriptions, use Trimble Identity for identification. You can use your Trimble Identity with other Trimble services, such as Trimble Connect and SketchUp 3D Warehouse.

For more information, see Create your Trimble Identity.

1.2 Get started with managing Tekla Structures in an enterprise company

To get started as a Tekla Structures administrator, familiarize yourself with the concepts related to installation, customization, and starting projects.
As a Tekla Structures administrator, you need a deeper understanding and more managed approach to defining and maintaining the configurations and settings that your users need in their work.

**Workflow for administrators or BIM managers**
The typical workflow for a Tekla Structures administrator or BIM manager is:
1. Plan the installation (page 12) needs for Tekla Structures.
2. Customize (page 35) and distribute the customizations to users in your company.
3. Set up new projects (page 136).

**Workflow for IT administrators**
As an IT administrator, you maintain the surrounding network environment, manage the Tekla Structures subscriptions, and deploy Tekla Structures for users.
The typical workflow for an IT administrator is:
1. Configure the network environment according to the installation requirements (page 26) for Tekla Structures.
2. Manage the users in your organization (page 372), and your subscriptions (page 373).
3. Deploy for users (page 26).

### 1.3 Get started with managing Tekla Structures in a small or medium company

Administrators in a small company typically manage the customization of Tekla Structures, as well as user accounts and subscriptions in your Tekla Online organization.

The typical workflow for an administrator in a small organization is:
1. Plan how you will install (page 12) and deploy Tekla Structures for users (page 26).
2. Manage the users in your organization (page 372), and your subscriptions (page 373).
3. Customize (page 35) and distribute the customizations to users in your company.
4. Set up new projects (page 136).
1.4 Get started with managing Tekla Structures as an individual user

If you are an individual user with your own personal Tekla Structures subscription, you might want to customize Tekla Structures for your own use. Basic configuration for your own use is generally explained in the documentation of each feature. The customizations can be copied between different models. If you are configuring Tekla Structures for your own use, it is good to have a basic understanding of the folder structure for Tekla Structures installation (page 14) and files for configuring (page 47).

The typical workflow for an individual user is:

1. Install Tekla Structures.
2. Customize (page 35) for your projects and way of working.
3. Create templates (page 151).
4. Check your settings in the advanced options (page 110).
Plan the installation and set up Tekla Structures

Planning is important for ensuring that your installation of Tekla Structures meets your needs.

When planning the Tekla Structures installation, consider:

- The hardware and software components that you will need for the installation
- How you will distribute Tekla Structures to users. See Tekla Structures installation for administrators (page 26).
- Which Tekla Structures environments you will use. See Overview of environments, roles, and configurations in Tekla Structures (page 13).
- How you will use the Project and firm folders (page 16) to store customized settings.

2.1 Tekla Structures installation requirements

For information about recommended operating system and hardware specifications, see the .

Tekla Structures also requires some Microsoft redistributable packages. If these redistributable packages or newer versions of them are not already installed on your computer, they are automatically installed during the Tekla Structures software installation. For more information, see Additional necessary software components in the hardware requirements.

If you create a customized installation package, make sure that the .NET Framework is installed on the client computers.

The following installers are also automatically installed during the Tekla Structures software installation:

- Tsep File Dispatcher Launcher
• Tekla Warehouse Service

These installers are needed for Tekla Warehouse to work correctly.

2.2 Overview of environments, roles, and configurations in Tekla Structures

A Tekla Structures environment defines the materials, grades, profiles, drawing settings, component settings, and .ini file settings that are used in a specific locale. There are many different environments in Tekla Structures. When you select a specific environment when you start Tekla Structures, you get the settings for that locale. You can install several environments at the same time, and you can add more environments at any time.

If you do not install any environments, only the Blank environment is available. You can use the Blank environment as the basis for your own environment or project settings. It includes standard settings, such as parametric profiles, undefined bolt, material and rebar grades, and basic drawing layouts that you can complement from your own firm or project folders and Tekla Warehouse.

Some environments give you the opportunity to select a role when signing in. The role is independent from your subscriptions or licenses. Using roles makes the user interface and settings clearer, easier, and faster for the users' tasks. Settings, filters, reports, and the user interface are set up for the role that the user has. For example, preloaded settings in object properties that are not relevant for the role are not shown.

Role selection is primarily meant to be configured by Trimble and reseller localization personnel, and is typically part of the Tekla Structures installation package. However, advanced users and Tekla Structures administrators can
also create their own roles inside their company organization. Additional content is available in the Tekla Warehouse offline and online collections.

Tekla Structures has many different configurations. The subscriptions or licenses that you have determine which configurations you can use.

See also

Hierarchy of Tekla Structures settings (page 35)

2.3 Folder structure for Tekla Structures installation

By default, the Tekla Structures app and environments are separated into different locations due to the requirements for Windows certification.

The files are installed in the following folders by default:

- The Tekla Structures app is installed in the ..\Program Files\Tekla Structures\<version> folder.
  
  When Tekla Structures is installed in the Program Files folder, any user can run the app but they cannot make changes to it. Configuration files are installed separately in the hidden Program Data folder. Installation in the Program Files folder requires administrator rights on the computer.

- Environments and extensions are installed in the hidden ..\ProgramData \Trimble\Tekla Structures\<version> folder.

- User settings are always installed in the ..\Users\<username>\AppData \Local\Trimble\Tekla Structures\<version> folder for each user, regardless of where the Tekla Structures app is installed. Each user has access to the files in their own user settings.

You can select the installation folder when you install Tekla Structures. You can use the default installation folders or install Tekla Structures in a normal file folder on the computer, such as C:\TeklaStructures.

If you want to prevent users from making changes to the Tekla Structures app, environments, or settings, we recommend that you use the default installation folders.

If users need to easily access all files for Tekla Structures or if it is not possible for users to install Tekla Structures with administrator rights, we recommend that you install Tekla Structures in a normal file folder. When you install Tekla Structures in a normal file folder, all files except for user settings are installed in that folder. Any users who have access to the folder have access to all of the installation, configuration, and environment files.
Hidden files and folders for Tekla Structures
When the Tekla Structures app is installed in the Program Files folder, some of the files needed to run Tekla Structures are located in hidden folders and are not visible.
If needed, you can make the hidden files and folders visible using the Folder Options in Windows.

Files related to the Tekla Structures app
The Tekla Structures app and files such as the following are installed under the ..\Program Files\Tekla Structures\<version>\ folder:
• contentattributes_global.lst
• contentattributes_userdefined.lst
  (in the USA environment: contentattributes_customer.lst)

Files related to environments
Environments and files such as the following are installed under the ..\ProgramData\Trimble\Tekla Structures\<version>\ folder:
• analysis_design_config.inp
• contentattributes.lst
• dimension_marks.sym
• InquiryTool.config
• objects.inp
• objects.inp
• privileges.inp
• product_finishes.dat
• rebar_config.inp
• TeklaStructures.lin
• TilePatternCatalog.dtd
• TilePatternCatalog.xml

The exact file location can vary depending on the folder structure of your environment files.

Files related to user settings
User settings and files such as the following are installed under the ..\Users <username>\AppData\Local\Trimble\Tekla Structures\<version>\ folder for each user:
• user.ini
• options.bin

Plan the installation and set up Tekla Structures 15 Folder structure for Tekla Structures installation
• customized property pane layout PropertyTemplates.xml and PropertyTemplates.Drawing.xml files
• customized ribbon and customized tab .xml files
• customized contextual toolbar .xml files
• customized toolbar .json files

Company folder structure
Using central project and firm folders makes taking backups and upgrading easier. For example, when upgrading to a new Tekla Structures version or updating the company logo, the files only need to be replaced in one place.

If you do not use Tekla Model Sharing, we recommend using project and firm folders (page 16) on a central file server for storing your models, and the setup files for company-specific and project-specific settings. Tekla Structures reads the settings from the central file server.

If you use Tekla Model Sharing, you can synchronize the project and firm folders through the Trimble Connect cloud service included in your Tekla Structures subscription.

Back up important Tekla Structures folders
Model folders, and the firm and project folders contain valuable information and work. It is important to take backups of these folders and settings.

If your company has a system for taking automatic scheduled backups, schedule your system to take the backups at night time, outside working hours to prevent any possible conflicts in models.

Virus protection and Tekla Structures folders
Virus protection software can cause problems in saving models and drawings to the model folder. These problems might occur especially if you have saved your model on a network drive.

We strongly recommend that you add Tekla Structures to the safe list for your antivirus system, and set up your virus protection so that it does not block or scan actions in your model folder.

2.4 Project and firm folders
Project and firm folders are meant for storing customized files. Customized files can include custom ribbons, drawing styles, profile and material catalogs, or any other settings that you want to store for future use.
You can use the same files each time you start a new model or install a new version of Tekla Structures.

<table>
<thead>
<tr>
<th>Folder</th>
<th>Typical contents</th>
</tr>
</thead>
</table>
| Firm   | Settings that are used on the company level, such as company logo and drawing standard.  
Use the firm folder and its sub-folders to store customized files for the entire organization or company. The settings and files in the firm folder are meant to be used in all projects within the company. For example, let's say you regularly work for a company that has specific drawing layout standards it expects you to use. Customize the drawing templates once for the company and save them in the firm folder or in a sub-folder of the firm folder. You can then use the customized drawing templates for all future projects for that company. |
| Project| Settings that are used on a specific project.  
Use the project folder and its sub-folders to store customized files that are only used in a particular project. A project might consist of several models done by separate teams in different locations. You can save project-specific files and settings in the project folder, so that everyone in the project can use them. A project might also consist of one model that is shared by different companies. |

Property files are always saved in the \attributes folder under the current model folder, such as \TeklaStructuresModels\<my_building>\attributes. We recommend that you copy these files to the project or firm folder, or to user-defined sub-folders under the project or firm folder.

**Benefits of the project and firm folders**

Using project and firm folders to store your customized settings makes it easier to update company settings, ensure that everyone uses the same settings in a project, and upgrade to a newer version of Tekla Structures.

Tekla Structures does not replace files in the project and firm folders when you install a new version. You can retain your customized files without having to copy and paste, or export and import from the previous versions. Using project and firm folders makes upgrading faster and easier. When you store
files in one place, it is also easier to update the settings and ensure that everyone in a project uses the same settings. Using project and firm folders also allows you to easily revert back to the default settings because your customized settings do not overwrite any of the system files.

**Example:**

In the current project, 123_project_ABC, you have set up the properties for a concrete column, and saved them as column_ABC. To make these saved settings available for everyone working in the 123_project_ABC project:

1. Copy column_ABC.ccl from the \attributes folder under the model folder to the \123_project_ABC project folder or on your file server, or to a user-defined sub-folder under the \123_project_ABC project folder.
2. Ensure that everyone in the project has the correct path for the XS_PROJECT advanced option in the .ini file.

**Advanced options for defining the project and firm folders**

Project and firm folders are defined by the XS_FIRM and XS_PROJECT advanced options.

To use the saved settings in a firm and a project folder, set the path to the folder by using the XS_PROJECT and XS_FIRM advanced options. These advanced options should be put in the initialization, .ini, files. You can have several different .ini files. You can define in the Tekla Structures shortcut which .ini files to run and which settings to apply.

It might be useful to create a startup shortcut on your desktop that contains all necessary folders for each project.

**WARNING** Changing an advanced option value in .ini files located outside the model folder does not affect the existing models. You can only update advanced options in the Advanced Options dialog box or in the options.ini file located in model folder; not from an options.ini file located in folders defined for the advanced options or . The .ini files are read also when you open an existing model, but only new advanced options that do not exist in options_model.db or options_drawings.db are inserted, for example, such options that are not yet in the Advanced Options dialog box but have been added in the software.

**Create a project or firm folder**

The firm and project folders are usually located network folders or on a shared file server that all users at the company can access.

**NOTE** Alternatively, you can use a Trimble Connect project (page 23) as the project or the firm folder. You can use the settings stored in a Trimble
Connect project for single-user, multi-user, or Tekla Model Sharing models.

1. Create an empty project or firm folder in a shared location.
2. In Tekla Structures, go to the File menu and select Settings --> Advanced options.
3. In the File locations category, define the path to the firm or project folder as the value of the XS_FIRM or XS_PROJECT advanced option.
4. Restart Tekla Structures for the change to take effect.

Example of using a firm folder
This example shows how to set up a firm folder, and set the value of the XS_FIRM advanced option so that Tekla Structures uses the settings in the firm folder.

1. In a shared location, such as a network drive, create a folder named Firm.

   You can give the folder any name. This example uses the name Firm.

2. In the firm folder, create an initialization file.

   You can use this file to set advanced options for each model.
   a. In a text editor, create a text file.
   b. Add this advanced option to the file:

   ```
   set XS_USE_ASSEMBLY_NUMBER_FOR=MAIN_PART
   ```
   c. Save the file as firm.ini in the Firm folder.

3. Set the value of the XS_FIRM advanced option so that Tekla Structures uses the firm folder.
   a. In Tekla Structures, go to the File menu and select Settings --> Advanced options.
   b. In the File locations category, define the path to the firm folder as the value of the XS_FIRM advanced option. For example, \\
      `\network-drive\TeklaStructures\Company-Settings\Firm\`

4. Restart Tekla Structures for the change to take effect.
5. To verify that Tekla Structures is using the settings from the firm folder, check the value of the XS_USE_ASSEMBLY_NUMBER_FOR advanced option.
   a. In Tekla Structures, go to the File menu and select Settings --> Advanced options.
   b. In the Numbering category, check that the value of the XS_USE_ASSEMBLY_NUMBER_FOR advanced option is MAIN_PART.
**Fixed sub-folders in project and firm folders**

Some files need to be stored in particular, or *fixed*, sub-folders under project and firm folders. If the files are not stored in these folders, Tekla Structures cannot read the files. See the files which should be stored in fixed sub-folders in the following table.

<table>
<thead>
<tr>
<th>XS_FIRM or XS_PROJECT sub-folder</th>
<th>Further sub-folders and necessary files</th>
<th>See also</th>
</tr>
</thead>
<tbody>
<tr>
<td>\AdditionalPSe ts</td>
<td>Use this folder to store additional property set configuration files for IFC export in the .xml format.</td>
<td>Property set configuration files used in IFC export</td>
</tr>
</tbody>
</table>
| \CustomInquiry                   | Use this folder to store:  
• report templates for custom inquiries as .it files  
• the InquiryTool.config file for defining which attributes are included by default in the Manage content dialog box for selecting the properties shown in custom inquiries | Custom inquiry |
| \Drawing Details                 | Use this folder to store 2D drawing details as .ddf and .png files.  
Note that to see the drawing details stored in the \Drawing Details sub-folder under a firm or project folder in Tekla Structures:  
1. In the **Drawing 2D library** side pane, click the **Folder** button.  
2. Select **Firm** or **Project**. | 2D Library in drawings |
| \macros                          | This sub-folder has the following sub-folders:  
• \Drawings  
Use this folder to store macros related to drawings as .bmp, .cs, and .cs.pdb files. | Working with applications  
• XS_MACRO_DIRECTORY |
<table>
<thead>
<tr>
<th>XS_FIRM or XS_PROJECT sub-folder</th>
<th>Further sub-folders and necessary files</th>
<th>See also</th>
</tr>
</thead>
<tbody>
<tr>
<td>• \Modeling</td>
<td>Use this folder to store macros related to modeling as .bmp, .cs, and .cs.pdb files. Note that macros are primarily read from the folder defined by the <code>XS_MACRO_DIRECTORY</code> advanced option. This advanced option can point to any folder, not just the <code>\macros</code> sub-folder of a firm or project folder.</td>
<td>• Customize the shape catalog (page 312)</td>
</tr>
<tr>
<td>\profil</td>
<td>This sub-folder can have the following sub-folders: • \ShapeGeometries Use this folder to store shape geometry descriptions as .tez or .xml files. • \Shapes Use this folder to store shape descriptions as .xml files.</td>
<td>• Customized default setup for Organizer</td>
</tr>
<tr>
<td>\ProjectOrganizerData</td>
<td>This folder has the following sub-folders: • \DefaultCategoryTrees Use this folder to store Organizer categories as .category files. • \PropertyTemplates Use this folder to store property templates from Organizer as .propertytemplate files. • \ExcelTemplates Use this folder to store customized templates in .xlt format for exporting object property values from Organizer.</td>
<td>• Distribute customized property pane layouts by using a project, firm,</td>
</tr>
<tr>
<td>\PropertyRepository</td>
<td>Use this folder to store customized property pane layouts in the PropertyTemplates.xml file.</td>
<td></td>
</tr>
<tr>
<td>XS_FIRM or XS_PROJECT sub-folder</td>
<td>Further sub-folders and necessary files</td>
<td>See also</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>------------------------------------------</td>
<td>----------</td>
</tr>
<tr>
<td>\Symbols</td>
<td>Use this folder to store:</td>
<td>or environment folder (page 45)</td>
</tr>
<tr>
<td></td>
<td>• symbols as .sym and .dwg files</td>
<td>• Add symbols in drawings</td>
</tr>
<tr>
<td></td>
<td>• other images and bitmaps used in drawings</td>
<td>• DXK_SYMBOLPATH</td>
</tr>
<tr>
<td></td>
<td>Note that symbols are primarily read from the folder defined by the DXK_SYMBOLPATH advanced option. This advanced option can point to any folder, not just the \Symbols sub-folder of a firm or project folder.</td>
<td></td>
</tr>
<tr>
<td>\template</td>
<td>Use this folder to store graphical templates used in drawing layouts as .tpl files.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Note that templates are primarily read from the folder defined by the XS_TEMPLATE_DIRECTORY advanced option.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>In the same way, the tpled.ini is primarily read from the folder defined by the XS_TPLED_INI advanced option.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>These advanced options can point to any folder, not just the \Template sub-folder of a firm or project folder.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>This folder also contains the following sub-folders:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• \mark</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Use this folder to store graphical templates used in drawing marks.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Note that templates used in drawing marks are primarily read from the folder defined by the XS_TEMPLATE_MARK_SUB_DIRECTORY folder. This advanced option can point to any folder, not just the</td>
<td></td>
</tr>
</tbody>
</table>
2.5 Use a Trimble Connect project as the project or the firm folder

You can use a Trimble Connect project as the project or the firm folder to store customized files. Using Trimble Connect project to set up XS_PROJECT and XS_FIRM is often the most convenient way to store the customized files. Especially, when multiple licenses are used in one company, and you want to ensure that users always use the same settings and that the updates are automatically shared with everyone. You can use the settings stored in a Trimble Connect project for single-user, multi-user, or Tekla Model Sharing models.

When a model is opened, Tekla Structures checks the file differences between the files in the Trimble Connect project folder and in the local ..\Users <user>\AppData\Local\Trimble\tekla folder sync\ folder. The project and firm folder information is updated from Trimble Connect to local versions of the models, not vice versa.

In practice, this means that Tekla Structures downloads new files from the project or film folder to the local model and updates any changed files. If a
local file is not stored in the Trimble Connect project folder, the file is removed from the local model.

When Tekla Structures detects a change between the local model data and the data in the Trimble Connect project or firm folder, the following notification appears:

If you click Yes, the model is saved and closed. Then, the local model data is updated and the model is re-opened.

Tekla Structures uses Trimble Connect folder sync (CONNECT_FOLDER_SYNC) to synchronize the data.

For more detailed information on how to create the Trimble Connect project and folders, see Video: How to use a Trimble Connect folder as the project or firm folder and Using Trimble Connect files in Tekla Structures.

Note that

- if you use the Trimble Connect project and firm folders with Tekla Model Sharing, all users need to have access both to the Trimble Connect project and to the Tekla Model Sharing model.
- files that are generated when macros are compiled (cs.dll and .cs.pdb) are ignored in the folder sync operation. Thus, adding these two files in the local folder will not trigger an update.

Set a folder in a Trimble Connect project as XS_PROJECT

1. Create a Tekla Structures model.
2. To link the model to a Trimble Connect project, on the File menu, go to Trimble Connect --> Start collaboration, select the needed options and click Create.

The model is linked to the selected Trimble Connect project.

3. To open the Trimble Connect project explorer, on the Trimble Connect ribbon tab, click For browser --> Project expoler.
4. Create a folder that you want to use as a project folder to the Trimble Connect project.
   Add the needed settings and files to the folder.

5. In Tekla Structures, on the File menu, go to Settings --> Advanced options, and find the XS_PROJECT advanced option.

6. Set the value of XS_PROJECT to %CONNECT_FOLDER_SYNC%<folder>, where the folder is the Trimble Connect project folder.
   If you use the same Trimble Connect project both as the XS_PROJECT folder and for collaboration, use a sub-folder in the XS_PROJECT folder, so that the XS_PROJECT folder is separated from the Trimble Connect collaboration information. Set the sub-folder to %CONNECT_FOLDER_SYNC%\<folder>\<sub-folder of the folder>.
   For example, you could save the project folder under the Project settings folder with the name Project. In this example, the value should then be set to %CONNECT_FOLDER_SYNC%\Project Settings \Project. You can also use lower level sub-folders.

7. Click OK.

8. Restart Tekla Structures for the change to take effect.

9. When you open the model, a notification about the changes in project folder data appears. Click Yes.

**Set a folder in a Trimble Connect project as XS_FIRM**

1. Create a Tekla Structures model.

2. Open the Trimble Connect project that you want to use as firm folder.

3. Create a folder that you want to use as a firm folder to the Trimble Connect project.
   Add the needed settings and files to the folder or in the sub-folder.

4. Find out the project identifier and the region of the project.
   You can see the project identifier and the region in Trimble Connect for Browser:

   ![web.connect.trimble.com/projects?cp=Q3VCH9o data/folder/OZ6gEcCjgYA?region=Europe](image)

   The region is the same as the project server location setting. The options are:
   - asia
5. In Tekla Structures, on the **File** menu, go to **Settings** --> **Advanced options**, and find the **XS_FIRM** advanced option.

6. Set the value of **XS_FIRM** to `%CONNECT_FOLDER_SYNC%\<ProjectID>\<region>\<folder>\<sub-folder of the folder>`.

   For example, the value could be `%CONNECT_FOLDER_SYNC%\3cp-Q3VCH9ogeurope`.

   Note that the path works whether you use a `\` separator between the project ID and the region (`%CONNECT_FOLDER_SYNC%\<ProjectID>\<region>`), or whether you leave the separator out (`%CONNECT_FOLDER_SYNC%\<ProjectID><region>`)

   If you use the same Trimble Connect project both as the **XS_FIRM** folder and for collaboration, use a sub-folder in the **XS_FIRM** folder, so that the **XS_FIRM** folder is separated from the Trimble Connect collaboration information. Set the sub-folder to `%CONNECT_FOLDER_SYNC%\<ProjectID>\<region>\<folder>\<sub-folder of the folder>`.

   For example, you could save the project folder under the **Project settings** folder with the name **Project**. In this case, the value should be set to `%CONNECT_FOLDER_SYNC%\3cp-Q3VCH9o\europe\Project Settings\Project`. You can also use lower level sub-folders.

7. Click **OK**.

8. Restart Tekla Structures for the change to take effect.

9. When you open the model, a notification about the changes in project folder data appears. Click **Yes**.

### 2.6 Tekla Structures installation for administrators

You can install Tekla Structures on users' workstations using the standard installation packages or by creating your own centralized installation using MSI packages. You can also run Tekla Structures in a virtual environment.

**Tekla Structures installation on workstations**

You can install Tekla Structures on each workstation using the standard installation packages or by creating your own centralized installation using MSI packages.

You can download Tekla Structures software and environments from **Tekla Downloads**. To use the latest software, we recommend that you install the
latest service pack of Tekla Structures. Service packs include improvements and fixes to the previous main version or service pack of Tekla Structures. Service packs are available for all users with a valid maintenance contract or subscription.

**NOTE** You must install Tekla Structures with administrator rights. When you use centralized installation, the end users do not need administrator rights for the installation.

### Installation files for Tekla Structures software and environments
The installers for the Tekla Structures software and environments are `.msi` installers.

When installing a new version of Tekla Structures, first install the software, then install one or more environments. The environment `.msi` installers are installed to your computer before opening Tekla Structures.

When you run the environment `.msi` installer, the installer creates the environment folder. The installer also creates the `RemoveEnv.bat` and `ToBeRemoved.txt` files, and places them to the `..\Environments \<environment>` folder. These files are used when uninstalling an environment.

#### Standard Tekla Structures installation
The Tekla Structures installation wizard has detailed instructions about the installation.

For more information, see Install and license Tekla Structures.

#### Centralized Tekla Structures installation
Installing Tekla Structures centrally across the company network saves time in a large company when there are many Tekla Structures users.

Centralized installation allows you to run the Tekla Structures installation silently in the background so that the users do not see the installation wizard dialog boxes. For detailed information about centralized installation, see Centralized distribution of Tekla Structures 2024.

#### Tekla Structures installation in a virtual environment
You can also run Tekla Structures in a virtual environment. Application and desktop virtualization allow users to run software from a server on the
network without locally-installed Tekla Structures on their workstation. Using
Tekla Structures from the server ensures that all users in a project are using
the same project environment set-up. For detailed information about
installation in a virtual environment, see Use Tekla Structures with application
and desktop virtualization (page 31).

2.7 Install .tsep packages

Tekla Structures extension packages (.tsep packages) are Tekla Structures
extensions.

Extensions are not part of the Tekla Structures product release. .tsep
packages are available for download in Tekla Warehouse.

You can install .tsep packages in these ways:

• Directly from the file system
• Using the Extension manager in Tekla Structures
• Centrally

Install .tsep packages directly from the file system

Before you begin, download the .tsep packages that you want to install from
Tekla Warehouse. Alternatively, you can run some .tsep installers directly
from Tekla Warehouse using the Insert into model option. For more
information, see Insert Tekla Warehouse content into a Tekla Structures
model.

1. Double-click the .tsep installer that you have downloaded.

   If the .tsep installer does not automatically open with Tekla Structures
   extension manager, right-click the .tsep installer, then select
   Properties. In Opens with, click Change, then browse to
   TsepFileDispatcherLauncher.

   The Tekla Structures extension manager dialog box opens with the
   name of the extension that is going to be installed.

2. Select the Tekla Structures versions to which you want to import the
   extension, then click Import.

   The imported extension is installed the next time that you start Tekla
   Structures. It is shown in Tekla Structures extension manager, and is ready
   for use in the Applications & components catalog.
Install .tsep packages using the Extension manager in Tekla Structures

You can install a .tsep package using the Extension manager in Tekla Structures.

Before you begin, download the .tsep packages that you want to install from Tekla Warehouse.

**TIP** In Extension manager, you can search for content based on name, author, description, and type of extension.

1. In the Applications & components catalog, click > Manage extensions --> Extension manager .
2. Click Import, then browse to the .tsep installer that you want to install.
3. Click Open.

The imported extension is installed the next time that you start Tekla Structures. It is shown in Tekla Structures extension manager, and is ready for use in the Applications & components catalog.

**Update installed extensions**

When updates for your installed extensions are available, you can download and install the updated .tsep packages in the same way as you install other .tsep packages.

To receive notifications when new versions of extensions are available, Subscribe to alerts about content updates in Tekla Warehouse.

If there is an older version of the same extension package, it is uninstalled before installing the new version. Installation is canceled if the same or newer version has already been installed.

**Uninstall .tsep packages in Tekla Structures extension manager**

1. In Tekla Structures extension manager, select the .tsep packages that you want to uninstall.

   Use **Ctrl** or **Shift** to select more than one .tsep package.

2. Click Remove.

The .tsep packages are removed the next time that you start Tekla Structures.
Uninstall .tsep packages in Tekla Structures Extension Package (TSEP) builder and test runner

1. To open the Tekla Structures Extension Package (TSEP) builder and test runner dialog box, browse to ..\Program Files\Tekla Structures\<version\bin, then double-click TeklaExtensionPackage.Builder.exe.

2. On the Uninstall TSEP based extensions tab, select the .tsep packages that you want to uninstall, then click Uninstall selected.

Use Ctrl or Shift to select more than one .tsep package.

The selected .tsep are removed. You do not need to restart Tekla Structures.

Centralized installation of .tsep packages

You can centrally install a batch of .tsep installers across company workstations. This method is meant for system administrators.

By default, the .tsep installers waiting for installation are stored in \ProgramData\Trimble\Tekla Structures\<version>\Extensions\To be installed. To install .tsep packages centrally, copy the .tsep installers to the %XSDATADIR%\Extensions\To be installed folder. If the folder does not yet exist, create it.

When Tekla Structures starts, it checks the available .tsep installers from the \To be installed folder and installs them automatically. If there is an older version of the same extension package, it is uninstalled before installing the new version. Installation is canceled if the same or newer version has already been installed.

• The installed .tsep installers are stored in the %XSDATADIR%\Extensions \Installed folder.

• Invalid .tsep installers are uninstalled and moved to the %XSDATADIR% \Extensions\Invalid installations folder.

• Canceled .tsep installers are stored in %XSDATADIR%\Extensions \Cancelled installations.

Tools for copying .tsep installers

We recommend that you use ROBOCOPY from the command prompt (cmd.exe) to copy the .tsep installers. You can find more information about ROBOCOPY on the Microsoft website.

The basic syntax for ROBOCOPY is:

```
robocopy <Source> <Destination> [[<File>[ ...]]] [Options]
```

For example, to copy .tsep installers in Tekla Structures 2024:

```
robocopy "\\Server1\prod\TeklaStructures\2024.0\Environments_TSEP"
```
This command copies all .tsep installers from the \Server1 network directory to the local user's \To be installed folder. After copying, TepAutoInstaller.exe installs all .tsep installers from the local user's \To be installed folder. Installing the packages allows users to start Tekla Structures without first waiting for the installations to complete.

Centralized uninstallation of .tsep packages
You can uninstall .tsep packages in batches by creating an empty file named RemoveExtensionOnStartup in the folder for each extension that you want to uninstall. For example, \ProgramData\Trimble\Tekla Structures \<version>\Extensions\Installed\ [Extension_To_Be_Uninstalled].

The extensions are removed the next time that Tekla Structures is started.

2.8 Use Tekla Structures with application and desktop virtualization
Using Tekla Structures together with Citrix Virtual Apps and Desktops with Azure is a flexible and safe way to quickly add users to Tekla Structures projects without locally installing Tekla Structures.
This image shows the main concepts in Tekla Structures virtualization.

Citrix application and desktop virtualization products are products of Citrix Systems, Inc.

Streaming applications from the server makes it possible to use Tekla Structures on client computers, tablets, and smartphones that have different hardware and software configurations. Tekla Structures runs on Windows on the remote server and the virtualization solution allows client devices to be used for display and user input.

Users connect through a secure connection to the data center. The project data is stored only on the server. Using Tekla Structures from a centralized location ensures that all users in the project are using the same project environment.

**Prerequisites for using Tekla Structures in a virtual environment**

We recommend using Citrix Virtual Apps and Desktops with Azure for Tekla Structures virtualization. For more information, see [Citrix Virtual Apps and Desktops with Azure](https://www.citrix.com/solutions/virtual-apps-and-desktops/azure/).

This image shows the main components in Tekla Structures virtualization.
1. Users can access Tekla Structures using a thin client application, such as Citrix Receiver. Users can use Citrix XenApp client or Citrix XenDesktop desktop viewer on any supported operating system and hardware. Multiple concurrent clients can share one virtual machine instance.

2. Each `TeklaStructures.exe` running in the virtual environment must have a valid subscription or license.

   If you use legacy on-premises licenses, you can use a local, enterprise, or cloud Tekla license server. The license server can be hosted in the data center or outside of the data center.

3. Read and write project files from network-attached storage (NAS). Fast disk access is required.

   Never store models on the local disk of the virtual server. Store project data, including environments, on another server in the data center or on a file system inside the company network.

   Because accessing files from the client's local file system can be slow, we recommend that you avoid accessing files from the client's local file system as much as possible.

**Set up the virtual environment for Tekla Structures**

Set up the server, define delivery groups, and install the Tekla Structures software and environments on the server. Ensure that Tekla Structures users install the Citrix Receiver on their computers.
After setting up the virtual environment, you can use Tekla Structures on the virtual desktop in the same way as if it was installed on your own computer. When you use the virtual desktop for the first time, you can give read and write access to your local files in the file access dialog box. Giving access to your local files has the following limitations:

- Referencing local files from your computer directly in Tekla Structures is not recommended. If you need to access those files in Tekla Structures, copy them to a shared network location first.
- Model folders are not copied to the client computers.

The Citrix Receiver client is updated frequently. Always install the latest client when the web user interface prompts you to do so.

1. Set up the server.
   We recommend deploying Tekla Structures using Citrix Virtual Apps and Desktops with Azure.
   For more information, see Citrix Virtual Apps and Desktops with Azure.

2. Install Tekla Structures software and environments on the server.
   Never store models on the local disk of the virtual server. Store project data on another server in the data center or on a file system inside the company network. Select the correct network location for the model folder during the Tekla Structures installation.
   Tekla Structures environment settings are the same for all users that use the same virtual machine. As with normal desktop installations, you must still ensure that the environments on different virtual machines are the same.
   We strongly recommend that you use standard Tekla Structures environments and customize them with company or project-specific settings on the network file server.

3. Install Citrix Receiver on each Tekla Structures client computer.
   We recommend that you use the Citrix Receiver web user interface.
   a. In your web browser, open the Citrix Receiver web user interface. Use the https address provided by your company's administrators.
   b. To install Citrix Receiver, follow the steps in the installation wizard. In the installation wizard, do not create an account or sign in. Finish the installation, then return to the Citrix Receiver web user interface.
   c. After the installation, return to the Citrix Receiver web user interface and sign in with the credentials provided by your company's administrators.
   d. Select the virtual desktop. If the virtual desktop does not start automatically, run the downloaded Citrix (.ica) file.
As the Tekla Structures administrator or BIM manager, you can customize Tekla Structures to use your company's standards. Customizing Tekla Structures for the company standards and projects needs allows end user to focus on the design process.

Each new version of Tekla Structures introduces new features and functionalities to improve the overall process used for completing a project. Tekla Structures has multiple environments to suit the needs and requirements of specific markets. Many features are localized in each Tekla Structures version. Most of the changes in versions are focused on making the default saved attributes more consistent, organized, simplified, and practical.

Before you start customizing Tekla Structures to suit the needs of your company and your projects, collect the needed information, such as drawing standards, used profiles, grades and materials, company logos, and naming conventions.

The overall localization of Tekla Structures can be divided into these layers:

• Tekla Structures environment
• Company-level settings
• Project-level settings

With the exception of the Tekla Structures environment, these settings are mainly managed by company administrators.

3.1 Hierarchy of Tekla Structures settings
Tekla Structures settings are managed on several layers. On the highest layer there are hard-coded default settings that you cannot change directly but that you can override on lower layers.
1. Common environment settings that have preset values included in the installation. The common environment is always included in the installation. Do not modify or remove the common settings.

2. Regional environment settings with preset values that are suited for specific regional areas.

3. The advanced option XS_FIRM that defines a folder, typically on a network drive, that loads settings for all users within your company. This folder is the main container of files for the company.

4. The advanced option XS_PROJECT that defines a folder, typically on a network drive, that loads important settings for all users within a specific project (page 136).

5. The model template that is loaded from the environment, or from the network folders. The model template is loaded only once when you start creating a new model.

6. The model folder content that is saved locally when you add or edit settings.
   If you save content in the model folder, the saved settings in other locations override the same settings in the model folder.

**Environment settings for administrators**

Environment settings include common settings that are the same in all environments, and country-specific or region-specific settings that are localized by your local Trimble office or reseller.

**Common environment settings**

*NOTE* Do not modify or remove the common settings.

All settings and files that are the same in all environments are located in the \Tekla Structures\&lt;version&gt;\Environments\common folder. Files and settings that are specific to an environment are located in separate environment folders.

The `env_global_default.ini` file is also located in the \common folder. This file determines the standard settings, and it is the first file that is read. Other initialization files (page 51) are read after this file, and if the other files contain the same settings, they override the previous settings.

**Country-specific environment settings**

Country-specific, or region-specific, settings are located in environments folders. The folder structure of the environments can vary, but the same kind of settings exist. For example, the settings that are localized include profile database, material database, reports, selection filters, view filters, components and custom components, macros, user-defined attributes, and drawings settings.

**Company settings for administrators**

Company-level settings are mainly settings that are used throughout the company for all projects. These settings are set using `XS_SYSTEM` and `XS_FIRM`.

For a larger company with subsidiaries, the settings could be used as follows:

* XS_SYSTEM might contain multiple paths, and it points to general settings inside the company. These can be company logo, reports, printer settings, drawing settings, templates, for example. These are settings that very seldom change, and are stored on a server available for all. For example, if the company logo is updated, it only has to be replaced in one place.
- **XS_FIRM** points to the firm folder set up by the company, or a subsidiary. The folder contains all the company settings used at the particular office. These can be logos, drawing settings, templates, reports, or printer settings, for example. The firm folder can also have user-defined sub-folders for storing property files.

- **XS_PROJECT** points to the project folder. The folder contains project settings, such as logos for contractors and fabricators, or drawing settings, for example. The project folder can also have user-defined sub-folders for storing project-specific property files.

For more information about the folder search order, see [Folder search order](page 48).

You can also use company-specific collections in Tekla Warehouse online or offline in your own network. For more information, see [Getting started with Tekla Warehouse](page 48).

Access to offline collections is managed with folder rights in your network, and on the collection level in the `collections.json` file on each user's computer.

```json
"collections"
"\\server-A\company\Tekla Structures collection"
```

The `collections.json` file can be shared with selected users by copying it to the `C:\Users\Public\Documents\Tekla\Tekla Warehouse` folder.

### Customization of model templates
You can save a model with customized settings and use the model as a template when you create new models. Using model templates can be very useful if your company has different kinds of projects, such as, parking garages, office buildings, bridges, and industrial.

To create a model template, see .

By default, the model template folder is located in your environment folder, under `..ProgramData\Trimble\Tekla Structures\<version>\environments\<your environment>\`. The exact folder location might vary depending on your environment and role. Use the advanced option XS_MODEL_TEMPLATE_DIRECTORY to define a different location.

You can download, share, and store model templates in [Tekla Warehouse](page 48). This image shows an example of a model template in Tekla Warehouse.
The **Insert into model** button in Tekla Warehouse installs the model template directly in the folder defined by `XS_MODEL_TEMPLATE_DIRECTORY`. You can immediately use the template when creating a new model.

**Update model templates**

When you upgrade Tekla Structures, we strongly recommend that you update your model templates.

1. Create a new model using an existing model template.
2. Give the model the same name as in the previous Tekla Structures version.
3. Open a 3D view.
4. On the **File** menu, click **Diagnose and repair** → **Diagnose model**.
5. On the **View** tab, click **Screenshot** → **Project thumbnail** to create a project thumbnail, or add a custom image named `thumbnail.png` in the model folder.
   
   The preferred size of the image is 120 x 74 pixels.
6. On the **File** menu, click **Save as** → **Save**.
   
   If you do not do this, a message might appear warning about the model being created with a previous version.
7. On the **File** menu, click **Save as** → **Save as model template**.
8. Update the content of the model template.
a. Select which catalogs, drawing templates, report templates, and model sub-folders you want to include in the model template.

b. Manually remove all *.db files (environment database, options database files) from the model folder.

   Do not remove the db.idrm and xslib.idrm files. They are part of the model.

c. Click OK.

The *.bak, *.log and xs_user files are automatically removed from the model folder.

The model template is saved in the location defined by XS_MODEL_TEMPLATE_DIRECTORY.

You now have a sample image for your model template. The Applications & components catalog is now also in order and easy to use.

Customization of reports and drawings

If your company already has graphical templates in the DXF, DWG, or DGN format, you can convert these templates to Tekla Structures templates.

For detailed instructions, see the information about AutoCAD and Microstation files in the Template Editor User's Guide.

For information about how to create your own templates and reports, see the Template Editor User's Guide, , and Templates (page 151).

Create cloning templates for drawings

Creating cloning templates for drawings allows you to use existing drawings as the basis for creating new drawings of similar parts, assemblies, or cast units. You only need to modify the parts of the cloned drawing that differ from the original drawing.

Consider cloning drawings when:

- There are several similar parts, assemblies, or cast units in the model.
- You need to produce single-part, assembly, or cast-unit drawings of similar parts, assemblies, or cast units.
- The drawings need a lot of manual editing.

For example, you can create a drawing for one truss, edit the drawing, then clone it for similar trusses. You only need to modify the cloned drawings where the trusses differ.

The cloned drawing might contain more parts than the original drawing. Part properties, marks, associative notes, and related text objects are cloned from a similar part in the original drawing.

You can clone drawings by using Master Drawing Catalog templates. A cloning template in the Master Drawing Catalog can also be used in other
models. You can use cloning templates in projects that have the same kind of drawings.

1. In the **Document manager**, select a drawing.
2. Right-click, select **Add to Master Drawing Catalog**, then fill in the required properties.

The cloning template can be found under **Cloning templates** in the **Master Drawing Catalog**. To use cloning templates in other models, open the **Master Drawing Catalog** in the model, click the button on the toolbar, and add the model where the templates are saved.

For more information about the **Master Drawing Catalog** and cloning templates, see Create drawings in Master Drawing Catalog.

### 3.2 Distribute customized ribbons by using a firm or environment folder

Administrators can distribute the customized ribbon files to other users in the company by placing the ribbon files in a firm or environment folder.

For example, you can create company ribbons and save them in the firm folder. These ribbons are shown in the Tekla Structures user interface for all users who use the same firm folder.

#### Add ribbons to a firm or environment folder

1. In the Ribbon editor, create the modeling and drawing ribbons that you want to share.
   
   The ribbons are saved in the ..\Users\<user>\AppData\Local \Trimble\Tekla Structures\<version>\UI\Ribbons folder.
   
   If you cannot find the folder, ensure that you are able to view the hidden files and folders on your computer.
2. Copy the entire \Ribbons folder either to your company's firm folder or to the system folder.
3. If the ribbon contains user-defined commands, create a sub-folder named \Commands on the same level as the \Ribbons folder, and copy the UserDefined.xml file from the ..\Users\<user>\AppData\Local \Trimble\Tekla Structures\<version>\UI\Commands folder to the \Commands folder you just created.
4. Restart Tekla Structures.
Loading order of custom ribbons

Tekla Structures loads the ribbons in the following order:
1. Tekla Structures default ribbon
2. Company ribbons in the environment folders
3. Company ribbons in the firm folder
4. User-defined ribbons under %localappdata%

Ribbons that are loaded later override previously loaded ribbons that have the same combination of configuration and editing mode. For example, a ribbon defined in the firm folder overrides ribbons in the environment folders.

If you have a customized ribbon in the ..\Users\<user>\AppData\Local\Trimble\Tekla Structures<version>\UI\Ribbons folder, it overrides company ribbons. To use the ribbon in the environment or firm folder, open the Ribbon editor and click Restore. Alternatively, you can remove or rename your own customized ribbons.

Naming convention for ribbon files

The customization tool saves the custom ribbons as .xml files. The naming convention for these files is:

<Tekla-Structures-configuration_identifier>--<Tekla-Structures-editing-mode>.xml

The name consists of an internal configuration name, a separator of two dash characters (--), an internal editing mode name, and the file name extension .xml. For example, the Full license modeling ribbon is called albl_up_Full--main_menu.xml.

<table>
<thead>
<tr>
<th>Configuration identifier</th>
<th>Configuration name</th>
</tr>
</thead>
<tbody>
<tr>
<td>albl_up_Diamond</td>
<td>Tekla Structures Diamond</td>
</tr>
<tr>
<td>albl_up_Graphite</td>
<td>Tekla Structures Graphite</td>
</tr>
<tr>
<td>albl_up_Carbon</td>
<td>Tekla Structures Carbon</td>
</tr>
<tr>
<td>albl_up_Construction_Modeling</td>
<td>Construction Modeling</td>
</tr>
<tr>
<td>albl_up_Developer</td>
<td>Developer</td>
</tr>
<tr>
<td>albl_up_Drafter</td>
<td>Drafter</td>
</tr>
<tr>
<td>albl_up_Educational</td>
<td>Educational</td>
</tr>
<tr>
<td>albl_up_Engineering</td>
<td>Engineering</td>
</tr>
<tr>
<td>albl_up_Full</td>
<td>Full</td>
</tr>
<tr>
<td>albl_up_PC_Detailing</td>
<td>Precast Concrete Detailing</td>
</tr>
<tr>
<td>albl_up_Rebar_Detailing</td>
<td>Rebar Detailing</td>
</tr>
<tr>
<td>albl_up_Steel_Detailing</td>
<td>Steel Detailing</td>
</tr>
</tbody>
</table>

Distribute customized ribbons by using a firm or environment folder.
<table>
<thead>
<tr>
<th>Configuration identifier</th>
<th>Configuration name</th>
</tr>
</thead>
<tbody>
<tr>
<td>albl_up_Tekla_Structures_Prim ary</td>
<td>Primary</td>
</tr>
<tr>
<td>albl_up_Viewer</td>
<td>Project Viewer</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Editing mode</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>main_menu</td>
<td>Modeling ribbon</td>
</tr>
<tr>
<td>edit_draw_menu</td>
<td>Drawing ribbon</td>
</tr>
<tr>
<td>plan_main_menu</td>
<td>Importing ribbon</td>
</tr>
</tbody>
</table>

3.3 **Distribute customized tabs by using a firm or environment folder**

As an alternative to customized ribbon files, which override the existing ribbon, you can distribute customized tabs to other users in the company by placing the tab files in a firm or an environment folder.

The customized tabs are automatically appended to the end of the ribbon for all users who use the same firm or environment folder. An administrator can distribute customizations to all users in the company while still allowing individual users to customize their ribbons.

These customized tabs do not appear in the Ribbon editor, so the users are not able to edit them. When an administrator updates the contents of a customized tab, the users receive the update when they restart Tekla Structures. Tabs are not configuration-specific. They are imported regardless of the user's Tekla Structures subscription configuration. If the tab contains commands that are not available in the user's configuration, the commands appear dimmed on the ribbon.

**NOTE** If you use a firm folder to distribute the custom tabs, set the firm folder path in an .ini file, such as user.ini, teklastructures.ini, project.ini, or company.ini. If you set the firm folder path in the advanced option XS_FIRM, the tab file does not work correctly because the XS_FIRM definition in the advanced options is made on the model level and the custom tab is not initialized.

1. Create the following folder structure in your company's firm folder or in the system folder.
2. In the Ribbon editor, create a customized tab and add commands to it.
3. Save the ribbon.
4. Go to the `..\Users<user>\AppData\Local\Trimble\Tekla Structures<version>\UI\Ribbons` folder.
5. In a text editor, open the ribbon *.xml file that contains the tab that you want to share with other users.
6. Remove all the other content from the ribbon file except the first row and the description of the tab that you want to share.
   Alternatively, you can copy the content to a new text file.
   For example:
   ```xml
   <?xml version="1.0" encoding="utf-8" standalone="yes"?>
   <Tab Header="My Tab" IsCollapsed="false" IsUserDefined="true">
     <SimpleButton X="0" Y="0" Width="3" Height="4" Command="Common.Interrupt" Text="command:ShortText" Icon="myicon.png" ShowText="true" ShowIcon="true" />
     <SimpleButton X="3" Y="0" Width="3" Height="4" Command="RibbonEditor.Open" Text="command:ShortText" Icon="somefolder\myicon2.png" ShowText="true" ShowIcon="true" />
   </Tab>
   ``
   The button icons use relative paths. The icon path is relative to the *.xml file where tab is read from. For example Icon="myicon.png" refers to an icon in the same folder as the *.xml file, and the Icon="somefolder\myicon2.png" refers to an icon in a sub-folder.
   Alternatively, you can also create paths to folders at levels above the current folder: Icon="..\myicon.png".
7. Save the *.xml file with a new name in the `..\CustomTabs\Modeling` or `..\CustomTabs\Drawing` folder.
   Tab files have the file name extension *.xml. We recommend that you use the same name as for the tab. For example, MyTab.xml. The file name is not case sensitive.
   The tab is added to either the modeling or drawing mode ribbons, depending on the folder that it is located in. There can be several custom tab files in the same folder. They are added to the ribbon one after the other. If the same tab file exists in both the environment and firm folders, the firm version overrides the environment version.
NOTE To avoid file name conflicts, we recommend that administrators prefix all custom tab files with the company name, and that extension developers prefix all custom tab files with the name of the extension (for example, MyExtension_TabName.xml).

8. If the tab contains user-defined commands, copy the UserDefined.xml file from the ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Commands folder to the \Commands folder that you created in the firm folder or the system folder.

   The customized tab now appears at the end of the ribbon.

3.4 Distribute customized property pane layouts by using a project, firm, or environment folder

Administrators can distribute the customized property pane layouts to other users in the company by placing the PropertyTemplates.xml property pane layout file in the PropertyRepository\Templates folder in a project, firm, or environment folder.

For example, you can create company property pane layouts and save them in the firm folder. These property panes are available in the Tekla Structures user interface for all users who use the same firm folder.

Add a property pane layout file in a project, firm, or environment folder

1. In the Property pane editor, create the property pane layouts that you want to share.
   The property pane layouts are saved in the PropertyTemplates.xml file, in the ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\PropertyTemplates folder.
   If you cannot find the folder, ensure that you are able to view the hidden files and folders on your computer.

2. In your company’s project folder or firm folder, or in the system folder, create a folder named PropertyRepository\Templates.

3. Copy the PropertyTemplates.xml file to the PropertyRepository\Templates folder.

4. Restart Tekla Structures.
Search order of customized property pane layout files

The PropertyTemplates.xml file contains all the property pane layouts for different object types. The property pane layouts for different object types are treated separately. For example, Tekla Structures can read the property pane layout for steel beam from a different location than the property pane layout for steel column.

If different object types are defined in different folder locations, the definitions are combined. If the same object type is defined differently in different folder locations, the definition that is higher in the search order is used.

The property pane layout in the ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\PropertyTemplates\ folder has the highest priority, and after that Tekla Structures uses the default search order.

3.5 Distribute customized property pane settings by using a project, firm, or environment folder

Administrators can distribute customized property pane settings to other users in the company.

Place the PropertyPaneSettings.xml file in a folder called \PropertyPane in a project, firm, or environment folder.

1. Customize the property pane settings that you want to share.
   
   The property pane settings are saved in the PropertyPaneSettings.xml file, in the ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\PropertyPane folder.

   If you cannot find the folder, ensure that you are able to view the hidden files and folders on your computer.

2. Create a folder called \PropertyPane either in your company’s project folder, firm folder, or in the system folder.

3. Copy the PropertyPaneSettings.xml file to the \PropertyPane folder.

4. Restart Tekla Structures.

   The file in ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\PropertyPane has the highest priority in
the search order, and after that Tekla Structures uses the default search order.

If the PropertyPaneSettings.xml file is placed in several different folder locations, Tekla Structures reads the settings from different folders and merges them.

3.6 Distribute customized toolbars by using a project, firm, or environment folder

Company administrators can distribute customized Selecting, Snapping, and Snap override toolbars to other users in the company.

Place the toolbar .json files in a folder called \Toolbars in a project, firm, or environment folder. For example, you can create company toolbars and save them in the firm folder. These toolbars are available in the Tekla Structures user interface for all users who use the same firm folder.

1. Customize the toolbars that you want to share.
   The toolbars are saved in corresponding .json files, in the ..\Users <user>\AppData\Local\Trimble\Tekla Structures<version> \Toolbars folder.
   If you cannot find the folder, ensure that you are able to view the hidden files and folders on your computer.

2. In your company's project folder or firm folder, or in the system folder, create a folder called \Toolbars.

3. Copy the toolbar .json files to the \Toolbars folder.

4. Restart Tekla Structures.
   Files in ..\Users<user>\AppData\Local\Trimble\Tekla Structures<version>\Toolbars have the highest priority in the search order. After that, Tekla Structures uses the default search order.

3.7 Files for configuring Tekla Structures

Tekla Structures contains a large number of files that affect the way that the app works. It is important to know where Tekla Structures stores information, the types of files that Tekla Structures contains, where the files are located, and how to use the files.
See also
Folder search order (page 48)
Check and change Tekla Structures file and folder locations in Directory browser (page 51)
Initialization files for start-up parameters and default settings (page 51)
Input files (.inp files) for configuring Tekla Structures (page 61)
Data files (.dat files) for configuring Tekla Structures (page 66)
Customize user interface text in message files (page 68)
Customize object properties and settings in property files (page 69)
Standard files (page 70)
Files related to catalogs (page 73)
Font files for customizing Tekla Structures (page 75)
Symbol files for drawings (page 76)
Files related to templates, reports and drawings (page 76)
Supported image file formats in Tekla Structures (page 79)
Log files about the operation of Tekla Structures (page 80)
Files and file name extensions in the Tekla Structures model folder (page 87)
Files related to options and advanced options (page 110)

Folder search order
When you open a model, Tekla Structures searches for the associated files in specific folders in a specific order.

When Tekla Structures finds the first associated file, it stops searching. Any files with the same file name that are located later in the search order are ignored. The error log lists the names of the ignored files.

**WARNING** Do not store your customized files in the system folder. Tekla Structures replaces files in the system folder when you install a new version.

Many settings files and attribute files must be located either at the root level of the folder or in specific subfolders inside the main folder. For example:

- .tpl and .rpt files must be located at the root level of the model folder.
- .OrgObjGrp files must be located at the root level of the firm folder.
- Other attribute files can be located in the attributes subfolder inside the main folder.

The folder search order is:
<table>
<thead>
<tr>
<th>Order</th>
<th>Folder</th>
<th>Defined by</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Current model</td>
<td>The open model</td>
</tr>
<tr>
<td>2</td>
<td>Project</td>
<td>Advanced option. If property files are stored in user-defined subfolders under the project folder, Tekla Structures searches the subfolders for files in alphabetical order.</td>
</tr>
<tr>
<td>3</td>
<td>Firm</td>
<td>Advanced option. If property files are stored in user-defined subfolders under the firm folder, Tekla Structures searches the subfolders in alphabetical order.</td>
</tr>
<tr>
<td>4</td>
<td>Environment</td>
<td>Tekla Structures searches in the \Environments\common subfolder first, then in the subfolders for the environment and role that the user selects when they start Tekla Structures.</td>
</tr>
<tr>
<td>5</td>
<td>Role</td>
<td>The role that the user selects when they start Tekla Structures.</td>
</tr>
<tr>
<td>6</td>
<td>System</td>
<td>Advanced option. You can specify more than one system folder to define specific settings for each role. Use the role options defined in the env_&lt;environment&gt;.ini file to point to the roles when specifying the system folders in the advanced option. Separate the options pointing to the roles with semicolons. For example: set XS_SYSTEM=%XS_STEEL;%XS_ENGINEERING;%XS_CONTRACTOR;%XS_GENERAL;%XSDATADIR\environments\common\system\</td>
</tr>
</tbody>
</table>

For some specific files and file types, Tekla Structures searches in a different order. The exceptions are:
<table>
<thead>
<tr>
<th>File or file type</th>
<th>Search order</th>
</tr>
</thead>
<tbody>
<tr>
<td>.dat files (page 66)</td>
<td>System folder (XS_SYSTEM)</td>
</tr>
<tr>
<td>Reports (.rpt files)</td>
<td>1. Model folder 2. System folder (XS_SYSTEM)</td>
</tr>
<tr>
<td>Templates (page 151) (.tpl files)</td>
<td>1. Folder that contains your templates defined by the advanced option 2. Model folder</td>
</tr>
</tbody>
</table>

Customize Tekla Structures for users 50 Files for configuring Tekla Structures
<table>
<thead>
<tr>
<th>File or file type</th>
<th>Search order</th>
</tr>
</thead>
<tbody>
<tr>
<td>3. Project folder (XS_PROJECT)</td>
<td></td>
</tr>
<tr>
<td>4. Firm folder (XS_FIRM)</td>
<td></td>
</tr>
<tr>
<td>5. Environment-specific system templates defined by the advanced option</td>
<td></td>
</tr>
<tr>
<td>6. System folder (XS_SYSTEM)</td>
<td></td>
</tr>
</tbody>
</table>

**Check and change Tekla Structures file and folder locations in Directory browser**

Directory browser is a tool that helps you to find and modify the location of the various Tekla Structures files and folders, and customize user settings.

**NOTE** Generally, only administrators should change these settings. If you change them yourself, and you are sharing the same model with other users, and your settings differ from those of the project, you will have problems. Also, adding or modifying files in some of these folders may require administrator rights.

To locate files and folders, and customize your Tekla Structures settings:

1. Click the Applications & components button in the side pane to open the Applications & components catalog.
2. Click the arrow next to Applications to open the applications list.
   The Directory browser dialog box opens. You can check the most common folder paths, and customize the settings in your user.ini file, or in the user-specific or model-specific options.ini file.
4. Check the folder paths and change them if necessary by clicking the buttons on the left of the Basic tab.
   If you click the Project or Firm button and you have not set your firm and project folder, Tekla Structures will prompt you to do so and add the folder path definition to your user.ini file.
5. Check the settings in the user.ini and options.ini files and change them if necessary by clicking the buttons on the right of the Basic tab.
6. Go to the Advanced tab and define the folder paths for additional folders that you may need to access, such as custom components and macros.
Initialization files for start-up parameters and default settings

Initialization files (.ini files) define Tekla Structures start-up parameters and default settings.

Initialization files contain advanced options that are used for configuring Tekla Structures for different standards, and for your or your company’s style of working. Advanced options determine the appearance and the behavior of Tekla Structures, such as the language used, the behavior of part marks on drawings, and the location of your model folder.

Tekla Structures automatically creates the necessary initialization files during installation. The number of initialization files that it creates depends on how many Tekla Structures environments you have installed.

See also

Create customized desktop shortcuts for Tekla Structures (page 367)

Typical initialization files (.ini files) and their reading order

Initialization files are read in a default order when Tekla Structures starts up. If different files contain the same settings, settings in files that are read later override settings in files that were read earlier.

To check which files were read when you started Tekla Structures and the order in which they were read, select File menu --> Logs --> Session history log.

This image shows the default reading order of the .ini files, excluding language-specific files and optional files:
This table lists the typical initialization files that are read when Tekla Structures starts up. The table lists the default location of each file. The exact location of the files might vary depending on the folder in which you install Tekla Structures.

<table>
<thead>
<tr>
<th>Order</th>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>fonts_&lt;lang&gt;.ini</td>
<td>Do not change these settings.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>These optional files contain fonts for languages that use special characters.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>These files are only needed if you use Tekla Structures in languages that use special characters. For example, the fonts_jpn.ini file is the fonts file for the Japanese language.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>These files are automatically installed in the \bin folder when Tekla Structures is installed. The default location is .. \Program Files\Tekla Structures&lt;version&gt;\bin.</td>
</tr>
<tr>
<td>2</td>
<td>teklastructures.ini</td>
<td>Do not change these settings.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This file contains basic system settings, such as the location of software and environment files, that are needed for Tekla Structures to run.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This file is read when Tekla Structures starts up.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This file is automatically installed in the \bin folder when Tekla Structures is installed. The default location is .. \Program Files\Tekla Structures&lt;version&gt;\bin.</td>
</tr>
<tr>
<td>3</td>
<td>lang_&lt;lang&gt;.ini</td>
<td>Do not change these settings.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This file contains the language settings for the Tekla Structures user interface.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The language file that is read when Tekla Structures starts up depends on the language that you have selected in <strong>File menu --&gt; Settings --&gt; Change language</strong> in the previous Tekla Structures session. The languages that you have selected to install during the software installation determine</td>
</tr>
<tr>
<td>Order</td>
<td>File</td>
<td>Description</td>
</tr>
<tr>
<td>-------</td>
<td>------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
|       |      | **which `lang_<lang>.ini` files are available.**  
This file is automatically installed in the `\bin` folder when Tekla Structures is installed. The default location is `..\Program Files\Tekla Structures\<version>\bin\`. |
| 4     | `env_global_default.ini` | **Do not change these settings.**  
This file contains the global default settings for all environments. You can use environment-specific `env_<environment>.ini` files to override the settings in this file.  
This file is automatically installed in the `\Environments\common` folder when you install the common environment installation package. The default location is `..\ProgramData\Trimble\Tekla Structures\<version>\Environments\common\`. |
| 5     | Any `.ini` files defined in the start-up shortcut or on the command line with `-I <name>.ini` | Usually none. |
| 6     | `env_<environment>.ini` | These files contain advanced options that have environment-specific settings.  
The settings in these files can override the settings in the `env_global_default.ini` file. The content of the `env_<environment>.ini` files is typically defined by your area office or reseller.  
The `env_<environment>.ini` file that is read depends on the environment that you select when Tekla Structures starts up.  
Each `env_<environment>.ini` file is installed in the `\Environments <environment>` folder when you install an environment. The default location is `..\ProgramData\Trimble\Tekla Structures\<version>\Environments <environment>`. |
<table>
<thead>
<tr>
<th>Order</th>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>File</td>
<td>Which env_&lt;environment&gt;.ini files are installed on your computer depends on which environment packages you have installed.</td>
</tr>
<tr>
<td></td>
<td>Description</td>
<td>You can optionally define specific settings for roles in your environment and store these settings in role-specific folders under the ..\ProgramData\Trimble\Tekla Structures&lt;version&gt;\Environments &lt;environment&gt; folder.</td>
</tr>
<tr>
<td></td>
<td>In the env_&lt;environment&gt;.ini file, each role has an option where you can add the paths that point to the folders in which you have stored the role settings. Do not change any other settings in the env_&lt;environment&gt;.ini file.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>For example, XS_STEEL(\Steel), XS_CONCRETE(\Concrete), XS_ENGINEERING(\Engineering) and XS_PRECAST(\Precast) each point to the folders that contain settings specific to that role.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Example for the steel role: set XS_STEEL=%XSDATADIR% \environments\Steel \master_drawings;%XSDATADIR% \environments\Steel\model_filters ;%XSDATADIR%\environments\Steel \model_settings\ For example, XS_GENERAL points to the \General folder that has content common for all roles and settings.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>When defining role settings in XS_SYSTEM, you use the role options defined in the env_&lt;environment&gt;.ini to point to the role-specific settings. You do not need to add the folder paths in XS_SYSTEM. They are defined in the env_&lt;environment&gt;.ini file.</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>role_&lt;role&gt;.ini</td>
<td>Do not change these settings. These files contain advanced options that have typical role-specific settings.</td>
</tr>
</tbody>
</table>
The role `<role>` ini file that is read depends on the environment that you select when Tekla Structures starts up.

These files are automatically installed when you install an environment. The default location is `..\ProgramData\Trimble\Tekla Structures\<version>\Environments\<environment>`.

Which role `<role>` ini files are installed on your computer depends on which environment packages you have installed. For example, the role_Engineer.ini file in the `\Environments\uk` folder contains all the settings for the Engineering role in the UK environment.

Any .ini files defined in the start-up shortcut or on the command line with `-i <name>.ini` Usually none.

This optional file is useful when you want to unify enterprise-level settings. This file is read only if the advanced option is set, from the folder specified with the advanced option.

To use this file, you must create it. It is not automatically created by the installation.

This file contains each user’s personal settings.

The user.ini file is created when you start Tekla Structures for the first time, and create and save a model using the current version. When you change settings in the Advanced Options dialog box, the settings are saved in the user.ini file.

The default location for this file is `C:\Users\<user_name>\AppData\Local\Trimble\Tekla Structures <version>\UserSettings`.

Advanced options that are set in the user.ini file override advanced options that are set in other .ini files. For
<table>
<thead>
<tr>
<th>Order</th>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>example, if the same advanced option is set in another .ini file, in a file in the environments sub-folder, and in the user.ini file, Tekla Structures uses the value in the user.ini file.</td>
</tr>
<tr>
<td>11</td>
<td>options.ini in the system folder</td>
<td>This file contains the system settings. The options.ini in the system folder is always read when Tekla Structures starts up. The folder for this file is specified with the advanced option.</td>
</tr>
<tr>
<td>12</td>
<td>options.ini in the firm folder</td>
<td>The options.ini files that contains firm-specific or project-specific model settings are saved in and read from user-defined locations specified with the advanced options and. To use these files, you must copy or move an options.ini file to these locations. You can only update model-specific and user-specific advanced options from the Advanced Options dialog box or the options.ini file located in model folder, not from the firm-specific or project-specific options.ini files. The options.ini in the firm or project folder is read when you start Tekla Structures or open the model.</td>
</tr>
<tr>
<td>13</td>
<td>options.ini in the project folder</td>
<td>This file contains the model-specific settings. The options.ini file in the model folder is read when you open the model. <strong>Note:</strong> Changing a model-specific advanced option value in an .ini file located outside the model folder does not affect existing models.</td>
</tr>
<tr>
<td>14</td>
<td>options.ini in the model folder</td>
<td>This file contains the model-specific settings. The options.ini file in the model folder is read when you open the model. <strong>Note:</strong> Changing a model-specific advanced option value in an .ini file located outside the model folder does not affect existing models.</td>
</tr>
</tbody>
</table>

**See also**

*Settings defined by advanced options (page 132)*
Global default environment settings - env_global_default.ini
The env_global_default.ini file defines the global defaults for advanced options.

The file is read from ..\ProgramData\Trimble\Tekla Structures <version>\environments\common\.

WARNING Do not modify the env_global_default.ini file. If you need to modify some environment settings, copy the needed advanced options from this file to your user.ini (page 60) file and modify the settings there, or modify the settings in the Advanced Options dialog box.

For advanced options that are set according to your local standards, see the environment settings file env_<environment name>.ini (page 58) and the role settings file role_<role name>.ini (page 58). The local files override the advanced options set in env_global_default.ini.

If the advanced option in the env_global_default.ini file is preceded by rem, the software defaults are used and shown as the value. The outdated advanced options are listed at the end of the file.

Local environment settings - env_<environment>.ini
The env_<environment>.ini file contains advanced options that are set according to local standards and that are different from the global defaults.

WARNING Do not edit the env_<environment>.ini file. If you need to change some settings, copy the advanced options from the env_<environment>.ini file to your user.ini (page 60) file and change the settings there. You can also change the settings in the Advanced Options dialog box.

The file is read from the <installation folder>\Environments\ folder.

The file location can vary depending on the folder structure of your environment files. For example, if you install Tekla Structures in the \\Program Files\Tekla Structures\<version> folder, the file is located in the ..\ProgramData\Trimble\Tekla Structures\<version>\Environments\ folder.

The global default environment settings file env_global_default.ini (page 57) contains a complete listing of advanced options. The local files override the advanced options set in env_global_default.ini.

Role settings - role_<role>.ini
The role_<role>.ini files contain all the advanced options that have typical role-specific settings.
The file is read from the environment folder `.\.ProgramData\Trimble\Tekla Structures\<version>\environments\`. The exact location might vary depending on the environment.

**WARNING** Do not modify the `role_<role>.ini` file. If you need to modify some settings, copy the needed advanced options from this file to your `user.ini` (page 60) file and modify the settings there, or modify the settings in the Advanced Options dialog box.

The `role_<role>.ini` file contains advanced options that are set according to typical role requirements in your local area. These settings are different from your environment settings in `env_<environment name>.ini` (page 58). The global default environment settings file `env_global_default.ini` (page 57) contains a complete listing of advanced options. The advanced option settings in `role_<role>.ini` override the ones in `env_<environment>.ini`.

### Using roles for ribbon selection with subscription configurations

**NOTE** Ribbon selection with subscription configurations is primarily meant to be configured by Trimble and reseller localization personnel.

With subscriptions, roles can be used for controlling which ribbon is shown for a certain role. The `role-specific .ini` files in the environments (page 58), such as `role_Steel_Detaller.ini` or `role_Rebar_Detaller.ini`, contain the advanced options `XS_RIBBON_CONFIGURATION_DIAMOND`, `XS_RIBBON_CONFIGURATION_GRAPHITE`, and `XS_RIBBON_CONFIGURATION_CARBON`. These advanced options define the ribbons for the specific role.

The advanced options must point to the configuration identifiers (page 42) of the ribbon files, or to the configuration identifiers of the subscription configurations. It is not possible to make up new configuration identifiers.

If the advanced options are not set, Tekla Structures uses the default ribbons for each subscription configuration.

**Example:**

For the users who select the **Precast Concrete Detailing** role, you could have the following settings in the `role_Precast_Detaller.ini` file:

```
set XS_RIBBON_CONFIGURATION_CARBON=albl_up_Carbon
set XS_RIBBON_CONFIGURATION_GRAPHITE=albl_up_PC_Detailing
set XS_RIBBON_CONFIGURATION_DIAMOND=albl_up_PC_Detailing
```

For more examples, see your `role_<role>.ini` files used in your environment.

**TIP** Administrators who have their own environment and roles: for the role, such as timber detailer, you can create a folder for the ribbon files in `.\.<environment>\Timber\Detailing\Ribbons`, for example.
Place the customized ribbon files in the folder, and include the folder in the XS_SYSTEM path definition for that specific role.

**Add an advanced option to the user.ini file**

You can save your personal user settings in the user.ini file.

The user.ini file is located in the same location as the user-specific options.bin file, such as ..\Users\<user>\AppData\Local\Trimble \Tekla Structures\<version>\UserSettings.

**NOTE** We recommend that you add only system-specific (page 132) advanced options to the user.ini file.

You can also add model-specific (page 132) advanced options, but the model-specific advanced options only affect new models that you create. This is because only the new advanced options that do not yet exist in options_model.db or options_drawings.db are taken into account. For more information, see Files storing options and advanced options.

Adding user-specific advanced options in user.ini might not work as desired as options.bin is loaded after user.ini and might override the value.

**TIP** When you are moving to a new version of Tekla Structures, you can use the Migration Wizard to automatically copy your user.ini file to the new version. The Migration Wizard appears once you start Tekla Structures for the first time after installation.

1. In Windows Explorer, right-click the user.ini file, select Open with, then select a text editor from the list of available programs.
2. On a new line, enter set, then a space, then the name of the advanced option followed by an equal sign, and then the value in a single line.

   Tekla Structures only reads lines in the initialization file that start with set.

   Example:

   ```
   set %XS_DIR%=C:\\TeklaStructures\\2022
   ```

<table>
<thead>
<tr>
<th>Possible values</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRUE</td>
<td>set XS_DISABLE_WELD_PREP_SOLID=TRUE</td>
</tr>
<tr>
<td>FALSE</td>
<td>set XS_UNDERLINE_AFTER_POSITION_NUMBER_IN_HARDSTAMP=FALSE</td>
</tr>
<tr>
<td>1</td>
<td>set XS_SINGLE_CLOSE_DIMENSIONS=1</td>
</tr>
<tr>
<td>0</td>
<td>set XS_SINGLE_USE_WORKING_POINTS=0</td>
</tr>
</tbody>
</table>
### Possible values

<table>
<thead>
<tr>
<th>Possible values</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>string value</td>
<td>set XS_USER_DEFINED_BOLT_SYMBOL_TABLE=bolt_symbol_table.txt</td>
</tr>
<tr>
<td>switches</td>
<td>set XS_ASSEMBLY_FAMILY_POSITION_NUMBER_FORMAT_STRING=%%TPL:PROJECTNUMBER%%</td>
</tr>
</tbody>
</table>

Use two switches.

3. Save the changes to the `user.ini` file.
4. Restart Tekla Structures to apply the changes.

**See also**

Typical initialization files (.ini files) and their reading order (page 52)

### Input files (.inp files) for configuring Tekla Structures

Tekla Structures uses input files (.inp files) for various purposes, such as to manage user-defined attributes and component dialog boxes, and to define how components work.

All input files have the extension .inp. You can use these input files for configuring Tekla Structures.

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>analysis_design_config.inp</td>
<td>Contains settings for analysis and design.</td>
</tr>
<tr>
<td>fltprops.inp</td>
<td>Includes materials and dimensions of available flat bars (page 62).</td>
</tr>
<tr>
<td>mesh_database.inp</td>
<td>Contains definitions for reinforcement meshes.</td>
</tr>
<tr>
<td>objects.inp</td>
<td>Used to manage user-defined attributes.</td>
</tr>
<tr>
<td>objects_rebar_set.inp</td>
<td>Used to manage user-defined attributes of rebar sets.</td>
</tr>
<tr>
<td>pop_mark_parts.inp</td>
<td>Contains settings for pop-marking.</td>
</tr>
<tr>
<td>privileges.inp</td>
<td>Used to control access rights.</td>
</tr>
<tr>
<td>profitab.inp</td>
<td>Contains available parametric profiles (page 265).</td>
</tr>
<tr>
<td>rebar_config.inp</td>
<td>Contains settings for reinforcement marks.</td>
</tr>
<tr>
<td>rebar_database.inp</td>
<td>Rebar catalog (page 348). Contains definitions for reinforcing bars and strands.</td>
</tr>
</tbody>
</table>

Customize Tekla Structures for users 61 Files for configuring Tekla Structures
<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>rebar_schedule_config.inp</td>
<td>Contains internal bending types of reinforcing bars and their mapping to area specific bending codes. <strong>Rebar shape manager</strong> is a more versatile way to define reinforcing bar bending shapes.</td>
</tr>
</tbody>
</table>

Tekla Structures also imports and exports rebar catalogs as `.inp` files.

**Show plates as flat bars in drawings and reports**

Tekla Structures can show plates as the equivalent flat bars for manufacturing. Tekla Structures shows the plates as flat bars in reports and drawings.

1. Set the advanced option `XS_USE_FLAT_DESIGNATION` to `TRUE`.
2. Indicate the prefix that you want to use for flat bars using the advanced option. For example, `XS_FLAT_PREFIX=FLAT`.

   **TIP** To prevent Tekla Structures from showing the profile in metric units in the US environment Imperial role, add the flat bar prefix to the `profitab.inp` file as a parametric profile.

3. Set other advanced options related to plate work in the **Advanced options** dialog box as required:
   - `XS_FLAT_TOLERANCE`: Tekla Structures uses this value to check plate width to determine whether to convert it to a flat bar.
   - `XS_FLAT_THICKNESS_TOLERANCE`: Tekla Structures uses this value to check plate thickness to determine whether to convert it to a flat bar.
   - `XS_CHECK_FLAT_LENGTH_ALSO`: Tekla Structures checks plate length and plate width, and then compares those with the possible dimensions for flat bars in `fltprops.inp`.


**Define materials, thickness, and width of flat bars in the Fltprops.inp file**

Use the `Fltprops.inp` file to define the materials, thickness, and width of the flat bars that are shown for plates in drawings and reports.

The `Fltprops.inp` file is located in the `\profil` folder in one of the folders under the environment folder `..\ProgramData\Trimble\Tekla Structures\<version>\Environments`. The exact location might vary.
depending on your environment. In the default environment, Fltprops.inp is located in ..\ProgramData\Trimble\TeklaStructures\<version>\Environments\default\General\Shared.

**NOTE** Copy the Fltprops.inp file to a model, project or firm folder, then modify the file in the new location.

The first row in the file contains flat bar material definitions enclosed in quotes " " and without spaces, followed by plate thicknesses. If you do not define a material, you can use all materials for all flat bars. The rows after that define the widths of available flat bars.

The units are millimeters.

**Example**

Fltprops.inp contains the following data:

```
5,6,"S235",8,10,"S275J0",10,15
40,45
50,55
60,65
70,75
100,110
200,220
```

With this data, Tekla Structures shows the following plates as flat bars in drawings and reports:

<table>
<thead>
<tr>
<th>Plate</th>
<th>Material</th>
</tr>
</thead>
<tbody>
<tr>
<td>5x40, 5x45, 6x50, 6x55</td>
<td>All materials</td>
</tr>
<tr>
<td>8x60, 8x65, 10x70, 10x75</td>
<td>S235</td>
</tr>
<tr>
<td>10x100, 10x110, 15x200, 15x220</td>
<td>S275J0</td>
</tr>
</tbody>
</table>

Set advanced options related to plate work in the **Advanced options** dialog box as required:

- **XS_USE_FLAT_DESIGNATION**: Tekla Structures uses flat bar designation, which means that it shows plates as the equivalent flat bars for manufacturing.
- **XS_FLAT_PREFIX**: The flat bars get the prefix that is set as the value for this advanced option.
- **XS_FLAT_TOLERANCE**: Tekla Structures uses this value to check plate width to determine whether to convert it to a flat bar.
- **XS_FLAT_THICKNESS_TOLERANCE**: Tekla Structures uses this value to check plate thickness to determine whether to convert it to a flat bar.
- **XS_CHECK_FLAT_LENGTH_ALSO**: When this advanced option is set to TRUE, Tekla Structures checks the plate length and plate width, and then compares those with the possible dimensions for flat bars in fltprops.inp.
Define unfolding parameters in the unfold_corner_ratios.inp file

The unfolding parameters define the location of the neutral axis when a profile is unfolded. The neutral axis is a line that runs along the length of a profile where stress and strain are equal to zero. Tekla Structures uses these parameters to create NC files and to show unfolded profiles in single-part drawings.

The settings in the unfold_corner_ratios.inp file have no effect in the following cases:

- If the advanced option XS_USE_OLD_POLYBEAM_LENGTH_CALCULATION is set to TRUE.
- If the advanced option XS_CALCULATE_POLYBEAM_LENGTH_ALONG_REFERENCE_LINE is set to TRUE. This only applies to polybeams with straight sections.

1. Open the unfold_corner_ratios.inp file in a standard text editor.
   - This file is usually located in your environment folder. If this file does not exist in your environment folder, modify the unfold_corner_ratios.inp file located in the ..\ProgramData\Trimble\Tekla Structures\<version>\environments\common\system folder.

2. Modify the unfolding parameters, then save the file.
   - You can copy the unfold_corner_ratios.inp file to a model, project, or firm folder and then modify the file in the new location as required. Tekla Structures searches for this file in the default search order.

3. Restart Tekla Structures for the changes to take effect.

Unfolding parameter properties

This example shows unfolding parameters in the unfold_corner_ratios.inp file and the descriptions of the parameters.

1 HE300A S235JR 0 180 2 0 1000 .7

<table>
<thead>
<tr>
<th>Property</th>
<th>In the example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>1</td>
<td>1 is polybeams</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2 is plates modeled as polybeams (for example, PLT)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3 is for parts which are not unfolded and follow the old polybeam calculation (for example, the line 3 L* * disables unfolding of L profiles)</td>
</tr>
<tr>
<td>Property</td>
<td>In the example</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>----------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Profile</td>
<td>HE300A</td>
<td>You can also use wildcards with profile, for example, HE300*.</td>
</tr>
<tr>
<td>Material</td>
<td>S235JR</td>
<td>You can also use wildcards with material, for example, S235*.</td>
</tr>
</tbody>
</table>
| Rotation / thickness min | 0              | For polybeams: the minimum angle when the profile is rotated around its longitudinal axis  
For plates: the minimum thickness of plate |
| Rotation / thickness max | 180            | For polybeams: the maximum angle when the profile is rotated around its longitudinal axis  
For plates: the maximum thickness of plate |
| Flag                 | 2              | This property defines what kind of parts are affected by the next two properties.  
1 is sharp folds. Only polybeams with straight chamfers are affected.  
2 is curved bends. Only polybeams with curved chamfers are affected. |
| Angle / radius min   | 0              | For sharp folds: the minimum angle  
For curved bends: the minimum radius |
| Angle / radius max   | 1000           | For sharp folds: the maximum angle  
For curved bends: the maximum radius  
Maximum radius is measured to the plane defined by the ratio, so it is not dependent on how |
<table>
<thead>
<tr>
<th>Property</th>
<th>In the example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ratio</td>
<td>.7</td>
<td>Defines how much the profile stretches or shrinks when unfolded. Ratio = (1 - the relative location of the neutral axis). If only the inner surface of the profile shrinks, the ratio is 1. If only the outer surface of the profile stretches, the ratio is 0. By default, the ratio is 0.5 for length calculation and 0.0 for bending radius calculation. Tekla Structures applies the unfolding ratio if the profile properties are within the range indicated by the minimum and maximum values.</td>
</tr>
</tbody>
</table>

**Data files (.dat files) for configuring Tekla Structures**

Data files (.dat files) contain information used by certain components and the **Rebar shape manager**.

Default data files are read from the environment's system folder. User-defined data files are stored in the model's `\attributes` folder.

**WARNING** These files affect the operation of components and the **Rebar shape manager**. Do not modify these files unless you are an administrator.

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>gauge_lines.dat</td>
<td>Contains data for gage lines that define the location of bolts on a brace.</td>
</tr>
<tr>
<td></td>
<td>Use gage lines to:</td>
</tr>
<tr>
<td>File</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>• Specify distances between bolts, horizontally and vertically</td>
</tr>
<tr>
<td></td>
<td>• Specify distances from the center of bolts to the edge of braces</td>
</tr>
<tr>
<td></td>
<td>• Adjust the position of individual bolts</td>
</tr>
<tr>
<td></td>
<td>• Remove bolts</td>
</tr>
<tr>
<td>The following components use the gauge_lines.dat file:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• <strong>Tower 1 diagonal</strong> (87)</td>
</tr>
<tr>
<td></td>
<td>Tower 2 diagonal (89)</td>
</tr>
<tr>
<td></td>
<td>Leg 1 diagonal (178)</td>
</tr>
<tr>
<td></td>
<td>Bolted gusset brace (167)</td>
</tr>
<tr>
<td></td>
<td>Bolted brace (181)</td>
</tr>
<tr>
<td></td>
<td>Bolted plate brace (182)</td>
</tr>
<tr>
<td></td>
<td>Batten plates (585)</td>
</tr>
<tr>
<td></td>
<td>Windbrace connection (110)</td>
</tr>
<tr>
<td></td>
<td>Bent gusset (140)</td>
</tr>
<tr>
<td></td>
<td>L splice (175)</td>
</tr>
<tr>
<td></td>
<td>Parallel L profiles (176)</td>
</tr>
<tr>
<td>joints.dat</td>
<td>Contains data used in <strong>Handrailing</strong> (1024) and <strong>Stanchions</strong> (S76) components. Used in the <strong>Stanchion connection type</strong> option.</td>
</tr>
<tr>
<td>railings.dat</td>
<td>Contains data used in <strong>Handrailing</strong> (1024). Used in the <strong>Stanchion connection type</strong> option.</td>
</tr>
<tr>
<td>steps.dat</td>
<td>Contains the data for <strong>Stairs</strong> (S82) and <strong>Stairs</strong> (S71). Used in the <strong>Step profile</strong> and <strong>Catalogue step</strong> options.</td>
</tr>
</tbody>
</table>
| std_flange_plates.dat      | Contains data for **Tapered column** (S99). Used in the options:  
|                            | • **Outer flange profile**                                                                                                                     |
|                            | • **Inner flange profile**                                                                                                                     |
|                            | • **Top plate profile**                                                                                                                        |
| std_stiffener_plates.dat   | Contains data used in **Tapered column** (S99). Used in the **Horizontal stiffener profile** box.                                             |
| marketsize.dat             | Contains available market sizes for certain material grade. Can be used with fMarketSize() function in the custom component editor. |

Customize Tekla Structures for users 67 Files for configuring Tekla Structures
<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>import_macro_data_types.dat</td>
<td>Contains the user-defined attributes that you can include in an input file in attribute import.</td>
</tr>
<tr>
<td>RebarShapeManager.CustomProperties.dat</td>
<td>Contains the custom properties, template attributes, and user-defined attributes that you can use in bending shape rules in the <strong>Rebar shape manager</strong>.</td>
</tr>
</tbody>
</table>

**Customize user interface text in message files**

Tekla Structures uses the information in the message files to show messages in the user interface.

Message files include texts in languages in which the Tekla Structures user interface is available. You can customize the texts in message files, such as the texts used in dialog boxes.

**Customize message files**

You can customize the messages that Tekla Structures shows in the user interface.

**NOTE** Do not directly edit the default message files.

1. Browse to the message file that contains the text that you want to customize.
   - Message files with the `.ail` extension are located in the folder `..\Tekla Structures\<version>\bin\messages`
   - Message files with the `.xml` extension are located in the folder `..\Tekla Structures\<version>\bin\messages\DotAppsStrings`

2. Make your own copy of the file and save it in a location that does not get overwritten during upgrades, such as in the **firm folder (page 16)**.

3. Update the value of the `XS_MESSAGES_PATH` advanced option to use the location of your customized file.

4. Open the message file using a text editor, such as Microsoft Notepad.

5. Modify the messages as required.
   - If you duplicate the default strings in your custom files, add a custom message group prefix to the default strings to make them unique.

Example: customize a message file

This example shows how to modify a message that Tekla Structures uses for near side plates in drawings to show (NS) instead of (N/S).

1. Go to the ..\Tekla Structures\<version>\bin\messages folder.
2. Make a copy of the by_number.ail file and save it in the firm folder.
   The by_number.ail file contains both prompts and default texts that Tekla Structures uses in drawings.
3. Update the value of the XS_MESSAGES_PATH advanced option to use the location of your customized file.
4. Open your copy of the by_number.ail using a text editor.
5. Browse to the following section:

```
string by_number_msg_no_675 {
...
  entry = ("enu", "(N/S)");
};
```
6. Change (N/S) to (NS) in the entry row.
7. Save and close the file.

Customize object properties and settings in property files

Property files contain the object properties and settings that are shown in the property pane or in the dialog boxes of model objects or drawing objects.

By default, Tekla Structures uses the standard property files when you apply commands. The default standard property files are read from the environment's system folder.

In addition to the default property files, you can define user-defined property files, and load these saved properties later when you create, for example, new model objects or drawing objects. Tekla Structures stores the saved, user-defined property files in the current model's \attributes folder.

Save a user-defined property file in the property pane

1. Enter a name for the property file in the field next to the button.
2. Click to save the property file.

Example

This example shows how to change the standard steel column properties so that you create a new type of column called custom1.

1. Open the steel column properties in the property pane.
2. Enter or modify the properties you want to save.

3. In the field next to the button, enter a name for the new column properties. For example, custom1.

4. Click .
   
   Tekla Structures saves the new custom1.clm property file in the current model's \attributes folder.

**Save a user-defined property file in a dialog box**

1. Enter a name for the property file in the field next to the **Save as** button.
2. Click **Save** or **Save as** to save the property file.

**Standard files**

Standard files are *property files* that Tekla Structures uses by default when you apply commands.

Standard properties are shown in the property pane of different model objects, such as beams, columns or plates, or in the dialog boxes of objects, such as drawing objects.

Standard files are named standard.*, where the symbol * is the file name extension. The file extension indicates the type of object that the properties in the standard file are used for. For example, the standard.clm file is used for the properties of steel columns.

User-defined attributes are saved with the standard files as *.more files. For example, the standard.clm.more file is used for user-defined attributes for steel columns.

**How properties are loaded from standard files**

- In the property pane, the properties are loaded when you select the standard option in the upper part of the property pane. The properties are applied immediately.
  
  If the values that you loaded are different from the previous values, the property pane highlights the modified properties.
• In dialog boxes, the properties are loaded when you select the **standard** option in the list next to the **Load** button, and click the **Load** button.

Tekla Structures reads the default **standard** files from the environment's system folder.

If you want to load the default property settings from the **standard** files that are saved in the **attributes** folder, go to **Quick Launch** and use the **Load defaults** command.

**Save a set of standard files**
You can save a set of **standard** files in the **\attributes** folder for the current model.

After saving the **standard** files, you can copy them to the project folder or the firm folder to set up Tekla Structures to suit the way you work.

1. Go to **Quick Launch** and start typing **save defaults**.
2. Select **Save defaults** from the list.

Tekla Structures saves the following list of **standard** and ***.more** files in the **..\TeklaStructuresModels\<model_name>\attributes** folder:

<table>
<thead>
<tr>
<th>File</th>
<th>Property</th>
</tr>
</thead>
<tbody>
<tr>
<td>standard.bpl</td>
<td>Bent plate properties</td>
</tr>
<tr>
<td>standard.bpl.more</td>
<td></td>
</tr>
<tr>
<td>standard.clm</td>
<td>Steel column properties</td>
</tr>
<tr>
<td>standard.clm.more</td>
<td></td>
</tr>
<tr>
<td>standard.cpl</td>
<td>Contour plate properties</td>
</tr>
<tr>
<td>standard.cpl.more</td>
<td></td>
</tr>
<tr>
<td>standard.crs</td>
<td>Orthogonal beam properties</td>
</tr>
<tr>
<td>standard.crs.more</td>
<td></td>
</tr>
<tr>
<td>standard.dia</td>
<td>Twin profile properties</td>
</tr>
<tr>
<td>standard.dia.more</td>
<td></td>
</tr>
<tr>
<td>standard.fms</td>
<td>Plotting frames</td>
</tr>
<tr>
<td>standard.fms.more</td>
<td></td>
</tr>
<tr>
<td>standard.fpl</td>
<td>Folded plate properties</td>
</tr>
<tr>
<td>standard.fpl.more</td>
<td></td>
</tr>
<tr>
<td>standard.ipc</td>
<td>Concrete item properties</td>
</tr>
<tr>
<td>standard.ipc.more</td>
<td></td>
</tr>
<tr>
<td>File</td>
<td>Property</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------------------</td>
</tr>
<tr>
<td>standard.ips</td>
<td>Item properties</td>
</tr>
<tr>
<td>standard.ips.more</td>
<td></td>
</tr>
<tr>
<td>standard.ler</td>
<td>Layer properties</td>
</tr>
<tr>
<td>standard.ler.more</td>
<td></td>
</tr>
<tr>
<td>standard.mvi</td>
<td>Model view properties</td>
</tr>
<tr>
<td>standard.mvi.more</td>
<td></td>
</tr>
<tr>
<td>standard.num</td>
<td>Numbering setup</td>
</tr>
<tr>
<td>standard.num.more</td>
<td></td>
</tr>
<tr>
<td>standard.prf</td>
<td>Project properties</td>
</tr>
<tr>
<td>standard.prf.more</td>
<td></td>
</tr>
<tr>
<td>standard.prt</td>
<td>Steel beam properties</td>
</tr>
<tr>
<td>standard.prt.more</td>
<td></td>
</tr>
<tr>
<td>standard.scr</td>
<td>Bolt properties</td>
</tr>
<tr>
<td>standard.scr.more</td>
<td></td>
</tr>
<tr>
<td>standard.wld</td>
<td>Weld properties</td>
</tr>
<tr>
<td>standard.wld.more</td>
<td></td>
</tr>
</tbody>
</table>

You can now copy the standard files to the project folder or the firm folder.

**Create user-defined standard files**
You can create your own standard files.

Tekla Structures saves the user-defined standard files in the \attributes folder for the current model.

1. Open the property pane or a dialog box for which you want to save the properties as a standard file.
2. Modify the properties.
3. Save the properties in one of these ways:
   - In the property pane: enter standard as the name
     ![standard](image)
     , then click ![Save](image).
   - In a dialog box: in the box next to the Save as button, enter standard as the name
     ![Save as](image)
     , then click Save as.

Tekla Structures saves the standard file and the related *.more file in the current model's \attributes folder. If a standard file with the same file
name extension exists in the \attributes folder, Tekla Structures overwrites the previous file.

When you want to load the standard file, select it from the list of the property files in the property pane or in a dialog box.

Alternatively, to load the default property settings from the standard files that are saved in the \attributes folder, go to **Quick Launch** and use the **Load defaults** command.

## Files related to catalogs
Tekla Structures uses ASCII and binary files to manage profile, material, reinforcement, bolt, and bolt assembly catalogs.

Each environment has its own folder where the files related to different catalogs are stored. For example, ..\Environments\uk\general\profil\ contains the files for managing catalog files used in the United Kingdom. The exact file location might vary depending on the folder structure of your environment files.

<table>
<thead>
<tr>
<th>File type</th>
<th>File name</th>
<th>Used for</th>
<th>Default location</th>
</tr>
</thead>
<tbody>
<tr>
<td>.inp</td>
<td>profitab.inp</td>
<td>Defines the names that you can use for parametric profiles.</td>
<td>..\ProgramData \Trimble\Tekla Structures &lt;version&gt; \Environments &lt;environment&gt; \profil</td>
</tr>
<tr>
<td></td>
<td>rebar_database.inp</td>
<td>The rebar catalog.</td>
<td>..\ProgramData \Trimble\Tekla Structures &lt;version&gt; \Environments &lt;environment&gt; \profil</td>
</tr>
<tr>
<td></td>
<td>mesh_database.inp</td>
<td>The reinforcement mesh catalog.</td>
<td>..\ProgramData \Trimble\Tekla Structures &lt;version&gt; \Environments &lt;environment&gt; \profil</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can define the file name while exporting.</td>
<td>Created when you export rebar catalogs. You can define the folder while exporting.</td>
</tr>
<tr>
<td>File type</td>
<td>File name</td>
<td>Used for</td>
<td>Default location</td>
</tr>
<tr>
<td>-----------</td>
<td>------------------------</td>
<td>--------------------------------------------------------------------------</td>
<td>-------------------------------------------------------</td>
</tr>
<tr>
<td>.cnv</td>
<td>matexp_&lt;software&gt;.cnv</td>
<td>Converting material names when transferring model information using links. For example, converts S235JR to FE360B for DSTV.</td>
<td>..\ProgramData\Trimble\Tekla Structures&lt;version&gt;\Environments&lt;environment&gt;\profil</td>
</tr>
<tr>
<td>prfexp_&lt;software&gt;.cnv</td>
<td>Converting profile names when transferring model information using links. For example, converts HEA100 to HE100A for DSTV.</td>
<td>..\ProgramData\Trimble\Tekla Structures&lt;version&gt;\Environments&lt;environment&gt;\profil</td>
<td></td>
</tr>
<tr>
<td>.clb</td>
<td>RU_CF.clb</td>
<td>Contains the definitions of parametric profiles used in profitab.inp.</td>
<td>..\ProgramData\Trimble\Tekla Structures&lt;version&gt;\Environments\common\inp</td>
</tr>
<tr>
<td>.lis</td>
<td>Many possible file names. You can define the file name while exporting.</td>
<td>Created when you export bolt, profile, and material catalogs.</td>
<td>Many possible folders. You can define the folder while exporting.</td>
</tr>
<tr>
<td>.db</td>
<td>assdb.db</td>
<td>The bolt assembly catalog.</td>
<td>..\ProgramData\Trimble\Tekla Structures&lt;version&gt;\Environments&lt;environment&gt;\profil</td>
</tr>
<tr>
<td></td>
<td>screwdb.db</td>
<td>The bolt catalog.</td>
<td>..\ProgramData\Trimble\Tekla Structures&lt;version&gt;\Environments&lt;environment&gt;\profil</td>
</tr>
<tr>
<td>.bin</td>
<td>profdb.bin</td>
<td>The profile catalog.</td>
<td>..\ProgramData\Trimble\Tekla Structures&lt;version&gt;\Environments</td>
</tr>
</tbody>
</table>

Customize Tekla Structures for users 74 Files for configuring Tekla Structures
### File type | File name | Used for | Default location
---|---|---|---
| | matdb.bin | The material catalog. | ..\ProgramData\Trimble\Tekla Structures\<version>\Environments\<environment>\profil |
| .xml | Many possible file names | Attributes of shapes in the shape catalog, such as the name and GUID. | <model_folder>\Shapes |
| .tez or .xml | Many possible file names | Geometric properties of shapes in the shape catalog, such as coordinates. | <model_folder>\ShapeGeometries |

**See also**
- Customize the material catalog (page 244)
- Customize the profile catalog (page 252)
- Customize the shape catalog (page 312)
- Customize the bolt catalog (page 333)
- Customize the rebar catalog (page 348)

### Font files for customizing Tekla Structures

You can define the location of font files with the advanced option `DXK_FONTPATH` in the `teklastructures.ini` or your environment initialization file.

For example, you can use fonts available in the `<installation folder>\Environments\common\fonts` folder.

If you install Tekla Structures in the `Program Files\Tekla Structures\<version>` folder, the fonts are located in the `..\ProgramData\Trimble Tekla Structures\<version>\Environments\common\fonts` folder.

This folder includes the following Tekla Structures system fonts:

- `fixfont.fon`
- `romco.fon`
- `romsim.fon`
The Cyrillic fonts GOST 2.304-81 type A.ttf and GOST 2.304-81 type B.ttf are located in the C:\Windows\Fonts folder, not the <installation folder>Environments\common\fonts folder.

Fonts are converted using font conversion files that are available in the same folder:

<table>
<thead>
<tr>
<th>File</th>
<th>Used for</th>
</tr>
</thead>
<tbody>
<tr>
<td>template_fonts.cnv</td>
<td>Converting Tekla Structures system fonts, such as Template Editor fonts, to Windows fonts in DWG/DXF export.</td>
</tr>
<tr>
<td>dxf_fonts.cnv</td>
<td>Converting True Type fonts to the SHX font format that is understood by AutoCAD in the old DWG/DXF export.</td>
</tr>
</tbody>
</table>

See also

Initialization files for start-up parameters and default settings (page 51)

Symbol files for drawings
Symbols are used in various places in drawings, for example, as separate objects, and in marks.

You can create symbols with the Symbol Editor. The file name extension is .sym. You can also use symbols in .dwg format.

By default, Tekla Structures stores symbol files in the folder ..\Environments\common\symbols.

Files related to templates, reports and drawings
Tekla Structures has several files that relate to templates, reports, drawings and printing.

<table>
<thead>
<tr>
<th>File or file type</th>
<th>Description</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>.rpt</td>
<td>Report templates (page 151) created with the Template Editor</td>
<td>System folders defined for the advanced option XS_SYSTEM</td>
</tr>
<tr>
<td>.tpl</td>
<td>Drawing templates (page 151) created with the Template Editor</td>
<td>Template folders defined for the advanced option XS_TEMPLATE_DIRECTORY</td>
</tr>
<tr>
<td><strong>File or file type</strong></td>
<td><strong>Description</strong></td>
<td><strong>Location</strong></td>
</tr>
<tr>
<td>----------------------</td>
<td>----------------</td>
<td>-------------</td>
</tr>
<tr>
<td>.lay</td>
<td>Layout definitions created with the <strong>Drawings &amp; reports</strong> --&gt; <strong>Drawing properties</strong> --&gt; <strong>Drawing layout editor</strong> command.</td>
<td>The \attributes sub-folder in the model folder</td>
</tr>
<tr>
<td>plotdev.bin</td>
<td>Printer device definitions created with the <strong>Printer Catalog</strong> printer instances.</td>
<td>System folders defined with the advanced option XS_SYSTEM</td>
</tr>
<tr>
<td>xdproc</td>
<td><strong>Master Drawing Catalog</strong> rule set</td>
<td>System folders defined with the advanced option XS_SYSTEM</td>
</tr>
<tr>
<td>xdproc.master</td>
<td><strong>Master Drawing Catalog</strong> master drawing file</td>
<td>System folders defined with the advanced option XS_SYSTEM</td>
</tr>
<tr>
<td>xdproc.master.png</td>
<td><strong>Master Drawing Catalog</strong> sample (preview) image files</td>
<td>System folders defined with the advanced option XS_SYSTEM</td>
</tr>
<tr>
<td>xdproc.png</td>
<td><strong>Master Drawing Catalog</strong> thumbnail image files</td>
<td>System folders defined with the advanced option XS_SYSTEM</td>
</tr>
</tbody>
</table>

For more information about the folder search order, see [Folder search order](page 48).

The default drawing, report, and template files are read from the system folders defined with the XS_SYSTEM advanced option or from the XS_TEMPLATE_DIRECTORY folders, but user-defined files are stored in the \attributes sub-folder in the model folder.

**DWG reference model plug-in configuration settings**

The settings in the DWG reference model plug-in configuration file dwgplug.config are described below.

**NOTE** The advanced settings in dwgplug.config do not normally need to be changed, but in some scenarios, things like very large radius arcs can end up with the generated straight line segments not small enough for the user’s needs, and adjusting these settings can help. The dwgplug.config file is located in the ..\bin\plugins\referenceplugins\dwg\ folder, and you might need administrator rights to access the file.

Example of the configuration file:
The settings used in the configuration file are described below:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>acistessellation</td>
<td>This setting may or may not do anything depending on the plug-in version - in earlier versions it configures the tessellation density of the solids.</td>
</tr>
<tr>
<td>largecircledelimiter</td>
<td>Defines the radius of a circle that is then considered to be a large circle w.r.t. the parameters LinesInSmallCircle and LinesInLargeCircle. A circle radius that is equal to or greater than this value will be treated as a large circle. This value is in dwg units.</td>
</tr>
<tr>
<td>LinesInSmallCircle</td>
<td>Sets the number of tessellation lines in the circle (with a 'small' radius) that an arc represents. This is then used when tessellating the arc into straight line segments. Valid range is 3 to 10000.</td>
</tr>
<tr>
<td>LinesInLargeCircle</td>
<td>Sets the number of tessellation lines in the circle (with a 'large' radius) that an arc represents. This is then used when tessellating the arc into straight line segments. Valid range is 3 to 10000.</td>
</tr>
<tr>
<td>externalGUID</td>
<td>Configures the style of the id attached to parts. This parameter should not be changed.</td>
</tr>
</tbody>
</table>
## Setting Description

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>maximumsize</td>
<td>Single shapes larger than the value you specify will be excluded. Units are in model units. Set to 0 to disable.</td>
</tr>
</tbody>
</table>

## Supported image file formats in Tekla Structures

You can use image files in many places in Tekla Structures.

You can use image files in:
- Templates in drawings
- Drawing snapshots
- Component dialog boxes and thumbnails
- Drawing line types
- The surface treatment dialog box
- The **Master Drawing Catalog** for thumbnails and sample images
- Profile properties dialog boxes

These image file formats are supported in Tekla Structures:

<table>
<thead>
<tr>
<th>Used in</th>
<th>Supported image formats</th>
</tr>
</thead>
</table>
| Templates                                                              | • bmp  
|                                                                      | • gif  
|                                                                      | • grd  
|                                                                      | • jpg  
|                                                                      | • ppm  
|                                                                      | • pgm  
|                                                                      | • rle  
|                                                                      | • tiff  
|                                                                      | • xkrl  |
| Drawing snapshots                                                      | png  |
| Thumbnail and sample images for the **Master Drawing Catalog**         | png  |
| Other uses                                                             | bmp  |

**See also**

*Add images in a template (page 189)*
Log files about the operation of Tekla Structures

Tekla Structures writes information about the operation of Tekla Structures to log files when you perform some actions, such as numbering a model or saving a model.

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>analysis.log</td>
<td>Tekla Structures stores information in this file when you run the analysis. The file also contains information about the errors that occurred during load distribution. This log file is saved in the current model folder.</td>
</tr>
<tr>
<td>check_database.log</td>
<td>Tekla Structures stores information in this file when you run the Repair command in File menu -&gt; Diagnose &amp; repair --&gt; Model. This log file is saved in the current model folder.</td>
</tr>
<tr>
<td>ClashCheck.log</td>
<td>Contains clashes found in the most recent clash check. This log file is saved in the current model folder.</td>
</tr>
<tr>
<td>ClientLog_cat.txt</td>
<td>The client log files contain diagnostic information and error messages about the Tekla Model Sharing sharing service, such as connecting to the sharing service or the status of the sharing service. The client log files are saved in the \Users&amp;lt;user&gt; \AppData\Local\Tekla DataSharing folder by default.</td>
</tr>
<tr>
<td>ClientLog_dog.txt</td>
<td>There are two client log files with a maximum size of 1 megabyte each, so that the information does not use too much disk space. When the maximum file size is reached in one file, log writing changes to the other file. Each time that the active client log file changes, any information previously saved in the current log file is cleared before any new log information is written to the log file.</td>
</tr>
<tr>
<td>ComponentCatalog_&lt;user&gt;.log</td>
<td>Contains troubleshooting information related to the Applications &amp; components catalog and any errors that have occurred in the Applications &amp; components catalog. For example, errors in catalog definition files are stored in the ComponentCatalog_&lt;user&gt;.log file. This log file is saved in the \logs folder under the current model folder.</td>
</tr>
</tbody>
</table>

A limited number of older log messages related to the Applications & components catalog are archived and saved in the
<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ComponentCatalog_&lt;user&gt;.bak.log</td>
<td>ComponentCatalog_&lt;user&gt;.bak.log file. This file contains approximately 1024 KB of data.</td>
</tr>
<tr>
<td>conflict.log</td>
<td>Contains conflicts that have occurred when more than a one user has modified an object in multi-user mode. This log file is saved in the current model folder.</td>
</tr>
<tr>
<td>DocumentManager_&lt;user&gt;.log</td>
<td>Contains troubleshooting information related to the Document manager, and any errors that have occurred in the Document manager. This log file is saved in the \logs folder under the current model folder.</td>
</tr>
<tr>
<td></td>
<td>A limited number of older log messages related to the Document manager are archived and saved in the DocumentManager_&lt;user&gt;.bak.log file. This file contains approximately 256 KB of data.</td>
</tr>
<tr>
<td>DPMPrinter_&lt;user&gt;.log</td>
<td>Contains troubleshooting information related to printing, and any errors that have occurred in printing drawings or reports to a printer, a plot file, or a PDF file. This log file is saved in the \logs folder under the current model folder.</td>
</tr>
<tr>
<td></td>
<td>A limited number of older log messages related to printing are archived and saved in the DPMPrinter2_&lt;user&gt;.log file. This file contains approximately 1024 KB of data.</td>
</tr>
<tr>
<td>drawing_cloning.log</td>
<td>Contains information about cloned drawings. This log file is saved in the current model folder.</td>
</tr>
<tr>
<td>drawing_history.log</td>
<td>Contains information about drawing history. Use the advanced option XS_DRAWING_HISTORY_LOG_TYPE to define the contents of the file. This log file is saved in the current model folder.</td>
</tr>
<tr>
<td>dstv_nc.log</td>
<td>Each time you create NC files, Tekla Structures stores information in this file about the processed assemblies. This log file is saved in the current model folder.</td>
</tr>
<tr>
<td>error_&lt;user&gt;<em>YYYYYMDD</em>&lt;HHMMSS&gt;.log</td>
<td>Each time an error occurs in Tekla Structures, the error is saved in an error log file. Error log files contain the description of errors that have occurred at a particular time. For example, if an error has occurred on April 1, 2019 at 9:15:30 AM, the name of the related error log file is error_&lt;user&gt;_20190401_091530.log. This log file is saved in the \logs folder under the current model folder.</td>
</tr>
<tr>
<td>File</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>filetranerror.log</td>
<td>Used only for cold rolled components, such as Albion, Ayrshire, and Hispan. If the <strong>File Transfer</strong> components do not work as expected, Tekla Structures stores error messages in this file. This log file is saved in the current model folder.</td>
</tr>
<tr>
<td>modelsharing.log</td>
<td>Contains the sharing operations that have been performed in Tekla Model Sharing. For example, opening a shared model and reading in the changes made by other users are stored in the <code>modelsharing.log</code> file. This log file is saved in the <code>\logs</code> folder under the current model folder.</td>
</tr>
<tr>
<td>numberinghistory.txt</td>
<td>Contains full details of each numbering session carried out on the model. Each session is in a different block of the file. This log file is saved in the current model folder.</td>
</tr>
<tr>
<td>PublishToTrimbleConnect.log</td>
<td>Contains upload information and the errors that have occurred when uploading the Tekla Structures model to a linked Trimble Connect project as a <code>.tekla</code> file. This log file is saved in the <code>\logs</code> folder under the current model folder.</td>
</tr>
<tr>
<td>save_history.log</td>
<td>Tekla Structures stores information in this file each time you save a model. This log file is saved in the current model folder.</td>
</tr>
<tr>
<td>sharingfacade.log</td>
<td>Contains the essential information from the client log files when an error has occurred in the Tekla Model Sharing sharing service. This log file is saved in the <code>\logs</code> folder under the current model folder.</td>
</tr>
<tr>
<td>TeklaStructures_&lt;user&gt;.log</td>
<td>Contains information about the entire Tekla Structures session from opening the model to closing it. The file contains, for example, errors and information about which catalogs were used. This temporary log file is saved in the <code>\TeklaStructuresModels</code> folder, and is removed when you close Tekla Structures.</td>
</tr>
<tr>
<td>wizard.log</td>
<td>Tekla Structures stores information in this file when you run a drawing rule set (wizard) file. The file contains, for example, errors and the number of drawings created. This log file is saved in the current model folder.</td>
</tr>
</tbody>
</table>
**View a log file**

You can view most log files in the Tekla Structures log viewer, or in the application that has been associated with the file type, such as Microsoft Notepad.

If the log file contains information about parts or assemblies, you can check the parts or assemblies in the model. In the log file, select a row that contains a part or an assembly.

Parts and assemblies have the prefix `guid`.

Tekla Structures highlights the part in the model. If there are several parts or assemblies on a row and you select that row, Tekla Structures highlights all the parts in the model. You can also select parts on different rows.

**TIP** You can open the right-click menu for a part or an assembly from the log file by right-clicking a row that contains a part or an assembly. Tekla Structures shows the same menu as when you right-click a part or an assembly in the model.

1. Open the model for which you want to view the log history.
2. On the **File** menu, click **Logs**, then select a log file.
   - **Clash Check history log** (`ClashCheck.log`)
   - **Session history log** (`TeklaStructures_<user>.log`)
   - **Numbering history log** (`numberinghistory.txt`)
   - **Saving history log** (`save_history.log`)
   - **Drawing history log** (`drawing_history.log`)
   - **Analysis history log** (`analysis.log`)
3. View the log file in one of the following ways:
   - To view the log file in the log viewer, in **File --> Logs** select **View with Tekla Structures log viewer**.
   - To view the log file in the application associated with the file type, **File --> Logs** select **View with default application**.

**Change the name and location of session history log file**

You can change the name and location of the session history log file (`TeklaStructures_<user>.log`).

If someone else manages your installation of Tekla Structures, do not change these settings unless you are instructed to do so.

Windows username and the `.log` file extension are always added after the customizable part of the name.

1. Open a suitable **initialization file (page 52)** for editing.
   - For example, `user.ini` or `company.ini`.
2. To change the **name** of the session history log file, add the following line to the initialization file:

```bash
set XS_LOG_FILE_NAME=<name of the file>
```

For example:

```bash
set XS_LOG_FILE_NAME=sessionhistory
```

If the Windows user name is "achilles", this example would result in a log file named `sessionhistory_achilles.log`.

The default name is `TeklaStructures_<user>.log`.

3. To change the **location** of the session history log file, add the following line to the initialization file:

```bash
set XS_LOGPATH=<location of the file>
```

If there is no other location set, the file is stored in the parent folder for model folders (by default `c:\TeklaStructuresModels`).

4. Save the initialization file.

5. Restart Tekla Structures for the changes to take effect.

---

**Numbering history log file**

The `numberinghistory.txt` log file contains full details of each numbering session carried out on the model. Each numbering session is in a different block of the file.

If one numbering series overlaps another, the errors are written to the log file.

**NOTE** If you remove or delete the `numberinghistory.txt` log file, Tekla Structures generates a new file with the same name the next time you run numbering. The new file does not contain a history of previous numbering sessions.

---

**Example**

This example shows the contents of a `numberinghistory.txt` log file.

```
1  *** Numbering (Jaka): Thu Jun 14 13:08:05 2012
2  Modified numbering
3  Compare modified to old parts
4  Compare new to old parts
5  Check for standard parts
6  Use old numbers
7  Tolerance: 1.000000
8  SteelTolerance: 0.000000
9  ConcreteTolerance: 2.000000
10  RebarTolerance: 2.000000
11  Part guid: E011079940-0000-0017-3133-3556933853237  series:Concrete_C-1/1  Concrete_C-1/0 -> Concrete_C-1/1
12  Assembly guid: E011079940-0000-0016-3133-3556933853237  series:C/1  C/6 -> C/1
13  *** Operation finished Thu Jun 14 13:08:05 2012
```

1  User name, date and time of the numbering.
Numbering method.

- **Modified numbering** is displayed when you run the **Number modified objects** command.
- **Modified numbering for selected series** is displayed when you run the **Number series of selected objects** command.
- **Diagnose & Repair Numbering: All** is displayed when you run the **Diagnose & repair numbering: All** command.
- **Diagnose & Repair Numbering: Series of selected objects** is displayed when you run the **Diagnose & repair numbering: Series of selected objects** command.
- **Renumber all** is displayed when you select the **Renumber all** option in the **Numbering Setup** dialog box.

Some **Compare** options set in the **Numbering Setup** dialog box are displayed in the **numbering.history** log file only if they are set differently than the default value:

- Compare modified to old parts
- Compare new to old part
- No holes comparing
- No part name comparing
- Beam orientation
- Column orientation

Numbering options.

- **Use old numbers** is displayed only when you have selected the **Re-use old numbers** option in the **Numbering Setup** dialog box.
- **Check for standard parts** is displayed only when you have selected the **Check for standard parts** option in the **Numbering Setup** dialog box.

Tolerances are set in the **Numbering Setup** dialog box.

Changes in the position numbers and in the numbering series during one numbering session.

---

**Numbering series in the numbering history log file**

Tekla Structures lists information about the numbered parts and assemblies in the **numberinghistory.txt** log file.

**Example 1**

The **numberinghistory.txt** log after one concrete beam B/20 has been created and numbered:
1. **Part position number.**
   - The part with the GUID ID510F595D-0000-0030-3133-353939383335 is a part of the numbering series Concrete_B-20/1.
   - The part becomes the first part in the numbering series: Concrete_B-20/0 -> Concrete_B-20/1.

2. **Assembly position number.**
   - The assembly ID of the part is ID510F595D-0000-002F-3133-353939383335.
   - The part belongs to the B/20 assembly numbering series, which is also the cast unit numbering series.
   - The part gets the assembly position number: B/20: B/0 -> B/20.

**Example 2**

The numbering history log after another concrete beam B/21 has been created and numbered:
Part position number of the new part.

- The part with the ID ID510F595D-0000-0030-3133-353939383335 is part of the numbering series Concrete_B-20/1.
- The part becomes the second part in the numbering series: Concrete_B-20/0 -> Concrete_B-20/2.

Assembly position number.

- The assembly ID of the part is ID510F595D-0000-002F-3133-353939383335.
- The part belongs to the B/20 assembly numbering series, which is also the cast unit numbering series.
- The part gets the assembly position number: B/20 B/0 -> B/21.

Files and file name extensions in the Tekla Structures model folder

These tables list the folders, files and file name extensions of files located in a Tekla Structures model folder.

**Files in the Tekla Structures model folder**

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.db1</td>
<td>Model database</td>
</tr>
<tr>
<td>.db2</td>
<td>Numbering database</td>
</tr>
<tr>
<td>environment.db</td>
<td>Database for user-defined attribute definitions</td>
</tr>
<tr>
<td>xslib.db1</td>
<td>Contains information about user-defined connections and details, and default component descriptions.</td>
</tr>
<tr>
<td>.idrm</td>
<td>Mapping file, which handles IDs.</td>
</tr>
<tr>
<td>NOTE</td>
<td>Do not modify this file.</td>
</tr>
<tr>
<td>xslib.db2</td>
<td>Contains numbering information.</td>
</tr>
<tr>
<td>options_model.db and options_drawings.db</td>
<td>Contain values for model-specific options from the Options dialog box and values for model-specific advanced options from the Advanced options dialog box. When a model is created, Tekla Structures reads model-specific options and advanced options</td>
</tr>
<tr>
<td>File or file name extension</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>values from the standard.opt file and .ini files in the environment folders and saves them in these two databases.</td>
<td><strong>history.db</strong> Model history database.</td>
</tr>
<tr>
<td>This file is used to show the name of the model in the Open dialog box.</td>
<td><strong>xsdb.xs</strong></td>
</tr>
</tbody>
</table>
| Contains interface settings specified by the user. This file contains settings for many of the options in the Options dialog box and the settings for the icons on the Selecting and Snapping toolbars. Each time a model is saved, an xs_user.<username> file is created or updated. These settings are user-specific. If the xs_user.<username> file is not found in the model folder when you open the model, Tekla Structures searches for the xs_user.default file in the following folder search order:  
1. Model folder  
2. model\attributes  
3. Project folder  
4. XS_FIRM\attributes  
5. System folder  
If this file is not found, the default settings for Tekla Structures default settings are used. | **xs_user.<username>** |
| Contains information about which snap switches are switched on or off in the drawing mode. This file is user-specific. | **drawing_user.<username>** |
| Each time the model is saved, Tekla Structures stores the information in this file. The file includes the time and date that the file was saved, and information about any conflicts during saving. | **save_history.log** |
| This file is used to show a notification report of assignments when you open a model. | **notification_report.xsr** |
| Contains a copy of basic details about the Tekla Structures model, such as the model name, the version it was last saved with, and the Tekla Structures environment that was used. Tekla | **TeklaStructuresModel.xml** |

**NOTE** Do not modify this file.
<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Structures overwrites the details in this file each time the model is saved. The model details that you see when you select a model on the startup screen are read from this file. The file can also be used as an information source for external tools, such as scripts.</td>
<td></td>
</tr>
<tr>
<td>dotlog.txt</td>
<td>A log file that contains information about Tekla Open API application use.</td>
</tr>
<tr>
<td>.locked</td>
<td>A temporary file that locks the files in the model folder to prevent modifications while the model is in use.</td>
</tr>
<tr>
<td>.bak</td>
<td>A backup copy of a file with a corresponding name. For example, the <code>&lt;modelname&gt;.db1.bak</code> file is the backup copy of the model database file <code>&lt;modelname&gt;.db1</code>.</td>
</tr>
<tr>
<td>assert.txt</td>
<td>A log file that contains information about assertion errors.</td>
</tr>
<tr>
<td>ClashCheck.txt</td>
<td>A log file that contains information about clashes found in the most recent clash check, and the date and time of the clash check.</td>
</tr>
<tr>
<td>ClashCheck.history</td>
<td>A file that contains information about clashes found in all past clash checks, and the dates and times of the clash checks.</td>
</tr>
<tr>
<td>wizard.txt</td>
<td>Tekla Structures stores information in this file when you run a drawing rule set (wizard) file. The file contains information such as errors, the number of drawings created, and information about which commands were used.</td>
</tr>
<tr>
<td>.lis</td>
<td>Export files for catalogs. You can export catalogs and import them to different Tekla Structures models as .lis files. These catalogs include profile, material, and bolt catalogs.</td>
</tr>
<tr>
<td>.tsc</td>
<td>Export files for shapes. You can export shapes and import them to different Tekla Structures models as .tsc files.</td>
</tr>
<tr>
<td>.This_is_multiuser_model</td>
<td>Contains information about the PC that is running the Tekla Structures multi-user server.</td>
</tr>
</tbody>
</table>

**NOTE** In normal circumstances, do not alter or delete this file. If you move the model to a different server, you should delete this file.
<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Structures generates a new file for the new server.</td>
<td></td>
</tr>
<tr>
<td>ComponentCatalog.xml</td>
<td>Contains the model level catalog definitions of the Applications &amp; components catalog.</td>
</tr>
<tr>
<td>&lt;user&gt;_ComponentCatalogUserSettings.xml</td>
<td>Lists the recently used applications and components, and their location in the Applications &amp; components catalog structure.</td>
</tr>
<tr>
<td>Worktypes.xml</td>
<td>Lists available task types. This file is created when you start the Task manager.</td>
</tr>
<tr>
<td>WorkTypeProperties.xml</td>
<td>Lists allowed property types and their units.</td>
</tr>
<tr>
<td>.tmp</td>
<td>Stores temporary data.</td>
</tr>
<tr>
<td>.cnv</td>
<td>Maps Tekla Structures profile and material names with names used in other software.</td>
</tr>
<tr>
<td>.colorset</td>
<td>This file is created when you export a color set from the Organizer.</td>
</tr>
<tr>
<td>DocumentManager_&lt;user&gt;.xml</td>
<td>Stores the Document manager window layout changes.</td>
</tr>
<tr>
<td>DocumentManagerDataGridSettings_&lt;user&gt;.xml</td>
<td>Stores the Document manager user interface layout changes.</td>
</tr>
<tr>
<td>DocumentManagerCategories_&lt;user&gt;.xml</td>
<td>Stores the Document manager category changes.</td>
</tr>
<tr>
<td>.dwg, .dxf</td>
<td>Files exported through Export 3D DWG/DXF.</td>
</tr>
</tbody>
</table>

### Files in the Analysis folder

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.ifc</td>
<td>The analysis model exported in IFC format.</td>
</tr>
<tr>
<td>.stp</td>
<td>The analysis model exported in CIS/2 format.</td>
</tr>
<tr>
<td>.map</td>
<td>A file used for debugging analysis models.</td>
</tr>
<tr>
<td>analysis_results.db5</td>
<td>Database that contains saved analysis results for all load combinations.</td>
</tr>
<tr>
<td>.db6</td>
<td>Analysis model database.</td>
</tr>
</tbody>
</table>
## Files in the \attributes folder

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.rmcs</td>
<td>Comparison set files used in reference model change detection.</td>
</tr>
<tr>
<td>.rmct</td>
<td>Property set comparison tolerance setting files used in reference model change detection.</td>
</tr>
<tr>
<td>.rop</td>
<td>Reference object properties</td>
</tr>
<tr>
<td>.rop.more</td>
<td>Reference object user-defined attribute properties</td>
</tr>
<tr>
<td>.m10000017</td>
<td>FabTrol XML import properties</td>
</tr>
<tr>
<td>.m10000015</td>
<td>Import attribute properties</td>
</tr>
<tr>
<td>.ncf</td>
<td>NC file properties</td>
</tr>
<tr>
<td>.ExportIFC.MainDialog</td>
<td>IFC export properties</td>
</tr>
<tr>
<td>.dwgsetting</td>
<td>Drawing export properties <em>(Export drawings as DWG/DXF)</em></td>
</tr>
<tr>
<td>.m440000004</td>
<td>3D DWG/DXF export properties</td>
</tr>
<tr>
<td>.dwgExport.json</td>
<td>3D DWG export properties</td>
</tr>
<tr>
<td>.m440000003</td>
<td>3D DGN export properties</td>
</tr>
<tr>
<td>.dgnExport.json</td>
<td>3D DGN v. 8 export properties</td>
</tr>
<tr>
<td>.m1000004</td>
<td>FEM export properties</td>
</tr>
<tr>
<td>.m170000068</td>
<td>ELiPLAN export properties</td>
</tr>
<tr>
<td>.HmsExport.HmsExportForm.xml</td>
<td>HMS export properties</td>
</tr>
<tr>
<td>.m160000079</td>
<td>Unitechnik export properties</td>
</tr>
<tr>
<td>.BvbsExport.BvbsExportForm.xml</td>
<td>BVBS export properties</td>
</tr>
<tr>
<td>.ExportSketchup.MainDialog.xml</td>
<td>Sketchup export properties</td>
</tr>
<tr>
<td>.m1000007</td>
<td>CAD export properties</td>
</tr>
<tr>
<td>.m10000016</td>
<td>Cover sheet export properties</td>
</tr>
<tr>
<td>.SOBJGrp</td>
<td>Model selection filter properties</td>
</tr>
<tr>
<td>.VOBJGrp</td>
<td>Model view filter properties</td>
</tr>
<tr>
<td>.OrgOBJGrp</td>
<td>Organizer filter properties</td>
</tr>
<tr>
<td>.POBJGrp</td>
<td>Object group filter properties</td>
</tr>
<tr>
<td>.IFCOBJGrp</td>
<td>IFC object group filter properties</td>
</tr>
<tr>
<td>.grd</td>
<td>Rectangular grid properties</td>
</tr>
<tr>
<td>.grd.more</td>
<td>Rectangular grid user-defined attribute properties</td>
</tr>
<tr>
<td>.rgrd</td>
<td>Radial grid properties</td>
</tr>
<tr>
<td>File or file name extension</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>.rgrd.more</td>
<td>Radial grid user-defined attribute properties</td>
</tr>
<tr>
<td>.grdp</td>
<td>Grid line properties</td>
</tr>
<tr>
<td>.grdp.more</td>
<td>Grid line user-defined attribute properties</td>
</tr>
<tr>
<td>.cnl</td>
<td>Construction line properties</td>
</tr>
<tr>
<td>.cncrl</td>
<td>Construction circle properties</td>
</tr>
<tr>
<td>.cnarc</td>
<td>Construction arc properties</td>
</tr>
<tr>
<td>.cnplycrv</td>
<td>Construction polycurve properties</td>
</tr>
</tbody>
</table>
| .mvi                        | Model view properties that you have saved for the model. The default 3D, part, component, custom component, assembly, and cast unit view settings files must be saved with the names used in common environment:  
  3D view: basic_view  
  3D part view: part_basic_view  
  Part front view: part_front_view  
  Part top view: part_top_view  
  Part end view: part_end_view  
  Part perspective view: part_persp_view  
  3D component view: component_basic_view  
  Component front view: component_front_view  
  Component top view: component_top_view  
  Component end view: component_end_view  
  Component perspective view: component_persp_view  
  Custom component front view: custom_object_editor_front_view  
  Custom component top view: custom_object_editor_top_view  
  Custom component end view: custom_object_editor_end_view  
  Custom component perspective view: custom_object_editor_perspective_view  
  3D assembly or cast unit view: assembly_basic_view |
<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assembly or cast unit front view: assembly_front_view</td>
<td></td>
</tr>
<tr>
<td>Assembly or cast unit top view: assembly_top_view</td>
<td></td>
</tr>
<tr>
<td>Assembly or cast unit end view: assembly_end_view</td>
<td></td>
</tr>
<tr>
<td>Assembly or cast unit back view: assembly_back_view</td>
<td></td>
</tr>
<tr>
<td>Assembly or cast unit bottom view: assembly_bottom_view</td>
<td></td>
</tr>
<tr>
<td>Assembly or cast unit perspective view: assembly_persp_view</td>
<td></td>
</tr>
<tr>
<td>.gvi</td>
<td>Saved properties for creating views along grid lines</td>
</tr>
<tr>
<td>.rep</td>
<td>Object representation properties</td>
</tr>
<tr>
<td>.clm</td>
<td>Steel column properties</td>
</tr>
<tr>
<td>.clm.more</td>
<td>Steel column user-defined attribute properties</td>
</tr>
<tr>
<td>.prt</td>
<td>Steel beam properties</td>
</tr>
<tr>
<td>.prt.more</td>
<td>Steel beam user-defined attribute properties</td>
</tr>
<tr>
<td>.sb</td>
<td>Steel spiral beam properties</td>
</tr>
<tr>
<td>.sb.more</td>
<td>Steel spiral beam user-defined attribute properties</td>
</tr>
<tr>
<td>.crs</td>
<td>Orthogonal beam properties</td>
</tr>
<tr>
<td>.crs.more</td>
<td>Orthogonal beam user-defined attribute properties</td>
</tr>
<tr>
<td>.dia</td>
<td>Twin profile properties</td>
</tr>
<tr>
<td>.dia.more</td>
<td>Twin profile user-defined attribute properties</td>
</tr>
<tr>
<td>.cpl</td>
<td>Contour plate properties</td>
</tr>
<tr>
<td>.cpl.more</td>
<td>Contour plate user-defined attribute properties</td>
</tr>
<tr>
<td>.blp</td>
<td>Bent plate properties</td>
</tr>
<tr>
<td>.blp.more</td>
<td>Bent plate user-defined attribute properties</td>
</tr>
<tr>
<td>.ipl</td>
<td>Lofted plate properties</td>
</tr>
<tr>
<td>.ipl.more</td>
<td>Lofted plate user-defined attribute properties</td>
</tr>
<tr>
<td>.ips</td>
<td>Item properties</td>
</tr>
<tr>
<td>.ips.more</td>
<td>Item user-defined attribute properties</td>
</tr>
<tr>
<td>.cpf</td>
<td>Pad footing properties</td>
</tr>
<tr>
<td>.cpf.more</td>
<td>Pad footing user-defined attribute properties</td>
</tr>
<tr>
<td>.csf</td>
<td>Strip footing properties</td>
</tr>
<tr>
<td>.csf.more</td>
<td>Strip footing user-defined attribute properties</td>
</tr>
<tr>
<td>.ccl</td>
<td>Concrete column properties</td>
</tr>
<tr>
<td>File or file name extension</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>.ccl.more</td>
<td>Concrete column user-defined attribute properties</td>
</tr>
<tr>
<td>.cbm</td>
<td>Concrete beam or concrete polybeam properties</td>
</tr>
<tr>
<td>.cbm.more</td>
<td>Concrete beam or concrete polybeam user-defined attribute properties</td>
</tr>
<tr>
<td>.csb</td>
<td>Concrete spiral beam properties</td>
</tr>
<tr>
<td>.csb.more</td>
<td>Concrete spiral beam user-defined attribute properties</td>
</tr>
<tr>
<td>.csl</td>
<td>Concrete slab properties</td>
</tr>
<tr>
<td>.csl.more</td>
<td>Concrete slab user-defined attribute properties</td>
</tr>
<tr>
<td>.cpn</td>
<td>Concrete panel properties</td>
</tr>
<tr>
<td>.cpn.more</td>
<td>Concrete panel user-defined attribute properties</td>
</tr>
<tr>
<td>.lsl</td>
<td>Concrete lofted slab properties</td>
</tr>
<tr>
<td>.lsl.more</td>
<td>Concrete lofted slab user-defined attribute properties</td>
</tr>
<tr>
<td>.ipc</td>
<td>Concrete item properties</td>
</tr>
<tr>
<td>.ipc.more</td>
<td>Concrete item user-defined attribute properties</td>
</tr>
<tr>
<td>.rbr</td>
<td>Reinforcing bar properties</td>
</tr>
<tr>
<td>.rbr.more</td>
<td>Reinforcing bar user-defined attribute properties</td>
</tr>
<tr>
<td>.rgb</td>
<td>Reinforcing bar group properties</td>
</tr>
<tr>
<td>.rgb.more</td>
<td>Reinforcing bar group user-defined attribute properties</td>
</tr>
<tr>
<td>.rcu</td>
<td>Curved reinforcing bar group properties and user-defined attributes</td>
</tr>
<tr>
<td>.rcu.more</td>
<td>Curved reinforcing bar group properties and user-defined attributes</td>
</tr>
<tr>
<td>.rci</td>
<td>Circular reinforcing bar group properties and user-defined attributes</td>
</tr>
<tr>
<td>.rci.more</td>
<td>Circular reinforcing bar group properties and user-defined attributes</td>
</tr>
<tr>
<td>.rbm</td>
<td>Reinforcement mesh properties</td>
</tr>
<tr>
<td>.rbm.more</td>
<td>Reinforcement mesh user-defined attribute properties</td>
</tr>
<tr>
<td>.rbs</td>
<td>Reinforcement strand pattern properties</td>
</tr>
<tr>
<td>.rbs.more</td>
<td>Reinforcement strand pattern user-defined attribute properties</td>
</tr>
<tr>
<td>.rsp</td>
<td>Reinforcement splice properties</td>
</tr>
<tr>
<td>.rsp.more</td>
<td>Reinforcement splice user-defined attribute properties</td>
</tr>
<tr>
<td>.rst</td>
<td>Rebar set properties</td>
</tr>
<tr>
<td>.rst.more</td>
<td>Rebar set user-defined attribute properties</td>
</tr>
<tr>
<td>.rst_ls</td>
<td>Rebar set leg surface properties</td>
</tr>
<tr>
<td>File or file name extension</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>.rst_pm</td>
<td>Rebar set property modifier properties</td>
</tr>
<tr>
<td>.rst_pm.more</td>
<td>Rebar set property modifier user-defined attribute properties</td>
</tr>
<tr>
<td>.rst_edm</td>
<td>Rebar set end detail modifier properties</td>
</tr>
<tr>
<td>.rst_edm.more</td>
<td>Rebar set end detail modifier user-defined attribute properties</td>
</tr>
<tr>
<td>.rst_sm</td>
<td>Rebar set splitter properties</td>
</tr>
<tr>
<td>.admodel</td>
<td>Analysis model properties</td>
</tr>
<tr>
<td>.admodel.more</td>
<td>Analysis model user-defined attribute properties</td>
</tr>
<tr>
<td>.lm1</td>
<td>Point load properties</td>
</tr>
<tr>
<td>.lm2</td>
<td>Line load properties</td>
</tr>
<tr>
<td>.lm3</td>
<td>Area load properties</td>
</tr>
<tr>
<td>.lm4</td>
<td>Uniform load properties</td>
</tr>
<tr>
<td>.m10000028</td>
<td>Wind load properties</td>
</tr>
<tr>
<td>.lm6</td>
<td>Temperature load properties</td>
</tr>
<tr>
<td>.lco</td>
<td>Load combination properties</td>
</tr>
<tr>
<td>.adnode</td>
<td>Analysis node properties</td>
</tr>
<tr>
<td>.adnode.more</td>
<td>Analysis node user-defined attribute properties</td>
</tr>
<tr>
<td>.prt_ad,.prt_design</td>
<td>File types associated with steel beam analysis property settings. .prt_ad contains information associated with the analysis part properties and .prt_design contains information associated with the actual steel beam design.</td>
</tr>
<tr>
<td>.crs_ad,.crs_design</td>
<td>File types associated with orthogonal steel beam analysis property settings. .crs_ad contains information associated with the analysis part properties and .crs_design contains information associated with orthogonal steel beam design.</td>
</tr>
<tr>
<td>.clm_ad,.clm_design</td>
<td>File types associated with steel column analysis property settings. .clm_ad contains information associated with the analysis part properties and .clm_design contains information associated with the actual steel column design.</td>
</tr>
<tr>
<td>.dia_ad,.dia_design</td>
<td>File types associated with steel twin profile analysis property settings. .dia_ad contains information associated with the analysis part properties and .dia_design contains information associated with actual twin profile design.</td>
</tr>
<tr>
<td>.cpl_ad,.cpl_design</td>
<td>File types associated with contour plate analysis property settings. .cpl_ad contains information...</td>
</tr>
<tr>
<td>File or file name extension</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>.cpl_ad, .cpl_design</strong></td>
<td>File types associated with contour plate analysis property settings. <strong>.cpl_ad</strong> contains information associated with the analysis part properties and <strong>.cpl_design</strong> contains information associated with the actual contour plate design.</td>
</tr>
<tr>
<td><strong>.cpf_ad, .cpf_design</strong></td>
<td>File types associated with pad footing analysis property settings. <strong>.cpf_ad</strong> contains information associated with the analysis part properties and <strong>.cpf_design</strong> contains information associated with the actual pad footing design.</td>
</tr>
<tr>
<td><strong>.csf_ad, .csf_design</strong></td>
<td>File types associated with strip footing analysis property settings. <strong>.csf_ad</strong> contains information associated with the analysis part properties and <strong>.csf_design</strong> contains information associated with the actual strip footing design.</td>
</tr>
<tr>
<td><strong>.ccl_ad, .ccl_design</strong></td>
<td>File types associated with concrete column analysis property settings. <strong>.ccl_ad</strong> contains information associated with the analysis part properties and <strong>.ccl_design</strong> contains information associated with the actual concrete column design.</td>
</tr>
<tr>
<td><strong>.cbm_ad, .cbm_design</strong></td>
<td>File types associated with concrete beam analysis property settings. <strong>.cbm_ad</strong> contains information associated with the analysis part properties and <strong>.cbm_design</strong> contains information associated with the actual concrete beam design.</td>
</tr>
<tr>
<td><strong>.csl_ad, .csl_design</strong></td>
<td>File types associated with concrete slab analysis property settings. <strong>.csl_ad</strong> contains information associated with the analysis part properties and <strong>.csl_design</strong> contains information associated with the actual slab design.</td>
</tr>
<tr>
<td><strong>.cpn_ad, .cpn_design</strong></td>
<td>File types associated with concrete panel analysis property settings. <strong>.cpl_ad</strong> contains information associated with the analysis part properties and <strong>.cpl_design</strong> contains information associated with the actual concrete panel design.</td>
</tr>
<tr>
<td><strong>.srf</strong></td>
<td>Surface treatment properties</td>
</tr>
<tr>
<td><strong>.srf.more</strong></td>
<td>User-defined surface treatment attribute properties</td>
</tr>
<tr>
<td><strong>.srfo</strong></td>
<td>Surface properties</td>
</tr>
<tr>
<td><strong>.srfo.more</strong></td>
<td>User-defined surface attribute properties</td>
</tr>
<tr>
<td><strong>.cha</strong></td>
<td>Edge chamfer properties</td>
</tr>
<tr>
<td><strong>.cha.more</strong></td>
<td>User-defined edge chamfer attribute properties</td>
</tr>
<tr>
<td><strong>.scr</strong></td>
<td>Bolt properties</td>
</tr>
<tr>
<td><strong>.scr.more</strong></td>
<td>User-defined bolt attribute properties</td>
</tr>
<tr>
<td>File or file name extension</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>.wld</td>
<td>Weld properties</td>
</tr>
<tr>
<td>.wld.more</td>
<td>User-defined weld attribute properties</td>
</tr>
<tr>
<td>*.udwcs</td>
<td>User-defined weld cross sections (UserDefinedWeldCrossSections.udwcs)</td>
</tr>
<tr>
<td>.m1000009</td>
<td>Control number properties</td>
</tr>
<tr>
<td>.m1000010</td>
<td>Control number locking properties</td>
</tr>
<tr>
<td>.num</td>
<td>Numbering setup properties</td>
</tr>
<tr>
<td>.rpr</td>
<td>Report properties</td>
</tr>
<tr>
<td>.4d</td>
<td>Project status visualization properties</td>
</tr>
<tr>
<td>.sas</td>
<td>Assembly properties</td>
</tr>
<tr>
<td>.pas</td>
<td>Precast cast unit properties</td>
</tr>
<tr>
<td>.ias</td>
<td>Cast-in-place cast unit properties</td>
</tr>
<tr>
<td>.ras</td>
<td>Rebar assembly properties</td>
</tr>
<tr>
<td>.punit</td>
<td>Pour unit properties and user-defined attributes</td>
</tr>
<tr>
<td>.punit.more</td>
<td>Pour unit properties and user-defined attributes</td>
</tr>
<tr>
<td>.pour</td>
<td>Pour object properties and user-defined attributes</td>
</tr>
<tr>
<td>.pour.more</td>
<td>Pour object properties and user-defined attributes</td>
</tr>
<tr>
<td>.pbreak</td>
<td>Pour break properties</td>
</tr>
<tr>
<td>.it</td>
<td>Report template used in Custom inquiry</td>
</tr>
<tr>
<td>.ColorPalette.xml</td>
<td>Custom color palette file saved in color palette editing mode.</td>
</tr>
<tr>
<td>standard.opt</td>
<td>Settings are saved in standard.opt in the \attributes folder only when you save your own settings in the Options dialog box using Save. There is a standard.opt file in the environment folder that gives the initial values to be loaded when a model is created.</td>
</tr>
</tbody>
</table>

**Tekla PowerFab export settings in the \attributes folder**

The standard Tekla PowerFab export settings file is saved with the name standard.TeklaPowerFabPluginSettings.xml in the \attributes folder under the model folder. If you save the settings with another name, the settings file is saved as <name>.TeklaPowerFabPluginSettings.xml.
Component properties files in the \attributes folder

Properties files for components in the Applications & components catalog, such as .j310000063 for 2L Splice (63) component properties. These files are stored in the attributes folder under the model folder.

Object-level drawing settings saved in the \attributes folder

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.dpri</td>
<td>Object-level part properties</td>
</tr>
<tr>
<td>.dim</td>
<td>Object-level dimension properties</td>
</tr>
<tr>
<td>.dimension_mark</td>
<td>Object-level dimension tag properties</td>
</tr>
<tr>
<td>.rdim</td>
<td>Object-level rebar dimension mark properties</td>
</tr>
<tr>
<td>.pm</td>
<td>Object-level part mark properties</td>
</tr>
<tr>
<td>.jm</td>
<td>Object-level connection mark properties</td>
</tr>
<tr>
<td>.sm</td>
<td>Object-level bolt mark properties</td>
</tr>
<tr>
<td>.rm</td>
<td>Object-level reinforcement mark properties</td>
</tr>
<tr>
<td>.mrm</td>
<td>Object-level merged reinforcement mark properties</td>
</tr>
<tr>
<td>.pom</td>
<td>Pour object mark properties</td>
</tr>
<tr>
<td>.surf</td>
<td>Object-level surface treatment mark properties</td>
</tr>
<tr>
<td>.note</td>
<td>Object-level associative note properties</td>
</tr>
<tr>
<td>.wls</td>
<td>Object-level weld mark properties</td>
</tr>
<tr>
<td>.lev</td>
<td>Object-level level mark properties</td>
</tr>
<tr>
<td>.rev</td>
<td>Object-level revision mark properties</td>
</tr>
<tr>
<td>.drmsh</td>
<td>Object-level reinforcement mesh properties</td>
</tr>
<tr>
<td>.drbr</td>
<td>Object-level reinforcement properties</td>
</tr>
<tr>
<td>.po</td>
<td>Object-level pour object properties</td>
</tr>
<tr>
<td>.sc</td>
<td>Object-level bolt properties</td>
</tr>
<tr>
<td>.dserf</td>
<td>Object-level surface treatment properties</td>
</tr>
<tr>
<td>.dgr</td>
<td>Object-level grid properties</td>
</tr>
<tr>
<td>.sbl</td>
<td>Object-level symbol properties</td>
</tr>
<tr>
<td>.wls</td>
<td>Object-level weld mark properties</td>
</tr>
<tr>
<td>.drtxt</td>
<td>Object-level text properties</td>
</tr>
<tr>
<td>.gln</td>
<td>Object-level line properties</td>
</tr>
<tr>
<td>.gtr</td>
<td>Object-level rectangle properties</td>
</tr>
<tr>
<td>.gci</td>
<td>Object-level circle properties</td>
</tr>
<tr>
<td>.gar</td>
<td>Object-level arc properties</td>
</tr>
<tr>
<td>File or file name extension</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------</td>
</tr>
<tr>
<td>.gpl</td>
<td>Object-level polyline properties</td>
</tr>
<tr>
<td>.gpg</td>
<td>Object-level polygon and cloud properties</td>
</tr>
</tbody>
</table>

**View-level drawing settings saved in the \attributes folder**

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.vi</td>
<td>View-level view properties</td>
</tr>
<tr>
<td>.vi.copt</td>
<td>View-level detailed object-level settings</td>
</tr>
<tr>
<td>.viewdim</td>
<td>View-level dimension properties</td>
</tr>
<tr>
<td>.vpm</td>
<td>View-level part mark properties</td>
</tr>
<tr>
<td>.vsm</td>
<td>View-level bolt mark properties</td>
</tr>
<tr>
<td>.vnpm</td>
<td>View-level neighbor part mark properties</td>
</tr>
<tr>
<td>.vsurfm</td>
<td>View-level surface treatment mark properties</td>
</tr>
<tr>
<td>.vjm</td>
<td>View-level connection mark properties</td>
</tr>
<tr>
<td>.vrm</td>
<td>View-level reinforcement mark properties</td>
</tr>
<tr>
<td>.vnrm</td>
<td>View-level neighbor reinforcement mark properties</td>
</tr>
<tr>
<td>.vpom</td>
<td>View-level pour object mark properties</td>
</tr>
<tr>
<td>.vp</td>
<td>View-level part properties</td>
</tr>
<tr>
<td>.vs</td>
<td>View-level bolt properties</td>
</tr>
<tr>
<td>.vnp</td>
<td>View-level neighbor part properties</td>
</tr>
<tr>
<td>.vsurfm</td>
<td>View-level surface treatment properties</td>
</tr>
<tr>
<td>.vw</td>
<td>View-level welding properties</td>
</tr>
<tr>
<td>.vr</td>
<td>View-level reinforcement properties</td>
</tr>
<tr>
<td>.vnr</td>
<td>View-level neighbor reinforcement properties</td>
</tr>
<tr>
<td>.vrmmp</td>
<td>View-level reference object properties</td>
</tr>
<tr>
<td>.vpo</td>
<td>View-level pour object properties</td>
</tr>
<tr>
<td>.vg</td>
<td>View-level grid properties</td>
</tr>
<tr>
<td>.vf</td>
<td>View-level filter properties</td>
</tr>
<tr>
<td>.vnf</td>
<td>View-level neighbor part filter properties</td>
</tr>
<tr>
<td>.GridsDimXml</td>
<td>Dimensioning rules</td>
</tr>
<tr>
<td>.ShapeDimXml</td>
<td></td>
</tr>
<tr>
<td>.HolesDimXml</td>
<td></td>
</tr>
<tr>
<td>.FilterDimXml</td>
<td></td>
</tr>
<tr>
<td>File or file name extension</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>.OverallDimXml</td>
<td></td>
</tr>
<tr>
<td>.RecessesDimXml</td>
<td></td>
</tr>
<tr>
<td>.SecPartsDimXml</td>
<td></td>
</tr>
<tr>
<td>.NeighborDimXml</td>
<td></td>
</tr>
<tr>
<td>.SpiralBeamDimXML</td>
<td></td>
</tr>
</tbody>
</table>

**Files related to drawing level properties for single-part drawings saved in \attributes folder**

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.wd</td>
<td>Single-part drawing properties</td>
</tr>
<tr>
<td>.wd.copt</td>
<td></td>
</tr>
<tr>
<td>.wd.more</td>
<td>Single-part drawing user-defined attributes</td>
</tr>
<tr>
<td>.wdf</td>
<td>Single-part drawing filter properties</td>
</tr>
<tr>
<td>.wdf</td>
<td></td>
</tr>
<tr>
<td>.wdnf</td>
<td>Single-part drawing neighbor part filter properties</td>
</tr>
<tr>
<td>.wdl</td>
<td>Single-part drawing layout properties</td>
</tr>
<tr>
<td>.wdl.more</td>
<td>Single-part drawing user-defined layout attributes</td>
</tr>
<tr>
<td>.wdv</td>
<td>Single-part drawing view properties</td>
</tr>
<tr>
<td>.wdv.more</td>
<td>Single-part drawing user-defined view attributes</td>
</tr>
<tr>
<td>.wdc</td>
<td>Single-part drawing section view properties</td>
</tr>
<tr>
<td>.wdc.more</td>
<td>Single-part drawing user-defined section view attributes</td>
</tr>
<tr>
<td>.wdd</td>
<td>Single-part drawing dimension properties</td>
</tr>
<tr>
<td>.wdd.more</td>
<td>Single-part drawing user-defined dimension attributes</td>
</tr>
<tr>
<td>.wdcd</td>
<td>Single-part drawing dimensioning properties</td>
</tr>
<tr>
<td>.wdcd more</td>
<td>Single-part drawing user-defined dimensioning attributes</td>
</tr>
<tr>
<td>.wpm</td>
<td>Single-part drawing part mark properties</td>
</tr>
<tr>
<td>.wsm</td>
<td>Single-part drawing bolt mark properties</td>
</tr>
<tr>
<td>.wnpm</td>
<td>Single-part drawing neighbor part mark properties</td>
</tr>
<tr>
<td>.wdsurfm</td>
<td>Single-part drawing surface treatment mark properties</td>
</tr>
</tbody>
</table>

Customize Tekla Structures for users  100  Files for configuring Tekla Structures
<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.wdsurfm.more</td>
<td>Single-part drawing user-defined surface treatment mark attributes</td>
</tr>
<tr>
<td>.wjm</td>
<td>Single-part drawing connection mark properties</td>
</tr>
<tr>
<td>.wdp</td>
<td>Single-part drawing part properties</td>
</tr>
<tr>
<td>.wds</td>
<td>Single-part drawing bolt properties</td>
</tr>
<tr>
<td>.wds.more</td>
<td>Single-part drawing user-defined bolt attributes</td>
</tr>
<tr>
<td>.wdnp</td>
<td>Single-part drawing neighbor part properties</td>
</tr>
<tr>
<td>.wdnp.more</td>
<td>Single-part drawing user-defined neighbor part attributes</td>
</tr>
<tr>
<td>.wdsrf</td>
<td>Single-part drawing surface treatment properties</td>
</tr>
<tr>
<td>.wdsrf.more</td>
<td>Single-part drawing user-defined surface treatment attributes</td>
</tr>
<tr>
<td>.wdgr</td>
<td>Single-part drawing grid properties</td>
</tr>
<tr>
<td>.wdgr.more</td>
<td>Single-part drawing user-defined grid attributes</td>
</tr>
<tr>
<td>.wdr</td>
<td>Single-part drawing protection properties</td>
</tr>
<tr>
<td>.wdr.more</td>
<td>Single-part drawing user-defined protection attributes</td>
</tr>
<tr>
<td>.wsection_mark_a1 - a5</td>
<td>Single part drawings: section mark properties in section views</td>
</tr>
</tbody>
</table>

Files related to drawing level properties for assembly drawings saved in the `attributes` folder

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.ad</td>
<td>Assembly drawing properties</td>
</tr>
<tr>
<td>.ad.more</td>
<td>Assembly drawing user-defined attributes</td>
</tr>
<tr>
<td>.adf</td>
<td>Assembly drawing filter properties</td>
</tr>
<tr>
<td>.adnf</td>
<td>Assembly drawing neighbor part filter properties</td>
</tr>
<tr>
<td>.adl</td>
<td>Assembly drawing layout properties</td>
</tr>
<tr>
<td>.adl.more</td>
<td>Assembly drawing user-defined layout attributes</td>
</tr>
<tr>
<td>.adv</td>
<td>Assembly drawing view properties</td>
</tr>
<tr>
<td>.adc</td>
<td>Assembly drawing section view properties</td>
</tr>
<tr>
<td>.add</td>
<td>Assembly drawing dimension properties</td>
</tr>
<tr>
<td>File or file name extension</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>.add.more</td>
<td>Assembly drawing user-defined dimension attributes</td>
</tr>
<tr>
<td>.adcd</td>
<td>Assembly drawing dimensioning properties (Integrated dimensioning)</td>
</tr>
<tr>
<td>.adcd.more</td>
<td>Assembly drawing user-defined dimensioning attributes</td>
</tr>
<tr>
<td>.apm</td>
<td>Assembly drawing part mark properties</td>
</tr>
<tr>
<td>.asm</td>
<td>Assembly drawing bolt mark properties</td>
</tr>
<tr>
<td>.anpm</td>
<td>Assembly drawing neighbor part mark properties</td>
</tr>
<tr>
<td>.adsurfm</td>
<td>Assembly drawing surface treatment mark properties</td>
</tr>
<tr>
<td>.adsurfm.more</td>
<td>Assembly drawing user-defined surface treatment mark attributes</td>
</tr>
<tr>
<td>.ajm</td>
<td>Assembly drawing connection mark properties</td>
</tr>
<tr>
<td>.adp</td>
<td>Assembly drawing part properties</td>
</tr>
<tr>
<td>.adp.more</td>
<td>Assembly drawing user-defined part attributes</td>
</tr>
<tr>
<td>.ads</td>
<td>Assembly drawing bolt properties</td>
</tr>
<tr>
<td>.adnp</td>
<td>Assembly drawing neighbor part properties</td>
</tr>
<tr>
<td>.adnp.more</td>
<td>Assembly drawing user-defined neighbor part attributes</td>
</tr>
<tr>
<td>.adsrf</td>
<td>Assembly drawing surface treatment properties</td>
</tr>
<tr>
<td>.adsrf.more</td>
<td>Assembly drawing user-defined surface treatment attributes</td>
</tr>
<tr>
<td>.adw</td>
<td>Assembly drawing welding properties</td>
</tr>
<tr>
<td>.adw.more</td>
<td>Assembly drawing user-defined welding attributes</td>
</tr>
<tr>
<td>.adgr</td>
<td>Assembly drawing grid properties</td>
</tr>
<tr>
<td>.adgr.more</td>
<td>Assembly drawing user-defined grid attributes</td>
</tr>
<tr>
<td>.adr</td>
<td>Assembly drawing protection properties</td>
</tr>
<tr>
<td>.asection_view_mark_a1 - a5</td>
<td>Assembly drawings: section mark properties in section views</td>
</tr>
</tbody>
</table>
### Files related to drawing level properties for cast unit drawings saved in the attributes folder

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.cud</td>
<td>Cast unit drawing properties</td>
</tr>
<tr>
<td>.cud.copt</td>
<td>Cast unit drawing user-defined attributes</td>
</tr>
<tr>
<td>.cud.more</td>
<td>Cast unit drawing user-defined layout attributes</td>
</tr>
<tr>
<td>.cudl</td>
<td>Cast unit drawing layout properties</td>
</tr>
<tr>
<td>.cudl.more</td>
<td>Cast unit drawing user-defined layout attributes</td>
</tr>
<tr>
<td>.cudv</td>
<td>Cast unit drawing view properties</td>
</tr>
<tr>
<td>.cudv.more</td>
<td>Cast unit drawing user-defined view attributes</td>
</tr>
<tr>
<td>.cudc</td>
<td>Cast unit drawing section view properties</td>
</tr>
<tr>
<td>.cudc.more</td>
<td>Cast unit drawing user-defined section view attributes</td>
</tr>
<tr>
<td>.cudd</td>
<td>Cast unit drawing dimension properties</td>
</tr>
<tr>
<td>.cudd.more</td>
<td>Cast unit drawing user-defined dimension attributes</td>
</tr>
<tr>
<td>.cudcd</td>
<td>Cast unit drawing dimensioning properties (Integrated dimensioning)</td>
</tr>
<tr>
<td>.cudcd.more</td>
<td>Cast unit drawing user-defined dimensioning properties</td>
</tr>
<tr>
<td>.cudp</td>
<td>Cast unit drawing part properties</td>
</tr>
<tr>
<td>.cudp.more</td>
<td>Cast unit drawing user-defined part attributes</td>
</tr>
<tr>
<td>.cuds</td>
<td>Cast unit drawing bolt properties</td>
</tr>
<tr>
<td>.cuds.more</td>
<td>Cast unit drawing user-defined bolt attributes</td>
</tr>
<tr>
<td>.cudnp</td>
<td>Cast unit drawing neighbor part properties</td>
</tr>
<tr>
<td>File or file name extension</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>.cudnp.more</td>
<td>Cast unit drawing user-defined neighbor part attributes</td>
</tr>
<tr>
<td>.cudsr</td>
<td>Cast unit drawing surface treatment properties</td>
</tr>
<tr>
<td>.cudsr.more</td>
<td>Cast unit drawing user-defined surface treatment attributes</td>
</tr>
<tr>
<td>.cudr</td>
<td>Cast unit drawing reinforcement properties</td>
</tr>
<tr>
<td>.cudr.more</td>
<td>Cast unit drawing user-defined reinforcement attributes</td>
</tr>
<tr>
<td>.cudw</td>
<td>Cast unit drawing welding properties</td>
</tr>
<tr>
<td>.cudw.more</td>
<td>Cast unit drawing user-defined welding attributes</td>
</tr>
<tr>
<td>.cudgr</td>
<td>Cast unit drawing grid properties</td>
</tr>
<tr>
<td>.cudgr.more</td>
<td>Cast unit drawing user-defined grid attributes</td>
</tr>
<tr>
<td>.cudrp</td>
<td>Cast unit drawing protection properties</td>
</tr>
<tr>
<td>.cudrp.more</td>
<td>Cast unit drawing user-defined protection attributes</td>
</tr>
<tr>
<td>.cuf</td>
<td>Cast unit drawing filter properties</td>
</tr>
<tr>
<td>.cunf</td>
<td>Cast unit drawing neighbor part filter properties</td>
</tr>
<tr>
<td>.cusection_mark_a1 - a5</td>
<td>Cast unit drawings: section mark properties in section views</td>
</tr>
</tbody>
</table>

**Files related to drawing level properties for general arrangement drawings saved in the Attributes folder**

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.gd</td>
<td>General arrangement drawing properties</td>
</tr>
<tr>
<td>.gd.copt</td>
<td>General arrangement drawing detailed object-level settings</td>
</tr>
<tr>
<td>.gclassif</td>
<td>General arrangement drawing user-defined properties</td>
</tr>
<tr>
<td>.gclassif.copt</td>
<td>General arrangement drawing layout properties</td>
</tr>
<tr>
<td>.gd.more</td>
<td>General arrangement drawing user-defined layout attributes</td>
</tr>
<tr>
<td>.gdl</td>
<td>General arrangement drawing view properties</td>
</tr>
<tr>
<td>File or file name extension</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>.gdv.more</td>
<td>General arrangement drawing user-defined view attributes</td>
</tr>
<tr>
<td>.gdd</td>
<td>General arrangement drawing dimension properties</td>
</tr>
<tr>
<td>.gdd.more</td>
<td>General arrangement drawing user-defined dimension attributes</td>
</tr>
<tr>
<td>.gdcd</td>
<td>General arrangement drawing dimensioning properties</td>
</tr>
<tr>
<td>.gdcd.more</td>
<td>General arrangement drawing user-defined dimensioning attributes</td>
</tr>
<tr>
<td>.gpm</td>
<td>General arrangement drawing part mark properties</td>
</tr>
<tr>
<td>.gsm</td>
<td>General arrangement drawing bolt mark properties</td>
</tr>
<tr>
<td>.gnpm</td>
<td>General arrangement drawing neighbor part mark properties</td>
</tr>
<tr>
<td>.gdsurfm</td>
<td>General arrangement drawing surface treatment mark properties</td>
</tr>
<tr>
<td>.gdsurfm.more</td>
<td>General arrangement drawing user-defined surface treatment mark attributes</td>
</tr>
<tr>
<td>.gjm</td>
<td>General arrangement drawing connection mark properties</td>
</tr>
<tr>
<td>.gdrm</td>
<td>General arrangement drawing reinforcement mark properties</td>
</tr>
<tr>
<td>.gdrm.more</td>
<td>General arrangement drawing user-defined reinforcement mark attributes</td>
</tr>
<tr>
<td>.gnrm</td>
<td>General arrangement drawing neighbor reinforcement mark properties</td>
</tr>
<tr>
<td>.gpom</td>
<td>General arrangement drawing pour object mark properties</td>
</tr>
<tr>
<td>.gdp</td>
<td>General arrangement drawing part properties</td>
</tr>
<tr>
<td>.gdp.more</td>
<td>General arrangement drawing user-defined part attributes</td>
</tr>
<tr>
<td>.gds</td>
<td>General arrangement drawing bolt properties</td>
</tr>
<tr>
<td>.gds.more</td>
<td>General arrangement drawing user-defined bolt attributes</td>
</tr>
<tr>
<td>.gdnp</td>
<td>General arrangement drawing neighbor part properties</td>
</tr>
<tr>
<td>.gdnp.more</td>
<td>General arrangement drawing user-defined neighbor part attributes</td>
</tr>
<tr>
<td>File or file name extension</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>.gdsrf</td>
<td>General arrangement drawing surface treatment properties</td>
</tr>
<tr>
<td>.gdw</td>
<td>General arrangement drawing welding properties</td>
</tr>
<tr>
<td>.gdw.more</td>
<td>General arrangement drawing user-defined welding attributes</td>
</tr>
<tr>
<td>.gdr</td>
<td>General arrangement drawing reinforcement properties</td>
</tr>
<tr>
<td>.gdr.more</td>
<td>General arrangement drawing user-defined reinforcement attributes</td>
</tr>
<tr>
<td>.gnr</td>
<td>General arrangement drawing neighbor reinforcement properties</td>
</tr>
<tr>
<td>.gpo</td>
<td>General arrangement drawing pour object properties</td>
</tr>
<tr>
<td>.gpbr</td>
<td>General arrangement drawing pour break properties</td>
</tr>
<tr>
<td>.gdrmp</td>
<td>General arrangement drawing reference object properties</td>
</tr>
<tr>
<td>.gdrmp.more</td>
<td>General arrangement drawing user-defined reference model attributes</td>
</tr>
<tr>
<td>.gdgr</td>
<td>General arrangement drawing grid properties</td>
</tr>
<tr>
<td>.gdgr.more</td>
<td>General arrangement drawing user-defined grid attributes</td>
</tr>
<tr>
<td>.gdrp</td>
<td>General arrangement drawing protection properties</td>
</tr>
<tr>
<td>.gdrp.more</td>
<td>General arrangement drawing user-defined protection attributes</td>
</tr>
<tr>
<td>.gdf</td>
<td>General arrangement drawing filter properties</td>
</tr>
<tr>
<td>.gdnf</td>
<td>General arrangement drawing neighbor part filter properties</td>
</tr>
</tbody>
</table>

**Files related to drawing level properties for multidrawings saved in the attributes folder**

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.md</td>
<td>Multidrawing properties</td>
</tr>
<tr>
<td>.md.more</td>
<td>Multidrawing user-defined attributes</td>
</tr>
<tr>
<td>.mdl</td>
<td>Multidrawing layout properties</td>
</tr>
<tr>
<td>.mdl.more</td>
<td>Multidrawing user-defined layout attributes</td>
</tr>
<tr>
<td>File or file name extension</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>.mdr</td>
<td>Multidrawing protection properties</td>
</tr>
<tr>
<td>.mdr.more</td>
<td>Multidrawing user-defined protection attributes</td>
</tr>
</tbody>
</table>

**Files common to all drawings and files in the \drawings folder**

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.dg</td>
<td>Drawing files</td>
</tr>
<tr>
<td>.ldb</td>
<td>Drawing export layer properties</td>
</tr>
<tr>
<td>.ldr</td>
<td>Drawing link properties</td>
</tr>
<tr>
<td>.cs</td>
<td>Section mark properties</td>
</tr>
<tr>
<td>.detail</td>
<td>Detail mark properties</td>
</tr>
<tr>
<td>.fas</td>
<td>Text file properties</td>
</tr>
<tr>
<td>.fhl</td>
<td>Hyperlink properties</td>
</tr>
<tr>
<td>.dsf</td>
<td>Drawing selection filter properties. This file is saved when you select the <strong>Drawing --&gt; Selection filter</strong> check box in the <strong>Filter</strong> or <strong>Selection Filter</strong> properties.</td>
</tr>
<tr>
<td>.dg.DPM</td>
<td>Drawing snapshot files in the &lt;model&gt;\drawings\snapshots sub-folder. The files are created either automatically or based on a user request. To create a snapshot of a drawing automatically at the same time that you create the drawing, set the advanced option <code>XS_DRAWING_CREATE_SNAPSHOT_ON_DRAWING_CREATION</code> to <code>TRUE</code>. For more information about creating snapshots, see Snapshots in drawings.</td>
</tr>
</tbody>
</table>

**Files created in the \DataStorage\ref folder**

When a reference model is inserted or updated, reference model data is automatically copied to the `<current model>\DataStorage\ref folder`. There is no need to manually copy reference models to the model folder. Duplicated data can use a large amount of disk space and might make copying or sharing the model using Tekla Model Sharing unnecessarily slow.

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.trb</td>
<td>A TrimBIM file converted from the reference model file</td>
</tr>
<tr>
<td>File or file name extension</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>.ifc, .ifc4, .ifcZIP, .ifcXML, .tcZIP, .3dd, .dxf, .dwg, .dgn, .xml, .LandXML, .stp, .igs, .skp, .pdf</td>
<td>Reference model files in different formats</td>
</tr>
<tr>
<td>.logxml</td>
<td>Reference model import log</td>
</tr>
</tbody>
</table>

**Files created in the `\Plotfiles` folder**

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.pdf</td>
<td>Printed PDF files</td>
</tr>
<tr>
<td>.plt</td>
<td>Printed plotter files</td>
</tr>
<tr>
<td>.dwg</td>
<td>Drawing DWG files exported through <strong>Export drawings as DWG/DXF</strong>.</td>
</tr>
</tbody>
</table>

**Files created in the `\DGN` folder**

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.dgn</td>
<td>Files created through the <strong>3D DGN v8</strong> export.</td>
</tr>
</tbody>
</table>

**Files created in the `\Drawing Details` folder**

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.ddf</td>
<td>Details created in <strong>2D Library</strong> in drawings together with metadata.</td>
</tr>
</tbody>
</table>

**Files related to IFC export in the `\IFC` folder**

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.ifc, .ifcXML, and .ifcZIP</td>
<td>Exported IFC files</td>
</tr>
</tbody>
</table>

**Files related to NC (numerical control) in the `\DSTV_Profiles` folder**

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.nc1</td>
<td>NC (numerical control) files</td>
</tr>
</tbody>
</table>
### Files in the \ModelSharing folder

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ModelSharingService.key</td>
<td>Key file that is needed to share models in Tekla Model Sharing.</td>
</tr>
<tr>
<td>FileSharing.ini</td>
<td>File sharing settings in Tekla Model Sharing.</td>
</tr>
<tr>
<td>FileSharing.xml</td>
<td>File needed for file sharing in Tekla Model Sharing.</td>
</tr>
</tbody>
</table>

### Files in the \ProjectOrganizer folder

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.db</td>
<td>Created when the Organizer is opened for the first time. Contains all property template and category information used in the model. The database name shows the version of the database, such as ProjOrg000020.db.</td>
</tr>
<tr>
<td>.propertytemplate</td>
<td>Created when you export a property template from the Organizer.</td>
</tr>
<tr>
<td>.category</td>
<td>Created when you export a category from the Organizer.</td>
</tr>
</tbody>
</table>

### Files related to reports in the \Reports folder

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.xsr</td>
<td>Tekla Structures reports</td>
</tr>
</tbody>
</table>

### Files in the \SessionFileRepository folder

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Files in the SessionFileRepository folder</td>
<td>Backup copies of the files that are updated or deleted during a Tekla Model Sharing read in.</td>
</tr>
<tr>
<td>SessionFile.db</td>
<td>Database for managing model folder files in Tekla Model Sharing.</td>
</tr>
<tr>
<td>.storage</td>
<td>Configuration file for SessionFile.db.</td>
</tr>
</tbody>
</table>
**Files related to shapes in the \ShapeGeometries and \Shapes folders**

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.tez</td>
<td>Shape geometry descriptions in the \ShapeGeometries folder.</td>
</tr>
<tr>
<td>.xml</td>
<td>Shape descriptions in the Shapes folder.</td>
</tr>
</tbody>
</table>

**Files in the \screenshots folder**

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.png</td>
<td>Screenshot taken in Tekla Structures.</td>
</tr>
</tbody>
</table>

**Files related to Unitechnik export in the \UT_files folder**

<table>
<thead>
<tr>
<th>File or file name extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.uni</td>
<td>Exported Unitechnik files</td>
</tr>
</tbody>
</table>

**Files related to options and advanced options**

**About model-specific options and advanced options**

**NOTE** Changing an advanced option value in .ini files located outside of the model folder does not affect existing models.

You can only change model-specific advanced options in the Advanced Options dialog box or in the options.ini file located in the model folder. You cannot change model-specific advanced options in an options.ini file located in folders defined by the or advanced option.

When a new model is created, Tekla Structures reads the values of model-specific options and advanced options from the standard.opt file, and from the .ini files in a specific reading order (page 52). Tekla Structures creates the options_model.db and options_drawings.db databases, and the options.ini file in the model folder.

The .ini files are also read when you open an existing model, but only new advanced options that do not exist in the options_model.db or options_drawings.db database are inserted. For example, options that are not yet in the Advanced Options dialog box but that have been added in the software would be inserted.
When you change model-specific options or advanced options

- You can change model-specific advanced options only in the Advanced Options dialog box or in the options.ini file that is located in the model folder.

- You can change model-specific options only in the dialog box (page 111) dialog box manually or by loading standard.opt file values in the dialog box.

When you save your own model-specific settings in the Options by pressing Save, the standard.opt file is saved in the \attributes folder under the model folder.

- When you change a model-specific (page 132) option or advanced option, the settings are applied when you press OK or Apply.

- The updated model-specific option or advanced option settings are saved in options_model.db and options_drawings.db in the model folder when the model is saved.

- The options.ini file located in the folder also contains some special model-specific advanced options that can be updated, such as new advanced options that are not yet in the Advanced Options dialog box.

What happens when you change user-specific options or advanced options

- You can change user-specific advanced options in the Advanced Options dialog box or by editing the user.ini file.

- You can change user-specific options only in the Options dialog box manually or by loading standard.opt file values in the dialog box.

- When you change a user-specific (page 132) option or advanced option, the settings are saved when you press OK or Apply.

The settings are saved in the options.bin file in the ..\Users\<user> \AppData\Local\Trimble\Tekla Structures\<version> \UserSettings folder.

Create a list of advanced options and their values
To create a complete list of advanced options in a text file, click Write to file in the Advanced Options dialog box.

The list shows the name of the advanced option, current value and type.

For more information about the standard.opt file, see Standard.opt settings

Settings in the Options dialog box
The Options dialog box (File menu --> Settings --> Options) contains the current values for many Tekla Structures settings.
Check the settings before you start modeling and change them, if necessary.

The **model-specific** settings in this dialog box are saved in the `options_model.db` and `options_drawings.db` databases in the model folder, and the **user-specific** settings in `options.bin` in your local `<user>` folder. Changing user- or model-specific options in the **Options** dialog box does not require you to restart Tekla Structures.

You can also save your own settings by using the **Save** button. Then the `standard.opt` file is saved in the `\attributes` folder under model folder. You might want to copy this file to your firm folder. When you create a model, the `standard.opt` is read from the firm folder.

The options in the **Options** dialog box are described below.

### Clash check settings

Settings on this page are model-specific. Changing the settings does not require you to restart Tekla Structures.

Depending on how the objects selected for clash checking have been modeled, different clash check settings are used. For example, if you have modeled embeds as studs, steel parts, or reinforcing bars, respectively either bolt settings, part settings, or reinforcement settings are relevant.

**NOTE** Tekla Structures uses a hard-coded tolerance when checking clashes between native parts. If native parts overlap less than 0.25 mm, clashes are not reported.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Allowed penetration volume</strong></td>
<td>Defines the allowed clash check tolerance if small collisions are acceptable and can be ignored. If the clashing volume is smaller than the given value, the clash is not reported.</td>
</tr>
<tr>
<td><strong>Clash check between bolt and bolted part</strong></td>
<td>Defines whether the model is checked for clashes that occur between bolts and the related bolted parts. If you select <strong>Yes</strong>, Tekla Structures checks the bolts against the real geometry of the bolted part profiles including roundings, and using the real bolt dimensions.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Define the clash check clearance area for bolts</strong></td>
<td>Use to check if bolts collide with parts and if there is enough space to fix the bolts. Enter the clearance dimensions in relation to the bolt head or nut diameter ( d ) (the larger value), and the nut thickness ( t ). The clearance in front of the bolted parts is the same as the bolt length. If you do not enter a value, Tekla Structures uses the default value. If you clear the check boxes, the clearance is zero. If Tekla Structures cannot find the bolt head or nut diameter in the bolt catalog, it uses the shank diameter instead.</td>
</tr>
<tr>
<td><img src="image.png" alt="Diagram" /></td>
<td></td>
</tr>
<tr>
<td><strong>Exact solid weld clash check</strong></td>
<td>Defines whether the model is checked for duplicate and overlapping welds and for clashes that occur between welds and other objects (such as parts and bolts). If you select <strong>Yes</strong>, Tekla Structures checks the welds against other welds, against bolts, and against the real geometry of the part profiles including roundings, and using the weld solid dimensions with normal accuracy.</td>
</tr>
<tr>
<td><strong>Reinforcing bar vs steel part clearance (negative value to allow overlap)</strong></td>
<td>Defines the minimum clearance or the allowed overlap for reinforcing bars when they are checked against steel parts. To allow reinforcing bars to overlap steel parts and to ignore the ribs of bars, enter a negative value. The maximum overlap is the actual bar radius. Tekla Structures only checks the distance from bar side to part. Tekla Structures for users 113 Files for configuring Tekla Structures</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Structures does not check the distance from bar end to part. If you clear the check box, Tekla Structures does not check the clearance.</td>
<td></td>
</tr>
<tr>
<td>Reinforcing bar clearance (negative value to allow overlap)</td>
<td>Defines the minimum clearance or the allowed overlap for reinforcing bars when they are checked against other reinforcing bars. To allow reinforcing bars to overlap, enter a negative value. If you clear the check box, Tekla Structures does not check the clearance.</td>
</tr>
<tr>
<td>Reinforcing bar cover thickness</td>
<td>Defines the reinforcing bar cover thickness. Tekla Structures checks the cover thickness against the part that the reinforcing bar belongs to. Tekla Structures only checks the distance from bar side to part surface. Tekla Structures does not check the distance from bar end to part surface. If the bar penetrates a part surface, a clash is reported, even if the bar is completely inside a cast unit or pour. If you clear the check box, Tekla Structures does not check the cover thickness.</td>
</tr>
</tbody>
</table>

**Components settings**

Tekla Structures uses the information about the **Components** tab when it creates parts using system components.

Component properties defined in component dialog boxes override these settings. Tekla Structures only uses these settings if the corresponding boxes in the component dialog boxes are empty.

If you change components settings, Tekla Structures only applies the new settings to components that you create after you change the settings. Components that you created before you changed the settings are not affected.
**NOTE** In some cases, the new default part numbering settings can also affect the part numbers of components that you created before you changed the settings. For example, if you modify a component that was created before you changed the default part start numbers, the new default part start numbers are applied to the modified component.

Settings on this page are model-specific. Changing the settings does not require you to restart Tekla Structures.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Profile names</strong></td>
<td>Defines parametric profile prefixes for plates. It is important that profile names are set up correctly so that you can use filters and wizards effectively.</td>
</tr>
<tr>
<td></td>
<td>Profile names must exist in the profile catalog. If you want to use a parametric profile that does not have a name in the catalog, first add it to the Profile Catalog, then enter it here. Tekla Structures uses the Folded plate prefix when you use the folded plates in components.</td>
</tr>
<tr>
<td><strong>Bolts</strong></td>
<td>In components, Tekla Structures uses Factor of bolt edge distance and Compare edge distance to to check that the bolts it creates are not too close to the edge of a part, and warns you if they are. Check that Factor of bolt edge distance is set according to the standard you are using. The default edge distance setting depends on your environment. Compare edge distance defines whether the edge distance checks are based on bolt or hole diameter. To define the default bolt properties to use in connections, select a Bolt standard and Bolt size.</td>
</tr>
<tr>
<td><strong>Parts</strong></td>
<td><strong>Part material</strong> defines the default part material grade. <strong>Part start numbers</strong> defines start numbers for parts that are Welded to primary and Welded to secondary, Loose parts, and Assembly loose parts. Check the part numbering settings against the numbering series that you define to make sure that they do not overlap. If they overlap, Tekla Structures might create two non-identical parts with the same part number. This generates an error in the Numbering history log file.</td>
</tr>
</tbody>
</table>
### Drawing dimensions settings

Settings on this page are model-specific. Changing the settings does not require you to restart Tekla Structures.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Exaggeration</strong></td>
<td>This setting defines the default values for <strong>Exaggeration limit</strong> and <strong>Exaggeration scaling</strong>.</td>
</tr>
<tr>
<td></td>
<td>When you enable the exaggeration of the dimensions, a drawing dimension that is narrower than the defined limit is expanded. <strong>Exaggeration limit</strong> defines the default value for this limit.</td>
</tr>
<tr>
<td></td>
<td><strong>Exaggeration scaling</strong> defines whether you are using <strong>Paper</strong> or <strong>Model</strong> as the exaggeration scaling method:</td>
</tr>
<tr>
<td></td>
<td>• If you select <strong>Paper</strong>, the exaggeration limit is multiplied by the view scale.</td>
</tr>
<tr>
<td></td>
<td>• If you select <strong>Model</strong>, and the scale is 1:10, all the dimensions smaller than 10 mm are exaggerated regardless of the drawing scale.</td>
</tr>
<tr>
<td><strong>Absolute dimensions</strong></td>
<td><strong>Show zero in absolute dimensions</strong> --&gt; <strong>Yes</strong> shows zero at the zero points in absolute dimensions.</td>
</tr>
<tr>
<td></td>
<td><strong>Draw absolute dimension values parallel to dimension line</strong> --&gt; <strong>Yes</strong> shows dimensions parallel to dimension lines in absolute dimensions.</td>
</tr>
<tr>
<td><strong>Dimensions in tags</strong></td>
<td><strong>Units</strong>, <strong>Format</strong> and <strong>Precision</strong> define the default unit, format and precision used in dimension tags.</td>
</tr>
<tr>
<td></td>
<td>Available units: mm, cm, m, foot - inch, cm / m, inch, feet.</td>
</tr>
<tr>
<td></td>
<td>Available formats: ###, ###.[.#], ###.##, ###.[##], ###.[#], ###.[###], ###.[!], ###, #/# and #/##.</td>
</tr>
<tr>
<td></td>
<td>Available precision: 0.00, 0.50, 0.33, 0.25, 1/8, 1/16, 1/32, 1/10, 1/100, 1/1000.</td>
</tr>
<tr>
<td><strong>Show dimension in middle tag of automatic dimension</strong></td>
<td>Defines whether you want to create dual dimension tags in assembly, single-part, cast unit, or general arrangement drawings.</td>
</tr>
<tr>
<td></td>
<td>When Tekla Structures creates the drawing, it adds the lower dimension tag in the selected unit, format and precision.</td>
</tr>
</tbody>
</table>
**Dimension line**

- **Dimension line extension length for line arrow** defines the length of the line extension for dimensions that have line arrows.

  Note that line extensions are not applied to dimensions that have different arrows from line arrows, and certain knock-off dimension types.

---

**Drawing objects settings**

Settings on this page are model-specific. Changing the settings does not require you to restart Tekla Structures.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edge chamfer</td>
<td><strong>Line color</strong> defines the default line color of the edge chamfers in drawings.</td>
</tr>
<tr>
<td></td>
<td><strong>Line type</strong> defines the default line type of the edge chamfers in drawings.</td>
</tr>
<tr>
<td></td>
<td>These values are overridden by the values set in the Edge Chamfer Properties dialog box.</td>
</tr>
</tbody>
</table>

---

**General settings**

On this page, **Autosave** settings are user-specific. All other settings are model-specific. Changing the settings does not require you to restart Tekla Structures.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Autosave</strong></td>
<td><strong>Autosave interval:</strong> Autosave after every xx minutes defines the number of minutes after which Tekla Structures automatically saves the model.</td>
</tr>
<tr>
<td></td>
<td>Note that the time-based autosave interval does not apply to drawings.</td>
</tr>
<tr>
<td></td>
<td><strong>Autosave after creating every xx drawings</strong> defines the number of drawings after which Tekla Structures automatically saves your work.</td>
</tr>
<tr>
<td></td>
<td>For more information, see: Save a model, Autosaving in multi-user mode</td>
</tr>
<tr>
<td>Default adaptivity</td>
<td><strong>Off</strong> means that adaptivity is not defined.</td>
</tr>
<tr>
<td></td>
<td><strong>Relative</strong> defines that handles retain their relative distances to the nearest part faces in relation to the part's overall size.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Fixed</td>
<td>defines that handles retain their absolute distances to the nearest part faces. You can also modify the adaptivity settings for each part separately. These modifications override the default settings in the Options dialog box. For more information about adaptivity, see Modify the adaptivity of reinforcement, surface treatment, or edge chamfers in parts.</td>
</tr>
</tbody>
</table>

**Load modeling settings**

Use the settings on the **Arrow length** tab to scale loads in model views.

Use the settings on the other tabs of this page to define the building code and safety factors Tekla Structures uses in load combination.

- Settings on this page are model-specific. Changing the settings does not require you to restart Tekla Structures.
- You usually do not need to change the building code or safety factors during the project. If you change these settings, you must also change the load group types and check the load combinations.

**Numbering settings**

Settings on this page are model-specific. Changing the settings does not require you to restart Tekla Structures.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Position number separator</strong></td>
<td>Defines the default position number separator. The options are dot (.), comma (,), slash (/), and hyphen (-).</td>
</tr>
<tr>
<td><strong>Rebar position number separator</strong></td>
<td>Defines the default reinforcing bar position number separator. The options are dot (.), comma (,), slash (/), and hyphen (-).</td>
</tr>
<tr>
<td><strong>Part number type</strong></td>
<td>Defines the default part number type. The options are Part number and Combined assembly / part number.</td>
</tr>
</tbody>
</table>

**Orientation mark settings**

Settings on this page are model-specific. Changing the settings does not require you to restart Tekla Structures.

For details of what affects the part orientation and how, see Indicate part orientation.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>North direction</td>
<td>Project north (degrees counter clockwise from global x) defines which direction is north in the model. Enter the value in degrees counter-clockwise from the global x axis.</td>
</tr>
<tr>
<td>Part viewing direction</td>
<td>Defines which direction parts are viewed from in drawings.</td>
</tr>
<tr>
<td>Beam skew limit</td>
<td>Tekla Structures uses limit angles to determine whether a part is a beam or a column when creating orientation marks. Tekla Structures treats parts outside these limits as braces.</td>
</tr>
<tr>
<td>Column skew limit</td>
<td></td>
</tr>
<tr>
<td>Preferred location for mark</td>
<td>Defines the location of part marks in drawings, to the left or right end of the part.</td>
</tr>
<tr>
<td>Mark always to center of column</td>
<td>This setting only affects columns. Yes places part marks in the center of columns in plan views. To indicate part orientation, include compass direction (Face direction) in the part mark instead.</td>
</tr>
<tr>
<td></td>
<td>No places part marks on the same flange in general arrangement and assembly drawings.</td>
</tr>
</tbody>
</table>
**Rebar set settings**

Settings on this page are model-specific and only apply to rebar sets, not to single reinforcing bars, reinforcing bar groups, or reinforcement meshes. Changing the settings does not require you to restart Tekla Structures, but you must update the existing rebar sets in the model. To do this, go to the Rebar tab on the ribbon and click **More --> Regenerate.**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Concrete cover</strong></td>
<td>Under <strong>Part global coordinate system</strong>, define the default concrete cover thickness between the rebar set bars and the following faces of concrete parts:  &lt;br&gt;  • Top  &lt;br&gt;  • Bottom  &lt;br&gt;  • Sides  &lt;br&gt;  To use the parts' local coordinate system, under <strong>Part local coordinate system</strong>, define the default concrete cover thickness at the following faces of concrete parts:  &lt;br&gt;  • Top  &lt;br&gt;  • Bottom  &lt;br&gt;  • Front  &lt;br&gt;  • Back  &lt;br&gt;  • Start  &lt;br&gt;  • End  &lt;br&gt;  You can also define concrete cover settings for each concrete part separately. These modifications override the default settings in the <strong>Options</strong> dialog box.</td>
</tr>
<tr>
<td><strong>Layer prefix</strong></td>
<td>Under <strong>Part global coordinate system</strong> and/or <strong>Part local coordinate system</strong>, define the default bar layer prefixes at different faces of concrete parts.  &lt;br&gt;  You can also define bar layer settings for individual rebar sets or leg faces, or for individual bars using the user-defined attributes of property modifiers. These modifications override the default settings in the <strong>Options</strong> dialog box.</td>
</tr>
<tr>
<td><strong>Links</strong></td>
<td>Define the bar layer prefix for rebar set bars that have four or more legs, for example closed stirrups.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>General tab</strong></td>
<td></td>
</tr>
<tr>
<td>Minimum lengths to be created</td>
<td>Define <strong>Minimum bar length</strong> to prevent Tekla Structures from creating reinforcing bars that are too short. This setting is primarily for straight bars. Enter the minimum bar length as <strong>Distance</strong> or as <strong>Coefficient of bar diameter</strong>. Define <strong>Minimum straight start/end leg length</strong> for bent reinforcing bars. Enter the minimum leg length as <strong>Distance</strong> or as <strong>Coefficient of bar diameter</strong>. These settings are also available in the <strong>Rebar set</strong> properties and in the <strong>Rebar property modifier</strong> properties.</td>
</tr>
<tr>
<td><strong>Rounding and step tapering tab</strong></td>
<td></td>
</tr>
<tr>
<td>Rounding</td>
<td>Define whether the lengths of straight bars, first and last legs, and intermediate legs are rounded in the model, and whether the bar lengths are rounded up, down, or to the nearest suitable number according to the rounding accuracy. At splitter locations, define how much the bar lengths can be rounded up. Rounding settings are also available in the <strong>Rebar set</strong> properties and in the <strong>Rebar property modifier</strong> properties.</td>
</tr>
<tr>
<td>Step tapering</td>
<td>Define the tapering step values for straight bars, first and last legs, and intermediate legs. Step tapering settings are also available in the <strong>Rebar set</strong> properties and in the <strong>Rebar property modifier</strong> properties.</td>
</tr>
<tr>
<td><strong>Units and decimals settings</strong></td>
<td>Settings on this page are model-specific. Changing the settings does not require you to restart Tekla Structures. The number located to the right of</td>
</tr>
</tbody>
</table>

Customize Tekla Structures for users 121 Files for configuring Tekla Structures
each option indicates the number of decimals. The number of decimals affects the input and storage accuracy. Always use a sufficient number of decimals.

For more information about unit and decimal settings, see Change units and decimals (page 131).

<table>
<thead>
<tr>
<th>Option</th>
<th>Units</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Modeling tab</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Length</strong></td>
<td>mm, cm, m, in (decimal), ft (decimal), ft-in</td>
</tr>
<tr>
<td><strong>Angle</strong></td>
<td>°, rad</td>
</tr>
<tr>
<td><strong>Spring constant</strong></td>
<td>kg/m, kg/cm, kg/mm, kg/mm, T/m, T/cm, T/mm, N/m, N/cm, N/mm, daN/m</td>
</tr>
<tr>
<td>Option</td>
<td>Units</td>
</tr>
<tr>
<td>------------------------</td>
<td>----------------------------</td>
</tr>
<tr>
<td></td>
<td>daN/cm</td>
</tr>
<tr>
<td></td>
<td>daN/mm</td>
</tr>
<tr>
<td></td>
<td>kN/m</td>
</tr>
<tr>
<td></td>
<td>kN/cm</td>
</tr>
<tr>
<td></td>
<td>kN/mm</td>
</tr>
<tr>
<td></td>
<td>lbf/in</td>
</tr>
<tr>
<td></td>
<td>lbf/ft</td>
</tr>
<tr>
<td></td>
<td>kip/in</td>
</tr>
<tr>
<td></td>
<td>kip/ft</td>
</tr>
<tr>
<td>Rot. spring constant</td>
<td>kgm/rad</td>
</tr>
<tr>
<td></td>
<td>kgm/°</td>
</tr>
<tr>
<td></td>
<td>Tm/rad</td>
</tr>
<tr>
<td></td>
<td>TM/°</td>
</tr>
<tr>
<td></td>
<td>Nm/rad</td>
</tr>
<tr>
<td></td>
<td>Nm/°</td>
</tr>
<tr>
<td></td>
<td>daNm/rad</td>
</tr>
<tr>
<td></td>
<td>daNm/°</td>
</tr>
<tr>
<td></td>
<td>kNm/rad</td>
</tr>
<tr>
<td></td>
<td>kNm/°</td>
</tr>
<tr>
<td></td>
<td>lbf-in/rad</td>
</tr>
<tr>
<td></td>
<td>lbf-in/°</td>
</tr>
<tr>
<td></td>
<td>lbf-ft/rad</td>
</tr>
<tr>
<td></td>
<td>lbf-ft/°</td>
</tr>
<tr>
<td></td>
<td>kip-in/rad</td>
</tr>
<tr>
<td></td>
<td>kip-in/°</td>
</tr>
<tr>
<td></td>
<td>kip-ft/rad</td>
</tr>
<tr>
<td></td>
<td>kip-ft/°</td>
</tr>
<tr>
<td>Factor</td>
<td>(no units)</td>
</tr>
<tr>
<td>Force</td>
<td>kg</td>
</tr>
<tr>
<td></td>
<td>T</td>
</tr>
<tr>
<td></td>
<td>N</td>
</tr>
<tr>
<td></td>
<td>daN</td>
</tr>
<tr>
<td></td>
<td>kN</td>
</tr>
<tr>
<td>Option</td>
<td>Units</td>
</tr>
<tr>
<td>------------------------</td>
<td>----------------------</td>
</tr>
<tr>
<td></td>
<td>lbf</td>
</tr>
<tr>
<td></td>
<td>kip</td>
</tr>
<tr>
<td><strong>Distributed load</strong></td>
<td>kg/m</td>
</tr>
<tr>
<td></td>
<td>T/m</td>
</tr>
<tr>
<td></td>
<td>N/m</td>
</tr>
<tr>
<td></td>
<td>daN/m</td>
</tr>
<tr>
<td></td>
<td>kN/m</td>
</tr>
<tr>
<td></td>
<td>lbf/in</td>
</tr>
<tr>
<td></td>
<td>lbf/ft</td>
</tr>
<tr>
<td></td>
<td>kip/in</td>
</tr>
<tr>
<td></td>
<td>kip/ft</td>
</tr>
<tr>
<td><strong>Surface load</strong></td>
<td>kg/m²</td>
</tr>
<tr>
<td></td>
<td>T/m²</td>
</tr>
<tr>
<td></td>
<td>N/m²</td>
</tr>
<tr>
<td></td>
<td>daN/m²</td>
</tr>
<tr>
<td></td>
<td>kN/m²</td>
</tr>
<tr>
<td></td>
<td>psi</td>
</tr>
<tr>
<td></td>
<td>psf</td>
</tr>
<tr>
<td></td>
<td>ksi</td>
</tr>
<tr>
<td></td>
<td>ksf</td>
</tr>
<tr>
<td><strong>Moment</strong></td>
<td>kgm</td>
</tr>
<tr>
<td></td>
<td>Tm</td>
</tr>
<tr>
<td></td>
<td>Nm</td>
</tr>
<tr>
<td></td>
<td>daNm</td>
</tr>
<tr>
<td></td>
<td>kNm</td>
</tr>
<tr>
<td></td>
<td>lbf-in</td>
</tr>
<tr>
<td></td>
<td>lbf-ft</td>
</tr>
<tr>
<td></td>
<td>kip-in</td>
</tr>
<tr>
<td></td>
<td>kip-ft</td>
</tr>
<tr>
<td><strong>Distributed moment</strong></td>
<td>kgm/m</td>
</tr>
<tr>
<td></td>
<td>Tm/m</td>
</tr>
<tr>
<td></td>
<td>Nm/m</td>
</tr>
<tr>
<td></td>
<td>daNm/m</td>
</tr>
<tr>
<td>Option</td>
<td>Units</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------</td>
</tr>
<tr>
<td></td>
<td>kN/m/m</td>
</tr>
<tr>
<td></td>
<td>lbf-ft/ft</td>
</tr>
<tr>
<td></td>
<td>kip-ft/ft</td>
</tr>
<tr>
<td>Temperature</td>
<td>°C</td>
</tr>
<tr>
<td></td>
<td>°F</td>
</tr>
<tr>
<td></td>
<td>°K</td>
</tr>
<tr>
<td>Deformation</td>
<td>mm</td>
</tr>
<tr>
<td></td>
<td>cm</td>
</tr>
<tr>
<td></td>
<td>m</td>
</tr>
<tr>
<td></td>
<td>in (decimal)</td>
</tr>
<tr>
<td></td>
<td>ft (decimal)</td>
</tr>
<tr>
<td></td>
<td>ft-in</td>
</tr>
<tr>
<td>Catalogs tab</td>
<td></td>
</tr>
<tr>
<td>Section dimension</td>
<td>mm</td>
</tr>
<tr>
<td></td>
<td>cm</td>
</tr>
<tr>
<td></td>
<td>m</td>
</tr>
<tr>
<td></td>
<td>in (decimal)</td>
</tr>
<tr>
<td></td>
<td>ft (decimal)</td>
</tr>
<tr>
<td></td>
<td>in</td>
</tr>
<tr>
<td></td>
<td>ft-in</td>
</tr>
<tr>
<td>Angle</td>
<td>°</td>
</tr>
<tr>
<td></td>
<td>rad</td>
</tr>
<tr>
<td>Area</td>
<td>mm²</td>
</tr>
<tr>
<td></td>
<td>cm²</td>
</tr>
<tr>
<td></td>
<td>m²</td>
</tr>
<tr>
<td></td>
<td>in²</td>
</tr>
<tr>
<td></td>
<td>ft²</td>
</tr>
<tr>
<td>Section modulus</td>
<td>mm³</td>
</tr>
<tr>
<td></td>
<td>cm³</td>
</tr>
<tr>
<td></td>
<td>m³</td>
</tr>
<tr>
<td></td>
<td>in³</td>
</tr>
<tr>
<td></td>
<td>ft³</td>
</tr>
<tr>
<td>Option</td>
<td>Units</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>Moment of inertia</td>
<td>mm$^4$</td>
</tr>
<tr>
<td></td>
<td>cm$^4$</td>
</tr>
<tr>
<td></td>
<td>in$^4$</td>
</tr>
<tr>
<td>Radius of inertia</td>
<td>mm</td>
</tr>
<tr>
<td></td>
<td>cm</td>
</tr>
<tr>
<td></td>
<td>m</td>
</tr>
<tr>
<td></td>
<td>in (decimal)</td>
</tr>
<tr>
<td></td>
<td>ft (decimal)</td>
</tr>
<tr>
<td></td>
<td>ft-in</td>
</tr>
<tr>
<td>Torsion constant</td>
<td>mm$^4$</td>
</tr>
<tr>
<td></td>
<td>cm$^4$</td>
</tr>
<tr>
<td></td>
<td>in$^4$</td>
</tr>
<tr>
<td>Warping constant</td>
<td>mm$^6$</td>
</tr>
<tr>
<td></td>
<td>cm$^6$</td>
</tr>
<tr>
<td></td>
<td>in$^6$</td>
</tr>
<tr>
<td>Cover area</td>
<td>m$^2$/m</td>
</tr>
<tr>
<td></td>
<td>mm$^2$/m</td>
</tr>
<tr>
<td></td>
<td>cm$^2$/m</td>
</tr>
<tr>
<td></td>
<td>ft$^2$/ft</td>
</tr>
<tr>
<td></td>
<td>in$^2$/ft</td>
</tr>
<tr>
<td></td>
<td>in$^2$/in</td>
</tr>
<tr>
<td>Strength</td>
<td>kg/m$^2$</td>
</tr>
<tr>
<td></td>
<td>kg/cm$^2$</td>
</tr>
<tr>
<td></td>
<td>kg/mm$^2$</td>
</tr>
<tr>
<td></td>
<td>T/m$^2$</td>
</tr>
<tr>
<td></td>
<td>T/cm$^2$</td>
</tr>
<tr>
<td></td>
<td>T/mm$^2$</td>
</tr>
<tr>
<td></td>
<td>N/m$^2$</td>
</tr>
<tr>
<td></td>
<td>N/cm$^2$</td>
</tr>
<tr>
<td></td>
<td>N/mm$^2$</td>
</tr>
<tr>
<td></td>
<td>daN/m$^2$</td>
</tr>
<tr>
<td>Option</td>
<td>Units</td>
</tr>
<tr>
<td>----------</td>
<td>----------------</td>
</tr>
<tr>
<td></td>
<td>daN/cm$^2$</td>
</tr>
<tr>
<td></td>
<td>daN/mm$^2$</td>
</tr>
<tr>
<td></td>
<td>kN/m$^2$</td>
</tr>
<tr>
<td></td>
<td>kN/cm$^2$</td>
</tr>
<tr>
<td></td>
<td>kn/mm$^2$</td>
</tr>
<tr>
<td></td>
<td>psi</td>
</tr>
<tr>
<td></td>
<td>psf</td>
</tr>
<tr>
<td></td>
<td>ksi</td>
</tr>
<tr>
<td></td>
<td>ksf</td>
</tr>
<tr>
<td>Modulus</td>
<td>kg/m$^2$</td>
</tr>
<tr>
<td></td>
<td>kg/cm$^2$</td>
</tr>
<tr>
<td></td>
<td>kg/mm$^2$</td>
</tr>
<tr>
<td></td>
<td>T/m$^2$</td>
</tr>
<tr>
<td></td>
<td>T/cm$^2$</td>
</tr>
<tr>
<td></td>
<td>T/mm$^2$</td>
</tr>
<tr>
<td></td>
<td>N/m$^2$</td>
</tr>
<tr>
<td></td>
<td>N/cm$^2$</td>
</tr>
<tr>
<td></td>
<td>N/mm$^2$</td>
</tr>
<tr>
<td></td>
<td>daN/m$^2$</td>
</tr>
<tr>
<td></td>
<td>daN/cm$^2$</td>
</tr>
<tr>
<td></td>
<td>daN/mm$^2$</td>
</tr>
<tr>
<td></td>
<td>kN/m$^2$</td>
</tr>
<tr>
<td></td>
<td>kN/cm$^2$</td>
</tr>
<tr>
<td></td>
<td>kN/mm$^2$</td>
</tr>
<tr>
<td></td>
<td>psi</td>
</tr>
<tr>
<td></td>
<td>psf</td>
</tr>
<tr>
<td></td>
<td>ksi</td>
</tr>
<tr>
<td></td>
<td>ksf</td>
</tr>
<tr>
<td>Density</td>
<td>kg/m$^3$</td>
</tr>
<tr>
<td></td>
<td>T/m$^3$</td>
</tr>
<tr>
<td></td>
<td>N/m$^3$</td>
</tr>
<tr>
<td>Option</td>
<td>Units</td>
</tr>
<tr>
<td>----------------</td>
<td>-------</td>
</tr>
<tr>
<td><strong>Option</strong></td>
<td>kN/m³</td>
</tr>
<tr>
<td></td>
<td>lbf/ft³</td>
</tr>
<tr>
<td><strong>Weight</strong></td>
<td>kg</td>
</tr>
<tr>
<td></td>
<td>T</td>
</tr>
<tr>
<td></td>
<td>N</td>
</tr>
<tr>
<td></td>
<td>lbf</td>
</tr>
<tr>
<td></td>
<td>kip</td>
</tr>
<tr>
<td><strong>Strain</strong></td>
<td>o/oo</td>
</tr>
<tr>
<td></td>
<td>%</td>
</tr>
<tr>
<td></td>
<td>(No units)</td>
</tr>
<tr>
<td><strong>Thermal dilat. coeff.</strong></td>
<td>1/°C</td>
</tr>
<tr>
<td></td>
<td>1/°F</td>
</tr>
<tr>
<td></td>
<td>1/°K</td>
</tr>
<tr>
<td><strong>Ratio</strong></td>
<td>o/oo</td>
</tr>
<tr>
<td></td>
<td>%</td>
</tr>
<tr>
<td></td>
<td>(No units)</td>
</tr>
<tr>
<td><strong>Volume</strong></td>
<td>mm³</td>
</tr>
<tr>
<td></td>
<td>cm³</td>
</tr>
<tr>
<td></td>
<td>m³</td>
</tr>
<tr>
<td></td>
<td>in³</td>
</tr>
<tr>
<td></td>
<td>ft³</td>
</tr>
<tr>
<td><strong>Analysis results tab</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Length</strong></td>
<td>mm</td>
</tr>
<tr>
<td></td>
<td>cm</td>
</tr>
<tr>
<td></td>
<td>m</td>
</tr>
<tr>
<td></td>
<td>in (decimal)</td>
</tr>
<tr>
<td></td>
<td>ft (decimal)</td>
</tr>
<tr>
<td></td>
<td>ft-in</td>
</tr>
<tr>
<td><strong>Angle</strong></td>
<td>°</td>
</tr>
<tr>
<td></td>
<td>rad</td>
</tr>
<tr>
<td><strong>Reinforcement area</strong></td>
<td>mm²</td>
</tr>
<tr>
<td></td>
<td>cm²</td>
</tr>
<tr>
<td></td>
<td>m²</td>
</tr>
<tr>
<td>Option</td>
<td>Units</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------------</td>
</tr>
<tr>
<td></td>
<td>in²</td>
</tr>
<tr>
<td></td>
<td>ft²</td>
</tr>
<tr>
<td>Transverse reinforc.</td>
<td>m²/m</td>
</tr>
<tr>
<td></td>
<td>mm²/m</td>
</tr>
<tr>
<td></td>
<td>cm²/m</td>
</tr>
<tr>
<td></td>
<td>ft²/ft</td>
</tr>
<tr>
<td></td>
<td>in²/ft</td>
</tr>
<tr>
<td></td>
<td>in²/in</td>
</tr>
<tr>
<td>Weight</td>
<td>kg</td>
</tr>
<tr>
<td></td>
<td>T</td>
</tr>
<tr>
<td></td>
<td>N</td>
</tr>
<tr>
<td></td>
<td>lbf</td>
</tr>
<tr>
<td></td>
<td>kip</td>
</tr>
<tr>
<td>Mass/Length</td>
<td>kg/m</td>
</tr>
<tr>
<td></td>
<td>T/m</td>
</tr>
<tr>
<td></td>
<td>N/m</td>
</tr>
<tr>
<td></td>
<td>daN/m</td>
</tr>
<tr>
<td></td>
<td>kN/m</td>
</tr>
<tr>
<td></td>
<td>lbf/ft</td>
</tr>
<tr>
<td>Volume</td>
<td>mm³</td>
</tr>
<tr>
<td></td>
<td>cm³</td>
</tr>
<tr>
<td></td>
<td>m³</td>
</tr>
<tr>
<td></td>
<td>in³</td>
</tr>
<tr>
<td></td>
<td>ft³</td>
</tr>
<tr>
<td>Force</td>
<td>kg</td>
</tr>
<tr>
<td></td>
<td>T</td>
</tr>
<tr>
<td></td>
<td>N</td>
</tr>
<tr>
<td></td>
<td>daN</td>
</tr>
<tr>
<td></td>
<td>kN</td>
</tr>
<tr>
<td></td>
<td>lbf</td>
</tr>
<tr>
<td></td>
<td>kip</td>
</tr>
<tr>
<td>Option</td>
<td>Units</td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Distributed load</td>
<td>kg/m, T/m, N/m, daN/m, kN/m, lbf/in, lbf/ft, kip/in, kip/ft</td>
</tr>
<tr>
<td>Surface load</td>
<td>kg/m², T/m², N/m², daN/m², kN/m², psi, psf, ksi, ksf</td>
</tr>
<tr>
<td>Moment</td>
<td>kgm, Tm, Nm, daNm, kNm, lbf-in, lbf-ft, kip-in, kip-ft</td>
</tr>
<tr>
<td>Temperature</td>
<td>°C, °F, °K</td>
</tr>
<tr>
<td>Stress</td>
<td>kg/m², kg/cm²</td>
</tr>
<tr>
<td>Option</td>
<td>Units</td>
</tr>
<tr>
<td>------------</td>
<td>---------------------</td>
</tr>
<tr>
<td></td>
<td>kg/mm² &lt;br&gt; T/m² &lt;br&gt; T/cm² &lt;br&gt; T/mm² &lt;br&gt; N/m² &lt;br&gt; N/cm² &lt;br&gt; N/mm² &lt;br&gt; daN/m² &lt;br&gt; daN/cm² &lt;br&gt; daN/mm² &lt;br&gt; kN/m² &lt;br&gt; kN/cm² &lt;br&gt; kn/mm² &lt;br&gt; psi &lt;br&gt; psf &lt;br&gt; ksi &lt;br&gt; ksf</td>
</tr>
<tr>
<td>Deformation</td>
<td>mm &lt;br&gt; cm &lt;br&gt; m &lt;br&gt; in (decimal) &lt;br&gt; ft (decimal) &lt;br&gt; ft-in</td>
</tr>
</tbody>
</table>

**Change units and decimals**

You can define which units and how many decimals Tekla Structures uses. The settings are model-specific. Note that these settings do not have any effect on drawings or reports, or on the Inquire and Measure tools.

1. On the **File** menu, click **Settings --> Options**, and go to the **Units and decimals** settings.
2. Modify the units and decimals to suit your needs.
The number located to the right of each option indicates the number of decimals. The number of decimals affects the input and storage accuracy. Always use a sufficient number of decimals.

- The settings on the **Modeling** tab affect the data that is used when you are modeling, for example copying, moving, creating grids, creating points, and so on.
- The settings on the **Catalogs** tab affect the profile and material data, for example catalogs.
- The settings on the **Analysis results** tab affect the output data. **Reinforcement area** and **Mass/Length** also affect cross section area and weight per unit length in the rebar catalog (page 348).
- The settings on the **MEP** tab affect the data that is used in mechanical, electrical, and plumbing design and construction.

3. Click **OK** to save the changes.

**See also**

*Settings in the Options dialog box (page 111)*

**Settings defined by advanced options**

Advanced options can be specific to the user, model, system, or role.

**User-specific advanced options**

User-specific advanced options work in the specified way in all of your models and are saved in your local options.bin file. By default, this file is located in C:\Users\<user>\AppData\Local\Trimble\Tekla Structures \<version>\UserSettings. The folder can be changed using the advanced option.

In the **Advanced Options** dialog box, the type is **USER**. Some user-specific advanced options require you to restart Tekla Structures after changing the value.

**Model-specific advanced options**

Model-specific advanced options work in the specified way only in the current model. They are saved to options_model.db and options_drawings.db files in the model folder.

In the **Advanced Options** dialog box, the type is **MODEL** or **DRAWING**. Some special model-specific options that are not visible in the **Advanced Options** dialog box can be changed in the options.ini file in the model folder.
System-specific advanced options

System-specific advanced options are general to all sessions of Tekla Structures, and work in the specified way for all users and in all models.

In the Advanced Options dialog box, the type is SYSTEM. A system-specific advanced option can be stored to options database by clicking SYSTEM next to the option and changing it to MODEL(SYSTEM). Note that the changed value only works for the current model. A MODEL(SYSTEM) advanced option can be changed back to SYSTEM by changing it to SYSTEM, and in this case it will be removed from the options database. Some system-specific advanced options require restarting of Tekla Structures after changing the value.

The system-specific advanced options are read from environment .ini files:

- **Global system settings** are read from common env_global_default.ini (page 57) in ..\ProgramData\Trimble\Tekla Structures\<version>\environments\common\. These settings are used in all environments.

- **Environment-specific system settings** are read from env_<environment>.ini (page 58) in your environment folder. They override any settings that are defined on a global level in env_global_default.ini.

- **Role-specific system settings** are read from role_<role>.ini (page 58) in environment folder. They override any settings that are defined on a global and environment level in env_global_default.ini and env_<environment>.ini.

- **Company level system-specific system settings** override all other system-specific advanced options. You can save them in the firm or project folders by setting the folders for the advanced options XS_FIRM and XS_PROJECT.

For more information about how the environment .ini files are read, see Typical initialization files (.ini files) and their reading order (page 52).

SYSTEM(ROLE) advanced options

SYSTEM(ROLE) options are typically role specific. The settings are read from .ini files and are not saved to the databases. When a setting or the type is changed, the option becomes model-specific and is saved to the databases.

MODEL(ROLE) and DRAWING(ROLE) options are SYSTEM(ROLE) options for which the type or settings have been changed. The change would be used when you want the SYSTEM(ROLE) option to be saved with the model to options_model.db and options_drawings.db under model folder. These settings can be set back to SYSTEM(ROLE), which will then take into use the default value.

See also

Typical initialization files (.ini files) and their reading order (page 52)
Tekla Structures settings in the Windows registry
The Windows registry stores configuration settings and options in Microsoft Windows operating systems. Registry settings are used during Tekla Structures sessions and during Tekla Structures installation.

WARNING  Do not change the registry settings. Changing the settings can cause the operating system to fail. It is possible to view the registry settings using the Registry Editor in Windows.

User settings in the Windows registry
Some of the Tekla Structures user settings, such as general options, and dialog box locations and sizes are stored in the registry.

The settings are saved in a registry key named after the Tekla Structures version number in the registry branch HKEY_CURRENT_USER\Software \Trimble\Tekla Structures\<VERSION>.

When you start Tekla Structures for the first time after the installation, Tekla Structures uses the hardcoded default settings. If you change a setting during a Tekla Structures session, Tekla Structures saves the change during the session, or when you exit Tekla Structures. When you open the same version of Tekla Structures again, the changed setting is used.

When upgrading to a newer Tekla Structures version, you can use the Migration Wizard tool to copy the settings that you have changed.

Installation settings in the Windows registry
The Tekla Structures installation saves information to the HKEY_LOCAL_MACHINE\SOFTWARE\Trimble\Tekla Structures \<VERSION> registry key.

3.8 Develop applications using Tekla Open API
You can develop your own applications and additional features for Tekla Structures through the Tekla Open API (application programming interface). The Tekla Open API is implemented using Microsoft .NET technology.

Applications that are developed using the Tekla Open API to work with Tekla Structures are called extensions. To develop your own extensions, you must write program code outside Tekla Structures. Alternatively, you can download extensions created by others from Tekla Warehouse.

With Tekla Open API you can:
• Record and run user interface actions
  By recording and running user interface actions, you can automate routine tasks, such as creating daily reports.

• Create automation tools
  You can create automation tools for frequently needed objects. For example, with automation tools you can create basic structures or add typical details to drawings.

• Integrate Tekla Structures with other software
  You can use the Tekla Open API and .NET to transfer information between Tekla Structures and other software, such as Analysis & Design software.

• Create new functionality.

For more information about the Tekla Open API and extensions, visit the Tekla Developer Center. Tekla Open API documentation in the Tekla Developer Center includes:
• API reference
• Release notes
• Programming guides
• Exercises
• Code examples
• Best practices
4 Start new projects as a Tekla Structures administrator

Check and customize settings when you start new projects.

4.1 Start the first project

Before you start the first project, plan the project needs and collect the needed resources for the project.

- Set up the Project and firm folders (page 16) to store your customized settings.
  - Use the project folder to store all project-specific files, such as drawing title block content, or specific custom tools and settings that should not be used for the entire company. Define the location of the folder using the advanced option in the settings for all users.
  - Use the firm folder and its sub-folders to store all general company-specific files. Define the location of the folder using the advanced option in the settings for all users.

- Plan your company's modeling guidelines.
- Plan the numbering guidelines.
- Set up and import a reference model.
- Define the project properties so that reports and drawings show the correct information.
- Set up Templates (page 151).
- Plan how users will share models and data. See Set up a project for collaboration and interoperability (page 205).
- Check the material, profile, shape, bolt, and rebar needs for your project. Plan how you will Customize catalogs and databases (page 243) to suit your project needs.
If necessary, you can add new content to the catalogs from other environments, from Tekla Warehouse, or you can import content created in other software solutions.

You can optionally also set up a component folder in the Applications & components catalog to ensure that everyone in the project uses the same components and finds the components faster.

4.2 Start new projects

When you start new projects, check the project settings that you have previously defined and update them if necessary.

- Set up a new project folder and update the location of the folder for users using the advanced option.
- Reuse files and settings from previous projects or Tekla Structures versions (page 137).

Settings stored in the Project and firm folders (page 16) are used automatically when you start a new project. You can optionally transfer other files and settings to the new project manually.

- Check and update the project properties. See .
- Update your company's modeling guidelines document if your company has started to use any new practices after the previous project.
- Check the material, profile, shape, bolt, and rebar needs for your project. Clean up the catalogs and databases so that they contain the relevant content for your project. See Customize catalogs and databases (page 243).

4.3 Define project properties

Project information is needed many times during a project. Define the project information at the beginning of a project so that reports and drawings show the correct information automatically.

You can also update the project properties during the project. See .

1. On the File menu, click Project properties.
2. Edit the project properties.

   When you edit the properties, Tekla Structures highlights the modified properties in yellow.

3. Click Modify to apply the changes.
4.4 Reuse files and settings from previous projects or Tekla Structures versions

You can transfer customized files and settings from a previous project or Tekla Structures version to reuse them in a new project or Tekla Structures version.

If you use project and firm folders (page 16) to store customized settings, the settings are used automatically when you start a new project or upgrade to a new Tekla Structures version.

If you do not use project and firm folders, you must manually transfer the customized settings to the new project or the new Tekla Structures version.

Check advanced options for the project and firm folders

If you use project and firm folders to store customized files for a model, check that advanced options point to the folders where the customized files are located.

1. On the File menu, select Settings --> Advanced Options.
2. Check that the XS_FIRM, XS_PROJECT and XS_COMPANY_SETTINGS_DIRECTORY point to the correct folders.

Manually transfer files and settings to a new project

You can copy many types of files using a local or private online Tekla Warehouse collection. See the Tekla Warehouse instructions for more information.

You can also copy some information automatically to the new version using the Migration Wizard tool.

1. Check at least the following files and settings:
   - Advanced options (page 110)
   - Files (page 47) related to templates, reports and drawings
   - Catalog files (page 73): profile catalog, material catalog, bolt catalog, bolt assembly catalog, rebar shape catalog
   - Conversion files (page 214)
   - NC export settings
   - Printer catalog settings
   - User-defined attributes
   - Saved model object properties
2. Re-install extensions for the new Tekla Structures version.
Import Tekla Structures model and drawings into another model

You can use the **Import model** command to import a Tekla Structures model and drawings to another model. If the imported model is later updated, you can re-import the updated model.

You can use the **Import model** command if you want to:

- Import the model into a new blank model due to some issues in the model, such as when:
  - The model is corrupt.
  - There are corrupt parts in the model.
  - The model will not open.
  - A specific function causes an application error, such as numbering or creating a drawing.
- Merge models.
- Bring an older project into a new Tekla Structures version.

Some things to consider before importing:

- The import only works in one direction. It cannot be used for two-directional data exchange. For that we recommend using Tekla Model Sharing.
- If you import into an existing model, fix the possible numbering conflicts by adding prefixes in the numbering series.
- You cannot import models from older versions of Tekla Structures directly into a newer version. You must open the model for upgrade.
- You can use the **Import model** command as a replacement for the old model dump import. Import the model into an empty Tekla Structures model created without a model template.
- It is not possible to import a model or parts of it directly into the same model (for example, if the model folder has been copied in the file system and then worked on separately). You can work around this, for example, by first importing the model into a new empty model or by using the **Save as** command to create a copy of the model.
- The **Import model** command only imports the model and the drawings. It does not import attribute files, or database files, because those files might be the cause for the problems in the model.
- A log is created at the model import. You can use the advanced option XS_IMPORT_MODEL_LOG to control whether a new log is created every time you import a model, or if the log entries are appended to the existing log.
1. Open the Tekla Structures model into which you want to import the other model.

2. Go to Quick Launch, start typing import model, then select the Import model command from the list that appears.

3. Select a model folder to import, then click OK.

If you open a model from a previous Tekla Structures version, the following message is shown:

To open and save the model in the new version, click Open for upgrade.
The model objects and drawings are imported, and the changes are shown using the same listing as is used in Tekla Model Sharing.

With default settings, the **Locked** attribute is set to **Yes** in the imported objects. Locking is controlled by the advanced option `XS_MODEL_IMPORT_LOCK_OBJECTS` in the **Import** category of the **Advanced options** dialog box.

### 4.5 Define and update user-defined attributes (UDAs)

User-defined attributes (UDAs) are attributes that you can set for an object in a model or a drawing. You can use UDAs for many purposes, such as in filters, drawings, reports, export, import, fabrication, erection, and revision handling.

The property pane and many dialog boxes contain UDAs for various objects, including beams, columns, bolts and drawings. Tekla Structures shows these...
fields when you click the More button in the property pane or the User-defined attributes button in a dialog box.

When you define new user-defined attributes
You can create your own user-defined attributes that you need in your company, or for a specific project.

The user-defined attributes can be numbers, text, lists of options, or dates. They can be set to be unique for an object or allowed to be copied. They can also be ignored by numbering or can affect numbering.

User-defined attributes are managed in objects.inp files. To define new user-defined attributes, create your own objects.inp file in the model, project, or firm folder.

For more information about the contents of the objects.inp file, see Properties of the objects.inp file.

WARNING Do not copy the global objects.inp file in the ..\environments\common\inp\ folder. Copying the file creates unnecessary duplicates and later objects.inp updates by Tekla Structures can be lost.

Best practice for user-defined attribute names
Follow these best practices for user-defined attribute names.
• User-defined attribute names must be unique. Make sure that the global objects.inp file does not already use the same attribute name.

• For project-specific user-defined attributes, add the prefix P_ before the user-defined attribute name. For example, P_RESP_DESIGNER.

• The maximum length for a user-defined attribute name is 19 characters. Tekla Structures only looks for the first 19 characters. For example, Tekla Structures does not consider TEST_ATTRIBUTE_OBJECT and TEST_ATTRIBUTE_OBJECT1 to be different.

• User-defined attribute names are case-sensitive.

• Do not use spaces or reserved characters in attribute names.

Best practices for user-defined attribute definitions
Follow these best practices for user-defined attribute definitions.

• The definition of the user-defined attribute must be unique. A user-defined attribute cannot have different definitions for different object types, such as beams and columns.

• After adding your own user-defined attributes, run the Diagnose and change attribute definitions command to update the definitions in the model.

Best practices for user-defined attribute translations
For user-defined attributes that will be translated, add the prefix j_ before the label text in the objects.inp file.

Example:

```plaintext
attribute("releases", "j_MomentConnection", label, "%s", no, none, "0.0", "0.0", 30, 310)
```

Add the strings to be translated to the relevant .ail message files. For more information, see Customize user interface text in message files (page 68).

Search order of objects.inp files
User-defined attributes are defined in objects.inp files. These files are located in different folders following the Tekla Structures folder setup, and they are merged together during startup.
The objects.inp file reads the user-defined attributes in order from the folders listed below, starting from the model folder:

<table>
<thead>
<tr>
<th>Folder defined by advanced option</th>
<th>Advanced option</th>
</tr>
</thead>
<tbody>
<tr>
<td>Model</td>
<td>Current model folder</td>
</tr>
<tr>
<td>Project</td>
<td>XS_PROJECT (your defined project folder)</td>
</tr>
<tr>
<td>Firm</td>
<td>XS_FIRM (your defined firm folder)</td>
</tr>
<tr>
<td>System</td>
<td>XS_SYSTEM (your defined system folder)</td>
</tr>
<tr>
<td>inp</td>
<td>XS_INP (your defined inp folder)</td>
</tr>
</tbody>
</table>

The files are merged so that if there are user-defined attributes in any of the files, they are shown in the user interface. Tekla Structures merges the files so that duplicate attributes are removed. If Tekla Structures encounters the same attribute name in different objects.inp files, the attribute from the first read objects.inp file is used.

If you need to have several objects.inp files in the same folder, you can use a suffix in the file name to use all the files. This way you can have several objects_<suffix>.inp files in the same folder. For example, a file name with a suffix could be objects_precast.inp.

**If you need to change existing user-defined attribute definitions**

If you need to change the existing user-defined attributes, such as changing the value_type, create a new user-defined attribute instead of modifying the current one in the objects.inp file. For example, if you change the value_type from string to option, the value cannot be changed for parts that have the property specified with the old value type, and the value is shown incorrectly in reports or when you inquire objects.

When the advanced option XS_DIAGNOZE_AND_REPAIR_WRONG_UDA_TYPE is set to TRUE, you can use Diseagnose & repair --> Diagnose and change attribute definitions to detect and repair the incorrect UDA value types by reverting the value types to the default values. The command checks that the UDA value types, such as string or option, defined in the objects.inp file match their values defined in environment.db. A mismatch can happen if you change the value types after the UDA values have been assigned.

**Update definitions of user-defined attributes (UDAs) in a model**

When you have changed definitions of a user-defined attribute by modifying the objects.inp file, update the definitions in the model.
1. Open the model.
2. On the File menu, click Diagnose & repair.
3. In the Utilities section, click Diagnose and change attribute definitions.

   The Diagnose & Change Attribute Definitions dialog box opens.
4. Select an attribute from the list on left side to see the comparison of current definitions and objects.inp definitions.
5. In the Object classes with Objects.inp differences compared to current settings list, select the definitions that you want to update.
6. Click Change current settings to selected Objects.inp settings.

Environment database file
To ensure consistent model behavior when a model is used with different roles, the environment database file (environment.db) contains the definitions of the user-defined attributes (UDAs) used in the model.

When you create a new model, Tekla Structures merges the definitions from your objects.inp files to the environment.db file. Later, when you add new user-defined attributes to the objects.inp file, the definitions are saved in environment.db when you open the model.

You can modify your user-defined attributes in an objects.inp file but the changed definitions are not automatically applied. If there are conflicts between definitions in an objects.inp file and definitions the environment.db file, the definitions in environment.db are used. To see the conflicts, run the Diagnose and change attribute definitions command, then select the attribute definitions that you want to update in the objects.inp file.

   NOTE   Do not directly edit the environment.db file.

Example: Create and update a user-defined attribute (UDA)
This example shows how to create your own user-defined attribute (UDA) and update the model to use the changed attribute definition.

Example: Create a user-defined attribute
1. Create a new model and save it.
   The user-defined attributes in the model are merged from objects.inp files and Tekla Structures saves the attribute definitions in the environment.db file in the model folder.

2. Close the model.
3. Create an input file called `objects.inp` in the model folder by using a standard text editor.

4. Enter the following information in the `objects.inp` file:

```plaintext
/* Part attributes */
part(0,"Part")
{
/* User defined tab page */
tab_page("My UDA tab")
{
/* User defined attribute */
attribute("MY UDA", "My UDA", string,"%s", no, none, "0,0", "0,0")
{
value("", 0)
}
}
tab_page("My UDA tab", "My UDA tab", 19)
modify (1)
}
/* Column attributes */
column(0,"j_column")
{
/* Reference to the user defined tab page that is defined above in */
/* the part() section: */
tab_page("My UDA tab", "My UDA tab", 19)
modify (1)
}
```

In this example, the `special_flag` property is set to `no`. If you want to create a user-defined attribute that also affects numbering, set the `special_flag` property of the attribute to `yes`.

5. Save the file.

**Example: Test the user-defined attribute**

1. Open the model.
2. Create a steel column.
3. Double-click the steel column to open its properties in the property pane.
4. Click the **More** button.
5. Go to the **My UDA tab**.

![My UDA tab]

6. Enter a value in the **My UDA** field.
7. Click **Modify**.
8. Copy the steel column.
9. Select the **My UDA** check box for the new steel column. The attribute value is also copied.
10. Close the model.

**Example: Modify the user-defined attribute to make it unique**

1. Open the `objects.inp` file in the model folder by using a standard text editor.
2. Enter `unique_` before the user-defined attribute.

```plaintext
/ **************************************************************************
/* User-defined attributes */
/ **************************************************************************
/* part(0,"Part")
  { /* Common tab pages for part attributes */
    tab_page("My UDA tab")
    unique_attribute("MY UDA", "My UDA", string,"%s", no, none, "0,0", "0,0")
      { value("", 0)
    }
    tab_page("My UDA tab", "My UDA tab", 19)
    modify (1)
  }

/ **************************************************************************
/* Column attributes */
/ **************************************************************************
/* column(0,"j_column")
  { tab_page("My UDA tab", "My UDA tab", 19)
    modify (1)
  }

Adding `unique_` before the user-defined attribute makes the user-defined attribute unique. The value of the user-defined attribute is not copied to another part.

3. Save the file.

**Example: Test the unique user-defined attribute**

1. Open the model.
2. Enter a value in the **My UDA** field for a steel column and click **Modify**.
3. Copy the steel column.
4. Select the **My UDA** check box for the new column.
5. The value was copied, so the user-defined attribute in the model is not unique. There is a conflict between the `environment.db` and `objects.inp` definitions.

**Example: Update the definitions of user-defined attributes**

1. On the **File** menu, click **Diagnose & repair** and
2. In the **Utilities** section, click **Diagnose and change attribute definitions**.
   - The **Diagnose & Change Attribute Definitions** dialog box opens.
3. Select **My UDA** in the **Attribute** area on the left.
   - You can see that **My UDA** is not unique in the current setting, but it is set to unique in `objects.inp`.

<table>
<thead>
<tr>
<th>Object classes with <code>Objects.inp</code> differences compared to current settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current settings</td>
</tr>
<tr>
<td>unique=no</td>
</tr>
</tbody>
</table>

4. Select the definition in the area on the right.
5. Click **Change current settings to selected `Objects.inp` settings**.
   - Now the definition of the user-defined attribute is updated in the model.
   - If you now copy a steel column that has a value for **My UDA**, the value is not copied to the new column.

**Example: Add a tab page to the definitions of user-defined attributes**

The tab page display order is defined by the last number in the definition row.

Avoid using the same page numbers that are already used in the `object.inp` file in the common environment.

1. Define the tab page content.

```plaintext
tab_page("","jd_Parameters",3)
{
    attribute("PROJECT_COMMENT", "j_proj_comment", string, "%s", no, none, "0.0", "0.0")
    {
        value("", 0)
    }
}
```
2. Add the tab page content to drawing objects for GA drawings and multidrawings.

```plaintext
/  *******************************************************************************************************************/
/* Drawing attributes - GA */
/  *******************************************************************************************************************/
*/
```
Add UDAs in reference models
To use user-defined attributes in your reference models, you must add the UDAs to the objects.inp file if your environment does not contain the necessary reference model UDAs.

**NOTE** Do not edit the original objects.inp file under the environments folder.

To define new user-defined attributes, create your own objects.inp file in the model, project or firm folder.

This example shows the text you must add to an objects.inp file to create the UDAs that is shown in the image of the side pane.
Start new projects as a Tekla Structures administrator

150

Define and update user-defined attributes (UDAs)
Properties of the objects.inp file

User-defined attribute definitions in the objects.inp file follow this structure.

For general information about modifying the definitions, such as file locations and reading order, see Define and update user-defined attributes (UDAs) (page 141).

You can also hide or dim user-defined attributes. For more information, see How to hide and grey out user-defined attributes.

This example shows the main properties of objects.inp:

```plaintext
attribute("MY_INFO_1", "My Info 1", string, "%s", no, none, "0.0", "0.0") {
  value ("", 0)
}
picture("image_name", 8, 2, 260, 25)
```

4.6 Templates

Templates are descriptions of forms and tables that can be included in Tekla Structures. The contents of the template fields are filled in by Tekla Structures at run time.

Templates are either graphical or textual. Graphical templates are inserted in drawing layouts as tables, text blocks, and drawing headers, for example. Textual templates are used for creating reports.

Tekla Structures includes a large number of standard templates you can use. Use the Template Editor to modify existing templates, or create new ones to suit your needs.

Graphical template definitions have the file name extension .tpl. Textual template definitions have the file name extension .rpt.

The ready-made textual and graphical templates are located under the environment folders, in ...\ProgramData\Trimble\Tekla Structures \<version>\environments\. The exact file location may vary depending on the folder structure of your environment files. Textual and graphical templates, except mark templates, can also be read from XS_FIRM or XS_PROJECT folders. For more information on where the templates are searched for, see Folder search order (page 48).

Examples

Example of a title block:
Example of an inquiry report:

Example of a part list report:
For more information on using templates, see Template Editor User's Guide (page 153) or open the Template Editor Help in the Template Editor by clicking Help --> Contents.

See also
Create a textual template (page 153)
Create a graphical template (page 166)

Template Editor User's Guide
This guide describes how you can use Template Editor to create, modify and manage template definitions for both reports and drawings.

With Template Editor, you can produce labels, reports and legends allowing you to gather and produce accurate and targeted information. Tekla Structures has a number of ready-made templates, and you can use the Template Editor to modify the existing templates, or create new ones to suit your needs.

Template Editor is also used in other products than Tekla Structures. For this reason, the term *product* is used frequently in the content instead of the name of specific software products. For exact instructions about how to use Template Editor together with Tekla Structures to create and modify templates, see the other articles under Templates (page 151).

The Template Editor User's Guide is currently available in English only. The content is the same as in the Template Editor help. You can find the guide in the PDF format here: Tekla Structures PDF documentation.

Create a textual template
Textual templates (.*rpt) only contain text. They are primarily used for creating reports or listings of Tekla Structures specific objects, for example, in material lists of construction assemblies.
We will create a simple part list as an example of a textual template. First, we will add a page header with a report description and date information, then a row for the part list, and finally a page footer for summarizing the part data.

1. On the Tekla Structures File menu, click Editors --> Template editor. You can also open Template Editor from the Windows Start menu.

2. In Template Editor, click File --> New.

3. Select Textual template.

   ![Template Editor](image)

   To create a new template based on a pre-defined template, select a file from the pre-defined templates section in the Template types dialog box.

4. Click OK.

   An empty template opens in the template work area, and you can start adding content. If you selected a pre-defined template, the work area contains the pre-defined content.

5. Set or modify the template page settings and margin settings:
a. Double-click the template to open the **Template Page Properties** dialog box.

b. In the **Output**, **Workarea**, and **Margins** areas, modify the following:
   - **Width** and **Height**: Set in characters. The option to use page breaks if the page height is exceeded is selected by default. If this is not selected, no page breaks appear in the output.
   - **View height**: Set the page height in characters for template design, but does not affect template output.
   - **Margins**: Set the margins for the left, right and bottom of the template in characters.

c. Click **OK** to save the changes.

6. To add a page header row in the template, click **Insert --> Component --> Page header**.

7. Add the necessary text labels to the page header.
   a. Select the page header and click the **Text** button on the toolbar.
   b. Type the needed text and click **OK**.
   c. Pick a location for the text in the page header.
   d. Add other text labels in the same way. For example, add a label for the report name, page number, and date, and column header labels for the part list that will be placed under the page header.

Here we have added some text labels to the header, including the column header labels for the part list:

8. Modify the text properties.
   a. Double-click a text label in the page header.
b. Modify the necessary properties.

You can change the color of a text object. To do this, double-click a text object in the template, and in the object properties, click the button next to the font setting. Then click the color box and select a standard color or a custom color.
c. Click OK.

9. Add the necessary value fields to the page header.
   a. Select the page header, click **Insert --> ValueField** and pick a location for the value field in the header.
b. Select an attribute to add in the value field from the list of available attributes.
c. Click OK.
d. Add other value fields in the same way.

We have added some value fields and attributes to the page header: PROJECT.NUMBER, PROJECT.NAME, PAGE, and DATE.

10. Modify the value field properties.
a. Double-click a value field in the page header or in the content browser on the left.
b. Modify the value field properties.

Pay attention to the content browser on the left while you are adding content to the template. It shows you the added content objects and allows you to quickly select and work with the content objects. When you select an object from the content browser, the object is also selected in the template.
11. Add new rows in the template.
   a. Click **Insert --> Component --> Row**.
   b. Select a content type (page 192) for the row, and click **OK**.

   The content type that you select affects the template attributes that you can add in the value fields. In this example, we will select PART.

12. Add value fields to get the required data from your Tekla Structures database.
   a. Click **Insert --> Value field**.
   b. Pick a location for the value field in the row.
The **Select Attribute** dialog box is displayed.
c. Select an attribute from the list and click **OK**.

d. Add the rest of the needed value fields and attributes in the same way.

Here we have added the following template attributes to the row:
PART_POS, PROFILE, NUMBER, MATERIAL, LENGTH, AREA, and WEIGHT.

13. To add a page footer row in the template, click **Insert --> Component --> Page footer**.

14. Add the necessary text labels and value fields to the page footer in the same way as you added to the header, and modify the properties if necessary.

We have added some text labels and value fields to the page footer:
NUMBER_TOTAL, AREA_TOTAL, and WEIGHT_TOTAL.

15. Finalize the template.

When you have the desired content in the template, you can make the template look nicer by repositioning labels and value fields, cropping some rows, or adding lines to separate the rows. Cropping removes any unnecessary space from around the rows.

- To crop the page header row, part row, or page footer row, select the row, right-click, select **Crop**, and then select the desired crop option.

- Drag the text labels and value fields to reposition them if necessary.

- Add lines in the template between rows. In textual templates, you can use **Text** objects to add dashed lines (---) between the rows.

Here is the final template content:

16. Save the template.

a. Click **File --> Save as**.

b. Save the template in the model folder. If you want to use the template in other projects as well, save the template in the template folder defined for the advanced option **XS_FIRM** or **XS_PROJECT**.

c. In the **File name** field, enter a name for the template.

d. Click **OK**.
Here is an example of the part list report.

**TIP** Another way to create a new template is to open an existing template in Template Editor, modify the template as required, and save the template with another name.

**Example: Create a template for nested assemblies**
This example shows how to produce a template that shows the hierarchical structure of nested assemblies.

These steps show how to create a nested assembly structure in a textual template similar to the one in this picture:
1. On the **File** menu, click **Editors --> Template Editor**.

2. In the Template Editor, click **File > New**.

3. Select **Textual template**, then click **OK**.

4. Add four new rows in the template.
   a. To add a new row, click **Insert --> Component --> Row**.
   b. Select a content type for the row, then click **OK**.

   For the first and third row, select the **ASSEMBLY** content type. For the second and fourth row, select the **PART** content type.

5. Use the arrow buttons under **Sorting and drawing order** to create a nested assembly structure for the template.
   a. Move the second and third row down one level.
   b. Move the fourth row down two levels.

   ![Sorting and drawing order](image)

   The structure should now look like this:
6. Add value fields to get the required data from your Tekla Structures database.
   In this example, the added value fields are assembly or part position, number, and weight.
   a. Click **Insert --> Value field**.
   b. Click a point to define the location of the field within the row.
      The **Select Attribute** dialog box open and prompts you to select an attribute for the value field.
   c. Select an attribute, then click **OK**.

7. Modify the layout of the template. For example:
   a. Move objects to show the nested assembly structure in the printed report.
      Select the object that you want to move and drag it to the new position.
   b. Align objects.
      Select the objects that you want to align, right-click, then select an alignment option. For example, select **Align --> Right**.
   c. Add a header and a footer.
      Click **Insert --> Component --> Page header** and **Insert --> Component --> Page footer**.
      Add the required information to the header and footer.

8. Save the template.

**Example**

This example shows a textual template and a report that has been created using the template:
NOTE  You can create graphical templates for nested assemblies in the same manner as textual templates. The difference between graphical and textual templates is that in a graphical template you can show project and company information and graphics, such as table outlines, pictures, or symbols.
Create a graphical template
You can insert graphical templates (.tpl) in drawing layouts as tables, text blocks, or drawing headers, for example. You can also add graphical templates as elements in marks and associative notes.

We will create a drawing title block as an example of a graphical template. The title block contains drawing details such as the title, author name, scale, and date the drawing was created.

1. On the Tekla Structures File menu, click Editors --> Template editor. You can also open Template Editor from the Windows Start menu.
2. In Template Editor, click File --> New.
3. Select Graphical template.

   ![Template Editor](image)

   To create a new template based on a pre-defined template, select a file from the pre-defined templates section in the Template types dialog box.

4. Click OK.
An empty template opens in the template work area, and you can start adding content. If you selected a pre-defined template, the work area contains pre-defined content.

5. Set or modify the template page settings and margin settings:
   a. Double-click the template to open the Template Page Properties dialog box.
   b. In the Output, Workarea, and Margins areas, modify the following:
      • **Width** and **Height**: Set in graphical units. The option to use page breaks if the page height is exceeded is selected by default. If this is not selected, no page breaks appear in the output.
      • **View height**: Set the page height for template design, but does not affect template output.
      • **Margins**: Set the margins for the left, right and bottom of the template in graphical units.
      • **Use font CAP height**: Set how the font size is calculated and output in graphical templates. It means that the text size will output exactly as defined. See Control font height in graphical templates (page 176) for more information.
   c. Click **OK** to save the changes.

6. Add a row in the template for the drawing title block.
   a. Click **Insert --> Component --> Row**.
   b. Select the content type (page 192) for the row, and click **OK**.

   The content type that you select affects the template attributes that you can add in the value fields. In this example, we select DRAWING.
7. Add the needed text labels to the row.
   a. Select the row and click **Insert -> Text**.
   b. Type the needed text and click **OK**.
   c. Pick a location for the text in the row.
   d. To modify the text properties, double-click the text, adjust the properties, and click **OK**.
For example, enter a name for the text object and change the font size. The name will be shown in the content browser.

Pay attention to the content browser on the left while you are adding content to the template. It shows you the added content objects and allows you to quickly select and work with the content objects. When you select an object from the content browser, the object is also selected in the template.

You can change the color of a text object. To do this, double-click a text object in the template, and in the object properties, click the button next to the font setting. Then click the color box and select a custom color.
e. Add the rest of the text labels to the row in the same way.

8. Add the necessary value fields to the row.
   a. Select the row, click **Insert --> ValueField** and pick a location for the value field in the row.
b. Select an attribute to add in the value field from the list of available attributes and click **OK**.

In this example, we select **NAME** under **PROJECT**.
c. Add other value fields in the same way.

d. To modify the value field properties, double-click the value field. For example, change the value field name, font size, and allowed text length. The value field name will be shown in the content browser and in the template.

e. Click OK.

Here we have added the needed value fields to the row and modified the value field properties:

The content browser shows the added content:
9. Finalize the template.

When you have the desired content in the template, you can make the template look nicer by repositioning labels and value fields, cropping the rows, or adding lines to separate the columns and rows. Cropping removes any unnecessary space from around the rows.

- To crop the row, select the row, right-click, select Crop, and then select the desired crop option.
- Drag the text labels and value fields to reposition them if necessary.
- Draw lines in the template between columns and rows by using the graphical tools. You can double-click the created objects to change the color and other properties.

You can change the color of a shape object. To do this, double-click a shape object, such as a line, and in the object properties, click the color box and select a standard color or a custom color.
Here is the final template content:

10. Save the template.
   
   a. Click **File --> Save as**.
   
   b. Save the template in the model folder. If you want to use the template in other projects as well, save the template in the template folder defined for the advanced option `XS_FIRM` or `XS_PROJECT`.
   
   c. In the **File name** field, enter a name for the template.
   
   d. Click **OK**.

Here is an example of the created title block in a drawing:
**TIP** Another way to create a new template is to open an existing template in Template Editor, modify the template as required, and save the template with another name.

In graphical templates, you can also import DWG/DXF files and use those as title blocks. For more information, see "Import DWG into Template Editor to create custom Title blocks".

**Control font height metric in graphical templates**

You can use CAP height as the font height metric in Tekla Structures drawings and have more control over the font height in drawing-related content like printing and exports. You can also apply the CAP font height in graphical templates.

Traditionally, the height of the text in Tekla Structures drawings has been based on em (point size) font height metric only. However, some projects require the height of the text to be determined using another industry standard, CAP font height. CAP height represents the height of a capital letter more accurately than em height.

(1) CAP height
You can control the font height in drawings with the advanced option `XS_DRAWINGS_USE_CAP_HEIGHT_FOR_FONT_HEIGHT`. CAP height is used when this advanced option is set to `TRUE`, whereas em (point size) height is used when this advanced option is set to `FALSE` (default value).

The font metric change is not automatically applied to the existing templates. Texts in drawings created by the drawing templates in Template Editor are not directly affected by the `XS_DRAWINGS_USE_CAP_HEIGHT_FOR_FONT_HEIGHT` advanced option. The reason for this is that the change in the font height might cause overlapping in the template fields.

- If you want to use CAP height in a specific drawing template, you need to select the **Use font CAP height** option in the template page properties of the particular template and then adjust the template content as necessary to correct any overlapping fields.

- When you create a new drawing template, the preselection of the **Use font CAP height** option depends on how you have started Template Editor:
  - If you have started Template Editor from within Tekla Structures from the **File** menu or when editing a drawing layout, Template Editor follows the `XS_DRAWINGS_USE_CAP_HEIGHT_FOR_FONT_HEIGHT` setting.
  - If you have started Template Editor from outside Tekla Structures from the Microsoft Windows **Start** menu, the option is controlled by the
Template Editor preferences, and whether you have selected the **User font CAP height for new graphical templates** check box:

![Template Editor preferences](image)

**Create a template in HTML format**

Templates in the HTML format give you more possibilities for different layout, fonts, and images. Templates that generate output in HTML format are graphical and have the file name extension `.html.rpt`.

**NOTE** If you add images to your HTML template (page 189), the images must be in the `.\Program Files\Tekla Structures\<version>\bin\applications\Tekla\Tools\TplEd\bitmaps` folder. Images in other folders are not shown in the HTML output.

1. On the **File** menu, click **Editors --> Template Editor**.
2. In the Template Editor, click **File > New**.
3. Select **Graphical template**, then click **OK**.
4. Add new rows in the template.
   a. To add a new row, click **Insert --> Component --> Row**.
   b. Select a content type for the row, then click **OK**.
5. Add value fields to get the required data from your Tekla Structures database.
   a. Click **Insert --> Value field**.
   b. Click a point to define the location of the field within the row.
      The **Select Attribute** dialog box opens and prompts you to select an attribute for the value field.
   c. Select an attribute, then click **OK**.

6. Add a header for each value field.
   a. Click **Insert --> Component --> Header...**
   b. Click **Insert --> Text...**
   c. Enter a heading for the template, and then click **OK**.
   d. Click a point to define the location of the heading in the header row.

7. Save the template:
   a. Click **File --> Save as**
   b. Save the template in the model folder. If you want to use the template in other projects as well, save the template in the template folder defined for the advanced option `XS_FIRM` or `XS_PROJECT`.
   c. In the **File name** field, enter a name for the template.
      Include the extension `*.html.rpt` in the file name. For example, `Part_list.html.rpt`.
   d. Click **OK**.

**Example**

1. Header that contains text fields
2. Row that contains two value fields

TIP • To export reports to Microsoft Excel with a certain layout, for example, merged cells, border lines, font types and sizes, you can use HTML in Template editor. When you save the template with the file name extension .xls.rpt, the Excel report will automatically open in Excel when Show report is set to With associated viewer. For more information, see How to make basic HTML-based excel reports.

• To create an additional set of pictures to the report folder, set the advanced option XS_CREATE_ALSO_BIG_HTML_REPORT_PICTURES to TRUE. The pictures are three times larger in size compared to the ones in the HTML report.

Create a .pdf report template
You can create graphical templates to be used for .pdf reports.
1. On the File menu, select Editors --> Template editor.
2. Select File --> New --> Graphical template.
3. Click Edit --> Properties.
4. In Template page properties dialog box, set the page size to match the target page size (for example A4):

   ![Template Page Properties dialog box](image)

   The size must match one of the sizes defined in the PaperSizesForDrawings.dat configuration file.
5. Add new rows and value fields to get the required data from your Tekla Structures database. For more information about adding new rows and value fields, see Create a graphical template (page 166).

6. Click File → Save as, and save the report with the file name extension .pdf.rpt.

7. Copy the new template to your template folder, such as model or your company settings folder (XS_FIRM).

You can now create a .pdf report using the new .pdf report template. For more information, see Create a report.

**Example .pdf report**

In this report example, the following page size is used:

![Template Page Properties](image)

Below is an example of a report that has been created using this particular report template.
Create a template for bending schedules or pull-out pictures

You can use the Template Editor to create bending schedules or pull-out pictures for reinforcement bars and bent meshes, and control the type of information that is shown in the bending schedules.

1. On the File menu, click Editors --> Template Editor.
2. Click File --> New.
3. Select Graphical template, then click OK.
4. To add a new row, click Insert --> Component --> Row.
5. Select REBAR or MESH as the content type for the row.
6. Add value fields to get the required data from your Tekla Structures database.
   a. Click Insert --> Value field.
   b. Click a point to define the location of the field within the row.
      The Select Attribute dialog box open and prompts you to select an attribute for the value field.
   c. Select an attribute, then click OK.
7. Insert a graphical field in your REBAR or MESH content type row.
   a. Click Insert --> Graphical Field...
   b. Click and drag with the mouse to draw a frame.
8. Double-click the graphical field to open the Graphical Field Properties dialog box.
9. Click Free attributes and go to the Application tab.
10. Select the required bending diagram attributes.

You can also define the bending diagram attributes on the User tab. Note that if the same attribute is set both as User attribute and Application attribute, the Application attribute takes precedence.

For a list of attributes and values that can be used for bending schedules in templates, see “Bending schedule attributes” below.

11. Save the template.
Example

REBAR BENDING SCHEDULE

<table>
<thead>
<tr>
<th>Pass</th>
<th>Diameter</th>
<th>Number</th>
<th>Grade</th>
<th>Length</th>
<th>Kg/p</th>
<th>Weight</th>
<th>Bending shape</th>
</tr>
</thead>
<tbody>
<tr>
<td>R/19</td>
<td>12</td>
<td>6</td>
<td>Under***</td>
<td>10680</td>
<td>9.48</td>
<td>55.9</td>
<td></td>
</tr>
<tr>
<td>R/189</td>
<td>20</td>
<td>2</td>
<td>Under***</td>
<td>10680</td>
<td>28.34</td>
<td>52.7</td>
<td></td>
</tr>
<tr>
<td>98</td>
<td>16</td>
<td>2</td>
<td>Under***</td>
<td>2230</td>
<td>3.52</td>
<td>7.0</td>
<td></td>
</tr>
<tr>
<td>R/10</td>
<td>12</td>
<td>4</td>
<td>Under***</td>
<td>1560</td>
<td>1.39</td>
<td>5.5</td>
<td></td>
</tr>
<tr>
<td>R/11</td>
<td>12</td>
<td>4</td>
<td>Under***</td>
<td>1430</td>
<td>1.27</td>
<td>5.1</td>
<td></td>
</tr>
<tr>
<td>R/15</td>
<td>12</td>
<td>4</td>
<td>Under***</td>
<td>1380</td>
<td>1.21</td>
<td>4.8</td>
<td></td>
</tr>
<tr>
<td>R/18</td>
<td>12</td>
<td>2</td>
<td>Under***</td>
<td>1680</td>
<td>1.47</td>
<td>2.9</td>
<td></td>
</tr>
<tr>
<td>R/55</td>
<td>8</td>
<td>6</td>
<td>Under***</td>
<td>1430</td>
<td>0.57</td>
<td>3.4</td>
<td></td>
</tr>
<tr>
<td>R/57</td>
<td>8</td>
<td>57</td>
<td>Under***</td>
<td>2760</td>
<td>1.09</td>
<td>62.1</td>
<td></td>
</tr>
<tr>
<td>R/100</td>
<td>16</td>
<td>4</td>
<td>Under***</td>
<td>980</td>
<td>1.52</td>
<td>8.1</td>
<td></td>
</tr>
<tr>
<td>R/138</td>
<td>10</td>
<td>4</td>
<td>Under***</td>
<td>1030</td>
<td>0.64</td>
<td>2.5</td>
<td></td>
</tr>
<tr>
<td>R/137</td>
<td>10</td>
<td>4</td>
<td>Under***</td>
<td>1270</td>
<td>0.78</td>
<td>3.1</td>
<td></td>
</tr>
</tbody>
</table>

Total: 212.3
**Autoscaling pull-out pictures**

There is a free attribute available for the PULLOUT attribute in graphical templates that you can use to define the scale type. If you set the free attribute ScaleType to 1 on the User tab in the Free attributes dialog box, the pull-out pictures will be scaled to fit the available space in both X and Y dimensions. As a result, the shape becomes out of proportion, but small segments can be seen more easily. Note that you can also set this attribute on the Application tab.

A bending shape might look like this if you do not define the free attribute ScaleType:

![Bending shape without ScaleType](image)

The same bending shape that uses the free attribute ScaleType with value 1.
Changing the appearance of pull-out pictures

Tekla Structures uses the settings in the `rebar_config.inp` file in the system folder defined by the advanced option `XS_SYSTEM` to define the appearance of the pull-out pictures. You can change the colors, lines, and dimension unit, format, and precision used in pull-out pictures, for example. For a list of settings and values in `rebar_config.inp`, see...

**Bending schedule attributes**

This table lists the attributes and values that can be used for bending schedules in templates.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Default value</th>
<th>Available values</th>
</tr>
</thead>
<tbody>
<tr>
<td>FontName</td>
<td>romsim</td>
<td>Available template fonts</td>
</tr>
<tr>
<td>FontSize</td>
<td>2.0</td>
<td>Available font sizes</td>
</tr>
<tr>
<td>FontColor</td>
<td>1 (black)</td>
<td>1 = black</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2 = red</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3 = bright green</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4 = blue</td>
</tr>
<tr>
<td></td>
<td></td>
<td>5 = cyan</td>
</tr>
<tr>
<td></td>
<td></td>
<td>6 = yellow</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7 = magenta</td>
</tr>
<tr>
<td></td>
<td></td>
<td>8 = brown</td>
</tr>
<tr>
<td></td>
<td></td>
<td>9 = green</td>
</tr>
<tr>
<td></td>
<td></td>
<td>10 = dark blue</td>
</tr>
<tr>
<td></td>
<td></td>
<td>11 = forest green</td>
</tr>
<tr>
<td></td>
<td></td>
<td>12 = orange</td>
</tr>
<tr>
<td></td>
<td></td>
<td>13 = gray</td>
</tr>
<tr>
<td>RotationAxis</td>
<td>2</td>
<td>0 = by view</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1 = by global Z</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2 = by local axis</td>
</tr>
<tr>
<td>Attribute</td>
<td>Default value</td>
<td>Available values</td>
</tr>
<tr>
<td>--------------------</td>
<td>---------------</td>
<td>---------------------------------------</td>
</tr>
<tr>
<td>ScaleType</td>
<td>0</td>
<td>0 = no</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1 = yes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If you set the free attribute <code>ScaleType</code> to 1 for the <code>PULLOUT</code> attribute, the pull-out pictures will be scaled to fit the available space in both X and Y dimensions. As a result, the shape becomes out of proportion, but small segments can be seen more easily.</td>
</tr>
<tr>
<td>Exaggeration</td>
<td>1</td>
<td>0 = no</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1 = yes</td>
</tr>
<tr>
<td>EndMark</td>
<td>1</td>
<td>1 = straight</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2 = half arrow</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3 = full arrow</td>
</tr>
<tr>
<td>Dimensions</td>
<td>1</td>
<td>0 = no</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1 = yes</td>
</tr>
<tr>
<td>BendingRadius</td>
<td>0</td>
<td>Shows the bending radius in form of diameter of the bending roll.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>0 = no</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1 = yes</td>
</tr>
<tr>
<td>BendingAngle</td>
<td>1</td>
<td>0 = no</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1 = yes</td>
</tr>
<tr>
<td>ImageWidth</td>
<td>Width of the graphical field multiplied by 4.</td>
<td>Number of pixels</td>
</tr>
<tr>
<td>ImageHeight</td>
<td>Height of the graphical field multiplied by 4.</td>
<td>Number of pixels</td>
</tr>
<tr>
<td>CouplerSymbols</td>
<td>1</td>
<td>Show rebar coupler and end anchor symbols in rebar bending schedules. Rebar coupler symbols will be shown if <code>CouplerSymbols</code></td>
</tr>
<tr>
<td>Attribute</td>
<td>Default value</td>
<td>Available values</td>
</tr>
<tr>
<td>-----------</td>
<td>--------------</td>
<td>-----------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>property value is set to 1 and disabled if 0 is entered. The default value is 1.</td>
</tr>
</tbody>
</table>

**Add images in a template**
You can add images in graphical templates. For example, you might want to include a company logo in your drawings.

Tekla Structures supports the following image formats in graphical templates:

- .bmp
- .jpeg
- .jpg
- .png
- .tif
- .tiff

When adding images in templates:

- Do not add very large images because they update very slowly.
- The image might look different in the image editor and in the printout or in the exported DWG file.
- When you export the drawing as a DWG file, Tekla Structures copies the images in the same folder as the DWG file. If the image is not in the same folder, only the name of the image is shown together with an empty frame instead of the image in the DWG.
- If environments have local symbols, the local symbol folder is also included in the search path with the `common\symbols` folder. If the local symbols folder contains files with the same name as `common\symbols` folder, the local symbol file is used.
- When you open the drawing that contains the images that you inserted in the template, Tekla Structures first looks for the images in the model folder and then in the `\symbols` folder in the current environment.
- You can define a folder where Tekla Structures always looks for images using the advanced option. You can also define a firm folder for your images.

1. To open Template Editor, in Tekla Structures, go to the **File** menu and click **Editors --> Template editor**. You can also open Template Editor from the Windows Start menu.
2. Open an existing graphical template or create a new graphical template in the Template Editor.
3. Add a new row in the template:
   a. To add a new row, click **Insert --&gt; Component --&gt; Row**.
   b. Select a content type for the row, then click **OK**.

4. Ensure that you have the row selected, then click **Insert > Picture** to open the **Select Picture File** dialog box.

   If a local symbols folder exists, the contents of that folder are shown by default. You can browse for the contents of the **common\symbols** folder by selecting that folder. If a local symbols folder does not exist, Tekla Structures shows the contents of the **common\symbols** folder.

5. If you have images in other folders, you can show these folders in the **Select Picture File** dialog box:
   a. In the Template Editor, click **Options --&gt; Preferences**.
   b. Go to the **File Locations** tab.
   c. On the **Symbols, pictures** row, add a new folder separated by a semicolon (;).

   For example:
   ```plaintext
   Symbols, pictures (;)
   "$\text{\textbackslash{}common\textbackslash{}symbols}:[\text{\textbackslash{}common\textbackslash{}symbols}]$
   ```

   The folder that you defined is shown in the **Directory** list:

   ![](image)

6. Select an image from the **File** list, click **OK**, and add the image.
   You can adjust the size by dragging from the image handles.

   **Example**
   These examples of the **Select Picture File** dialog box show the folder structure in different environments.
In this example, a company logo has been added in a template.
You can also import a DWG file to be used as a title block. For more information, see "Import DWG into Template Editor to create custom title blocks".

**Content types in templates**

When you create a new row in the template, you must select a content type for the row.

For example, when you add a row, then add a value field, the Template Editor prompts you to specify the content type. The content type determines which template attributes you can use on that row.

The available content types are:

<table>
<thead>
<tr>
<th>Content type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANALYSIS RIGID_LINK</td>
<td>Use to create lists of analysis rigid links.</td>
</tr>
<tr>
<td>ANTIMATERIAL</td>
<td>Use to create lists of holes and recesses, or parts removed as a result of a cut.</td>
</tr>
<tr>
<td></td>
<td>In Template Editor, the same attributes that are available for PART are available for ANTIMATERIAL. However, only the attributes that are useful to be used with ANTIMATERIAL are shown, including NAME, LENGTH, WIDTH, HEIGHT, AREA, PROFILE, and NUMBER, and user-defined attributes.</td>
</tr>
<tr>
<td>ASSEMBLY</td>
<td>Use to create lists of assemblies and single parts. Includes all assemblies containing the selected parts and bolts.</td>
</tr>
<tr>
<td>BOLT</td>
<td>Use to create screw and bolt lists. Includes all bolts connected to selected parts.</td>
</tr>
<tr>
<td>CAST_UNIT</td>
<td>Use to create lists of cast units.</td>
</tr>
<tr>
<td>CHAMFER</td>
<td>Use to create lists of the length of the chamfers.</td>
</tr>
<tr>
<td>Content type</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>COMMENT</td>
<td>Use to create empty rows or rows that only have textual data or lines anywhere on a template.</td>
</tr>
<tr>
<td>CONNECTION</td>
<td>Use to create lists of connections.</td>
</tr>
<tr>
<td></td>
<td>This content type works only for connections and details (object type 3), not for modeling tools or custom parts (object type 4).</td>
</tr>
<tr>
<td>DRAWING</td>
<td>Use to create drawing lists without revision history information. Use for reports and included drawings.</td>
</tr>
<tr>
<td>HIERARCHIC_CAST_UNIT</td>
<td>Use to create reports listing subassemblies of concrete.</td>
</tr>
<tr>
<td>HIERARCHIC_OBJECT</td>
<td>Use to create lists of various types of hierarchies. For example, lists hierarchical objects in Organizer.</td>
</tr>
<tr>
<td>HISTORY</td>
<td>Use to retrieve history information of the model.</td>
</tr>
<tr>
<td></td>
<td>You can use this content type with PART, REBAR, CONNECTION and DRAWING rows.</td>
</tr>
<tr>
<td></td>
<td>The following template attributes can be used with this content type:</td>
</tr>
<tr>
<td></td>
<td>• TYPE: the type of the historical action, for example update or numbering.</td>
</tr>
<tr>
<td></td>
<td>• USER: the user who made the change.</td>
</tr>
<tr>
<td></td>
<td>• TIME: the time the change was made.</td>
</tr>
<tr>
<td></td>
<td>• COMMENT: the comment which was entered upon clicking Save.</td>
</tr>
<tr>
<td></td>
<td>• REVISION_CODE: the revision code which was entered upon clicking Save.</td>
</tr>
<tr>
<td>HOELE</td>
<td>Use to create lists of holes.</td>
</tr>
<tr>
<td>LOAD</td>
<td>Use to create lists of loads.</td>
</tr>
<tr>
<td>LOADGROUP</td>
<td>Use to create lists of load groups.</td>
</tr>
<tr>
<td>MESH</td>
<td>Use to create lists of meshes.</td>
</tr>
<tr>
<td>NUT</td>
<td>Use to create lists of nuts. Contains all nuts for bolts associated with the selected parts.</td>
</tr>
<tr>
<td>PART</td>
<td>Use to create lists of parts.</td>
</tr>
<tr>
<td>POUR_BREAK</td>
<td>Use to create lists of pour breaks.</td>
</tr>
<tr>
<td>POUR_OBJECT</td>
<td>Use to create lists of pour objects.</td>
</tr>
<tr>
<td>POUR_UNIT</td>
<td>Use to create lists of pour units.</td>
</tr>
<tr>
<td>REBAR</td>
<td>Use to create lists of reinforcing bars.</td>
</tr>
<tr>
<td>REBAR ASSEMBLY</td>
<td>Use to create lists of rebar assemblies.</td>
</tr>
<tr>
<td>Content type</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>REFERENCE_MODEL</td>
<td>Use to list the reference models.</td>
</tr>
<tr>
<td>REFERENCE_OBJECT</td>
<td>Use to list the reference model objects in a reference model. Only reference model objects that have user-defined attributes are displayed in reports.</td>
</tr>
<tr>
<td>REFERENCE_ASSEMBLY</td>
<td>Use to list the reference assemblies in a reference model.</td>
</tr>
<tr>
<td>REVISION</td>
<td>Use to create lists of revision marks.</td>
</tr>
<tr>
<td>SIMILAR_ASSEMBLY</td>
<td>Use to create lists of similar parts.</td>
</tr>
<tr>
<td>SIMILAR_CAST_UNIT</td>
<td>To use this content type, you need to have an empty (hidden in output) ASSEMBLY, PART or CAST_UNIT row in the row hierarchy above the row with SIMILAR_* content type:</td>
</tr>
<tr>
<td>SIMILAR_PART</td>
<td>You cannot have any rows below SIMILAR_* row content type in the row hierarchy.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Used in drawings to collect similar object information from the model. All the other attribute information is collected from visible drawing objects.</td>
</tr>
<tr>
<td>SINGLE_REBAR</td>
<td>Use to create lists of individual bars in reinforcing bar groups. For example, use it to get the lengths of the individual bars in tapered reinforcing bar groups. For rebar sets, SINGLE_REBAR works in the same way as REBAR.</td>
</tr>
<tr>
<td>SINGLE_STRAND</td>
<td>Use to create lists of individual prestressed strands.</td>
</tr>
<tr>
<td>STRAND</td>
<td>Use to create lists of prestressed strands.</td>
</tr>
<tr>
<td>STUD</td>
<td>Use to create lists of studs.</td>
</tr>
<tr>
<td>SURFACE</td>
<td>Use to create lists of surfaces.</td>
</tr>
<tr>
<td>SURFACING</td>
<td>Use to create lists of surface treatments.</td>
</tr>
<tr>
<td>Content type</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td>SUMMARY</td>
<td>Use to summarize the contents of the row(s) that are above SUMMARY in the hierarchy. For example, use PART - SUMMARY hierarchy to summarize the contents of the PART rows.</td>
</tr>
<tr>
<td>TASK</td>
<td>Use to create lists of tasks.</td>
</tr>
<tr>
<td>WASHER</td>
<td>Use to create lists of washers. Contains all washers for all bolts associated with the selected parts.</td>
</tr>
<tr>
<td>WELD</td>
<td>Use to create lists of welds.</td>
</tr>
</tbody>
</table>

**Template attribute files (contentattributes.lst)**

Template attributes represent object properties. You can use template attributes in value fields, formulas, and row rules to get the required data from your Tekla Structures database.

When you output the template, Tekla Structures replaces the attribute with the actual value of the corresponding object property. For example, if you include the attribute WEIGHT in a report template, Tekla Structures shows the weight of the model object in the report.

Template attributes are defined in the following files:

<table>
<thead>
<tr>
<th>File name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>contentattributes.lst</td>
<td>This is a container file listing all the files that contain the actual attribute definitions. The files are added with INCLUDE sentences. The order of the files included in contentattributes.lst defines the reading order of the files. This file is overwritten in the installation when you install a newer version of Tekla Structures. Ensure that you make a copy of this file before updating. Generally, there is no need to modify contentattributes.lst. Do not modify it if you are not an administrator.</td>
</tr>
</tbody>
</table>
### File Name and Description

<table>
<thead>
<tr>
<th>File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>contentattributes_global.lst</td>
<td>This file contains attributes that are hard-coded into the program. <strong>Do not edit this file.</strong></td>
</tr>
<tr>
<td>contentattributes_userdefined.lst</td>
<td>This file contains user-defined attributes, the same as in the objects.inp file. This file is overwritten in the installation when you install a newer version of Tekla Structures. To use your own attributes in templates and reports, create a copy of this file and add the necessary attributes to that file.</td>
</tr>
</tbody>
</table>

**By default, these files are located in** \..\Program Files\Tekla Structures \<version>\bin\applications\Tekla\Tools\TplEd\settings, **but the location might be different in your environment.**

The search order for the `contentattributes.lst` file is defined in the `tpled.ini` file. The location of the `tpled.ini` file is defined by the advanced option.

The following pointers are allowed in the `tpled.ini` file:

- `@\` = location of the `tpled.ini` file
- `\` = location of `tpled.exe` (C:\Program Files\Tekla Structures \<version>\bin\applications\Tekla\Tools\TplEd)

To include your own attributes, modify the `contentattributes.lst` files in the relevant environment folders. The `contentattributes.lst` files are overwritten when you install a new version of Tekla Structures.

**User-defined template attributes**

User-defined template attributes are defined in the `contentattributes_userdefined.lst` file. By default, this file includes most of the user-defined attributes that are visible in the part properties.

To use your own attributes in templates and reports, make a copy of the file, rename it appropriately, and add the necessary attributes to that file.

The `contentattributes_userdefined.lst` file is divided into two sections:
A list of attribute names and default settings:

<table>
<thead>
<tr>
<th></th>
<th>Name</th>
<th>Datatype</th>
<th>Justify</th>
<th>Cacheable</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>xxxxxx</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ax11</td>
<td>FLOAT</td>
<td>RIGHT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>8</td>
</tr>
<tr>
<td>ax12</td>
<td>FLOAT</td>
<td>RIGHT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>8</td>
</tr>
<tr>
<td>BOLT_COMMENT</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>64</td>
</tr>
<tr>
<td>BOLT_USERFIELD_1</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>64</td>
</tr>
<tr>
<td>BOLT_USERFIELD_2</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>64</td>
</tr>
<tr>
<td>BOLT_USERFIELD_3</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>64</td>
</tr>
<tr>
<td>BOLT_USERFIELD_4</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>64</td>
</tr>
<tr>
<td>BOLT_USERFIELD_5</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>64</td>
</tr>
<tr>
<td>BOLT_USERFIELD_6</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>64</td>
</tr>
<tr>
<td>BOLT_USERFIELD_7</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>64</td>
</tr>
<tr>
<td>BOLT_USERFIELD_8</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>64</td>
</tr>
<tr>
<td>cabinring</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>64</td>
</tr>
<tr>
<td>CHECKED_BY</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>20</td>
</tr>
<tr>
<td>CHECKED_DATE</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>20</td>
</tr>
<tr>
<td>comment</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>30</td>
</tr>
<tr>
<td>CONN_CODE_END1</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>20</td>
</tr>
<tr>
<td>CONN_CODE_END2</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>20</td>
</tr>
<tr>
<td>DRAUGHTING_USERFIELD_1</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>64</td>
</tr>
<tr>
<td>DRAUGHTING_USERFIELD_2</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>64</td>
</tr>
<tr>
<td>DRAUGHTING_USERFIELD_3</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>64</td>
</tr>
<tr>
<td>DRAUGHTING_USERFIELD_4</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
<td>TRUE</td>
<td>64</td>
</tr>
</tbody>
</table>

A list of attributes assigned to content types:

1. The content type of the row in Template Editor
2. The attribute hierarchy in Template Editor
3. Customizable comments, such as the tab name in the user-defined attributes dialog box
4. The name of the user-defined attribute, must be the same as in the objects.inp file

Example: Add user-defined template attributes to the Template Editor

This example shows how to add your own user-defined attributes to the attribute tree in the Template Editor.
Before you start, add your user-defined attribute to the objects.inp file. For example, you might add an attribute named MY_ATTRIBUTE to the user-defined properties of drawings.

1. Open the contentattributes_userdefined.lst file in a text editor. You can find this file in the \bin\applications\Tekla\Tools\TplEd\settings folder in the Tekla Structures installation folder.

2. Save the file with an appropriate name, for example MY_contentattributes_userdefined.lst, in the same folder.

3. Add MY_ATTRIBUTE to the list of attribute names and, define the settings as follows:

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Type</th>
<th>Align</th>
<th>Visible</th>
</tr>
</thead>
<tbody>
<tr>
<td>MORTAR_WIDTH</td>
<td>FLOAT</td>
<td></td>
<td>TRUE</td>
</tr>
<tr>
<td>MY_ATTRIBUTE</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
</tr>
<tr>
<td>OBJECT_LOCKED</td>
<td>CHARACTER</td>
<td>LEFT</td>
<td>TRUE</td>
</tr>
</tbody>
</table>

4. Add MY_ATTRIBUTE to the list of attributes assigned to content types. Select the content type according to which object the attribute is associated in the objects.inp file. In this example, the content type is DRAWING. Add the attribute in the format USERDEFINED.<ATTRIBUTE_NAME>.

```plaintext
// Drawing attributes
// --------------
// tab_page("DR_Parameters")
// --------------------------
DRAWING = USERDEFINED.MY_ATTRIBUTE
```

5. Save the changes.

6. Open the contentattributes.lst file in a text editor.

7. Add the following line in the file:

   [INCLUDE MY_contentattributes_userdefined.lst]

8. Save the changes.
Add comments to user-defined template attributes

You can add your own comments to the user-defined attributes in the Template Editor attribute tree.

1. Open your copy of the contentattributes_userdefined.lst file.
   For example, MY_contentattributes_userdefined.lst. Do not modify the original contentattributes_userdefined.lst file.

2. Scroll down to the list of attributes assigned to content types.

3. Add your comment inside quotation marks, after the attribute name.
   For example:

   ```
   DRAWING = USER-DEFINED.MY_ATTRIBUTE "my comment"
   ```

4. Save the changes.
The comment you added is shown in the attribute tree in Template Editor:

![Attribute Tree Screenshot]

**Add hierarchy to user-defined template attributes**
You can add your own hierarchy to the Template Editor attribute tree.

**WARNING** User-defined attributes are case sensitive. Ensure that you enter the attribute name using the correct case for all characters.

1. Open your copy of the `contentattributes_userdefined.lst` file. For example, `MY_contentattributes_userdefined.lst`. Do not modify the original `contentattributes_userdefined.lst` file.

2. Scroll down to the list of attributes assigned to content types.

3. Define the hierarchy in square brackets, between `USERDEFINED` and the attribute name.
   For example:
   ```
   DRAWING = USERDEFINED.[Folder 1 Folder 2].MY_ATTRIBUTE "my comment"
   ```

   **NOTE** Ensure that you include the periods after the brackets and between the hierarchies.

4. Save the changes.
The new hierarchy is shown in the attribute tree:

![Attribute Tree Diagram]

**Tips for templates**
These tips can help you to use templates more efficiently.

**Using type attributes in calculations**

Change text to numeric format

```java
double(GetValue("ASSEMBLY_TOP_LEVEL"))
```

Change into correct format for calculation (double=decimals)

```java
format(double(GetValue("ASSEMBLY_TOP_LEVEL")),"Length", "mm", 1)
```

Add all above into calculation formula

```java
format(double(GetValue("ASSEMBLY_TOP_LEVEL")),"Length", "mm", 1)+15000
```

Another example of the same for part elevation

```java
(double(GetValue("TOP_LEVEL"))-
(double(GetValue("BOTTOM_LEVEL"))))*1000
```

**Change value field content to use imperial units**

Advanced option to check if imperial units are in use:

```java
GetValue("ADVANCED_OPTION.XS_IMPERIAL")==TRUE
```

Translated string call for multi lingual text:
GetValue("TranslatedText("albl_Diameter_")")

Formatting of units:
format(GetValue("DIAMETER"), "Length", "inch-frac", 1/16)
format(GetValue("DIAMETER"), "Length", "mm", 1)

Combine all above in a rule:
if GetValue("ADVANCED_OPTION.XS.IMPERIAL") == TRUE then
    GetValue("TranslatedText("albl_Diameter_")") +
    format(GetValue("DIAMETER"), "Length", "inch-frac", 1/16) + " Inches"
else
    GetValue("TranslatedText("albl_Diameter_")") +
    format(GetValue("DIAMETER"), "Length", "mm", 1) + " mm"
endif

Define customized date format

Use mid function to find year, month and day:
mid("","","") string, offset, n
year:
mid(format(GetValue("DATE"), "Date", "dd.mm.yyyy", ),"6","4")
month:
mid(format(GetValue("DATE"), "Date", "dd.mm.yyyy", ),"3","2")
days:
mid(format(GetValue("DATE"), "Date", "dd.mm.yyyy", ),"0","2")

Combine all above in rule:
mid(format(GetValue("DATE"), "Date", "dd.mm.yyyy", ),"6","4") +"-" +
mid(format(GetValue("DATE"), "Date", "dd.mm.yyyy", ),"3","2") +"-" +
mid(format(GetValue("DATE"), "Date", "dd.mm.yyyy", ),"0","2")

Assembly or cast unit drawing sheet number

Use match function to find "-" character
match(GetValue("NAME_BASE"), "-*")

Use of mid function to return only characters after "-"
mid(GetValue("NAME_BASE"), (1+ (find(GetValue("NAME_BASE"), "-"))), 2)

Combine all above in rule

if (match(GetValue("NAME_BASE"), "*-"))
then mid(GetValue("NAME_BASE"), (1+ (find(GetValue("NAME_BASE"), "-"))), 2)
else ""
endif

**Use format functions in value fields**

You can define the format used in a value field in two ways: In the **Value Field Properties** dialog box by filling in the fields for **Datatype**, **Meaning**, **Unit** and **Decimals**, or by creating a formula in the **Formula** field. In formulas, you can use the format function that converts an attribute value to a formatted information string.

When you use a format function in a formula, always set the **Datatype** to **Text** in the **Value Field Properties** dialog box. Leave the other fields in the **Format** area empty.

For example, if you want to convert the attribute value to numbers with decimals in the report, you need to include the conversion function `double` in the format function:

![Value Field Properties dialog box](image)

The default values for unit and decimals are defined in the **contentattributes_global.lst** file. The format function converts the attribute value to a formatted information string on the basis of what you have defined in the format function. The format function overrides the definitions in the **contentattributes_global.lst** file and settings that you have defined in the **Format** area of **Value Field Properties** dialog box.

Example of the result in a report when you use the formula above:

Mesh Information:
Geometry Size: 4/4-150/150-2750*2000
Example of the result of the formula, when you use set the advanced option XS_IMPERIAL to FALSE instead of TRUE:

Mesh Information:
Geometry Size: 4/4-150/150-2750*2000
Length: 2750 mm
Height: 2000 mm

For a list of valid unit and precision strings, see the valuefieldclasses.lst file located in the ..\Program Files\Tekla Structures\<version>\bin \applications\Tekla\Tools\TplEd\settings folder. Do not make changes in this file. Below is an example of the file content, which may change between Tekla Structures versions.

```
//
// - Use only letters, numbers, slashes and underlines.

// Class = units { precision }

Length = mm, dm, cm, m, inch, ft, yd, inch-frac
{ 1/2, 1/4, 1/8, 1/16 }, ft-frac { 1/2, 1/4, 1/8, 1/16 }
Angle = Degrees, radians
Area = mm², cm², m², sq.inch, sq.ft, sq.yd
Area/length = mm²/m, cm²/m, dm²/m, m²/m, in²/in,
in²/ft, ft²/ft, sq.yd/ft
Volume = mm³, cm³, m³, cu.in, cu.ft, cu.yd
Weight = kg, T, N, lbf, kip
Weight/length = kg/m, T/m, N/m, daN/m, kN/m, lbf/ft
Density = kg/m³, T/m³, N/m³, kN/m³, lbf/ft³
Temperature = Kelvin, Celsius, Fahrenheit
Section_modulus = mm³, cm³, in³
Moment_of_inertia = mm⁴, cm⁴, in⁴
Warping_modulus = mm⁶, cm⁶, in⁶
Force = kg, T, N, daN, kN, lbf, kip
Force/length = kg/m, T/m, N/m, daN/m, kN/m, lbf/ft
Force/area = kg/m, kg/cm, kg/mm, T/m, T/cm, T/mm, N/m,
N/cm, N/mm, daN/m, daN/cm, daN/mm, kN/m, kN/cm, kN/mm, lbf/in, lbf/ft,
lbf/in, kip/in, kip/ft
Force/area = kg/m, kg/cm, kg/mm, T/m, T/cm, T/mm, N/m,
N/cm, N/mm, daN/m, daN/cm, daN/mm, kN/m, kN/cm, kN/mm, lbf/in, lbf/ft,
lbf/in, kip/in, kip/ft
Moment = kgm, Tm, Nm, daNm, kNm, lbf-in, lbf-ft,
kNm/m, kN/m/m, kNm/m, lbf-
ft/ft, kip-ft/ft
Moment = kgm, Tm, Nm, daNm, kNm, lbf-in, lbf-ft,
kNm/m, kN/m/m, kNm/m, lbf-
ft/ft, kip-ft/ft
Stress = kg/m², kg/cm², kg/mm², T/m², T/cm², T/
mm², N/m², N/cm², N/mm², daN/m², daN/cm², daN/mm², kN/m², kN/cm², kN/mm²,
psi, psf, ksi, ksf
Date = dd.mm.yyyy, mm.dd.yyyy, mm/dd/yyyy,
yyyy/mm/dd, dd-mm-yy, dd-mm-y, yyyy-mm-dd, dd/mm/y

Start new projects as a Tekla Structures administrator

Templates

204
4.7 Set up a project for collaboration and interoperability

Collaborative modeling allows several people to simultaneously work in the same Tekla Structures model. Importing to and exporting from Tekla Structures allows you to use the same models and data in Tekla Structures and in other software and systems.

Checklist for interoperability

If you plan to use collaborative modeling, decide which method you will use.

- If your company takes part in external projects, or if more than one user works with the same model at different locations, we recommend using Tekla Model Sharing. For more information, see What is Tekla Model Sharing.

- If users do not need to work simultaneously with other users on the same model, or you only need to give others viewing access to the model, you can use Trimble Connect for model coordination and exchange of other project files. For more information, see Trimble Connect.

Set up a project for collaboration and interoperability

Collaborative modeling allows several people to simultaneously work in the same Tekla Structures model. Importing to and exporting from Tekla Structures allows you to use the same models and data in Tekla Structures and in other software and systems.

Collaborative modeling for administrators

You can use Tekla Model Sharing or Trimble Connect for collaborative modeling.

If your company takes part in external projects, or if more than one user works with the same model at different locations, we recommend using Tekla Model Sharing. For more information, see What is Tekla Model Sharing.

If users do not need to work simultaneously with other users on the same model, or you only need to give others viewing access to the model, you can
use Trimble Connect for model coordination and exchange of other project files. For more information, see Trimble Connect.

**Management of Tekla Model Sharing**

In Tekla Model Sharing each user has a local version of the model, and the model data is shared and synchronized over the internet using a cloud sharing service.

Status information for the Tekla Model Sharing cloud sharing service and other online services is available on the Tekla Online status page. On this page, you can also find information about service breaks.

When a user shares a model, the organization that the user belongs to becomes the **model owner**. In Tekla Model Sharing, an organization always owns all the models shared by the users in the organization. A shared model is always owned by only one organization.

You can view and manage the shared models owned by your organization with the Management Console for Tekla Model Sharing. For more information, see:

- Manage shared models in Management Console for Tekla Model Sharing
- Managing Tekla Model Sharing as an administrator

**Install the cache service for Tekla Model Sharing**

Using the cache service for Tekla Model Sharing makes downloading model data faster when the same data is requested more than once, such as when several users in the same office are working in a shared model. The cache service is especially helpful in locations where download speed might be limited.

The cache service downloads model data from the Tekla Model Sharing service and caches the data in the file system in a local area network (LAN). The first time that a user fetches a packet, it is stored in the cache service. Any later requests for the same packet are served from the cache service in the LAN.

The cache is not used for packets that are written out.

The cache service is useful even if there is only one Tekla Model Sharing user in the same office. For example, rejoining a model is faster because the model data is available locally in the cache service. Also, because the model data is always loaded in small data blocks, the cache service can download any missing blocks later if the download is interrupted.

This image shows how the model data is stored in the sharing service and used with the cache service for Tekla Model Sharing.
NOTE If the cache service cannot be reached, Tekla Structures uses the cloud storage for model changes directly. Tekla Structures also uses the cloud storage if the connection to the cache service times out while a download operation is in progress.

You can see whether Tekla Structures is using the cache service by checking the `ClientLog_cat.txt` and `ClientLog_dog.txt` log files in the `\Users <user>\AppData\Local\Tekla DataSharing` folder.

Data is not automatically cleared from the cache service. To clear unnecessary data, you can delete old files from the cache service.

**Software and system requirements for cache service installation**

The computer or server where you install the cache service must have:

- One of these Windows operating systems:
  - Windows Server 2019 or later
  - Windows 10 or later
- Microsoft .NET Framework 4.8 or newer. This software is not included in the Tekla Model Sharing Cache server installation package.
- An internet connection to download model data from the sharing service
• Enough disk space to store the cached model data.

The required disk space can vary from a few gigabytes to terabytes, depending on the number of Tekla Model Sharing users and the size of the models.

Make sure that your firewall allows inbound traffic on TCP/IP ports 9001 and 9998 for the cache service host. If the ports cause conflicts with other services, you can change the ports in the Tekla Model Sharing cache server installer.

Install the cache service for Tekla Model Sharing

Before you begin, download the Tekla Model Sharing cache server installation file from Tekla Downloads.

1. Run the TeklaModelSharingCacheService.exe installation file and follow the steps in the installation wizard to complete the installation.
   • The default cache folder is C:\TeklaModelSharingCache. If needed, you can change the folder destination.
   • The default TCP/IP port number for the cache service is 9998.
     Use this port number when you configure Tekla Structures client workstations to use the cache. This port is the main communication and control channel to the cache service.
   • The default TCP/IP port number for internal communication is 9001.
     This port is automatically fetched from the cache service, and it is used for the data transfer.

2. Check that the Tekla Model Sharing Cache service has started.
   • Locate Tekla Model Sharing Cache from the Windows services by using, for example, the Computer Management console compmgmt.msc or the Services management console services.msc.
   • Use Windows Event Viewer to verify that there are no errors from the service and that there are Information messages showing that the service has started.

Modify settings for the cache service after installation

If needed, you can modify the settings for the cache service after installation, such as to change the previously set cache folder or port numbers.

To modify the settings, run the TeklaModelSharingCacheService.exe installation file again and select Repair.

   • If you change the previously set cache folder, copy any content that you want to continue using from the previous cache folder to the new folder.
   • If you change the port numbers, make sure that your firewall allows inbound traffic on the new ports.
Configure Tekla Structures client workstations to use the cache service

1. In Tekla Structures, on the File menu, click Sharing --> Sharing settings.
2. Configure the Tekla Model Sharing cache settings in the Sharing settings dialog box:
   a. In the Name box, enter the name of the computer on which the cache is installed.
      To check the computer name in Windows, select Windows Control Panel --> System and Security --> System.
      If the computer on which the cache is installed has a static IP address, you can enter the IP address in the Name box instead of the computer name.
   b. In the Port box, enter the cache service port number that you set when you installed the cache service.
      The default value is 9998.
3. Click Set.

Troubleshoot the cache service

<table>
<thead>
<tr>
<th>Problem</th>
<th>Possible solutions</th>
</tr>
</thead>
</table>
| Cannot connect to the cache service from Tekla Structures | • Ensure that the Tekla Model Sharing cache Windows Service is running.  
• Ensure that your firewalls allow inbound traffic on the TCP/IP ports configured for the cache service for Tekla Model Sharing. The default ports are 9001 and 9998. |
| Cache service does not start | Check the Application Log in the Windows Event Viewer for errors. |

Set the Log On account for the Tekla Model Sharing cache Windows service

If the Tekla Model Sharing cache service needs to access some special resources, such as shared network drives, ensure that the Log On account for the cache Windows service has permissions to access those resources. The Log On account also needs to have reading and writing permissions for the C:\ProgramData\Tekla\ModelSharingCache folder.

By default, the Log On account for the cache Windows service is Local System Account. You might need to change the account if the Local System Account does not have access to these folders and resources.

We recommend that you use the same account for installing the cache service and as the Log On account for the cache Windows service.
1. Right-click the cache Tekla Model Sharing cache Windows Service in the Services dialog box, then select Properties.

2. On the Log On tab, select This Account, then enter the account name and password.

3. Click OK.

Host your own potree point cloud data
Hosting your own potree point cloud data allows you to share point clouds across the internet using a URL. We recommend hosting your potree point cloud data on a Microsoft Azure Storage Account.

Create a potree file with Point cloud manager
You can download Point cloud manager from Tekla Warehouse.
For detailed instructions about using Point cloud manager, see the Point cloud manager help. You can open the help by clicking the help button.

1. Install the application, and start it from the start menu or start screen, depending on your Windows version.

2. Set the root folder for the project. For example, C:\Trimble\PTRS.

3. Create a new project.
   a. Click the Add new project button.

   b. In the Project name box, enter a name for the project.
This name will be the name of the potree database and potree folder.

4. Import one or more point cloud models:
   a. Click **Add file**.
   b. Browse for the point cloud file.

5. When the point cloud has been imported, click **Start** to start the conversion to potree.

6. Expand **Conversion settings**, select **Directory structure**, then click **Start**.

The potree data is now available in the root folder for the project.

**Configure an Azure Storage Account to host the point cloud data**

A Microsoft Azure subscription is required.

Before you begin, configure the security controls for your Azure subscription according to your organization's policies.
1. In the Azure Portal, create a new Azure storage account. For detailed instructions, see the Microsoft Azure documentation.

2. In the **Static website** settings, enable Static website.

   ![Static website settings](image)

   **TIP** The URLs in the **Primary endpoint** and **Secondary endpoint** boxes are generated automatically.

3. In the **CORS** settings, add a CORS rule for the **Blob service**, then configure the rule settings.

<table>
<thead>
<tr>
<th>CORS rule setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Allowed origins</strong></td>
<td>Specifies which domains are allowed to access the resources.</td>
</tr>
<tr>
<td></td>
<td>• If you only plan to use the data from your point cloud with the Connect 3D app, enter <code>https://3d.connect.trimble.com</code>.</td>
</tr>
<tr>
<td></td>
<td>• To allow all domains, enter <code>*</code>.</td>
</tr>
<tr>
<td><strong>Allowed methods</strong></td>
<td>Specifies which HTTP methods are allowed when making requests.</td>
</tr>
<tr>
<td></td>
<td>Enter <code>GET</code>.</td>
</tr>
<tr>
<td><strong>Allowed headers</strong></td>
<td>Specifies which HTTP headers are allowed when making requests.</td>
</tr>
<tr>
<td></td>
<td>To allow all headers, enter <code>*</code>.</td>
</tr>
<tr>
<td><strong>Exposed headers</strong></td>
<td>Specifies which headers JavaScript in browsers is allowed to access.</td>
</tr>
<tr>
<td></td>
<td>To allow all headers, enter <code>*</code>.</td>
</tr>
<tr>
<td><strong>Max age</strong></td>
<td>Specifies how long the results of a request can be cached.</td>
</tr>
<tr>
<td></td>
<td>Enter the number of seconds.</td>
</tr>
</tbody>
</table>
Upload potree data to your Azure Storage Account

1. In Azure Storage Explorer, navigate to your storage account, then browse to the $web blob container.
2. Copy the folder that contains the point clouds from C:\Trimble\PTRS to the storage for your blob container.
3. Copy the <potree_name> folder to a shared location.

**NOTE** Do not replace existing potree data, especially if it is used by other users.

Add a link to your point cloud data to your Trimble Connect Project

Add a point cloud URL from your computer or a drive.

1. Open your project in Trimble Connect for Windows.
2. Navigate to the 3D Viewer.
3. Open the Point Clouds panel.
4. Click Add URL.
5. Enter a name for the point cloud.
6. In the URL box, enter or paste the URL of the point cloud file.
   For example:
   https://potreehosting.z6.web.core.windows.net/pointclouds/example
7. Click Add.

When you click this file in the Trimble Connect 3D app, your point cloud opens.

Files for import and export

You can use several different file type to import to and export from Tekla Structures.

**See also**

Conversion files (page 214)
Create property sets for IFC export (page 217)
DSTV file description (page 229)
Conversion files

Conversion files (.cnv) map Tekla Structures profile, twin profile, and material names with names used in other software.

Conversion files are simple text files, containing the Tekla Structures name in the first column, and the name used in the other software package in the second column. Columns are separated by a space. All parametric profiles must be entered in the profile conversion file.

You can use the same conversion file both when importing and exporting models, and you can specify the location of conversion files in most of the import and export tools.

If you enter a conversion file name without a path, Tekla Structures searches for the file in the current model folder. If you leave the box empty, Tekla Structures searches for the file indicated by the advanced option XS_PROFDB in File menu --> Settings --> Advanced options --> File locations. This is also the case, if the tool does not allow you to define the path and conversion file.

Tekla Structures has several conversion files in the standard installation, and you can also create your own. Standard conversion files are located in the \profil folder under the environment folder ...\ProgramData\Trimble\Tekla Structures\<version>\environments\ folder. The exact location may vary depending on your environment. All conversion files have the .cnv extension.

Note that these instructions do not apply to all export and import types. If a tool has specific instructions regarding the conversion files, the instructions are included in the export or import instructions.
Create conversion files
You can create your own conversion files if the ones that come with Tekla Structures installation do not suit your needs.

1. Open an existing conversion file using any standard text editor.
   By default, conversion files are located in the `\profil` folder under the `environment folder`...`\ProgramData\Trimble\Tekla Structures <version>\environments\`. The exact location may vary depending on your environment.

2. Save the file with another name.
   If the export/import tool allows you to define the path to the conversion file, you can save the file where you like. If this is not the case, save the file in a location defined by the advanced option `XS_PROFDB` in *File menu --> Settings --> Advanced options --> File locations*.

3. Modify the file: enter profile names recognized by Tekla Structures in the first column, and the corresponding name recognized by the other software in the second column.
   While modifying, ensure that:
   - You do not have blank material definitions (" ", empty quotation marks).
   - You do not have spaces in the profile position strings. For example, enter "Hand_Rail" not Hand Rail".

4. Save your changes.

**NOTE**
- All the three files (profile, twin profile and material) are not needed if the differences in the profile name is just concerning * X or x formats, because these are normally handled automatically. For example, if you wanted to import UC254x254x73 to be UC254*254*73, the lower case "x" is automatically changed to "X" so the format of the conversion file would be UC254*254*73 254X254X73.
- If you have problems importing the model, check any error messages in the Tekla Structures log file, and check the conversion files.

**Example**
Below are some examples of conversion files:

**SDNF**

```
! Profile name conversion Tekla Structures -> SDNF
!
! If Converted-name does not exist, it will be the same
```
as Tekla Structures-name.

Tekla Structures-name Converted-name

C10X15.3  C10X15.3
C10X20    C10X20
C10X25    C10X25
C10X30    C10X30
C12X20.7  C12X20.7
C12X25    C12X25
C12X30    C12X30
C15X33.9  C15X33.9
C15X40    C15X40
C15X50    C15X50
C3X4.1    3X4.1

DSTV

Profile name conversion Tekla Structures -> DSTV

If Converted-name does not exist, it will be the same
as Tekla Structures-name.

DSTV

Profile name conversion Tekla Structures -> DSTV

If Converted-name does not exist, it will be the same
as Tekla Structures-name.

Below there is first an example of an incorrect conversion file and then of a correct one, errors are highlighted:

00100782 4 0 2 "brace" "Tread 4" 1 "TREAD4.5" "" 0.000000 0 0
0.000000 1.000000 0.000000 16.250000 13.154267 3.857143
15.500000 13.154267 3.857143 0.000000 0.000000 0.000000

Start new projects as a Tekla Structures administrator

Set up a project for collaboration and interoperability
Twin profile conversion files
Tekla Structures contains separate conversion files for twin profiles, and it reads the twin profile conversion file before the profile conversion file, so you must include the profiles from the original model in the import.

The twin profile conversion file is a text file containing the profile prefix (characters only) and the distance between the profiles in mm, separated by a space. Tekla Structures converts all profiles with the specified prefix to twin profiles.

The twin profile conversion file could be named twin_profiles.cnv and it could contain lines such as the one below:

```
DL 20
```

The distance between the profiles is the same for all profiles with the same profile prefix. For example, profiles with the prefix DL will always have the same spacing. If you want different spacing values, then you need to use a different profile prefix.

You also need to add the twin profile to the profile conversion file to get the DL profile converted to L-profile:

```
L200*20 DL200/20-20
```

Limitations
• Twin profile conversion cannot be used for profiles that start with a number. This means that you cannot define double angles as 2L. Instead, you need to use DL as the prefix for a twin profile, for example:

```
DL200/20-20
```

• Twin profile conversion does not work for FEM import. We recommend that each angle is modeled separately rather than as twin profiles, as SP3D does not control the gaps between members in the same way as Tekla Structures and there are, for example, various conversion and mapping difficulties. It is easier to convert members that are modeled as two members.

Create property sets for IFC export
You can create property sets from template attributes and user-defined attributes, define properties for the attributes, and bind the Tekla Structures
property sets to IFC entities for IFC export. You can save the property sets in property set configuration files.

You can use the default property sets, and you do not need to create any custom property sets if the default property sets work for you. You can also modify the default property sets. In addition, you can import buildingSMART property sets.

When Tekla Structures exports an IFC file, it uses the configuration file you selected in the Property sets list to export property sets with the exported IFC entities. The list of configuration files includes predefined files located in your environment folders and files stored in the \AdditionalPsets folder under the current folder.

The Property set definitions dialog box allows you to add and modify the property sets needed in the IFC export. The property set configuration files that you create, will be visible in both IFC2x3 export and IFC4 export.

**NOTE** We recommend that you define property sets only in the Property set definitions dialog box instead of modifying the file itself to ensure that the XML configuration files are valid.

[Diagram of Property set definitions dialog box]

(1) The name of the selected property set configuration file. In the list, you can see all the available configuration files stored in your environment folders, and select the desired file. The file is loaded automatically after selection.

Use the 📃 Save button to save the changes in the configuration file after you have added or modified the property sets. You can also give a new name for...
the configuration file and save it. New and modified configuration files are saved in the \AdditionalPsets folder under the current model folder. You can also read configuration files from the following folders:

XS_FIRM
XS_PROJECT
XS_SYSTEM

Use the button to clear the contents of the displayed configuration file and create a new configuration file.

(2) To show in the list only the property sets and properties that you have selected using the Include check box, select Show only included.

(3) Property sets in the current configuration file. You can drag property sets up or down in the list.

(4) Search for a specific property set. The list of property sets might be very long, and the search could be very useful when you want to find and select a specific property set.

(5) Show only the property sets for the selected IFC entities.

(6) Show only the property sets for the selected IFC versions.

(7) To export all property sets and all properties in the list, select the Include check box on the title row for the property set or properties section. To export only the needed property sets and properties for different export purposes, select the check box next to a specific property set or property.

(8) Filters allowing you to further limit for which objects to export the property set. For example, specify a filter to further limit which IfcBeam objects to export the property set for, like for steel beams only.

(9) Command buttons for working with property sets:

Add buildingSMART property sets. The property sets beginning with Pset_ or Qto_ are buildingSMART property sets. The buildingSMART property sets are protected, and you cannot change the IFC entities that they are exported with, or edit the names of the properties they contain. However, you can edit the properties in the buildingSMART property sets, and select to include or exclude them.

Add a property set.

Edit the selected property set.

Delete the selected property set.
Duplicate the selected property set. You can then modify the property set so that the properties are the same but the filtering criteria are different, for example.

(10) Properties in the selected property set. You can drag properties up or down in the list.

(11) To enlarge the property set section or the property section, drag the dialog box divider up or down.

(12) Command buttons for working with properties:

- Add a property in the selected property set.
- Edit the selected property.
- Delete the selected property from the selected property set.

Create a custom IFC property set configuration file

In addition to the default configuration files, you can create custom configuration files.

1. On the File menu, click Export --> IFC or Export --> IFC4.

2. Select <new> from the Property sets list and click the Edit button.
   The Property set definitions dialog box opens.
   You can also create a new configuration file in the Property set definitions dialog box by clicking the button next to the button at the top.

3. Add the needed property sets. For details, see "Add property sets" below.

4. Enter a name for the configuration file.

5. Click Save.
   New and modified configuration files are saved in the \AdditionalPsets folder under the current model folder. You can also read configuration files from the following folders:
   - XS_FIRM
   - XS_PROJECT
   - XS_SYSTEM
   Next, add property sets in the configuration file.
Add property sets
You can add both custom property sets and buildingSMART property sets in a configuration file. For example, you can add COGs and start and end points on the part level, and scheduling information on the assembly level.

1. In the Property set definitions dialog box, open a property set configuration file.

2. To add a custom property set, in the property set section, click Add property set to this configuration file.

3. In the Add property set dialog box, enter the property set name and description.

   The property set name may contain any text, including spaces. The maximum length of the property set name is 255 characters. Do not start the property set name with prefixes Pset_ or Qto_, these prefixes are reserved for buildingSMART property sets.

4. You can use a filter to further limit which objects get exported with a given property set.
For example, specify a filter to further limit which IfcBeam objects to export the property set for, like for steel beams only.

Do one of the following:

- Select an existing filter from the list of filters.

- Create a new filter: click the Display filter button. In the Object group - IFC property export dialog box, create a filter, set Filter type to IFC property export, and save the filter.

5. Select the IFC entities for the property set. You must select at least one IFC entity.

6. To save the new property set, click Add. Now you can add properties in the new property set, see "Add properties in a property set" below.

7. To add buildingSMART property sets, click Import buildingSMART property sets. For details about adding buildingSMART property sets, see "Add a buildingSMART property set" below.

8. When you have added all the property sets and properties, click Save to save the current configuration file.

When you have several property sets in the list, you can drag those up or down in the list.

**Add properties in a property set**

You can add properties in an existing property set.

The buildingSMART property sets are protected, and you cannot add properties in those. Property sets with names beginning with Pset_ or Qto_ are buildingSMART property sets. However, you can modify the properties included in buildingSMART property sets.

1. Open a property set configuration file in the Property set definitions dialog box.

---

Start new projects as a Tekla Structures administrator 222  Set up a project for collaboration and interoperability
2. Select a property set from the property set list, and in the property section, click **Add property to this property set**.

In the displayed **Add property** dialog box, all the default properties are listed. You can search for properties, or use the **Group** drop-down options to narrow down the list according to the object type.

3. Click a property to select it. When you have selected a property, **Name**, **Tekla property**, and **Type** are filled in automatically.

You can change the **Name** of the property. Once you have changed the **Name**, it no longer changes automatically.

4. To change the type of the property, click the **Type** drop-down.

The **Type** can be one of the following:
- **String**: sequence of characters
- **Boolean**: true or false
- **Integer**: a whole number
- **Measurement**
- **Real**: a number that has a decimal representation
- **Time stamp**

5. If you selected **Measurement** as the type, more settings are displayed:

   **Measurement type**: Select the appropriate measurement type from the list.

   **Conversion**: Select the unit conversion factor. The available options depend on the selected measurement type.

   ![Conversion Options](image)

   In the area property conversion, the 1E-06 factor is used, and 1E-06 = 0.000001. For example, 1 m² is 1000000 mm² in Tekla Structures. In IFC, the area unit is m², and the Tekla Structures value needs to be converted by 1E-06: 1000000 mm² × 1E-6 = 1 m².

   In the volume property conversion, the 1E-09 factor is used, and 1E-09 = 0.000000001.

   **Accuracy**: Indicate the accuracy that is used when writing the property to IFC. Enter decimals, for example, 0.1 or 0.01. For example with length, when accuracy is 0.1, with a 1000 mm IFC file the value would be 1000.0. If accuracy was 0.01, the value would be 1000.00. If the accuracy was 0.5, the Tekla Structures value 1000.6 would be 1000.5, 1000.8 would be 1001.0, and 1000.2 would be 1000.0.

   You cannot change the **Source** value, it is either **Template** (page 195) or **UDA** (page 196) depending on the property that you selected.

6. Select the desired values and click **Add**.

7. To save the changes in the property set configuration file, click **Save**.

   When you have several properties in the list, you can drag those up or down in the list. To modify the created property set, select the property set and click **Modify selected property set**.
Add a buildingSMART property set
You can add buildingSMART property sets to property set configuration files.

1. In the Property set definitions dialog box, open the property set configuration file where you want to add buildingSMART property sets.

2. Click the Import buildingSMART property sets button on the right.

3. Select the property sets that you want to add. To do this, select the Import check box next to the property set. You can search for property sets using the Search box. You can also limit the number of the displayed property sets by selecting the desired property set categories, IFC entities, or IFC versions.

4. Click Import. The selected buildingSMART property sets are added in the property set list. The buildingSMART property sets are protected, and you cannot edit those, but you can exclude the unnecessary buildingSMART property sets from the export, and change and edit the mapped Tekla properties.

5. To save the changes in property set configuration file, click Save.

Delete a property set
If a property set is no longer needed, you can delete it from the configuration file.
1. In the **Property set definitions** dialog box, a custom property set configuration file.

2. Select a property set from the property set list.

3. Click the **Delete selected property sets**.

4. To save the changes in property set configuration file, click **Save**.

   If you do not want to include the property set in the export but still want to leave the property set in the configuration, clear the **Include** check box next to the property set.

**Delete properties from a property set**

If a property is no longer needed in a property set, you can delete it.

The buildingSMART property sets (beginning with prefixes *Pset_* or *Qto_*) are protected, and you cannot delete properties from those. However, you can exclude properties included in buildingSMART property sets, see section "Include or exclude property sets or properties" above.

1. Open a property set configuration file in the **Property set definitions** dialog box.

2. In the property set list, select a property set from which you want to delete a property.

3. Select a property from the property list.

4. Click the **Delete selected property**.

   If you do not want to include the property in the export but still want to leave the property in the property set, clear the **Include** check box next to the property.

**Duplicate a property set**

When you want to have a new property set that is very similar to an existing property set, you can duplicate the existing property set. You can then modify the property set so that the properties are the same but the filtering criteria is different, for example.

You cannot duplicate a buildingSMART property set.

1. Open a property set configuration file in the **Property set definitions** dialog box.

2. In the property set list, select a property set that you want to duplicate.

3. Click **Duplicate selected property set**.

   The property set is duplicated and added under the original property set in the list.
4. To modify the property set, select the duplicated property set and click Modify selected property set. Change the property set name, select the desired entities, and specify another selection filter, for example.

Change the property set name, select the desired entities, or specify a selection filter that exports the property set for some other objects, for example.

5. When you are done, click Modify.

Include or exclude property sets or properties
You can keep a property set or a property in the configuration file, but exclude it from the export.
You can also exclude buildingSMART property sets and properties.
1. On the File menu, click Export --> IFC or Export --> IFC4.
2. Select an existing property set from the Property sets list and click the Edit button.
3. Do one of the following:
   • To export all property sets in the list, select the Include check box on the title row of the property set section.
   • To export all properties for the selected property set, select the Include check box on the title row of the properties section.
   • To export only the needed property sets, select the check boxes next to the property sets.

   • To export only the needed properties for the selected property set, select the check boxes next to the properties.

4. To save the changes in property set configuration file, click Save.
Property set configuration file contents

A property set configuration file contains the structure of the property sets, and the data definitions for the properties inside the property sets.

When configuring property sets for IFC export in XML format, two files are needed:

- IfcPropertySetConfigurations.xsd is a schema file that describes the structure of the XML file and is used for validation of the XML file. This file is read when the software is started. There is only one schema file in your environment. You do not need to touch this file.
- The XML file <configuration_file_name>.xml is the actual property set configuration file.

The modified configuration files are saved in the \AdditionalPSets folder under the model, and they are also read from the system, project, and firm folders.

- The property set XML configuration file contains the following definitions:
  - Template attribute or UDA name. Template attributes are read from contentattributes_global.lst and the user-defined attributes from the environment database.
  - Data type, such as String, Integer, Float, Timestamp, Boolean, Logical, or planeanglemeasure.
  - Unit type, such as length, area, volume, or mass.
  - Unit value scaling of unitless UDA values. Conversion factor is added so that unitless values can be converted to correspond to the global units used in the IFC files. Area and volume units need these factors.
  - Possibility to use default values.
  - Possibility to ignore the set to export if template attribute or UDA does not have a value.
- Below is an example of the contents of a property set configuration XML file.

```xml
<PropertySet referenceId="assemblies" isIgnored="false">
  <Name>Tekla Assembly</Name>
  <Description>Assembly Properties</Description>
  <Properties>
    <Property xsi:type="PropertySingleValueType" optional="true" isIgnored="false">
      <Name>Assembly/Cast unit Mark</Name>
      <PropertyValue xsi:type="StringValueType" stringType="IfcLabel">
        <GetValue xsi:type="TemplateVariableType">
          <TemplateName>ASSEMBLY_POS</TemplateName>
        </GetValue>
      </PropertyValue>
    </Property>
    <Property xsi:type="PropertySingleValueType" optional="true" isIgnored="false">
      <Name>Assembly/Cast unit position code</Name>
      <PropertyValue xsi:type="StringValueType" stringType="IfcLabel">
        <GetValue xsi:type="TemplateVariableType">
          <TemplateName>ASSEMBLY_POS</TemplateName>
        </GetValue>
      </PropertyValue>
    </Property>
  </Properties>
</PropertySet>
```
• The configuration file also contains the rules for binding the property sets to IFC entities:
  • Binding to IFC entity type hierarchy including support for not only building elements but also for bolts, reinforcing bars, and assemblies.
  • You have the possibility to use limiting rules, such as Equal, NotEqual, LessThan, GreaterThan, LessThanOrEqual, and GreaterThanOrEqual for numbers, and Equal and NotEqual for texts.
    If you want to add any limiting rules, you need to modify your custom property set configuration file using a suitable text editor.
  • There can be any number of binding rules for any property set, but only one property set definition for each referenceId.
  • You can bind different property sets to different IFC entity types. For example, a plate may have a different property set than a beam.

```
<PropertySetBind referenceId="assemblies">
  <Rules>
    <Include entityType="IfcElementAssembly" subtypes="true" />
  </Rules>
</PropertySetBind>
```

• If no value is found for a property in the export, the export does not write the property set at all. To avoid this, add optional=true for that property in the property set.

**DSTV file description**

Tekla Structures produces NC files in DSTV format. DSTV format is an industrial standard defined by the German Steel Construction Association (Deutsche Stahlbau-Verband). A DSTV file is a text file in ASCII format. In most cases each part has its own DSTV file.
To learn more about the DTSV syntax, see Standard Description for Steel Structure Pieces for the Numerical Controls.

**Blocks**
The DTSV file is divided into blocks that describe the content of the file.

<table>
<thead>
<tr>
<th>DSTV block</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ST</td>
<td>Start of the file</td>
</tr>
<tr>
<td>EN</td>
<td>End of the file</td>
</tr>
<tr>
<td>BO</td>
<td>Hole</td>
</tr>
<tr>
<td>SI</td>
<td>Hardstamp</td>
</tr>
<tr>
<td>AK</td>
<td>External contour</td>
</tr>
<tr>
<td>IK</td>
<td>Internal contour</td>
</tr>
<tr>
<td>PU</td>
<td>Powder</td>
</tr>
<tr>
<td>KO</td>
<td>Mark</td>
</tr>
<tr>
<td>KA</td>
<td>Bending</td>
</tr>
</tbody>
</table>

**Profile types**
Profile types are named according to the DTSV standard.

<table>
<thead>
<tr>
<th>DSTV profile type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td>I profiles</td>
</tr>
<tr>
<td>U</td>
<td>U and C profiles</td>
</tr>
<tr>
<td>L</td>
<td>L profiles</td>
</tr>
<tr>
<td>M</td>
<td>Rectangular tubes</td>
</tr>
<tr>
<td>RO</td>
<td>Round bars</td>
</tr>
<tr>
<td>RU</td>
<td>Round tubes</td>
</tr>
<tr>
<td>B</td>
<td>Plate profiles</td>
</tr>
<tr>
<td>C</td>
<td>C profiles</td>
</tr>
<tr>
<td>T</td>
<td>T profiles</td>
</tr>
<tr>
<td>SO</td>
<td>Z profiles and all the other types of profile</td>
</tr>
</tbody>
</table>

**Part faces**
Single letters in the DTSV file describe the part faces.

<table>
<thead>
<tr>
<th>Letter</th>
<th>Part face</th>
</tr>
</thead>
<tbody>
<tr>
<td>v</td>
<td>front</td>
</tr>
<tr>
<td>o</td>
<td>top</td>
</tr>
<tr>
<td>u</td>
<td>bottom</td>
</tr>
<tr>
<td>h</td>
<td>behind</td>
</tr>
</tbody>
</table>
**tekla_dstv2dxf_<env>.def file description**

The *tekla_dstv2dxf_<env>.def* file is used when converting from the DSTV to the DXF format using the *tekla_dstv2dxf.exe*. It contains all the necessary conversion settings. The .def file is located in the ..\Tekla Structures\<version>\bin\applications\Tekla\Tools\dstv2dxf folder.

The DSTV to DXF conversion settings are described below.

**Environment settings [ENVIRONMENT]**

**INCLUDE_SHOP_DATA_SECTION=FALSE**

Specify whether to include a special data section in the DXF file to allow the DXF file to be better imported into CNC software written by Shop Data Systems. Including this special data section in the DXF file makes the DXF file unreadable by AutoCAD.

**Options:** TRUE, FALSE

**NO_INFILE_EXT_IN_OUTFILE=TRUE**

Use to add the input file extension to the output file.

**Options:**

- TRUE: p1001.dxf
- FALSE: p1001.nc1.dxf

**DRAW_CROSSHAIRS=HOLES**

Draw crosshair for holes and slotted holes.

**Options:** HOLES, LONG_HOLES, BOTH, NONE

**HOLES:**

![Image of HOLES crosshair]

**LONG_HOLES:**

![Image of LONG_HOLES crosshair]

**BOTH:**

![Image of BOTH crosshair]
SIDE_TO_CONVERT=FRONT
Define which side of the member to convert.
Options: FRONT, TOP, BACK, BELOW
Defines which part face is shown in the DXF file. This setting is originally designed for plates.
FRONT is the most typical option. Sometimes you may need another rotation for a plate, and then you can try if changing this setting to BACK would help. In addition to the SIDE_TO_CONVERT setting, it requires that the NC files are created with the advanced option XS_DSTV_WRITE_BEHIND_FACE_FOR_PLATE set to TRUE, which will include the back side data of a plate in the NC file.

OUTPUT_CONTOURS_AS=POLYLINES
Convert contours as polylines or lines and arcs.
Options: POLYLINES, LINES_ARCS

NOTE  If you set OUTPUT_CONTOURS_AS=LINES_ARCS:
  • Slotted holes may sometimes have a gap/offset between a straight line and an arc.
  • Sometimes a 3D DXF is produced instead of a 2D DXF.
If you set OUTPUT_CONTOURS_AS=POLYLINES, the DXF file may not be correct if the NC is created with the Inner corner=0 setting.

CONTOUR_DIRECTION=REVERSE
Define the contour direction. This option changes the coordinates of the vertices, and the order they are written. You can see the difference if you open the DXF file in a text editor: "reverse" is clockwise and "forward" is counterclockwise.
Options: REVERSE, FORWARD
CONTOUR_DIRECTION only works if you have set OUTPUT_CONTOURS_AS=POLYLINES. If you have set it to use LINES_ARCS, the output is always FORWARD (counter-clockwise).

CONVERT_HOLES_TO_POLYLINES=TRUE
Convert holes to polylines.

Options: TRUE, FALSE

MAX_HOLE DIAMETER_TO_POINTS=10.0
Convert small holes to points in the DXF file.

When you set MAX_HOLE_DIAMETER_TO_POINTS to a value, the holes with a diameter smaller than this value will follow the HOLE_POINT_SIZE and HOLE_POINT_STYLE settings. With this kind of point visualization, the hole symbols will no longer show if a hole is bigger or smaller than the other one, but they will all have the same size.

HOLE_POINT_STYLE=33 and HOLE_POINT_SIZE=5
Point style and size for holes.

1 is a circle, but this setting is not in use
2 is +
3 is X
4 is short line
33 is circle
34 is a circle with +
35 is a circle with X
36 is a circle with short line

**SCALE_DSTV_BY=0.03937**
Use 0.03937 to scale to imperial units.
Use 1.0 to scale to metric units.

**ADD_OUTER_CONTOUR_ROUNDINGS=FALSE**
Add holes to roundings. This only affects the roundings that are created using the Inner corners shape: 1 setting in the NC file settings dialog box on the Holes and cuts tab. The hole size information is coming to the DSTV file from the Radius value in the NC file settings dialog box, and you cannot adjust the hole size in the dstv2dxf converter.

Options: TRUE, FALSE

ADD_OUTER_CONTOUR_ROUNDINGS=FALSE:

![ADD_OUTER_CONTOUR_ROUNDINGS=FALSE](image1)

ADD_OUTER_CONTOUR_ROUNDINGS=TRUE:

![ADD_OUTER_CONTOUR_ROUNDINGS=TRUE](image2)

**MIN_MATL_BETWEEN_HOLES=2.0**
Define how close the holes can be to each other in slotted hole conversion.

**INPUT_FILE_DIR=** and **OUTPUT_FILE_DIR=**

Start new projects as a Tekla Structures administrator

234

Set up a project for collaboration and interoperability
Folders for input and output files.

**DEBUG**=FALSE

Show data processing in the DOS window.

Options: TRUE or FALSE

**Text specifications** [TEXT_SPECS]

**TEXT_OPTIONS**=PQDG

Define the text options that you want to use in the DXF file:

S adds a side mark (Side: v)
P adds a part mark (Part: P/1)
B adds a part mark and side mark (Part: P/1 Side: v)
Q adds the quantity (Quantity: 5)
G adds the steel grade (Material: A36)
T adds the thickness (Thickness: 3)
D adds the profile description (Desc: FL5/8X7)

**TEXT_POSITION_X=30.0 and TEXT_POSITION_Y=30.0**

The X/Y location of lower-left corner of first line of text from the origin point <0,0> of the DXF file.

**TEXT_HEIGHT=0.0**

TEXT_HEIGHT is not used, the text height is always 10.0, also in text layers.

**Text item prefixes**

You can define several different prefixes for text items. The prefix is only written in the file if the option **CONCATENATE_TEXT** is set to 0.

You can use the following prefix definitions:

- **PART_MARK_PREFIX**=Part:
- **SIDE_MARK_PREFIX**=Side:
- **STEEL_QUALITY_PREFIX**=Material:
- **QUANTITY_PREFIX**=Quantity:
- **THICKNESS_PREFIX**=Thickness:
- **DESCRIPTION_PREFIX**=Desc:

**CONCATENATE_TEXT**=1

Combine text items (part mark, quantity, profile, grade) into one or two lines.

Options:

0: Text lines are not combined. Prefixes work only with this option.
1: Part mark text on one line, other texts combined on another line.
Define a separator of max 19 characters for the text items.

**Examples of different text specifications**

The following settings are used the example below:

```
TEXT_OPTIONS=PQDG
TEXT_POSITION_X=30.0
TEXT_POSITION_Y=30.0
TEXT_HEIGHT=0.0
PART_MARK_PREFIX=Part:
SIDE_MARK_PREFIX=Side:
STEEL_QUALITY_PREFIX=Material:
QUANTITY_PREFIX=Quantity:
THICKNESS_PREFIX=Thickness:
DESCRIPTION_PREFIX=Desc:
CONCATENATE_TEXT=1
CONCATENATE_CHAR=+
```

The following settings are used for the example below: TEXT_OPTIONS=B, CONCATENATE_TEXT=0:

```
Part: 1014 Side: v
```
### Miscellaneous layers [MISC_LAYERS]

<table>
<thead>
<tr>
<th>Entity</th>
<th>Layer Name</th>
<th>Color</th>
<th>Text Height</th>
<th>Output as</th>
</tr>
</thead>
<tbody>
<tr>
<td>TEXT</td>
<td>TEXT</td>
<td>7</td>
<td>Not used, always the same as the general text height definition 10.0.</td>
<td></td>
</tr>
<tr>
<td>OUTER_CONTOUR</td>
<td>CUT</td>
<td>7</td>
<td></td>
<td></td>
</tr>
<tr>
<td>INNER_CONTOUR</td>
<td>CUTOUT</td>
<td>4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PART_MARK</td>
<td>SCRIBE</td>
<td>3</td>
<td>Do not set a value for this option. If you set one, the DXF file will not be created.</td>
<td></td>
</tr>
<tr>
<td>PHANTOM</td>
<td>LAYOUT</td>
<td>4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>NS_POP_PMARK</td>
<td>NS_POP_MARK</td>
<td>5</td>
<td></td>
<td>POP_CIRCLE 2.0 (POP_CIRCLE or POP_POINT followed by size)</td>
</tr>
<tr>
<td>FS_POP_PMARK</td>
<td>FS_POP_MARK</td>
<td>6</td>
<td>1.0</td>
<td>POP_CIRCLE 2.0 (POP_CIRCLE or POP_POINT followed by size)</td>
</tr>
</tbody>
</table>

**Color table**

1 = red  
2 = yellow  
3 = green  
4 = cyan  
5 = blue
6 = magenta
7 = white
8 = dark grey
9 = light grey

Hole layers [HOLE_LAYERS]

<table>
<thead>
<tr>
<th>Layer Name</th>
<th>Min Diam</th>
<th>Max Diam</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>P1</td>
<td>8.0</td>
<td>10.31</td>
<td>7</td>
</tr>
<tr>
<td>P2</td>
<td>10.32</td>
<td>11.90</td>
<td>7</td>
</tr>
<tr>
<td>P3</td>
<td>11.91</td>
<td>14.0</td>
<td>7</td>
</tr>
</tbody>
</table>

Slot layers [SLOT_LAYERS]

The type and color affect the symbol, but the color of the slot outline or arrow (phantom) is defined by the PHANTOM layer definition in the MISC_LAYERS definition.

<table>
<thead>
<tr>
<th>Layer Name</th>
<th>Min Diam</th>
<th>Max Diam</th>
<th>Min ‘b’</th>
<th>Max ‘b’</th>
<th>Min ‘h’</th>
<th>Max ‘h’</th>
<th>Typ</th>
<th>Colo</th>
<th>Phantom</th>
</tr>
</thead>
<tbody>
<tr>
<td>13_16x1</td>
<td>20.6</td>
<td>20.6</td>
<td>4.75</td>
<td>4.78</td>
<td>0.0</td>
<td>0.02</td>
<td>3</td>
<td>3</td>
<td>PHANTOM_OUTLINE</td>
</tr>
<tr>
<td>13_16x1-7_8</td>
<td>20.6</td>
<td>20.6</td>
<td>26.9</td>
<td>26.9</td>
<td>0.0</td>
<td>0.02</td>
<td>3</td>
<td>3</td>
<td>PHANTOM_OUTLINE</td>
</tr>
</tbody>
</table>

Below there are three examples with different phantom types. The other settings used are Slot type=1, HOLE_POINT_STYLE=33 and HOLE_POINT_SIZE=1

PHANTOM_ARROW:

PHANTOM_BOTH:

PHANTOM_OUTLINE:
For an explanation of the “b” and “h” dimensions, see the image below:

Examples of slot types
These example use different slot types, but the other setting are the same:

- Slot layer color is 3 (green).
- Hole layer color is 6 (magenta).
- Phantom layer color is 1 (red).
- Slot layer phantom type: PHANTOM_OUTLINE
- Hole point settings: HOLE_POINT_STYLE=35, HOLE_POINT_SIZE=10

<table>
<thead>
<tr>
<th>Slot type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SLOT_TYPE_1</td>
<td>One hole symbol to the center of slot. The hole symbol follows the HOLE_POINT_STYLE and HOLE_POINT_SIZE settings. The slot symbol is created according to the selected phantom setting (PHANTOM_OUTLINE in this</td>
</tr>
<tr>
<td>Slot type</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>example)</td>
<td>The circle color follows the slot layer color, and the slot color follows the phantom layer color.</td>
</tr>
<tr>
<td>SLOT_TYPE_2</td>
<td>Two hole symbols to the slot. The hole symbol follows the HOLE_POINT_STYLE and HOLE_POINT_SIZE settings. The slot symbol is created according to the selected phantom setting (PHANTOM_OUTLINE in this example). The hole symbol color follows the hole layer color, and the slot color follows the phantom layer color.</td>
</tr>
<tr>
<td>SLOT_TYPE_3</td>
<td>One circle to the center of slot. The size of the circle corresponds to the real hole size. The circle color follows the slot layer color, and the slot color follows the phantom layer color. The slot symbol is created according to the selected phantom setting (PHANTOM_OUTLINE in this example).</td>
</tr>
<tr>
<td>SLOT_TYPE_4</td>
<td>Two circles to the slot. The size of the circle corresponds to the real hole size. If the circles would be touching each other, only one circle in the middle of slot is created. The slot symbol is created according to the selected phantom setting (PHANTOM_OUTLINE in this example). The circle color follows the hole layer color, and the slot color follows the phantom layer color.</td>
</tr>
<tr>
<td>SLOT_TYPE_5</td>
<td>Hole symbol to the first slot center point. The hole symbol follows the HOLE_POINT_STYLE and HOLE_POINT_SIZE settings. The slot symbol is created according to the selected phantom setting (PHANTOM_OUTLINE in this example). The hole symbol color follows the hole layer color, and the slot symbol color follows the phantom layer.</td>
</tr>
<tr>
<td>SLOT_TYPE_6</td>
<td>One circle to the first slot center point. The slot symbol is created according to the selected phantom setting (PHANTOM_OUTLINE in this example). The circle color follows the hole layer color, and the slot symbol color follows the phantom layer color.</td>
</tr>
<tr>
<td>SLOT_TYPE_7</td>
<td>No hole symbol is created. The slot symbol is created according to the selected phantom setting (PHANTOM_OUTLINE in this example). The slot color follows the slot layer color.</td>
</tr>
</tbody>
</table>
**ASCII file description**

In an `import.asc` file each part is described by 8 lines. These lines are repeated for each part to be transferred. Units are always in millimeters, blanks are used as separators.

Below is an example of a beam part description:

```
import.asc
4169 HEA300 1
290.000000 8.500000 300.000000 14.000000 300.000000 14.000000
A/6 BEAM
5235JR 5235JR
0.000000
16.500000 24000.000000 4855.000000
6000.000000 24000.000000 4855.000000
16.500000 24000.000000 5855.000000
```

<table>
<thead>
<tr>
<th>Line</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line 1</td>
<td>4169 HEA300 1 = ID profile type</td>
</tr>
<tr>
<td></td>
<td>• ID 4169: Unique ID (integer).</td>
</tr>
<tr>
<td></td>
<td>• PROFILE HEA300: Profile name (string).</td>
</tr>
<tr>
<td></td>
<td>• TYPE 1: Profile type (integer)</td>
</tr>
</tbody>
</table>

The available profile types are:

0 = free cross section (can be used for special profiles which are not in the database)
1 = I profiles
2 = Welded hollow core profiles (HK, HQ)
3 = U profiles
4 = L profiles
5 = Round bars
6 = Round tubes
7 = Rectangular hollow core sections (RHS, P)
8 = T profiles
9 = Rectangular bars (FL, PL)
10 = Z profiles
11 = C profiles
12 = Omega profiles
13 = Sigma profiles
<table>
<thead>
<tr>
<th>Line</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>14</td>
<td>Rail profile</td>
</tr>
<tr>
<td>16</td>
<td>Reinforcement bars (DH)</td>
</tr>
</tbody>
</table>

Line 2
The contents of line 2 depend on the part profile.

- Polygon plates:
  - N_POINTS COORDINATES
    - N_POINTS: For profiles of type 0.
    - COORDINATES: Number of the corner points (integer).
    - The X and Y coordinates of the plate corners (floating). Rotation direction is clockwise. Coordinates follow the global coordinate system. Z coordinates are taken from the center line in the plate thickness direction.
    - Note that the line 2 can be divided into several rows in the file.

- Profiles:
  - For profile types 1-16, the line includes the physical dimensions of the cross section.
  - HEIGHT S W1 T1 W2 T2: 290.000000 8.500000 300.000000 14.000000 300.000000 14.000000
    - HEIGHT 290.000000: Height of the cross section
    - S 8.500000: Web thickness.
    - W1 300.000000: Width of the upper flange.
    - T1 14.000000: Thickness of the upper flange.
    - W2 300.000000: Width of the lower flange.
    - T2 14.000000: Thickness of the lower flange.

Line 3
A/6 BEAM = mark name

- MARK A/6: Position mark of the part (string).
- NAME BEAM: Part name (string).

Line 4
S235JR S235JR = material

Material of the part (string).

Line 5
0.000000 = rotation

Rotation angle (in degrees) around the local x-axis of the beam.

Line 6
16.500000 24000.000000 4855.000000 = X1 Y1 Z1

Coordinates of the beam start point. Z coordinates are center-line coordinates.
### 4.8 Customize catalogs and databases

You can customize catalogs and databases to contain the only relevant content for your project. Customizing catalogs and databases helps you to simplify your work and avoid mistakes.

You can customize catalogs and databases for:

- materials
- profiles
- shapes (page 312)
- bolts (page 333)
- rebars (page 348)
- applications and components (page 359)

Always ensure that the catalog content is correct. Mistakes in catalogs might lead to serious inconsistencies in quantity information, data transfer, or other calculations. For example, incorrect material density leads to systematic errors in reported weights.

You can add new content to catalogs from other environments, from Tekla Warehouse, or import content created in other software solutions.

#### Additional content in Tekla Warehouse

In Tekla Warehouse, you can find additional content, such as application tools and environment content.

You can download Tekla Warehouse offline content that includes the catalog content of environments, such as profiles, bolts, materials, and reinforcements. The content is in .tsep packages that are installed when you open Tekla Structures.

The offline catalog content is under **Tekla Structures collections** in Tekla Warehouse. To find this content, search for **Catalogs**, then under **Show** select **Collections**.

---

<table>
<thead>
<tr>
<th>Line</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line 7</td>
<td>6000.000000 24000.000000 4855.000000 = X2 Y2 Z2</td>
</tr>
<tr>
<td></td>
<td>Coordinates of the beam end point. Z-coordinates are center-line coordinates.</td>
</tr>
<tr>
<td>Line 8</td>
<td>16.500000 24000.000000 5855.000000 = X3 Y3 Z3</td>
</tr>
<tr>
<td></td>
<td>Direction vector showing the direction of the local z-axis.</td>
</tr>
</tbody>
</table>
You can also create a local collection for your company, and share it with your organization in your internal network. You can manage the access rights on the folder and collection level in the collections.json file on each user’s computer. Copy the file to the same location on each user’s computer. The file is located in C:\Users\Public\Public Documents\Trimble\Tekla Warehouse\collections.json.

This image shows an example of the collection paths with four Tekla Structures collections:

```
{
    "collections": [
        "\\Server1\Tekla Warehouse\OfflineContent\austria",
        "\\Server1\Tekla Warehouse\OfflineContent\brazil",
        "\\Server1\Tekla Warehouse\OfflineContent\china",
        "\\Server1\Tekla Warehouse\OfflineContent\czech"
    ]
}
```

In Tekla Warehouse the collections are found after mapping under **My collections --> Local and network collections**.

### Customize the material catalog

The material catalog contains information about material types and grades. Materials are shown in a hierarchical tree grouped according to their types, with material grades listed under each material type.

The following material types are available in Tekla Structures:

- Steel
- Concrete
- Timber
- Miscellaneous

You cannot add, modify, or delete material types.
By default, the material catalog contains standard, environment-specific materials. You can add, modify, and delete material grades.

Tekla Structures stores the material information in the `matdb.bin` file.

**Important buttons in the material catalog**

When you work with the material grades, note the usage of the following buttons in the `Modify Material Catalog` dialog box:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Update</strong></td>
<td>Saves the changes of a single edited material grade to the computer’s memory until you click <strong>OK</strong>.</td>
</tr>
<tr>
<td><strong>OK</strong></td>
<td>Saves the changes in the model folder. Tekla Structures saves the modified catalog on the hard disk when you click <strong>OK</strong> to close the dialog box and then click <strong>OK</strong> in the <strong>Save confirmation</strong> dialog box.</td>
</tr>
<tr>
<td><strong>Cancel</strong></td>
<td>Closes the <code>Modify Material Catalog</code> dialog box without saving the changes. Note that all changes made to the catalog will be lost even if you have clicked <strong>Update</strong>, because the changes have not been saved on the hard disk. The changes made to the catalog are visible during one session, because the catalog is using the computer’s memory. When you start Tekla Structures the next time, the previous data is restored from the hard disk.</td>
</tr>
</tbody>
</table>

Tekla Structures stores the material information in the `matdb.bin` file. When you first open a model, Tekla Structures reads the data from the hard disk and stores it in the computer’s memory.

When you select a material, Tekla Structures reads the data from the computer’s memory and displays it in the `Modify Material Catalog` dialog box. This is faster than accessing the data from the hard disk.

**Add a material grade**

1. On the **File** menu, click **Catalogs** --> **Material catalog** to open the `Modify Material Catalog` dialog box.
2. Select a material type, for example, steel.
3. Right-click and select **Add Grade**.
   
   A new material grade is added under to the material type you selected.
4. Change the material grade name by clicking the grade and entering a new name for it.
5. Enter the material grade properties.
6. Click **OK** to save the material grade and close the **Modify Material Catalog** dialog box.

7. Click **OK** in the **Save confirmation** dialog box to save the changes.

---

**Copy a material grade**

You can add new material grades by modifying a copy of an existing, similar material grade.

1. On the **File** menu, click **Catalogs --> Material catalog** to open the **Modify Material Catalog** dialog box.

2. Select a material grade that is similar to the one that you want to create.

3. Right-click and select **Copy Grade**.

   A copy of the material grade with the name **COPY** is added to the material tree.

4. Change the material grade name by clicking the grade and entering a new name for it.

5. Modify the material grade properties.

6. Click **OK** to save the material grade and close the **Modify Material Catalog** dialog box.

7. Click **OK** in the **Save confirmation** dialog box to save the changes.

---

**Modify a material grade**

You can modify existing material grades using the material catalog.

1. On the **File** menu, click **Catalogs --> Material catalog** to open the **Modify Material Catalog** dialog box.

2. Select a material grade in the tree and modify its properties.

   • Use the **General** tab for entering three alternative names for the material. The names are usually the material names used in different countries or standards. The tab also contains the profile and plate density values.

   • Use the **Analysis** tab for entering information on the properties used in structural analysis.

   • Use the **Design** tab for entering information on the design-specific properties, such as strengths and partial safety factors.

   • Use the **User attributes** tab for creating your own attributes for material grades.

   - For example, you can define a paint layer thickness, or the maximum grain size of concrete using a user-defined attribute.

3. When you have finished modifying the material grade, click **Update**.
4. Click **OK** to close the **Modify Material Catalog** dialog box.
   Tekla Structures asks if you want to save the changes to the model folder.
5. Click **OK** in the **Save confirmation** dialog box to save the changes.
   The modified material catalog is saved in the current model folder and is available only for that model. To make the modified catalog available for all the other models, use export and import.

**Delete a material grade**
1. On the **File** menu, click **Catalogs** --> **Material catalog** to open the **Modify Material Catalog** dialog box.
2. Select the material grade that you want to delete.
3. Right-click and select **Delete Grade**.
4. Click **OK** to close the **Modify Material Catalog** dialog box.
5. Click **OK** in the **Save confirmation** dialog box to save the changes.

**Add user attributes to material grades**
You can add user attributes and their values to the material grades. The user attributes can then be used, for example, in filtering.
1. On the **File** menu, click **Catalogs** --> **Material catalog** to open the **Modify Material Catalog** dialog box.
2. On the **User attributes** tab, click **Definitions** to open the **Modify Material Properties** dialog box.
3. Click **Add** to add a new row.
4. To define a user attribute, click each item on a row.
   a. In the **Category** list, select a material category to which the user attribute is applied.
   b. In the **Design code** list, select a design code to which the attribute is added.
   c. In the **Material type** list, select a material type for the attribute.
   d. In the **Quantity type** list, select the type of information that the user attribute contains, for example, weight, area, ratio, or string.
   e. In the **Order** column, define the order in which the user attributes are shown in the dialog box. Smaller values are shown first.
   f. In the **Property name** column, define a name for the property.
   The name is saved in the catalog and can be used in reports and templates. When **Property name** is used in a template, \texttt{MATERIAL.PROPERTY\_NAME} indicates where the property name appears.
g. In the **Label** column, define a label for the attribute.

5. **Click Update.**

6. **Click OK** to close the **Modify Material Properties** dialog box.

---

**Create user-defined material definitions**

You can replace the existing material definitions with your own definitions and use them, for example, in drawing part marks. Material definitions can contain text, numbers and symbols.

1. **Save the symbol file** `user_material_symbols.sym` in the symbol folder (usually the folder `..<\ProgramData\Trimble\Tekla Structures <version>\environments\common\symbols\`).

2. **In a text editor**, such as Microsoft Notepad, create a text file that contains your material definitions.

   Each row in the file defines a material. Use the following syntax:

   `material_name symbol_file_name@n`, where

   - **material_name** is the name of the material used in the material catalog
   - **symbol_file_name** is the symbol file name to be used
   - **n** is the number of the symbol.

   For example:

   ```
   S235JRG1    user_material_symbols@1    B
   S235JRG2    user_material_symbols@2    C
   S235JR      user_material_symbols@0    A
   S275JR      user_material_symbols@3    D
   S235JR      user_material_symbols@4    E
   ```

   **WARNING** The order of material names in the definition file affects the conversion. Materials with more specific names must be listed before the ones with similar, but simpler names, such as S235JRG1, must be listed before S235JR. Otherwise they both get the same symbol.

3. **Save the file** for example with the name

   `user_material_definitions.txt`

   All the named materials in the material catalog will be replaced with the ones defined in this file.

4. **Set the name of the file as a value for the advanced option**

   `XS_MATERIAL_SYMBOL_REPRESENTATION_FILE` in **File menu --> Settings --> Advanced options --> Drawing Properties** as follows:
You can also enter a full path to the material definition file. Without the path, Tekla Structures searches for the file in the model, firm, project, and system folders.

**About importing and exporting material grades**

Use importing and exporting for merging material catalogs. Material catalogs are imported and exported as .lis files.

Importing and exporting is useful when you:
- upgrade to a newer version of Tekla Structures and want to use a customized material catalog from a previous version
- want to combine material catalogs that are stored in different locations
- want to share material catalog information with other users
- want to combine material catalogs across different environments.

**TIP** You can also download or share material grades using .

**Export a part of the material catalog**

If you do not want to export the whole material catalog, you can export a branch of the material tree, meaning all the material grades grouped under one material type, or a single material grade. Material catalogs are exported from Tekla Structures models as .lis files.

1. On the **File** menu, click **Catalogs --> Material catalog** to open the **Modify Material Catalog** dialog box.
2. Select material grades to be exported.
   - To export a branch of the material tree, right-click the branch and select **Export Grades**.
   - To export a single material grade, right-click the material grade and select **Export Grade**.
3. Browse for the folder where you want to save the export files.
   By default, the file is saved to the current model folder.
4. Enter a name for the file and click **OK**.
5. Click **OK** to close the **Modify Material Catalog** dialog box.
6. Click **OK** in the **Save confirmation** dialog box to save the changes.

**Export an entire material catalog**

Exporting and importing are used to merge material catalogs. Material catalogs are exported from Tekla Structures models as .lis files. Note that the Export command exports the entire catalog.
1. On the **File** menu, click **Catalogs --> Material catalog** to open the **Modify Material Catalog** dialog box.

2. Click **Export**.

   By default, the file is saved to the current model folder.

4. Enter a name for the file and click **OK**.

5. Click **OK** to close the **Modify Material Catalog** dialog box.

6. Click **OK** in the **Save confirmation** dialog box to save the changes.

---

**Import a material catalog**

Material catalogs are imported to Tekla Structures models as .lis files. You can move an exported .lis file to any model folder and import it to an existing material catalog.

1. Open the model to which you want to import a material catalog.

2. On the **File** menu, click **Catalogs --> Material catalog** to open the **Modify Material Catalog** dialog box.

3. Click **Import**.

4. Browse for the folder that contains the import file, and select the file.

5. Click **OK**.
   If a material with a same name as the material being imported already exists, the **Import confirmation** dialog box appears and you have three options:
   - **Replace**: The existing material is replaced with the imported material.
   - **Merge**: Material properties that are different in the import file are added to the existing material. All the other properties remain unchanged.
     Use this option to import only certain elements of the material catalog, such as user attributes.
   - **Leave**: The existing material is not replaced and the material definitions in the import file are ignored.

   If you select the **Apply for all** check box, Tekla Structures uses the same option (Replace, Merge, or Leave) for all the existing materials that have the same name as the one being imported.

   If a user attribute with a different definition already exists, you are prompted to Replace or Leave the existing attribute.

6. Click **OK** to close the **Modify Material Catalog** dialog box.

7. Click **OK** in the **Save confirmation** dialog box to save the changes.

---

Start new projects as a Tekla Structures administrator

250 Customize catalogs and databases
**Units used in import and export**

This table lists the units Tekla Structures uses when importing and exporting profile catalogs and material catalogs.

<table>
<thead>
<tr>
<th>Type</th>
<th>Unit (if blank, no unit)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boolean</td>
<td></td>
</tr>
<tr>
<td>Integer</td>
<td></td>
</tr>
<tr>
<td>String</td>
<td></td>
</tr>
<tr>
<td>Ratio</td>
<td></td>
</tr>
<tr>
<td>Strain</td>
<td></td>
</tr>
<tr>
<td>Angle</td>
<td>degree</td>
</tr>
<tr>
<td>Length</td>
<td>mm</td>
</tr>
<tr>
<td>Deformation</td>
<td>mm</td>
</tr>
<tr>
<td>Dimension</td>
<td>mm</td>
</tr>
<tr>
<td>Radius of inertia</td>
<td>mm</td>
</tr>
<tr>
<td>Area</td>
<td>mm²</td>
</tr>
<tr>
<td>Reinforcement area</td>
<td>mm²</td>
</tr>
<tr>
<td>Transverse reinforcement area</td>
<td>mm²/m</td>
</tr>
<tr>
<td>Area/unit length</td>
<td>mm²/m</td>
</tr>
<tr>
<td>Volume</td>
<td>mm³</td>
</tr>
<tr>
<td>Section modulus</td>
<td>mm³</td>
</tr>
<tr>
<td>Moment of inertia</td>
<td>mm⁴</td>
</tr>
<tr>
<td>Torsion constant</td>
<td>mm⁴</td>
</tr>
<tr>
<td>Warping constant</td>
<td>mm⁶</td>
</tr>
<tr>
<td>Force</td>
<td>N</td>
</tr>
<tr>
<td>Weight</td>
<td>kg</td>
</tr>
<tr>
<td>Distributed load</td>
<td>N/m</td>
</tr>
<tr>
<td>Spring constant</td>
<td>N/m</td>
</tr>
<tr>
<td>Mass/length</td>
<td>kg/m</td>
</tr>
<tr>
<td>Surface load</td>
<td>N/m²</td>
</tr>
<tr>
<td>Strength</td>
<td>N/m²</td>
</tr>
<tr>
<td>Stress</td>
<td>N/m²</td>
</tr>
<tr>
<td>Modulus</td>
<td>N/m²</td>
</tr>
<tr>
<td>Density</td>
<td>kg/m³</td>
</tr>
<tr>
<td>Moment</td>
<td>Nm</td>
</tr>
<tr>
<td>Distributed moment</td>
<td>Nm/m</td>
</tr>
<tr>
<td>Type</td>
<td>Unit (if blank, no unit)</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>--------------------------</td>
</tr>
<tr>
<td>Rotation spring constant</td>
<td>Nm/rad</td>
</tr>
<tr>
<td>Temperature</td>
<td>K (°C)</td>
</tr>
<tr>
<td>Thermal dilation coefficient</td>
<td>1/K (1/°C)</td>
</tr>
<tr>
<td>Factor</td>
<td></td>
</tr>
</tbody>
</table>

**Customize the profile catalog**

The profile catalog contains information about profiles, their rules and types, and the analysis and design properties of the profiles. Profiles are shown in a hierarchical tree grouped according to the rules.

By default, the profile catalog contains standard, environment-specific profiles and generic parametric profiles. You can add, modify, import, export, and delete profiles.

You can define your own user-defined profiles, which can be either fixed or parametric. Use the profile catalog to create new fixed profiles, either from scratch or by copying an existing one. Use the sketch editor or .clb files to create new parametric profiles.

Tekla Structures stores the profile catalog information in the profdb.bin file.

**Important buttons in the profile catalog**

When you work with the profiles, note the usage of the following buttons in the Modify Profile Catalog dialog box:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Update" /></td>
<td>Saves the changes of a single edited profile to the computer's memory until you click <strong>OK</strong>.</td>
</tr>
<tr>
<td><img src="image" alt="OK" /></td>
<td>Saves the changes in the model folder. Tekla Structures saves the modified catalog on the hard disk when you click <strong>OK</strong> to close the dialog box and then click <strong>OK</strong> in the <strong>Save confirmation</strong> dialog box.</td>
</tr>
<tr>
<td><img src="image" alt="Cancel" /></td>
<td>Closes the Modify Profile Catalog dialog box without saving the changes. Note that all changes made to the catalog will be lost even if you have clicked <strong>Update</strong>, because the changes have not been saved on the hard disk. The changes made to the catalog are visible during one session, because the catalog is using the computer's memory. When you start Tekla Structures the next time, the previous data is restored from the hard disk.</td>
</tr>
</tbody>
</table>
Tekla Structures stores the information of fixed profiles in the `profdb.bin` file. When you first open a model, Tekla Structures reads the data from the hard disk and stores it in the computer's memory.

When you select a profile, Tekla Structures reads the data from the computer's memory and displays it in the Modify Profile Catalog dialog box. This is faster than accessing the data from the hard disk.

**How profiles are grouped together**

In the profile catalog, the profiles are displayed in a hierarchical tree and they are grouped according to rules, such as the profile type (for example, I profiles) and the profile subtype (for example, HEA). To change how the profiles are grouped in the profile tree, you need to modify the rules.

The order in which you create the rules does not matter, only the location of the rules in the profile tree.

Tekla Structures reads the rules from top to bottom in the profile tree. Profiles are in the highest group where they meet the criteria defined in the rule. For example, a rule that collects All profiles overrides all rules that are below it in the profile tree.

**Add a rule to the profile catalog**

1. On the File menu, click Catalogs --> Profile catalog to open the Modify Profile Catalog dialog box.
2. Right-click any existing rule and select Add Rule.

   **TIP** You can add a next level rule that creates a subgroup under an existing rule. Use the Add Next Level Rule command to add the next level rule.

3. Define the rule properties.
   a. Enter a rule name in the Rule name box.
   b. Select the Profile type to which the rule is applied.
   c. Enter the Name filter string that defines the new rule.

      By default, the wildcard symbol (*) is entered, meaning “all entries”.

      For example, to group all catalog entries with names beginning with A, enter `A*` in the Name filter string box, or to group all catalog entries with names containing 100, enter `*100*`. Tekla Structures groups the catalog entries that meet your criteria under the new rule.

4. Click OK to close the Profile manager rules dialog box.
5. Click OK to close the Modify Profile Catalog dialog box.
6. Click **OK** in the **Save confirmation** dialog box to save the changes.

**Modify a rule in the profile catalog**
Profiles in the profile tree are listed in an alphabetical order, and rules are listed in the order you specify. To change the order in which the rules appear, use the **Move up** and **Move down** commands.

**TIP** If you want to delete a rule, right-click an existing rule and select **Delete Rule**.

1. On the **File** menu, click **Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.
2. Right-click any existing rule and select **Edit Rule**.
   The **Profile manager rules** dialog box appears.
3. Modify the rule properties.
4. Click **OK** to close the **Profile manager rules** dialog box.
5. Click **OK** to close the **Modify Profile Catalog** dialog box.
6. Click **OK** in the **Save confirmation** dialog box to save the changes.

**See also**
• Wildcards

**Add user attributes to profiles**
You can add your own attributes to profiles. For example, you can specify paint layer thickness, define the maximum grain size of concrete, sort out different profile types by material, or create profile aliases for converting between imperial and metric profiles.

1. On the **File** menu, click **Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.
2. On the **User attributes** tab, click **Definitions**.
   The **Modify Profile Properties** dialog box appears.
3. Click **Add** to add a new row.
4. To define a user attribute, click each item on a row.
   a. In the **Profile type** list, select a profile type to which the user attribute is applied.
   b. In the **Quantity type** list, select the type of information that the user attribute contains, for example, weight, area, ratio, or string.
   c. In the **Order** list, define the order in which the user attributes are shown in the dialog box. Larger values are shown first.
d. In the **Property name** list, define a name for the property.

The name is saved in the catalog and can be used in reports and templates. When **Property name** is used in a template, `PROFILE.PROPERTY_NAME` indicates where the property name appears. For example, `PAINT_LAYER_THICKNESS`.

e. In the **Symbol** column, define an abbreviation that can be used for the property, such as `Ix` or `ct`.

f. In the **Label** column, define a label for the attribute.

5. Click **Update**.

6. Click **OK** to close the **Modify Profile Properties** dialog box.

**Example: Add a user attribute to a profile and use it in a rule**

You can add your own attributes and their values to profiles. The user attributes can then be used, for example, in profile filtering.

This example shows how to add a user attribute for the rule for I profiles.

1. On the **File** menu, click ** Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.

2. On the **User attributes** tab, click **Definitions**.

   The **Modify Profile Properties** dialog box appears.

3. Click **Add** to add a new row, then select the row and modify the properties as follows:

   • Set **Profile type** to **I profiles**.
   
   • Set **Quantity type** to **String**.
   
   • Set **Property name** to **HISTORICAL_PROFILE**.
   
   • Set **Symbol** to **Hist**.
   
   • Set **Label** to **Historical profile**.

4. Click **Update**, then click **OK**.

5. In the profile tree, select **I profiles**, then select **HEA**.

6. Right-click and select **Add Next Level Rule**.
7. In the **Profile manager rules** dialog box, set the rule properties as follows:
   
   - Set **Rule name** to **Historical profiles**.
   - In **Profile type**, clear the **All profiles** check box and select the **I profiles** check box.
   - Enter **HEA* in the Name filter string** box.
   - Set **User attribute** to **HISTORICAL_PROFILE** and **Equals**, and enter **Yes** in the box next to the two other boxes.

![Profile manager rules dialog box](image)

8. Click **OK**.

   **Historical profiles** appears in the profile tree.

9. Select the required historical profile, such as **HEA120**, in the profile tree.

Start new projects as a Tekla Structures administrator  
256  
Customize catalogs and databases
10. On the **User attributes** tab, and change the **Value** field for **Historical profile** to **Yes**.

![User attributes tab](image)

11. Click **Update**.

12. Click **OK** to close the **Modify Profile Catalog** dialog box.

13. Click **OK** in the **Save confirmation** dialog box to save the changes.

The next time that you open the profile catalog, the profiles appear under **Historical profiles** in the profile tree.

**Associate profile types with a certain material**

You can define which profiles are available for steel parts, concrete parts, or both. The associated profile type affects which profile types are shown in the **Select Profile** dialog box when you change the material of a part.

1. On the **File** menu, click **Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.

2. Select a profile type, for example, **L profiles**.

3. To associate the profiles with steel, right-click and select **Material --> Steel**.
A check mark next to **Steel** indicates that the profiles are available for steel parts.

4. To also make the selected profiles available for concrete parts, right-click and select **Material --> Concrete**. If needed, you can remove the check mark by clicking the material again.

5. Click **OK** to close the **Modify Profile Catalog** dialog box.

6. Click **OK** in the **Save confirmation** dialog box to save the changes.

**See also**

- Select and change the profile or material of a part

**Delete a profile from the profile catalog**

1. On the **File** menu, click **Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.

2. Select the profile that you want to delete.

3. Right-click and select **Delete Profile**.

4. Click **OK** to close the **Modify Profile Catalog** dialog box.

5. Click **OK** in the **Save confirmation** dialog box to save the changes.

Tekla Structures continues to show parts that use the deleted profiles in model views until you modify the parts or reopen the model. After that, parts that
have profiles that are not available in the profile catalog, are shown as sticks without a profile.

If the deleted profile used a custom cross-section definition, delete it separately to remove the cross-section from your model.

**Import and export profiles**

Import and export profiles to merge profiles across profile catalogs.

Profile catalogs are imported and exported as .lis files, sketched profiles as .uel files, and user-defined parametric profiles as .clb files.

When you export an entire profile catalog, Tekla Structures creates three separate files: profiles.clb, profiles.lis and rules.lis. The .clb file contains parametric profile definitions, if they are used in the profiles in the catalog, otherwise it is empty. The profiles.lis file includes the actual profile definitions and the rules.lis file the branch rules. When you export a branch of a profile catalog, the branch name is attached as prefix to the file names.

Importing and exporting is useful when you:

- upgrade to a newer version of Tekla Structures and want to use a customized profile catalog from a previous version
- want to combine profile catalogs that are stored in different locations
- want to share profile catalog information with other users
- want to combine profile catalogs across different environments.

**Limitations of importing and exporting profiles**

- You cannot import or export hard-coded profiles such as PROFILE_ZZ, PROFILE_CC, and PROFILE_CW.
- You cannot import profiles that do not have a defined cross section.
- If you have used a sketched profile or a user-defined parametric profile as the cross section for a fixed profile, you also need to import the sketched profile or the user-defined parametric profile to the new model.

**TIP** You can also download or share profiles using Tekla Warehouse.

**Import profile catalog items**

Tekla Structures has five types of profile catalog items: fixed profiles, hard-coded parametric profiles, sketched profiles, user-defined parametric profiles, and rule sets. Profiles and rule sets are imported to Tekla Structures models.
as .lis files, sketched profiles as .uel files, and user-defined parametric profiles as .clb files.

If you are importing an entire profile catalog or a branch, we recommend that you save the related files in a separate folder. This makes the import process faster.

1. Open the model to which you want to import profile catalog items.
2. On the File menu, click Catalogs --> Profile catalog to open the Modify Profile Catalog dialog box.
3. Click Import to import a single file, or Import Directory to import the contents of a file folder.
4. Select the import file or the import folder.
5. Click OK. Tekla Structures checks if there are duplicates in the profile names in the import file compared to the profile catalog.
   a. If the Review import items dialog box appears, there are duplicate profile names and you must select each duplicate and assign the action you want to perform with the following buttons:
      • Leave: The existing profile item is not replaced and the profile definitions in the import file are ignored.
      • Merge: Profile properties that are different in the import file are added to the existing profile. All the other properties remain unchanged.
        Use this option to import only certain elements of the profile catalog, such as user attributes.
      • Replace: The existing profile item is replaced with the imported profile item.
      • If you leave Unknown as the action for a profile item, it is not imported.

You can select more than one profile item at a time by using the Shift and Ctrl keys and assign the same action to the entire selection.

   b. After you have selected the actions, click Continue to perform them.
6. Click OK to close the Modify Profile Catalog dialog box.
7. Click OK in the Save confirmation dialog box to save the changes.

NOTE Each cross section definition has a unique name and ID number. If during an import, a cross section with the same name but different properties is found in the existing profile catalog, the cross section being imported is renamed by adding an incremental number at the end of the existing name.
Test and approve the catalog content, then export the new catalog and set it up to be used in models.

**Export an entire profile catalog**

Profile catalogs are exported from Tekla Structures models as .lis, .uel, and .clb files.

1. On the **File** menu, click **Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.
2. Click **Export**.
3. Browse for the folder where you want to save the export files.
   By default, the files are saved to the current model folder. For faster profile catalog import, we recommend that you create a separate sub-folder for the catalog files.
4. Click **OK** to close the **Modify Profile Catalog** dialog box.

Set up the catalog to be used in models.

**Export a part of the profile catalog**

If you do not want to export an entire profile catalog, you can export a branch of the profile tree, meaning all the profiles grouped under one rule, or a single profile. Profiles and rule sets are exported from Tekla Structures models as .lis files, sketched profiles as .uel files, and user-defined parametric profiles as .clb files.

1. On the **File** menu, click **Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.
2. Select profiles to be exported.
   • To export a branch of the profile tree, right-click the branch and select **Export Profiles**.
   • To export a single profile, right-click the profile and select **Export Profile**.
3. Browse for the folder where you want to save the export files.
   By default, the files are saved to the current model folder.
   If you are exporting a single profile, enter a name for the file.
4. Click **OK**.
5. Click **OK** to close the **Modify Profile Catalog** dialog box.

**Example of a profile export file**

The export .lis file is divided into specific sections.

The first row in the file is `PROFILE CATALOG EXPORT VERSION = n`, where `n` is the version number.
The next section defines the hierarchical tree structure that is used to display the contents of the catalog.

The section after that contains the profiles.

**Fixed profiles**

```
PROFILE_NAME = "HEA120";
{
  TYPE = 1; SUB_TYPE = 1001; COORDINATE = 0.000;
  "FLANGE_SLOPE_RATIO"  0.000000000E+000
  "ROUNDING_RADIUS_2"    0.000000000E+000
  "ROUNDING_RADIUS_1"    1.200000000E+001
  "FLANGE_THICKNESS"     8.000000000E+000
  "WEB_THICKNESS"        5.000000000E+000
  "WIDTH"                1.200000000E+002
  "HEIGHT"               1.140000000E+001
```

**Fixed user-defined profiles**

Fixed user-defined profiles can have more than one cross section. The profile type for fixed user-defined profiles is 998. SUB_TYPE refers to the name of the cross section definition. When importing fixed user-defined profiles, the relevant cross section definitions must be in the same import file as the profile.

```
PROFILE_NAME = "TAN_HK_TEST_2_CS";
{
  TYPE = 998; SUB_TYPE = 253; COORDINATE = 0.000;
  "EQUIVALENT_TYPE"       11
  "FLANGE_SLOPE_RATIO"    0.000000000E+000
  "ECCENTRICITY_Y"        0.000000000E+000
  "ECCENTRICITY_X"        0.000000000E+000
  "ROUNDING_RADIUS_2"     0.000000000E+000
  "FLANGE_THICKNESS_2"    0.000000000E+000
  "WEB_THICKNESS_2"       0.000000000E+000
```

**Cross section definitions**

```
CROSS_SECTION_NAME = "MY_OWN_PROFILE"
POINT_NUMBER = 1;
  POINT_X = 200.00;
  POINT_Y = -200.00;
  CHAMFER_TYPE = 0;
  CHAMFER_X = 0.00;
  CHAMFER_Y = 0.00;
POINT_NUMBER = 2;
  POINT_X = 200.00;
  POINT_Y = 200.00;
  CHAMFER_TYPE = 0;
  CHAMFER_X = 0.00;
  CHAMFER_Y = 0.00;
```
**Units used in import and export**
This table lists the units Tekla Structures uses when importing and exporting profile catalogs and material catalogs.

<table>
<thead>
<tr>
<th>Type</th>
<th>Unit (if blank, no unit)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boolean</td>
<td></td>
</tr>
<tr>
<td>Integer</td>
<td></td>
</tr>
<tr>
<td>String</td>
<td></td>
</tr>
<tr>
<td>Ratio</td>
<td></td>
</tr>
<tr>
<td>Strain</td>
<td></td>
</tr>
<tr>
<td>Angle</td>
<td>degree</td>
</tr>
<tr>
<td>Length</td>
<td>mm</td>
</tr>
<tr>
<td>Deformation</td>
<td>mm</td>
</tr>
<tr>
<td>Dimension</td>
<td>mm</td>
</tr>
<tr>
<td>Radius of inertia</td>
<td>mm</td>
</tr>
<tr>
<td>Area</td>
<td>mm²</td>
</tr>
<tr>
<td>Reinforcement area</td>
<td>mm²</td>
</tr>
<tr>
<td>Transverse reinforcement area</td>
<td>mm²/m</td>
</tr>
<tr>
<td>Area/unit length</td>
<td>mm²/m</td>
</tr>
<tr>
<td>Volume</td>
<td>mm³</td>
</tr>
<tr>
<td>Section modulus</td>
<td>mm³</td>
</tr>
<tr>
<td>Moment of inertia</td>
<td>mm⁴</td>
</tr>
<tr>
<td>Torsion constant</td>
<td>mm⁴</td>
</tr>
<tr>
<td>Warping constant</td>
<td>mm⁶</td>
</tr>
<tr>
<td>Force</td>
<td>N</td>
</tr>
<tr>
<td>Weight</td>
<td>kg</td>
</tr>
<tr>
<td>Distributed load</td>
<td>N/m</td>
</tr>
<tr>
<td>Spring constant</td>
<td>N/m</td>
</tr>
<tr>
<td>Mass/length</td>
<td>kg/m</td>
</tr>
<tr>
<td>Surface load</td>
<td>N/m²</td>
</tr>
<tr>
<td>Strength</td>
<td>N/m²</td>
</tr>
<tr>
<td>Stress</td>
<td>N/m²</td>
</tr>
<tr>
<td>Modulus</td>
<td>N/m²</td>
</tr>
<tr>
<td>Density</td>
<td>kg/m³</td>
</tr>
<tr>
<td>Moment</td>
<td>Nm</td>
</tr>
<tr>
<td>Distributed moment</td>
<td>Nm/m</td>
</tr>
<tr>
<td>Rotation spring constant</td>
<td>Nm/rad</td>
</tr>
</tbody>
</table>
### Type and Unit (if blank, no unit)

<table>
<thead>
<tr>
<th>Type</th>
<th>Unit (if blank, no unit)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Temperature</td>
<td>K (°C)</td>
</tr>
<tr>
<td>Thermal dilation coefficient</td>
<td>1/K (1/°C)</td>
</tr>
<tr>
<td>Factor</td>
<td></td>
</tr>
</tbody>
</table>

#### Import and export sketched profiles

To use a sketched profile in other Tekla Structures models, export the profile as a .uel file, then import the file into another Tekla Structures model.

We recommend that you use the profile catalog to import and export sketched profiles. You can also use the Applications & components catalog to import sketched profiles together with related custom components.

The exported .uel file contains information about the version of Tekla Structures from which it was exported. You can import the file into the same or newer version of Tekla Structures, but you cannot import a .uel file from a newer version into an older version.

#### Export sketched profiles

1. Open the Tekla Structures model you want to export from.
2. On the File menu, click Catalogs --> Profile catalog to open the Modify Profile Catalog dialog box.
3. Right-click the profile you want to export and select Export Profile.
4. In the Export Profile Catalog dialog box, enter a name for the export file in the Selection box.
5. If you want to save the export file to a specific location, browse for the folder.
   By default, Tekla Structures saves the export file in the current model folder.
6. Click OK.

#### Import sketched profiles

After you have exported sketched profiles to a .uel file, you can import them to another Tekla Structures model.

**TIP** To automatically import all .uel files from a folder when creating a new model, use the advanced option.

1. Open the Tekla Structures model you want to import to.
2. On the File menu, click Catalogs --> Profile catalog to open the Modify Profile Catalog dialog box.
3. Click Import.
4. In the Import Profile Catalog dialog box, select *.uel from the Filter list.
5. Select the file to import.
6. Click OK.
7. Click OK to close the Modify Profile Catalog dialog box.
8. Click OK in the Save confirmation dialog box to save the changes.

Create your own profiles
You can create your own profiles and save them in the profile catalog.

Use any of the following methods to create user-defined profiles in Tekla Structures:

<table>
<thead>
<tr>
<th>Profile type</th>
<th>Creation methods</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed profile</td>
<td>• Create user-defined cross sections in profiles (page 265)</td>
</tr>
<tr>
<td></td>
<td>• Create a fixed profile (page 271)</td>
</tr>
<tr>
<td></td>
<td>• Create a fixed profile by copying an existing profile (page 272)</td>
</tr>
<tr>
<td></td>
<td>• Create a fixed profile based on a parametric profile (page 273)</td>
</tr>
<tr>
<td>Parametric profile</td>
<td>• Create parametric profiles using .clb files (page 274)</td>
</tr>
<tr>
<td></td>
<td>• Create parametric profiles by sketching (page 282)</td>
</tr>
<tr>
<td>Parametric profile with variable cross sections</td>
<td>• Create parametric profiles with variable cross sections (page 307)</td>
</tr>
</tbody>
</table>

Create user-defined cross sections in profiles
You can use user-defined cross sections for creating fixed profiles. Define the cross sections before creating the profile.

Use any of the following methods to define a cross section:

- Define a cross section using a polygon without or with inner contours.
  Use this method to create a cross section with fixed dimensions.
- Define a cross section using a plate.
  Use this method if you have a contour plate in the model.
- Define a cross section using a DWG file.
  Use this method if you have a .dwg file of the profile you that want to define.
Define a cross section without inner contours using a polygon
Define a cross section with no inner contours by picking the shape of the cross section.

Because the cross section shape disappears after you have clicked the middle mouse button to close the shape, picking the center point of the cross section can be difficult.

To make it easier to define the shape, insert a reference model of the cross section in the model, and use the reference model as the basis for picking the cross section shape. Alternatively, you can create a few construction lines or points in the model and use them to define the cross section shape.

2. Pick the corner points of the cross section to define the shape.
   Start at the bottom-right corner and pick the points counter clockwise.
3. Pick the start point, then click the middle mouse button to close the shape.
4. Pick the center point of the cross section.

5. In the User Profile Cross Section dialog box, enter a name for the cross section.
6. Click OK to close the User Profile Cross Section dialog box.
7. Click OK in the Save confirmation dialog box to save the changes.

Use this cross section when you add a new profile to the profile catalog. The Profile type is User-defined, fixed.

Define a cross section with inner contours using a polygon
Define a cross section with inner contours by picking the shape of the cross section.
1. On the **File** menu, click **Catalogs --> Define profiles --> Define cross section using polygon**.

2. Pick the corner points of the cross section to define the shape, then pick the start point to close the shape.

3. For each inner contour, pick the corner points of the cross section inner contour, then pick the start point to close the shape.

4. When you have finished picking all inner contours, click the middle mouse button.

5. Pick the center point of the cross section.

6. In the **User Profile Cross Section** dialog box, enter a name for the cross section.

7. Click **OK** to close the **User Profile Cross Section** dialog box.

8. Click **OK** in the **Save confirmation** dialog box to save the changes.

Use this cross section when you add a new profile to the profile catalog. The **Profile type** is **User-defined, fixed**.

*Define a cross section using a plate*

If you have a contour plate in the model, you can define a cross section using a contour plate.

1. Create a contour plate that includes all the chamfers.

2. On the **File** menu, click **Catalogs --> Define profiles --> Define cross section using plate**.

3. On the **Parameters** tab of the **Profile Cross-Section from Plate (10)** dialog box, enter a name in the **Section name** and **Profile name** fields. Other properties are optional.

4. Click **OK**.
5. Select the contour plate.
Tekla Structures creates the cross section with the shape of the contour plate.

Properties: Profile cross-section from plate (10)
Use the Parameters tab to define the profile properties in the Profile cross-section from plate (10) component.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Section name</td>
<td>Name of the cross section shown in the Modify Profile Catalog dialog box. If you leave this box empty, no profile is created.</td>
</tr>
<tr>
<td>Profile name</td>
<td>Name of the profile shown in the Beam properties, and in the Modify Profile Catalog dialog box. If you leave this box empty, no profile is created.</td>
</tr>
<tr>
<td>Save to</td>
<td>The location of the profile catalog. Select one of the following options:</td>
</tr>
<tr>
<td></td>
<td>• Model directory: The current model folder.</td>
</tr>
<tr>
<td></td>
<td>• Global directory: ..\ProgramData\Trimble\Tekla Structures&lt;version&gt;\environments&lt;environment&gt;\profil</td>
</tr>
<tr>
<td></td>
<td>• Do not save: Does not save the profile. This is useful for testing.</td>
</tr>
<tr>
<td>Min distance between points</td>
<td>The minimum distance between the corner points of the cross section. To create simpler drawings of complicated cross sections, increase this value.</td>
</tr>
<tr>
<td>Center point offset</td>
<td>The origin of the plate defines the location of the profile reference line. Enter an offset value to move the reference line, relative to the cross section.</td>
</tr>
<tr>
<td>Coordinate system</td>
<td>Select one of the following options:</td>
</tr>
<tr>
<td></td>
<td>• Use local</td>
</tr>
<tr>
<td></td>
<td>• Use global xy-plane</td>
</tr>
<tr>
<td>Mirroring</td>
<td>Select one of the following options:</td>
</tr>
<tr>
<td></td>
<td>• Do not mirror</td>
</tr>
<tr>
<td></td>
<td>• Mirror to x-direction</td>
</tr>
<tr>
<td></td>
<td>• Mirror to y-direction</td>
</tr>
</tbody>
</table>
Option | Description
--- | ---
• Mirror to x- and y-direction

Use this cross section when you add a new profile to the profile catalog. The Profile type is User-defined, fixed.

*Define a cross section using a DWG file*

If you have a .dwg file of the profile you want to define, you can import the cross section and add it as a DWG profile to the profile catalog.

Before you start defining a cross section using a DWG file:

- Save the outline of the cross section as a DWG file. Ensure that the DWG file only contains the outline of the profile.
- Make sure that the cross section is created as a closed polyline.
- Make sure that the outline consists of only one closed polyline. You cannot, for example, define holes to your cross section with this method. If you need holes or openings, use the polygon or the plate creation method.
- Remove hatching and unnecessary lines from the DWG file. Tekla Structures imports all the lines it finds in the DWG file.
- If there are blocks in the DWG file, they must be exploded.

Tekla Structures supports DWG files that have been created using version ACAD2012 or earlier.

1. Open a model.
3. On the Parameters tab of the DWG Profile to Library (6) dialog box, browse for the DWG file.
4. Define the cross section properties.
5. Click OK.
6. In the model, pick the start and the end points of the cross section to be imported.

Tekla Structures imports the cross section and places the profile reference line at the origin of the DWG file.

*Properties: DWG Profile to Library (6)*

Use the Parameters tab to define the profile properties in the DWG profile to library (6) component.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input file</td>
<td>Browse for the DWG file to be imported.</td>
</tr>
<tr>
<td>Section name</td>
<td>Name of the cross section shown in the Modify Profile Catalog dialog box.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Profile name</strong></td>
<td>Name of the profile shown in the <strong>Modify Profile Catalog</strong> dialog box.</td>
</tr>
<tr>
<td><strong>Save to</strong></td>
<td>The location of the profile catalog. Select one of the following options:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Model directory</strong>: The current model folder.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Global directory</strong>: ..\ProgramData\Trimble \Tekla Structures&lt;version&gt; \environments&lt;environment&gt;\profile</td>
</tr>
<tr>
<td></td>
<td>• <strong>Do not save</strong>: Does not save the profile. This is useful for testing.</td>
</tr>
<tr>
<td><strong>Min distance between points</strong></td>
<td>The minimum distance between the corner points of the cross section. To create simpler drawings of complicated cross sections, increase this value.</td>
</tr>
<tr>
<td><strong>Center point offset</strong></td>
<td>The origin of the plate defines the location of the profile reference line. Enter an offset value to move the reference line, relative to the cross section.</td>
</tr>
</tbody>
</table>

Use this cross section when you add a new profile to the profile catalog. The **Profile type** is **User-defined, fixed**.

**Modify a user-defined cross section**
You can modify cross sections that have been defined using a polygon, a plate, or a DWG file.

1. On the **File** menu, click **Catalogs --> Define profiles --> Edit Polygon Cross Section**.

2. In the **Modify Cross Section** dialog box, select the cross section that you want to modify.

   **TIP**  If you want to delete a cross section, select the cross section, then click **Delete**.

3. Modify the cross section point properties.
   - **Number** refers to each point picked when the cross section was created, in numerical order. The first point picked is 1, the second 2, and so on.
   - **Chamfer** refers to the chamfer shape.
• **x:** and **y:** apply to the chamfer type. For example, if you want the chamfer to be equal on both sides of the angle, only enter a value for **x:**.

For an uneven chamfer, enter values for **x:** and **y:**.

4. Click **Update.**

5. Click **OK** to close the Modify Cross Section dialog box.

6. Click **OK** in the **Save confirmation** dialog box to save the changes.

**Create fixed profiles**

You can create completely new fixed profiles or create copies of existing fixed profiles. You can also convert parametric profiles into fixed profiles.

**Create a fixed profile**

You can create fixed profiles with a single cross section or with multiple cross sections.

Cross sections affect the total weight of the profile.

**WARNING** If you create a profile with multiple cross sections, create the cross sections with the same number of corner points and in the same order.

1. On the **File** menu, click **Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.

2. Right-click anywhere in the profile tree, then select **Add Profile.**

   A new fixed profile with the name **PROFILE1** is created.

3. Define the properties of the profile.
   a. In the **Profile name** field, enter a new name for the profile.

      The profile name must be in upper case letters, with no spaces. Tekla Structures automatically converts lower case letters to upper case letters.

   b. From the **Profile type** list, select **User-defined, fixed.**

   c. From the **Profile subtype** list, select the cross section that you want to use.

      If you have created your own user-defined cross sections (page 265), you can use one of them.

   d. Under **Equivalent type**, select a profile type that matches the new cross section as closely as possible. This is important because some connections only work for certain types of profiles.

      The equivalent type and the profile dimensions, such as height and width, affect which connections can be applied to the profile. An unsuitable equivalent type or missing dimension values may result in problems with connections.
e. Click **Update**.

4. Modify the dimension values.
   Always enter values for the dimensions **Height h** and **Width b**, as these values affect how Tekla Structures displays the profiles. If the values are 0, the part is drawn as a line.

5. Under **Cross section**, define a relative location for each cross section.
   a. From the **Number** list, select the number of the cross section.
   b. In the **Relative location** field, enter the location of the cross section.
      This value indicates the location of the cross section along the axis: 0.0 for the start end and 1.0 for the second end. If you only have a single cross section, select 1 for **Number** and enter 0.000 for **Relative location**.
   c. After defining each cross section, click **Update**.

6. Click **Add** to add more cross sections, if needed.
   - If you want to use a different cross section in the profile, select a new one from the **Profile subtype** list.
   - If you want to remove a cross section, select the cross section from the **Number** list, then click **Remove**.

7. Click **OK** to close the **Modify Profile Catalog** dialog box.

8. Click **OK** in the **Save confirmation** dialog box to save the changes.

**Example**
For a pitched profile, you need two cross sections with the same center point height. The **Relative location** value is 0.0 for the first cross section, 0.5 for the second cross section, and 1.0 for the third cross section.
Create a fixed profile by copying an existing profile
You can create new fixed profiles by modifying a copy of an existing, similar profile.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify Profile Catalog dialog box.
2. Select a fixed profile that is similar to the one that you want to create.
3. Right-click, then select Copy Profile.
   A new profile with the name <existing_profile_name COPY> is created.
4. In the Profile name field, enter a new name for the profile.
   The profile name must be in upper case letters, with no spaces. Tekla Structures automatically converts lower case letters to upper case letters.
5. Modify the profile properties on the General, Analysis, and User attributes tabs.
   • The General tab contains information about profile types and dimensions.

   WARNING Under Equivalent type, select a profile type that matches the new cross section as closely as possible. This is important because some connections only work for certain types of profiles.
   Always enter values for the dimensions Height h and Width b, as these values affect how Tekla Structures displays the profiles. If the values are 0, the part is drawn as a line.
   The equivalent type and the profile dimensions, such as height and width, affect which connections can be applied to the profile. An unsuitable equivalent type or missing dimension values may result in problems with connections.

   • The Analysis tab contains information about the properties used in structural analysis. The structure can be analyzed with different analysis software.
   • The User attributes tab is for viewing or entering user attributes for profiles.
6. Click Update.
7. Click OK to close the Modify Profile Catalog dialog box.
8. Click OK in the Save confirmation dialog box to save the changes.

Create a fixed profile based on a parametric profile
You can convert an existing parametric profile into a fixed profile.
1. On the File menu, click Catalogs --> Profile catalog to open the Modify Profile Catalog dialog box.

2. Select a parametric profile from the list.

3. Right-click, then select Add Profile.

A new standard fixed profile is created with the profile values of the parametric profile.

Modify a fixed profile
If necessary, you can modify existing fixed profiles using the profile catalog.

NOTE The fixed profiles conform to industry standards. Only administrators should modify them.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify Profile Catalog dialog box.

2. Select a fixed profile in the tree and modify its properties.
   • The General tab contains information about profile types and dimensions.
   • The Analysis tab contains information about the properties used in structural analysis. The structure can be analyzed with different analysis software.
   • The User attributes tab is for viewing or entering user attributes for profiles.

3. When you have finished modifying the profile, click Update.

4. Click OK to close the Modify Profile Catalog dialog box.

Tekla Structures asks if you want to save the changes to the model folder.

5. In the Save confirmation dialog box, click OK to save the changes.

Create parametric profiles using .clb files
You can create new parametric profiles using .clb files.

Follow the example workflow below to create a parametric profile with .clb files.

How the .clb, components.clb and profitab.inp files work together
When you create new parametric profiles using this method, you need these files.

• .clb

   This file contains the cross section definitions. Create a new .clb file in the ..\ProgramData\Trimble\Tekla Structures\<version>\environments\common\inp folder for each parametric profile you define.
components.clb

This file contains a list of all .clb files that contain cross section definitions. When you create a new .clb file, you need to add its file name to the components.clb file located in the ..\ProgramData\Trimble\Tekla Structures\<version>\environments\common\inp folder.

profitab.inp

This file is the link between the .clb files and the profile catalog. This file contains a list of all parametric profiles available in Tekla Structures. The file controls how the parametric profiles are displayed in the Modify Profile Catalog dialog box. When you want to take a new parametric profile into use, you must add the needed profile definitions, such as the profile type, prefix and the unit of measurement, to the profitab.inp file. The profitab.inp file is located under the environment folder in ..\ProgramData\Trimble\Tekla Structures\<version>\environments\<environment>\. The exact file location might vary depending on the folder structure of your environment files.

Tekla Structures searches for the profitab.inp file in the standard search order and then from the folder indicated by the advanced option XS_PROFDB.

Plan the shape and point coordinates of the profile
Start by defining the shape and point coordinates of the new profile on paper.

1. Design the profile on paper.
   a. Draw the cross section outline.
   b. Add the corner points.
   c. Add the dimensions.
   d. Place the y-z coordinate axis center point in the middle of the cross section.
2. Define the y and z coordinate directions.
   For example:
   • positive y axis: up
   • negative y axis: down
   • positive z axis: on the right
   • negative z axis: on the left
3. Define the y and z vectors.

For example:

- \( y_1, y_2, y_3 \)
- \( z_1, z_2, z_3 \)
4. Make coordinate pairs for the points. Assign $y, z$ vector pairs to each point. Start from the lower right corner and define the points in counterclockwise order.

For example:

- point 1: $y_1 z_3$
- point 2: $y_2 z_3$
- point 3: $y_3 z_2$
- point 4: $y_3 z_1$
- point 5: $y_1 z_1$

Create the `.clb` file

After defining the shape and point coordinates of the profile, continue by creating the `.clb` file.

1. Create a new `.clb` file using any standard text editor, such as Microsoft Notepad.
2. Define a library name to be used in the `profitab.inp` file for this profile.

   For example:
   ```
   library_id "1Gen"
   ```
3. Define a cross section name to be used in the `profitab.inp` file for this profile.
For example:

```plaintext
Section_type
{
  name "RectChamfer"
}

4. Define the dimensions of the cross section.
   For example:

```plaintext
base_attribute
{
  name "h"
  description "albl_Height"
  type dimension
  default 1000
}
```

5. Define the coordinates of the profile.
   The coordinates must be the same as the y and z vectors that you defined earlier. Define the default values.
   For example:

```plaintext
expression
{
  name "y1"
  type y
  default -400
  formula -h/2
}
```

6. Define the geometry of one or several faces of the profile.
   For example:

```plaintext
geometry
{
  name "default"
  face
  {
    index 0
    point 0 y1 z3
    point 0 y2 z4
    point 0 y3 z4
    point 0 y4 z3
    point 0 y4 z2
    point 0 y3 z1
    point 0 y2 z1
    point 0 y1 z1
  }
  face
  {
    index 1
    point 1 y5 z7
    point 1 y6 z8
    point 1 y7 z8
    point 1 y8 z7
    point 1 y8 z6
    point 1 y7 z5
    point 1 y6 z6
    point 1 y5 z6
  }
}
```
NOTE  The index number refers to the point number: 0=start point of the beam, 1=end point of the beam.

7. Save the .clb file in the ..\ProgramData\Trimble\Tekla Structures\<version>\environments\common\inp folder.

8. In a text editor, open the components.clb file.

9. Add your profile definition to the components.clb file by adding the following line:

   Include “new_file_name.clb” // give comment

10. Save the components.clb file.

Add profile definitions to the profitab.inp file
Before you start to use the new parametric profile, add the profile definitions to the profitab.inp file.

1. In Windows, browse to the environment folder in ..\ProgramData \Trimble\Tekla Structures\<version>\environments <environment>\ and find the profitab.inp file.

2. Copy the profitab.inp file to a model, project, or firm folder.

3. In a standard text editor, such as Microsoft Notepad, open the profitab.inp file in the new location.

4. Under a suitable category, add a new line for the profile definition.

   Use the following syntax:

   Prefix
   ! Type ! SO ! Z ! MI ! MA ! G3-NAME ! Z3-NAME !

   An example of a profile definition:

   PNL_A
   ! USER ! 0 ! ! 2 ! 3 !1Gen.RectChamfer !h*b-[c]

5. Save the file.

   The profile is now available in the profile catalog. You might have to restart Tekla Structures for the change to take effect.

Properties used in profitab.inp
Use these properties when you define new parametric profiles using the profitab.inp file.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prefix</td>
<td>Prefix of the parametric profile. The prefix is shown in the profile catalog. For example, PNL_A.</td>
</tr>
<tr>
<td><strong>Property</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>--------------</td>
<td>----------------</td>
</tr>
<tr>
<td><strong>Type</strong></td>
<td>Type of the parametric profile. The profile types are or include the following: I, L, Z, U, PL, D, PD, P, C, T, HK, HQ, ZZ, CC, CW, CU, EB, BF, SPD, EC, ED, EE, EF, EZ, EW, 102, 103, 104, 105, 106, USER. For example, in the default environment, parametric profiles with prefixes PD, EPD, CHS, CFCHS, O, Ø, and TUBE all group under the type PD, and appear under <strong>Circular hollow sections</strong> in the profile catalog.</td>
</tr>
<tr>
<td><strong>SO</strong></td>
<td>Sorting order. The options are: • -1: Decreasing sorting order • +1: Increasing sorting order • 0: No sorting order • -2: Name increasing, value decreasing • +2: Value increasing, name decreasing For example, if your profile is PLT200<em>10 or PLT10</em>200 and the sorting order is +2, the result in the output (such as a report) for both cases is PLT200<em>10. If the sorting order is -2, the result for both cases is PLT10</em>200.</td>
</tr>
<tr>
<td><strong>Z</strong></td>
<td>Unit of measurement. The options are: • 0: millimeters • 1: inches • 2: feet • 3: centimeters • 4: meters</td>
</tr>
<tr>
<td><strong>MI</strong></td>
<td>Minimum number of parameters you can use with the parametric profile. For example, the rectangular hollow section SHS has the following <strong>Profile subtypes</strong>: h<em>t, h</em>b<em>t, h1</em>b1-h2<em>b2</em>t. If you define SHS with a minimum of two and a maximum of two parameters, you only have the option h*t available in the <strong>Select Profile</strong> dialog box.</td>
</tr>
<tr>
<td><strong>MA</strong></td>
<td>Maximum number of parameters you can use with the parametric profile.</td>
</tr>
<tr>
<td><strong>G3-NAME</strong></td>
<td>Refers to a cross section file (.clb file). Can be a combination of a library id and the name of a cross section, separated by a full stop. For example, IGen.RectChamfer.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Z3-NAME</td>
<td>Defines how the profile parameters relate to the parameters in the cross section file. Parameters in the order of appearance in the .clb file, optional parameters in square brackets. For example, h*b-[c]. Can also be the name of the detailing component.</td>
</tr>
</tbody>
</table>

Create parametric profiles by sketching
You can create parametric user-defined profiles by sketching. You can change the dimensions of parametric profiles each time that you use them in a model.

- Use the cross section sketch editor to create and modify sketched profiles.
- The Sketch Browser shows the objects of a sketched profile.
- Use the Variables dialog box to define the properties of a sketched profile.

Open the sketch editor
1. Open a Tekla Structures model.
2. On the File menu, click Editors --> Define cross section in sketch editor.

Tekla Structures opens the sketch editor, the Sketch Browser, and the Variables dialog box.

When you first open the sketch editor, the view is empty. The grid coordinates and labels that you see in the sketch editor depend on the grid properties of your actual Tekla Structures model.
Sketch Browser

The Sketch Browser shows the objects (lines, arcs, circles, constraints, dimensions, and chamfers) of a sketched profile in a hierarchical, tree-like structure.

The Sketch Browser automatically opens when you open the sketch editor.

When you click an object in the sketch editor, Tekla Structures highlights the object in the Sketch Browser.
The **Sketch Browser** shows the following information about each sketched profile:

- Extrusion type (0, 1, or 2) and thickness of the sketched profile
- Lines, arcs, and circles
- Constraints
- Distances and dimensions and their values
- Chamfers and their type (0=**None**, 1=**Line** ... 7=**Line and arc**) and dimensions.

**Variables in sketched profiles**

Variables can define fixed properties, or they can include formulas, so that Tekla Structures calculates the property value each time you use the profile in a model.
Use the **Variables** dialog box to define the properties of a sketched profile. The **Variables** dialog box automatically opens when you open the sketch editor.

![Variables dialog box](image)

**NOTE** The **Variables** dialog box functions the same way as the corresponding dialog box in the custom component editor. For more information on how to use variables, see Add variables to a custom component.

---

**Sketch the outline of a profile**

When you create a new sketched profile, start by sketching the outline and the holes of the profile using lines, arcs, and circles.

Unless you are creating a profile of a consistent thickness, such as a cold-rolled profile, ensure that you create a closed shape.

**Sketch a polyline**

You can create line segments in the sketch editor by picking points. Tekla Structures automatically creates coincident constraints between the line segments and shows a chamfer symbol where line segments meet.

1. Open the sketch editor. (page 282)

2. Click the **Sketch polyline** button:

3. Pick points to create each line segment.

4. Click the middle mouse button to create the polyline.
Sketch an arc
You can create an arc in the sketch editor by picking three points.

1. **Open the sketch editor.** (page 282)
2. Click the **Sketch arc** button:
3. Pick three points to define the arc.

**TIP** You can use the advanced option `XS_CS_CHAMFER_DIVIDE_ANGLE` to define the smoothness of the arc.

---

Sketch a circle
You can create a circle in the sketch editor by picking two points.

1. **Open the sketch editor.** (page 282)
2. Click the **Sketch circle** button:
3. Pick a point to indicate the center of the circle (1).
4. Pick a point to indicate the radius of the circle (2).
Refine the shape of a sketched profile by adding a constraint
After you have sketched the outline of a profile, use constraints to refine your sketch and lock the shape.

For example, you can straighten lines, create 90 degree angles, force lines to meet, close the shape, and add chamfers in corners.

To straighten the entire profile, use horizontal and vertical constraints in conjunction with other constraints. Although the shape is locked, you can still rotate the profile in the model.

Add a parallel constraint
You can use a parallel constraint to force two lines in a sketched profile to be parallel to each other.

Before you begin, sketch the outline of the profile in the sketch editor. (page 285)

1. Click the Parallel constraint button.
2. Select a line in the sketch (1).
3. Select another line in the sketch (2).

Add a perpendicular constraint
You can use a perpendicular constraint to force a line in a sketched profile to be at a 90 degree angle to another line that you select.

Before you begin, sketch the outline of the profile in the sketch editor. (page 285)

The selected lines do not have to intersect. You can add a perpendicular constraint to any two lines.

1. Click the **Perpendicular constraint** button:
2. Select a line in the sketch (1).
3. Select another line in the sketch (2).

Add a coincident constraint

You can use a coincident constraint to force two lines in a sketched profile to start or end at the same point, by extending or shortening one or both lines.

Before you begin, sketch the outline of the profile in the sketch editor. (page 285)

The selected lines do not have to intersect. You can add a coincident constraint to any two lines.

**NOTE** Tekla Structures automatically creates coincident constraints:
- where two lines meet
- between line segments when you draw them with the Sketch polyline tool
- between the start of the first line segment and the end of the last line segment in a shape, if they are within a certain distance of each other

1. Ensure that the **Snap to end points** snap switch is active.
2. Click the **Coincident constraint** button:
3. Pick the end of the first line (1).
4. Pick the end of the second line (2).
Add a fixed constraint
You can use a fixed constraint to lock the position and angle of a line in a sketched profile so that other constraints do not affect it.
Before you begin, sketch the outline of the profile in the sketch editor. (page 285)

1. Click the **Fixed constraint** button: ![Fixed constraint button]
2. Select a line in the sketch.

Add a horizontal constraint
You can use a horizontal constraint to force a line in a sketched profile to be parallel to the local x axis.
Before you begin, sketch the outline of the profile in the sketch editor. (page 285)
Tekla Structures automatically creates horizontal constraints when you create lines that are nearly horizontal.

1. Click the **Horizontal constraint** button: ![Horizontal constraint button]
2. Select the lines you want to straighten (1, 2).

Add a vertical constraint
You can use a vertical constraint to force a line in a sketched profile to be parallel to the local y axis.

Before you begin, **sketch the outline of the profile in the sketch editor.** (page 285)

Tekla Structures automatically creates vertical constraints when you create lines that are nearly vertical.

1. Click the **Vertical constraint** button:
2. Select the lines you want to straighten (1, 2).

Delete a constraint

If a constraint is no longer needed, you can delete it from a sketched profile.

1. Click **to open the Sketch Browser.**
2. Select the constraint that you want to delete.
3. Right-click and select **Delete.**
4. Click **Refresh.**

**Add dimensions to a sketched profile**
After you have sketched a profile, use dimensions to make different distances in the profile parametric. You can use these dimensions to define the size of the profile when you use it in a model.

Tekla Structures also adds the dimensions you create to the list of variables that you can use in calculations.

**NOTE** Do not create too many dimensions in a sketch. If there are too many dimensions, the dimensions cannot adjust when the values are changed.

In this example, if you create the dimension marked in red, the dimension b1 no longer works:
Add a radial dimension to a sketch
You can create a radial dimension for an arc or a circle in a sketched profile.

Before you begin, sketch the outline of the profile in the sketch editor. (page 285)

1. Click the Sketch radial dimension button: 📈.
2. Select the arc or circle.

Add an angle dimension to a sketch
You can create an angle dimension between two lines in a sketched profile.
The angle is calculated counter clockwise from the first line you select.

Before you begin, sketch the outline of the profile in the sketch editor. (page 285)

1. Click the Sketch angle dimension button: 📈.
2. Select the first line (1).
3. Select the second line (2).
Add a dimension between two points in a sketch
You can add a dimension to a sketched profile, between two points you pick.
Before you begin, sketch the outline of the profile in the sketch editor.
(page 285)

1. Click the Sketch free dimension button:
2. Pick a point to indicate the start point of the dimension (1).
3. Pick a point to indicate the end point of the dimension (2).
4. Pick a point to indicate the location of the dimension lines and text.

Add a horizontal dimension to a sketch
You can add a horizontal dimension to a sketched profile, between two points you pick.
Before you begin, sketch the outline of the profile in the sketch editor.
(page 285)

1. Click the Sketch horizontal dimension button:
2. Pick a point to indicate the start point of the dimension (1).
3. Pick a point to indicate the end point of the dimension (2).
4. Pick a point to indicate the location of the dimension lines and text.

Add a vertical dimension to a sketch
You can add a vertical dimension to a sketched profile, between two points you pick.
Before you begin, sketch the outline of the profile in the sketch editor. (page 285)

1. Click the Sketch vertical dimension button.
2. Pick a point to indicate the start point of the dimension (1).
3. Pick a point to indicate the end point of the dimension (2).
4. Pick a point to indicate the location of the dimension lines and text.

Delete a dimension from a sketch
If a dimension is no longer needed in a sketch, you can delete it.
You can delete a dimension from a sketch in the sketch editor view, in the Variables dialog box, or in the Sketch Browser.

1. Select the dimension that you want to delete.
2. Do one of the following:
• In the sketch editor view or in the Sketch Browser, right-click and select Delete.
• In the Variables dialog box, click the Delete button.

Define positioning planes for a sketched profile
When you sketch a profile, you can define positioning planes for it. With positioning planes you can determine the planes that Tekla Structures uses for positioning parts and components.

Part positioning planes
With part positioning planes you can determine how Tekla Structures positions parts that have a sketched profile.

These planes are used for the On plane and At depth settings for parts, and also when placing custom components that are bound to boundary planes.

The part positioning planes are shown in blue:

The On plane options Left and Right are set according to the vertical blue planes, and the Middle option is halfway between them.

For the At depth setting, the Front and Behind options are set according to the horizontal blue planes, and the Middle option is halfway between them.

<table>
<thead>
<tr>
<th>Position</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>On plane</td>
<td>Middle</td>
</tr>
<tr>
<td>Rotation</td>
<td>Top</td>
</tr>
<tr>
<td>At depth</td>
<td>Middle</td>
</tr>
</tbody>
</table>

Example
You can define part positioning planes so that an asymmetric profile is positioned according to its web only. In the following example, gray dotted lines illustrate the Middle option:
(1) **Middle** option

Connection positioning planes  
With *connection positioning planes*, you can determine how Tekla Structures positions components in relation to the component main part that has a sketched profile.  
The connection positioning planes are shown in green:

**Example**  
This image shows the default connection positioning planes of a double tee slab that was created as a sketched profile. The green line illustrates the default connection positioning planes.
To place connections according to the location of the stems of the double tee, move the connection positioning planes as shown here.

Show and hide positioning planes

To show or hide the positioning planes, do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show or hide part positioning planes</td>
<td>Click <img src="image1" alt="Image" /></td>
</tr>
<tr>
<td>Show or hide connection positioning planes</td>
<td>Click <img src="image2" alt="Image" /></td>
</tr>
</tbody>
</table>

Move positioning planes

You can move the positioning planes by moving their handles.

If you move the handles away from the outermost corners of the sketched profile, you must bind them by adding a dimension to each handle. Otherwise, the positioning does not function correctly in the model.

1. Click the positioning plane to show the handles.
   
   The handles are shown in pink. By default, the handles are at the outermost corners of the sketched profile.
   
   For example:

   ![Image](image3)

2. Click a handle to select it.
**NOTE**  The same handle controls both the vertical and horizontal plane. You can move them both at the same time.

3.  Move the handle like any other object in Tekla Structures. For example, right-click and select **Move**.

4.  If the handle is not at the outermost corner of the profile, add a dimension between the handle and the corner.

**Example**

In this example, the left handle of the positioning plane has been bound by using a horizontal dimension (b1):

Revert to default positioning planes
You can revert to the default positioning planes of a sketched profile if you have moved the planes.

To revert to the default positioning planes, do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revert to the default <strong>part</strong> positioning planes</td>
<td>1.  Click <img src="image" alt="show part positioning planes" /> to show the part positioning planes.</td>
</tr>
<tr>
<td></td>
<td>2.  Select the part positioning planes.</td>
</tr>
<tr>
<td></td>
<td>3.  Right-click and select <strong>Delete</strong>.</td>
</tr>
<tr>
<td></td>
<td>4.  Click <img src="image" alt="delete" /> again to check that the planes have reverted back to the default.</td>
</tr>
</tbody>
</table>
To | Do this
---|---
Revert to the default **connection** positioning planes | 1. Click ![icon] to show the connection positioning planes.
2. Select the connection positioning planes.
3. Right-click and select **Delete**.
4. Click ![icon] again to check that the planes have reverted back to the default.

*Check a sketched profile*
You can check that the constraints and dimensions in a sketched profile work correctly.

1. Double-click a dimension line to open the **Distance Properties** dialog box.
2. Change the **Value** box.
3. Click **Modify**.
   Tekla Structures updates the profile in the sketch editor.
4. Check that the shape of the profile does not change and that the dimensions adjust correctly.
5. Click **Cancel** to close the **Distance Properties** dialog box.

**See also**
*Use sketched profiles in a model (page 301)*

*Save a sketched profile*
Tekla Structures saves the sketched profiles in the current model folder, in the **xslib.db** file, which is a library file containing custom components and sketches. Sketched profiles are available in the **Others** section in the profile catalog.

**NOTE** Note the following limitations when naming sketched profiles:
- You cannot use the name of a fixed profile.
- You cannot include numbers, special characters, or blank spaces in the profile name.
- Lower case letters are automatically converted into upper case letters.
To save a sketched profile, do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Save a new profile          | 1. Click **Save sketch**.  
                                 | 2. Enter a name in the **Prefix** box, and then click **OK**.                                                                                                                                               |
| Update an existing profile  | 1. Click **Save sketch**.  
                                 | 2. Click **Yes** when prompted to update the existing cross section.                                                                                                                                               |
| Save a copy of the profile  | 1. Click **Save sketch as**.  
                                 | 2. Enter a new name in the **Prefix** box, and then click **OK**.                                                                                                                                               |
| under a different name      |                                                                                                                                                                                                          |

**See also**

*Import and export sketched profiles (page 264)*

*Modify sketched profiles*
You can modify existing sketched profiles, such as by modifying chamfers or dimensions. You can also move corners or holes by moving the handles. The chamfers are moved automatically when you move the handles.

Modify a sketched cross section
• You cannot change dimensions that have been calculated using formulas in the **Variables** dialog box.
• Constraints might also prevent you from changing dimensions.
  1. On the **File** menu, click **Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.
  2. Open the **Others** branch at the end of the profile tree.
  3. To open the profile in the sketch editor, right-click a sketched profile, then select **Edit profile**.
  4. Double-click a sketch object to modify its properties.
      The sketch objects that you can modify appear in yellow.
  5. Modify the properties, then click **Modify**.
  6. Close the sketch object properties dialog box.
  7. Click the **Save sketch as** icon to save the changes.
Modify chamfers in a sketch
You can change the shape and dimensions of chamfers in a sketched profile. For example, you can create rounded profile corners.

1. In the sketch editor, double-click a chamfer symbol.
2. In the **Chamfer Properties** dialog box, change the shape and dimensions of the chamfer.
3. Click **Modify**.
4. Click **OK** to close the dialog box.
5. Click the **Save sketch as** icon to save the changes.

Set the sketch thickness
If you have sketched an open shape, such as a cold-rolled section, you must define the thickness and extrusion type of the sketch in the **Sketch Browser**.

Before you begin, **sketch an open polyline (page 285)** in the sketch editor.

The sketch thickness can be fixed or parametric.

1. Set the sketch thickness in one of the following ways:
   - To set a fixed thickness:
     a. In the **Sketch Browser**, right-click **Thickness**, then select **Add Equation**.
     b. Enter the value of the thickness after =.
   - To define a parametric thickness:
     a. In the **Variables** dialog box, add a new parameter variable (for example, P1) for **Length**.
     b. In the **Formula** column, define the default value for the parameter variable.
     c. In the **Sketch Browser**, right-click **Thickness**, then select **Add Equation**.
     d. Enter the name of the parameter variable (for example, P1) after =.
2. To define the extrusion type:
a. In the **Sketch Browser**, right-click **ExtrusionType**, then select **Add Equation**.

b. Enter the extrusion type number (0, 1, or 2) after \( = \).

3. Click the **Save sketch as** icon to save the changes.

### Extrusion types
The extrusion type defines how a sketched profile of a consistent thickness is extruded. You must define the extrusion type for sketches that consist of an open polyline.

When you change the thickness, the profile grows inwards, outwards, or symmetrically in both directions, depending on the extrusion type.

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
<th>Image</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>The sketch is extruded symmetrically to the outside and inside of the polyline. (Default)</td>
<td><img src="image1.png" alt="Image" /></td>
</tr>
<tr>
<td>1</td>
<td>The sketch is extruded to the outside of the polyline.</td>
<td><img src="image2.png" alt="Image" /></td>
</tr>
<tr>
<td>2</td>
<td>The sketch is extruded to the inside of the polyline.</td>
<td><img src="image3.png" alt="Image" /></td>
</tr>
</tbody>
</table>

*Use sketched profiles in a model*
After you have created a sketched profile and saved it, you are ready to use it in the model. If you have applied constraints correctly, the shape of the profile is maintained when you change its dimensions.

1. In the property pane, open the part properties.

   For example, to open the beam properties, on the **Steel** tab, hold down **Shift**, then click **_property**.
2. Click the ... button next to the **Profile** field.
   The **Select Profile** dialog box appears.
3. Open the **Others** branch at the end of the profile tree.
4. Select a sketched profile.
5. If the profile is parametric, define its dimensions in the **Value** column on the **General** tab.
6. Click **OK** to close the **Select Profile** dialog box.
7. Pick points to place the part in the model.

**See also**

*Create an image of a profile (page 310)*

**Example: Create a symmetric C-shaped profile by sketching**
This example shows how to create a sketched profile using variables.

After completing the tasks, you will have a symmetric C-shaped profile with the dimensions \( b_1 = b_2 \) and \( h_2 = h_3 \). When you use the profile in the model, you can change the following dimensions:

- Width \( b_1 \)
- Total height \( h_1 \)
- Height \( h_2 \)
- Thickness \( P_1 \)
- Chamfers \( P_2 \)

**Example: Sketch a C-shaped profile**
Start by sketching the outline of the profile.
1. Open the sketch editor.
2. Use the **Sketch polyline** command to create a rough C-shaped profile. At this stage, the profile does not have to be symmetric or have the right dimensions.

![C-shaped profile sketch](image)

3. Straighten the lines using the **Add horizontal constraint** and **Add vertical constraint** commands.

![Straightened lines](image)

4. Save the profile and name it **CSHAPE**.

Example: Add dimensions to the sketched profile
After sketching the outline of the profile, you can continue by adding dimensions.

1. Use the **Sketch horizontal dimension** command to create the distances b1 and b2.
2. Use the **Sketch vertical dimension** command to create the distances h1, h2, and h3.

3. In the **Variables** dialog box, enter the following values for the distances:

<table>
<thead>
<tr>
<th>Name</th>
<th>Formula</th>
<th>Value</th>
<th>Value type</th>
<th>Variable type</th>
<th>Visibility</th>
<th>Label in dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td>b1</td>
<td>150.00</td>
<td>150.00</td>
<td>Length</td>
<td>Distance</td>
<td>Show</td>
<td>Width</td>
</tr>
<tr>
<td>b2</td>
<td>=b1</td>
<td>150.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>Width</td>
</tr>
<tr>
<td>h1</td>
<td>300.00</td>
<td>300.00</td>
<td>Length</td>
<td>Distance</td>
<td>Show</td>
<td>Height</td>
</tr>
<tr>
<td>h2</td>
<td>70.00</td>
<td>70.00</td>
<td>Length</td>
<td>Distance</td>
<td>Show</td>
<td>Height</td>
</tr>
<tr>
<td>h3</td>
<td>=h2</td>
<td>70.00</td>
<td>Length</td>
<td>Distance</td>
<td>Hide</td>
<td>Height</td>
</tr>
</tbody>
</table>

4. Ensure that **Visibility** is set to **Show** for the distances b1, h1, and h2.

5. Save the sketched profile.
Example: Set the sketch thickness

After adding dimensions to the sketched profile, you can continue by defining the thickness of the sketch.

1. In the **Variables** dialog box, do the following:
   a. Click **Add** to add a parameter variable P1.
   b. In the **Formula** column, enter 20.00.
   c. In the **Visibility** column, select **Show**.
   d. In the **Label in dialog box** column, enter Thickness.

2. In the **Sketch Browser**, set the thickness using the parameter variable P1.
   a. Right-click **Thickness**, select **Add Equation**, and then enter =P1.
   b. Right-click **ExtrusionType**, select **Add Equation**, and then enter =2 to get the sketch extruded to the inside of the polyline.

![Sketch Browser](image)

3. Save the sketched profile.

Example: Modify the chamfers of the sketched profile

After setting the thickness of the sketch, you can continue by modifying the chamfers of the sketched profile.

1. In the sketch editor, do the following:
   a. Double-click a chamfer symbol.
   b. In the **Chamfer properties** dialog box, change the chamfer type to **Line** and then click **Modify**.
   c. Repeat steps 1a–b for all the chamfers.

2. In the **Variables** dialog box, do the following:
   a. Click **Add** to add a parameter variable P2.
b. In the **Formula** box, enter *10.00*.

c. In the **Visibility** box, select **Show**.

d. In the **Label in dialog box** box, enter Chamfer.

3. In the **Sketch Browser**, do the following:

   a. Double-click **Chamfer constraint** to open the chamfer properties.

   b. Right-click **Chamfer X**, select **Add Equation**, and then enter \(=P2\).

   c. Enter the same value for **Chamfer Y**.

   d. Repeat steps 4a–c for all the chamfers.

   ![Chamfer constraint diagram]

4. Save the sketched profile.

Example: Use the sketched profile in a model

Your sketched profile is now completed and you can use it in a model.

1. Double-click a part to open the part properties in the property pane.

2. Click the ... button next to the **Profile** box.

   The **Select Profile** dialog box appears.

3. Open the **Others** branch at the end of the profile tree, and select the **CSHAPE** profile.

4. If needed, modify the dimensions of the profile on the **General** tab.

   ![Profile properties table]

5. Click **OK** to apply the changes.

6. Pick points to place the part in the model.
Create parametric profiles with variable cross sections

You can create parametric user-defined profiles with variable cross sections using the Profile Editor. You can use a profile with variable cross sections like any other parametric profile.

You can

• use a cross section with different dimensions at different locations in a profile
• modify the variables of the cross sections and the profile
• save the profile and use it as a parametric profile through the profile catalog
• import and export variable cross section profiles

NOTE When you use this method, only the dimensions of a variable cross section can vary, not the actual shape of the cross section. If you want to use several different cross section shapes in the profile, create a fixed profile (page 271) with multiple cross sections instead.

Create a profile with variable cross sections

Before you start:

• Create a sketched profile (page 282) using the sketch editor.
• In the Variables dialog box in the sketch editor, set Visibility to Show for the dimensions that you want to change when using the profile in a model.

1. On the File menu, click Catalogs --> Define properties --> Define profile with variable cross section.
   The Define Profile with Variable Cross Section dialog box opens.

2. Select the sketch you want to use as the start and end cross section of the profile.

3. Click OK.
   The Profile Editor and the Profile preview view appear.

4. Under Cross sections of the profile, add cross sections or remove selected cross sections by clicking Add or Remove.
   When you click Add, Tekla Structures adds a new cross section at the end of the profile, at the location 1.0., and moves the existing cross sections towards the start of the profile. By default, cross sections are located at 0.1 intervals in the profile.

5. Under Cross section variables, define the following:
   • The relative location of each cross section in the profile.
     Use the *.Location variables. For example, start=0.00, middle=0.5, end=1.00.
   • How the cross sections are aligned in the horizontal and vertical direction.
     Use the *.HorPos and *.VerPos variables.
How much the cross sections are offset from the alignment. Use the *.HorOffset and *.VerOffset variables.

6. If you have added new cross sections, check that they do not overlap any existing cross sections.

7. Set **Visibility** to **Show** for the dimensions that you want to change when using the profile in a model.

8. If you want to use parameter variables and equations to define the cross section dimension, click **Add variable** and define the variable values.

9. **Save the profile.**
   a. Click **Save**.
   b. In the **Save profile as** dialog box, enter a unique name for the profile.
      You cannot include numbers in the profile name, or use the name of a standard profile.
   c. Click **OK**.
      Tekla Structures saves the profile in the current model folder.

**Modify a profile with variable cross sections**

1. On the **File** menu, click **Catalogs --> Profile catalog** to open the **Modify Profile Catalog** dialog box.

2. Open the **Others** branch at the end of the profile tree.

3. Right-click a profile with variable cross sections, and then select **Edit profile** to open the profile in the **Profile Editor**.

4. Modify the profile properties.

5. Click **Save**.
Define standardized values for parametric profiles
You can define standardized values for the dimensions of parametric profiles. The standardized values are visible in the profile catalog where you can select suitable dimension values for the profiles.

1. Under the <installation folder>\Environments\<environment> folder, locate the industry_standard_profiles.inp file.

   The file location can vary depending on the folder structure of your environment files.

   For example, if you install Tekla Structures in the \Program Files\Tekla Structures\<version> folder, the file is located in the ..\ProgramData\Trimble\Tekla Structures\<version> \Environments\<environment> folder.

   If there is no industry_standard_profiles.inp file in your environment, you can use the file from the default environment.

2. Copy the industry_standard_profiles.inp file and place it in your firm, project, or model folder.

3. Open the copied industry_standard_profiles.inp file using any standard text editor, such as Microsoft Notepad.

4. Modify the file.

   The file has the following format:
   • profile and profile subtype
   • parameters separated by spaces
   • units for each parameter
   • standardized values for each parameter.

   Each dimension combination has its own row.

5. Save the file.

Example
For example, the standardized combinations of dimension values for a C profile are as follows:

<table>
<thead>
<tr>
<th>c</th>
<th>h<em>b</em>t</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>h</td>
</tr>
<tr>
<td>mm</td>
<td>mm</td>
</tr>
<tr>
<td>75</td>
<td>35</td>
</tr>
<tr>
<td>75</td>
<td>35</td>
</tr>
<tr>
<td>75</td>
<td>35</td>
</tr>
<tr>
<td>100</td>
<td>40</td>
</tr>
<tr>
<td>100</td>
<td>40</td>
</tr>
<tr>
<td>100</td>
<td>40</td>
</tr>
</tbody>
</table>
Create an image of a profile
To illustrate the shape and dimensions of a profile you have created, you can create an image of it. Tekla Structures shows the image when you browse for profiles in the profile catalog.

The image must be in Windows bitmap (.bmp) format and can be created with any bitmap editor, such as Microsoft Paint.

1. Take a screenshot of the profile that you have drawn or sketched.
   For example, press the Print Screen (Prt Scr) key to take a screenshot of your entire desktop. To take a screenshot of an active window, press Alt + Print Screen. The screenshot is placed on the clipboard.

2. Open the screenshot in a bitmap editor and modify the image if necessary.

3. Save the image in .bmp format in the ..\ProgramData\Trimble\Tekla Structures\<version>\Bitmaps folder.
   The file name must match the profile name. For example, if the name of a fixed profile (page 271) or a sketched profile (page 282) is mysketch, the image must be named mysketch.bmp.
   If the profile has been created using a .clb file (page 274), the name of the image file must also include the library ID that has been used for the profile in the .clb file and in the profitab.inp file. For example, if the library ID is BuiltUps and the cross section name is BOXISMC, name the image file BuiltUps.BOXISMC.bmp.
   Note that the profile names, cross section names, and library IDs are case sensitive.

4. Restart Tekla Structures.
The image is now shown in the profile catalog.

[Profile type]
Profile type: User-defined, parametric
Profile subtype: MYSKETCH b1*b2*h1*h2*P1

Customize the shape catalog
The shape catalog contains information about shapes that are used for defining items. Use the Shape catalog dialog box to view and modify shape properties and metadata, to group and tag shapes, and to import and export shapes.

The shape catalog includes default shapes, for example Default and Concrete_Default, and other shapes that are read from specific shape folders in a set folder search order (page 48). The shapes that you import, download from Tekla Warehouse, or create using existing geometry (page 313) in the currently open model are also shown in the shape catalog.

Shape definition files
For each shape in the shape catalog, there are two definition files that contain the shape information:

- One .xml file for shape attributes, such as name and GUID, stored in the \Shapes folder
- One .tez or .xml file for geometric properties, such as coordinates, stored in the \ShapeGeometries folder

Tekla Structures searches for these subfolders and definition files in the model, project, firm, and system folders, and in the folder defined by the advanced option XS_DEFAULT_BREP_PATH.
The definition files of the shapes that are used for items in a model are automatically copied to the model folder.

If you have shapes that you would like to have available in the shape catalog for all new models that are created in your project or company, copy the corresponding .xml and .tez files to the correct subfolders (\Shapes and \ShapeGeometries) in the \profile folder under your project or firm folder (page 16).

Group structure and other shape files

The hierarchical group structure of the shape catalog is read from the ShapeCatalog.Groups.xml file in the model folder. Using this file, you can share the group structure with all users in a project, preferably in the beginning of the project.

If you modify the group structure, Tekla Structures saves the changes to the ShapeCatalog.Groups.user.<username>.xml file in the model folder.

The *.shapecatalog and *.ShapeCatalog.Groups.xml files are used for exporting and importing shapes and the group structure between Tekla Structures models.

Create shapes

In addition to importing item shapes or downloading them from Tekla Warehouse, you can create shapes using existing geometry and parts in Tekla Structures models.

For example, you can create a shape using a single part or several parts that have been attached to each other.

The part reference point that has the yellow handle determines the origin of the shape. The positive global x direction determines the direction of the shape. When you create items using the shape, the shape origin and direction align with the yellow and magenta item handles.

The shape name is generated using the part name and part location in the format <grid location>_<elevation>_<part name>. For example:

- 1/D_+0_FOOTING
- 3/C_+0-+3600_COLUMN
- 1-2/A-B_+3600_SLAB

If there is already a shape with the same name in the shape catalog, Tekla Structures adds two underscore characters and a running number at the end of the new shape name. For example, 1/D_+0_FOOTING_1.

Create a shape by using existing geometry in the model

Use this method if you want to create a new shape using an existing part, but you do not want to delete the part or change it to an item.
1. Using parts, model the geometry from which you want to create a shape.

2. If you want to include more than one part in the shape, attach the parts to each other.

3. On the Edit tab, click \( \text{Create shape from geometry} \).

4. Select the part.

   Alternatively, you can first select the part, right-click, and then select \( \text{Create shape from geometry} \).

Tekla Structures adds a new shape to the shape catalog (page 312).

You can then use the shape when you create items in the model. You can also modify items and shapes further in the Geometry editing mode.

**Create a shape by converting a part to an item**

When you change an existing part in the model to an item, Tekla Structures also creates a new shape and adds it to the shape catalog.

When you change a part to an item, Tekla Structures deletes the original part and replaces it with the newly created item in the model. The name, material, finish, class, pour phase, and the numbering properties of the original part are saved as the corresponding item properties. Other part type specific properties and user-defined attributes are not saved. The objects that are attached to the original part, such as reinforcement and surfaces, are deleted.

1. Create the parts that you want to change to an item.

2. If you want to include more than one part in the item, attach the parts to each other.

3. On the Edit tab, click \( \text{Convert part to item} \).

4. Select the part.

   Alternatively, you can first select the part, right-click, and then select \( \text{Convert part to item} \).

Tekla Structures changes the part to an item and adds a new shape to the shape catalog (page 312).

**Organize shapes and groups in the shape catalog**

You can arrange the shapes in the shape catalog in a hierarchical group structure.

The group structure is shown on the left side of the Shape catalog and Select shape dialog boxes. In the Shape catalog dialog box, you can add, modify,
and delete groups and sub-groups, and move and copy shapes between the
groups and sub-groups.

The group structure might vary depending on the Tekla Structures
environment that you are using. Alternatively, your company or project
administrator might have created and shared a group structure. If you are a
Tekla Structures administrator or main user, you can share your groups so that
they become available to all users in the shared model.

The group structure is read from the ShapeCatalog.Groups.xml file in the
model folder and from the *.ShapeCatalog.Groups.xml files in the shape
sub-folders in the project, firm, and system (XS_SYSTEM) folders. Some shapes
might first be in the Ungrouped group, but you can regroup them.

New shapes that you create (page 313) in the model are also added to the
Ungrouped group. If you import new shapes without a group structure, you
can select a group for the shapes. You can also group shapes by tagging or
starring (page 322) them.

Groups that are marked with are system groups. Groups that are marked
with are user-defined groups.

Current user-defined groups and the changes that you make to the group
structure are stored in the ShapeCatalog.Groups.user.<username>.xml
file in the model folder.
NOTE  Even if you modify the group structure, the definition files (.xml and .tez) for each shape remain in the original \Shapes and \ShapeGeometries folders.

The **Select shape** dialog box is used for selecting a shape for an item. In the **Select shape** dialog box, the **Recent** group is also shown. It contains the latest shapes that you have used.

**Add a new group or sub-group**

1. On the **File** menu, click **Catalogs --> Shape catalog** to open the **Shape catalog** dialog box.

2. To add a sub-group to an existing group, select the group on the left side of the dialog box.

   You can add sub-groups to both user-defined groups and system groups, but not to the **Starred**, **Tags**, or **Ungrouped** group.

3. Click ![New group](image) and do one of the following:
   - To create a highest-level group, select **New group**.
   - To add a sub-group under the selected group, select **New sub-group**.

4. In the **New group name** dialog box, enter a name for the new group, then click **Create**.

5. Add, move, or copy shapes to the new group, or modify the shape properties as needed.

6. Click ![Save](image) to save the changes to the shape catalog.

**Modify a group or sub-group**

You can rename groups and sub-groups, and modify group properties.

1. On the **File** menu, click **Catalogs --> Shape catalog** to open the **Shape catalog** dialog box.

2. Select the group or sub-group that you want to modify.

3. To rename the group, do the following:
   a. Right-click and select **Rename**.
   b. In the **Rename group** dialog box, enter the new name, then click **Rename**.

4. To modify group properties, such as the manufacturer or [tags](page 325) of the shapes in the group, do the following:
   a. Select all shapes in the group.
b. In the property area on the right side of the **Shape catalog** dialog box, modify the properties.

5. Click **Save** to save the changes to the shape catalog.

**Move or copy a group or sub-group**
You can move and copy groups and sub-groups in the shape catalog. You can move and copy both user-defined groups and system groups.

When you move or copy a group, the sub-groups of the selected group are also moved or copied.

You cannot move or copy the **Starred**, **Tags**, or **Ungrouped** group, or sub-groups in them.

1. On the **File** menu, click **Catalogs --> Shape catalog** to open the **Shape catalog** dialog box.
2. Select the group or sub-group that you want to move or copy.
3. Do one of the following:
   • To move the group, drag the group to a new location in the group structure.
   • To move a sub-group to the highest level in the group structure, right-click the sub-group and select **Move to top level**.
   • To copy the group, hold down **Ctrl** and drag the group to a new location.
   • To copy a sub-group to the highest level, right-click the sub-group and select **Copy to top level**.

4. Click **Save** to save the changes to the shape catalog.

**Select shapes**
You can use these methods when you select shapes in the **Shape catalog** dialog box.

Selecting different sets of shapes is useful when you want to export (page 329) or add tags (page 325) to certain shapes, or otherwise modify a sub-set of shapes.

• Use the following commands on the catalog ribbon:
  • Click **Select all** to select all the shapes in the currently visible group. Alternatively, you can select one shape, then press **Ctrl+A**.
  • Click **Select none** to clear the current selection.
  • Click **Invert selection** to select the currently unselected shapes and to deselect the currently selected shapes.
• To select several consecutive shapes, select the first shape, then hold down **Shift** and select the last shape.

• To select several non-consecutive shapes, select the first shape, then hold down **Ctrl** and select the other shapes.

**Preview a shape**

In the **Shape catalog** and **Select shape** dialog boxes, Tekla Structures shows a preview of the selected shape in the upper right corner of the dialog box.

Use these methods to examine the shape in the preview:

- Zoom in and out by scrolling with the mouse wheel
- Rotate the shape using the left mouse button ()
- Pan using the middle mouse button ()
- Adjust the viewing angle using the right mouse button ()
Move or copy shapes between groups

When you move a shape from one group to another, shapes are removed from the previous group. When you copy a shape between groups, the shapes remain in both groups.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape catalog dialog box.

2. Browse to and select the group from which you want to move or copy shapes.

3. Do one of the following:
   • To move one or more shapes to another group, select the shapes and drag them to the other group. Alternatively you can right-click the selected shapes, select Move to group, and then, in the dialog box that appears, select a group. In the dialog box, you can also create a new group or sub-group for the shapes, if needed.
   • To copy one or more shapes to another group, select the shapes, hold down Ctrl, then drag the shapes to the other group. Alternatively you can right-click the selected shapes, select Copy to group, and then, in the dialog box that appears, select a group. In the dialog box, you can also create a new group or sub-group for the shapes, if needed.
   • To remove one or more shapes from the selected group, select the shapes, right-click on one of the selected shapes, and then select Remove from group.

     If the shapes only belong to the selected group, the shapes are moved to the Ungrouped group. If the shapes also belong to any other group, they remain in that group.

4. Click Save to save the changes to the shape catalog.

Modify shape properties

1. On the File menu, click Catalogs --> Shape catalog to open the Shape catalog dialog box.

2. Browse to and select the group in which you want to modify shape properties.

3. Select one or more shapes.

4. In the property area on the right side of the Shape catalog dialog box, modify the shape properties.
For example, you can add a description or tags (page 325) to the selected shapes.

**NOTE** You cannot rename shapes. You cannot remove or change the solidity information, Tekla Structures version, source file location, or GUIDs of the shapes.

5. Click **Save** to save the changes to the shape catalog.

If you want to show shape properties or user-defined attributes in reports, use `PART` rows in the report templates and add the `PROFILE` or `SHAPE` prefix in front of the attribute names. For example, `GetValue("PROFILE.Material")` or `GetValue("SHAPE.Material")`. The attribute names can be found in the shape's definition file (.xml).

**Add a new user-defined attribute to shapes**

In addition to the shape properties that are shown by default in the shape catalog, you can add user-defined attributes to the selected shapes.

User-defined shape attributes are saved in each selected shape's definition file (.xml) in the `\Shapes` folder in the model folder.

1. On the **File** menu, click **Catalogs --> Shape catalog** to open the **Shape catalog** dialog box.
2. Select the shapes to which you want to add a new attribute.
3. Click **Add attribute**.
4. In the **Define attribute** dialog box, do the following:
   a. In the **Label** box, define a name for the attribute.
   b. In the **Type** list, select the type of information that the attribute contains.
   c. In the **Description** box, enter any additional information about the attribute.
   d. Click **Add attribute**.

Tekla Structures shows the new attribute at the end of the property list in the **Shape catalog** dialog box and in the **Select shape** dialog box, before the tags.

5. In the property list, enter a value for the new attribute in the **Value** cell, then press **Enter**.
6. If you need to modify a user-defined attribute, do the following:
   a. Select the attribute in the property list.
b. Click next to the name of the attribute.

c. In the Modify attribute dialog box, modify the type or description of the attribute, and then click Modify attribute.

You cannot modify the name of the attribute.

The modifications are applied to all shapes that have this attribute when you click Yes to confirm the modifications.

7. If you need to delete a user-defined attribute, do the following:

   a. Select the attribute in the property list.

   b. Click next to the name of the attribute.

   c. If you want to delete the attribute from certain shapes only, select the shapes.

   d. Select whether you want to delete the attribute from the selected shapes only, or from all shapes that have the attribute. Click Delete from selected or Delete from all accordingly.

8. Click Save to save the changes to the shape catalog.

Delete a group or sub-group, or shapes

You can delete groups, sub-groups, and shapes within the groups from the shape catalog. You can delete both the groups and the shapes in the groups at the same time, or you can delete groups and shapes separately.

Before you delete shapes, ensure that any shape that you want to delete is not used for items in your Tekla Structures model. When you delete a shape from the shape catalog, the shape is no longer available anywhere in the model.

If you try to delete shapes that are used for items in the model or whose definition files are not in the model folder, Tekla Structures does not delete those shapes.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape catalog dialog box.

2. Select a group or sub-group on the left side of the dialog box.

3. Do one of the following:

   • To only delete the group but not the shapes in it, right-click the group, then select Delete.

   If the shapes only belong to the deleted group, the shapes are moved to the Ungrouped group. If the shapes also belong to any other group, they remain in that group.

   • To delete both the group and the shapes in it, right-click on the group and select Delete with shapes.
• To only delete certain shapes in the group, select one or more unused model-folder shapes, right-click on one of the shapes, and then select **Delete**.

You are prompted to confirm the deletion.

4. Click **Yes**.

5. Click **Save** to save the changes to the shape catalog.

**Share groups with other users**

If you are a Tekla Structures administrator or main user, you might have organized shapes into groups in a project. You can then share the group structure so that your user-defined groups become system groups and are available to all users in the shared model.

1. On the **File** menu, click **Catalogs** –> **Shape catalog** to open the **Shape catalog** dialog box.

2. If still needed, modify the group structure and shape properties, then click **Save** to save the changes to the shape catalog.

3. Click **Share groups**.

4. When prompted to confirm the sharing, click **Share groups** in the dialog box that appears.

5. Click **OK**.

The other users in the shared model will see the shared groups when the users read in changes the next time.

**Organize the shape catalog view**

You can organize the shape catalog view to suit your needs and ways of working.

In the **Shape catalog** dialog box, you can show or hide property columns, or change the order of the property columns. You can also filter shapes and mark them with stars and tags.

In the **Select shape** dialog box, you can show or hide property columns, or change the order of the property columns. You can also filter shapes and mark them with stars.

The **Select shape** dialog box opens when you click the **...** button next to the **Shape** box in the item properties, or in a component dialog box.

The changes that you make to the dialog box layout are automatically saved to the **shape_catalog.settings.UI** file in the `.\Users\<user>\AppData`
Show or hide the catalog ribbon
You can show or hide the catalog ribbon in catalog dialog boxes and selection dialog boxes.

You can show or hide the catalog ribbon in the following dialog boxes:
- Rebar catalog
- Select rebar
- Shape catalog
- Select shape

By default, the ribbon is shown in catalog dialog boxes, but hidden in selection dialog boxes.
- To show the ribbon, click the down arrow \( \downarrow \) at the right side of the (Home) ribbon title bar.
- To hide the ribbon, click the up arrow \( \uparrow \) at the right side of the (Home) ribbon title bar.

Work with property columns in the catalog view
You can organize the catalog view by showing and hiding the property columns, and by changing the order, sort order, and width of the columns.

You can organize the columns in the catalog view in the following dialog boxes:
- Rebar catalog
- Select rebar
- Shape catalog
- Select shape

**NOTE**  The Star column is always visible and you cannot hide it.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Show or hide a property column          | 1. Click [Show columns](#) to open a list of the available property columns.  
A check mark in front of a column name indicates that the column is visible. |
<p>|                                         | 2. To show a column, click the column name to add a check mark in front of the column name. |
|                                         | 3. To hide a column, click the column name to remove the check mark. |</p>
<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the order of the property columns</td>
<td>Drag a column header to a new location.</td>
</tr>
</tbody>
</table>
| Change the sort order of a property column | Click the column header. The arrow symbol next to the column header indicates if the sort order is ascending ▲ or descending ▼. To sort values by two properties and in two columns:  
  1. Sort by one column.  
  2. Hold down Shift and then sort by the other column. |
| Resize a property column                | Drag the edge between this and the following column header. For example:  
  ![GRADE ▲□SIZE ▼□SIZE]  
  You can also click Fit columns to adjust the widths of the visible columns so that the longest value in each column (or the column header in the shape catalog) is shown. This does not affect the widths of the columns you have manually resized. |

**Filter shapes**  
Filtering shapes helps to narrow down the number of shapes shown in the shape catalog view.  
You can filter shapes in both the Shape catalog dialog box and the Select shape dialog box. You can use filtering together with other methods, such as sorting.  
1. Open the Shape catalog dialog box or the Select shape dialog box.  
   • On the File menu, click Catalogs --> Shape catalog to open the Shape catalog dialog box.  
   • To open the Select shape dialog box, click the ... button next to the Shape box in the item properties, or in a component dialog box.  
2. In the Filter box, type the search term or filtering criteria.  
3. Select a group or sub-group.  
   Tekla Structures shows the matching shapes in the selected group.
Add shapes to the Starred group
You can add stars to important or preferred shapes, so that you can easily find these shapes later. Shapes to which you add stars appear in the Starred group in the shape catalog.

Starring is user-specific, so it is only visible to you. The starring settings are stored in the shape_catalog.settings.user.<username> file in the current model folder.

1. Open the Shape catalog dialog box or the Select shape dialog box.
   • On the File menu, click Catalogs --> Shape catalog to open the Shape catalog dialog box.
   • To open the Select shape dialog box, click the ... button next to the Shape box in the item properties, or in a component dialog box.

2. Browse or search for the shapes to which you want to add stars.

3. In the list of shapes, click the white star symbol in the Star column for each shape that you want to add to the Starred group.
   By default, the Star column is the first column and the star symbol is at the beginning of each shape row.

   The star symbol turns yellow and the shape is added to the Starred group.

To remove a shape from the Starred group, click the yellow star symbol on the shape row. The star symbol turns white again.

Add tags to shapes
In the Shape catalog dialog box, you can add tags to shapes to add keywords or other metadata to the shapes.

Tags are model-specific and saved in the ShapeCatalog.Groups.User.<username>.xml file in the current model folder.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape catalog dialog box.

2. Select the shapes that you want to tag.

3. In the Tags box at the bottom-right corner of the Shape catalog dialog box, enter the keywords or metadata, then press Enter.
   To add several tags to a shape, enter the next tag in the next tag box, then press Enter.

   Each group of tagged shapes appears with the symbol under Tags in the list of groups.
4. Click Save to save the changes to the shape catalog.

**Remove tags from shapes or delete tags**
You can remove tags from shapes or delete tags when they are no longer needed.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape catalog dialog box.
2. Remove or delete tags.
   - To remove a tag from a shape, select the shape, then click the X symbol after the tag name in the Tags section in the property area.
   - To delete a tag, select the tagged group, select all the shapes in the group, then click the X symbol after the tag name in the Tags section in the property area.
3. Click Save to save the changes to the shape catalog.

**Import shapes into Tekla Structures**
You can import the following types of shape files:

- dgn
- dwg
- dxf
- ifc
- ifcXML
- ifcZIP
- iges
- igs
- shapecatalog
- skp
- step
- stp
- tsc

When you import a shape into the shape catalog, Tekla Structures creates two files: one .xml file for shape attributes, such as the name and GUID, and one .tez file for geometric properties, such as coordinates. The files are saved
in the current model folder under the Shapes and \ShapeGeometries sub-folders.

The shape name that is shown in the shape catalog is determined as follows:

• If you import a .tsc or .shapecatalog file, the shape name is read from the imported file.
• If you import other file types, the shape name is the name of the imported file.

TIP You can also download shapes from Tekla Warehouse, or create shapes using existing geometry (page 313) in Tekla Structures models.

Import shapes

When you use other modeling software to model shapes that you want to import into Tekla Structures, we recommend that you center parts around the origin and direct the parts along the x axis.

From Tekla Structures models you can also import shape catalog groups (page 314) either with the shapes as .shapecatalog files or without the shapes as .ShapeCatalog.Groups.xml files.

1. Open the model into which you want to import shapes or shape catalog groups.
2. On the File menu, click Catalogs --> Shape catalog to open the Shape catalog dialog box.
3. To import shapes without the group structure into a certain group or sub-group in the shape catalog, select the group or sub-group on the left side of the dialog box.
   If you do not select a group, Tekla Structures imports the shapes into the Ungrouped group.
4. Click Import.
5. In the Import shape definitions dialog box, browse to the folder that contains the files to be imported, select the files, then click Open.
   Tekla Structures checks if there are duplicates in the shapes in the import files compared to the existing shape catalog.
   In the Import dialog box, you can see the Status of each imported shape, such as New shape definition or Shape name already exists. If a shape has already been used in the model, you can also see the Instances of the shape.
6. If shapes with the same name and GUID as the shapes being imported already exist in the shape catalog, replace or keep the existing shapes. In the Import dialog box:
• Select **Overwrite** for each existing shape that you want to replace with a new, imported shape.
• Deselect **Overwrite** for each existing shape that you want to keep unchanged.

7. In the **Import** dialog box, click **Import**.
   Importing a large file can take several minutes.

8. Click **OK** to complete the import.
   
   The groups that contain new or modified shapes are marked with on the left side of the **Shape catalog** dialog box. The new or modified shape rows are highlighted in yellow in the list of shapes.

9. Click **Save** to save changes to the shape catalog.

Shape import has three possible results:
• Tekla Structures imports the shape as a watertight solid shape. All solid operations are available.
• Tekla Structures imports the shape as a non-solid shape. A non-solid shape means that the object might not be watertight. For example, it has holes, or is missing a face or an edge.
• Import fails. The import can fail for several reasons, such as if the shape is very complex or has no volume. There might also be a tolerance difference between Tekla Structures and the original software that was used to create the shape. To find out why the import failed, check the session history log by going to **File menu** --> **Logs** --> **Session history log**.

The **Solidity** column in the shape catalog shows whether a shape is solid or non-solid.

**Example: Import a shape from SketchUp Pro**
This example shows how to import a solid 3D shape from Trimble SketchUp Pro to a Tekla Structures model.
1. Create an empty model in SketchUp Pro.
   Delete any extra entities, such as the default person on the drawing area.

2. Create a group of entities.
   
   Although Tekla Structures supports importing separate individual entities, we recommend you create a group of entities or a component in SketchUp.

   All SketchUp groups and components should form watertight solids. Select the group or component and open **Entity Info** to check that the selection is a solid. SketchUp solids have a volume. If there is no volume listed, the selection is not a solid.
3. Select the group and click **Solid Tools --> Union** to make the group of entities into a union of solids.

Your group becomes a single solid volume: a solid.

4. Place the solid in SketchUp so that it lies along the positive x axis (red), and halfway on both y (green) and z axes (blue). In Tekla Structures, the yellow and magenta part handles will align with the x axis used in SketchUp.

The location and rotation of the solid in SketchUp are important, since they determine how an item is inserted and positioned in Tekla Structures. Different positioning in SketchUp causes an offset in Tekla Structures.

5. Save the SketchUp file.

6. In your Tekla Structures model, open the **Shape catalog** dialog box and click **Import**.

7. Select the SketchUp file.

8. Click **Import**.

Tekla Structures imports the shape to the shape catalog and you can use it to define the shape of an item or a concrete item.

**Export shapes**

You can export shapes and shape catalog groups together or separately from each other.

**TIP** You can also upload shapes to **Tekla Warehouse**.

1. Open the model from which you want to export shapes or shape catalog groups.

2. On the **File** menu, click **Catalogs --> Shape catalog** to open the **Shape catalog** dialog box.

3. Do one of the following to export shapes or groups:
<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export all the shapes in the catalog, but not the group structure</td>
<td>On the <strong>Shape catalog</strong> ribbon, click <strong>Export --&gt; Export all shapes.</strong></td>
</tr>
<tr>
<td>Export all the shapes and groups in the catalog</td>
<td>On the <strong>Shape catalog</strong> ribbon, click <strong>Export --&gt; Export all shapes with groups.</strong></td>
</tr>
<tr>
<td>Export the group structure of the catalog, but not the shapes</td>
<td>On the <strong>Shape catalog</strong> ribbon, click <strong>Export --&gt; Export group structure only.</strong></td>
</tr>
<tr>
<td>Export all the shapes in a group or sub-group</td>
<td>Select the group or sub-group, right-click, and select <strong>Export shapes.</strong> For example, you can export the shapes in the <strong>Starred</strong> group, or groups of tagged shapes.</td>
</tr>
<tr>
<td>Export all the shapes in a group or sub-group and also the group</td>
<td>Select the group or sub-group, right-click, and select <strong>Export shapes with group.</strong></td>
</tr>
<tr>
<td>Export a group or sub-group and its sub-groups, but not the shapes</td>
<td>Select the group or sub-group, right-click, and select <strong>Export selected group structure only.</strong></td>
</tr>
<tr>
<td>Export one or more individual shapes</td>
<td>Select the shapes (page 317), right-click, and select <strong>Export.</strong></td>
</tr>
</tbody>
</table>

4. In the **Export to** dialog box, browse to a folder, enter a name for the export file, and then click **Save.**

   If you are only exporting one individual shape, browse to and select a folder for the export file, then click **Select folder** in the **Export to** dialog box. The shape name is used as the name of the export file.

   If the shape name contains any of these characters, they are replaced with an _ (underscore) in the file name:
   - < (less than)
   - > (greater than)
   - : (colon)
   - " (double quote)
   - / (forward slash)
   - \ (backslash)
   - | (vertical bar or pipe)
We recommend that you avoid using these characters in shape names. Tekla Structures saves the export file in the selected folder. When the export is completed, you can click **Open folder** to open the export folder.

The file name extension of the export file depends on the exported content. The file name extension is:

- **.tsc** if only one shape is exported
- **.shapecatalog** if several shapes or both shapes and groups are exported
- **.ShapeCatalog.Groups.xml** if only the group structure is exported

### Compress shape geometry files

You can compress shape geometry files by converting the files from .xml format to compressed format .tez. Using the .tez format saves disk space.

In Tekla Model Sharing models, the shape geometry files are automatically converted from .xml to .tez.

In models that are not shared, you can manually compress the shape geometry files that are stored in the \ShapeGeometries sub-folder in the current model folder. The files in the \Shapes sub-folder are not compressed.

If you have already used any of the shapes for items in the model, they work the same way even after compression.

**NOTE**  Compression is a permanent action. You cannot undo it even if you do not save the model.

To compress existing shape geometry files, either re-import the original shape files (page 326), or use the **Compress shape geometries** application.

1. Open the model for which you want to compress shape geometry files.
2. Click the **Applications & components** button in the side pane to open the **Applications & components** catalog.
3. Search for the **Compress shape geometries** application, then double-click to open it.
4. In the **Compress shape XML files to TEZ format** dialog box, click **Compress**.
5. Close the model, then open it again.
**Clean or restore shape geometry files**

If some previously imported shapes cause missing faces or edges in items or drawings, you can clean the shape geometry files.

Cleaning means that Tekla Structures investigates and corrects the shape geometry, and tries to create solid objects.

**Clean shape geometry files**

To clean existing shape geometry files, either re-import the original shape files (page 326), or use the **Shape cleaner** application as follows:

1. Open the model for which you want to clean shape geometry files.

2. Click the **Applications & components** button in the side pane to open the **Applications & components** catalog.

3. Search for the **Shape cleaner** application, then double-click to open it.

   The **Shape cleaner** dialog box opens.

4. Select the shapes that you want to clean.

5. If you need to hide unnecessary edges or show more edges in the selected shapes, use the **Edge visibility settings**.

   ![Edge visibility settings](image)

   a. Enter a threshold value for the angle between the neighboring faces in each of the selected shapes.

   b. To hide edges when the neighboring shape faces are in a smaller angle than the threshold value, select the first check box.

   c. To show edges when the neighboring shape faces are in a greater angle than the threshold value, select the second check box.

   Shapes with too many visible or invisible edges can affect how various Tekla Structures features operate on items that are created using those shapes. For example, creating rebar sets might fail if complex shapes have too many edges visible.

6. To create backups of the shape geometry files, select **Create backups from shapes before cleaning**.

   Creating backups of the original shape geometry files allows you to restore them if needed.
7. Click **Clean**.
   Tekla Structures cleans the shapes and shows how many shapes resulted in being solid objects and how many non-solid.
   If you need to interrupt the cleaning process, you can click **Stop**.
8. To see the changed shape geometry in the items in the model, close the model, then open it again.

**Restore the original shape geometry files**
If you have created backup files, you can restore the original shape geometry files if you are not happy with the result of the cleaning.

1. Open the **Shape cleaner** dialog box again.
2. Select the shapes that you want to restore.
3. Click **Revert**.

**Customize the bolt catalog**

The individual *bolt assembly elements*, such as bolts of different sizes and lengths, nuts and washers, are listed in the bolt catalog. Each *bolt assembly* then consists of these bolt assembly elements. You cannot use a bolt if it does not belong to a bolt assembly. The bolt assemblies are listed in the bolt assembly catalog.

Tekla Structures stores the bolt catalog information in the **screwdb.db** file and the bolt assembly catalog information in the **assdb.db** file.

**See also**

- How the bolt catalog and bolt assembly catalogs work together (page 333)
- How bolt and bolt assembly catalogs affect length calculation (page 342)
How the bolt catalog and bolt assembly catalogs work together

(1) The **Bolt standard** options are read from the bolt assembly catalog.
(2) The bolt assembly catalog defines which bolt standard is used in the bolt assembly.
(3) The bolt catalog contains the different bolt diameters, lengths, and other properties used in the bolt standard.
(4) The **Bolt size** options are read from the bolt catalog depending on the selected **Bolt standard** option.

**Manage bolts and bolt assemblies**
In the bolt catalog and the bolt assembly catalog, you can add, modify, and delete bolts and bolt assemblies.

**Add a bolt to the catalog**
You must add individual bolt elements, such as bolts, nuts, and washers, to the bolt catalog before you can define bolt assemblies and use them in a model.
You cannot use a bolt if it does not belong to a bolt assembly. Ensure that the catalog also includes nuts and washers that work with the new bolt so that you can create a bolt assembly.

**TIP** You can also add bolts, nuts, and washers by importing them into the bolt catalog.

1. On the **File** menu, click **Catalogs** --> **Bolt catalog** to open the **Bolt Catalog** dialog box.
2. If you want to create a new bolt, nut, or washer based on an existing one, select an existing bolt, nut, or washer in the **Bolts** list.
3. Type a unique name in the box below the **Bolts** list.

   ![Add, Update, Delete buttons]

   You can enter a maximum of 40 characters in the name box.

4. From the **Type** list, select an option to define the bolt element type.

5. Define the other properties of the new bolt, nut, or washer.
   
   You can enter a maximum of 25 characters in the **Standard** box.
   
   Use different names for bolt, nut, washer, and stud standards to distinguish bolt element types from each other when defining bolt assemblies.

6. Click **Add**.

7. If the catalog does not include nuts and washers that work with the new bolt, click **Update**, then add the nuts and washers in the same way as you added the bolt.

8. When you have finished adding all bolts, nuts, and washers, click **OK**.
   
   The **Save confirmation** dialog box opens.

9. Select **Save changes to model folder**, then click **OK**.

   A new **screwdb.db** file that contains your new parts is created in the current model folder. You can copy this file to the firm folder or to a model template to use it in other new projects.

   Next, add a bolt assembly to the catalog to define the parts that make up the bolt type.

   **Add a stud bolt to the catalog**
   
   A stud is special type of bolt that is welded to steel parts to transfer loads between steel and concrete. You cannot use studs unless you have defined a stud assembly that contains the assembly’s name and material.

   1. On the **File** menu, click **Catalogs** --> **Bolt catalog** to open the **Bolt Catalog** dialog box.
2. Enter values for the following properties:
   • **Name**: Name for the stud bolt.
   • **Type**: 
     • **Standard**: This name is needed when creating a bolt assembly for the stud.
     • **Diameter**: Shank diameter.
     • **Length**: Stud length.
     • **Weight**: Stud weight.
     • **top thick**: Head thickness.
     • **top diameter**: Head diameter.
   The units depend on the settings in File menu -> Settings -> Options -> Units and decimals.

3. On the File menu, click Catalogs -> Bolt assembly catalog to open the Bolt Assembly Catalog dialog box.

4. Select the standard for the stud bolt.

5. Set all the other bolt assembly elements to **None**.

6. To create studs in the model, create bolts and select the stud assembly standard.

**Modify bolt information in the catalog**

1. On the File menu, click Catalogs -> Bolt catalog to open the Bolt Catalog dialog box.
2. Select a bolt from the list.
3. Modify the properties.
4. Click Update.
5. Click **OK**.
   The **Save confirmation** dialog box appears.

6. Select **Save changes to model folder** to save the changes in the `screwdb.db` file in the current model folder, and then click **OK**.

### Delete a bolt from the catalog

1. On the **File** menu, click **Catalogs --> Bolt catalog** to open the **Bolt Catalog** dialog box.

2. Select a bolt from the list. Use the **Shift** and **Ctrl** keys to select multiple bolts.

3. Click **Delete**.

4. Click **OK**.
   The **Save confirmation** dialog box appears.

5. Select **Save changes to model folder** to save the changes in the `screwdb.db` file in the current model folder, and then click **OK**.

### Add a bolt assembly to the catalog

Add a new bolt assembly to the bolt assembly catalog to define the parts that make up the bolt type.

You cannot use a bolt if it does not belong to a bolt assembly. The bolt assembly can contain bolts or studs, but not both.

1. On the **File** menu, click **Catalogs --> Bolt assembly catalog** to open the **Bolt Assembly Catalog** dialog box.

2. Type a unique name in the box below the **Bolt assemblies** list.

3. Define the other properties of the new bolt assembly and select the washer and nut types.
   You can enter a maximum of 30 characters in the **Standard** box. For all the other properties, you can enter a maximum of 25 characters.
   The values in the **Standard** and **Grade** boxes can be used in reports.

4. Click **Add**. The new bolt assembly is highlighted in the **Bolt assemblies** list.

5. Click **OK**.
   The **Save confirmation** dialog box opens.
6. Select **Save changes to model folder**, then click **OK**.

A new **assdb.db** file is created in the current model folder. You can copy this file to the firm folder or to a model template to use it in other new projects.

**Modify bolt assembly information in the catalog**

1. On the **File** menu, click **Catalogs --> Bolt assembly catalog** to open the **Bolt Assembly Catalog** dialog box.
2. Select a bolt assembly from the list.
3. Modify the properties (page 347).
4. Click **Update**.
5. Click **OK**.

The **Save confirmation** dialog box appears.

6. Select **Save changes to model folder** to save the changes in the **assdb.db** file in the current model folder, and then click **OK**.

**Delete a bolt assembly from the catalog**

1. On the **File** menu, click **Catalogs --> Bolt assembly catalog** to open the **Bolt Assembly Catalog** dialog box.
2. Select a bolt assembly from the list.
3. Click **Delete**.
4. Click **OK**.

The **Save confirmation** dialog box appears.

5. Select **Save changes to model folder** to save the changes in the **assdb.db** file in the current model folder, and then click **OK**.

**Import and export bolts and bolt assemblies**

You can import and export bolts and bolt assemblies to merge bolts and bolt assemblies across catalogs.

Importing and exporting bolt catalogs is useful, when you:

- Upgrade to newer version of Tekla Structures and you want to use a customized bolt catalog from a previous version.
- Want to combine bolt catalogs that are stored in different locations.
- Want to share bolt catalog information with other users.

Bolts, bolt assemblies, and bolt catalogs are imported and exported as the following types of files:

- **Bolts**: .bolts
- **Bolt assemblies**: .bass
Bolt catalogs: .lis

When you export single bolts or bolt assemblies, you can select the bolts or bolt assemblies that you want to include in the export file. When you import and export bolt assemblies, all the related bolt elements (bolts, studs, screws, nuts, washers) are also included in the export file.

You can import and export an entire bolt catalog. You can also import a part of an exported bolt catalog.

**TIP** You can also download or share bolt assemblies using Tekla Warehouse.

---

**Import bolts to the catalog**
Bolts are imported and exported as .bolts files. A .bolts file can include one bolt or several bolts.

1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt Catalog dialog box.
2. Right-click in the Bolts list, then select Import.
3. Select the import file.
4. Click OK.
   
   The bolts are shown on the Bolts list by their original names.
5. Click OK.
   
   The Save confirmation dialog box opens.
6. To save the changes in the screwdb.db file in the current model folder, select Save changes to model folder, then click OK.

---

**Export bolts from the catalog**
Bolts are imported and exported as .bolts files. A .bolts file can include one bolt or several bolts.

1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt Catalog dialog box.
2. From the Bolts list, select one or more bolts.
   
   Use the Shift and Ctrl keys to select multiple bolts.
3. Right-click in the Bolts list, then select Export.
4. Browse for the folder where you want to save the export file.
5. In the Selection field, enter a name for the file.
6. Click OK.

---

**Import bolt assemblies to the catalog**
Bolt assemblies are imported and exported as .bass files. A .bass file can include one bolt assembly or several bolt assemblies.
1. On the **File** menu, click **Catalogs --> Bolt assembly catalog** to open the **Bolt Assembly Catalog** dialog box.

2. Right-click in the **Bolt assemblies** list, then select **Import**.

3. Select the import file.

4. Click **OK**.

   If any bolt elements or bolt assemblies in the import file already exist in the bolt assembly catalog, the **Review import items** dialog box opens. Otherwise, the imported bolt assemblies are shown on the **Bolt assemblies** list with their original names.

5. In the **Review import items** dialog box, select the action for each bolt element or bolt assembly.

   a. Select the row for one or more bolt elements or bolt assemblies.

      To select multiple rows, hold down **Ctrl** or **Shift** and click the rows.

   b. Click one of these buttons to select the action for the selected rows:

      • **Leave**: The bolt element or bolt assembly in the import file is ignored. The bolt element or bolt assembly that already exists in the bolt assembly catalog is not changed.

      • **Replace**: The bolt element or bolt assembly in the import file replaces the existing bolt element or bolt assembly in the bolt assembly catalog.

   c. After you have selected the action for all rows, click **Continue**.

6. Click **OK**.

   The **Save confirmation** dialog box opens.

7. To save the changes in the **assdb.db** file in the current model folder, select **Save changes to model folder**, then click **OK**.

---

**Export bolt assemblies from the catalog**

Bolt assemblies are imported and exported as **.bass** files. A **.bass** file can include one bolt assembly or several bolt assemblies.

1. On the **File** menu, click **Catalogs --> Bolt assembly catalog** to open the **Bolt Assembly Catalog** dialog box.

2. From the **Bolt assemblies** list, select one or more bolt assemblies.

   Use the **Shift** and **Ctrl** keys to select multiple bolt assemblies.

3. Right-click in the **Bolt assemblies** list, then select **Export**.

4. Browse for the folder where you want to save the export file.

5. In the **Selection** field, enter a name for the file.

6. Click **OK**.
**Import a bolt catalog**

Bolt catalogs are imported to Tekla Structures models as .lis files.

1. Open the model into which you want to import a bolt catalog.
2. Copy the `screwdb.lis` file that you want to import to the current model folder.
3. To import the bolt catalog file `screwdb.lis` from the current model folder, go to **Quick Launch**, start typing `import bolt catalog`, and select the **Import Bolt Catalog** command from the list that appears.
   - Tekla Structures does not replace entries that have the same names as the entries in the import file.
4. Check the status bar for error messages.
   - To view errors, select **File --> Logs --> Session history log**.

**Import part of the bolt catalog**

If you do not want to import the entire bolt catalog, you can select the parts to be imported.

**TIP** If you only want to import a few bolts or bolt assemblies, use the import and export commands for the corresponding catalogs.

1. Open the model that contains the bolt catalog that you want to use.
2. Go to **Quick Launch**, start typing `export bolt catalog`, and select the **Export Bolt Catalog** command from the list that appears.
   - The bolt catalog is saved as the `screwdb.lis` file in the current model folder.
3. Open the `screwdb.lis` file using a text editor, such as Microsoft Notepad.
   - Each entry is listed on a separate row.
4. Delete the unwanted rows from the file.
   - **WARNING** Do not delete the `STARTLIST` and `ENDLIST` rows.
5. Save the file with the name `screwdb.lis`.
6. Open the model into which you want to import the bolt catalog.
7. Copy the `screwdb.lis` file that you want to import to the current model folder.
8. To import the bolt catalog file `screwdb.lis` from the current model folder, go to **Quick Launch**, start typing `import bolt catalog`, and select the **Import Bolt Catalog** command from the list that appears.
Export an entire bolt catalog
Bolt catalogs are exported from Tekla Structures models as .lis files.

1. Open the model that contains the bolt catalog that you want to export.
2. Go to Quick Launch, start typing export bolt catalog, and select the Export Bolt Catalog command from the list that appears.

The exported bolt catalog is the screwdb.lis file in the current model folder.

How bolt and bolt assembly catalogs affect length calculation
Tekla Structures uses values from the bolt catalog and the bolt assembly catalog when it calculates the bolt length. If the bolt catalog does not contain bolts with the length that you need, you must add them to the bolt catalog.

These Assembly settings in the properties dialog box affect the bolt length calculation.

(1) If this check box is not selected, only a hole is created.
(2) First washer
(3) Second washer
(4) Additional washers
(5) First nut
(6) Second nut

If the check box for a bolt element is selected, the bolt element is used in the bolt assembly and in the bolt length calculation.

The chart and the steps below explain the process of bolt length calculation.
1. Tekla Structures calculates the **minimum possible length** of the bolt:

   first washer thickness
   + material thickness
   + second washer thickness
   + additional washer thickness
   + first nut thickness
   + second nut thickness
   + extra length

2. Tekla Structures searches for the **closest match** in the bolt catalog.

3. Tekla Structures calculates the **number of washers required** (must not exceed 10) so that the **length of the shaft is less than**:

   first nut thickness
   + material thickness
   + second nut thickness
   + first washer thickness
   + second washer thickness
   + (number of washers * additional washer thickness)

4. Tekla Structures checks that the **bolt found in step 2 is longer than**:

   extra length
   + first nut thickness
   + material thickness
   + second nut thickness
   + add. dist (from the bolt catalog)
   + first washer thickness
   + second washer thickness
   + (number of washers * additional washer thickness)

5. If the selected bolt does not fulfill the criteria in step 4, Tekla Structures returns to step 2. Otherwise, it continues to step 6.
6. Tekla Structures checks that the selected bolt fulfills **all the following conditions**.

These calculations refer to the following parts of the bolt:

- **(1) Total shaft length**
- **(2) Grip length**: the length of the unthreaded shank, excluding the runout
- **(3) Thread length**: the length of the thread, excluding the runout
- **(4) Runout**: the part of the bolt between the unthreaded shank and the thread

- Can the thread be inside the material to be connected?
  
  Even if the thread **cannot** be inside the material, the calculation always allows 3 or 4 mm of thread to be inside the material, depending on the bolt diameter. If the bolt diameter is ≥ 24 mm, it allows 4 mm, otherwise it allows 3 mm.

- Grip length must be more than:

  \[
  \text{material thickness} + \text{extra length} + \text{first washer thickness} - \text{maximum allowed thread in material (OR 3 mm or 4 mm if thread in material = no)}
  \]

- Grip length is calculated as:

  \[
  \text{total shaft length} - \text{thread length} - \text{runout}
  \]

- The length of the runout is calculated as follows:

<table>
<thead>
<tr>
<th>Diameter of bolt (mm)</th>
<th>Runout (mm)</th>
</tr>
</thead>
<tbody>
<tr>
<td>&gt;33.0</td>
<td>10.0</td>
</tr>
<tr>
<td>&gt;27.0</td>
<td>8.0</td>
</tr>
<tr>
<td>&gt;22.0</td>
<td>7.0</td>
</tr>
<tr>
<td>Diameter of bolt (mm)</td>
<td>Runout (mm)</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>&gt;16.0</td>
<td>6.0</td>
</tr>
<tr>
<td>&gt;12.0</td>
<td>5.0</td>
</tr>
<tr>
<td>&gt;7.0</td>
<td>4.0</td>
</tr>
<tr>
<td>&gt;4.0</td>
<td>2.5</td>
</tr>
<tr>
<td>≤4</td>
<td>1.5</td>
</tr>
</tbody>
</table>

7. If the selected bolt does not fulfill all the above conditions, Tekla Structures returns to step 2 and tries the next longest bolt.

8. If the advanced option is set, the epsilon thickness is added to or subtracted from the material thickness to avoid inaccurate bolt length calculation.

For example, if this value is not taken into account and the calculated length is 38.001 mm, a 39 mm bolt might be selected.

**Bolt catalog properties**

Use the Bolt Catalog dialog box to view and modify the properties of individual bolt elements, such as bolts, washers, and nuts.

The units depend on the settings in File menu --> Settings --> Options --> Units and decimals.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>The type of the bolt element. The options are:</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Nut" /> (Nut)</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Washer" /> (Washer)</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Stud" /> (Stud)</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Standard</td>
<td>The name of the bolt element standard.</td>
</tr>
<tr>
<td></td>
<td>Used in the <strong>Bolt Assembly Catalog</strong> dialog box for defining bolt elements in a bolt assembly.</td>
</tr>
<tr>
<td></td>
<td>Use different names for bolt, nut, washer, and stud standards to distinguish bolt element types from each other.</td>
</tr>
<tr>
<td>Diameter</td>
<td>The diameter of the bolt element.</td>
</tr>
<tr>
<td>Length</td>
<td>The length of the bolt element.</td>
</tr>
<tr>
<td>Weight</td>
<td>The weight of the bolt element.</td>
</tr>
<tr>
<td>add. dist</td>
<td>The length of the part of the bolt that protrudes from the nut. The value is used in bolt length calculation.</td>
</tr>
<tr>
<td>top thick</td>
<td>The thickness of the bolt head.</td>
</tr>
<tr>
<td>thread len</td>
<td>The length of the threaded part of the bolt shaft. The value is not used in bolt length calculation (value is 0) if the bolt is fully-threaded.</td>
</tr>
<tr>
<td>washer tol</td>
<td>The tolerance between the washer inner diameter and the bolt diameter. The value is used when searching for the correct-sized washer for the bolt. Not used in bolt length calculation.</td>
</tr>
<tr>
<td>span size</td>
<td>The size of the wrench needed.</td>
</tr>
<tr>
<td>calc thick</td>
<td>The calculation thickness of a nut or a washer. This value is used in bolt length calculation.</td>
</tr>
<tr>
<td>real thick</td>
<td>The true thickness of a nut or a washer. This is for information only.</td>
</tr>
<tr>
<td>inner diam</td>
<td>The inner diameter of a nut or a washer. This is for information only.</td>
</tr>
<tr>
<td>outer diam</td>
<td>The outer diameter of a nut or a washer. This is for information only.</td>
</tr>
<tr>
<td>top diam</td>
<td>The diameter of the hexagon. This is for information only.</td>
</tr>
</tbody>
</table>

**See also**

- Manage bolts and bolt assemblies (page 334)
- How the bolt catalog and bolt assembly catalogs work together (page 333)
Bolt assembly catalog properties

Use the Bolt Assembly Catalog dialog box to view and modify the properties of bolt assemblies.

The units depend on the settings in File menu --> Settings --> Options --> Units and decimals.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Short name</td>
<td>This name is used in drawings and reports. It is usually the commercial name for a specific bolt.</td>
</tr>
<tr>
<td>Standard</td>
<td>This name is the full name which is shown in the bolt assemblies list in the Bolt Assembly Catalog dialog box, and in the Bolt standard list in the Bolt Properties dialog box. The value is used in bolt length calculation.</td>
</tr>
<tr>
<td>Material</td>
<td>The material of the bolt assembly.</td>
</tr>
<tr>
<td>Finish</td>
<td>The type of the finish.</td>
</tr>
<tr>
<td>Grade</td>
<td>The grade of the bolt assembly.</td>
</tr>
<tr>
<td>Tolerance</td>
<td>The tolerances of the bolt assembly. This is for information only. The values cannot be reported, for example.</td>
</tr>
</tbody>
</table>

Additional length for bolt calculation

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add. dist...</td>
<td>The Additional Distance option controls how much of the bolt protrudes from the nut. Additional Distance updates the Additional Distance values of all bolts that use the selected bolt standard and have the selected diameter. The value is used in bolt length calculation.</td>
</tr>
</tbody>
</table>
Select whether the value of the additional length affects all or individual diameters of one bolt assembly.

Enter the additional length value.

Select whether the value is absolute or relative to the diameter.

**See also**

*Manage bolts and bolt assemblies (page 334)*

**Customize the rebar catalog**

The rebar catalog contains definitions for different reinforcement types, such as reinforcing bars and strands of different grades.

The rebar catalog shows standard, environment-specific reinforcing bars and strands of the environment (or environments) that you have installed and that is currently open. The blank project environment only contains undefined reinforcing bars and strands.

You can add, copy, group, modify, and delete rebar definitions. You can also import and export single definitions, groups of definitions, or entire rebar catalogs.

Tekla Structures stores the rebar catalog information in the *rebar_database.inp* file that is by default saved to the current model folder.

Reinforcement meshes are not included in the rebar catalog. Standard meshes are defined in their own *catalog file (page 73)*, *mesh_database.inp*. 
Work with definitions in the rebar catalog
You can add, copy, modify, and delete rebar definitions in the rebar catalog. To use the newly added or modified rebar definitions in the model, reopen the model.

Create a new rebar definition
You can add new definitions to the rebar catalog by defining the bar properties.
1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar catalog dialog box.

2. Click New bar.
3. In the New bar dialog box, enter the bar properties.
   If a property is shown in red, it is missing a value or has a value that is not valid. For example, Grade and Size must have a value.
4. Click Add.

5. Click Save to save the changes to the rebar catalog.

Create a new rebar definition by copying an existing definition
You can add new definitions to the rebar catalog by copying an existing definition and then modifying it.
1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar catalog dialog box.
2. Browse for and select the definition that you want to copy.

3. Click Copy.
4. In the Copy dialog box, enter or modify the bar properties.
   Modify the property values that are shown in red so that the new definition is not the same as the original definition.
5. Click Add.

6. Click Save to save the changes to the rebar catalog.

Select rebar definitions
Selecting different sets of definitions is useful when you want to export or add tags to rebar definitions, or modify a sub-set of definitions.
You can use these methods when you select rebar definitions in the Rebar catalog dialog box.

- Use the following commands on the catalog ribbon:
  - Click Select all to select all the definitions in the currently visible group. Alternatively, you can select one definition and then press Ctrl+A.
  - Click Select none to clear the current selection.
  - Click Invert selection to select the currently unselected definitions and to deselect the currently selected definitions.
  - To select several consecutive definitions, select the first definition, then hold down Shift and select the last definition.
  - To select several non-consecutive definitions, select the first definition, then hold down Ctrl and select the other definitions.

Modify a rebar definition
1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar catalog dialog box.
2. Browse for and select the definition that you want to modify.
   To modify several definitions, hold down Ctrl or Shift when you select them.
3. In the property area on the right side of the Rebar catalog dialog box, modify the bar properties.
   For example, you can select whether the bar is a main bar, or a tie or stirrup. Or you can adjust hook lengths or lap lengths, or tolerances for rebar shape recognition. You might also want to add tags to the bar.
   If a property is shown in red, it is missing a value or has a value that is not valid. For example, Grade and Size must have a value.
4. Click Save to save the changes to the rebar catalog.

Delete rebar definitions
1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar catalog dialog box.
2. Select one or more rebar definitions.
3. Right-click and select Delete.
4. Click Yes to confirm the deletion.
5. Click Save to save the changes to the rebar catalog.
Work with groups in the rebar catalog

In the rebar catalog, the rebar definitions are arranged in groups. You can add, copy, modify, and delete groups, and arrange the groups according to different properties.

The groups are listed on the left side of the Rebar catalog and Select rebar dialog boxes.

By default, the definitions in the rebar catalog are grouped according to reinforcement grades. You can change how the definitions are grouped (page 355) in the Rebar catalog dialog box or in the Select rebar dialog box.

To use the newly added or modified rebar definition groups in the model, reopen the model.

Add a new group to the catalog

You can create new groups in the rebar catalog by copying an existing group and the definitions contained in it.

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar catalog dialog box.

2. On the left side of the dialog box, select a group, and then click Copy.

   Alternatively, you can right-click a group and select Copy.
3. In the **New group name** dialog box, enter a name for the new group, and then click **Copy**.
   Tekla Structures adds the new group to the catalog.

4. **Add, modify, and delete definitions (page 348)** contained in the new group as needed.

5. Click **Save** to save the changes to the rebar catalog.

**Modify a group in the catalog**

1. On the **File** menu, click **Catalogs --> Rebar catalog** to open the **Rebar catalog** dialog box.
2. Select the group that you want to modify.
3. Select all definitions in the group.
4. In the property area on the right side of the **Rebar catalog** dialog box, modify the group properties.
   For example, you can change the grade or cranked length type. You may also want to **add tags (page 358)** to all definitions in the group.

5. Click **Save** to save the changes to the rebar catalog.

**Delete a group from the catalog**

You can delete groups and the definitions contained in them from the rebar catalog.

1. On the **File** menu, click **Catalogs --> Rebar catalog** to open the **Rebar catalog** dialog box.
2. Select a group from the list on the left side of the dialog box.
3. Right-click and select **Delete**.
4. Click **Yes** to confirm the deletion.

5. Click **Save** to save the changes to the rebar catalog.

**Import and export rebar definitions**

You can import and export rebar definitions to merge rebar definitions across different catalogs, models, and Tekla Structures environments and versions.
To use reinforcing bars and strands in other Tekla Structures models, you can export rebar definitions to a file (*.inp), then import the file into another Tekla Structures model.

**TIP** You can also download or share rebar catalog content using Tekla Warehouse.

### Import definitions to the rebar catalog
You can customize the rebar catalog by importing rebar definitions from an .inp file.

1. Open the model to which you want to import rebar definitions.
2. On the **File** menu, click **Catalogs --> Rebar catalog** to open the Rebar catalog dialog box.
3. Click **Import**.
4. In the **Import rebar definitions** dialog box, browse for the folder that contains the import file, select the file, then click **Open**.
   Tekla Structures checks if there are duplicates in the definitions in the import file compared to the rebar catalog.
5. If rebar definitions with the same properties as the definitions being imported already exist in the rebar catalog, a confirmation dialog box appears and you have the following three options:
   • Click **Overwrite** to replace all existing definitions with the newly imported definitions.
   • Click **Keep existing** to discard the duplicate definitions being imported and to only import the new definitions.
   • Click **Cancel** to not to import any definitions.
6. Click **Save** to save the changes to the rebar catalog.
7. To use the newly imported definitions in the model, reopen the model.

### Export definitions from the rebar catalog
You can export all or selected rebar definitions, or a selected group of a rebar catalog to a file (.inp).

1. Open the model from which you want to export rebar definitions.
2. On the **File** menu, click **Catalogs --> Rebar catalog** to open the Rebar catalog dialog box.
3. Do one of the following:
   • To export the entire catalog, click **Export --> Export all.**
• To export a certain group only, select the group, right-click and select Export.

• To export certain definitions only, select the definitions, then click Export --> Export selected.

Alternatively, you can right-click one of the selected definitions, then select Export.

4. In the Export as dialog box, browse for a folder, enter a name for the export file, then click Save.

By default, Tekla Structures saves the file to the current model folder.

The file name extension is .inp.

**Organize the rebar catalog view**

You can organize the rebar catalog view to suit your needs and ways of working.

In the Rebar catalog dialog box, you can change how the rebar definitions are grouped, show or hide certain property columns, or change the order of the property columns. You can also filter definitions and mark them with stars and tags.

In the Select rebar dialog box, you can change how the rebar definitions are grouped, show or hide certain property columns, or change the order of the property columns. You can also filter definitions and mark them with stars.

The Select rebar dialog box opens when you click the ... button next to the Size box in a reinforcement object's properties, or in a component dialog box to select a rebar definition.

The status bar at the bottom of the Rebar catalog and Select rebar dialog boxes shows useful information, such as:

• The number of definitions in the selected group.
• The property by which the definitions are grouped.
• The property by which the definitions are sorted.

The arrow symbol indicates if the sort order is ascending ▲ or descending ▼.

In the Rebar catalog dialog box, the status bar also shows the number of the selected definitions.

The changes that you make to the dialog box layout are automatically saved to the rebar_catalog.settings.UI file in the ..\Users\<user>\AppData \Local\Trimble\Tekla Structures\<version>\Catalogs\ folder. Tekla Structures uses the saved layout next time that you open the dialog box.
Show or hide the catalog ribbon
You can show or hide the catalog ribbon in catalog dialog boxes and selection dialog boxes.

You can show or hide the catalog ribbon in the following dialog boxes:

• **Rebar catalog**
• **Select rebar**
• **Shape catalog**
• **Select shape**

By default, the ribbon is shown in catalog dialog boxes, but hidden in selection dialog boxes.

• To show the ribbon, click the down arrow at the right side of the (Home) ribbon title bar.
• To hide the ribbon, click the up arrow at the right side of the (Home) ribbon title bar.

Change the grouping of rebar definitions
You can select the property by which the rebar definitions are grouped in the rebar catalog. By default, the rebar definitions are grouped by grade.

You can also group the definitions by a property for which the property column is not visible.

The properties that are available might vary in the Rebar catalog and Select rebar dialog boxes.

1. Open the Rebar catalog dialog box or the Select rebar dialog box.
   • On the File menu, click Catalogs --> Rebar catalog to open the Rebar catalog dialog box.
   • To open the Select rebar dialog box, click the Size box in a reinforcement object’s properties, or in a component dialog box.

2. Click Group by, and then select the property by which you want to group the rebar definitions.
   For example, you can select Size or Cross section area.

Work with property columns in the catalog view
You can organize the catalog view by showing and hiding the property columns, and by changing the order, sort order, and width of the columns.

You can organize the columns in the catalog view in the following dialog boxes:

• **Rebar catalog**
• **Select rebar**
• **Shape catalog**
### Select shape

**NOTE**  The Star column is always visible and you cannot hide it.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Show or hide a property column          | 1. Click ![Show columns](image) to open a list of the available property columns.  
                                          |   A check mark in front of a column name indicates that the column is visible. |
|                                         | 2. To show a column, click the column name to add a check mark in front of the column name. |
|                                         | 3. To hide a column, click the column name to remove the check mark.     |
| Change the order of the property columns| Drag a column header to a new location.                                 |
| Change the sort order of a property column| Click the column header. The arrow symbol next to the column header indicates if the sort order is ascending ![ Ascending](image) or descending ![Descending](image).  
                                            | To sort values by two properties and in two columns:  
                                            | 1. Sort by one column. |
|                                         | 2. Hold down **Shift** and then sort by the other column. |
| Resize a property column                | Drag the edge between this and the following column header. For example:  
                                            | ![Grade Size](image)  
                                            | You can also click ![Fit columns](image) to adjust the widths of the visible columns so that the longest value in each column (or the column header in the shape catalog) is shown. This does not affect the widths of the columns you have manually resized.
Filter rebar definitions
Filtering rebar definitions helps to narrow down the number of rebar definitions shown in the rebar catalog view.

You can filter rebar definitions in both the Rebar catalog dialog box and the Select rebar dialog box. You can use filtering together with other methods, such as sorting.

1. Open the Rebar catalog dialog box or the Select rebar dialog box.
   • On the File menu, click Catalogs --> Rebar catalog to open the Rebar catalog dialog box.
   • To open the Select rebar dialog box, click the Size box in a reinforcement object's properties, or in a component dialog box.
2. In the Filter box, enter the search term or filtering criteria.
   For example, to find rebar definitions that are suitable for stirrups and ties, enter tie.
   Tekla Structures shows the groups that contain matching definitions.
3. Select a group.
   Tekla Structures shows the matching definitions in the group, for example, the definitions that have Usage set to tie/stirrup.

Add rebar definitions to the Starred group
You can add stars to important or preferred rebar definitions, so that you can easily find these definitions later. Rebar definitions to which you add stars appear in the Starred group in the shape catalog.

Starring is user-specific, so it is only visible to you. The starring settings are stored in the current model folder in the rebar_catalog.settings.user.<username> file, where the <username> suffix is your username.

If you have starred definitions, the Rebar catalog dialog box opens with the Starred group selected.

1. Open the Rebar catalog dialog box or the Select rebar dialog box.
   • On the File menu, click Catalogs --> Rebar catalog to open the Rebar catalog dialog box.
   • To open the Select rebar dialog box, click the Size box in a reinforcement object's properties, or in a component dialog box.
2. Browse or search for the definitions to which you want to add stars.
3. In the definition list, click the white star symbol in the Star column for each definition that you want to add to the Starred group.
By default, the **Star** column is the first column and the star symbol is at the beginning of each definition row.

<table>
<thead>
<tr>
<th>STAR</th>
<th>CODE</th>
<th>GRADE</th>
<th>SIZE</th>
</tr>
</thead>
<tbody>
<tr>
<td>✨</td>
<td>B4</td>
<td>A500HW</td>
<td>10</td>
</tr>
</tbody>
</table>

The star symbol turns yellow and the definition is added to the **Starred** group.

To remove a definition from the **Starred** group, click the yellow star symbol on the definition row. The star symbol turns white again.

**Add tags to rebar definitions**

In the **Rebar catalog** dialog box, you can add tags to rebar definition to add keywords or other metadata the definitions.

For example, you could use tags like **Stainless** and **Acid proof**.

Tags are model-specific and saved to the `rebar_catalog.settings` file in the current model folder.

1. On the File menu, click **Catalogs** --> **Rebar catalog** to open the **Rebar catalog** dialog box.
2. Select the definitions that you want to tag.
3. Enter the tag in the **Tags** box at the bottom-right corner of the **Rebar catalog** dialog box, and then press **Enter**.
   
   To add several tags to a definition, enter the next tag in the next tag box and press **Enter**.

Each group of tagged definitions appears with the ⚪ symbol in the list of groups, after the **Starred** group:
4. Click Save to save the changes to the rebar catalog.

**Remove tags from rebar definitions or delete tags**
You can remove tags from rebar definitions or delete tags when they are no longer needed.

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar catalog dialog box.
2. Remove or delete tags.
   - To remove a tag from a definition, select the definition and click the X symbol after the tag name in the Tags section in the property area.
   - To delete a tag completely, select the tagged group, select all the definitions in the group, and then click the X symbol after the tag name in the Tags section in the property area.
3. Click Save to save the changes to the rebar catalog.

**Customize the Applications & components catalog**
You can modify the catalog definition settings of the Applications & components catalog using catalog definition files, and set up a group structure to suit the needs of your company.

Always check the settings and the group structure when upgrading to a new Tekla Structures version.

Catalog definition files (ComponentCatalog.xml) can be located in folders that are defined by the XS_SYSTEM, XS_FIRM, and XS_PROJECT advanced options, and in the model folder. If there are several catalog definition files, Tekla Structures combines the information in the files. For more information about the folder search order, see Folder search order (page 48).

When you create a group structure for the Applications & components catalog, define the highest level structure in a catalog definition file that is located in a folder that is defined by the XS_SYSTEM advanced option. To hide unnecessary parts of the group structure and catalog content from certain roles, edit the catalog definition files of these roles.

You can also add your own instructor side pane help pages (page 365) for the tools in the Applications & components catalog.
**Edit the Applications & components catalog**

1. To edit the catalog definition files, set the `XS_COMPONENT_CATALOG_ALLOW_SYSTEM_EDIT` advanced option to `TRUE`.

2. In the **Applications & components** catalog, click **Access advanced features** --> **Catalog management** --> **Edit mode**, then select the catalog definition file that you want to edit.

   The list of files shows all the environment folders, the project and firm folders if defined, and the model folder. You can define the catalog definition file folder paths in `XS_SYSTEM`.  
   
   If `XS_COMPONENT_CATALOG_ALLOW_SYSTEM_EDIT` is not set to `TRUE`, a small warning icon is shown next to the files in the `XS_SYSTEM` folder locations. The image shows warning icons next to the files that appear dimmed.

Files that appear dimmed do not exist, but you can create the files by selecting them, and clicking **Yes** in the **Edit mode** message box.
You can remove an existing file by clicking the button next to the file.

3. Select the file that you want to edit.
The check mark in front of the folder name shows the file that is currently being edited.

4. Create new groups and subgroups to organize the catalog content, right-click in the catalog and select **New group**.
5. Move the content from **Ungrouped items** to the new groups, or to other predefined custom groups.
To move an item to another group, right-click the item, select **Add to group**, then select the target group.

![Applications & components catalog](image)

It is important to keep the **Ungrouped items** group empty because all items downloaded from Tekla Warehouse are placed in that group. When you place an item to a predefined group, it is automatically removed from the ungrouped items.

**Maintain the Applications & components catalog**

To keep the **Applications & components** catalog structure and content clear and in order, keep the groups up to date and organized, and remove the unnecessary items from the catalog definition files.

1. Click ![in the bottom-right corner in the Applications & components catalog to display the message log:](image)
If an item defined in a catalog definition file is removed from the Tekla Structures software, the removed item will be included in the Applications & components catalog error message log.

2. If the log contains references to missing items, edit the relevant ComponentCatalog.xml file to remove the references manually. We recommend that you make a back-up copy of the file before you start editing.

3. Thoroughly test that these changes do not create any further errors, or cause problems in the group structure in the Applications & components catalog.

   Check at least the Ungrouped items and Legacy catalog groups.

4. If there are new items in the group, move them from the Ungrouped items group to the appropriate predefined groups, and hide them from specific roles, if needed.

5. Add suitable thumbnails to the items, if needed.

Create your own component folder

Usually, only a few different connections and components are used in a project. To ensure that everyone in the project uses the same components and finds the components faster, we recommend that you create your own component folder.

TIP In the Applications & components catalog, use the commands in Access advanced features > Catalog management to modify catalog definitions.

   1. Click the Applications & components button in the side pane to open the Applications & components catalog.
2. To create a new group for the project, right-click in the catalog, then select New group.

3. Add components to the group.
   a. Select the components in the catalog, right-click, then select Add to group.
   b. Select the group to which you want to add the components.
      You can also drag the selected components to another group.

4. To hide the groups that you do not need, select the group, right-click, then select Hide/Unhide.

Troubleshooting components or groups in the Applications & components catalog
If a component or group in the Applications & components catalog is not working as expected, you can generate a troubleshooting dump file that shows the data used to construct the component or group.

1. In the Applications & components catalog, click Access advanced features --> Catalog management --> Show dump command for selected component or group.

2. In the catalog, select the component or group, then right-click and select Dump troubleshooting data.

3. In the dialog box that opens, select the target file path and enter the file name, then click Save to save the file.
   By default, the file is stored in the \local\temp folder for the model.

Add instructor help for applications and components
You can easily create side pane help for tools in the Applications & components catalog.

In the Applications & components catalog, the Instructor pane shows content when you select an item. The information is especially useful for giving advice to your users about how to choose the right component, or giving instructions before running a tool. To make full use of this feature, users should arrange their side panes so that both panes are visible.

1. Select the tool for which you want to add help in the Applications & components catalog.

2. In the Instructor pane, click the menu, then select Add help file.
A dialog box opens for creating the necessary files according to your selections.

3. Click **Next**, then select one or more languages.
   
   Select the languages that are used as Tekla Structures user interface languages in your organization. There must be a content file for each language even if you do not translate the content.

4. Click **Next**, then select the folder where you want to store the generated files.
   
   The files can be stored in the model, project, firm, or system folder. The standard **folder search order (page 48)** is followed.
   
   If you want to distribute the files to users, we recommend that you store the files in the project or firm folder.

5. Click **Create**.
   
   Tekla Structures creates an XML file that defines a link between the tool in the **Applications & components** catalog and an HTML file for the help content.
   
   The HTML files are stored in a folder structure that separates the files into language-specific folders. The XML file and the root folder for the content are named according to the identifier of the tool that the help is for. You can copy files between the allowed storage locations, but do not rename the files or folders or change the folder structure.

6. Edit the HTML content files in your preferred tool, such as Visual Basic, or replace the files with your own HTML files with the same file names.

   You can optionally add the instructor help files to the .tsep package for your extension so that the instructor help is automatically added when users install the .tsep package. You can use the wildcard character (*) in the project definition .xml file to add all files in the specified folder. For example:

   ```xml
   <TargetPathVariables>
     <PathVariable Id="HelpDirectory" Value="%ENVDIR%\common\extensions\"/>
   </TargetPathVariables>
   ```

Start new projects as a Tekla Structures administrator

Customize catalogs and databases
4.9 Create customized desktop shortcuts for Tekla Structures

To use the correct .ini files for a specific project, you can create shortcuts to start teklastructures.exe with customized initializations.

You can create desktop shortcuts for different purposes, for example, to have customized setup files depending on the client that you are working for in a project. The Tekla Structures installation automatically creates shortcuts for the selected environments.

NOTE We recommend that only administrators create the customization and desktop shortcuts. Otherwise, your settings might differ from the settings defined for your firm, or for the particular project you are working for.

For more information about initialization files (.ini files), see initialization files (files) (page 51).

Create a desktop shortcut for Tekla Structures with customized initializations

1. Create a customized initialization file.
   a. Open the user.ini file using any standard text editor.
      The user.ini file is located in ..\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UserSettings on your computer.
   b. Save the file with a new name, such as customer.ini or project.ini.
   c. Add the required settings to the file, then save the modified initialization file.
2. To make a copy of the default shortcut, right-click **Tekla Structures <version>** shortcut on your desktop, select **Copy**, then paste the shortcut to your desktop.

3. Right-click the shortcut, then select **Properties**.

4. In the **Target** field, enter the path to the current `teklastructures.exe`, then the project initialization parameters.

   If the path contains spaces, use quotation marks ("") around the path. For example, "C:\Program Files\Tekla Structures\"

<table>
<thead>
<tr>
<th>Target type:</th>
<th>Application</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target location:</td>
<td>bin</td>
</tr>
<tr>
<td>Target:</td>
<td><code>eklaStructures.exe&quot; -i&quot;C:\MyProject\project1.ini&quot;</code></td>
</tr>
<tr>
<td>Start in:</td>
<td>&quot;C:\Program Files\Tekla Structures\2022.0\bin&quot;</td>
</tr>
<tr>
<td>Shortcut key:</td>
<td>None</td>
</tr>
<tr>
<td>Run:</td>
<td>Normal window</td>
</tr>
<tr>
<td>Comment:</td>
<td></td>
</tr>
<tr>
<td>Open File Location</td>
<td>Change Icon...</td>
</tr>
<tr>
<td></td>
<td>Advanced...</td>
</tr>
</tbody>
</table>

**TIP** The maximum length of a shortcut is 256 characters. If your shortcut is too long, you can call all other necessary initialization files from your customized initialization file instead of adding them to the shortcut.

5. To override the settings defined in the shortcuts, use the parameter `-i <initialization_file>` in the **user.ini** and **option.ini** files.
**Available parameters in desktop shortcuts for Tekla Structures**

You can use these parameters in desktop shortcuts for Tekla Structures.

You can use the parameters in combinations. For example, you can set the parameters to automatically bypass the **Tekla Structures - Choose setup** dialog box, open a model, and run a macro.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>-I</code></td>
<td>The given <code>.ini</code> file is <strong>loaded before</strong> the environment <code>.ini</code> files. This parameter can be specified multiple times. This parameter can be used to bypass the <strong>Tekla Structures - Choose setup</strong> dialog (the login dialog). Example:</td>
</tr>
<tr>
<td><code>&lt;ini_file_path&gt;</code></td>
<td><code>&quot;C:\Program Files\Tekla Structures\&lt;version&gt;\bin\TeklaStructures.exe&quot; -I &quot;C:\ProgramData\Trimble\Tekla Structures\&lt;version&gt;\Environments\uk\Bypass.ini&quot;</code></td>
</tr>
<tr>
<td><code>-i</code></td>
<td>The given <code>.ini</code> file is <strong>loaded after</strong> the role <code>.ini</code> files. This parameter can be specified multiple times. Example:</td>
</tr>
<tr>
<td><code>&lt;ini_file_path&gt;</code></td>
<td><code>&quot;C:\Program Files\Tekla Structures\&lt;version&gt;\bin\TeklaStructures.exe&quot; -i &quot;C:\TeklaStructures\MySettings.ini&quot;</code></td>
</tr>
<tr>
<td>To open an existing model <code>&lt;model_path&gt;</code></td>
<td>The given model is opened after start-up. Example:</td>
</tr>
<tr>
<td></td>
<td><code>&quot;C:\Program Files\Tekla Structures\&lt;version&gt;\bin\TeklaStructures.exe&quot; &quot;&lt;model_path&gt;&quot;</code></td>
</tr>
<tr>
<td>To open an existing, autosaved model <code>&lt;model_path&gt; / autosaved</code></td>
<td>The given autosaved model is opened after start-up. Example:</td>
</tr>
<tr>
<td></td>
<td><code>&quot;C:\Program Files\Tekla Structures\&lt;version&gt;\bin\TeklaStructures.exe&quot;&quot;&lt;model_path&gt; / autosaved&quot;</code></td>
</tr>
<tr>
<td>To create a new model without a model template <code>/ create:</code> <code>&lt;model_path&gt;</code></td>
<td>A new model is created after start-up. Example:</td>
</tr>
<tr>
<td></td>
<td><code>&quot;C:\Program Files\Tekla Structures\&lt;version&gt;\bin\TeklaStructures.exe&quot;/ create:&quot;&lt;model_path&gt;&quot;</code></td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| To create a new model using a model template / create:<model_path> / modelTemplate:<template_name> | A new model using a model template is created after start-up.  
Example:  
"C:\Program Files\Tekla Structures\<version>\bin\TeklaStructures.exe"/create:"C:\TeklaStructuresModels\My model" /modelTemplate:"Cast-in-Place" |
| To create a new multi-user model / create:<model_path> / server:<servername> | A new multi-user model is created after start-up.  
Example:  
"C:\Program Files\Tekla Structures\<version>\bin\TeklaStructures.exe"/create:"C:\TeklaStructuresModels\My model" /server:"my-server:1234" |
| To run a macro after start-up -m <macro_file_path> | The given macro is executed after start-up.  
The example below opens Tekla Structures, sets the environment, role and configuration from the Bypass.ini file, opens the model, and reads in and saves the model by using the **Example Macro: Model Sharing Read in and Save** from the BIM Publisher tool that is available in Tekla Warehouse.  
"C:\Program Files\Tekla Structures\<version>\bin\TeklaStructures.exe" -I "C:\ProgramData\Trimble\Tekla Structures\<version>\Environments\<environment>\Bypass.ini" "C:\TeklaStructuresModels\<model>" -m "C:\ReadInSave2016.cs" |

**Example of an initialization file**

This example shows a customized project initialization file that calls other initialization files.

```ini
MyProject.ini
//The project is based on the default UK settings
call C:\ProgramData\Trimble\Tekla Structures\2019.0\Environments\uk\env_UK.ini  
//...But our company policy requires these changes
call c:\CompanySettings\OurPolicy.ini  
//...and the fabricator requires something
call c:\Fabricators\Fabricator1.ini  
//...and then we let users to make some changes (color etc.)
call c:\Users\user_%USERNAME%.ini
```

The project shortcut for this initialization file:
Bypass the sign in dialog box

You can bypass the sign in dialog box by creating a desktop shortcuts for Tekla Structures that uses a customized Bypass.ini file.

1. In a text editor, open an existing Bypass.ini file.
   
   You can find the Bypass.ini file for each environment in the %XSDATADIR%\Environments\<your environment> folder.

2. Set the following advanced options in the customized Bypass.ini file:
   
   • XS_LICENSE_SERVER_HOST: the license server address. For Tekla Structures subscriptions, set the value to https.
   
   • XS_DEFAULT_LICENSE: the default subscription or license for a user role.
   
   • XS_DEFAULT_ENVIRONMENT: the environment-specific .ini file, for example %XSDATADIR%\Environments\uk\env_UK.ini
   
   • XS_DEFAULT_ROLE: the role-specific .ini file, for example %XSDATADIR%\Environments\uk\role_Engineer.ini
   
   For example:
   
   set XS_LICENSE_SERVER_HOST=https
   set XS_DEFAULT_LICENSE=DIAMOND
   set XS_DEFAULT_ENVIRONMENT=%XSDATADIR%\Environments\uk\env_UK.ini
   set XS_DEFAULT_ROLE=%XSDATADIR%\Environments\uk\role_Engineer.ini

3. Save the modified Bypass.ini file.

4. Right-click Tekla Structures <version> shortcut on your desktop, then select Copy.

5. Paste the shortcut to your desktop.

6. Right-click the new shortcut, then select Properties.

7. In the Target field, enter the path to teklastructures.exe, followed by the parameter -I (capital i), then the path to the Bypass.ini file.

   If you have installed Tekla Structures in a path that contains spaces, use quotation marks ("") around each path.

   An example of the modified target:

   "C:\Program Files\Tekla Structures\<version>\bin\TeklaStructures.exe" -I
   "C:\ProgramData\Tekla Structures\<version>\Environments\uk\Bypass.ini"
5 Daily management of Tekla Structures

These tasks are often needed in the day-to-day management of Tekla Structures.

• Manage the users in your organization for services (page 372).
• Manage access to subscriptions (page 373) for users in your organization.
• Install service packs or new Tekla Structures versions to upgrade (page 373).
• Manage printer settings (page 374).

5.1 Management of the organization for Tekla Online services

Each organization has at least one administrator who is responsible for managing the Tekla Online organization (group) used in Tekla Online services.

Several people in your company can be Tekla Online organization administrators. The first user is invited by a Trimble representative, and that person is then responsible for adding other users and administrators as necessary.

As a Tekla Online organization administrator, you:

• Invite or approve employees to your company's Tekla Online organization to allow them unrestricted access in all Tekla Online services.
• Add external license users.
• Select who has access to your company's Tekla Structures subscriptions.
• Remove people from your company's employee group when they no longer belong to your company.

For more information, see Manage user accounts for Tekla products.
5.2 Management of Tekla Structures subscriptions

Tekla Structures subscriptions are the default licensing option for Tekla Structures and the Tekla Model Sharing feature.

As a Tekla Structures administrator, you activate subscriptions for each user's Trimble Identity, after which the user is able to select a license when they log in to Tekla Structures. Administrator users can monitor subscription usage and contract manager users can manage subscription renewals in the Tekla Online Admin Tool.

After the Tekla Online subscription is set up, you can verify that you have the correct number of licenses and that the licenses are used correctly.

You can monitor both current subscription users and view statistics about past usage in the Tekla Online Admin Tool.

If users are selecting incorrect license types or secondary users are reserving too many licenses, you can ensure that the correct types of licenses are available to the users who most need them by defining access rights for using licenses. You can adjust access rights for subscriptions in the Tekla Online Admin Tool.

For instructions, see Manage Tekla Structures subscriptions.

5.3 Tekla Structures upgrades for administrators

To upgrade Tekla Structures, you can install service packs or a new Tekla Structures version.

You can install service packs on top of the existing installation of Tekla Structures. Tekla Structures subscriptions automatically allow you to use any Tekla Structures version that is released during your subscription period.

Each new Tekla Structures version is installed as a separate app. You can install a new Tekla Structures version on the same computer as other Tekla Structures versions.

If you already have an older version of Tekla Structures installed on your computer, you can use the Migration Wizard to copy your personal settings to the new version.

When you customize Tekla Structures, we strongly recommend that you create project and firm folders (page 16) for the customized files. If you have customized previous Tekla Structures versions without using firm or project folders, you must transfer the customized information to the next Tekla Structures version.

Before you start using a new Tekla Structures version, always test that the previous company settings (page 37) work.
5.4 Printer settings

Tekla Structures uses Windows drivers to write the print data directly to the Windows print device interface.

You print drawings as a PDF file, save them as a plot file (.plt) for printing with a printer or plotter, or print them on a selected printer.

To print to several paper sizes, you must modify the . You can also change the line width of the printed drawings.

You can use advanced options specific to the drawing type to define how Tekla Structures automatically names .pdf files and .plt files.
Disclaimer

© 2024 Trimble Inc. and affiliates. All rights reserved.

Use of the Software and of this Software Manual are governed by a License Agreement which determines whether you are an authorized user of the Software and the Software Manual. The warranties and disclaimers set forth in the License Agreement apply to the Software and the Software Manual. Neither the Trimble entity granting the license nor any of its affiliates assume responsibility that the text is free of technical inaccuracies or typographical errors. The right to make changes and additions to this manual is reserved.

Trimble and certain product names are registered trademarks of Trimble Inc. in the United States, the European Union and other countries and may have similar statutory protections. Trademarks of third parties are not mentioned in this Manual to suggest an affiliation with or endorsement by their owners.

Elements of the software described in this Manual may be the subject of pending patent applications in the European Union and/or other countries.

Portions of this software:

EPM toolkit © 1995–2006 Jotne EPM Technology a.s., Oslo, Norway. All rights reserved.

Portions of this software make use of Open CASCADE Technology software. Open Cascade Express Mesh Copyright © 2019 OPEN CASCADE S.A.S. All rights reserved.

FLY SDK - CAD SDK © 2012 VisualIntegrity™. All rights reserved.

This application incorporates Open Design Alliance software pursuant to a license agreement with Open Design Alliance. Open Design Alliance Copyright © 2002–2020 by Open Design Alliance. All rights reserved.

CADhatch.com © 2017. All rights reserved.

RapidXml C++ library © All rights reserved.

FlexNet Publisher © 2016 Flexera Software LLC. All rights reserved. This product contains proprietary and confidential technology, information and creative works owned by Flexera Software LLC and its licensors, if any. Any use, copying, publication, distribution, display, modification, or transmission of such technology in whole or in part in any form or by any means without the
prior express written permission of Flexera Software LLC is strictly prohibited. Except where expressly provided by Flexera Software LLC in writing, possession of this technology shall not be construed to confer any license or rights under any Flexera Software LLC intellectual property rights, whether by estoppel, implication, or otherwise.

To see the third party open source software licenses, go to Tekla Structures, click File menu --&gt; Help --&gt; About Tekla Structures --&gt; 3rd party licenses and then click the option.
Index

.tsep packages
  installing................................................... 28
  uninstalling...............................................28

A
  adding
    bolt assemblies to catalog........................ 334
    bolts to catalog..................................... 334
    material grades.................................... 244
    profiles............................................... 271
    stud bolts to catalog................................ 334
    user attributes to material grades............. 244
    user attributes to profiles........................ 252
  user-defined attributes to Template Editor..... 196
  administrators
    advanced options........................................ 243
    applications & components............................ 359
    bypassing............................................... 243
    collaborative modeling................................ 205
    company.................................................. 35,37
    customizing............................................. 35,37
    starting projects..................................... 136
    environment.............................................. 35,37
    getting started.........................................9
    initialization files.................................... 243
    installation............................................. 26
    licenses................................................... 373
    organizations.......................................... 372
    project................................................... 35,136
    registry keys.......................................... 134
    registry settings....................................... 134
    roles....................................................... 35
    routine tasks........................................... 372
    setting up............................................... 35
    setting up.............................................. 37
    setting up.............................................. 136
    subscriptions........................................... 373

  tekla model sharing................................. 205
  tekla online............................................ 372
  trimble connect........................................ 205
  user-defined attributes.............................. 243
  advanced options........................................ 52
  storing settings......................................... 110

AII files
  message files............................................ 68

API................................................................. 134

applications and components
  adding instructor help................................. 359

arcs
  sketching in sketch editor........................... 285

assemblies
  bolt assemblies......................................... 333,334
  bolt catalog............................................ 333
  in templates............................................ 163

attributes
  in bending schedules.................................. 182
  in templates............................................ 192

B
  bending schedules
    attributes and values.................................. 182

bim managers
  getting started.......................................... 9

bolt assemblies
  exporting................................................ 338
  importing................................................ 338
  bolt assemblies.......................................... 334
  bolt catalog............................................. 333
  deleting................................................... 334
  modifying................................................ 334
  properties................................................ 347
  bolt assembly catalog.................................. 333
  bolt assembly elements
    bolt catalog............................................. 333
  bolts
    adding bolt assemblies to catalog.................. 334
adding to catalog...........................334
bolt assemblies..................................334
bolt assemblies..................................333
bolt assembly catalog........................333
bolt catalog......................................333
creating studs..................................334
deleting from catalog........................334
exporting.........................................338
importing........................................338
length calculation............................342
modifying bolt information..................334

C

calculating
  bolt length..................................342
calculations....................................201
catalog files.....................................73
catalogs
  bolt assembly catalog....................333,347
  bolt catalog................................333,345
  creating.....................................243
distributing...................................243
  exporting material catalog..............244
  material catalog............................244
  profile catalog.............................252
chamfers
  in sketching...............................299,302
checking
  sketched profiles.........................298
circles
  sketching in sketch editor...............285
clash check
  settings in Options dialog box.........111
CLB files......................................274
CNV files
  contents....................................214
  creating....................................214
CNV files
  font conversion............................75
  coincident constraints....................287
comments
  in templates................................196
  company.ini..................................52
  components.clb..............................274
components
  settings in Options dialog box..........111
compressing
  shape geometry files......................331
constraints
  coincident..................................287
deleting.......................................287
  fixed.........................................287
  horizontal..................................287
  in sketching................................287
  parallel......................................287
  perpendicular.............................287
  vertical.....................................287
content types
  rows..........................................192
templates......................................192
contentattributes.lst.....................196
contentattributes_userdefined.lst........196
conversion files
  contents.....................................214
  creating.....................................214
  material conversion.......................214
  profile conversion.........................214
twin profile conversion....................214
converting
  profiles.....................................271
copying
  material grades............................244
  profiles.....................................271
creating
  cross sections.............................265
customized initialization files..........367
graphical templates........................166
HTML templates..............................178
profiles......................................265,271,274,282
report templates............................153
shapes from geometry.......................313
shortcuts.....................................367
sketched profiles...........................285
studs..........................................334
textual templates............................153
cross sections
  creating.....................................265
defining........................................265
  modifying....................................265
  profiles with variable cross sections..307
user-defined..................................265
custom tabs....................................43
customized initializations...............367
customizing
  administrators.............................35
message files ........................................ 68
property pane settings .............................. 46
property pane layout................................ 45
ribs.......................................................... 41
tabs........................................................... 43
toolbars.................................................... 47
user-defined attributes......................... 141

D
DAT files.................................................. 66
data files................................................... 66
date
  formats.................................................. 201
decimals
  settings in Options dialog box............. 111
defining
cross sections........................................ 265
flat bar sizes.......................................... 62
  unfolding parameters.......................... 63
deleting
  bolt assemblies.................................. 334
  bolts from catalog............................. 334
  material grades.................................. 244
dimensions
default format........................................ 111
default precision..................................... 111
default unit........................................... 111
in sketching........................................... 290,302
settings.................................................. 111
settings in Options dialog box.............. 111
distributing
  customized property pane settings........ 46
  customized property pane layouts.......... 45
  customized ribbons............................. 41
  customized tabs.................................. 43
  customized toolbars............................ 47
drawing objects
  settings in Options dialog box............. 111
drawing sheet numbers
  templates............................................ 201
DWG files
  symbols............................................... 76
DWG profile to library (6)...................... 265
  properties.......................................... 265

E
enterprise organizations
  getting started...................................... 9
environment settings
  global default..................................... 57
  local................................................ 58
environment variables............................ 110
evironment.db.......................................... 141
environments
  administrators.................................... 35,37
database file.......................................... 141
eenv_<environment>.ini.............................. 52,58,132
eenv_global_default.ini........................... 52,132
eenv_global_default.ini.......................... 57
examples
  adding dimensions to sketched profile.... 302
  adding user attributes to profiles........ 252
  creating user-defined attribute........... 141
  flat bar sizes.................................... 62
  modifying chamfers in sketched profile ................................. 302
  profile export file............................. 259
  setting sketch thickness..................... 302
  sketching symmetric C-shaped profile.... 302
  updating user-defined attribute........... 141
  using sketched profile in model........... 302
exporting
  bolt assemblies................................. 338
  bolts................................................. 338
  groups from shape catalog.................. 329
  material grades................................ 244
  profiles............................................... 259
  rebar definitions................................ 352
  reinforcement..................................... 352
  shapes............................................. 329
  sketched profiles............................... 259
extensions
  Tekla Open API.................................... 134
extrusion types................................... 299

F
file name extensions............................. 87
file types
  catalog files..................................... 73
<table>
<thead>
<tr>
<th>Type of Files</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data files</td>
<td>66</td>
</tr>
<tr>
<td>Font files</td>
<td>75</td>
</tr>
<tr>
<td>Image files</td>
<td>79</td>
</tr>
<tr>
<td>Initialization files</td>
<td>51</td>
</tr>
<tr>
<td>Input files</td>
<td>61</td>
</tr>
<tr>
<td>Layout definition files</td>
<td>76</td>
</tr>
<tr>
<td>Log files</td>
<td>80</td>
</tr>
<tr>
<td>Message files</td>
<td>68</td>
</tr>
<tr>
<td>Profile files</td>
<td>73</td>
</tr>
<tr>
<td>Property files</td>
<td>69</td>
</tr>
<tr>
<td>Report files</td>
<td>76</td>
</tr>
<tr>
<td>Shape definition files</td>
<td>312</td>
</tr>
<tr>
<td>Standard files</td>
<td>69</td>
</tr>
<tr>
<td>Symbol files</td>
<td>76</td>
</tr>
<tr>
<td>Template files</td>
<td>76</td>
</tr>
<tr>
<td>Conversion files</td>
<td>214</td>
</tr>
<tr>
<td>Extensions</td>
<td>87</td>
</tr>
<tr>
<td>In model folder</td>
<td>87</td>
</tr>
<tr>
<td>Initialization files</td>
<td>51</td>
</tr>
<tr>
<td>Locations</td>
<td>51</td>
</tr>
<tr>
<td>Material conversion files</td>
<td>214</td>
</tr>
<tr>
<td>Profile conversion files</td>
<td>214</td>
</tr>
<tr>
<td>Symbol</td>
<td>76</td>
</tr>
<tr>
<td>Twin profile conversion files</td>
<td>214</td>
</tr>
<tr>
<td>Files related to environments</td>
<td>14</td>
</tr>
<tr>
<td>Software</td>
<td>14</td>
</tr>
<tr>
<td>User settings</td>
<td>14</td>
</tr>
<tr>
<td>Firm folders</td>
<td>16</td>
</tr>
<tr>
<td>Fixed constraints</td>
<td>287</td>
</tr>
<tr>
<td>Fixed profiles</td>
<td>271</td>
</tr>
<tr>
<td>Flat bars</td>
<td>62</td>
</tr>
<tr>
<td>In drawings</td>
<td>62</td>
</tr>
<tr>
<td>In reports</td>
<td>62</td>
</tr>
<tr>
<td>Sizes</td>
<td>62</td>
</tr>
<tr>
<td>Fitprops.inp</td>
<td>62</td>
</tr>
<tr>
<td>Folders</td>
<td>47</td>
</tr>
<tr>
<td>In model folder</td>
<td>87</td>
</tr>
<tr>
<td>Locations</td>
<td>51</td>
</tr>
<tr>
<td>Search order</td>
<td>48</td>
</tr>
<tr>
<td>FON files</td>
<td>75</td>
</tr>
<tr>
<td>Fonts</td>
<td>75</td>
</tr>
<tr>
<td>Font files</td>
<td>75</td>
</tr>
<tr>
<td>Fonts_&lt;lang&gt;.ini</td>
<td>52</td>
</tr>
<tr>
<td>Format functions templates</td>
<td>201</td>
</tr>
<tr>
<td>Formats date in templates</td>
<td>201</td>
</tr>
<tr>
<td>Formulas format functions</td>
<td>201</td>
</tr>
<tr>
<td>Free attributes</td>
<td>182</td>
</tr>
</tbody>
</table>

Getting Started
administrators | 9 |
bim managers | 9 |
enterprise organizations | 9 |
freelancers | 9 |
it administrators | 9 |
small organizations | 9 |
Global default environment settings | 37 |
Graphical templates creating | 178 |
Graphical templates pull-out pictures | 182 |
Grouping profiles | 252 |
Groups in rebar catalog | 351 |
in shape catalog | 314 |

Handles handles of positioning planes | 294 |
Hidden files and folders location | 14 |
Hiding positioning planes | 294 |
Hierarchy in templates | 196 |
Horizontal constraints | 287 |
HTML templates creating | 178 |
HTML files instructor | 359 |
html.rpt extension | 178 |

IFC files
defining property sets in export ........................................ 217
image files ........................................................................... 79
images .................................................................................. 79
file formats ........................................................................... 79
in templates ........................................................................... 189
of profile in profile catalog .................................................. 310
imperial units

template value fields ......................................................... 201
templates .............................................................................. 201
import items .......................................................................... 326
importing

bolt assemblies .................................................................... 338
bolts ....................................................................................... 338
groups to shape catalog ...................................................... 326
material grades ...................................................................... 244
model ..................................................................................... 137
profiles ................................................................................ 259
rebar definitions ..................................................................... 352
reinforcement ......................................................................... 352
shapes ................................................................................... 326
sketched profiles .................................................................... 259
SketchUp ................................................................................ 328
indexterm .............................................................................. 77, 264
INI files ................................................................................ 51
env_<environment>.ini ........................................................... 58
env_global_default.ini ......................................................... 58
options.ini ............................................................................. 132
role_<role>.ini ....................................................................... 132
INI files ................................................................................ 51
options.ini ............................................................................. 110
role_<role>.ini ....................................................................... 58
user.ini .................................................................................. 60
initialization files ................................................................... 51
creating customized ............................................................. 367
defining advanced options .................................................... 52
env_<environment>.ini ........................................................... 58
env_global_default.ini ......................................................... 57
file types ................................................................................ 52
reading order ......................................................................... 52
role_<role>.ini ....................................................................... 58
usage ....................................................................................... 52
INP files ................................................................................. 61
adding UDAs to Template Editor ........................................... 196
input files ............................................................................... 61
installation

planning ................................................................................. 12
requirements ......................................................................... 12
installing Tekla Structures

administrators ...................................................................... 26
installing Tekla Structures

configurations ...................................................................... 13
environments ....................................................................... 13
installation folders .............................................................. 14
roles ....................................................................................... 13
installing

tsep packages ....................................................................... 28
instructor

adding help for applications and components ....................... 359
it administrators

goinging started .................................................................... 9

L

lang_<lang>.ini ......................................................................... 52
LAY files

layout definitions ............................................................... 76
layout definition files .......................................................... 76
length

bolt length calculation ......................................................... 342
licenses

administrators ...................................................................... 373
managing .............................................................................. 373
load defaults ......................................................................... 69
load modeling

settings in Options dialog box .............................................. 111
local environment settings

env_<environment>.ini ........................................................... 58
locations

files ....................................................................................... 51
folders ................................................................................... 51
of hidden files ....................................................................... 14
log files

list of ....................................................................................... 80
numberinghistory.txt log ...................................................... 80
session history ....................................................................... 80
viewing .................................................................................. 80
viewing parts or assemblies .................................................. 80
LST files

user-defined attributes ....................................................... 196

M

managing

licenses .................................................................................. 373
Profile cross section from plate (10)........265
profile files........................................73
profiles
adding rules.......................................252
adding user attributes........................252
associating with materials....................252
converting.........................................271
copying..............................................271
creating............................................265,271,274,282
creating image of profile.....................310
defining cross sections.......................265
deleting...............................................252
exporting...........................................259
fixed..................................................271
grouping.............................................252
importing..........................................259
modifying.........................................271
parametric.........................................274
profile catalog..................................252
Profile Editor..................................307
profile export file..............................259
rules..................................................252
saving changes..................................252
sketching..........................................282
user-defined......................................265
with variable cross sections...............307
profitab.inp.......................................274
properties.........................................274
project folders..................................16
projects
transferring customized files..............137
properties
bolt assembly catalog.........................347
bolt catalog......................................345
DWG profile to library (6)....................265
objects.inp........................................151
Profile cross section from plate (10)...265
profitab.inp.......................................274
property files....................................69
property pane settings
customizing........................................46
property pane editor............................45,46
property pane layouts
customizing........................................45
property sets
defining in IFC export.........................217
pull-out pictures
bending schedules................................182
R
reading order
initialization files.............................52
reading order
folders.............................................48
rebar catalog..................................348
filtering..........................................354
organizing......................................354
sorting............................................354
stars...............................................354
tags...............................................354
rebar definitions
exporting..........................................352
importing...........................................352
rebar catalog
definitions......................................348
groups..............................................351
rebar definitions..................................348
reference models
adding UDAs........................................149
registry keys.....................................134
registry settings................................134
reinforcement
exporting..........................................352
importing...........................................352
rebar catalog..................................348
report files.....................................76
reports
creating templates.............................153
date..................................................201
tips...................................................201
reverting
to default positioning planes..............294
ribbon editor......................................41,43
ribbons
customizing........................................41
role settings......................................58
roles...............................................58
administrators...................................35
role_<role>.ini.................................52,58,132
rows
content types..................................192
RPT files
report templates...............................76
textual templates..............................151
RPT templates.................................153
rules
S

save defaults........................................69
save and load properties......................69
saving
advanced options..............................110
options..............................................110
profiles............................................252
sketched profiles...............................298
templates........................................153,166
search order
folders..............................................48
session history...................................80
setting up
administrators................................35
settings
bolt assembly catalog properties........347
bolt catalog properties.....................345
clash check........................................111
components......................................111
decimals...........................................111
dimensions........................................111
drawing objects................................111
general............................................111
general settings in Options dia box...111
in the Options dialog box...............111
load modeling..................................111
mouse..............................................111
north marks, see orientation marks...111
orientation marks..............................111
startup.............................................111
units................................................111
units and decimals............................131
shape catalog
importing shapes...............................326
shape catalog
filtering..........................................322
groups.............................................314
organizing.......................................322
sorting.............................................322
stars.................................................322
tags..................................................322
shape catalog.................................312,329
shape cleaner.................................331
shape definition files
shape catalog.................................312
shapes

cleaning........................................331
compressing geometry files..............331
creating........................................313
deleting........................................314
exporting.......................................329
from geometry................................313
grouping.........................................314
importing.......................................326
modifying properties......................314
shape catalog.................................312
sharing
point clouds.................................210
shortcuts
creating........................................367
showing
positioning planes.........................294
Sketch Browser..............................282
sketch editor.................................282
sketched profiles............................282
adding constraints..........................287
adding dimensions..........................290
arcs...............................................285
chamfers........................................299
checking.........................................298
circles............................................285
deleting constraints.......................287
deleting dimensions........................290
example: adding dimensions............302
example: creating symmetric C-shaped
profile............................................302
example: modifying chamfers..........302
example: setting sketch thickness.....302
example: using sketched profile in model....302
exporting.......................................259
extrusion types...............................299
importing.......................................259
modifying.......................................299
polylines......................................285
positioning planes.........................294
refining the shape..........................287
saving............................................298
setting the thickness.......................299
sketch editor.................................282
sketching the outline......................285
using in model...............................301
sketching, see sketched profiles.............. 282
small organizations
    getting started......................................... 9
solid shapes
    importing................................................326
standard files
    loading................................................... 69
    saving.................................................... 69
standard.opt............................................. 110,111
standardized values
    for parametric profiles............................. 309
startup
    settings in Options dialog box.................... 111
storing
    advanced options..................................... 110
    options................................................... 110
studs................................................................ 334
subscriptions
    administrators......................................... 373
    managing..................................................... 373
SYM files
    symbols....................................................... 76
    symbol files................................................ 76
    system files................................................ 76
system-specific settings.............................. 132

tabs
    importing customized tabs.......................... 43
tekla online
    administrators......................................... 372
    organizations.............................................. 372
Tekla Model Sharing
    cache service.......................................... 206
Tekla Open API
    extensions.............................................. 134
Tekla Structures files.................................. 47
Tekla Structures folders.............................. 47
teklastructures.ini.......................................... 52
TeklaStructures_<user>.log............................. 80
    template attributes..................................... 195
Template Editor........................................... 151,153
template files............................................. 76
    templates
        adding images........................................ 189
        aligning objects.................................... 163
        attributes............................................. 195
        bending schedules.................................. 182
content types............................................. 192
    creating..................................................... 178
    creating textual templates.......................... 153
    creating graphical..................................... 166
    creating report templates............................ 153
date............................................................ 201
date formats................................................. 201
drawing sheet numbers..................................... 201
    format functions.......................................... 201
free attributes............................................. 182
graphical...................................................... 151
graphical templates....................................... 178,182,189
headers and footers....................................... 178
headers and footers....................................... 163
imperial units.............................................. 201
in HTML format............................................. 178
moving objects.............................................. 163
    of bending schedules.................................. 182
    of nested assemblies................................... 163
    rows........................................................ 192
    saving..................................................... 153,166
    sorting order............................................. 163
textual........................................................ 151
textual templates.......................................... 163
tips............................................................... 201
    user-defined attributes............................. 196
testing
    sketched profiles....................................... 298
text type attributes
    in calculations........................................... 201
textual templates.......................................... 163
TEZ files...................................................... 331
    importing.................................................. 326
    shape catalog............................................. 312
thickness
    sketch thickness........................................ 299,302
tips
    templates and reports............................... 201
toolbars
    customizing............................................... 47
TPL templates.............................................. 166
TPL files
    drawing templates....................................... 76
graphical templates....................................... 151
Trimble Connect
    firm folders............................................... 23
    project folders.......................................... 23
troubleshooting
errors in model or parts.......................... 137
model not opening.............................. 137
TTF files
  fonts.............................................. 75
twin profile conversion files................. 214

U
UDAs
  adding to Template Editor.................. 196
unfolding parameters
  defining......................................... 63
unfold_corner_ratios.inp..................... 63
uninstalling
  .tsep packages................................ 28
units and decimals............................. 131
units
  in importing and exporting................ 244, 259
settings in Options dialog box............. 111
updating
  user-defined attributes in model......... 141
updating
  material catalog............................. 244
  profile catalog............................... 252
upgrading Tekla Structures
  administrators................................ 373
user attributes
  adding to material grades................ 244
  adding to profiles.......................... 252
user-defined attributes
  customizing.................................. 141
  environment.db............................... 141
  example........................................ 141
  updating in model........................... 141
user-defined attributes
  adding in reference models................ 149
  in templates.................................. 196
  objects.inp properties...................... 151
user-defined material symbols
  creating...................................... 244
user-defined profiles......................... 265
user-specific settings....................... 132
user.ini......................................... 51, 52
  modifying...................................... 60

V
value fields
  format functions............................ 201
  imperial units................................ 201
variable cross sections...................... 307
variables
  in sketching.................................. 282
vertical constraints.......................... 287
viewing parts or assemblies
  in log files................................. 80
viewing
  log files...................................... 80
virtual use of Tekla Structures................ 31
virtualization.................................. 31

X
XML files
  instructor..................................... 359
  message files................................. 68
  shape catalog............................... 312
XML to TEZ....................................... 331
XS_FIRM
  fixed sub-folders............................ 16
XS_PROJECT
  fixed sub-folders............................ 16