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1 Manage Tekla Structures

Managing Tekla Structures means customizing and deploying Tekla Structures
for users in your organization or for your own use.

Types of users who manage Tekla Structures include:

• Tekla Structures administrators or BIM managers, who customize Tekla
Structures for users in their organization.

• IT administrators who manage the network environment and Tekla
Structures subscriptions, and deploy Tekla Structures for users.

• Individual users, such as freelancers, who have a personal Tekla Structures
subscription and want to customize Tekla Structures for their own use.

1.1 Before you start using Tekla Structures
You must have a Trimble Identity to download Trimble products and to use
your subscriptions.

Tekla Online services, includingTekla Structures subscriptions, use Trimble
Identity for identification. You can use your Trimble Identity with other Trimble
services, such as Trimble Connect and SketchUp 3D Warehouse.

For more information, see Create your Trimble Identity.

1.2 Get started with managing Tekla Structures in an
enterprise company
To get started as a Tekla Structures administrator, familiarize yourself with the
concepts related to installation, customization, and starting projects.
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As a Tekla Structures administrator, you need a deeper understanding and
more managed approach to defining and maintaining the configurations and
settings that your users need in their work.

Workflow for administrators or BIM managers

The typical workflow for a Tekla Structures administrator or BIM manager is:

1. Plan the installation (page 12) needs for Tekla Structures.

2. Customize (page 32) and distribute the customizations to users in your
company.

3. Set up new projects (page 132).

Workflow for IT administrators

As an IT administrator, you maintain the surrounding network environment,
manage the Tekla Structures subscriptions, and deploy Tekla Structures for
users.

The typical workflow for an IT administrator is:

1. Configure the network environment according to the installation
requirements (page 22) for Tekla Structures.

2. Manage the users in your organization (page 352), and your subscriptions
(page 353) or legacy on-premises licenses (page 353).

3. Deploy for users (page 22).

1.3 Get started with managing Tekla Structures in a small
or medium company
Administrators in a small company typically manage the customization of Tekla
Structures, as well as user accounts and subscriptions in your Tekla Online
organization.

The typical workflow for an administrator in a small organization is:

1. Plan how you will install (page 12) and deploy Tekla Structures for users
(page 22).

2. Manage the users in your organization (page 352), and your subscriptions
(page 353) or legacy on-premises licenses (page 353).

3. Customize (page 32) and distribute the customizations to users in your
company.

4. Set up new projects (page 132).
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1.4 Get started with managing Tekla Structures as an
individual user
If you are an individual user with your own personal Tekla Structures
subscription, you might want to customize Tekla Structures for your own use.

Basic configuration for your own use is generally explained in the
documentation of each feature. The customizations can be copied between
different models. If you are configuring Tekla Structures for your own use, it is
good to have a basic understanding of the folder structure for Tekla Structures
installation (page 14) and files for configuring (page 44).

The typical workflow for an individual user is:

1. Install Tekla Structures.

2. Customize (page 32) for your projects and way of working.

3. Create templates (page 149).

4. Check your settings in the advanced options (page 105).

Manage Tekla Structures 11 Get started with managing Tekla Structures as an
individual user



2 Plan the installation and set up
Tekla Structures

Planning is important for ensuring that your installation of Tekla Structures
meets your needs.

When planning the Tekla Structures installation, consider:

• The hardware and software components that you will need for the 
installation

• How you will distribute Tekla Structures to users (page 22)

• Which Tekla Structures environments (page 13) you will use

• How you will use the project and firm folders (page 16) to store 
customized settings.

2.1 Tekla Structures installation requirements
For information about recommended operating system and hardware
specifications, see Tekla Structures .

Tekla Structures also requires some Microsoft redistributable packages. If
these redistributable packages or newer versions of them are not already
installed on your computer, they are automatically installed during the Tekla
Structures software installation. For more information, see Additional necessary
software components in the hardware recommendations.

If you create a customized installation package, make sure that the .NET
Framework is installed on the client computers.

The following installers are also automatically installed during the Tekla
Structures software installation:

• Tsep File Dispatcher Launcher

• Tekla Warehouse Service

These installers are needed for Tekla Warehouse to work correctly.
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2.2 Overview of environments, roles, and configurations
in Tekla Structures
A Tekla Structures environment defines the materials, grades, profiles, drawing
settings, component settings, and .ini file settings that are used in a specific
locale. There are many different environments in Tekla Structures. When you
select a specific environment when you start Tekla Structures, you get the
settings for that locale. You can install several environments at the same time,
and you can add more environments at any time.

If you do not install any environments, only the Blank environment is available.
You can use the Blank environment as the basis for your own environment or
project settings. It includes standard settings, such as parametric profiles,
undefined bolt, material and rebar grades, and basic drawing layouts that you
can complement from your own firm or project folders and Tekla Warehouse.

Some environments give you the opportunity to select a role when signing in.
The role is independent from your subscriptions or licenses. Using roles makes
the user interface and settings clearer, easier, and faster for the users' tasks.
Settings, filters, reports, and the user interface are set up for the role that the
user has. For example, preloaded settings in object properties that are not
relevant for the role are not shown.

Role selection is primarily meant to be configured by Trimble and reseller
localization personnel, and is typically part of the Tekla Structures installation
package. However, advanced users and Tekla Structures administrators can
also create their own roles inside their company organization. Additional
content is available in the Tekla Warehouse offline and online collections.

Tekla Structures has many different configurations. The subscriptions or
licenses that you have determine which configurations you can use.
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See also

Hierarchy of Tekla Structures settings (page 32)

2.3 Folder structure for Tekla Structures installation
By default, the Tekla Structures app and environments are separated into
different locations due to the requirements for Windows certification.

The files are installed in the following folders by default:

• The Tekla Structures app is installed in the ..\Program Files\Tekla
Structures\<version>\ folder.

When Tekla Structures is installed in the Program Files folder, any user
can run the app but they cannot make changes to it. Configuration files are
installed separately in the hidden Program Data folder. Installation in the
Program Files folder requires administrator rights on the computer.

• Environments and extensions are installed in the hidden ..\ProgramData
\Trimble\Tekla Structures\<version>\ folder.

• User settings are always installed in the ..\Users\<username>\AppData
\Local\Trimble\Tekla Structures\<version>\ folder for each user,
regardless of where the Tekla Structures app is installed. Each user has
access to the files in their own user settings.

You can select the installation folder when you install Tekla Structures. You can
use the default installation folders or install Tekla Structures in a normal file
folder on the computer, such as C:\TeklaStructures.

If you want to prevent users from making changes to the Tekla Structures app,
environments, or settings, we recommend that you use the default installation
folders.

If users need to easily access all files for Tekla Structures or if it is not possible
for users to install Tekla Structures with administrator rights, we recommend
that you install Tekla Structures in a normal file folder. When you install Tekla
Structures in a normal file folder, all files except for user settings are installed
in that folder. Any users who have access to the folder have access to all of the
installation, configuration, and environment files.

Hidden files and folders for Tekla Structures
When the Tekla Structures app is installed in the Program Files folder, some
of the files needed to run Tekla Structures are located in hidden folders and
are not visible.
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If needed, you can make the hidden files and folders visible using the Folder
Options in Windows.

Files related to the Tekla Structures app

The Tekla Structures app and files such as the following are installed under
the ..\Program Files\Tekla Structures\<version>\ folder:

• contentattributes_global.lst
• contentattributes_userdefined.lst

(in the USA environment: contentattributes_customer.lst)

Files related to environments

Environments and files such as the following are installed under
the ..\ProgramData\Trimble\Tekla Structures\<version>\ folder:

• analysis_design_config.inp
• contentattributes.lst
• dimension_marks.sym
• InquiryTool.config
• objects.inp
• objects.inp
• privileges.inp
• product_finishes.dat
• rebar_config.inp
• TeklaStructures.lin
• TilePatternCatalog.dtd
• TilePatternCatalog.xml
The exact file location can vary depending on the folder structure of your
environment files.

Files related to user settings

User settings and files such as the following are installed under the ..\Users
\<username>\AppData\Local\Trimble\Tekla Structures\<version>\
folder for each user:

• user.ini
• options.bin
• customized property pane layout PropertyTemplates.xml and

PropertyTemplates.Drawing.xml files

• customized ribbon and customized tab .xml files
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• customized contextual toolbar .xml files

• customized toolbar .json files

Company folder structure
Using central project and firm folders makes taking backups and upgrading
easier. For example, when upgrading to a new Tekla Structures version or
updating the company logo, the files only need to be replaced in one place.

If you do not use Tekla Model Sharing, we recommend using project and firm
folders (page 16) on a central file server for storing your models, and the
setup files for company-specific and project-specific settings. Tekla Structures
reads the settings from the central file server.

If you use Tekla Model Sharing, you can synchronize the project and firm
folders through the Trimble Connect cloud service included in your Tekla
Structures subscription.

Backing up important Tekla Structures folders
Model folders, and the firm and project folders contain valuable information
and work. It is important to take backups of these folders and settings.

If your company has a system for taking automatic scheduled backups,
schedule your system to take the backups at night time, outside working hours
to prevent any possible conflicts in models.

If you use legacy on-premises licenses, also take a backup of the license
entitlements and your active licenses.

Virus protection and Tekla Structures folders
Virus protection software can cause problems in saving models and drawings
to the model folder. These problems might occur especially if you have saved
your model on a network drive.

We strongly recommend that you add Tekla Structures to the safe list for your
antivirus system, and set up your virus protection so that it does not block or
scan actions in your model folder.

2.4 Project and firm folders
Project and firm folders are meant for storing customized files. Customized
files can include custom ribbons, drawing styles, profile and material catalogs,
or any other settings that you want to store for future use.
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You can use the same files each time you start a new model or install a new
version of Tekla Structures.

Folder Typical contents
Firm Settings that are used on the company level, such as

company logo and drawing standard.

Use the firm folder and its sub-folders to store customized
files for the entire organization or company. The settings and
files in the firm folder are meant to be used in all projects
within the company. For example, let's say you regularly work
for a company that has specific drawing layout standards it
expects you to use. Customize the drawing templates once
for the company and save them in the firm folder or in a sub-
folder of the firm folder. You can then use the customized
drawing templates for all future projects for that company.

Project Settings that are used on a specific project.

Use the project folder and its sub-folders to store customized
files that are only used in a particular project. A project might
consist of several models done by separate teams in different
locations. You can save project-specific files and settings in
the project folder, so that everyone in the project can use
them. A project might also consist of one model that is
shared by different companies.

Property files are always saved in the \attributes folder under the current
model folder, such as \TeklaStructuresModels\<my_building>
\attributes. We recommend that you copy these files to the project or firm
folder, or to user-defined sub-folders under the project or firm folder.

Benefits of the project and firm folders
Using project and firm folders to store your customized settings makes it
easier to update company settings, ensure that everyone uses the same
settings in a project, and upgrade to a newer version of Tekla Structures.

Tekla Structures does not replace files in the project and firm folders when you
install a new version. You can retain your customized files without having to
copy and paste, or export and import from the previous versions. Using
project and firm folders makes upgrading faster and easier. When you store
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files in one place, it is also easier to update the settings and ensure that
everyone in a project uses the same settings. Using project and firm folders
also allows you to easily revert back to the default settings because your
customized settings do not overwrite any of the system files.

Example:

In the current project, 123_project_ABC, you have set up the properties for a
concrete column, and saved them as column_ABC. To make these saved
settings available for everyone working in the 123_project_ABC project:

1. Copy column_ABC.ccl from the \attributes folder under the model
folder to the \123_project_ABC project folder or on your file server, or
to a user-defined sub-folder under the \123_project_ABC project folder.

2. Ensure that everyone in the project has the correct path for the 
XS_PROJECT advanced option in the .ini file.

Advanced options for defining the project and firm folders
Project and firm folders are defined by the XS_FIRM and XS_PROJECT
advanced options.

To use the saved settings in a firm and a project folder, set the path to the
folder by using the XS_PROJECT and XS_FIRM advanced options. These
advanced options should be put in the initialization, .ini, files. You can have
several different .ini files. You can define in the Tekla Structures shortcut
which .ini files to run and which settings to apply.

It might be useful to create a startup shortcut on your desktop that contains all
necessary folders for each project.

WARNING Changing an advanced option value in .ini files located outside the
model folder does not affect the existing models. You can only update
advanced options in the Advanced Options dialog box or in the
options.ini file located in model folder; not from an options.ini file
located in folders defined for the advanced options or . The .ini files are
read also when you open an existing model, but only new advanced
options that do not exist in options_model.db or
options_drawings.db are inserted, for example, such options that are
not yet in the Advanced Options dialog box but have been added in the
software.
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Create a project or firm folder
When working within one company, the firm and project folders are usually
located in network folders or on a shared file server accessible to all users so
that everyone can access them.

When working within Tekla Model Sharing projects, you can use a folder in the
linked project (page 182) as the project or firm folder.

1. Create an empty project or firm folder in a shared location.

2. In Tekla Structures, go to the File menu and select Settings --> Advanced
options.

3. In the File locations category, define the path to the firm or project folder
for the advanced option XS_FIRM or XS_PROJECT.

4. Restart Tekla Structures for the change to take effect.

Fixed sub-folders in project and firm folders
Some files need to be stored in particular, or fixed, sub-folders under project
and firm folders. If the files are not stored in these folders, Tekla Structures
cannot read the files. See the files which should be stored in fixed sub-folders
in the following table.

XS_FIRM or
XS_PROJECT sub-

folder

Further sub-folders and necessary
files

See also

\AdditionalPSe
ts

Use this folder to store additional
property set configuration files for IFC
export in the .xml format.

• Property set
configuration
files used in
IFC export

\CustomInquiry Use this folder to store:

• report templates for custom
inquiries as .it files

• the InquiryTool.config file for
defining which attributes are
included by default in the Manage
content dialog box for selecting
the properties shown in custom
inquiries

• Custom
inquiry

\Drawing
Details

Use this folder to store 2D drawing
details as .ddf and .png files.

Note that to see the drawing details
stored in the \Drawing Details
sub-folder under a firm or project
folder in Tekla Structures:

• 2D Library in
drawings
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XS_FIRM or
XS_PROJECT sub-

folder

Further sub-folders and necessary
files

See also

1. In the Drawing 2D library side

pane, click the  Folder
button.

2. Select Firm or Project.
\macros This sub-folder has the following sub-

folders:

• \Drawings
Use this folder to store macros
related to drawings as .bmp, .cs,
and .cs.pdb files.

• \Modeling
Use this folder to store macros
related to modeling as .bmp, .cs,
and .cs.pdb files.

Note that macros are primarily read
from the folder defined by the XS_
MACRO_DIRECTORY advanced option.
This advanced option can point to any
folder, not just the \macros sub-
folder of a firm or project folder.

• Working with
applications

• XS_MACRO_
DIRECTORY

\profil This sub-folder can have the following
sub-folders:

• \ShapeGeometries
Use this folder to store shape
geometry descriptions as .tez
or .xml files.

• \Shapes
Use this folder to store shape
descriptions as .xml files.

• Customize the
shape catalog
(page 294)

\ProjectOrgani
zerData

This folder has the following sub-
folders:

• \DefaultCategoryTrees
Use this folder to store Organizer
categories as .category files.

• Customized
default setup
for Organizer

Plan the installation and set up Tekla Structures 20 Project and firm folders



XS_FIRM or
XS_PROJECT sub-

folder

Further sub-folders and necessary
files

See also

• \PropertyTemplates
Use this folder to store property
templates from Organizer
as .propertytemplate files.

• \ExcelTemplates
Use this folder to store
customized templates in .xlt
format for exporting object
property values from Organizer.

\PropertyRepos
itory
\Templates

Use this folder to store customized
property pane layouts in the 
PropertyTemplates.xml file.

• Distribute
customized
property pane
layouts by
using a
project, firm,
or
environment
folder
(page 42)

\Symbols Use this folder to store:

• symbols as .sym and .dwg files

• other images and bitmaps used in
drawings

Note that symbols are primarily read
from the folder defined by the 
DXK_SYMBOLPATH advanced option.
This advanced option can point to any
folder, not just the \Symbols sub-
folder of a firm or project folder.

• Add symbols
in drawings

• DXK_SYMBOLP
ATH

\template Use this folder to store graphical
templates used in drawing layouts
as .tpl files.

Note that templates are primarily
read from the folder defined by the 
XS_TEMPLATE_DIRECTORY advanced
option.

In the same way, the tpled.ini is
primarily read from the folder defined
by the XS_TPLED_INI advanced
option.

• XS_TEMPLATE_
DIRECTORY

• XS_TEMPLATE_
MARK_SUB_
DIRECTORY
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XS_FIRM or
XS_PROJECT sub-

folder

Further sub-folders and necessary
files

See also

These advanced options can point to
any folder, not just the \Template
sub-folder of a firm or project folder.

This folder also contains the following
sub-folders:

• \mark
Use this folder to store graphical
templates used in drawing marks.

Note that templates used in
drawing marks are primarily read
from the folder defined by the XS_
TEMPLATE_MARK_SUB_DIRECTORY
folder. This advanced option can
point to any folder, not just the 
\template\mark sub-folder of a
firm or project folder.

• \settings
Use this folder to store the 
tpled.ini file, which defines
environment-specific template
settings, and the user-defined
attributes (UDAs) related to
Template Editor in the 
contentattributes_user-
defined_YOUR_COMPANY.lst
file.

Note that to read Template Editor
files from the template
\settings sub-folder within a
firm or project folder, the 
XS_TEMPLATE_DIRECTORY_SYSTE
M advanced option needs to point
to the \.ini sub-folder in the firm
or project folder.

Plan the installation and set up Tekla Structures 22 Tekla Structures installation for administrators



2.5 Tekla Structures installation for administrators
You can install Tekla Structures on users' workstations using the standard
installation packages or by creating your own centralized installation using MSI
packages. You can also run Tekla Structures in a virtual environment.

If you have legacy on-premises licenses, you must also install a license server
on your own hardware.

Tekla Structures installation on workstations
You can install Tekla Structures on each workstation using the standard
installation packages or by creating your own centralized installation using MSI
packages.

You can download Tekla Structures software and environments from Tekla
Downloads. To use the latest software, we recommend that you install the
latest service pack of Tekla Structures. Service packs include improvements
and fixes to the previous main version or service pack of Tekla Structures.
Service packs are available for all users with a valid maintenance contract or
subscription.

NOTE You must install Tekla Structures with administrator rights.

When you use centralized installation, the end users do not need
administrator rights for the installation.

Installation files for Tekla Structures software and
environments
The installers for the Tekla Structures software and environments are .msi
installers. Environment installers include sets of .tsep installers that contain
the environment files and settings.

When installing a new version of Tekla Structures, first install the software,
then install one or more environments. The environment .msi installers are
installed to your computer before opening Tekla Structures.

When you run the environment .msi installer, the installer creates the
environment folder and copies the .tsep installers to the..\Tekla
Structures\<version>\Extensions\To be installed folder. The
installer also creates the RemoveEnv.bat and ToBeRemoved.txt files, and
places them to the ..\Environments\<environment> folder. These files are
used when uninstalling an environment.

When running the environment .msi installer, you can select in the
installation wizard that the .tsep installers are run immediately when running
the environment installer. If you do not run the .tsep installers immediately,
the .tsep installers are run when you open Tekla Structures for the first time
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after the installation. In this case, Tekla Structures opens a dialog box that
shows the installation progress of the .tsep installers.

You can cancel the installation of extension .tsep installers in the dialog box
and postpone them to the next Tekla Structures start-up. The queued
environment .tsep installers are not canceled, they are installed even if you
cancel. The .tsep packages contain information about the product type:
environment or extension, which is used to determine which installers can be
canceled.

Running the .tsep installers does not require administrator rights. The .tsep
installers install the environment files to the ..\Tekla Structures
\<version>\Environments\<environment> folder.

If you are installing several environments for the first time, we recommend
that you do not run the .tsep installers with the .msi installer. Some of
the .tsep packages are used in more than one environment and the same
version of a .tsep package is only installed once. Starting Tekla Structures for
the first time after installation can take a long time particularly if you have
installed several environments, as all the .tsep installers are run.

Standard Tekla Structures installation
The Tekla Structures installation wizard has detailed instructions about the
installation.

For more information, see Install and license Tekla Structures.

Centralized Tekla Structures installation
Installing Tekla Structures centrally across the company network saves time in
a large company when there are many Tekla Structures users.

Centralized installation allows you to run the Tekla Structures installation
silently in the background so that the users do not see the installation wizard
dialog boxes. For detailed information about centralized installation, see
Centralized distribution of Tekla Structures 2022.

Tekla Structures installation in a virtual environment
You can also run Tekla Structures in a virtual environment. Application and
desktop virtualization allow users to run software from a server on the
network without locally-installed Tekla Structures on their workstation. Using
Tekla Structures from the server ensures that all users in a project are using
the same project environment set-up. For detailed information about
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installation in a virtual environment, see Use Tekla Structures with application
and desktop virtualization (page 28).

2.6 Install .tsep packages
Tekla Structures extension packages (.tsep packages) are Tekla Structures
extensions or additional environment content installers.

Extensions are not part of the Tekla Structures product release. .tsep
packages are available for download in Tekla Warehouse.

You can install .tsep packages in these ways:

• Directly

• In Tekla Structures extension manager

• Centrally

Install .tsep packages directly

TIP If the .tsep installer is not set to open with Tekla Structures extension
manager by default, you can set it manually. Right-click the .tsep
installer and select Properties. In Opens with, select Change and
browse to TsepFileDispatcherLauncher.

1. Double-click the .tsep installer that you have downloaded. 

The Tekla Structures extension manager dialog box opens with the
name of the extension that is going to be installed.

By default .tsep installers are opened with Tekla Structures extension
manager. Some .tsep installers are run directly from Tekla Warehouse
with the Insert into model option.

2. Select the Tekla Structures versions to which you want to import and click
the Import button. The next time you start Tekla Structures, the extension
is automatically installed, and it is shown in Tekla Structures extension
manager.

Install .tsep packages in Tekla Structures extension
manager
You can install a .tsep installer from Tekla Structures extension manager in
Tekla Structures.
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TIP In Extension manager, you can list the extensions by type: extension or
environment. You can also search for content based on name, author,
description, and type of extension.

1. In the Applications & components catalog, click  > Manage
extensions --> Extension manager .

2. Click Import and browse to the .tsep installer that you want to install.

3. Click Open.

The imported .tsep is installed the next time you start Tekla Structures. It is
shown in Tekla Structures extension manager, and is ready for use in the
Applications & components catalog.

Uninstall .tsep packages in Tekla Structures extension
manager

1. In Tekla Structures extension manager, select the .tsep packages that
you want to uninstall. 

Use Ctrl or Shift to select more than one .tsep package.

2. Click Remove.

The .tsep packages are removed when you restart Tekla Structures.

Uninstall .tsep packages in Tekla Structures Extension
Package (TSEP) builder and test runner

1. To open the Tekla Structures Extension Package (TSEP) builder and
test runner dialog box, browse to ..\Program Files\Tekla
Structures\<version\bin\ and double-click
TeklaExtensionPackage.Builder.exe.

2. On the Uninstall TSEP based extensions tab, select the .tsep packages
that you want to uninstall, then click Uninstall selected. 

Use Ctrl or Shift to select more than one .tsep package.

The selected .tsep are removed. You do not need to restart Tekla Structures.

Centralized installation of .tsep packages
You can centrally install a batch of .tsep installers across company
workstations. This method is meant for system administrators.
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By default, the .tsep installers waiting for installation are stored in
\ProgramData\Trimble\Tekla Structures\<version>\Extensions\To
be installed. To install centrally, copy the .tsep installers to the
%XSDATADIR%\Extensions\To be installed folder. If the folder does not
exist yet, create it.

When Tekla Structures starts, it checks the available .tsep installers from the
\To be installed folder and installs them automatically. If there is an older
version of the same extension package, it is uninstalled before installing the
new version. Installation is canceled if the same or newer version has already
been installed.

• The installed .tsep installers are stored in the %XSDATADIR%\Extensions
\Installed folder.

• Invalid .tsep installers are uninstalled and moved to the %XSDATADIR%
\Extensions\Invalid installations folder.

• Canceled .tsep installers are stored in %XSDATADIR%\Extensions
\Cancelled installations.

Tools for copying .tsep installers

We recommend that you use ROBOCOPY from the command prompt (cmd.exe)
to copy the .tsep installers. You can find more information about ROBOCOPY
on the Microsoft website.

The basic syntax for ROBOCOPY is: robocopy <Source> <Destination>
[<File>[ ...]] [<Options>]
For example, to copy .tsep installers in Tekla Structures 2023:

robocopy
"\\Server1\prod\TeklaStructures\2023.0\Environments_TSEP"
"C:\ProgramData\Trimble\Tekla Structures\2023.0\Extensions\To be 
installed"
*.tsep
"C:\Program Files\Tekla Structures\2023.0\bin
\TeklaExtensionPackage.TepAutoInstaller.exe"
2023.0 "C:\ProgramData\Trimble\Tekla Structures\2023.0" "2023"

This command copies all .tsep installers from the \Server1 network
directory to the local user's \To be installed folder. After copying,
TepAutoInstaller.exe installs all .tsep installers from the local user's \To
be installed folder. Installing the packages allows users to start Tekla
Structures without first waiting for the installations to complete.
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Centralized uninstallation of .tsep packages

You can uninstall .tsep packages in batches by creating an empty file named
RemoveExtensionOnStartup in the folder for each extension that you want
to uninstall. For example, \ProgramData\Trimble\Tekla Structures
\<version>\Extensions\Installed\
[Extension_To_Be_Uninstalled].

The extensions are removed the next time that Tekla Structures is started.

2.7 Use Tekla Structures with application and desktop
virtualization
Using Tekla Structures together with Citrix Virtual Apps and Desktops with
Azure is a flexible and safe way to quickly add users to Tekla Structures
projects without locally installing Tekla Structures.
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This image shows the main concepts in Tekla Structures virtualization.

Data center

Citrix thin clients
running on various
operating systems

Secure display data
connection over the internet

Virtualization platform
(hypervisor layer)

Virtual Tekla Structures
instances running on
Microsoft Windows

Citrix application and desktop virtualization products are products of Citrix
Systems, Inc.

Streaming applications from the server makes it possible to use Tekla
Structures on client computers, tablets, and smartphones that have different
hardware and software configurations. Tekla Structures runs on Windows on
the remote server and the virtualization solution allows client devices to be
used for display and user input.

Users connect through a secure connection to the data center. The project
data is stored only on the server. Using Tekla Structures from a centralized
location ensures that all users in the project are using the same project
environment.

Prerequisites for using Tekla Structures in a virtual
environment
We recommend using Citrix Virtual Apps and Desktops with Azure for Tekla
Structures virtualization. For more information, see Citrix Virtual Apps and
Desktops with Azure. .

This image shows the main components in Tekla Structures virtualization.
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Data center

Citrix XenServer/
VMware vSphere

License server

Citrix Receiver

File server

Virtual machine
running Windows

1

2

Citrix XenApp/XenDesktop

3

1. Users can access Tekla Structures using a thin client application, such as
Citrix Receiver. Users can use Citrix XenApp client or Citrix XenDesktop
desktop viewer on any supported operating system and hardware.
Multiple concurrent clients can share one virtual machine instance.

2. Each TeklaStructures.exe running in the virtual environment must
have a valid subscription or license.

If you use legacy on-premises licenses, you can use a local, enterprise, or
cloud Tekla license server. The license server can be hosted in the data
center or outside of the data center.

3. Read and write project files from network-attached storage (NAS). Fast
disk access is required.

Never store models on the local disk of the virtual server. Store project
data, including environments, on another server in the data center or on a
file system inside the company network.

Because accessing files from the client's local file system can be slow, we
recommend that you avoid accessing files from the client's local file
system as much as possible.

Set up the virtual environment for Tekla Structures
Set up the server, define delivery groups, and install the Tekla Structures
software and environments on the server. Ensure that Tekla Structures users
install the Citrix Receiver on their computers.
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After setting up the virtual environment, you can use Tekla Structures on the
virtual desktop in the same way as if it was installed on your own computer.

When you use the virtual desktop for the first time, you can give read and
write access to your local files in the file access dialog box. Giving access to
your local files has the following limitations:

• Referencing local files from your computer directly in Tekla Structures is not
recommended. If you need to access those files in Tekla Structures, copy
them to a shared network location first.

• Model folders are not copied to the client computers.

The Citrix Receiver client is updated frequently. Always install the latest client
when the web user interface prompts you to do so.

1. Set up the server. 

We recommend deploying Tekla Structures using Citrix Virtual Apps and
Desktops with Azure.

For more information, see Citrix Virtual Apps and Desktops with Azure.

2. Install Tekla Structures software and environments on the server. 

Never store models on the local disk of the virtual server. Store project
data on another server in the data center or on a file system inside the
company network. Select the correct network location for the model
folder during the Tekla Structures installation.

Tekla Structures environment settings are the same for all users that use
the same virtual machine. As with normal desktop installations, you must
still ensure that the environments on different virtual machines are the
same.

We strongly recommend that you use standard Tekla Structures
environments and customize them with company or project-specific
settings on the network file server.

3. Install Citrix Receiver on each Tekla Structures client computer. 

We recommend that you use the Citrix Receiver web user interface.

a. In your web browser, open the Citrix Receiver web user interface. 

Use the https address provided by your company's administrators.

b. To install Citrix Receiver, follow the steps in the installation wizard. 

In the installation wizard, do not create an account or sign in. Finish
the installation, then return to the Citrix Receiver web user interface.

c. After the installation, return to the Citrix Receiver web user interface
and sign in with the credentials provided by your company's
administrators.

d. Select the virtual desktop. If the virtual desktop does not start
automatically, run the downloaded Citrix (.ica) file.
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3 Customize Tekla Structures for
users

As the Tekla Structures administrator or BIM manager, you can customize
Tekla Structures to use your company's standards. Customizing Tekla
Structures for the company standards and projects needs allows end user to
focus on the design process.

Each new version of Tekla Structures introduces new features and
functionalities to improve the overall process used for completing a project.
Tekla Structures has multiple environments to suit the needs and
requirements of specific markets. Many features are localized in each Tekla
Structures version. Most of the changes in versions are focused on making the
default saved attributes more consistent, organized, simplified, and practical.

Before you start customizing Tekla Structures to suit the needs of your
company and your projects, collect the needed information, such as drawing
standards, used profiles, grades and materials, company logos, and naming
conventions.

The overall localization of Tekla Structures can be divided into these layers:

• Tekla Structures environment

• Company-level settings

• Project-level settings

With the exception of the Tekla Structures environment, these settings are
mainly managed by company administrators.

3.1 Hierarchy of Tekla Structures settings
Tekla Structures settings are managed on several layers. On the highest layer
there are hard-coded default settings that you cannot change directly but that
you can override on lower layers.

Customize Tekla Structures for users 32 Hierarchy of Tekla Structures settings



common environment  settings 

Windows AppData folder 

Tekla Structures hard-coded settings

regional environment settings 

XS_FIRM 

XS_PROJECT 

model template 

model folder 

These settings are constantly active

Tekla Structures reads these settings when a model is created

Tekla Structures reads these settings when a model is opened

1. Common environment settings that have preset values included in the
installation. The common environment is always included in the
installation.

Do not modify or remove the common settings.

2. Regional environment settings with preset values that are suited for
specific regional areas.

3. The advanced option XS_FIRM that defines a folder, typically on a network
drive, that loads settings for all users within your company.

This folder is the main container of files for the company.

4. The advanced option XS_PROJECT that defines a folder, typically on a
network drive, that loads important settings for all users within a specific
project (page 132).

5. The model template that is loaded from the environment, or from the
network folders. The model template is loaded only once when you start
creating a new model.

6. The model folder content that is saved locally when you add or edit
settings.

If you save content in the model folder, the saved settings in other
locations override the same settings in the model folder.
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7. The Windows AppData folder for user-specific settings related to the Tekla
Structures user interface.

Environment settings for administrators
Environment settings include common settings that are the same in all
environments, and country-specific or region-specific settings that are
localized by your local Trimble office or reseller.

Common environment settings

NOTE Do not modify or remove the common settings.

All settings and files that are the same in all environments are located in the
\Tekla Structures\<version>\Environments\common folder. Files and
settings that are specific to an environment are located in separate
environment folders.

The env_global_default.ini file is also located in the \common folder. This
file determines the standard settings, and it is the first file that is read. Other
initialization files (page 48) are read after this file, and if the other files
contain the same settings, they override the previous settings.

Country-specific environment settings
Country-specific, or region-specific, settings are located in environments
folders. The folder structure of the environments can vary, but the same kind
of settings exist. For example, the settings that are localized include profile
database, material database, reports, selection filters, view filters, components
and custom components, macros, user-defined attributes, and drawings
settings.

Company settings for administrators
Company-level settings are mainly settings that are used throughout the
company for all projects. These settings are set using XS_SYSTEM and 
XS_FIRM.

For a larger company with subsidiaries, the settings could be used as follows:

• XS_SYSTEM might contain multiple paths, and it points to general settings
inside the company. These can be company logo, reports, printer settings,
drawing settings, templates, for example. These are settings that very
seldom change, and are stored on a server available for all. For example, if
the company logo is updated, it only has to be replaced in one place.

Customize Tekla Structures for users 34 Hierarchy of Tekla Structures settings



• XS_FIRM points to the firm folder set up by the company, or a subsidiary.
The folder contains all the company settings used at the particular office.
These can be logos, drawing settings, templates, reports, or printer
settings, for example. The firm folder can also have user-defined sub-
folders for storing property files.

• XS_PROJECT points to the project folder. The folder contains project
settings, such as logos for contractors and fabricators, or drawing settings,
for example. The project folder can also have user-defined sub-folders for
storing project-specific property files.

For more information about the folder search order, see Folder search order
(page 45).

You can also use company-specific collections in Tekla Warehouse online or
offline in your own network. For more information, see Getting started with
Tekla Warehouse.

Access to offline collections is managed with folder rights in your network, and
on the collection level in the collections.json file on each user's computer.

 "collections" 
"\\\\server-A\\company\\Tekla Structures collection" 
        

The collections.json file can be shared with selected users by copying it to
the C:\Users\Public\Documents\Tekla\Tekla Warehouse\ folder.

Customization of model templates
You can save a model with customized settings and use the model as a
template when you create new models. Using model templates can be very
useful if your company has different kinds of projects, such as, parking
garages, office buildings, bridges, and industrial.

To create a model template, see .

By default, the model template folder is located in your environment folder,
under ..ProgramData\Trimble\Tekla Structures\<version>
\environments\<your environment>\. The exact folder location might
vary depending on your environment and role. Use the advanced option XS_
MODEL_TEMPLATE_DIRECTORY to define a different location.

You can download, share, and store model templates in Tekla Warehouse. This
image shows an example of a model template in Tekla Warehouse.
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The Insert into model button in Tekla Warehouse installs the model template
directly in the folder defined by XS_MODEL_TEMPLATE_DIRECTORY. You can
immediately use the template when creating a new model.

Update model templates
When you upgrade Tekla Structures, we strongly recommend that you update
your model templates.

1. Create a new model using an existing model template.

2. Give the model the same name as in the previous Tekla Structures
version.

3. Open a 3D view.

4. On the File menu, click Diagnose and repair --> Diagnose model.

5. On the View tab, click Screenshot --> Project thumbnail to create a
project thumbnail, or add a custom image named thumbnail.png in the
model folder. 

The preferred size of the image is 120 x 74 pixels.

6. On the File menu, click Save as --> Save. 

If you do not do this, a message might appear warning about the model
being created with a previous version.

7. On the File menu, click Save as --> Save as model template.

8. Update the content of the model template.
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a. Select which catalogs, drawing templates, report templates, and
model sub-folders you want to include in the model template.

b. Manually remove all *.db files (environment database, options
database files) from the model folder. 

Do not remove the db.idrm and xslib.idrm files. They are part of
the model.

c. Click OK.

The *.bak, *.log and xs_user files are automatically removed from the
model folder.

The model template is saved in the location defined by 
XS_MODEL_TEMPLATE_DIRECTORY.

You now have a sample image for your model template. The Applications &
components catalog is now also in order and easy to use.

Customization of reports and drawings
If your company already has graphical templates in the DXF, DWG, or DGN
format, you can convert these templates to Tekla Structures templates.

For detailed instructions, see the information about AutoCAD and Microstation
files in the Template Editor User's Guide.

For information about how to create your own templates and reports, see the
Template Editor User's Guide, , and Templates (page 149).

Create cloning templates for drawings
Creating cloning templates for drawings allows you to use existing drawings as
the basis for creating new drawings of similar parts, assemblies, or cast units.
You only need to modify the parts of the cloned drawing that differ from the
original drawing.

Consider cloning drawings when:

• There are several similar parts, assemblies, or cast units in the model.

• You need to produce single-part, assembly, or cast-unit drawings of similar
parts, assemblies, or cast units.

• The drawings need a lot of manual editing.

For example, you can create a drawing for one truss, edit the drawing, then
clone it for similar trusses. You only need to modify the cloned drawings where
the trusses differ.

The cloned drawing might contain more parts than the original drawing. Part
properties, marks, associative notes, and related text objects are cloned from a
similar part in the original drawing.

You can clone drawings by using Master Drawing Catalog templates. A
cloning template in the Master Drawing Catalog can also be used in other
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models. You can use cloning templates in projects that have the same kind of
drawings.

1. In the Document manager, select a drawing.

2. Right-click, select Add to Master Drawing Catalog, then fill in the
required properties.

The cloning template can be found under Cloning templates in the Master
Drawing Catalog. To use cloning templates in other models, open the Master

Drawing Catalog in the model, click the  button on the toolbar, and add
the model where the templates are saved.

For more information about the Master Drawing Catalog and cloning
templates, see Create drawings in Master Drawing Catalog.

3.2 Distribute customized ribbons by using a firm or
environment folder
Administrators can distribute the customized ribbon files to other users in the
company by placing the ribbon files in a firm or environment folder.

For example, you can create company ribbons and save them in the firm
folder. These ribbons are shown in the Tekla Structures user interface for all
users who use the same firm folder.

Add ribbons to a firm or environment folder
1. In the Ribbon editor, create the modeling and drawing ribbons that you

want to share. 

The ribbons are saved in the ..\Users\<user>\AppData\Local
\Trimble\Tekla Structures\<version>\UI\Ribbons folder.

If you cannot find the folder, ensure that you are able to view the hidden
files and folders on your computer.

2. Copy the entire \Ribbons folder either to your company's firm folder or
to the system folder.

3. If the ribbon contains user-defined commands, create a sub-folder named
\Commands on the same level as the \Ribbons folder, and copy the
UserDefined.xml file from the ..\Users\<user>\AppData\Local
\Trimble\Tekla Structures\<version>\UI\Commands folder to the
\Commands folder you just created.

4. Restart Tekla Structures.
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Loading order of custom ribbons
Tekla Structures loads the ribbons in the following order:

1. Tekla Structures default ribbon

2. Company ribbons in the environment folders

3. Company ribbons in the firm folder

4. User-defined ribbons under %localappdata%
Ribbons that are loaded later override previously loaded ribbons that have the
same combination of configuration and editing mode. For example, a ribbon
defined in the firm folder overrides ribbons in the environment folders.

If you have a customized ribbon in the ..\Users\<user>\AppData\Local
\Trimble\Tekla Structures\<version>\UI\Ribbons folder, it overrides
company ribbons. To use the ribbon in the environment or firm folder, open
the Ribbon editor and click Restore. Alternatively, you can remove or rename
your own customized ribbons.

Naming convention for ribbon files
The customization tool saves the custom ribbons as .xml files. The naming
convention for these files is:

<Tekla-Structures-configuration_identifier>--<Tekla-
Structures-editing-mode>.xml
The name consists of an internal configuration name, a separator of two dash
characters (--), an internal editing mode name, and the file name
extension .xml. For example, the Full license modeling ribbon is called
albl_up_Full--main_menu.xml.

Configuration identifier Configuration name
albl_up_Diamond Tekla Structures Diamond
albl_up_Graphite Tekla Structures Graphite
albl_up_Carbon Tekla Structures Carbon
albl_up_Construction_Modeling Construction Modeling
albl_up_Developer Developer
albl_up_Drafter Drafter
albl_up_Educational Educational
albl_up_Engineering Engineering
albl_up_Full Full
albl_up_PC_Detailing Precast Concrete Detailing
albl_up_Rebar_Detailing Rebar Detailing
albl_up_Steel_Detailing Steel Detailing
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Configuration identifier Configuration name
albl_up_Tekla_Structures_Prim
ary

Primary

albl_up_Viewer Project Viewer

Editing mode Purpose
main_menu Modeling ribbon
edit_draw_menu Drawing ribbon
plan_main_menu Importing ribbon

3.3 Distribute customized tabs by using a firm or
environment folder
As an alternative to customized ribbon files, which override the existing
ribbon, you can distribute customized tabs to other users in the company by
placing the tab files in a firm or an environment folder.

The customized tabs are automatically appended to the end of the ribbon for
all users who use the same firm or environment folder. An administrator can
distribute customizations to all users in the company while still allowing
individual users to customize their ribbons.

These customized tabs do not appear in the Ribbon editor, so the users are
not able to edit them. When an administrator updates the contents of a
customized tab, the users receive the update when they restart Tekla
Structures. Tabs are not configuration-specific. They are imported regardless
of the user's Tekla Structures subscription configuration. If the tab contains
commands that are not available in the user's configuration, the commands
appear dimmed on the ribbon.

NOTE If you use a firm folder to distribute the custom tabs, set the firm
folder path in an .ini file, such as user.ini,
teklastructures.ini,project.ini, or company.ini. If you set
the firm folder path in the advanced option XS_FIRM, the tab file does
not work correctly because the XS_FIRM definition in the advanced
options is made on the model level and the custom tab is not
initialized.

1. Create the following folder structure in your company's firm folder or in
the system folder. 
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2. In the Ribbon editor, create a customized tab and add commands to it.

3. Save the ribbon.

4. Go to the ..\Users\<user>\AppData\Local\Trimble\Tekla
Structures\<version>\UI\Ribbons folder.

5. In a text editor, open the ribbon *.xml file that contains the tab that you
want to share with other users.

6. Remove all the other content from the ribbon file except the first row and
the description of the tab that you want to share. 

Alternatively, you can copy the content to a new text file.

For example:

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<Tab Header="My Tab" IsCollapsed="false" IsUserDefined="true">
  <SimpleButton X="0" Y="0" Width="3" Height="4" 
Command="Common.Interrupt" Text="command:ShortText" Icon="myicon.png" 
ShowText="true" ShowIcon="true" />
  <SimpleButton X="3" Y="0" Width="3" Height="4" 
Command="RibbonEditor.Open" Text="command:ShortText" Icon="somefolder
\myicon2.png" ShowText="true" ShowIcon="true" />
</Tab>

The button icons use relative paths. The icon path is relative to the *.xml
file where tab is read from. For example Icon="myicon.png" refers to
an icon in the same folder as the *.xml file, and the Icon="somefolder
\myicon2.png" refers to an icon in a sub-folder.

Alternatively, you can also create paths to folders at levels above the
current folder: Icon="..\myicon.png".

7. Save the *.xml file with a new name in the ..\CustomTabs\Modeling
or ..\CustomTabs\Drawing folder. 

Tab files have the file name extension *.xml. We recommend that you
use the same name as for the tab. For example, MyTab.xml. The file
name is not case sensitive.

The tab is added to either the modeling or drawing mode ribbons,
depending on the folder that it is located in. There can be several custom
tab files in the same folder. They are added to the ribbon one after the
other. If the same tab file exists in both the environment and firm folders,
the firm version overrides the environment version.
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NOTE To avoid file name conflicts, we recommend that administrators
prefix all custom tab files with the company name, and that
extension developers prefix all custom tab files with the name of
the extension (for example, MyExtension_TabName.xml).

8. If the tab contains user-defined commands, copy the UserDefined.xml
file from the ..\Users\<user>\AppData\Local\Trimble\Tekla
Structures\<version>\UI\Commands folder to the \Commands folder
that you created in the firm folder or the system folder.

9. Restart Tekla Structures. 

The customized tab now appears at the end of the ribbon.

3.4 Distribute customized property pane layouts by using
a project, firm, or environment folder
Administrators can distribute the customized property pane layouts to other
users in the company by placing the PropertyTemplates.xml property pane
layout file in the PropertyRepository\Templates folder in a project, firm,
or environment folder.

For example, you can create company property pane layouts and save them in
the firm folder. These property panes are available in the Tekla Structures user
interface for all users who use the same firm folder.

Add a property pane layout file in a project, firm, or
environment folder
1. In the Property pane editor, create the property pane layouts that you

want to share. 

The property pane layouts are saved in the PropertyTemplates.xml
file, in the ..\Users\<user>\AppData\Local\Trimble\Tekla
Structures\<version>\UI\PropertyTemplates folder.

If you cannot find the folder, ensure that you are able to view the hidden
files and folders on your computer.

2. In your company's project folder or firm folder, or in the system folder,
create a folder named PropertyRepository\Templates.

3. Copy the PropertyTemplates.xml file to the PropertyRepository
\Templates folder.

4. Restart Tekla Structures.
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Search order of customized property pane layout files
The PropertyTemplates.xml file contains all the property pane layouts for
different object types. The property pane layouts for different object types are
treated separately. For example, Tekla Structures can read the property pane
layout for steel beam from a different location than the property pane layout
for steel column.

If different object types are defined in different folder locations, the definitions
are combined. If the same object type is defined differently in different folder
locations, the definition that is higher in the search order is used.

The property pane layout in the ..\Users\<user>\AppData\Local
\Trimble\Tekla Structures\<version>\UI\PropertyTemplates\
folder has the highest priority, and after that Tekla Structures uses the default
search order.

3.5 Distribute customized property pane settings by
using a project, firm, or environment folder
Administrators can distribute customized property pane settings to other
users in the company.

Place the PropertyPaneSettings.xml file in a folder called \PropertyPane
in a project, firm, or environment folder.

1. Customize the property pane settings that you want to share. 

The property pane settings are saved in the
PropertyPaneSettings.xml file, in the ..\Users\<user>\AppData
\Local\Trimble\Tekla Structures\<version>\UI\PropertyPane
\ folder.

If you cannot find the folder, ensure that you are able to view the hidden
files and folders on your computer.

2. Create a folder called \PropertyPane either in your company's project
folder, firm folder, or in the system folder.

3. Copy the PropertyPaneSettings.xml file to the \PropertyPane
folder.

4. Restart Tekla Structures. 

The file in ..\Users\<user>\AppData\Local\Trimble\Tekla
Structures\<version>\UI\PropertyPane\ has the highest priority in
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the search order, and after that Tekla Structures uses the default search
order.

If the PropertyPaneSettings.xml file is placed in several different
folder locations, Tekla Structures reads the settings from different folders
and merges them.

3.6 Distribute customized toolbars by using a project,
firm, or environment folder
Company administrators can distribute customized Selecting, Snapping, and
Snap override toolbars to other users in the company.

Place the toolbar .json files in a folder called \Toolbars in a project, firm, or
environment folder. For example, you can create company toolbars and save
them in the firm folder. These toolbars are available in the Tekla Structures
user interface for all users who use the same firm folder.

1. Customize the toolbars that you want to share. 

The toolbars are saved in corresponding .json files, in the ..\Users
\<user>\AppData\Local\Trimble\Tekla Structures\<version>
\Toolbars folder.

If you cannot find the folder, ensure that you are able to view the hidden
files and folders on your computer.

2. In your company's project folder or firm folder, or in the system folder,
create a folder called \Toolbars.

3. Copy the toolbar .json files to the \Toolbars folder.

4. Restart Tekla Structures. 

Files in ..\Users\<user>\AppData\Local\Trimble\Tekla
Structures\<version>\Toolbars have the highest priority in the
search order. After that, Tekla Structures uses the default search order.

3.7 Files for configuring Tekla Structures
Tekla Structures contains a large number of files that affect the way that the
app works. It is important to know where Tekla Structures stores information,
the types of files that Tekla Structures contains, where the files are located,
and how to use the files.

Customize Tekla Structures for users 44 Distribute customized toolbars by using a project,
firm, or environment folder



See also

Folder search order (page 45)

Check and change Tekla Structures file and folder locations in Directory
browser (page 48)

Initialization files for start-up parameters and default settings (page 48)

Input files (.inp files) for configuring Tekla Structures (page 58)

Data files (.dat files) for configuring Tekla Structures (page 64)

Customize user interface text in message files (page 65)

Customize object properties and settings in property files (page 66)

Standard files (page 66)

Files related to catalogs (page 69)

Font files for customizing Tekla Structures (page 71)

Symbol files for drawings (page 72)

Files related to templates, reports and drawings (page 73)

Supported image file formats in Tekla Structures (page 75)

Log files about the operation of Tekla Structures (page 76)

Files and file name extensions in the Tekla Structures model folder (page 84)

File storing options and advanced options (page 105)

Folder search order
When you open a model, Tekla Structures searches for the associated files in
specific folders in a specific order.

When Tekla Structures finds the first associated file, it stops searching. Any
files with the same file name that are located later in the search order are
ignored. The error log lists the names of the ignored files.

WARNING Do not store your customized files in the system folder. Tekla
Structures replaces files in the system folder when you install a
new version.

Many settings files and attribute files must be located either at the root level of
the folder or in specific subfolders inside the main folder. For example:

• .tpl and .rpt files must be located at the root level of the model folder.

• .OrgObjGrp files must be located at the root level of the firm folder.

• Other attribute files can be located in the attributes subfolder inside the
main folder.

The folder search order is:
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Order Folder Defined by
1 Current model The open model
2 Project Advanced option .

If property files are stored in
user-defined subfolders under
the project folder, Tekla
Structures searches the
subfolders for files in
alphabetical order.

3 Firm Advanced option .

If property files are stored in
user-defined subfolders under
the firm folder, Tekla Structures
searches the subfolders in
alphabetical order.

4 Environment Tekla Structures searches in the \
\Environments\common
subfolder first, then in the
subfolders for the environment
and role that the user selects
when they start Tekla Structures.

5 Role The role that the user selects
when they start Tekla Structures.

6 System Advanced option

You can specify more than one
system folder to define specific
settings for each role. Use the
role options defined in the
env_<environment>.ini file to
point to the roles when specifying
the system folders in the
advanced option. Separate the
options pointing to the roles with
semicolons. For example:

set XS_SYSTEM=%XS_STEEL
%;%XS_ENGINEERING
%;%XS_CONTRACTOR%;
%XS_GENERAL%;%XSDATADIR%
\environments\common
\system\

For some specific files and file types, Tekla Structures searches in a different
order. The exceptions are:
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File or file type Search order
Catalogs Profile, bolt (page 314), material, and rebar (page 328)

catalogs:

1. Model folder

2. Project folder (XS_PROJECT)

3. Firm folder (XS_FIRM)

4. Folder defined by the advanced option

Shape catalog (page 294):

1. Model folder

2. Project folder (XS_PROJECT)

3. Firm folder (XS_FIRM)

4. System folder (XS_SYSTEM)

5. Folder defined by the advanced option

Printer catalog:

1. Model folder

2. Project folder (XS_PROJECT)

3. Firm folder (XS_FIRM)

4. Folder defined by the advanced option
.dat files
(page 64)

System folder (XS_SYSTEM)

objects.inp 1. Model folder

2. Project folder (XS_PROJECT)

3. Firm folder (XS_FIRM)

4. System folder (XS_SYSTEM)

5. inp folder ()
privileges.inp 1. Model folder

2. Project folder (XS_PROJECT)

3. Firm folder (XS_FIRM)

4. System folder (XS_SYSTEM)

5. inp folder ()
Reports

(.rpt files)

1. Model folder

2. System folder (XS_SYSTEM)
Templates
(page 149) (.tpl
files)

1. Folder that contains your templates defined by the
advanced option

2. Model folder
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File or file type Search order
3. Project folder (XS_PROJECT)

4. Firm folder (XS_FIRM)

5. Environment-specific system templates defined by
the advanced option

6. System folder (XS_SYSTEM)

Check and change Tekla Structures file and folder locations
in Directory browser
Directory browser is a tool that helps you to find and modify the location of
the various Tekla Structures files and folders, and customize user settings.

NOTE Generally, only administrators should change these settings. If you
change them yourself, and you are sharing the same model with other
users, and your settings differ from those of the project, you will have
problems. Also, adding or modifying files in some of these folders may
require administrator rights.

To locate files and folders, and customize your Tekla Structures settings:

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

2. Click the arrow next to Applications to open the applications list.

3. Double-click Directory browser. 

The Directory browser dialog box opens. You can check the most
common folder paths, and customize the settings in your user.ini file,
or in the user-specific or model-specific options.ini file.

4. Check the folder paths and change them if necessary by clicking the
buttons on the left of the Basic tab. 

If you click the Project or Firm button and you have not set your firm and
project folder, Tekla Structures will prompt you to do so and add the
folder path definition to your user.ini file.

5. Check the settings in the user.ini and options.ini files and change
them if necessary by clicking the buttons on the right of the Basic tab.

6. Go to the Advanced tab and define the folder paths for additional folders
that you may need to access, such as custom components and macros.
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Initialization files for start-up parameters and default
settings
Initialization files (.ini files) define Tekla Structures start-up parameters and
default settings.

Initialization files contain advanced options that are used for configuring Tekla
Structures for different standards, and for your or your company’s style of
working. Advanced options determine the appearance and the behavior of
Tekla Structures, such as the language used, the behavior of part marks on
drawings, and the location of your model folder.

Tekla Structures automatically creates the necessary initialization files during
installation. The number of initialization files that it creates depends on how
many Tekla Structures environments you have installed.

See also

Create start-up shortcuts with customized initializations (page 346)

Typical initialization files (.ini files) and their reading order
Initialization files are read in a default order when Tekla Structures starts up. If
different files contain the same settings, settings in files that are read later
override settings in files that were read earlier.

To check which files were read when you started Tekla Structures and the
order in which they were read, select File menu --> Logs --> Session history
log .

This image shows the default reading order of the .ini files, excluding
language-specific files and optional files:
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This table lists the typical initialization files that are read when Tekla Structures
starts up. The table lists the default location of each file. The exact location of
the files might vary depending on the folder in which you install Tekla
Structures.

Order File Description
1 fonts_<lang>.ini

NOTE Do not change these settings.

These optional files contain fonts for
languages that use special characters.
These files are only needed if you use Tekla
Structures in languages that use special
characters. For example, the
fonts_jpn.ini file is the fonts file for the
Japanese language.

These files are automatically installed to the
\bin folder when Tekla Structures is
installed. The default location
is ..\Program Files\Tekla
Structures\<version>\bin\.

2 teklastructures.
ini NOTE Do not change these settings.

This file in the contains basic system
settings, such as the location of software
and environment files, that are needed for
Tekla Structures to run.

This file is read when Tekla Structures starts
up.

This file is automatically installed to the
\bin folder when Tekla Structures is
installed. The default location
is ..\Program Files\Tekla
Structures\<version>\bin

3 lang_<lang>.ini
NOTE Do not change these settings.

This file contains the language settings for
the Tekla Structures user interface.

The language file that is read when Tekla
Structures starts up depends on the
language that you have selected in File
menu --> Settings --> Change language in
the previous Tekla Structures session. The
languages that you have selected to install
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Order File Description
during the software installation determine
which lang_<lang>.ini files are
available.

This file is automatically installed to the
\bin folder when Tekla Structures is
installed. The default location
is ..\Program Files\Tekla
Structures\<version>\bin\.

4 env_global_defau
lt.ini NOTE Do not change these settings.

This file contains the global default settings
for all environments. You can use
environment-specific
env_<environment>.ini files to override
the settings in this file.

This file is automatically installed in the
\Environments\common folder when you
install the common environment
installation package. The default location
is ..\ProgramData\Trimble\Tekla
Structures\<version>\Environments
\common\

5 Any .ini files
defined in the start-
up shortcut or on
the command line
with -I
<name>.ini

Usually none.

6 env_<environment
>.ini

These files contain advanced options that
have environment-specific settings.

The settings in these files can override the
settings in the env_global_default.ini
file. The content of the
env_<environment>.ini files is typically
defined by your area office or reseller.

The env_<environment>.ini file that is
read depends on the environment that you
select when Tekla Structures starts up.

Each env_<environment>.ini file is
installed in the \Environments
\<environment> folder when you install
an environment. The default location
is ..\ProgramData\Trimble\Tekla
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Order File Description
Structures\<version>\Environments
\<environment>. Which
env_<environment>.ini files are
installed on your computer depends on
which environment packages you have
installed.

You can optionally define specific settings
for roles in your environment and store
these settings in role-specific folders under
the ..\ProgramData\Trimble\Tekla
Structures\<version>\Environments
\<environment> folder.

In the env_<environment>.ini file, each
role has an option where you can add the
paths that point to the folders in which you
have stored the role settings.

NOTE Do not change any other settings in
the env_<environment>.ini file.

For example, XS_STEEL (\Steel), 
XS_CONCRETE (\Concrete), 
XS_ENGINEERING (\Engineering) and 
XS_PRECAST (\Precast) each point to the
folders that contain settings specific to that
role.

Example for the steel role:

set XS_STEEL=%XSDATADIR%
\environments\Steel
\master_drawings\;%XSDATADIR%
\environments\Steel\model_filters
\;%XSDATADIR%\environments\Steel
\model_settings\

For example, XS_GENERAL points to the
\General folder that has content common
for all roles and settings.

When defining role settings in XS_SYSTEM,
you use the role options defined in the
env_<environment>.ini to point to the
role-specific settings. You do not need to
add the folder paths in XS_SYSTEM. They
are defined in the
env_<environment>.ini file.
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Order File Description
7 role_<role>.ini

NOTE Do not change these settings.

These files contain advanced options that
have typical role-specific settings.

The role_<role>.ini file that is read
depends on the environment that you
select when Tekla Structures starts up.

These files are automatically installed when
you install an environment. The default
location is ..\ProgramData\Trimble
\Tekla Structures\<version>
\Environments\<environment>.

Which role_<role>.ini files are installed
on your computer depends on which
environment packages you have installed.
For example, the role_Engineer.ini file
in the \Environments\uk folder contains
all the settings for the Engineering role in
the UK environment.

8 Any .ini files
defined in the start-
up shortcut or on
the command line
with -i
<name>.ini

Usually none.

9 company.ini This optional file is useful when you want to
unify enterprise-level settings. This file is
read only if the advanced option is set,
from the folder specified with the advanced
option.

To use this file, you must create it. It is not
automatically created by the installation.

10 user.ini This file contains each user's personal
settings.

The user.ini file is created when you
start Tekla Structures for the first time, and
create and save a model using the current
version. When you change settings in the
Advanced Options dialog box, the settings
are saved in the user.ini file.

The default location for this file is
C:\Users\<user_name>\AppData
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Order File Description
\Local\Trimble\Tekla Structures
\<version>\UserSettings.

Advanced options that are set in user.ini
override advanced options that are set in
other .ini files. For example, if the same
advanced option is set in another .ini file,
in a file in the environments sub-folder, and
in the user.ini file, Tekla Structures uses
the value in the user.ini file.

11 options.ini in the
system folder

This file contains the system settings.

The options.ini in the system folder is
always read when Tekla Structures starts
up.

The folder for this file is specified with the
advanced option .

12 options.ini in the
firm folder

The options.ini files that contains firm-
specific or project-specific model settings
are saved in and read from user-defined
locations specified with the advanced
options and . They work in the specified
way for the firm in question, or for the
specified project if the model has been set
up to read settings from these locations,
and if the user has manually moved the
options.ini file to these locations. An
options.ini is created in the firm or
project folder when you copy or move it
there.

Updating of model-specific and user-
specific advanced options can only be done
from the Advanced Options dialog box or
options.ini located in model folder, not
from the firm- or project-specific
options.ini files.

The options.ini in the firm or project
folder is read when you start Tekla
Structures or open the model.

13 options.ini in the
project folder

14 options.ini in the
model folder

This file contains the model-specific
settings.

The options.ini file in the model folder
is read when you open the model.
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Order File Description

NOTE Changing an advanced option
value in an .ini file located
outside the model folder does not
affect existing models.

See also

Settings defined by advanced options (page 126)

Global default environment settings - env_global_default.ini
The env_global_default.ini file defines the global defaults for advanced
options.

The file is read from ..\ProgramData\Trimble\Tekla Structures
\<version>\environments\common\.

WARNING Do not modify the env_global_default.ini file. If you need to
modify some environment settings, copy the needed advanced
options from this file to your user.ini (page 57) file and modify
the settings there, or modify the settings in the Advanced
Options dialog box.

For advanced options that are set according to your local standards, see the
environment settings file env_<environment name>.ini (page 55) and the role
settings file role_<role name>.ini (page 56). The local files override the
advanced options set in env_global_default.ini.

If the advanced option in the env_global_default.ini file is preceded by 
rem, the software defaults are used and shown as the value. The outdated
advanced options are listed at the end of the file.

Local environment settings - env_<environment>.ini
The env_<environment>.ini file contains advanced options that are set
according to local standards and are different from the global defaults.

The file is read from the environment folder..\ProgramData\Trimble
\Tekla Structures\<version>\environments\. The exact location might
vary depending on your environment.

WARNING Do not modify the env_<environment>.ini file. If you need to modify
some settings, copy the needed advanced options from this file to your
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user.ini (page 57) file and modify the settings there, or modify the
settings in the Advanced Options dialog box.

The global default environment settings file env_global_default.ini (page 55)
contains a complete listing of advanced options. The local files override the
advanced options set in env_global_default.ini.

Role settings - role_<role>.ini
The role_<role>.ini files contain all the advanced options that have typical
role-specific settings.

The file is read from the environment folder ..\ProgramData\Trimble
\Tekla Structures\<version>\environments\. The exact location might
vary depending on the environment.

WARNING Do not modify the role_<role>.ini file. If you need to modify some
settings, copy the needed advanced options from this file to your user.ini
(page 57) file and modify the settings there, or modify the settings in the
Advanced Options dialog box.

The role_<role>.ini file contains advanced options that are set according
to typical role requirements in your local area. These settings are different
from your environment settings in env_<environment name>.ini (page 55). The
global default environment settings file env_global_default.ini (page 55)
contains a complete listing of advanced options. The advanced option settings
in role_<role>.ini override the ones in env_<environment>.ini

Using roles for ribbon selection with subscription configurations

NOTE Ribbon selection with subscription configurations is primarily meant
to be configured by Trimble and reseller localization personnel.

With subscriptions, roles can be used for controlling which ribbon is shown for
a certain role. The role-specific .ini files in the environments (page 56), such as
role_Steel_Detailer.ini or role_Rebar_Detailer.ini, contain the
advanced options XS_RIBBON_CONFIGURATION_DIAMOND, 
XS_RIBBON_CONFIGURATION_GRAPHITE, and 
XS_RIBBON_CONFIGURATION_CARBON. These advanced options define the
ribbons for the specific role.

The advanced options must point to the configuration identifiers (page 39) of
the ribbon files, either to the configuration identifiers of the legacy on-
premises license configurations, or to the configuration identifiers of the
subscription configurations. It is not possible to make up new configuration
identifiers.

If the advanced options are not set, Tekla Structures uses the default ribbons
for each subscription configuration.

Example:
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For the users who select the Precast Concrete Detailing role, you could have
the following settings in the role_Precast_Detailer.ini file:

set XS_RIBBON_CONFIGURATION_CARBON=albl_up_Carbon
set XS_RIBBON_CONFIGURATION_GRAPHITE=albl_up_PC_Detailing
set XS_RIBBON_CONFIGURATION_DIAMOND=albl_up_PC_Detailing

For more examples, see your role_<role>.ini files used in your
environment.

TIP Administrators who have their own environment and roles: for the role,
such as timber detailer, you can create a folder for the ribbon files
in ..\<environment>\Timber\Detailing\Ribbons, for example.
Place the customized ribbon files in the folder, and include the folder in
the XS_SYSTEM path definition for that specific role.

Add an advanced option to the user.ini file
You can save your personal user settings in the user.ini file.

The user.ini file is located in the same location as the user-specific
options.bin file, such as ..\Users\<user>\AppData\Local\Trimble
\Tekla Structures\<version>\UserSettings.

NOTE We recommend that you add only system-specific (page 126)
advanced options to the user.ini file.

You can also add model-specific (page 126) advanced options, but the
model-specific advanced options only affect new models that you
create. This is because only the new advanced options that do not yet
exist in options_model.db or options_drawings.db are taken into
account. For more information, see Files storing options and advanced
options.

Adding user-specific advanced options in user.ini might not work as
desired as options.bin is loaded after user.ini and might override
the value.

TIP When you are moving to a new version of Tekla Structures, you can use
the Migration Wizard to automatically copy your user.ini file to the
new version. The Migration Wizard appears once you start Tekla
Structures for the first time after installation.

1. In Windows Explorer, right-click the user.ini file, select Open with, then
select a text editor from the list of available programs.
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2. On a new line, enter set, then a space, then the name of the advanced
option followed by an equal sign, and then the value in a single line. 

Tekla Structures only reads lines in the initialization file that start with set.

Example:

set %XS_DIR%=C:\TeklaStructures\2022

Possible values Example
TRUE
FALSE

set XS_DISABLE_WELD_PREP_SOLID=TRUE
set
XS_UNDERLINE_AFTER_POSITION_NUMBER_IN_HARDST
AMP=FALSE

1 set XS_SINGLE_CLOSE_DIMENSIONS=1
0 set XS_SINGLE_USE_WORKING_POINTS=0
string value set

XS_USER_DEFINED_BOLT_SYMBOL_TABLE=bolt_symbo
l_table.txt

switches set
XS_ASSEMBLY_FAMILY_POSITION_NUMBER_FORMAT_ST
RING=%%TPL:PROJECT.NUMBER%%
Use two switches.

3. Save the changes to the user.ini file.

4. Restart Tekla Structures to apply the changes.

See also

Typical initialization files (.ini files) and their reading order (page 49)

Input files (.inp files) for configuring Tekla Structures
Tekla Structures uses input files (.inp files) for various purposes, such as to
manage user-defined attributes and component dialog boxes, and to define
how components work.

All input files have the extension .inp. You can use these input files for
configuring Tekla Structures.

File Description
analysis_design_conf
ig.inp

Contains settings for analysis and design.

fltprops.inp Includes materials and dimensions of available
flat bars (page 60).

mesh_database.inp Contains definitions for reinforcement meshes.
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File Description
objects.inp Used to manage user-defined attributes.
objects_rebar_set.in
p

Used to manage user-defined attributes of rebar
sets.

pop_mark_parts.inp Contains settings for pop-marking.
privileges.inp Used to control access rights.
profitab.inp Contains available parametric profiles (page 247).
rebar_config.inp Contains settings for reinforcement marks.
rebar_database.inp Rebar catalog (page 328). Contains definitions for

reinforcing bars and strands.
rebar_schedule_confi
g.inp

Contains internal bending types of reinforcing
bars and their mapping to area specific bending
codes.

Rebar shape manager is a more versatile way to
define reinforcing bar bending shapes.

Tekla Structures also imports and exports rebar catalogs as .inp files.

See also

Properties of the objects.inp file (page 146)

Show plates as flat bars in drawings and reports
Tekla Structures can show plates as the equivalent flat bars for manufacturing.
Tekla Structures shows the plates as flat bars in reports and drawings.

1. Set the advanced option XS_USE_FLAT_DESIGNATION to TRUE.

2. Indicate the prefix that you want to use for flat bars using the advanced
option . 

For example, XS_FLAT_PREFIX=FLAT.

TIP To prevent Tekla Structures from showing the profile in metric units
in the US environment Imperial role, add the flat bar prefix to the
profitab.inp (page 262) file as a parametric profile.

3. Set other advanced options related to plate work in the Advanced
optionsdialog box as required: 
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XS_FLAT_TOLERANCE: Tekla Structures uses this value to check plate width
to determine whether to convert it to a flat bar.

XS_FLAT_THICKNESS_TOLERANCE: Tekla Structures uses this value to
check plate thickness to determine whether to convert it to a flat bar.

XS_CHECK_FLAT_LENGTH_ALSO: Tekla Structures checks plate length and
plate width, and then compares those with the possible dimensions for
flat bars in fltprops.inp.

4. Define materials, thickness, and width of available flat bars in the
Fltprops.inp (page 60) file.

Define materials, thickness, and width of flat bars in the Fltprops.inp
file
Use the Fltprops.inp file to define the materials, thickness, and width of the
flat bars that are shown for plates in drawings and reports.

The Fltprops.inp file is located in the \profil folder in one of the folders
under the environment folder ..\ProgramData\Trimble\Tekla
Structures\<version>\Environments\. The exact location might vary
depending on your environment. In the default environment, Fltprops.inp
is located in ..\ProgramData\Trimble\TeklaStructures\<version>
\Environments\default\General\Shared.

NOTE Copy the Fltprops.inp file to a model, project or firm folder, then modify
the file in the new location.

The first row in the file contains flat bar material definitions enclosed in quotes
" " and without spaces, followed by plate thicknesses. If you do not define a
material, you can use all materials for all flat bars. The rows after that define
the widths of available flat bars.

The units are millimeters.

Example

Fltprops.inp contains the following data:

5,6,"S235",8,10,"S275J0",10,15
40,45
50,55
60,65
70,75
100,110
200,220

With this data, Tekla Structures shows the following plates as flat bars in
drawings and reports:

Plate Material
5x40, 5x45, 6x50, 6x55 All materials
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Plate Material
8x60, 8x65, 10x70, 10x75 S235
10x100, 10x110, 15x200, 15x220 S275J0

Set advanced options related to plate work in the Advanced options dialog
box as required:

XS_USE_FLAT_DESIGNATION: Tekla Structures uses flat bar designation, which
means that it shows plates as the equivalent flat bars for manufacturing.

XS_FLAT_PREFIX: The flat bars get the prefix that is set as the value for this
advanced option.

XS_FLAT_TOLERANCE: Tekla Structures uses this value to check plate width to
determine whether to convert it to a flat bar.

XS_FLAT_THICKNESS_TOLERANCE: Tekla Structures uses this value to check
plate thickness to determine whether to convert it to a flat bar.

XS_CHECK_FLAT_LENGTH_ALSO: When this advanced option is set to TRUE,
Tekla Structures checks the plate length and plate width, and then compares
those with the possible dimensions for flat bars in fltprops.inp.

Define unfolding parameters in the unfold_corner_ratios.inp file
The unfolding parameters define the location of the neutral axis when a profile
is unfolded. The neutral axis is a line which runs along the length of a profile
where stress and strain are equal to zero. Tekla Structures uses these
parameters to create NC files and to display unfolded profiles in single-part
drawings.

To define unfolding parameters, modify the unfold_corner_ratios.inp
file, located in ..\ProgramData\Trimble\Tekla Structures\<version>
\environments\common\system, using a standard text editor. You can copy
the unfold_corner_ratios.inp file to a model, project or firm folder and
then modify the file in the new location as required. Tekla Structures searches
for this file in the default search order.

After modifying the unfold_corner_ratios.inp file, restart Tekla Structures
for the changes to take effect.

NOTE The settings in the unfold_corner_ratios.inp file have no effect
in the following cases:

• If the advanced option
XS_USE_OLD_POLYBEAM_LENGTH_CALCULATION is set to TRUE.

• If the advanced option
XS_CALCULATE_POLYBEAM_LENGTH_ALONG_REFERENCE_LINE is
set to TRUE. This only applies to polybeams with straight sections.
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Unfold parameter properties

See below for an example of unfolding parameters in the
unfold_corner_ratios.inp file and the descriptions of the parameters.

1 HE300A S235JR 0 180 2 0 1000 .7

Property In the example Description
Type 1 1 is polybeams

2 is plates modeled as
polybeams (for example,
PLT)

3 is for parts which are
not unfolded and follow
the old polybeam
calculation (for example,
the line 3 L* * disables
unfolding of L profiles)

Profile HE300A You can also use
wildcards with profile,
for example, HE300*.

Material S235JR You can also use
wildcards with material,
for example, S235*.

Rotation / thickness min 0 For polybeams: the
minimum angle when
the profile is rotated
around its longitudinal
axis

For plates: the minimum
thickness of plate

Rotation / thickness max 180 For polybeams: the
maximum angle when
the profile is rotated
around its longitudinal
axis

For plates: the maximum
thickness of plate

Flag 2 This property defines
what kind of parts are
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Property In the example Description
affected by the next two
properties.

1 is sharp folds. Only
polybeams with straight
chamfers are affected.

2 is curved bends. Only
polybeams with curved
chamfers are affected.

Angle / radius min 0 For sharp folds: the
minimum angle

For curved bends: the
minimum radius

Angle / radius max 1000 For sharp folds: the
maximum angle

For curved bends: the
maximum radius

Maximum radius is
measured to the plane
defined by the ratio, so it
is not dependent on how
the part is created
(where the reference
axis is located).

Ratio .7 Defines how much the
profile stretches or
shrinks when unfolded.

Ratio = (1 - the relative
location of the neutral
axis).

If only the inner surface
of the profile shrinks, the
ratio is 1. If only the
outer surface of the
profile stretches, the
ratio is 0. By default, the
ratio is 0.5 for length
calculation and 0.0 for
bending radius
calculation.

Tekla Structures applies
the unfolding ratio if the
profile properties are
within the range
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Property In the example Description
indicated by the
minimum and maximum
values.

Data files (.dat files) for configuring Tekla Structures
Data files (.dat files) contain information used by certain components and the
Rebar shape manager.

Default data files are read from the environment's system folder. User-defined
data files are stored in the model’s \attributes folder.

WARNING These files affect the operation of components and the Rebar
shape manager. Do not modify these files unless you are an
administrator.

File Description
joints.dat Contains data used in Handrailing (1024) and

Stanchions (S76) components. Used in the
Stanchion connection type option.

railings.dat Contains data used in Handrailing (1024). Used in
the Stanchion connection type option.

steps.dat Contains the data for Stairs (S82) and Stairs
(S71). Used in the Step profile and Catalogue
step options.

std_flange_plates.d
at

Contains data for Tapered column (S99). Used in
the options:

• Outer flange profile

• Inner flange profile

• Top plate profile
std_stiffener_plate
s.dat

Contains data used in Tapered column (S99).
Used in the Horizontal stiffener profile box.

marketsize.dat Contains available market sizes for certain
material grade. Can be used with fMarketSize()
function in the custom component editor.

import_macro_data_t
ypes.dat

Contains the user-defined attributes that you can
include in an input file in attribute import.

RebarShapeManager.C
ustomProperties.dat

Contains the custom properties, template
attributes, and user-defined attributes that you
can use in bending shape rules in the Rebar
shape manager.
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Customize user interface text in message files
Tekla Structures uses the information in the message files to show messages
in the user interface.

Message files include texts in languages in which the Tekla Structures user
interface is available. You can customize the texts in message files, such as the
texts used in dialog boxes.

• Message files with the .ail extension are located in the folder ..\Tekla
Structures\<version>\bin\messages.

• Message files with the .xml extension are located in the folder ..\Tekla
Structures\<version>\bin\messages\DotAppsStrings.

Customize message files
You can customize the messages that Tekla Structures shows in the user
interface.

1. Browse to the folder that contains the message file that you want to
modify.

• To modify an .ail message file, go to the ..\Tekla Structures
\<version>\bin\messages folder.

• To modify an .xml message file, go to the ..\Tekla Structures
\<version>\bin\messages\DotAppsStrings folder.

2. Open the message file using a text editor, such as Microsoft Notepad.

3. Modify the messages as required.

4. Save the message file.

Example: customize a message file

This example shows how to modify a message that Tekla Structures uses for
near side plates in drawings to show (NS) instead of (N/S).

1. Go to the ..\Tekla Structures\<version>\messages folder.

2. Open by_number.ail using a text editor.

The by_number.ail file contains both prompts and default texts that
Tekla Structures uses in drawings.

3. Browse to the following section:

string by_number_msg_no_675
 {
...
entry = ("enu", "(N/S)");
};
4. Change (N/S) to (NS) in the entry row.
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5. Save and close the file.

Customize object properties and settings in property files
Property files contain the object properties and settings that are shown in the
property pane or in the dialog boxes of model objects or drawing objects.

By default, Tekla Structures uses the standard property files when you apply
commands. The default standard property files are read from the
environment's system folder.

In addition to the default property files, you can define user-defined property
files, and load these saved properties later when you create, for example, new
model objects or drawing objects. Tekla Structures stores the saved, user-
defined property files in the current model’s \attributes folder.

Save a user-defined property file in the property pane

1. Enter a name for the property file in the field next to the  button.

2. Click  to save the property file.

Example

This example shows how to change the standard steel column properties so
that you create a new type of column called custom1.

1. Open the steel column properties in the property pane.

2. Enter or modify the properties you want to save.

3. In the field next to the  button, enter a name for the new column
properties. For example, custom1.

4. Click .

Tekla Structures saves the new custom1.clm property file in the current
model’s \attributes folder.

Save a user-defined property file in a dialog box
1. Enter a name for the property file in the field next to the Save as button.

2. Click Save or Save as to save the property file.

Standard files
Standard files are property files that Tekla Structures uses by default when you
apply commands.
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Standard properties are shown in the property pane of different model
objects, such as beams, columns or plates, or in the dialog boxes of objects,
such as drawing objects.

Standard files are named standard.*, where the symbol * is the file name
extension. The file extension indicates the type of object that the properties in
the standard file are used for. For example, the standard.clm file is used for
the properties of steel columns.

User-defined attributes are saved with the standard files as *.more files. For
example, the standard.clm.more file is used for user-defined attributes for
steel columns.

How properties are loaded from standard files
• In the property pane, the properties are loaded when you select the

standard option in the upper part of the property pane. The properties are
applied immediately.

If the values that you loaded are different from the previous values, the
property pane highlights the modified properties.

• In dialog boxes, the properties are loaded when you select the standard
option in the list next to the Load button, and click the Load button.

Tekla Structures reads the default standard files from the environment's
system folder.

If you want to load the default property settings from the standard files that
are saved in the attributes folder, go to Quick Launch and use the Load
defaults command.

Save a set of standard files
You can save a set of standard files in the \attributes folder for the
current model.

After saving the standard files, you can copy them to the project folder or the
firm folder to set up Tekla Structures to suit the way you work.

1. Go to Quick Launch and start typing save defaults.

2. Select Save defaults from the list.
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Tekla Structures saves the following list of standard and *.more files in
the ..\TeklaStructuresModels\<model_name>\attributes folder:

File Property
standard.bpl
standard.bpl.more

Bent plate properties

standard.clm
standard.clm.more

Steel column properties

standard.cpl
standard.cpl.more

Contour plate properties

standard.crs
standard.crs.more

Orthogonal beam properties

standard.dia
standard.dia.more

Twin profile properties

standard.fms
standard.fms.more

Plotting frames

standard.fpl
standard.fpl.more

Folded plate properties

standard.ipc
standard.ipc.more

Concrete item properties

standard.ips
standard.ips.more

Item properties

standard.ler
standard.ler.more

Layer properties

standard.mvi
standard.mvi.more

Model view properties

standard.num
standard.num.more

Numbering setup

standard.prf
standard.prf.more

Project properties

standard.prt
standard.prt.more

Steel beam properties

standard.scr
standard.scr.more

Bolt properties
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File Property
standard.wld
standard.wld.more

Weld properties

You can now copy the standard files to the project folder or the firm folder.

Create user-defined standard files
You can create your own standard files.

Tekla Structures saves the user-defined standard files in the \attributes
folder for the current model.

1. Open the property pane or a dialog box for which you want to save the
properties as a standard file.

2. Modify the properties.

3. Save the properties in one of these ways:

• In the property pane: enter standard as the name

, then click .

• In a dialog box: in the box next to the Save as button, enter standard

as the name , then click Save as.

Tekla Structures saves the standard file and the related *.more file in the
current model’s \attributes folder. If a standard file with the same file
name extension exists in the in the \attributes folder, Tekla Structures
overwrites the previous file.

When you want to load the standard file, select it from the list of the property
files in the property pane or in a dialog box.

Alternatively, to load the default property settings from the standard files
that are saved in the attributes folder, go to Quick Launch and use the
Load defaults command.

Files related to catalogs
Tekla Structures uses ASCII and binary files to manage profile, material,
reinforcement, bolt, and bolt assembly catalogs.

Each environment has its own folder where the files related to different
catalogs are stored. For example, ..\Environments\uk\general\profil\
contains the files for managing catalog files used in the United Kingdom. The
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exact file location might vary depending on the folder structure of your
environment files.

File
type

File name Used for Default location

.inp profitab.inp Defines the names that
you can use for
parametric profiles.

..\ProgramData
\Trimble\Tekla
Structures
\<version>
\Environments
\<environment>
\profil

rebar_databa
se.inp

The rebar catalog. ..\ProgramData
\Trimble\Tekla
Structures
\<version>
\Environments
\<environment>
\profil

mesh_databas
e.inp

The reinforcement mesh
catalog.

..\ProgramData
\Trimble\Tekla
Structures
\<version>
\Environments
\<environment>
\profil

You can define
the file name
while exporting.

Created when you
export rebar catalogs.

You can define the folder
while exporting.

.cnv matexp_<soft
ware>.cnv

Converting material
names when
transferring model
information using links.
For example, converts
S235JR to FE360B for
DSTV.

..\ProgramData
\Trimble\Tekla
Structures
\<version>
\Environments
\<environment>
\profil

prfexp_<soft
ware>.cnv

Converting profile
names when
transferring model
information using links.
For example, converts
HEA100 to HE100A for
DSTV.

..\ProgramData
\Trimble\Tekla
Structures
\<version>
\Environments
\<environment>
\profil

.clb For example,
RU_CF.clb

Contains the definitions
of parametric profiles
used in profitab.inp.

..\ProgramData
\Trimble\Tekla
Structures
\<version>
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File
type

File name Used for Default location

\Environments
\common\inp

.lis You can define
the file name
while exporting.

Created when you
export bolt, profile and
material catalogs.

You can define the folder
while exporting.

.db assdb.db The bolt assembly
catalog.

..\ProgramData
\Trimble\Tekla
Structures
\<version>
\Environments
\<environment>
\profil

screwdb.db The bolt catalog. ..\ProgramData
\Trimble\Tekla
Structures
\<version>
\Environments
\<environment>
\profil

.bin profdb.bin The profile catalog. ..\ProgramData
\Trimble\Tekla
Structures
\<version>
\Environments
\<environment>
\profil

matdb.bin The material catalog. ..\ProgramData
\Trimble\Tekla
Structures
\<version>
\Environments
\<environment>
\profil

See also

Customize the profile catalog (page 234)

Customize the material catalog (page 226)

Customize the bolt catalog (page 314)

Customize the rebar catalog (page 328)
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Font files for customizing Tekla Structures
You can define the location of font files with the advanced option 
DXK_FONTPATH in the teklastructures.ini or your environment
initialization file.

For example, you can use fonts available in the folder ..\ProgramData
\Trimble\Tekla Structures\<version>\Environments\common
\fonts.

This folder includes the following Tekla Structures system fonts:

• fixfont.fon
• romco.fon
• romsim.fon
• romsim8.fon

NOTE The Cyrillic fonts GOST 2.304-81 type A.ttf and GOST 2.304-81 type
B.ttf are located in the C:\Windows\Fonts folder, not
the ..\ProgramData\Trimble\Tekla Structures\<version>
\Environments\common\fonts folder.

Fonts are converted using font conversion files that are available in the same
folder:

File Used for
template_fonts.cnv Converting Tekla Structures system

fonts, such as Template Editor fonts,
to Windows fonts in DWG/DXF export.

dxf_fonts.cnv Converting True Type fonts to the SHX
font format that is understood by
AutoCAD in the old DWG/DXF export.

See also

Initialization files for start-up parameters and default settings (page 48)

Symbol files for drawings
Symbols are used in various places in drawings, for example, as separate
objects, and in marks.

You can create symbols with the Symbol Editor. The file name extension
is .sym. You can also use symbols in .dwg format.

By default, Tekla Structures stores symbol files in the
folder ..\Environments\common\symbols.
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Files related to templates, reports and drawings
Tekla Structures has several files that relate to templates, reports, drawings
and printing.

File or file
type

Description Location

.rpt Report templates (page 149)
created with the Template
Editor

System folders defined for the
advanced option XS_SYSTEM

.tpl Drawing templates (page 149)
created with the Template
Editor

Template folders defined for
the advanced option 
XS_TEMPLATE_DIRECTORY

.lay Layout definitions created
with the Drawings & reports
--> Drawing properties -->
Drawing layout editor
command.

The \attributes sub-folder
in the model folder

plotdev.bin Printer device definitions
created with the

Printer Catalog printer
instances.

System folders defined with
the advanced option 
XS_SYSTEM

xdproc Master Drawing Catalog rule
set

System folders defined with
the advanced option 
XS_SYSTEM

xdproc.mast
er

Master Drawing Catalog
master drawing file

System folders defined with
the advanced option 
XS_SYSTEM

xdproc.mast
er.png

Master Drawing Catalog
sample (preview) image files

System folders defined with
the advanced option 
XS_SYSTEM

xdproc.png Master Drawing Catalog
thumbnail image files

System folders defined with
the advanced option 
XS_SYSTEM

For more information about the folder search order, see Folder search order
(page 45).

The default drawing, report, and template files are read from the system
folders defined with the XS_SYSTEM advanced option or from the
XS_TEMPLATE_DIRECTORY folders, but user-defined files are stored in the
\attributes sub-folder in the model folder.
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DWG reference model plug-in configuration settings
The settings in the DWG reference model plug-in configuration file
dwgplugin.config are described below.

NOTE The advanced settings in dwgplugin.config do not normally need to be
changed, but in some scenarios, things like very large radius arcs can end up
with the generated straight line segments not small enough for the user's
needs, and adjusting these settings can help. The dwgplugin.config file is
located in the ..\bin\plugins\referenceplugins\dwg\ folder, and you
might need administrator rights to access the file.

Example of the configuration file:

<?xml version="1.0" encoding="UTF-8"?>
<tsplugin version="1" inproc="false" extensions=".dwg|.dxf">
  <hostenv>
  </hostenv>
  <configuration>
  </configuration>
  <settings>
    <acistesselation>15</acistesselation> <!-- degrees -->
    <largecircledelimiter>10000</largecircledelimiter> <!-- in dwg units 
-->
    <linesinlargecircle>256</linesinlargecircle>
    <linesinsmallcircle>32</linesinsmallcircle>
    <externalGUID>spatialHash</externalGUID>
    <!-- Single shapes larger than this will be excluded. Units are in 
model units. Set to 0 to disable. -->
    <maximumsize>1000000</maximumsize>
  </settings>
</tsplugin>

The settings used in the configuration file are described below:

Setting Description
acistessellation This setting may or may not do

anything depending on the plug-in
version - in earlier versions it
configures the tessellation density of
the solids.

largecircledelimiter Defines the radius of a circle that is
then considered to be a large circle
w.r.t. the parameters
LinesInSmallCircle and
LinesInLargeCircle. A circle radius that
is equal to or greater than this value
will be treated as a large circle. This
value is in dwg units.

LinesInSmallCircle Sets the number of tessellation lines
in the circle (with a 'small' radius) that
an arc represents. This is then used
when tessellating the arc into straight
line segments. Valid range is 3 to
10000.
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Setting Description
LinesInLargeCircle Sets the number of tessellation lines

in the circle (with a 'large' radius) that
an arc represents. This is then used
when tessellating the arc into straight
line segments. Valid range is 3 to
10000.

externalGUID Configures the style of the id attached
to parts. This parameter should not
be changed.

maximumsize Single shapes larger than the value
you specify will be excluded. Units are
in model units. Set to 0 to disable.

Supported image file formats in Tekla Structures
You can use image files in many places in Tekla Structures.

You can use image files in:

• Templates in drawings

• Drawing snapshots

• Component dialog boxes and thumbnails

• Drawing line types

• The surface treatment dialog box

• The Master Drawing Catalog for thumbnails and sample images

• Profile properties dialog boxes

These image file formats are supported in Tekla Structures:

Used in Supported image formats
Templates • bmp

• gif
• grd
• jpg
• ppm
• pgm
• rle
• tiff
• xkrl
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Used in Supported image formats
Drawing snapshots png
Thumbnail and sample images for the
Master Drawing Catalog

png

Other uses bmp

See also

Add images in a template (page 165)

Log files about the operation of Tekla Structures
Tekla Structures writes information about the operation of Tekla Structures to
log files when you perform some actions, such as numbering a model or
saving a model.

File Description
analysis.log Tekla Structures stores information in this file

when you run the analysis. The file also contains
information about the errors that occurred during
load distribution. This log file is saved in the
current model folder.

check_database.log Tekla Structures stores information in this file
when you run the Repair command in File menu
--> Diagnose & repair --> Model . This log file is
saved in the current model folder.

ClashCheck.log Contains clashes found in the most recent clash
check. This log file is saved in the current model
folder.

ClientLog_cat.txt
ClientLog_dog.txt

The client log files contain diagnostic information
and error messages about the Tekla Model Sharing
sharing service, such as connecting to the sharing
service or the status of the sharing service. The
client log files are saved in the \Users\<user>
\AppData\Local\Tekla DataSharing folder by
default.

There are two client log files with a maximum size
of 1 megabyte each, so that the information does
not use too much disk space. When the maximum
file size is reached in one file, log writing changes
to the other file. Each time that the active client log
file changes, any information previously saved in
the current log file is cleared before any new log
information is written to the log file.
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File Description
ComponentCatalog_<u
ser>.log

Contains troubleshooting information related to
the Applications & components catalog and any
errors that have occurred in the Applications &
components catalog. For example, errors in
catalog definition files are stored in the
ComponentCatalog_<user>.log file. This log file
is saved in the \logs folder under the current
model folder.

A limited number of older log messages related to
the Applications & components catalog are
archived and saved in the
ComponentCatalog_<user>.bak.log file. This
file contains approximately 1024 KB of data.

conflict.log Contains conflicts that have occurred when more
than a one user has modified an object in multi-
user mode. This log file is saved in the current
model folder.

DocumentManager_<us
er>.log

Contains troubleshooting information related to
the Document manager, and any errors that have
occurred in the Document manager. This log file
is saved in the \logs folder under the current
model folder.

A limited number of older log messages related to
the Document manager are archived and saved in
the DocumentManager_<user>.bak.log file. This
file contains approximately 256 KB of data.

DPMPrinter_<user>.l
og

Contains troubleshooting information related to
printing, and any errors that have occurred in
printing drawings or reports to a printer, a plot file,
or a PDF file. This log file is saved in the \logs
folder under the current model folder.

A limited number of older log messages related to
printing are archived and saved in the
DPMPrinter2_ <user>.log file. This file contains
approximately 1024 KB of data.

drawing_cloning.log Contains information about cloned drawings. This
log file is saved in the current model folder.

drawing_history.log Contains information about drawing history. Use
the advanced option to define the contents of the
file. This log file is saved in the current model
folder.

dstv_nc.log Each time you create NC files, Tekla Structures
stores information in this file about the processed
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File Description
assemblies. This log file is saved in the current
model folder.

error_<user>_<YYYYM
MDD>_<HHMMSS>.log

Each time an error occurs in Tekla Structures, the
error is saved in an error log file. Error log files
contain the description of errors that have
occurred at a particular time. For example, if an
error has occurred on April 1, 2019 at 9:15:30 AM,
the name of the related error log file is
error_<user>_20190401_091530.log. This log
file is saved in the \logs folder under the current
model folder.

filetranerror.log Used only for cold rolled components, such as
Albion, Ayrshire, and Hispan. If the File Transfer
components do not work as expected, Tekla
Structures stores error messages in this file. This
log file is saved in the current model folder.

modelsharing.log Contains the sharing operations that have been
performed in Tekla Model Sharing. For example,
opening a shared model and reading in the
changes made by other users are stored in the
modelsharing.log file. This log file is saved in
the \logs folder under the current model folder.

numberinghistory.tx
t

Contains full details of each numbering session
carried out on the model. Each session is in a
different block of the file. This log file is saved in
the current model folder.

PublishToTrimbleCon
nect.log

Contains upload information and the errors that
have occurred when uploading the Tekla Structures
model to a linked Trimble Connect project as
a .tekla file. This log file is saved in the \logs
folder under the current model folder.

save_history.log Tekla Structures stores information in this file each
time you save a model. This log file is saved in the
current model folder.

sharingfacade.log Contains the essential information from the client
log files when an error has occurred in the Tekla
Model Sharing sharing service. This log file is saved
in the \logs folder under the current model
folder.

TeklaStructures_<us
er>.log

Contains information about the entire Tekla
Structures session from opening the model to
closing it. The file contains, for example, errors and
information about which catalogs were used. This
temporary log file is saved in the
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File Description
\TeklaStructuresModels folder, and is
removed when you close Tekla Structures.

UserFeedbackLog.txt Contains usage data about how you use Tekla
Structures. This log file is saved in the
\TeklaStructuresModels folder.

The UserFeedbackLog.txt log file is always
opened with the default text editor, unlike other
log files which can be opened through the Tekla
Structures log viewer. The option to change
between the viewers does not work for the
UserFeedbackLog.txt file.

wizard.log Tekla Structures stores information in this file
when you run a drawing rule set (wizard) file. The
file contains, for example, errors and the number
of drawings created. This log file is saved in the
current model folder.

View a log file
You can view most log files in the Tekla Structures log viewer, or in the
application that has been associated with the file type, such as Microsoft
Notepad.

If the log file contains information about parts or assemblies, you can check
the parts or assemblies in the model. In the log file, select a row that contains
a part or an assembly.

Parts and assemblies have the prefix guid.

Tekla Structures highlights the part in the model. If there are several parts or
assemblies on a row and you select that row, Tekla Structures highlights all the
parts in the model. You can also select parts on different rows.

TIP You can open the right-click menu for a part or an assembly from the log
file by right-clicking a row that contains a part or an assembly. Tekla
Structures shows the same menu as when you right-click a part or an
assembly in the model.

1. Open the model for which you want view the log history.

2. On the File menu, click Logs, then select a log file.

• Clash Check history log (ClashCheck.log)

• Session history log (TeklaStructures_<user>.log)

• Numbering history log (numberinghistory.txt)

• Saving history log (save_history.log)
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• Drawing history log (drawing_history.log)

• Analysis history log (analysis.log)

• Usage data log (UserFeedbackLog.txt)

3. View the log file in one of the following ways:

• To view the log file in the log viewer, in File --> Logs select View with
Tekla Structures log viewer.

NOTE You cannot view the UserFeedbackLog.txt log file in the
Tekla Structures log viewer.

• To view the log file in the application associated with the file type, File
--> Logs select View with default application.

Change the name and location of session history log file
You can change the name and location of the session history log file
(TeklaStructures_<user>.log).

If someone else manages your installation of Tekla Structures, do not change
these settings unless you are instructed to do so.

Windows username and the .log file extension are always added after the
customizable part of the name.

1. Open a suitable initialization file (page 49) for editing. 

For example, user.ini or company.ini.

2. To change the name of the session history log file, add the following line
to the initialization file: 

set XS_LOG_FILE_NAME=<name of the file>
For example:

set XS_LOG_FILE_NAME=sessionhistory
If the Windows user name is "achilles", this example would result in a log
file named sessionhistory_achilles.log.

The default name is TeklaStructures_<user>.log.

3. To change the location of the session history log file, add the following
line to the initialization file: 

set XS_LOGPATH=<location of the file>
If there is no other location set, the file is stored in the parent folder for
model folders (by default c:\TeklaStructuresModels).

4. Save the initialization file.

5. Restart Tekla Structures for the changes to take effect.

See also

Customize Tekla Structures for users 80 Files for configuring Tekla Structures



• XS_LOG_FILE_NAME

• XS_LOGPATH

Numbering history log file
The numberinghistory.txt log file contains full details of each numbering
session carried out on the model. Each numbering session is in a different
block of the file.

If one numbering series overlaps another, the errors are written to the log file.

NOTE If you remove or delete the numberinghistory.txt log file, Tekla Structures
generates a new file with the same name the next time you run numbering.
The new file does not contain a history of previous numbering sessions.

Example

This example shows the contents of a numberinghistory.txt log file.

1 User name, date and time of the numbering.
2 Numbering method.

• Modified numbering is displayed when you run the Number
modified objects command.

• Modified numbering for selected series is displayed
when you run the Number series of selected objects
command.

• Diagnose & Repair Numbering: All is displayed when you
run the Diagnose & repair numbering: All command.

• Diagnose & Repair Numbering: Series of selected
objects is displayed when you run the Diagnose & repair
numbering: Series of selected objects command.

• Renumber all is displayed when you select the Renumber all
option in the Numbering Setup dialog box.

3 Some Compare options set in the Numbering Setup dialog box are
displayed in the numbering.history log file only if they are set
differently than the default value:

• Compare modified to old parts
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• Compare new to old part
• No holes comparing
• No part name comparing
• Beam orientation
• Column orientation
Some Compare options are not displayed at all:

• Reinforcing bars

• Embedded objects

• Surface treatment
4 Numbering options.

• Use old numbers is displayed only when you have selected the
Re-use old numbers option in the Numbering Setup dialog box.

• Check for standard parts is displayed only when you have
selected the Check for standard parts option in the Numbering
Setup dialog box.

5 Tolerances are set in the Numbering Setup dialog box.
6 Changes in the position numbers and in the numbering series

during one numbering session.

See also

•

Numbering series in the numbering history log file
Tekla Structures lists information about the numbered parts and assemblies in
the numberinghistory.txt log file.

Example 1

The numberinghistory.txt log after one concrete beam B/20 has been
created and numbered:
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1 Part position number.

• The part with the GUID 
ID510F595D-0000-0030-3133-353939383335 is a part of the
numbering series Concrete_B-20/1.

• The part becomes the first part in the numbering series: 
Concrete_B-20/0 -> Concrete_B-20/1.

2 Assembly position number.

• The assembly ID of the part is 
ID510F595D-0000-002F-3133-353939383335.

• The part belongs to the B/20 assembly numbering series, which
is also the cast unit numbering series.

• The part gets the assembly position number: B/20: B/0 ->
B/20.

Example 2

The numberinghistory.txt log after another concrete beam B/21 has been
created and numbered:

1 Part position number of the new part.

• The part with the ID 
ID510F595D-0000-0030-3133-353939383335 is part of the
numbering series Concrete_B-20/1.

• The part becomes the second part in the numbering series: 
Concrete_B-20/0 -> Concrete_B-20/2.

2 Assembly position number.

• The assembly ID of the part is 
ID510F595D-0000-002F-3133-353939383335.

• The part belongs to the B/20 assembly numbering series, which
is also the cast unit numbering series.
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• The part gets the assembly position number: B/20 B/0 ->
B/21.

Files and file name extensions in the Tekla Structures
model folder
These tables list the folders, files and file name extensions of files located in a
Tekla Structures model folder.

Files in the Tekla Structures model folder

File or file name
extension

Description

.db1 Model database

.db2 Numbering database
environment.db Database for user-defined attribute definitions
xslib.db1 Contains information about user-defined

connections and details, and default component
descriptions.

.idrm Mapping file, which handles IDs.

NOTE Do not modify this file.

xslib.db2 Contains numbering information.
options_model.db and
options_drawings.db

Contain values for model-specific options from the
Options dialog box and values for model-specific
advanced options from the Advanced Options
dialog box.

When a model is created, Tekla Structures reads
model-specific options and advanced options
values from the standard.opt file and .ini files
in the environment folders and saves them in
these two databases.

history.db Model history database.
xsdb.xs This file is used to show the name of the model in

the Open dialog box.
xs_user.<username> Contains interface settings specified by the user.

This file contains settings for many of the options
in the Options dialog box and the settings for the
icons on the Selecting and Snapping toolbars.
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File or file name
extension

Description

Each time a model is saved, an
xs_user.<username> file is created or updated.
These settings are user-specific.

If the xs_user.<username> file is not found in
the model folder when you open the model, Tekla
Structures searches for the xs_user.default file
in the following folder search order:

1. Model folder

2. model\attributes
3. Project folder

4. XS_FIRM\attributes
5. System folder

If this file is not found, the default settings for Tekla
Structures default settings are used.

drawing_user.<usern
ame>

Contains information about which snap switches
are switched on or off in the drawing mode. This
file is user-specific.

NOTE Do not modify this file.

save_history.log Each time the model is saved, Tekla Structures
stores the information in this file. The file includes
the time and date that the file was saved, and
information about any conflicts during saving.

notification_report
.xsr

This file is used to show a notification report of
assignments when you open a model.

TeklaStructuresMode
l.xml

Contains a copy of basic details about the Tekla
Structures model, such as the model name, the
version it was last saved with, and the Tekla
Structures environment that was used. Tekla
Structures overwrites the details in this file each
time the model is saved.

The model details that you see when you select a
model on the startup screen are read from this file.
The file can also be used as an information source
for external tools, such as scripts.

dotlog.txt A log file that contains information about Tekla
Open API application use.

.locked A temporary file that locks the files in the model
folder to prevent modifications while the model is
in use.
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File or file name
extension

Description

.bak A backup copy of a file with a corresponding name.

For example, the <modelname>.db1.bak file is
the backup copy of the model database file 
<modelname>.db1.

assert.txt A log file that contains information about assertion
errors.

ClashCheck.txt A log file that contains information about clashes
found in the most recent clash check, and the date
and time of the clash check.

ClashCheck.history A file that contains information about clashes
found in all past clash checks, and the dates and
times of the clash checks.

wizard.txt Tekla Structures stores information in this file
when you run a drawing rule set (wizard) file. The
file contains information such as errors, the
number of drawings created, and information
about which commands were used.

.lis Export files for catalogs. You can export catalogs
and import them to different Tekla Structures
models as .lis files. These catalogs include
profile, material, and bolt catalogs.

.tsc Export files for shapes. You can export shapes and
import them to different Tekla Structures models
as .tsc files.

.This_is_multiuser_
model

Contains information about the PC that is running
the Tekla Structures multi-user server.

NOTE In normal circumstances, do not alter or
delete this file.

If you move the model to a different
server, you should delete this file. Tekla
Structures generates a new file for the new
server.

ComponentCatalog.xm
l

Contains the model level catalog definitions of the
Applications & components catalog.

<user>_ComponentCat
alogUserSettings.xm
l

Lists the recently used applications and
components, and their location in the
Applications & components catalog structure.

Worktypes.xml Lists available task types. This file is created when
you start the Task Manager.
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File or file name
extension

Description

WorkTypeProperties.
xml

Lists allowed property types and their units.

.tmp Stores temporary data.

.cnv Maps Tekla Structures profile and material names
with names used in other software.

.colorset This file is created when you export a color set
from the Organizer.

Files in the \Analysis folder

File or file name
extension

Description

.ifc The analysis model exported in IFC format.

.stp The analysis model exported in CIS/2 format.

.map A file used for debugging analysis models.
analysis_results.db
5

Database that contains saved analysis results for
all load combinations.

.db6 Analysis model database.

Files in the \attributes folder

File or file name
extension

Description

.rmcs Comparison set files used in reference model
change detection.

.rmct Property set comparison tolerance setting files
used in reference model change detection.

.rop Reference object properties

.rop.more Reference object user-defined attribute properties

.m10000017 FabTrol XML import properties

.m10000015 Import attribute properties

.ncf NC file properties

.ExportIFC.MainDial
og

IFC export properties

.m440000004 3D DWG/DXF export properties

.m440000003 3D DGN export properties

.m1000004 FEM export properties

.m10000011 CIS analysis model export properties
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File or file name
extension

Description

.m10000026 CIS manufacturing model export properties

.m1000007 CAD export properties

.m10000016 Cover sheet export properties

.SObjGrp Model selection filter properties

.VObjGrp Model view filter properties

.OrgObjGrp Organizer filter properties

.PObjGrp Object group filter properties

.grd Rectangular grid properties

.grd.more Rectangular grid user-defined attribute properties

.rgrd Radial grid properties

.rgrd.more Radial grid user-defined attribute properties

.grdp Grid line properties

.grdp.more Grid line user-defined attribute properties

.cnl Construction line properties

.cncrl Construction circle properties

.cnarc Construction arc properties

.cnplycrv Construction polycurve properties

.mvi Model view properties that you have saved for the
model.

The default 3D, part, component, custom
component, assembly, and cast unit view settings
files must be saved with the names used in
common environment:

3D view: basic_view

3D part view: part_basic_view

Part front view: part_front_view

Part top view: part_top_view

Part end view: part_end_view

Part perspective view: part_persp_view

3D component view: component_basic_view

Component front view: component_front_view

Component top view: component_top_view

Component end view: component_end_view

Component perspective view:
component_persp_view
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File or file name
extension

Description

Custom component front view:
custom_object_editor_front_view

Custom component top view:
custom_object_editor_top_view

Custom component end view:
custom_object_editor_end_view

Custom component perspective view:
custom_object_editor_perspective_view

3D assembly or cast unit view:
assembly_basic_view

Assembly or cast unit front view:
assembly_front_view

Assembly or cast unit top view: assembly_top_view

Assembly or cast unit end view:
assembly_end_view

Assembly or cast unit back view:
assembly_back_view

Assembly or cast unit bottom view:
assembly_bottom_view

Assembly or cast unit perspective view:
assembly_persp_view

.gvi Saved properties for creating views along grid lines

.rep Object representation properties

.clm Steel column properties

.clm.more Steel column user-defined attribute properties

.prt Steel beam properties

.prt.more Steel beam user-defined attribute properties

.sb Steel spiral beam properties

.sb.more Steel spiral beam user-defined attribute properties

.crs Orthogonal beam properties

.crs.more Orthogonal beam user-defined attribute properties

.dia Twin profile properties

.dia.more Twin profile user-defined attribute properties

.cpl Contour plate properties

.cpl.more Contour plate user-defined attribute properties

.blp Bent plate properties

.blp.more Bent plate user-defined attribute properties
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File or file name
extension

Description

.lpl Lofted plate properties

.lpl.more Lofted plate user-defined attribute properties

.ips Item properties

.ips.more Item user-defined attribute properties

.cpf Pad footing properties

.cpf.more Pad footing user-defined attribute properties

.csf Strip footing properties

.csf.more Strip footing user-defined attribute properties

.ccl Concrete column properties

.ccl.more Concrete column user-defined attribute properties

.cbm Concrete beam or concrete polybeam properties

.cbm.more Concrete beam or concrete polybeam user-defined
attribute properties

.csb Concrete spiral beam properties

.csb.more Concrete spiral beam user-defined attribute
properties

.csl Concrete slab properties

.csl.more Concrete slab user-defined attribute properties

.cpn Concrete panel properties

.cpn.more Concrete panel user-defined attribute properties

.lsl Concrete lofted slab properties

.lsl Concrete lofted slab user-defined attribute
properties

.ipc Concrete item properties

.ipc.more Concrete item user-defined attribute properties

.rbr Reinforcing bar properties

.rbr.more Reinforcing bar user-defined attribute properties

.rbg Reinforcing bar group properties

.rbg.more Reinforcing bar group user-defined attribute
properties

.rcu

.rcu.more
Curved reinforcing bar group properties and user-
defined attributes

.rci

.rci.more
Circular reinforcing bar group properties and user-
defined attributes

.rbm Reinforcement mesh properties
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File or file name
extension

Description

.rbm.more Reinforcement mesh user-defined attribute
properties

.rbs Reinforcement strand pattern properties

.rbs.more Reinforcement strand pattern user-defined
attribute properties

.rsp Reinforcement splice properties

.rsp.more Reinforcement splice user-defined attribute
properties

.rst Rebar set properties

.rst.more Rebar set user-defined attribute properties

.rst_ls Rebar set leg surface properties

.rst_pm Rebar set property modifier properties

.rst_pm.more Rebar set property modifier user-defined attribute
properties

.rst_edm Rebar set end detail modifier properties

.rst_edm.more Rebar set end detail modifier user-defined
attribute properties

.rst_sm Rebar set splitter properties

.admodel Analysis model properties

.admodel.more Analysis model user-defined attribute properties

.lm1 Point load properties

.lm2 Line load properties

.lm3 Area load properties

.lm4 Uniform load properties

.m10000028 Wind load properties

.lm6 Temperature load properties

.lco Load combination properties

.adnode Analysis node properties

.adnode.more Analysis node user-defined attribute properties

.prt_ad, .prt_design File types associated with steel beam analysis
property settings. .prt_ad contains information
associated with the analysis part properties
and .prt_design contains information associated
with the actual steel beam design.

.crs_ad, .crs_design File types associated with orthogonal steel beam
analysis property settings. .crs_ad contains
information associated with the analysis part
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File or file name
extension

Description

properties and .crs_design contains information
associated with orthogonal steel beam design.

.clm_ad, .clm_design File types associated with steel column analysis
property settings. .clm_ad contains information
associated with the analysis part properties
and .clm_design contains information associated
with the actual steel column design.

.dia_ad, .dia_design File types associated with steel twin profile analysis
property settings. .dia_ad contains information
associated with the analysis part properties
and .dia_design contains information associated
with actual twin profile design.

.cpl_ad, .cpl_design File types associated with contour plate analysis
property settings. .cpl_ad contains information
associated with the analysis part properties
and .cpl_design contains information associated
with actual contour plate design.

.cpf_ad, .cpf_design File types associated with pad footing analysis
property settings. .cpf_ad contains information
associated with the analysis part properties
and .cpf_design contains information associated
with the actual pad footing design.

.csf_ad, .csf_design File types associated with strip footing analysis
property settings. .csf_ad contains information
associated with the analysis part properties
and .csf_design contains information associated
with the actual strip footing design.

.ccl_ad, .ccl_design File types associated with concrete column analysis
property settings. .ccl_ad contains information
associated with the analysis part properties
and .ccl_design contains information associated
with the actual concrete column design.

.cbm_ad, .cbm_design File types associated with concrete beam analysis
property settings. .cbm_ad contains information
associated with the analysis part properties
and .cbm_design contains information associated
with the actual concrete beam design.

.csl_ad, .csl_design File types associated with concrete slab analysis
property settings. .csl_ad contains information
associated with the analysis part properties
and .csl_design contains information associated
with the actual slab design.
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File or file name
extension

Description

.cpn_ad, .cpn_design File types associated with concrete panel analysis
property settings. .cpl_ad contains information
associated with the analysis part properties
and .cpl_design contains information associated
with the actual concrete panel design.

.srf Surface treatment properties

.srf.more User-defined surface treatment attribute
properties

.srfo Surface properties

.srfo.more User-defined surface attribute properties

.cha Edge chamfer properties

.cha.more User-defined edge chamfer attribute properties

.scr Bolt properties

.scr.more User-defined bolt attribute properties

.wld Weld properties

.wld.more User-defined weld attribute properties
*.udwcs User-defined weld cross sections

(UserDefinedWeldCrossSections.udwcs)
.m1000009 Control number properties
.m1000010 Control number locking properties
.num Numbering setup properties
.rpr Report properties
.4d Project status visualization properties
.sas Assembly properties
.pas Precast cast unit properties
.ias Cast-in-place cast unit properties
.ras Rebar assembly properties
.punit
.punit.more

Pour unit properties and user-defined attributes

.pour

.pour.more
Pour object properties and user-defined attributes

.pbreak Pour break properties
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File or file name
extension

Description

standard.opt Settings are saved in standard.opt in the
\attributes folder only when you save your own
settings in the Options dialog box using Save.

There is a standard.opt file in the environment
folder that gives the initial values to be loaded
when a model is created.

Tekla PowerFab export settings in the \attributes folder

The standard Tekla PowerFab export settings file is saved with the name
standard.TeklaPowerFabPluginSettings.xml in the \attributes
folder under the model folder. If you save the settings with another name, the
settings file is saved as <name>.TeklaPowerFabPluginSettings.xml.

Component properties files in the \attributes folder

Properties files for components in the Applications & components catalog,
such as .j310000063 for 2L Splice (63) component properties. These files are
stored in the attributes folder under the model folder.

Object-level drawing settings saved in the \attributes folder

File or file name extension Description
.dprt Object-level part properties
.dim Object-level dimension properties
.dimension_mark Object-level dimension tag properties
.rdim Object-level rebar dimension mark properties
.pm Object-level part mark properties
.jm Object-level connection mark properties
.sm Object-level bolt mark properties
.rm Object-level reinforcement mark properties
.mrms Object-level merged reinforcement mark

properties
.pom Pour object mark properties
.surfm Object-level surface treatment mark

properties
.note Object-level associative note properties
.wls Object-level weld mark properties
.lev Object-level level mark properties
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File or file name extension Description
.rev Object-level revision mark properties
.drmsh Object-level reinforcement mesh properties
.drbr Object-level reinforcement properties
.po Object-level pour object properties
.sc Object-level bolt properties
.dsrf Object-level surface treatment properties
.dgr Object-level grid properties
.sbl Object-level symbol properties
.wls Object-level weld mark properties
.drtxt Object-level text properties
.gln Object-level line properties
.grt Object-level rectangle properties
.gci Object-level circle properties
.gar Object-level arc properties
.gpl Object-level polyline properties
.gpg Object-level polygon and cloud properties

View-level drawing settings saved in the \attributes folder

File or file name extension Description
.vi
.vi.copt

View-level view properties

.vclassif

.vclassif.copt
View-level detailed object-level settings

.vpm View-level part mark properties

.vsm View-level bolt mark properties

.vnpm View-level neighbor part mark properties

.vsurfm View-level surface treatment mark properties

.vjm View-level connection mark properties

.vrm View-level reinforcement mark properties

.vnrm View-level neighbor reinforcement mark
properties

.vpom View-level pour object mark properties

.vp View-level part properties

.vs View-level bolt properties

.vnp View-level neighbor part properties

Customize Tekla Structures for users 95 Files for configuring Tekla Structures



File or file name extension Description
.vsurf View-level surface treatment properties
.vw View-level welding properties
.vr View-level reinforcement properties
.vnr View-level neighbor reinforcement properties
.vrmp View-level reference object properties
.vpo View-level pour object properties
.vg View-level grid properties
.vf View-level filter properties
.vnf View-level neighbor part filter properties

Files related to drawing level properties for single-part drawings saved
in \attributes folder

File or file name extension Description
.wd
.wd.copt

Single-part drawing properties

.wd.more Single-part drawing user-defined attributes

.wdf Single-part drawing filter properties

.wdnf Single-part drawing neighbor part filter
properties

.wdl Single-part drawing layout properties

.wdl.more Single-part drawing user-defined layout
attributes

.wdv Single-part drawing view properties

.wdv.more Single-part drawing user-defined view
attributes

.wdc Single-part drawing section view properties

.wdc.more Single-part drawing user-defined section view
attributes

.wdd Single-part drawing dimension properties

.wdd.more Single-part drawing user-defined dimension
attributes

.wdcd Single-part drawing dimensioning properties

.wdcd more Single-part drawing user-defined
dimensioning attributes

.wpm Single-part drawing part mark properties

.wsm Single-part drawing bolt mark properties
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File or file name extension Description
.wnpm Single-part drawing neighbor part mark

properties
.wdsurfm Single-part drawing surface treatment mark

properties
.wdsurfm.more Single-part drawing user-defined surface

treatment mark attributes
.wjm Single-part drawing connection mark

properties
.wdp Single-part drawing part properties
.wds Single-part drawing bolt properties
.wds.more Single-part drawing user-defined bolt

attributes
.wdnp Single-part drawing neighbor part properties
.wdnp.more Single-part drawing user-defined neighbor

part attributes
.wdsrf Single-part drawing surface treatment

properties
.wdsrf.more Single-part drawing user-defined surface

treatment attributes
.wdgr Single-part drawing grid properties
.wdgr.more Single-part drawing user-defined grid

attributes
.wdr Single-part drawing protection properties
.wdr.more Single-part drawing user-defined protection

attributes

Files related to drawing level properties for assembly drawings saved
in the \attributes folder

File or file name extension Description
.ad Assembly drawing properties
.ad.more Assembly drawing user-defined attributes
.adf Assembly drawing filter properties
.adnf Assembly drawing neighbor part filter

properties
.adl Assembly drawing layout properties
.adl.more Assembly drawing user-defined layout

attributes
.adv Assembly drawing view properties
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File or file name extension Description
.adc Assembly drawing section view properties
.add Assembly drawing dimension properties
.add.more Assembly drawing user-defined dimension

attributes
.adcd Assembly drawing dimensioning properties
.adcd.more Assembly drawing user-defined dimensioning

attributes
.apm Assembly drawing part mark properties
.asm Assembly drawing bolt mark properties
.anpm Assembly drawing neighbor part mark

properties
.adsurfm Assembly drawing surface treatment mark

properties
.adsurfm.more Assembly drawing user-defined surface

treatment mark attributes
.ajm Assembly drawing connection mark

properties
.adp Assembly drawing part properties
.adp.more Assembly drawing user-defined part

attributes
.ads Assembly drawing bolt properties
.adnp Assembly drawing neighbor part properties
.adnp.more Assembly drawing user-defined neighbor part

attributes
.adsrf Assembly drawing surface treatment

properties
.adsrf.more Assembly drawing user-defined surface

treatment attributes
.adw Assembly drawing welding properties
.adw.more Assembly drawing user-defined welding

attributes
.adgr Assembly drawing grid properties
.adgr.more Assembly drawing user-defined grid

attributes
.adr Assembly drawing protection properties
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Files related to drawing level properties for cast unit drawings saved in
the \attributes folder

File or file name extension Description
.cud
.cud.copt

Cast unit drawing properties

.cud.more Cast unit drawing user-defined attributes

.cudl Cast unit drawing layout properties

.cudl.more Cast unit drawing user-defined layout
attributes

.cudv Cast unit drawing view properties

.cudv.more Cast unit drawing user-defined view
attributes

.cudc Cast unit drawing section view properties

.cudc.more Cast unit drawing user-defined section view
attributes

.cudd Cast unit drawing dimension properties

.cudd.more Cast unit drawing user-defined dimension
attributes

.cudcd Cast unit drawing dimensioning properties

.cudcd.more Cast unit drawing user-defined dimensioning
properties

.cupm Cast unit drawing part mark properties

.cusm Cast unit drawing bolt mark properties

.cunpm Cast unit drawing neighbor part mark
properties

.cudsurfm Cast unit drawing surface treatment mark
properties

.cudsurfm.more Cast unit drawing user-defined surface
treatment mark attributes

.cudrm Cast unit drawing reinforcement mark
properties

.cudrm.more Cast unit drawing user-defined reinforcement
mark attributes

.cudp Cast unit drawing part properties

.cudp.more Cast unit drawing user-defined part attributes

.cuds Cast unit drawing bolt properties

.cuds.more Cast unit drawing user-defined bolt attributes

.cudnp Cast unit drawing neighbor part properties

.cudnp.more Cast unit drawing user-defined neighbor part
attributes
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File or file name extension Description
.cudsrf Cast unit drawing surface treatment

properties
.cudsrf.more Cast unit drawing user-defined surface

treatment attributes
.cudr Cast unit drawing reinforcement properties
.cudr.more Cast unit drawing user-defined reinforcement

attributes
.cudw Cast unit drawing welding properties
.cudw.more Cast unit drawing user-defined welding

attributes
.cudgr Cast unit drawing grid properties
.cudgr.more Cast unit drawing user-defined grid attributes
.cudrp Cast unit drawing protection properties
.cudrp.more Cast unit drawing user-defined protection

attributes
.cuf Cast unit drawing filter properties
.cunf Cast unit drawing neighbor part filter

properties

Files related to drawing level properties for general arrangement
drawings saved in the \attributes folder

File or file name extension Description
.gd
.gd.copt

General arrangement drawing properties

.gclassif

.gclassif.copt
General arrangement drawing detailed
object-level settings

.gd.more General arrangement drawing user-defined
properties

.gdl General arrangement drawing layout
properties

.gdl.more General arrangement drawing user-defined
layout attributes

.gdv General arrangement drawing view
properties

.gdv.more General arrangement drawing user-defined
view attributes

.gdd General arrangement drawing dimension
properties
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File or file name extension Description
.gdd.more General arrangement drawing user-defined

dimension attributes
.gdcd General arrangement drawing dimensioning

properties
.gdcd.more General arrangement drawing user-defined

dimensioning attributes
.gpm General arrangement drawing part mark

properties
.gsm General arrangement drawing bolt mark

properties
.gnpm General arrangement drawing neighbor part

mark properties
.gdsurfm General arrangement drawing surface

treatment mark properties
.gdsurfm.more General arrangement drawing user-defined

surface treatment mark attributes
.gjm General arrangement drawing connection

mark properties
.gdrm General arrangement drawing reinforcement

mark properties
.gdrm.more General arrangement drawing user-defined

reinforcement mark attributes
.gnrm General arrangement drawing neighbor

reinforcement mark properties
.gpom General arrangement drawing pour object

mark properties
.gdp General arrangement drawing part properties
.gdp.more General arrangement drawing user-defined

part attributes
.gds General arrangement drawing bolt properties
.gds.more General arrangement drawing user-defined

bolt attributes
.gdnp General arrangement drawing neighbor part

properties
.gdnp.more General arrangement drawing user-defined

neighbor part attributes
.gdsrf General arrangement drawing surface

treatment properties
.gdw General arrangement drawing welding

properties
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File or file name extension Description
.gdw.more General arrangement drawing user-defined

welding attributes
.gdr General arrangement drawing reinforcement

properties
.gdr.more General arrangement drawing user-defined

reinforcement attributes
.gnr General arrangement drawing neighbor

reinforcement properties
.gpo General arrangement drawing pour object

properties
.gpbr General arrangement drawing pour break

properties
.gdrmp General arrangement drawing reference

object properties
.gdrmp.more General arrangement drawing user-defined

reference model attributes
.gdgr General arrangement drawing grid properties
.gdgr.more General arrangement drawing user-defined

grid attributes
.gdrp General arrangement drawing protection

properties
.gdrp.more General arrangement drawing user-defined

protection attributes
.gdf General arrangement drawing filter

properties
.gdnf General arrangement drawing neighbor part

filter properties

Files related to drawing level properties for multidrawings saved in the
\attributes folder

File or file name extension Description
.md Multidrawing properties
.md.more Multidrawing user-defined attributes
.mdl Multidrawing layout properties
.mdl.more Multidrawing user-defined layout attributes
.mdr Multidrawing protection properties
.mdr.more Multidrawing user-defined protection

attributes
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Files common to all drawings and files in the \drawings folder

File or file name extension Description
.dg Drawing files
.ldb Drawing export layer properties
.ldr Drawing link properties
.cs Section symbol properties
.detail Detail symbol properties
.fas Text file properties
.fhl Hyperlink properties
.dsf Drawing selection filter properties. This file is

saved when you select the Drawing -->
Selection filter check box in the Filter or
Selection Filter properties.

.GridsDimXml

.ShapeDimXml

.HolesDimXml

.FilterDimXml

.OverallDimXml

.RecessesDimXml

.SecPartsDimXml

Dimensioning rules

.dg.DPM Drawing snapshot files in the\<model>
\drawings\snapshots sub-folder. The files
are created either automatically or based on
a user request.

To create a snapshot of a drawing
automatically at the same time that you
create the drawing, set the advanced option
XS_DRAWING_CREATE_
SNAPSHOT_ON_DRAWING_CREATION to 
TRUE. For more information about creating
snapshots, see Snapshots in drawings.

Files related to IFC export in the \IFC folder

File or file name extension Description
.ifc Exported IFC files
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Files related to NC (numerical control) in the \DSTV_Profiles folder

File or file name extension Description
.nc1 NC (numerical control) files

Files in the \ModelSharing folder

File or file name extension Description
ModelSharingService.key Key file that is needed to share models in

Tekla Model Sharing.
FileSharing.ini File sharing settings in Tekla Model Sharing.
FileSharing.xml File needed for file sharing in Tekla Model

Sharing.

Files in the \ProjectOrganizer folder

File or file name extension Description
.db Created when the Organizer is opened for

the first time. Contains all property template
and category information used in the model.

The database name shows the version of the
database, such as ProjOrg000020.db.

.propertytemplate Created when you export a property template
from the Organizer.

.category Created when you export a category from the
Organizer.

Files related to reports in the \Reports folder

File or file name extension Description
.xsr Tekla Structures reports

Files in the \SessionFileRepository folder

File or file name extension Description
Files in the
SessionFileRepository
folder

Backup copies of the files that are updated or
deleted during a Tekla Model Sharing read in.

SessionFile.db Database for managing model folder files in
Tekla Model Sharing.

.storage Configuration file for SessionFile.db.
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Files related to shapes in the \ShapeGeometries and \Shapes folders

File or file name extension Description
.tez
.xml

Shape geometry descriptions in the
\ShapeGeometries folder.

.xml Shape descriptions in the Shapes folder.

Files in the \screenshots folder

File or file name extension Description
.png Screenshot taken in Tekla Structures.

Files related to Unitechnik export in the \UT_files folder

File or file name extension Description
.uni Exported Unitechnik files

File storing options and advanced options

WARNING Changing an advanced option value in .ini files located outside of the
model folder does not affect existing models.

You can only change advanced options in the Advanced Options dialog box or
in the options.ini file located in the model folder. You cannot change
advanced options in an options.ini file located in folders defined for the
advanced options or .

The .ini files are read when you open an existing model, but only new
advanced options that do not exist in options_model.db or
options_drawings.db, such as options that are not yet in the Advanced
Options dialog box but have been added in the software are inserted.

What happens at model creation
When a new model is created, Tekla Structures reads the values of model-
specific options and advanced options from the standard.opt file, and from
the .ini files in a certain reading order (page 49). Tekla Structures creates the
databases options_model.db and options_drawings.db, and the
options.ini file under the model folder.
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What happens when you change model-specific options or advanced
options
• When you change a model-specific (page 126) option or advanced option in

the Options or Advanced Options dialog box, the settings are applied
when you press OK or Apply.

• The updated model-specific option or advanced option settings are saved
in options_model.db and options_drawings.db under the model
folder when the model is saved.

• There are also some special model-specific advanced options that can be
updated from the options.ini file located in the model folder, such as
new advanced options that are not yet in the Advanced Options dialog
box.

• You can change model-specific advanced options only in the Advanced
Options dialog box or in the options.ini file that is located in the model
folder.

• You can change model-specific options only in the Options dialog box
manually or by loading standard.opt file values in the dialog box.

What happens when you change user-specific options or advanced
options
• When you change a user-specific (page 126) option or advanced option in

the Options or Advanced Options dialog box, the settings are saved when
you press OK or Apply.

The settings are saved in the options.bin file in the ..\Users\<user>
\AppData\Local\Trimble\Tekla Structures\<version>
\UserSettings folder.

• You can change user-specific advanced options only in the Advanced
Options dialog box.

• You can change user-specific options only in the Options dialog box
manually or by loading standard.opt file values in the dialog box.

What happens when you save customized settings in the Options
dialog box
When you save your own model-specific settings in the Options dialog box
(page 107) by pressing Save, the standard.opt file is saved in the
\attributes folder under the model folder.

Create a list of advanced options and their values

• To create a complete list of advanced options in a text file, click Write to
file in the Advanced Options dialog box. 
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The list shows the name of the advanced option, current value and type.

For more information about the standard.opt file, see Standard.opt
settings

Settings in the Options dialog box
The Options dialog box (File menu > Settings > Options) contains the current
values for a number of Tekla Structures settings.

Check the settings before you start modeling and change them, if necessary.

The model-specific (page 126) settings in this dialog box are saved in the
options_model.db and options_drawings.db databases in the model
folder, and the user-specific (page 126) settings in options.bin in your local
<user> folder. Changing user- or model-specific options in the Options dialog
box does not require Tekla Structures restart.

You can also save your own settings by using the Save button. Then the
standard.opt file is saved in the \attributes folder under model folder.
You might want to copy this file to your firm folder. When you create a model,
the standard.opt is read from the firm folder.

The options in the Options dialog box are described below.

Clash check settings

NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

Depending on how the objects selected for clash checking have been modeled,
different clash check settings are used. For example, if you have modeled
embeds as studs, steel parts, or reinforcing bars, respectively either bolt
settings, part settings, or reinforcement settings are relevant.

NOTE Tekla Structures uses a hard-coded tolerance when checking clashes between
native parts. If native parts overlap less than 0.25 mm, clashes are not
reported.

Option Description
Allowed penetration volume Defines the allowed clash check

tolerance if small collisions are
acceptable and can be ignored.

If the clashing volume is smaller than
the given value, for example 1 mm3,
then the clash is not reported.

Enter the value in the current volume
units.
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Option Description
Clash check between bolt and
bolted part

Defines whether the model is checked
for clashes that occur between bolts
and the related bolted parts.

If you select Yes, Tekla Structures will
check the bolts against the real
geometry of the bolted part profiles
including roundings, and using the
real bolt dimensions.

Define the clash check clearance
area for bolts

Use to check if bolts collide with parts
and if there is enough space to fix the
bolts.

Enter the clearance dimensions in
relation to the bolt head or nut
diameter d (the larger value), and the
nut thickness t. The clearance in front
of the bolted parts is the same as the
bolt length.

If you do not enter a value, Tekla
Structures uses the default value.

If you clear the check boxes, the
clearance will be zero.

If Tekla Structures cannot find the bolt
head or nut diameter in the bolt
catalog, it uses the shank diameter
instead.

Exact solid weld clash check Defines whether the model is checked
for duplicate and overlapping welds
and for clashes that occur between
welds and other objects (such as
parts and bolts).

If you select Yes, Tekla Structures will
check the welds against other welds,
against bolts, and against the real
geometry of the part profiles
including roundings, and using the
weld solid dimensions with normal
accuracy.

Reinforcing bar vs steel part
clearance (negative value to allow
overlap)

Defines the minimum clearance or
the allowed overlap for reinforcing
bars when they are checked against
steel parts.

To allow reinforcing bars to overlap
steel parts and to ignore the ribs of
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Option Description
bars, enter a negative value. The
maximum overlap is the actual bar
radius.

Tekla Structures only checks the
distance from bar side to part. Tekla
Structures does not check the
distance from bar end to part.

If you clear the check box, Tekla
Structures will not check the
clearance.

Reinforcing bar clearance (negative
value to allow overlap)

Defines the minimum clearance or
the allowed overlap for reinforcing
bars when they are checked against
other reinforcing bars.

To allow reinforcing bars to overlap,
enter a negative value.

If you clear the check box, Tekla
Structures will not check the
clearance.

Reinforcing bar cover thickness Defines the reinforcing bar cover
thickness.

Tekla Structures checks the cover
thickness against the part that the
reinforcing bar belongs to. Tekla
Structures only checks the distance
from bar side to part surface. Tekla
Structures does not check the
distance from bar end to part surface.
If the bar penetrates a part surface, a
clash is reported, even if the bar is
completely inside a cast unit or pour.

If you clear the check box, Tekla
Structures will not check the cover
thickness.

Components settings

Tekla Structures uses the information about the Components tab when it
creates parts using system components.

Component properties defined in component dialog boxes override these
settings. Tekla Structures only uses these settings if the corresponding boxes
in the component dialog boxes are empty.
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If you change settings here, Tekla Structures only applies the new settings to
components you subsequently create. Components you created prior to
changing the preferences are not affected.

NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

Option Description
Profile names Defines parametric profile prefixes for plates. It is

important that profile names are set up correctly
so that you can use filters and wizards effectively.

Profile names must exist in the profile catalog. If
you want to use a parametric profile that does not
have a name in the catalog, first add it to the
Profile Catalog, then enter it here. Tekla
Structures uses the Folded plate prefix when you
use the folded plates in components.

Bolts In components, Tekla Structures uses Factor of
bolt edge distance and Compare edge distance
to to check that the bolts it creates are not too
close to the edge of a part, and warns you if they
are. Check that Factor of bolt edge distance is set
according to the standard you are using. The
default edge distance setting depends on your
environment.

Compare edge distance defines whether the edge
distance checks are based on bolt or hole
diameter.

To define the default bolt properties to use in
connections, select a Bolt standard and Bolt size.

Parts Part material defines the default part material
grade.

Part start numbers defines start numbers for parts
that are Welded to primary and Welded to
secondary, Loose parts, and Assembly loose
parts.

Cross-check these settings against the numbering
series you define to make sure they do not overlap.
If they overlap, Tekla Structures might create two
non-identical parts with the same part number.
This generates an error in the Numbering history
log file.
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Drawing dimensions settings

NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

Option Description
Exaggeration This setting defines the default values for

Exaggeration limit and Exaggeration scaling.

When you enable the exaggeration of the
dimensions, a drawing dimension that is narrower
than the defined limit is expanded. Exaggeration
limit defines the default value for this limit.

Exaggeration scaling defines whether you are
using Paper or Model as the exaggeration scaling
method:

• If you select Paper, the exaggeration limit is
multiplied by the view scale.

• If you select Model, and the scale is 1:10, all the
dimensions smaller than 10 mm are
exaggerated regardless of the drawing scale.

Absolute dimensions Show zero in absolute dimensions --> Yes shows
zero at the zero points in absolute dimensions.

Draw absolute dimension values parallel to
dimension line --> Yes shows dimensions parallel
to dimension lines in absolute dimensions.

Dimensions in tags Units, Format and Precision define the default
unit, format and precision used in dimension tags.

Available units: mm, cm, m, foot - inch, cm / m,
inch, feet.

Available formats: ###, ###[.#], ###.#, ###[.##],
###.##, ###[.###], ###.###, ### #/# and ###/
##.###.

Available precision: 0.00, 0.50, 0.33, 0.25, 1/8, 1/16,
1/32, 1/10, 1/100, 1/1000

Show dimension in
middle tag of
automatic dimension

Defines whether you want to create dual
dimension tags in assembly, single-part, cast unit,
or general arrangement drawings.

When Tekla Structures creates the drawing, it adds
the lower dimension tag in the selected unit,
format and precision.
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Option Description
Dimension line Dimension line extension length for line arrow

defines the length of the line extension for
dimensions that have line arrows.

Note that line extensions are not applied to
dimensions that have different arrows from line
arrows, and certain knock-off dimension types.

Drawing objects settings

NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

Option Description
Edge chamfer Line color defines the default line color of the

edge chamfers in drawings.

Line type defines the default line type of the edge
chamfers in drawings.

These values are overridden by the values set in
the Edge Chamfer Properties dialog box.

General settings

NOTE: On this page, Autosave settings are user specific. All other settings are
model specific. Changing the settings does not require Tekla Structures restart.

Option Description
Autosave Autosave interval: Autosave after every xx

modeling or editing commands defines how
often Tekla Structures automatically saves a model
and a drawing.

This number represents the number of commands
you have given. For example, if you create many
objects without interrupting (Esc), it counts as one
command.

Autosave after creating every xx drawings
defines the number of drawings after which Tekla
Structures automatically saves your work.

For more information, see:

Save a model

Autosaving in multi-user mode

Customize Tekla Structures for users 112 Files for configuring Tekla Structures



Option Description
Default adaptivity Off means that adaptivity is not defined.

Relative defines that handles retain their relative
distances to the nearest part faces in relation to
the part’s overall size.

Fixed defines that handles retain their absolute
distances to the nearest part faces.

You can also modify the adaptivity settings for each
part separately. These modifications override the
default settings in the Options dialog box.

For more information about adaptivity, see Modify
the adaptivity of reinforcement, surface treatment,
or edge chamfers in parts.

Load modeling settings

Use the settings on the Arrow length tab to scale loads in model views.

Use the settings on the other tabs of this page to define the building code and
safety factors Tekla Structures uses in load combination.

NOTES:

• Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

• You should not need to change the building code or safety factors during
the project. If you change these settings, you will also need to change the
load group types and check the load combinations.

Numbering settings

NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

Option Description
Position number
separator

Defines the default position number separator.
The options are dot (.), comma (,), slash (/), and
hyphen (-).

Rebar position number
separator

Defines the default reinforcing bar position
number separator. The options are dot (.), comma
(,), slash (/), and hyphen (-).

Part number type Defines the default part number type. The options
are Part number and Combined assembly / part
number.
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Orientation mark settings

NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

For details of what affects the part orientation and how, see Indicate part
orientation.

Option Description
North direction Project north (degrees counter clockwise from

global x) defines which direction is north in the
model. Enter the value in degrees counter-
clockwise from the global x axis.

Part viewing direction Defines which direction parts are viewed from in
drawings.

Beam skew limit

Column skew limit

Tekla Structures uses limit angles to determine
whether a part is a beam or a column when
creating orientation marks. Tekla Structures treats
parts outside these limits as braces.

Parts skewed more than 80° are columns.

Parts skewed less than 10° are beams.
Preferred location for
mark

Defines the location of part marks in drawings, to
the left or right end of the part.

Mark always to center
of column

This setting only affects columns.

Yes places part marks in the center of columns in
plan views. To indicate part orientation, include
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Option Description
compass direction (Face direction) in the part
mark instead.

No places part marks on the same flange in
general arrangement and assembly drawings.

Rebar set settings

NOTE: Settings on this page are model specific and only apply to rebar sets,
not to single reinforcing bars, reinforcing bar groups, or reinforcement
meshes. Changing the settings does not require Tekla Structures restart, but
you need to update the existing rebar sets in the model. To do this, go to the
Rebar tab on the ribbon and click More --> Regenerate.

Option Description
Covers and locations tab
Concrete cover Under Part global coordinate system, define the

default concrete cover thickness between the rebar
set bars and the following faces of concrete parts:

• Top

• Bottom

• Sides

To use the parts' local coordinate system, under
Part local coordinate system, define the default
concrete cover thickness at the following faces of
concrete parts:

• Top

• Bottom

• Front

• Back

• Start

• End

You can also define concrete cover settings for
each concrete part separately. These modifications
override the default settings in the Options dialog
box.

Layer prefix Under Part global coordinate system and/or
Part local coordinate system, define the default
bar layer prefixes at different faces of concrete
parts.

You can also define bar layer settings for individual
rebar sets or leg faces, or for individual bars using
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Option Description
the user-defined attributes of property modifiers.
These modifications override the default settings in
the Options dialog box.

Links Define the bar layer prefix for rebar set bars that
have four or more legs, for example closed
stirrups.

General tab
Minimum lengths to be
created

Define Minimum bar length to prevent Tekla
Structures from creating reinforcing bars that are
too short. This setting is primarily for straight bars.
Enter the minimum bar length as Distance or as
Coefficient of bar diameter.

Define Minimum straight start/end leg length
for bent reinforcing bars. Enter the minimum leg
length as Distance or as Coefficient of bar
diameter.

These settings are also available in the Rebar set
properties and in the Rebar property modifier
properties.

Rounding and step tapering tab
Rounding Define whether the lengths of straight bars, first

and last legs, and intermediate legs are rounded in
the model, and whether the bar lengths are
rounded up, down, or to the nearest suitable
number according to the rounding accuracy.

At splitter locations, define how much the bar
lengths can be rounded up.

Rounding settings are also available in the Rebar
set properties and in the Rebar property
modifier properties.

Step tapering Define the tapering step values for straight bars,
first and last legs, and intermediate legs.

Step tapering settings are also available in the
Rebar set properties and in the Rebar property
modifier properties.

Units and decimals settings

NOTE: Settings on this page are model specific. Changing the settings does not
require Tekla Structures restart.

The number located to the right of each option indicates the number of
decimals. The number of decimals affects the input and storage accuracy.
Always use a sufficient number of decimals.
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For more information about unit and decimal settings, see Change units and
decimals.

Option Units
Modeling tab
Length mm

cm

m

in (decimal)

ft (decimal)

ft-in
Angle °

rad
Spring constant kg/m

kg/cm

kg/mm

T/m

T/cm

T/mm

N/m

N/cm

N/mm

daN/m

daN/cm

daN/mm
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Option Units
kN/m

kN/cm

kN/mm

Ibf/in

Ibf/ft

kip/in

kip/ft
Rot. spring constant kgm/rad

kgm/°

Tm/rad

TM/°

Nm/rad

Nm/°

daNm/rad

daNm/°

kNm/rad

kNm/°

Ibf-in/rad

Ibf-in/°

Ibf-ft/rad

Ibf-ft/°

kip-in/rad

kip-in/°

kip-ft/rad

kip-ft/°
Factor (no units)
Force kg

T

N

daN

kN

Ibf

kip
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Option Units
Distributed load kg/m

T/m

N/m

daN/m

kN/m

Ibf/in

Ibf/ft

kip/in

kip/ft
Surface load kg/m2

T/m2

N/m2

daN/m2

kN/m2

psi

psf

ksi

ksf
Moment kgm

Tm

Nm

daNm

kNm

Ibf-in

Ibf-ft

kip-in

kip-ft
Distributed moment kgm/m

Tm/m

Nm/m

daNm/m

kNm/m
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Option Units
Ibf-ft/ft

kip-ft/ft
Temperature °C

°F

°K
Deformation mm

cm

m

in (decimal)

ft (decimal)

ft-in
Catalogs tab
Section dimension mm

cm

m

in (decimal)

ft (decimal)

in

ft-in
Angle °

rad
Area mm2

cm2

m2

in2

ft2

Section modulus mm3

cm3

m3

in3

ft3
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Option Units
Moment of inertia mm4

cm4

in4

Radius of inertia mm

cm

m

in (decimal)

ft (decimal)

ft-in
Torsion constant mm4

cm4

in4

Warping constant mm6

cm6

in6

Cover area m2/m

mm2/m

cm2/m

ft2/ft

in2/ft

in2/in
Strength kg/m2

kg/cm2

kg/mm2

T/m2

T/cm2

T/mm2

N/m2

N/cm2

N/mm2

daN/m2
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Option Units
daN/cm2

daN/mm2

kN/m2

kN/cm2

kn/mm2

psi

psf

ksi

ksf
Modulus kg/m2

kg/cm2

kg/mm2

T/m2

T/cm2

T/mm2

N/m2

N/cm2

N/mm2

daN/m2

daN/cm2

daN/mm2

kN/m2

kN/cm2

kN/mm2

psi

psf

ksi

ksf
Density kg/m3

T/m3

N/m3
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Option Units
kN/m3

Ibf/ft3

Weight kg

T

N

Ibf

kip
Strain o/oo

%

(No units)
Thermal dilat. coeff. 1/°C

1/°F

1/°K
Ratio o/oo

%

(No units)
Volume mm3

cm3

m3

in3

ft3

Analysis results tab
Length mm

cm

m

in (decimal)

ft (decimal)

ft-in
Angle °

rad
Reinforcement area mm2

cm2

m2
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Option Units
in2

ft2

Transverse reinforc. m2/m

mm2/m

cm2/m

ft2/ft

in2/ft

in2/in
Weight kg

T

N

Ibf

kip
Mass/Length kg/m

T/m

N/m

daN/m

kN/m

Ibf/ft
Volume mm3

cm3

m3

in3

ft3

Force kg

T

N

daN

kN

Ibf

kip
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Option Units
Distributed load kg/m

T/m

N/m

daN/m

kN/m

Ibf/in

Ibf/ft

kip/in

kip/ft
Surface load kg/m2

T/m2

N/m2

daN/m2

kN/m2

psi

psf

ksi

ksf
Moment kgm

Tm

Nm

daNm

kNm

Ibf-in

Ibf-ft

kip-in

kip-ft
Temperature °C

°F

°K
Stress kg/m2

kg/cm2
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Option Units
kg/mm2

T/m2

T/cm2

T/mm2

N/m2

N/cm2

N/mm2

daN/m2

daN/cm2

daN/mm2

kN/m2

kN/cm2

kn/mm2

psi

psf

ksi

ksf
Deformation mm

cm

m

in (decimal)

ft (decimal)

ft-in

Settings defined by advanced options
Advanced options can be specific to the user, model, system, or role.

User-specific advanced options

User-specific advanced options work in the specified way in all of your models
and are saved in your local options.bin file. By default, this file is located in
C:\Users\<user>\AppData\Local\Trimble\Tekla Structures
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\<version>\UserSettings. The folder can be changed using the advanced
option .

In the Advanced Options dialog box, the type is USER. Some user-specific
advanced options require you to restart Tekla Structures after changing the
value.

Model-specific advanced options

Model-specific advanced options work in the specified way only in the current
model. They are saved to options_model.db and options_drawings.db
files in the model folder.

In the Advanced Options dialog box, the type is MODEL or DRAWING.

Some special model-specific options that are not visible in the Advanced
Options dialog box can be changed in the options.ini file in the model
folder.

System-specific advanced options

System-specific advanced options are general to all sessions of Tekla
Structures, and work in the specified way for all users and in all models.

In the Advanced Options dialog box, the type is SYSTEM. A system-specific
advanced option can be stored to options database by clicking SYSTEM next to
the option and changing it to MODEL(SYSTEM). Note that the changed value
only works for the current model. A MODEL(SYSTEM) advanced option can be
changed back to SYSTEM by changing it to SYSTEM, and in this case it will be
removed from the options database. Some system-specific advanced options
require restarting of Tekla Structures after changing the value.

The system-specific advanced options are read from environment .ini files:

• Global system settings are read from common env_global_default.ini
(page 55) in ..\ProgramData\Trimble\Tekla Structures\<version>
\environments\common\. These settings are used in all environments.

• Environment-specific system settings are read from
env_<environment>.ini (page 55) in your environment folder. They override
any settings that are defined on a global level in
env_global_default.ini.

• Role-specific system settings are read from role_<role>.ini (page 56) in
environment folder. They override any settings that are defined on a global
and environment level in env_global_default.ini and
env_<environment>.ini.

• Company level system-specific system settings override all other
system-specific advanced options. You can save them in the firm or project
folders by setting the folders for the advanced options XS_FIRM and XS_
PROJECT.

For more information about how the environment .ini files are read, see
Typical initialization files (.ini files) and their reading order (page 49).
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SYSTEM(ROLE) advanced options

SYSTEM(ROLE) options are typically role specific. The settings are read
from .ini files and are not saved to the databases. When a setting or the type
is changed, the option becomes model-specific and is saved to the databases.

MODEL(ROLE) and DRAWING(ROLE) options are SYSTEM(ROLE) options for
which the type or settings have been changed. The change would be used
when you want the SYSTEM(ROLE) option to be saved with the model to
options_model.db and options_drawings.db under model folder. These
settings can be set back to SYSTEM(ROLE), which will then take into use the
default value.

See also

Typical initialization files (.ini files) and their reading order (page 49)

Change advanced option values in Advanced options dialog box
Use advanced options to configure Tekla Structures to suit the way you work,
or to comply with specific project requirements or industry standards.

NOTE The settings in the Advanced options dialog box override the settings
in any other initialization files. We recommend that you change
advanced options in the Advanced options dialog box in most cases.

In some cases, you might need to change the advanced option in an .ini file,
such as when the advanced option does not exist in the Advanced options
dialog box, or when you want to use the same value in all new models.

For example, you can add the advanced option to an environment .ini file.
For more information about other .ini files, see Typical initialization files (.ini
files) and their reading order (page 49).

1. On the File menu, click Settings --> Advanced options to open the
Advanced Options dialog box.

2. Browse the categories or search to find the advanced option that you
want to set. 

To search for advanced options, enter a search term in the Search field.
To search for the search term in all categories, select In all categories.

You can also use wildcards in searches. For example, to find all advanced
options that have the words anchor and filter, with any characters
between these two words, enter anchor*filter.

3. Select the type of the advanced options from the list next to the option
type. 

• You can change the type of role-specific advanced option between
SYSTEM (ROLE), MODEL (ROLE), and DRAWING(ROLE).
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• When you change the option type to SYSTEM(ROLE), the value
automatically changes to the default value.

• When you enter a value for a SYSTEM (ROLE) option, it changes to
MODEL (ROLE) or DRAWING(ROLE).

• You can change the type of system-specific advanced options from
SYSTEM to MODEL(SYSTEM). When you change the option type to
MODEL(SYSTEM), the value is saved in the options database. If you
change the advanced option back to SYSTEM, the value is removed
from the options database and the value specified in initialization files
is used.

4. Enter the value for the advanced option or select the value from the list. 

• You can use switches with some advanced options, for example, to
define the contents of marks: %TPL:PROJECT.NUMBER%.

If you are defining a switch for an advanced option in the Advanced
Options dialog box, use single percent signs %xxx% around the switch.

If you are defining the switch in an .ini file, use double percent signs
%%xxx%% around the switch.

For example, add %%BOLT_NUMBER%%*D%%HOLE.DIAMETER%% to
define the advanced option XS_BOLT_MARK_STRING_FOR_SIZE in
an .ini file.

• If you need to enter a folder path, you can type a backslash at the end
of the folder path or leave it out.

5. Click Apply or OK. 

TIP To create a complete list of advanced options in a text file, click
Write to file. The list shows the name of the advanced option
together with its current value and type. Note that writing to a file is
only an export of the current settings, it is not another way of
changing the advanced options.

Tekla Structures settings in the Windows registry
The Windows registry stores configuration settings and options in Microsoft
Windows operating systems. Registry settings are used during Tekla Structures
sessions and during Tekla Structures installation.

WARNING Do not change the registry settings. Changing the settings can
cause the operating system to fail. It is possible to view the
registry settings using the Registry Editor in Windows.
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User settings in the Windows registry
Some of the Tekla Structures user settings, such as general options, and dialog
box locations and sizes are stored in the registry.

The settings are saved in a registry key named after the Tekla Structures
version number in the registry branch HKEY_CURRENT_USER\Software
\Trimble\Tekla Structures\<VERSION>.

When you start Tekla Structures for the first time after the installation, Tekla
Structures uses the hardcoded default settings. If you change a setting during
a Tekla Structures session, Tekla Structures saves the change during the
session, or when you exit Tekla Structures. When you open the same version
of Tekla Structures again, the changed setting is used.

When upgrading to a newer Tekla Structures version, you can use the
Migration Wizard tool to copy the settings that you have changed.

Installation settings in the Windows registry
The Tekla Structures installation saves information to the 
HKEY_LOCAL_MACHINE\SOFTWARE\Trimble\Tekla Structures
\<VERSION> registry key.

3.8 Develop applications using Tekla Open API
You can develop your own applications and additional features for Tekla
Structures through the Tekla Open API (application programming interface).
The Tekla Open API is implemented using Microsoft .NET technology.

Applications that are developed using the Tekla Open API to work with Tekla
Structures are called extensions. To develop your own extensions, you must
write program code outside Tekla Structures. Alternatively, you can download
extensions created by others from Tekla Warehouse.

With Tekla Open API you can:

• Record and run user interface actions

By recording and running user interface actions, you can automate routine
tasks, such as creating daily reports.

• Create automation tools

You can create automation tools for frequently needed objects. For
example, with automation tools you can create basic structures or add
typical details to drawings.

• Integrate Tekla Structures with other software

You can use the Tekla Open API and .NET to transfer information between
Tekla Structures and other software, such as Analysis & Design software.

• Create new functionality.
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For more information about the Tekla Open API and extensions, visit the Tekla
Developer Center. Tekla Open API documentation in the Tekla Developer
Center includes:

• API reference

• Release notes

• Programming guides

• Exercises

• Code examples

• Best practices
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4 Start new projects as a Tekla
Structures administrator

Check and customize settings when you start new projects.

4.1 Start the first project
Before you start the first project, plan the project needs and collect the needed
resources for the project.

• Set up the project and firm folders (page 16) to store your customized
settings.

• Use the project folder to store all project-specific files, such as drawing
title block content, or specific custom tools and settings that should not
be used for the entire company. Define the location of the folder using
the advanced option in the settings for all users.

• Use the firm folder and its sub-folders to store all general company-
specific files. Define the location of the folder using the advanced option
in the settings for all users.

• Plan your company's modeling guidelines. 

• Plan the numbering guidelines.

• Set up and import a reference model.

• Define the project properties so that reports and drawings show the
correct information.

• Set up templates (page 149).

• Plan how users will share models and data (page 181).

• Check the material, profile, shape, bolt, and rebar needs for your project.
Plan how you will customize catalogs and databases (page 225) to suit your
project needs. 

Start new projects as a Tekla Structures
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If necessary, you can add new content to the catalogs from other
environments, from Tekla Warehouse, or you can import content created in
other software solutions.

You can optionally also set up a component (page 339) folder in the
Applications & components catalog to ensure that everyone in the project
uses the same components and finds the components faster.

4.2 Start new projects
When you start new projects, check the project settings that you have
previously defined and update them if necessary.

• Set up a new project folder and update the location of the folder for users
using the advanced option.

• Reuse files and settings from previous projects (page 133).

Settings stored in the project and firm folders (page 16) are used
automatically when you start a new project. You can optionally transfer
other files and settings to the new project manually.

• Check and update the project properties.

• Update your company's modeling guidelines document if your company
has started to use any new practices after the previous project.

• Check the material, profile, shape, bolt, and rebar needs for your project.
Clean up the catalogs and databases (page 225) so that they contain the
relevant content for your project.

4.3 Define project properties
Project information is needed many times during a project. Define the project
information at the beginning of a project so that reports and drawings show
the correct information automatically.

You can also update the project properties during the project.

1. On the File menu, click Project properties.

2. Edit the project properties.

When you edit the properties, Tekla Structures highlights the modified
properties in yellow.

3. Click Modify to apply the changes.
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4.4 Reuse files and settings from previous projects or
Tekla Structures versions
You can transfer customized files and settings from a previous project or Tekla
Structures version to reuse them in a new project or Tekla Structures version.

If you use project and firm folders (page 16) to store customized settings, the
settings are used automatically when you start a new project or upgrade to a
new Tekla Structures version.

If you do not use project and firm folders, you must manually transfer the
customized settings to the new project or the new Tekla Structures version.

Check advanced options for the project and firm folders
If you use project and firm folders to store customized files for a model, check
that advanced options point to the folders where the customized files are
located.

1. On the File menu, select Settings --> Advanced Options.

2. Check that the XS_FIRM, XS_PROJECT and 
XS_COMPANY_SETTINGS_DIRECTORY point to the correct folders.

Manually transfer files and settings to a new project
You can copy many types of files using a local or private online Tekla
Warehouse collection. See the Tekla Warehouse instructions for more
information.

You can also copy some information automatically to the new version using
the Migration Wizard tool.

1. Check at least the following files and settings: 

• Advanced options (page 105)

• Files (page 44) related to templates, reports and drawings

• Catalog files (page 69): profile catalog, material catalog, bolt catalog,
bolt assembly catalog, rebar shape catalog

• Conversion files (page 192)

• NC export settings

• Printer catalog settings

• User-defined attributes

• Saved model object properties

2. Re-install extensions for the new Tekla Structures version.
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Import Tekla Structures model and drawings into another
model
You can use the Import model command to import a Tekla Structures model
and drawings to another model. If the imported model is later updated, you
can re-import the updated model.

You can use the Import model command if you want to:

• Import the model into a new blank model due to some issues in the model,
such as when:

• The model is corrupt.

• There are corrupt parts in the model.

• The model will not open.

• A specific function causes an application error, such as numbering or
creating a drawing.

• Merge models.

• Bring an older project into a new Tekla Structures version.

Some things to consider before importing:

• The import only works in one direction. It cannot be used for two-
directional data exchange. For that we recommend using Tekla Model
Sharing.

• If you import into an existing model, fix the possible numbering conflicts by
adding prefixes in the numbering series.

• You cannot import models from older versions of Tekla Structures directly
into a newer version. You must open the model for upgrade.

• You can use the Import model command as a replacement for the old
model dump import. Import the model into an empty Tekla Structures
model created without a model template.

• It is not possible to import a model or parts of it directly into the same
model (for example, if the model folder has been copied in the file system
and then worked on separately). You can work around this, for example, by
first importing the model into a new empty model or by using the Save as
command to create a copy of the model.

• The Import model command only imports the model and the drawings. It
does not import attribute files, or database files, because those files might
be the cause for the problems in the model.

1. Open the Tekla Structures model into which you want to import the other
model.

2. Go to Quick Launch, start typing import model, then select the Import
model command from the list that appears.
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3. Select a model folder to import, then click OK.

If you open a model from a previous Tekla Structures version, the
following message is shown:

To open and save the model in the new version, click Open for upgrade.

Start new projects as a Tekla Structures
administrator

136 Reuse files and settings from previous projects or
Tekla Structures versions



The model objects and drawings are imported, and the changes are shown
using the same listing as is used in Tekla Model Sharing.

With default settings, the Locked attribute is set to Yes in the imported
objects. Locking is controlled by the advanced option 
XS_MODEL_IMPORT_LOCK_OBJECTS in the Import category of the Advanced
options dialog box.

4.5 Define and update user-defined attributes (UDAs)
User-defined attributes (UDAs) are attributes that you can set for an object in a
model or a drawing. You can use UDAs for many purposes, such as in filters,
drawings, reports, export, import, fabrication, erection, and revision handling.

The property pane and many dialog boxes contain UDAs for various objects,
including beams, columns, bolts and drawings. Tekla Structures shows these
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fields when you click the More button in the property pane or the User-
defined attributes button in a dialog box.

When you define new user-defined attributes
You can create your own user-defined attributes that you need in your
company, or for a specific project.

The user-defined attributes can be numbers, text, lists, or dates. They can be
set to be unique for an object or allowed to be copied. They can also be
ignored by numbering or can affect numbering.

• The user-defined attributes are managed in the objects.inp (page 146) file.

To define new user-defined attributes, create your own objects.inp file
in the model, project or firm folder.

• When you define a new user-defined attribute, the maximum length for a
user-defined attribute name is 19 characters. Tekla Structures only looks
for the first 19 characters. For example, Tekla Structures does not consider
TEST_ATTRIBUTE_OBJECT and TEST_ATTRIBUTE_OBJECX to be different.

The attribute name is case-sensitive. Do not use spaces or reserved
characters in attribute names.

• Make the definition of the user-defined attribute unique. A user-defined
attribute cannot have different definitions for different object types, such
as beams and columns.
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• After adding your own user-defined attributes, run the Diagnose and
change attribute definitions command to update the definitions in the
model.

• The object.inp files are merged so that if there are user-defined
attributes in any of the files, they are shown in the user interface. Tekla
Structures merges the files in a way that eliminates duplicate attributes. If
Tekla Structures encounters the same attribute name in different
objects.inp files, the attribute from the first read objects.inp file is
used.

• If you need to have several objects.inp files in the same folder, you can
use a suffix in the file name to use all the files. This way you can have
several objects_<suffix>.inp files in the same folder. The file name
could be objects_precast.inp, for example.

WARNING Do not copy the objects.inp file in the ..\environments\common
\inp\ folder. Copying the file creates unnecessary duplicates and later
objects.inp updates by Tekla Structures can be lost.

Search order of objects.inp files
User-defined attributes are defined in objects.inp files. These files are
located in different folders following the Tekla Structures folder setup, and
they are merged together during startup.

The objects.inp file reads the user-defined attributes in order from the
folders listed below, starting from the model folder:

Folder defined by
advanced option

Advanced option

Model Current model folder
Project XS_PROJECT (your defined project folder)
Firm XS_FIRM (your defined firm folder)
System XS_SYSTEM (your defined system folder)
inp XS_INP (your defined inp folder)

The files are merged so that if there are user-defined attributes in any of the
files, they are shown in the user interface. Tekla Structures merges the files so
that duplicate attributes are removed. If Tekla Structures encounters the same
attribute name in different objects.inp files, the attribute from the first read
objects.inp file is used.

If you need to have several objects.inp files in the same folder, you can use
a suffix in the file name to use all the files. This enables having several
objects_<suffix>.inp files in the same folder. The file name could be
objects_precast.inp, for example.
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If you need to change existing user-defined attribute
definitions
If you need to change the existing user-defined attributes, such as changing
the value_type, create a new user-defined attribute instead of modifying the
current one in the objects.inp file. For example, if you change the 
value_type from string to option, the value cannot be changed for parts
that have the property specified with the old value type, and the value is
shown incorrectly in reports or when you inquire objects.

When the advanced option XS_DIAGNOZE_AND_REPAIR_WRONG_UDA_TYPE is
set to TRUE, you can use Diagnose & repair --> Diagnose and change
attribute definitions to detect and repair the incorrect UDA value types by
reverting the value types to the default values. The command checks that the
UDA value types, such as string or option, defined in the objects.inp file
match their values defined in environment.db. A mismatch can happen if
you change the value types after the UDA values have been assigned.

Update definitions of user-defined attributes (UDAs) in a
model
When you have changed definitions of a user-defined attribute by modifying
the objects.inp file, update the definitions in the model.

1. Open the model.

2. On the File menu, click Diagnose & repair.

3. In the Utilities section, click Diagnose and change attribute definitions.

The Diagnose & Change Attribute Definitions dialog box opens.

4. Select an attribute from the list on left side to see the comparison of
current definitions and objects.inp definitions.

5. In the Object classes with Objects.inp differences compared to
current settings list, select the definitions that you want to update.

6. Click Change current settings to selected Objects.inp settings.

Environment database file
To ensure consistent model behavior when a model is used with different
roles, the environment database file (environment.db) contains the
definitions of the user-defined attributes (UDAs) used in the model.

When you create a new model, Tekla Structures merges the definitions from
your objects.inp (page 146) files to the environment.db file. Later, when you
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add new user-defined attributes to the objects.inp file, the definitions are
saved in environment.db when you open the model.

You can modify your user-defined attributes in an objects.inp file but the
changed definitions are not automatically applied. If there are conflicts
between definitions in an objects.inp file and definitions the
environment.db file, the definitions in environment.db are used. To see the
conflicts, run the Diagnose and change attribute definitions command,
then select the attribute definitions that you want to update in the
objects.inp file.

NOTE Do not directly edit the environment.db file.

Example: Create and update a user-defined attribute (UDA)
This example shows how to create your own user-defined attribute (UDA) and
update the model to use the changed attribute definition.

Example: Create a user-defined attribute

1. Create a new model and save it.

The user-defined attributes in the model are merged from objects.inp
files and Tekla Structures saves the attribute definitions in the
environment.db file in the model folder.

2. Close the model.

3. Create an input file called objects.inp in the model folder by using a
standard text editor.

4. Enter the following information in the objects.inp file:

/
**************************************************************************
*/
/* Part attributes */
/
**************************************************************************
*/
part(0,"Part")
{
 /* User defined tab page */
 tab_page("My UDA tab")
 {
 /* User defined attribute */
 attribute("MY UDA", "My UDA", string,"%s", no, none, "0,0", "0,0")
 {
 value("", 0)
 }
 }
 tab_page("My UDA tab", "My UDA tab", 19)
 modify (1)
 }
 /
**************************************************************************
*/
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 /* Column attributes */
 /
**************************************************************************
*/
 column(0,"j_column")
 {
 /* Reference to the user defined tab page that is defined above in */
 /* the part() section: */
 tab_page("My UDA tab", "My UDA tab", 19)
 modify (1)

NOTE If you want to create a user-defined attribute that also affects
numbering, set the special_flag (page 146) property of the
attribute to yes (it is no in the example above). Also, just like in
the example above, the definition of the tab_page must be in the 
part section, and the column (beam, etc.) section must have only
a reference to it.

5. Save the file.

Example: Test the user-defined attribute

1. Open the model.

2. Create a steel column.

3. Double-click the steel column to open its properties in the property pane.

4. Click the More button.

5. Go to the My UDA tab.

6. Enter a value in the My UDA field.

7. Click Modify.

8. Copy the steel column.

9. Select the My UDA check box for the new steel column.

The attribute value is also copied.

10. Close the model.

Example: Modify the user-defined attribute to make it unique

1. Open the objects.inp file in the model folder by using a standard text
editor.

2. Enter unique_ before the user-defined attribute.

/
**************************************************************************
*/
/* User-defined attributes */
/
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**************************************************************************
*/
part(0,"Part")
{
 /* Common tab pages for part attributes */
 tab_page("My UDA tab")
 {
 unique_attribute("MY UDA", "My UDA", string,"%s", no, none, "0,0", "0,0")
 {
 value("", 0)
 }
 }
 tab_page("My UDA tab", "My UDA tab", 19)
 modify (1)
 }
 /
**************************************************************************
*/
 /* Column attributes */
 /
**************************************************************************
*/
 column(0,"j_column")
 {
 tab_page("My UDA tab", "My UDA tab", 19)
 modify (1)
 }

Adding unique_ before the user-defined attribute makes the user-
defined attribute unique. The value of the user-defined attribute is not
copied to another part.

3. Save the file.

Example: Test the unique user-defined attribute

1. Open the model.

2. Enter a value in the My UDA field for a steel column and click Modify.

3. Copy the steel column.

4. Select the My UDA check box for the new column.

5. The value was copied, so the user-defined attribute in the model is not
unique. There is a conflict between the environment.db and
objects.inp definitions.

Example: Update the definitions of user-defined attributes

1. On the File menu, click Diagnose & repair and

2. In the Utilities section, click Diagnose and change attribute definitions.

The Diagnose & Change Attribute Definitions dialog box opens.

3. Select My UDA in the Attribute area on the left.

You can see that My UDA is not unique in the current setting, but it is set
to unique in objects.inp.
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4. Select the definition in the area on the right.

5. Click Change current settings to selected Objects.inp settings.

Now the definition of the user-defined attribute is updated in the model.

If you now copy a steel column that has a value for My UDA, the value is
not copied to the new column.

Add UDAs in reference models
To use user-defined attributes in your reference models, you must add the
UDAs to the objects.inp file if your environment does not contain the
necessary reference model UDAs.

NOTE Do not edit the original objects.inp file under the environments
folder.

To define new user-defined attributes, create your own objects.inp file in
the model, project or firm folder.

This example shows the text you must add to an objects.inp file to create
the UDAs that is shown in the image of the side pane.
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/
**************************************************************************
*/
/* Reference attributes */
/
**************************************************************************
*/
reference(0,"j_Reference_model")
 {
 tab_page("","jd_Parameters",10)
 {
   attribute("VENDOR", "Ref. Model Vendor", string, "%s", no, none, 
"0.0", "0.0")
   {
     value("", 0)
   }
   attribute("DISCIPLINE", "Discipline", string, "%s", no, none, "0.0", 
"0.0")
   {
     value("", 0)
   }
   attribute("PERCENT_COMPLETE", "% Complete", integer, "%s", no, none, 
"0.0", "0.0")
   {
     value("", 0)
   }
   unique_attribute("USER_PHASE", "User Phase", string, "%s", yes, none, 
"0.0", "0.0")
   {
     value("", 0)
   }
}
modify(1)
}
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Properties of the objects.inp file
User-defined attribute definitions in the objects.inp file follow this
structure.

For general information about modifying the definitions, such as file locations
and reading order, see Define and update user-defined attributes (UDAs)
(page 137).

This example shows the main properties of objects.inp:

attribute("MY_INFO_1", "My Info 1", string, "%s", no, none, "0.0", "0.0")
{
    value ("", 0)
}
picture("image_name", 8, 2, 260, 25)

General properties

Property In the example Description
attribute or 
unique_attribu
te

attribute Specifies whether the attribute is a
regular attribute or a non-copyable
attribute.

attribute is a regular attribute,
which is copied with other part
properties.

unique_attribute is a non-
copyable attribute. The value of the
attribute is never copied to another
part. For example, part checking
status attributes usually cannot be
copied.

attribute_name MY_INFO_1 The attribute name is used to find the
attribute value.

Ensure that Tekla Structures does not
already use the attribute name that
you use. Consider using a prefix that
ensures the name is unique, such as
your initials, or an abbreviation of
your company name.

The attribute name is case-sensitive.
Do not use spaces or reserved
characters in attribute names. The
maximum length of the name can be
19 characters.

To include the attribute in a report or
template, add the name of the
attribute to your layout in the
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Property In the example Description
Template Editor. When you run a
report or create a drawing, Tekla
Structures shows the current value of
the attribute.

label_text My Info 1 A label that Tekla Structures shows in
the dialog box.

Some default attributes have prompts
like j_comment, meaning that the
prompt comes from the joints.ail
message file.

value_type string The type of value that the field can
contain:

• integer: whole numbers

• float: numbers that include a
decimal point

• string: text

The maximum string length is 79
characters.

• string_not_modifiable: Text
whose modification is prevented.
A field with the 
string_not_modifiable
property is always shown as
dimmed and it cannot be switched
on or off. The value in the field is
not saved when clicking the Apply
button or modified when clicking
the Modify button.

• option: lists

• date: date with a small calendar

• date_time_min: date and time in
hours and minutes [12:00] with a
small calendar

• date_time_sec: date and time in
hours, minutes, and seconds
[12:00:00] with a small calendar

If you need to change the 
value_type, create a new user-
defined attribute instead of modifying
the current one in the objects.inp
file. For example, if you change the 
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Property In the example Description
value_type from string to option,
the value cannot be changed for parts
that have the property specified with
the old value type, and the value is
shown incorrectly in reports or when
you inquire objects.

When the advanced option
XS_DIAGNOZE_AND_REPAIR_WRONG_
UDA_TYPE is set to TRUE, you can use
Diagnose & repair --> Diagnose and
change attribute definitions to
detect and repair the incorrect UDA
value types by reverting the value
types to the default values. The
command checks that the UDA value
types, such as string or option,
defined in the objects.inp file
match their values defined in
environment.db. A mismatch can
happen if you change the value types
after the UDA values have been
assigned.

field_format %s Definition of the field format in the
dialog box

• %s for strings

• %d for numbers
special_flag no no or yes

For parts: consider in numbering

For drawings: show the attribute
value in Document manager

For other elements: no effect
check_switch none none

This option is not used.
attribute_value_m
ax

0.0 0.0
This option is not used.

attribute_value_m
in

0.0 0.0
This option is not used.
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Picture properties

Property In the example Description
picture picture picture is used for adding images in

user-defined attributes dialog boxes.
image name image_name The name of the image
width 2 The width reserved for the image
height 8 The height reserved for the image
horizontal offset 260 The horizontal distance of the left

edge of the image from the left edge
of the dialog box

vertical offset 25 The vertical distance of the top edge
of the image from the top edge of the
dialog box counted from the lower
edge of the tab section

You can also hide or dim user-defined attributes. For more information, see
How to hide and grey out user-defined attributes.

4.6 Templates
Templates are descriptions of forms and tables that can be included in Tekla
Structures. The contents of the template fields are filled in by Tekla Structures
at run time.

Templates are either graphical or textual. Graphical templates are inserted in
drawing layouts as tables, text blocks, and drawing headers, for example.
Textual templates are used for creating reports.

Tekla Structures includes a large number of standard templates you can use.
Use the Template Editor to modify existing templates, or create new ones to
suit your needs.

Graphical template definitions have the file name extension .tpl. Textual
template definitions have the file name extension .rpt.

The ready-made textual and graphical templates are located under the
environment folders, in ...\ProgramData\Trimble\Tekla Structures
\<version>\environments\. The exact file location may vary depending on
the folder structure of your environment files. Textual and graphical templates,
except mark templates, can also be read from XS_FIRM or XS_PROJECT
folders. For more information on where the templates are searched for, see
Folder search order (page 45).

Examples

Example of a title block:
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Example of an inquiry report:

Example of a part list report:
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For more information on using templates, see Template Editor User's Guide
(page 151) or open the Template Editor Help in the Template Editor by clicking
Help --> Contents .

See also

Create a template (page 151)

Template Editor User's Guide
This guide describes how you can use Template Editor to create, modify and
manage template definitions for both reports and drawings.

With Template Editor, you can produce labels, reports and legends allowing
you to gather and produce accurate and targeted information. Tekla Structures
has a number of ready-made templates, and you can use the Template Editor
to modify the existing templates, or create new ones to suit your needs.

Template Editor is also used in other products than Tekla Structures. For this
reason, the term product is used frequently in the content instead of the name
of specific software products. For exact instructions about how to use
Template Editor together with Tekla Structures to create and modify templates,
see the other articles under Templates (page 149).

The Template Editor User's Guide is currently available in English only. The
content is the same as in the Template Editor help. You can find the guide in
the PDF format here: Tekla Structures PDF documentation.

Create a template
1. On the File menu, click Editors --> Template Editor.

2. In the Template Editor, click File > New.
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3. Select the template type and click OK. 

A new empty template is created.

4. Add new rows in the template.

a. To add a new row, click Insert --> Component --> Row .

b. Select a content type for the row, then click OK.

5. Add value fields to get the required data from your Tekla Structures
database.

a. Click Insert --> Value field .

b. Click a point to define the location of the field within the row. 

The Select Attribute dialog box open and prompts you to select an
attribute for the value field.

c. Select an attribute, then click OK.

6. Save the template.

a. Click File --> Save as.

b. Browse to the template folder defined for the advanced option
XS_TEMPLATE_DIRECTORY.

c. In the File name field, enter a name for the template.

d. Click OK.

Create a template in HTML format
Templates in HTML format give you more possibilities for different layout,
fonts, and images. Templates that generate output in HTML format are
graphical and have the file name extension *.html.rpt.

NOTE If you add images to your HTML template (page 165), the images must
be in the ..\Program Files\Tekla Structures\<version>\bin
\applications\Tekla\Tools\TplEd\bitmaps folder. Images in
other folders are not shown in the HTML output.

1. On the File menu, click Editors --> Template Editor.

2. In the Template Editor, click File > New.

3. Select Graphical template, then click OK.

4. Add new rows in the template.

a. To add a new row, click Insert --> Component --> Row .

b. Select a content type for the row, then click OK.

5. Add value fields to get the required data from your Tekla Structures
database.
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a. Click Insert --> Value field .

b. Click a point to define the location of the field within the row. 

The Select Attribute dialog box open and prompts you to select an
attribute for the value field.

c. Select an attribute, then click OK.

6. Add a header for each value field.

a. Click Insert --> Component --> Header...

b. Click Insert --> Text...

c. Enter a heading for the template, and then click OK.

d. Click a point to define the location of the heading in the header row.

7. Save the template:

a. Click File --> Save as

b. Browse to the template folder defined for the advanced option
XS_TEMPLATE_DIRECTORY.

c. In the File name field, enter a name for the template. 

Include the extension *.html.rpt in the file name. For example,
Part_list.html.rpt.

d. Click OK.

Example

1. Header that contains text fields

2. Row that contains two value fields
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Create a .pdf report template
You can create graphical templates to be used for .pdf reports.

1. On the File menu, select Editors --> Template editor.

2. Select File --> New --> Graphical template.

3. Click Edit --> Properties.

4. In Template page properties dialog box, set the page size to match the
target page size (for example A4): 

The size must match one of the sizes defined in the
PaperSizesForDrawings.dat configuration file.

5. Add new rows and value fields to get the required data from your Tekla
Structures database. For more information about adding new rows and
value fields, see Create a template (page 151).

6. Click File --> Save as, and save the report with the file name
extension .pdf.rpt.
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7. Copy the new template to your template folder, such as model or your
company settings folder (XS_FIRM).

You can now create a .pdf report using the new .pdf report template. For
more information, see Create a report.

Example .pdf report

In this report example, the following page size is used:

Below is an example of a report that has been created using this particular
report template.
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Example: Create a template for nested assemblies
This example shows how to produce a template that shows the hierarchical
structure of nested assemblies.
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These steps show how to create a nested assembly structure in a textual
template similar to the one in this picture:

1. On the File menu, click Editors --> Template Editor.

2. In the Template Editor, click File > New.

3. Select Textual template, then click OK.

4. Add four new rows in the template.

a. To add a new row, click Insert --> Component --> Row .

b. Select a content type for the row, then click OK. 

For the first and third row, select the ASSEMBLY content type. For the
second and fourth row, select the PART content type.

5. Use the arrow buttons under Sorting and drawing order to create a
nested assembly structure for the template.

a. Move the second and third row down one level.

b. Move the fourth row down two levels. 

The structure should now look like this:
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6. Add value fields to get the required data from your Tekla Structures
database. 

In this example, the added value fields are assembly or part position,
number, and weight.

a. Click Insert --> Value field .

b. Click a point to define the location of the field within the row. 

The Select Attribute dialog box open and prompts you to select an
attribute for the value field.

c. Select an attribute, then click OK.

7. Modify the layout of the template. For example:

a. Move objects to show the nested assembly structure in the printed
report. 

Select the object that you want to move and drag it to the new
position.

b. Align objects. 

Select the objects that you want to align, right-click, then select an
alignment option. For example, select Align --> Right .

c. Add a header and a footer. 

Click Insert --> Component --> Page header and Insert -->
Component --> Page footer.

Add the required information to the header and footer.

8. Save the template.

Example

This example shows a textual template and a report that has been created
using the template:
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NOTE You can create graphical templates for nested assemblies in the same manner
as textual templates. The difference between graphical and textual templates
is that in a graphical template you can show project and company information
and graphics, such as table outlines, pictures, or symbols.
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Create a template for bending schedules or pull-out
pictures
You can use the Template Editor to create bending schedules or pull-outs
pictures for reinforcement bars and bent meshes, and control the type of
information that is shown in the bending schedules.

1. On the File menu, click Editors --> Template Editor.

2. Click File --> New .

3. Select Graphical template, then click OK.

4. To add a new row, click Insert --> Component --> Row .

5. Select REBAR or MESH as the content type for the row.

6. Add value fields to get the required data from your Tekla Structures
database.

a. Click Insert --> Value field .

b. Click a point to define the location of the field within the row. 

The Select Attribute dialog box open and prompts you to select an
attribute for the value field.

c. Select an attribute, then click OK.

7. Insert a graphical field in your REBAR or MESH content type row.

a. Click Insert --> Graphical Field...

b. Click and drag with the mouse to draw a frame.

8. Double-click the graphical field to open the Graphical Field Properties
dialog box.

9. Click Free attributes and go to the Application tab.

10. Select the required bending diagram attributes. 

You can also define the bending diagram attributes on the User tab. Note
that if the same attribute is set both as User attribute and Application
attribute, the Application attribute takes precedence.

For a list of attributes and values that can be used for bending schedules
in templates, see Bending schedule attributes.

11. Save the template.
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Example
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Autoscaling pull-out pictures
There is a free attribute available for the PULLOUT attribute in graphical
templates that you can use to define the scale type. If you set the free
attribute ScaleType to 1 on the User tab in the Free attributes dialog box,
the pull-out pictures will be scaled to fit the available space in both X and Y
dimensions. As a result, the shape becomes out of proportion, but small
segments can be seen more easily. Note that you can also set this attribute on
the Application tab.

A bending shape might look like this if you do not define the free attribute 
ScaleType:

The same bending shape that uses the free attribute ScaleType with value 1.

Start new projects as a Tekla Structures
administrator

162 Templates



Changing the appearance of pull-out pictures
Tekla Structures uses the settings in the rebar_config.inp file in the system
folder defined by the advanced option XS_SYSTEM to define the appearance of
the pull-out pictures. You can change the colors, lines, and dimension unit,
format, and precision used in pull-out pictures, for example. For a list of
settings and values in rebar_config.inp, see

Bending schedule attributes
This table lists the attributes and values that can be used for bending
schedules in templates.

Attribute Default value Available values
FontName romsim Available template fonts
FontSize 2.0 Available font sizes
FontColor 1 (black) 1 = black

2 = red

3 = bright green

4 = blue

5 = cyan

6 = yellow

7 = magenta

8 = brown

9 = green

10 = dark blue

11 = forest green

12 = orange

13 = gray
RotationAxis 2 0 = by view

1 = by global Z

2 = by local axis
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Attribute Default value Available values
ScaleType 0 0 = no

1 = yes

If you set the free
attribute ScaleType to 
1 for the PULLOUT
attribute, the pull-out
pictures will be scaled to
fit the available space in
both X and Y
dimensions. As a result,
the shape becomes out
of proportion, but small
segments can be seen
more easily.

Exaggeration 1 0 = no

1 = yes
EndMark 1 1 = straight

2 = half arrow

3 = full arrow
Dimensions 1 0 = no

1 = yes
BendingRadius 0 Shows the bending

radius in form of
diameter of the bending
roll.

0 = no

1 = yes
BendingAngle 1 0 = no

1 = yes
ImageWidth Width of the graphical

field multiplied by 4.
Number of pixels

ImageHeight Height of the graphical
field multiplied by 4.

Number of pixels

CouplerSymbols 1 Show srebar coupler and
end anchor symbols in
rebar bending
schedules. Rebar
coupler symbols will be
shown if
CouplerSymbols
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Attribute Default value Available values
property value is set to 1
and disabled if 0 is
entered. The default
value is 1.

Add images in a template
You can add images in graphical templates. For example, you might want to
include a company logo in your drawings.

Tekla Structures supports the following image formats in graphical templates:

• .bmp
• .jpeg
• .jpg
• .png
• .tif
• .tiff
When adding images in templates:

• Do not add very large images because they update very slowly.

• The image might look different in the image editor and in the printout or in
the exported DWG file.

• When you export the drawing as a DWG file, Tekla Structures copies the
images in the same folder as the DWG file. If the image is not in the same
folder, only the name of the image is shown together with an empty frame
instead of the image in the DWG.

• If environments have local symbols, the local symbol folder is also included
in the search path with the common\symbols folder. If the local symbols
folder contains files with the same name as common\symbols folder, the
local symbol file is used.

• When you open the drawing that contains the images that you inserted in
the template, Tekla Structures first looks for the images in the model folder
and then in the \symbols folder in the current environment.

• You can define a folder where Tekla Structures always looks for images
using the advanced option . You can also define a firm folder for your
images.

1. Open an existing graphical template or create a new graphical template in
the Template Editor.

2. Add a new row in the template:

a. To add a new row, click Insert --> Component --> Row .
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b. Select a content type for the row, then click OK.

3. Ensure that you have the row selected, then click Insert > Picture to open
the Select Picture File dialog box. 

If a local symbols folder exists, the contents of that folder are shown by
default. You can browse for the contents of the common\symbols folder
by selecting that folder. If a local symbols folder does not exist, Tekla
Structures shows the contents of the common\symbols folder.

4. If you have images in other folders, you can show these folders in the
Select Picture File dialog box:

a. In the Template Editor, click Options --> Preferences.

b. Go to the File Locations tab.

c. On the Symbols, pictures row, add a new folder separated by a
semicolon (;). 

For example:

The folder that you defined is shown in the Directory list:

5. Select an image from the File list, click OK, and add the image. 

You can adjust the size by dragging from the image handles.

Example

These examples of the Select Picture File dialog box show the folder
structure in different environments.
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In this example, a company logo has been added in a template.
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Content types in templates
When you create a new row in the template, you must select a content type for
the row.

For example, when you add a row, then add a value field, the Template Editor
prompts you to specify the content type. The content type determines which
template attributes you can use on that row.

The available content types are:

Content type Description
ANALYSIS_RIGID_LINK Use to create lists of analysis rigid links.
ANTIMATERIAL Use to create lists of holes and recesses, or parts

removed as a result of a cut.

In Template Editor, the same attributes that are
available for PART are available for ANTIMATERIAL.
However, only the attributes that are useful to be
used with ANTIMATERIAL are shown, including 
NAME, LENGTH, WIDTH, HEIGHT, AREA, PROFILE,
and NUMBER, and user-defined attributes.

ASSEMBLY Use to create lists of assemblies and single parts.
Includes all assemblies containing the selected
parts and bolts.

BOLT Use to create screw and bolt lists. Includes all bolts
connected to selected parts.

CAST_UNIT Use to create lists of cast units.
CHAMFER Use to create lists of the length of the chamfers.
COMMENT Use to create empty rows or rows that only have

textual data or lines anywhere on a template.
CONNECTION Use to create lists of connections.
DRAWING Use to create drawing lists without revision history

information. Use for reports and included
drawings.

HIERARCHIC_CAST_UNI
T

Use to create reports listing subassemblies of
concrete.

HIERARCHIC_OBJECT Use to create lists of various types of hierarchies.
For example, lists hierarchical objects in Organizer.

HISTORY Use to retrieve history information of the model.
You can use this content type with PART, REBAR, 
CONNECTION and DRAWING rows.

The following template attributes can be used with
this content type:
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Content type Description
• TYPE: the type of the historical action, for

example update or numbering.

• USER: the user who made the change.

• TIME: the time the change was made.

• COMMENT: the comment which was entered
upon clicking Save.

• REVISION_CODE: the revision code which was
entered upon clicking Save.

HOLE Use to create lists of holes.
LOAD Use to create lists of loads.
LOADGROUP Use to create lists of load groups.
MESH Use to create lists of meshes.
NUT Use to create lists of nuts. Contains all nuts for

bolts associated with the selected parts.
PART Use to create lists of parts.
POUR_BREAK Use to create lists of pour breaks.
POUR_OBJECT Use to create lists of pour objects.
POUR_UNIT Use to create lists of pour units.
REBAR Use to create lists of reinforcing bars.
REBAR_ASSEMBLY Use to create lists of rebar assemblies.
REFERENCE_MODEL Use to list the reference models.
REFERENCE_OBJECT Use to list the reference model objects in a

reference model.

Only reference model objects that have user-
defined attributes are displayed in reports.

REFERENCE_ASSEMBLY Use to list the reference assemblies in a reference
model.

REVISION Use to create lists of revision marks.
SIMILAR_ASSEMBLY Use to create lists of similar parts.

To use this content type, you need to have an
empty (hidden in output) ASSEMBLY, PART or 
CAST_UNIT row in the row hierarchy above the row
with SIMILAR_* content type:

SIMILAR_CAST_UNIT
SIMILAR_PART
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Content type Description

You cannot have any rows below SIMILAR_* row
content type in the row hierarchy.

Note: Used in drawings to collect similar object
information from the model. All the other attribute
information is collected from visible drawing
objects.

SINGLE_REBAR Use to create lists of individual bars in reinforcing
bar groups.

For example, use it to get the lengths of the
individual bars in tapered reinforcing bar groups.

For rebar sets, SINGLE_REBAR works in the same
way as REBAR.

SINGLE_STRAND Use to create lists of individual prestressed
strands.

STRAND Use to create lists of prestressed strands.
STUD Use to create lists of studs.
SURFACE Use to create lists of surfaces.
SURFACING Use to create lists of surface treatments.
SUMMARY Use to summarize the contents of the row(s) that

are above SUMMARY in the hierarchy.

For example, use PART - SUMMARY hierarchy to
summarize the contents of the PART rows.

TASK Use to create lists of tasks.
WASHER Use to create lists of washers. Contains all washers

for all bolts associated with the selected parts.
WELD Use to create lists of welds.
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Template attribute files (contentattributes.lst)
Template attributes represent object properties. You can use template
attributes in value fields, formulas, and row rules to get the required data from
your Tekla Structures database.

When you output the template, Tekla Structures replaces the attribute with the
actual value of the corresponding object property. For example, if you include
the attribute WEIGHT in a report template, Tekla Structures shows the weight
of the model object in the report.

Template attributes are defined in the following files:

File name Description
contentattributes.lst This is a container file listing all the files that

contain the actual attribute definitions. The
files are added with INCLUDE sentences. The
order of the files included in
contentattributes.lst defines the
reading order of the files.

This file is overwritten in the installation when
you install a newer version of Tekla
Structures. Ensure that you make a copy of
this file before updating.

Generally, there is no need to modify
contentattributes.lst. Do not modify it
if you are not an administrator.

contentattributes_globa
l.lst

This file contains attributes that are hard-
coded into the program. Do not edit this file.

contentattributes_userd
efined.lst

This file contains user-defined attributes, the
same as in the objects.inp file.

This file is overwritten in the installation when
you install a newer version of Tekla
Structures. To use your own attributes in
templates and reports, create a copy of this
file and add the necessary attributes to that
file.

By default, these files are located in ..\Program Files\Tekla Structures
\<version>\bin\applications\Tekla\Tools\TplEd\settings, but the
location might be different in your environment.

The search order for the contentattributes.lst file is defined in the
tpled.ini file. The location of the tpled.ini file is defined by the advanced
option.

The following pointers are allowed in the tpled.ini file:
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• @\ = location of the tpled.ini file

• .\ = location of tpled.exe (C:\Program Files\Tekla Structures
\<version>\bin\applications\Tekla\Tools\TplEd)

To include your own attributes, modify the contentattributes.lst files in
the relevant environment folders. The contentattributes.lst files are
overwritten when you install a new version of Tekla Structures.

User-defined template attributes
User-defined template attributes are defined in the
contentattributes_userdefined.lst file. By default, this file includes
most of the user-defined attributes that are visible in the part properties.

To use your own attributes in templates and reports, make a copy of the file,
rename it appropriately, and add the necessary attributes to that file.

The contentattributes_userdefined.lst file is divided into two sections:

• A list of attribute names and default settings:
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• A list of attributes assigned to content types:

1. The content type of the row in Template Editor

2. The attribute hierarchy in Template Editor

3. Customizable comments, such as the tab name in the user-defined
attributes dialog box

4. The name of the user-defined attribute, must be the same as in the
objects.inp file

Example: Add user-defined template attributes to the Template Editor
This example shows how to add your own user-defined attributes to the
attribute tree in the Template Editor.

Before you start, add your user-defined attribute to the objects.inp file. For
example, you might add an attribute named MY_ATTRIBUTE to the user-
defined properties of drawings.

1. Open the contentattributes_userdefined.lst file in a text editor. 

You can find this file in the \bin\applications\Tekla\Tools\TplEd
\settings folder in the Tekla Structures installation folder.
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2. Save the file with an appropriate name, for example
MY_contentattributes_userdefined.lst, in the same folder.

3. Add MY_ATTRIBUTE to the list of attribute names and, define the settings
as follows: 

4. Add MY_ATTRIBUTE to the list of attributes assigned to content types. 

Select the content type according to which object the attribute is
associated in the objects.inp file. In this example, the content type is 
DRAWING. Add the attribute in the format 
USERDEFINED.<ATTRIBUTE_NAME>.

5. Save the changes.

6. Open the contentattributes.lst file in a text editor.

7. Add the following line in the file: 

[INCLUDE MY_contentattributes_userdefined.lst]
8. Save the changes. 
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The attribute is shown in the attribute tree in Template Editor, under 
DRAWING > USERDEFINED:

Add comments to user-defined template attributes
You can add your own comments to the user-defined attributes in the
Template Editor attribute tree.

1. Open your copy of the contentattributes_userdefined.lst file. 

For example, MY_contentattributes_userdefined.lst. Do not
modify the original contentattributes_userdefined.lst file.

2. Scroll down to the list of attributes assigned to content types.

3. Add your comment inside quotation marks, after the attribute name. 

For example:

4. Save the changes. 
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The comment you added is shown in the attribute tree in Template Editor:

Add hierarchy to user-defined template attributes
You can add your own hierarchy to the Template Editor attribute tree.

WARNING User-defined attributes are case sensitive. Ensure that you enter
the attribute name using the correct case for all characters.

1. Open your copy of the contentattributes_userdefined.lst file. 

For example, MY_contentattributes_userdefined.lst. Do not
modify the original contentattributes_userdefined.lst file.

2. Scroll down to the list of attributes assigned to content types.

3. Define the hierarchy in square brackets, between USERDEFINED. and the
attribute name. 

For example:

NOTE Ensure that you include the periods after the brackets and
between the hierarchies.

4. Save the changes.
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The new hierarchy is shown in the attribute tree:

Tips for templates
These tips can help you to use templates more efficiently.

Using type attributes in calculations

Change text to numeric format

double(GetValue("ASSEMBLY_TOP_LEVEL"))
Change into correct format for calculation (double=decimals)

format(double(GetValue("ASSEMBLY_TOP_LEVEL")),"Length", "mm",
1)
Add all above into calculation formula

format(double(GetValue("ASSEMBLY_TOP_LEVEL")),"Length", "mm",
1)+15000
Another example of the same for part elevation

(double(GetValue("TOP_LEVEL"))-
(double(GetValue("BOTTOM_LEVEL"))))*1000

Change value field content to use imperial units

Advanced option to check if imperial units are in use:

GetValue("ADVANCED_OPTION.XS_IMPERIAL")==TRUE
Translated string call for multi lingual text:
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GetValue("TranslatedText("albl_Diameter_")")
Formatting of units:

format(GetValue("DIAMETER"),"Length","inch-frac", 1/16)
format(GetValue("DIAMETER"),"Length","mm", 1)
Combine all above in a rule:

if GetValue("ADVANCED_OPTION.XS_IMPERIAL")==TRUE then
GetValue("TranslatedText("albl_Diameter_")")+
format(GetValue("DIAMETER"),"Length","inch-frac", 1/16) + "
Inches"
else
GetValue("TranslatedText("albl_Diameter_")")+
format(GetValue("DIAMETER"),"Length","mm", 1)+" mm"
endif

Define customized date format

Use mid function to find year, month and day:

mid("","","") string, offset, n
year:

mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"6","4")
month:

mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"3","2")
days:

mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"0","2")
Combine all above in rule:

mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"6","4")
+"-"+
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"3","2")
+"-"+
mid(format(GetValue("DATE"),"Date","dd.mm.yyyy", ),"0","2")

Assembly or cast unit drawing sheet number

Use match function to find "-" character

match(GetValue("NAME_BASE"),"*-*")
Use of mid function to return only characters after "-"
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mid(GetValue("NAME_BASE"),(1+
(find(GetValue("NAME_BASE"),"-"))),2)
Combine all above in rule

if (match(GetValue("NAME_BASE"),"*-*"))
then mid(GetValue("NAME_BASE"),(1+
(find(GetValue("NAME_BASE"),"-"))),2)
else ""
endif

Use format functions in value fields

You can define the format used in a value field in two ways: In the Value Field
Properties dialog box by filling in the fields for Datatype, Meaning, Unit and
Decimals, or by creating a formula in the Formula field. In formulas, you can
use the format function that converts an attribute value to a formatted
information string.

When you use a format function in a formula, always set the Datatype to Text
in the Value Field Properties dialog box. Leave the other fields in the Format
area empty.

For example, if you want to convert the attribute value to numbers with
decimals in the report, you need to include the conversion function double in
the format function:

The default values for unit and decimals are defined in the
contentattributes_global.lst file. The format function converts the
attribute value to a formatted information string on the basis of what you have
defined in the format function. The format function overrides the definitions in
the contentattributes_global.lst file and settings that you have defined
in the Format area of Value Field Properties dialog box.

Example of the result in a report when you use the formula above:

Mesh Information:
Geometry Size: 4/4-150/150-2750*2000
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Length: 9'-1/4"
Height: 6'-6 3/4"

Example of the result of the formula, when you use set the advanced option 
XS_IMPERIAL to FALSE instead of TRUE:

Mesh Information:
Geometry Size: 4/4-150/150-2750*2000
Length: 2750 mm
Height: 2000 mm

For a list of valid unit and precision strings, see the valuefieldclasses.lst
file located in the ..\Program Files\Tekla Structures\<version>\bin
\applications\Tekla\Tools\TplEd\settings folder. Do not make
changes in this file. Below is an example of the file content, which may change
between Tekla Structures versions.

// 
--------------------------------------------------------------------------
-------------
// 
// - Use only letters, numbers, slashes and underlines.
//
// 
--------------------------------------------------------------------------
-------------
//
// Class               =        units { presicions }

Length                 =        mm, dm, cm, m, inch, ft, yd, inch-frac 
{1/2, 1/4, 1/8, 1/16 }, ft-frac { 1/2, 1/4, 1/8, 1/16 }
Angle                  =        Degrees, radians
Area                   =        mm2, cm2, dm2, m2, sq.inch, sq.ft, sq.yd
Area/length            =        mm2/m, cm2/m, dm2/m, m2/m, in2/in, 
in2/ft, ft2/ft, sq.yd/ft
Volume                 =        mm3, cm3, dm3, m3, cu.in, cu.ft, cu.yd 
Weight                 =        kg, T, N, lbf, kip
Weight/length          =        kg/m, T/m, N/m, daN/m, kN/m, lbf/ft
Density                =        kg/m3, T/m3, N/m3, kN/m3, lbf/ft3
Temperature            =        Kelvin, Celsius, Fahrenheit
Section_modulus        =        mm3, cm3, in3
Moment_of_inertia      =        mm4, cm4, in4
Warping_modulus        =        mm6, cm6, in6
Force                  =        kg, T, N, daN, kN, lbf, kip
Force/length           =        kg/m, T/m, N/m, daN/m, kN/m, lbf/in, 
lbf/ft, kip/in, kip/ft
Force/area             =        kg/m, kg/cm, kg/mm, T/m, T/cm, T/mm, N/m, 
N/cm, N/mm, daN/m, daN/cm, daN/mm, kN/m, kN/cm, kN/mm, lbf/in, lbf/ft, 
kip/in, kip/ft
Moment                 =        kgm, Tm, Nm, daNm, kNm, lbf-in, lbf-ft, 
kip-in, kip-ft
Moment/length          =        kgm/m, Tm/m, Nm/m, daNm/m, kNm/m, lbf-
ft/ft, kip-ft/ft
Stress                 =        kg/m2, kg/cm2, kg/mm2, T/m2, T/cm2, T/
mm2, N/m2, N/cm2, N/mm2, daN/m2, daN/cm2, daN/mm2, kN/m2, kN/cm2, kN/mm2, 
psi, psf, ksi, ksf
Date                   =        dd.mm.yyyy, mm.dd.yyyy, mm/dd/yyyy, 
yyyy/mm/dd, dd-mm-yy, dd-mm-yy, yyyy-mm-dd, dd/mm/yy
Time                   =        hh:mm:ss, hh:mm:ss:am/pm
Date&&Time             =        dd.mm.yyyy, mm.dd.yyyy, mm/dd/yyyy, 
yyyy/mm/dd, dd-mm-yy, dd-mm-yyyy, yyyy-mm-dd, dd/mm/yy
Date_local             =        dd.mm.yyyy, mm.dd.yyyy, mm/dd/yyyy, 
yyyy/mm/dd, dd-mm-yy, dd-mm-yyyy, yyyy-mm-dd, dd/mm/yy
Time_local             =        hh:mm:ss, hh:mm:ss:am/pm
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Date&&Time_local       =        dd.mm.yyyy, mm.dd.yyyy, mm/dd/yyyy, 
yyyy/mm/dd, dd-mm-yy, dd-mm-yyyy, yyyy-mm-dd, dd/mm/yyLeadingZeroes
LeadingZeroes
DistanceList           =        mm, dm, cm, m, inch, ft, yd, inch-frac 
{1/2, 1/4, 1/8, 1/16 }, ft-frac { 1/2, 1/4, 1/8, 1/16 }

For more information about value fields, formats, format functions and other
functions, see Template Editor User's Guide.

4.7 Set up a project for collaboration and interoperability
Collaborative modeling allows several people to simultaneously work in the
same Tekla Structures model. Importing to and exporting from Tekla
Structures allows you to use the same models and data in Tekla Structures and
in other software and systems.

Checklist for interoperability
If you plan to use collaborative modeling, decide which method you will use.

• If your company takes part in external projects, or if more than one user
works with the same model at different locations, we recommend using
Tekla Model Sharing. For more information, see What is Tekla Model
Sharing .

• If users do not need to work simultaneously with other users on the same
model, or you only need to give others viewing access to the model, you
can use Trimble Connect for model coordination and exchange of other
project files. For more information, see Trimble Connector.

Set up a project for collaboration and interoperability
Collaborative modeling allows several people to simultaneously work in the
same Tekla Structures model. Importing to and exporting from Tekla
Structures allows you to use the same models and data in Tekla Structures and
in other software and systems.

Collaborative modeling for administrators
You can use Tekla Model Sharing or Trimble Connect for collaborative
modeling.

If your company takes part in external projects, or if more than one user works
with the same model at different locations, we recommend using Tekla Model
Sharing. For more information, see What is Tekla Model Sharing .

If users do not need to work simultaneously with other users on the same
model, or you only need to give others viewing access to the model, you can
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use Trimble Connect for model coordination and exchange of other project
files. For more information, see Trimble Connector.

Management of Tekla Model Sharing
In Tekla Model Sharing each user has a local version of the model, and the
model data is shared and synchronized over the internet using a cloud sharing
service.

Status information for the Tekla Model Sharing cloud sharing service and other
online services is available on the Tekla Online status page. On this page, you
can also find information about service breaks.

When a user shares a model, the organization that the user belongs to
becomes the model owner. In Tekla Model Sharing, an organization always
owns all the models shared by the users in the organization. A shared model is
always owned by only one organization.

You can view and manage the shared models owned by your organization with
the Management Console for Tekla Model Sharing. For more information, see:

• Manage shared models in Management Console for Tekla Model Sharing

• Managing Tekla Model Sharing as an administrator

Use a Trimble Connect folder as the project or firm folder
When you need to set up a project folder XS_PROJECT or a firm folder 
XS_FIRM to be used in Tekla Model Sharing, the most convenient way to do
this is to use a Trimble Connect project as the project or the firm folder.

By using a Trimble Connect project as the project or firm folder, you ensure
that all Tekla Model Sharing users always use the same settings and that the
updates are automatically shared with everyone.

Note that all users need to have access both to the Trimble Connect project
and to the Tekla Model Sharing model.

The project and firm folder information is only updated from the Trimble
Connect project to local versions of the shared models, not vice versa. In
practice, this means that Tekla Structures downloads new files from the project
or film folder to the local model and updates any changed files. If a local file is
not stored in the Trimble Connect project folder, the file is removed from the
local model.

Tekla Structures uses Trimble Connect folder sync (CONNECT_FOLDER_SYNC) to
synchronize the data.

When Tekla Structures detects a change between the local model data and the
data in the Trimble Connect project or firm folder, you get the following
notification:
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If you click Yes, the model is saved and closed. Then, the local model data is
updated and the model is re-opened.

To set a folder in a Trimble Connect project as the XS_PROJECT or XS_FIRM
folder:

1. Create a project in Trimble Connect, and the folders that you want to use
as project or firm folders. 

Add the needed settings and files to the folders.

For more detailed information on how to create the Trimble Connect
project and folders, see How to use a Trimble Connect folder as the
project or firm folder and Using Trimble Connect files in Tekla Structures.

2. In Tekla Structures, on the File menu, go to Settings --> Advanced
options.

3. Depending on the option, do one of the following: 

To set a Trimble
Connect project

folder as

Do this

The XS_PROJECT
folder

a. In the Advanced options dialog box, find the
XS_PROJECT option.

b. Set the value of XS_PROJECT to
%CONNECT_FOLDER_SYNC%.

Tekla Structures searches for differences between
the files in the Trimble Connect project folder and
the local ..\Users\<user>\AppData\Local
\Trimble\Tekla folder sync\<folder>
folder.

If you use the same Trimble Connect project both
as the XS_PROJECT folder and for collaboration,
use a sub-folder in the XS_PROJECT folder, so that
the XS_PROJECT folder is separated from the
Trimble Connect collaboration information. Set
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To set a Trimble
Connect project

folder as

Do this

the sub-folder to %CONNECT_FOLDER_SYNC%
\<folder>\<sub-folder of the folder>.

For example, you could save the project folder
under the Project settings folder with the
name Project. In this example, the value should
then be set to %CONNECT_FOLDER_SYNC%
\Project Settings\Project. You can also use
lower level sub-folders.

The XS_FIRM folder a. In the Advanced options dialog box, find the
XS_FIRM option.

b. Set the value of XS_FIRM to
%CONNECT_FOLDER_SYNC%\<ProjectID>
\<region>(\<folder>\<sub-folder of the
folder>).

You can see the project ID in Trimble Connect for
Browser:

The region is the same as the project server
location setting. The options are:

• asia

• europe

• northAmerica

For example, the value could be
%CONNECT_FOLDER_SYNC%\g7nzNr838Tg
\europe
If you use the same Trimble Connect project both
as the XS_FIRM folder and for collaboration, use a
sub-folder in the XS_FIRM folder, so that the
XS_FIRM folder is separated from the Trimble
Connect collaboration information. Set the sub-
folder to %CONNECT_FOLDER_SYNC%
\<ProjectID>\<region>\<folder>\<sub-
folder of the folder>.

For example, you could save the project folder
under the Project settings folder with the
name Project. In this case, the value should be
set to %CONNECT_FOLDER_SYNC%
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To set a Trimble
Connect project

folder as

Do this

\g7nzNr838Tgeurope\Project Settings
\Project. You can also use lower level sub-
folders.

4. Click OK to save the project or firm folder.

5. Close and re-open the model to take the new project or firm folder into
use.

Note that files that are generated when macros are compiled (cs.dll
and .cs.pdb) are ignored in the folder sync operation. Thus, adding these two
files in the local folder will not trigger an update.

See also

Project and firm folders (page 16)

Install the Cache service for Tekla Model Sharing
Tekla Model Sharing Cache service downloads model data from the Tekla
Model Sharing service and caches the data in the file system inside a LAN.
Using the cache service reduces the use of the Internet, resulting in faster
download times when the same data is requested more than once. Note that
the cache is not used for packets that are written out.

The cache service needs an Internet connection to download model data from
the sharing service. The first time a user fetches a packet it will be loaded to
the cache service. Any following requests to the same packet will then be
served fast from the cache service inside the LAN.

The cache service is useful even if there is only one Tekla Model Sharing user
in the same office. For example, rejoining a model is faster as the model data
is available in the cache service. In addition, the model data is always loaded
as small data blocks. This is useful if the downloading is interrupted for some
reason, because the cache service can just download the missing blocks later.

Note that data is not automatically cleared from the Cache service. To clear
unnecessary data, you can simply delete old files from the Cache service.

If there are several Tekla Model Sharing users in the same office, we highly
recommend you to install the Tekla Model Sharing Cache service. The Cache
service is recommended especially in regions where the download speed may
be limited.

The image below shows how the model data is stored to the sharing service
and used with the Tekla Model Sharing Cache service.
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NOTE If the Cache service cannot be reached for any reason, Tekla
Structures will use the cloud storage for model changes directly. This
can also happen when a download operation is on-going, if the
connection to Cache service times out.

You can see whether the Cache service is in use by checking the
ClientLog_cat.txtClientLog_dog.txt log files in the \Users
\<user>\AppData\Local\Tekla DataSharing folder.

Software and system requirements for a cache installation:

• Windows Server 2008 R2, or later

• .NET Framework 4.5.1

Install the Cache service

1. Ensure that you have an active Windows computer or a server with
enough disk space to store the cached model data.

2. Download the Tekla Model Sharing Cache service installation file from
Tekla Downloads.

3. Run the installation file and follow the steps in the installation wizard to
complete the installation. 
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• The default cache folder is C:\TeklaModelSharingCache. If needed,
you can change the folder destination.

Ensure that the destination folder has enough disk space for the
estimated usage of the service. The required disk space can vary from
a few gigabytes to terabytes, depending on the amount of Tekla Model
Sharing users and the size of the models.

• The default TCP/IP port number for the cache service is 9998.

Use this port number when you configure Tekla Structures client
workstations to use the cache. This port is the main communication
and control channel to the cache service.

• The default TCP/IP port number for internal communication is 9001.

This port is automatically fetched from the cache service, and it is used
for the actual data transfer.

Network access

You need to allow inbound traffic for TCP/IP ports (defaults 9001 and
9998) for the cache service host.

If the ports cause conflicts or other problems because of other services or
a firewall, you can change the ports to some other ports.

The cache service needs an Internet connection to download model
changes from the sharing service.

NOTE If you later need to modify the installation, re-run the
TeklaModelSharingCacheService.exe installation file and
select Repair. You can then change the previously set cache
folder or port numbers. To use content from the previous cache
folder, copy or move the needed content to the new folder.

4. Check that the Tekla Model Sharing Cache service has started. 

• Locate Tekla Model Sharing Cache from the Windows services by
using, for example, the Computer Management console 
compmgmt.msc or the Services management console services.msc.

• Use Windows Event Viewer to verify that there are no errors from the
service and that there are Information messages showing that the
service has started.

5. Configure Tekla Structures client workstations to use the cache. 

In Tekla Structures, on the File menu, click Sharing --> Sharing settings .

In the Sharing settings dialog box:

• Name is the name of the computer on which the cache is installed. To
check the computer name, click Windows Control Panel --> System
and Security --> System .
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• Port is the cache service port number that you have set when you
installed the cache service. The default value is 9998.

Troubleshoot the Cache service installation

Problem Possible solutions
Cannot connect to the Cache service
from Tekla Structures

• Ensure that the Tekla Model
Sharing Windows Service is
running.

• Ensure sure that the firewalls do
not block TCP/IP ports configured
to Tekla Structures, for example 
9001 or 9998 when you use the
default ports.

Cache service does not start Check the Windows Event Viewer's
Application Log for errors.

Set the Log On account for the Cache Windows service

In case the Cache service needs to access some special resources, such as
shared network drives, you need to ensure that the Log On account for the
Cache Windows service has permissions to access those resources. Note that
the Log On account also needs to have reading and writing permissions to the
C:\ProgramData\Tekla\ModelSharingCache folder. We recommend that
you use the same account both for installing the Cache service and, if needed,
as the Log On account for the Cache Windows service.

By default, the Log On account for the Cache Windows service is Local System
Account, so you may need to change the account:

1. Right-click the Cache Windows Service in the Services dialog box.

2. Select Properties.

3. On the Log On tab, select This Account and type the account name and
password.

4. Click OK.

Host your own potree point cloud data
Hosting your own potree point cloud data allows you to share point clouds
across the internet using a URL. We recommend hosting your potree point
cloud data on a Microsoft Azure Storage Account.
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Create a potree file with Point cloud manager
You can download Point cloud manager from Tekla Warehouse.

For detailed instructions about using Point cloud manager, see the Point

cloud manager help. You can open the help by clicking the help button .

1. Install the application, and start it from the start menu or start screen,
depending on your Windows version.

2. Set the root folder for the project. For example, C:\Trimble\PTRS.

3. Create a new project.

a. Click the Add new project button. 

b. In the Project name box, enter a name for the project. 

This name will be the name of the potree database and potree folder.

4. Import one or more point cloud models:

a. Click Add file.

b. Browse for the point cloud file.
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5. When the point cloud has been imported, click  to start the
conversion to potree.

6. Expand Conversion settings, select Directory structure, then click Start.

The potree data is now available in the root folder for the project.

Configure an Azure Storage Account to host the point cloud data
A Microsoft Azure subscription is required.

Before you begin, configure the security controls for your Azure subscription
according to your organization's policies.

1. In the Azure Portal, create a new Azure storage account. 

For detailed instructions, see the Microsoft Azure documentation.

2. In the Static website settings, enable Static website.

TIP The URLs in the Primary endpoint and Secondary endpoint boxes
are generated automatically.

3. In the CORS settings, add a CORS rule for the Blob service, then configure
the rule settings. 
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CORS rule setting Description
Allowed origins Specifies which domains are allowed to access the

resources.

• If you only plan to use the data from your point
cloud with the Connect 3D app, enter https://
3d.connect.trimble.com.

• To allow all domains, enter *.
Allowed methods Specifies which HTTP methods are allowed when

making requests.

Enter GET.
Allowed headers Specifies which HTTP headers are allowed when

making requests.

To allow all headers, enter *.
Exposed headers Specifies which headers JavaScript in browsers is

allowed to access.

To allow all headers, enter *.
Max age Specifies how long the results of a request can be

cached.

Enter the number of seconds.

Upload potree data to your Azure Storage Account
1. In Azure Storage Explorer, navigate to your storage account, then browse

to the $web blob container.

2. Copy the folder that contains the point clouds from C:\Trimble\PTRS to
the storage for your blob container.

3. Copy the <potree_name> folder to a shared location. 

NOTE Do not replace existing potree data, especially if it is used by other
users.

Add a link to your point cloud data to your Trimble Connect Project
Add a point cloud URL from your computer or a drive.

1. Open your project in Trimble Connect for Windows.
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2. Navigate to the 3D Viewer.

3. Open the Point Clouds panel.

4. Click Add URL.

5. Enter a name for the point cloud.

6. In the URL box, enter or paste the URL of the point cloud file. 

For example:

https://potreehosting.z6.web.core.windows.net/pointclouds/example
7. Click Add.

When you click this file in the Trimble Connect 3D app, your point cloud opens.

Files for import and export
You can use several different file type to import to and export from Tekla
Structures.

See also

Conversion files (page 192)

Create new property sets for IFC export (page 196)

DSTV file description (page 210)

tekla_dstv2dxf_<env>.def file description (page 212)

ASCII file description (page 222)

Conversion files
Conversion files (.cnv) map Tekla Structures profile, twin profile, and material
names with names used in other software.

Conversion files are simple text files, containing the Tekla Structures name in
the first column, and the name used in the other software package in the
second column. Columns are separated by a space. All parametric profiles
must be entered in the profile conversion file.

You can use the same conversion file both when importing and exporting
models, and you can specify the location of conversion files in most of the
import and export tools.
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If you enter a conversion file name without a path, Tekla Structures searches
for the file in the current model folder. If you leave the box empty, Tekla
Structures searches for the file indicated by the advanced option XS_PROFDB
in File menu --> Settings --> Advanced options --> File locations . This is also
the case, if the tool does not allow you to define the path and conversion file.

Tekla Structures has several conversion files in the standard installation, and
you can also create your own. Standard conversion files are located in the 
\profil folder under the environment folder ...\ProgramData\Trimble
\Tekla Structures\<version>\environments\ folder. The exact location
may vary depending on your environment. All conversion files have the .cnv
extension.

Note that these instructions do not apply to all export and import types. If a
tool has specific instructions regarding the conversion files, the instructions
are included in the export or import instructions.

Create conversion files
You can create your own conversion files if the ones that come with Tekla
Structures installation do not suit your needs.

1. Open an existing conversion file using any standard text editor. 

By default, conversion files are located in the \profil folder under the
environment folder...\ProgramData\Trimble\Tekla Structures
\<version>\environments\. The exact location may vary depending on
your environment.

2. Save the file with another name. 

If the export/import tool allows you to define the path to the conversion
file, you can save the file where you like. If this is not the case, save the file
in a location defined by the advanced option XS_PROFDB in File menu -->
Settings --> Advanced options --> File locations .
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3. Modify the file: enter profile names recognized by Tekla Structures in the
first column, and the corresponding name recognized by the other
software in the second column. 

While modifying, ensure that:

• You do not have blank material definitions (" ", empty quotation
marks).

• You do not have spaces in the profile position strings. For example,
enter "Hand_ Rail" not Hand Rail".

4. Save your changes. 

NOTE • All the three files (profile, twin profile and material) are not
needed if the differences in the profile name is just concerning
* X or x formats, because these are normally handled
automatically. For example, if you wanted to import
UC254x254x73 to be UC254*254*73, the lower case "x" is
automatically changed to "X" so the format of the conversion
file would be UC254*254*73 254X254X73.

• If you have problems importing the model, check any error
messages in the Tekla Structures log file, and check the
conversion files.

Example

Below are some examples of conversion files:

SDNF
! Profile name conversion Tekla Structures -> SDNF
!
! If Converted-name does not exist, it will be the same
! as Tekla Structures-name.

! Tekla Structures-name Converted-name

C10X15.3 C10X15.3
C10X20 C10X20
C10X25 C10X25
C10X30 C10X30
C12X20.7 C12X20.7
C12X25 C12X25
C12X30 C12X30
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C15X33.9 C15X33.9
C15X40 C15X40
C15X50 C15X50
C3X4.1 3X4.1
DSTV
! Profile name conversion Tekla Structures -> DSTV
!
! If Converted-name does not exist, it will be the same
! as Tekla Structures-name.

! Tekla Structures-name Converted-name

C10X15.3  C10X15.3
C10X20    C10X20
C10X25    C10X25
C10X30    C10X30
C12X20.7  C12X20.7
C12X25    C12X25
Below there is first an example of an incorrect conversion file and then of a
correct one, errors are highlighted:

00100782 4 0 2 "brace" "Tread 4" 1 "TREAD4.5" "" 0.000000 0 0 
0.000000 1.000000 0.000000 16.250000 13.154267 3.857143
15.500000 13.154267 3.857143 0.000000 0.000000 0.000000
0.000000 0.000000 0.000000 0.000000 0.000000 0.000000
0.000000 0 0 0 0 0 0 0 0 0 0 0 0
00100782 4 0 2 "brace" "Tread_4" 1 "TREAD4.5" "A36" 0.000000
0 0 0.000000 1.000000 0.000000 16.250000 13.154267 3.857143
15.500000 13.154267 3.857143 0.000000 0.000000 0.000000
0.000000 0.000000 0.000000 0.000000 0.000000 0.000000
0.000000 0 0 0 0 0 0 0 0 0 0 0 0

Twin profile conversion files
Tekla Structures contains separate conversion files for twin profiles, and it
reads the twin profile conversion file before the profile conversion file, so you
must include the profiles from the original model in the import.

The twin profile conversion file is a text file containing the profile prefix
(characters only) and the distance between the profiles in mm, separated by a
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space. Tekla Structures converts all profiles with the specified prefix to twin
profiles.

The twin profile conversion file could be named twin_profiles.cnv and it
could contain lines such as the one below:

DL 20
The distance between the profiles is the same for all profiles with the same
profile prefix. For example, profiles with the prefix DL will always have the
same spacing. If you want different spacing values, then you need to use a
different profile prefix.

You also need to add the twin profile to the profile conversion file to get the DL
profile converted to L-profile:

L200*20 DL200/20-20

Limitations

• Twin profile conversion cannot be used for profiles that start with a
number. This means that you cannot define double angles as 2L. Instead,
you need to use DL as the prefix for a twin profile, for example: 
DL200/20-20.

• Twin profile conversion does not work for FEM import. We recommend that
each angle is modeled separately rather than as twin profiles, as SP3D does
not control the gaps between members in the same way as Tekla
Structures and there are, for example, various conversion and mapping
difficulties. Ii is easier to convert members that are modeled as two
members.

Create new property sets for IFC export
You can create additional property sets from template attributes and user-
defined attributes, define properties for the attributes, and bind the Tekla
Structures property sets to IFC entities for IFC export.

Tekla Structures saves additional property sets in configuration files. You can
keep several configuration files in several locations. When Tekla Structures
exports an IFC file, it reads the predefined property sets and the additional
property sets.

Add an IFC property set configuration file

1. On the File menu, click Export --> IFC or Export --> IFC4.

2. In the Additional property sets list, select <new>, then click Edit. 

The Property Set Definitions dialog box opens.

3. In the Property set configuration file name box, enter a name for the
configuration file.
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4. To add a new property set, click the add button  under Property Set. 

You can create several property sets in one configuration file. For
example, you can add COGs, and start and end points on the part level,
and scheduling information on the assembly level.

5. In the dialog box that opens, enter a name and a description for the
property set, then click Create. 

The property set name can contain any text, including spaces. The
maximum length of the property set name is 255 characters. The "Pset_"
prefix is reserved for the standard BuildingSMART property sets. Do not
use this prefix in the name of your custom property sets.

6. In the Entities list, select the entity type category. 

Structural is the default category. When you select the category, the
related IFC entities are shown in the Select entity types list.

7. From the Select entity types list, select an entity type. 

The Select attributes list shows the attributes that are available for the
selected entity type.

8. From the Select attributes list, select one or more attributes. 

The attribute is added to the List of all selected properties list on the
right. This list shows which attributes are exported:

• When you select an attribute in the list, its properties are shown under
Create/Modify property.

• You can add new attributes by entering an attribute name in the
Attribute box in the Create/Modify property area and clicking the
Add button.

• You can modify and remove attributes on the list by selecting the
attributes on the list and clicking Modify or Remove.

9. Under Create/Modify property, define the attribute properties.

a. Select Property type for the selected attribute. 

Here, always select Template attribute for user-defined attributes
whose name contains more than 19 characters. For example, select
Template attribute for ASSEMBLY.USERDEFINED.PLANS_STATUS.

b. Enter the name of the selected attribute in the Name box.

c. Select the Type of the attribute. 

The Type can be one of the following:

• String: sequence of characters

• Boolean: true or false

• Integer: a whole number
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• Measurement

• Real: a number that has a decimal representation

• Time stamp

d. If the type of the user-defined attribute is Measurement: 

• You can select the Measurement type: Length, Area, Volume,
Mass, Positive length or Count.

• You can select the Conversion factor and Accuracy.

To be able to define the value for Conversion, you need to know
the unit used for a particular property (for example length) in
Tekla Structures and the unit used for the property in IFC. For
example, for length, the unit is mm in both Tekla Structures and
IFC, which means that the conversion value is 1. If the unit was m
in Tekla Structures, the conversion value would need to be 1000.

In the area property conversion, the 1E-06 factor is used, and
1E-06 = 0.000001. For example, 1 m2 is 1000000 mm2 in Tekla
Structures. In IFC, the area unit is m2, and the Tekla Structures
value needs to be converted by 1E-06: 1000000 mm2 x 1E-6= 1 m2.

In the volume property conversion, the 1E-09 factor is used, and
1E-09 = 0.000000001.

Accuracy indicates the accuracy that is used when writing the
property to IFC, decimals are used here. For example with length,
when accuracy is 0.1, with a 1000 mm IFC file the value would be
1000.0. If accuracy was 0.01, the value would be 1000.00. If the
accuracy was 0.5, the Tekla Structures value 1000.6 would be
1000.5, 1000.8 would be 1001.0, and 1000.2 would be 1000.0.

User-definable accuracy allows better IFC file size optimization.

10. Click Save.
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1) The entity groups where Tekla Structures attributes are written in the
exported IFC file

2) The template attributes or user-defined attributes that you want to export
for the selected entity

3) List showing the selected attributes

4) The properties that you can define for the attributes

TIP Be careful to select the correct Type when defining property sets from UDAs. For
example, if the UDA properties are normal text, select String. If your UDA
properties are whole numbers, select Integer. If the wrong Type is selected, the
property set export will fail. Note that you can get a string value for a user-
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defined attribute so that you add the prefix USERDEFINED. to the user-defined
attribute, change the Property type to Template attribute and the Type to
String.

Example:

Predefined property set configuration files in IFC2x3 export

The predefined configuration files are read-only and they are read
from ..\ProgramData\Trimble\Tekla Structures\<version>
\Environments\Common\inp. The location may vary depending on your
environment.

• IfcPropertySetConfigurations_CV2.xml (default property sets)/
IfcPropertySetConfigurations_CV2_1.xml (minimum property sets)
contains the property sets for Export type Coordination view 2.0.

• IfcPropertySetConfigurations_SG.xml (default property sets)/
IfcPropertySetConfigurations_CV2_1.xml (minimum property sets)
contains the property sets for Export type Surface geometry.

• IfcPropertySetConfigurations_AISC.xml (default property sets)/
IfcPropertySetConfigurations_AISC_1.xml (minimum property
sets) contains the property sets for Export type Steel fabrication view.

The IfcPropertySetConfigurations_CV1.xsd file in the same folder is a
schema file that describes the structure of the XML file and is used for
validation of the XML file. This file is read when the software is started.

Additional property set configuration files in IFC2x3 and IFC4 export

NOTE We recommend that you define additional property sets in the Property Set
Definitions dialog box instead of modifying the file itself to ensure that the
XML configuration files are valid. The additional property sets you create are
saved to the \AdditionalPSets folder under the model folder by default.
You can also read additional property sets from the following folders:

• XS_SYSTEM
• XS_PROJECT
• XS_FIRM
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You can define your own property sets for both IFC2x3 export and IFC4 export.
When you configure property sets for IFC export in XML format, you need two
files:

• IfcPropertySetConfigurations.xsd is a schema file that describes
the structure of the XML file and is used for validation of the XML file. This
file is read when the software is started.

• IfcPropertySetConfigurations.xml is the actual property set
configuration file.

If you use the above mentioned folders, save the files in a folder called
\AdditionalPSets under the system, project or firm folder.

Property set configuration file contents
A configuration file includes the structure of property sets, and the data
definitions for the properties inside the property sets.

• • Template attribute or UDA name. Template attributes are read from
contentattributes_global.lst and the user-defined attributes
from the environment database.

• Data type, such as String, Integer, Float, Timestamp, Boolean, Logical, or
planeanglemeasure.

• Unit type, such as length, area, volume, or mass.

• Unit value scaling of unitless UDA values. Conversion factor is added so
that unitless values can be converted to correspond to the global units
used in the IFC files. Area and volume units need these factors.

• If you need the option type UDA value to be the same as in the user
interface, you can change the type from User defined attribute to
string type Template attribute in Property Set Definitions dialog box.

• Possibility to use default values.
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• Possibility to ignore the set to export if template attribute or UDA does
not have a value.

• A configuration file includes property set binding rules to IFC entities:

• Binding to IFC entity type hierarchy including support for not only
building elements but also for bolts, reinforcing bars, and assemblies.

• Possibility to use limiting rules, such as Equal, NotEqual, LessThan,
GreaterThan, LessThanOrEqual, and GreaterThanOrEqual for numbers,
and Equal and NotEqual for texts.

You need to modify your additional property set configuration file using
a suitable editor, if you want to add these limiting rules.

• There can be any number of binding rules for any property set, but only
one property set definition for each ReferenceId.

• You can bind different property sets to different IFC entity types. For
example, a plate may have a different property set than a beam.

• If no value is found for a property in export, the export does not write the
property set at all. To avoid this, add optional=true for that property in
the property set.

Below is an example of the contents of the
IfcPropertySetConfigurations_CV2.xml file.
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Below is an example of the contents of the
IfcPropertySetConfigurations.xml file.

Hardcoded IFC4 properties and quantities
In the IFC4 export, the exported properties and quantities are hardcoded.
These properties and quantities are exported by default.

/*! Hard coded IfcBeam properties */
    { ENTITY_IfcBeam, Pset_BeamCommon {
        Quantity(Quantity::Enum, L"Status", 
L"USERDEFINED.RENOVATION_STATUS"),
        Quantity(Quantity::Boolean, L"IsExternal", 
L"USERDEFINED.IS_EXTERNAL"),
        Quantity(Quantity::Boolean, L"LoadBearing", 
L"USERDEFINED.LOAD_BEARING"),
        Quantity(Quantity::Identifier, L"Reference", 
L"USERDEFINED.REF_ID"),
        Quantity(Quantity::Label, L"FireRating", 
L"USERDEFINED.FIRE_RATING"),

Start new projects as a Tekla Structures
administrator

203 Set up a project for collaboration and
interoperability



        Quantity(Quantity::Angle, L"Slope", L"SLOPE"),
        Quantity(Quantity::Angle, L"Roll", L"ROLL"),
        Quantity(Quantity::PositiveLength, L"Span", L"USERDEFINED.SPAN"),
        Quantity(Quantity::Thermal, L"ThermalTransmittance", 
L"USERDEFINED.THERMAL_TRANSMITTAN") }
    },
    /*! Hard coded IfcBuildingElementProxy properties */
    { ENTITY_IfcBuildingElementProxy, Pset_BuildingElementProxymCommon  {
        Quantity(Quantity::Enum, L"Status", 
L"USERDEFINED.RENOVATION_STATUS"),
        Quantity(Quantity::Identifier, L"Reference", 
L"USERDEFINED.REF_ID"),
        Quantity(Quantity::Boolean, L"IsExternal", 
L"USERDEFINED.IS_EXTERNAL"),
        Quantity(Quantity::Thermal, L"ThermalTransmittance", 
L"USERDEFINED.THERMAL_TRANSMITTAN"),
        Quantity(Quantity::Boolean, L"LoadBearing", 
L"USERDEFINED.LOAD_BEARING"),
        Quantity(Quantity::Label, L"FireRating", 
L"USERDEFINED.FIRE_RATING")}
    },
    /*! Hard coded IfcMember properties */
    { ENTITY_IfcMember, Pset_MemberCommon  {
        Quantity(Quantity::Enum, L"Status", 
L"USERDEFINED.RENOVATION_STATUS"),
        Quantity(Quantity::Boolean, L"IsExternal", 
L"USERDEFINED.IS_EXTERNAL"),
        Quantity(Quantity::Boolean, L"LoadBearing", 
L"USERDEFINED.LOAD_BEARING"),
        Quantity(Quantity::Identifier, L"Reference", 
L"USERDEFINED.REF_ID"),
        Quantity(Quantity::Label, L"FireRating", 
L"USERDEFINED.FIRE_RATING"),
        Quantity(Quantity::Angle, L"Slope", L"SLOPE"),
        Quantity(Quantity::Angle, L"Roll", L"ROLL"),
        Quantity(Quantity::PositiveLength, L"Span", L"USERDEFINED.SPAN"),
        Quantity(Quantity::Thermal, L"ThermalTransmittance", 
L"USERDEFINED.THERMAL_TRANSMITTAN") }
    },
    /*! Hard coded IfcColumn properties */
    { ENTITY_IfcColumn, Pset_ColumnCommon   {
        Quantity(Quantity::Enum, L"Status", 
L"USERDEFINED.RENOVATION_STATUS"),
        Quantity(Quantity::Boolean, L"IsExternal", 
L"USERDEFINED.IS_EXTERNAL"),
        Quantity(Quantity::Boolean, L"LoadBearing", 
L"USERDEFINED.LOAD_BEARING"),
        Quantity(Quantity::Identifier, L"Reference", 
L"USERDEFINED.REF_ID"),
        Quantity(Quantity::Label, L"FireRating", 
L"USERDEFINED.FIRE_RATING"),
        Quantity(Quantity::Angle, L"Slope", L"SLOPE"),
        Quantity(Quantity::Angle, L"Roll", L"ROLL"),
        Quantity(Quantity::Thermal, L"ThermalTransmittance", 
L"USERDEFINED.THERMAL_TRANSMITTAN") }
    },
    /*! Hard coded IfcPile properties */
    { ENTITY_IfcPile, Pset_PileCommon    {
        Quantity(Quantity::Enum, L"Status", 
L"USERDEFINED.RENOVATION_STATUS"),
        Quantity(Quantity::Boolean, L"LoadBearing", 
L"USERDEFINED.LOAD_BEARING"),
        Quantity(Quantity::Identifier, L"Reference", 
L"USERDEFINED.REF_ID") }
    },
    /*! Hard coded IfcFooting properties */
    { ENTITY_IfcFooting, Pset_FootingCommon     {
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        Quantity(Quantity::Enum, L"Status", 
L"USERDEFINED.RENOVATION_STATUS"),
        Quantity(Quantity::Boolean, L"LoadBearing", 
L"USERDEFINED.LOAD_BEARING"),
        Quantity(Quantity::Identifier, L"Reference", 
L"USERDEFINED.REF_ID") }
    },
    /*! Hard coded IfcElementAssembly properties */
    { ENTITY_IfcElementAssembly, Pset_ElementAssemblyCommon {
        Quantity(Quantity::Enum, L"Status", 
L"USERDEFINED.RENOVATION_STATUS"),
        Quantity(Quantity::Identifier, L"Reference", L"ASSEMBLY_POS") }
    },
    /*! Hard coded IfcSlab properties */
    { ENTITY_IfcSlab, Pset_SlabCommon  {
        Quantity(Quantity::Identifier, L"Reference", 
L"USERDEFINED.REF_ID"),
        Quantity(Quantity::Label, L"AcousticRating", 
L"USERDEFINED.ACOUSTIC_RATING"),
        Quantity(Quantity::Boolean, L"IsExternal", 
L"USERDEFINED.IS_EXTERNAL"),
        Quantity(Quantity::Boolean, L"LoadBearing", 
L"USERDEFINED.LOAD_BEARING"),
        Quantity(Quantity::Enum, L"Status", 
L"USERDEFINED.RENOVATION_STATUS"),
        Quantity(Quantity::Angle, L"PitchAngle", 
L"USERDEFINED.PITCH_ANGLE"),
        Quantity(Quantity::Boolean, L"Combustible", 
L"USERDEFINED.COMBUSTIBLE"),
        Quantity(Quantity::Label, L"SurfaceSpreadOfFlame", 
L"USERDEFINED.SPREAD_OF_FLAME"),
        Quantity(Quantity::Label, L"FireRating", 
L"USERDEFINED.FIRE_RATING"),
        Quantity(Quantity::Boolean, L"Compartmentation", 
L"USERDEFINED.COMPARTMENT"),
        Quantity(Quantity::Thermal, L"ThermalTransmittance", 
L"USERDEFINED.THERMAL_TRANSMITTAN") }
    },
        /*! Hard coded IfcRoof properties */
    { ENTITY_IfcRoof, Pset_RoofCommon   {
        Quantity(Quantity::Identifier, L"Reference", 
L"USERDEFINED.REF_ID"),
        Quantity(Quantity::Enum, L"Status", 
L"USERDEFINED.RENOVATION_STATUS"),
        Quantity(Quantity::Label, L"AcousticRating", 
L"USERDEFINED.ACOUSTIC_RATING"),
        Quantity(Quantity::Boolean, L"IsExternal", 
L"USERDEFINED.IS_EXTERNAL"),
        Quantity(Quantity::Boolean, L"LoadBearing", 
L"USERDEFINED.LOAD_BEARING"),
        Quantity(Quantity::Label, L"FireRating", 
L"USERDEFINED.FIRE_RATING"),
        Quantity(Quantity::Thermal, L"ThermalTransmittance", 
L"USERDEFINED.THERMAL_TRANSMITTAN") }
    },
    /*! Hard coded IfcWall properties */
    { ENTITY_IfcWall, Pset_WallCommon    {
       Quantity(Quantity::Identifier, L"Reference", 
L"USERDEFINED.REF_ID"),
       Quantity(Quantity::Enum, L"Status", 
L"USERDEFINED.RENOVATION_STATUS"),
       Quantity(Quantity::Label, L"AcousticRating", 
L"USERDEFINED.ACOUSTIC_RATING"),
       Quantity(Quantity::Label, L"FireRating", 
L"USERDEFINED.FIRE_RATING"),
       Quantity(Quantity::Boolean, L"IsExternal", 
L"USERDEFINED.IS_EXTERNAL"),
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       Quantity(Quantity::Boolean, L"LoadBearing", 
L"USERDEFINED.LOAD_BEARING"),
       Quantity(Quantity::Boolean, L"Combustible", 
L"USERDEFINED.COMBUSTIBLE"),
       Quantity(Quantity::Label, L"SurfaceSpreadOfFlame", 
L"USERDEFINED.SPREAD_OF_FLAME"),
       Quantity(Quantity::Boolean, L"Compartmentation", 
L"USERDEFINED.COMPARTMENT"),
       Quantity(Quantity::Boolean, L"ExtendToStructure", 
L"USERDEFINED.EXTEND_TO_STRUCTURE"),
       Quantity(Quantity::Thermal, L"ThermalTransmittance", 
L"USERDEFINED.THERMAL_TRANSMITTAN")}
    },
    /*! Hard coded IfcWallStandardCase properties */
    { ENTITY_IfcWallStandardCase, Pset_WallCommon     {
        Quantity(Quantity::Identifier, L"Reference", 
L"USERDEFINED.REF_ID"),
        Quantity(Quantity::Enum, L"Status", 
L"USERDEFINED.RENOVATION_STATUS"),
        Quantity(Quantity::Label, L"AcousticRating", 
L"USERDEFINED.ACOUSTIC_RATING"),
        Quantity(Quantity::Label, L"FireRating", 
L"USERDEFINED.FIRE_RATING"),
        Quantity(Quantity::Boolean, L"IsExternal", 
L"USERDEFINED.IS_EXTERNAL"),
        Quantity(Quantity::Boolean, L"LoadBearing", 
L"USERDEFINED.LOAD_BEARING"),
        Quantity(Quantity::Boolean, L"Combustible", 
L"USERDEFINED.COMBUSTIBLE"),
        Quantity(Quantity::Label, L"SurfaceSpreadOfFlame", 
L"USERDEFINED.SPREAD_OF_FLAME"),
        Quantity(Quantity::Boolean, L"Compartmentation", 
L"USERDEFINED.COMPARTMENT"),
        Quantity(Quantity::Boolean, L"ExtendToStructure", 
L"USERDEFINED.EXTEND_TO_STRUCTURE"),
        Quantity(Quantity::Thermal, L"ThermalTransmittance", 
L"USERDEFINED.THERMAL_TRANSMITTAN")}
    },
     /*! Hard coded IfcPlate properties */
    { ENTITY_IfcPlate, Pset_PlateCommon {
       Quantity(Quantity::Label, L"AcousticRating", 
L"USERDEFINED.ACOUSTIC_RATING"),
       Quantity(Quantity::Enum, L"Status", 
L"USERDEFINED.RENOVATION_STATUS"),
       Quantity(Quantity::Boolean, L"IsExternal", 
L"USERDEFINED.IS_EXTERNAL"),
       Quantity(Quantity::Boolean, L"LoadBearing", 
L"USERDEFINED.LOAD_BEARING"),
       Quantity(Quantity::Identifier, L"Reference", 
L"USERDEFINED.REF_ID"),
       Quantity(Quantity::Label, L"FireRating", 
L"USERDEFINED.FIRE_RATING"),
       Quantity(Quantity::Thermal, L"ThermalTransmittance", 
L"USERDEFINED.THERMAL_TRANSMITTAN") }
    },
    /*! Hard coded IfcCovering properties */
    { ENTITY_IfcCovering, Pset_CoveringCommon  {
        Quantity(Quantity::Label, L"AcousticRating", 
L"USERDEFINED.ACOUSTIC_RATING"),
        Quantity(Quantity::Label, L"FlammabilityRating", 
L"FLAMMABILITY_RATING"),
        Quantity(Quantity::Label, L"FragilityRating", 
L"FRAGILITY_RATING"),
        Quantity(Quantity::Boolean, L"Combustible", 
L"USERDEFINED.COMBUSTIBLE"),
        Quantity(Quantity::Label, L"SurfaceSpreadOfFlame", 
L"USERDEFINED.SPREAD_OF_FLAME"),
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        Quantity(Quantity::Label, L"Finish", L"FINISH") }
    },
    /*! Hard coded IfcOpeningElement properties */
    { ENTITY_IfcOpeningElement, Pset_OpeningElementCommon {
        Quantity(Quantity::Label, L"Purpose", L"PURPOSE"),
        Quantity(Quantity::Boolean, L"FireExit", L"FIRE_EXIT"),
        Quantity(Quantity::Boolean, L"ProtectedOpening", 
L"PROTECTED_OPENING") }
    },
    /*! Hard coded IfcTendon properties */
    { ENTITY_IfcTendon, Pset_TendonCommon  {
        Quantity(Quantity::Identifier, L"Reference", 
L"USERDEFINED.REF_ID"),
        Quantity(Quantity::PositiveLength, L"NominalDiameter", 
L"DIAMETER_NOMINAL") }
    },
    /*! Hard coded IfcTendon anchor properties */
    { ENTITY_IfcTendonAnchor, Pset_TendonAnchorCommon   > {
        Quantity(Quantity::Identifier, L"Reference", 
L"USERDEFINED.REF_ID"),
        Quantity(Quantity::Enum, L"Status", 
L"USERDEFINED.RENOVATION_STATUS") }
    },
    /*! Hard coded IfcReinforcingBar properties */
    { ENTITY_IfcReinforcingBar, Pset_ReinforcingBarCommon    {
        Quantity(Quantity::Identifier, L"Reference", L"REBAR_POS"),
        Quantity(Quantity::Enum, L"Status", 
L"USERDEFINED.RENOVATION_STATUS"),
        Quantity(Quantity::PositiveLength, L"NominalDiameter", L"SIZE"),
        Quantity(Quantity::PositiveLength, L"BarLength", L"LENGTH"),
        Quantity(Quantity::PositiveLength, L"BarSpacing", L"CC_EXACT"),
        Quantity(Quantity::Identifier, L"BendingShapeCode", L"SHAPE") }
    },
    /*! Hard coded IfcReinforcingMesh properties */
    { ENTITY_IfcReinforcingMesh, Pset_ReinforcingMeshCommon     {
        Quantity(Quantity::Identifier, L"Reference", L"MESH_POS"),
        Quantity(Quantity::Enum, L"Status", 
L"USERDEFINED.RENOVATION_STATUS"),
        Quantity(Quantity::PositiveLength, L"MeshLength", L"LENGTH"),
        Quantity(Quantity::PositiveLength, L"MeshWidth", L"WIDTH"),
        Quantity(Quantity::PositiveLength, 
L"LongitudinalBarNominalDiameter", L"CC_DIAMETER_MIN_LONG"),
        Quantity(Quantity::PositiveLength, L"LongitudinalBarSpacing", 
L"CC_MIN_LONG"),
        Quantity(Quantity::PositiveLength, 
L"TransverseBarNominalDiameter", L"CC_DIAMETER_MIN_CROSS"),
        Quantity(Quantity::PositiveLength, L"TransverseBarSpacing", 
L"CC_MIN_CROSS"),
        Quantity(Quantity::Enum, L"LongitudinalBarSurface", 
SET_CONSTANT_VALUE("TEXTURED").c_str()),
        Quantity(Quantity::Enum, L"TransverseBarSurface", 
SET_CONSTANT_VALUE("TEXTURED").c_str()),
        Quantity(Quantity::Identifier, 
L"LongitudinalBarBendingShapeCode", SET_CONSTANT_VALUE("A").c_str()),
        Quantity(Quantity::Identifier, L"TransverseBarBendingShapeCode", 
SET_CONSTANT_VALUE("A").c_str()),
        Quantity(Quantity::Label, L"LongitudinalBarBendingParameters", 
L"{LENGTH}"),
        Quantity(Quantity::Label, L"TransverseBarBendingParameters", 
L"{WIDTH}") }
    }
};

/*! Hard coded quantities by entity type */
const std::unordered_map<IfcParser::IfcTypeAll_t, std::vector<Quantity>> 
s_Quantities{
    /*! Hard coded IfcBeam quantities */
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    { ENTITY_IfcBeam, Qto_BeamBaseQuantities {
        Quantity(Quantity::Length, L"Length", L"LENGTH"),
        Quantity(Quantity::Area, L"CrossSectionArea", 
L"PROFILE.CROSS_SECTION_AREA", MM2_to_M2),
        Quantity(Quantity::Area, L"OuterSurfaceArea", L"AREA_GROSS", 
MM2_to_M2),
        Quantity(Quantity::Area, L"GrossSurfaceArea", L"AREA_GROSS", 
MM2_to_M2),
        Quantity(Quantity::Area, L"NetSurfaceArea", L"AREA_NET", 
MM2_to_M2),
        Quantity(Quantity::Volume, L"GrossVolume", L"VOLUME_GROSS", 
MM3_to_M3),
        Quantity(Quantity::Volume, L"NetVolume", L"VOLUME_NET", 
MM3_to_M3),
        Quantity(Quantity::Weight, L"GrossWeight", L"WEIGHT_GROSS"),
        Quantity(Quantity::Weight, L"NetWeight", L"WEIGHT_NET")} },
    /*! Hard coded IfcMember quantities */
    { ENTITY_IfcMember, Qto_MemberBaseQuantities {
        Quantity(Quantity::Length, L"Length", L"LENGTH"),
        Quantity(Quantity::Area, L"CrossSectionArea", 
L"PROFILE.CROSS_SECTION_AREA", MM2_to_M2),
        Quantity(Quantity::Area, L"OuterSurfaceArea", L"AREA_GROSS", 
MM2_to_M2),
        Quantity(Quantity::Area, L"GrossSurfaceArea", L"AREA_GROSS", 
MM2_to_M2),
        Quantity(Quantity::Area, L"NetSurfaceArea", L"AREA_NET", 
MM2_to_M2),
        Quantity(Quantity::Volume, L"GrossVolume", L"VOLUME_GROSS", 
MM3_to_M3),
        Quantity(Quantity::Volume, L"NetVolume", L"VOLUME_NET", 
MM3_to_M3),
        Quantity(Quantity::Weight, L"GrossWeight", L"WEIGHT_GROSS"),
        Quantity(Quantity::Weight, L"NetWeight", L"WEIGHT_NET")} },
    /*! Hard coded IfcColumn quantities */
    { ENTITY_IfcColumn, Qto_ColumnBaseQuantities {
        Quantity(Quantity::Length, L"Length", L"LENGTH"),
        Quantity(Quantity::Area, L"CrossSectionArea", 
L"PROFILE.CROSS_SECTION_AREA", MM2_to_M2),
        Quantity(Quantity::Area, L"OuterSurfaceArea", L"AREA_GROSS", 
MM2_to_M2),
        Quantity(Quantity::Area, L"GrossSurfaceArea", L"AREA_GROSS", 
MM2_to_M2),
        Quantity(Quantity::Area, L"NetSurfaceArea", L"AREA_NET", 
MM2_to_M2),
        Quantity(Quantity::Volume, L"GrossVolume", L"VOLUME_GROSS", 
MM3_to_M3),
        Quantity(Quantity::Volume, L"NetVolume", L"VOLUME_NET", 
MM3_to_M3),
        Quantity(Quantity::Weight, L"GrossWeight", L"WEIGHT_GROSS"),
        Quantity(Quantity::Weight, L"NetWeight", L"WEIGHT_NET")} },
    /*! Hard coded IfcFooting quantities */
    { ENTITY_IfcFooting, Qto_FootingBaseQuantities {
        Quantity(Quantity::Length, L"Height", L"LENGTH"),
        Quantity(Quantity::Length, L"Length", L"HEIGHT"),
        Quantity(Quantity::Length, L"Width", L"WIDTH"),
        Quantity(Quantity::Area, L"CrossSectionArea", 
L"PROFILE.CROSS_SECTION_AREA", MM2_to_M2),
        Quantity(Quantity::Area, L"OuterSurfaceArea", L"AREA_GROSS", 
MM2_to_M2),
        Quantity(Quantity::Area, L"GrossSurfaceArea", L"AREA_GROSS", 
MM2_to_M2),
        Quantity(Quantity::Volume, L"GrossVolume", L"VOLUME_GROSS", 
MM3_to_M3),
        Quantity(Quantity::Volume, L"NetVolume", L"VOLUME_NET", 
MM3_to_M3),
        Quantity(Quantity::Weight, L"GrossWeight", L"WEIGHT_GROSS"),
        Quantity(Quantity::Weight, L"NetWeight", L"WEIGHT_NET")} },
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    /*! Hard coded IfcPile quantities */
    { ENTITY_IfcPile, Qto_PileBaseQuantities {
        Quantity(Quantity::Length, L"Length", L"LENGTH"),
        Quantity(Quantity::Area, L"CrossSectionArea", 
L"PROFILE.CROSS_SECTION_AREA", MM2_to_M2),
        Quantity(Quantity::Area, L"OuterSurfaceArea", L"AREA_GROSS", 
MM2_to_M2),
        Quantity(Quantity::Area, L"GrossSurfaceArea", L"AREA_GROSS", 
MM2_to_M2),
        Quantity(Quantity::Volume, L"GrossVolume", L"VOLUME_GROSS", 
MM3_to_M3),
        Quantity(Quantity::Volume, L"NetVolume", L"VOLUME_NET", 
MM3_to_M3),
        Quantity(Quantity::Weight, L"GrossWeight", L"WEIGHT_GROSS"),
        Quantity(Quantity::Weight, L"NetWeight", L"WEIGHT_NET")} },
    /*! Hard coded IfcSlab quantities */
    { ENTITY_IfcSlab, Qto_SlabBaseQuantities {
        Quantity(Quantity::Length, L"Depth", L"WIDTH"),
        Quantity(Quantity::Length, L"Length", L"LENGTH"),
        Quantity(Quantity::Length, L"Width", L"HEIGHT"),
        Quantity(Quantity::Area, L"GrossArea", L"AREA_GROSS", MM2_to_M2),
        Quantity(Quantity::Area, L"NetArea", L"AREA_NET", MM2_to_M2),
        Quantity(Quantity::Area, L"SideArea", L"AREA_FORM_SIDE", 
MM2_to_M2),
        Quantity(Quantity::Volume, L"GrossVolume", L"VOLUME_GROSS", 
MM3_to_M3),
        Quantity(Quantity::Volume, L"NetVolume", L"VOLUME_NET", 
MM3_to_M3),
        Quantity(Quantity::Weight, L"GrossWeight", L"WEIGHT_GROSS"),
        Quantity(Quantity::Weight, L"NetWeight", L"WEIGHT_NET"),
        Quantity(Quantity::Length, L"Perimeter", L"PERIMETER")} },
    /*! Hard coded IfcWall quantities */
    { ENTITY_IfcWall, Qto_WallBaseQuantities{
        Quantity(Quantity::Length, L"Width", L"WIDTH"),
        Quantity(Quantity::Length, L"Length", L"LENGTH"),
        Quantity(Quantity::Length, L"Height", L"HEIGHT"),
        Quantity(Quantity::Area, L"NetSideArea", L"AREA_FORM_SIDE", 
MM2_to_M2),
        //Quantity(Quantity::Area, L"GrossSideArea", 
L"AREA_FORM_SIDE_GLOBAL", MM2_to_M2), // AREA_FORM_SIDE_GLOBAL not 
implemented yet.
        Quantity(Quantity::Area, L"NetFootprintArea", 
L"AREA_PROJECTION_GXY_NET", MM2_to_M2),
        Quantity(Quantity::Volume, L"GrossVolume", L"VOLUME_GROSS", 
MM3_to_M3),
        Quantity(Quantity::Volume, L"NetVolume", L"VOLUME_NET", 
MM3_to_M3),
        Quantity(Quantity::Weight, L"GrossWeight", L"WEIGHT_GROSS"),
        Quantity(Quantity::Weight, L"NetWeight", L"WEIGHT_NET")} },
    /*! Hard coded IfcWallStandardCase quantities */
    { ENTITY_IfcWallStandardCase, Qto_WallBaseQuantities{
        Quantity(Quantity::Length, L"Width", L"WIDTH"),
        Quantity(Quantity::Length, L"Length", L"LENGTH"),
        Quantity(Quantity::Length, L"Height", L"HEIGHT"),
        Quantity(Quantity::Area, L"NetSideArea", L"AREA_FORM_SIDE", 
MM2_to_M2),
        // Quantity(Quantity::Area, L"GrossSideArea", 
L"AREA_FORM_SIDE_GLOBAL", MM2_to_M2), // AREA_FORM_SIDE_GLOBAL not 
implemented yet.
        Quantity(Quantity::Area, L"NetFootprintArea", 
L"AREA_PROJECTION_GXY_NET", MM2_to_M2),
        Quantity(Quantity::Volume, L"GrossVolume", L"VOLUME_GROSS", 
MM3_to_M3),
        Quantity(Quantity::Volume, L"NetVolume", L"VOLUME_NET", 
MM3_to_M3),
        Quantity(Quantity::Weight, L"GrossWeight", L"WEIGHT_GROSS"),
        Quantity(Quantity::Weight, L"NetWeight", L"WEIGHT_NET")} },
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     /*! Hard coded IfcPlate quantities */
    { ENTITY_IfcPlate, Qto_PlateBaseQuantities {
        Quantity(Quantity::Length, L"Width", L"WIDTH"),
        Quantity(Quantity::Area, L"GrossArea", L"AREA_GROSS", MM2_to_M2),
        Quantity(Quantity::Area, L"NetArea", L"AREA_NET", MM2_to_M2),
        Quantity(Quantity::Area, L"SideArea", L"AREA_FORM_SIDE", 
MM2_to_M2),
        Quantity(Quantity::Volume, L"GrossVolume", L"VOLUME_GROSS", 
MM3_to_M3),
        Quantity(Quantity::Volume, L"NetVolume", L"VOLUME_NET", 
MM3_to_M3),
        Quantity(Quantity::Weight, L"GrossWeight", L"WEIGHT_GROSS"),
        Quantity(Quantity::Weight, L"NetWeight", L"WEIGHT_NET"),
        Quantity(Quantity::Length, L"Perimeter", L"PERIMETER")} },
    /*! Hard coded IfcBuildingElementProxy quantities */
    { ENTITY_IfcBuildingElementProxy, Qto_BuildingElementProxyQuantities {
        Quantity(Quantity::Area, L"NetSurfaceArea", L"AREA_NET", 
MM2_to_M2),
        Quantity(Quantity::Volume, L"NetVolume", L"VOLUME_NET", 
MM3_to_M3)} },
    /*! Hard coded IfcCovering quantities */
    { ENTITY_IfcCovering, Qto_CoveringBaseQuantities {
        Quantity(Quantity::Length, L"Width", L"WIDTH"),
        Quantity(Quantity::Area, L"GrossArea", L"AREA_GROSS", MM2_to_M2),
        Quantity(Quantity::Area, L"NetArea", L"AREA_NET", MM2_to_M2)} },
    /*! Hard coded IfcReinforcingBar quantities */
    { ENTITY_IfcReinforcingBar, Qto_ReinforcingElementBaseQuantities {
        Quantity(Quantity::Length, L"Length", L"LENGTH"),
        Quantity(Quantity::Weight, L"Weight", L"WEIGHT") } },
    /*! Hard coded IfcOpeningElement quantities */
    { ENTITY_IfcOpeningElement, Qto_OpeningBaseQuantities {
        Quantity(Quantity::Length, L"Width", L"WIDTH"),
        Quantity(Quantity::Length, L"Height", L"HEIGHT"),
        Quantity(Quantity::Area, L"Area", L"AREA", MM2_to_M2),
        Quantity(Quantity::Volume, L"Volume", L"VOLUME", MM3_to_M3)} },
    /*! Hard coded IfcRoof quantities */
    { ENTITY_IfcRoof, Qto_RoofBaseQuantities {
        Quantity(Quantity::Area, L"GrossArea", L"AREA_GROSS", MM2_to_M2),
        Quantity(Quantity::Area, L"NetArea", L"AREA_NET", MM2_to_M2),
        Quantity(Quantity::Area, L"ProjectedArea", 
L"AREA_PROJECTION_GXY_NET", MM2_to_M2)} },
    /*! Hard coded IfcRailing quantities */
    { ENTITY_IfcRailing, Qto_RailingBaseQuantities{
        Quantity(Quantity::Length, L"Length", L"LENGTH")} },
    /*! Hard coded IfcRampFlight quantities */
    { ENTITY_IfcRampFlight, Qto_RampFlightBaseQuantities{
        Quantity(Quantity::Length, L"Length", L"LENGTH"),
        Quantity(Quantity::Length, L"Width", L"WIDTH"),
        Quantity(Quantity::Area, L"GrossArea", L"AREA_GROSS", MM2_to_M2),
        Quantity(Quantity::Area, L"NetArea", L"AREA_NET", MM2_to_M2),
        Quantity(Quantity::Volume, L"GrossVolume", L"VOLUME_GROSS", 
MM3_to_M3),
        Quantity(Quantity::Volume, L"NetVolume", L"VOLUME_NET", 
MM3_to_M3)} },
    /*! Hard coded IfcStairFlight quantities */
    { ENTITY_IfcStairFlight, Qto_StairFlightBaseQuantities{
        Quantity(Quantity::Length, L"Length", L"LENGTH"),
        Quantity(Quantity::Volume, L"GrossVolume", L"VOLUME_GROSS", 
MM3_to_M3),
        Quantity(Quantity::Volume, L"NetVolume", L"VOLUME_NET", 
MM3_to_M3)} }
};
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DSTV file description
Tekla Structures produces NC files in DSTV format. DSTV format is an industrial
standard defined by the German Steel Construction Association (Deutsche
Stahlbau-Verband). A DSTV file is a text file in ASCII format. In most cases each
part has its own DSTV file.

To learn more about the DTSV syntax, see Standard Description for Steel
Structure Pieces for the Numerical Controls.

Blocks

The DSTV file is divided into blocks that describe the content of the file.

DSTV block Description
ST Start of the file
EN End of the file
BO Hole
SI Hardstamp
AK External contour
IK Internal contour
PU Powder
KO Mark
KA Bending

Profile types

Profile types are named according to the DSTV standard.

DSTV profile type Description
I I profiles
U U and C profiles
L L profiles
M Rectangular tubes
RO Round bars
RU Round tubes
B Plate profiles
CC CC profiles
T T profiles
SO Z profiles and all the other types of

profile

Part faces

Single letters in the DSTV file describe the part faces.
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Letter Part face
v front
o top
u bottom
h behind

tekla_dstv2dxf_<env>.def file description
The tekla_dstv2dxf_<env>.def file is used when converting from the DSTV
to the DXF format using the tekla_dstv2dxf.exe. It contains all the
necessary conversion settings. The .def file is located in the ..\Tekla
Structures\<version>\bin\applications\Tekla\Tools\dstv2dxf
folder.

The DSTV to DXF conversiong settings are described below.

Environment settings [ENVIRONMENT]

INCLUDE_SHOP_DATA_SECTION=FALSE

Specify whether to include a special data section in the DXF file to allow the
DXF file to be better imported into CNC software written by Shop Data
Systems. Including this special data section in the DXF file makes the DXF file
unreadable by AutoCAD.

Options: TRUE, FALSE
NO_INFILE_EXT_IN_OUTFILE=TRUE

Use to add the input file extension to the output file.

Options:

TRUE: p1001.dxf

FALSE: p1001.nc1.dxf

DRAW_CROSSHAIRS=HOLES
Draw crosshair for holes and slotted holes.

Options: HOLES, LONG_HOLES, BOTH, NONE
HOLES:

LONG_HOLES:
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BOTH:

NONE:

SIDE_TO_CONVERT=FRONT

Define which side of the member to convert.

Options: FRONT, TOP, BACK, BELOW
Defines which part face is shown in the DXF file. This setting is originally
designed for plates.

FRONT is the most typical option. Sometimes you may need another rotation
for a plate, and then you can try if changing this setting to BACK would help. In
addition to the SIDE_TO_CONVERT setting, it requires that the NC files are
created with the advanced option 
XS_DSTV_WRITE_BEHIND_FACE_FOR_PLATE set to TRUE, which will include
the back side data of a plate in the NC file.

OUTPUT_CONTOURS_AS=POLYLINES

Convert contours as polylines or lines and arcs.

Options: POLYLINES, LINES_ARCS

NOTE If you set OUTPUT_CONTOURS_AS=LINES_ARCS:

• Slotted holes may sometimes have a gap/offset between a straight
line and an arc.

• Sometimes a 3D DXF is produced instead of a 2D DXF.

If you set OUTPUT_CONTOURS_AS=POLYLINES, the DXF file may not be
correct if the NC is created with the Inner corner=0 setting.
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CONTOUR_DIRECTION=REVERSE

Define the contour direction. This option changes the coordinates of the
vertices, and the order they are written. You can see the difference if you open
the DXF file in a text editor: "reverse" is clockwise and "forward" is counter-
clockwise.

Options: REVERSE, FORWARD
CONTOUR_DIRECTION only works if you have set 
OUTPUT_CONTOURS_AS=POLYLINES. If you have set it to use LINES_ARCS, the
output is always FORWARD (counter-clockwise).

CONVERT_HOLES_TO_POLYLINES=TRUE

Convert holes to polylines.

Options: TRUE, FALSE
MAX_HOLE_DIAMETER_TO_POINTS=10.0

Convert small holes to points in the DXF file.

When you set MAX_HOLE_DIAMETER_TO_POINTS to a value, the holes with a
diameter smaller than this value will follow the HOLE_POINT_SIZE and 
HOLE_POINT_STYLE settings. With this kind of point visualization, the hole
symbols will no longer show if a hole is bigger or smaller than the other one,
but they will all have the same size.

HOLE_POINT_STYLE=33 and HOLE_POINT_SIZE=5

Point style and size for holes.
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1 is a circle, but this setting is not in use

2 is +

3 is X

4 is short line

33 is circle

34 is a circle with +

35 is a circle with X

36 is a circle with short line

SCALE_DSTV_BY=0.03937

Use 0.03937 to scale to imperial units.

Use 1.0 to scale to metric units.

ADD_OUTER_CONTOUR_ROUNDINGS=FALSE

Add holes to roundings. This only affects the roundings that are created using
the Inner corners shape: 1 setting in the NC file settings dialog box on the
Holes and cuts tab. The hole size information is coming to the DSTV file from
the Radius value in the NC file settings dialog box, and you cannot adjust the
hole size in the dstv2dxf converter.

Options: TRUE, FALSE
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ADD_OUTER_CONTOUR_ROUNDINGS=FALSE:

ADD_OUTER_CONTOUR_ROUNDINGS=TRUE:

MIN_MATL_BETWEEN_HOLES=2.0

Define how close the holes can be to each other in slotted hole conversion.

INPUT_FILE_DIR= and OUTPUT_FILE_DIR=

Folders for input and output files.

DEBUG=FALSE

Show data processing in the DOS window.

Options: TRUE or FALSE

Text specifications [TEXT_SPECS]

TEXT_OPTIONS=PQDG

Define the text options that you want to use in the DXF file:

S adds a side mark (Side: v)

P adds a part mark (Part: P/1)

B adds a part mark and side mark (Part: P/1 Side: v)

Q adds the quantity (Quantity: 5)

G adds the steel grade (Material: A36)

T adds the thickness (Thickness: 3)
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D adds the profile description (Desc: FL5/8X7)

TEXT_POSITION_X=30.0 and TEXT_POSITION_Y=30.0

The X/Y location of lower-left corner of first line of text from the origin point
<0,0> of the DXF file.

TEXT_HEIGHT=0.0

TEXT_HEIGHT is not used, the text height is always 10.0, also in text layers.

Text item prefixes

You can define several different prefixes for text items. The prefix is only
written in the file if the option CONCATENATE_TEXT is set to 0.

You can use the following prefix definitions:

PART_MARK_PREFIX=Part:
SIDE_MARK_PREFIX=Side:
STEEL_QUALITY_PREFIX=Material:
QUANTITY_PREFIX=Quantity:
THICKNESS_PREFIX=Thickness:
DESCRIPTION_PREFIX=Desc:
CONCATENATE_TEXT=1

Combine text items (part mark, quantity, profile, grade) into one or two lines.

Options:

0: Text lines are not combined. Prefixes work only with this option.

1: Part mark text on one line, other texts combined on another line.

2: All text on one line.

CONCATENATE_CHAR=+

Define a separator of max 19 characters for the text items.

Examples of different text specifications

The following settings are used the example below:

TEXT_OPTIONS=PQDG
TEXT_POSITION_X=30.0
TEXT_POSITION_Y=30.0
TEXT_HEIGHT=0.0
PART_MARK_PREFIX=Part:
SIDE_MARK_PREFIX=Side:
STEEL_QUALITY_PREFIX=Material:
QUANTITY_PREFIX=Quantity:
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THICKNESS_PREFIX=Thickness:
DESCRIPTION_PREFIX=Desc:
CONCATENATE_TEXT=1
CONCATENATE_CHAR=+

The following settings are used for the example below: TEXT_OPTIONS=B,
CONCATENATE_TEXT=0:

Miscellaneous layers [MISC_LAYERS]

Entity Layer Name Col
or

Text Height Output as

TEXT TEXT 7 Not used,
always the
same as the
general text
height
definition 10.0.

 

OUTER_CONTOUR CUT 7   
INNER_CONTOUR CUTOUT 4   
PART_MARK SCRIBE 3 Do not set a

value for this
option. If you
set one, the
DXF file will not
be created.
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Entity Layer Name Col
or

Text Height Output as

PHANTOM LAYOUT 4   
NS_POP_PMARK NS_POP_MAR

K
5  POP_CIRCLE

2.0
(POP_CIRCLE
or POP_POINT
followed by
size)

FS_POP_PMARK FS_POP_MAR
K

6 1.0

This ‘1.0’ is the
diameter of the
hole used for
far side pop
marks. It must
match the
value in the
“drill thru”
option in the
machinex.ini
file

POP_CIRCLE
2.0
(POP_CIRCLE
or POP_POINT
followed by
size)

Color table

1 = red

2 = yellow

3 = green

4 = cyan

5 = blue

6 = magenta

7 = white

8 = dark grey

9 = light grey

Hole layers [HOLE_LAYERS]

Layer Name Min Diam Max Diam Color
P1 8.0 10.31 7
P2 10.32 11.90 7
P3 11.91 14.0 7
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Slot layers [SLOT_LAYERS]

The type and color affect the symbol, but the color of the slot outline or arrow
(phantom) is defined by the PHANTOM layer definition in the MISC_LAYERS
definition.

Layer
Name

Min
Dia
m

Max
Dia
m

Min
‘b’

Max
‘b’

Min
‘h’

Max
‘h’

Typ
e

Colo
r

Phantom

13_16x1 20.6
2

20.6
5

4.75 4.78 0.0 0.02 3 3 PHANTOM_O
UTLINE

13_16x1-7_
8

20.6
2

20.6
5

26.9
7

26.9
9

0.0 0.02 3 3 PHANTOM_O
UTLINE

Below there are three examples with different phantom types. The other
settings used are Slot type=1, HOLE_POINT_STYLE=33 and 
HOLE_POINT_SIZE=1
PHANTOM_ARROW:

PHANTOM_BOTH:

PHANTOM_OUTLINE:

PHANTOM_NONE:

For an explanation of the “b” and “h” dimensions, see the image below:
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Examples of slot types

These example use different slot types, but the other setting are the same:

• Slot layer color is 3 (green).

• Hole layer color is 6 (magenta).

• Phantom layer color is 1 (red).

• Slot layer phantom type: PHANTOM_OUTLINE
• Hole point settings: HOLE_POINT_STYLE=35, HOLE_POINT_SIZE=10

Slot type Description
SLOT_TYPE_1 One hole symbol to the center of slot. The hole symbol

follows the HOLE_POINT_STYLE and HOLE_POINT_SIZE
settings. The slot symbol is created according to the
selected phantom setting (PHANTOM_OUTLINE in this
example). The circle color follows the slot layer color, and
the slot color follows the phantom layer color.

SLOT_TYPE_2 Two hole symbols to the slot. The hole symbol follows the 
HOLE_POINT_STYLE and HOLE_POINT_SIZE settings.
The slot symbol is created according to the selected
phantom setting (PHANTOM_OUTLINE in this example).
The hole symbol color follows the hole layer color, and
the slot color follows the phantom layer color.

SLOT_TYPE_3 One circle to the center of slot. The size of the circle
corresponds to the real hole size. The circle color follows
the slot layer color, and the slot color follows the
phantom layer color. The slot symbol is created according
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Slot type Description
to the selected phantom setting (PHANTOM_OUTLINE in
this example).

SLOT_TYPE_4 Two circles to the slot. The size of the circle corresponds
to the real hole size. If the circles would be touching each
other, only one circle in the middle of slot is created. The
slot symbol is created according to the selected phantom
setting (PHANTOM_OUTLINE in this example). The circle
color follows the hole layer color, and the slot color
follows the phantom layer color.

SLOT_TYPE_5 Hole symbol to the first slot center point. The hole
symbol follows the HOLE_POINT_STYLE and 
HOLE_POINT_SIZE settings. The slot symbol is created
according to the selected phantom setting
(PHANTOM_OUTLINE in this example). The hole symbol
color follows the hole layer color, and the slot symbol
color follows the phantom layer.

SLOT_TYPE_6 One circle to the first slot center point. The slot symbol is
created according to the selected phantom setting
(PHANTOM_OUTLINE in this example). The circle color
follows the hole layer color, and the slot symbol color
follows the phantom layer color.

SLOT_TYPE_7 No hole symbol is created. The slot symbol is created
according to the selected phantom setting
(PHANTOM_OUTLINE in this example). The slot color
follows the slot layer color.

ASCII file description

In an import.asc file each part is described by 8 lines. These lines are
repeated for each part to be transferred. Units are always in millimeters,
blanks are used as separators.

Below is an example of a beam part description:
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Line Description
Line 1 4169 HEA300 1 = ID profile type

• ID 4169: Unique ID (integer).

• PROFILE HEA300: Profile name (string).

• TYPE 1: Profile type (integer)

The available profile types are:

0 = free cross section (can be used for special profiles which are not in
the database)

1 = I profiles

2 = Welded hollow core profiles (HK, HQ)

3 = U profiles

4 = L profiles

5 = Round bars

6 = Round tubes

7 = Rectangular hollow core sections (RHS, P)

8 = T profiles

9 = Rectangular bars (FL, PL)

10 = Z profiles

11 = C profiles

12 = Omega profiles

13 = Sigma profiles

14 = Rail profile

16 = Reinforcement bars (DH)
Line 2 The contents of line 2 depend on the part profile.

• Polygon plates:

N_POINTS COORDINATES
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Line Description
N_POINTS: For profiles of type 0.

COORDINATES: Number of the corner points (integer).

The X and Y coordinates of the plate corners (floating). Rotation
direction is clockwise. Coordinates follow the global coordinate
system. Z coordinates are taken from the center line in the plate
thickness direction.

Note that the line 2 can be divided into several rows in the file.

• Profiles:

For profile types 1-16, the line includes the physical dimensions of
the cross section.

HEIGHT S W1 T1 W2 T2: 290.000000 8.500000 300.000000
14.000000 300.000000 14.000000
• HEIGHT 290.000000: Height of the cross section

• S 8.500000: Web thickness.

• W1 300.000000: Width of the upper flange.

• T1 14.000000: Thickness of the upper flange.

• W2 300.000000: Width of the lower flange.

• T2 14.000000: Thickness of the lower flange.
Line 3 A/6 BEAM = mark name

• MARK A/6: Position mark of the part (string).

• NAME BEAM: Part name (string).
Line 4 S235JR S235JR = material

Material of the part (string).
Line 5 0.000000 = rotation

Rotation angle (in degrees) around the local x-axis of the beam.
Line 6 16.500000 24000.000000 4855.000000 = X1 Y1 Z1

Coordinates of the beam start point. Z coordinates are center-line
coordinates.

Line 7 6000.000000 24000.000000 4855.000000 = X2 Y2 Z2

Coordinates of the beam end point. Z-coordinates are center-line
coordinates.

Line 8 16.500000 24000.000000 5855.000000 = X3 Y3 Z3

Direction vector showing the direction of the local z-axis.

Start new projects as a Tekla Structures
administrator

224 Set up a project for collaboration and
interoperability



4.8 Customize catalogs and databases
You can customize catalogs and databases to contain the only relevant content
for your project. Customizing catalogs and databases helps you to simplify
your work and avoid mistakes.

You can customize catalogs and databases for:

• materials

• profiles

• shapes (page 294)

• bolts (page 314)

• rebars (page 328)

• applications and components (page 339)

Always ensure that the catalog content is correct. Mistakes in catalogs might
lead to serious inconsistencies in quantity information, data transfer, or other
calculations. For example, incorrect material density leads to systematic errors
in reported weights.

You can add new content to catalogs from other environments, from Tekla
Warehouse, or import content created in other software solutions.

Additional content in Tekla Warehouse
In Tekla Warehouse, you can find additional content, such as application tools
and environment content.

You can download Tekla Warehouse offline content that includes the catalog
content of environments, such as profiles, bolts, materials, and
reinforcements. The content is in .tsep packages that are installed when you
open Tekla Structures.

The offline catalog content is under Tekla Structures collections in Tekla
Warehouse. To find this content, search for Catalogs, then under Show select
Collections.

You can also create a local collection for your company, and share it with your
organization in your internal network. You can manage the access rights on
the folder and collection level in the collections.json file on each user's
computer. Copy the file to the same location on each user's computer. The file
is located in C:\Users\Public\Public Documents\Trimble\Tekla
Warehouse\collections.json.

This image shows an example of the collection paths with four Tekla Structures
collections:
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In Tekla Warehouse the collections are found after mapping under My
collections --> Local and network collections .

Customize the material catalog
The material catalog contains information about material types and grades.
Materials are shown in a hierarchical tree grouped according to their types,
with material grades listed under each material type.

The following material types are available in Tekla Structures:

• Steel

• Concrete

• Reinforcing bar

• Timber

• Miscellaneous

By default, the material catalog contains standard, environment-specific
materials. You can add, modify, and delete material grades.

Tekla Structures stores the material information in the matdb.bin file.

Important buttons in the material catalog
When you work with the material grades, note the usage of the following
buttons in the Modify Material Catalog dialog box:
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Button Description
Saves the changes of a single edited material grade to the
computer’s memory until you click OK.
Saves the changes in the model folder.

Tekla Structures saves the modified catalog on the hard disk
when you click OK to close the dialog box and then click OK in
the Save confirmation dialog box.
Closes the Modify Material Catalog dialog box without
saving the changes.

Note that all changes made to the catalog will be lost even if
you have clicked Update, because the changes have not been
saved on the hard disk. The changes made to the catalog are
visible during one session, because the catalog is using the
computer’s memory. When you start Tekla Structures the
next time, the previous data is restored from the hard disk.

Tekla Structures stores the material information in the matdb.bin file. When
you first open a model, Tekla Structures reads the data from the hard disk and
stores it in the computer’s memory.

When you select a material, Tekla Structures reads the data from the
computer’s memory and displays it in the Modify Material Catalog dialog
box. This is faster than accessing the data from the hard disk.

Add a material grade
1. On the File menu, click Catalogs --> Material catalog to open the Modify

Material Catalog dialog box.

2. Select a material type, for example, steel.

3. Right-click and select Add Grade. 

A new material grade is added under to the material type you selected.

4. Change the material grade name by clicking the grade and entering a new
name for it.

5. Enter the material grade properties.

6. Click OK to save the material grade and close the Modify Material
Catalog dialog box.

7. Click OK in the Save confirmation dialog box to save the changes.

Copy a material grade
You can add new material grades by modifying a copy of an existing, similar
material grade.
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1. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

2. Select a material grade that is similar to the one that you want to create.

3. Right-click and select Copy Grade. 

A copy of the material grade with the name COPY is added to the material
tree.

4. Change the material grade name by clicking the grade and entering a new
name for it.

5. Modify the material grade properties.

6. Click OK to save the material grade and close the Modify Material
Catalog dialog box.

7. Click OK in the Save confirmation dialog box to save the changes.

Modify a material grade
You can modify existing material grades using the material catalog.

1. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

2. Select a material grade in the tree and modify its properties. 

• Use the General tab for entering three alternative names for the
material. The names are usually the material names used in different
countries or standards. The tab also contains the profile and plate
density values.

• Use the Analysis tab for entering information on the properties used
in structural analysis.

• Use the Design tab for entering information on the design-specific
properties, such as strengths and partial safety factors.

• Use the User attributes tab for creating your own attributes for
material grades.

For example, you can define a paint layer thickness, or the maximum
grain size of concrete using a user-defined attribute.

3. When you have finished modifying the material grade, click Update.

4. Click OK to close the Modify Material Catalog dialog box. 

Tekla Structures asks if you want to save the changes to the model folder.

5. Click OK in the Save confirmation dialog box to save the changes. 

The modified material catalog is saved in the current model folder and is
available only for that model. To make the modified catalog available for
all the other models, use export and import.
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Delete a material grade
1. On the File menu, click Catalogs --> Material catalog to open the Modify

Material Catalog dialog box.

2. Select the material grade that you want to delete.

3. Right-click and select Delete Grade.

4. Click OK to close the Modify Material Catalog dialog box.

5. Click OK in the Save confirmation dialog box to save the changes.

Add user attributes to material grades
You can add user attributes and their values to the material grades. The user
attributes can then be used, for example, in filtering.

1. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

2. On the User attributes tab, click Definitions to open the Modify
Material Properties dialog box.

3. Click Add to add a new row.

4. To define a user attribute, click each item on a row.

a. In the Category list, select a material category to which the user
attribute is applied.

b. In the Design code list, select a design code to which the attribute is
added.

c. In the Material type list, select a material type for the attribute.

d. In the Quantity type list, select the type of information that the user
attribute contains, for example, weight, area, ratio, or string.

e. In the Order column, define the order in which the user attributes are
shown in the dialog box. Smaller values are shown first.

f. In the Property name column, define a name for the property. 

The name is saved in the catalog and can be used in reports and
templates. When Property name is used in a template, 
MATERIAL.PROPERTY_NAME indicates where the property name
appears.

g. In the Label column, define a label for the attribute.

5. Click Update.

6. Click OK to close the Modify Material Properties dialog box.
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Create user-defined material definitions
You can replace the existing material definitions with your own definitions and
use them, for example, in drawing part marks. Material definitions can contain
text, numbers and symbols.

1. Save the symbol file user_material_symbols.sym in the symbol folder
(usually the folder ..\ProgramData\Trimble\Tekla Structures
\<version>\environments\common\symbols\).

2. In a text editor, such as Microsoft Notepad, create a text file that contains
your material definitions. 

Each row in the file defines a material. Use the following syntax: 
material_name symbol_file_name@n, where

• material_name is the name of the material used in the material
catalog

• symbol_file_name is the symbol file name to be used

• n is the number of the symbol.

For example:

S235JRG1    user_material_symbols@1    B
S235JRG2    user_material_symbols@2    C
S235JR      user_material_symbols@0    A
S275JR      user_material_symbols@3    D
S235JR      user_material_symbols@4    E

WARNING The order of material names in the definition file affects the
conversion. Materials with more specific names must be
listed before the ones with similar, but simpler names, such
as S235JRG1, must be listed before S235JR. Otherwise they
both get the same symbol.

3. Save the file for example with the name
user_material_definitions.txt. 

All the named materials in the material catalog will be replaced with the
ones defined in this file.

4. Set the name of the file as a value for the advanced option 
XS_MATERIAL_SYMBOL_REPRESENTATION_FILE in File menu -->
Settings --> Advanced options --> Drawing Properties as follows: 

set XS_MATERIAL_SYMBOL_REPRESENTATION_FILE=user_material_definitions.txt

You can also enter a full path to the material definition file. Without the
path, Tekla Structures searches for the file in the model, firm, project, and
system folders.
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About importing and exporting material grades
Use importing and exporting for merging material catalogs. Material catalogs
are imported and exported as .lis files.

Importing and exporting is useful when you:

• upgrade to a newer version of Tekla Structures and want to use a
customized material catalog from a previous version

• want to combine material catalogs that are stored in different locations

• want to share material catalog information with other users

• want to combine material catalogs across different environments.

TIP You can also download or share material grades using .

Export a part of the material catalog
If you do not want to export the whole material catalog, you can export a
branch of the material tree, meaning all the material grades grouped under
one material type, or a single material grade. Material catalogs are exported
from Tekla Structures models as .lis files.

1. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

2. Select material grades to be exported. 

• To export a branch of the material tree, right-click the branch and
select Export Grades.

• To export a single material grade, right-click the material grade and
select Export Grade.

3. Browse for the folder where you want to save the export files. 

By default, the file is saved to the current model folder.

4. Enter a name for the file and click OK.

5. Click OK to close the Modify Material Catalog dialog box.

6. Click OK in the Save confirmation dialog box to save the changes.

Export an entire material catalog
Exporting and importing are used to merge material catalogs. Material
catalogs are exported from Tekla Structures models as .lis files. Note that
the Export command exports the entire catalog.

1. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

2. Click Export.
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3. Browse for the folder where you want to save the exported file. 

By default, the file is saved to the current model folder.

4. Enter a name for the file and click OK.

5. Click OK to close the Modify Material Catalog dialog box.

6. Click OK in the Save confirmation dialog box to save the changes.

Import a material catalog
Material catalogs are imported to Tekla Structures models as .lis files. You
can move an exported .lis file to any model folder and import it to an
existing material catalog.

1. Open the model to which you want to import a material catalog.

2. On the File menu, click Catalogs --> Material catalog to open the Modify
Material Catalog dialog box.

3. Click Import.

4. Browse for the folder that contains the import file, and select the file.

5. Click OK. 

If a material with a same name as the material being imported already
exists, the Import confirmation dialog box appears and you have three
options:

• Replace: The existing material is replaced with the imported material.

• Merge: Material properties that are different in the import file are
added to the existing material. All the other properties remain
unchanged.

Use this option to import only certain elements of the material catalog,
such as user attributes.

• Leave: The existing material is not replaced and the material
definitions in the import file are ignored.

If you select the Apply for all check box, Tekla Structures uses the same
option (Replace, Merge, or Leave) for all the existing materials that have
the same name as the one being imported.

If a user attribute with a different definition already exists, you are
prompted to Replace or Leave the existing attribute.

6. Click OK to close the Modify Material Catalog dialog box.

7. Click OK in the Save confirmation dialog box to save the changes.

Units used in import and export
This table lists the units Tekla Structures uses when importing and exporting
profile catalogs and material catalogs.
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Type Unit (if blank, no unit)
Boolean  
Integer  
String  
Ratio  
Strain  
Angle degree
Length mm
Deformation mm
Dimension mm
Radius of inertia mm
Area mm2

Reinforcement area mm2

Transverse reinforcement area mm2/m
Area/unit length mm2/m
Volume mm3

Section modulus mm3

Moment of inertia mm4

Torsion constant mm4

Warping constant mm6

Force N
Weight kg
Distributed load N/m
Spring constant N/m
Mass/length kg/m
Surface load N/m2

Strength N/m2

Stress N/m2

Modulus N/m2

Density kg/m3

Moment Nm
Distributed moment Nm/m
Rotation spring constant Nm/rad
Temperature K (°C)
Thermal dilation coefficient 1/K (1/°C)
Factor  
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Customize the profile catalog
The profile catalog contains information about profiles, their rules and types,
and the analysis and design properties of the profiles. Profiles are shown in a
hierarchical tree grouped according to the rules.

By default, the profile catalog contains standard, environment-specific profiles
and generic parametric profiles. You can add, modify, import, export, and
delete profiles.

You can define your own user-defined profiles, which can be either fixed or
parametric. Use the profile catalog to create new fixed profiles, either from
scratch or by copying an existing one. Use the sketch editor or .clb files to
create new parametric profiles.

Tekla Structures stores the profile catalog information in the profdb.bin file.

Important buttons in the profile catalog
When you work with the profiles, note the usage of the following buttons in
the Modify Profile Catalog dialog box:

Button Description
Saves the changes of a single edited profile to the computer’s
memory until you click OK.
Saves the changes in the model folder.

Tekla Structures saves the modified catalog on the hard disk
when you click OK to close the dialog box and then click OK in
the Save confirmation dialog box.
Closes the Modify Profile Catalog dialog box without saving
the changes.

Note that all changes made to the catalog will be lost even if
you have clicked Update, because the changes have not been
saved on the hard disk. The changes made to the catalog are
visible during one session, because the catalog is using the
computer’s memory. When you start Tekla Structures the
next time, the previous data is restored from the hard disk.

Tekla Structures stores the information of fixed profiles in the profdb.bin
file. When you first open a model, Tekla Structures reads the data from the
hard disk and stores it in the computer’s memory.

When you select a profile, Tekla Structures reads the data from the computer’s
memory and displays it in the Modify Profile Catalog dialog box. This is faster
than accessing the data from the hard disk.
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How profiles are grouped together
In the profile catalog, the profiles are displayed in a hierarchical tree and they
are grouped according to rules , such as the profile type (for example, I
profiles) and the profile subtype (for example, HEA). To change how the
profiles are grouped in the profile tree, you need to modify the rules.

The order in which you create the rules does not matter, only the location of
the rules in the profile tree.

Tekla Structures reads the rules from top to bottom in the profile tree. Profiles
are in the highest group where they meet the criteria defined in the rule. For
example, a rule that collects All profiles overrides all rules that are below it in
the profile tree.

Add a rule to the profile catalog
1. On the File menu, click Catalogs --> Profile catalog to open the Modify

Profile Catalog dialog box.

2. Right-click any existing rule and select Add Rule. 

TIP You can add a next level rule that creates a subgroup under an
existing rule. Use the Add Next Level Rule command to add the
next level rule.

The Profile manager rules dialog box appears.

3. Define the rule properties.

a. Enter a rule name in the Rule name box.

b. Select the Profile type to which the rule is applied.

c. Enter the Name filter string that defines the new rule. 

By default, the wildcard symbol (*) is entered, meaning “all entries”.

For example, to group all catalog entries with names beginning with
A, enter A* in the Name filter string box, or to group all catalog
entries with names containing 100, enter *100*. Tekla Structures
groups the catalog entries that meet your criteria under the new rule.

4. Click OK to close the Profile manager rules dialog box.

5. Click OK to close the Modify Profile Catalog dialog box.

6. Click OK in the Save confirmation dialog box to save the changes.
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Modify a rule in the profile catalog
Profiles in the profile tree are listed in an alphabetical order, and rules are
listed in the order you specify. To change the order in which the rules appear,
use the Move up and Move down commands.

TIP If you want to delete a rule, right-click an existing rule and select Delete
Rule.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Right-click any existing rule and select Edit Rule. 

The Profile manager rules dialog box appears.

3. Modify the rule properties.

4. Click OK to close the Profile manager rules dialog box.

5. Click OK to close the Modify Profile Catalog dialog box.

6. Click OK in the Save confirmation dialog box to save the changes.

See also

• Wildcards

Add user attributes to profiles
You can add your own attributes to profiles. For example, you can specify paint
layer thickness, define the maximum grain size of concrete, sort out different
profile types by material, or create profile aliases for converting between
imperial and metric profiles.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. On the User attributes tab, click Definitions. 

The Modify Profile Properties dialog box appears.

3. Click Add to add a new row.

4. To define a user attribute, click each item on a row.

a. In the Profile type list, select a profile type to which the user attribute
is applied.

b. In the Quantity type list, select the type of information that the user
attribute contains, for example, weight, area, ratio, or string.

c. In the Order list, define the order in which the user attributes are
shown in the dialog box. Larger values are shown first.

d. In the Property name list, define a name for the property. 

The name is saved in the catalog and can be used in reports and
templates. When Property name is used in a template, 
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PROFILE.PROPERTY_NAME indicates where the property name
appears. For example, PAINT_LAYER_THICKNESS.

e. In the Symbol column, define an abbreviation that can be used for
the property, such as Ix or ct.

f. In the Label column, define a label for the attribute.

5. Click Update.

6. Click OK to close the Modify Profile Properties dialog box.

Example: Add a user attribute to a profile and use it in a rule

You can add your own attributes and their values to profiles. The user
attributes can then be used, for example, in profile filtering.

This example shows how to add a user attribute for the rule for I profiles.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. On the User attributes tab, click Definitions.

The Modify Profile Properties dialog box appears.

3. Click Add to add a new row, then select the row and modify the properties
as follows:

• Set Profile type to I profiles.

• Set Quantity type to String.

• Set Property name to HISTORICAL_PROFILE.

• Set Symbol to Hist.

• Set Label to Historical profile.

4. Click Update, then click OK.

5. In the profile tree, select I profiles, then select HEA.

6. Right-click and select Add Next Level Rule.

7. In the Profile manager rules dialog box, set the rule properties as
follows:

• Set Rule name to Historical profiles.
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• In Profile type, clear the All profiles check box and select the I
profiles check box.

• Enter HEA* in the Name filter string box.

• Set User attribute to HISTORICAL_PROFILE and Equals, and enter
Yes in the box next to the two other boxes.

8. Click OK.

Historical profiles appears in the profile tree.

9. Select the required historical profile, such as HEA120, in the profile tree.
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10. On the User attributes tab, and change the Value field for Historical
profile to Yes.

11. Click Update.

12. Click OK to close the Modify Profile Catalog dialog box.

13. Click OK in the Save confirmation dialog box to save the changes.

The next time that you open the profile catalog, the profiles appear under
Historical profiles in the profile tree.

Associate profile types with a certain material
You can define which profiles are available for steel parts, concrete parts, or
both. The associated profile type affects which profile types are shown in the
Select Profile dialog box when you change the material of a part.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Select a profile type, for example, L profiles.

3. To associate the profiles with steel, right-click and select Material -->
Steel . 
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A check mark next to Steel indicates that the profiles are available for
steel parts.

4. To also make the selected profiles available for concrete parts, right-click
and select Material --> Concrete . 

If needed, you can remove the check mark by clicking the material again.

5. Click OK to close the Modify Profile Catalog dialog box.

6. Click OK in the Save confirmation dialog box to save the changes.

See also

• Select and change the profile or material of a part

Delete a profile from the profile catalog
1. On the File menu, click Catalogs --> Profile catalog to open the Modify

Profile Catalog dialog box.

2. Select the profile that you want to delete.

3. Right-click and select Delete Profile.

4. Click OK to close the Modify Profile Catalog dialog box.

5. Click OK in the Save confirmation dialog box to save the changes.

Tekla Structures continues to show parts that use the deleted profiles in model
views until you modify the parts or reopen the model. After that, parts that
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have profiles that are not available in the profile catalog, are shown as sticks
without a profile.

If the deleted profile used a custom cross-section definition, delete it
separately to remove the cross-section from your model.

Import and export profiles
Import and export profiles to merge profiles across profile catalogs.

Profile catalogs are imported and exported as .lis files, sketched profiles
as .uel files, and user-defined parametric profiles as .clb files.

When you export an entire profile catalog, Tekla Structures creates three
separate files: profiles.clb, profiles.lis and rules.lis. The .clb file
contains parametric profile definitions, if they are used in the profiles in the
catalog, otherwise it is empty. The profiles.lis file includes the actual
profile definitions and the rules.lis file the branch rules. When you export a
branch of a profile catalog, the branch name is attached as prefix to the file
names.

Importing and exporting is useful when you:

• upgrade to a newer version of Tekla Structures and want to use a
customized profile catalog from a previous version

• want to combine profile catalogs that are stored in different locations

• want to share profile catalog information with other users

• want to combine profile catalogs across different environments.

Limitations of importing and exporting profiles

• You cannot import or export hard-coded profiles such as PROFILE_ZZ,
PROFILE_CC, and PROFILE_CW.

• You cannot import profiles that do not have a defined cross section.

• If you have used a sketched profile or a user-defined parametric profile as
the cross section for a fixed profile, you also need to import the sketched
profile or the user-defined parametric profile to the new model.

TIP You can also download or share profiles using Tekla Warehouse.

Import profile catalog items
Tekla Structures has five types of profile catalog items: fixed profiles, hard-
coded parametric profiles, sketched profiles, user-defined parametric profiles,
and rule sets. Profiles and rule sets are imported to Tekla Structures models
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as .lis files, sketched profiles as .uel files, and user-defined parametric
profiles as .clb files.

If you are importing an entire profile catalog or a branch, we recommend that
you save the related files in a separate folder. This makes the import process
faster.

1. Open the model to which you want to import profile catalog items.

2. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

3. Click Import to import a single file, or Import Directory to import the
contents of a file folder.

4. Select the import file or the import folder.

5. Click OK. Tekla Structures checks if there are duplicates in the profile
names in the import file compared to the profile catalog.

a. If the Review import items dialog box appears, there are duplicate
profile names and you must select each duplicate and assign the
action you want to perform with the following buttons: 

• Leave: The existing profile item is not replaced and the profile
definitions in the import file are ignored.

• Merge: Profile properties that are different in the import file are
added to the existing profile. All the other properties remain
unchanged.

Use this option to import only certain elements of the profile
catalog, such as user attributes.

• Replace: The existing profile item is replaced with the imported
profile item.

• If you leave Unknown as the action for a profile item, it is not
imported.

You can select more than one profile item at a time by using the Shift
and Ctrl keys and assign the same action to the entire selection.

NOTE Each cross section definition has a unique name and ID
number. If during an import, a cross section with the same
name but different properties is found in the existing profile
catalog, the cross section being imported is renamed by
adding an incremental number at the end of the existing
name.

b. After you have selected the actions, click Continue to perform them.

6. Click OK to close the Modify Profile Catalog dialog box.

7. Click OK in the Save confirmation dialog box to save the changes.
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Test and approve the catalog content, then export the new catalog and set it
up to be used in models.

Export an entire profile catalog
Profile catalogs are exported from Tekla Structures models as .lis, .uel,
and .clb files.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Click Export.

3. Browse for the folder where you want to save the export files. 

By default, the files are saved to the current model folder. For faster
profile catalog import, we recommend that you create a separate sub-
folder for the catalog files.

4. Click OK to close the Modify Profile Catalog dialog box.

Set up the catalog to be used in models.

Export a part of the profile catalog
If you do not want to export an entire profile catalog, you can export a branch
of the profile tree, meaning all the profiles grouped under one rule, or a single
profile. Profiles and rule sets are exported from Tekla Structures models
as .lis files, sketched profiles as .uel files, and user-defined parametric
profiles as .clb files.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Select profiles to be exported. 

• To export a branch of the profile tree, right-click the branch and select
Export Profiles.

• To export a single profile, right-click the profile and select Export
Profile.

3. Browse for the folder where you want to save the export files. 

By default, the files are saved to the current model folder.

If you are exporting a single profile, enter a name for the file.

4. Click OK.

5. Click OK to close the Modify Profile Catalog dialog box.

Example of a profile export file

The export .lis file is divided into specific sections.

The first row in the file is PROFILE CATALOG EXPORT VERSION = n, where n
is the version number.
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WARNING Do not delete this row. If the row does not appear in the file, the
import is canceled.

The next section defines the hierarchical tree structure that is used to display
the contents of the catalog.

The section after that contains the profiles.

Fixed profiles

PROFILE_NAME = "HEA120";
{
TYPE = 1; SUB_TYPE = 1001; COORDINATE = 0.000;
{
"FLANGE_SLOPE_RATIO"    0.000000000E+000
"ROUNDING_RADIUS_2"     0.000000000E+000
"ROUNDING_RADIUS_1"     1.200000000E+001
"FLANGE_THICKNESS"      8.000000000E+000
"WEB_THICKNESS"         5.000000000E+000
"WIDTH"                 1.200000000E+002
"HEIGHT"                1.140000000E+001

Fixed user-defined profiles

Fixed user-defined profiles can have more than one cross section. The profile
type for fixed user-defined profiles is 998. SUB_TYPE refers to the name of the
cross section definition. When importing fixed user-defined profiles, the
relevant cross section definitions must be in the same import file as the
profile.

PROFILE_NAME = "TAN_HK_TEST_2_CS";
{
TYPE = 998; SUB_TYPE = 253; COORDINATE = 0.000;
{
"EQUIVALENT_TYPE"       11
"FLANGE_SLOPE_RATIO"    0.000000000E+000
"ECCENTRICITY_Y"        0.000000000E+000
"ECCENTRICITY_X"        0.000000000E+000
"ROUNDING_RADIUS_2"     0.000000000E+000
"FLANGE_THICKNESS_2"    0.000000000E+000
"WEB_THICKNESS_2"       0.000000000E+000

Cross section definitions

CROSS_SECTION_NAME = "MY_OWN_PROFILE
POINT_NUMBER = 1;
POINT_X =  200.00;
POINT_Y = -200.00;
CHAMFER_TYPE = 0;
CHAMFER_X = 0.00;
CHAMFER_Y = 0.00;
POINT_NUMBER = 2;
POINT_X =  200.00;
POINT_Y =  200.00;
CHAMFER_TYPE = 0;
CHAMFER_X = 0.00;
CHAMFER_Y = 0.00;
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Units used in import and export
This table lists the units Tekla Structures uses when importing and exporting
profile catalogs and material catalogs.

Type Unit (if blank, no unit)
Boolean  
Integer  
String  
Ratio  
Strain  
Angle degree
Length mm
Deformation mm
Dimension mm
Radius of inertia mm
Area mm2

Reinforcement area mm2

Transverse reinforcement area mm2/m
Area/unit length mm2/m
Volume mm3

Section modulus mm3

Moment of inertia mm4

Torsion constant mm4

Warping constant mm6

Force N
Weight kg
Distributed load N/m
Spring constant N/m
Mass/length kg/m
Surface load N/m2

Strength N/m2

Stress N/m2

Modulus N/m2

Density kg/m3

Moment Nm
Distributed moment Nm/m
Rotation spring constant Nm/rad
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Type Unit (if blank, no unit)
Temperature K (°C)
Thermal dilation coefficient 1/K (1/°C)
Factor  

Import and export sketched profiles
To use a sketched profile in other Tekla Structures models, export the profile
as a .uel file, then import the file into another Tekla Structures model.

We recommend that you use the profile catalog to import and export sketched
profiles. You can also use the Applications & components catalog to import
sketched profiles together with related custom components.

The exported .uel file contains information about the version of Tekla
Structures from which it was exported. You can import the file into the same
or newer version of Tekla Structures, but you cannot import a .uel file from a
newer version into an older version.

Export sketched profiles

1. Open the Tekla Structures model you want to export from.

2. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

3. Right-click the profile you want to export and select Export Profile.

4. In the Export Profile Catalog dialog box, enter a name for the export file
in the Selection box.

5. If you want to save the export file to a specific location, browse for the
folder. 

By default, Tekla Structures saves the export file in the current model
folder.

6. Click OK.

Import sketched profiles
After you have exported sketched profiles to a .uel file, you can import them
to another Tekla Structures model.

TIP To automatically import all .uel files from a folder when creating a new
model, use the advanced option .

1. Open the Tekla Structures model you want to import to.

2. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

3. Click Import.

4. In the Import Profile Catalog dialog box, select *.uel from the Filter list.
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5. Select the file to import.

6. Click OK.

7. Click OK to close the Modify Profile Catalog dialog box.

8. Click OK in the Save confirmation dialog box to save the changes.

Create your own profiles
You can create your own profiles and save them in the profile catalog.

Use any of the following methods to create user-defined profiles in Tekla
Structures:

Profile type Creation methods
Fixed profile • Create user-defined cross sections in

profiles (page 247)

• Create a fixed profile (page 253)

• Create a fixed profile by copying an
existing profile (page 254)

• Create a fixed profile based on a
parametric profile (page 255)

Parametric profile • Create parametric profiles using .clb files
(page 256)

• Create parametric profiles by sketching
(page 264)

Parametric profile with
variable cross sections

• Create parametric profiles with variable
cross sections (page 289)

Create user-defined cross sections in profiles
You can use user-defined cross sections for creating fixed profiles. Define the
cross sections before creating the profile.

Use any of the following methods to define a cross section:

• Define a cross section using a polygon without or with inner contours.

Use this method to create a cross section with fixed dimensions..

• Define a cross section using a plate.

Use this method if you have a contour plate in the model.

• Define a cross section using a DWG file.

Use this method if you have a .dwg file of the profile you that want to
define.
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Define a cross section without inner contours using a polygon
Define a cross section with no inner contours by picking the shape of the cross
section.

Because the cross section shape disappears after you have clicked the middle
mouse button to close the shape, picking the center point of the cross section
can be difficult.

To make it easier to define the shape, insert a reference model of the cross
section in the model, and use the reference model as the basis for picking the
cross section shape. Alternatively, you can create a few construction lines or
points in the model and use them to define the cross section shape.

1. On the File menu, click Catalogs --> Define profiles --> Define cross
section using polygon.

2. Pick the corner points of the cross section to define the shape. 

Start at the bottom-right corner and pick the points counter clockwise.

3. Pick the start point, then click the middle mouse button to close the
shape.

4. Pick the center point of the cross section. 

5. In the User Profile Cross Section dialog box, enter a name for the cross
section.

6. Click OK to close the User Profile Cross Section dialog box.

7. Click OK in the Save confirmation dialog box to save the changes.

Use this cross section when you add a new profile to the profile catalog. The
Profile type is User-defined, fixed.

Define a cross section with inner contours using a polygon
Define a cross section with inner contours by picking the shape of the cross
section.
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1. On the File menu, click Catalogs --> Define profiles --> Define cross
section using polygon.

2. Pick the corner points of the cross section to define the shape, then pick
the start point to close the shape.

3. For each inner contour, pick the corner points of the cross section inner
contour, then pick the start point to close the shape.

4. When you have finished picking all inner contours, click the middle mouse
button.

5. Pick the center point of the cross section.

6. In the User Profile Cross Section dialog box, enter a name for the cross
section.

7. Click OK to close the User Profile Cross Section dialog box.

8. Click OK in the Save confirmation dialog box to save the changes.

Use this cross section when you add a new profile to the profile catalog. The
Profile type is User-defined, fixed.

Define a cross section using a plate
If you have a contour plate in the model, you can define a cross section using a
contour plate.

1. Create a contour plate that includes all the chamfers.

2. On the File menu, click Catalogs --> Define profiles --> Define cross
section using plate.

3. On the Parameters tab of the Profile Cross-Section from Plate (10)
dialog box, enter a name in the Section name and Profile name fields. 

Other properties are optional.

4. Click OK.
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5. Select the contour plate.

Tekla Structures creates the cross section with the shape of the contour plate.

Properties: Profile cross-section from plate (10)

Use the Parameters tab to define the profile properties in the Profile cross-
section from plate (10) component.

Option Description
Section name Name of the cross section shown in the Modify

Profile Catalog dialog box.

If you leave this box empty, no profile is created.
Profile name Name of the profile shown in the Beam properties,

and in the Modify Profile Catalog dialog box.

If you leave this box empty, no profile is created.
Save to The location of the profile catalog.

Select one of the following options:

• Model directory: The current model folder.

• Global directory: ..\ProgramData\Trimble
\Tekla Structures\<version>
\environments\<environment>\profil

• Do not save: Does not save the profile. This is
useful for testing.

Min distance between
points

The minimum distance between the corner points
of the cross section.

To create simpler drawings of complicated cross
sections, increase this value.

Center point offset The origin of the plate defines the location of the
profile reference line.

Enter an offset value to move the reference line,
relative to the cross section.

Coordinate system Select one of the following options:

• Use local

• Use global xy-plane
Mirroring Select one of the following options:

• Do not mirror

• Mirror to x-direction

• Mirror to y-direction
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Option Description
• Mirror to x- and y-direction

Use this cross section when you add a new profile to the profile catalog. The
Profile type is User-defined, fixed.

Define a cross section using a DWG file
if you have a .dwg file of the profile you that want to define, you can import
the cross section and add it as a DWG profile to the profile catalog.

Before you start defining a cross section using a DWG file:

• Save the outline of the cross section as a DWG file. Ensure that the DWG file
only contains the outline of the profile.

• Make sure that the cross section is created as a closed polyline.

• Make sure that the outline consists of only one closed polyline. You cannot,
for example, define holes to your cross section with this method. If you
need holes or openings, use the polygon or the plate creation method.

• Remove hatching and unnecessary lines from the DWG file. Tekla
Structures imports all the lines it finds in the DWG file.

• If there are blocks in the DWG file, they must be exploded.

Tekla Structures supports DWG files that have been created using version
ACAD2012 or earlier.

1. Open a model.

2. On the File menu, click Catalogs --> Define profiles --> Define cross
section using DWG file.

3. On the Parameters tab of the DWG Profile to Library (6) dialog box,
browse for the DWG file.

4. Define the cross section properties.

5. Click OK.

6. In the model, pick the start and the end points of the cross section to be
imported.

Tekla Structures imports the cross section and places the profile reference line
at the origin of the DWG file.

Properties: DWG Profile to Library (6)

Use the Parameters tab to define the profile properties in the DWG profile to
library (6) component.

Option Description
Input file Browse for the DWG file to be imported.
Section name Name of the cross section shown in the Modify

Profile Catalog dialog box.

Start new projects as a Tekla Structures
administrator

251 Customize catalogs and databases



Option Description
Profile name Name of the profile shown in the Modify Profile

Catalog dialog box.
Save to The location of the profile catalog.

Select one of the following options:

• Model directory: The current model folder.

• Global directory: ..\ProgramData\Trimble
\Tekla Structures\<version>
\environments\<environment>\profil

• Do not save: Does not save the profile. This is
useful for testing.

Min distance between
points

The minimum distance between the corner points
of the cross section.

To create simpler drawings of complicated cross
sections, increase this value.

Center point offset The origin of the plate defines the location of the
profile reference line.

Enter an offset value to move the reference line,
relative to the cross section.

Use this cross section when you add a new profile to the profile catalog. The
Profile type is User-defined, fixed.

Modify a user-defined cross section
You can modify cross sections that have been defined using a polygon, a plate,
or a DWG file.

1. On the File menu, click Catalogs --> Define profiles --> Edit Polygon
Cross Section.

2. In the Modify Cross Section dialog box, select the cross section that you
want to modify. 

TIP If you want to delete a cross section, select the cross section, then
click Delete.

3. Modify the cross section point properties. 

• Number refers to each point picked when the cross section was
created, in numerical order. The first point picked is 1, the second 2,
and so on.

• Chamfer refers to the chamfer shape.
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• x: and y: apply to the chamfer type. For example, if you want the
chamfer to be equal on both sides of the angle, only enter a value for
x:.

For an uneven chamfer, enter values for x: and y:.

4. Click Update.

5. Click OK to close the Modify Cross Section dialog box.

6. Click OK in the Save confirmation dialog box to save the changes.

Create fixed profiles
You can create completely new fixed profiles or create copies of existing fixed
profiles. You can also convert parametric profiles into fixed profiles.

Create a fixed profile
You can create fixed profiles with a single cross section or with multiple cross
sections.

Cross sections affect the total weight of the profile.

WARNING If you create a profile with multiple cross sections, create the
cross sections with the same number of corner points and in the
same order.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Right-click anywhere in the profile tree, then select Add Profile. 

A new fixed profile with the name PROFILE1 is created.

3. Define the properties of the profile.

a. In the Profile name field, enter a new name for the profile. 

The profile name must be in upper case letters, with no spaces. Tekla
Structures automatically converts lower case letters to upper case
letters.

b. From the Profile type list, select User-defined, fixed.

c. From the Profile subtype list, select the cross section that you want
to use. 

If you have created your own user-defined cross sections (page 247),
you can use one of them.

d. Under Equivalent type, select a profile type that matches the new
cross section as closely as possible. This is important because some
connections only work for certain types of profiles. 

The equivalent type and the profile dimensions, such as height and
width, affect which connections can be applied to the profile. An
unsuitable equivalent type or missing dimension values may result in
problems with connections.
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e. Click Update.

4. Modify the dimension values. 

Always enter values for the dimensions Height h and Width b, as these
values affect how Tekla Structures displays the profiles. If the values are 0,
the part is drawn as a line.

5. Under Cross section, define a relative location for each cross section.

a. From the Number list, select the number of the cross section.

b. In the Relative location field, enter the location of the cross section. 

This value indicates the location of the cross section along the axis:
0.0 for the start end and 1.0 for the second end. If you only have a
single cross section, select 1 for Number and enter 0.000 for
Relative location.

c. After defining each cross section, click Update.

6. Click Add to add more cross sections, if needed.

• If you want to use a different cross section in the profile, select a new
one from the Profile subtype list.

• If you want to remove a cross section, select the cross section from the
Number list, then click Remove.

7. Click OK to close the Modify Profile Catalog dialog box.

8. Click OK in the Save confirmation dialog box to save the changes.

Example

For a pitched profile, you need two cross sections with the same center point
height. The Relative location value is 0.0 for the first cross section, 0.5 for
the second cross section, and 1.0 for the third cross section.
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Create a fixed profile by copying an existing profile
You can create new fixed profiles by modifying a copy of an existing, similar
profile.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Select a fixed profile that is similar to the one that you want to create.

3. Right-click, then select Copy Profile. 

A new profile with the name <existing_profile_name COPY> is created.

4. In the Profile name field, enter a new name for the profile. 

The profile name must be in upper case letters, with no spaces. Tekla
Structures automatically converts lower case letters to upper case letters.

5. Modify the profile properties on the General, Analysis, and User
attributes tabs. 

• The General tab contains information about profile types and
dimensions.

WARNING Under Equivalent type, select a profile type that matches
the new cross section as closely as possible. This is
important because some connections only work for
certain types of profiles.

Always enter values for the dimensions Height h and
Width b, as these values affect how Tekla Structures
displays the profiles. If the values are 0, the part is drawn
as a line.

The equivalent type and the profile dimensions, such as
height and width, affect which connections can be applied
to the profile. An unsuitable equivalent type or missing
dimension values may result in problems with
connections.

• The Analysis tab contains information about the properties used in
structural analysis. The structure can be analyzed with different
analysis software.

• The User attributes tab is for viewing or entering user attributes for
profiles.

6. Click Update.

7. Click OK to close the Modify Profile Catalog dialog box.

8. Click OK in the Save confirmation dialog box to save the changes.

Create a fixed profile based on a parametric profile
You can convert an existing parametric profile into a fixed profile.
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1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Select a parametric profile from the list.

3. Right-click, then select Add Profile.

A new standard fixed profile is created with the profile values of the
parametric profile.

Modify a fixed profile
If necessary, you can modify existing fixed profiles using the profile catalog.

NOTE The fixed profiles conform to industry standards. Only administrators
should modify them.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Select a fixed profile  in the tree and modify its properties. 

• The General tab contains information about profile types and
dimensions.

• The Analysis tab contains information about the properties used in
structural analysis. The structure can be analyzed with different
analysis software.

• The User attributes tab is for viewing or entering user attributes for
profiles.

3. When you have finished modifying the profile, click Update.

4. Click OK to close the Modify Profile Catalog dialog box. 

Tekla Structures asks if you want to save the changes to the model folder.

5. In the Save confirmation dialog box, click OK to save the changes.

Create parametric profiles using .clb files
You can create new parametric profiles using .clb files.

Follow the example workflow below to create a parametric profile with .clb
files.

How the .clb, components.clb and profitab.inp files work together
When you create new parametric profiles using this method, you need these
files.

• .clb
This file contains the cross section definitions. Create a new .clb file in
the ..\ProgramData\Trimble\Tekla Structures\<version>
\environments\common\inp folder for each parametric profile you
define.
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• components.clb
This file contains a list of all .clb files that contain cross section
definitions. When you create a new .clb file, you need to add its file name
to the components.clb file located in the ..\ProgramData\Trimble
\Tekla Structures\<version>\environments\common\inp folder.

• profitab.inp
This file is the link between the .clb files and the profile catalog. This file
contains a list of all parametric profiles available in Tekla Structures. The file
controls how the parametric profiles are displayed in the Modify Profile
Catalog dialog box. When you want to take a new parametric profile into
use, you must add the needed profile definitions, such as the profile type,
prefix and the unit of measurement, to the profitab.inp file. The
profitab.inp file is located under the environment folder
in ..\ProgramData\Trimble\Tekla Structures\<version>
\environments\<environment>\. The exact file location might vary
depending on the folder structure of your environment files .

Tekla Structures searches for the profitab.inp file in the standard search
order and then from the folder indicated by the advanced option 
XS_PROFDB.

Plan the shape and point coordinates of the profile
Start by defining the shape and point coordinates of the new profile on paper.

1. Design the profile on paper.

a. Draw the cross section outline.

b. Add the corner points.

c. Add the dimensions.

d. Place the y-z coordinate axis center point in the middle of the cross
section. 
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2. Define the y and z coordinate directions. 

For example:

• positive y axis: up

• negative y axis: down

• positive z axis: on the right

• negative z axis: on the left
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3. Define the y and z vectors. 

For example:

• y1, y2, y3

• z1, z2, z3
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4. Make coordinate pairs for the points. 

Assign y, z vector pairs to each point. Start from the lower right corner and
define the points in counterclockwise order.

For example:

• point 1: y1 z3

• point 2: y2 z3

• point 3: y3 z2

• point 4: y3 z1

• point 5: y1 z1

Create the .clb file
After defining the shape and point coordinates of the profile, continue by
creating the .clb file.

1. Create a new .clb file using any standard text editor, such as Microsoft
Notepad.

2. Define a library name to be used in the profitab.inp file for this profile.

For example:

library_id "1Gen"
3. Define a cross section name to be used in the profitab.inp file for this

profile. 
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For example:

Section_type
{
name "RectChamfer"
4. Define the dimensions of the cross section. 

For example:

base_attribute
{
name "h"
description "albl_Height"
type dimension
default 1000
}
5. Define the coordinates of the profile. 

The coordinates must be the same as the y and z vectors that you defined
earlier. Define the default values.

For example:

expression
{
  name "y1"
type y
  default -400
formula -h/2
}
6. Define the geometry of one or several faces of the profile. 

For example:

geometry
{
name "default"
face
  {
  index 0
  point 0 y1 z3
  point 0 y2 z4
  point 0 y3 z4
  point 0 y4 z3
  point 0 y4 z2
  point 0 y3 z1
  point 0 y2 z1
  point 0 y1 z1
  }
face
  {
  index 1
  point 1 y5 z7
  point 1 y6 z8
  point 1 y7 z8
  point 1 y8 z7
  point 1 y8 z6
  point 1 y7 z5
  point 1 y6 z6
  point 1 y5 z6
  }
}
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NOTE The index number refers to the point number: 0=start point of the
beam, 1=end point of the beam.

7. Save the .clb file in the ..\ProgramData\Trimble\Tekla
Structures\<version>\environments\common\inp folder.

8. In a text editor, open the components.clb file.

9. Add your profile definition to the components.clb file by adding the
following line: 

Include ”new_file_name.clb” // give comment
10. Save the components.clb file.

Add profile definitions to the profitab.inp file
Before you start to use the new parametric profile, add the profile definitions
to the profitab.inp file.

1. In Windows, browse to the environment folder in ..\ProgramData
\Trimble\Tekla Structures\<version>\environments
\<environment>\ and find the profitab.inp file.

2. Copy the profitab.inp file to a model, project, or firm folder.

3. In a standard text editor, such as Microsoft Notepad, open the
profitab.inp file in the new location.

4. Under a suitable category, add a new line for the profile definition. 

Use the following syntax:

Prefix
! Type ! SO ! Z ! MI ! MA ! G3-NAME ! Z3-NAME !

An example of a profile definition:

PNL_A
! USER ! 0 ! ! 2 ! 3 !1Gen.RectChamfer !h*b-[c]
5. Save the file. 

The profile is now available in the profile catalog. You might have to
restart Tekla Structures for the change to take effect.

Properties used in profitab.inp
Use these properties when you define new parametric profiles using the
profitab.inp file.

Property Description
Prefix Prefix of the parametric profile. The prefix is shown in the

profile catalog.

For example, PNL_A.
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Property Description
Type Type of the parametric profile.

The profile types are or include the following:

I, L, Z, U, PL, D, PD, P, C, T, HK, HQ, ZZ, CC, CW, CU, EB, BF,
SPD, EC, ED, EE, EF, EZ, EW, 102, 103, 104, 105, 106, USER

For example, in the default environment, parametric
profiles with prefixes PD, EPD, CHS, CFCHS, O, Ø, and
TUBE all group under the type PD, and appear under
Circular hollow sections in the profile catalog.

SO Sorting order. The options are:

• -1: Decreasing sorting order

• +1: Increasing sorting order

• 0: No sorting order

• -2: Name increasing, value decreasing

• +2: Value increasing, name decreasing

For example, if your profile is PLT200*10 or PLT10*200
and the sorting order is +2, the result in the output (such
as a report) for both cases is PLT200*10. If the sorting
order is -2, the result for both cases is PLT10*200.

Z Unit of measurement. The options are:

• 0: millimeters

• 1: inches

• 2: feet

• 3: centimeters

• 4: meters
MI Minimum number of parameters you can use with the

parametric profile.

For example, the rectangular hollow section SHS has the
following Profile subtypes: h*t, h*b*t, h1*b1-h2*b2*t.

If you define SHS with a minimum of two and a maximum
of two parameters, you only have the option h*t available
in the Select Profile dialog box.

MA Maximum number of parameters you can use with the
parametric profile.

G3-NAME Refers to a cross section file (.clb file).

Can be a combination of a library id and the name of a
cross section, separated by a full stop. For example, 
1Gen.RectChamfer.
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Property Description
Z3-NAME Defines how the profile parameters relate to the

parameters in the cross section file.

Parameters in the order of appearance in the .clb file,
optional parameters in square brackets. For example, 
h*b-[c].

Can also be the name of the detailing component.

Create parametric profiles by sketching
You can create parametric user-defined profiles by sketching. You can change
the dimensions of parametric profiles each time that you use them in a model.

• Use the cross section sketch editor to create and modify sketched profiles.

• The Sketch Browser shows the objects of a sketched profile.

• Use the Variables dialog box to define the properties of a sketched profile.

Open the sketch editor

1. Open a Tekla Structures model.

2. On the File menu, click Editors --> Define cross section in sketch editor.

Tekla Structures opens the sketch editor, the Sketch Browser, and the
Variables dialog box.

When you first open the sketch editor, the view is empty. The grid coordinates
and labels that you see in the sketch editor depend on the grid properties of
your actual Tekla Structures model.
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Sketch Browser
The Sketch Browser shows the objects (lines, arcs, circles, constraints,
dimensions, and chamfers) of a sketched profile in a hierarchical, tree-like
structure.

The Sketch Browser automatically opens when you open the sketch editor.

When you click an object in the sketch editor, Tekla Structures highlights the
object in the Sketch Browser.
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The Sketch Browser shows the following information about each sketched
profile:

• Extrusion type (0, 1, or 2) and thickness of the sketched profile

• Lines, arcs, and circles

• Constraints

• Distances and dimensions and their values

• Chamfers and their type (0=None, 1=Line ... 7=Line and arc) and
dimensions.

Variables in sketched profiles
Variables can define fixed properties, or they can include formulas, so that
Tekla Structures calculates the property value each time you use the profile in
a model.

Start new projects as a Tekla Structures
administrator

266 Customize catalogs and databases



Use the Variables dialog box to define the properties of a sketched profile.
The Variables dialog box automatically opens when you open the sketch
editor.

NOTE The Variables dialog box functions the same way as the
corresponding dialog box in the custom component editor. For more
information on how to use variables, see Add variables to a custom
component.

Sketch the outline of a profile
When you create a new sketched profile, start by sketching the outline and the
holes of the profile using lines, arcs, and circles.

Unless you are creating a profile of a consistent thickness, such as a cold-rolled
profile, ensure that you create a closed shape.

Sketch a polyline
You can create line segments in the sketch editor by picking points. Tekla
Structures automatically creates coincident constraints between the line
segments and shows a chamfer symbol where line segments meet.

1. Open the sketch editor. (page 264)

2. Click the Sketch polyline button: .

3. Pick points to create each line segment.

4. Click the middle mouse button to create the polyline. 
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Sketch an arc
You can create an arc in the sketch editor by picking three points.

1. Open the sketch editor. (page 264)

2. Click the Sketch arc button: .

3. Pick three points to define the arc. 

TIP You can use the advanced option XS_CS_CHAMFER_DIVIDE_ANGLE to
define the smoothness of the arc.

Sketch a circle
You can create a circle in the sketch editor by picking two points.

1. Open the sketch editor. (page 264)

2. Click the Sketch circle button: .

3. Pick a point to indicate the center of the circle (1).

4. Pick a point to indicate the radius of the circle (2). 

Start new projects as a Tekla Structures
administrator

268 Customize catalogs and databases



Refine the shape of a sketched profile by adding a constraint
After you have sketched the outline of a profile, use constraints to refine your
sketch and lock the shape.

For example, you can straighten lines, create 90 degree angles, force lines to
meet, close the shape, and add chamfers in corners.

To straighten the entire profile, use horizontal and vertical constraints in
conjunction with other constraints. Although the shape is locked, you can still
rotate the profile in the model.

Add a parallel constraint
You can use a parallel constraint to force two lines in a sketched profile to be
parallel to each other.

Before you begin, sketch the outline of the profile in the sketch editor.
(page 267)

1. Click the Parallel constraint button: .

2. Select a line in the sketch (1).

3. Select another line in the sketch (2). 

Add a perpendicular constraint
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You can use a perpendicular constraint to force a line in a sketched profile to
be at a 90 degree angle to another line that you select.

Before you begin, sketch the outline of the profile in the sketch editor.
(page 267)

The selected lines do not have to intersect. You can add a perpendicular
constraint to any two lines.

1. Click the Perpendicular constraint button: .

2. Select a line in the sketch (1).

3. Select another line in the sketch (2). 

Add a coincident constraint
You can use a coincident constraint to force two lines in a sketched profile to
start or end at the same point, by extending or shortening one or both lines.

Before you begin, sketch the outline of the profile in the sketch editor.
(page 267)

The selected lines do not have to intersect. You can add a coincident constraint
to any two lines.

NOTE Tekla Structures automatically creates coincident constraints:

• where two lines meet

• between line segments when you draw them with the Sketch
polyline tool

• between the start of the first line segment and the end of the last
line segment in a shape, if they are within a certain distance of
each other

1. Ensure that the Snap to end points  snap switch is active.

2. Click the Coincident constraint button: .

3. Pick the end of the first line (1).

4. Pick the end of the second line (2). 
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Add a fixed constraint
You can use a fixed constraint to lock the position and angle of a line in a
sketched profile so that other constraints do not affect it.

Before you begin, sketch the outline of the profile in the sketch editor.
(page 267)

1. Click the Fixed constraint button: .

2. Select a line in the sketch.

Add a horizontal constraint
You can use a horizontal constraint to force a line in a sketched profile to be
parallel to the local x axis.

Before you begin, sketch the outline of the profile in the sketch editor.
(page 267)

Tekla Structures automatically creates horizontal constraints when you create
lines that are nearly horizontal.

1. Click the Horizontal constraint button: .

2. Select the lines you want to straighten (1, 2). 

Add a vertical constraint
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You can use a vertical constraint to force a line in a sketched profile to be
parallel to the local y axis.

Before you begin, sketch the outline of the profile in the sketch editor.
(page 267)

Tekla Structures automatically creates vertical constraints when you create
lines that are nearly vertical.

1. Click the Vertical constraint button: 

2. Select the lines you want to straighten (1, 2). 

Delete a constraint
If a constraint is no longer needed, you can delete it from a sketched profile.

1. Click  to open the Sketch Browser.

2. Select the constraint that you want to delete.

3. Right-click and select Delete.

4. Click Refresh.

Add dimensions to a sketched profile
After you have sketched a profile, use dimensions to make different distances
in the profile parametric. You can use these dimensions to define the size of
the profile when you use it in a model.

Tekla Structures also adds the dimensions you create to the list of variables
that you can use in calculations.

NOTE Do not create too many dimensions in a sketch. If there are too many
dimensions, the dimensions cannot adjust when the values are changed.

In this example, if you create the dimension marked in red, the dimension b1
no longer works:
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Add a radial dimension to a sketch
You can create a radial dimension for an arc or a circle in a sketched profile.

Before you begin, sketch the outline of the profile in the sketch editor.
(page 267)

1. Click the Sketch radial dimension button: .

2. Select the arc or circle. 

Add an angle dimension to a sketch
You can create an angle dimension between two lines in a sketched profile.
The angle is calculated counter clockwise from the first line you select.

Before you begin, sketch the outline of the profile in the sketch editor.
(page 267)

1. Click the Sketch angle dimension button: .

2. Select the first line (1).

3. Select the second line (2). 
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TIP If you are unable to see the angle symbol, scroll with the mouse
wheel to zoom in.

Add a dimension between two points in a sketch
You can add a dimension to a sketched profile, between two points you pick.

Before you begin, sketch the outline of the profile in the sketch editor.
(page 267)

1. Click the Sketch free dimension button: 

2. Pick a point to indicate the start point of the dimension (1).

3. Pick a point to indicate the end point of the dimension (2).

4. Pick a point to indicate the location of the dimension lines and text. 

Add a horizontal dimension to a sketch
You can add a horizontal dimension to a sketched profile, between two points
you pick.

Before you begin, sketch the outline of the profile in the sketch editor.
(page 267)

1. Click the Sketch horizontal dimension button: .

2. Pick a point to indicate the start point of the dimension (1).
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3. Pick a point to indicate the end point of the dimension (2).

4. Pick a point to indicate the location of the dimension lines and text. 

Add a vertical dimension to a sketch
You can add a vertical dimension to a sketched profile, between two points
you pick.

Before you begin, sketch the outline of the profile in the sketch editor.
(page 267)

1. Click the Sketch vertical dimension button: .

2. Pick a point to indicate the start point of the dimension (1).

3. Pick a point to indicate the end point of the dimension (2).

4. Pick a point to indicate the location of the dimension lines and text. 

Delete a dimension from a sketch
If a dimension is no longer needed in a sketch, you can delete it.

You can delete a dimension from a sketch in the sketch editor view, in the
Variables dialog box, or in the Sketch Browser.

1. Select the dimension that you want to delete.

2. Do one of the following: 
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• In the sketch editor view or in the Sketch Browser, right-click and
select Delete.

• In the Variables dialog box, click the Delete button.

Define positioning planes for a sketched profile
When you sketch a profile, you can define positioning planes for it. With
positioning planes you can determine the planes that Tekla Structures uses for
positioning parts and components.

Part positioning planes
With part positioning planes you can determine how Tekla Structures positions
parts that have a sketched profile.

These planes are used for the On plane and At depth settings for parts, and
also when placing custom components that are bound to boundary planes.

The part positioning planes are shown in blue:

The On plane options Left and Right are set according to the vertical blue
planes, and the Middle option is halfway between them.

For the At depth setting, the Front and Behind options are set according to
the horizontal blue planes, and the Middle option is halfway between them.

Example

You can define part positioning planes so that an asymmetric profile is
positioned according to its web only. In the following example, gray dotted
lines illustrate the Middle option:
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(1) Middle option

Connection positioning planes
With connection positioning planes, you can determine how Tekla Structures
positions components in relation to the component main part that has a
sketched profile.

The connection positioning planes are shown in green:

Example

This image shows the default connection positioning planes of a double tee
slab that was created as a sketched profile. The green line illustrates the
default connection positioning planes.
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To place connections according to the location of the stems of the double tee,
move the connection positioning planes as shown here.

Show and hide positioning planes

To show or hide the positioning planes, do one of the following:

To Do this
Show or hide part positioning planes

Click .
Show or hide connection positioning
planes Click .

Move positioning planes
You can move the positioning planes by moving their handles.

If you move the handles away from the outermost corners of the sketched
profile, you must bind them by adding a dimension to each handle. Otherwise,
the positioning does not function correctly in the model.

1. Click the positioning plane to show the handles. 

The handles are shown in pink. By default, the handles are at the
outermost corners of the sketched profile.

For example:

2. Click a handle to select it. 
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NOTE The same handle controls both the vertical and horizontal plane.
You can move them both at the same time.

3. Move the handle like any other object in Tekla Structures. 

For example, right-click and select Move.

4. If the handle is not at the outermost corner of the profile, add a
dimension between the handle and the corner.

Example

In this example, the left handle of the positioning plane has been bound by
using a horizontal dimension (b1):

Revert to default positioning planes
You can revert to the default positioning planes of a sketched profile if you
have moved the planes.

To revert to the default positioning planes, do one of the following:

To Do this
Revert to the default part positioning
planes

1.
Click  to show the part
positioning planes.

2. Select the part positioning
planes.

3. Right-click and select Delete.

4.
Click  again to check that the
planes have reverted back to the
default.
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To Do this
Revert to the default connection
positioning planes

1.
Click  to show the
connection positioning planes.

2. Select the connection positioning
planes.

3. Right-click and select Delete.

4.
Click  again to check that the
planes have reverted back to the
default.

Check a sketched profile
You can check that the constraints and dimensions in a sketched profile work
correctly.

1. Double-click a dimension line to open the Distance Properties dialog
box.

2. Change the Value box.

3. Click Modify. 

Tekla Structures updates the profile in the sketch editor.

4. Check that the shape of the profile does not change and that the
dimensions adjust correctly.

5. Click Cancel to close the Distance Properties dialog box.

See also

Use sketched profiles in a model (page 283)

Save a sketched profile
Tekla Structures saves the sketched profiles in the current model folder, in the
xslib.db1 file, which is a library file containing custom components and
sketches. Sketched profiles are available in the Others section in the profile
catalog.

NOTE Note the following limitations when naming sketched profiles:

• You cannot use the name of a fixed profile.

• You cannot include numbers, special characters, or blank spaces in
the profile name.

• Lower case letters are automatically converted into upper case
letters.
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To save a sketched profile, do one of the following:

To Do this
Save a new profile 1.

Click Save sketch .

2. Enter a name in the Prefix box, and then
click OK.

Update an existing profile 1.
Click Save sketch .

2. Click Yes when prompted to update the
existing cross section.

Save a copy of the profile
under a different name

1.
Click Save sketch as .

2. Enter a new name in the Prefix box, and
then click OK.

Modify sketched profiles
You can modify existing sketched profiles, such as by modifying chamfers or
dimensions. You can also move corners or holes by moving the handles. The
chamfers are moved automatically when you move the handles.

Modify a sketched cross section

• You cannot change dimensions that have been calculated using formulas in
the Variables dialog box.

• Constraints might also prevent you from changing dimensions.

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Open the Others branch at the end of the profile tree.

3. To open the profile in the sketch editor, right-click a sketched profile, then
select Edit profile.

4. Double-click a sketch object to modify its properties. 

The sketch objects that you can modify appear in yellow.

5. Modify the properties, then click Modify.

6. Close the sketch object properties dialog box.

7. Click the Save sketch as icon  to save the changes.

Modify chamfers in a sketch
You can change the shape and dimensions of chamfers in a sketched profile.
For example, you can create rounded profile corners.
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1. In the sketch editor, double-click a chamfer symbol .

2. In the Chamfer Properties dialog box, change the shape and dimensions
of the chamfer.

3. Click Modify.

4. Click OK to close the dialog box.

5. Click the Save sketch as icon  to save the changes.

Set the sketch thickness
If you have sketched an open shape, such as a cold-rolled section, you must
define the thickness and extrusion type of the sketch in the Sketch Browser.

Before you begin, sketch an open polyline (page 267) in the sketch editor.

The sketch thickness can be fixed or parametric.

1. Set the sketch thickness in one of the following ways:

• To set a fixed thickness:

a. In the Sketch Browser, right-click Thickness, then select Add
Equation.

b. Enter the value of the thickness after =.

• To define a parametric thickness:

a. In the Variables dialog box, add a new parameter variable (for
example, P1) for Length.

b. In the Formula column, define the default value for the parameter
variable.

c. In the Sketch Browser, right-click Thickness, then select Add
Equation.

d. Enter the name of the parameter variable (for example, P1) after
=.

2. To define the extrusion type:

a. In the Sketch Browser, right-click ExtrusionType, then select Add
Equation.
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b. Enter the extrusion type number (0, 1, or 2) after =.

3. Click the Save sketch as icon  to save the changes.

Extrusion types
The extrusion type defines how a sketched profile of a consistent thickness is
extruded. You must define the extrusion type for sketches that consist of an
open polyline.

When you change the thickness, the profile grows inwards, outwards, or
symmetrically in both directions, depending on the extrusion type.

Type Description Image
0 The sketch is extruded

symmetrically to the outside
and inside of the polyline.

(Default)

1 The sketch is extruded to the
outside of the polyline.

2 The sketch is extruded to the
inside of the polyline.

Use sketched profiles in a model
After you have created a sketched profile and saved it, you are ready to use it
in the model. If you have applied constraints correctly, the shape of the profile
is maintained when you change its dimensions.

1. In the property pane, open the part properties. 

For example, to open the beam properties, on the Steel tab, hold down

Shift, then click .

2. Click the ... button next to the Profile field. 

The Select Profile dialog box appears.
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3. Open the Others branch at the end of the profile tree.

4. Select a sketched profile.

5. If the profile is parametric, define its dimensions in the Value column on
the General tab.

6. Click OK to close the Select Profile dialog box.

7. Pick points to place the part in the model.

See also

Create an image of a profile (page 292)

Example: Create a symmetric C-shaped profile by sketching
This example shows how to create a sketched profile using variables.

After completing the tasks, you will have a symmetric C-shaped profile with the
dimensions b1 = b2 and h2 = h3. When you use the profile in the model, you
can change the following dimensions:

• Width (b1)

• Total height (h1)

• Height (h2)

• Thickness (P1)

• Chamfers (P2)

Example: Sketch a C-shaped profile

Start by sketching the outline of the profile.

1. Open the sketch editor.

2. Use the Sketch polyline command to create a rough C-shaped profile. 
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At this stage, the profile does not have to be symmetric or have the right
dimensions.

3. Straighten the lines using the Add horizontal constraint  and Add

vertical constraint  commands. 

4. Save the profile and name it CSHAPE.

Example: Add dimensions to the sketched profile

After sketching the outline of the profile, you can continue by adding
dimensions.

1. Use the Sketch horizontal dimension  command to create the
distances b1 and b2. 
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2. Use the Sketch vertical dimension  command to create the
distances h1, h2, and h3. 

3. In the Variables dialog box, enter the following values for the distances: 

Name Formula Value Value
type

Variable
type

Visibility Label in
dialog

box
b1 150.00 150.00 Length Distance Show Width
b2 =b1 150.00 Length Distance Hide Width
h1 300.00 300.00 Length Distance Show Height
h2 70.00 70.00 Length Distance Show Height
h3 =h2 70.00 Length Distance Hide Height

4. Ensure that Visibility is set to Show for the distances b1, h1, and h2.

5. Save the sketched profile.
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Example: Set the sketch thickness

After adding dimensions to the sketched profile, you can continue by defining
the thickness of the sketch.

1. In the Variables dialog box, do the following:

a. Click Add to add a parameter variable P1.

b. In the Formula column, enter 20.00.

c. In the Visibility column, select Show.

d. In the Label in dialog box column, enter Thickness.

2. In the Sketch Browser, set the thickness using the parameter variable P1.

a. Right-click Thickness, select Add Equation, and then enter =P1.

b. Right-click ExtrusionType, select Add Equation, and then enter =2 to
get the sketch extruded to the inside of the polyline. 

3. Save the sketched profile.

Example: Modify the chamfers of the sketched profile

After setting the thickness of the sketch, you can continue by modifying the
chamfers of the sketched profile.

1. In the sketch editor, do the following:

a. Double-click a chamfer symbol .

b. In the Chamfer properties dialog box, change the chamfer type to

Line , and then click Modify.

c. Repeat steps 1a–b for all the chamfers.

2. In the Variables dialog box, do the following:

a. Click Add to add a parameter variable P2.
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b. In the Formula box, enter 10.00.

c. In the Visibility box, select Show.

d. In the Label in dialog box box, enter Chamfer.

3. In the Sketch Browser, do the following:

a. Double-click Chamfer constraint to open the chamfer properties.

b. Right-click Chamfer X, select Add Equation, and then enter =P2.

c. Enter the same value for Chamfer Y.

d. Repeat steps 4a–c for all the chamfers. 

4. Save the sketched profile.

Example: Use the sketched profile in a model

Your sketched profile is now completed and you can use it in a model.

1. Double-click a part to open the part properties in the property pane.

2. Click the ... button next to the Profile box. 

The Select Profile dialog box appears.

3. Open the Others branch at the end of the profile tree, and select the
CSHAPE profile.

4. If needed, modify the dimensions of the profile on the General tab. 

5. Click OK to apply the changes.

6. Pick points to place the part in the model. 
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Create parametric profiles with variable cross sections
You can create parametric user-defined profiles with variable cross sections
using the Profile Editor. You can use a profile with variable cross sections like
any other parametric profile.

You can

• use a cross section with different dimensions at different locations in a
profile

• modify the variables of the cross sections and the profile

• save the profile and use it as a parametric profile through the profile
catalog

• import and export variable cross section profiles

NOTE When you use this method, only the dimensions of a variable cross
section can vary, not the actual shape of the cross section. If you want
to use several different cross section shapes in the profile, create a
fixed profile (page 253) with multiple cross sections instead.

Create a profile with variable cross sections

Before you start:

• Create a sketched profile (page 264) using the sketch editor.
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• In the Variables dialog box in the sketch editor, set Visibility to Show for
the dimensions that you want to change when using the profile in a model.

1. On the File menu, click Catalogs --> Define properties --> Define profile
with variable cross section. 

The Define Profile with Variable Cross Section dialog box opens.

2. Select the sketch you want to use as the start and end cross section of the
profile.

3. Click OK. 

The Profile Editor and the Profile preview view appear.

4. Under Cross sections of the profile, add cross sections or remove
selected cross sections by clicking Add or Remove. 

When you click Add, Tekla Structures adds a new cross section at the end
of the profile, at the location 1.0., and moves the existing cross sections
towards the start of the profile. By default, cross sections are located at
0.1 intervals in the profile.

5. Under Cross section variables, define the following: 

• The relative location of each cross section in the profile.

Use the *.Location variables. For example, start=0.00, middle=0.5,
end=1.00.

• How the cross sections are aligned in the horizontal and vertical
direction.

Use the *.HorPos and *.VerPos variables.
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• How much the cross sections are offset from the alignment.

Use the *.HorOffset and *.VerOffset variables.

6. If you have added new cross sections, check that they do not overlap any
existing cross sections.

7. Set Visibility to Show for the dimensions that you want to change when
using the profile in a model.

8. If you want to use parameter variables and equations to define the cross
section dimension, click Add variable and define the variable values.

9. Save the profile.

a. Click Save.

b. In the Save profile as dialog box, enter a unique name for the profile.

You cannot include numbers in the profile name, or use the name of
a standard profile.

c. Click OK. 

Tekla Structures saves the profile in the current model folder.

Modify a profile with variable cross sections

1. On the File menu, click Catalogs --> Profile catalog to open the Modify
Profile Catalog dialog box.

2. Open the Others branch at the end of the profile tree.

3. Right-click a profile with variable cross sections, and then select Edit
profile to open the profile in the Profile Editor.

4. Modify the profile properties.

5. Click Save.
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Define standardized values for parametric profiles
You can define standardized values for the dimensions of parametric profiles.
The standardized values are visible in the profile catalog where you can select
suitable dimension values for the profiles.

1. Under ..\ProgramData\Trimble\Tekla Structures\<version>
\environments\<environment> folder, locate the
industry_standard_profiles.inp file. 

The exact file location may vary depending on the folder structure of your
environment files.

If there is no industry_standard_profiles.inp file in your
environment, you can use the file of the default environment.

2. Copy the industry_standard_profiles.inp file and place it in your
firm, project, or model folder.

3. Open the copied industry_standard_profiles.inp file using any
standard text editor, for example, Microsoft Notepad.

4. Modify the file. 

The file has the following format:

• profile and profile subtype

• parameters separated by spaces

• units for each parameter

• standardized values for each parameter.

Each dimension combination has its own row.

5. Save the file.

Example

For example, the standardized combinations of dimension values for a C
profile are as follows:

c h*b*t
h    b    t
mm      mm      mm
75      35      5
75      35      6
75      35      7
100     40      7
100     40      8
100     40      9
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Create an image of a profile
To illustrate the shape and dimensions of a profile you have created, you can
create an image of it. Tekla Structures shows the image when you browse for
profiles in the profile catalog.

The image must be in Windows bitmap (.bmp) format and can be created with
any bitmap editor, such as Microsoft Paint.

1. Take a screenshot of the profile that you have drawn or sketched. 

For example, press the Print Screen (Prt Scr) key to take a screenshot of
your entire desktop. To take a screenshot of an active window, press Alt
+Print Screen. The screenshot is placed on the clipboard.

2. Open the screenshot in a bitmap editor and modify the image if
necessary.

3. Save the image in .bmp format in the ..\ProgramData\Trimble\Tekla
Structures\<version>\Bitmaps folder. 

The file name must match the profile name. For example, if the name of a
fixed profile (page 253) or a sketched profile (page 264) is mysketch, the
image must be named mysketch.bmp.

If the profile has been created using a .clb file (page 256), the name of the
image file must also include the library ID that has been used for the
profile in the .clb file and in the profitab.inp file. For example, if the
library ID is BuiltUps and the cross section name is BOXISMC, name the
image file BuiltUps.BOXISMC.bmp.

Note that the profile names, cross section names, and library IDs are case
sensitive.

4. Restart Tekla Structures. 
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The image is now shown in the profile catalog.

Customize the shape catalog
The shape catalog contains information about shapes that are used for
defining items. Use the Shape catalog dialog box to view and modify shape
properties and metadata, to group and tag shapes, and to import and export
shapes.

The shape catalog includes default shapes, for example Default and
Concrete_Default, and other shapes that are read from specific shape folders
in a set folder search order (page 45). The shapes that you import, download
from Tekla Warehouse, or create using existing geometry (page 295) in the
currently open model are also shown in the shape catalog.

Shape definition files

For each shape in the shape catalog, there are two definition files that contain
the shape information:

• One .xml file for shape attributes, such as name and GUID, stored in the
\Shapes folder

• One .tez or .xml file for geometric properties, such as coordinates, stored
in the \ShapeGeometries folder

Tekla Structures searches for these subfolders and definition files in the
model, project, firm, and system folders, and in the folder defined by the
advanced option XS_DEFAULT_BREP_PATH.
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The definition files of the shapes that are used for items in a model are
automatically copied to the model folder.

If you have shapes that you would like to have available in the shape catalog
for all new models that are created in your project or company, copy the
corresponding .xml and .tez files to the correct subfolders (\Shapes and
\ShapeGeometries) in the \profil folder under your project or firm folder
(page 16).

Group structure and other shape files

The hierarchical group structure of the shape catalog is read from the
ShapeCatalog.Groups.xml file in the model folder. Using this file, you can
share the group structure with all users in a project, preferably in the
beginning of the project.

If you modify the group structure, Tekla Structures saves the changes to the
ShapeCatalog.Groups.user.<username>.xml file in the model folder.

The *.shapecatalog and *.ShapeCatalog.Groups.xml files are used for
exporting and importing shapes and the group structure between Tekla
Structures models.

Create shapes
In addition to importing item shapes or downloading them from Tekla
Warehouse, you can create shapes using existing geometry and parts in Tekla
Structures models.

For example, you can create a shape using a single part or several parts that
have been attached to each other.

The part reference point that has the yellow handle determines the origin of
the shape. The positive global x direction determines the direction of the
shape. When you create items using the shape, the shape origin and direction
align with the yellow and magenta item handles.

The shape name is generated using the part name and part location in the
format <grid location>_<elevation>_<part name>. For example:

• 1/D_+0_FOOTING

• 3/C_+0-+3600_COLUMN

• 1-2/A-B_+3600_SLAB

If there is already a shape with the same name in the shape catalog, Tekla
Structures adds two underscore characters and a running number at the end
of the new shape name. For example, 1/D_+0_FOOTING__1.

Create a shape by using existing geometry in the model
Use this method if you want to create a new shape using an existing part, but
you do not want to delete the part or change it to an item.
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1. Using parts, model the geometry from which you want to create a shape.

2. If you want to include more than one part in the shape, attach the parts to
each other.

3. On the Edit tab, click  Create shape from geometry.

4. Select the part. 

Alternatively, you can first select the part, right-click, and then select
Create shape from geometry.

Tekla Structures adds a new shape to the shape catalog (page 294).

You can then use the shape when you create items in the model. You can also
modify items and shapes further in the Geometry editing mode.

Create a shape by converting a part to an item
When you change an existing part in the model to an item, Tekla Structures
also creates a new shape and adds it to the shape catalog.

When you change a part to an item, Tekla Structures deletes the original part
and replaces it with the newly created item in the model. The name, material,
finish, class, pour phase, and the numbering properties of the original part are
saved as the corresponding item properties. Other part type specific
properties and user-defined attributes are not saved. The objects that are
attached to the original part, such as reinforcement and surfaces, are deleted.

1. Create the parts that you want to change to an item.

2. If you want to include more than one part in the item, attach the parts to
each other.

3. On the Edit tab, click  Convert part to item.

4. Select the part. 

Alternatively, you can first select the part, right-click, and then select
Convert part to item.

Tekla Structures changes the part to an item and adds a new shape to the
shape catalog (page 294).

Organize shapes and groups in the shape catalog
You can arrange the shapes in the shape catalog in a hierarchical group
structure.

The group structure is shown on the left side of the Shape catalog and Select
shape dialog boxes. In the Shape catalog dialog box, you can add, modify,
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and delete groups and sub-groups, and move and copy shapes between the
groups and sub-groups.

The group structure might vary depending on the Tekla Structures
environment that you are using. Alternatively, your company or project
administrator might have created and shared a group structure. If you are a
Tekla Structures administrator or main user, you can share your groups so that
they become available to all users in the shared model.

The group structure is read from the ShapeCatalog.Groups.xml file in the
model folder and from the *.ShapeCatalog.Groups.xml files in the shape
sub-folders in the project, firm, and system (XS_SYSTEM) folders. Some shapes

might first be in the  Ungrouped group, but you can regroup them.

New shapes that you create (page 295) in the model are also added to the
Ungrouped group. If you import new shapes without a group structure, you
can select a group for the shapes. You can also group shapes by tagging or
starring (page 304) them.

Groups that are marked with  are system groups. Groups that are marked

with  are user-defined groups.

Current user-defined groups and the changes that you make to the group
structure are stored in the ShapeCatalog.Groups.user.<username>.xml
file in the model folder.
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NOTE Even if you modify the group structure, the definition files (.xml and .tez) for
each shape remain in the original \Shapes and \ShapeGeometries folders.

The Select shape dialog box is used for selecting a shape for an item. In the

Select shape dialog box, the  Recent group is also shown. It contains the
latest shapes that you have used.

Add a new group or sub-group

1. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

2. To add a sub-group to an existing group, select the group on the left side
of the dialog box. 

You can add sub-groups to both user-defined groups and system groups,
but not to the Starred, Tags, or Ungrouped group.

3. Click  New group and do one of the following:

• To create a highest-level group, select New group.

• To add a sub-group under the selected group, select New sub-group.

4. In the New group name dialog box, enter a name for the new group, then
click Create.

5. Add, move, or copy shapes to the new group, or modify the shape
properties as needed.

6. Click  Save to save the changes to the shape catalog.

Modify a group or sub-group
You can rename groups and sub-groups, and modify group properties.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

2. Select the group or sub-group that you want to modify.

3. To rename the group, do the following:

a. Right-click and select Rename.

b. In the Rename group dialog box, enter the new name, then click
Rename.

4. To modify group properties, such as the manufacturer or tags (page 307)
of the shapes in the group, do the following:

a. Select all shapes in the group.
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b. In the property area on the right side of the Shape catalog dialog
box, modify the properties.

5. Click  Save to save the changes to the shape catalog.

Move or copy a group or sub-group
You can move and copy groups and sub-groups in the shape catalog. You can
move and copy both user-defined groups and system groups.

When you move or copy a group, the sub-groups of the selected group are
also moved or copied.

You cannot move or copy the Starred, Tags, or Ungrouped group, or sub-
groups in them.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

2. Select the group or sub-group that you want to move or copy.

3. Do one of the following:

• To move the group, drag the group to a new location in the group
structure.

• To move a sub-group to the highest level in the group structure, right-
click the sub-group and select Move to top level.

• To copy the group, hold down Ctrl and drag the group to a new
location.

• To copy a sub-group to the highest level, right-click the sub-group and
select Copy to top level.

4. Click  Save to save the changes to the shape catalog.

Select shapes
You can use these methods when you select shapes in the Shape catalog
dialog box.

Selecting different sets of shapes is useful when you want to export (page 311)
or add tags (page 307) to certain shapes, or otherwise modify a sub-set of
shapes.

• Use the following commands on the catalog ribbon:

• Click Select all to select all the shapes in the currently visible group.

Alternatively, you can select one shape, then press Ctrl+A.

• Click Select none to clear the current selection.

• Click Invert selection to select the currently unselected shapes and to
deselect the currently selected shapes.
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• To select several consecutive shapes, select the first shape, then hold down
Shift and select the last shape.

• To select several non-consecutive shapes, select the first shape, then hold
down Ctrl and select the other shapes.

Preview a shape
In the Shape catalog and Select shape dialog boxes, Tekla Structures shows a
preview of the selected shape in the upper right corner of the dialog box.

Use these methods to examine the shape in the preview:

• Zoom in and out by scrolling with the mouse wheel

• Rotate the shape using the left mouse button ( )

• Pan using the middle mouse button ( )

• Adjust the viewing angle using the right mouse button ( )
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Move or copy shapes between groups

When you move a shape from one group to another, shapes are removed
from the previous group. When you copy a shape between groups, the shapes
remain in both groups.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

2. Browse to and select the group from which you want to move or copy
shapes.

3. Do one of the following:

• To move one or more shapes to another group, select the shapes and
drag them to the other group.

Alternatively you can right-click the selected shapes, select Move to
group, and then, in the dialog box that appears, select a group. In the
dialog box, you can also create a new group or sub-group for the
shapes, if needed.

• To copy one or more shapes to another group, select the shapes, hold
down Ctrl, then drag the shapes to the other group.

Alternatively you can right-click the selected shapes, select Copy to
group, and then, in the dialog box that appears, select a group. In the
dialog box, you can also create a new group or sub-group for the
shapes, if needed.

• To remove one or more shapes from the selected group, select the
shapes, right-click on one of the selected shapes, and then select
Remove from group.

If the shapes only belong to the selected group, the shapes are moved
to the Ungrouped group. If the shapes also belong to any other group,
they remain in that group.

4. Click  Save to save the changes to the shape catalog.

Modify shape properties

1. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

2. Browse to and select the group in which you want to modify shape
properties.

3. Select one or more shapes.

4. In the property area on the right side of the Shape catalog dialog box,
modify the shape properties. 

Start new projects as a Tekla Structures
administrator

301 Customize catalogs and databases



For example, you can add a description or tags (page 307) to the selected
shapes.

NOTE You cannot rename shapes. You cannot remove or change the
solidity information, Tekla Structures version, source file location,
or GUIDs of the shapes.

5. Click  Save to save the changes to the shape catalog.

Add a new user-defined attribute to shapes
In addition to the shape properties that are shown by default in the shape
catalog, you can add user-defined attributes to the selected shapes.

User-defined shape attributes are saved in each selected shape's definition file
(.xml) in the \Shapes folder in the model folder.

User-defined attributes of shapes cannot be shown in reports.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

2. Select the shapes to which you want to add a new attribute.

3. Click  Add attribute.

4. In the Define attribute dialog box, do the following:

a. In the Label box, define a name for the attribute.

b. In the Type list, select the type of information that the attribute
contains.

c. In the Description box, enter any additional information about the
attribute. 

d. Click Add attribute.

Tekla Structures shows the new attribute at the end of the property list in
the Shape catalog dialog box and in the Select shape dialog box, before
the tags.

5. In the property list, enter a value for the new attribute in the Value cell,
then press Enter.

6. If you need to modify a user-defined attribute, do the following:

a. Select the attribute in the property list.

b. Click  next to the name of the attribute.

c. In the Modify attribute dialog box, modify the type or description of
the attribute, and then click Modify attribute. 
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You cannot modify the name of the attribute.

The modifications are applied to all shapes that have this attribute
when you click Yes to confirm the modifications.

7. If you need to delete a user-defined attribute, do the following:

a. Select the attribute in the property list.

b. Click  next to the name of the attribute.

c. If you want to delete the attribute from certain shapes only, select the
shapes.

d. Select whether you want to delete the attribute from the selected
shapes only, or from all shapes that have the attribute. Click Delete
from selected or Delete from all accordingly.

8. Click  Save to save the changes to the shape catalog.

Delete a group or sub-group, or shapes
You can delete groups, sub-groups, and shapes within the groups from the
shape catalog. You can delete both the groups and the shapes in the groups at
the same time, or you can delete groups and shapes separately.

Before you delete shapes, ensure that any shape that you want to delete is not
used for items in your Tekla Structures model. When you delete a shape from
the shape catalog, the shape is no longer available anywhere in the model.

If you try to delete shapes that are used for items in the model or whose
definition files are not in the model folder, Tekla Structures does not delete
those shapes.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

2. Select a group or sub-group on the left side of the dialog box.

3. Do one of the following:

• To only delete the group but not the shapes in it, right-click the group,
then select Delete.

If the shapes only belong to the deleted group, the shapes are moved
to the Ungrouped group. If the shapes also belong to any other group,
they remain in that group.

• To delete both the group and the shapes in it, right-click on the group
and select Delete with shapes.

• To only delete certain shapes in the group, select one or more unused
model-folder shapes, right-click on one of the shapes, and then select
Delete.

You are prompted to confirm the deletion.
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4. Click Yes.

5. Click  Save to save the changes to the shape catalog.

Share groups with other users
If you are a Tekla Structures administrator or main user, you might have
organized shapes into groups in a project. You can then share the group
structure so that your user-defined groups become system groups and are
available to all users in the shared model.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

2. If still needed, modify the group structure and shape properties, then click

 Save to save the changes to the shape catalog.

3. Click  Share groups.

4. When prompted to confirm the sharing, click Share groups in the dialog
box that appears.

5. Click OK.

The other users in the shared model will see the shared groups when the
users read in changes the next time.

Organize the shape catalog view
You can organize the shape catalog view to suit your needs and ways of
working.

In the Shape catalog dialog box, you can show or hide property columns, or
change the order of the property columns. You can also filter shapes and mark
them with stars and tags.

In the Select shape dialog box, you can show or hide property columns, or
change the order of the property columns. You can also filter shapes and mark
them with stars.

The Select shape dialog box opens when you click the ... button next to the
Shape box in the item properties, or in a component dialog box.

The changes that you make to the dialog box layout are automatically saved to
the shape_catalog.settings.UI file in the ..\Users\<user>\AppData
\Local\Trimble\Tekla Structures\<version>\Catalogs\ folder. Tekla
Structures uses the saved layout next time you open the dialog box.
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Show or hide the catalog ribbon
You can show or hide the catalog ribbon in catalog dialog boxes and selection
dialog boxes.

You can show or hide the catalog ribbon in the following dialog boxes:

• Rebar catalog

• Select rebar

• Shape catalog

• Select shape

By default, the ribbon is shown in catalog dialog boxes, but hidden in selection
dialog boxes.

• To show the ribbon, click the down arrow  at the right side of the (Home)
ribbon title bar.

• To hide the ribbon, click the up arrow  at the right side of the (Home)
ribbon title bar.

Work with property columns in the catalog view
You can organize the catalog view by showing and hiding the property
columns, and by changing the order, sort order, and width of the columns.

You can organize the columns in the catalog view in the following dialog boxes:

• Rebar catalog

• Select rebar

• Shape catalog

• Select shape

NOTE The Star column is always visible and you cannot hide it.

To Do this
Show or hide a property
column

1.
Click  Show columns to open a list of the
available property columns.

A check mark in front of a column name
indicates that the column is visible.

2. To show a column, click the column name to
add a check mark in front of the column name.

3. To hide a column, click the column name to
remove the check mark.

Change the order of the
property columns

Drag a column header to a new location.
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To Do this
Change the sort order of
a property column

Click the column header.

The arrow symbol next to the column header
indicates if the sort order is ascending  or
descending .

To sort values by two properties and in two
columns:

1. Sort by one column.

2. Hold down Shift and then sort by the other
column.

Resize a property
column

Drag the edge between this and the following
column header. For example:

You can also click  Fit columns to adjust the
widths of the visible columns so that the longest
value in each column (or the column header in the
shape catalog) is shown. This does not affect the
widths of the columns you have manually resized.

Filter shapes
Filtering shapes helps to narrow down the number of shapes shown in the
shape catalog view.

You can filter shapes in both the Shape catalog dialog box and the Select
shape dialog box. You can use filtering together with other methods, such as
sorting.

1. Open the Shape catalog dialog box or the Select shape dialog box.

• On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

• To open the Select shape dialog box, click the ... button next to the
Shape box in the item properties, or in a component dialog box.

2. In the Filter box, type the search term or filtering criteria.

3. Select a group or sub-group. 

Tekla Structures shows the matching shapes in the selected group.
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Add shapes to the Starred group
You can add stars to important or preferred shapes, so that you can easily find
these shapes later. Shapes to which you add stars appear in the Starred group
in the shape catalog.

Starring is user-specific, so it is only visible to you. The starring settings are
stored in the shape_catalog.settings.user.<username> file in the
current model folder.

1. Open the Shape catalog dialog box or the Select shape dialog box.

• On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

• To open the Select shape dialog box, click the ... button next to the
Shape box in the item properties, or in a component dialog box.

2. Browse or search for the shapes to which you want to add stars.

3. In the list of shapes, click the white star symbol  in the Star column for
each shape that you want to add to the Starred group. 

By default, the Star column is the first column and the star symbol is at
the beginning of each shape row.

The star symbol turns yellow  and the shape is added to the Starred
group.

To remove a shape from the Starred group, click the yellow star symbol on the
shape row. The star symbol turns white again.

Add tags to shapes
In the Shape catalog dialog box, you can add tags to shapes to add keywords
or other metadata to the shapes.

Tags are model-specific and saved in the
ShapeCatalog.Groups.User.<username>.xml file in the current model
folder.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

2. Select the shapes that you want to tag.

3. In the Tags box at the bottom-right corner of the Shape catalog dialog
box, enter the keywords or metadata, then press Enter. 

To add several tags to a shape, enter the next tag in the next tag box, then
press Enter.

Each group of tagged shapes appears with the  symbol under Tags in
the list of groups.

Start new projects as a Tekla Structures
administrator

307 Customize catalogs and databases



4. Click  Save to save the changes to the shape catalog.

Remove tags from shapes or delete tags
You can remove tags from shapes or delete tags when they are no longer
needed.

1. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

2. Remove or delete tags.

• To remove a tag from a shape, select the shape, then click the X
symbol after the tag name in the Tags section in the property area.

• To delete a tag, select the tagged group, select all the shapes in the
group, then click the X symbol after the tag name in the Tags section in
the property area.

3. Click  Save to save the changes to the shape catalog.

Import shapes into Tekla Structures
You can import the following types of shape files:

• dgn
• dwg
• dxf
• ifc
• ifcXML
• ifcZIP
• iges
• igs
• shapecatalog
• skp
• step
• stp
• tsc
When you import a shape into the shape catalog, Tekla Structures creates two
files: one .xml file for shape attributes, such as the name and GUID, and
one .tez file for geometric properties, such as coordinates. The files are saved
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in the current model folder under the \Shapes and \ShapeGeometries sub-
folders.

The shape name that is shown in the shape catalog is determined as follows:

• If you import a .tsc or .shapecatalog file, the shape name is read from
the imported file.

• If you import other file types, the shape name is the name of the imported
file.

TIP You can also download shapes from Tekla Warehouse, or create shapes using
existing geometry (page 295) in Tekla Structures models.

Import shapes

When you use other modeling software to model shapes that you want to
import into Tekla Structures, we recommend that you center parts around the
origin and direct the parts along the x axis.

From Tekla Structures models you can also import shape catalog groups
(page 296) either with the shapes as .shapecatalog files or without the
shapes as .ShapeCatalog.Groups.xml files.

1. Open the model into which you want to import shapes or shape catalog
groups.

2. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

3. To import shapes without the group structure into a certain group or sub-
group in the shape catalog, select the group or sub-group on the left side
of the dialog box. 

If you do not select a group, Tekla Structures imports the shapes into the
Ungrouped group.

4. Click  Import.

5. In the Import shape definitions dialog box, browse to the folder that
contains the files to be imported, select the files, then click Open. 

Tekla Structures checks if there are duplicates in the shapes in the import
files compared to the existing shape catalog.

In the Import dialog box, you can see the Status of each imported shape,
such as New shape definition or Shape name already exists. If a shape has
already been used in the model, you can also see the Instances of the
shape.

6. If shapes with the same name and GUID as the shapes being imported
already exist in the shape catalog, replace or keep the existing shapes. In
the Import dialog box:
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• Select Overwrite for each existing shape that you want to replace with
a new, imported shape.

• Deselect Overwrite for each existing shape that you want to keep
unchanged.

7. In the Import dialog box, click Import. 

Importing a large file can take several minutes.

8. Click OK to complete the import. 

The groups that contain new or modified shapes are marked with  on
the left side of the Shape catalog dialog box. The new or modified shape
rows are highlighted in yellow in the list of shapes.

9. Click  Save to save changes to the shape catalog.

Shape import has three possible results:

• Tekla Structures imports the shape as a watertight solid shape. All solid
operations are available.

• Tekla Structures imports the shape as a non-solid shape. A non-solid shape
means that the object might not be watertight. For example, it has holes, or
is missing a face or an edge.

• Import fails. The import can fail for several reasons, such as if the shape is
very complex or has no volume. There might also be a tolerance difference
between Tekla Structures and the original software that was used to create
the shape. To find out why the import failed, check the session history log
by going to File menu --> Logs --> Session history log.

The Solidity column in the shape catalog shows whether a shape is solid or
non-solid.

Example: Import a shape from SketchUp Pro
This example shows how to import a solid 3D shape from Trimble SketchUp
Pro to a Tekla Structures model.

1. Create an empty model in SketchUp Pro. 

Delete any extra entities, such as the default person on the drawing area.

2. Create a group of entities. 

Although Tekla Structures supports importing separate individual entities,
we recommend you create a group of entities or a component in
SketchUp.

All SketchUp groups and components should form watertight solids.
Select the group or component and open Entity Info to check that the
selection is a solid. SketchUp solids have a volume. If there is no volume
listed, the selection is not a solid.
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3. Select the group and click Solid Tools --> Union to make the group of
entities into a union of solids. 

Your group becomes a single solid volume: a solid.

4. Place the solid in SketchUp so that it lies along the positive x axis (red),
and halfway on both y (green) and z axes (blue). In Tekla Structures, the
yellow and magenta part handles will align with the x axis used in
SketchUp. 

The location and rotation of the solid in SketchUp are important, since
they determine how an item is inserted and positioned in Tekla Structures.
Different positioning in SketchUp causes an offset in Tekla Structures.

5. Save the SketchUp file.

6. In your Tekla Structures model, open the Shape catalog dialog box and

click  Import.

7. Select the SketchUp file.

8. Click Import.

Tekla Structures imports the shape to the shape catalog and you can use it to
define the shape of an item or a concrete item.

Export shapes
You can export shapes and shape catalog groups together or separately from
each other.

TIP You can also upload shapes to Tekla Warehouse.

1. Open the model from which you want to export shapes or shape catalog
groups.

2. On the File menu, click Catalogs --> Shape catalog to open the Shape
catalog dialog box.

3. Do one of the following to export shapes or groups: 
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To Do this
Export all the shapes in the catalog,
but not the group structure

On the Shape catalog ribbon, click

 Export --> Export all shapes.
Export all the shapes and groups in
the catalog

On the Shape catalog ribbon, click

 Export --> Export all shapes
with groups.

Export the group structure of the
catalog, but not the shapes

On the Shape catalog ribbon, click

 Export --> Export group
structure only.

Export all the shapes in a group or
sub-group

Select the group or sub-group, right-
click, and select Export shapes.

For example, you can export the
shapes in the Starred group, or
groups of tagged shapes.

Export all the shapes in a group or
sub-group and also the group

Select the group or sub-group, right-
click, and select Export shapes with
group.

Export a group or sub-group and its
sub-groups, but not the shapes

Select the group or sub-group, right-
click, and select Export selected
group structure only.

Export one or more individual shapes Select the shapes (page 299), right-
click, and select Export.

4. In the Export to dialog box, browse to a folder, enter a name for the
export file, and then click Save. 

If you are only exporting one individual shape, browse to and select a
folder for the export file, then click Select folder in the Export to dialog
box. The shape name is used as the name of the export file.

Tekla Structures saves the export file in the selected folder. When the export is
completed, you can click Open folder to open the export folder.

The file name extension of the export file depends on the exported content,
being:

• .tsc if only one shape is exported

• .shapecatalog if several shapes or both shapes and groups are exported

• .ShapeCatalog.Groups.xml if only the group structure is exported
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Compress shape geometry files
You can compress shape geometry files by converting the files from .xml
format to compressed format .tez. Using the .tez format saves disk space.

In Tekla Model Sharing models, the shape geometry files are automatically
converted from .xml to .tez.

In models that are not shared, you can manually compress the shape
geometry files that are stored in the \ShapeGeometries sub-folder in the
current model folder. The files in the \Shapes sub-folder are not compressed.

If you have already used any of the shapes for items in the model, they work
the same way even after compression.

NOTE Compression is a permanent action. You cannot undo it even if you do
not save the model.

To compress existing shape geometry files, either re-import the original shape
files (page 308), or use the Compress shape geometries application.

1. Open the model for which you want to compress shape geometry files.

2. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

3. Search for the Compress shape geometries application, then double-
click to open it.

4. In the Compress shape XML files to TEZ format dialog box, click
Compress.

5. Close the model, then open it again.

Clean or restore shape geometry files
If some previously imported shapes cause missing faces or edges in items or
drawings, you can clean the shape geometry files.

Cleaning means that Tekla Structures investigates and corrects the shape
geometry, and tries to create solid objects.

Clean shape geometry files

To clean existing shape geometry files, either re-import the original shape files
(page 308), or use the Shape cleaner application as follows:

1. Open the model for which you want to clean shape geometry files.

2. Click the Applications & components button  in the side pane to
open the Applications & components catalog.

3. Search for the Shape cleaner application, then double-click to open it. 

The Shape cleaner dialog box opens.
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4. Select the shapes that you want to clean.

5. If you need to hide unnecessary edges or show more edges in the
selected shapes, use the Edge visibility settings. 

a. Enter a threshold value for the angle between the neighboring faces
in each of the selected shapes.

b. To hide edges when the neighboring shape faces are in a smaller
angle than the threshold value, select the first check box.

c. To show edges when the neighboring shape faces are in a greater
angle than the threshold value, select the second check box.

Shapes with too many visible or invisible edges can affect how various
Tekla Structures features operate on items that are created using those
shapes. For example, creating rebar sets might fail if complex shapes have
too many edges visible.

6. To create backups of the shape geometry files, select Create backups
from shapes before cleaning. 

Creating backups of the original shape geometry files allows you to
restore them if needed.

7. Click Clean. 

Tekla Structures cleans the shapes and shows how many shapes resulted
in being solid objects and how many non-solid.

If you need to interrupt the cleaning process, you can click Stop.

8. To see the changed shape geometry in the items in the model, close the
model, then open it again.

Restore the original shape geometry files
If you have created backup files, you can restore the original shape geometry
files if you are not happy with the result of the cleaning.

1. Open the Shape cleaner dialog box again.

2. Select the shapes that you want to restore.

3. Click Revert.
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Customize the bolt catalog
The individual bolt assembly elements, such as bolts of different sizes and
lengths, nuts and washers, are listed in the bolt catalog. Each bolt assembly
then consists of these bolt assembly elements. You cannot use a bolt if it does
not belong to a bolt assembly. The bolt assemblies are listed in the bolt
assembly catalog.

Tekla Structures stores the bolt catalog information in the screwdb.db file
and the bolt assembly catalog information in the assdb.db file.

See also

How the bolt catalog and bolt assembly catalogs work together (page 315)

How bolt and bolt assembly catalogs affect length calculation (page 322)

How the bolt catalog and bolt assembly catalogs work together

(1) The Bolt standard options are read from the bolt assembly catalog.

(2) The bolt assembly catalog defines which bolt standard is used in the bolt
assembly.
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(3) The bolt catalog contains the different bolt diameters, lengths, and other
properties used in the bolt standard.

(4) The Bolt size options are read from the bolt catalog depending on the
selected Bolt standard option.

Manage bolts and bolt assemblies
In the bolt catalog and the bolt assembly catalog, you can add, modify, and
delete bolts and bolt assemblies.

Add a bolt to the catalog
You must add individual bolt elements, such as bolts, nuts, and washers, to the
bolt catalog before you can define bolt assemblies and use them in a model.

These steps are for adding bolts, but they also apply to adding nuts and
washers.

TIP You can also add bolts by importing them into the bolt catalog.

1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt
Catalog dialog box.

2. Enter the name of the bolt in the following box: 

You can enter a maximum of 40 characters in the name box.

3. In the Type list, select an option to define the bolt element type.

4. Define the other properties of the new bolt. 

You can enter a maximum of 25 characters in the Standard box.

Use different names for bolt, nut, washer, and stud standards to
distinguish bolt element types from each other when defining bolt
assemblies.

5. Click Add to add the bolt to the bolt catalog. 

You cannot use a bolt if it does not belong to a bolt assembly. Therefore,
we recommend checking that the catalog also includes nuts and washers
that work with the new bolt so that you can create a bolt assembly. If the
catalog does not include suitable nuts and washers, add them the same
way as you added the new bolt.

6. Click OK. 

The Save confirmation dialog box appears.

7. Select Save changes to model folder to save the changes in the
screwdb.db file in the current model folder, and then click OK.
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Add a stud bolt to the catalog
A stud is special type of bolt that is welded to steel parts to transfer loads
between steel and concrete. You cannot use studs unless you have defined a
stud assembly that contains the assembly's name and material.

1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt
Catalog dialog box.

2. Enter values for the following properties: 

• Name: Name for the stud bolt.

• Type: 

• Standard: This name is needed when creating a bolt assembly for the
stud.

• Diameter: Shank diameter.

• Length: Stud length.

• Weight: Stud weight.

• top thick: Head thickness.

• top diameter: Head diameter.

The units depend on the settings in File menu --> Settings --> Options -->
Units and decimals .

3. On the File menu, click Catalogs --> Bolt assembly catalog to open the
Bolt Assembly Catalog dialog box.

4. Select the standard for the stud bolt.

5. Set all the other bolt assembly elements to None. 

6. To create studs in the model, create bolts and select the stud assembly
standard.
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Modify bolt information in the catalog

1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt
Catalog dialog box.

2. Select a bolt from the list.

3. Modify the properties.

4. Click Update.

5. Click OK. 

The Save confirmation dialog box appears.

6. Select Save changes to model folder to save the changes in the
screwdb.db file in the current model folder, and then click OK.

Delete a bolt from the catalog

1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt
Catalog dialog box.

2. Select a bolt from the list. 

Use the Shift and Ctrl keys to select multiple bolts.

3. Click Delete.

4. Click OK. 

The Save confirmation dialog box appears.

5. Select Save changes to model folder to save the changes in the
screwdb.db file in the current model folder, and then click OK.

Add a bolt assembly to the catalog
You can add new bolt assemblies to the bolt assembly catalog. The bolt
assembly can contain only bolts or studs, but not both.

1. On the File menu, click Catalogs --> Bolt assembly catalog to open the
Bolt Assembly Catalog dialog box.

2. Enter the name of the bolt assembly in the following box: 

3. Define the other properties of the new bolt assembly. 

You can enter a maximum of 30 characters in the Standard box. For all
the other properties, you can enter a maximum of 25 characters.

4. Click Add to add the bolt assembly to the catalog.

5. Click OK. 

The Save confirmation dialog box appears.
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6. Select Save changes to model folder to save the changes in the
assdb.db file in the current model folder, and then click OK.

Modify bolt assembly information in the catalog

1. On the File menu, click Catalogs --> Bolt assembly catalog to open the
Bolt Assembly Catalog dialog box.

2. Select a bolt assembly from the list.

3. Modify the properties (page 327).

4. Click Update.

5. Click OK. 

The Save confirmation dialog box appears.

6. Select Save changes to model folder to save the changes in the
assdb.db file in the current model folder, and then click OK.

Delete a bolt assembly from the catalog

1. On the File menu, click Catalogs --> Bolt assembly catalog to open the
Bolt Assembly Catalog dialog box.

2. Select a bolt assembly from the list.

3. Click Delete.

4. Click OK. 

The Save confirmation dialog box appears.

5. Select Save changes to model folder to save the changes in the
assdb.db file in the current model folder, and then click OK.

Import and export bolts and bolt assemblies
You can import and export bolts and bolt assemblies to merge bolts and bolt
assemblies across catalogs.

Importing and exporting bolt catalogs is useful, when you:

• Upgrade to newer version of Tekla Structures and you want to use a
customized bolt catalog from a previous version.

• Want to combine bolt catalogs that are stored in different locations.

• Want to share bolt catalog information with other users.

Bolts, bolt assemblies, and bolt catalogs are imported and exported as the
following types of files:

• Bolts: .bolts
• Bolt assemblies: .bass
• Bolt catalogs: .lis
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When you export single bolts or bolt assemblies, you can select the bolts or
bolt assemblies that you want to include in the export file. When you import
and export bolt assemblies, all the related bolt elements (bolts, studs, screws,
nuts, washers) are also included in the export file.

You can import and export an entire bolt catalog. You can also import a part of
an exported bolt catalog.

TIP You can also download or share bolt assemblies using Tekla Warehouse.

Import bolts to the catalog
Bolts are imported and exported as .bolts files. A .bolts file can include
one bolt or several bolts.

1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt
Catalog dialog box.

2. Right-click in the Bolts list, then select Import.

3. Select the import file.

4. Click OK. 

The bolts are shown on the Bolts list by their original names.

5. Click OK. 

The Save confirmation dialog box opens.

6. To save the changes in the screwdb.db file in the current model folder,
select Save changes to model folder, then click OK.

Export bolts from the catalog
Bolts are imported and exported as .bolts files. A .bolts file can include
one bolt or several bolts.

1. On the File menu, click Catalogs --> Bolt catalog to open the Bolt
Catalog dialog box.

2. From the Bolts list, select one or more bolts. 

Use the Shift and Ctrl keys to select multiple bolts.

3. Right-click in the Bolts list, then select Export.

4. Browse for the folder where you want to save the export file.

5. In the Selection field, enter a name for the file.

6. Click OK.

Import bolt assemblies to the catalog
Bolt assemblies are imported and exported as .bass files. A .bass file can
include one bolt assembly or several bolt assemblies.
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1. On the File menu, click Catalogs --> Bolt assembly catalog to open the
Bolt Assembly Catalog dialog box.

2. Right-click in the Bolt assemblies list, then select Import.

3. Select the import file.

4. Click OK. 

The bolt assemblies are shown on the Bolt assemblies list with their
original names.

5. Click OK. 

The Save confirmation dialog box opens.

6. To save the changes in the assdb.db file in the current model folder,
select Save changes to model folder, then click OK.

Export bolt assemblies from the catalog
Bolt assemblies are imported and exported as .bass files. A .bass file can
include one bolt assembly or several bolt assemblies.

1. On the File menu, click Catalogs --> Bolt assembly catalog to open the
Bolt Assembly Catalog dialog box.

2. From the Bolt assemblies list, select one or more bolt assemblies. 

Use the Shift and Ctrl keys to select multiple bolt assemblies.

3. Right-click in the Bolt assemblies list, then select Export.

4. Browse for the folder where you want to save the export file.

5. In the Selection field, enter a name for the file.

6. Click OK.

Import a bolt catalog
Bolt catalogs are imported to Tekla Structures models as .lis files.

1. Open the model into which you want to import a bolt catalog.

2. Copy the screwdb.lis file that you want to import to the current model
folder.

3. To import the bolt catalog file screwdb.lis from the current model
folder, go to Quick Launch, start typing import bolt catalog, and
select the Import Bolt Catalog command from the list that appears. 

Tekla Structures does not replace entries that have the same names as
the entries in the import file.

4. Check the status bar for error messages. 

To view errors, select File --> Logs --> Session history log .
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Import part of the bolt catalog
If you do not want to import the entire bolt catalog, you can select the parts to
be imported.

TIP If you only want to import a few bolts or bolt assemblies, use the import
and export commands for the corresponding catalogs.

1. Open the model that contains the bolt catalog that you want to use.

2. Go to Quick Launch, start typing export bolt catalog, and select the
Export Bolt Catalog command from the list that appears. 

The bolt catalog is saved as the screwdb.lis file in the current model
folder.

3. Open the screwdb.lis file using a text editor, such as Microsoft
Notepad. 

Each entry is listed on a separate row.

4. Delete the unwanted rows from the file. 

WARNING Do not delete the STARTLIST and ENDLIST rows.

5. Save the file with the name screwdb.lis.

6. Open the model into which you want to import the bolt catalog.

7. Copy the screwdb.lis file that you want to import to the current model
folder.

8. To import the bolt catalog file screwdb.lis from the current model
folder, go to Quick Launch, start typing import bolt catalog, and
select the Import Bolt Catalog command from the list that appears.

Export an entire bolt catalog
Bolt catalogs are exported from Tekla Structures models as .lis files.

1. Open the model that contains the bolt catalog that you want to export.

2. Go to Quick Launch, start typing export bolt catalog, and select the
Export Bolt Catalog command from the list that appears.

The exported bolt catalog is the screwdb.lis file in the current model folder.

How bolt and bolt assembly catalogs affect length calculation
Tekla Structures uses values from the bolt catalog and the bolt assembly
catalog when it calculates the bolt length. If the bolt catalog does not contain
long enough bolts for your purposes, you must add them to the bolt catalog.

The following Assembly settings in the Bolt properties affect the bolt length
calculation. If the check box is selected, the bolt element is used in the bolt
assembly.
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Bolt assembly Bolt elements
1: If the check box is clear, only a hole
is created

2: Washer (1)

3: Washer (2)

4: Washers (3)

5: Nut (1)

6: Nut (2)

The chart and the detailed steps below explain the process of bolt length
calculation.

1. Tekla Structures calculates the minimum possible length of the bolt as
follows:

washer (1) thickness (if the check box is selected) +

material thickness +

washer (2) thickness (if the check box is selected) +

washer (3) thickness (if the check box is selected) +

nut (1) thickness +

nut (2) thickness +

extra length

2. Tekla Structures searches for the closest match in the bolt catalog.
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3. Tekla Structures calculates the number of washers required (must not
exceed 10) so that the length of the shaft is less than:

nut (1) thickness +

material thickness +

nut (2) thickness +

washer (1) thickness +

washer (2) thickness +

(number of washers*washer (3) thickness)

4. Tekla Structures checks that the bolt found in step 2 is longer than:

extra length +

nut (1) thickness +

material thickness +

nut (2) thickness +

add. dist (from the bolt catalog) +

washer (1) thickness +

washer (2) thickness +

(number of fitting washers * washer (3) thickness)

5. If the selected bolt does not fulfill the criteria in step 4, Tekla Structures
returns to step 2, otherwise it continues on to step 6.

6. Tekla Structures checks that the selected bolt fulfills all the following
conditions:

• Can the thread be inside the material to be connected? Even if this is
not allowed, the calculation always allows 3 or 4 mm of thread to be
inside the material, depending on the bolt diameter. If the bolt
diameter is ≥ 24 mm, it allows 4 mm, otherwise it allows 3 mm.

• Shaft length must be more than:

material thickness +

extra length +

washer (1) thickness (if checked) -

maximum thread in material allowed (if thread in material = no) =
3 mm or 4 mm

• Shaft length is calculated as:

Screw length - screw thread length - thread end.
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• Thread end is the part of the bolt between the shaft and the thread. It
is calculated as follows:

Diameter of bolt (mm) Thread end (mm)
>33.0 10.0
>27.0 8.0
>22.0 7.0
>16.0 6.0
>12.0 5.0
>7.0 4.0
>4.0 2.5
≤4 1.5

7. If the selected bolt does not fulfill all the above conditions, Tekla
Structures returns to step 2 and tries the next longest bolt.

8. If the advanced option is set, the epsilon thickness is added to, or
subtracted from, the material thickness to avoid inaccurate bolt length
calculation.

For example, if this value is not taken into account, and the calculated
length is 38.001 mm, a 39 mm bolt might be selected.

Bolt catalog properties
Use the Bolt Catalog dialog box to view and modify the properties of
individual bolt elements, such as bolts, washers, and nuts.

The units depend on the settings in File menu --> Settings --> Options -->
Units and decimals .

Option Description
Type The type of the bolt element. The options are:

 (Nut)

 (Washer)
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Option Description

 (Stud)
Standard The name of the bolt element standard.

Used in the Bolt Assembly Catalog dialog box for defining
bolt elements in a bolt assembly.

Use different names for bolt, nut, washer, and stud standards
to distinguish bolt element types from each other.

Diameter The diameter of the bolt element.
Length The length of the bolt element.
Weight The weight of the bolt element.
add. dist The length of the part of the bolt that protrudes from the nut.

The value is used in bolt length calculation.
top thick The thickness of the bolt head.
thread len The length of the threaded part of the bolt shaft.

The value is not used in bolt length calculation (value is 0) if
the bolt is fully-threaded.

washer tol The tolerance between the washer inner diameter and the
bolt diameter.

The value is used when searching for the correct-sized
washer for the bolt. Not used in bolt length calculation.

span size The size of the wrench needed.
calc thick The calculation thickness of a nut or a washer.

This value is used in bolt length calculation.
real thick The true thickness of a nut or a washer.

This is for information only.
inner diam The inner diameter of a nut or a washer.

This is for information only.
outer diam The outer diameter of a nut or a washer.

This is for information only.
top diam The diameter of the hexagon.

This is for information only.

See also

Manage bolts and bolt assemblies (page 316)
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How the bolt catalog and bolt assembly catalogs work together (page 315)

Bolt assembly catalog properties
Use the Bolt Assembly Catalog dialog box to view and modify the properties
of bolt assemblies.

The units depend on the settings in File menu --> Settings --> Options -->
Units and decimals .

Option Description
Short name This name is used in drawings and reports. It is usually the

commercial name for a specific bolt.
Standard This name is the full name which is shown in the bolt

assemblies list in the Bolt Assembly Catalog dialog box, and
in the Bolt standard list in the Bolt Properties dialog box.

The value is used in bolt length calculation.
Material The material of the bolt assembly.
Finish The type of the finish.
Grade The grade of the bolt assembly.
Tolerance The tolerances of the bolt assembly.

This is for information only. The values cannot be reported,
for example.

Additional length for bolt calculation

Option Description
Add. dist... The Additional Distance option controls how much of the

bolt protrudes from the nut.

Additional Distance updates the Additional Distance
values of all bolts that use the selected bolt standard and
have the selected diameter.

The value is used in bolt length calculation.
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Select whether the value of the additional length affects all or
individual diameters of one bolt assembly.

Enter the additional length value.

Select whether the value is absolute or relative to the diameter.

See also

Manage bolts and bolt assemblies (page 316)

Customize the rebar catalog
The rebar catalog contains definitions for different reinforcement types, such
as reinforcing bars and strands of different grades.

The rebar catalog shows standard, environment-specific reinforcing bars and
strands of the environment (or environments) that you have installed and that
is currently open. The blank project environment only contains undefined
reinforcing bars and strands.

You can add, copy, group, modify, and delete rebar definitions. You can also
import and export single definitions, groups of definitions, or entire rebar
catalogs.

Tekla Structures stores the rebar catalog information in the
rebar_database.inp file that is by default saved to the current model
folder.

Reinforcement meshes are not included in the rebar catalog. Standard meshes
are defined in their own catalog file (page 69), mesh_database.inp.
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Work with definitions in the rebar catalog
You can add, copy, modify, and delete rebar definitions in the rebar catalog.

To use the newly added or modified rebar definitions in the model, reopen the
model.

Create a new rebar definition
You can add new definitions to the rebar catalog by defining the bar
properties.

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

2. Click  New bar.

3. In the New bar dialog box, enter the bar properties. 

If a property is shown in red, it is missing a value or has a value that is not
valid. For example, Grade and Size must have a value.

4. Click Add.

5. Click  Save to save the changes to the rebar catalog.

Create a new rebar definition by copying an existing definition
You can add new definitions to the rebar catalog by copying an existing
definition and then modifying it.

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

2. Browse for and select the definition that you want to copy.

3. Click  Copy.

4. In the Copy dialog box, enter or modify the bar properties. 

Modify the property values that are shown in red so that the new
definition is not the same as the original definition.

5. Click Add.

6. Click  Save to save the changes to the rebar catalog.

Select rebar definitions
Selecting different sets of definitions is useful when you want to export or add
tags to rebar definitions, or modify a sub-set of definitions.
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You can use these methods when you select rebar definitions in the Rebar
catalog dialog box.

• Use the following commands on the catalog ribbon:

• Click Select all to select all the definitions in the currently visible group.

Alternatively, you can select one definition and then press Ctrl+A.

• Click Select none to clear the current selection.

• Click Invert selection to select the currently unselected definitions and
to deselect the currently selected definitions.

• To select several consecutive definitions, select the first definition, then
hold down Shift and select the last definition.

• To select several non-consecutive definitions, select the first definition, then
hold down Ctrl and select the other definitions.

Modify a rebar definition

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

2. Browse for and select the definition that you want to modify. 

To modify several definitions, hold down Ctrl or Shift when you select
them.

3. In the property area on the right side of the Rebar catalog dialog box,
modify the bar properties. 

For example, you can select whether the bar is a main bar, or a tie or
stirrup. Or you can adjust hook lengths or lap lengths, or tolerances for
rebar shape recognition. You might also want to add tags to the bar.

If a property is shown in red, it is missing a value or has a value that is not
valid. For example, Grade and Size must have a value.

4. Click  Save to save the changes to the rebar catalog.

Delete rebar definitions

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

2. Select one or more rebar definitions.

3. Right-click and select Delete.

4. Click Yes to confirm the deletion.

5. Click  Save to save the changes to the rebar catalog.
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Work with groups in the rebar catalog
In the rebar catalog, the rebar definitions are arranged in groups. You can add,
copy, modify, and delete groups, and arrange the groups according to different
properties.

The groups are listed on the left side of the Rebar catalog and Select rebar
dialog boxes.

By default, the definitions in the rebar catalog are grouped according to
reinforcement grades. You can change how the definitions are grouped
(page 335) in the Rebar catalog dialog box or in the Select rebar dialog box.

To use the newly added or modified rebar definition groups in the model,
reopen the model.

Add a new group to the catalog
You can create new groups in the rebar catalog by copying an existing group
and the definitions contained in it.

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

2. On the left side of the dialog box, select a group, and then click 
Copy. 

Alternatively, you can right-click a group and select Copy.
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3. In the New group name dialog box, enter a name for the new group, and
then click Copy. 

Tekla Structures adds the new group to the catalog.

4. Add, modify, and delete definitions (page 328) contained in the new group
as needed.

5. Click  Save to save the changes to the rebar catalog.

Modify a group in the catalog

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

2. Select the group that you want to modify.

3. Select all definitions in the group.

4. In the property area on the right side of the Rebar catalog dialog box,
modify the group properties. 

For example, you can change the grade or cranked length type. You may
also want to add tags (page 338) to all definitions in the group.

5. Click  Save to save the changes to the rebar catalog.

Delete a group from the catalog
You can delete groups and the definitions contained in them from the rebar
catalog.

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

2. Select a group from the list on the left side of the dialog box.

3. Right-click and select Delete.

4. Click Yes to confirm the deletion.

5. Click  Save to save the changes to the rebar catalog.

Import and export rebar definitions
You can import and export rebar definitions to merge rebar definitions across
different catalogs, models, and Tekla Structures environments and versions.
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To use reinforcing bars and strands in other Tekla Structures models, you can
export rebar definitions to a file (*.inp), then import the file into another
Tekla Structures model.

TIP You can also download or share rebar catalog content using Tekla Warehouse.

Import definitions to the rebar catalog
You can customize the rebar catalog by importing rebar definitions from
an .inp file.

1. Open the model to which you want to import rebar definitions.

2. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

3. Click  Import.

4. In the Import rebar definitions dialog box, browse for the folder that
contains the import file, select the file, then click Open. 

Tekla Structures checks if there are duplicates in the definitions in the
import file compared to the rebar catalog.

5. If rebar definitions with the same properties as the definitions being
imported already exist in the rebar catalog, a confirmation dialog box
appears and you have the following three options:

• Click Overwrite to replace all existing definitions with the newly
imported definitions.

• Click Keep existing to discard the duplicate definitions being imported
and to only import the new definitions.

• Click Cancel to not to import any definitions.

6. Click  Save to save the changes to the rebar catalog.

7. To use the newly imported definitions in the model, reopen the model.

Export definitions from the rebar catalog
You can export all or selected rebar definitions, or a selected group of a rebar
catalog to a file (.inp).

1. Open the model from which you want to export rebar definitions.

2. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

3. Do one of the following:

• To export the entire catalog, click  Export --> Export all.
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• To export a certain group only, select the group, right-click and select
Export.

• To export certain definitions only, select the definitions, then click

 Export --> Export selected.

Alternatively, you can right-click one of the selected definitions, then
select Export.

4. In the Export as dialog box, browse for a folder, enter a name for the
export file, then click Save. 

By default, Tekla Structures saves the file to the current model folder.

The file name extension is .inp.

Organize the rebar catalog view
You an organize the rebar catalog view to suit your needs and ways of working.

In the Rebar catalog dialog box, you can change how the rebar definitions are
grouped, show or hide certain property columns, or change the order of the
property columns. You can also filter definitions and mark them with stars and
tags.

In the Select rebar dialog box, you can change how the rebar definitions are
grouped, show or hide certain property columns, or change the order of the
property columns. You can also filter definitions and mark them with stars.

The Select rebar dialog box opens when you click the ... button next to the
Size box in a reinforcement object's properties, or in a component dialog box
to select a rebar definition.

The status bar at the bottom of the Rebar catalog and Select rebar dialog
boxes shows useful information, such as:

• The number of definitions in the selected group.

• The property by which the definitions are grouped.

• The property by which the definitions are sorted.

The arrow symbol indicates if the sort order is ascending  or descending
.

In the Rebar catalog dialog box, the status bar also shows the number of the
selected definitions.

The changes that you make to the dialog box layout are automatically saved to
the rebar_catalog.settings.UI file in the ..\Users\<user>\AppData
\Local\Trimble\Tekla Structures\<version>\Catalogs\ folder. Tekla
Structures uses the saved layout next time that you open the dialog box.
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Show or hide the catalog ribbon
You can show or hide the catalog ribbon in catalog dialog boxes and selection
dialog boxes.

You can show or hide the catalog ribbon in the following dialog boxes:

• Rebar catalog

• Select rebar

• Shape catalog

• Select shape

By default, the ribbon is shown in catalog dialog boxes, but hidden in selection
dialog boxes.

• To show the ribbon, click the down arrow  at the right side of the (Home)
ribbon title bar.

• To hide the ribbon, click the up arrow  at the right side of the (Home)
ribbon title bar.

Change the grouping of rebar definitions
You can select the property by which the rebar definitions are grouped in the
rebar catalog. By default, the rebar definitions are grouped by grade.

You can also group the definitions by a property for which the property
column is not visible.

The properties that are available might vary in the Rebar catalog and Select
rebar dialog boxes.

1. Open the Rebar catalog dialog box or the Select rebar dialog box.

• On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

• To open the Select rebar dialog box, click the Size box in a
reinforcement object's properties, or in a component dialog box.

2. Click  Group by, and then select the property by which you want to
group the rebar definitions. 

For example, you can select Size or Cross section area.

Work with property columns in the catalog view
You can organize the catalog view by showing and hiding the property
columns, and by changing the order, sort order, and width of the columns.

You can organize the columns in the catalog view in the following dialog boxes:

• Rebar catalog

• Select rebar

• Shape catalog
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• Select shape

NOTE The Star column is always visible and you cannot hide it.

To Do this
Show or hide a property
column

1.
Click  Show columns to open a list of the
available property columns.

A check mark in front of a column name
indicates that the column is visible.

2. To show a column, click the column name to
add a check mark in front of the column name.

3. To hide a column, click the column name to
remove the check mark.

Change the order of the
property columns

Drag a column header to a new location.

Change the sort order of
a property column

Click the column header.

The arrow symbol next to the column header
indicates if the sort order is ascending  or
descending .

To sort values by two properties and in two
columns:

1. Sort by one column.

2. Hold down Shift and then sort by the other
column.

Resize a property
column

Drag the edge between this and the following
column header. For example:

You can also click  Fit columns to adjust the
widths of the visible columns so that the longest
value in each column (or the column header in the
shape catalog) is shown. This does not affect the
widths of the columns you have manually resized.
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Filter rebar definitions
Filtering rebar definitions helps to narrow down the number of rebar
definitions shown in the rebar catalog view.

You can filter rebar definitions in both the Rebar catalog dialog box and the
Select rebar dialog box. You can use filtering together with other methods,
such as sorting.

1. Open the Rebar catalog dialog box or the Select rebar dialog box.

• On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

• To open the Select rebar dialog box, click the Size box in a
reinforcement object's properties, or in a component dialog box.

2. In the Filter box, enter the search term or filtering criteria. 

For example, to find rebar definitions that are suitable for stirrups and
ties, enter tie.

Tekla Structures shows the groups that contain matching definitions.

3. Select a group. 

Tekla Structures shows the matching definitions in the group, for example,
the definitions that have Usage set to tie/stirrup.

Add rebar definitions to the Starred group
You can add stars to important or preferred rebar definitions, so that you can
easily find these definitions later. Rebar definitions to which you add stars
appear in the Starred group in the shape catalog.

Starring is user-specific, so it is only visible to you. The starring settings are
stored in the current model folder in the
rebar_catalog.settings.user.<username> file, where the <username>
suffix is your username.

If you have starred definitions, the Rebar catalog dialog box opens with the
Starred group selected.

1. Open the Rebar catalog dialog box or the Select rebar dialog box.

• On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

• To open the Select rebar dialog box, click the Size box in a
reinforcement object's properties, or in a component dialog box.

2. Browse or search for the definitions to which you want to add stars.

3. In the definition list, click the white star symbol in the Star column for
each definition that you want to add to the Starred group. 
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By default, the Star column is the first column and the star symbol is at
the beginning of each definition row.

The star symbol turns yellow  and the definition is added to the
Starred group.

To remove a definition from the Starred group, click the yellow star symbol on
the definition row. The star symbol turns white again.

Add tags to rebar definitions
In the Rebar catalog dialog box, you can add tags to rebar definition to add
keywords or other metadata the definitions.

For example, you could use tags like Stainless and Acid proof.

Tags are model-specific and saved to the rebar_catalog.settings file in
the current model folder.

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

2. Select the definitions that you want to tag.

3. Enter the tag in the Tags box at the bottom-right corner of the Rebar
catalog dialog box, and then press Enter. 

To add several tags to a definition, enter the next tag in the next tag box
and press Enter.

Each group of tagged definitions appears with the  symbol in the list of
groups, after the Starred group:
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4. Click  Save to save the changes to the rebar catalog.

Remove tags from rebar definitions or delete tags
You can remove tags from rebar definitions or delete tags when they are no
longer needed.

1. On the File menu, click Catalogs --> Rebar catalog to open the Rebar
catalog dialog box.

2. Remove or delete tags.

• To remove a tag from a definition, select the definition and click the X
symbol after the tag name in the Tags section in the property area.

• To delete a tag completely, select the tagged group, select all the
definitions in the group, and then click the X symbol after the tag
name in the Tags section in the property area.

3. Click  Save to save the changes to the rebar catalog.

Customize the Applications & components catalog
You can modify the catalog definition settings of the Applications &
components catalog using catalog definition files, and set up a group
structure to suit the needs of your company.

Always check the settings and the group structure when upgrading to a new
Tekla Structures version.

Catalog definition files (ComponentCatalog.xml) can be located in folders
that are defined by the XS_SYSTEM, XS_FIRM, and XS_PROJECT advanced
options, and in the model folder. If there are several catalog definition files,
Tekla Structures combines the information in the files. For more information
about the folder search order, see Folder search order (page 45).

When you create a group structure for the Applications & components
catalog, define the highest level structure in a catalog definition file that is
located in a folder that is defined by the XS_SYSTEM advanced option. To hide
unnecessary parts of the group structure and catalog content from certain
roles, edit the catalog definition files of these roles.

You can also add your own instructor side pane help pages (page 345) for the
tools in the Applications & components catalog.
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Edit the Applications & components catalog
1. To edit the catalog definition files, set the

XS_COMPONENT_CATALOG_ALLOW_SYSTEM_EDIT advanced option to 
TRUE.

2. In the Applications & components catalog, click  Access advanced
features --> Catalog management --> Edit mode, then select the catalog
definition file that you want to edit. 

The list of files shows all the environment folders, the project and firm
folders if defined, and the model folder. You can define the catalog
definition file folder paths in XS_SYSTEM.

If XS_COMPONENT_CATALOG_ALLOW_SYSTEM_EDIT is not set to TRUE, a
small warning icon is shown next to the files in the XS_SYSTEM folder
locations. The image shows warning icons next to the files that appear
dimmed.

Files that appear dimmed do not exist, but you can create the files by
selecting them, and clicking Yes in the Edit mode message box.
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You can remove an existing file by clicking the  button next to the file.

3. Select the file that you want to edit. 
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The check mark in front of the folder name shows the file that is currently
being edited.

4. Create new groups and subgroups to organize the catalog content, right-
click in the catalog and select New group....

5. Move the content from Ungrouped items to the new groups, or to other
predefined custom groups. 
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To move an item to another group, right-click the item, select Add to
group, then select the target group.

It is important to keep the Ungrouped items group empty because all
items downloaded from Tekla Warehouse are placed in that group. When
you place an item to a predefined group, it is automatically removed from
the ungrouped items.

Maintain the Applications & components catalog
To keep the Applications & components catalog structure and content clear
and in order, keep the groups up to date and organized, and remove the
unnecessary items from the catalog definition files.

1. Click  in the bottom-right corner in the Applications & components
catalog to display the message log: 
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If an item defined in a catalog definition file is removed from the Tekla
Structures software, the removed item will be included in the
Applications & components catalog error message log.

2. If the log contains references to missing items, edit the relevant
ComponentCatalog.xml file to remove the references manually. 

We recommend that you make a back-up copy of the file before you start
editing.

3. Thoroughly test that these changes do not create any further errors, or
cause problems in the group structure in the Applications &
components catalog. 

Check at least the Ungrouped items and Legacy catalog groups.

4. If there are new items in the group, move them from the Ungrouped
items group to the appropriate predefined groups, and hide them from
specific roles, if needed.

5. Add suitable thumbnails to the items, if needed.

Create your own component folder
Usually, only a few different connections and components are used in a
project. To ensure that everyone in the project uses the same components and
finds the components faster, we recommend that you create your own
component folder.

TIP In the Applications & components catalog, use the commands in

Access advanced features  > Catalog management to modify
catalog definitions.

1. Click the Applications & components button  in the side pane to
open the Applications & components catalog.
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2. To create a new group for the project, right-click in the catalog, then select
New group.

3. Add components to the group.

a. Select the components in the catalog, right-click, then select Add to
group.

b. Select the group to which you want to add the components. 

You can also drag the selected components to another group.

4. To hide the groups that you do not need, select the group, right-click, then
select Hide/Unhide.

Troubleshooting components or groups in the Applications &
components catalog
If a component or group in the Applications & components catalog is not
working as expected, you can generate a troubleshooting dump file that shows
the data used to construct the component or group.

1. In the Applications & components catalog, click  Access advanced
features --> Catalog management --> Show dump command for
selected component or group.

2. In the catalog, select the component or group, then right-click and select
Dump troubleshooting data.

3. In the dialog box that opens, select the target file path and enter the file
name, then click Save to save the file. 

By default, the file is stored in the \local\temp folder for the model.

Add instructor help for applications and components
You can easily create side pane help for tools in the Applications &
components catalog.

In the Applications & components catalog, the Instructor shows content
when you select an item, so the information is especially useful for giving
advice to your users on choosing between different components or giving
instructions before running a tool. To make full use of this feature, users
should arrange their side panes so that both panes are visible.

1. Select the tool you want to add help for in the Applications &
components catalog.

2. Click the Add help files button in the Instructor pane. 
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A dialog box opens for creating the necessary files according to your
selections.

3. Click Next and select the languages that are used as user interface
languages in your organization. There needs to be a content file for each
language even if you do not translate the content.

4. Click Next and select the folder where you want to store the generated
files. The files can be stored in the model, project, firm, or system folder.
The standard folder search order (page 45) is followed.

5. Click Create. 

Tekla Structures creates an XML file that defines a link between the tool in
the Applications & components catalog and an HTML file for the help
content.

The HTML files are stored in a folder structure that separates files into
language-specific folders. The XML file and the root folder for the content
are named according to the identifier of the tool you are documenting.
You can copy files between the allowed storage locations, but do not
rename the files or folders or change the folder structure.

6. Edit the HTML content file(s) in your preferred tool, such as a text editor,
or replace the file with your own HTML file of the same name. If you do
not have any HTML editing experience, there are several good tutorials
available on the internet to quickly learn the few basics you need to know.
You can create your own HTML files by saving as HTML from familiar tools,
such as Microsoft Word or Google Docs. Note that the resulting files will
not look exactly the same as the original document.

4.9 Create start-up shortcuts with customized
initializations
To use the correct .ini files for a specific project, you can create shortcuts to
start teklastructures.exe with customized initializations.

You can use this functionality to create shortcuts for different purposes, for
example, to have customized setup files depending on the client you are
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working for in a project. The Tekla Structures installation automatically creates
shortcuts for the selected environments.

NOTE We recommend that only administrators create the customization and the
necessary shortcuts. Otherwise, your settings may differ from the settings
defined for your firm, or for the particular project you are working for.

For more information about initialization files (.ini files), see initialization files
( files) (page 48).

Create a start-up shortcut with customized initialization
1. Create a customized initialization file.

a. Open the user.ini file using any standard text editor. 

The user.ini file is located in ..\Users\<user>\AppData\Local
\Trimble\Tekla Structures\<version>\UserSettings on
your computer.

b. Save the file with a new name, such as customer.ini or
project.ini.

c. Add the required settings to the file, then save the modified
initialization file.

2. To make a copy of the default shortcut, right-click Tekla Structures
<version> shortcut on your desktop, select Copy, then paste the shortcut
to your desktop.

3. Right-click the shortcut, then select Properties.

4. In the Target field, enter the path to the current teklastructures.exe,
then the project initialization parameters. 
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If the path contains spaces, use quotation marks (") around the path. For
example, "C:\Program Files\Tekla Structures\"

TIP The maximum length of a shortcut is 256 characters. If your shortcut
is too long, you can call all other necessary initialization files from
your customized initialization file instead of adding them to the
shortcut.

5. To override the settings defined in the shortcuts, use the parameter -i
<initialization_file> in the user.ini and option.ini files.

Available parameters in shortcuts
You can use these parameters in start-up shortcuts.

You can use the parameters in combinations. For example, you can set the
parameters to automatically bypass the Tekla Structures - Choose setup
dialog box, open a model, and run a macro.

Parameter Description
-I
<ini_file_path
>

The given .ini file is loaded before the
environment .ini files. This parameter can be specified
multiple times.

This parameter can be used to bypass the Tekla
Structures - Choose setup dialog (the login dialog).

Example:

"C:\Program Files\Tekla Structures\<version>
\bin\TeklaStructures.exe" -I "C:\ProgramData
\Trimble\Tekla Structures\<version>
\Environments\uk\Bypass.ini"
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Parameter Description
-i
<ini_file_path
>

The given .ini file is loaded after the role .ini files.
This parameter can be specified multiple times.

Example:

"C:\Program Files\Tekla Structures\<version>
\bin\TeklaStructures.exe" -i
"C:\TeklaStructures\MySettings.ini"

To open an
existing model

<model_path>

The given model is opened after start-up.

Example:

"C:\Program Files\Tekla Structures\<version>
\bin\TeklaStructures.exe"
"C:\TeklaStructuresModels\My model"

To open an
existing,
autosaved model

<model_path> /
autosaved

The given autosaved model is opened after start-up.

Example:

"C:\Program Files\Tekla Structures\<version>
\bin
\TeklaStructures.exe""C:\TeklaStructuresMode
ls\My model" /autosaved

To create a new
model without a
model template

/
create:<model_
path>

A new model is created after start-up.

Example:

"C:\Program Files\Tekla Structures\<version>
\bin\TeklaStructures.exe"/
create:"C:\TeklaStructuresModels\My model"

To create a new
model using a
model template

/
create:<model_
path> /
modelTemplate:
<template_name
>

A new model using a model template is created after
start-up.

Example:

"C:\Program Files\Tekla Structures\<version>
\bin\TeklaStructures.exe"/
create:"C:\TeklaStructuresModels\My model" /
modelTemplate:"Cast-in-Place"

To create a new
multi-user model

/
create:<model_
path> /
server:<server
_name>

A new multi-user model is created after start-up.

Example:

"C:\Program Files\Tekla Structures\<version>
\bin\TeklaStructures.exe"/
create:"C:\TeklaStructuresModels\My model" /
server:"my-server:1234"
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Parameter Description
To run a macro
after start-up

-m
<macro_file_pa
th>

The given macro is executed after start-up.

The example below opens Tekla Structures, sets the
environment, role and configuration from the
Bypass.ini file, opens the model, and reads in and
saves the model by using the Example Macro: Model
Sharing Read in and Save from the BIM Publisher tool
that is available in Tekla Warehouse.

"C:\Program Files\Tekla Structures\<version>
\bin\TeklaStructures.exe" -I "C:\ProgramData
\Trimble\Tekla Structures\<version>
\Environments\<environment>\Bypass.ini"
"C:\TeklaStructuresModels\<model>" -m
"C:\ReadInSave2016.cs"

Example of an initialization file
This example shows a customized project initialization file that calls other
initialization files.

MyProject.ini
//The project is based on the default UK settings
call C:\ProgramData\Trimble\Tekla Structures\2019.0\Environments\uk
\env_UK.ini
//..but our company policy requires these changes
call c:\CompanySettings\OurPolicy.ini
//..and the fabricator requires something
call c:\Fabricators\Fabricator1.ini
//..and then we let users to make some changes (color etc.)
call c:\Users\user_%USERNAME%.ini

The project shortcut for this initialization file:

"C:\Program Files\Tekla Structures\<version>\bin\TeklaStructures.exe" -i 
"\\MyServer\MyProject\MyProject.ini" "\\MyServer\MyProject\MyModel\"

Bypass the sign in dialog box
You can bypass the sign in dialog box by creating a start-up shortcut that uses
a customized Bypass.ini file.

1. In a text editor, open an existing Bypass.ini file. 

You can find the Bypass.ini file for each environment in the
%XSDATADIR%\Environments\<your environment> folder.

2. Set the following advanced options in the customized Bypass.ini file: 

• XS_LICENSE_SERVER_HOST: the on-premises license server address. To
use Tekla Structures subscriptions, set the value to https.
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• XS_DEFAULT_LICENSE: the default subscription or license for a user
role.

• XS_DEFAULT_ENVIRONMENT: the environment-specific .ini file, for
example %XSDATADIR%\Environments\uk\env_UK.ini

• XS_DEFAULT_ROLE: the role-specific .ini file, for example
%XSDATADIR%\Environments\uk\role_Engineer.ini

For example:

set XS_LICENSE_SERVER_HOST=https
set XS_DEFAULT_LICENSE=DIAMOND
set XS_DEFAULT_ENVIRONMENT=%XSDATADIR%\Environments\uk\env_UK.ini 
set XS_DEFAULT_ROLE=%XSDATADIR%\Environments\uk\role_Engineer.ini 
3. Save the modified Bypass.ini file.

4. Right-click Tekla Structures <version> shortcut on your desktop, then
select Copy.

5. Paste the shortcut to your desktop.

6. Right-click the new shortcut, then select Properties.

7. In the Target field, enter the path to teklastructures.exe, followed by
the parameter -I (capital i) , then the path to the Bypass.ini file. 

If you have installed Tekla Structures in a path that contains spaces, use
quotation marks (") around each path.

An example of the modified target:

"C:\Program Files\Tekla Structures\2022\bin\TeklaStructures.exe" -I 
"C:\ProgramData\Tekla Structures\2022\Environments\uk\Bypass.ini"
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5 Daily management of Tekla
Structures

These tasks are often needed in the day-to-day management of Tekla
Structures.

• Manage the users in your organization for Tekla Online services (page 352).

• Manage access to Tekla Structures subscriptions (page 353) for users in 
your organization.

• If you have legacy on-premises licenses (page 353), maintain license servers 
and manage licenses for users.

• Install service packs or new Tekla Structures versions to upgrade Tekla 
Structures (page 441).

• Manage printer settings (page 441).

5.1 Management of the organization for Tekla Online
services
Each organization has at least one administrator who is responsible for
managing the Tekla Online organization (group) used in Tekla Online services.

Several people in your company can be Tekla Online organization
administrators. The first user is invited by a Trimble representative, and that
person is then responsible for adding other users and administrators as
necessary.

As a Tekla Online organization administrator, you:

• Invite or approve employees to your company's Tekla Online organization
to allow them unrestricted access in all Tekla Online services.

• Add external license users.

• Select who has access to your company's Tekla Structures subscriptions.
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• Remove people from your company's employee group when they no longer
belong to your company.

For more information, see Manage user accounts for Tekla products.

5.2 Management of Tekla Structures subscriptions
Tekla Structures subscriptions are the default licensing option for Tekla
Structures and the Tekla Model Sharing feature.

As a Tekla Structures administrator, you activate subscriptions for each user's
Trimble Identity, after which the user is able to select a license when they log
in to Tekla Structures. Administrator users can monitor subscription usage and
contract manager users can manage subscription renewals in the Tekla Online
Admin Tool.

After the Tekla Online subscription is set up, you can verify that you have the
correct number of licenses and that the licenses are used correctly.

You can monitor both current subscription users and view statistics about past
usage in the Tekla Online Admin Tool.

If users are selecting incorrect license types or secondary users are reserving
too many licenses, you can ensure that the correct types of licenses are
available to the users who most need them by defining access rights for using
licenses. You can adjust access rights for subscriptions in the Tekla Online
Admin Tool.

For instructions, see Manage Tekla Structures subscriptions.

5.3 Legacy on-premises licensing for Tekla Structures
On-premises licenses are a legacy licensing option for Tekla Structures.

The information on this page is not valid for Tekla subscriptions.

On-premises licenses are licenses that you activate locally on a license server
that you install on your own hardware. Users connect to your local license
server to reserve a license.

Working with on-premises licenses
To get started with legacy on-premises license administration:

1. Make sure that you understand how licensing works, see Tekla Structures
legacy on-premises licensing for administrators (page 354).
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2. Install the license server as explained in Installing Tekla on-premises
license server (page 369).

3. Make sure the license server can connect to Trimble's activation server
and clients can connect to the license server, see Allowing Tekla on-
premises license server to operate through Windows Firewall (page 380).

4. Activate your licenses on the server as explained in Activate on-premises
licenses (page 390).

5. Test that licensing works and connect the clients to the license server as
explained in Preconfigure license server settings for users (page 379).

Additionally, you can ensure that the correct types of on-premises licenses are
available to the users who most need them by defining access rights for using
and borrowing licenses as explained in Modify on-premises license access
rights (tekla.opt) (page 397). This can prevent situations where there are no
licenses available for users that need them because someone else has
reserved or borrowed a license that they do not really need.

When you renew on-premises licenses and when you need to make hardware
changes on the license server, you must deactivate your licenses as explained
in Deactivate on-premises licenses (page 394).

If your on-premises licenses have become untrusted or disabled, they cannot
be used and you need to repair them. For information about how to do this,
see Repair an on-premises license (page 403).

Tekla Structures legacy on-premises licensing for
administrators

The information on this page is not valid for Tekla subscriptions.

Legacy on-premises licenses are an alternative to the default Tekla Structures
subscription. The type of subscription or license is determined when you
purchase a license, so you cannot change between on-premises licenses and
subscriptions yourself. You activate on-premises licenses on a license server
that you install on your own computer hardware. Tekla Structures installations
for one or more users connect to the license server to reserve a license.

Legacy on-premises licensing technology

With legacy on-premises licensing, Tekla Structures uses FlexNet (FlexNet
Publisher License Management) licensing system by Flexera Software. We
provide our own Tekla-specific tools for managing the licenses on top of the
common FlexNet platform, replacing some of the standard tools that you
might have encountered when using other software products that use FlexNet
for licensing.

The license server software is compatible with several versions of Tekla
Structures. To see which license server version to use with your current Tekla
Structures version, see Hardware recommendations for Tekla license server.
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The licenses are also compatible with older versions of Tekla Structures in
addition to the highest allowed version stated in the license. The license is sent
to you attached in an email as an entitlement certificate HTML file.

NOTE Keep backup copies of your license entitlements in a safe place.

Local licensing on your workstation

If there are few users in your organization and you do not need to share the
same licenses between users, you can install a license server directly on each
Tekla Structures workstation. When you activate a license on the local license
server, Tekla Structures always uses that license and you can also start Tekla
Structures offline without borrowing a license. For more information, see
Installation and licensing workflow.

For organizations with many users, it is not optimal to install and manage a
license server on each workstation because of the extra work involved, lack of
visibility and inability to flexibly share licenses between users. In this situation,
it is better to set up a central license server in your internal network.

License server in your local area network (floating licenses)

This illustration shows how licensing works in a typical corporate setup where
licenses are activated on a centrally-managed license server, and a mix of on-
premises licenses and Tekla Structures subscriptions is used.

Main user / IT administrator
License entitlement via email1

4
Tekla Subscriptions

Tekla license server
License administration tool

(FlexNet & LMTOOLS)2
3

4

Tekla Structures users

Tekla Structures
License borrow tool (optional)

1. An administrator (main user or IT administrator) receives entitlement
certificates for new and updated FlexNet licenses as email attachments.
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2. The administrator activates and manages the FlexNet licenses in the Tekla
License Administration Tool on the license server installed at your
organization.

For successful activation, the system must be able to contact Trimble's
license activation service.

3. The administrator adds users to your organization and allows access to
your purchased Tekla Structures subscriptions in the Tekla Online Admin
tool.

Exception: educational users must get their free Tekla Student
subscription themselves at the Tekla Campus site.

4. Tekla Structures installations on the end-users' workstations reserve a
license on the license server or in the cloud when a user starts Tekla
Structures or joins Tekla Model Sharing. When the user stops using Tekla
Structures, the license reservation is revoked.

• You can optionally allow users to borrow licenses for a set period of
time, which allows the user to start Tekla Structures without network
access to the license server. To borrow a license, the user must have
the license borrow tool installed on their workstation.

• Tekla Structures subscriptions cannot be borrowed. Users must have
internet access to start Tekla Structures with a subscription. For more
information about subscriptions, see Manage Tekla subscriptions.

Tekla Structures holds licenses in trusted storage. This means that Tekla
Structures does not support three-server redundancy, where licenses are held
in license files. However, you can have any number of license servers, and use
search paths for defining and finding them.

Using multiple license servers in one company

You might want to spread your license pool on several servers in your
company. You might have offices in many cities, each office with its own
license server, or you might simply want to divide the license pool to minimize
disruption caused by server downtime.
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License entitlement - 20 seats

Office A - 10 licenses

Office B users

Office B - 10 licenses

Office A users Office C users

You do not have to activate all of the licenses on the same license server even
if they are on the same entitlement certificate. For example, you can divide
your total license entitlement on several servers simply by activating one half
of your licenses on one server and the other half of the licenses on another
server. Or, as another example, you can activate some of the licenses on a
common server and the rest locally on each user’s computer. You can easily
change the location of the licenses by deactivating them on one license server
and activating on another so you can adjust the number of licenses to changes
in your user base over time.

In Tekla Structures, you can define two server addresses separated by a
semicolon (;). This way, if there is a maintenance break on one of the servers,
users can obtain the license from the other server.

Daily management of Tekla Structures 357 Legacy on-premises licensing for Tekla Structures



NOTE Defining several license servers can slow down the starting of Tekla
Structures. Therefore, we do not recommend defining more than two
servers.

License server hardware

The Tekla license server does not need high performance hardware. However,
it is important to ensure that the network connection and server hardware are
reliable, and to maintain the server system carefully.

NOTE Deactivate your licenses before you make changes to the hardware
or perform a major operating system upgrade on the license server
computer. Keep copies of your license entitlement certificate(s) in a
safe place in case something goes wrong, so that you can easily and
quickly activate the deactivated licenses on a different system. You can
only activate the same licenses again if they have first been
deactivated on the previous system. If the license server system
becomes permanently inoperable with the licenses still activated,
contact your local Tekla support for assistance.

See Tekla license server hardware recommendations for information about
operating systems and virtual machine platforms.

Configuration features for on-premises licenses

You have fine-grained control over the license use:

• You can control license use based on the license type (enterprise/domestic)
or Tekla Structures configuration.

• You can define minimum and maximum numbers of licenses users/user
groups have available.
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• You can allow or prevent license borrowing from named users/user groups.

The configurations can be done based on host addresses, individual user
names or by user groups. See Modify on-premises license access rights
(tekla.opt) (page 397) for more information.

Checklists for on-premises licensing implementation

There are several prerequisites the administrator needs to take into account
before starting with FlexNet licensing. Take a look at the following listings:

• Checklist of Trimble deliverables needed in on-premises licensing
(page 359)

• Checklist of IT resources needed in on-premises licensing (page 360)

• Checklist for the on-premises license server administrator (page 361)

• Rights needed for administrator tasks in on-premises licensing (page 362)

Additional information sources

In addition to Tekla Structures specific documentation, you can find useful
information about the FlexNet system in the documents provided with the
installation and in Tekla Downloads. The following FlexNet License
Administration Guides by Flexera Software are generic guides that contain,
for example, instructions on how to create user groups and manage access
rights:

• C:\Tekla\License\Server\fnp_LicAdmin.pdf
• C:\Tekla\License\Server\LicenseAdministration.pdf

See also

Distribution and management of on-premises licenses (page 362)

Examples of different on-premises licensing setups (page 364)

Installing Tekla on-premises license server (page 369)

Checklist of Trimble deliverables needed in on-premises licensing

The information on this page is not valid for Tekla subscriptions.

To get started with the Tekla Structures on-premises FlexNet licensing, the
administrator needs to have the following items provided by Trimble:

• Entitlement certificate

Trimble has sent the license entitlement certificate in an e-mail to the
person in your organization who has made the license purchase, or to
someone named as the contact person. The entitlement certificate lists all
the Tekla Structures licenses you are entitled to use and includes the
activation IDs for entitled licenses.

For entitlement requests, contact your local Tekla representative.
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• Tekla license server installation package

The Tekla license server installation package is available on Tekla
Downloads product download service. The installation package contains
the license server files and Tekla License Administration Tool.

• License Administration Guide

This guide by Flexera Software is a general guide that contains, for
example, instructions on how to create user groups and manage access
rights. This guide is provided in the license server installation package and
is installed in the folder where you install the license server in the .pdf
format.

Checklist of IT resources needed in on-premises licensing

The information on this page is not valid for Tekla subscriptions.

In Tekla Structures on-premises licensing, you need to install the licensing
tools on your own hardware, taking into account the following IT resource
related requirements:

• Supported operating system

The FlexNet licensing system for Tekla Structures runs in Windows
operating system. The support for virtual servers is limited. For more
information, see Tekla Structures Hardware recommendations in Tekla
User Assistance.

• Windows user account with administrator rights

Your Windows login user name should not contain any special characters.

You need to have administrator rights to install and manage the license
server. For more information, see Rights needed for administrator tasks in
on-premises licensing (page 362).

• TCP/IP port 27007 for license server

Tekla licensing service (lmgrd) is automatically run in the TCP/IP port
27007. This port should be dedicated for Tekla licensing service only. If
required, you can manually set a different TCP/IP port for the licensing
service, see Modify the license file tekla.lic manually (page 375).

• Local area network

The license server and the client computers need to be in the same local
area network. The clients need to be able to contact the license server. If
there is no local area network in your company, we recommend that you
install the license server on each computer that has Tekla Structures and
activate one license on each computer.

• Internal firewall and direct communication

The internal firewall of your company (for example, Windows Firewall) must
allow the communication between the server computer and the computers
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with Tekla Structures. You must allow the applications tekla.exe and
lmgrd.exe to operate through the firewall. For more information, see
Allowing Tekla on-premises license server to operate through Windows
Firewall (page 380).

Direct communication from the server computer to the Internet needs to
be allowed when the license server at your company contacts the
activation server at Trimble Solutions. The activation communication uses
SOAP over HTTPS on the TCP/IP port 443.

Your firewall should not block any incoming or outgoing information during
the activation. To allow the activation communication, use the activation
server address in your firewall settings:

https://activate.tekla.com:443/flexnet/services/ActivationService?wsdl

If direct communication from the server computer to the Internet is not
allowed, contact your local Tekla Structures support for manual activation.

• System backup settings

If you have an automatic backup and restore system in your company,
configure your system so that it does not overwrite your actual Trusted
Storage with the backup copy. Trusted Storage is the place where the
licensing information is stored on the server computer, and it is located in
C:\ProgramData\FLEXnet depending on the operating system.

Checklist for the on-premises license server administrator

The information on this page is not valid for Tekla subscriptions.

Your company or organization should assign an administrator for the Tekla
Structures on-premises license server. The license server administrator's
primary responsibilities are:

• Install the Tekla license server: Installing Tekla on-premises license server
(page 369)

• If automatic installation is not possible, manually install and configure Tekla
license server: Install Tekla license server - manual installation (page 372),
Configure Tekla license server manually (page 377), Modify the license file
tekla.lic manually (page 375)

• Save the entitlement certificate on the license server computer and activate
licenses on the server to make the licenses available for Tekla Structures
users, or for yourself, if the license server is installed on your own
computer: Activate on-premises licenses (page 390)

• Inform users of the license server name and port number so that they can
connect Tekla Structures to the server: Preconfigure license server settings
for users (page 379)
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• If necessary, modify the firewall settings to allow licensing traffic: Allowing
Tekla on-premises license server to operate through Windows Firewall
(page 380)

• If necessary, modify license access rights in the tekla.opt options file:
Modify on-premises license access rights (tekla.opt) (page 397)

• Export a customized product ID files for license borrowing and deliver them
to offline users: Provide offline users with a customized product ID file
(page 406)

• Inform users of the license policy of the company and monitor license use.

Rights needed for administrator tasks in on-premises licensing

The information on this page is not valid for Tekla subscriptions.

You need to have Windows administrator rights to install and manage the
Tekla Structures on-premises license server. Some applications also need to be
run as administrator separately. This depends on the Windows version you are
using.

• In Windows 7, Windows 8/8.1 and Windows 10, you need to log in as
administrator. In some cases, you need to run applications as
administrator. To do this, go to the folder containing the application, right-
click the application and select Run as administrator from the pop-up
menu.

• In Windows Server you need to log in as administrator. In some cases, you
need to run applications with unrestricted rights. To do this, right-click the
application, select Run as, and clear the Run this program with restricted
access check box.

Distribution and management of on-premises licenses
The information on this page is not valid for Tekla subscriptions.

The Tekla Structures FlexNet licensing system offers several options for
distributing on-premises licenses to users. The way you distribute the licenses
depends on the size of the company or organization, and the amount of Tekla
Structures users.

There are two basic ways of distributing on-premises licenses to users:

• The licenses are available for multiple users on a common license server.

• The licenses are activated on each user’s own computer.

You can also use a combination of license distribution methods. For example,
you can activate one license on a separate computer and activate the rest of
your licenses on a common license server.

Daily management of Tekla Structures 362 Legacy on-premises licensing for Tekla Structures



You can also use subscriptions together with on-premises licenses. Users can
change between the two licensing methods when they start Tekla Structures.
For example, users can use an on-premises license at the office, but change to
a subscription when they are outside the office when they are mostly within
reach of the internet. Using a subscription eliminates the need to borrow
licenses or connect to the office through VPN just to reserve a license.

The following table shows what is typical for managing the licenses that are
activated separately on each computer, and for licenses that are activated on a
common license server.

Licenses are activated on user's
own computer

Licenses are activated on a
common license server

No need for an assigned license
server administrator.

Each user manages the license server
that is installed on the user's own
computer.

Centralized maintaining and
administration of licenses is needed.

A license server administrator
maintains the license server and
manages the license use.

Typically, there are a few Tekla
Structures main users in a company.
The main users are good candidates
for license server administrators,
because they are already familiar with
Tekla Structures. For more
information on the responsibilities of
the license server administrator, see
Checklist for the on-premises license
server administrator (page 361)

No need to manage license access
rights.

Each user activates only the licenses
that are needed.

By default, all license configurations
activated on the server are available
for all Tekla Structures users.
However, centralized access rights
management is possible.

The license server administrator can
give different users access to different
configurations. The license server
administrator needs to modify the
tekla.opt options file to manage
the license access rights. For more
information on managing license
access rights, see Modify on-premises
license access rights (tekla.opt)
(page 397).
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Licenses are activated on user's
own computer

Licenses are activated on a
common license server

Tekla Structures can be used out of
office.

If the user's license is activated on a
computer, license borrowing or a VPN
connection is not needed.

Tekla Structures can be used out of
office.

A user needs to borrow a license from
the common license server or use a
VPN connection to the license server
to use Tekla Structures out of office.

Licenses are used only by one person.

Users have access only to the licenses
that are activated on their own
computer. If a user needs a license
that is activated on another
computer, the user needs to use the
other computer. Another option is to
deactivate licenses on one computer
and activate them on another, which
requires effort.

Licenses are checked out frequently
by several users.

When the licenses are activated on a
common server, they are available for
multiple users. The licenses are
checked out from the license server
only when they are needed. When a
user does not need a license, the user
closes Tekla Structures and the
license becomes available for another
user. Changing from using one license
to another is simple.

 Rules of license usage

Tekla Structures users should accept
common rules or an internal
company policy. The rules should
contain regulations of managing the
licenses, for example, who is allowed
to borrow licenses. Usage of common
rules minimizes the amount of
conflicts in license management.

Examples of different on-premises licensing setups

The information on this page is not valid for Tekla subscriptions.

The purpose of the following examples is to provide guidelines for Tekla
Structures on-premises license management in companies or organizations of
different sizes.

Example 1: One Tekla Structures user, all licenses activated on one
computer

Only one user in the company uses Tekla Structures. The user installs Tekla
Structures and the license server on the same computer.

• Installing the license server is straightforward, and the default license
server settings can be used. The user does not need to modify the license
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server settings, because the user runs the license server and Tekla
Structures on the same computer.

• Because the user installs the license server on a computer, the user does
not need to borrow a license or use a VPN connection to use Tekla
Structures out of office.

Example 2: Three Tekla Structures users, necessary licenses activated
separately on each computer

There are three Tekla Structures users in a company. Because the users use
different Tekla Structures configurations, each user installs a license server
separately on the user's own computer and activates only the needed licenses.

• A license server administrator is not needed, the users maintain their
license servers.

• Because the users install the license servers on their computers, they do
not need to borrow a license or use a VPN connection to use Tekla
Structures out of office.
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Example 3: Ten Tekla Structures users, necessary licenses activated on a
common license server and one user's computer

There are ten Tekla Structures users in a compan

y.
Because the users use different configurations, the company uses a common
license server.

• The company has an internal policy for license use containing regulations
for managing the licenses.

• One of the main users is assigned as the license server administrator. The
administrator installs the license server and informs the other users of the
hostname and port number of the server. The license server administrator
also performs other server maintenance duties.

• One of the users travels a lot and needs Tekla Structures on the journeys. A
license server is installed separately on the user’s computer, so the user
does not need to borrow a license or use a VPN connection for offline use
of Tekla Structures.

• Other users borrow licenses from the license server when they need to use
Tekla Structures offline.
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Example 4: Fifty Tekla Structures users in two offices, necessary licenses
activated on two separate servers

There are fifty Tekla Structures users in two separate offices. Both offices have
their own license servers.

• Both offices have assigned license server administrators. The license server
administrators install the license servers and perform license server
maintenance duties.

• The company has an internal policy for using licenses. The policy contains,
for example, the rules that define who is allowed to borrow licenses.

• Because the amount of Tekla Structures users is large, the license server
administrators create tekla.opt options files for controlling the access
rights for different licenses.

• Only a couple of users need to use Tekla Structures offline. The license
server administrators modify the option files to enable the license
borrowing only for those users who need to borrow licenses.

• If one server fails, the users can connect to the license server at the other
office. If there are licenses available on the license server, the users can use
the licenses.
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Installing Tekla on-premises license server

The Tekla on-premises license server installation package contains license
server files, applications for license management and guides. To install the
license server software, download the license server installation package with
the latest updates from Tekla Downloads product download service.

You have two choices in installation:

• Automatic default installation: Select automatic installation for normal
setup. Automatic installation is recommended.

For detailed installation instructions, see Install Tekla license server -
automatic installation (page 371).
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• Manual installation: Use manual installation if you need to separately
install the license server, modify the license file, configure the license
service, and start the server software. This is needed if you want to use
another TCP/IP port than the one used in the automatic installation, for
example. Use manual installation only if you are an advanced user of
FlexNet or FlexIm licensing.

For detailed installation instructions, see Install Tekla license server -
manual installation (page 372).

Installing an on-premises license server

If you have on-premises licenses, you must install the license server on your
own hardware. If you only use one license of Tekla Structures, you can install
the license server on the same computer as Tekla Structures, making the
license available on this one workstation. In an environment with multiple
licenses and users, you install the license server in your company network,
which allows for more flexible and efficient use of your licenses according to
need.

Before users can start using Tekla Structures with on-premises licenses, you
must:

• Install and set up a license server on a computer.

• Save the entitlement certificate and activate the licenses.

• Connect each client computer with Tekla Structures to the license server
either manually, through a customized installation or by instructing the
users.

Before installing the Tekla on-premises license server:

• Turn off the internal firewall and pause the antivirus protection.

• Ensure that you have access to the Internet. The Internet connection is
needed during the license activation process. An unreliable connection
speed can cause errors.

• If you are using other FlexNet licensing services, stop them before you
install the Tekla license server. When you have completed installing the
Tekla license server, you can restart the other licensing services.

See also

Problems in Tekla license server installation and connecting to the license
server (page 412)

Activate on-premises licenses (page 390)

Allowing Tekla on-premises license server to operate through Windows Firewall
(page 380)
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Which on-premises license server version to use

Check the table below to see which on-premises license server version to use
with your current Tekla Structures version. Also check if you need to upgrade
to a new service pack or progress release.

For information about updating the on-premises license server, see Update
the Tekla on-premises license server.

Tekla Structures
version

License Server 2016
SP1

License Server 2017 or
later

2018 or later  

2017i - all versions  

2017 - all versions

2016i - all versions

2016 SP5/PR5 or later

2016 up to SP4/PR4 Upgrade to 2016
SP5/PR5 or later

21.1 SR7 or later

21.1 up to SR6 Upgrade to 21.1 SR7 or
later

21.1 all PV versions

21.0 or earlier

For instructions on how to install the license server, see Installing Tekla on-
premises license server (page 369).

Install Tekla license server - automatic installation

Before you start license server installation, stop FlexNet licensing services and
other licensing services.

For more information about which license server version to use, see Hardware
recommendations for Tekla license server.

To install the default setup of the Tekla license server to a computer that does
not have a previous version of Tekla license server installed:

1. To download the license server installation package with the latest
updates, go to Tekla Downloads, select the Tekla Structures version, and
click All downloads. On the next page, select License server as the File
type and click Apply filter. Then select the License server.

2. Select the installation language.
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3. Select Automatic as the licensing service installation type to install the
default setup.

4. Select the folder where you want to install the license server and complete
the installation.

Tekla license server is installed.

In automatic license server installation, the license server address is
automatically set to 27007@your_hostname, where 27007 is the port and
your_hostname is the computer name/hostname. 27007@your_hostname is
used as the license server address in every Tekla Structures installation.

When you have installed the license server, you need to do the following:

• Save the entitlement certificate and activate the licenses. For more
information, see Activate on-premises licenses (page 390).

• Connect Tekla Structures to the license server. For more information, see
Preconfigure license server settings for users (page 379).

• You can also change the language of the user interface in Tekla License
Administration Tool by opening the tool and clicking Language.

See also

Install Tekla license server - manual installation (page 372)

Problems in Tekla license server installation and connecting to the license
server (page 412)

Problems in Tekla licensing: Error codes and their descriptions (page 426)

Install Tekla license server - manual installation
Use manual installation if you want to separately install the license server,
modify the license file, configure the license server, and start the license server
software. In manual installation of Tekla license server, you also install two
files: installanchorservice.exe and uninstallanchorservice.exe.
You need these files when you manually install or uninstall FlexNet Licensing
Service.

For example, you need to install the license server manually if the default
TCP/IP port 27007 is already in use by other services or applications, and you
need to define another port in the license file tekla.lic.

Before you start license server installation, stop other FlexNet licensing
services.

To install the license server manually:

1. To download the license server installation package with the latest
updates, go to Tekla Downloads, select the Tekla Structures version, and
click All downloads. On the next page, select License server as the File
type and click Apply filter. Then select the License server.
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2. Select the installation language.

3. Select Manual as the licensing server installation type and complete the
installation.

4. Go to the Start menu or Start screen (depending on your Windows
operating system) and open Command Prompt as administrator.

5. At the command prompt, enter the following commands:

a. cd /d %SYSTEMDRIVE%\Tekla\License\Server
b. installanchorservice.exe 

The licensing server is installed.

6. Modify the license file to include the hostname or IP address of the server,
and the correct TCP/IP port:

a. Open the ..\Tekla\License\Server folder on the server
computer.

b. Open the tekla.lic (license file) file with a text editor.

c. Replace text localhost on the line SERVER localhost ANY with
the hostname (computer name) or IP address of the license server.

d. Enter the TCP/IP port number after text SERVER server_hostname
ANY.

e. Save the changes and close the text editor.

7. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

8. On the Service/License File tab, click Configuration using Services.

9. On the Config Services tab to configure the licensing service:

a. In the Service Name box, enter the name of the service exactly as
follows: Tekla Licensing Service.

b. Click the Browse buttons to locate the lmgrd.exe (license server
manager), tekla.lic and tekla_debug.log files. 
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By default, lmgrd.exe, tekla.lic and tekla_debug.log are
located in the C:\Tekla\License\Server folder.

Note that if you set Path to the debug log file outside the
"C:\ProgramData\..." folder, you get an error message:
"Windows preferred path <SystemDrive>\ProgramData to store
service data is not set." This error message can be ignored.

c. Select the Use Services check box to run the licensing service as a
Windows service.

d. Select the Start Server at Power Up check box to start the licensing
service automatically after Windows startup.

e. Click Save Service to save the settings. 

10. Go to the Start/Stop/Reread tab and click Start Server to start the
license server. 
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11. Go to the Server Status tab and click Perform Status Enquiry. 

In the status list, the line License server status shows the TCP/IP
port and hostname of the license server.

Now you can activate the licenses and connect Tekla Structures to the
license server.

You can also change the language of the user interface in Tekla License
Administration Tool by opening the tool and clicking Language.

See also

Modify the license file tekla.lic manually (page 375)

Activate on-premises licenses (page 390)

Configure Tekla license server manually (page 377)

Problems using LMTOOLS in Tekla licensing (page 421)

Problems in Tekla licensing: Error codes and their descriptions (page 426)

Modify the license file tekla.lic manually

If you selected the Automatic installation option, the license server is set to
your hostname: 27007@server_hostname (port@hostname).

The licensing system automatically searches for an available TCP/IP port and
uses the first available port detected. The Automatic installation sets the port
to 27007.

You need to modify the tekla.lic license file if you:

• Select the Manual license server installation option
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• Want to change the TCP/IP port of the licensing server

• Want to use the IP address of your computer instead of the hostname

To modify the license file tekla.lic manually:

1. Go to the ..\Tekla\License\Server folder on the server computer.

2. Open the tekla.lic file in a text editor.

3. Make the necessary changes: 

• To use hostname or IP address: Replace text on the first line between
words SERVER and ANY with the hostname or IP address of your
license server.

Do not delete texts SERVER and ANY when you enter the hostname or
IP address of the license server.

The following formats are valid:

Hostname:server_hostname
Domain name: server_hostname.mycompany.com
IP address: 10.0.0.12

You can check the hostname of the license server in LMTOOLS on the
System Settings tab. Go to Tekla Licensing --> LMTOOLS through the
Start menu or Start screen, depending on your Windows operating
system.

• To set the TCP/IP port manually: Enter the TCP/IP port number after
text SERVER server_hostname ANY.

The port number can be any free port in the range of 0 - 64000.
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4. Save the changes and close the text editor.

5. Restart the Tekla Licensing Service in LMTOOLS or Windows Services for
the changes to take effect.

See also

Install Tekla license server - manual installation (page 372)

LMTOOLS options and settings used in Tekla licensing (page 435)

Configure Tekla license server manually
If you encounter problems during the Tekla license server installation, the
license server may not start automatically. If this happens, you need to
configure the license server manually using LMTOOLS.

To configure the Tekla license server manually:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system. Start LMTOOLS
with administrators rights.

2. Go to the Service/License File tab and select Configuration using
Services.

3. Go to the Config Services tab and do the following: 

Service Name: Select the licensing service. When working with Tekla
license server, always select Tekla Licensing Service.

Path to the lmgrd.exe: Click Browse and locate lmgrd.exe. This file is by
default located in the C:\Tekla\License\Server folder.

Path to the license exe: Click Browse and locate tekla.lic. This file is
by default located in the C:\Tekla\License\Server folder.

Path to the debug log file: Click Browse and locate tekla_debug.log.

This file is by default located in the C:\Tekla\License\Server folder.

To append the logging entries in the debug log file, start the debug log file
name path with the plus sign (+), like by default for tekla_debug.log. If
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the plus sign is missing, the log file will be rewritten each time the service
is started.

Note that if you set Path to the debug log file outside the
"C:\ProgramData\..." folder, you get an error message: "Windows
preferred path <SystemDrive>\ProgramData to store service data is not
set." This error message can be ignored.

Use Services: Select the check box to run the licensing service as a
Windows service.

Start Server at Power Up: Select the check box to start the licensing
service automatically after Windows startup.

4. Click the Save Service button to save the settings.

5. Go to the Utilities tab and do the following: 

Vendor Name: Enter tekla (all letters lowercase).

Path: Enter the name of the license server.

• If you run the license server and Tekla Structures on the same
computer, enter @localhost. You can also enter the TCP/IP port, for
example, 27007@localhost.

• If you run the license server and Tekla Structures on separate
computers, enter the hostname of the license server, for example,
@server_hostname.

• You can also enter the TCP/IP port of the license server, for example,
27007@server_hostname. You must define the port if you use
another port than the default port.

• You can also enter several license servers. Separate the server names
with a semicolon. For example,
27007@server_hostname;27007@localhost.

6. Click the Override Path button to replace the existing license servers
displayed in the status list on the Server Status tab.

7. Go to the Start/Stop/Reread tab and start the license server by clicking
Start Server. 

The status bar should display a message telling that server start was
successful.

8. Go to the Server Status tab and enquire the license server status by
clicking Perform Status Enquiry.
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The status list displayes the TCP/IP port and hostname of the license server.
The list should indicate that license server is up and vendor daemon tekla is
up. The list also displays all the activated licenses on the server.

See also

Installing Tekla on-premises license server (page 369)

LMTOOLS options and settings used in Tekla licensing (page 435)

Problems in Tekla licensing: Error codes and their descriptions (page 426)

Preconfigure license server settings for users
When the license server is on a separate server in the network, Tekla
Structures connects to the license server to fetch a license. To be able to do
this, the license server address must be defined on each computer. This can
be done by typing in the address when starting the software for the first time
or you can include the address in an intialization file that you distribute as part
of your customized installation. You can also predefine the license,
environment and role with a customized startup shortcut and intialization file.

By default, when Tekla Structures starts for the first time on a computer, the
system asks for the address of your Tekla license server unless Tekla
Structures can find a license server with an active license installed on the same
computer. To avoid this manual process, you can include the Tekla license
server address in your customized configuration. Similarly, you can also select
the license for the user, and if you also preset the environment and role, the
user does not need to make any selections when starting Tekla Structures. To
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set up this for your users, see the instructions in Customize Tekla Structures
for users (page 32).

See also

Modify the license file tekla.lic manually (page 375)

Allowing Tekla on-premises license server to operate
through Windows Firewall
When you set up Tekla on-premises license server in your network, you might
also need to configure the firewall and antivirus settings:

• You must allow the applications tekla.exe and lmgrd.exe to operate
through the firewall on the license servers and on the client computers.

• The internal firewall at your company must allow communication between
the license server computer and the client computers where Tekla
Structures is installed.

• If your Internet connection is restricted, change your firewall settings to
allow outbound traffic on TCP port 443 (the default HTTPS port) to
https://identity.trimble.com for the Tekla On-demand License
Administration Tool and https://activate.tekla.com for the Tekla
License Administration Tool.

• In addition to allowing the exceptions in your firewall software, you might
need to configure exceptions for Windows Firewall. Windows Firewall might
be enabled without you being aware of it because some Windows updates
might automatically turn on Windows Firewall.
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For instructions about how to modify the firewall settings so that Windows
Firewall or firewalls from other vendors on the license server allow licensing
traffic, see:

• Allow exceptions in firewall for lmgrd.exe and tekla.exe (page 381)

• Allow traffic in fixed TCP/IP ports (page 381)

Allow exceptions in firewall for lmgrd.exe and tekla.exe
You need to allow the applications tekla.exe and lmgrd.exe to operate
through the firewall on the license server computer to enable licensing traffic.

To allow exceptions for lmgrd.exe and tekla.exe on the license server
computer:

1. Press the Windows logo key + R on your keyboard to show the Run
dialog box, then type firewall.cpl and press Enter.

2. In the left pane, click Allow a program or feature through Windows
Firewall or Allow an app or feature through Windows Firewall
(depending on the operating system).

3. In Allowed programs or Allowed apps (depending on the operating
system), click Change settings. 

Administrator permission is required. If you're prompted for an
administrator password or confirmation, enter the password or confirm.

4. Click Allow another program or Allow another app (depending on the
operating system).

5. Click Browse to browse for the \Server folder on the computer, select
lmgrd.exe and click Open. 

By default, the path is ...\TeklaStructures\License\Server.

6. Click Add to add lmgrd.exe to the Allowed programs or Allowed apps
and features list (depending on the operating system).

7. Select both Home/Work (Private) or Private (depending on the
operating system) and Public check boxes next to lmgrd.exe.

8. Allow the exceptions also for tekla.exe by repeating the steps 4 – 7.

9. Click OK to confirm the changes.

See also

Allowing Tekla on-premises license server to operate through Windows Firewall
(page 380)
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Allow traffic in fixed TCP/IP ports
You need to modify the firewall settings to allow traffic through fixed TCP/IP
port.

To allow traffic in fixed TCP/IP ports in Windows on the license server
computer:

1. Ensure that no other software or service is using the ports that you are
about to set fixed. 

Use the command line command netstat -anp TCP to find out which
ports are in use.

The numbers in the Local Address column after the colon (:) are the port
numbers that are in use.

2. Browse for tekla.lic, and open it using a text editor. 

By default, the path is ..\Tekla\License\Server.

3. To set a fixed port for lmgrd.exe, enter the TCP/IP port number at the
end of the SERVER row. 

The Automatic installation option sets the port to 27007.

4. Enter the text port=free_port at the end of the VENDOR row, for
example, port=1234. 
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Defining the TCP/IP port number on the VENDOR row may slow down the
restart time of Tekla Licensing Service.

5. Save the changes and close tekla.lic.

6. Update your license server with the changes:

a. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

b. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected. 

c. Go to the Start/Stop/Reread tab and click Stop Server to stop the
license server, and then start the server again by clicking Start
Server.

7. Click the Windows logo key on your keyboard to show the Start menu or
Start screen, depending on the operating system.

8. Type wf.msc and press Enter. The Windows Firewall with Advance
Security MMS snap-in is displayed.
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9. In the navigation tree, select Inbound Rule, and then in the Actions pane,
click New Rule. 

10. On the Rule type panel, select Port and then click Next. 
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11. On the Protocol and Ports panel, select TCP, enter the TCP/IP port
numbers that you set in steps 3 and 4 in Specific local ports, and then
click Next. 
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12. On the Action panel, select Allow the connection, and then click Next.

13. On the Profile panel, select the appropriate profiles, and then click Next. 
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14. On the Name panel, enter the name of the rule, and then click Finish. 
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The rule is created and automatically enabled.
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Tekla Structures

Allow exceptions in firewall for lmgrd.exe and tekla.exe (page 381)

Allowing Tekla on-premises license server to operate through Windows Firewall
(page 380)

Activate on-premises licenses
You need to activate the on-premises licenses on the license server to be able
to use them.

How license activation works

When you activate on-premises licenses, your license server contacts the
activation server at Trimble Solutions, and the license rights are transferred to
the license server in your company network or on your computer. You can
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activate licenses in Tekla License Administration Tool, which is installed
together with the license server.

• Internet access is required in license activation because the license server
at your company needs to contact the activation server at Trimble
Solutions.

• The activation server at Trimble Solutions tracks the activation status of
your licenses. You are not allowed to activate any version of the same
license again without first deactivating it. Deactivate the licenses before
you make any major changes to the computer that runs the Tekla license
server.

• You do not need to activate all the licences at once. You can activate part of
the licenses now and part of the licenses later on some other computer, for
example. Different configurations and different versions need to be
selected for activation separately.

Activate licenses

To activate an on-premises license, you must have the corresponding license
entitlement certificate file EntitlementCertificate.html. The entitlement
certificate is sent in an e-mail to the person in your organization who has
made the license purchase, or to someone they have named as the contact
person. The entitlement certificate states the configurations, quantities and
identifiers of the licenses you are entitled to use.

• We recommend that you save the entitlement certificate file
EntitlementCertificate.html to the ..\Tekla\License\Server
folder. You will need the file again if you later need to move the licenses to
a different computer.

If you have licenses in several entitlement files, rename the files as
necessary to avoid overwriting.

• You can activate licenses using either manual or automatic server
notification. Do not use automatic notification if you are using some other
FlexNet license and license server administration tool, such as FlexNet
Manager. Otherwise, we recommend using automatic notification. You can
find the instructions for both procedures below.

Activate on-premises licenses using automatic server notification
You can activate Tekla Structures on-premises licenses in Tekla License
Administration Tool, which is included in the license server installation. To
activate the license, the license server at your company contacts the activation
server at Trimble Solutions through the internet. Tekla Structures subscriptions
do not need to be activated.

NOTE Do not use automatic notification if you are using some other FlexNet
license and license server administration tool, such as FlexNet
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Manager. To notify the license server about license changes manually,
see Activate on-premises licenses.

To activate the licenses and notify the license server automatically:

1. Go to Tekla Licensing --> Tekla License Administration Tool through
the Start menu or Start screen, depending on your Windows operating
system.

2. Make sure the automatic license server notification is enabled. Check the

status on the  Notify Server button in the toolbar and click the
button if necessary.

3. Click Open and open the EntitlementCertificate.html file that
contains the license. The license information is displayed in the Entitled
Licenses area.

4. Click the Activate cell and select the number of licenses to activate. 

5. Click the Activate button. 

Your license server contacts the license activation server at Trimble
Solutions.

• The activated licenses are displayed in the Activated Licenses area.

• We recommend that you back up the trusted storage (..\ProgramData
\FLEXnet\) in a safe place away from the computer running the license
server. Backups can help you restore your licenses on the same server if
active licenses are accidentally erased.

• When you open Tekla License Administration Tool later on, it detects
expired and broken licenses you may have and asks if you want to
deactivate or repair them. If you select Yes, an automatic deactivation or
repair is run.

Activate on-premises licenses using manual server notification
You have to use manual notification if you are using some other FlexNet
license and license server administration tool, such as FlexNet Manager.

To activate the licenses and notify the server manually:
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1. Go to Tekla Licensing --> Tekla License Administration Tool through
the Start menu or Start screen, depending on your Windows operating
system.

2. Make sure the automatic license server notification is disabled. Check the

status on the  Notify Server button in the toolbar and click the button
if necessary.

3. Click Open and open the EntitlementCertificate.html file that
contains the license. The license information is displayed in the Entitled
Licenses area.

4. Click the Activate cell and select the number of licenses to activate. 

5. Click the Activate button. 

Your license server contacts the license activation server at Trimble
Solutions.

6. Next, you need to notify the server. This has to be done each time you
activate a license.

a. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

b. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

c. In the LMTOOLS dialog box, go to the Start/Stop/Reread tab.

d. Click ReRead License File. 

The license server reads the license information.

• The activated licenses are displayed in the Activated Licenses area.

• We recommend that you back up the trusted storage (..\ProgramData
\FLEXnet\) in a safe place away from the computer running the license
server. Backups can help you restore your licenses on the same server if
active licenses are accidentally erased.

• When you open Tekla License Administration Tool, it detects expired and
broken licenses you may have and asks if you want to repair or deactivate
them. If you select Yes, an automatic deactivation or repair is run.
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See also

Problems in Tekla license activation (page 415)

Problems in Tekla licensing: Error codes and their descriptions (page 426)

Deactivate on-premises licenses
License deactivation releases license rights from a license server, which allows
you to activate a new version of the same license or to activate the same
license on different hardware. There is no deactivation for Tekla Structures
subscriptions.

The activation server at Trimble Solutions tracks the activation status of your
on-premises licenses. You are not allowed to activate any version of the same
license again without first deactivating it.

When you deactivate licenses, your license server contacts the activation
server at Trimble Solutions, and the license rights are transferred away from
your Tekla license server.

When you need to deactivate licenses

• Before you upgrade or reinstall the operating system or before you change
the hardware components of any computer that has a license server
installation with active licenses.

• Before you activate a replacement license, including licenses that entitle
you to run a new version of Tekla Structures and replacement licenses for
any temporary licenses.

• Before you activate the same license on a different license server, for
example, when you want to change from one license server computer to
another.

• Before you change the IP address on the license server computer.

• Before you format the hard drive of or decommission your server
computer.

When you do not need to deactivate licenses

You do not need to deactivate licenses before uninstalling and reinstalling the
Tekla license server software.

Deactivate on-premises licenses
The information on this page is not valid for Tekla subscriptions.

• Internet access is required in license deactivation.
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• Deactivation must be done on the license server containing the active
license. If your license server fails and cannot be recovered, contact your
local support for assistance.

To deactivate licenses:

1. Start the Tekla License Administration Tool app with administrator rights.
This tool is installed together with the Tekla license server and you can
find it through the Windows Start menu on the computer that is hosting
your license server.

2. In the Tekla License Administration Tool dialog box, go to the Statistic
tab and ensure that no one is using the licenses.

NOTE Before you deactivate licenses, ensure that the licenses are not in
use or borrowed. The borrowed licenses must be returned before
they can be deactivated.

3. If you have not activated the automatic server notifications (the Notify
Server option in Tekla License Administration Tool), you need to stop
the license server manually in LMTOOLS:

a. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system. Start
LMTOOLS with administrator rights.

b. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

c. Go to the Start/Stop/Reread tab and click Stop Server.

4. In Tekla License Administration Tool, go to the Licenses tab. 

The Activated Licenses area lists the active licenses.

5. Select the Deactivate check box to select the license for deactivation. 

If you activated more than one license of the same type in one go, you
cannot deactivate those licenses one by one, but you need to deactivate
all of the licenses in one go.

6. The Deactivate button is activated, click it.

The license server contacts the activation server at Trimble Solutions. Internet
access is required at this stage. After a successful deactivation you will see the
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license successfully deactivated message, and the Tekla License
Administration Tool is updated to reflect the deactivation.

See also

Problems in Tekla license deactivation (page 419)

Problems in Tekla licensing: Error codes and their descriptions (page 426)

Maintain legacy on-premises licenses
After on-premises licensing is set up, you can verify that you have the correct
number of licenses and that the licenses are used correctly.

With on-premises licenses, you can monitor who is currently using licenses
(page 396).

You need to make changes in the following situations:

• If users are selecting incorrect license types or secondary users are
reserving too many licenses, you can ensure that the correct types of
licenses are available to the users who most need them by defining access
rights for using licenses.

For adjusting on-premises license usage, see Modify on-premises license
access rights (tekla.opt) (page 397).

• If you have on-premises licenses, you need to deactivate your existing
licenses (page 394):

• When you start using a new version of Tekla Structures, which requires
activating renewed licenses.

• Before you activate a changed version of the same license (for example,
the number of concurrent users is changed).

• Before you make hardware changes that affect the license server.

• If you want to move the licenses to a different license server (page 402).

• If your on-premises licenses become untrusted or disabled, you can repair
them a limited number of times as explained in Repair an on-premises
license (page 403).

Monitor Tekla Structures license use
With on-premises licenses, you can view current license usage using the
LMTOOLS application that is delivered with the Tekla license server.

The LMTOOLS application requires Windows administrator privileges to run.

When you use Tekla Structures subscriptions, you can monitor both current
subscription users and view statistics about past usage in the Tekla Online
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Admin Tool. For more information, see Manage user accounts for Tekla
products.

To view which licenses are currently in use:

1. Go to  Tekla Licensing --> LMTOOLS  through the Start menu or Start
screen, depending on your Windows operating system.

2. If the correct Tekla license server is not defined, switch to the Utilities tab
and add the license server path:

a. Type tekla in the Vendor Name box.

b. Type your license server address as port@host in the Path box.

c. Click Override Path.

3. On the Server Status tab, click Perform Status Enquiry. You will receive
a listing of how many licenses and which configurations are activated on
the server, and how many of the licenses are in use at the moment of
inquiry. 

The status inquiry uses abbreviations of Tekla Structures configurations,
which are explained here (page 399). You can also find the description of
the abbreviations in your entitlement certificate or in Tekla License
Administration Tool.

For a comprehensive description of the status inquiry syntax, see
LMTOOLS options and settings used in Tekla licensing (page 435).

Modify on-premises license access rights (tekla.opt)
The Tekla Structures on-premises license server administrator may grant
different users and user groups different rights to use licenses by modifying
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the tekla.opt options file. This can prevent situations where there are no
licenses available for users that need them because someone else has
reserved or borrowed a license that they do not really need.

The information on this page is not valid for Tekla subscriptions.

The licensing options file tekla.opt is located in the ..\Tekla\License
\Server folder.

The most common configuration options include the following:

• You can define the access rights for specific usernames or hostnames/IP
addresses either individually or using groups that you define. You can use
the same username or hostname in several groups.

• You can reserve a number of licenses for a specific configuration (e.g.,
Steel detailing) for exclusive use by a specific user or user group. If
necessary, the users in the group can reserve more licenses than the
reserved quota. Other users can only use one of the remaining free
licenses outside the reserved quota.

• You can define a maximum (max) number of licenses that a user or group
can simultaneously use. Users who are not included in this limitation can
use any free license.

• You can include (allow) a user or group in the exclusive use of all licenses
for a specific configuration. Other users are prevented from using the
configuration.

• You can exclude (disallow) specific users from using any licenses for a
specific configuration. All other users are allowed to use the configuration.

• You can include and exclude users from borrowing licenses.

To modify access rights in the tekla.opt file:

1. Go to the ..\Tekla\License\Server folder.

2. Open the tekla.opt file in a text editor.

3. Enter your definitions for license access rights and restrictions. 

The definition string consists of the following parts: [keyword] [Tekla
Structures feature] [user type] [name]
When you write the definition, follow the rules below.

• Note that the options file is case sensitive.

• If you need to define user groups and host groups, define them first.

Use Windows user names when defining user groups and hostnames
or IP addresses when defining host groups.

• Enter one definition per row. A definition consists of the following
things:

• An options keyword that defines the actions.
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• A feature, such as a configuration, that is affected by the keyword.

• The type that is affected by the keyword.

The options are: USER, GROUP, HOST, and HOST_GROUP.

• The name of the user, user group, host, or host group that is
affected by the keyword.

You can use the hostnames or IP addresses of the computers with
the HOST and HOST_GROUP keywords.

• To disable a row in the options file, enter # in the beginning of the row.

Examples of definitions:

INCLUDE PCD-C USER scarlett (Only the user scarlett is allowed to
use the Precast Concrete Detailing configuration.)

RESERVE 1 RCD-C USER vera (One license of the Rebar Detailing
configuration is reserved for the user vera.)

For details about the allowed keywords and configuration codes together
with more examples, Configuration codes and keywords used in access
right definitions (page 399).

4. Save the changes and close the text editor.

5. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

6. In LMTOOLS, go to the Start/Stop/Reread tab and click the ReRead
License File button to update the changes in the license file and in the
options file.

Useful links

For more information about limiting certain Tekla Structures versions to
certain users, see the following Support Article in Tekla User Assistance: How
to limit certain Tekla Structures version to certain users

Configuration codes and keywords used in access right definitions
When you define access rights in tekla.opt, you need to use correct
abbreviations (codes) for the configurations, otherwise the definitions do not
work. The access rights are defined using certain keywords.

Configuration codes

When you define access rights for different Tekla Structures configurations in
the tekla.opt options file, you need to add a proper code for each
configuration in the definition.

NOTE The configuration codes are backward compatible, and the codes used
for licensing in older Tekla Structures versions still work. However, the
commercial product name of the configuration may change between
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versions. For example, the commercial product name for STDL-C used
to be Steel Detailing Limited, but now it is Primary.

The codes for the Tekla Structures configurations are listed below:

Configuration code Configuration
CM-C Construction Modeling
DEV-C Developer
DFR-C Drafter
EDU-C Educational
FUD-C Full
PCD-C Precast Concrete Detailing
RCD-C Rebar Detailing
SDE-C Engineering
STD-C Steel Detailing
PPC-C Production Planner for Concrete
STDL-C Primary
VIE-C Project Viewer

Most common keywords

The most common keywords that are used for defining license access rights
and restrictions in the tekla.opt options file are listed and described below:

Keyword Description Usage information
EXCLUDE Prevent access to a Tekla

Structures configuration.
Use with the
abbreviation of the
configuration.

EXCLUDE_ENTITLEMENT Prevent license
borrowing.

Use with the activation
ID of the license.

EXCLUDEALL Prevent access to all
Tekla Structures
configurations.

 

GROUP Define a user group for
use with any options.

Use with Windows user
names (separated with
spaces).

HOST_GROUP Define a host group for
use with any options.

Use with computer
hostnames or IP
addresses (separated
with spaces).

INCLUDE Allow a user to use a
Tekla Structures
configuration.

Use with the
abbreviation of the
configuration.
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Keyword Description Usage information
INCLUDE_ENTITLEMENT Allow a user to borrow a

license.
Use with the activation
ID of the license.

INCLUDEALL Allow a user to use all
Tekla Structures
configurations.

MAX Limit the usage of a
configuration.

Use with the number of
licenses and the
abbreviation of the
configuration.

RESERVE Reserve licenses for a
user/host or a group of
users/hosts.

Use with the number of
licenses and the
abbreviation of the
configuration.

• When somebody is allowed to use a configuration with the INCLUDE
keyword, other users are automatically prevented from using the
configuration.

• When somebody is denied to use a configuration with the EXCLUDE
keyword, other users are automatically allowed to use the configuration.

• If no rules exist, everybody is allowed to use the configuration.

Some examples of definitions in a tekla.opt options file are given below:

Options file definition Description
INCLUDE PCD-C USER
scarlett

Only the user scarlett is allowed to use the
Precast Concrete Detailing configuration.

EXCLUDE FUD-C USER justin The user justin is not allowed to use the
Full configuration. Other users are allowed
to use the Full configuration.

GROUP tsusers jessica joe
neil
INCLUDEALL GROUP tsusers

The users jessica, joe and neil belong to
the group tsusers. Only the group tsusers
is allowed to use all configurations.

EXCLUDEALL HOST pcrobert No configuration is allowed to be used on
the computer pcrobert.

INCLUDE_ENTITLEMENT
qwer-1234-asdf-5678-zx
USER gwen

Only the user gwen is allowed to borrow a
license whose activation ID is qwer-1234-
asdf-5678-zx.

EXCLUDE_ENTITLEMENT
rtyu-9876-fghj-5432-cv
USER matt

The user matt is not allowed to borrow a
license whose activation ID is rtyu-9876-
fghj-5432-cv.
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Options file definition Description
GROUP students amy chloe
andy dean
MAX 3 EDU-C GROUP
students

The users amy, chloe, andy, and dean
belong to the group students. The limit to
the usage of the Educational configuration
for the group students is three licenses.

RESERVE 1 RCD-C USER vera One license of the Rebar Detailing
configuration is reserved for the user vera.

GROUP STUDENTS user1
user2 user3
RESERVE 3 VIE-C GROUP
STUDENTS

The users user1 user2 user3 belong to the
group STUDENTS. 3 licenses of the Project
Viewer configuration are reserved for the
group STUDENTS.

STUDENTS is a group name.

user1 - user 3 are Windows user names
separated with spaces.

The number 3 is the number of licenses to
reserve.

VIE-C is the configuration code for the
Project Viewer configuration.

Note that any licenses reserved for a group
are dedicated to that group. Even when
that group is not actively using the licenses,
the licenses are unavailable to other users.

INCLUDE VIE-
C:VENDOR_STRING=Enterpris
e USER john

Only the user john is allowed to use the
Project Viewer configuration which is of
type Enterprise.

Useful links

For more information about limiting certain Tekla Structures versions to
certain users, see the following Support Article in Tekla User Assistance: How
to limit certain Tekla Structures version to certain users

Move licenses between license servers
You can transfer an on-premises license from one license server to another.
Moving licenses can be necessary, for example, if you are switching to new
hardware or if you want to consolidate licenses from several workstations to a
central server.

The information on this page is not valid for Tekla subscriptions.

1. Deactivate the licenses that you want to move (page 394) in the Tekla
License Administration Tool on the computer that currently contains the
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licenses.

2. If the license entitlement certificate file containing these licenses is not
available on the other computer, find the 
EntitlementCertificate.html file that contains the license and copy
it to the computer on which you want to activate the licenses. 

• Entitlement certificate files are sent over email. In the installation
instructions, we recommend storing the entitlement files in the license
server installation folder (..\Tekla\License\Server\), from where
you can copy it to the same folder on the other computer.

• Rename the files as necessary to avoid overwriting different
entitlement certificate files with each other.

• There can be several licenses in one file, so you can activate different
licenses on different computers using the same entitlement certificate
file.

3. Activate the licenses (page 390) in the Tekla License Administration Tool
on the other computer to complete the move.

We recommend that you back up the trusted storage (..\ProgramData
\FLEXnet\) in a safe place away from the computer running the license
server. Backups can help you restore your licenses on the same server if active
licenses are accidentally erased.

See also

Installing Tekla on-premises license server (page 369)

Repair an on-premises license
If your on-premises licenses have become untrusted or disabled, they cannot
be used and you need to repair them.

The information on this page is not valid for Tekla subscriptions.

The license trust status is indicated in the Activated Licenses area in Tekla
License Administration Tool. If a trust status symbol is green, the information
is trusted, if red, the information is untrusted.

WARNING Because of technical and security reasons, you can repair an
Activation ID only a limited number of times, which at the
moment is two times a year. Therefore it is important that you
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inform your local Tekla Structures representative about the
license repairs you have been performing, and keep count of the
repairs.

The status can be one of the following:

• A red H (Host) indicates that the server has been moved to another
computer, or the computer hardware has changed radically.

The Host trust status of your license is not trusted:

NOTE In some cases, it might not be possible to repair licenses that have
the Host trust status untrusted.

• A red T (Time) indicates that the system clock has been tampered with.

The Time trust status of your license is not trusted:

• A red R (Restore) indicates that the license is obtained from a backup copy.

The Restore trust status of your license is not trusted:

To repair a license:

1. Go to Tekla Licensing --> Tekla License Administration Tool through
the Start menu or Start screen, depending on your Windows operating
system. 

The Activated Licenses area displays the activated licenses.

2. Click Repair. 

The license server contacts the activation server at Trimble Solutions.
After successful repairing the trust status in Tekla License Administration
Tool dialog box is updated.

Set up on-premises license borrowing for offline use
Users who want to work in a location that does not have a reliable connection
to the on-premises license server can borrow an activated license from the
Tekla license server before leaving the office. The user receives a temporary
local license file valid for a set time period.
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The information on this page is not valid for Tekla subscriptions.

Users can borrow Tekla Structures on-premises licenses for offline use in Tekla
License Borrow Tool. Users need to have a network connection to the license
server to borrow and return a license.

Borrowed licenses are reserved for the duration of the borrowing even when
they are not in use, so the borrowed license is not available for other users.

Configuration files

A product ID (.tpi) file is needed for borrowing licenses. If you use the
licensing options file (tekla.opt) for managing license access rights, you
must always provide a customized product ID file for users. The default file
that lists all configurations will technically work in other cases, but
administrators should still provide a customized product ID file. The
customized file makes it easier for the users to select a license, because it
includes just those licenses that you have actually activated on the server. For
more information, see Provide offline users with a customized product ID file
(page 406).

You can define which licenses are available for which users in the licensing
options file (tekla.opt) on the license server. For more information, see
Modify on-premises license access rights (tekla.opt) (page 397).

How on-premises license borrowing works

License borrowing reserves and releases the on-premises licenses like this:

• The maximum license borrow period is one month. The user defines the
borrow expiration date when borrowing the license. The borrowed licenses
are unavailable to other users until they are returned or the license borrow
period ends.

• The user can return a license before the license borrow period is over
through the license borrow tool on the borrowing computer. Make sure
your users return all borrowed licenses before a major operating system
upgrade, reinstallation or major hardware changes on their computer.

• Borrowed licenses must be returned before you deactivate those licenses
on the license server, for example, to upgrade the licenses to a new version
or to move the license server to new hardware. You can see who has
borrowed which licenses by enquiring the license status in the LMTOOLS
(page 435) application on the license server.

NOTE If you do not follow the guidelines above, all users may lose the use of
the borrowed licenses until the end of the license borrowing period,
including the users who originally borrowed the licenses.

1. Install the Tekla License Borrow Tool on the users' computers with
customized product ID file(s).
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2. To borrow a license, users must open the Tekla License Borrow Tool
installed on their computer when they are still online and can connect to
the Tekla license server.

The version of Tekla License Borrow Tool should be the same as the
version of Tekla license server.

3. After borrowing a license, users can go offline and freely work with, close
and reopen Tekla Structures within the license borrow period.

4. When the users are back online, they should return the borrowed licenses
to the license server.

If a user does not return the license, it becomes available for other users
on the license server after the license borrow time is over. However, the
license is still listed in the license borrow tool for the user until the user
returns it.

For detailed instructions, see Set up Tekla License Borrow Tool for Tekla
Structures offline use (page 407).

For end-user instructions, see Borrow a license from on-premises license
server (page 408) and Return a borrowed on-premises license (page 410).

See also

Problems in Tekla license borrowing (page 419)

Problems in Tekla licensing: Error codes and their descriptions (page 426)

Provide offline users with a customized product ID file
Tekla License Borrow Tool for on-premises licenses needs the activation IDs of
the licenses during borrowing. When you export a product ID file (.tpi) in
Tekla License Administration Tool, the activation IDs of the activated licenses
are written in the file. Then you can send the file to offline users.

The information on this page is not valid for Tekla subscriptions.

When you install Tekla License Borrow Tool, the standard.tpi file is
automatically installed in the ..\Tekla\License\Borrow folder. This default
product ID file lists all Tekla Structures configurations and their product IDs.
However, users can only borrow the licenses that are activated on the license
server.

You can create a customized product ID file that only lists the activation IDs of
the activated licenses available for borrowing. You need to export the product
ID file on the license server computer using Tekla License Administration Tool
and save the file on the computers of the users who borrow licenses. The
activation IDs are encrypted.

WARNING Product ID files are not updated automatically. If you deactivate
borrowable licenses or activate new licenses for borrowing, you
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need to export a new product ID file and send it to Tekla
Structures offline users who borrow licenses.

1. Go to Tekla Licensing --> Tekla License Administration Tool through
the Start menu or Start screen, depending on your Windows operating
system.

2. Click Export.

3. In the Save Product ID file As dialog box, enter the name of the product
ID file or keep the default file name, select a folder where you want to
save the file and click Save.

4. In a text editor, open your copy of the product ID file, add the activation
IDs of the activated licenses available for borrowing, then save the file.

5. Send the product ID file to the Tekla Structures users who need to borrow
licenses and inform the users about the usage of the file. 

If the name of the file is standard.tpi and the file is saved in
the ..\Tekla\License\Borrow folder on the user’s computer, the file is
opened automatically when the user starts Tekla License Borrow Tool.

See also

Set up Tekla License Borrow Tool for Tekla Structures offline use (page 407)

Set up Tekla License Borrow Tool for Tekla Structures offline use
You can use Tekla Structures on-premises licenses offline or off-site by
borrowing Tekla licenses with Tekla License Borrow Tool.

The information on this page is not valid for Tekla subscriptions.

Before you start, download and install the latest Tekla License Borrow Tool
from the Tekla Downloads product download page.

You can use the same Tekla License Borrow Tool for borrowing licenses for
different Tekla Structures versions. The version of Tekla License Borrow Tool
should be the same as the version of Tekla license server.

To set up Tekla License Borrow Tool for Tekla Structures offline use:

1. Go to Tekla License Borrow --> Tekla License Borrow Tool through the
Start menu or Start screen, depending on your Windows operating
system.

2. In the Setup dialog box, enter the port number and the hostname
(computer name) of the license server in the Server box in the format 
port@hostname, for example, 27007@server_hostname.

3. Still in the Setup dialog box, click Browse and select the product ID file.

4. Click OK. 
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The Products area in the Tekla License Borrow Tool is updated.

5. In the Tekla License Borrow Tool dialog box, click Language and change
the language of the Tekla License Borrow Tool user interface, if necessary.

NOTE When you start Tekla Structures, and if Tekla Structures does not start with
the borrowed license, enter an asterisk (*) in the server box of the licensing
dialog box. This will force Tekla Structures to search for all possible locations
for the license. This may take a while.

See also

Tekla License Borrow Tool options and settings (page 433)

Problems in Tekla license borrowing (page 419)

Borrow a license from on-premises license server
In Tekla License Borrow Tool, you can borrow Tekla Structures on-premises
licenses from Tekla license server when you want to work offline. Borrow the
license on the same computer that you will use for offline work.

The information on this page is not valid for Tekla subscriptions.

Before you can borrow an on-premises license, you need to install Tekla
License Borrow Tool, connect the computer with Tekla Structures to the license
server and open the product ID file.
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For more information about the prerequisites, see Set up Tekla License Borrow
Tool for Tekla Structures offline use (page 407).

To borrow a license:

1. Close Tekla Structures.

2. Go to Tekla License Borrow --> Tekla License Borrow Tool through the
Start menu or Start screen, depending on your Windows operating
system.

3. Click the Setup button at the top of the dialog box.

4. In the Setup dialog box, enter the port number and the hostname
(computer name) of the license server in the Server box in the format 
port@hostname, for example, 27007@server_hostname. 

You need to use exactly the same port and host name as when starting
Tekla Structures.

5. Still in the Setup dialog box, click Browse and select the product ID file.

6. Click OK.

7. In the Products area, click the Borrow Until box and select the expiration
date for the borrowing period from the calendar. 

The maximum borrowing period is one month. The exact maximum
borrow period varies between 29 to 32 days depending on the borrowing
date.

8. Click the Borrow button to borrow the license. 

The borrowing progress is displayed in the Borrowing License(s) dialog
box. After successful borrowing, the Borrowed Licenses area shows the
borrowed license.

9. To ensure that the borrowing succeeded, disconnect your computer from
the license server and start Tekla Structures with the borrowed license.

See also

Problems in Tekla license borrowing (page 419)

Problems in Tekla licensing: Error codes and their descriptions (page 426)

Daily management of Tekla Structures 409 Legacy on-premises licensing for Tekla Structures



View and diagnose errors in Tekla Structures license activation, deactivation
and borrowing (page 411)

Set up on-premises license borrowing for offline use (page 404)

Return a borrowed on-premises license
You can return a borrowed Tekla Structures on-premises license back to the
Tekla license server before the expiration date.

The information on this page is not valid for Tekla subscriptions.

A borrowed license is automatically available on the license server on the day
following the expiration date.

However, the Borrowed Licenses area in Tekla License Borrow Tool is not
automatically updated. The license should be returned to the server that has
the same name as the name of the server from which the license was
borrowed. We recommend that you always return the expired licenses when
you want to stop borrowing a license.

To return a borrowed Tekla license:

1. Ensure that you are connected to the license server.

2. Close Tekla Structures.

3. Go to Tekla License Borrow --> Tekla License Borrow Tool through the
Start menu or Start screen, depending on your Windows operating
system.

4. Select the Return check box in the Borrowed Licenses area to select the
license for returning.

5. Click the Return button to return the license. 

After successful returning of licenses, the Borrowed Licenses area is
updated.

See also

Problems in Tekla licensing: Error codes and their descriptions (page 426)

Troubleshoot Tekla Structures legacy on-premises licensing
Click the links below for help in solving problems encountered in the following
areas:

• View and diagnose errors in Tekla Structures license activation, deactivation
and borrowing (page 411)

• Problems in Tekla license server installation and connecting to the license
server (page 412)

• Problems in FlexNet (page 414)
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• Problems in Tekla license activation (page 415)

• Problems in Tekla license deactivation (page 419)

• Problems in Tekla license borrowing (page 419)

• Problems in Tekla license trusted storage (page 420)

• Problems using LMTOOLS in Tekla licensing (page 421)

• Problems in starting Tekla Structures (page 423)

• Problems with options file tekla.opt (page 425)

For more information about error messages starting with an error code, see
Problems in Tekla licensing: Error codes and their descriptions (page 426).

View and diagnose errors in Tekla Structures license activation,
deactivation and borrowing
Tekla License Administration Tool and Tekla License Borrow Tool both give
error messages when errors occur. The tools automatically create packages of
all necessary files required for diagnosing the errors.

If you have a problem with activating or deactivating licenses, or borrowing or
returning licenses, Tekla License Administration Tool and Tekla License Borrow
Tool display an error message in the Activating Licenses(s), Deactivating
License(s), Borrowing License(s) or Returning Borrowed License(s) dialog
boxes, depending on the subject of the error.

• You can view more detailed information about an error by clicking the View
button in an error dialog box.

• Tekla License Administration Tool and Tekla License Borrow Tool
automatically create zip packages of all necessary files required for
diagnosing the errors in the C:\Tekla\License\Server\Reports folder
and in the %TEMP%\Tekla License Borrow Tool\Reports folder. Click
Browse in the error dialog box to browse for the folder containing the
error report package. You can send the package to your local support to get
help.

The error report package contains the following files:

tekla_debug.log - Tekla license server debug log file

error.txt - error report, contains error information. The Tekla License
Borrow Tool zip package only contains this file.

tekla.opt - access rights options file

tekla.lic - Tekla license file

See also

Troubleshoot Tekla Structures legacy on-premises licensing (page 410)

Problems in Tekla licensing: Error codes and their descriptions (page 426)
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Problems in Tekla license server installation and connecting to the
license server

License server installation fails, and the following message is displayed:
"A newer version of this application is already installed on this computer.
If you wish to install this version, please uninstall the newer version first.
Click OK to exit the wizard."

Reason: You have a newer version the license server installed.

Solution: You should not install an old version of the license server. Check the
latest available license server release on the Tekla Downloads product
download page.

The license server version is not dependent on Tekla Structures. However, if
you need to use an older version of the license server for some reason,
uninstall the newer version on your computer before installing the older
version.

License server installation does not finish (no error message)

Reason: Another software using the FlexNet licensing system is running on the
computer.

Solution: Stop all licensing services in LMTOOLS, then install the Tekla license
server and restart the licensing services you stopped earlier:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services is selected, select a license service from the services list, go to
the Start/Stop/Reread tab and click Stop Server.

Do the same for all the services you need to stop.

3. Install the Tekla license server.

4. In LMTOOLS, start the licensing services you stopped earlier.

Problem in license server connection. The following message is displayed:
"Error when connecting to the license server. Contact your system
administrator or try another server".

Reason: This problem is often related to firewall settings.

Solution: Check that your firewall allows the client to contact the license
server.
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License library initialization failed with error: The licensing service is not
installed.

Reason: The error occurs when you are starting Tekla License Administration
Tool, or when you are trying to run serveractutil.exe command line tool.

Solution: If you selected the Manual option for Tekla Licensing Service
installation then you need to manually install FLEXnet licensing service:

1. If you have some other FlexNet licensing service running on the server,
stop it before entering the commands.

2. Go to the Start menu or Start screen, depending on your Windows
operating system, and open Command Prompt as an administrator.

3. At the command prompt, type the following commands:

cd /D full_path_to_installation_directory
For example, if you install Tekla license server to the default folder, you
need to enter cd /D C:\Tekla\License\Server.

installanchorservice.exe

Cannot connect to the license server.

Solution: For the first time that you connect to the Tekla license server a client
computer that has a new version of Tekla Structures installed, you need to do
the following:

• Ensure that both (the client computer and the license server) are in the
same domain.

• Ensure that Local Area Network connection is established. The license
server and the client computers need to be in the same Local Area
Network.

• Turn off the firewall and pause the antispyware/antivirus protection of your
computer.

After the steps above do the following on your company's license server:

1. Make sure that no one is using Tekla Structures (ask all users to close
Tekla Structures).

2. Go to C:\Tekla\License\Server and open the tekla.lic file in a text
editor.

3. Add a free TCP/IP port for the licensing service at the end of the first row,
if it does not exist by default. Note that the automatic installation option
sets the port by default to 27007.

Example of the first row: SERVER MYSERVER ANY 27007, where
MYSERVER is the license server and 27007 is the port.
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4. Save and close the file after changes.

5. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

6. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

7. On the Start/Stop/Reread tab, click Stop Server. Wait couple of seconds
and click on Start Server.

After defining the server and the port, do the following on your Tekla
Structures workstations:

1. Start Tekla Structures.

2. When you are asked for a server, add the port to the front of the server
definition and click OK.

Example: 27007@MYSERVER

Cannot start the Tekla licensing service.

Reason: The tekla-debug.log file may be locked, thus preventing the
service from starting.

Solution: Delete the tekla-debug.log and restart the computer.

See also

Problems in Tekla licensing: Error codes and their descriptions (page 426)

Installing Tekla on-premises license server (page 369)

LMTOOLS options and settings used in Tekla licensing (page 435)

Allowing Tekla on-premises license server to operate through Windows Firewall
(page 380)

Problems in FlexNet

An internal error occurred. FlexNet internal error.

Reason: There is a problem with the Tekla license server installation.

Solution: This error can often be fixed by performing the steps below:

1. Uninstall all existing Tekla license server installations.

2. Check that all the files are deleted from the Tekla license server
installation folder: .. \Tekla\License\Server.

3. Install the latest Tekla license server. Check for the latest version in Tekla
Downloads.
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See also

Installing Tekla on-premises license server (page 369)

Problems in Tekla licensing: Error codes and their descriptions (page 426)

Problems in Tekla license activation

The following message is displayed: "Error reading entitlement file".

Reason: The .NET Framework is not working for some reason.

Solution: Reinstall the existing .NET Framework, or install the latest .NET
Framework version that is available for your operating system.

License activation fails, and the following message is displayed: "Unable
to activate more licenses than you are entitled to".

Reason: There are a couple of possible reasons for the problem:

• You may have activated licenses on another computer. You cannot activate
more licenses than you are entitled to.

• You tried to activate a renewed temporary license or a permanent license
without deactivating the previous temporary license.

Solution: There are two possible solutions:

• Deactivate a license on another computer and then activate the license on
your computer.

• Deactivate the existing temporary license and then activate the succeeding
linked license.

For more information about deactivating licenses, see Deactivate on-premises
licenses (page 394).

The amount of activated licenses in Tekla License Administration Tool
and LMTOOLS does not match.
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Reason: The licensing service is not updated with new license information.

Solution 1: Reread the license file in LMTOOLS:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Start/Stop/Reread tab, click ReRead License File.

Solution 2: If you are connected to several license servers, rereading the
license file may not work. In that case, you need to stop the license server and
then restart it in LMTOOLS:

1. Ensure that no one is using Tekla license server.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

3. On the Start/Stop/Reread tab in LMTOOLS, select the Force Server
Shutdown check box and click Stop Server.

4. Check that the status is "Stopping server". Wait for a few minutes.

5. Click Start Server, and ensure that "Server Start Successful" is displayed.
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TIP To avoid the problem in the future, ensure that the license server is
automatically notified when you activate, deactivate, or repair licenses.

To enable the automatic notification functionality in Tekla License
Administration Tool, click the Notify Server button.

For more information about starting and stopping server and rereading
the license file, see LMTOOLS options and settings used in Tekla licensing
(page 435).

For more information about activating licenses, see Activate on-premises
licenses (page 390).

No warning is displayed, even though the temporary license will expire
within one month.

Reason: The expiry warning message appears only when someone uses the
expiring license. Probably there are several permanent licenses (that have
been activated first) and some temporary licenses that have been activated
after the permanent ones.

When somebody starts Tekla Structures, the system uses licenses in the order
of activation. For example, if you have 10 permanent and 2 temporary
licenses, all 10 licenses must be in use before someone obtains the temporary
license, and receives the warning about the expiring license.

When you try to open the entitlement certificate in Tekla License
Administration Tool, nothing is shown.

Reason 1: You have not downloaded the attached entitlement certificate from
your e-mail application, but opened the certificate in an Internet browser and
saved it as an .html file from the browser.

Solution: Open the e-mail containing the entitlement certificate attachment
EntitlementCertificate.html. Download the entitlement certificate to
the ..\Tekla\License\Server folder from e-mail. Then try to open it again
in Tekla License Administration Tool by clicking Open.

For more information, see Activate on-premises licenses (page 390).

Reason 2: The virus protection system of your computer has removed the
Trimble Solutions logo from the license entitlement certificate.

Solution: The sender of the entitlement certificate should zip the entitlement
certificate file. Unzip the entitlement certificate file on the computer where the
licenses are going to be activated.

License was activated successfully, but the following error message is
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displayed when you run the command line command ”serveractutil -
view”: "Activation library initialization failed."

Reason: The license server installation was not successful.

Solution: Do the following:

1. Stop other FlexNet licensing services in LMTOOLS.

2. Run the installanchorservice.exe at the command prompt, restart
the license server.

After doing this you will be able to activate your licenses and use Tekla
Structures.

If the above did not work, you need to uninstall the license server and reinstall
the recent version once again with administrator rights.

For more information about uninstalling and installing the license server, see
and Installing Tekla on-premises license server (page 369).

The automatic notification functionality in Tekla License Administration
Tool does not work: nothing happens when you click the Notify Server
button

Reason: One of the reasons why the Notify Server button does not work in
Tekla License Administration Tool might be that Tekla Licensing Service is not
started on the computer.

Solution: To solve the issue, open Windows Control Panel --> Administrative
Tools --> Services . Ensure that the Tekla Licensing Service status is Running .
The Startup Type of the service should be set either to Automatic or to
Automatic (Delayed Start).

Your licenses no longer appear as activated licenses, or old version
licenses are activated, but they do not work.

Reason: Windows system restore may cause problems for licensing. For more
information, see Windows system restore might affect your model and
licensing.

Useful links

For more information about the status of the activated licenses in the trusted
storage, see instructions in the following Support Articles in Tekla User
Assistance:

Checking the status of the activated licenses in the trusted storage

Checking the status of the activated licenses in the trusted storage (including
borrowing info)
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See also

Problems in Tekla licensing: Error codes and their descriptions (page 426)

Problems in Tekla license deactivation

Unable to select a license for deactivation.

Reason: You cannot select a license for deactivation if the license is still
borrowed.

Solution: Return the license and then deactivate the license.

See also

Problems in Tekla licensing: Error codes and their descriptions (page 426)

Deactivate on-premises licenses (page 394)

Problems in Tekla license borrowing

Unable to select a date from the calendar in the Borrow Until box.

Reason: The maximum borrowing period is one month.

Solution: In Tekla License Borrow Tool, select a date that is within one month
from the date of borrowing:

1. Go to Tekla License Borrow --> Tekla License Borrow Tool through the
Start menu or Start screen, depending on your Windows operating
system.

2. In the Products area, click the Borrow Until box and select from the
calendar the expiration date that is within one month from the date of
borrowing.

Tekla Structures does not start up with the borrowed license.

Problem: You borrowed a license and disconnected from the network. When
you open Tekla Structures, the licensing dialog box is displayed, but Tekla
Structures does not find the borrowed license.
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Solution: If Tekla Structures does not start up with the borrowed license,
please type only an asterisk character (*) into the server box in the licensing
dialog box.

This will force Tekla Structures to search for all possible locations for the
license. It might take some time until it finds the license.

The computer that is running a borrowed license crashed, what should I
do?

Solution: If your computer only needs rebooting, you can use the borrowed
license again after rebooting. If your computer completely breaks down, the
license will automatically be available on the license server when the
borrowing period expires.

See also

Problems in Tekla licensing: Error codes and their descriptions (page 426)

Set up on-premises license borrowing for offline use (page 404)

Problems in Tekla license trusted storage

A license cannot be used.

Reason: The Host (H) trust status of your license is not trusted. Hardware
setup of your server computer has changed radically.

Solution: The licenses with the untrusted H trust status cannot be repaired.
Contact your local support.

We recommend that you run your license server on a proper server computer
that is regularly maintained. You need to deactivate your licenses before
performing any maintenance actions on your server computer. However,
unnecessary deactivations should be avoided due to technical and security
reasons.

For more information, see Repair an on-premises license (page 403).

A license cannot be used.

Reason: The Time (T) trust status of your license is not trusted. Time settings
of your server computer have changed radically.
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Solution: You need to set the correct system date and time and after that
repair the license in Tekla License Administration Tool.

Do not manipulate system clock settings of the server computer that has
activated licenses.

For more information, see Repair an on-premises license (page 403).

A license cannot be used.

Reason: The Restore (R) trust status of your license is not trusted. Your
backup system may have overwritten some licensing information.

Solution: You need to repair the license in Tekla License Administration Tool.

We recommend that you configure your system backup settings so that the
existing licensing software, tools and files are not automatically overwritten or
replaced with the restored ones.

For more information, see Repair an on-premises license (page 403).

See also

Problems in Tekla licensing: Error codes and their descriptions (page 426)

Repair an on-premises license (page 403)

Problems using LMTOOLS in Tekla licensing

LMTOOLS does not reread the license file.

Reason: Rereading the license file does not work if you are running a licensing
service locally on your computer and you are connected to another license
server at the same time.

Solution: You need to stop and restart the licensing service. Do the following:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

3. On the Start/Stop/Reread tab, click Stop Server and wait a few seconds
for the service to stop.

4. Click Start Server.
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LMTOOLS is unable to stop the license server, and the message "Unable
to Stop Server" is displayed in the LMTOOLS message bar.

Reason: You may have selected an incorrect licensing service.

Solution: You need to select Tekla Licensing Service as the licensing service.
Do the following:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

3. Go to the Start/Stop/Reread tab, and click Stop Server.

4. If this does not help, select the Force Server Shutdown check box and
click Stop Server again.

LMTOOLS is unable to stop the license server.

Reason: You did not run LMTOOLS with administrator rights.

Solution: Run LMTOOLS with administrator rights. For more information, see
Rights needed for administrator tasks in on-premises licensing (page 362).

Starting or stopping the server or rereading the license file cannot be
performed, and the message "No Server Selected" is displayed.

Reason: You have not selected the licensing service.

Solution: You need to select Tekla Licensing Service as the licensing service.
Do the following:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

3. Go to the Start/Stop/Reread tab and start or stop the server or reread
the license file.

Starting or stopping the server or rereading the license file is not
possible.

The status list in LMTOOLS indicates that the license server manager (lmgrd)
has not been started: "Error getting status: Cannot connect to license server
system. The license server manager (lmgrd) has not been started yet, the
wrong port@hostname or license file is being used, or the port or hostname in
the license file has been changed".

Daily management of Tekla Structures 422 Legacy on-premises licensing for Tekla Structures



Reason: LMTOOLS points to the wrong lmgrd.exe.

Solution: You need to modify the settings in LMTOOLS. Do the following:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

3. Go to the Config Services tab, and click Browse to locate the lmgrd.exe
file.

By default, the file is installed in the ..\Tekla\License\Server folder.

4. Click Save Service.

5. Go to the Start/Stop/Reread tab and click Stop Server.

6. Click Start Server to restart the server.

The changes are applied.

LMTOOLS does not show the licensing service status.

The status list on the Server status tab in LMTOOLS indicates that the license
file cannot be found: "Error getting status: Cannot find license file. The license
files (or license server system network addresses) attempted are listed below.
Use LM_LICENSE_FILE to use a different license file, or contact your software
provider for a license file".

Reason: You are trying to perform a status enquiry of a licensing service that is
not running.

Solution: You need to start Tekla Licensing Service. Do the following:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

3. Go to the Start/Stop/Reread tab and click Start Server.

4. Go to the Server Status tab and click Perform Status Enquiry again.

See also

LMTOOLS options and settings used in Tekla licensing (page 435)

Install Tekla license server - manual installation (page 372)

Configure Tekla license server manually (page 377)

Problems in Tekla licensing: Error codes and their descriptions (page 426)
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Problems in starting Tekla Structures

Tekla Structures does not start. The following message is displayed:
"Error when connecting to the license server. Contact your system
administrator or try another server".

Reason: You are not connected to the license server.

Solution: Check the following:

• Check that your network connection is working.

• Check that you have entered the license server name correctly.

For more information, see Preconfigure license server settings for users
(page 379).

• Check that license information in LMTOOLS is correct. If not, reread the
license file in LMTOOLS and try to start Tekla Structures again.

For more information about LMTOOLS, see LMTOOLS options and settings
used in Tekla licensing (page 435).

Tekla Structures does not start. The following message is displayed:
"License server system does not support this feature".

Reason: Your license server may not be up to date.

Solution: Update the status of your license server. Do the following:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system. Start LMTOOLS
using administrator rights.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

3. On the Start/Stop/Reread tab, click Stop Server and wait a couple of
seconds.

4. Click Start Server.

5. Start Tekla Structures.

If the problem still persists, contact your local Tekla Structures support. The
support will need a copy of the following files: tekla.lic, tekla.opt, and
tekla_debug.log files.

Tekla Structures does not start occasionally.

The following message is displayed: "Cannot connect to license server system.
The license server manager (lmgrd) has not been started, the wrong
port@host or license file is being used, or the port and hostname in the license
file has been changed".
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Reason: There may be communication problems between your license server
and Tekla Structures client computers if the port of the license server is not
defined.

Solution: Define the port for the license server. Do the following:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

3. On the license server computer, define a free port for the license server in
the tekla.lic file. For more information, see Modify the license file
tekla.lic manually (page 375).

4. Go to the Start/Stop/Reread tab and stop the license server by clicking
Stop Server.

5. Click Start Server.

6. Start Tekla Structures on a client computer.

7. In Tekla Structures, click Tools --> Change License Server . Define the
port and hostname of the license server.

8. Close Tekla Structures.

9. Repeat steps 5 to 7 on all Tekla Structures client computers.

See also

Preconfigure license server settings for users (page 379)

Problems in Tekla licensing: Error codes and their descriptions (page 426)

Problems with options file tekla.opt

The tekla.opt file does not take effect.

Reason: The licensing service has not read the options file.

Solution: Do the following:

1. Go to Tekla Licensing --> LMTOOLS through the Start menu or Start
screen, depending on your Windows operating system.

2. On the Service/License File tab, ensure that Configuration using
services and Tekla Licensing Service are selected.

3. On the Start/Stop/Reread tab, click ReRead License File.

4. Browse to the ..\Tekla\License\Server folder and open the
tekla_debug.log file and the tekla.opt file with a text editor.
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5. Check that the tekla_debug.log file contains the same keyword strings
as the tekla.opt file.

If this does not help, please contact your local support.

See also

Modify on-premises license access rights (tekla.opt) (page 397)

Problems in Tekla licensing: Error codes and their descriptions (page 426)

Problems in Tekla licensing: Error codes and their descriptions

Error 6

Problem: License library initialization failed with error: Activation Library
Initialization error #6. Please, contact software vendor to resolve the
problem.

Reason: Tekla license server installation folder contains .dll files that are
from the previous Tekla license server version.

Solution: To resolve the problem, do the following:

1. Close Tekla License Administration Tool and stop the Tekla license server
in LMTOOLS by clicking Stop Server on the Start/Stop/Reread tab.

2. Uninstall all existing Tekla license server installations.
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3. If the Tekla license server installation folder contains any .dll files,
remove the files manually.

4. Now you can install Tekla license server to the same folder where the
uninstalled version was.

For more information about license server installation, see Installing Tekla on-
premises license server (page 369).

NOTE Deactivation is not needed in this case. Licenses are kept safe in a
specific Flexera Software location outside Tekla license server
installation directory.

Error 20

Problem: Error 20: The licensing service is not installed.

Reason: The error occurs when you are starting Tekla License Administration
Tool, or when you are trying to run serveractutil.exe command line tool.

Solution: If you selected the Manual option for Tekla Licensing Service
installation then you need to manually install FLEXnet licensing service:

1. If you have some other FlexNet licensing service running on the server,
stop it before entering the commands.

2. Go to the Start menu or Start screen, depending on your Windows
operating system, and open Command Prompt as an administrator.

3. At the command prompt, type the following commands:

cd /D full_path_to_installation_directory
For example, if you install Tekla license server to the default folder, you
need to enter cd /D C:\Tekla\License\Server.

installanchorservice.exe

Error 109

Problem: There are no activated licenses to return. Another program may
have modified the activated licenses rights concurrently. (109) Unable to
return as there is no licenses in Trusted Storage.

Reason: The trusted storage has been modified, probably by some other
program.

 The red Restore (R) trust status of your license is not trusted. The
license is broken, therefore it cannot be returned.

Solution: The license will become available on the server machine
automatically when the borrow period ends.
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Error 123 or error 50030

Problem: Message 1: Row n: An error occurred but FLEXnet Licensing did
not return an error number. (123)

Message 2: Failed to load trusted storage or specified ASR. (50030)

Reason: These error messages indicate that the trusted storage cannot be
loaded, and your trusted storage is corrupted.

Solution: Your licenses need to be replaced. Contact your local Tekla
representative for a replacement along with some instructions.

Error 1316

Problem: License server installation fails.

The following message is displayed: "A network error occurred while
attempting to read from the file C:\Documents and Settings\<user>
\Local Settings\Application Data\Downloaded Installations
\...\Tekla Structures License Server v1.01.msi".

Reason: You have an older version of the license server installed.

Solution: Uninstall the old version and then install the new version of the
license server.

For more information about uninstalling the server, see Uninstall Tekla
Structures.

Error 7109

Problem: License activation fails.

Reason 1: The emergency licenses are outdated.

Solution: Use a valid emergency license.

Reason 2: You tried to activate an entitlement for a Tekla Structures
subscription using the Tekla License Administration Tool.

Solution: Activate the Tekla Structures subscription using the Tekla Online
Admin Tool.

For more information, see Manage Tekla Structures subscriptions.

Error 7174

License activation fails, and the following message is displayed:
"Unspecified FLEXnet Error with code 7174 Only deployed entitlement
line item can be fulfilled."

Reason: You are trying to activate an obsolete license.

Solution: You should have received a new entitlement certificate from your
local Tekla representative. Try the activation again with the new entitlement
certificate, and move the old obsolete entitlement certificate in an archive
folder.

For more information, see Activate on-premises licenses (page 390).
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Error 7284

Problem: Unspecified FLEXnet Error with code 7284. Cannot perform
support actions on inactive fulfillment record
FID_xxxxxxxx_xxxxxxxxxxx__xxxx.

Reason: Trusted Storage has been restored from an old backup copy. The
license with fulfillment ID FID_ xxxxxxxx_xxxxxxxxxxx__xxxx has been
deactivated already.

Solution: You need to restore trusted storage files from the most recent
backup copy and then repair licenses if needed.

For more information about repairing licenses, see Repair an on-premises
license (page 403).

Error 7288 and error 111

Message 1: The activation of the fulfillment is denied by the activation
policy because fulfill count exceeded the available seat count.

Message 2: The activation of the fulfillment is denied by the activation
policy because number of copies left is zero.

Reason 1: You may be trying to activate some licenses that have been
activated before on another server/computer.

Solution: Deactivate the licenses from the other computer, and then activate
the licenses on the new server/computer.

Reason 2: You may be trying to activate a renewed temporary license or
permanent licenses without deactivating the previous linked activated licenses.

Solution: Deactivate the existing temporary licenses first and then activate the
succeeding linked licenses.

For more information about deactivating licenses, see Deactivate on-premises
licenses (page 394).

Error 7343

Problem: Unspecified FLEXnet Error with code 7343 Entitlement line item
has expired on <date> <time>.

Reason: License has expired. It is not possible to activate or repair expired
licenses.

Error 7466

Problem: License deactivation fails, and the following message is
displayed: "The return of the fulfillment is denied by the return policy
because max return exceeded".

Reason: You have deactivated the license too many times in a 30 days period.

Solution: You can deactivate the license again when 30 days have passed
since the first deactivation of the license in the past 30 days. The number of
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deactivations of a license within a given time period is limited due to technical
and security reasons.

Error 7581

Problem: Unspecified FLEXnet Error with code 7581. Online Return/Repair
Request for the activationId XXXX-XXXX-XXXX-XXXX-XXXX-XX is not
originated from the original client machine.

Reason and solution: The computer is not the same where the licenses were
originally activated, and you need to return/repair licenses from the original
computer. Another reason might be that the computer has changed so much
that activation server at Trimble Solutions no longer recognizes it as the same
one, in which case you need to replace your licenses.

For more information about returning and repairing licenses, see Returning a
borrowed license (page 410) and Repair an on-premises license (page 403).

Error 9999

Problem 1: Cannot connect to the license server at Trimble Solutions

Reason 1: Licensing server at Trimble Solutions is down.

Solution: Wait for a while and retry.

Problem 2: Difficulties when trying to activate the license

Reason 2: The problem is related to long activation ID chains, which are typical
for old licenses ordered for a long time ago for the first time. Typically, the
license has been renewed for years without the need of a replacement of the
license. Activation IDs may have been linked for a long time, which might
cause a timeout when trying to activate the newest version of the license.

Solution: Your licenses need to be replaced. Contact your local Tekla
representative for a replacement along with some instructions.

Error 50005

Problem: Error (5005) License Activation failed - Initialization of API
Failed.

The activated licenses are not visible and it is not possible to activate new
licenses.

Reason: The installation package has failed to initialize or register some of the
software components.

Solution: Do the following:

1. Log in with administrator's rights.

2. Close Tekla License Administration Tool.

3. Stop Tekla license server and other license servers on the same computer
on the LMTOOLS --> Start/Stop/Reread tab.

4. Go to ..\Tekla\License\Server folder.
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5. Double-click installanchorservice.exe.

6. Start Tekla license server and other license servers on the same computer
on the LMTOOLS --> Start/Stop/Reread tab.

7. Open Tekla License Administration Tool. The message should not be
displayed anymore.

Error 50018

Problem: License borrowing fails.

Reason: Wrong product ID file is used.

Solution: Do one of the following:

• Export a product ID file in Tekla License Administration Tool and use the file
for borrowing.

Error 50033

Problem: License borrowing fails.

Reason 1: Your license server may not have up-to-date license information.

Solution: In LMTOOLS, stop and then restart the server.

Reason 2: The INCLUDE keyword in the options file prevents the borrowing of
the configuration.

Solution: You need to add a dummy user "ACTIVATED LICENSE(S)" into the
group of the included users to enable the borrowing. Do the following:

1. Open tekla.opt using a text editor.

2. Add "ACTIVATED LICENSE(S)" in the group of the included users, for
example:

GROUP steel "ACTIVATED LICENSE(S)" user1 user2 user3
user4
INCLUDE STD-C GROUP steel

3. Save the changes you made in tekla.opt.

4. In LMTOOLS, reread the license file or stop the server and then start the
server.

Error 50035

Problem: License borrowing fails.

Reason: The user tried to borrow a license that is not activated on the license
server. For example, the user tried to borrow a version 20 license and there
are only version 21 licenses activated on the server.

Solution: Do the following:

• Check that the product ID file is up to date. If not, export a new product ID
file in Tekla License Administration Tool ( File --> Export ) and send this file
to the user for borrowing. Then ask the user to save the new product ID
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file, open the Tekla License Borrow Tool, click Open and browse for the
new .tpi file and try borrowing again.

• Check that your license information is up to date in LMTOOLS. If not,
reread the license file.

Error 50036

Problem: License borrowing fails.

Reason: You are not allowed to borrow the license.

Solution: Do one of the following:

• The options file (tekla.opt) needs to be modified so that the borrowing of
the license is allowed. For more information, see Modify on-premises
license access rights (tekla.opt) (page 397).

• Borrow another license.

Error 50037

Problem: License returning fails.

Reason: You tried to return the license to a different license server than it was
borrowed from.

Solution: You need to return the license to the same license server that it was
borrowed from. Do the following:

1. Go to Tekla License Borrow --> Tekla License Borrow Tool through the
Start menu or Start screen, depending on your Windows operating
system.

2. Click Setup and enter the name of the license server where you originally
borrowed the license from and click OK.

3. Select the Return check box in the Borrowed Licenses area to select the
license for returning.

4. Click the Return button to return the license.

After successful returning of licenses, the Borrowed Licenses area is
updated.

Error 50040 or error 50041

Error 50040 or error 50041, problem 1: License activation, deactivation or
repairing fails

Reason: Your license server was not able to connect to activation server at
Trimble Solutions correctly. Usually this is a temporary problem in online
activation.

Solution: Do the following:

• Check that your Internet connection is working. An Internet connection is
needed during license activation and deactivation. A low connection speed
may also cause errors.
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• Close Tekla License Administration Tool and try to activate the license a
while later.

• Try to activate another license.

• Your firewall may block the activation communication. Check your firewall
settings. For more information, see Allowing Tekla on-premises license
server to operate through Windows Firewall (page 380).

• Check that you have the latest Tekla license server version.

• This error could be caused by unfinalized Windows updates on the server
computer. Reboot the server and try again.

• Your Windows login user name may contain special characters. Try to log in
with another user name, for example, administrator.

• Check that your Internet connection is working.

• Contact your local Tekla Structures support and ask for a manual
activation.

Error 50040 or error 50041, problem 2: License borrowing fails.

Reason: You are not connected to the license server.

Solution: Do the following:

• Check that your network connection is working.

• Start Tekla License Borrow Tool and check that you have entered the
correct license server information.

See also

View and diagnose errors in Tekla Structures license activation, deactivation
and borrowing (page 411)

Problems in Tekla license activation (page 415)

Problems in Tekla license borrowing (page 419)

Problems in Tekla license deactivation (page 419)

Licensing tools settings
This section contains detailed reference information about the user interface
of the following licensing tools:

• Tekla License Borrow Tool options and settings (page 433)

• LMTOOLS options and settings used in Tekla licensing (page 435)
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Tekla License Borrow Tool options and settings
Tekla License Borrow Tool displays information about licenses that are
available for borrowing and the licenses that have been borrowed. You can
also borrow and return licenses

The Products area displays information on licenses, and allows you to set the
expiration date for the license borrowing:

Option/
Setting

Description

Borrow Until Select an expiration date for a borrowed license. One month is
the maximum.

Configuration The name of the configuration that you are borrowing.
Version The version number of the configuration.
Activation ID
In Use

Indicates whether the activation ID is used for borrowing. The box
is selected only if you are using a customized and exported
product ID file.

Start Date The date when the license came into effect.
Expiration
Date

The date when the license expires.

The Borrowed Licenses area displays information on borrowed licenses, and
allows you to return borrowed licenses.

Option/
Setting

Description

Return Used for returning licenses.
Trust Status The Host (H), Time (T) and Restore (R) Trust Status. Green symbol

indicates that information is trusted. Red symbol indicates that
information is not trusted. If any of these are not trusted, the
license cannot be used.

• Host indicates whether the server has been moved from one
computer to another or the computer hardware has radically
changed.

• Time indicates whether the system clock has been tampered
with.
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Option/
Setting

Description

• Restore indicates whether the license is obtained from a
backup copy.

Enabled Indicates whether the license is enabled or disabled. For
example, a license may be disabled if there is a disconnection
during the borrowing. A disabled license cannot be used.

Configuration The name of the configuration.
Version The version number of the configuration.
Borrow Until The date when the borrowing expires.
Borrowed
From

The license server from where the license is borrowed.

See also

Set up on-premises license borrowing for offline use (page 404)

Problems in Tekla license borrowing (page 419)

Problems in Tekla licensing: Error codes and their descriptions (page 426)

View and diagnose errors in Tekla Structures license activation, deactivation
and borrowing (page 411)

LMTOOLS options and settings used in Tekla licensing
LMTOOLS is a graphical user interface that allows you to administer the
license server. This utility is provided by Flexera Software.

NOTE If you are using FlexNet Manager by Flexera Software for managing
licenses, do not use LMTOOLS.

In addition to Tekla licenses, you can also manage licenses of other software
that are using FlexNet or FLEXIm. You can also run LMTOOLS on client
computers to check the status of the licenses on the license server.

Go to Tekla Licensing --> LMTOOLS through the Start menu or Start screen,
depending on your Windows operating system.

Service/License File tab

Option/Setting Description
Configuration using
License File

Not used.

Configuration using
Services

You must always have Configuration using
Services and Tekla Licensing Service selected on
the Service/License File tab when you manage
Tekla licenses. These options are selected by
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Option/Setting Description
default during the installation of the Tekla license
server. If you need to configure the license server
manually, see Configure Tekla license server
manually (page 377).

LMTOOLS ignores
license path
environment variables

Not used.

System Settings tab

The System Settings tab displays common device and operating system
information about the computer on which you are running LMTOOLS. All the
relevant information on licensing is available. For example, you can check the
hostname of your server computer.

Option/Setting Description
Hostid Settings Computer/Hostname

Username

CPU ID

IP Address

Etnernet Address

Disk Volume Serial Number

FLEXID
Time Settings System Time Zone

GMT Time

Difference from UTC

MSDOS Time

Local Time

Windows Directory
Save HOSTID info to a
file

Save the hostid information to a text file.

Utilities tab

You can affect the information that is displayed in the status list on the Server
Status tab by defining values on the Utilities tab. By default, the status list
displays information about all the license servers you are connected to.

Option/Setting Description
File Name Find out the version of FlexNet Licensing linked

with a file. Useful for diagnosing errors. Browse
for the file and click Find Version.
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Option/Setting Description
Browse

Find Version
Vendor Name

Path

Add Vendor Path

Override Path

List All Vendor Paths

An example of the vendor name and path:

Vendor Name: tekla
Path: 27007@myserver (port and license server
computer name/hostname)

The Vendor Name that is used for Tekla license
server is tekla (all letters lowercase).

Add a licensing service to be listed in the status
list on the Server Status tab, enter the vendor
information in the Vendor Name and Path boxes
and click Add Vendor Path.

If you want the status list to only display
information on certain license servers, enter the
vendor information in the Vendor Name and
Path boxes and then click Override Path to
replace the existing license servers displayed in
the status list.

The List All Vendor Paths button lists all the
licensing services that are displayed in more
detail in the status list on the Server Status tab.

Start/Stop/Reread tab

On the Start/Stop/Reread tab, you can stop and start the license server, and
adjust some setting related to stopping the server.

NOTE When you perform actions concerning the Tekla license server, Tekla
Licensing Service must be active in the FlexNet license services
installed on this computer list. You can select Tekla Licensing Service
from the services list on the Service/License File tab.

Option/Setting Description
FlexNet license services
installed on this
computer

Lists all FlexNet license services available on the
license server computer.

Always ensure that Tekla Licensing Service is
active in the FlexNet license services installed
on this computer list when you perform actions
concerning the Tekla license server.

• Activate Tekla Licensing Service by selecting it
from the services list on the Service/License
File tab.
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Option/Setting Description
Start Server Starts the license server that is active in the

FlexNet license services installed on this
computer list.

Stop Server Stops the license server that is active in the
FlexNet license services installed on this
computer list. When you click the button, the
status bar displays the message Stopping the
Server, and it takes a couple of seconds to stop
the license server. The message does not change
when the server is stopped.

If Stop Server does not stop the server, select
the Force Server Shutdown check box and click
Stop Server again.

ReRead License File Updates the license server without stopping and
starting it. You need to use this button, when you
manually notify the license server about license
changes.

For more information, see Activate on-premises
licenses (page 390) .

Advanced settings
Restrict lmdown to work
only from node where
lmgrd is running.

When this option is selected, you can stop the
server only on the server computer. No-one can
accidentally stop the license server on a client
computer.

We recommend that you use this option.
Disable lmdown utility,
use task manager.

When this option is selected, you cannot stop the
server in LMTOOLS. The server can only be
stopped in Windows Task Manager.

Disable ’lmremove’ of
license file.

Not in use in Tekla licensing.

Server Status tab

The Server Status tab displays the status of the license server and the
licenses. Here you can check how many licenses are in use or borrowed, who is
currently using licenses on the server and on which computers licenses have
been borrowed.

If you want to check the status of the Tekla license server and licenses only,
enter tekla in the Individual Daemon box and click Perform Status
Enquiry.

Below is an example of license server information:
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1. The license server port@hostname

2. The license server is up and running

3. License server with Tekla identity is up and running

4. A default value for TeklaServer displayed in every status check

Below is an example of license information:

1. Indications the configuration for which license information is displayed. In
this case, Full Detailing.

2. The number of activated licenses on the license server

3. The number of the licenses in use; checked out from the license server or
borrowed

4. A borrowed license

5. On which computer the license was borrowed

6. Tekla license version

7. Time when the license was borrowed

8. Licenses checked out from the license server

9. On which computer and display the user has checked the license out. In
this case, the user is user4, the computer and display names are
computer7.

10. The license server hostname/port from where the license is checked out

11. Time when the Tekla Structures session was started
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12. Usage of licenses of other configurations. In this case, Precast Concrete
Detailing.

Server Diags tab

The Server Diags tab shows more information about the license servers and
licenses, and provides diagnostics.

NOTE If you have problems with the license server, send a copy of the
tekla.lic, tekla.opt, and tekla_debug.log files to your local
Tekla Structures support. The information on the Server Diags tab is
not detailed enough to solve some of the problems.

• To display the diagnostics, click Perform Diagnostics.

Below is an example of the LMTOOLS license server and license diagnostics:

1. The license server port@hostname

2. Common information for all Tekla license server installations

3. On which configuration the information is displayed. In this case it is
Viewer.

4. Tekla license version

5. The license server hostname

6. The expiration date of the license. In this case, the license is permanent.

Config services tab

The values on the Config Services tab are filled in automatically during the
installation of the Tekla license server. However, if you encounter problems
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during the installation and the license server does not start automatically, you
need to configure the settings manually on the Config Services tab.

For more information about the data you should add/select on this tab, see
Configure Tekla license server manually (page 377).

NOTE Whenever you make modifications or perform any actions in
LMTOOLS concerning the Tekla license server, you need to have Tekla
Licensing Service selected in the Service Name list.

Borrowing tab

WARNING Use Tekla License Borrow Tool for borrowing Tekla licenses. Do
not use the Borrowing tab of LMTOOLS with Tekla licenses.

5.4 Tekla Structures upgrades for administrators
To upgrade Tekla Structures, you can install service packs or a new Tekla
Structures version.

You can install service packs on top of the existing installation of Tekla
Structures. You can upgrade to new service packs without updating the
existing Tekla Structures subscription or legacy on-premises license.

Each new Tekla Structures version is installed as a separate app. You can install
a new Tekla Structures version on the same computer as other Tekla
Structures versions.

Tekla Structures subscriptions automatically allow you to use any Tekla
Structures version that is released during your subscription period. If you have
legacy on-premises licenses, the licenses have a newest allowed version. You
must update your legacy on-premises licenses when you upgrade to a version
that is newer than the newest allowed version.

If you already have an older version of Tekla Structures installed on your
computer, you can use the Migration Wizard to copy your personal settings to
the new version.

When you customize Tekla Structures, we strongly recommend that you create
project and firm folders (page 16) for the customized files. If you have
customized previous Tekla Structures versions without using firm or project
folders, you must transfer the customized information to the next Tekla
Structures version.

Before you start using a new Tekla Structures version, always test that the
previous company settings (page 34) work.
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5.5 Printer settings
Tekla Structures uses Windows drivers to write the print data directly to the
Windows print device interface.

You print drawings as a PDF file, save them as a plot file (.plt) for printing
with a printer or plotter, or print them on a selected printer.

To print to several paper sizes, you must modify the . You can also change the
line width of the printed drawings.

You can use advanced options specific to the drawing type to define how Tekla
Structures automatically names .pdf files and .plt files.
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6 Disclaimer

© 2023 Trimble Solutions Corporation and its licensors. All rights reserved.

This Software Manual has been developed for use with the referenced
Software. Use of the Software, and use of this Software Manual are governed
by a License Agreement. Among other provisions, the License Agreement sets
certain warranties for the Software and this Manual, disclaims other
warranties, limits recoverable damages, defines permitted uses of the
Software, and determines whether you are an authorized user of the Software.
All information set forth in this manual is provided with the warranty set forth
in the License Agreement. Please refer to the License Agreement for important
obligations and applicable limitations and restrictions on your rights. Trimble
does not guarantee that the text is free of technical inaccuracies or
typographical errors. Trimble reserves the right to make changes and
additions to this manual due to changes in the software or otherwise.

In addition, this Software Manual is protected by copyright law and by
international treaties. Unauthorized reproduction, display, modification, or
distribution of this Manual, or any portion of it, may result in severe civil and
criminal penalties, and will be prosecuted to the full extent permitted by law.

Tekla Structures, Tekla Model Sharing, Tekla PowerFab, Tekla Structural
Designer, Tekla Tedds, Tekla Civil, Tekla Campus, Tekla Downloads, Tekla User
Assistance, Tekla Discussion Forum, Tekla Warehouse and Tekla Developer
Center are either registered trademarks or trademarks of Trimble Solutions
Corporation in the European Union, the United States, and/or other countries.
More about Trimble Solutions trademarks: http://www.tekla.com/tekla-
trademarks. Trimble is a registered trademark or trademark of Trimble Inc. in
the European Union, in the United States and/or other countries. More about
Trimble trademarks: http://www.trimble.com/trademarks.aspx. Other product
and company names mentioned in this Manual are or may be trademarks of
their respective owners. By referring to a third-party product or brand, Trimble
does not intend to suggest an affiliation with or endorsement by such third
party and disclaims any such affiliation or endorsement, except where
otherwise expressly stated.

Portions of this software:

EPM toolkit © 1995-2006 Jotne EPM Technology a.s., Oslo, Norway. All rights
reserved.
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Portions of this software make use of Open CASCADE Technology software.
Open Cascade Express Mesh Copyright © 2019 OPEN CASCADE S.A.S. All rights
reserved.

PolyBoolean C++ Library © 2001-2012 Complex A5 Co. Ltd. All rights reserved.

FLY SDK - CAD SDK © 2012 VisualIntegrity™. All rights reserved.

This application incorporates Open Design Alliance software pursuant to a
license agreement with Open Design Alliance. Open Design Alliance Copyright
© 2002-2020 by Open Design Alliance. All rights reserved.

CADhatch.com © 2017. All rights reserved.

FlexNet Publisher © 2016 Flexera Software LLC. All rights reserved.

This product contains proprietary and confidential technology, information
and creative works owned by Flexera Software LLC and its licensors, if any. Any
use, copying, publication, distribution, display, modification, or transmission of
such technology in whole or in part in any form or by any means without the
prior express written permission of Flexera Software LLC is strictly prohibited.
Except where expressly provided by Flexera Software LLC in writing,
possession of this technology shall not be construed to confer any license or
rights under any Flexera Software LLC intellectual property rights, whether by
estoppel, implication, or otherwise.

To see the third party open source software licenses, go to Tekla Structures,
click File menu --> Help --> About Tekla Structures --> 3rd party licenses
and then click the option.

The elements of the software described in this Manual are protected by
several patents and possibly pending patent applications in the United States
and/or other countries. For more information, go to page http://
www.tekla.com/tekla-patents.
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