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1 Tekla Structures configurations

Depending on your Tekla Structures subscription, you have access to the Tekla
Structures Carbon, Tekla Structures Graphite, or Tekla Structures
Diamond configuration.

NOTE Only legacy configurations are supported if you use legacy on-premises
licenses.

You can view the subscription details, including renewal information, in the
Tekla Online Admin Tool.

Each subscription progressively enables more product features.

• Tekla Structures Diamond is for detailing and production information.

• Tekla Structures Graphite is for modeling and design documentation.

• Tekla Structures Carbon is for viewing and collaboration.

This documentation covers the content of the Tekla Structures Diamond
configuration, so you might not have access to all the described features. If
your subscription includes several different configurations, you can select
between them when you start Tekla Structures.

Feature map for Tekla Structures subscriptions

 Carbon Graphite Diamond
Modeling
Opening and
viewing models

✔ ✔ ✔

Modeling of parts,
steel assemblies,
precast cast units,
concrete pour
units

 ✔ ✔

Creating steel and
concrete
components

 ✔1 ✔
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 Carbon Graphite Diamond
Creating unique
part marking
(numbering)

 ✔2 ✔

Intelligent batch
editing tools

  ✔

Planning tools
Logistics planning,
sequencing,
scheduling,
classifying, status
visualization

✔ ✔ ✔

Drawings and reports
Creating reports &
print drawings

✔ ✔ ✔

Creating general
arrangement,
rebar and anchor
bolt drawings
(plan, section,
erection)

 ✔ ✔

Creating steel and
concrete
production
drawings (part,
assembly, cast
units)

  ✔

Interoperability
Exports for steel
CNC & MIS
systems

✔ ✔ ✔

Exports to rebar
manufacturing
systems

✔ ✔ ✔

Exports for
precast concrete
ERP & MES
systems

✔ ✔ ✔

Work with
reference models
(such as DWG,
DXF, IFC formats)

✔ ✔ ✔

Analyzing    
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 Carbon Graphite Diamond
Create analysis
models and
analysis loads

 ✔ ✔

Analysis and
design interfaces

 ✔ ✔

Other    
Open API
capabilities

✔ ✔ ✔

✔1 = Conceptual components only.

✔2 = Numbering is not available for steel or precast assemblies,
reinforcement is still numbered.

Feature map for legacy on-premises licenses

 Full Ste
el

Det
aili
ng

Pre
cas

t
Con
cret

e
Det
aili
ng

Reb
ar

Det
aili
ng

Eng
ine
eri
ng
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ucti
on
Mo
deli
ng
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M

Mo
del
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Pri
ma
ry

Pro
duc
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n

Pla
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r
for
Con
cret

e

Pro
ject
Vie
wer

Dra
fter

Viewing ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Grids,
construction
lines, points

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Building
elements

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔1

Assemblies ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Precast cast units ✔ ✔ ✔ ✔ ✔

Batch editing ✔ ✔ ✔ ✔    ✔    
Pour modeling ✔2 ✔2 ✔2 ✔2 ✔2 ✔2 ✔2 ✔2
Pour viewing ✔2 ✔2 ✔2 ✔2 ✔2 ✔2 ✔2 ✔2 ✔2 ✔2 ✔2
Cast in Place cast
units

✔ ✔ ✔ ✔ ✔ ✔

Numbering ✔ ✔6 ✔ ✔3 ✔

Assigning control
numbers

✔ ✔ ✔ ✔
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Steel
components

✔ ✔ ✔8 ✔8 ✔8 ✔8 ✔

Concrete
components

✔ ✔ ✔5,
8

✔8 ✔8 ✔8 ✔

User-defined
attributes

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔9 ✔9 ✔7

Locking ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Multi-user ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Clash check
manager

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Planning tools
Lotting ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Precast planning
tools (such as
Palletizer and
Stacker)

✔ ✔1
0

✔ ✔

Sequencer ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Project status
visualization (4D)

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Task manager ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Organizer ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔4
External editors
Symbol Editor ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Template Editor ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Drawings, plans and reports
Drawing layout
editor

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Creating general
arrangement
drawings (plan,
section, erection)

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔
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Modifying
general
arrangement
drawings (plan,
section, erection)

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Creating steel
fabrication
drawings (single-
part drawings)

✔ ✔ ✔ ✔

Modifying steel
fabrication
drawings (single-
part drawings)

✔ ✔ ✔ ✔

Creating steel
fabrication
drawings
(assembly
drawings)

✔ ✔ ✔ ✔

Modifying steel
fabrication
drawings
(assembly
drawings)

✔ ✔ ✔ ✔

Creating precast
concrete
drawings (cast
unit drawings)

✔ ✔ ✔ ✔

Modifying
precast concrete
drawings (cast
unit drawings)

✔ ✔ ✔ ✔

Creating cast-in-
place concrete
drawings (cast
unit drawings)

✔ ✔ ✔ ✔ ✔

Tekla Structures configurations 9



 Full Ste
el

Det
aili
ng

Pre
cas

t
Con
cret

e
Det
aili
ng

Reb
ar

Det
aili
ng

Eng
ine
eri
ng

Con
str

ucti
on
Mo
deli
ng

EP
M

Mo
del
er

Pri
ma
ry

Pro
duc
tio
n

Pla
nne

r
for
Con
cret

e

Pro
ject
Vie
wer

Dra
fter

Modifying cast-in-
place concrete
drawings (cast
unit drawings)

✔ ✔ ✔ ✔ ✔

Anchor bolt plans ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Reports ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Printing and
plotting

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Interoperability
Export CNC, DSTV ✔ ✔ ✔ ✔ ✔ ✔

Steel MIS links ✔ ✔ ✔ ✔ ✔ ✔

Import 2D and
3D DWG, DXF

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Export 3D DWG,
DXF, DGN

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Export drawings
(DXF, DWG)

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Import and
export CAD and
FEM packages

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

IFC export ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

CIS/2 import and
export

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

ELiPLAN import
and export

✔ ✔ ✔ ✔

BVBS export ✔ ✔ ✔ ✔ ✔

HMS export ✔ ✔ ✔ ✔

Unitechnik
export

✔ ✔ ✔ ✔

View reference
models

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔
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Insert reference
models (DXF,
DWG, DGN, IFC,
XML, PDF)

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Layout manager ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔

Analyzing
Create analysis
model

✔ ✔ ✔ ✔ ✔ ✔

Analysis and
Design interface

✔ ✔ ✔ ✔ ✔ ✔

Loads ✔ ✔ ✔ ✔ ✔ ✔

Open API
Open API
capabilities

✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔ ✔4

✔1 = Limitation: 2500 parts, 5000 reinforcement objects, unlimited number of
bolts.

✔2 = Pours are enabled by an advanced option.

✔3 = Numbering is limited to cast-in-place parts, cast units and reinforcement.

✔4 = View only.

✔5 = Cast in Place concrete components only.

✔6 = Numbering is limited to steel parts and cast units.

✔7 = User-defined attributes in drawing properties can be edited, others view
only.

✔8 = Conceptual components only.

✔9 = User-defined attributes that affect numbering cannot be edited.

✔10 = Availability depends on the extension. Check the Tekla Warehouse page
for details.
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2 Start Tekla Structures

With Tekla Structures, you can create information-rich 3D models of all
structures and materials, and the 3D model is also the single source of
information for drawings and other outputs, such as reports and NC data files.

When you start Tekla Structures, you are asked to choose your Tekla Structures
setup. The setup consists of an environment, role, and configuration.

• Environment means region-specific settings and information. It defines, for
example, which profiles, material grades, default values, drawing settings,
component settings, reports, and templates are available and used for the
specific region.

• Role is a user group profile that limits the availability of files and settings in
an environment. The user interface has been customized for each role,
meaning that some of the settings that are not relevant for the specific role
are hidden to make the user interface clearer and easier to use.

• Configuration consists of a set of features that the user is entitled to based
on the license agreement.

If you are a company administrator, see Overview of environments, roles, and
configurations.

2.1 Choose your Tekla Structures setup
1. Start Tekla Structures by selecting it from the Windows Start menu or by

double-clicking the desktop icon.

2. Sign in using your Trimble Identity when prompted. 

A dialog box where you choose your Tekla Structures setup and the type
of license appears. Proceed with the default Tekla Structures subscription
option.

If you have an on-premises license, click Change license server --> Use
your on-premises license server.
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3. Select an environment that fits the region where your project is done. 

If you cannot find the environment that you want in the list, see Install and
license Tekla Structures.

You can also select blank project and use it as the basis to create your
own customized environment.

4. Select a role. 

The availability of roles depends on your environment, but typically the
following roles are available:

• Concrete Contractor

• Engineer

• General Contractor

• Precast Concrete Detailer

• Production Planner for Concrete

• Rebar Detailer

• Steel Detailer

5. Select a configuration. 

The configuration that you are using might not contain all the features
described in the Tekla Structures product guides. For more information on
the features available in each configuration, see Tekla Structures
configurations (page 5).

6. Click OK. 
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The start screen appears.

7. Select what you want to do: 

• On the Recent tab, you can open a recently used model (page 16).

If the Recent tab is empty, then the All models tab is shown.

• On the All models tab, you can open any existing model (page 16).

If the All models tab is empty, then the New tab is shown.

On the Recent and All models tabs, you can sort each of the columns.
Additionally, you can change the order and size of the columns by
dragging them.

You can search models by name just by starting to type the name of
the model. For example, when you type N, Tekla Structures selects the
first model starting with the letter N.

To open the selected model, double-click the selected model, or select
the model and click the Open button.

• On the Shared models tab, you can open a model that has been
shared by using Tekla Model Sharing.

• On the New tab, you can create a new model (page 17).

2.2 Create your own environment: blank project
Blank project is a Tekla Structures environment that includes only generic
content, such as parametric profiles, undefined bolt, material and rebar
grades, and basic drawing layouts. It can be used for gathering region-,
company-, or project-specific settings, tools, and information. The blank
project is always included in the Tekla Structures installation.

Download and install content to the blank project

You can use Tekla Warehouse to download and install content to the blank
project. For example, you can download profiles, material grades, bolts,
reinforcement, components, applications, and templates from Tekla
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Warehouse across all environment- and manufacturer-specific collections, and
make combinations that suit your needs.

You can download and install content from Tekla Warehouse both before and
during a project. Before starting a project, you can install content to your
project and firm folders. During a project, you can install content to the model
folder.

2.3 Check or change your Tekla Structures setup
You can check your current Tekla Structures setup (environment, role, and
configuration) at any time without having to close the model.

1. On the File menu, click Settings and scroll down to the License area. 

You current setup is displayed.

2. Change the setup if needed. 

You might be required to restart Tekla Structures after the changes.

2.4 Tekla Structures usage data
Tekla Structures collects usage data on how you use the software. This
information helps to improve Tekla Structures, and it is an easy way to
influence the future development of Tekla Structures. Your data is combined
with other people's data to make a statistical analysis.

Tekla Structures collects usage patterns and trends of how you use the
commands and tools in the software. The program collects this information
automatically while you use Tekla Structures. You can view the log file to check
the collected data.

1. On the File menu, click Logs --> Usage data log to view the log file. 

Note that the UserFeedbackLog.txt log file is always opened with the
default text editor, unlike other log files which can be opened through the
Tekla Structures log viewer. The option to switch between the viewers
does not work for the UserFeedbackLog.txt file.

The UserFeedbackLog.txt log file is located in the Logs folder under
the path defined with XSUSERDATADIR in teklastructures.ini file.
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2. To fine-tune the data saving interval or the data sending interval, use the
advanced options XS_AUTOMATIC_USER_FEEDBACK_SAVING_INTERVAL
and XS_AUTOMATIC_USER_FEEDBACK_SENDING_INTERVAL.

2.5 Open a model
You can have one model open at a time. If you open a model and already have
one open, Tekla Structures prompts you to save the first model.

Open a recently used model
1. On the File menu, click Open.

2. Click Recent.

3. Select a model in the list. 

Tekla Structures shows the thumbnail image (page 18) of the model, if
you have added a one, and some basic creation information of the model.

4. To open the selected model, click Open or double-click the model. 

If no views are visible in the model, Tekla Structures prompts you to select
one.

NOTE If you want to remove a model from the Recent models list, right-click
a model and select one of the options.

• Delete the selected item: delete the selected model from the list

• Clear all: remove all the models from the list

• Clear invalid entries: remove all invalid models from the list, such
as deleted models that cannot be opened anymore

Open any existing model
1. On the File menu, click Open.

2. Click All models. 

If you want to search for models in another folder, click Browse....

If you want to sort the models based on name or the modification date,
use the Order by sorting.

3. Select a model in the list. 

Tekla Structures shows the thumbnail image (page 18) of the model, if
you have added a one, and some basic creation information of the model.
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4. To open the selected model, click Open or double-click the model. 

If no views are visible in the model, Tekla Structures prompts you to select
one.

Open a shared model
If you want to open and work with a model that has been shared by using
Tekla Model Sharing, you need to have a valid Tekla Model Sharing license.

1. On the File menu, click Open.

2. Click Browse shared models. 

Tekla Structures prompts you to log in with your Trimble Identity, if not
already done so.

3. Select the shared model in the Shared models dialog box.

2.6 Create a new model
Create a separate model for each Tekla Structures project. Each model is
stored in its own folder under the TeklaStructuresModels folder.

1. On the File menu, click New.

2. In the Name box, enter a name for the new model. 

The maximum length of the name is 40 characters.

Do not use special characters (/ \ ; : |). We recommend that you try
to decide on a permanent name at this point. The name of the model can
be changed afterward, but it involves changing several file names.

3. Define where to save the new model. 

By default, the model is saved in the TeklaStructuresModels folder
that was created during installation. You can change the default folder by
clicking Browse. You can also select a recently used folder in the Place in
list.

4. Select whether to run Tekla Structures in single-user or multi-user mode. 

• Single-user: the model will be used by one person at a time.

• Multi-user: the model is stored on a server and may be used by several
people simultaneously. Enter the name of the server in the Server box.

5. If you want to use a model template, select one. 

You can mark the important model templates as favorites, or hide the
templates that you do not need.

a. Select a model template in the list.
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b. Right-click and select Favorite or Hidden. 

If you marked a template as Favorite, it is placed on top of the
template list. Alternatively, use the star icon on the template to mark
it as Favorite, or to remove the marking.

If you marked a template as Hidden, it is removed from the template
list. Select the Show hidden items check box to show it again.

6. If you want to link the model to a Trimble Connect project, select the Start
Trimble Connect collaboration check box. 

Linking the model to a Trimble Connect project happens after the model
has been created. For further instructions, see Link a Tekla Structures
model to a Trimble Connect project.

7. Click Create. 

Tekla Structures creates the model and opens the default model view. The
contents of the model view may differ based on the model template you
chose in step 5.

See also

Create a thumbnail image of a model (page 18)

Edit project properties (page 19)

2.7 Create a thumbnail image of a model
You can add a thumbnail image to make it easier to recognize your project
even when you do not remember the exact name of the model. The thumbnail
image is displayed when you browse for existing models.

1. On the View tab, click  Screenshot --> Project thumbnail.

2. Select a view. 

Tekla Structures creates the image and saves it in the model folder with
the name thumbnail.png.

3. To check the thumbnail, go to the File menu, click Open, and select the
model you created the thumbnail for in the Recent or in the All models
list. 
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The image is now displayed with other model information. For example:

4. If you are unhappy with the thumbnail image, you can repeat steps 1–2 as
many times as you need. 

For example, you can zoom the model in and out to adjust what is shown
in the thumbnail image. When you create a new thumbnail, Tekla
Structures overrides the existing thumbnail image with the new one.

TIP Alternatively, if you want to use a custom image, you can add the image directly
to the model folder with the name thumbnail.png. The preferred size of the
image is 120 x 74 pixels.

2.8 Edit project properties
You will need project information, such as project number and name, many
times during a project. Update the project properties at the beginning of each
project to make reports and drawings display the correct information
automatically. All of the fields are optional.

1. On the File menu, click Project properties.

2. Edit the general project properties, and enter a description that helps you
identify the model when you next need to open it. 

The description is listed with the other model information when you select
a model in the Recent or in the All models list.

The limit for the length of the description is 78 characters.

When you edit the properties, Tekla Structures highlights the modified
properties in yellow. When you are ready with the modifications, click
Modify to apply the changes.

3. If you want to use another coordinate system for interoperability and
collaboration, click Base points to define a new base point. 

Once a base point has been defined, you can select it from the Location
by list.
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4. To define project-specific user-defined attributes, click User-defined
attributes. 

By default, you can define:

• Project comment

• User fields

• Execution class

• Classification system

• IFC export attributes, like IFC site name, IFC building name, IFC building
storey name, and IFC bridge name

• Status attributes

• Unitechnik factory location

The availability of the various user-defined attributes depends on your
environment (page 12), role and configuration (page 5).

Once you are finished with editing the project properties, as a result, you will
get updated project properties in drawings and reports.

Displaying project information in templates and reports

The fields in the image below refer to template attributes, which you can use
when designing your own reports and templates. To display project
information, add the corresponding template attributes in the templates and
reports.
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(1) NUMBER#2

(2) NAME

(3) BUILDER
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(4) OBJECT

(5) DESIGNER

(6) LOCATION

(7) ADDRESS

(8) POSTAL_BOX

(9) TOWN

(10) REGION

(11) POSTAL_CODE

(12) COUNTRY

(13) DATE_START

(14) DATE_END

(15) INFO1, INFO2

(16) DESCRIPTION

2.9 Save a model
You should save your model regularly to avoid losing any work. Tekla
Structures also automatically saves your work at regular intervals.

NOTE Tekla Structures versions are not backwards compatible. When you save a
model, you cannot open it in older versions of Tekla Structures due to
database differences.

Save the current model
To save changes to the current model file, do one of the following:

• On the top left corner of the screen, click Save .

• On the File menu, click Save as --> Save.

• Press Ctrl+S.

Save a copy with different name or location
You can create a copy of the model with a different name or in a different
folder. The original version of the model remains intact.
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NOTE When you save the model with a different name, all the GUIDs
(globally unique identifiers) of the saved model will change and be
different than in the original model. This means that the saved model
has no relation to the original model, and the saved model cannot be
used as backup.

1. On the File menu, click Save as --> Save as.

2. In the Model name box, enter a new name.

3. To save in a different location, click Browse and define where you want to
save the model.

4. Click OK. 

Tekla Structures creates a new copy with a different name, but the original
version of the model remains intact.

Save a backup copy
You can create a backup copy of the model with the same GUIDs (globally
unique identifiers) as the original model.

1. On the File menu, click Save as --> Save and create backup copy. 

Tekla Structures saves a copy of the model in
the ..\TeklaStructuresModels\backup\<model_name>\<date-
time> folder.

2. If you need to take the backup copy into use in place of the current model,
move the backup copy from the chosen date to your model folder. 

You can either replace all contents of the current model folder with the
content of the chosen backup folder, or you can rename the backup
folder (<date-time>) to match the original model name.

3. If you want to change the location of the backup folder, use the advanced
option XS_MODEL_BACKUP_DIRECTORY.

NOTE To save disk space, you can compress the 
XS_MODEL_BACKUP_DIRECTORY folder.

Save as a model template
You can save a model with the desired settings and use the model as a
template when you create new models.
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Define autosave settings
Use Autosave to automatically back up and save your work at set intervals.
You can set the autosave interval separately for the model and drawings.
Autosave files have the extension .db1_<user>.

If the autosave is not successful for some reason, check the status bar
messages (page 48) for more information.

1. On the File menu, click Settings --> Options, and go to the General
settings.

2. Under Autosave, set the autosave interval.

a. In the first box, enter the number of minutes after which Tekla
Structures saves the model. The default value is 15 minutes. 

If there are no changes in the model during the autosave interval, the
model is not autosaved.

b. In the second box, enter the number of drawings after which Tekla
Structures saves your work.

NOTE The smallest accepted value for the autosave interval is 2, both
for modeling and for drawings.

If you try to enter a value smaller than 2, Tekla Structures
automatically changes the value to 2.

3. Click OK.

4. Define where to store the Autosave files. 

By default, Tekla Structures stores the autosave files in
the ..\TeklaStructuresModels\autosave folder. To change the
folder, use the advanced option XS_AUTOSAVE_DIRECTORY.

5. Define whether to keep old autosave files. 

By default, Tekla Structures deletes the autosave files when you close a
model, to save disk space. To keep autosave files even if you exit Tekla
Structures without saving the model, use the advanced option
XS_KEEP_AUTOSAVE_FILES_ON_EXIT_WHEN_NOT_SAVING.

When to use an autosaved model
You can use the autosaved model if there are errors when trying to open a
model (page 16). When you open a model, Tekla Structures automatically
checks if the previous session ended normally. If it did not, Tekla Structures
asks whether you want to continue by using the autosaved model or the
original model.

If Tekla Structures displays the warning Fatal: Model memory corrupted by
read, it means that hardware problems have damaged the model database.
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Your hard disk may be damaged. Use autosave or system backup files to
restore the model.
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3 Introduction to Tekla Structures
user interface

When you open a Tekla Structures model, a new window appears. By default,
the user interface will look something like this:

(1) This is your Tekla Structures model. If you are starting a completely new
project, you will only see the default model view and an empty grid at this
point.

(2) The green cube symbol represents the global coordinate system and it lies
at the global origin (x=0, y=0, z=0).

(3) The box around the grid represents the work area. In a view, you can only
see the parts that are within this area. Objects that are outside the work area
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exist in the model, but they are not visible. You can shrink and expand the
work area to suit your needs. You can also hide the work area box.

(4) The coordinate symbol with the three axes x, y, and z represents the local
coordinate system. It also indicates the direction of the model.

(5) The File menu is where you manage your models. You can save models
(page 22), print drawings, and import and export models, among other things.

(6) The ribbon contains all the commands and other functions you will use
when building your model. You can customize the ribbon according to your
needs.

(7) By default, the Quick Access Toolbar (page 48) contains the Save, Undo,
Redo, and Undo history shortcuts icons. You can customize the Quick Access
Toolbar according to your needs.

(8) The upper right corner shows your user-name and a green symbol
indicating that you are signed in and your subscription or license is working as
expected. If a clock symbol is shown instead of the green symbol, the clock
indicates that you are disconnected from the Tekla subscription service.

(9) If you cannot find the command or dialog box you are looking for, search
with Quick Launch (page 31).

(10) Use the side pane (page 32) on the right side of the screen to check
instructions for the currently active ribbon command, view objects properties,
add reference models and components, attach point clouds, use custom
inquiry, or to find direct access to Tekla Online services.

(11) The work plane handler toolbar controls which work plane you currently
have in use in the model.

(12) The model search toolbar enables a quick search for objects in the entire
model or within the selected model objects.

(13) The snap switches control which positions you can pick when creating
objects.

(14) The selection switches (page 41) control which objects you can select.

(15) When you create objects, the status bar (page 48) will tell you how to
proceed and when to pick points.

3.1 How to use the ribbon and the commands on the
ribbon
All the essential commands in Tekla Structures are available on the ribbon. The
commands are grouped according to their use. You can modify the
appearance of the ribbon, and customize the content of the ribbon, if needed.
All commands throughout Tekla Structures work in the same manner.
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How to use commands on the ribbon

To Do this
Find commands Slide the ribbon right or left with your

mouse, or scroll with your mouse
wheel.

Some commands have more options
under them. The options become
available when you click the
command's name:

Activate the command you want to
use

On the ribbon, click the command.

The command runs until you end it or
use another command.

Check which command you need for
your current task, if you are unsure

Rest the mouse pointer on a
command.

A small window called tooltip
appears. Tooltips provide more
information about commands and
also give examples, hints, and tips.
For example:
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To Do this
Press Ctrl+F1 when a tooltip is open
to find more help on the command.

To switch the tooltips on or off, click
File menu --> Settings --> Switches ,
and then select or clear the Tooltips
check box.

View more detailed instructions on
how to use the currently active ribbon
command

In the side pane, click  to open
the Instructor side pane window.

On the ribbon, click a command. The
Instructor side pane window shows
short videos, steps and other
information on how to use the active
command.

End command Right-click and select Interrupt.

You can also press Esc.
Re-activate the last command Press Enter.

NOTE You can complete many commands by using the Enter or the space
key as a shortcut, or by using the middle mouse button.

To use the Enter key as a shortcut for completing commands, set the
advanced option XS_ENTER_FINALIZES_COMMANDS to TRUE.

Change the appearance of the ribbon
You can change the order of ribbon tabs, choose how they are aligned, and
even hide some parts of the ribbon if you do not need them in your current
project. For example, if you are only modeling steel parts, you can temporarily
hide the Concrete tab.

To Do this
Change the order of tabs on the
ribbon

Drag and drop the tab titles.

Change how the tabs are aligned Right-click on the top bar of the
ribbon, select Navigation mode, and
then select one of the options.

• Scroll visible: the ribbon
movement is minimal when you
switch between the tabs

• Align to left: the icons start from
the left side of the ribbon
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To Do this
• Align to tab: the icons start from

the left side of the current tab
Hide the tabs that you do not need in
your current project

1. Rest the mouse pointer on a tab
title.

A small eye symbol appears next
to the tab title:

2. Click the eye symbol .

The eye symbol changes and the
tab title becomes gray:

The View tab is now hidden from
the ribbon. If you slide the
ribbon, hidden tabs appear as:

3. To re-display the hidden tab, click
the eye symbol again.

Minimize the ribbon
You can minimize the ribbon to save space on your screen. When the ribbon is
minimized, the command buttons are hidden but the tabs are visible.

1. Right-click on the top bar of the ribbon, and select Minimized. 

The ribbon is now minimized to save space on the screen:

2. To access the commands when the ribbon is minimized, click a tab title. 

The ribbon becomes visible so that you can select a command.
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3. To restore the ribbon, right-click on the top bar of the ribbon, and select
Minimized again.

3.2 How to use Quick Launch to find commands, dialog
boxes, and toolbars
Use the Quick Launch box in the upper-right corner of the screen to find
commands, dialog boxes, toolbars, and other functions. The shortcut key for
Quick Launch is Ctrl+Q.

1. In the Quick Launch box , enter a search term. 

For example, type bolt if you are looking for bolt commands.

2. Wait for a list of search results to appear. For example: 

The search results show the location of the command. You can navigate in
the list by clicking the Recent, Ribbon, Menu, and All commands tabs.
The Recent tab lists 10 most recently started commands from the search
results.

Alternatively, you can navigate in the search results by using the up and
down arrow keys on the keyboard. Start the selected command by clicking
Enter.

Tekla Structures highlights the commands on the ribbon or on the File
menu. For example:
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If the command you have searched is in the side pane, Tekla Structures
opens the side pane window.

3. To run a command, click its name on the search results list. 

Or press the Enter key to instantly run the first command on the list.

4. For some basic settings (page 35) and toolbars a check box appears in
front them on the search results list. Click the command to activate the
setting, or to have the toolbar visible. 

5. If you want to open the list of search results again, click the Quick Launch
box and the list opens automatically. 

To clear the Quick Launch box, click the  button or press the Esc key.

See also

How to use the ribbon and the commands on the ribbon (page 27)

How to use the side pane (page 32)

3.3 How to use the side pane
Use the side pane on the right side of the screen, for example, to view object
properties, and to add reference models and components.

To Do this
Open a side pane
window

Click a side pane button to open a side pane
window.

•
Click  to view model object properties
using Custom inquiry.

•
Click  to open Instructor and to view
instructions for the currently active ribbon
command.
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To Do this
•

Click  to find shortcut access to the
different Tekla Online services.

•
Click  to attach point clouds to a model.

•
Click  to show the properties of model or
drawing objects.

•
Click  to show the reference models list.

•
Click  to show the Applications &
components catalog.

When you click a side pane button, the side pane
window opens and becomes active. Active side

pane windows have blue buttons .
Keep multiple side pane
windows open at the
same time

Tekla Structures opens only one side pane window
at a time by default. You can keep multiple side
pane windows open at the same time if needed.

• Right-click a side pane button and select Single
pane or Stacked panes.

Single pane: Tekla Structures opens a new side
pane window and closes all the other open side
pane windows.

Stacked panes: Tekla Structures opens a new
side pane window and keeps the other open
side pane windows stacked on top of each
other.

• Click Ctrl+side pane button to open the side
pane windows stacked on top of each other.

You can resize the side pane windows and change
their order by dragging them.

Close a side pane
window

You can close one active side pane window at a
time, or several windows at one go if you have
stacked them on top of each other.

• Click another side pane button to close the
active side pane window and to open a new
window.

•
Click the  button in the upper right corner of
each side pane window.
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To Do this
•

Click the arrow  in the side pane.
Move a side pane
window

When you position the mouse pointer on the
upper part of the side pane window, the upper
part is shown in light blue.

Grab the upper part of the side pane window and
drag the window to a new location.

Float and dock a side
pane window

You can float or dock the side pane windows.

• To float a side pane window: right-click a side
pane button and select Float.

• To dock a side pane window: right-click the side
pane button of a floating window and select
Attach to side pane.

Alternatively, you can drag the side pane
window back to the docking area on the right or
at the bottom of the screen. The docking area is
marked with blue color.

If you float a side pane window and close Tekla
Structures, the side pane window will be opened in
its floating position when you start Tekla Structures
the next time.

Adjust the size of a side
pane window

Resize a floating side pane window by dragging its
borders.

Find more help on the
content of a side pane
window

Click the  button.

TIP Sometimes a side pane window opens on a second display that is not
connected to your computer at the moment. To return the side pane
window to the main display, right-click the side pane button and select
Attach to side pane.
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See also

Introduction to Tekla Structures user interface (page 26)

3.4 Basic settings in the File menu
Use the toolbar settings and the switches in File menu --> Settings to control
some basic modeling and drawing settings.

1. In the upper-left corner of the screen, click File.

2. Go to Settings.

3. Under User interface, Switches, or Toolbars, switch the options either
on or off.

In drawings, under Color mode, click one of the options to change the
color mode to Black and white, Grayscale, or Color.

Alternatively, you can use Quick Launch (page 31) box  to
control the toolbars and the switches. Start typing the name of the toolbar or
the switch, for example, smart, in the Quick Launch box and select the
toolbar or the switch on the search results list to activate the setting.

User interface

• Toolbars: Use the option buttons to adjust the size of the icons on the
toolbars at the bottom of the screen, and at the same time the toolbar size.

• Font size (Ribbon): Use the slider to adjust the ribbon font size. The
default font size is 11p.

Switches

Option Description
Smart select Change how drag-and-drop works for object

handles.

When the option is on, you can drag from object
handles without selecting them first.

When the option is off, you must select the
handles before dragging.
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Option Description
Drag & drop Activate or inactivate the drag-and-drop command.

When the option is on, you can use drag-and-drop
when copying or moving objects.

When the option is off, drag-and-drop cannot be
used.

Middle button pan Change the panning mode.

When the option is on, you can move the model or
drawing using the middle mouse button.

When the option is off, you can move the model
using the left mouse button.

Centered zooms Change the zooming mode.

When the option is on, the center point of zooming
is kept in the middle of the view, regardless of the
mouse pointer position.

When the option is off, the mouse pointer position
determines the center point of zooming.

Basic view auto
rotation

Activate or inactivate the auto rotation of part and
component 3D views.

When the option is on, Tekla Structures rotates the
view once whenever you create a new 3D view of a
part or component.

When the option is off, Tekla Structures does not
rotate the view.

Crossing selection Change how area selection works.

When the option is on, all objects that fall at least
partially inside the rectangular area are selected,
regardless of the dragging direction.

When the option is off, the dragging direction
affects the selection of objects.

Rollover highlight Switch the highlighting of objects on or off.

Depending on the rendering engine you are using,
OpenGL or DirectX, Tekla Structures highlights the
objects differently when rollover highlight is on.

When the option is on, Tekla Structures highlights
selectable objects when you move the mouse
pointer on them.

When the option is off, selectable objects are not
highlighted.
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Option Description
Select on right-click Change how objects can be selected.

When the option is on, you can select objects also
with the right mouse button. Also the related
context menu is displayed immediately.

When the option is off, you can select objects with
the left mouse button.

Automatic rotation
center

Define how the view point is set.

When the option is on, the view point changes
whenever you click the middle mouse button.

When the option is off, the view point stays in a set
position.

Ortho Activate or inactivate orthogonal snapping.
Orthogonal snapping also works in drawings.

When the option is on, Tekla Structures snaps to
the closest orthogonal point on the plane (0, 45,
90, 135, 180 degrees, and so on). The mouse
pointer automatically snaps to positions at even
distances in the given direction.

When the option is off, orthogonal snapping is not
used.

Use legacy rendering Activate or inactivate the DirectX rendering.

When the option is on, the legacy OpenGL
rendering is used.

When the option is off, the DirectX rendering is
used. DirectX rendering is better optimized for
modern graphics cards.

The rendering setting is model view specific, which
means that you can use a different rendering
options in different model views. If you switch
between the rendering options, you need to
reopen the model view to activate the new value.

Hatching of
overlapping surfaces

In the DirectX rendered model views, switch the
hatching of overlapping surfaces on the same
plane on or off.

When the option is on, the overlapping surfaces
are visualized with a hatch, and you can detect
duplicate objects or any overlapping parts.

When the option is off, the overlapping surfaces
are not visualized.
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Option Description
Hatching is shown in views whose rendering option
is Parts rendered / Components rendered (Ctrl/
Shift+4).

If you switch the option on or off, you need to
reopen the view to activate the new value.

Dashed line for hidden
line

In the DirectX rendered model views, show or hide
dashed lines for part edge lines when the part
edge lines are hidden behind another part.

When the option is on, the dashed lines are shown,
making it easier to see, for example, if the part
flange is facing towards or away from the web, or,
in more complex 3D views, which part is on top of
which.

Using the dashed lines also increases Tekla
Structures performance in the transparent views.

When the option is off, the dashed lines are not
shown and the performance effect is removed.

Dashed lines can be shown in all views whose
rendering option is one of the following:

• Parts wireframe / Components wireframe
(Ctrl/Shift+1)

• Parts shaded wireframe / Components
shaded wireframe (Ctrl/Shift+2)

• Parts grayscale / Components grayscale
(Ctrl/Shift+3)

• Show only selected part / Show only selected
component (Ctrl/Shift+5).

If you switch the option on or off, you need to
reopen the view to activate the new value.

Tooltips Show or hide the tooltips (page 27).

When the option is on, a small window with
examples, hints, and tips appears when you rest
the mouse pointer on a command.

When the option is off, no tooltips appear.
Snap tooltips Show or hide the snap tooltips.

When the option is on and you start a command
that requires picking points, Tekla Structures
displays a snap tooltip that shows the name of the
snap point.

When the option is off, no snap tooltips appear.
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The following settings are available only in the drawing mode:

Option Description
Printer line widths Show on the screen the drawing lines with the

defined line thickness in color and grayscale color
modes.

The black and white color mode always shows the
printer line thicknesses on the screen, whereas the
color and grayscale color modes only show the
printer line thicknesses on the screen if the Printer
line widths switch is enabled.

When the option is on, the lines in color and
grayscale modes are shown with defined thickness.

When the option is off, the lines in color and
grayscale modes are shown with default thickness.

Printer line colors Show line colors in the drawing. Selecting this
setting shows the changed drawing line colors
immediately in drawings.

Ghost outline Show hidden objects in drawings as ghost outlines
in color drawings. In grayscale and black and white
drawings, hidden objects are not shown even if
Ghost outline is selected.

When the option is on, hidden lines are shown as
ghost outlines.

When the option is off, hidden lines are not shown.
Associativity symbol Shows which drawing objects are associative and

automatically updated. Associativity symbols are
shown only when you select a drawing object, for
example a dimension.

Objects that do not have valid association get a
ghost associativity symbol and a question mark.
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Option Description

When the option is on, associativity symbols are
shown.

When the option is off, associativity symbols are
not shown.

Dimension creation
associativity

Activate the dimension creation associativity
functionality, which displays and allows you to
change the dimension associativity rule for each
dimension point separately during the manual
dimensioning of the drawing objects.

Drawing drag & drop Activate or inactivate the drag-and-drop command
in drawings.

When the option is on, you can use drag-and-drop
when moving objects such as annotations, sketch
objects and grid lines without selecting the objects
or handles first.

When the option is off, you need to select the
objects or handles first before you can drag.

Toolbars

Use the toolbar switches to switch the selected toolbars on and off:

• Snapping toolbar

• Snap override toolbar

• Selecting toolbar

• Work plane handler toolbar

• Model search toolbar
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• Contextual toolbar

By default, the toolbars are located at the bottom of the screen.

See also

Snapping toolbar (page 45)

Selecting toolbar (page 41)

View and modify object properties by using the contextual toolbar (page 71)

How to use the ribbon and the commands on the ribbon (page 27)

How to use Quick Launch to find commands, dialog boxes, and toolbars
(page 31)

3.5 Selecting toolbar
The selection switches on the Selecting toolbar are special commands that
control which objects and object types you can select. For example, if you
select the entire model area but only the Select parts switch is active, only the
parts become selected.

Click the selection switches on the Selecting toolbar to switch them on or off.

By default, the Selecting toolbar is located at the bottom of the screen. If you
are unable to find the toolbar, click File --> Settings, and in the Toolbars list
ensure that the Selecting toolbar is selected.

Alternatively, you can control the selection switches with Quick Launch. Start
typing the name of the selection switch, for example, select, and click the
name of the selection switch on the search results list to activate the switch.

Main selection switches

The main selection switches control whether you can select components and
assemblies, or objects included in them. These switches have the highest
priority.

Switch Selectable objects Description
Components When you click any object

belonging to a component, Tekla
Structures selects the
component symbol and
highlights (but does not select)
all component objects.

Component objects Objects created automatically
by a component can be
selected.
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Switch Selectable objects Description
Assemblies and cast
units

When you click any object in an
assembly or a cast unit, Tekla
Structures selects the assembly
or cast unit and highlights all
objects in the same assembly or
cast unit.

Objects in
assemblies and cast
units

You can select single objects in
assemblies and cast units.

Other selection switches

The table below lists the remaining selection switches. Use these switches to
control which object types you want to select.

Switch Selectable objects Description
Any objects Turns all switches on. You can

select all object types, except for
single bolts.

Components You can select component
symbols.

Parts You can select parts, such as
columns, beams, or plates.

Surface treatments
and surfaces

You can select surface
treatments and surfaces.

Points You can select points.

Construction lines
and circles

You can select construction lines
and circles.

Reference models You can select entire reference
models.

This selection switch may affect
the speed of zooming and
rotating in the model. For more
information, see Tips for large
models.

Grids You can select entire grids by
selecting one line in the grid.

Grid lines You can select single grid lines.

Welds You can select welds.
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Switch Selectable objects Description
Cuts and added
material

You can select line, part, and
polygon cuts, fittings, and added
material.

Views You can select model views.

Bolt group You can select entire bolt groups
by selecting one bolt in the
group.

Single bolts You can select single bolts.

Rebar sets You can select rebar sets, and
also reinforcing bar groups and
single reinforcing bars.

Rebar groups You can select bar groups in
rebar sets, and also reinforcing
bar groups and single
reinforcing bars.

Single rebars You can select single bars in
rebar sets, and also reinforcing
bar groups and single
reinforcing bars.

Pour breaks You can select pour breaks.

Planes You can select construction
planes.

Distances You can select distances that are
used in custom components or
in parametric modeling.

Tasks You can select Task Manager
tasks.

 Switch Direct Modification on or
off.

 Hide selected switches from the
toolbar.

Analysis model switches

The following switches can be used to select objects in an analysis model:
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Switch Selectable objects Description
Loads You can select point, line, area,

uniform, and temperature
loads.

Analysis parts You can select analysis parts.

Nodes You can select analysis nodes.

Rigid links You can select analysis rigid
links.

Selection switches in drawings

Similar selection switches are available in drawings:

Switch Selectable objects Description
Any objects Turns all switches on. You can

select all object types, an entire
group of dimensions, or an
entire grid.

Lines You can select drawing objects
such as lines, arcs, circles,
rectangles, polylines, polygons,
and clouds.

Text You can select any text in
drawings.

Marks You can select all kinds of marks
and associative notes in
drawings. This selection switch
also selects weld marks.

Parts You can select parts, such as
columns, beams, and plates in
drawings.

Section symbols You can select section symbols
in drawings.

Welds You can select welds in
drawings. To select weld marks,
use the Select drawing marks
selection switch.

Views You can select drawing views.

Dimensions You can select drawing
dimensions. You can select an
entire group of dimensions by
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Switch Selectable objects Description
selecting one dimension in the
group.

Single dimensions You can select single drawing
dimensions.

Grids You can select grids in drawings.

Grid lines You can select single grid lines
in drawings.

Detail marks You can select details marks in
drawings.

Plugins You can select custom plugins in
drawings.

3.6 Snapping toolbar
Use the snap switches on the Snapping toolbar to control which positions you
can pick in the model or drawing. By using snap switches, you can position
objects precisely without having to know the coordinates. Use the Snapping
toolbar to activate snap switches and to access additional snapping options.

Click the snap switches on the Snapping toolbar to switch them on or off. If
there is more than one point available to snap to, press the Tab key to cycle
forward through the snap points, and Shift+Tab to cycle backwards through
them. Click the left mouse button to select the appropriate point.

By default, the Snapping toolbar is located at the bottom of the screen. If you
are cannot find the toolbar, click File --> Settings, and in the Toolbars list
ensure that the Snapping toolbar is selected.

Alternatively, you can control the snap switches with Quick Launch. Start
typing the name of the snap switch, for example, snap, and click the name of
the snap switch in the search results list to activate the switch.

Main snap switches
The two main snap switches define whether you can snap to reference points
or any other points on objects, for example part corners. These switches have
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the highest snap priority. If both these switches are off, you cannot snap to
any positions, even if all the other switches are on.

Switch Snap positions Description Symbol
Reference lines
and points

You can snap to object
reference points (points
that have handles).

Large

Geometry lines
and points

You can snap to any
point on an object.

In drawings, you can use
this switch to snap to
snapshot overlays.

Small

Snap switches and snap points
The snap symbols have two colors in the model:

• Orange for model objects

• Green for objects inside components

Make sure that you do not have too many snap switches on when snapping, as
it may easily lead to inaccuracies and errors in snapping. Be particularly careful

when you use the  Snap to any position snap switch.

Switch Snap positions Description
Points Snaps to points and grid line

intersections.
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Switch Snap positions Description
End points Snaps to end points of lines,

polyline segments, and arcs.

Centers Snaps to centers of circles and
arcs.

In a drawing, when you want to
snap to the center point of a
circle that has been created by
using a polygon cut in the
model, set the advanced option
XS_ADD_SNAPPING_SYMBOL_T
O_CIRCLES to TRUE.

Midpoints Snaps to midpoints of lines,
polyline segments, and arcs.

Intersections Snaps to intersections of lines,
polyline segments, arcs, and
circles.

Perpendicular Snaps to points on objects that
form a perpendicular alignment
with another object.

Line extensions Snaps to the line extensions of
nearby objects, and reference
and geometry lines of drawing
objects.

Any position Snaps to any position.

Nearest point Snaps to the nearest points on
objects, for example, any point
on part edges or lines.

Lines Snaps to grid lines, reference
lines, and the edges of existing
objects.

Dimensions and
mark lines, drawing
layout items and
drawing frames

Snaps to annotation
geometries, drawing layout
items and drawing frames.

Available only in drawings.
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Snapping in drawings
In drawings, you can snap in positions in the same way as in the model. You
can also snap to orthogonal angles while placing drawing objects or sketching.

3.7 View status bar messages
Status bar is the area located at the bottom of the Tekla Structures main
window. Follow the instructions on the status bar when you use commands.
For example, when you are creating a part, the status bar will tell you how to
proceed and when to pick points.

1. Instructions and error messages

2. The status of Ortho (O), Smart select (S) and coordinate locks (X, Y, Z).

3. The level in assembly or component hierarchy (0–9)

4. The middle mouse button mode (Pan or Scroll)

5. The current phase

6. The number of selected objects and handles

See also

Basic settings in the File menu (page 35)

3.8 Icons on the Quick Access Toolbar
Quick Access Toolbar provides shortcut icons to the commonly used
commands. The toolbar is located on top left corner of the screen.

If needed, you can customize the Quick Access Toolbar and add the
commands of your choice to it.

Icon Description
Save (page 22) changes to the current model file.

Undo the last action.

Redo the actions previously undone.

Open the Undo history (page 49) dialog box. The dialog box lists
the commands you have run and the modifications you have
done. Use the list to undo or redo several commands or
modifications at one go.
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Icon Description
This icon is visible if you use Tekla Model Sharing.

Read in other users' model changes from the sharing service. Only
the changed data is read in.
This icon is visible if you use Tekla Model Sharing.

Write out your model changes to the sharing service. Only new or
changed data is written out.
The icon is visible if you use Tekla Model Sharing.

Show read in changes. After you have read in, a list of model
changes is displayed.

See also

Introduction to Tekla Structures user interface (page 26)

3.9 Undo modeling and drawing changes
The Undo history list helps you to check which commands and modifications
you have done and undone, and to keep track of the changes. By selecting a
command or an action in the Undo history dialog box, you can undo or redo
several commands at one go, and thus go back and forth in the model history.
Undo history is available both in the modeling and in the drawing mode.

How to use Undo history

To open the Undo history dialog box, click the  button on the Quick Access
Toolbar, next to the Undo and Redo buttons. Alternatively, use Quick Launch
to open the dialog box.

To Do this
Undo commands Click any row on the list.

If the undo operation takes a long
time, Tekla Structures highlights the
clicked row to show what was
selected.

All the modifications you have done
after the selected command are
undone. The modifications you have
undone have a dark gray background
color in the list.
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To Do this
Redo previously undone commands Click any row with a dark gray

background color in the list.

All the modifications you have done
before the selected command are
redone.

Add a bookmark Move your mouse pointer over any

row. A bookmark icon  is shown.
Click the bookmark icon to mark
certain commands.

Use the bookmarks to mark
important commands or actions. You
can later return to these commands
or actions if the changes in the model
are not satisfactory.

To remove a bookmark, click the

bookmark icon  again.

The Undo history dialog box

• lists the commands you have run and modifications you have done,
starting from the top of the list. The latest commands and modifications
are at the bottom of the list.

• updates constantly according to the changes you make in the model or in
the drawing.

• creates a hierarchy for some of the used commands. The hierarchy is
created when you first run a command, then you undo some commands to
a certain point in the list, and run another command.

The hierarchy is marked with an arrow in the list. You can undo or redo
commands at any point in the hierarchy, making it possible to undo
commands that you have previously redone.

This means that after you have undone a command, you can continue
working with the model, and you still have the option to go back to the
commands you have used first.

The Undo history list is cleared when you

• save a model

• open or close a drawing

• synchronize Organizer with the model

• read in or write out model changes using Tekla Model Sharing

• use CIS/2 or SDNF import commands.
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See also

Introduction to Tekla Structures user interface (page 26)

3.10 Default keyboard shortcuts
Tekla Structures contains a large number of keyboard shortcuts that you can
use to speed up your work.

If you want to assign new shortcuts or change the default shortcuts, you can
customize the keyboard shortcuts (page 111).

Common commands

Command Keyboard shortcut
Help F1
Help: when tooltip is open Ctrl+F1
Open Recent models list Ctrl+O
Create new model Ctrl+N
Save model Ctrl+S
Delete Del
Open properties

When an object is selected, the
properties are opened either in the
property pane or in a dialog box.

Alt+Enter

Undo Ctrl+Z
Redo Ctrl+Y
Interrupt Esc
Repeat last command Enter
Show/hide contextual toolbar Ctrl+K
Switch direct modification on/off D
Quick Launch Ctrl+Q
Open Advanced options dialog box Ctrl+E
Open Applications & components
catalog side pane

Ctrl+F

Open Keyboard shortcuts dialog box Ctrl+Shift+C
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Rendering options

Command Keyboard shortcut
Parts wireframe Ctrl+1
Parts shaded wireframe Ctrl+2
Parts grayscale Ctrl+3
Parts rendered Ctrl+4
Show only selected part Ctrl+5
Components wireframe Shift+1
Components shaded wireframe Shift+2
Components grayscale Shift+3
Components rendered Shift+4
Show only selected component Shift+5
References wireframe Ctrl+Shift+1
References shaded wireframe Ctrl+Shift+2
References grayscale Ctrl+Shift+3
References rendered Ctrl+Shift+4
Show only selected reference Ctrl+Shift+5

Selecting objects

Command Keyboard shortcut
Switch rollover highlight on/off H
Select all selection switch F2
Select parts selection switch F3
Select rebar sets selection switch Alt+Q
Select rebar groups selection switch Alt+W
Select single rebars selection switch Alt+E
Select all objects in the model Ctrl+A
Select previous objects Alt+P
Select assembly Alt+object
Add to selection Shift
Toggle selection Ctrl
Selection filters Ctrl+G
Hide object Shift+H
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Snapping

Command Keyboard shortcut
Snap to reference lines/points F4
Snap to geometry lines/points F5
Snap to nearest points F6
Snap to any position F7
Switch Ortho on/off O
Relative coordinate input R
Absolute coordinate input A
Global coordinate input G
Cycle forward through the available
snap points

Tab

Cycle backwards through the
available snap points

Shift+Tab

Switch coordinate lock X, Y or Z on/off X, Y or Z

Copying and moving objects

Command Keyboard shortcut
Copy Ctrl+C
Move Ctrl+M
Switch smart select on/off S

Viewing the model

Command Keyboard shortcut
Open the Views list Ctrl+I
Switch between 3D/plane view Ctrl+P
Switch between views Ctrl+Tab
Updated window Ctrl+U
Zoom original Home
Zoom previous End
Zoom in Page Up
Zoom out Page Down
Zoom selected Shift+Space
Rotate using mouse Ctrl+R
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Command Keyboard shortcut
Rotate using keyboard Ctrl+arrow keys

Shift+arrow keys
Set view rotation point V
Rotate once

Rotate continuously

Shift+R

Shift+T
Switch view rotation on/off F8
Pan P
Switch middle button pan on/off Shift+M
Move right

Move left

Move down

Move up

arrow keys

Center by cursor

Use to center the model on a
particular point.

Insert

Fly Shift+F
Create clip plane Shift+X
Switch fullscreen on/off F11

Checking the model

Command Keyboard shortcut
Inquire object Shift+I
Measure distance F
Create report Ctrl+B
Open Phase manager Ctrl+H
Create AutoConnections Ctrl+J

Rebar display options

Command Keyboard shortcut
Leg face visibility Alt+1
Guideline visibility Alt+2
Property modifier visibility Alt+3
Splitter visibility Alt+4
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Command Keyboard shortcut
End detail modifier visibility Alt+5
Rebar dimension visibility Alt+6
Color rebar groups Alt+7

Part position options

These keyboard shortcuts work for both native Tekla Structures parts as well
as for analysis parts.

Command Keyboard shortcut
Part position up Alt+arrow up
Part position down Alt+arrow down
Part position left Alt+arrow left
Part position right Alt+arrow right
Part rotation clockwise 90 degrees

Note that this command is not
available for analysis parts.

Alt+space

Drawings

Command Keyboard shortcut
Open Document manager in model Ctrl+L
Open Document manager in
drawing mode

Ctrl+O

Print drawings Shift+P
Open next drawing Ctrl+Page Down
Open previous drawing Ctrl+Page Up
Associativity symbol Shift+A
Set next drawing color mode B
Ghost outline Shift+G
Add orthogonal dimension G
Add free dimension F
Open any drawing after creating the
drawing

Ctrl+Shift

In Document manager: Open user-
defined attributes

Alt+U
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Command Keyboard shortcut
In Document manager: Add to
Master Drawing Catalog

Ctrl+M

In Document manager: Revision
handling

Ctrl+R

In Master Drawing Catalog: Select all Ctrl+A
In Master Drawing Catalog: Create
drawings for all parts

Alt+A

In Master Drawing Catalog: Create
drawings

Alt+C

Set UCS origin U
Set UCS by two points Shift+U
Toggle orientation Ctrl+T
Reset current Ctrl+1
Reset all Ctrl+0

3.11 Change the language of Tekla Structures user
interface
You can change the language of the Tekla Structures user interface at any
time.

1. On the File menu, click Settings --> Change language.

2. Select a language from the list. 

You have the following options. The three-letter language codes that are
given in parentheses are used in some language-dependent file and folder
names.

• Chinese – simplified (chs)

• Chinese – traditional (cht)

• Czech (csy)

• Dutch (nld)

• English (enu)

• French (fra)

• German (deu)

• Hungarian (hun)

• Italian (ita)

• Japanese (jpn)

• Korean (kor)
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• Polish (plk)

• Portuguese (ptg)

• Portuguese – Brazilian (ptb)

• Russian (rus)

• Spanish (esp)

3. Click OK.

4. Restart Tekla Structures for the change to take effect.

3.12 Take screenshots
A screenshot is an image of a model or drawing view. You can use screenshots
in posters, brochures, or other material to show projects carried out using
Tekla Structures.

By default, the screenshots are saved in the \screenshots folder under the
current model folder with the name snap_xx.png.

Take a screenshot of a model
You can take screenshots of model views.

1. Open a model and adjust the model view according to your needs. 

For example, hide the work area box if you do not want to show it.

2. On the View tab, click  Screenshot --> Screenshot.

3. If you have multiple views of the model, click Pick view and select the
view to take the screenshot from.

4. To modify the settings, click Options.

a. Define the width, height, and DPI of the screenshot.

b. Click OK to save the changes.

5. Define a name and location for the screenshot.

a. Select Print to file and enter a descriptive name for the screenshot in
the File name box. 

You can also change the whole path. If you do not want to do this, you
can keep the default values for the path and the file name.

6. Click Show with associated viewer to show the screenshot in an
application that is by default associated with this file type.

7. Click Capture.
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Take a screenshot of a drawing
A drawing screenshot is an image of an open drawing with or without borders.

1. Open a drawing and adjust the drawing view according to your needs. 

For example, delete unnecessary marks or dimensions, and hide
unnecessary parts.

2. On the Views tab, click  Screenshot --> Screenshot.

3. Do one of the following: 

• Select View to take a screenshot of the open drawing with window
borders

• Select View without borders to take a screenshot of the open drawing
without window borders.

4. Under the preselected Print to file option enter a descriptive name for
the screenshot in the File name box. 

You can also change the whole path. If you do not want to do this, you can
keep the default values for the path and the file name.

5. Click Show with associated viewer to show the screenshot in an
application that is by default associated with this file type.

6. Click Capture.

Save a screenshot in bitmap format
By default, screenshots are created as Portable Network Graphics (.png) files.
You can also save a screenshot in bitmap (.bmp) format to use it, for example,
as a custom component thumbnail. Note that the bitmap file size is much
larger than when saving as PNG.

1. On the Views tab, click  Screenshot --> Screenshot.

2. Select Place on clipboard.

3. Click Capture.

4. Paste the screenshot in your graphics editor and save it in .bmp format.

NOTE The software that you use to open the screenshot may have a limit for the
number of pixels.

Screenshot settings
Use the Screenshot dialog box to view and modify the screenshot settings.
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The following options are available in model views and in drawings.

Option Description
View name Shows the selected view name.
View Includes the view content and window

borders in the screenshot.

Not available in model views.
View without borders Includes only the view content in the

screenshot.

Not available in model views.
Rendered view For high resolution screenshots from

model views. The Options button
displays the Screenshot Options
dialog box.

Not available in drawings.
Place on clipboard Places the screenshot on the

clipboard.

Not available in drawings.
Print to file Saves the screenshot to a file.

The following screenshot options are only available in model views:

Option Description
Final width The width of the screenshot.

The units depend on the settings in
File menu --> Settings --> Options --
> Units and decimals .

Final height The height of the screenshot.

The units depend on the settings in
File menu --> Settings --> Options --
> Units and decimals .

DPI The pixel density (DPI) of the
screenshot.

There are limitations to pixel density.
You can change the DPI using a
graphics editor.

White background Uses white background.
Smooth lines Uses smooth lines to decrease jagged

edges.
Line width Sets the line width.
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4 Work with model object and
drawing object properties

When you start creating model or drawing objects in Tekla Structures, most
commands ask you to pick points to place the objects in the model or in the
drawing. The objects are typically then created by using a predefined set of
properties.

The object properties can be viewed and further modified, typically by using
the property pane (page 60). Alternatively, you can also use contextual
toolbar (page 71) to modify many of the object properties. Some properties,
such as analysis part properties, are modified by using dialog boxes
(page 78).

The property pane or contextual toolbar can be used for copying properties
from one object to another. Additionally, you can define the properties for
each object type you plan to create before you start modeling or creating
drawings. You can save and load these properties (page 76) in the property
pane or in the dialog boxes.

4.1 View and modify object properties by using the
property pane
Tekla Structures shows the properties of different model objects and drawing
objects in the property pane, which is a side pane window.

Work with model object and drawing object
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Note that you can have only one property pane window open at a time. This
means that you can view the properties of only one object type at a time.

You can customize the property pane (page 96). For example, you can
organize the settings as you wish, or hide or remove the settings you do not
need.

Open the property pane
To open the properties in the property pane:

• If the property pane is closed: double-click a model or a drawing object, or

click the Properties  button in the side pane.

• If the property pane is open: select a model or a drawing object.

• Hold down Shift and click a command on the ribbon.

• Double-click a command on the ribbon.
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Modify the properties of a model object or a drawing object
1. To start modifying the properties, double-click a model or a drawing

object. 

The property pane opens and shows the current properties of the object.

2. Modify the properties as needed. 

Tekla Structures highlights the modified properties in yellow in the
property pane.

3. If you want to discard some of the changes, click the check marks next to
each setting to remove them. 

You can clear the check marks one by one, or select a whole section and
all its properties.

You can use the Select All and Select None switches at the bottom of the
property pane to select all the changes or to clear all the changes.

4. When you are ready with the modifications, click Modify to apply the
changes.

5. If you want to create an object using the standard values instead of the
values you just applied, load the standard file first. 

Note that if you use the contextual toolbar or direct modification to modify an
object, the current properties do not change and are not automatically applied
when you create the next object of the same type.
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Modify the properties of multiple model objects or drawing
objects
You can select several model or drawing objects in the model or in the
drawing, and change their properties at one go. The selected objects can be of
the same object type, such as steel columns or drawing sketch objects, or they
can be of different object types.

The property pane shows only the properties that are common for all the
selected objects.

1. Select the objects in the model or in the drawing. 

Property pane shows the properties for the selected objects.

The settings where the values differ have the text Varies, and the values
or options are shown in a list. If there are no common properties, the
property pane is empty.

2. Modify the properties as needed. 

You can select a value from a list or enter a new value for a property, in
the same way when only one model or drawing object is selected.

Tekla Structures highlights the modified properties in yellow.

3. Click Modify. 

The selected properties are modified.

TIP To check which objects you have selected in the model or in the drawing,

click the Object type list  button to open the list of the selected
objects.
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To modify the object selection, hold down Ctrl, and in the list click the
object types that you want to exclude or include in the selection.

The content of the property pane changes according to your selection.

If you want to select all the objects, click the Select all button.

Modify the properties of drawing annotation objects in
visual editor
The drawing property pane contains a visual editor for editing drawing
annotations, such as dimension tags, view labels, associative notes, and most
mark types. You can see the resulting annotation as you create it, which makes
the editing of the drawing objects much easier.

1. To start modifying the properties, double-click an annotation object in an
open drawing. 
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The property pane opens and shows the current properties of the
annotation object. The properties are located in boxes called containers.
Below is an example of the section mark visual editor.

• To load predefined contents for the annotation object, select a
property file from the Property file list.

• To show either the property name or the property value in the preview,
click the Properties or Values button. These buttons are only available
when you are modifying an annotation.

• The % button shows the current zoom level in the preview. You can
zoom in or out by scrolling the middle mouse button. Click the %
button to zoom to the best fit.

• In section marks, to indicate which end of the cutting line you want to
work with, click Start or End.

2. To add an element in a container, click a container, and then click the 
New element button. 

• If the container is empty, the element list opens automatically when
you click the container.

• In most of the visual editors, you can drag elements and containers. In
the section mark editor, you can only drag elements inside and
between containers. The dimension tag editor only allows you to drag
elements inside a container.

• To delete an element or a container, click the red delete button  in
the upper-right corner of the element or container.
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• To search for elements, use the search box that opens when you open
the element list. The available elements vary according to the
annotation object type.

• To add new containers in section marks, detail marks, or view labels,

click the  New container button. You can add up to five containers.

• In dimension tags, you first need to click a tag container to be able to
add elements in the tag in the tag editor. When a dimension tag has

some content, the container icon changes to . You can also type
text directly in dimension tags, the text will be shown as it is in the
container.

3. Modify the representation of the whole annotation object or an individual
element. For example, modify the font styles and frames.

4. Modify other annotation object properties.

5. Click Modify.

Show only frequently used properties
You can control separately for each object type which properties are shown in
the property pane. Thus, you can create your favorite sets of properties for
every object type, and make the property pane less cluttered by hiding the
properties that are not needed frequently.

Customize the property pane layout (page 96) using the Property pane
editor, and mark each property as frequently or infrequently used. When
using the property pane, you can select between showing only the frequently
used properties or all the properties of one object type.

After you have marked the properties as frequently or infrequently used in the
Property pane editor, the Show fewer properties or the Show all
properties button is activated at the bottom of the property pane. Use the
buttons to switch between showing the frequently or the infrequently used
properties.

1. To show only frequently used properties in the property pane, customize
the property pane layout (page 96) of the selected object type.

2. In the model or in the drawing, double-click an object to open the
property pane. 

Only the properties that are marked as frequently used are shown. Other
properties are hidden.

If all the properties are marked as frequently used, the Show fewer
properties button is not available.

3. If you want to see all properties, click the Show all properties button. 
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4. If you want to switch back to only frequently used properties, click the
Show fewer properties button. 

NOTE If you close Tekla Structures or switch between modeling mode
and drawing mode, Tekla Structures shows the frequently used
properties in the property pane.

You have to click the Show all properties button to show all the
properties.

Control the visibility of property groups in the property
pane
You can control which property groups are shown in the property pane
without customizing the property pane layout (page 96) by using the

Property pane settings .

1. Click the Property pane settings  button to open a drop-down menu.

2. If you want to expand or collapse all the property groups (page 98), click
Expand all or Collapse all.

3. In the modeling mode: 

You can select between showing only those properties that have a value,
or showing the property groups that you have defined to be visible.

• Show properties that have a value: property pane shows all the
properties and user-defined attributes (UDAs) for which you or
someone else has entered a value. Properties and UDAs which do not
have a value are hidden.

UDAs with a value are listed in the Additional matches property
group.

The Show properties that have a value option is common for all
object types. For example, if you select a steel beam in the model and
use the Show properties that have a value option, and then select a
concrete beam in the model, only properties that have a value are
shown for the concrete beam.

• Show properties based on group visibility: property pane shows all
the property groups that are marked to be visible. Property groups
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with the  icon are visible. Property groups with the  icon are
hidden. Click the property group names to change the visibility. You
can show and hide only the main level property groups, not nested
groups.

The Show properties based on group visibility option is common for
all object types. If different object types have property groups of the
same name, the visibility of a property group is adjusted for all the
object types. For example, if you select a steel beam and hide the
Position property group, and then select a concrete beam, the
Position property group is hidden for the concrete beam as well.

The default visibility of property groups can be defined in the Property
pane editor. Note that the changes in the visibility settings in the
property pane override the default settings done in the Property pane
editor.

4. In the drawing mode: 

Show and hide property groups. Property groups with the  icon are
visible. Property groups with the  icon are hidden. Click the property
group names to change the visibility. You can show and hide only the main
level property groups, not nested groups.

Showing and hiding of property groups is common for all object types. If
different object types have property groups of the same name, the
visibility of a property group is adjusted for all the object types.

The default visibility of property groups can be defined in the Property
pane editor. Note that the changes in the visibility settings in the
property pane override the default settings done in the Property pane
editor.

Search in the property pane
Use the search to find the needed properties or the user-defined attributes
(UDAs). Enter the search term in the search box in the property pane.

If you have several different object types selected in the model, the search
finds the properties that are common to the all selected object types. UDAs
that match to the search criteria are shown even if they have not been added
to the property pane layout.

If you enter a single asterisk * in the search box, all properties and UDAs
available for the selected object type are shown. You can then easily enter a
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value for a property or for an UDA, even if the property or the UDA is not
visible in the property pane by default.

Switch between automatic and manual applying of
properties
When you modify object properties in the property pane, you can switch
between automatic and manual applying of properties. This means that you
can select whether only the selected object is modified, or if also the next
objects of the same type that you create use the current values.

You can switch between manual and automatic applying of properties at any

time in the Property pane settings  by selecting the Set default values
automatically option. The option is not dependent on the selected object
type.

Enable automatic applying of properties (the default option)

1. Select an object in the model or in the drawing.

2. Click the Property pane settings  button in the property pane to
open a drop-down menu.

3. Ensure that the Set default values automatically option is selected.

When the Set default values automatically option is selected, Tekla
Structures automatically uses the current values for the next objects of
the same type.

4. Change the property values as needed.

5. Click Modify.

Tekla Structures modifies the object and creates the next object of the
same type using the current values.

Enable manual applying of properties

1. Select an object in the model or in the drawing.

2. Click the Property pane settings  button in the property pane to
open a drop-down menu.

3. Ensure that the Set default values automatically option is not selected.

A Set as default button appears at the bottom of the property pane.

Note that if you have selected multiple objects in the model, the Set as
default button does not appear.

4. Change the property values as needed.
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5. Select how to proceed.

• To modify only the selected object, click Modify.

• To modify the selected object and to use the current values for the
next objects of the same type, click the Set as default button and then
click Modify.

• To use the current values for the next objects of the same type, but not
to modify the selected object, click the Set as default button.

Depending on your actions, Tekla Structures either modifies the selected
object or creates the next object of the same type using the current
values.

Property pane settings
When you modify the property pane settings by clicking the Property pane

settings  button and selecting an option, the current settings are saved to
the PropertyPaneSettings.xml or to the
PropertyPaneDrawingSettings.xml file. The files are located in
the ..\Users\<user>\AppData\Local\Trimble\Tekla Structures
\<version>\UI\PropertyPane\ folder.

If you do not change the settings, the PropertyPaneSettings.xml or the
PropertyPaneDrawingSettings.xml file is not created.

The settings in the file are:

• FilterMode: ByData for Show properties that have a value

• FilterMode: ByGroups for Show properties based on group visibility

• AutoApply: True when Set default values automatically is selected

• AutoApply: False when Set default values automatically is not selected

The PropertyPaneSettings.xml and the
PropertyPaneDrawingSettings.xml files are read when Tekla Structures is
started and a model is opened.

If the settings in the PropertyPaneSettings.xml and the
PropertyPaneDrawingSettings.xml files are customized, the company
administrators can distribute the customized property pane settings to other
users in the company.

1. Create a sub-folder called \PropertyPane either in a model, project
(XS_PROJECT), firm (XS_FIRM) or environment (XS_SYSTEM) folder.

2. Place the PropertyPaneSettings.xml and the
PropertyPaneDrawingSettings.xml file to the \PropertyPane
folder.

3. Restart Tekla Structures.
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The property pane settings in the ..\Users\<user>\AppData\Local
\Trimble\Tekla Structures\<version>\UI\PropertyPane\ folder has
the highest priority, and after that Tekla Structures uses the default search
order.

If the PropertyPaneSettings.xml and the
PropertyPaneDrawingSettings.xml file is placed in several different folder
locations, Tekla Structures reads the settings from different folders and
merges them.

See also

Copy properties from another object by using the property pane or the
contextual toolbar (page 73)

Save and load object properties in the property pane or in the dialog boxes
(page 76)

Undo modeling and drawing changes (page 49)

Customize the property pane layout (page 96)

4.2 View and modify object properties by using the
contextual toolbar
When you click an object in a model or drawing, a contextual toolbar symbol

 appears next to the mouse pointer. Click the symbol to open the
contextual toolbar. Use the contextual toolbar to quickly view and change
some basic properties of an object, view, grid, and so on.

If multiple objects are being selected, the contextual toolbar displays the text
Varies for any properties that differ.

How to change object properties using contextual toolbar
The changes that you make on the contextual toolbar are immediately applied
to the model or drawing.

1. Click an object in a model or drawing. 

A contextual toolbar appears next to the mouse pointer.
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2. Change the object properties on the contextual toolbar. 

The changes are applied immediately.

TIP Press the Tab key to move between the properties and command buttons on the
contextual toolbar.

Drawing commands in contextual toolbar
In the model, the Open or create drawings command in the contextual
toolbar opens a menu that lists the drawings created for the selected objects,
and contains the Create fabrication drawing command for creating single-
part, assembly and cast unit drawings, and a command for showing the
drawings created for the selected objects in Document manager, where you
can then open the drawings.

In drawings, you can use the contextual toolbar to quickly view and change
some basic properties of a drawing object, view, grid, and so on.

Show or hide contextual toolbar
You can define whether the contextual toolbar is visible in Tekla Structures.

1. On the File menu, click Settings.

2. Under Toolbars, select or clear the Contextual toolbar check box. 

Alternatively, use the keyboard shortcut Ctrl+K to show or hide the
contextual toolbar.

Define contextual toolbar's position
You can define the position of the contextual toolbar, relative to an object's
reference point.

1. Select an object.

2. Hold down the Ctrl key and click the contextual toolbar with the left
mouse button. 
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A dashed line appears between the contextual toolbar and the object.

3. Drag the contextual toolbar to a new position. 

For example, you can position the contextual toolbar on the left side of
the selected object.

4. Release the left mouse button. 

The contextual toolbar now appears in the position you defined, for
example on the left side of any object you select.

Pin contextual toolbar in place
You can pin the contextual toolbar to a specific location on the screen, so that
the position is locked. For example, you could have it appear at the upper left
corner of the screen. In the locked state, the position of the contextual toolbar
is independent of the individual part’s location.

1. Drag the contextual toolbar to a new location.

2. Click  to pin the contextual toolbar to the new location. 

The pin icon changes when the position is locked.

3. To unlock the position, click .

Minimize contextual toolbar
You can minimize the contextual toolbar so that it takes less space on your
screen.

1. On the contextual toolbar, click . The contextual toolbar now has the

symbol .

2. To restore the contextual toolbar to its original size, click  again.
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4.3 Copy properties from another object by using the
property pane or the contextual toolbar

Use the  Copy properties command in the property pane to copy model
or drawing object properties from one object to another. Alternatively, you can
use the contextual toolbar if you want to quickly copy properties to a few
objects only.

Copy object properties by using the property pane
You can use the property pane to copy properties between any objects as long
as both of the objects have the same property available. Use this method
when you need to copy properties to a large number of objects.

1. Select the object you want to copy properties from.

2. Click  Copy properties in the property pane. 

The mouse pointer changes into a paintbrush. In the property pane, Tekla
Structures uses the same properties as when you previously copied
properties of an object of the same type.

If you want to discard some of the changes, remove the check marks next
to the properties.

You can clear the check marks one by one, or select a whole section and
all its properties, or use the Select All and Select None switches at the
bottom of the property pane to select all the changes or to clear all the
changes.

If you clear all the selections, all check marks will be selected the next time
you start the Copy properties command.

3. Select the objects you want to copy properties to. 

You can use area selection to quickly select a large number of objects.
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4. In the property pane, Tekla Structures highlights the modified properties
in yellow. 

If needed, you can clear the check marks if you do not wish to copy some
of the properties.

5. Click Modify or press Enter. 

When the properties have been copied, the mouse pointer returns to
normal.

Note that if you have customized the property pane and added user-
defined attributes (UDAs) to it, the values of the UDAs are copied when
you use the Copy properties command in the property pane.

Values of the UDAs that are visible only in the UDA dialog boxes are not
copied with the object.

Unique user-defined attributes (unique_attribute) are not copied with
the object.

TIP To copy properties to multiple objects, double-click the  Copy
properties button to keep the Copy properties command running.
Click Modify after each selected object. The mouse pointer remains

in the paintbrush mode until you press Esc or click  again.

Copy object properties by using the contextual toolbar
Use this method when you want to quickly copy properties to a few objects
only.

1. Select the object you want to copy properties from. 

A contextual toolbar (page 71) appears.

2. Click  Copy properties on the contextual toolbar. 

The mouse pointer changes into a paintbrush.

3. Select the object you want to copy properties to. 

When the properties have been copied, the mouse pointer returns to
normal.

Note that user-defined attributes (UDAs) are not copied with the object,
even if you have customized the contextual toolbar and added UDAs to it.
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4. To copy properties to multiple objects, double-click the  Copy
properties button. 

Now you can copy properties to multiple objects. The pointer remains in
the paintbrush mode until you press Esc or start another command.

4.4 Save and load object properties in the property pane
or in the dialog boxes
The property pane and many dialog boxes have the possibility to save the
property information in property files. You can load these saved properties
later on when you create new objects.

For example, you can define the properties for each object type you plan to
create before you start modeling, and then use these user-defined property
files when you are creating new objects. Tekla Structures stores the user-
defined property files, including the properties of sub-dialog boxes, in the
current model’s \attributes folder.

You can save and load object properties either in the property pane or in a
dialog box, depending on the object type.

Save and load properties in the property pane
Use the property pane to save and load the properties of model or drawing
objects.

1. Click a model or a drawing object to view the current properties in the
property pane.

2. In the property pane, modify or enter the properties (page 60) you want to
save.

3. In the box next to the  button, enter a name for the property file in
which the properties are saved. 

For example, MyProperties.

4. Click  to save the properties in the property file. 

The property file is now saved in the current model folder:
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5. When you want to load the saved properties, select the property file from
the list. 

• If you select an object in the model or in the drawing and load a
property file in the property pane, the properties and the user-defined
attributes (UDAs) are loaded immediately. Changed values are
highlighted in yellow in the property pane. Click Modify to apply the
new values.

If there are changes only in the UDA values in the UDA dialog box and
not in the values in the property pane, the Modify button in the
property pane does not become active. Click Modify in the UDA dialog
box to active the UDA values.

• If you start an object creation command and load a property file in the
property pane, the properties and the user-defined attributes (UDAs)
are used immediately and Tekla Structures creates the object using the
loaded values.

NOTE If the UDA dialog box is open when you load a property file in the
property pane, the UDA dialog box updates and shows the values
of the UDAs that are saved in the property file. However, if you
first select an object and load a property file and only then open
the UDA dialog box, the dialog box shows the UDA values of the
selected object.

To check which UDA values are saved in a property file, you need
to open the UDA dialog box first, or load the property file again
after opening the UDA dialog box.

6. If you want to make changes to an existing property file:

a. Load the property file you want to change.

b. Modify the properties.

c. Click . 

Tekla Structures saves the changes in the property file shown in the
list, overwriting the old property file.

Tekla Structures uses the new properties the next time you create an
object of the same type.

If you want to create an object using the standard values instead of
the saved properties, load the standard file.

Save and load properties in a dialog box
Use this method with properties that are displayed in a traditional dialog box.
For example, with view properties.
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1. Open the properties dialog box.

2. In the dialog box, modify or enter the properties you want to save.

3. In the box next to the Save as button, enter a name for the property file in
which the properties are saved. 

For example, MyProperties.

4. Click Save as to save the properties in the property file. 

The property file is now saved in the current model folder:

5. When you want to load the saved properties, select the property file from
the list, and click Load.

6. If you want to make changes to an existing property file:

a. Load the property file you want to change.

b. Modify the properties.

c. Click Save. 

Tekla Structures saves the changes in the property file shown in the
list, overwriting the old property file.

Remove existing properties
You can remove user-defined property files manually by removing them from
the model's \attributes folder.

1. Remove the selected property file from the model's \attributes folder. 

The property files may have different file name extensions, depending on
their type.

2. Restart Tekla Structures.

4.5 View and modify properties by using dialog boxes
You can use dialog boxes to view and modify the properties of various objects
in Tekla Structures.

NOTE Model and drawing object properties, such as part properties, are modified
with the property pane (page 60), not with dialog boxes.
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Learn the common dialog box buttons

The following table lists some common buttons that can be found in the Tekla
Structures dialog boxes.

Button Description
Saves the properties and closes the dialog box. Tekla
Structures uses these properties the next time you create an
object of this type.
Saves the properties without closing the dialog box. Tekla
Structures uses these properties the next time you create an
object of this type.
Modifies the selected objects using the current properties of
the dialog box.
Fills the dialog box with the properties of the selected object.
If several objects are being selected, Tekla Structures takes
the properties randomly from one of them.
Switches all check boxes in the dialog box on and off.

Closes the dialog box without saving the properties or
modifying objects.
Saves the properties in the file shown in the list.

Loads the previously saved properties to the dialog box.
Tekla Structures also loads the properties of sub-dialog
boxes, even if they are not open. Select the name of the
properties file you want to use.
Saves the properties with the name given in the box. The
Save as button also updates the Load list. This is important
if you add or delete files manually.

Tekla Structures stores the properties files in the model
folder, also including the properties of sub-dialog boxes.

Use dialog boxes to modify properties

1. Double-click an object to open the properties dialog box.

2. To indicate which properties should be changed, select or clear the
desired check boxes.

For example, if you want some properties to share the same value but do
not want to change any other individual properties, ensure that only the
check box for the specific property is selected.

TIP Click  to switch all check boxes on or off.

3. Modify the properties as needed.
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4. Select the objects you want to modify.

5. Click Modify.

Tekla Structures changes the properties whose check boxes you selected.
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5 Customize the basic user
interface elements

You can customize the basic user interface elements according to your needs.

The following user interface elements are customizable:

• ribbon (page 81)

• property pane (page 96)

• keyboard shortcuts (page 111)

• toolbars (page 115)

• contextual toolbar (page 115)

The customizations can be distributed to other users in the company.

5.1 Customize the ribbon
With the Ribbon editor you can customize the ribbon according to your
needs. You can change the size and shape of any button, for example. You can
create user-defined commands, and bring your favorite components and
extensions to the ribbon for an easy access.
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To open Ribbon editor, click File menu --> Settings --> Customize -->
Ribbon .

With the Ribbon editor, you can

• add new buttons to the ribbon

• move existing buttons on the ribbon

• resize the buttons on the ribbon

• change the icons and texts of the buttons

• remove buttons you do not need

• create new commands and add buttons for them

• add separator bars to the ribbon

• add new tabs

NOTE If you want to customize the modeling ribbon, open the Ribbon
editor in the modeling mode.

If you want to customize the drawing ribbon, open the Ribbon editor
in the drawing mode.

You can only customize the ribbons that are available in your
configuration.

Customize the basic user interface elements 82 Customize the ribbon



The customized ribbons are saved to ..\Users\<user>\AppData\Local
\Trimble\Tekla Structures\<version>\UI\Ribbons folder. If you
cannot find the folder, ensure that you are able to view the hidden files and
folders on your computer.

Company administrators can distribute the customized ribbons or tabs to the
whole organization, in the same way as customized property pane layouts.

Add a button to the ribbon
You can add buttons simply by selecting a button type and its appearance and
then dragging the command to the ribbon or to the Quick Access Toolbar.

To Do this
Add a button for a single
command

1. In the Add ribbon item list, select
Simple button.

2. In the Command list, select the
command you want to add to the
ribbon.

You can also add components, macros,
and extensions. Browse through the list
or use the Search box to filter content.
For example, type mesh to find the
Create reinforcement mesh command
and other mesh related components:

3. In the Appearance list:

• Select whether the button has an
icon. Select the size of the icon, or
whether you want to use a scalable
icon, or browse for the icon image.
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To Do this
• Select whether the button has any

text.

4. Previewshows what the button looks
like. Modify the button appearance, if
needed.

5. Drag the button to the ribbon.

The blue color indicates the place where
the button will be inserted.

Add a toggle button that
switches a particular command
on or off

Use this to add any switch from the File
menu --> Settings --> Switches to the
ribbon, for example. You can also add single
snap switches and select switches to the
ribbon.

1. In the Add ribbon item list, select
Check button.
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To Do this
2. In the Command list, select a command

that can be switched on or off.

Commands that can be switched on or
off have a check box next to them.

3. In the Appearance list:

• Select whether the button has an
icon. Select the size of the icon, or
whether you want to use a scalable
icon, or browse for the icon image.

• Select whether the button has any
text.

4. Preview shows what the button looks
like. Modify the button appearance, if
needed.

5. Drag the button to the ribbon.

The blue color indicates the place where
the button will be inserted.

Add a drop-down button with a
group of commands
underneath it

1. In the Add ribbon item list, select Drop-
down button.

2. In the Appearance list:

• Select whether the button has an
icon. Browse for the icon image.
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To Do this
• Select whether the button has any

text.

3. Preview shows what the button looks
like. Modify the button appearance, if
needed.

4. Drag the button to the ribbon.

The button is now an empty placeholder
for single commands. You need to add
commands to the drop-down button to
make it work.

a. In the Add ribbon item list, select
Simple button.

b. In the Command list, select the
command you want to add to the
drop-down list.

c. In the Appearance list, set the
appearance of the button.

d. Drag the button to the drop-down
list.

The blue color indicates the place
where the button will be inserted. If
you hover over a down arrow, a list
will open and you can drag
commands to the list. The list will
remain open until you click the
down arrow again.

e. Add as many commands as needed
to the drop-down button.

Add a button for a single
command, plus a drop-down
button with a group of
commands underneath it

1. In the Add ribbon item list, select Split
button.

2. In the Command list, select the
command you want to add to the
ribbon as the main button for the whole
split button.
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To Do this
3. In the Appearance list:

• Select whether the button has an
icon. Select the size of the icon, or
whether you want to use a scalable
icon, or browse for the icon image.

• Select whether the button has any
text.

4. Preview shows what the button looks
like. Modify the button appearance, if
needed.

5. Drag the button to the ribbon.

The button now has a single command.
You need to add commands to the
drop-down list.

a. In the Add ribbon item list, select
Simple button.

b. In the Command list, select the
command you want to add to the
drop-down list.

c. In the Appearance list, set the
appearance of the button.

d. Drag the button to the drop-down
list.

The blue color indicates the place
where the button will be inserted. If
you hover over a down arrow, a list
will open and you can drag
commands to the list. The list will
remain open until you click the
down arrow again.

e. Add as many commands as needed
to the drop-down button.
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You can also drag commands to the Quick Access Toolbar, which is located
above the ribbon, or to the fixed container on the left side of the ribbon:

Move a button
You can rearrange buttons on the ribbon. Note that you cannot move drop-
down buttons underneath each other.

1. Select the button you want to move. 

The button becomes highlighted:

2. Drag the button to a new location. 

The blue color indicates the place where the button will be inserted. For
example:

Resize a button
You can change the size of existing buttons.

1. Select the button you want to resize: 
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2. Move the mouse pointer over any side or corner of the button to display a
white arrow symbol: 

3. Drag with the arrow to define a new size: 

The size of the button changes accordingly. The other buttons are
automatically moved forward on the ribbon, if needed.

4. Double-click the button to expand it. 

The button now fully occupies the empty space around it:

Change the appearance of a button
You can change the appearance of any button.

1. Select the button you want to modify. 

• If you are adding a new button: select the command in the Command
list.

The current properties of the button are shown in the Appearance list.
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• If the button already exists on the ribbon: right-click the selected
button on the ribbon.

2. To change the icon, select one of the options:

a. None: no icon is used for the button
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b. Command: Large icon: the default large icon (32x32) is used

c. Command: Small icon: the default small icon (16x16) is used

d. Command: Scalable icon: the scalable vector icon is used

e. Gallery (bitmap): select a large or small bitmap icon from the Tekla
Structures icon gallery

f. Gallery (scalable): select a scalable icon from the Tekla Structures
icon gallery

g. Custom: define a custom icon by selecting a suitable image file. The
recommended size is 32x32 pixels for large buttons and 16x16 pixels
for small buttons. If you have problems with your custom image not
appearing the right size, check the DPI setting of the image file. A DPI
of 96 is recommended.

3. To change the name, select one of the options: 

• None: no name is used for the button

• Command: Full text: the default full version of the name is used

• Command: Short text: the default short version of the name is used

• Custom: enter a custom name for the button

Create a user-defined command with Command editor
You can create user-defined commands and link them to any file or URL.
Create the user-defined commands with Command editor.

The user-defined commands are saved to ..\Users\<user>\AppData
\Local\Trimble\Tekla Structures\<version>\UI\Commands folder.

1. Click File menu --> Settings --> Customize --> User-defined commands
to open Command editor.

2. Click New.

3. Enter a unique ID for the command, and then click OK. 

For example, create a link to the Tekla Discussion Forum. Enter
OpenTeklaDiscussionForum as the ID of the command.

A new column with more properties appears.
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4. In the Full name and Short name boxes, enter a name for the command.

This name will be visible in the Tekla Structures user interface. You can
define two alternative names: a full name and a short version. For
example, enter Tekla Discussion Forum as the full name of the
command, and Forum as the short version.

5. In the Large icon, Small icon, and Scalable iconsettings, select an icon
for the command. 

You can define three alternative icons: a large one and a small one, or a
scalable vector icon.

You can use your own icon or select a suitable icon from the Tekla
Structures icon gallery.

6. In the Tooltip box enter a tooltip for the command. 

For example, enter Go to the Tekla discussion forum.

7. In the Action box define a file or URL. 

For example, enter https://forum.tekla.com.

8. In Availability, select the mode where the command will be available.

9. Click Save to save the new command.

10. Go to Ribbon editor.
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11. Select the button type.

12. In the Command list, search for the new command you created.

13. In the Appearance list, modify the appearance of the button, if needed.

14. Drag the new button to the ribbon. 

15. To modify a user-defined command, right-click the command on the
ribbon and edit the command properties just like for any other command.

Add a separator bar
You can add vertical and horizontal separator bars to divide buttons into
smaller groups on the ribbon.

1. In the Add ribbon item list, select Separator.

2. In the Appearance list, select whether to add a horizontal or a vertical
bar, and the thickness of the bar. 

Preview shows what the separator bar looks like.

3. Drag the preview item to the ribbon.

4. To modify the orientation or the line thickness of the bar, right-click the
bar on the tab and select Orientation or Thickness.

5. To delete the bar, select the bar on the ribbon and press Delete on your
keyboard. 

Alternatively, right-click the bar on the ribbon and select Delete.

Remove a button
1. Select the button on the ribbon.

2. Press Delete on your keyboard. 

Alternatively, right-click the button on the ribbon and select Delete.

Add, hide, and edit tabs
You can add, move and rename ribbon tabs, choose how they are aligned, and
hide some tabs if you do not need them in your current project. For example,
if you are only modeling steel parts, you can temporarily hide the Concrete
tab.
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To Do this
Add a new tab 1. In the Add ribbon item list, select Tab.

2. Enter a name for the tab in the Text box.

3. Click Add tab to add it to the ribbon.
Change the order of tabs
on the ribbon

Drag and drop the tab titles.

Select how the tabs are
aligned

Right-click in the ribbon area and select one of
the Navigation mode options:

• Scroll visible: the ribbon movement is
minimal when you switch between the tabs

• Align to left: the icons start from the left side
of the ribbon

• Align to tab: the icons start from the left side
of the current tab

Hide the tabs that you do
not need in your current
project

1. Rest the mouse pointer on a tab title.

A small eye symbol appears next to the tab
title:

2. Click the eye symbol .

The eye symbol changes and the tab title
becomes gray:

The View tab is now hidden from the ribbon. If
you slide the ribbon, hidden tabs appear as:

To re-display the hidden tab, click the eye symbol
again.

Rename a tab Right-click the tab and select Rename. Enter a
new name for the tab.

Remove a tab Select the tab and press Delete.

Alternatively, right-click the tab and select
Delete.
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Save the ribbon
When you are happy with the changes, save the customized ribbon.

1. In Ribbon editor, click the Save button.

2. When you return to Tekla Structures and the program asks if you wish to
load the new ribbon, click Yes. The ribbon becomes updated with the
changes you made.

Check the changes
You can compare the original ribbon with the changes you have made. You can
check what has been added and removed, and what has been moved to
different tabs.

1. Save the customized ribbon, if you have not already done so.

2. Click the Compare button.

3. In the Compare ribbons dialog box, check the changes you have made. 

For example:

• Not present: these commands have been removed

• Moved: these commands have been moved to a new place

• Customized additions: these commands have been added

NOTE Original ribbon refers to the ribbon file that came with theTekla
Structures installation for your current configuration.
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4. If you have removed a command that you would like to get back, drag it
from the Compare ribbons dialog box to the ribbon.

5. When you are finished, click Close.

Back up and restore ribbons
You can restore the default Tekla Structures ribbons at any time. Before
restoring the default settings, make sure to save a backup copy of your
customized ribbon, because the customizations will be permanently deleted.
You can use the backup file to take your customized ribbon back into use, to
copy the ribbon settings to another computer, or to share the customized
ribbon with your co-workers.

1. To save a backup copy of the customized ribbon:

a. In Ribbon editor, click the Save button.

b. Go to the ..\Users\<user>\AppData\Local\Trimble\Tekla
Structures\<version>\UI\Ribbons folder.

c. Make a copy of the desired ribbon file and save it in another folder. 

The ribbons are named according to the Tekla Structures
configurations. For example, in the Full configuration, the name of
the Modeling ribbon file is albl_up_Full--main_menu.xml.

2. Click the Restore button to restore the default Tekla Structures modeling
or drawing ribbon.

3. To take the customized ribbon back into use:

a. Copy the backup file back to the ..\Users\<user>\AppData
\Local\Trimble\Tekla Structures\<version>\UI\Ribbons
folder.

b. When you return to Tekla Structures and the program asks if you wish
to load the new ribbon, click Yes. 

The ribbon becomes updated with the changes you made.

5.2 Customize the property pane layout
Tekla Structures shows the model object or the drawing object properties in
the property pane. Use the Property pane editor to customize the property
pane to better suit your needs. You can select separately for each object type
which properties you want to see in the property pane. You can show, hide
and organize the settings in the property pane, and add your most needed
user-defined attributes (UDAs) directly to the property pane.
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To open the Property pane editor, click File menu --> Settings --> Customize
--> Property pane , or, in the property pane, click the Property pane settings

 button and select Customize....

With the Property pane editor, you can

• organize properties to a suitable order or to suitable groups

• hide or remove properties you do not use or need

• create your own groups for properties that you find relevant, including
user-defined attributes (UDAs)

• add properties, including user-defined attributes (UDAs), to an existing
group

• create nested property groups

• rename properties or groups

• save the customized property pane layouts

The customized property pane layouts are saved to the
PropertyTemplates.xml or PropertyTemplates.Drawing.xml files in
the ..Users\<user>\AppData\Local\Trimble\Tekla Structures
\<version>\UI\PropertyTemplates\ folder. If you cannot find the folder,
ensure that you are able to view the hidden files and folders on your
computer.

Company administrators can distribute the customized property pane layouts
to the whole organization, in the same way as customized ribbons or
customized tabs.
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Add a property or a property group
The Property pane editor has three columns:

• Object type list on the left. The list shows all the objects that have a property
pane. Select from the list the object type whose property pane layout you
want to modify.

Each object type's tooltip shows the source from where the object type
definition is loaded: the default source, your environment, or a user-
defined customization.

• Property list in the middle. The list shows all the available properties for
each model object or drawing object. For model objects, also the user-
defined attributes (UDAs) for each object type are shown. You can add
these properties and UDAs to the property pane layout as regular
properties. Properties which are already in use cannot be added for a
second time but you can reorganize them in the property pane layout.
Properties that are incompatible with the selected object type cannot be
added.

• Property pane layout on the right. It shows the current layout of the
property pane for the selected object type.

To Do this
Select the object type
whose property pane
layout you want to
modify

In the object type list on the left, browse through
the list or use the Search box to filter content.

Add a new property to
the property pane layout

1. In the middle column's Add section, select
Property.

2. In the property list, select a property.

Use the Ctrl or Shift key to select multiple
properties.
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To Do this

3. Drag the property to the property pane layout
on the right.

You can drag the property to any group in the
property pane.

Add a new group to the
property pane layout

1. In the middle column's Add section, select
Empty group.

2. Enter a title for the new group.

3. Drag the group template to the property pane
layout on the right.
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To Do this
You can create a new group, or insert a new group
inside an existing group to create nested groups.

You can reorganize the existing groups by dragging
them.

Add the User-defined
attributes button to the
property pane layout

If you have accidentally removed the User-defined
attributes button from the property pane layout,
you can add it back to the property pane layout for
model objects.

1. In the middle column's Add section, select
Special.

2. Drag the User-defined attributes button to
the property pane layout on the right.

Note that the User-defined attributes button
cannot be added for some object types, such as
components.

Some model object types have user-defined attributes that are part of an
attribute group and/or hidden in the Property pane editor. For example, the
Bottom concrete cover belongs to the Concrete covers for rebar sets group.
If you need to use these attributes individually, you can find them by entering
__ (double underscore) in the middle column's search box. You can also use
these attributes in templates. For example, to add the Bottom concrete cover
to a report template, use the value field formula
GetValue("USERDEFINED.__CovThickBottom").

Change the name of a property or a property group

To Do this
Rename a property or a
property group

1. In the property pane layout, select the
property or the property group that you want
to rename.
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To Do this
2.

Click .

3. In the Rename dialog box, enter a new name
and click OK.

Alternatively, right-click the name of the property
or the property group and select Rename....

Restore the original
name of a property or a
property group

1. In the property pane layout, select the group
or the property whose name you want to
restore to the original.

2. Right-click and select Restore original name.

Copy properties from one object type to another object
type
You can copy properties from one object type to another object type, for
example, from steel beam to steel plate. If needed, you can copy several
property groups at one go.

1. In the object type list on the left, select the object type from which you
want to copy properties.

2. In the property pane layout on the right, select the properties you want to
copy. 

Use the Ctrl or Shift key to select multiple properties.
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3. Click  to copy the selected properties. 

Alternatively, right-click and select Copy properties.

The copied properties are shown in the middle column, under the
Content section.

4. In the object type list on the left, select the object type to which you want
to copy the properties.

5. In the Add section, ensure that the Copied properties option is selected.

6. Drag the Copied properties box from the middle column to the property
pane layout on the right. 
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The names and the content of the copied groups are shown in the middle
column until you copy another group or close the Property pane editor.

If you copy nested groups, all the nested groups inside the main group are
copied, too.
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NOTE Properties that are already in use cannot be added for a second
time. If you copy properties that are already in use, the copied
properties have the text In use in the Content section.

Properties that cannot be added to the selected object type have
the text Incompatible in the Content section.

Set the default visibility for a single property
You can define separately for each object type which properties are visible or
hidden by default in the property pane, and create your favorite sets of
properties.

By default, some object types have a large number of properties visible in the
property pane, and it can be cumbersome to find the needed property among
all the properties. To make the property pane less cluttered, you can mark
properties as frequently or infrequently used and thus hide the infrequently
needed properties.

1. In the property pane layout on the right, select the property you want to
mark as frequently or infrequently used. Use the star to mark it frequently
used. 

• Clear the star selection to mark the property infrequently used. The
property will be hidden in the property pane.

• Select the star to mark the property frequently used. The property will
be visible in the property pane.

2. To mark several properties as frequently or infrequently used at one go,
use the Ctrl or Shift key to select multiple properties. 

When you save the customized property pane layout, only the properties
that have been marked as frequently used are visible.
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Set the default visibility for a property group
You can define whether selected property groups are by default visible or
hidden in the property pane.

1. In the property pane layout on the right, select the property groups you
want to hide.

2. Right-click and select Hide by default. 

The eye icon changes to hidden: . The selected property groups are now
by default hidden in the property pane.

3. To have the property groups by default visible again in the property pane,
right-click and select Show by default. 

The eye icon changes to visible: . The selected property groups are now
by default visible in the property pane.

Note that the property group visibility changes in the property pane (page 67)
override these default settings.

Remove a customization

To Do this
Delete a property or a
property group

1. In the property pane layout, select the
property or the property group to be deleted.

Use the Ctrl or Shift key to select multiple
properties.

2.
Click .

Alternatively, right-click a property or a property
group, and select Delete.

Discard changes Click the Revert all button to discard changes and
to revert to the previous save.
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To Do this
Remove a single
customization

Click the Restore button to remove the
customization of a selected object type's property
pane.

Alternatively, right-click the selected object type
and select Restore to default.

Remove all
customizations

Click the Restore all button to remove the
customization of all property pane layouts.

Save the changes
When you are happy with the changes, save the customized property pane
layout.

1. Click the Save all button. When you return to Tekla Structures, Tekla
Structures asks if you want to reload the changed property pane
templates.

2. Click Yes to apply the customized property pane layout.

User-defined attributes (UDAs) in the customized property
pane

In the property pane of model objects, the User-defined attributes button in
the More property group opens the user-defined attributes (UDAs) dialog box.
If you customize the property pane, you can add your most important UDAs
directly to the property pane, so that you do not need to open separate UDA
dialog boxes.

Note that the User-defined attributes button is not available for some object
types, such as components. Drawing objects do not have UDAs.

When you create or modify model objects, UDAs are automatically applied
together with all the other object properties. UDAs are automatically applied
regardless of them being in the property pane or in the UDA dialog boxes.

UDAs with the following unit types are supported and work correctly if they are
added in the property pane: Option, String, Integer, Float, Date, 
Distance, Weight, Force, Moment, Angle, Factor, and Area. UDAs with
other unit types need to be used through the UDA dialog boxes.

NOTE You can control the visibility of UDAs in the property pane also without
customizing the property pane layout. Use the property visibility
options (page 67) and search in the property pane.
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Example: How to add IFC related user-defined attributes to
the property pane layout and copy them to another object
type
This example shows how to add a group of IFC related user-defined attributes
(UDAs) to the steel column property pane layout, and copy the group to the
steel beam property pane layout.

1. In the object type list, select Steel column. 

2. In the Add section, select Empty group. Enter IFC as the title for the new
group. 

3. Drag the group template to the property pane layout on the right. 
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4. In the Add section, select Property. In the search, enter IFC to search the
IFC related UDAs. 

5. Select all the IFC UDAs and drag them to the group you created in the
property pane layout. 
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6. When you have added the needed UDAs to the new group, copy the group
so that you can add the group also to the steel beam property pane
layout. Select the title of the group and click the Copy selected items

 button. 

The name of the copied property group and the content of the group is
shown in the middle column. You can see that the properties are copied
from steel column.
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7. To add the copied property group in the steel beam property pane layout,
select Steel beam in the object type list.

8. Drag the copied group from the middle column to the steel beam
property pane layout on the right. 
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Now the IFC related UDAs are available both in the steel column property
pane layout and in the steel beam property pane layout.

9. Click the Save all button to save the changes. When you return to Tekla
Structures, Tekla Structures asks if you want to reload the changed
property pane templates. Click Yes to apply the customized property pane
layout. 
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5.3 Customize the keyboard shortcuts
In the Keyboard shortcuts dialog box, you can view a list of all shortcuts
available in Tekla Structures. You can define new keyboard shortcuts and
remove existing ones. After customization, you can export the keyboard
shortcuts and share them with your co-workers.

Define new keyboard shortcuts
You can assign keyboard shortcuts to any command, macro, or component.
You can even change the default keyboard shortcuts, if needed.

1. On the File menu, click Settings --> Keyboard shortcuts . 
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The Keyboard shortcuts dialog box opens.

2. In the Group list, select the shortcut group you want to modify. 

A list of commands and shortcuts appears.

3. If you want to search for a particular command or keyboard shortcut,
enter some text in the Filter box. 

For example:

• Type grid to only see the commands whose name contains the word
"grid".

• Type "+" to get a list of shortcuts that consist of two parts (such as Ctrl
+S).
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• Type "," to get a list of shortcuts that consist of two consecutive keys
(such as M, N).

4. Select a command from the list.

5. Click Enter shortcut.

6. On the keyboard, enter the combination of keys you would like to use as
the shortcut.

7. Check the Conflicts box to see if the keyboard shortcut is already
assigned to another command. 

If the shortcut is already in use, enter a different combination of keys.

NOTE If you reassign a keyboard shortcut that is already used, it will no
longer be associated with the command it was originally assigned
to.

8. Click Assign to save the keyboard shortcut.

Clear and reset shortcuts
You can remove any existing shortcut. You can also reset all shortcuts back to
the defaults.

1. On the File menu, click Settings --> Keyboard shortcuts.

2. To remove a keyboard shortcut, select the command from the list and click
Clear.

3. To reset all the keyboard shortcuts to the defaults (page 51), click the
Restore button.

Export keyboard shortcuts
You can export your customized keyboard shortcuts and share them with your
co-workers.

1. On the File menu, click Settings --> Keyboard shortcuts.

2. Click Export.

3. Enter a file name and location.

4. Click Save to export the keyboard shortcuts.

5. To share your keyboard shortcuts with other users, send them the
exported file.
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Import keyboard shortcuts
You can import keyboard shortcuts from a file. Use this method to import
keyboard shortcuts from Tekla Structures 2016 or newer.

1. On the File menu, click Settings --> Keyboard shortcuts.

2. Click Import.

3. Browse for the shortcuts file you want to import. For example, ..\Users
\<user>\AppData\Local\Trimble\Tekla Structures\<version>
\Settings\KeyboardShortcuts_4.xml.

4. Click Open to import the keyboard shortcuts.

5.4 Customize the Selecting, Snapping, and Snap override
toolbars
You can customize the Selecting, Snapping, and Snap override toolbars by
hiding some of the switches. You can customize the toolbars both in the
modeling mode and in the drawing mode.

You can define which selection switches or snap switches are visible and which
are hidden on the selected toolbar. Company administrators can distribute the
customized toolbars to the whole organization.

1. Click the eye button  on the toolbar to open a list that contains all the
switches on the toolbar. 

Alternatively, right-click on the selected toolbar to open the list.

2. To hide a switch, click the name of the switch in the list. 

The selected switch becomes hidden on the toolbar and the eye icon
changes to hidden: .

3. To have the switch visible again, click the hidden switch in the list. 

The selected switch becomes visible on the toolbar and the eye icon
changes to visible: .
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5.5 Customize the contextual toolbar
You can customize the contextual toolbar by selecting which toolbar elements
are visible. You can also adjust the width of the elements, and add icons and
additional titles to the elements.

Customize contextual toolbar
1. On the contextual toolbar, click .

2. In the list of contextual toolbars, select the toolbar you want to customize.

The list of contextual toolbars shows only the toolbars that are available in
the current mode, meaning in the modeling mode or in the drawing
mode.

3. Select and clear check boxes to define which toolbar elements you wish to
show or hide. 

The Preview area shows what the toolbar will look like. For example:

4. To modify the toolbar elements:

a. Click the toolbar element. 

If the element can be modified, the following box appears:

b. Use the slider to adjust the width of the toolbar element.

c. To add an additional title, click the text box and enter a title.
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d. To add an icon, click  and select an icon from the list.

e. To remove the icon or title, click .

5. To add macros and user-defined attributes:

a. Select the desired macro or user-defined attribute from the list.

b. Click Add. 

Tekla Structures adds the macro or the user-defined attribute to the
list of toolbar elements and to the Preview image. For example:

c. To hide the macro or user-defined attribute, clear the corresponding
check box in the toolbar elements list.

6. Click OK to save the changes.

Create user profiles for contextual toolbars
You can create multiple profiles for contextual toolbars. Each profile contains
the same contextual toolbars, but with different settings.

1. On the contextual toolbar, click .

2. In the Set profiles box, enter a name for the profile.

3. Click  to save the new profile.

4. Customize the selected contextual toolbar. 

For example, remove some elements from the contextual toolbar.

5. Click OK to save the changes. 

The user profile is now active with the settings you defined.

6. To switch to another profile:

a. In the Set profiles list, select another profile from the list.

b. Modify the settings.

c. Click OK. 

This user profile is now active.

When Tekla Structures is restarted, the last used profile is loaded by default.
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Back up and share contextual toolbars
We recommend you to save a backup copy of your customized contextual
toolbars. You can use the backup file to copy settings to another computer or
to share the customizations with your co-workers.

1. Save the contextual toolbar under a user profile, with a name that you can
easily recognize. For example, MyContextualToolbar.

2. Go to the ..\Users\<user>\AppData\Local\Trimble\Tekla
Structures\<version>\ContextualToolbar\Profiles folder.

3. Make a copy of your customized contextual toolbar and save it in the
corresponding folder on another computer.

4. To open a customized contextual toolbar on another computer:

a. On the contextual toolbar, click .

b. In the Set profiles list, select the correct profile from the list. 

For example, MyContextualToolbar, if that is the name you used in
step 1.

c. Click OK. 

The customizations are now active.

NOTE Alternatively, you can place the entire ContextualToolbar folder in
your company's firm folder or in the system folder. Note that the firm
folder location needs to be defined in the teklastructures.ini file.
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6 Contact Tekla Structures
support (Support tool)

The Support tool allows you to contact Tekla Structures support directly. With
this tool you can collect the model, related files, and other necessary
information in one support request, and safely upload your request to Tekla
Structures support.

The Support tool:

• Automatically identifies the open model and includes all files or selected
files according to your selection from the model folder as attachments to
your request. Some logs and files in other folders are also attached, such
as the user feedback log, Tekla Structures logs and user-defined attribute
files.

• Automatically gathers application and system information.

• If a crash is encountered, attaches automatically to the Support tool the
crash dumps, session log files and Windows logs of type Error from last 72
hours. They can be skipped by clearing the Crash information file category
selection.

• Uploads the problem description, attached model, attached files, and all
other gathered information to Tekla Structures support.

NOTE Confidentiality information

All files you upload are treated as confidential. Only the recipient can access
the files.

6.1 Create a support request
1. On the File menu, click Help --> Contact Tekla support .

2. Log in using your Trimble Identity. 
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The Support tool opens and automatically fills in user, application and
Tekla Structures version information. Support tool reads your name, email
address, company name and support email address from your Trimble
Identity profile.

You can switch to another account by clicking Switch user.

3. Select a category from the list of predefined categories, or select Other
and enter the category.

4. Enter the problem description.

5. Click Next.

6. Select what you want to attach. The file name, file group, file size, and file
location are mentioned for each file. 

• By default all files are selected.

• Select the All check box, or select specific files from the Select the
files list.

• If you want to send some other attachments than shown in the Select
the files list, click the Add extra files button and browse for the files.

7. Click Next. 

The Support tool creates the package and shows the total attachment
size. You can also check application information and operating system
information before finalizing the support case creation.

8. Click Create case to upload your case to Tekla Structures support.

While you create the support case, the navigating back button in the upper-left
corner is disabled for a moment so that you cannot accidentally interrupt the
upload.

When the upload is complete, you will receive a notification at your email
address. After a successful upload, an automatic confirmation message will be
sent to you, and then Tekla Structures support will start solving your case.

For a list of offices and resellers together with their contact information, see
Offices and resellers.
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7 Disclaimer

© 2023 Trimble Solutions Corporation and its licensors. All rights reserved.

This Software Manual has been developed for use with the referenced
Software. Use of the Software, and use of this Software Manual are governed
by a License Agreement. Among other provisions, the License Agreement sets
certain warranties for the Software and this Manual, disclaims other
warranties, limits recoverable damages, defines permitted uses of the
Software, and determines whether you are an authorized user of the Software.
All information set forth in this manual is provided with the warranty set forth
in the License Agreement. Please refer to the License Agreement for important
obligations and applicable limitations and restrictions on your rights. Trimble
does not guarantee that the text is free of technical inaccuracies or
typographical errors. Trimble reserves the right to make changes and
additions to this manual due to changes in the software or otherwise.

In addition, this Software Manual is protected by copyright law and by
international treaties. Unauthorized reproduction, display, modification, or
distribution of this Manual, or any portion of it, may result in severe civil and
criminal penalties, and will be prosecuted to the full extent permitted by law.

Tekla Structures, Tekla Model Sharing, Tekla PowerFab, Tekla Structural
Designer, Tekla Tedds, Tekla Civil, Tekla Campus, Tekla Downloads, Tekla User
Assistance, Tekla Discussion Forum, Tekla Warehouse and Tekla Developer
Center are either registered trademarks or trademarks of Trimble Solutions
Corporation in the European Union, the United States, and/or other countries.
More about Trimble Solutions trademarks: http://www.tekla.com/tekla-
trademarks. Trimble is a registered trademark or trademark of Trimble Inc. in
the European Union, in the United States and/or other countries. More about
Trimble trademarks: http://www.trimble.com/trademarks.aspx. Other product
and company names mentioned in this Manual are or may be trademarks of
their respective owners. By referring to a third-party product or brand, Trimble
does not intend to suggest an affiliation with or endorsement by such third
party and disclaims any such affiliation or endorsement, except where
otherwise expressly stated.

Portions of this software:

EPM toolkit © 1995-2006 Jotne EPM Technology a.s., Oslo, Norway. All rights
reserved.
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Portions of this software make use of Open CASCADE Technology software.
Open Cascade Express Mesh Copyright © 2019 OPEN CASCADE S.A.S. All rights
reserved.

PolyBoolean C++ Library © 2001-2012 Complex A5 Co. Ltd. All rights reserved.

FLY SDK - CAD SDK © 2012 VisualIntegrity™. All rights reserved.

This application incorporates Open Design Alliance software pursuant to a
license agreement with Open Design Alliance. Open Design Alliance Copyright
© 2002-2020 by Open Design Alliance. All rights reserved.

CADhatch.com © 2017. All rights reserved.

FlexNet Publisher © 2016 Flexera Software LLC. All rights reserved.

This product contains proprietary and confidential technology, information
and creative works owned by Flexera Software LLC and its licensors, if any. Any
use, copying, publication, distribution, display, modification, or transmission of
such technology in whole or in part in any form or by any means without the
prior express written permission of Flexera Software LLC is strictly prohibited.
Except where expressly provided by Flexera Software LLC in writing,
possession of this technology shall not be construed to confer any license or
rights under any Flexera Software LLC intellectual property rights, whether by
estoppel, implication, or otherwise.

To see the third party open source software licenses, go to Tekla Structures,
click File menu --> Help --> About Tekla Structures --> 3rd party licenses
and then click the option.

The elements of the software described in this Manual are protected by
several patents and possibly pending patent applications in the United States
and/or other countries. For more information, go to page http://
www.tekla.com/tekla-patents.
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